XenCenter 入门

通过 XenCenter，您可以从 Windows® 桌面计算机管理 XenServer 环境并部署、管理和监视虚拟机。了解这些内容，只需单击下面的主题。

主题 | 内容
添加新服务器 | 连接 XenServer 主机服务器并将其添加到 XenCenter 中的托管资源列表中。
新建存储 创建共享存储 | 创建 XenServer 存储库 (SR) 以提供可以在托管服务器之间共享的存储。
新建池 创建新池 | 使用新建池向导将多个托管服务器组合成一个具有共享存储的资源池。
创建虚拟机 | 使用新建 VM 向导创建新的虚拟机 (VM)。
管理用户 | 添加 Active Directory (AD) 用户帐户并通过基于角色的访问控制 (RBAC) 功能分配不同的访问级别，从而配置访问控制。

有关 Citrix XenServer 和 XenCenter 系统要求的信息，请参阅《XenServer 安装指南》。

版权所有 © 2012 Citrix Systems, Inc.


启动 XenCenter

要启动 XenCenter 会话，请执行以下操作之一：

  • 在开始菜单中，选择：

    开始 > 所有程序 > Citrix > Citrix XenCenter

  • 双击 Citrix XenCenter 桌面快捷方式。

如果在先前的会话中将 XenCenter 配置为在启动时还原服务器连接，并且设置了主密码，系统将提示您在继续操作前输入该密码。有关如何设置服务器重新连接首选项的信息，请参阅存储服务器连接状态。

请注意，每个用户只能运行一个 XenCenter 会话。

相关主题


退出 XenCenter

CloseXenCenterWarningDialog 1600

退出当前 XenCenter 会话：在文件菜单中，单击退出。

如果在您退出时有处于运行状态的服务器和 VM，这些服务器和 VM 在 XenCenter 应用程序窗口关闭后仍将继续运行。

如果有任何正在运行的 XenCenter 任务（例如导入或导出 VM），在您尝试退出时系统将发出警告。您可以选择继续退出（在这种情况下未完成的任务可能不会成功完成），或者等到未完成的任务完成后再退出。


卸载 XenCenter

要卸载 XenCenter，可以使用 Windows 控制面板：

  • Windows XP：在控制面板中，打开添加或删除程序，从列表中选择 Citrix XenCenter，然后单击删除。
  • Windows Vista 和 Windows 7：在“控制面板”中的“程序”下，单击卸载程序，从列表中选择 Citrix XenCenter，然后单击卸载。

请注意，卸载 XenCenter 应用程序时，不会删除 XenCenter 用户配置数据和日志文件。日志文件和用户配置数据存储在以下文件夹中：

%appdata%\Citrix\XenCenter


XenServer 许可

主题
关于 XenServer 许可
激活免费 XenServer 产品
管理许可证


关于 XenServer 许可

Citrix XenServer 免费版包含创建虚拟基础结构所需的所有功能，可以免费使用。XenServer 免费版可以免费用在生产环境中，没有任何约束条件或时间限制 - 您只需在首次安装后的 30 天内激活产品，向 Citrix 登记您使用该产品的意图。激活过程非常简单，仅需几分钟时间。

三个付费 XenServer 版本（高级版、企业版和铂金版）提供了一套管理和自动化功能，对免费 Citrix XenServer 平台的功能进行了扩展。有关不同版本 XenServer 中可用功能的更多信息，请单击此处。

Citrix Licensing

本产品的所有付费版本都采用 Citrix 集中许可的方式，而且与其他 Citrix 组件一样，必须使用 Citrix 许可证服务器分配许可证。所有 XenServer 版本的许可证必须安装在单独的一台 Citrix Licensing 服务器上，并使用 Citrix 许可证管理控制台进行维护和控制。通过这种方法，XenServer 可以和其他 Citrix 产品共享相同的许可模式，并且可以在其他 Citrix 产品之间共享该许可服务器。有关如何安装及运行 Citrix Licensing 的详细信息，请查看 Citrix eDocs 网站上的在线文档。

隐私声明

激活免费 XenServer 产品或者申请/应用付费版本的许可证时，有关 XenServer 服务器版本和许可证类型的信息可能会传送到 Citrix。Citrix 不会收集或接收与任何系统用户、环境中运行的虚拟机或部署 XenServer 的环境相关的任何其他信息。许可期间传送到 Citrix 的有限信息将依照 Citrix 隐私政策进行处理，您可以在 http://www.citrix.com/privacy 查看该隐私政策的副本。


激活免费 XenServer 产品

LicenseKeyDialog 6800, SelectHostDialogLicense 6801

要激活免费的 XenServer 产品，需要对主机服务器应用激活密钥（有时也称为“许可证密钥”）。激活过程大致如下：

  1. 向 Citrix 申请激活密钥。之后您将通过电子邮件收到激活密钥文件 license.xslic。
  2. 将激活密钥应用到要激活的免费 XenServer 产品所在的服务器。

要应用激活密钥，只需在 Windows 资源管理器中双击密钥文件，然后选择要应用密钥文件的服务器即可，或者也可以在 XenCenter 中使用许可证管理器来应用密钥。

注意：激活免费 XenServer 产品时，有关 XenServer 服务器版本和许可证类型的信息可能会传送到 Citrix。Citrix 不会收集或接收与任何系统用户、环境中运行的虚拟机或部署 XenServer 的环境相关的任何其他信息。许可期间传送到 Citrix 的有限信息将依照 Citrix 隐私政策进行处理，您可以在 http://www.citrix.com/privacy 查看该隐私政策的副本。

申请激活密钥

  1. 打开许可证管理器：在“工具”菜单中，单击许可证管理器。
  2. 选择一个或多个运行免费 XenServer 产品的服务器，单击激活免费 XenServer，然后单击申请激活密钥。

    此时将打开一个 Web 浏览器，并进入 Citrix XenServer 激活网页，其中记录了所选服务器的详细激活信息，您需要在此页面中填写联系信息和电子邮件地址。

    如果 XenCenter 无法连接到 XenServer 激活服务器，系统将询问您是否要将所选主机服务器的详细激活信息保存到文件中。如果选择保存，您可以在以后恢复 Internet 连接时，将该文件导入 XenServer 激活服务器中。

填写激活表单后，您将通过电子邮件收到每个免费 XenServer 产品的激活密钥。例如：

然后您需要将相应的密钥文件应用到每个 XenServer 主机，以激活这些主机。

在 XenCenter 中应用激活密钥

开始操作前，确保可以从运行 XenCenter 的计算机访问激活密钥文件，并且已将相关服务器连接（添加）到 XenCenter 的托管资源集中。

  1. 打开许可证管理器：在工具菜单中，单击许可证管理器。
  2. 选择运行免费 XenServer 产品的服务器，单击激活免费 XenServer，然后单击应用激活密钥。
  3. 找到激活密钥文件 (license.xslic)，然后单击打开。

通过密钥文件应用激活密钥

  1. 在 Windows 资源管理器中找到激活密钥文件 (license.xslic)，然后双击该文件。
  2. 在应用激活密钥对话框中，选择要激活的免费 XenServer 产品所在的服务器，然后单击应用。


管理许可证

XenServer 高级版、企业版和铂金版与其他 Citrix 产品共享相同的许可模式，每个主机服务器需要的许可证将安装在单独的 Citrix Licensing 服务器上。有关如何安装及运行 Citrix Licensing 的详细信息，请查看 Citrix eDocs 网站上的 Citrix 在线文档。

可以使用 XenCenter 的许可证管理器管理 XenServer 高级版、企业版和铂金版：在工具菜单中，单击许可证管理器。通过许可证管理器，您可以：

  • 为托管服务器分配 XenServer 许可证。分配许可证时，XenCenter 会联系 Citrix 许可证服务器，并请求指定类型的许可证。如果有可用许可证，则会将该许可证从许可证服务器中签出。
  • 释放 XenServer 许可证。释放许可证时，XenCenter 会联系 Citrix 许可证服务器，并将许可证签入服务器。

XenServer 资源池中的每个主机服务器必须分别进行许可。例如，如果在一个资源池中支持四个 XenServer 主机，则必须为其中的每一个主机分配一个许可证。尽管可以在同一池中混合不同版本的 XenServer 主机，但是务必注意，许可证级别最低的主机决定了池中所有成员可用的功能。例如，在高级版和铂金版主机混合而成的池中，将只启用高级版主机的功能。因此，如果将主机更改为使用较低级别的许可证，实际上会禁用池中的某些功能。

分配 XenServer 许可证

  1. 打开许可证管理器：在工具菜单中，单击许可证管理器。
  2. 选择一个或多个服务器，然后单击分配许可证。
  3. 在分配许可证对话框中，选择要从许可证服务器请求的许可证类型：
    • Citrix XenServer 高级版：这种许可证可以激活 XenCenter 内的特定管理功能，包括高可用性、VM 保护和恢复 (VMPR)、动态内存控制、实时警报和有关 VM 性能的历史报告。
    • Citrix XenServer 企业版：这种许可证在高级版功能的基础上增加了与现有存储基础结构集成的自动 Workload Balancing 和 StorageLink 功能。
    • Citrix XenServer 铂金版：这种许可证所激活的功能需要在 XenCenter 外部进行管理，如 Provisioning Services 和 Lab Management。Lab Management 和 Stage Management 的许可证可以从 mycitrix.com 随 Citrix Lab Manager 安装 ISO 一起另行下载；Lab Management 许可证从 Lab Manager 管理控制台内应用。
    • Citrix XenServer for XenDesktop：选择该选项可以从许可证服务器请求现有的 Citrix XenServer for XenDesktop 许可证。获得该许可证后，您可以使用 XenServer 企业版来根据需要托管桌面 VM 和所有 XenDesktop 基础结构 VM，其中包括 XenDesktop 主机和 XenApp 主机。
  4. 输入许可证服务器详细信息，然后单击确定。

XenCenter 将联系指定的 Citrix V6 许可证服务器，并为指定服务器请求许可证。如果成功，将签出一个许可证，并更新 XenCenter 许可证管理器中显示的信息。如果无法联系许可证服务器，服务器将进入 30 天的许可宽限期。

注意：激活免费 XenServer 产品或申请/应用付费版本的许可证时，有关 XenServer 服务器版本和许可证类型的信息可能会传送到 Citrix。Citrix 不会收集或接收与任何系统用户、环境中运行的虚拟机或部署 XenServer 的环境相关的任何其他信息。许可期间传送到 Citrix 的有限信息将依照 Citrix 隐私政策进行处理，您可以在 http://www.citrix.com/privacy 查看该隐私政策的副本。

许可宽限期

Citrix V6 Licensing 内置了超时技术。如果 XenServer 主机无法联系许可证服务器（例如，由于许可证服务器硬件或软件问题，或者网络出现故障），则有 30 天的宽限期，XenServer 主机可以在宽限期内继续运行，就像仍然在与许可证服务器通信一样。XenServer 主机签出启动许可证后，XenServer 与许可证服务器每五分钟交换一次“检测信号”消息，以告知对方其仍处于启动及运行状态。如果 XenServer 和许可证服务器无法发送或接收检测信号，XenServer 会进入许可宽限期，并通过缓存的信息自行完成许可授予。30 天的宽限期过后，XenServer 会停止接受连接。XenServer 与许可证服务器之间重新建立通信后，宽限期将重置。要产生宽限期，XenServer 与许可证服务器至少曾经成功通信一次。

释放 XenServer 许可证

  1. 打开许可证管理器：在“工具”菜单中，单击许可证管理器。
  2. 选择服务器，然后单击释放许可证。


浏览 XenCenter 工作区

主题
XenCenter 窗口概述
工具栏
资源窗格
选项卡
键盘快捷方式
更改 XenCenter 选项
隐藏对象


XenCenter 窗口概述

单击可找到关于使用工具栏的更多信息 单击可找到关于使用资源窗格的更多信息 单击可找到关于使用选项卡的更多信息
编号 | 名称 | 说明
1 | 菜单栏 | 包含管理服务器、池、SR、VM 和模板所需的所有命令。
2 | 工具栏 | 用于快速访问常用菜单命令的子集。请参阅工具栏。
3 | 资源窗格 | 列出当前从 XenCenter 管理的所有服务器、池、VM、模板和 SR。请参阅资源窗格。
4 | 状态栏 | 显示关于当前任务的进度信息。
5 | 属性选项卡 | 查看及设置选定资源的属性。请参阅选项卡。


工具栏

通过 XenCenter 工具栏，可以快速访问某些最常见的 XenCenter 任务（例如，连接新服务器和创建新 VM）。

使用工具栏上的“后退”和“前进”按钮

工具栏上 [image] 后退和 [image] 前进按钮的作用与浏览器上的“后退”和“前进”按钮相同，用于在资源视图之间快速切换。

  • 要显示上一个资源视图，请单击 [image] 后退。
  • 要显示下一个资源视图（如果使用过后退），请单击 [image] 前进。
  • 要显示在此会话中曾使用的某个资源视图，请单击“后退”或“前进”按钮旁的 [image] 箭头，然后从列表中选择所需的视图。请参阅示例。

显示和隐藏工具栏

如果需要（例如，需要在 XenCenter 窗口中为控制台的显示留出更多空间），您可以隐藏工具栏。要隐藏工具栏，请执行以下操作之一：

  • 在工具栏上的任何位置单击鼠标右键，然后在快捷菜单上单击显示工具栏复选框以删除复选标记。
  • 在视图菜单上，单击工具栏复选框以删除复选标记。

要重新打开工具栏，请执行以下操作之一：

  • 在菜单栏上的任何位置单击鼠标右键，然后在快捷菜单上单击显示工具栏复选框以将其选中。
  • 在视图菜单上，单击工具栏复选框以将其选中。

对 XenCenter 工具栏可见性进行的任何更改都是持久性的更改，会在会话之间保留。

XenCenter 系统警报

可以通过 XenCenter 窗口右上角的系统警报通知区域，来快速查看是否有任何系统警报。单击此处可打开系统警报窗口，用以查看当前所有系统警报的列表并处理这些警报。

请注意，如果工具栏处于隐藏状态，可以使用 XenCenter 窗口右上角的小按钮查看当前系统警报的计数并打开系统警报对话框：

要了解更多信息，请参阅 XenCenter 系统警报。


资源窗格

资源窗格将显示有关托管资源（服务器、池、VM 和存储）的详细信息。您可以按物理位置（服务器视图）或者文件夹、标记或自定义字段等属性（文件夹视图）查看资源。有关详细信息，请参阅下面几节。

您可以在资源窗格上方的“搜索”框中键入单词或短语，按资源名称执行简单的文本搜索。键入搜索内容后，将显示匹配的资源。要删除查询并再次查看所有资源，请单击“搜索”框右侧的 [image] 按钮。

您也可以将以前保存的搜索查询应用于资源窗格。XenCenter 中包含几个保存的有用搜索，便于您按网络、操作系统、电源状态、vApp 成员身份和 XenServer Tools 状态进行搜索。您也可以随时在该列表中创建和添加自己的自定义搜索。有关详细信息，请参阅创建搜索查询和保存的搜索。要将保存的搜索应用于资源窗格中的内容，请从“资源”窗格上方的视图列表中选择保存的搜索查询。

服务器视图 – 按物理位置查看资源

从“资源”窗格上方的视图列表中选择服务器视图以切换到服务器视图。

在服务器视图中，物理资源和虚拟资源按物理位置进行组织。在资源窗格中展开某个资源池条目时，可以看到该池中包含的所有服务器；当您展开某个托管服务器时，可以看到该服务器上托管的虚拟机和存储。

XenCenter 为您提供了用于选择是否在服务器视图中显示本地存储和 VM 模板（标准模板和自定义模板）的选项。要在资源窗格中自定义服务器视图，请执行以下操作：从 XenCenter 主菜单中，选择视图，然后选择服务器视图。单击可用选项选择相应的内容或取消选择选定的内容。

文件夹视图 – 按类别（文件夹、标记、vApp、对象类型和自定义字段）查看资源

从“资源”窗格上方的视图列表中选择文件夹视图以切换到文件夹视图。

在文件夹视图中，您可以按许多不同的方式（按文件夹、标记或自定义字段）将资源分组。文件夹视图中资源的组织方式是概念性方式，而不是物理性方式，因此将资源移入文件夹或者标记资源时，不会影响其物理位置。

要更详细地了解有关使用文件夹的信息，请参阅使用文件夹。


选项卡

XenCenter 采用基于选项卡的导航方式，保证您无需同时打开和关闭许多窗口即可快速访问托管资源。在任何时候，可用的选项卡都取决于在资源窗格中选择的内容；例如，大部分资源都有一个常规选项卡，而高可用性和 WLB 选项卡仅在选择池的情况下才可用，快照选项卡仅在选择 VM 的情况下才可用。

“控制台”选项卡

TabPageConsole 1020

通过该选项卡，可以在 VM 或托管服务器上运行控制台会话。

另请参阅运行远程控制台会话，以了解 XenCenter 中支持的不同类型的远程 VM 控制台。

控制台控件 | 操作
切换到远程桌面 切换到默认桌面 | 在不同类型的 Windows 远程控制台之间切换。
切换到图形控制台 切换到文本控制台 | 在不同类型的 Linux 远程控制台之间切换。切换到图形控制台时，您可能需要首先输入 VNC 密码。
发送 Ctrl-Alt-Del | 向远程控制台发送 Ctrl+Alt+Del 键序列。 默认情况下，在使用远程控制台时，大多数键盘快捷方式都会传输到服务器或虚拟机。但是，如果您尝试在远程控制台上直接键入 Ctrl+Alt+Del 键序列，本地系统始终会截获并阻止发送该序列。
取消停靠 (Alt+Shift+U) | 取消控制台选项卡在浮动窗口中的停靠。 要从浮动控制台窗口关闭或重新启动服务器、安装 XenServer Tools、关闭、重新启动或挂起虚拟机，请单击该窗口左上角的 [image] ，然后单击相应的命令。 要使用其他键盘快捷方式停靠和取消停靠控制台，请转至 XenCenter 的选项对话框：单击工具 > 选项。
查找控制台 | 打开已最小化的浮动控制台窗口，或者将隐藏在其他窗口后面的浮动控制台窗口置于最前面。
重新停靠 (Alt+Shift+U) 重新连接控制台 | 将浮动控制台窗口重新停靠到控制台选项卡。
缩放 | 缩放远程控制台屏幕，使其恰好放在控制台选项卡或窗口内，以便您可以方便地查看远程控制台上的所有内容。清除该复选框可按正常大小显示远程控制台屏幕。 默认情况下，当您取消停靠控制台或者在不同类型的控制台（例如，VNC 和文本控制台）之间切换时，将保留在控制台选项卡中所使用的缩放设置，但是否保留这些设置是可以配置的。要更改此设置，请转至选项对话框的控制台选项卡。
全屏 (Ctrl+Enter) | 以全屏模式显示控制台。按 Ctrl+Alt 可退出全屏模式；要使用其他键序列，请转至 XenCenter 的选项对话框。 当在全屏模式下将鼠标指向屏幕顶部的中心时，将显示连接栏，其中将显示所处理的 VM 或服务器的名称，并且包含两个控件：Pin（锁定）按钮用于永久打开连接栏，Restore down（还原）按钮用于退出全屏模式。

可以在 XenCenter 的选项对话框中控制许多控制台设置。例如，默认情况下，本地计算机上的文本剪贴板将共享给远程控制台，这样，您剪切或复制的项目将放置在该剪贴板上并且可以粘贴到本地计算机或远程控制台上。您可以从 XenCenter 的选项对话框关闭剪贴板共享功能并更改许多其他控制台设置；请参阅更改 XenCenter 选项。

“常规”选项卡

TabPageSettings 1030, EditGeneralSettingsDialog 6240

在常规选项卡上，可以查看所选虚拟机、服务器、资源池、模板或存储库的常规属性；单击属性可设置或更改属性。

您可以将此窗格中显示的任何值快速复制到 Windows 剪贴板中，以粘贴到其他位置（例如粘贴到文本编辑器中），方法是在该值上单击鼠标右键，然后单击快捷菜单上的复制。

“高可用性”选项卡

在池的高可用性选项卡上，可以执行以下操作：

  • 使用配置高可用性按钮启用高可用性。
  • 使用配置高可用性按钮更改池的高可用性配置。
  • 禁用（关闭）高可用性。

当高可用性处于启用状态时，可以在高可用性选项卡上查看当前的高可用性状态（故障容量和服务器故障限制）以及所选检测信号 SR 的状态。

请参阅配置高可用性、禁用高可用性和更改高可用性设置。

Citrix XenServer 高级版或更高版本中提供高可用性功能。要了解有关不同 XenServer 版本中可用功能的详细信息，请单击此处。

“主页”选项卡

在主页选项卡上，可以向托管主机服务器列表中添加服务器、打开 XenCenter 帮助系统、打开浏览器窗口以及查找有关 XenServer 和其他 Citrix 产品的更多信息。

“日志”选项卡

在日志选项卡上，可以查看当前 XenCenter 会话期间在所选资源池、服务器或虚拟机中由 XenCenter 记录的事件的列表。使用该选项卡顶部的复选框可以过滤所显示的信息。默认情况下，此处显示错误、警报、操作和信息事件。

有关使用日志选项卡和查看 XenCenter 事件日志文件的详细信息，请参阅 XenCenter 事件日志。

“内存”选项卡

BallooningWizard_SettingsPane 4202

在内存选项卡上，可以启用动态内存控制 (DMC) 和配置动态内存限制。VM 可以采用静态内存分配，也可以配置为使用动态内存控制。动态内存控制允许随着服务器上内存要求的变化而即时调整分配给 VM 的内存量，而不必重新启动 VM。

请参阅关于 VM 内存配置、动态内存控制 (DMC)和配置 DMC

Citrix XenServer 高级版或更高版本中提供动态内存控制功能。要了解有关不同 XenServer 版本中可用功能的详细信息，请单击此处。

“网络连接”选项卡

TabPageNetwork 1070

在网络连接选项卡上，可以查看所选服务器或 VM 的网络连接配置详细信息。可以更改某些网络设置，方法是在列表中选择网络，然后单击属性。

请参阅配置网络连接（对于服务器）和配置 VM 网络连接。

“NIC”选项卡

在 NIC 选项卡上，可以查看有关所选服务器上物理网络接口卡 (NIC) 的详细信息并配置 NIC 绑定。

NIC 绑定（或称“NIC 成组”）可以将两个或更多物理 NIC 视为一个 NIC 使用，如果绑定中的一个 NIC 出现故障，服务器的网络通信将自动通过第二个 NIC 进行路由，确保了服务器的管理连通性，从而提高了服务器复原能力。请参阅配置 NIC。

注意：您必须使用 vSwitch 作为网络堆栈才能绑定四个 NIC。使用 Linux 桥接时只能绑定两个 NIC。

“性能”选项卡

在性能选项卡上，可以查看 VM 和托管服务器的性能数据。请注意，只有在安装了 XenServer Tools 时，才能查看 VM 的完整性能数据。

该选项卡提供整个资源池性能的实时监视统计数据，并以图表方式显示虚拟机和物理机性能的趋势。默认情况下，该选项卡上提供显示 CPU、内存、网络和磁盘 I/O 情况的图表。 单击配置图表可添加更多性能数据并更改图表的外观；请参阅配置性能图表。

还可以让 XenCenter 在托管服务器或虚拟机上的 CPU、网络 I/O 或磁盘 I/O 使用率超出指定阈值时生成性能警报；请参阅配置性能警报。

Citrix XenServer 高级版或更高版本中提供高级性能报告和警报功能。要了解有关不同 XenServer 版本中可用功能的详细信息，请单击此处。

“搜索”选项卡

在资源窗格中选择顶层 XenCenter 项目（池或服务器），然后单击搜索选项卡，以对托管资源执行复杂搜索。可以基于对象类型、文件夹和属性（例如名称、说明、标记、高可用性状态或重启优先级以及电源状态）构造查询。

请参阅创建搜索查询、将搜索结果过滤和分组、保存的搜索、导出和导入搜索。

“快照”选项卡

在快照选项卡上，可以创建、删除和导出 VM 快照、将 VM 还原到所选快照以及使用现有快照创建新的 VM 和模板。

请参阅 VM 快照。

“存储”选项卡

TabPageStorage 1050, TabPageSR 1060

在存储选项卡上，可以查看所选虚拟机、服务器、资源池或存储库的存储配置。此选项卡上显示的设置取决于当前在资源窗格中选择的资源类型。

所选资源 | “存储”选项卡上显示的内容 | 了解详情
VM 和模板 | 显示有关 VM 上每个虚拟磁盘的信息，其中包括虚拟磁盘的大小和位置（虚拟磁盘所在的 SR）、数据访问状态和磁盘访问优先级。 要编辑某个虚拟磁盘的设置，请在列表中选择该虚拟磁盘，然后单击属性。单击添加可添加新磁盘，单击连接可连接现有磁盘。 | 配置虚拟存储
服务器和池 | 显示可用存储库的列表以及有关可用存储库 (SR) 的类型、大小、可用空间和共享状态的摘要信息。 要编辑某个 SR 的名称或说明，请在列表中选择该 SR，然后单击属性。单击添加可添加 SR，单击分离可分离所选 SR。 | 管理存储库
存储库 | 显示所选 SR 上虚拟磁盘或 ISO 的列表。单击添加可添加新的虚拟磁盘。 | 添加虚拟磁盘

“标记”选项卡

单击资源窗格中的顶层 XenCenter 项目，然后单击标记选项卡，以查看以标记云形式分配给资源的所有标记，在标记云中，标记的大小反映其使用次数。单击标记云中的标记可以搜索具有该标记的所有资源，并将结果显示在搜索选项卡上。

请参阅使用标记。

“用户”选项卡

在用户选项卡上，可以通过 AD 用户帐户置备和 XenServer 基于角色的访问控制 (RBAC) 来为 XenServer 用户和组配置基于角色的访问权限。在该选项卡上，可以将池或服务器加入 Active Directory (AD) 域、将 AD 用户或组添加到池中以及为用户和组分配角色。

请参阅管理用户。

“WLB”选项卡

在 WLB 选项卡上，可以访问关键的 Workload Balancing 功能（包括配置、优化建议和状态）。

请参阅 Workload Balancing 概述。

Citrix XenServer 企业版或更高版本中提供 Workload Balancing。要了解有关不同 XenServer 版本中可用功能的详细信息，请单击此处。


资源状态图标

在 XenCenter 中，托管资源（服务器（主机）、虚拟机、存储和模板）的当前状态在资源窗格和其他位置以不同的图标表示：

服务器
 | 已连接并且正在正常运行的服务器。
 | 暂时未连接到 XenCenter 的服务器（例如，由于服务器正在重新启动或者已挂起）。
 | 已断开连接的服务器（例如，由于服务器已关闭）。
 | 当前处于维护模式的服务器。请参阅在维护模式下运行。
 | 由于系统故障而创建了故障转储文件的服务器。故障转储文件位于服务器 /var 目录下的 crash 文件夹中。故障转储文件可以为技术支持工程师提供有助于诊断 XenServer 相关问题的宝贵信息，可以纳入在 XenCenter 中使用获取服务器状态报告实用程序生成的服务器状态报告中。有关使用此功能的详细信息，请参阅创建服务器状态报告。 从服务器的 /var 目录中删除故障转储文件后，XenCenter 中显示的服务器状态图标将还原为正常状态。
 | 有可用更新的服务器。请参阅更新托管服务器。
 | 运行的 XenServer 版本早于池主服务器所用版本的服务器。请参阅更新托管服务器。
虚拟机、VM 模板和 vApp
 | 正在正常运行的虚拟机。
 | 当前已挂起的虚拟机。
 | 当前不可用的虚拟机（例如，由于虚拟机正在重新启动或者已挂起）。
 | 当前未运行的虚拟机（例如，由于虚拟机已关闭）。
 | 当前正在迁移的虚拟机。请参阅迁移虚拟机。
 | XenServer VM 模板。
 | 自定义（用户定义）VM 模板。
 | XenServer vApp。请参阅管理 vApp。
VM 快照
 | VM 的仅磁盘快照。
 | 计划的 VM 仅磁盘快照。
 | VM 的磁盘和内存快照。
 | 计划的 VM 磁盘和内存快照。
存储
 | 存储库。
 | 池的默认存储库。
 | 当前未连接的存储库。
 | 当前不可用的存储库。请参阅解决 SR 连接问题。
 | 需要升级的存储库。请参阅升级旧 SR。
 | 虚拟磁盘。
 | 虚拟磁盘快照。这是虚拟机磁盘的快照，在生成 VM 快照时创建。有关生成 VM 快照的信息，请参阅 VM 快照。要了解有关磁盘快照的详细信息，请参阅《XenServer 管理员指南》。


键盘快捷方式

可以使用键盘和鼠标在 XenCenter 中进行导航及执行任务。例如，可以使用箭头键在资源窗格中的项目之间及各菜单之间导航。

菜单导航

要开启或关闭菜单模式，请按 F10 或 Alt 键。在菜单模式下，可以使用键盘进行菜单导航。

右箭头、左箭头 | 在菜单栏中导航，依次选择各个菜单。
上箭头、下箭头 | 依次选择每个菜单命令。
Enter | 激活选定命令。
Esc | 取消选定命令并关闭菜单。
带下划线的字母（访问键） 使用带下划线的字母可选择特定菜单和菜单命令。

例如，要复制虚拟机，可以先按 Alt 或 F10 键，然后按 M 键选择 VM 菜单，再按 C 键选择复制 VM。

在 Windows XP 和 Windows Vista 中，默认情况下带下划线的字母处于隐藏状态，直到您按下 F10 或 Alt 键。要更改此设置以始终显示带下划线的字母：

  • 在 Windows XP 的控制面板中，双击显示，然后单击外观选项卡。单击效果并清除直到我按 ALT 键之前，请隐藏有下划线的字母供键盘使用复选框。
  • 在 Windows Vista 和 Windows 7 的控制面板中，单击轻松访问，然后在轻松访问中心标题下，单击更改键盘的工作方式。向下滚动到选项页面的底部，然后在使键盘快捷方式使用更容易下，选中给键盘快捷方式和访问键加下划线复选框。
快捷键 | 使用快捷键组合激活特定菜单命令。请参阅使用快捷键。

使用快捷键

有了快捷键，您可以使用键盘（而不是鼠标）快速执行任务。例如，按 Ctrl+N 可打开新建 VM 向导，这与在 VM 菜单中单击新建 VM 效果相同。有些快捷键显示在菜单中和工具栏的工具提示中。使用数字小键盘时，请确保 Num Lock 关闭。

F1 | 显示联机帮助
Alt+F4 | 退出 XenCenter 并关闭 XenCenter 窗口
Ctrl+Alt | 在控制台的全屏显示模式与窗口显示模式之间切换
Ctrl+B | 启动选定的 VM
Ctrl+C | 将选定文本复制到 Windows 剪贴板
Ctrl+E | 关闭选定的 VM
Ctrl+N | 打开新建 VM 向导
Ctrl+R | 重新启动选定 VM
Ctrl+V | 从 Windows 剪贴板粘贴选定文本
Ctrl+X | 将选定文本剪切到 Windows 剪贴板
Ctrl+Y | 挂起或恢复选定 VM
Ctrl+Z | 撤销上次文本编辑操作


更改 XenCenter 选项

OptionsDialog 6170, AllowUpdatesDialog 6410

可以更改影响 XenCenter 工作环境的一些设置。在工具菜单中单击选项，单击某个选项卡并更改设置，然后单击确定保存更改。

“安全”设置

选项 | 说明 | 默认设置
找到新 SSL 证书时警告我 | 如果选中该复选框，每当在托管服务器上找到新的 SSL（安全套接字层）安全证书时，XenCenter 都会显示一条警告消息。如果您不希望在连接托管服务器时显示找到新证书的警告消息，可清除该复选框。 | 禁用
SSL 证书更改时警告我 | 如果您不希望在连接托管服务器时显示找到已修改证书的警告消息，可清除该复选框。如果选中该复选框，每当在托管服务器上找到已修改证书时，XenCenter 都会显示一条警告消息。 | 启用

另请参阅：连接服务器和断开服务器连接。

“更新”设置

选项 | 说明 | 默认设置
检查新版本 XenServer | 如果选中该复选框，XenCenter 将定期检查是否有可用的新版本 XenServer，如果发现新版本，将向您发出通知。清除该复选框可以禁用定期检查功能。 | 禁用
检查 XenServer 更新 | 如果选中该复选框，XenCenter 将定期检查是否有可用的 XenServer 更新，如果发现新更新，将向您发出通知。清除该复选框可以禁用定期检查功能。 | 启用
检查新 XenCenter 版本 | 如果选中该复选框，XenCenter 将定期检查是否有可用的新版本 XenCenter，如果发现新版本，将向您发出通知。清除该复选框可以禁用定期检查功能。 | 启用

另请参阅：关于软件更新、更新托管服务器、更新 XenCenter。

“性能图表”设置

选项 | 说明
面积图 | 如果您希望以面积图形式查看性能选项卡上显示的性能数据，请单击该单选按钮。例如：
线图 | 如果您希望以线图形式查看性能选项卡上显示的性能数据，请单击该单选按钮。例如：

另请参阅：监视系统性能。

“控制台”设置

选项 | 说明 | 默认设置
与远程控制台共享剪贴板内容 | 如果选中该复选框，将与远程控制台共享本地文本剪贴板内容。剪切或复制的项目将放置在剪贴板上，并且粘贴到本地计算机或远程控制台上。 | 启用
全屏模式 | 用于来回切换控制台全屏模式的键盘快捷方式。 | Ctrl+Enter
停靠/取消停靠 | 用于从 XenCenter 窗口取消停靠控制台选项卡以及重新停靠该选项卡的键盘快捷方式。 | Alt+Shift+U
释放键盘和鼠标 | 当 VM 中的操作系统捕获键盘和鼠标光标供来宾 OS 使用时，您所执行的全部击键、鼠标移动和按钮单击操作都将转到该 VM。为了将键盘和鼠标的所有权返还给主机操作系统，XenCenter 在键盘上保留了一个特殊键，即主机键。默认情况下，主机键是键盘上的右 Ctrl 键。可以使用此功能更改此默认设置。 | 右 Ctrl
将控制台取消停靠时保留当前缩放设置 | 如果选中该复选框，可在控制台停靠和取消停靠时使用相同的控制台缩放设置。 | 启用
切换回默认控制台时保留当前缩放设置 | 如果选中该复选框，在不同控制台类型（例如，VNC/文本控制台）之间切换时，将保持相同的控制台缩放设置。 | 启用
向远程桌面控制台发送 Windows 键组合 | 如果选中该复选框，XenCenter 会将从键盘输入的任何 Windows 键组合发送到远程桌面控制台。 | 启用
从远程桌面控制台接收声音 | 如果选中该复选框，XenCenter 将在本地计算机（运行 XenCenter 的计算机）上播放来自远程桌面控制台上运行的应用程序的声音。 | 启用
远程桌面控制台变为可用时自动切换到该控制台 | 如果选中该复选框，每当远程桌面控制台可用时，XenCenter 都会自动从使用标准图形控制台切换为使用远程桌面控制台。 | 启用
直接连接服务器的控制台会话 | 如果选中该复选框，在打开远程桌面控制台会话时，XenCenter 将连接到远程服务器上的现有控制台，而不是创建新的虚拟控制台会话。 | 启用
启用远程桌面控制台扫描 | 如果选中该复选框，XenCenter 将自动扫描 RDP 连接。清除该复选框可以禁止 XenCenter 自动扫描（轮询）RDP 端口（例如，在有防火墙阻止 RDP 通信时）。请注意，如果启用该选项，即使自动切换到远程桌面选项处于禁用状态，XenCenter 仍将继续扫描 RDP 端口，因此您可以在 RDP 可用时立即切换到 RDP。 | 启用

对 Windows 远程桌面控制台设置进行的更改都将在重新启动 XenCenter 后生效。

另请参阅：运行远程控制台会话。

“连接”设置

选项 | 说明 | 默认设置
代理服务器 XenCenter 可以配置为直接连接托管服务器，或者使用代理服务器进行连接。可以使用 Internet Explorer 代理服务器设置，也可以另外指定代理服务器。
  • 选择不使用代理服务器时，XenCenter 直接连接托管服务器而不使用代理服务器。
  • 选择使用 Internet Explorer 的代理服务器设置时，将使用 Internet Explorer 的代理设置。
  • 如果您希望 XenCenter 连接到指定的代理服务器，并使用 HTTP CONNECT 与服务器间建立安全的 SSL 隧道，请选择使用此代理服务器。输入代理服务器地址以及要使用的端口号。

要直接请求连接本地资源而不通过代理服务器，请选中为本地地址绕过代理服务器复选框。要通过代理服务器请求所有连接，请清除该复选框。

本地地址是指 LAN 或 Intranet 地址，语法上通过不含句点 (.) 来识别，例如 URI http://webserver/ 和 http://localhost/。

 不使用代理服务器
连接超时 | 可以通过调整等待连接超时的秒数，指定在尝试与托管服务器建立连接时等待的时长。如果您不希望由于网络问题而收到大量虚假警报，则不应将此值设置得过低。 | 20 秒

另请参阅：连接服务器和断开服务器连接。

“保存和还原”设置

通过该选项卡上的设置，可以指定是否希望存储托管服务器的登录凭据，并在启动每个 XenCenter 会话时使用这些凭据自动重新连接所有托管服务器。您也可以在此处设置主密码来保护存储的登录凭据。

选项 | 说明 | 默认设置
保存并在启动时还原服务器连接状态 | 可以在 XenCenter 会话之间存储所有托管服务器的登录凭据（用户名和密码），并在启动每个新 XenCenter 会话时使用凭据自动重新连接这些服务器。选中此复选框时，XenCenter 将在每个会话结束时记住所有托管服务器的连接状态，并在启动下一个会话时尝试还原连接状态。 | 禁用
需要主密码 | 如果启用保存并在启动时还原服务器连接状态，可以使用主密码来保护存储的登录凭据，以确保这些凭据的安全；在启动每个会话时，系统将在自动还原与托管服务器的连接之前，提示您输入此主密码。 | 禁用
更改主密码 | 单击该项可以更改当前主密码；系统将提示您输入当前密码，然后输入新的主密码并进行确认。 |

插件设置

插件是可选组件，可以添加到 XenCenter 中以扩展其功能。使用 XenCenter 插件可以在 XenCenter 的主窗口中添加自定义菜单项甚至整个选项卡。例如，通过插件的形式，ISV 可以将自己的产品与 XenCenter 相集成，而最终用户可以将产品与公司现有库存管理功能集成。菜单项可以在客户端计算机上运行 Microsoft PowerShell 脚本，甚至可以运行任意可执行文件。选项卡用 Web 页面来填充，并且可以由网络上的其他服务或 VM 调用。

选项 | 说明 | 默认设置
插件组件 XenCenter 插件包含以下组件：
  • XML 配置文件。
  • 每个受支持区域的资源 DLL。
  • 应用程序及其所需的任何资源。

插件组件应放入 XenCenter 安装文件夹的 plugins 子文件夹。这些组件将在启动 XenCenter 时加载。例如，如果使用默认 XenCenter 安装目录，则插件将位于：

C:\Program Files\Citrix\XenCenter\plugins\<your_organization_name>\<your_plugin_name>

 禁用
查看可用插件 | 要查看 XenCenter 中当前可用插件的列表，以及启用或禁用各个插件，请在工具菜单中单击选项。此时将显示选项对话框。从左侧窗格中的选项列表中，单击插件。 | 启用
创建插件 | 要了解如何创建 XenCenter 插件，请参阅 XenCenter 插件 Web 页面。您可以通过在帮助菜单中单击联机 XenCenter 插件，随时从 XenCenter 访问该 Web 页面。


隐藏对象

可以在 XenCenter 中隐藏网络、PIF 和 VM，方法是在 XenServer API 中为相应对象的 other_config 参数添加键 HideFromXenCenter=true。例如，如果某些 VM 不应由环境中的一般用户直接使用，则可以将其隐藏。用该键标记的对象称为隐藏对象，默认情况下，这些对象不在 XenCenter 中的任何位置显示。

要使隐藏对象在 XenCenter 中可见，请在视图菜单中单击隐藏对象以将其选中。要再次隐藏这些对象，请在视图菜单中清除隐藏对象的复选标记。

有关使用 HideFromXenCenter 键标记对象的更多信息，请参阅《XenServer 软件开发工具包指南》。


组织资源

XenCenter 提供了许多不同的方法来组织物理资源和虚拟资源，您可以使用最合适的方法。

主题
使用文件夹
使用标记
使用自定义字段


使用文件夹

资源窗格中的资源可以通过两种不同的方式查看：

  • 在服务器视图中，所有托管资源将以分层结构先按池再按服务器列出并分组。
  • 在文件夹视图中，可以按文件夹、资源类型、标记和自定义字段组织和管理物理资源和虚拟资源。您只需将资源拖动到某个文件夹上，即可将该资源移动到该文件夹中；要为资源应用标记，只需将该资源拖动到标记上。

要在服务器视图和文件夹视图之间切换，请单击资源窗格上方的视图列表，然后从列表中选择文件夹视图或服务器视图。

在文件夹视图中工作

文件夹是一个容器，可用来以对环境有意义的方式将任何托管资源分组；例如，可以为贵组织中的每个分支机构创建一个文件夹。文件夹可以包含来自 XenServer 环境中任何位置的、任何类型的资源。对资源的访问与引用这些资源的文件夹无关。

XenCenter 中的文件夹组织方式是概念性方式，而不是物理性方式。资源并不实际位于文件夹中，因此，将资源放入文件夹中时，并不影响资源的物理位置。例如，将 VM 放入某个文件夹时，并不会将其主机服务器也放入该文件夹；将服务器放入某个文件夹时，并不会将该服务器上的所有 VM 和存储资源也放入该文件夹。

在文件夹视图中可以方便地为资源添加标记和自定义字段：要标记资源，只需选择资源并将其拖动到标记组中的所需标记上。同样，要在文件夹视图中为资源添加自定义字段，请选择资源并将其拖动到自定义字段组中的所需条目上。请注意，在文件夹视图中不能选择网络和虚拟磁盘，因此，要为网络和虚拟磁盘添加标记和自定义字段，应使用常规选项卡，如使用标记和使用自定义字段中所述。

文件夹还可以用在搜索查询中，例如，可以通过“包含于”/“不包含于”关系及文件夹的下拉层次结构按文件夹进行搜索。请参阅创建搜索查询。

资源当前所在的文件夹显示在资源的常规选项卡和属性对话框中，因此，您随时可以查看资源的文件夹信息。还可以使用常规选项卡将资源移入其他文件夹中或从某个文件夹中删除。请参阅将资源移入和移出文件夹。

创建新文件夹

NewFolderDialog 7210

创建新文件夹的最简单方法是使用资源窗格：在文件夹视图中，单击文件夹组，单击鼠标右键，然后从快捷菜单中选择新建文件夹。输入新文件夹的名称以及将存储文件夹元数据的服务器，然后单击确定。

您还可以从常规选项卡为任何资源创建新文件夹：

  1. 在资源窗格中，选择池、服务器、SR、虚拟机或模板，单击常规选项卡，然后单击属性。
  2. 在属性对话框的常规选项卡上，单击文件夹框中的更改。
  3. 在更改文件夹对话框中，单击新建文件夹。
  4. 输入新文件夹的名称以及将存储文件夹元数据的服务器，然后单击确定。
  5. 单击移动，以应用所做的更改并关闭更改文件夹对话框。

将资源移入和移出文件夹

FolderChangeDialog 7200

将资源移入文件夹的最简单方法是将其从资源窗格或搜索选项卡拖放到所需文件夹上。资源只能位于一个文件夹中，因此，如果资源已经位于另一个文件夹中，则执行此操作后资源将会移动。

还可以使用常规选项卡将资源移入其他文件夹中或从某个文件夹中删除：

  1. 在资源窗格中，选择要放入文件夹中的池、服务器、SR、虚拟机或模板，单击常规选项卡，然后单击属性。
  2. 在属性对话框的常规选项卡上，单击文件夹框中的更改。
  3. 要将资源从其当前所在的文件夹中删除，请选择不在任何文件夹中。
  4. 要将资源移动到其他文件夹中，请选择在此文件夹中并从列表中选择一个文件夹或子文件夹。
  5. 要将资源放入新文件夹中，请单击新建文件夹，输入新文件夹的名称以及将存储文件夹元数据的服务器，然后单击确定。
  6. 单击移动，以应用所做的更改并关闭更改文件夹对话框。

重命名文件夹

  1. 在文件夹视图中，选择文件夹，单击鼠标右键，然后从快捷菜单中选择重命名文件夹。
  2. 键入新名称。

删除文件夹

请注意，删除文件夹时并不会实际删除文件夹中的资源：资源将返回到其常规集合中。

  1. 在文件夹视图中，选择文件夹，单击鼠标右键，然后从快捷菜单中选择删除文件夹。
  2. 单击确定确认删除。

    所有内容都将从该文件夹中移出，然后该文件夹被删除。


使用标记

HelpID:TabPageTagCloud 1400

通过标记，您可以按新方法标识资源。标记类似于关键字或标签，您可以使用标记根据对您来说比较重要的条件（例如应用程序、位置、成本中心、所有者或生命周期阶段）在 XenCenter 中重新排列资源的视图。

您可以在需要时构建标记并且可以使用任意多个标记，您还可以基于自己的标记构建搜索，例如“位于北京的所有 Windows 7 测试机”。

单击资源的常规选项卡可以查看当前分配给该资源的标记，也可以添加和删除标记。

创建新标记

  1. 在资源窗格中，选择一个资源，单击其常规选项卡，然后单击属性。
  2. 在属性对话框的常规选项卡上，单击编辑标记。
  3. 在编辑标记框中键入单词或短语，然后单击创建。
  4. 新标记将自动分配给所选资源。要删除该标记，请清除复选框。
  5. 单击确定，以应用所做的更改并关闭编辑标记对话框。

删除标记

  1. 在资源窗格中，切换到文件夹视图。
  2. 打开标记组。
  3. 选择标记，单击鼠标右键，然后单击删除标记。

该标记将从当前带有该标记的所有资源中删除。

标记资源

为资源分配现有标记的最简单方法是，将资源拖放到资源窗格中的标记上（文件夹视图）。您可以从文件夹视图的资源窗格或搜索选项卡上的搜索结果列表中拖放资源。

您还可以使用编辑标记对话框为资源分配现有标记或新标记：

  1. 在资源窗格中，选择要标记的池、服务器、SR、虚拟机或模板，单击常规选项卡，然后单击属性。
  2. 在属性对话框的常规选项卡上，单击编辑标记。
    • 要创建新标记并将其添加到所选资源，请在编辑标记框中键入单词或短语，然后单击创建。
    • 要添加现有标记，请在标记列表中单击选中该标记的复选框。
  3. 单击确定，以应用所做的更改并关闭编辑标记对话框。

取消资源的标记

取消资源标记（从资源删除标记）的最简单方法是，在资源窗格（文件夹视图）中选择该资源，单击鼠标右键，然后单击快捷菜单上的取消标记对象。

您还可以从编辑标记对话框取消资源的标记：

  1. 在资源窗格中，选择要取消标记的池、服务器、SR、虚拟机或模板，单击常规选项卡，然后单击属性。
  2. 在属性对话框的常规选项卡上，单击编辑标记。
  3. 在标记列表中清除该标记的复选框。
  4. 单击确定，以应用所做的更改并关闭编辑标记对话框。

查看标记云

可以查看作为标记云分配的所有标记，在标记云中，标记的大小反映标记的使用次数。例如：

要查看 XenCenter 标记云，请单击资源窗格中的顶层 [image] XenCenter 项目，然后单击标记选项卡。

当您单击标记云中的某个标记时，具有该标记的所有资源的列表将显示在搜索选项卡上。


使用自定义字段

CustomFieldsDialog 7400

通过自定义字段，可以为资源添加结构化信息，这些信息随后可帮助您更有效地查找和管理资源。

例如，可以按物理位置标识所有主机，或者标记所有虚拟机上运行的成本中心和应用程序。您只需为池中的服务器、VM 或任何其他资源添加自定义字段并为该字段赋值。然后在构建搜索查询时，即可使用自定义字段值。

自定义字段在池级别共享。在常规选项卡或者资源属性对话框的自定义字段选项卡上为池中的任何资源设置自定义字段后，该字段将可供池中的所有其他资源使用。

创建新的自定义字段

NewCustomFieldDialog 7410
  1. 选择任何资源，然后单击常规选项卡上的属性，以打开该资源的属性窗口。
  2. 在属性窗口中的自定义字段选项卡上，单击编辑自定义字段。
  3. 单击添加，输入字段名称并选择字段类型，然后单击确定。

为资源的自定义字段赋值

  1. 选择该资源，然后单击常规选项卡上的属性，以打开该资源的属性窗口。
  2. 在属性窗口中的自定义字段选项卡上，输入自定义字段的值。
  3. 单击确定。

为资源设置的任何自定义字段都将显示在该资源的常规选项卡上。

删除自定义字段

  1. 选择任何资源，然后单击常规选项卡上的属性，以打开该资源的属性窗口。
  2. 在属性窗口中的自定义字段选项卡上，单击编辑自定义字段。
  3. 从列表中选择自定义字段，然后单击删除。


搜索资源

在资源窗格中选择顶层 XenCenter 项目（池或服务器），然后单击搜索选项卡，以对托管资源执行复杂搜索。

您也可以在资源窗格上方的“搜索”框中键入单词或短语，按资源名称执行简单的文本搜索。键入搜索内容后，将显示匹配的资源。要删除查询并再次查看所有资源，请单击“搜索”框右侧的 [image] 按钮。

主题
创建搜索查询
将搜索结果过滤和分组
保存的搜索
导出和导入搜索


创建搜索查询

通过搜索选项卡，可以基于对象类型、文件夹和属性（例如名称、说明、标记、高可用性状态或重启优先级以及电源状态）构造查询。

  • 在搜索选项卡上双击某个搜索结果时，将显示该资源的常规选项卡。
  • 要将搜索结果快速放入文件夹中，请选择搜索结果并将其拖入资源窗格中的文件夹上（文件夹视图）。资源只能位于一个文件夹中，因此，如果资源已经位于另一个文件夹中，则执行此操作后资源将会移动。要了解更多信息，请参阅使用文件夹。
    • 要选择单个搜索结果，请单击该结果。
    • 要选择一系列连续的结果，请在按住 Shift 键的同时单击。
    • 要选择一系列不连续的结果，请在按住 Ctrl 键的同时单击。
  • 要快速标记搜索结果，请选择搜索结果并将其拖入资源窗格中的标记上（文件夹视图）。有关使用标记的详细信息，请参阅使用标记。

创建新搜索查询

  1. 在搜索选项卡上，单击搜索选项，然后单击自定义搜索。
  2. 在搜索内容下，选择要搜索的资源类型或资源组合。除资源类型（例如服务器、VM 和存储库）外，此列表中还包含一些常见的资源类型组合，以及用于搜索所有资源的选项。

    要定义自己的搜索类别，请单击自定义并选择要搜索的资源类型。

    在搜索内容下选择某个选项后，将立即应用该搜索，结果将立即显示在搜索选项卡的下半部分。

要将搜索进一步细化，可以为搜索结果应用过滤器。请参阅将搜索结果过滤和分组。在此处选择某个过滤器选项后，将立即应用相应的过滤器，结果将立即更新。

保存搜索查询

NameAndConnectionPrompt 7300
  1. 在搜索选项卡上，单击搜索选项，然后单击保存当前搜索。
  2. 在名称框中输入搜索查询的标题。
  3. 要选择将保存搜索查询元数据的服务器，请单击位置列表，然后选择服务器。
  4. 单击保存。


将搜索结果过滤和分组

可以为选定的搜索类别应用过滤器，以将搜索进一步细化。可用的过滤器适用于要搜索的资源类型。

例如，在搜索服务器时，可以按服务器名称、地址（服务器的 IP 地址）、服务器所在的池以及服务器上的 VM 过滤搜索结果。在搜索虚拟磁盘时，可以使用多种条件（例如，虚拟磁盘是否为共享磁盘、虚拟磁盘所在的存储库）过滤搜索结果。

过滤搜索结果

  1. 单击过滤器正下方的按钮，然后从列表中选择过滤器类别：

    您只能选择适用于要搜索的资源的过滤器。

  2. 如果适用，请选择一个运算符（例如“是”、“包含”或“启动时间”），然后输入一个值。

    在此处选择某个选项后，过滤器将立即应用于搜索结果，结果将立即更新。

  3. 要添加更多过滤器，请单击过滤器正下方的按钮，然后从列表中选择一个多过滤器类别。

要删除过滤器，请单击搜索选项卡右侧的 删除 删除按钮。

将搜索结果分组

  1. 在分组方式下，从下拉列表中选择要应用的分组选项。

    在此处选择某个选项后，将立即应用分组，结果将立即更新。

  2. 要为搜索结果添加其他分组类别，请单击添加组，然后单击要添加的分组类别。
  3. 要删除分组，请单击分组按钮，然后选择删除分组。


保存的搜索

XenCenter 中包含几个保存的有用搜索，便于您按网络、操作系统、电源状态和 XenServer Tools 状态进行搜索。您也可以随时在该列表中创建和添加自己的自定义搜索。有关详细信息，请参阅创建搜索查询。保存的搜索将显示在 XenCenter 的资源窗格中视图列表底部。

应用保存的搜索

要在资源窗格中运行保存的搜索，请从视图列表中选择搜索。搜索结果将列在资源窗格中。

要在搜索选项卡上运行保存的搜索，请单击搜索选项，然后单击应用保存的搜索。从列表中选择保存的搜索查询，以在搜索选项卡上显示结果。

删除保存的搜索

在搜索选项卡上，单击搜索选项，然后单击删除保存的搜索。从列表中选择保存的搜索查询，然后单击确定进行确认。


导出和导入搜索

XenCenter 搜索查询可以保存为 XenSearch (.xensearch) 文件。只保存搜索查询，而不保存搜索结果。

导出当前的搜索

  1. 在搜索选项卡上，单击搜索选项，然后单击导出到文件。
  2. 输入导出文件的名称和位置，然后单击保存。

导入搜索

  1. 在搜索选项卡上，单击搜索选项，然后单击导入。

    或者，在 XenCenter 的文件菜单上，选择导入搜索。

  2. 通过浏览找到所导出的搜索文件（文件扩展名为 .xensearch），然后单击打开。将立即执行导入的搜索，结果将显示在搜索选项卡上。

要将导入的搜索保存为新的自定义搜索，请单击搜索选项，然后单击保存当前搜索。


获取帮助

可以在多个不同位置查找所需要的关于使用 XenServer 的信息：

  • XenServer 产品文档。面向 XenServer 管理员和开发人员的综合参考文档：在 XenServer 产品 CD 中以 PDF 格式提供，并且通过 Citrix 知识中心的 XenServer 部分在线提供。
  • Citrix 知识中心。如果已连接到 Internet，可以在线浏览或搜索知识库文章和技术说明，以及最新的 XenServer 产品文档。有关详细信息，请访问 Citrix 知识中心。
  • XenCenter 联机帮助。XenCenter 包含上下文相关的帮助系统，可以根据您在应用程序中所处的位置以及尝试执行的操作提供相应帮助。
    • 主题
    帮助窗口
    搜索帮助
    打印帮助主题


帮助窗口

XenCenter 帮助显示在 HTML 帮助窗口中：

  • 窗口左侧是一个导航窗格，其中包含目录、搜索和收藏夹选项卡。
  • 窗口右侧是主题窗格。该窗格显示选定的帮助主题或默认帮助主题。
  • 顶部是工具栏。

使用帮助工具栏

隐藏导航窗格，仅显示主题窗格，以节省屏幕空间。
显示导航窗格。只有当先前使用了隐藏功能时，此按钮才可用。
显示上次查看的主题。
显示下一个主题（如果先前使用了后退功能）。
打印主题（请参阅打印帮助主题）。
提供用于在 HTML 帮助窗口中导航的各种设置，以及对某些功能的另一种访问途经。

使用“目录”选项卡

单击目录选项卡可列出帮助主题：

文件夹图标用于启动一个新的主题。如果文件夹处于折叠状态，单击 [image] 可将其展开以列出其中的各个主题，单击 [image] 可将其再次折叠。
主题图标代表单个帮助主题。单击主题图标或其标题可将该主题显示在主题窗格中。许多主题中包含一些链接，指向包含相关信息的主题：单击主题底部的相关主题按钮，然后选择要显示的主题。

当前在主题窗格中查看的主题会在目录中突出显示。转到其他主题时，目录将根据需要展开，以指示您在帮助系统中所处的位置。

可以展开或折叠整个目录：在“目录”选项卡中单击鼠标右键，然后在快捷菜单中单击全部打开或全部关闭。

使用“搜索”选项卡

可以在帮助系统的所有文本内容中搜索单词或短语。可以在先前的结果中进行搜索、匹配相似的单词或仅搜索主题标题。要了解更多信息，请参阅搜索帮助。

使用“收藏夹”选项卡

  • 要创建收藏帮助主题列表，请找到要作为收藏主题的帮助主题，单击收藏夹选项卡，然后单击添加。
  • 要返回到收藏主题，单击收藏夹选项卡，选择主题，然后单击显示。
  • 要重命名收藏主题，请在列表中的该主题上单击鼠标右键，在快捷菜单中单击重命名，然后为收藏项键入新名称。
  • 要删除收藏主题，请选择该主题，然后单击删除。

更改 HTML 帮助窗口的布局

  • 要节省屏幕空间，可以只显示主题窗格：在工具栏上单击隐藏 隐藏目录窗格 以隐藏导航窗格。单击显示 显示目录窗格 可再次显示该窗格。
  • 要调整导航窗格或主题窗格的大小，请将鼠标指针指向两个窗格之间的垂直拆分条。当鼠标指针变为双向箭头 [image] 时，向右或向左拖动垂直拆分条。
  • 要调整整个 HTML 帮助窗口的大小，请将鼠标指针指向窗口的一角。当鼠标指针变为双向箭头时，拖动该角。
  • 要更改 HTML 帮助窗口的高度或宽度，请将鼠标指针指向该窗口的上、下、左、右边缘。当鼠标指针变为双向箭头时，拖动相应的边。
  • 要在屏幕上移动 HTML 帮助窗口，请将鼠标指针移到标题栏上，然后将窗口拖动到新位置。


搜索帮助

可以在帮助系统的所有文本内容中搜索单词或短语。可以在先前的结果中进行搜索、匹配相似的单词或仅搜索主题标题。

过程

  1. 单击搜索选项卡，然后键入要查找的单词或短语。
  2. 要仅在主题标题中进行搜索，请选中只搜索标题复选框。将搜索所有主题文件，包括目录中未列出的任何主题文件。
  3. 要仅在最近找到的主题组中搜索，请选中搜索以前的结果复选框。要在帮助系统的所有文件中进行搜索，请清除该复选框。
  4. 单击列出主题，然后双击所需主题，或选择主题并单击显示。

提示

  • 搜索不区分大小写，因此可以使用大写或小写字符键入搜索内容。
  • 可以搜索任意字母 (a-z) 和数字 (0-9) 的组合。
  • 搜索过程中将忽略除了双引号之外的标点符号，如句点、冒号、分号、逗号和连字符。
  • 使用双引号可搜索短语。例如，"服务器 root 用户密码" 将查找包含短语“服务器 root 用户密码”的主题，而服务器 root 用户密码查找包含单词“服务器”、“root 用户”和“密码”的主题，但不要求这些词连成一个短语。
  • 使用通配符表达式可搜索一个或多个字符：使用星号搜索零个或多个字符，使用问号搜索一个字符。
  • 使用嵌套表达式可创建复杂搜索。例如，“更新 AND ((管理器 OR 对话框) NEAR 服务器)”查找包含单词“更新”并且“管理器”与“服务器”邻近的主题，或包含单词“更新”并且“对话框”与“服务器”邻近的主题。
  • 嵌套表达式的深度不能超过五层。
  • 使用布尔运算符可以将搜索进一步细化。单击 [image] 并使用 AND、OR、NOT 和 NEAR 运算符。
  • 默认情况下，搜索词会在找到的主题中突出显示；要关闭此功能，请单击工具栏上的选项，然后单击关闭搜索突出显示。


打印帮助主题

打印当前主题

  1. 展开所有部分：选中主题顶部的显示所有文字复选框，或单击主题并按 Alt+X。
  2. 在主题窗格中单击鼠标右键，然后在快捷菜单中单击打印。或者，在工具栏中单击打印 打印帮助主题 ，单击打印选择的主题，然后单击确定。
  3. 在打印对话框中，设置所需的打印机选项，然后单击打印。

可以选择打印“目录”选项卡中显示的一组主题。但请注意以下几点：

  • 打印主题时所有部分都会展开。
  • 所打印主题的格式与屏幕上显示的格式在外观上不完全相同。
  • 图像的打印位置可能不正确，会遮盖邻近的文字。

打印一组主题

  1. 在“目录”选项卡中，在包含待打印主题的手册上单击鼠标右键，然后在快捷菜单中单击打印，或在工具栏上单击打印 打印帮助主题 。
  2. 单击打印选择的标题和所有副标题，然后单击确定。
  3. 在打印对话框中，设置所需的打印机选项，然后单击打印。


管理服务器

主题
连接和断开连接
  • 添加新服务器
  • 断开服务器连接
  • 重新连接服务器
  • 导出和导入托管服务器列表
  • 存储服务器连接状态
配置网络连接
  • 关于 XenServer 网络
  • 添加新网络
  • 删除网络
  • 查看和更改网络属性
配置 NIC
配置 IP 地址
配置主机开机
更改服务器属性
备份和还原服务器
重新启动服务器
关闭服务器
远程开启服务器
从 XenCenter 删除服务器
在维护模式下运行


连接服务器和断开服务器连接

主题
添加新服务器
断开服务器连接
重新连接服务器
导出和导入托管服务器列表
存储服务器连接状态


添加新服务器

AddServerDialog 6000

为了从 XenCenter 监视和管理服务器上的活动，需要将该服务器添加到 XenCenter 的“托管”资源集合中。首次连接服务器时（通过工具栏上的添加新服务器或服务器菜单），该服务器会添加到 XenCenter 窗口左侧的资源窗格中。该服务器的默认存储库（如果配置）及其任何物理 CD 或 DVD 驱动器也可能会显示在此窗格中。之后可以将托管服务器断开连接、重新连接、关闭或置于维护模式，在从 XenCenter 删除该服务器前，始终可从资源窗格对其进行访问。

首次使用 XenCenter 连接服务器时，将显示保存和还原连接状态对话框。在此对话框中，可以设置相关首选项，以存储服务器连接信息并在每个 XenCenter 会话启动时自动还原服务器连接。请参阅存储服务器连接状态。

向 XenCenter 中添加服务器

  1. 单击 [image] 添加新服务器。

    或者：

    • 在服务器菜单中，单击添加。
    • 在资源窗格中，选择最顶层的 XenCenter 条目，单击鼠标右键，然后在快捷菜单中单击添加。
    • 在 XenCenter 主页上，单击添加新服务器按钮：
  2. 在服务器框中，输入要添加的服务器的 IP 地址或 DNS 名称。例如：182.31.32.28 或 belt.orion.com。

    提示：通过在服务器框中输入用分号分隔的名称或 IP 地址，可以添加具有相同登录凭据的多个服务器。

  3. 键入在 XenServer 安装期间设置的用户名（例如 root）和密码。

    如果在 XenServer 环境中启用了 Active Directory (AD) 授权，可以在此处输入 AD 凭据。有关详细信息，请参阅 RBAC 概述。

  4. 单击添加。将显示连接进度监视器：要取消连接，请单击取消。

您在此处输入的登录信息在当前 XenCenter 会话期间会被记住，因此如果重新连接同一会话中之前断开的服务器，将无需再次输入登录信息。也可以断开（注销）托管服务器，而使用不同的用户凭据（例如，使用 AD 登录凭据而非本地根帐户）重新与其建立连接。

如果需要，可以将 XenCenter 配置为存储所有托管服务器的登录凭据，并在启动每个新的 XenCenter 会话时，使用这些凭据自动还原连接。请参阅存储服务器连接状态。

安全证书

可以将 XenCenter 配置为每当连接托管服务器时发现新的或修改的 SSL（安全套接字层）安全证书，就显示一条警告消息。单击查看证书可查看安全证书。要阻止生成 SSL 证书警告，可使用 XenCenter 选项对话框中的安全设置选项卡。


断开服务器连接

断开连接的服务器仍然是托管服务器，在 XenCenter 的资源窗格中仍然可用，其状态图标为：

您可以快速查看当前断开连接的服务器，方法是：在资源窗格中切换到文件夹视图，然后单击已断开连接的服务器。

断开服务器连接

要断开服务器连接，在资源窗格中选择该服务器，然后在服务器菜单中单击连接/断开连接 > 断开连接。可以随时与断开连接的服务器重新连接。请参阅重新连接服务器。

或者，在资源窗格中单击鼠标右键，并在快捷菜单中选择断开连接。

要从资源窗格中删除断开连接的服务器，请参阅从 XenCenter 删除服务器。


重新连接服务器

LoadSessionDialog 6200, PasswordPromptDialog 6600

在 XenCenter 中添加服务器后，无论该服务器的状态如何（连接或断开，正常运行或处于维护模式），在整个当前 XenCenter 会话中都可以通过资源窗格访问该服务器。

要重新连接断开的托管服务器，只需在资源窗格中双击该服务器，或者单击鼠标右键，然后在快捷菜单中单击连接。在当前 XenCenter 会话期间，系统将记住服务器连接信息，因此如果要使用同一个用户帐户重新连接，无需在同一个 XenCenter 会话中多次输入相同的登录凭据。

也可以使用不同的登录凭据（例如使用 AD 登录凭据而非本地根帐户）重新连接已连接的服务器。

使用不同的登录凭据重新连接已连接的服务器

  1. 在资源窗格中选择服务器。
  2. 在服务器菜单中，单击连接/断开连接，然后单击重新连接身份。

    3. 或者，执行以下操作之一：

    • 在资源窗格中单击鼠标右键，然后在快捷菜单中选择重新连接身份。
    • 在服务器菜单中，单击连接/断开连接，然后单击重新连接身份。
  3. 输入新的用户名和密码。

    如果在 XenServer 环境中启用了 Active Directory 授权，可以在此处输入 AD 凭据。请参阅 RBAC 概述。

  4. 单击确定。


导出和导入托管服务器列表

可以将托管服务器列表从 XenCenter 导出到配置文件中，然后将该文件导入到其他计算机上运行的 XenCenter 会话中。此功能非常有用，例如可以帮助您将托管服务器列表从台式机复制到便携式计算机，避免在新计算机上手动添加长长的服务器列表。

每个托管 VM 的 IP 地址/DNS 名称、端口和显示名称以 XML 格式保存在扩展名为 .config 的 XenCenter 配置文件中。文件中不存储登录凭据。

导出托管服务器列表

  1. 在 XenCenter 的文件菜单中，单击导出服务器列表。
  2. 指定导出文件的名称和位置，然后单击保存。

导入服务器列表

  1. 在 XenCenter 的文件菜单中，单击导入服务器列表。
  2. 找到 XenCenter 配置文件，然后单击打开。

    服务器将显示在 XenCenter 的资源窗格中，状态为断开连接 [image] 。

  3. 在资源窗格中，双击每个导入的服务器以与之连接。


存储服务器连接状态

LoadSessionDialog 6200, PasswordPromptDialog 6600, SaveAndRestoreDialog 6100

可以在 XenCenter 会话之间存储所有托管服务器的登录凭据（用户名和密码），并在启动每个新 XenCenter 会话时使用凭据自动重新连接这些服务器。启用该功能后，XenCenter 将在每个会话结束时记住所有托管服务器的连接状态，并尝试在下一个会话启动时还原连接状态。如果在上一个会话结束时与某个服务器处于连接状态，将自动与该服务器重新连接，而不会提示您输入详细的服务器登录信息；如果在上一会话结束时与某个服务器断开连接，则不会自动重新连接该服务器。

如果选择关闭自动重新连接功能，则每次打开 XenCenter 时都需要为每个托管服务器输入用户名和密码来重新连接这些服务器。

注意：系统管理员可能会禁用服务器登录凭据的保存功能，因此该功能可能不可用。

您可以选择利用主密码来保护存储的登录凭据，以确保这些凭据的安全；在启动每个会话时，系统将在还原与托管服务器的连接之前，提示您输入此主密码。

打开或关闭自动重新连接功能

  1. 打开 XenCenter 选项对话框：在工具菜单中，单击选项。
  2. 单击保存和还原选项卡，然后选中或清除保存并在启动时还原服务器连接状态复选框。

使用主密码

SetMasterPasswordDialog 6110, ChangeMasterPasswordDialog 6120, EnterMasterPasswordDialog 6130

如果选择在 XenCenter 中存储服务器登录凭据，还可以设置一个主密码；在自动还原与托管服务器的连接之前，必须输入此密码。您可以在 XenCenter 选项对话框的保存和还原选项卡中设置、删除和更改主密码。

请注意，如果丢失或忘记主密码，将无法恢复。如果出现这种情况，需要再次连接每个托管服务器，然后设置新的主密码。

设置主密码：

  1. 打开 XenCenter 选项对话框：在工具菜单中，单击选项。
  2. 单击保存和还原选项卡。
  3. 确保选中保存并在启动时还原服务器连接状态复选框。
  4. 在主密码下，选中需要主密码复选框，然后输入密码并确认，单击确定。请记住，密码区分大小写。

更改主密码：

  1. 打开 XenCenter 选项对话框：在工具菜单中，单击选项。
  2. 单击保存和还原选项卡。
  3. 在主密码下，单击更改主密码。
  4. 输入现有主密码，然后输入新的主密码并确认，单击确定。

清除主密码：

  1. 打开 XenCenter 选项对话框：在工具菜单中，单击选项。
  2. 单击保存和还原选项卡。
  3. 在主密码下，清除需要主密码复选框。
  4. 如果提示输入密码，输入当前主密码并确认，然后单击确定。


配置网络连接

主题
关于 XenServer 网络
添加新网络
删除网络
查看和更改网络属性
配置 NIC
配置 IP 地址


关于 XenServer 网络

每个托管服务器都有一个或多个网络。XenServer 网络是虚拟的以太网交换机，它可以连接到外部接口（带或不带 VLAN 标记），或者是单个服务器或池内部完全虚拟的网络。

在物理服务器上安装 XenServer 后，系统将为该服务器上的每个物理 NIC 创建一个网络。该网络在虚拟机上的虚拟网络接口 (VIF) 与主机服务器上网络接口卡 (NIC) 所关联的物理网络接口 (PIF) 之间起到桥接的作用。

将托管服务器移至资源池中时，这些默认网络将合并，这样，设备名称相同的所有物理 NIC 都将连接到同一个网络。通常，只有当您希望创建内部网络、使用现有 NIC 设置新 VLAN 或创建 NIC 绑定时，才需要添加一个新网络。您最多可以为每个托管服务器配置 16 个网络，或者最多配置 8 个绑定的网络接口。

可以使用巨型帧来优化存储通信的性能。可以在新建网络向导中为新服务器网络设置最大传输单元 (MTU)，或者在属性窗口中为现有网络设置最大传输单元，以允许使用巨型帧。MTU 值的允许范围为 1500 到 9216。

网络类型

在 XenCenter 内创建新网络时，有四种不同的物理（服务器）网络类型可供选择。

单服务器专用网络
这种网络类型属于内部网络，与物理网络接口没有关联，仅在指定服务器上的虚拟机之间提供连接，不与外部连接。
跨服务器专用网络
这种网络类型属于池级别的网络，在一个池中的各 VM 之间提供专用连接，但不与外部连接。跨服务器专用网络将单服务器专用网络的隔离属性与跨资源池的功能结合在一起，从而可以对连接跨服务器专用网络的 VM 使用 VM 的各种灵活功能（如 XenMotion 实时迁移和 Workload Balancing (WLB)）。尽管 VLAN 也提供类似功能，但与 VLAN 不同的是，跨服务器专用网络通过使用通用路由封装 (GRE) IP 隧道协议提供隔离功能，而无需配置物理交换机结构。要创建跨服务器专用网络，必须满足以下条件：
  • 池中的所有服务器必须使用 XenServer 5.6 Feature Pack 1 或更高版本；
  • 池中的所有服务器必须使用 OpenVSwitch 来进行网络连接；
  • 池必须配置了 vSwitch 控制器，用来处理 vSwitch 连接所需的初始化和配置任务（必须在 XenCenter 外部完成）。
外部网络
这种类型的网络与物理网络接口关联，在虚拟机与外部网络之间起到桥接作用，从而使 VM 能够通过服务器的物理网络接口卡连接外部资源。
绑定网络
此类网络的构成方式是绑定两个或更多 NIC，创建一个高性能的通道，用于连接 VM 与外部网络。支持以下三种绑定模式：
  • 主动-主动：在此模式下，将在两个绑定的 NIC 之间平衡通信。如果绑定的一个 NIC 出现故障，则主机的所有网络通信将自动通过另一个 NIC 进行路由。此模式可以在绑定的两个物理 NIC 之间实现虚拟机通信的负载平衡。
  • 主动-被动（主动-备用）：只有一个绑定的 NIC 处于活动状态；当且仅当活动 NIC 发生故障时，非活动 NIC 才变为活动状态，从而实现热备用功能。
  • 链路聚合控制协议 (LACP) 绑定：该模式提供主动-主动型绑定，将在绑定的 NIC 之间平衡通信。与 Linux 桥接环境中的主动-主动型绑定不同，LACP 可以对所有通信类型进行负载平衡。该模式下的两个可用选项为：
    • LACP 与基于源 MAC 地址的负载平衡功能绑定：在该模式下，根据发起通信的 VM 的 MAC 地址选择传出 NIC。使用该选项可以在同一主机上有多个 VM 的环境中平衡通信。如果 VIF 数量少于 NIC，则该选项不适用：负载平衡不是最优方法，因为通信不能在 NIC 之间划分。
    • LACP 与基于源和目标的 IP 和端口的负载平衡功能绑定 - 在这种模式下，源 IP 地址、源端口号、目标 IP 地址和目标端口号用于在 NIC 之间路由通信。该选项非常适合在 NIC 数量超过 VIF 数量的环境中平衡 VM 的通信。例如，只将一个虚拟机配置为使用三个 NIC 的绑定。
    注意：
  • 您必须配置 vSwitch 作为网络堆栈，才能查看 XenCenter 中的 LACP 绑定选项，并创建新的 LACP 绑定。此外，交换机必须符合 IEEE 802.3ad 标准。
  • 主动-主动和主动-被动绑定类型适用于 vSwitch 和 Linux 桥接。
  • vSwitch 作为网络堆栈时，您可以绑定两个、三个或四个 NIC，而 Linux 桥接作为网络堆栈时，您只能绑定两个 NIC。

有关 XenServer 中 NIC 绑定支持的详细信息，请参阅《XenServer 管理员指南》。


添加新网络

NewNetworkWizard 8000

要在池中或独立服务器上创建新网络，请使用新建网络向导执行以下操作：在资源窗格中选择服务器或池，单击网络连接选项卡，然后单击添加网络。

添加新的外部网络

外部网络与物理网络接口卡 (NIC) 关联，在虚拟机与外部网络之间起到桥接作用，从而使虚拟机可以通过 NIC 连接到外部资源。

  1. 打开新建网络向导。
  2. 在向导的第一页中，选择外部网络，然后单击下一步。
  3. 为新网络输入名称和可选的说明，然后单击下一步。
  4. 在网络设置页面上，为新网络配置 NIC、VLAN 和 MTU 设置：
    1. 从 NIC 列表中选择物理网络接口卡 (NIC)。
    2. 在 VLAN 框中，为新的虚拟网络分配编号。
    3. 要使用巨型帧，请将最大传输单元 (MTU) 设置为介于 1500 与 9216 之间的值。
  5. 选中自动将此网络添加到新虚拟机复选框，以将新网络添加到使用新建 VM 向导创建的任何新 VM 中。
  6. 单击完成，以创建新网络并关闭向导。

添加新的单服务器专用网络

单服务器专用网络属于内部网络，与物理网络接口没有关联，仅在指定服务器上的虚拟机之间提供连接，不连接池中其他服务器上的 VM，也不与外部连接。

  1. 打开新建网络向导。
  2. 在向导的第一页中，选择单服务器专用网络，然后单击下一步。
  3. 输入新网络的名称和可选说明，然后单击下一步。
  4. 在网络设置页面上，选中自动将此网络添加到新虚拟机复选框，以将新网络添加到使用新建 VM 向导创建的任何新 VM 中。
  5. 单击完成，以创建新网络并关闭向导。

添加新的跨服务器专用网络

跨服务器专用网络属于池级别的网络，在池中的 VM 之间提供专用连接，但不与外部连接。要创建跨服务器专用网络，必须满足以下条件：

  • 池中的所有服务器必须使用 XenServer 5.6 Feature Pack 1 或更高版本；
  • 池中的所有服务器必须使用 OpenVSwitch 来进行网络连接；
  • 池必须配置了 vSwitch 控制器，用来处理 vSwitch 连接所需的初始化和配置任务（必须在 XenCenter 外部完成）。

过程

  1. 打开新建网络向导。
  2. 在向导的第一页中，选择跨服务器专用网络，然后单击下一步。
  3. 输入新网络的名称和可选说明，然后单击下一步。
  4. 在网络设置页面上，从管理接口列表中选择新网络要使用的接口。
  5. 选中自动将此网络添加到新虚拟机复选框，以将新网络添加到使用新建 VM 向导创建的任何新 VM 中。
  6. 单击完成，以创建新网络并关闭向导。

添加新的绑定网络

此类网络的构成方式是将两个或更多 NIC 绑定到一起，创建一个高性能的通道，用于连接 VM 与外部网络。

注意：尽可能在将其他服务器加入池中或创建 VM 之前，在初始资源池创建过程中创建 NIC 绑定。这样，在服务器加入池时，系统可以将绑定配置自动复制到其中，从而减少了所需的步骤。

过程

  1. 打开新建网络向导。
  2. 在向导的第一页中，选择绑定网络，然后单击下一步。
  3. 在绑定成员页面上，选择要绑定到一起的 NIC。要选择 NIC，可以在列表中选中其对应的复选框。在该列表中最多可以选择四个 NIC。清除复选框可以取消选中 NIC。
  4. 在绑定模式下，选择绑定类型：
    • 选择主动-主动可配置主动-主动型绑定，这种绑定类型可以在绑定的 NIC 之间平衡通信，如果其中一个绑定的 NIC 出现故障，主机服务器的网络通信将自动通过另一个 NIC 进行路由。
    • 选择主动-被动可配置主动-被动型绑定，在这种绑定类型中，通信仅通过其中一个绑定的 NIC 传输。在此模式下，只有在活动 NIC 出现故障（例如，失去网络连接）时，另一个 NIC 才会变为活动状态。
    • 选择 LACP 与基于源 MAC 地址的负载平衡功能绑定可配置 LACP 绑定，这种绑定类型根据发起通信的 VM 的 MAC 地址选择传出 NIC。使用该选项可以在同一主机上有多个 VM 的环境中平衡通信。如果虚拟接口 (VIF) 数量少于 NIC，则该选项不适用：负载平衡不是最优方法，因为通信不能在 NIC 之间划分。
    • 选择 LACP 与基于源和目标的 IP 和端口的负载平衡功能绑定可配置 LACP 绑定，在该模式下，源 IP 地址、源端口号、目标 IP 地址和目标端口号用于在 NIC 之间分配通信。使用该选项可以在 NIC 数量超过 VIF 数量的环境中平衡 VM 的通信。
        • 注意：
      • 您必须配置 vSwitch 作为网络堆栈，才能查看 XenCenter 中的 LACP 绑定选项，并创建新的 LACP 绑定。此外，交换机必须符合 IEEE 802.3ad 标准。
      • 主动-主动和主动-被动绑定类型适用于 vSwitch 和 Linux 桥接。
      • vSwitch 作为网络堆栈时，您可以绑定两个、三个或四个 NIC，而 Linux 桥接作为网络堆栈时，您只能绑定两个 NIC。
  5. 要使用巨型帧，请将最大传输单元 (MTU) 设置为介于 1500 与 9216 之间的值。
  6. 选中自动将此网络添加到新虚拟机复选框，以将新网络添加到使用新建 VM 向导创建的任何新 VM 中。
  7. 单击完成，以创建新网络并关闭向导。

有关详细信息，请参阅配置 NIC。


删除网络

过程

  1. 在资源窗格中选择服务器或池，然后单击网络连接选项卡。
  2. 在网络连接选项卡上，在列表中选择要删除的网络，然后单击删除网络。


查看和更改网络属性

HelpIDs:TabPageNetworkServer 1071, EditNetworkGeneralSettingsDialog 6252

查看服务器的当前网络配置

单击服务器的网络连接选项卡，以查看该服务器上当前配置的所有网络，以及有关每个网络的信息：

名称 | 网络的名称。
说明 | （可选）网络的说明。
NIC | 网络所使用的物理网络接口卡 (NIC)、NIC 绑定或内部虚拟网络。
VLAN | 对于外部网络，该列显示虚拟 LAN (VLAN) 标记。
自动 | 该列指示网络是否会自动添加到使用新建 VM 向导所创建的任何新虚拟机中。
链接状态 | 网络的链接状态：连接或断开。
MAC | 网络适配器 (NIC) 的介质访问控制地址。对于一个特定网络适配器，此标识符是唯一的。
MTU | 最大传输单元值介于 1500 与 9216 之间时，允许使用巨型帧。

更改服务器的网络配置

在 XenCenter 网络连接选项卡上，选择网络并单击属性。除了名称、说明、文件夹、标记和自定义字段属性外，还可以在网络设置选项卡上更改下列网络配置设置：

选项 | 说明
绑定模式 该配置选项仅显示在绑定网络中。
  • 选择主动-主动可配置主动-主动型绑定，这种绑定类型可以在绑定的 NIC 之间平衡通信，如果其中一个绑定的 NIC 出现故障，主机服务器的网络通信将自动通过另一个 NIC 进行路由。
  • 选择主动-被动可配置主动-被动型绑定，在这种绑定类型中，通信仅通过其中一个绑定的 NIC 传输。在此模式下，只有在活动 NIC 出现故障（例如，失去网络连接）时，另一个 NIC 才会变为活动状态。
  • 选择 LACP 与基于源 MAC 地址的负载平衡功能绑定可配置 LACP 绑定，这种绑定类型根据发起通信的 VM 的 MAC 地址选择传出 NIC。使用该选项可以在同一主机上有多个 VM 的环境中平衡通信。如果虚拟接口 (VIF) 数量少于 NIC，则该选项不适用：负载平衡不是最优方法，因为通信不能在 NIC 之间划分。
  • 选择 LACP 与基于源和目标的 IP 和端口的负载平衡功能绑定可配置 LACP 绑定，在该模式下，源 IP 地址、源端口号、目标 IP 地址和目标端口号用于在 NIC 之间分配通信。使用该选项可以在 NIC 数量超过 VIF 数量的环境中平衡通信。
      • 注意：
    • 您必须配置 vSwitch 作为网络堆栈，才能查看 XenCenter 中的 LACP 绑定选项，并创建新的 LACP 绑定。此外，交换机必须符合 IEEE 802.3ad 标准。
    • 主动-主动和主动-被动绑定类型适用于 vSwitch 和 Linux 桥接。
    • vSwitch 作为网络堆栈时，您可以绑定两个、三个或四个 NIC，而 Linux 桥接作为网络堆栈时，您只能绑定两个 NIC。

    有关详细信息，请参阅配置 NIC。
MTU | 要使用巨型帧，请将最大传输单元 (MTU) 设置为介于 1500 与 9216 之间的任何值。
自动将此网络添加到新虚拟机 | 如果选中该复选框，网络会自动添加到使用新建 VM 向导所创建的新 VM 中。


配置 NIC

XenServer 根据相关的网络、虚拟网络接口、服务器网络和绑定配置，按需要自动对 NIC 进行管理。通过 NIC 选项卡可以查看可用的 NIC、配置 NIC 绑定，并将 NIC 专用于特定功能。

NIC 绑定可以将两个或更多物理 NIC 当作一个 NIC 使用，从而提高服务器的弹性。两个或更多 NIC 可以绑定在一起，创建一个高性能通道，用于连接 VM 与外部网络。支持以下三种绑定模式：

  • 主动-主动。此模式可以在绑定的两个物理 NIC 之间实现虚拟机通信的负载平衡。如果绑定的一个 NIC 出现故障，则主机的所有网络通信将自动通过另一个 NIC 进行路由。
  • 主动-被动（主动-备份）。该模式可以提供故障转移功能。只有一个绑定的 NIC 处于活动状态；当且仅当活动 NIC 发生故障时，非活动 NIC 才变为活动状态。
  • 链路聚合控制协议 (LACP) 绑定。该模式提供主动-主动型绑定，将在绑定的 NIC 之间平衡通信。与 Linux 桥接环境中的主动-主动型绑定不同，LACP 可以对所有通信类型进行负载平衡。

    • 注意：您必须配置 vSwitch 作为网络堆栈，才能查看 XenCenter 中的 LACP 绑定选项，并创建新的 LACP 绑定。此外，交换机必须符合 IEEE 802.3ad 标准。交换机必须包含为主机上每个 LACP 绑定配置的单独 LAG 组。有关创建 LAG 组的详细信息，请参阅《XenServer 管理员指南》。

    有关 XenServer 中 NIC 绑定支持的详细信息，请参阅《XenServer 管理员指南》。

使用 XenCenter 绑定两个单独 NIC 时，会创建一个新的 NIC：新 NIC 为绑定主 NIC，绑定的 NIC 称为从属 NIC。NIC 绑定随后可以连接到 XenServer 网络，以实现虚拟机通信和服务器管理功能。在 XenCenter 中，可以通过 NIC 选项卡或服务器的网络连接选项卡创建 NIC 绑定（网络类型 = 绑定网络）。

查看可用 NIC

对于服务器上每个可用的 NIC，NIC 选项卡上将显示以下设备属性：

NIC | 标识物理网络接口卡或内部虚拟网络。
MAC | NIC 的介质访问控制地址。
链接状态 | NIC 的连接状态：连接或断开。
速度 | NIC 的数据传输速率。
双工 | NIC 的双工模式：全双工或半双工。
供应商、设备 | NIC 的供应商和设备名称。
PCI 总线路径 | 传递设备的 PCI 总线路径。

在 XenServer 主机上添加新的物理接口（例如，新的以太网控制器）时，该接口可能不显示在 NIC 选项卡上的列表中。如果出现这种情况，可以在 NIC 选项卡上单击重新扫描，强制 XenServer 扫描新的接口卡。

创建新的 NIC 绑定

  1. 确保要绑定到一起的 NIC（绑定从属 NIC）未在使用中：在创建绑定之前，必须先关闭其虚拟网络接口使用绑定从属 NIC 的任何 VM。创建绑定后，需要将这些虚拟网络接口重新连接到适当网络。
  2. 在资源窗格中选择服务器，单击 NIC 选项卡，然后单击创建绑定。
  3. 选择要绑定到一起的 NIC。要选择 NIC，可以在列表中选中其对应的复选框。在该列表中最多可以选择四个 NIC。清除复选框可以取消选中 NIC。为了保持网络的灵活性和安全性，您可以使用 vSwitch 作为网络堆栈，绑定两个、三个或四个 NIC，而 Linux 桥接作为网络堆栈时，您只能绑定两个 NIC。

  4. 在绑定模式下，选择绑定类型：
    • 选择主动-主动可配置主动-主动型绑定，这种绑定类型可以在绑定的 NIC 之间平衡通信，如果其中一个绑定的 NIC 出现故障，主机服务器的网络通信将自动通过另一个 NIC 进行路由。
    • 选择主动-被动可配置主动-被动型绑定，在这种绑定类型中，通信仅通过其中一个绑定的 NIC 传输。在此模式下，只有在活动 NIC 出现故障（例如，失去网络连接）时，另一个 NIC 才会变为活动状态。
    • 选择 LACP 与基于源 MAC 地址的负载平衡功能绑定可配置 LACP 绑定，这种绑定类型根据发起通信的 VM 的 MAC 地址选择传出 NIC。使用该选项可以在同一主机上有多个 VM 的环境中平衡通信。如果虚拟接口 (VIF) 数量少于 NIC，则该选项不适用：负载平衡不是最优方法，因为通信不能在 NIC 之间划分。
    • 选择 LACP 与基于源和目标的 IP 和端口的负载平衡功能绑定可配置 LACP 绑定，在该模式下，源 IP 地址、源端口号、目标 IP 地址和目标端口号用于在 NIC 之间分配通信。使用该选项可以在 NIC 数量超过 VIF 数量的环境中平衡 VM 的通信。

      • 注意：LACP 绑定仅适用于 vSwitch，而主动-主动和主动-被动绑定模式适用于 vSwitch 和 Linux 桥接。

    有关 XenServer 中 NIC 绑定支持的详细信息，请参阅《XenServer 管理员指南》。

  5. 要使用巨型帧，请将最大传输单元 (MTU) 设置为介于 1500 与 9216 之间的值。
  6. 要使新的绑定网络自动添加到使用新建 VM 向导所创建的任何新 VM 中，请选中该复选框。
  7. 单击创建以创建 NIC 绑定并关闭对话框。

创建新绑定后，XenCenter 会自动将管理接口和辅助接口从绑定从属 NIC 移至绑定主 NIC。

请注意，不允许将其管理接口在绑定 NIC 上的服务器加入池中。要将其加入池，必须重新配置服务器的管理接口并将其移回物理 NIC。

删除 NIC 绑定

如果将服务器还原到非绑定配置，应注意下列要求：

  • 与创建绑定过程一样，在销毁绑定之前，必须先关闭其虚拟网络接口使用该绑定的所有虚拟机。还原为非绑定配置后，需要将这些虚拟网络接口重新连接到适当网络。
  • 在删除绑定之前，必须先使用管理接口对话框将管理接口移至其他 NIC，否则将与服务器（包括 XenCenter）断开连接。

删除绑定

  1. 在资源窗格中选择服务器，然后单击 NIC 选项卡。
  2. 单击删除绑定。

将 NIC 专用于特定功能

您可以为 NIC 分配 IP 地址，以将 NIC 专用于执行特定功能，例如存储或其他类型的网络通信。有关详细信息，请参阅配置 IP 地址。


配置 IP 地址

托管服务器上用作管理接口的 NIC 最初在 XenServer 安装期间指定。在 XenCenter 中，XenServer xe 命令行接口 (CLI) 以及独立计算机上运行的其他任何管理软件都通过管理接口的 IP 地址连接到服务器。

如果一个服务器有两个或更多 NIC，您可以选择一个不同的 NIC 或 NIC 绑定用作其管理接口。您可以为 NIC 分配 IP 地址（也称为配置辅助接口），并将 NIC 专用于执行特定功能，例如存储或其他类型的网络通信。请注意，不支持在 VLAN 网络上使用管理接口。

还要注意，当新服务器加入池时，该服务器将自动继承池主服务器的网络配置（包括网络和绑定信息）。但是，加入的服务器的管理接口不会变为与主服务器相同，因此需要在加入后重新对其进行配置，以使用与池主服务器相同的绑定。还应注意，管理接口正在绑定的服务器不可以加入池，因此，如果要加入池，必须重新配置该服务器的管理接口，并将其移回物理 NIC。

下面几节提供了使用配置 IP 地址对话框在 XenCenter 中为 NIC 分配 IP 地址以及更改服务器或池的管理接口的说明。

为 NIC 分配 IP 地址

您可以使用 XenCenter 为 NIC 配置 IP 地址来执行特定功能，例如存储通信。为 NIC 配置 IP 地址时，本质上是在创建辅助接口。

为了保持网络的灵活性和安全性，您可以创建辅助接口来将网络通信分段，这些管理接口使用专用 NIC 建立单独的网络，用于服务器管理、应用程序生产通信和存储通信，等等。在默认 XenServer 网络连接配置中，基于 IP 的存储设备的所有网络通信都通过用于管理接口的 NIC 进行。另请务必注意，辅助接口从管理接口继承 DNS 服务器设置。

要为 NIC 分配 IP 地址来执行特定功能，需要有适当的网络配置，以确保 NIC 用于所需通信。例如，要将 NIC 专用于存储通信，您必须为新创建的接口分配 IP 地址，该地址 (a) 与存储控制器在同一子网中（如果适用）；(b) 与管理接口在不同子网中；(c) 不与其他任何辅助接口在同一子网中。此外，还必须将 NIC、存储目标、交换机和/或 VLAN 配置为只能通过分配的 NIC 访问目标。这样就可以使用标准的 IP 路由来控制通信在托管服务器内多个 NIC 之间的路由。

要为 NIC 分配 IP 地址并创建辅助接口，请执行以下操作：

  1. 在服务器或池的网络连接选项卡中，在 IP 地址配置下单击配置。
  2. 单击添加 IP 地址。
  3. 输入新辅助接口的名称。
  4. 从网络列表中选择 XenServer 网络。
  5. 配置新接口的网络连接设置：
    • 要使用自动动态主机配置协议 (DHCP) 自动分配网络连接设置（包括 IP 地址、子网掩码和网关），请选择使用 DHCP 自动获取网络设置。
    • 要手动配置网络连接设置，请单击使用以下设置，然后输入所需值。您必须输入 IP 地址和子网掩码，但网关设置为可选项。
  6. 要配置更多接口，请再次单击添加 IP 地址，然后重复执行上述配置步骤。
  7. 完成后，单击确定保存配置选择。

    8. 注意：如果您选择手动配置网络设置，则系统会提示您确认设置。单击仍然重新配置进行确认。

删除辅助接口

  1. 在服务器或池的网络连接选项卡中，在 IP 地址配置下单击配置。
  2. 在对话框左侧已配置的接口列表中，选择要删除的接口，然后单击 Remove this Interface（删除此接口）。
  3. 单击确定保存配置选择。

更改管理接口

  1. 在服务器或池的网络连接选项卡中，在 IP 地址配置下单击配置。
  2. 在主选项卡上，从网络列表中选择 XenServer 网络。
  3. 配置管理接口的网络设置：
    • 要使用自动动态主机配置协议 (DHCP) 自动分配网络连接设置（包括 IP 地址、子网掩码、网关和 DNS 服务器），请选择使用 DHCP 自动获取网络设置。
    • 要手动配置网络设置，请单击使用以下设置，然后输入所需值。您必须输入 IP 地址和子网掩码，但网关和 DNS 服务器设置为可选项。
  4. 完成后，单击确定保存配置选择。

    5. 注意：如果您选择手动配置网络设置，则系统会提示您确认设置。单击仍然重新配置进行确认。


配置主机开机

通过 XenServer 主机开机功能，您可以手动开启或关闭远程主机（服务器）。要使用该功能，需要执行以下步骤：

  1. 确保主机支持远程电源控制（即，主机具有 Wake-on-LAN 功能、DRAC 或 iLO 卡，或使用自定义脚本）。请参阅主机开机功能必备条件。
  2. 按照启用或禁用主机开机功能所述启用主机开机功能。要对 iLO 和 DRAC 处理器执行此过程，需要使用在处理器固件中设置的处理器凭据。

对服务器配置主机开机功能后，就可以从 XenCenter 开启该服务器，方法是选择该服务器，然后在服务器菜单中单击开机。

如果安装并配置了 Workload Balancing，还可以将 XenServer 配置为在 VM 合并或恢复联机后自动开启或关闭主机。这一功能称为电源管理。Workload Balancing 和电源管理功能都只在 XenServer 企业版或更高版本中提供。请参阅自动优化和管理电源。

主机开机功能必备条件

要启用主机开机功能，主机服务器必须具有以下电源控制解决方案之一：

  • 支持 Wake On LAN (WOL) 的网卡。
  • Dell Remote Access Controller (DRAC)。要将 XenServer 与 DRAC 结合使用，需要遵循以下步骤：
    1. 安装 Dell 补充软件包。
    2. 在装有远程访问控制器的主机服务器上安装 RACADM 命令行实用程序。
    3. 启用 DRAC 及其接口。RACADM 通常包含在 DRAC 管理软件中。有关详细信息，请参阅 Dell 的 DRAC 文档。
  • Hewlett-Packard Integrated Lights-Out (iLO)。要将 XenServer 与 iLO 结合使用，必须在主机上启用 iLO 并将其连接到网络。有关详细信息，请参阅 HP 的 iLO 文档。
  • 基于 Xen-API 的自定义开机脚本，允许通过 XenServer 开关机。对于 DRAC 和 iLO，可以使用加密功能（通过指定密钥 power_on_password_secret）帮助您更安全地存储密码。有关详细信息，请参阅《XenServer 管理员指南》。

启用或禁用主机开机功能

可以通过主机的属性窗口对单个主机服务器启用主机开机功能，或者通过池的属性窗口对多个服务器启用主机开机功能。

  1. 选择服务器或池，并打开其属性对话框：在服务器或池菜单中，单击属性。
  2. 单击开机选项卡，在开机模式下，选择所需选项：

    禁用 | 选择该选项可关闭主机开机功能。
    Wake-on-LAN (WoL) | 要使用此选项，主机必须配备支持 Wake on LAN 功能的网卡。
    HP Integrated Light-Out (iLO) | 要使用此选项，必须在主机上启用 iLO 并将其连接到网络。有关详细信息，请参阅 HP 的 iLO 文档。
    Dell Remote Access Controller (DRAC) | 要使用此选项，主机服务器上必须安装有 Dell 补充软件包以获得 DRAC 支持。有关详细信息，请参阅 Dell 的 DRAC 文档。
    自定义开机脚本 | 可以使用自定义 Python Linux 脚本从远程位置开启 XenServer 主机的电源。有关创建脚本（包括受支持键/值对的列表）的信息，请参阅《XenServer 管理员指南》。

  3. 如果选择了 HP iLO 或 Dell DRAC，请输入以下信息：

    IP 地址 | 您指定用来与电源控制卡通信的 IP 地址。或者，也可以输入配置了 iLO 或 DRAC 的网络接口的域名。
    用户名 | 与管理处理器相关联的 iLO 或 DRAC 用户名，您可能已更改其出厂时的默认设置，也可能未更改。
    密码 | 与用户名相关联的密码。

  4. 如果选择了自定义开机脚本，请输入所创建的自定义脚本的文件名和路径，然后在配置选项下，输入要用来配置脚本的键/值对。通过单击或使用 Tab 键可在字段间移动。

    指定自定义脚本的文件名时，无需指定 .py 扩展名。

  5. 单击确定，以保存配置更改并关闭属性窗口。

完成配置后，可以配置并运行 Workload Balancing 自动化和主机开机功能，如自动优化和管理电源所述。


更改服务器属性

EditHostGeneralSettingsDialog 6240

在资源窗格中选择任何已连接的服务器，然后单击常规选项卡，即可查看其属性和当前状态。可以通过在常规选项卡上单击属性来更改服务器属性。

常规属性 — 名称、说明、文件夹和标记

可以在服务器属性对话框的常规属性选项卡上更改名称、说明、文件夹和标记。

  • 要更改服务器的名称，请在名称框中输入新的名称。
  • 要更改其说明，请在说明框中输入新文本。
  • 要将服务器放入文件夹中或将其移至不同的文件夹中，请在文件夹框中单击更改，然后选择文件夹。有关使用文件夹的详细信息，请参阅使用文件夹。
  • 要对服务器进行标记或取消标记，以及创建和删除标记，请参阅使用标记。

iSCSI IQN（“常规”选项卡）

当服务器连接 iSCSI 存储库 (SR) 时，将使用服务器的 iSCSI IQN 来唯一标识该服务器。XenServer 主机支持单个 iSCSI 发起程序，该发起程序在主机安装期间自动创建并配有一个随机 IQN。单个发起程序可以用来同时连接多个 iSCSI 目标 (SR)。有关 XenServer 的 iSCSI 存储支持功能的更多详细信息，请参阅《XenServer 管理员指南》。

重要提示 - iSCSI 目标 (SR) 和池中的所有服务器必须设置不同的 IQN。如果使用不唯一的 IQN 标识符，则数据会遭到破坏，并且/或者对目标的访问可能被拒绝。

更改托管服务器的 iSCSI IQN 值

注意：在更改服务器的 iSCSI IQN 值之前，必须断开所有现有的 SR。还请注意，如果更改服务器的 IQN，在相应更新存储目标前，该服务器可能无法连接新的或现有的 SR。

  1. 在资源窗格中选择服务器，单击常规选项卡，然后单击属性。
  2. 在属性对话框的常规选项卡上，在 iSCSI IQN 框中输入新值。
  3. 单击确定，以保存更改并关闭对话框。

自定义字段

可以使用自定义字段为托管资源添加信息，使这些资源更易于搜索和组织。有关如何为托管资源指定自定义字段的信息，请参阅使用自定义字段。

警报

使用该选项卡可针对服务器的 CPU、内存、网络 I/O 和磁盘 I/O 使用情况配置性能警报。请参阅配置性能警报。

XenServer 高级版和更高版本中提供高级警报功能。要了解有关不同 XenServer 版本中可用功能的详细信息，请单击此处。

电子邮件选项（独立服务器）

使用该选项卡可以针对独立服务器上生成的系统警报配置电子邮件通知。对于池中的服务器，该功能在池级别配置。有关如何设置警报电子邮件通知的详细信息，请参阅 XenCenter 系统警报。

XenServer 高级版和更高版本中提供基于电子邮件的性能和错误警报功能。要了解有关不同 XenServer 版本中可用功能的详细信息，请单击此处。

StorageLink Gateway（仅限 XenServer 5.6 FP1 独立服务器）

如果使用 StorageLink Gateway (CSLG) 服务从 XenServer 5.6 Feature Pack 1 独立服务器访问不同的存储阵列，可以在该选项卡上更改 CSLG 服务器详细信息以及测试与该服务器的连接。如果使用同一台 CSLG 服务器为多个不同的池或独立服务器提供存储，可以选择在所有池和独立服务器中使用这些 StorageLink 服务器凭据，以在任何位置都使用相同的 CSLG 凭据。

对于池中的 XenServer 5.6 Feature Pack 1 服务器，StorageLink Gateway 存储功能在池级别配置（池 > 属性）。

多路径

光纤通道和 iSCSI 存储库支持动态存储多路径功能，可以通过服务器属性对话框中的多路径选项卡启用此功能。

有关启用和禁用多路径的信息，请参阅存储多路径。

开机（独立服务器）

使用该选项卡可配置 XenServer 主机开机功能，以允许远程开启托管服务器。有关配置此功能的详细信息，请参阅配置主机开机。对于池中的服务器，该功能在池级别配置。

日志目标位置

XenServer 系统日志消息可以存储在本地服务器上或者存储在远程服务器上。

要接收日志并将这些日志正确聚合在一起，远程服务器必须运行 syslogd 后台程序。syslog 后台程序是所有类型的 Linux 和 Unix 的标准组件，Windows 和其他操作系统可以使用其第三方版本。还应将远程服务器配置为允许从池中的主机远程连接，并正确配置其防火墙。

查看或更改 XenServer 日志目标位置

  1. 在资源窗格中选择服务器，单击常规选项卡，然后单击属性。
  2. 在属性对话框中单击日志目标位置选项卡，然后：
    • 要在本地存储 XenServer 日志消息，请单击本地。
    • 要在其他服务器上存储 XenServer 日志消息，请单击远程并输入路径名。
  3. 单击确定，以保存更改并关闭对话框。


备份和还原服务器

可以将托管服务器备份到 XenServer 备份文件 (.xbk) 中，当出现硬件故障时，可以使用该文件还原服务器。请注意，这种方法只备份服务器本身，而不会备份可能在该服务器上运行的任何 VM。

建议您经常备份服务器，以便能够从可能发生的服务器和/或软件故障进行恢复。在 XenCenter 中备份服务器时，应注意以下几点：

  • 不应在 XenServer 控制域（域 0）上创建备份。有关 XenServer 控制域的详细信息，请参阅《XenServer 管理员指南》。
  • XenServer 备份文件可能非常大。

要还原服务器，可以在 XenCenter 中选择并还原备份文件，然后通过 XenServer 安装 CD 重新启动该服务器，以完成还原。

备份服务器配置和软件

  1. 在资源窗格中选择服务器，然后在服务器菜单中单击备份。
  2. 通过浏览找到用于保存备份文件的文件夹并输入文件名，然后单击保存开始备份。

备份过程可能需要一段时间。可以单击日志选项卡查看备份进度。

通过备份还原服务器软件和配置

  1. 在资源窗格中选择服务器，然后在服务器菜单中单击从备份还原。
  2. 通过浏览找到备份文件，然后单击打开开始还原。
  3. 在主机服务器上，重新引导至主机安装 CD，然后选择从备份还原。


重新启动服务器

在 XenCenter 中重新启动服务器时，将首先关闭所有在其中运行的虚拟机 (VM)，随后将该服务器断开连接并重新启动。如果服务器是某个池的成员，在服务器恢复启动时，将处理关机时断开的连接，池也将恢复。如果关闭另一个池成员（非主服务器），其他池成员和主服务器将继续发挥作用。如果关闭主服务器，池将无法正常工作，直到主服务器重新启动并恢复联机状态（此时其他成员将重新连接并与主服务器同步），或者直到使其他某个成员成为主服务器（可以通过 XenServer xe 命令行接口 (CLI) 来实现）。

请注意，安装了 XenServer Tools 的 VM（“半虚拟化”VM）将在您重新启动主机服务器时正常关闭，而在 HVM 模式下运行的 VM（即未安装 XenServer Tools 的 VM）则通过强制关机进行关闭；为避免出现此情况，应在所有 HVM 虚拟机上安装 XenServer Tools。

服务器重新启动后，XenCenter 将自动尝试重新连接该服务器。重新连接服务器后，您需要重新启动之前在该服务器中运行的任何 VM，除非这些 VM 配置为在主机服务器重新启动时自动启动（请参阅更改 VM 属性）。

重新启动服务器

在资源窗格中选择服务器，然后在工具栏上单击 重新启动服务器 重新启动。

或者：

  • 单击鼠标右键，然后在快捷菜单中单击重新启动。
  • 在服务器菜单中，单击重新启动。


关闭服务器

在 XenCenter 中关闭服务器时，将首先关闭在其中运行的所有虚拟机 (VM)，随后将该服务器断开连接并关闭。如果服务器是某个池的成员，在服务器恢复启动时，将处理关机时断开的连接，池也将恢复。如果关闭另一个池成员（非主服务器），其他池成员和主服务器将继续发挥作用。如果关闭主服务器，池将无法正常工作，直到主服务器重新启动并恢复联机状态（此时其他成员将重新连接并与主服务器同步），或者直到使其他某个成员成为主服务器（可以通过 XenServer xe 命令行接口 (CLI) 来实现）。

请注意，安装了 XenServer Tools 的 VM（“半虚拟化”VM）将正常关闭，但在 HVM 模式下运行的 VM（即未安装 XenServer Tools 的 VM）将通过强制关机进行关闭；为避免出现此情况，应在所有 HVM 虚拟机上安装 XenServer Tools。

重新启动服务器后，需要再次与之连接。请参阅重新连接服务器。

关闭服务器

在资源窗格中选择服务器，然后在工具栏上单击 [image] 关闭。

或者：

  • 在资源窗格中单击鼠标右键，然后在快捷菜单中单击关闭。
  • 在服务器菜单中，单击关闭。

服务器关闭后，其状态在资源窗格中变为已断开连接 [image] 。


远程开启服务器

通过 XenServer 的主机开机功能，您可以从 XenCenter 远程开启托管服务器。要使用该功能，服务器必须支持远程电源控制（Wake-on-LAN 功能、DRAC 或 iLO 卡或者自定义开机脚本），并且必须在每个服务器的属性中都启用了主机开机功能（可以在池级别一次为多个服务器同时启用该功能）。

有关设置和启用此功能所需操作的信息，请参阅配置主机开机。

过程

配置了主机开机功能后，选择服务器，然后执行以下操作之一：

  • 在服务器菜单中，单击开机。
  • 单击鼠标右键，然后在快捷菜单中选择开机。


从 XenCenter 删除服务器

如果从 XenCenter 中删除托管服务器，将停止对该服务器的所有管理和监视活动，但这样做不会影响该服务器上运行的活动，也不会删除其中安装的任何 VM。删除服务器只是断开 XenCenter 与服务器及其 VM 之间的连接，并从 XenCenter 删除其所有足迹。

要删除服务器，请在资源窗格中选择服务器，然后在服务器菜单中单击从 XenCenter 中删除。

要将删除的服务器放回托管资源列表中，需要通过首次连接该服务器时所用的方法再次将其添加到 XenCenter 中。请参阅添加新服务器


在维护模式下运行

EvacuateHostDialog 6280

您可能出于多种原因而需要将托管服务器脱机，例如滚动升级虚拟化软件、添加或测试与新网络的连接、诊断基础硬件问题或添加与新存储系统的连接。在 XenCenter 中，可以通过将服务器置于维护模式使其暂时脱机。如果服务器位于资源池中，则将其置于维护模式时，所有运行的 VM 将自动从该服务器迁移到同一池中的其他服务器。如果该服务器是池主服务器，还将为池选择一个新的主服务器。

如果启用了 Workload Balancing，该服务器上运行的虚拟机将根据 Workload Balancing 建议（性能数据、放置策略和性能阈值），自动迁移到其最优服务器上（如果可用）。请参阅在启用 Workload Balancing 的状态下进入维护模式。

当服务器处于维护模式时，您无法在该服务器上创建或启动任何 VM。

将服务器置于维护模式

  1. 在资源窗格中选择服务器，然后执行以下操作之一：
    • 单击鼠标右键，在快捷菜单中单击进入维护模式。
    • 在服务器菜单中，单击进入维护模式。
  2. 单击进入维护模式。

如果所有正在运行的 VM 都已成功迁移出该服务器，则在资源窗格中，该服务器的状态变为 [image] 。

使服务器退出维护模式

  1. 在资源窗格中选择服务器，然后执行以下操作之一：
    • 单击鼠标右键，在快捷菜单中单击退出维护模式。
    • 在服务器菜单中，单击退出维护模式。
  2. 单击退出维护模式。


管理池

主题
关于资源池
池要求
新建池
向池中添加服务器
从池中删除服务器
从池中销毁服务器
迁移虚拟机
删除池
更改池属性
更改 root 用户密码


关于资源池

使用 Citrix XenServer 池，可以将多个服务器及其连接的共享存储作为一个统一的资源进行查看，从而可以根据虚拟机资源需求和业务优先级灵活部署虚拟机。一个池中最多可以包含 16 个服务器，这些服务器都运行同一版本的 XenServer 软件（具有相同的修补程序级别），而且具有广泛的硬件兼容性。有关硬件和配置必备条件的详细信息，请参阅池要求。

池中的一个服务器被指定为池主服务器，为池中的所有服务器提供单一联系点，以根据需要将通信路由到池中的其他成员。

如果池主服务器关闭，则在池主服务器重新启动并恢复联机状态之前，或者在指定其他某个成员作为新的池主服务器之前，池将不可用。资源池的每个成员都包含根据需要接管池主服务器角色所需的全部信息。在启用了高可用性的池中，如果池主服务器关闭，会自动指定新的池主服务器。


池要求

创建池或将服务器加入现有池前，应确保池中的所有服务器满足下面介绍的要求。

硬件要求

XenServer 资源池中的所有服务器必须具有广泛兼容的 CPU，也就是说：

  • 所有服务器上的所有 CPU 都来自同一家 CPU 供应商（Intel 或 AMD）。具体而言，就是不能混用 AMD-V 和 Intel VT CPU。
  • 所有 CPU 必须具有相同的功能集。要在同一个池中加入具有不同 CPU 的服务器，可以通过 CPU 屏蔽来隐藏不兼容的功能。
  • 要运行 HVM (Windows) 虚拟机，所有 CPU 都必须启用虚拟化功能。

使用 CPU 屏蔽（异类池）

在基础 CPU 功能不同的服务器之间，不能进行实时的 VM 迁移。但是，较新一代的 CPU 能够隐藏（“屏蔽”）软件可见处理器功能的差异，从而使具有不同基础硬件功能的 CPU 看上去相同。使用 CPU 屏蔽时，仅公开资源池中所有处理器都支持的功能，使 VM 可以在处理器功能可能不同的服务器之间安全地实现实时迁移。

此功能由 Intel® Virtualization Technology FlexMigration (Intel® VT FlexMigration) 和 AMD-VTM Extended Migration 技术提供。

将新服务器放入 XenServer 资源池时，将对现有 CPU 和新加入 CPU 上的功能集进行比较，如果发现彼此兼容，则允许新服务器加入池中。在确定 CPU 兼容性时，仅考虑公开的 CPU 功能。如果启用 CPU 屏蔽功能，在新 CPU 上将仅公开旧服务器的 CPU 上存在的功能，其他/更新的功能将被屏蔽。这样，如果新服务器的 CPU 支持实时迁移，则该服务器将可以放入“功能更少的”旧服务器所在的资源池中。（这种类型的池称为异类池。）

如果不启用 CPU 屏蔽功能，池中的所有服务器必须具有相同的 CPU，也就是说，CPU 具有完全相同的功能集（这称为同类池）。XenCenter 不允许将具有不同基础处理器功能的服务器放在同一个资源池中。如果在池中的现有服务器上检测到与新服务器不同的 CPU 功能集，XenCenter 将自动尝试使用 CPU 屏蔽功能。

只有 Citrix XenServer 企业版或更高版本才支持异类池。要了解有关不同 XenServer 版本中可用功能的详细信息，请单击此处。

其他要求

除上述的硬件必备条件外，加入池的服务器还需要满足许多其他配置方面的必备条件：

  • 服务器必须具有静态 IP 地址（在服务器本地配置或者使用 DHCP 服务器上的相应配置）。这同样适用于提供 NFS 或 iSCSI 存储的服务器。
  • 服务器的系统时钟必须与池主服务器同步（例如，通过 NTP）。
  • 服务器不能是某个现有资源池的成员。
  • 服务器上不能有任何正运行或挂起的 VM，其 VM 中不能有任何正在执行的操作（例如关机或导出）；必须先关闭所有 VM，然后服务器才能加入池中。
  • 不能为服务器配置任何共享存储。
  • 服务器不能有绑定的管理接口。将服务器加入池中前，需要重新配置该服务器的管理接口并将其移回到物理 NIC，然后在服务器成功加入池中后立即重新进行配置；请参阅配置管理接口。
  • 服务器与池中的服务器必须运行相同版本的 XenServer 软件，修补程序级别也必须相同。
  • 为服务器配置的补充软件包必须与池中现有服务器相同。补充软件包用于将附加软件安装到 XenServer 控制域 dom0 中。为防止在池中出现不一致的用户体验，有必要在池中的所有服务器上安装相同修订版的相同补充软件包。
  • 服务器必须与池中的现有服务器具有相同的 XenServer 产品许可证版本。例如，不能将免费 XenServer 系统添加到使用 XenServer 高级版或更高版本许可证的服务器所在的资源池中。如果尝试将运行免费 XenServer 版本的服务器添加到包含已授权服务器的池中，您将有机会从 Citrix 许可证服务器为加入的服务器分配一个许可证（如果有可用的许可证）。有关详细信息，请参阅管理许可证。

共享池存储

创建资源池时，尽管从技术角度而言并不一定要求池具有共享存储库，但只有在池具有一个或多个共享存储库时，池的优势（例如，在最合适的服务器上运行 VM 以及在服务器之间迁移 VM）才会体现出来。

除非具有共享存储，否则我们建议您不要尝试创建池。添加共享存储后，可以通过复制 VM 将磁盘位于本地存储中的任何现有 VM 移动到共享存储中。

当具有共享 SR 的服务器成为池主服务器时，该 SR 将成为池的共享 SR。如果新的池主服务器没有任何共享存储，则必须为池创建新的共享 SR：请参阅创建新 SR。


新建池

NewPoolDialog 5100

在尝试创建新池之前，请确保要加入新池的所有服务器都满足池要求中所列出的要求。

创建新池

  1. 在工具栏上单击 新建池 新建池以打开新建池对话框。

    或者：

    • 在池菜单中，单击新建池
    • 在资源窗格中，选择独立服务器，单击鼠标右键，然后在快捷菜单中单击添加到池 > 新建池
  2. 输入新池的名称和可选说明；该名称将显示在资源窗格中。
  3. 通过从主服务器列表中选择服务器来指定池主服务器。
  4. 从其他成员列表中选择更多要加入到新池中的服务器。

    将列出所有可用的托管服务器。如果某个服务器未列出，您可以通过单击添加新服务器将该服务器添加到列表中。如果某个托管服务器未列出，原因可能是它不满足池要求中列出的加入池所应达到的一项或多项要求。

  5. 单击创建池，以创建新池并关闭对话框。

如果池主服务器已经有一个共享存储库 (SR)，此存储库将成为池的共享 SR。如果新的池主服务器没有任何共享存储，则必须为池创建新的共享 SR：请参阅创建新 SR。

其他池配置步骤

要配置新池，请使用属性选项卡：

  • 要向池中添加共享存储，请参阅创建新 SR。
  • 要向池中添加更多服务器，请参阅向池中添加服务器。


向池中添加服务器

向资源池中添加任何新服务器之前，请确保要加入的服务器满足池要求中所列出的硬件和配置要求。

重要提示 在尝试将服务器添加到池中之前，应首先备份该服务器上托管的所有虚拟机。

向现有池添加服务器

  1. 在资源窗格中，选择服务器，然后执行以下操作之一：
    • 将所选服务器拖动到资源窗格中的目标池上。
    • 在服务器菜单中，单击添加到池，然后单击目标池。
    • 单击鼠标右键，并在快捷菜单中单击添加到池，然后单击目标池。
  2. 单击确定进行确认。

服务器加入池后，即会在资源窗格中作为池成员显示，例如：

当您将服务器添加到池中时，XenCenter 将尽可能尝试解决任何池配置问题：

  • 要加入的服务器必须取得与池主服务器相同级别的许可证（例如，两者都使用企业版许可证）。不能将服务器添加到使用不同许可证的池主服务器所属的池中（例如，将获得铂金版许可证的服务器添加到使用企业版许可证的池主服务器所属的池中）。

    如果将免费 XenServer 添加到已获许可（高级版、企业版或铂金版）的池主服务器所属的池中，系统将提示您为要加入的服务器升级许可证，使之与池主服务器的许可证匹配。只有这样才能将该服务器添加到池中。如果没有可用许可证，则无法将该服务器添加到池中。

    将服务器加入池后，可以更改任何池成员的许可证。许可证级别最低的服务器决定了池中的所有成员可以使用的功能。有关许可的详细信息，请参阅管理许可证。

  • 如果池主服务器已加入某个域中，系统会提示您为要加入池的服务器配置 Active Directory (AD)。当系统提示您为要加入的服务器提供凭据时，请输入池所加入的域的 AD 凭据。这些凭据必须具有足够的权限才能将服务器添加到域中。

请注意，可能会有其他硬件或配置问题阻止服务器成功加入池：有关资源池必备条件的详细信息，请参阅池要求。

当新服务器加入池中时，该服务器将自动继承池主服务器的网络配置（包括网络和绑定信息）。但是，加入的服务器的管理接口不会变为与主服务器相同，因此需要在加入后重新对其进行配置，以使用与池主服务器相同的绑定。有关如何执行此操作的信息，请参阅配置管理接口。

向新池添加服务器

可以使用新建池向导将托管服务器添加到新池中。该服务器将成为新池中的主服务器。

  1. 在资源窗格中，选择服务器。
  2. 单击鼠标右键，并在快捷菜单中单击添加到池，然后单击新建池。
  3. 使用新建池对话框创建新池。请参阅创建新池。


从池中删除服务器

重要提示从资源池中删除服务器时，存储在本地磁盘（本地存储）上的所有 VM 数据都将清除。如果本地虚拟磁盘上有重要数据，在删除服务器前，必须先将这些磁盘移动到同一资源池内的共享存储库中。

从资源池中删除服务器

  1. 将本地磁盘上存储的所有数据移动到同一资源池内的共享存储库中；请参阅移动虚拟磁盘。
  2. 关闭服务器上运行的所有 VM；请参阅关闭 VM。
  3. 在资源窗格中选择服务器，然后执行以下操作之一：
    • 在资源窗格中单击鼠标右键，然后单击快捷菜单上的从池中删除服务器。
    • 在池菜单中，单击删除服务器。


从池中销毁服务器

重要提示 - 从资源池中销毁服务器将在不明确与指定的 XenServer 主机联系的情况下将该主机忘记，并将其连同本地 SR、DVD 驱动器以及可移动存储一起永久删除。使用该选项可以销毁无法联系或实际已出现故障的服务器。另请注意，销毁服务器的操作无法撤消。

从资源池中销毁服务器

  1. 在资源窗格中选择服务器，然后执行以下操作之一：
    • 在资源窗格中单击鼠标右键，然后在快捷菜单中选择销毁。
    • 在服务器菜单中，单击销毁。
  2. 单击是，销毁进行确认。


删除池

可以将仅包含一个托管服务器的资源池（单例池）删除，从而有效地使该服务器成为独立服务器。

要删除某个池，请在资源窗格中选择该池，然后执行以下操作之一：

  • 在资源窗格中单击鼠标右键，然后在快捷菜单中单击删除。
  • 在池菜单中，单击删除。


更改池属性

EditPoolGeneralSettingsDialog 6242

在资源窗格中选择任何资源池，然后单击常规选项卡，即可查看其属性和当前状态。单击常规选项卡上的属性可更改池的属性。

常规属性 — 名称、说明、文件夹和标记

在常规属性选项卡上，可以更改池的名称和说明，将池放入文件夹中，以及管理池的标记。

  • 要更改池的名称，请在名称框中输入新名称。
  • 要更改其说明，请在说明框中输入新文本。
  • 要将池放入文件夹中或者将其移动到其他文件夹中，请单击文件夹框中的更改，然后选择文件夹。有关使用文件夹的详细信息，请参阅使用文件夹。
  • 要对池进行标记或取消标记，以及创建标记或删除标记，请参阅使用标记。

自定义字段

可以使用自定义字段为托管资源添加信息，使这些资源更易于搜索和组织。有关如何为托管资源指定自定义字段的信息，请参阅使用自定义字段。

电子邮件选项

此选项卡用于为池中任何服务器或 VM 上生成的系统警报配置电子邮件通知。有关如何设置警报电子邮件通知的详细信息，请参阅 XenCenter 系统警报。

XenServer 高级版及更高版本中提供基于电子邮件的性能和错误警报功能。要了解有关不同 XenServer 版本中可用功能的详细信息，请单击此处。

StorageLink Gateway（仅限 XenServer 5.6 FP1 池）

如果使用 StorageLink Gateway (CSLG) 服务从 XenServer 版本 5.6 Feature Pack 1 池访问不同的存储阵列，则可以在该选项卡上更改 CSLG 服务器的详细信息并测试与该服务器的连接。如果使用同一台 CSLG 服务器为多个不同的池或独立服务器提供存储，可以选择在所有池和独立服务器中使用这些 StorageLink 服务器凭据，以在任何位置都使用相同的 CSLG 凭据。

对于独立服务器，StorageLink Gateway 存储功能在服务器级别配置（服务器 > 属性）。

开机

通过 XenServer 的开机功能，可以为支持电源管理的服务器配置电源管理首选项，使这些服务器可以根据池的总工作负载（通过 Workload Balancing）自动关闭和打开电源。

  • 在该选项卡顶部的服务器列表中，选择要配置电源管理的服务器。
  • 在开机模式下，为选定的服务器指定“开机”设置（禁用、Wake-on-LAN、HP iLO、DRAC 或自定义脚本）。
  • 在配置选项下，根据选择的开机模式选项，指定 IP 地址和凭据或者主机开机脚本的键值对。

有关主机开机功能配置的必备条件及不同可用配置选项的详细信息，请参阅配置主机开机。


更改 root 用户密码

您可以更改池的 root 用户密码（即用于池中所有服务器的密码），方法是：在资源窗格中选择该池或池中的任何服务器，然后单击池菜单或服务器菜单上的更改服务器密码。

要更改独立服务器的 root 用户密码，请执行以下操作：在资源窗格中选择服务器，从服务器菜单中单击密码，然后单击更改。

如果 XenCenter 配置为在会话之间保存服务器登录凭据，则系统将记住新密码；有关详细信息，请参阅存储服务器连接状态。


管理存储库 (SR)

主题
关于 XenServer SR
创建新 SR
删除 SR
重新连接 SR
存储多路径
更改 SR 属性
升级旧 SR


关于 XenServer SR

XenServer 存储库 (SR) 是用来存储虚拟磁盘的存储容器。存储库和虚拟磁盘都是磁盘上独立于 XenServer 而存在的持久对象。SR 可以在资源池中的各服务器之间共享，可以存在于不同类型的内部和外部物理存储设备（包括本地磁盘设备和共享网络存储）上。使用新建存储库向导创建新的存储库时，可以使用许多不同的存储类型。根据所选择的存储类型，可以在 XenCenter 中配置许多高级存储功能，其中包括：

  • 动态多路径。在光纤通道和 iSCSI 存储库中，可以使用轮循模式负载平衡来配置存储多路径。有关详细信息，请参阅存储多路径。
  • 精简置备。在 NetApp、Dell EqualLogic 和 StorageLink SR 上，可以选择所使用的空间管理类型。默认情况下，所分配的空间采用密集置备方式，并且在文件管理器上全面实施所有虚拟分配保证措施，从而保证虚拟磁盘永远不出现空间不足的情况，并且不会因此发生磁盘写入失败。精简置备可以提高磁盘的利用率，因为只有当 VM 需要空间时（即 VM 写入时）才分配物理容量，从而实现可用存储的过度置备并最大程度地利用存储资产。

配置服务器或池时，可以指定用来存储故障转储数据和已挂起 VM 映像的默认 SR，该 SR 将用作新虚拟磁盘的默认 SR。在池级别，默认 SR 必须是共享 SR。在资源池中创建的任何新虚拟磁盘、故障转储文件或已挂起 VM 映像都将存储在池的默认 SR 中，从而提供了一种物理服务器故障恢复机制。对于独立服务器，默认 SR 可以是本地 SR，也可以是共享 SR。在独立服务器中添加共享存储时，共享存储将自动成为该服务器的默认 SR。

请注意，可以通过 XenServer xe 命令行接口 (CLI) 针对 VM、故障转储数据和已挂起 VM 使用其他 SR。有关详细信息，请参阅《XenServer 管理员指南》。


创建新 SR

NewSRWizard 4000, NewSRWizard_TypePane 4010, NewSRWizard_FinishPane 4030

要创建新的存储库，请使用新建存储库向导：要打开该向导，请单击工具栏上的 新建存储 新建存储。

或者，执行以下操作之一：

  • 在所选池或服务器的存储选项卡上，单击新建 SR。
  • 在存储菜单上，单击新建 SR。

在新建存储库向导的第一页选择物理存储类型，然后按照向导中的步骤操作，该向导将引导您完成该存储类型的配置过程。向导中的可用设置集取决于您在第一页选择的存储系统供应商/型号。单击下面的链接可以了解有关创建不同类型 SR 的详细信息。

SR 创建步骤

新建存储库向导将引导您完成新 SR 的创建过程：

  1. 在类型页面上，选择基础存储的类型：
    选项 | 说明 | 阅读更多信息
    NFS VHD | 在 NFS VHD SR 中，VM 映像以精简置备的 VHD 格式文件存储在共享 NFS 目标上。通过 TCP/IP 支持 NFS V3 的现有 NFS 服务器可以直接用作虚拟磁盘的存储库。可以将 NFS SR 共享，使虚拟磁盘位于 NFS VHD 存储库中的任何 VM 都可以在同一个资源池中的各服务器之间迁移。 | NFS VHD 存储
    软件 iSCSI | 软件 iSCSI SR 在通过 iSCSI 与 SAN 连接的 LUN 上使用共享逻辑卷管理器 (LVM)。系统通过使用 open-iSCSI 软件 iSCSI 发起程序或使用受支持的 iSCSI 主机总线适配器 (HBA)，来支持 iSCSI。 | 软件 iSCSI 存储
    硬件 HBA | 硬件 HBA SR 通过 HBA 连接到光纤通道 (FC)、以太网光纤通道 (FCoE) 或共享串联 SCSI (SAS) LUN。在运行新建存储库向导之前，需要执行必要的配置以公开 LUN：该向导将自动探查可用的 LUN 并显示找到的所有 LUN 的列表。 | 硬件 HBA 存储
    StorageLink 技术 | 使用此选项，可以配置 StorageLink SR，以便对 NetApp/IBM N 系列或 Dell EqualLogic PS 系列阵列中的自动光纤/发起程序和阵列配置功能进行本机访问。适用于给定 StorageLink SR 的功能取决于阵列的功能。 | StorageLink 存储
    Windows 文件共享 (CIFS) | CIFS ISO SR 处理以 ISO 格式文件存储且作为 Windows (CIFS) 共享提供的 CD 映像。这种类型的 SR 对于创建共享 ISO 库（例如，VM 安装映像）非常有用。 | ISO 存储
    NFS ISO | NFS ISO SR 处理以 ISO 格式文件存储且作为 NFS 共享提供的 CD 映像。这种类型的 SR 对于创建共享 ISO 库（例如，VM 安装映像）非常有用。 | ISO 存储
  2. 在名称页面上，输入新 SR 的名称。默认情况下，向导将为该 SR 自动生成一个说明，其中包括您在执行该向导的过程中所选配置选项的摘要。要输入自己的说明，请清除自动生成说明复选框并在说明框中键入说明。
  3. 在位置页面上，输入基础存储阵列的位置并设置配置选项。此页面及后续向导页面上提供的选项取决于您在该向导第一页选择的存储类型。
  4. 单击完成，以创建新的 SR 并关闭向导。


NFS VHD 存储

NewSRWizard_LocationPane_NFSVHD 4011

在 NFS VHD 存储库中，VM 映像以精简置备的 VHD 格式文件存储在共享 NFS 目标上。通过 TCP/IP 支持 NFS V3 的现有 NFS 服务器可以直接用作虚拟磁盘的存储库。可以将 NFS SR 共享，使虚拟磁盘位于 NFS VHD 存储库中的任何 VM 都可以在同一个资源池中的各服务器之间迁移。

由于 NFS 存储库 (SR) 上的虚拟磁盘采用稀疏格式创建，因此您必须确保在 SR 上为所有必需的虚拟磁盘保留足够的磁盘空间。

有关 XenServer 的 NFS 存储支持功能的更多详细信息，请参阅《XenServer 管理员指南》。

配置 NFS VHD SR

  1. 打开新建存储库向导：单击工具栏上的 新建存储 新建存储。

    或者：

    • 在所选池或服务器的存储选项卡上，单击新建 SR。
    • 在存储菜单上，单击新建 SR。
    • 在资源窗格中，选择服务器或池，单击鼠标右键，然后单击快捷菜单上的新建 SR。
  2. 选择 NFS VHD 作为物理存储类型，然后单击下一步。
  3. 在名称页面上，输入新 SR 的名称。默认情况下，向导将为该 SR 自动生成一个说明，其中包括您在执行该向导的过程中所选配置选项的摘要。要输入自己的说明，请清除自动生成说明复选框并在说明框中键入说明。

    单击下一步继续操作。

  4. 在位置页面上，指定 NFS 存储目标的详细信息：

    共享名称

    服务器的 IP 地址或 DNS 名称和路径。例如，server:/ShareName，其中 server 是服务器计算机的 DNS 名称或 IP 地址，ShareName 是文件夹或文件名及路径。

    必须将配置为 NFS 服务器导出池中所有服务器的指定路径。

    高级选项

    可以在此处输入任何其他配置选项。

  5. 单击扫描，使向导在指定位置扫描现有的 NFS SR。
  6. 如果找到现有 SR 并且这些 SR 尚未连接，可以选择其中一个并将其作为新存储库进行连接：单击重新连接现有 SR，在列表中选择该 SR，然后单击完成。
  7. 如果未找到现有 SR，只需单击完成，以完成新 SR 的配置并关闭该向导。


软件 iSCSI SR

显示所有文字

软件 iSCSI 存储

NewSRWizard_LocationPane_ISCSI 4012; IscsiChoicesDialog 9591

软件 iSCSI SR 在通过 iSCSI 与 SAN 连接的 LUN 上使用共享逻辑卷管理器 (LVM)。系统通过使用 open-iSCSI 软件 iSCSI 发起程序或使用受支持的 iSCSI 主机总线适配器 (HBA)，来支持 iSCSI。

请注意，系统为 iSCSI 存储库提供动态多路径支持。默认情况下，多路径功能采用轮循模式的负载平衡，因此在正常操作期间，两个路由通道上都具有活动通信。在 XenCenter 中，可以通过服务器属性对话框上的多路径选项卡启用和禁用存储多路径功能；请参阅存储多路径。

有关 XenServer 的 iSCSI 存储支持功能的更多详细信息，请参阅《XenServer 管理员指南》。

创建软件 iSCSI SR

  1. 打开新建存储库向导：单击工具栏上的 新建存储 新建存储。

    或者：

    • 在所选池或服务器的存储选项卡上，单击新建 SR。
    • 在存储菜单上，单击新建 SR。
    • 在资源窗格中，选择服务器或池，单击鼠标右键，然后单击快捷菜单上的新建 SR。
  2. 选择软件 iSCSI 作为物理存储类型，然后单击下一步。
  3. 在名称页面上，输入新 SR 的名称。默认情况下，向导将为该 SR 自动生成一个说明，其中包括您在执行该向导的过程中所选配置选项的摘要。要输入自己的说明，请清除自动生成说明复选框并在说明框中键入说明。

    单击下一步继续操作。

  4. 在位置页面上，指定 iSCSI 存储目标的详细信息：

    目标主机

    iSCSI 目标的 IP 地址或 DNS 名称。

    使用 CHAP

    如果 iSCSI 目标配置为使用 CHAP 身份验证方式，请选中使用 CHAP 复选框并填写以下详细信息：

    • CHAP 用户：连接目标时应使用的 CHAP 身份验证用户名凭据。
    • CHAP 密码：连接目标时应使用的 CHAP 身份验证密码凭据。

    目标 IQN

    要指定 iSCSI 目标 IQN，请单击检测 IQN 按钮，然后从目标 IQN 列表中选择 IQN。

    重要提示 - iSCSI 目标和池中的所有服务器不得设置相同的 IQN。每个 iSCSI 目标和发起程序必须具有唯一的 IQN。如果使用不唯一的 IQN 标识符，则数据会遭到破坏，并且/或者对目标的访问可能被拒绝。

    目标 LUN

    要指定将创建存储库的 LUN，请单击检测 LUN 按钮，然后从目标 LUN 列表中选择 LUN。

    每个 iSCSI 存储库必须整个位于单个逻辑单元号上，不能跨多个 LUN。如果该 LUN 已经包含一个 SR，可以使用现有 SR，也可以用新的 SR 替换现有 SR（这样做会销毁磁盘上的所有数据）。

  5. 单击完成，以完成新 SR 的配置并关闭该向导。


硬件 HBA 存储

NewSRWizard_LocationPane_HBA 4013

硬件 HBA SR 通过 HBA 连接到光纤通道 (FC)、以太网光纤通道 (FCoE) 或共享串联 SCSI (SAS) LUN。在运行新建存储库向导之前，需要执行必要的配置以公开 LUN：该向导将自动探查可用的 LUN 并显示找到的所有 LUN 的列表。

系统为光纤通道和 iSCSI 存储库提供动态多路径支持。要启用存储多路径，请在服务器的属性对话框上打开多路径选项卡；请参阅存储多路径。

有关管理 HBA 的更全面的信息，请参阅《XenServer 管理员指南》。

创建硬件 HBA SR

  1. 打开新建存储库向导：单击工具栏上的 新建存储 新建存储。

    或者：

    • 在所选池或服务器的存储选项卡上，单击新建 SR。
    • 在存储菜单上，单击新建 SR。
    • 在资源窗格中，选择服务器或池，单击鼠标右键，然后单击快捷菜单上的新建 SR。
  2. 选择硬件 HBA 作为物理存储类型，然后单击下一步。
  3. 在名称页面上，输入新 SR 的名称。默认情况下，向导将为该 SR 自动生成一个说明，其中包括您在执行该向导的过程中所选配置选项的摘要。要输入自己的说明，请清除自动生成说明复选框并在说明框中键入说明。

    单击下一步继续操作。

  4. 该向导将扫描可用的 LUN，然后显示一个页面，其中列出找到的所有 LUN。从列表中选择一个 LUN。
  5. 单击完成，以完成新 SR 的配置并关闭该向导。


StorageLink 存储

NewSRWizard_SL_System 4014; NewSRWizard_SL_SLServer_options 4019

StorageLink SR 可以实现对高性能存储的直接访问，使 XenServer 环境中的 VM 充分利用各种阵列端企业存储服务的优势（例如复制、重复数据删除、精简置备、快照和克隆、数据保护和性能优化）。

StorageLink SR 使用存储适配器通过光纤通道或 iSCSI 访问采用各种常见存储技术（包括 NAS 和 SAN）的不同存储阵列。适用于给定 StorageLink SR 的功能取决于基础阵列的功能。在同一存储阵列硬件上，StorageLink SR 可以与其他 SR 类型共存，并且可以在同一个资源池内定义多个 StorageLink SR。

根据您的环境和目标，StorageLink 可以提供以下三项优势：

  • StorageLink SR 使用存储管理软件访问存储。
  • StorageLink 可以简化存储配置过程。例如，从 XenCenter 中创建 StorageLink SR 时，StorageLink 将自动为您创建 LUN、卷和发起程序组。这意味着您不必使用存储管理软件创建这些对象。但是，您需要在运行 XenCenter SR 向导之前创建聚合。
  • 创建的每个 VDI 都有自己的 LUN。所有 StorageLink SR 都采用“每个 VDI 对应于一个 LUN”的模式，即为每个虚拟磁盘 (VDI) 置备一个新 LUN。

默认情况下，基于块设备的 XenServer 存储将插入磁盘上的逻辑卷管理器，可以是逻辑上连接的设备（LVM 类型的 SR），也可以是通过光纤通道（LVMoHBA 类型的 SR）、iSCSI（LVMoISCSI 类型的 SR）或 SAS（LVMoHBA 类型的 SR）连接的 SAN LUN。使用 StorageLink 配置 SR 时，LUN 将作为 VDI 直接映射到虚拟机。因此，阵列存储抽象与 VDI 存储抽象相符，这在从阵列级别管理存储置备的环境中非常有用。

注意：StorageLink SR 不支持 XenDesktop。

StorageLink SR 创建方法

创建 StorageLink SR 的方法包括以下两种：使用 StorageLink 创建卷（默认）或者提前创建卷。使用 StorageLink 创建 SR 的默认方法可能并非在所有环境中都最优。

StorageLink 创建卷（默认）

使用 StorageLink 创建 SR 的标准（默认）方法是，在 SR 创建向导中选择聚合，然后使用 StorageLink 自动为您创建卷和 LUN。采用这种方法时，每个 VDI 都会获得唯一卷中的一个 LUN。但是，如果要在环境中创建多个 VDI，这种方法可能并不理想，因为您会创建多个卷。某些存储供应商对每个存储阵列上卷的数量建议了上限。同样，使用 StorageLink 创建 SR 时，卷名称由系统自动生成，因此这些名称并不易读或有意义，这样会使管理复杂化。另外，采用这种方法时，您不能使用重复数据删除减少卷中通用数据（例如操作系统或应用程序）占用的空间。

预创建卷

使用 StorageLink 创建 SR 的最佳做法是，通过在 XenCenter SR 向导中选择“全部显示”按钮指定之前创建的卷。如果采用这种方法，每个虚拟磁盘都会获得一个 LUN。但是，不会出现多个名称无意义的卷。

使用 StorageLink SR 向导创建 SR 时指定之前创建的卷可以简化卷的管理。在这种情况下，每个 VDI 都会获得选定卷中的一个 LUN。但是，不会出现数量过多而且可能难以管理的卷（即每个 VDI 对应于一个卷）。采用这种方法，您可以创建大量的 VDI。您也可以为卷创建更易于用户理解的名称，而不是由系统自动生成名称。 此外，这种方法还可以提供更高效的存储，因为共享通用数据（例如同一操作系统或应用程序）的虚拟磁盘映像可能存储在同一卷中，您可以使用重复数据删除处理这些数据。

为 NetApp 阵列创建 StorageLink SR

StorageLink 创建 SR（以及关联的 LUN 和卷）时，StorageLink 将自动为 Linux 操作系统创建发起程序组。不建议为其他操作系统手动配置发起程序组。

注意：要使用 StorageLink 创建光纤通道 SR，在 NetApp 存储控制器初始检测阶段或运行 ONTAP 8.1 时，您必须具有存储的 iSCSI 许可证。如果这两种方法都不适用，请按照创建新 SR 中的说明，采用标准 SR 创建过程（不使用 StorageLink）创建 SR。

要使用 StorageLink 连接到 NetApp 存储阵列，在使用 XenCenter 的“新建 SR”向导之前，您必须在存储阵列上启用 httpd。

池必须获得 XenServer 企业版或 XenServer 铂金版的许可。

注意：如以下所示在 XenCenter 中配置 Storagelink（Dell EqualLogic 和 NetApp）SR 的操作过程适用于运行 XenServer 6.0 或更高版本的服务器。对于运行 XenServer 5.6 版本 FP1 的服务器，请参阅 StorageLink 存储 (XenServer 5.6 FP1)。

创建 StorageLink SR

  1. 打开新建存储库向导：单击工具栏上的 新建存储 新建存储。

    或者：

    • 在所选池或服务器的存储选项卡上，单击新建 SR。
    • 在存储菜单上，单击新建 SR。
    • 在资源窗格中，选择服务器或池，单击鼠标右键，然后单击快捷菜单上的新建 SR。
  2. 选择 StorageLink 技术作为物理存储类型，然后单击下一步。
  3. 在名称页面上，输入新 SR 的名称。默认情况下，向导将为该 SR 自动生成一个说明，其中包括您在执行该向导的过程中所选配置选项的摘要。要输入自己的说明，请清除自动生成说明复选框并在说明框中键入说明。

    单击下一步继续操作。

  4. 在存储适配器页面上，选择一种可用的存储系统适配器，然后单击下一步继续操作。
  5. 在存储系统页面上，选择将为该 SR 托管存储的存储系统：
    1. 在阵列目标框中，输入阵列管理控制台的主机名或 IP 地址。
    2. 在凭据下，输入要用来连接阵列管理控制台的用户名和密码。
    3. 单击检测，以在目标阵列中扫描存储系统。检测完毕后，从存储系统列表中选择一个存储系统，然后单击下一步继续操作。
  6. 在设置页面上，定义 SR 设置；每个新 SR 的可用设置集取决于存储系统供应商/型号以及所选存储池的配置。

    存储池

    确定指定存储系统内用于分配存储的存储池。对于某些类型的存储系统，可以使用全部显示复选框在此处列出所有存储池。

    RAID 类型

    选择存储阵列支持的、用于 SR 的 RAID 等级

    置备类型

    设置置备类型（默认值密集，或精简）

    置备选项

    设置置备选项（例如，重复数据删除）

    协议

    设置用来将托管服务器连接到存储的存储协议（iSCSI、光纤通道或自动供系统选择）。

    使用 CHAP 身份验证

    如果服务器配置为使用 CHAP 身份验证方式，请选中该复选框并填写要使用的用户名和密码。

  7. 单击完成，以完成新 StorageLink SR 的配置并关闭该向导。

使用 StorageLink 为光纤通道创建 SR 和 LUN

  1. 在 XenCenter 的资源窗格中，在池上单击鼠标右键，然后选择新建 SR。
  2. 选择 StorageLink 技术，然后单击下一步。
  3. 在名称页面上为 SR 输入有意义的名称，然后单击下一步。
  4. 在存储适配器页面上选择 NetApp/IBM N 系列存储适配器，然后单击下一步。
  5. 在存储系统页面上，执行以下操作：
    • 在阵列目标框中，输入存储控制器的 IP 地址。StorageLink 最初通过 IP 与存储进行通信。
    • 在凭据部分，输入存储的用户名和密码，然后单击检测。
  6. 在存储系统框中显示 NetApp 控制器之后，单击下一步。
  7. 在设置页面上，指定配置 LUN 的位置和方式：
    • 从存储池框中，选择要从中创建 LUN 的聚合。

      注意：NetApp 不建议在 aggr0 聚合中创建 LUN，因为该聚合要为系统文件预留。

    • 在 RAID 类型框中，选择希望存储格式化 LUN 所采用的 RAID 级别。RAID6 相当于 NetApp 的 RAID-DP RAID 类型。
    • 在置备类型框中，选择“复杂置备”或“精简置备”。如果希望存储根据使用情况分配空间，请选中“精简置备”复选框。
    • 在置备选项框中，选择无或重复数据删除。
    • 在协议框中，选择光纤通道。
  8. 单击完成创建 SR 和 LUN。StorageLink 创建 SR 和 LUN 之后，SR 将显示在资源窗格中。


StorageLink 存储 (XenServer 5.6 FP1)

在运行 XenServer 5.6 Feature Pack 1 的池和独立服务器上，可以创建 StorageLink SR，这些 StorageLink SR 使用现有 Network ApplianceTM (NetApp) 或 Dell EqualLogicTM 存储基础结构，或者使用 Citrix StorageLink Gateway (CSLG) 访问各种不同的存储系统。

这些信息对于运行 XenServer 5.6 Feature Pack 1 版本的池和独立服务器有效，而不适用于更高版本的 XenServer，更高版本的软件采用不同的 StorageLink SR 配置过程；有关如何在更高版本的 XenServer 中配置 Dell EqualLogic 和 NetApp 存储的详细信息，请参阅 StorageLink 存储。

连接 Citrix StorageLink Gateway

StorageLink 服务的安装和配置必须在 XenCenter 外部执行；有关详细信息，请参阅 StorageLink 文档。

请注意，这些配置说明仅对运行 XenServer 5.6 Feature Pack 1 版本的池和独立服务器有效。

连接 StorageLink Gateway (CSLG) 时，连接的详细信息存储在 XenCenter 中，可以通过池的属性窗口（对于独立服务器，则通过服务器的属性窗口）查看和更改这些信息。

连接 CSLG：

  1. 在资源窗格中选择池或独立服务器，然后在常规选项卡上单击属性。

    或者，执行以下操作之一：

    • 在资源窗格中单击鼠标右键，然后单击属性。
    • 对于池，请单击池菜单上的属性。
    • 对于独立服务器，请单击服务器菜单上的属性。
  2. 单击 Citrix StorageLink Gateway 选项卡，输入运行 StorageLink 服务的计算机的主机名或 IP 地址、用户名（默认用户名为 admin，不能进行更改）和密码（默认密码为 storagelink）。
  3. 要测试与服务器的连接，请单击测试。如果与服务器建立了连接，该对话框中测试按钮的右侧将出现“连接成功”消息。
  4. 如果使用同一台 CSLG 服务器为多个不同的池或独立服务器提供存储，则可以选择在所有池和独立服务器中使用这些 StorageLink 服务器凭据，以在所有托管池和托管服务器之间使用相同的 CSLG 凭据。
  5. 单击确定，以保存连接信息并关闭属性窗口。

还可以从新建 SR 向导配置与 CSLG 服务器的新连接；请参阅在 XenServer 5.6 服务器上创建 CSLG SR。

创建 CSLG SR

请注意，这些配置说明仅对运行 XenServer 5.6 Feature Pack 1 版本的池和独立服务器有效。

CSLG SR 支持通过一个 Citrix StorageLink Gateway (CSLG) 访问各种不同的存储系统，从而实现对一系列 iSCSI 和光纤通道阵列及自动光纤/发起程序和阵列配置功能进行本机访问。适用于给定 SR 的功能取决于阵列的功能。在同一存储阵列硬件上，CSLG SR 可以与其他 SR 类型共存，并且可以在同一个资源池内定义多个 CSLG SR。

过程

  1. 打开新建存储库向导：单击工具栏上的 新建存储 新建存储。

    或者：

    • 在所选池或服务器的存储选项卡上，单击新建 SR。
    • 在存储菜单上，单击新建存储库。
    • 在资源窗格中，选择服务器或池，单击鼠标右键，然后单击快捷菜单上的新建存储库。
  2. 选择 StorageLink 技术作为物理存储类型，然后单击下一步。
  3. 在名称页面上，输入新 SR 的名称。默认情况下，向导将为该 SR 自动生成一个说明，其中包括您在执行该向导的过程中所选配置选项的摘要。要输入自己的说明，请清除自动生成说明复选框并在说明框中键入说明。

    单击下一步继续操作。

  4. 在存储系统页面上，选择存储系统：

    如果已经为池配置了 CSLG 服务器连接：

    1. 要使用 CSLG 服务器上的现有存储系统，请从存储系统列表中选择该存储系统。
    2. 要在该列表中添加 CSLG 服务器上的新存储系统，请单击添加，然后在出现的对话框中输入存储系统的详细信息：选择存储适配器，提供主机名或 IP 地址名、CIMOM 命名空间（对于符合 SIMS-S 规范的存储系统）、端口号、用户名和密码；在确认密码字段中重复输入密码，然后单击确定。

    如果尚未为池配置 StorageLink 服务器连接：

    1. 单击配置 Citrix StorageLink Gateway 服务器连接。
    2. 在属性对话框中输入连接的详细信息：提供运行 StorageLink 服务的计算机的主机名或 IP 地址、用户名（默认用户名为 admin，不能进行更改）和密码（默认密码为 storagelink）。

      完成后，可以如上所述从存储系统列表中选择 CSLG 服务器上的存储系统。

    单击下一步，以进入新建 SR 向导的下一页。

  5. 在该向导的下一页中，定义 CSLG SR 设置；可用设置集取决于存储系统供应商/型号以及所选存储池的配置：

    位置

    确定将用来放置新 SR 的位置。

    存储池

    确定要用来创建新 SR 的 StorageLink 存储池。对某些类型的存储（例如，NetApp），可以使用全部显示复选框在此处列出所有存储池。

    RAID 类型

    选择存储阵列支持的、用于 SR 的 RAID 等级

    置备类型

    设置置备类型（默认值密集，或精简）

    置备选项

    设置置备选项（例如，重复数据删除）

    协议

    设置用来将托管服务器连接到存储的存储协议（iSCSI、光纤通道或自动供系统选择）。

    使用 CHAP 身份验证

    如果服务器配置为使用 CHAP 身份验证方式，请选中该复选框并填写要使用的用户名和密码。

  6. 单击完成，以完成新 CSLG SR 的配置并关闭该向导。

配置 Dell EqualLogic SR（直接连接）

NewSRWizard_SL_EQL_filer 4015; NewSRWizard_SL_EQL_options 4016

请注意，这些配置说明仅对运行 XenServer 5.6 Feature Pack 1 版本的池和独立服务器有效。

XenServer Dell EqualLogic SR 连接 Dell EqualLogicTM 文件管理器，从而提供一种可扩展形式的高性能网络连接存储。虚拟磁盘存储在文件管理器上，每个虚拟磁盘使用一个 LUN，而且 SR 将可以直接控制存储阵列，从而充分利用文件管理器的精简置备、快照和快速克隆功能。

过程

  1. 打开新建存储库向导：单击工具栏上的 新建存储 新建存储。

    或者：

    • 在所选池或服务器的存储选项卡上，单击新建 SR。
    • 在存储菜单上，单击新建存储库。
    • 在资源窗格中，选择服务器或池，单击鼠标右键，然后单击快捷菜单上的新建存储库。
  2. 选择 StorageLink 技术作为物理存储类型，然后单击下一步。
  3. 在名称页面上，输入新 SR 的名称。默认情况下，向导将为该 SR 自动生成一个说明，其中包括您在执行该向导的过程中所选配置选项的摘要。要输入自己的说明，请清除自动生成说明复选框并在说明框中键入说明。

    单击下一步继续操作。

  4. 在存储系统页面上，选择 Dell EqualLogic，然后单击下一步。
  5. 输入文件管理器的详细信息，然后单击下一步：

    名称

    新存储库的名称；此名称将显示在资源窗格中。

    Dell EqualLogic 文件管理器地址

    文件管理器的 IP 地址或 DNS 名称

    用户名

    用于操纵阵列上的 LUN 的登录用户名

    密码

    用于操纵阵列上的 LUN 的登录密码

    使用 CHAP

    如果 Dell EqualLogic 文件管理器配置为使用 CHAP 身份验证方式，请选中使用 CHAP 复选框并填写以下详细信息：

    • CHAP 用户：连接目标时应使用的 CHAP 身份验证用户名凭据。
    • CHAP 密码：连接目标时应使用的 CHAP 身份验证密码凭据。

    单击下一步后，系统将在文件管理器中扫描现有 SR。

  6. 要使用在文件管理器上找到的一个现有 SR，请单击重新连接文件管理器上的一个现有 SR，然后从列表中选择一个 SR。
  7. 要在文件管理器上创建新的 SR，请单击在以下存储池上创建新 SR，然后从列表中选择存储池。此时将显示有关每个可用存储池的信息（包括总空间量、可用空间量、卷数以及池成员数）。
  8. 要使用 EqualLogic 精简置备功能，请选中使用精简置备复选框。默认设置是使用密集置备。
  9. 单击完成，以完成新 SR 的配置并关闭该向导。

配置 NetApp SR（直接连接）

请注意，这些配置说明仅对运行 XenServer 5.6 Feature Pack 1 版本的池和独立服务器有效。

NetApp 存储系统必须运行 7.0 或更高版本的 Data ONTAP 7G，它支持在文件管理器上使用快速快照和快速克隆功能。

配置 NetApp SR

  1. 打开新建存储库向导：单击工具栏上的 新建存储 新建存储。

    2. 或者：

    • 在所选池或服务器的存储选项卡上，单击新建 SR。
    • 在存储菜单上，单击新建存储库。
    • 在资源窗格中，选择服务器或池，单击鼠标右键，然后单击快捷菜单上的新建存储库。
  2. 选择 StorageLink 技术作为物理存储类型，然后单击下一步。
  3. 在名称页面上，输入新 SR 的名称。默认情况下，向导将为该 SR 自动生成一个说明，其中包括您在执行该向导的过程中所选配置选项的摘要。要输入自己的说明，请清除自动生成说明复选框并在说明框中键入说明。

    单击下一步继续操作。

  4. 在存储系统页面上，选择 NetApp，然后单击下一步。
  5. 在 NetApp 文件管理器页面上，输入 NetApp 文件管理器的详细信息：

    NetApp 文件管理器地址

    SR 所在的 NetApp 服务器的 IP 地址或主机名

    用户名

    用于操纵文件管理器上的 LUN 的登录用户名

    密码

    用于操纵文件管理器上的 LUN 的登录密码

    使用 CHAP

    如果 NetApp 文件管理器配置为使用 CHAP 身份验证方式，请选中使用 CHAP 复选框并填写以下详细信息：

    • CHAP 用户：在 CHAP 身份验证期间使用的用户名
    • CHAP 密码：在 CHAP 身份验证期间使用的密码
  6. 单击下一步：XenCenter 将轮询 NetApp 文件管理器以查找现有的 SR 和聚合，片刻后将出现 NetApp 设置页面。
  7. 指定是要重新连接现有 SR，还是在现有聚合上创建新的 SR，然后提供以下 NetApp 配置信息：

    FlexVol 数（可选）

    要分配给新 SR 的 FlexVol 数。可以使用 1 到 32 个 FlexVol；默认值为 8。使用的 FlexVol 越多，生成 VM 快照的效率越高，因为同一个 FlexVol 支持的 VM 更少。而且，每个 FlexVol 还有最大快照数的限制，通常为 256。但其缺点在于 ONTAP 重复数据删除算法当前仅适用于 FlexVol 内部，因此，使用更多的 FlexVol 会影响 VM 之间的重复数据删除功能，使该功能的优势大大降低。

    使用 NetApp 精简置备（可选）

    如果要使用 NetApp 精简置备，请选中此复选框。默认设置是使用密集置备。如果文件管理器支持 ONTAP 重复数据删除，则还可以选中启用 ONTAP 重复数据删除复选框。

  8. 单击完成，以完成新 SR 的配置并关闭该向导。

详细信息

有关 NetApp 存储注意事项的概述以及 XenServer 的 NetApp 存储支持功能的更多详细信息，请参阅《XenServer 管理员指南》。


ISO 存储

NewSRWizard_LocationPane_NFSISO 4021; NewSRWizard_LocationPane_CIFSISO 4020

这种类型的 SR 对于创建共享 ISO 库（例如，VM 安装映像）非常有用。系统提供了两种 ISO SR 类型，来处理以 ISO 格式文件存储的 CD 映像：

  • NFS ISO SR 类型处理以 ISO 格式文件存储且作为 NFS 共享提供的 CD 映像。
  • CIFS ISO SR 类型处理以 ISO 格式文件存储且作为 Windows (CIFS) 共享提供的 CD 映像。

配置新 ISO SR

  1. 打开新建存储库向导：单击工具栏上的 新建存储 新建存储。

    或者：

    • 在所选池或服务器的存储选项卡上，单击新建 SR。
    • 在存储菜单上，单击新建 SR。
    • 在资源窗格中，选择服务器或池，单击鼠标右键，然后单击快捷菜单上的新建 SR。
    • 在新建 VM 向导的安装介质页面上，单击新建 ISO 库。
  2. 在 ISO 库下，选择 NFS ISO 或 CIFS ISO 作为存储类型，然后单击下一步。
  3. 在名称页面上，输入新 SR 的名称。默认情况下，向导将为该 SR 自动生成一个说明，其中包括您在执行该向导的过程中所选配置选项的摘要。要输入自己的说明，请清除自动生成说明复选框并在说明框中键入说明。

    单击下一步继续操作。

  4. 在位置页面上，指定 ISO 存储目标的详细信息：

    共享名称

    例如，server:/ShareName (NFS) 或 \\server\ShareName (CIFS)，其中 server 是服务器计算机的 DNS 名称或 IP 地址，ShareName 是文件夹或文件名。

    使用其他用户名

    （仅限 CIFS 共享）如果要使用其他用户名连接 CIFS 服务器，请选中此复选框，然后输入您的登录用户名和密码。

  5. 单击完成，以完成新 SR 的配置并关闭该向导。


删除 SR

通过 XenCenter，可以临时或永久删除存储库：

  • 分离。分离存储库时，存储设备与池或服务器之间的关联将会断开，存储库的虚拟磁盘将变得无法访问。虚拟磁盘的内容和虚拟机用来访问虚拟磁盘的元数据信息将会保留。需要临时将存储库置于脱机状态（例如，为了进行维护）时，可以使用分离。已分离的 SR 随后可以重新连接；请参阅重新连接 SR。
  • 忘记。忘记某个 SR 时，该 SR 上虚拟磁盘的内容将会保留，但用来将虚拟机连接到其中的虚拟磁盘的信息将永久删除。该 SR 将从资源窗格中删除。忘记操作无法撤消。
  • 销毁。销毁 SR 会永久删除 SR 的内容，并将 SR 从资源窗格中删除。销毁操作无法撤消。有关如何销毁 SR 的信息，请参阅《XenServer 管理员指南》。

注意：如果存储库包含当前正在运行的虚拟机的虚拟磁盘，则您不能将其删除。

分离存储库

  1. 在资源窗格中选择 SR，然后单击存储选项卡。
  2. 注意当前连接到任何虚拟机的虚拟磁盘。
  3. 将虚拟磁盘与虚拟机分离。有关详细信息，请参阅分离虚拟磁盘。
  4. 在资源窗格中选择 SR，然后执行以下操作之一：
    • 在资源窗格中单击鼠标右键，然后在快捷菜单中单击分离。
    • 在存储菜单中，单击分离。
  5. 单击是进行确认。

忘记存储库

重要提示：

  • SR 忘记操作无法撤消。用来将 VM 连接到 SR 上虚拟磁盘的信息将永久删除。
  • 在尝试忘记 SR 之前，必须分离某些类型的存储库，例如 iSCSI。

要忘记 SR，请执行以下步骤：

  1. 在资源窗格中选择 SR，然后执行以下操作之一：
    • 在资源窗格单击鼠标右键，然后在快捷菜单中单击忘记。
    • 在存储菜单中，单击忘记。
  2. 单击是，忘记进行确认。


重新连接 SR

已分离的存储设备与任何池或服务器都没有关联，但是存储在其中的数据都将保留。将存储库重新连接到托管服务器时，需要按照添加新存储库时所用的方式提供存储配置信息。

重新连接已分离的 SR

  1. 在资源窗格中选择已分离的 SR，然后执行以下操作之一：
    • 单击鼠标右键，然后在资源窗格快捷菜单上单击重新连接存储库。
    • 在存储菜单上，单击重新连接存储库。
  2. 按照添加新存储库时所用的方式输入所需的配置信息。请参阅：
    • NFS VHD 存储
    • 软件 iSCSI 存储
    • 硬件 HBA 存储
    • StorageLink 存储
    • ISO 存储
  3. 单击完成，以完成 SR 的配置并关闭该向导。


存储多路径

系统为光纤通道和 iSCSI 存储库提供动态多路径支持。默认情况下，多路径功能采用轮循模式的负载平衡，因此在正常操作期间，两个路由通道上都具有活动通信。在 XenCenter 中，可以通过服务器属性对话框上的多路径选项卡启用和禁用存储多路径功能。

启用多路径前：

  • 确认存储服务器上提供了多个可用目标。
  • 必须将服务器置于维护模式；这样可以确保在进行更改前迁移正在运行的、其虚拟磁盘在受影响存储库中的所有虚拟机。
  • 必须在池中的每个主机上配置多路径。对于每个主机上相应的 NIC，所有布线和子网配置（对于 iSCSI）必须相符。（例如，必须将所有 NIC 3 配置为使用同一子网。有关详细信息，请参阅为 NIC 分配 IP 地址。）
有关详细深入的多路径信息，请参阅《配置 XenServer 的 iSCSI 多路径支持指南》和《XenServer 管理员指南》。

启用多路径

  1. 在资源窗格中，选择服务器，然后将其置于维护模式。

    在 XenCenter 迁移任何活动虚拟机和拔出现有存储时，会出现短暂的延迟；如果服务器是池主服务器，在分配新的池主服务器时，它将暂时断开连接并从资源窗格中消失。当该服务器以 [image] 图标重新出现在资源窗格中时，请继续执行下一步操作。

  2. 在常规选项卡上，单击属性，然后单击多路径选项卡。
  3. 要启用多路径，请选中在此服务器上启用多路径复选框。要禁用多路径，请清除该复选框。
  4. 单击确定，以应用新设置并关闭该对话框。

    在 XenCenter 保存新的存储配置时，会出现短暂的延迟。

  5. 将该服务器退出维护模式：在资源窗格中选择该服务器，单击鼠标右键，然后单击退出维护模式。


更改 SR 属性

EditSRGeneralSettingsDialog 6243, TabPageStorageServer 1052

要查看存储的详细信息，请在资源窗格中选择服务器或池，然后单击存储选项卡。将列出有关本地存储库和共享存储库的信息，其中包括 SR 的名称、说明、存储类型、大小及可用空间量。

常规属性 — 名称、说明、文件夹和标记

在常规属性选项卡上，可以更改 SR 的名称、说明和文件夹，并管理其标记：

  • 要更改 SR 的名称，请在名称框中输入新名称。
  • 要更改其说明，请在说明框中输入新文本。
  • 要将 SR 放入文件夹中或者将其移动到其他文件夹中，请单击文件夹框中的更改，然后选择文件夹。有关使用文件夹的详细信息，请参阅使用文件夹。
  • 要为 SR 添加和取消标记、创建标记或删除标记，请参阅使用标记。

自定义字段

可以使用自定义字段为托管资源添加信息，使这些资源更易于搜索和组织。有关如何为托管资源指定自定义字段的信息，请参阅使用自定义字段。


升级旧 SR

自 XenServer 5.5 起，LVM 存储库开始采用 Microsoft 的 VHD 技术，支持快速克隆和快照功能。

在 XenCenter 中，通过 XenServer xe 命令行接口 (CLI)，可以将在早期版本的 XenServer 中创建的 LVM 存储库快速而简便地升级到 LVHD 格式。在常规和搜索选项卡中，可以升级的 SR 将以该 SR 需要升级消息进行标记。

请注意，存储升级操作无法撤消。

将 LVM 存储升级到 LVHD 格式

选择 SR 并执行以下操作之一：

  • 在资源窗格中，单击鼠标右键，然后选择快捷菜单上的升级存储库。
  • 从存储菜单中，选择升级。
  • 单击常规和搜索选项卡上的该 SR 需要升级消息。


创建 VM

主题
关于 VM 和模板
创建新 VM（新建 VM 向导）
  • 模板和 BIOS 选项
  • VM 名称和说明
  • OS 安装介质
  • 主服务器
  • CPU 和内存配置
  • 虚拟磁盘配置
  • 配置虚拟网络接口
  • 完成新 VM 的创建
快速（无人参与）创建 VM
创建新模板
复制 VM 和模板


关于 VM

显示所有文字

关于 VM 和模板

虚拟机 (VM) 是在宿主物理计算机上运行的软件容器（有时称为“来宾”），其行为与物理计算机本身一样。VM 由操作系统、CPU、内存 (RAM)、网络资源和软件应用程序组成。

模板是封装到文件中的虚拟机，通过模板可以快速部署新的 VM。每个模板都包含安装元数据，即创建具有特定来宾操作系统以及最佳存储、CPU、内存和虚拟网络配置的新 VM 时需要的设置信息。

在 XenCenter 中可以通过许多不同的方式创建新 VM：

  • 新建 VM 向导将引导您逐步完成从模板或快照创建新 VM 的过程，允许您配置操作系统、CPU、存储、网络连接和其他参数。
  • 您可以绕过新建 VM 向导而基于自定义的 VM 模板创建“即时 VM”，该自定义模板指定所有必需的 VM 配置参数。您只需在 XenCenter 中选择预先配置的模板，然后单击鼠标右键并单击从模板创建即时 VM。这种无人参与的 VM 安装模式对于部署大量相同的 VM 非常有用。
  • 您可以复制（或“克隆”）现有的 VM。
  • 您可以导入先前导出的 VM。

XenServer PV 驱动程序 – XenServer Tools

XenServer 环境中的 VM 可以完全虚拟化 (HVM) 或半虚拟化：

  • 在 HVM（硬件辅助虚拟化或硬件虚拟机）模式下，VM 完全虚拟化，可以在支持虚拟化的硬件上以接近本机处理器的速度运行，而无需对来宾操作系统进行任何修改。
  • 在半虚拟化（非 HVM）模式下，来宾操作系统经过调整和优化，可以在虚拟环境中运行，而不依赖于基础处理器的能力。这种模式具有更佳的性能和更高的灵活性。

半虚拟化 (PV) 驱动程序适用于 Windows 和 Linux VM，能够增强磁盘和网络性能。这些驱动程序在 XenServer Tools 软件包中提供，应安装到所有的新 VM 上；请参阅安装 XenServer Tools。VM 迁移和历史性能数据跟踪等 XenServer 功能只能在安装 XenServer Tools 的 VM 上使用。

使用模板

XenServer 提供了许多不同的模板，这些模板中包含在新 VM 上安装特定来宾操作系统时所需的所有配置设置。您还可以创建自己的自定义模板并为其配置相应的来宾操作系统、内存、CPU、存储和网络设置，可以使用这些模板创建新的 VM。有关该版本支持的模板/操作系统的列表以及 Windows 和 Linux 上不同安装机制的详细信息，请参阅《XenServer 虚拟机用户指南》。

您可以在资源窗格中查看产品随附的 XenServer 模板以及自己创建的任何自定义模板。

XenServer 模板 XenServer 模板
自定义模板 自定义模板

在服务器视图中，可以控制在资源窗格中显示 XenServer 模板还是自定义模板：

  • 要显示标准 XenServer VM 模板：请在视图菜单中，单击服务器视图，然后单击 XenServer 模板将其选中；要隐藏这些模板，请单击复选框以清除选中标记。
  • 要显示自定义 VM 模板：请在视图菜单中，单击服务器视图，然后单击自定义模板将其选中；要隐藏这些模板，请单击复选框以清除选中标记。


创建新 VM

NewVMWizard 2000

新建 VM 向导将引导您逐步完成创建新虚拟机 (VM) 的过程。要启动新建 VM 向导，请单击工具栏上的 [image] 新建 VM。

或者，执行以下操作之一：

  • 按 Ctrl+N。
  • 在 VM 菜单上，单击新建 VM。
  • 在资源窗格中选择服务器，单击鼠标右键，然后单击快捷菜单上的新建 VM。
通过该向导，可以完全按照所需的方式配置新的 VM，调整 CPU、存储和网络连接资源的各种配置参数。根据您在该向导第一页上选择的 VM 模板，您会看到在后续页面上显示的 VM 配置选项略有不同，因为所显示的安装选项是针对每个来宾操作系统定制的。单击 [image] 帮助或在任何向导页面上按 F1 键可获得有关具体操作的详细信息。

在实现了基于角色的访问控制 (RBAC) 的 XenServer 环境中，新建 VM 向导在启动时将执行检查，以确保您拥有的角色具有足够的权限来创建新的 VM。如果您的 RBAC 角色没有足够的权限（例如，“VM 操作员”或“只读”角色），您将无法继续创建 VM。有关详细信息，请参阅 RBAC 概述。

VM 创建步骤的概述

“新建 VM”向导将引导您完成以下步骤，来创建新的 VM：

  1. 选择模板。

    第一步是选择 VM 模板。模板中包含在创建具有特定来宾操作系统以及最佳存储、CPU、内存和虚拟网络配置的新 VM 时需要的设置信息。系统提供了许多不同的模板，您也可以添加自己的自定义模板。有关此步骤的详细信息，请参阅模板和 BIOS 选项。

  2. 为新 VM 指定名称。

    接下来，为新 VM 指定名称和（可选）说明。在 XenCenter 内不会检查 VM 名称是否唯一，因此，为不同的 VM 指定有意义且好记的名称可以方便对 VM 进行管理。有关此步骤的详细信息，请参阅 VM 名称和说明。

  3. 指定操作系统安装介质。

    该过程中的第三步是指定 OS 安装介质的类型和位置。Windows 操作系统可以从 ISO 库、物理 DVD/CD 驱动器（CD 或 DVD-ROM）中的安装介质或者网络引导位置进行安装。Linux 操作系统则可以从网络安装存储库进行安装。有关此步骤的详细信息，请参阅 OS 安装介质。

  4. 选择主服务器。

    此步骤为可选步骤，但是您可以为新 VM 选择主服务器。XenServer 将始终尽可能尝试在指定的主服务器上启动 VM。有关此步骤的详细信息，请参阅主服务器。

  5. 配置 CPU 和内存。

    然后，需要为新的 VM 分配虚拟 CPU (VCPU) 数以及一些内存。创建新 VM 后，这两项设置都可以进行调整。有关此步骤的详细信息，请参阅 CPU 和内存配置。

  6. 配置存储。

    下一步是为新的 VM 配置一些虚拟磁盘。向导会自动配置一个虚拟磁盘（最小值），您选择的模板可能包含更多的虚拟磁盘。有关此步骤的详细信息，请参阅虚拟磁盘配置。

  7. 配置网络连接。

    置备新 VM 过程的最后一步是配置网络连接。可以在每个 VM 上配置多达 4 个虚拟网络接口。有关此步骤的详细信息，请参阅配置虚拟网络接口。

  8. 完成新 VM 的创建。

    在该向导的最后一页上，可以检查已选择的所有配置选项。选中自动启动 VM 复选框，以便在创建新 VM 后立即将其启动。


VM 模板和 BIOS 选项

NewVMWizard_TemplatePane 2010

XenServer 随附了许多不同的 VM 模板，使用这些模板可以通过不同的方式创建新的 VM。每个模板都包含安装元数据，即创建具有特定来宾操作系统以及最佳存储、CPU、内存和虚拟网络配置的新 VM 时需要的设置信息。

有关每个 XenServer 版本支持的来宾操作系统的完整列表，请参阅《XenServer 虚拟机用户指南》。

您还可以创建自己的自定义模板并为其配置相应的来宾操作系统、内存、CPU、存储和网络设置，可以使用这些模板创建新的 VM；请参阅创建新模板。

选择 BIOS 选项

XenServer VM 可以采用通用 BIOS，也可以采用专用 BIOS：

  • 通用 BIOS：VM 具有通用 XenServer BIOS 字符串；
  • 自定义 BIOS：VM 具有池中特定服务器的 BIOS 字符串的副本；
  • 不具有 BIOS 字符串：如果 VM 在首次启动时未设置 BIOS 字符串，系统会在其中插入标准的 XenServer BIOS 设置，该 VM 将采用通用 BIOS。

在使用新建 VM 向导创建新的 VM 时，可以将同一池中某个 OEM 服务器的 BIOS 字符串复制到新的 VM 中。这样，当以后需要时，您将能够在 VM 上安装经销商可选套件（BIOS 锁定）OEM 版本的 Windows。从中复制 BIOS 字符串的 OEM 服务器将被指定为新 VM 的主服务器。

采用自定义 BIOS 的 VM 可以迁移、导入和导出到具有相同 BIOS 字符串的服务器和具有不同 BIOS 字符串的服务器。

重要提示 EULA 中对您安装的任何 BIOS 锁定操作系统的使用有相应规定，您必须遵守这些的规定。


VM 名称和说明

在名称框中输入新 VM 的名称。可以根据自己的喜好选择任何名称，但通常最好使用描述性的名称。尽管建议您避免为多个 VM 使用相同的名称，但并不是必须要这样做，XenCenter 不会针对 VM 名称实施唯一性约束。

为不同的 VM 指定有意义且好记的名称可以方便对 VM 进行管理，例如，描述 VM 操作系统的名称 (Windows 7 64-bit JA)、描述应用程序软件的名称 (Citrix XenServer Web Self Service v1.0 (Build 9057)) 或者描述角色的名称 (db-server, Outlook Server, Windows 7 Test) 有助于您以后进行识别。

对于包含空格的名称，不必使用引号。

还可以在该向导页上输入 VM 的详细说明（可选）。


OS 安装介质

NewVMWizard_InstallationMediaPane 2030

新建 VM 向导的安装介质页面所提供的 OS 安装介质选项取决于在该向导的第一页上选择的 OS/模板。

选项 说明 模板
从 ISO 库或 DVD 驱动器安装

选择从 ISO 库或 DVD 驱动器安装，然后从下拉列表中选择一个 ISO 映像或 DVD 驱动器。

如果列表中未列出要使用的 ISO 映像，可以单击新建 ISO 库并使用新建存储库向导创建新的 ISO SR。创建新的 ISO SR 之后，您即可在此处从可用 ISO 库列表中选择该库。

请注意，如果此处未列出任何 ISO 映像，则需要按照《XenServer 虚拟机用户指南》中的说明，创建外部 NFS 或 SMB/CIFS 共享目录，为服务器提供这些 ISO。

 Windows® 和 Linux
从网络引导 选中此选项可以使用 PXE/网络引导 (Windows) 和其他安装介质模板。

选中此选项后，网络将排在新 VM 引导顺序的首位。

 Windows
从 URL 安装

CentOS、SUSE Linux Enterprise Server 和 Red Hat Linux 操作系统可以从网络安装存储库进行安装。选中从 URL 安装，并按如下形式输入一个 URL，其中必须包括服务器 IP 地址和存储库路径：

nfs://server/path
ftp://server/path
http://server/path

例如：nfs://10.10.32.10/SLES10，其中 10.10.32.10 是 NFS 服务器的 IP 地址，/SLES10 是安装存储库的位置。

如果需要，还可以选择提供其他操作系统引导参数。

 Linux


主服务器

NewVMWizard_HomeServerPane 2035

主服务器是为池中的 VM 提供资源的服务器。为 VM 指定主服务器时，XenServer 将始终尝试在该服务器上启动 VM（如果可以），如果无法启动，则自动选择同一个池中的备用服务器。

  • 要在新建 VM 向导中为 VM 指定主服务器，请单击 将 VM 置于此服务器上（将此服务器用作 VM 的主服务器）并从列表中选择所需的服务器。
  • 如果不想指定主服务器，请单击 不为此 VM 分配主服务器（自动选择具有可用资源的主服务器）；该 VM 将使用最适合的可用服务器上的资源。

如果创建采用自定义 BIOS 的 VM，系统会自动选择您从中复制 BIOS 字符串的 OEM 服务器作为新 VM 的主服务器。

可以从 VM 的属性对话框更改 VM 的主服务器配置；请参阅更改 VM 属性。

Workload Balancing (WLB) 注意事项

在启用了 Workload Balancing (WLB) 的池中，不使用指定的主服务器来启动、重新启动、恢复或迁移 VM，而是由 WLB 分析 XenServer 资源池指标并提供优化建议，从而为 VM 指定最佳服务器。有关 WLB 的详细信息，请参阅 Workload Balancing 概述。


VM CPU 和内存分配

NewVMWizard 2000 NewVMWizard_CPUMemoryPane 2040

在创建新 VM 期间可以为其分配 CPU 和初始内存资源。在安装新 VM 后，还可以根据需要更改这些值。

选项 说明
vCPU 数

输入要分配给新 VM 的虚拟 CPU (VCPU) 数。

在一个 VM 上最多可以配置 8 个 VCPU。此页面将显示服务器上可用物理 CPU 的数量：为了确保新 VM 实现最佳性能，为其分配的 VCPU 数不应超过服务器上物理 CPU 的数量。

如果需要，也可以在以后更改此值。请参阅更改 VM 属性：CPU

内存

输入要分配给 VM 的内存量。

XenServer 模板基于来宾操作系统的类型提供了典型的 VM 配置并设置了合理的内存默认值。在决定最初为新 VM 分配的内存量时，还应考虑以下注意事项：

  • 将在 VM 上运行的应用程序种类。
  • 将使用相同内存资源的其他虚拟机。
  • 服务器上将与虚拟机一起运行的应用程序。

创建新 VM 后，可以在 VM 的内存选项卡上调整内存分配量。在该选项卡上，还可以启用动态内存控制 (DMC)，以允许在同一个池中的各 VM 之间动态地重新分配内存。有关详细信息，请参阅配置 VM 内存文件夹中的帮助主题。


虚拟存储配置

NewVMWizard_VirtualDisksPane 2050

使用新建 VM 向导创建的虚拟机将至少有一个虚拟磁盘，所选 VM 模板还可能包含更多的虚拟磁盘。一个 VM 最多可以有七个虚拟磁盘和一个虚拟 CD-ROM。

可以通过新建 VM 向导的存储页面，添加更多虚拟磁盘、删除虚拟磁盘以及更改虚拟磁盘的大小和位置。

选项 | 说明
使用以下虚拟磁盘

选择该选项可以使用列出的虚拟磁盘。

  • 要添加更多虚拟磁盘，请单击添加并指定名称、大小和位置 (SR)；请参阅添加虚拟磁盘。
  • 要删除虚拟磁盘，请单击删除。
  • 要将虚拟磁盘移至其他 SR，请在列表中将其选中，单击属性，然后从位置列表中选择 SR。
  • 要增大或减小虚拟磁盘，请在列表中将其选中，单击属性，然后在大小框中输入新值。
  • 要更改虚拟磁盘的名称或说明，请在列表中将其选中，单击属性，然后输入新文本。
使用存储级快速磁盘克隆 如果用来创建新 VM 的模板或快照中的所有虚拟磁盘都在同一个 SR 上，则会显示该复选框。选中该复选框后，可以使用硬件级别的克隆功能将虚拟磁盘从模板/快照复制到新的 VM。使用存储级快速磁盘克隆功能可以非常快速地创建新 VM。

只有使用远程 NFS 共享存储或基于 VHD 的本地存储的 VM 才支持该选项。

创建从网络引导的无磁盘 VM | 如果您先前在向导的 OS 安装介质页面上选中了从网络引导选项，则可以选择该选项将新 VM 设置为无磁盘 VM。


虚拟网络连接配置

NewVMWizard_VirtualInterfacesPane 2060

在新建 VM 向导的网络连接页面上，最多可以配置 4 个虚拟网络接口。要配置 4 个以上的虚拟网络接口，请在创建 VM 之后转至 VM 的网络连接选项卡，并在该选项卡上添加虚拟网络接口。

默认情况下，所有的虚拟网络接口都将使用自动创建的随机 MAC 地址。要输入其他 MAC 地址，请单击属性，并在虚拟接口属性对话框中，使用十六进制字符以 aa:bb:cc:dd:ee:ff 形式输入新地址。

  • 要添加新的虚拟网络接口，请单击添加。
  • 要删除虚拟网络接口，请在列表中将其选中，然后单击删除。
  • 要更改虚拟磁盘的物理网络、MAC 地址或服务质量 (QoS) 优先级，请选择该虚拟磁盘，然后单击属性。请参阅更改虚拟网络接口属性。

以后可以在需要时使用网络连接选项卡更改 VM 的虚拟网络连接配置；请参阅配置 VM 网络连接文件夹中的帮助主题。


完成新 VM 的创建

在新建 VM 向导的最后一页上，选中自动启动新 VM 复选框，可确保新 VM 在安装之后立即启动。

创建新 VM 的过程需要花费一些时间，具体用时取决于模板的大小以及目标服务器与 XenCenter 之间的网络连接速度和带宽。进度将显示在 XenCenter 状态栏和日志选项卡中。

重要提示 在创建新 VM 之后，应当在其中安装 XenServer Tools，以确保实现优化的 I/O 性能：请参阅安装 XenServer Tools。


快速（无人参与）创建 VM

要基于自定义 VM 模板创建多个相同 VM 的用户可以绕过新建 VM 向导，而直接使用 XenCenter 中的快速创建功能：

  1. 创建一个自定义的 VM 模板，该模板为新 VM 提供所需的全部配置参数。请参阅创建新模板。
  2. 在资源窗格中选择该自定义模板，在模板菜单上指向根据所选项创建 VM，然后单击快速创建。

    或者，在资源窗格中单击鼠标右键，然后单击快捷菜单上的快速创建。

系统随后将使用该模板中指定的所有配置设置创建和置备新 VM。


创建新模板

ImportTemplateWizard 9600, DuplicateTemplateNameDialog 6390

在 XenCenter 中可以通过多种不同的方式创建新的自定义模板：

  • 通过复制现有模板；请参阅复制 VM 和模板。
  • 通过将现有 VM 转换为新模板。
  • 通过将 VM 快照的副本保存为新模板。
  • 通过导入先前从现有模板或 VM 快照导出的 XVA 文件形式的模板。

将现有 VM 转换为模板

请注意，使用此方法创建新模板时，VM 的磁盘将复制到新模板中，原始 VM 将不再存在。请注意，当前位于 vApp 中的 VM 不能转换为模板。

  1. 按关闭 VM 中的说明关闭该 VM。
  2. 在资源窗格中，选择该 VM，单击鼠标右键，然后单击转换为模板。

    或者，在 VM 菜单上，单击转换为模板。

  3. 单击确定进行确认。

    可以在 XenCenter 窗口底部的状态栏中以及日志选项卡上查看转换进度。

    转换完毕时，该 VM 将从资源窗格中消失，并作为新的自定义模板重新出现。新的自定义模板随后可以像任何其他模板一样用来创建新的 VM。

将快照副本保存为新模板

  1. 在快照选项卡上，选择快照，单击鼠标右键，然后单击快捷菜单上的从快照创建模板。
  2. 输入新模板的名称，然后单击确定。

成功创建新模板后，它将作为自定义模板显示在资源窗格中以及新建 VM 向导的模板页面上。

从 XVA 文件导入模板

可以使用 XenCenter 的导入向导来导入先前导出为 XVA 文件的 VM 模板和快照：在文件菜单上，单击导入，在该向导的第一页上选择包含该模板的 XVA 文件，然后按照从 XVA 导入 VM 的相同步骤操作；请参阅从 XVA 导入 VM。

导入进度显示在 XenCenter 窗口底部的状态栏中以及日志选项卡上。导入过程可能需要一些时间，具体取决于模板的大小以及 XenCenter 与安装模板的服务器之间的网络连接速度和带宽。当新导入的模板可用时，将作为自定义模板显示在资源窗格中。新模板与最初导出的模板具有相同的配置属性。要更改新模板的配置属性，请使用该模板的属性窗口。


复制 VM 和模板

CopyVMDialog 9000

可以通过复制（克隆）现有 VM 或模板来创建新的 VM 和模板。XenServer 使用完整复制和快速克隆这两种机制来复制 VM 和模板：

  • 完整复制生成 VM 磁盘的完整副本。
  • 快速克隆（写入时复制）仅将修改的数据块写入磁盘，使用硬件级别的克隆功能将现有 VM 中的磁盘复制到新 VM。只有采用文件作为后端的 VM 才支持此模式。“写入时复制”旨在节省磁盘空间并实现快速克隆，但会略微降低正常的磁盘性能。

只能在同一个资源池中直接复制 VM。要将 VM 复制到其他池中的服务器，需要导出 VM，然后再将其导入目标服务器。

复制（克隆）VM

重要提示 在复制 Windows VM 前，应使用 Windows 实用程序 sysprep 确保安全 ID (SID) 的唯一性。如果不先执行建议的系统准备步骤就复制 VM，会导致发生 SID 重复及其他问题。有关克隆 VM 和运行 sysprep 的说明，请参阅《XenServer 虚拟机用户指南》。

  1. 如果要复制的 VM 是 Windows VM，请按照《XenServer 虚拟机用户指南》中的说明运行 sysprep 实用程序。
  2. 如果该 VM 正在运行，则必须在复制前关闭 VM。
  3. 在资源窗格中选择该 VM，然后在 VM 菜单上单击复制 VM。
  4. 输入新 VM 的名称和（可选）有意义的说明。
  5. 选择复制模式：快速克隆或完整复制。
  6. 如果选择完整复制作为复制模式，请选择将用来放置所复制的该 VM 虚拟磁盘的存储库 (SR)。如果将 VM 从本地存储移动到共享存储，请确保在此处选择共享 SR。
  7. 单击复制。

复制（克隆）模板

  1. 在资源窗格中选择模板，然后在模板菜单上单击复制模板。
  2. 输入新模板的名称和（可选）有意义的说明。
  3. 选择复制模式：快速克隆或完整复制。
  4. 如果选择完整复制作为复制模式，请选择将用来放置所复制的虚拟磁盘的 SR。
  5. 单击复制。


配置 VM

主题
安装 XenServer Tools
配置 VM 内存
  • 关于 VM 内存配置
  • 动态内存控制 (DMC)
  • 配置 DMC
配置 VM 存储
  • 关于虚拟磁盘
  • 添加虚拟磁盘
  • 连接虚拟磁盘
  • 分离虚拟磁盘
  • 移动虚拟磁盘
  • 删除虚拟磁盘
  • 更改虚拟磁盘属性
配置 VM 网络连接
  • 添加虚拟网络接口
  • 激活/取消激活虚拟网络接口
  • 删除虚拟网络接口
  • 更改虚拟网络接口属性
更改 VM 属性


安装 XenServer Tools

HelpID:InstallTools 6700

XenServer Tools 提供了高性能的 Windows 驱动程序和管理代理，增强了 XenServer VM 的磁盘和网络性能。有关详细信息，请参阅 XenServer PV 驱动程序 – XenServer Tools。

要使用 xe CLI 或 XenCenter，必须在每个虚拟机（Windows 和 Linux）上安装 XenServer Tools，如果不安装这些工具，将会显著降低 VM 的性能。不安装这些工具的情况下，您将无法执行以下所有操作：

  • 彻底关闭、重新启动或挂起 VM。
  • 在 XenCenter 中查看 VM 性能数据。
  • 迁移正在运行的 VM（通过 XenMotion）。
  • 创建静态快照或带有内存（检查点）的快照，或者还原到快照。
  • 调整运行中的 Linux VM 上的 vCPU 数量（对于 Windows VM，需要重新启动才能使更改生效）。

重要提示 不支持在未安装 XenServer Tools 的情况下运行 VM。

确定 VM 上是否安装了 XenServer Tools

可以通过查看 VM 常规选项卡上报告的虚拟化状态，来确定 VM 上是否安装了 XenServer Tools。

  • 已优化(已安装 n.n 版本) – 安装了最新版本的 XenServer Tools。
  • 未安装 XenServer Tools – VM 上当前未安装 XenServer Tools。可以单击此状态消息，以从 XenServer Tools ISO 安装最新版本的该软件。
  • 工具已过期(已安装 x.y 版本) – VM 上安装了早期版本 XenServer 中的旧版 XenServer Tools。对于 Windows VM，可以通过单击此状态消息，切换到 VM 控制台，加载 Tools ISO 并启动 Tools 安装向导；对于 Linux VM，可以通过单击此状态文本，切换到 VM 控制台并加载 Tools ISO，然后您可以装载 ISO 并手动运行安装程序，如下面所述。

在 Windows VM 上安装 XenServer Tools

重要提示 请注意，安装 XenServer Tools 会导致虚拟机 CD/DVD 驱动器中的介质弹出。如果虚拟机的 CD/DVD 驱动器正在使用（例如，正在从 CD 安装 OS），请不要尝试安装 XenServer Tools。

  1. 在资源窗格中选择该 VM，单击鼠标右键，然后单击快捷菜单上的安装 XenServer Tools。

    或者，在 VM 菜单上，单击安装 XenServer Tools

  2. 单击消息框上的安装 XenServer Tools 以转至 VM 的控制台并开始进行安装。
  3. 如果针对 VM 的 CD 驱动器启用了自动播放功能，则片刻之后安装过程将自动启动。如果未启用自动播放功能，请双击 CD 驱动器开始安装 XenServer Tools。
  4. 按照屏幕上的说明操作，并在出现提示时重新启动 VM。

在 Linux VM 上安装 XenServer Tools

  1. 在资源窗格中选择该 VM，单击鼠标右键，然后单击快捷菜单上的安装 XenServer Tools。

    或者，在 VM 菜单上，单击安装 XenServer Tools

  2. 单击消息框上的安装 XenServer Tools 以转至 VM 的控制台。
  3. 以根用户身份将映像装载到 VM 中：
    mount /dev/xvdd/mnt
  4. 以根用户身份执行安装脚本：
    /mnt/Linux/install.sh
  5. 如果内核已经升级，或者 VM 已从前一版本升级，请立即重新启动 VM。

请注意，连接到 Linux VM 的 CD-ROM 驱动器和 ISO 显示为 /dev/xvdd，而不是您希望的 /dev/cdrom。这是因为它们并不是真正的 CD-ROM 设备，而只是普通设备。XenCenter 弹出 CD 时，将从 VM 中热拔出该设备，该设备将会消失。这与 Windows VM 不同，对于 Windows VM，CD 会保留在 VM 中，但处于空白状态。


配置 VM 内存

主题
关于 VM 内存配置
动态内存控制 (DMC)
配置 DMC


关于 VM 内存配置

TabPageBallooning 1033

首次创建 VM 时，系统会为其分配固定数量的内存。要增大 XenServer 环境中物理内存的利用率，可以使用动态内存控制 (DMC)，这是一项能够在 VM 之间动态重新分配内存的内存管理功能。

XenCenter 中的内存选项卡将显示 VM 和服务器中内存的使用率和配置信息。

  • 对于服务器，将显示可用内存总量和当前内存使用率，您可以查看内存在托管 VM 之间的分配情况。
  • 对于 VM，除了当前内存使用率外，还可以查看 VM 的内存配置信息（即，DMC 是否启用、当前动态最小值和最大值），以及编辑 DMC 配置设置。

在内存选项卡上，具有相同内存配置的 VM 将组合在一起，以便您可以方便地查看和配置各 VM 和各组 VM 的内存设置。

Citrix XenServer 高级版或更高版本中提供动态内存控制功能。要了解有关不同 XenServer 版本中可用功能的详细信息，请单击此处。


动态内存控制 (DMC)

TabPageBallooning 1033

XenServer DMC（有时称为“动态内存优化”、“内存过度使用”或“内存膨胀”）的工作方式是：自动调整正在运行的 VM 的内存，使分配给每个 VM 的内存量保持在指定的最小内存值与最大内存值之间，在保证性能的同时，允许每个服务器具有更大的 VM 密度。

如果不启用 DMC，则当服务器满载时，启动更多 VM 会因“内存不足”错误而失败。要减少现有 VM 内存分配，为更多 VM 释放空间，您必须编辑每个 VM 的内存分配，然后重新启动 VM。如果启用 DMC，即使在服务器满载时，XenServer 仍能通过在运行中 VM 的指定内存范围内自动减少其当前内存分配量来尝试回收内存。

动态和静态内存范围

对于每个 VM，可以设置一个动态内存范围，在此范围内，可以添加/删除 VM 的内存而无需重新启动 VM。可以在 VM 运行期间调整动态范围，而无需重新启动 VM。XenServer 始终保证为 VM 分配的内存量保持在动态范围内。例如，如果最小动态内存设置为 512 MB，最大动态内存设置为 1024 MB，则 VM 的动态内存范围 (DMR) 将为 512 - 1024 MB，在此范围内，VM 将正常运行。通过 DMC，XenServer 可确保始终为每个 VM 分配指定 DMR 范围内的内存量。

如果主机服务器的内存充足，所有运行中的 VM 将获得最大动态内存级别；如果主机的内存不足，所有运行中的 VM 将获得最小动态内存级别。如果需要在“满载”的服务器上启动新 VM，则正在运行的 VM 会为新 VM 的启动“腾出”自己的内存。获得所需额外内存的方法是：在现有运行中 VM 的预定义动态范围内按比例腾出内存。

XenServer 支持的许多操作系统不完全支持动态添加或删除内存。因此，XenServer 必须在 VM 引导时声明 VM 需要占用的最大内存量，以允许来宾操作系统相应调整其页表和其他内存管理结构的大小。这就在 XenServer 中引入了静态内存范围的概念。在 VM 运行期间无法调整静态内存范围，在下次重新启动 VM 前，动态内存范围始终限定在静态内存范围内。请注意，最小静态内存（静态内存范围的下限）是管理员的一项保护措施，其值等于操作系统在 XenServer 上运行所需要的最小内存量。

重要提示 由于最小静态内存级别是在每个操作系统所支持的级别上设置的，因此 Citrix 建议您不要对其进行更改：有关更多详细信息，请参考《XenServer 管理员指南》。请将最大静态内存设置为高于最大动态内存，这样设置后，当您以后需要为 VM 分配更多内存时，无需重新启动即可进行分配。

DMC 内存限制

设置 DMC 值时，XenCenter 强制实施以下限制：

  • 最小动态内存值不能低于最小静态内存值。
  • 最小动态内存值不能高于最大动态内存值。
  • 最大动态内存值不能高于最大静态内存值。

可以将 VM 的内存属性更改为满足这些限制条件（需经过验证检查）的任何值。除了这些限制外，对于特定操作系统，Citrix 仅支持某些 VM 内存配置。详细信息在《XenServer 管理员指南》中介绍。

动态内存控制功能在 XenServer 高级版及更高版本中提供。要了解有关不同 XenServer 版本中可用功能的详细信息，请单击此处。


配置 DMC

TabPageBallooning 1033

启用 DMC

  1. 在资源窗格中选择任一 VM 或服务器，然后单击内存选项卡。
  2. 对于要配置 DMC 的一个或一组 VM，单击相应的编辑按钮。
  3. 对于当前内存配置相同的多个 VM，选择要配置的 VM，然后单击下一步。
  4. 单击自动在此范围内分配内存选项，然后通过使用滑块或直接键入具体值，来设置所需的最大和最小动态内存范围值。
  5. 单击确定，以应用更改并关闭对话框。

禁用 DMC

  1. 在资源窗格中选择 VM 或主机服务器，然后单击内存选项卡。
  2. 对于要配置的一个或一组 VM，单击相应的编辑按钮。
  3. 对于当前内存配置相同的多个 VM，选择要配置的 VM，然后单击下一步。
  4. 单击设置固定内存选项并指定要分配的内存量。
  5. 单击确定，以应用更改并关闭对话框。


配置虚拟存储

在资源窗格中选择 VM，然后单击存储选项卡，即可查看和更改其虚拟存储设置。

主题
关于虚拟磁盘
添加虚拟磁盘
连接虚拟磁盘
分离虚拟磁盘
移动虚拟磁盘
删除虚拟磁盘
更改虚拟磁盘属性


关于虚拟磁盘

XenServer VM 上的存储由虚拟磁盘提供。虚拟磁盘是磁盘上独立于所连接的 VM 而存在的持久对象。虚拟磁盘存储在 XenServer 存储库 (SR) 上，可以根据需要与相同或不同的 VM 连接、分离和重新连接。可以在创建 VM 时（使用新建 VM 向导）创建新虚拟磁盘，也可以在创建 VM 后从 VM 的存储选项卡添加新虚拟磁盘。

半虚拟化的 VM（即，安装了 XenServer Tools 的 VM）上的虚拟磁盘可以“热插拔”，即，您不需要先关闭 VM 就可以添加、删除、连接和分离虚拟磁盘。在 HVM 模式下运行的 VM（即，未安装 XenServer Tools 的 VM）必须先关闭才能执行上述任何操作；为了避免出现这种情况，应当在所有 HVM 虚拟机上安装 XenServer Tools。

在 XenCenter 中 VM 的存储选项卡上，可以执行以下操作：

  • 新增虚拟磁盘。
  • 配置虚拟磁盘 — 更改虚拟磁盘的大小、位置、读/写模式和其他配置参数。
  • 将现有的虚拟磁盘连接到 VM。
  • 分离虚拟磁盘，以保留虚拟磁盘及其中的所有数据。
  • 将虚拟磁盘移动到指定的存储库。
  • 删除虚拟磁盘，从而永久销毁虚拟磁盘及其中存储的所有数据。


添加虚拟磁盘

NewDiskDialog 5000

要添加新虚拟磁盘，请使用添加虚拟磁盘对话框。

重要提示 如果 VM 在 HVM 模式（即未安装 XenServer Tools）下运行，则需要先将其关闭，然后才能添加虚拟磁盘；为了避免出现这种情况，应当在所有 HVM 虚拟机上安装 XenServer Tools。

过程

  1. 执行下列任一操作以打开添加虚拟磁盘对话框：
    • 在资源窗格中，选择 VM 或 SR，单击存储选项卡，然后单击添加。
    • 在存储菜单上，单击虚拟磁盘，然后单击新建虚拟磁盘。
    • 在新建 VM 向导的存储页面上，单击添加。
  2. 输入新虚拟磁盘的名称和可选说明。
  3. 输入新虚拟磁盘的大小。

    应确保用来存储虚拟磁盘的存储库 (SR) 有足够的空间存储新虚拟磁盘。

  4. 选择用来存储新虚拟磁盘的 SR。
  5. 单击创建，以添加新虚拟磁盘并关闭该对话框。


连接虚拟磁盘

AttachDiskDialog 3000

可以通过连接现有虚拟磁盘的方式在 VM 中添加存储。

  1. 在资源窗格中选择 VM，单击存储选项卡，然后单击连接。

    或者，在存储菜单上，单击虚拟磁盘，然后单击连接虚拟磁盘。

  2. 从列表中选择虚拟磁盘。
  3. 要将对虚拟磁盘的访问权限设置为只读，请选中以只读方式连接复选框。这样做可以防止在多个 VM 访问磁盘时磁盘数据被覆盖或更改，并且允许虚拟磁盘连接多个 VM。要允许对虚拟磁盘进行写访问，请清除该复选框。
  4. 单击连接。

提示：如果基础 SR 出现问题，有时会导致连接的虚拟磁盘被取消激活（“拔出”）。如果出现这种情况，应在 VM 的存储选项卡中选择该虚拟磁盘并单击激活将其重新激活。


分离虚拟磁盘

将虚拟磁盘与 VM 分离时，虚拟磁盘及其中的所有数据都将保留，但是该虚拟磁盘将不再供 VM 使用；分离的存储设备以后可以重新连接同一 VM、连接其他 VM，也可以移动到其他存储库 (SR) 中。

如果 VM 满足下列所有条件，则无需先关闭（“热拔出”）VM 就可以分离虚拟磁盘：

  • VM 未挂起。
  • VM 必须已安装 XenServer Tools。
  • 虚拟磁盘不是系统磁盘。
  • 必须取消激活虚拟磁盘才能彻底将其分离。请注意，术语“取消激活”与“拔出”意思相同，在《XenServer 管理员指南》和 CLI 中，针对该操作使用的是术语“拔出”。

如果不满足上述任一条件，则必须关闭 VM，然后才能分离虚拟磁盘。

过程

  1. 在资源窗格中选择 VM，然后单击存储选项卡。
  2. 从列表中选择虚拟磁盘，单击取消激活，然后单击分离。
  3. 单击确定确认该操作。


移动虚拟磁盘

MoveVirtualDiskDialog 5001

虚拟磁盘可以从一个存储库 (SR) 移动或迁移到同一池中的其他 SR。其中包括：

  • 当前未连接到任何 VM 的虚拟磁盘。
  • 连接到未在运行的 VM 的虚拟磁盘。
  • 连接到正在运行的 VM 的虚拟磁盘（使用 Citrix XenServer 企业版或更高版本中提供的 Storage XenMotion）。

请注意，您可以将本地存储中的虚拟磁盘移至其他服务器上的共享存储中，但是不能将其移至其他服务器上的本地存储中。

关于 Storage XenMotion

使用 Storage XenMotion，您可以移动虚拟磁盘而无需先关闭 VM，从而能够执行一些管理操作，例如：

  • 将 VM 从便宜的本地存储移至由阵列支持的快速且有弹性的存储。
  • 将 VM 从开发环境移至生产环境。
  • 当 VM 受存储容量限制时，在存储层之间移动 VM。
  • 执行存储阵列升级。

请注意，此时 Storage XenMotion 存在以下限制：

  • 无法迁移位于 Integrated StorageLink Storage Repository (SR) 中的虚拟磁盘。
  • 无法迁移具有多个快照的虚拟磁盘。

Storage XenMotion 功能在 Citrix XenServer 企业版或更高版本中提供。要了解有关不同 XenServer 版本中可用功能的详细信息，请单击此处。

移动虚拟磁盘

  1. 在 XenCenter 的“资源”窗格中，选择虚拟磁盘当前存储到的 SR，然后单击存储选项卡。

    2. 要找到虚拟磁盘，请执行以下操作：

    • 在 XenCenter 的“资源”窗格中，选择要移动的虚拟磁盘连接到的 VM。
    • 单击存储选项卡，然后确定虚拟磁盘当前存储到的 SR。
  2. 从虚拟磁盘列表中，选择要移动的一个或多个虚拟磁盘，然后单击移动。

    或者，在选定的虚拟磁盘上单击鼠标右键，然后从快捷菜单中选择移动虚拟磁盘。

  3. 在移动虚拟磁盘对话框中，选择要将虚拟磁盘移至的目标 SR。

    确保目标 SR 上有足够的空间容纳另一个虚拟磁盘：可用空间显示在可用 SR 的列表中。

  4. 单击移动移动虚拟磁盘。


删除虚拟磁盘

如果 VM 满足下列所有条件，则无需先关闭 VM 就可以删除虚拟磁盘：

  • VM 未挂起。
  • VM 必须已安装 XenServer Tools。
  • 虚拟磁盘不是系统磁盘。
  • 必须首先取消激活虚拟磁盘。请注意，术语“取消激活”与“拔出”意思相同，在《XenServer 管理员指南》和 CLI 中，针对该操作使用的是术语“拔出”。

如果不满足上述任一条件，则必须关闭 VM，然后才能删除虚拟磁盘。

重要提示 删除虚拟磁盘时，将永久删除该磁盘，从而销毁其中存储的任何数据。

过程

  1. 在 VM 的存储选项卡上，从列表中选择虚拟磁盘，单击取消激活，然后单击删除。
  2. 单击确定确认删除。


更改虚拟磁盘属性

HelpIDs:EditVDIGeneralSettingsDialog 6262

要更改虚拟磁盘的属性，请单击 VM 的存储选项卡，然后选择虚拟磁盘并单击属性。

常规属性 — 名称、说明、文件夹和标记

名称 | 虚拟磁盘的名称。
说明 | 虚拟磁盘的说明（可选）。
文件夹 | 虚拟磁盘所在的资源文件夹的名称（如果适用）。
标记 | 已经用于该虚拟磁盘的一系列标记。

自定义字段

在自定义字段选项卡上，可以为虚拟磁盘指定新的自定义字段、更改已指定给虚拟磁盘的任何现有自定义字段的值，以及删除自定义字段。

有关添加、设置、修改和删除自定义字段的信息，请参阅使用自定义字段。

磁盘大小和位置

在该选项卡上设置虚拟磁盘的大小并选择虚拟磁盘所在的存储库。

设备选项

虚拟磁盘属性对话框中的最后一个选项卡，可用来为虚拟磁盘设置一些设备选项。

模式 | 可以更改对虚拟磁盘的读/写权限，例如，通过更改权限防止用于备份目的的虚拟磁盘上的数据被覆盖。
设备位置 | 该虚拟磁盘在驱动器序列中所占的位置。
磁盘访问优先级 | 对于某些虚拟磁盘，还可以调整磁盘 I/O 优先级（服务质量，简称 QoS）。该设置仅适用于基于 LVM 的存储库（即本地存储库、共享 iSCSI 存储库或硬件 HBA 存储库）上的虚拟磁盘。有关调整 QoS 设置以及 QoS 控件如何处理不同存储类型的详细信息，请参阅《XenServer 管理员指南》。


配置 VM 网络连接

主题
关于虚拟网络接口
添加虚拟网络接口
激活/取消激活虚拟网络接口
删除虚拟网络接口
更改虚拟网络接口属性


关于虚拟网络接口

每个虚拟机 (VM) 可以有一个或多个充当虚拟 NIC 的虚拟网络接口。

虚拟网络接口具有以下属性：
网络 | 虚拟网络接口的（物理）网络位置。
MAC 地址 | 虚拟网络接口的 MAC 地址。
QoS 限制 | 可选 I/O 优先级服务质量设置 (QoS)（为了实现最大网络传输率）。当内存资源较少时，按照这种方式使用 I/O 限制会降低内存处理速度，但由于避免了崩溃的发生，因而有助于提高系统的稳定性。

您可以在 VM 的网络连接选项卡上查看其所有虚拟网络接口。在该选项卡上，可以添加新的虚拟网络接口，还可以编辑、激活、取消激活和删除现有的虚拟网络接口。


添加虚拟网络接口

HelpIDs:NewVMNetworkWizard 8500

  1. 通过执行以下操作之一打开添加虚拟接口对话框：
    • 在资源窗格中选择 VM，单击网络连接选项卡，然后单击添加接口。
    • 在新建 VM 向导的网络页面上，单击添加。
  2. 从网络列表中选择一个网络位置。
  3. 指定 MAC 地址，可以使用基于 NIC MAC 地址自动创建的 MAC 地址，也可以手动输入 MAC 地址：
    • 要使用自动生成的 MAC 地址，请单击自动生成 MAC 地址。
    • 要明确输入 MAC 地址，请单击使用此 MAC 地址并按照 XY:XX:XX:XX:XX:XX 形式输入地址，其中 X 是任何十六进制数字，Y 是 2、6、A 或 E。
  4. 要设置可选的 I/O 优先级服务质量 (QoS) 设置以实现最大网络传输率，请选中此复选框并输入以千字节/秒 (kB/s) 为单位的值。

    如果池配置为使用 vSwitch 控制器，则添加虚拟接口对话框中的 QoS 选项将不可用；在这种情况下，应在需要时使用 vSwitch 控制器配置 QoS 设置。

  5. 单击添加。


激活/取消激活虚拟网络接口

满足以下所有条件时，可以在运行的 VM 上激活或取消激活虚拟网络接口：

  • VM 未挂起。
  • VM 必须已安装 XenServer Tools。

要激活（“插入”）或取消激活（“拔出”）虚拟网络接口，请在 VM 的网络连接选项卡上，选择该接口，然后单击标有激活或取消激活的按钮。


删除虚拟网络接口

如果满足以下所有条件，您无需关闭 VM（“热拔出”）即可从 VM 中删除虚拟网络接口：

  • VM 未挂起。
  • VM 必须已安装 XenServer Tools。

如果上面的一项或两项条件未满足，您必须先关闭 VM，然后才能删除虚拟网络接口。

删除虚拟网络接口

  1. 在资源窗格中选择 VM，然后单击网络连接选项卡。
  2. 在网络连接选项卡上的列表中，选择虚拟网络接口，然后单击删除。


更改虚拟网络接口属性

EditVmNetworkSettingsDialog 6270, VIFdialog 6251

要更改虚拟网络接口的属性，请通过执行以下操作之一打开虚拟接口属性对话框：

  • 单击 VM 的网络连接选项卡，选择虚拟网络接口，然后单击属性。
  • 在新建 VM 向导的网络页面上，单击属性。

可以更改虚拟网络接口的网络位置和 MAC 地址，也可以为虚拟网络接口设置 I/O 优先级。

网络 | 虚拟网络接口的网络位置。
MAC 地址 | 虚拟网络接口的 MAC 地址可以自动生成，您也可以按照 XY:XX:XX:XX:XX:XX 形式手动输入 MAC 地址，其中 X 是任何十六进制数字，Y 是 2、6、A 或 E。
启用 QoS 限制 | 通过选择此选项并输入以千字节/秒 (kB/s) 为单位的值，可以设置可选的 I/O 优先级服务质量 (QoS) 设置以实现最大网络传输率。 当内存资源较少时，按照这种方式使用 I/O 限制会降低内存处理速度，但由于避免了崩溃的发生，因而有助于提高系统的稳定性。 如果池配置为使用 vSwitch 控制器，则此处的 QoS 选项将不可用；在这种情况下，应在需要时使用 vSwitch 控制器配置 QoS 设置。


更改 VM 属性

EditVMGeneralSettingsDialog 6241

在资源窗格中选择虚拟机，然后单击常规选项卡，即可查看其属性。可以在 VM 的属性对话框中更改其中的许多属性：单击常规选项卡右上角的属性按钮。

常规属性 — 名称、说明、文件夹和标记

在常规属性选项卡上，可以更改 VM 的名称和说明，将 VM 放入文件夹中，以及管理 VM 的标记。

  • 要更改 VM 的名称，请在名称框中输入新名称。
  • 要更改 VM 的说明，请在说明框中输入新文本。
  • 要将 VM 放入文件夹中或者将其移到其他文件夹中，请单击文件夹框中的更改，然后选择文件夹。有关使用文件夹的详细信息，请参阅使用文件夹。
  • 要对 VM 进行标记或取消标记，以及创建或删除标记，请参阅使用标记。

自定义字段

可以使用自定义字段为托管资源添加信息，使这些资源更易于搜索和组织。有关如何为托管资源指定自定义字段的信息，请参阅使用自定义字段。

CPU

在 CPU 选项卡上，可以调整分配给 VM 的虚拟 CPU 的数量并设置 VCPU 优先级。在一个 VM 上最多可以配置 8 个虚拟 CPU。为了确保 VM 实现最佳性能，VCPU 的数量不应超过主机服务器上物理 CPU 的数量。VCPU 优先级是在 CPU 调度期间为每个 CPU 指定的优先级（相对于主机服务器上运行的所有其他 VM）。

要更改虚拟 CPU 的数量，请在 VCPU 数框中更改数量。

要调整 VCPU 优先级，请移动 VCPU 滑块。

XenServer 模板基于来宾操作系统的类型提供了典型的 VM 配置并设置了合理的内存默认值。在决定为 VM 分配的内存量时，还应考虑以下注意事项：

  • 将在 VM 上运行的应用程序种类。
  • 将使用相同内存资源的其他虚拟机。
  • 服务器上将与虚拟机一起运行的应用程序。

引导选项

该选项卡上提供的引导选项可能因来宾操作系统而异。例如，在某些 VM 上，可以更改启动顺序，或者指定其他引导参数。

  • 要更改引导顺序，请在引导顺序列表中选择一个项目，然后单击上移或下移。
  • 要指定其他引导参数，请在 OS 引导参数框中输入这些参数。例如，在 Debian VM 上，可以输入 single 以在单用户模式下引导 VM。

启动选项

在该选项卡上，可以为选定的 VM 调整启动顺序、启动延迟间隔和高可用性重启优先级。

值 | 说明
启动顺序 | 指定各个 VM 在 vApp 内或在高可用性恢复操作期间的启动顺序，使某些 VM 先于其他 VM 启动。启动顺序值为 0（零）的 VM 将首先启动，启动顺序值为 1 的 VM 接着启动，然后是启动顺序值为 2 的 VM，以此类推。
尝试在以下时间后启动下一个 VM | 这是一段延迟时间间隔，用于指定从启动 VM 到尝试启动启动序列中下一组 VM（即，启动顺序更靠后的 VM）之间的等待时间。该值将应用于 vApp 中的 VM，以及高可用性恢复操作期间的各个 VM。
高可用性重启优先级 在启用了高可用性的池中，该值指定在基础硬件出现故障或者 VM 的主机服务器丢失时，哪些 VM 将自动重新启动。
  • 如果池中有足够的资源，将保证高可用性重启优先级为重新启动的 VM 重新启动。它们将先于优先级为在可能时重新启动的 VM 而重新启动。
  • 在计算故障计划时，不考虑高可用性重启优先级为在可能时重新启动的 VM，但当运行这些 VM 的服务器出现故障时，将尝试进行一次重新启动。此次重新启动尝试将在所有更高优先级的 VM 重新启动后进行，如果启动尝试失败，则将不再进行重试。
  • 高可用性重启优先级为不重新启动的 VM 将不会自动重新启动。

有关这些设置的详细信息，请参阅 VM 启动设置。

Citrix XenServer 高级版或更高版本中提供 XenServer 高可用性功能。要了解有关不同 XenServer 版本中可用功能的详细信息，请单击此处。

警报

在警报选项卡上，可以为 VM 的 CPU、内存、网络 I/O 和磁盘 I/O 使用情况配置性能警报。

有关配置警报的信息，请参阅配置性能警报。

Citrix XenServer 高级版或更高版本中提供高级警报功能。要了解有关不同 XenServer 版本中可用功能的详细信息，请单击此处。

主服务器

ChangeHomeDialog 6150

在 VM 属性对话框的主服务器选项卡上，可以指定为 VM 提供资源的服务器。如果可能，VM 将在该服务器上启动；否则将自动选择同一个池中的备用服务器。要了解有关主服务器的详细信息，请参阅创建新 VM。

请注意，在启用了 Workload Balancing (WLB) 的池中，不能设置主服务器，而是由 XenCenter 分析 XenServer 资源池指标并提供优化建议，从而为 VM 指定最佳服务器。您可以决定系统在提出这些建议时考虑资源性能还是硬件密度，可以调整各个资源指标（CPU、网络、内存和磁盘）的加权，以使放置建议和临界阈值符合环境的需求。有关 WLB 的详细信息，请参阅 Workload Balancing 概述。

GPU（仅限 Windows VM）

在 VM 的 GPU 属性选项卡上，可以为 Windows VM 分配专用的图形处理单元 (GPU)，从而可以从 VM 直接访问图形硬件。GPU 传递功能允许 VM 利用 GPU 的全部处理能力，从而为高端 3D 专业图形应用程序（如 CAD/CAM、GIS 和医学成像应用程序）提供更好的支持。

要启用 GPU 传递，请从 GPU 类型列表（其中列出了当前池中可用的 GPU）中选择一个 GPU。

高级选项（优化）

在高级选项选项卡上，可以调整分配给具有辅助硬件的 VM 的重影内存量。在 Citrix XenApp 等某些专用应用程序工作负载中，需要具有额外的重影内存才能获得最佳性能。此内存被视为开销项，在核算 VM 内存时，这种内存与常规的内存分开计算。

  • 要优化运行 Citrix XenApp 的 VM 的性能，请单击针对 Citrix XenApp 进行优化。
  • 要手动调整 VM 的重影内存分配，请单击手动优化，然后在重影内存系数框中输入一个值。
  • 要还原重影内存的默认设置，请选中针对一般用途进行优化选项。


管理 VM

主题
启动 VM
挂起和恢复 VM
关闭 VM
重新启动 VM
运行远程控制台会话
迁移 VM
删除 VM


启动 VM

对于池中的 VM，可以根据所选主机服务器上的可用资源选择 VM 的启动位置。所选服务器取决于 VM 和池的配置方式：

  • 在启用了 Workload Balancing (WLB) 的池中，该功能会提供一些建议来帮助您选择可能最适合 VM 工作负载的物理服务器。有关详细信息，请参阅为 VM 的初始放置、迁移和恢复选择最优服务器。
  • 在未配置 Workload Balancing 的池中，可以选择在 VM 的主服务器上或者池中的任何其他服务器上（取决于该服务器上的可用存储）启动 VM。要了解有关主服务器的详细信息，请参阅创建新 VM。

当 VM 启动并运行时，在资源窗格中，其状态指示器将变为 [image] 。

在特定服务器上启动 VM

  1. 在资源窗格中选择 VM。
  2. 单击鼠标右键，单击在服务器上启动，然后在快捷菜单上选择所需的服务器。

    或者，在 VM 菜单上，单击在服务器上启动，然后在子菜单上选择所需的服务器。

在最优服务器或主服务器上启动 VM

在资源窗格中选择 VM，然后单击工具栏上的 [image] 启动。

或者，执行以下操作之一：

  • 在资源窗格中单击鼠标右键，然后在快捷菜单中选择启动。
  • 在 VM 菜单上，单击启动。
  • 在启用了 WLB 的池中，该操作将在最优服务器上启动 VM。
  • 在未配置 Workload Balancing 的池中，该操作将在该 VM 所在的主服务器上启动 VM，如果未设置主服务器，则将在第一台可用服务器上启动。


挂起和恢复 VM

挂起 VM 时，其当前状态存储在默认存储库 (SR) 上的一个文件中。通过这种方式，当您关闭 VM 的主机服务器并在以后重新启动后，将可以恢复 VM，使其回到最初的运行状态。

注意：在其他类型的服务器上创建的已挂起 VM 可能无法恢复。例如，在使用 Intel VT CPU 的服务器上创建的 VM 可能无法在使用 AMD-V CPU 的服务器上恢复。

挂起 VM

  1. 如果当前的默认 SR 已分离，请选择新的默认 SR。
  2. 在资源窗格中选择 VM，然后单击工具栏上的 挂起 VM 挂起。

    或者：

    • 单击鼠标右键，在快捷菜单中单击挂起。
    • 在 VM 菜单上，单击挂起。

当 VM 挂起时，在资源窗格中其状态指示器将变为 [image] 。

恢复已挂起的 VM

通常可以为池中的 VM 选择恢复位置。所选服务器取决于 VM 和池的配置方式：

  • 在启用了 Workload Balancing (WLB) 的池中，该功能会提供一些建议来帮助您选择可能最适合 VM 工作负载的物理服务器。有关详细信息，请参阅为 VM 的初始放置、迁移和恢复选择最优服务器。
  • 在未配置 Workload Balancing 的池中，可以选择在 VM 的主服务器上或者池中的任何其他服务器（取决于该服务器上的可用存储）上恢复 VM。要了解有关为 VM 指定主服务器的详细信息，请参阅主服务器。

当已挂起的 VM 成功恢复之后，在资源窗格中其状态指示器将变为 [image] 。

在特定服务器上恢复已挂起的 VM

  1. 在资源窗格中选择 VM。
  2. 单击鼠标右键，单击在服务器上恢复，然后在快捷菜单上选择所需的服务器。

    或者，在 VM 菜单上，单击在服务器上恢复，然后在子菜单上选择所需的服务器。

在最优服务器或主服务器上恢复 VM

在资源窗格中选择 VM，然后单击工具栏上的 恢复 VM 恢复。

或者，执行以下操作之一：

  • 在资源窗格中单击鼠标右键，然后在快捷菜单中选择恢复。
  • 在 VM 菜单上，单击恢复。
  • 在启用了 WLB 的池中，该操作将在最优服务器上启动 VM。
  • 在未配置 Workload Balancing 的池中，该操作将在 VM 所在的主服务器上启动该 VM，如果未设置主服务器或者指定的服务器不可用，则将在第一台可用服务器上启动。


关闭 VM

您可能出于多种原因而需要关闭正在运行的 VM，例如，要释放其资源或者重新配置其虚拟网络硬件或虚拟磁盘存储。可以通过 VM 的控制台或者使用 XenCenter 关闭 VM。XenCenter 提供两种关闭 VM 的方法：

  • 软关闭以正常方式关闭 VM，所有正在运行的进程将逐个停止。
  • 强制关闭执行硬关闭，相当于拔出物理服务器。强制关闭可能不会始终关闭所有正在运行的进程，如果用这种方式关闭 VM，可能会有丢失数据的风险。只有在无法执行软关闭时，才可以使用强制关闭。

在 HVM 模式下运行的 VM（即，未安装 XenServer Tools 的 VM）只能使用强制关闭方式关闭；为避免出现这种情况，应当在所有的 HVM 虚拟机上安装 XenServer Tools。

执行软关闭

在资源窗格中选择 VM，然后单击工具栏上的 [image] 关闭。

或者：

  • 在资源窗格中单击鼠标右键，然后在快捷菜单中单击关闭。
  • 在 VM 菜单上，单击关闭。

要在 VM 的浮动控制台窗口中关闭 VM，请单击 [image] ，然后单击关闭。

停止运行中的进程时，VM 的控制台上将显示关闭消息。当完成关闭时，资源窗格中的 VM 状态指示器将变为 [image] 。

执行强制关闭

在资源窗格中选择 VM，然后单击工具栏上的 [image] 强制关闭。

或者：

  • 单击鼠标右键，然后在资源窗格快捷菜单中单击强制关闭。
  • 在 VM 菜单上，单击强制关闭。

要在 VM 的浮动控制台窗口中关闭 VM，请单击 [image] ，然后单击强制关闭。

当完成关闭时，资源窗格中的 VM 状态指示器将变为 [image] 。


重新启动 VM

在 XenCenter 中，可以通过两种不同的方法重新启动 VM：

  • 软重启以正常方式关闭 VM，然后重新启动。
  • 强制重启是硬重启，在不执行任何关机程序的情况下重新启动 VM。这种方式相当于将物理服务器上的插头拔出、再重新插入，然后重新打开服务器。

如非绝对必要（例如，在出现严重错误的情况下强制重新恢复系统），请不要执行强制重启。

在 HVM 模式下运行的 VM（即，未安装 XenServer Tools 的 VM）只能使用强制重启方式重新启动；为避免出现这种情况，应当在所有 HVM 虚拟机上安装 XenServer Tools。

正常重新启动 VM

在资源窗格中选择 VM，然后单击工具栏上的 重新启动 重新启动。

或者：

  • 在资源窗格中单击鼠标右键，然后在快捷菜单中单击重新启动。
  • 在 VM 菜单上，单击重新启动。

VM 将关闭并重新启动。完成该过程后，资源窗格中的 VM 状态指示器将恢复为 [image] 。

执行强制重启

在资源窗格中选择 VM，然后单击工具栏上的 [image] 强制重启。

或者：

  • 单击鼠标右键，然后在资源窗格快捷菜单中单击强制重启。
  • 在 VM 菜单上，单击强制重启。

VM 将立即关闭并重新启动。完成该过程后，资源窗格中的 VM 状态指示器将恢复为 [image] 。


运行远程控制台会话

TabPageConsole 1020

要在 VM 上打开远程控制台会话，请选择该 VM，然后单击控制台选项卡。

Linux VM

在 Linux VM 上，可以使用文本控制台或图形控制台运行控制台会话。图形控制台采用 VNC 技术，并要求在虚拟机上安装和配置 VNC 服务器和 X 显示管理器。有关为 Linux 虚拟机配置 VNC 的信息，请参阅《XenServer 虚拟机用户指南》。

要在两种类型的远程控制台之间切换，请使用控制台选项卡上的切换到图形控制台/切换到文本控制台按钮。

Windows VM

Windows VM 上的控制台会话可以使用标准图形控制台或远程桌面控制台，这两种控制台均支持完全的键盘和鼠标交互。标准图形控制台使用 XenServer 内置的 VNC 技术提供对虚拟机控制台的远程访问，而远程桌面控制台则使用远程桌面协议技术。可以随时使用 XenCenter 控制台选项卡上的切换到远程桌面/切换到默认桌面按钮，在标准图形控制台和远程桌面控制台之间切换。

要使用远程桌面控制台连接，必须满足以下要求：

  • 必须在虚拟机上启用远程桌面 – 有关如何在 Windows 虚拟机上启用远程桌面的信息，请参阅《XenServer 虚拟机用户指南》。
  • 必须安装 XenServer Tools。
  • 虚拟机必须具有网络接口，并且能够连接到 XenCenter。

远程桌面控制台环境受许多不同 XenCenter 设置的影响：

  • Windows 组合键发送到远程桌面控制台。
  • 在本地计算机上播放来自远程桌面控制台上运行的应用程序的声音。
  • 默认情况下，打开远程桌面控制台会话时，将与远程服务器上的控制台会话建立连接，而不是创建虚拟控制台会话。
  • XenCenter 自动扫描 RDP 连接，并在该连接变为可用状态时自动切换到远程桌面控制台。

可以通过 XenCenter 选项对话框中的控制台选项卡更改这些设置和其他远程桌面控制台设置；请参阅更改 XenCenter 选项。


迁移 VM

显示所有文字

迁移虚拟机

RelocateToDialog 6300

使用 Storage XenMotion，可以将正在运行的虚拟机从一台服务器移动到同一个资源池中的另一台服务器，而几乎不会造成任何服务中断。目标服务器的选择取决于 VM 和池的配置方式：例如，在启用了 Workload Balancing (WLB) 的池中，该功能会提供一些建议来帮助您选择可能最适合 VM 工作负载的物理服务器。有关详细信息，请参阅为 VM 的初始放置、迁移和恢复选择最优服务器。

通过 XenCenter，您可以使用移动 VM 对话框，将当前未在运行的 VM 移至同一池中的新存储。要移动 VM，请执行以下操作：从 XenCenter 菜单中，单击 VM，然后单击移动 VM。选择要将 VM 移至的存储库，然后单击移动。

关于使用 XenMotion 和 Storage XenMotion 迁移 VM

XenMotion

XenMotion 在所有版本的 XenServer 中都提供，当 VM 磁盘位于由两个主机共享的存储中时，使用 XenMotion 可以将正在运行的 VM 从一个主机移至另一个主机。这样便可执行一些池维护功能，例如 Workload Balancing (WLB)、高可用性以及滚动池升级 (RPU) 来自动移动 VM。利用这些功能，可以在不发生任何 VM 停机的情况下，执行工作负载调平、基础结构弹性和服务器软件升级操作。由于存储只能由同一池中的主机共享，因此 VM 只能在同一池中移动。

Storage XenMotion

当 VM 并不位于由两个主机共享的存储中时，使用 Storage XenMotion 也可以将 VM 从一个主机移至另一个主机。因此，可以在不发生停机的情况下迁移本地存储中存储的 VM，并且可以将 VM 从一个池移至另一个池。这样系统管理员便可：

  • 重新平衡 XenServer 池之间的 VM（例如从开发环境到生产环境）。
  • 在不发生任何 VM 停机的情况下，升级和更新独立 XenServer 主机。
  • 升级 XenServer 主机硬件。

注意：将 VM 从一个主机移至另一个主机会保留 VM 状态。状态信息包括用于定义和确定 VM 以及 CPU 和网络使用量等历史性能指标的信息。

使用 Storage XenMotion，您还可以将虚拟磁盘从一个存储库 (SR) 移至同一池中的其他 SR。有关详细信息，请参阅移动虚拟磁盘。

Storage XenMotion 功能在 Citrix XenServer 企业版或更高版本中提供。要了解有关不同 XenServer 版本中可用功能的详细信息，请单击此处。

兼容性要求

使用 XenMotion 或 Storage XenMotion 迁移 VM 时，新 VM 主机必须符合以下兼容性要求才能继续迁移：

  • 必须在要迁移的每个 VM 上安装 XenServer Tools。
  • 必须在目标主机上安装与源主机上相同版本或更新版本的 XenServer。
  • 对于 Storage XenMotion，如果源主机与目标主机上的 CPU 不同，目标主机提供的全套功能必须至少与源主机的 CPU 相同。因此，不可能在不同处理器（例如 AMD 和 Intel 处理器）之间移动 VM。
  • 对于 Storage XenMotion，无法迁移具有多个快照的 VM。
  • 对于 Storage XenMotion，无法迁移连接超过六个 VDI 的 VM。
  • 目标主机上必须有足够的备用内存容量，或者能够使用动态内存控制功能释放足够的容量。如果内存不足，则迁移将无法完成。
  • 对于 Storage XenMotion，目标存储中必须有足够的可用磁盘空间（用于存储 VM 及其快照）容纳传入 VM。如果空间不足，则迁移将无法完成。

XenMotion 和 Storage XenMotion 限制

XenMotion 和 Storage XenMotion 受到以下限制：

  • Storage XenMotion 不能用于 XenDesktop 部署。
  • 无法迁移带有位于 Integrated StorageLink (iSL) SR 中的 VDI 的 VM。
  • 无法迁移使用 PCI 传递功能的 VM。
  • VM 性能在迁移期间会下降。
  • 对于 Storage XenMotion，尝试 VM 迁移之前，应在由高可用性或 WorkLoad Balancing (WLB) 保护的池中禁用高可用性和 WLB。
  • 完成 VM 迁移所用时间取决于 VM 的内存占用空间及其活动。此外，使用 Storage XenMotion 迁移的 VM 将受 VDI 的大小及其存储活动的影响。

迁移 VM

  1. 在资源窗格中，选择 VM，然后执行下列操作之一：
    • 单击鼠标右键，在快捷菜单上单击迁移至服务器，然后单击迁移 VM 向导。
    • 在 VM 菜单上，单击迁移至服务器，然后单击迁移 VM 向导。
    • 在“文件夹视图”中，将 VM 拖到目标服务器上。请注意，必须使用“文件夹视图”，才能通过在资源窗格中拖放 VM 的方式迁移 VM。
  2. 从目标位置下拉列表中选择独立服务器或池。
  3. 从主服务器列表中选择服务器为 VM 分配主服务器，然后单击下一步。
  4. 在存储选项卡中指定要将迁移的 VM 的虚拟磁盘放置到的存储库，然后单击下一步。
    • 将迁移的所有虚拟磁盘放置到同一 SR 中单选按钮默认情况下处于选中状态，并显示目标池中的默认共享 SR。
    • 从存储库下拉列表中，单击将迁移的虚拟磁盘放置到指定 SR 中指定 SR。使用该选项，您可以为迁移的 VM 上的每个虚拟磁盘选择不同的 SR。
  5. 从存储网络下拉列表中，选择要用于 VM 虚拟磁盘实时迁移的目标池中的网络，然后单击下一步。

    注意：由于性能原因，建议不要将管理网络用于实时迁移。

  6. 检查配置设置，然后单击完成开始迁移 VM。


删除 VM

ConfirmVMDeleteDialog 6400

删除虚拟机会将其配置和文件系统从服务器中删除。删除 VM 时，可以选择同时删除与该 VM 相连的任何虚拟磁盘以及该 VM 的任何快照，也可以选择保留它们。

删除 VM

  1. 关闭 VM。
  2. 在资源窗格中选择已停止的 VM，单击鼠标右键，然后单击快捷菜单上的删除。

    或者，在 VM 菜单上，单击删除。

  3. 要删除所连接的虚拟磁盘，请选中与之对应的复选框。重要提示 存储在 VM 的虚拟磁盘驱动器中的所有数据都将丢失。
  4. 要删除 VM 的快照，请选中与之对应的复选框。
  5. 单击删除。

    完成删除操作后，该 VM 将从资源窗格中删除。

请注意，已经删除了父 VM 的 VM 快照（“孤立快照”）仍可以通过资源窗格的文件夹视图进行访问，也可以将其导出、删除以及用来创建新的 VM 和模板。要在资源窗格中查看快照，请切换到文件夹视图，单击展开类型组，然后展开快照组。


导入和导出 VM

主题
关于 VM 导入和导出
开放虚拟化格式（OVF 和 OVA）
磁盘映像格式（VHD 和 VMDK）
从 OVF/OVA 导入 VM
导入磁盘映像
从 XVA 导入 VM
将 VM 导出为 OVF/OVA
将 VM 导出为 XVA


关于 VM 导入和导出

VM 可以从 OVF/OVA 包、磁盘映像和 XenServer XVA 文件导入，可以使用 OVF/OVA 包和 XenServer XVA 文件形式导出。在 XenCenter 中，可以使用导入和导出向导来导入和导出 VM。XenCenter 使用“传输 VM”功能来传输磁盘映像的内容。

导入在 XenCenter 以外的其他虚拟机管理程序（例如 Hyper-V 或 VMware）上创建的 VM 时，必须使用“操作系统修复”工具确保所导入的 VM 能够在 XenServer 上引导。

支持的导入和导出格式

格式 | 说明
开放虚拟化格式（OVF 和 OVA） | OVF 是用于打包和分发由一个或多个虚拟机组成的虚拟设备的开放标准。 有关 XenCenter 对 OVF 和 OVA 文件格式的支持功能的详细信息，请参阅开放虚拟化格式（OVF 和 OVA）。
磁盘映像格式（VHD 和 VMDK） | 可以使用导入向导导入虚拟硬盘 (VHD) 和虚拟机磁盘 (VMDK) 格式的磁盘映像文件。当仅有一个可用虚拟磁盘映像，但没有与其关联的 OVF 元数据时，您可能需要导入磁盘映像。 有关受支持的磁盘映像格式的详细信息，请参阅磁盘映像格式（VHD 和 VMDK）
XenServer XVA 格式 | XVA 是基于 Xen 的虚拟机管理程序所专有的格式，用来将单个 VM 打包为单个文件存档（包括描述符和磁盘映像）。其文件扩展名为 .xva。
XenServer XVA 版本 1 (ova.xml) | XVA 版本 1 是用于将单个 VM 打包为一组文件（包括描述符和磁盘映像）的格式。描述符（称为 ova.xml）用来指定单个 VM 的虚拟硬件。磁盘映像格式是一个文件目录。目录名对应于描述符中的引用名称。磁盘映像的每个 GB 区块对应一个文件。每个文件的基本名称中包含十进制的区块编号。文件中包含磁盘映像的一个区块，采用原始二进制格式，并以 gzip 格式压缩。

使用哪种格式？

使用 OVF/OVA 可以：

  • 与支持 OVF 的其他虚拟机管理程序共享 XenServer vApp 和 VM。
  • 保存多个 VM。
  • 保护 vApp 或 VM 不被损坏和篡改。
  • 包括许可协议。
  • 通过将 OVF 包存储在一个 OVA 中来简化 vApp 的分发。

使用 XVA 可以：

  • 与 6.0 以下版本的 XenServer 共享 VM。
  • 通过命令行接口 (CLI) 使用脚本导入和导出 VM。

操作系统修复

XenCenter 包含一个高级的虚拟机管理程序互操作性功能（操作系统修复），该功能旨在确保导入 XenServer 的 VM 具有基本级别的互操作性。从 OVF/OVA 包和磁盘映像导入在其他虚拟机管理程序上创建的 VM 时，将需要使用“操作系统修复”。

“操作系统修复”将启用对于在 XenServer 中完成引导非常关键的引导设备，并禁用用于 XenServer 以外其他虚拟机管理程序的任何服务（也称为工具），从而将来宾操作系统配置为在 XenServer 中引导。来宾操作系统包括 XenServer 支持的所有 Windows 版本以及一些 Linux 版本。请注意，“操作系统修复”不会将来宾操作系统从一个虚拟机管理程序转换到另一个虚拟机管理程序。

“操作系统修复”以自动引导的 ISO 映像形式提供，该映像连接到所导入 VM 的 DVD 驱动器，它将在 VM 首次启动时执行必要的配置更改，然后关闭 VM。下次启动新 VM 时，引导设备将重置，VM 将按正常方式启动。

要针对所导入的磁盘映像和 OVF/OVA 包使用“操作系统修复”，可以在 XenCenter 导入向导的 OS 修复设置页面上启用该功能，然后指定将存储所复制的修复 ISO（以供 XenServer 使用）的位置。

操作系统修复的要求

“操作系统修复”需要一个具有 40 MB 可用空间和 256 MB 虚拟内存的 ISO SR。

传输 VM

“传输 VM”是内置的 VM，它仅在导入或导出虚拟磁盘映像期间运行，用以在磁盘映像文件位置与 XenServer 存储库 (SR) 之间传输映像内容。每导入或导出一个磁盘映像，都会运行一次“传输 VM”。如果导入或导出具有多个磁盘映像的 VM 或 vApp，则一次仅传输一个磁盘映像。

您需要在导入和导出向导中为“传输 VM”配置网络连接设置。

“传输 VM”的要求

XenServer 运行一个“传输 VM”时，要求如下：

虚拟 CPU | 1
虚拟内存 | 256 MB
存储 | 8 MB
网络连接 | 可从 XenServer 主机访问的网络 - 通常为管理网络。 静态或动态 IP 地址。（Citrix 建议使用动态 IP 地址。）

默认传输协议为 iSCSI，这种情况下要求在 XenCenter 主机上安装 iSCSI 发起程序。也可以使用 RawVDI 作为备用传输协议。有关详细信息，请参阅《XenServer 虚拟机用户指南》。

导入 VM：概述

导入 VM 时，将有效地创建新的 VM，该过程涉及到的许多步骤与使用新建 VM 向导创建和置备新 VM 时的步骤相同，例如指定主服务器，以及为新 VM 配置存储和网络连接；有关其中每个步骤的详细信息，请参阅创建新 VM。

导入向导将引导您通过以下步骤导入 VM：

  1. 选择导入文件。

    第一步是找到并选择要导入的 VM 所在的文件。

    对于当前未在本地 XenCenter 主机上的文件，可以在文件名框中输入 URL 位置 (http | https | file | ftp)。单击下一步后，下载文件对话框将打开，您可以在其中指定 XenCenter 主机上要存储所复制的文件的文件夹。文件下载完毕后，导入向导将进入下一页。

  2. （仅限 VHD 和 VMDK 导入）为新 VM 指定名称并分配 vCPU 和内存资源。

    从 VHD 或 VMDK 文件导入时，需要为新 VM 指定名称并分配一些虚拟 CPU (vCPU) 和内存。创建新 VM 后，所有这些值都可以进行调整。有关此步骤的详细信息，请参阅 VM CPU 和内存配置。在 XenCenter 内不会检查 VM 名称是否唯一，因此，为不同的 VM 指定有意义且好记的名称可以方便 VM 的管理；有关详细信息，请参阅 VM 名称和说明。

  3. （仅限 OVF/OVA）检查/接受 EULA。

    如果导入的软件包中包含任何 EULA，请接受这些 EULA，然后单击下一步继续操作。如果该软件包中不包含 EULA，则该向导将跳过此步骤而直接进入下一页。

  4. 选择位置/主服务器。

    选择要用来放置所导入 VM 的目标池或独立服务器。要为传入的 VM 指定主服务器，请在列表中选择服务器。

  5. 配置存储。

    然后，选择要用来放置所导入 VM 中虚拟磁盘的存储库 (SR)：

    • 对于 XVA 格式的 VM，请选择将用来放置所导入 VM 中所有虚拟磁盘的 SR。
    • 对于 OVF/OVA 包中或磁盘映像文件中的 VM，可以将所导入的所有虚拟磁盘放在同一个 SR 上，也可以将各个虚拟磁盘放在不同的 SR 上。
  6. 配置网络连接。

    然后，将所导入 VM 中的虚拟网络接口映射到目标池/独立服务器中的目标网络。

  7. （仅限 OVF/OVA）安全性验证。

    如果为所选 OVF/OVA 包配置了证书或清单文件等安全功能，则需要指定必要的信息。

  8. （仅限 OVF/OVA 和磁盘映像）配置“操作系统修复”和“传输 VM”设置。

    如果导入的 VM 是在 XenServer 以外的其他虚拟机管理程序上构建的，您将需要配置“操作系统修复”功能，以允许所导入的 VM 在 XenServer 上正确引导。您还需要为“传输 VM”（在从磁盘映像和 OVF/OVA 包导入/导出 VM 时所使用的一个临时 VM）配置网络连接。

  9. 完成新 VM 的创建。

    在导入向导的最后一页上，可以检查已选择的所有配置选项。从 XVA 导入时，可以选中自动启动 VM 复选框，以便在创建新 VM 后立即将其启动。

    单击完成，以完成所选 VM 的导入并关闭该向导。

导出 VM：概述

选择要导出的 VM，然后打开导出向导：在 VM 菜单上，单击导出。

  1. 指定导出文件的详细信息。

    在该向导的第一页上，输入导出文件的名称，指定要保存导出文件的文件夹，然后从格式列表中选择导出文件格式：

    • 选择 XVA 文件(*.xva) 可将所选 VM 导出到 XVA 文件中。使用此格式只能导出单个 VM。
    • 选择 OVF/OVA 包(*.ovf, *.ova) 可将所选 VM 导出为 OVF 或 OVA 包。
  2. 确认已选择要导出的 VM。

    在该向导的下一页上，可以修改 VM 选择集，例如，在要导出的 VM 集中添加更多 VM 或者取消选择其他 VM。请注意，在导出为 XVA 时，只能选择一个 VM。

  3. （仅限 OVF/OVA）配置 EULA、“高级选项”和“传输 VM”设置。

    将 VM 导出为 OVF 或 OVA 包时，可以配置许多其他设置。有关详细信息，请参阅将 VM 导出为 OVF/OVA。

  4. 完成 VM 的导出。

    在该向导的最后一页上，检查在前面的向导页面上选择的设置。要让向导验证导出文件，请选中导出完成时进行验证复选框。

    单击完成，以开始导出所选 VM 并关闭该向导。


开放虚拟化格式（OVF 和 OVA）

OVF 是由分布式管理任务组 (DMTF) 指定的开放标准，用于打包和分发由一个或多个虚拟机 (VM) 组成的虚拟设备。

OVF 包中包含用于描述虚拟机的元数据和文件元素、以及对于 OVF 包中应用程序的部署和操作至关重要的其他信息。其文件扩展名为 .ovf。

开放虚拟设备 (OVA) 是一个 OVF 包，位于扩展名为 .ova 的单个文件存档中。

请注意，在实施了基于角色的访问控制 (RBAC) 的 XenServer 环境中，只有具有“池管理员”RBAC 角色的用户才可以导入和导出 OVF 和 OVA 包。有关 RBAC 角色的详细信息，请参阅 RBAC 概述。

OVF 包中的内容

OVF 包中始终包含一个描述符文件 (*.ovf)，此外可能还包括许多其他文件。

文件类型 | 说明
描述符 | 描述符用于指定服务对虚拟硬件的要求，并且还包括其他信息，例如虚拟磁盘的说明、服务本身、来宾操作系统、许可协议 (EULA)、在设备中启动和停止 VM 的说明以及服务安装说明。描述符文件的扩展名为 .ovf。
清单文件 | 清单文件是软件包中每个文件的 SHA-1 摘要，可以用来检测任何损坏，以验证软件包的内容。清单文件的扩展名为 .mf。
签名 | 签名是用软件包所含 X.509 证书中的公钥进行签名的清单文件摘要，用于对软件包作者进行验证。签名文件的扩展名为 .cert。
虚拟磁盘 | OVF 不指定磁盘映像格式。OVF 包中包括由虚拟磁盘组成的文件，这些文件的格式由导出虚拟磁盘的虚拟化产品定义。XenServer 生成的 OVF 包具有动态 VHD 格式的磁盘映像；VMware 产品和 Virtual Box 生成的 OVF 包具有经过流技术优化的 VMDK 格式的虚拟磁盘。

OVA 包是磁带存档 (tar) 格式的单个存档文件，包含组成 OVF 包的各个文件。

应使用哪种格式？

OVF 包包含一系列未压缩的文件，对于需要访问文件中各个磁盘映像的用户而言更为方便，而 OVA 包只是一个大型文件。尽管您可以压缩此文件，但它不像一系列文件（如 OVF）那样具有灵活性。

OVA 更适用于适合只使用一个文件的特定应用场合（例如创建用于 Web 下载的软件包），这种情况下软件包更易于处理。与 OVF 相比，导出和导入 OVA 包所需的时间更长。

使用操作系统修复

使用 OVF 作为打包方法时，不能保证软件包中所包含的虚拟机能够跨虚拟机管理程序实现兼容。在一个虚拟机管理程序上创建的 OVF 包可能无法自动在其他虚拟机管理程序上工作。出现这种情况的原因有多种，其中包括：不同虚拟机管理程序对于 OVF 规范、来宾操作系统设备、驱动程序及实施有不同的解释。

XenCenter 包含一个高级的虚拟机管理程序互操作性功能（操作系统修复），该功能旨在确保导入 XenServer 的 OVF 包具有基本级别的互操作性。在对于创建于其他虚拟机管理程序的导入 VM 上，必须运行“操作系统修复”，以确保这些 VM 能够在 XenServer 上正确引导。

有关“操作系统修复”功能的详细信息，请参阅操作系统修复。

有关 OVF 的更多信息

有关 OVF 的详细信息，请参阅 Citrix 知识中心网站和 DMTF 网站上的以下文档：

  • Overview of the Open Virtualization Format（开放虚拟化格式概述）
  • Open Virtualization Format Specification（开放虚拟化格式规范）


磁盘映像格式（VHD 和 VMDK）

使用导入向导，可以将磁盘映像作为 VM 导入到资源池或特定主机。

当仅有一个可用虚拟磁盘映像，但没有与其关联的 OVF 元数据时，您可能需要导入磁盘映像。可能达到这种条件的情况包括：

  • 无法读取 OVF 元数据。但是，仍然可以导入磁盘映像。
  • 有一个虚拟磁盘未在 OVF 包中定义。
  • 在从中移动虚拟磁盘的平台（例如，早期的平台或映像）上无法创建 OVF 设备。
  • 要导入的早期 VMware 设备缺少 OVF 信息。
  • 要导入的独立 VM 缺少 OVF 信息。

在可能的情况下，Citrix 建议您导入包含 OVF 元数据的设备软件包，而不要只导入单个磁盘映像。OVF 数据提供了导入向导在从磁盘映像重新创建 VM 时所需要的信息，其中包括与 VM 相关联的磁盘映像数、处理器、存储以及内存要求等。如果缺少这些信息，尝试重新创建 VM 时可能会更加复杂，并且更易于出错。

请注意，在实施了基于角色的访问控制 (RBAC) 的 XenServer 环境中，只有具有“池管理员”RBAC 角色的用户才可以导入磁盘映像。有关 RBAC 角色的详细信息，请参阅 RBAC 概述。

支持的磁盘映像格式

可以使用 XenCenter 的导入向导导入以下磁盘映像格式：

格式 | 说明
虚拟硬盘 (VHD) | VHD 是 Microsoft 在开放规范承诺书中指定的一组虚拟磁盘映像格式。文件扩展名为 .vhd。XenCenter 将导入和导出动态 VHD 格式（精简置备的虚拟磁盘映像，仅在使用时分配空间）。
虚拟机磁盘 (VMDK) | VMDK 是一组由 VMware® 指定的虚拟磁盘映像格式。文件扩展名为 .vmdk。XenCenter 将导入经过流技术优化的 VMDK 格式和 monolithicFlat VMDK 格式。经过流技术优化的 VMDK 是由 VMware 和 Virtual Box 虚拟机管理程序生成的 OVF 包所使用的格式。MonolithicFlat VMDK 是一种常见的、可供 VMware 管理客户端下载的虚拟磁盘格式。

使用操作系统修复

XenCenter 包含一个高级的虚拟机管理程序互操作性功能（操作系统修复），该功能旨在确保在 XenServer 以外其他虚拟机管理程序上创建的 VM 具有基本级别的互操作性。在从创建于其他虚拟机管理程序上的磁盘映像导入 VM 时，必须运行“操作系统修复”，以确保这些 VM 能够在 XenServer 上正确引导。

要查找详细信息，请参阅操作系统修复。


从 OVF/OVA 导入 VM

可以使用导入向导来导入已保存为 OVF/OVA 文件的虚拟机 (VM)。该向导将引导您完成在 XenCenter 中创建新 VM 时所需要的许多通用步骤：指定主服务器；为新 VM 配置存储和网络连接；以及在导入过程中所需要的一些其他步骤，其中包括：

  • 指定安全设置（如果 OVF 包中包括证书或清单文件）。
  • 为传输 VM 配置网络连接。
  • 指定操作系统修复设置（如果要导入的 VM 是在 XenServer 以外的其他虚拟机管理程序上构建的）。

有关在创建新 VM 时所涉及的各步骤的概述，请参阅创建新 VM。

使用 XenCenter 导入 OVF 包时，该软件包将显示为 vApp。导入完毕时，新 VM 将显示在 XenCenter 的资源窗格中，新 vApp 将显示在管理 vApp 对话框中。

必备条件

  • 需要具有“池管理员”RBAC 角色才能导入 OVF/OVA 包。导入向导将执行检查，以确保您在目标池中具有“池管理员”角色，然后才允许您继续操作。有关 RBAC 角色的详细信息，请参阅 RBAC 概述。
  • 如果导入的 OVF 包经过压缩或者包含压缩文件，则 XenServer 主机上需要有额外的可用磁盘空间来解压这些文件。

导入 OVF 包

  1. 打开导入向导：在文件菜单上，选择导入。
  2. 在该向导的第一页上，找到要导入的软件包（文件扩展名为 .ovf、.ova 或 .ova.gz），然后单击下一步继续操作。

    如果选择压缩的 OVA 文件 (*.ova.gz)，则在单击下一步时，该文件将解压为一个 OVA 文件，原 *.ova.gz 文件将被删除。

    如果在文件名框中输入 URL 位置 (http | https | file | ftp)，则在单击下一步时，将打开下载软件包对话框，您必须指定 XenCenter 主机上将存储所复制软件包的文件夹。

  3. 检查/接受 EULA。

    如果导入的软件包中包含任何 EULA，请接受这些 EULA，然后单击下一步继续操作。如果该软件包中不包含 EULA，则该向导将跳过此步骤而直接进入下一页。

  4. 指定 VM 位置和主服务器。

    在位置页面上，从将 VM 导入列表中选择用来放置所导入 VM 的池或独立服务器，然后为 VM 分配一个主服务器（可选）：

    • 要为 VM 指定主服务器，请从主服务器列的列表中选择服务器。XenServer 将始终尽可能尝试在 VM 的主服务器上启动 VM。有关为新 VM 分配主服务器的详细信息，请参阅主服务器。
    • 如果不希望指定主服务器，请从主服务器列的列表中选择不分配主服务器。

    单击下一步继续操作。

  5. 为导入的 VM 配置存储。

    在存储页面上，选择一个或多个要用来放置所导入 VM 磁盘映像的存储库 (SR)，然后单击下一步继续操作。

    • 要将导入的所有磁盘映像放在同一个 SR 上，请单击将导入的所有 VM 放在此目标 SR 上，然后从列表中选择一个 SR。
    • 要将传入 VM 的磁盘映像放在不同的 SR 上，请单击将导入的 VM 放在指定的目标 SR 上，然后针对每个虚拟磁盘，从 SR 列的列表中选择目标 SR。
  6. 为导入的 VM 配置网络连接。

    在网络连接页面上，将导入的 VM 中的虚拟网络接口映射到目标池中的目标网络。此页面上传入 VM 列表中显示的网络和 MAC 地址作为初始（导出）VM 定义的一部分存储在导出文件中。要将传入的虚拟网络接口映射到目标网络，请从目标网络列的列表中选择网络。

    单击下一步继续操作。

  7. 指定安全设置。

    如果为所选 OVF/OVA 包配置了证书或清单文件等安全功能，请在安全页面上指定必要的信息，然后单击下一步继续操作。此页面上显示的选项因 OVF 包上配置的安全功能而异：

    • 如果该软件包具有签名，此处将显示验证数字签名复选框；如果您希望验证签名，请单击此复选框。单击查看证书可显示用来对软件包进行签名的证书。如果该证书显示为不受信任，则可能是根证书或证书颁发机构在本地计算机上不受信任。
    • 如果软件包中包括清单文件，此处将显示验证清单文件内容复选框。选中此复选框时，向导将验证软件包中的文件列表。

    请注意，如果软件包具有数字签名，系统会自动验证关联的清单文件，因此，验证清单文件内容复选框不会出现在安全页面上。

    重要提示 VMware Workstation 7.1 生成的 OVF 设备将包含具有无效 SHA-1 哈希的清单文件。如果在从该来源导入设备时选择验证清单文件，导入操作将会失败。

  8. 启用“操作系统修复”。

    如果所导入软件包中的 VM 是在 XenServer 以外的其他虚拟机管理程序上构建的，请选中使用操作系统修复复选框，并选择可以存储所复制的修复 ISO（以供 XenServer 使用）的 ISO SR。有关此功能的详细信息，请参阅操作系统修复。

    如果未列出所需的 ISO 库，请单击新建 ISO 库创建新的 ISO SR；有关使用此选项的详细信息，请参阅 ISO 存储。

    单击下一步继续操作。

  9. 配置“传输 VM”的网络连接。

    在传输 VM 设置页面上，为传输 VM 配置网络连接设置，然后单击下一步继续操作。

    • 从目标池或独立服务器可用网络接口的列表中选择网络。
    • 要使用自动动态主机配置协议 (DHCP) 自动分配网络连接设置（包括 IP 地址、子网掩码和网关），请选择使用 DHCP 自动获取网络设置。
    • 要手动配置网络连接设置，请单击使用以下网络设置并输入 IP 地址、子网掩码和网关。
  10. 在完成页面上，检查所有的导入设置，然后单击完成，以开始执行导入过程并关闭该向导。

导入进度显示在 XenCenter 窗口底部的状态栏中以及日志选项卡上。

导入过程可能需要一些时间，具体取决于所导入虚拟磁盘的大小、可用网络带宽以及 XenCenter 主机的磁盘接口速度。导入完毕时，新导入的 VM 将显示在资源窗格中，新 vApp 将显示在管理 vApp 对话框中。

    注意：使用 XenCenter 导入包含 Windows 操作系统的 OVF 包之后，您必须设置平台参数。参数的设置因 OVF 包中所含 Windows 版本不同而异：
    • 对于 Windows Vista Server 2008 及更高版本，请将平台参数设置为 device_id=0002。例如：

      xe vm-param-set uuid=<VM UUID> platform:device_id=0002

    • 对于其他所有 Windows 版本，请将平台参数设置为 viridian=true。例如：

      xe vm-param-set uuid=<VM UUID> platform:viridian=true

尝试启动导入的 VM 时出错

如果无法引导从 OVF 包导入的 VM，请尝试在不使用“操作系统修复”功能的情况下重新导入该软件包：在导入向导的 OS 修复设置页面上，清除使用操作系统修复复选框（有关此功能的详细信息，请参阅操作系统修复。）


导入磁盘映像

通过 XenCenter 的导入向导，可以将磁盘映像导入资源池或特定主机中，从而创建新的 VM。该向导将引导您完成在 XenCenter 中创建新 VM 时所需要的许多通用步骤：指定主服务器；为新 VM 配置存储和网络连接；以及在导入过程中所需要的一些其他步骤，其中包括：

  • 为传输 VM 配置网络连接。
  • 指定操作系统修复设置（如果要导入的磁盘映像是在 XenServer 以外的其他虚拟机管理程序上构建的）。

导入磁盘映像的要求

  • 需要具有“池管理员”RBAC 角色才能导入磁盘映像。导入向导将执行检查，以确保您在目标池中具有“池管理员”角色，然后才允许您继续操作。有关 RBAC 角色的详细信息，请参阅 RBAC 概述。

过程

  1. 打开导入向导：在文件菜单上，选择导入。
  2. 在该向导的第一页上，找到要导入的磁盘映像文件，然后单击下一步继续操作。

    如果在文件名框中输入 URL 位置 (http | https | file | ftp)，则在单击下一步时，将打开下载软件包对话框，您必须指定 XenCenter 主机上将存储所复制磁盘映像的文件夹。

  3. 指定 VM 名称并分配 CPU 和内存资源。

    在 VM 定义页面上，输入将从所导入磁盘映像创建的新 VM 的名称，并分配 CPU 和初始内存资源。有关这些字段的说明，请参阅 VM CPU 和内存分配。

    单击下一步继续操作。

  4. 指定用来放置新 VM 的位置并选择主服务器。

    在位置页面上，选择要用来放置新 VM 的位置，为其分配主服务器（可选），然后单击下一步继续操作。

    • 在将 VM 导入列表中，单击池或独立服务器。
    • 要为该 VM 指定主服务器，请从主服务器列的列表中选择服务器。XenServer 将始终尽可能尝试在 VM 的主服务器上启动 VM。有关为新 VM 分配主服务器的详细信息，请参阅主服务器。
    • 如果不希望指定主服务器，请从主服务器列的列表中选择不分配主服务器。
  5. 为新 VM 配置存储。

    在存储页面上，选择要用来放置所导入虚拟磁盘的存储库 (SR)，然后单击下一步继续操作。

  6. 为新 VM 配置网络连接。

    在网络连接页面上，在目标池/独立服务器中为新 VM 的虚拟网络接口选择目标网络。

    单击下一步继续操作。

  7. 启用“操作系统修复”。

    如果要导入的磁盘映像是在 XenServer 以外的其他虚拟机管理程序上构建的，请选中使用操作系统修复复选框，并选择可以存储所复制的修复 ISO（以供 XenServer 使用）的 ISO SR。有关此功能的详细信息，请参阅操作系统修复。

    单击下一步继续操作。

  8. 配置“传输 VM”的网络连接。

    在传输 VM 设置页面上，为传输 VM 配置网络连接设置，然后单击下一步继续操作。

    • 从目标池或独立服务器可用网络接口的列表中选择网络。
    • 要使用自动动态主机配置协议 (DHCP) 自动分配网络连接设置（包括 IP 地址、子网掩码和网关），请选择使用 DHCP 自动获取网络设置。
    • 要手动配置网络连接设置，请单击使用以下网络设置并输入 IP 地址、子网掩码和网关。
  9. 在完成页面上，检查所有的导入设置，然后单击完成，以开始执行导入过程并关闭该向导。

导入进度显示在 XenCenter 窗口底部的状态栏中以及日志选项卡上。

导入过程可能需要一些时间，具体取决于所导入虚拟磁盘的大小、可用网络带宽以及 XenCenter 主机的磁盘接口速度。导入完毕后，新导入的 VM 将显示在资源窗格中。

    注意：使用 XenCenter 导入包含 Windows 操作系统的磁盘映像之后，您必须设置平台参数。参数的设置因磁盘映像中所含 Windows 版本不同而异：
    • 对于 Windows Vista Server 2008 及更高版本，请将平台参数设置为 device_id=0002。例如：

      xe vm-param-set uuid=<VM UUID> platform:device_id=0002

    • 对于其他所有 Windows 版本，请将平台参数设置为 viridian=true。例如：

      xe vm-param-set uuid=<VM UUID> platform:viridian=true


从 XVA 导入 VM

通过 XenCenter 的导入向导，可以导入先前以 XVA 格式（文件扩展名为 .xva）或 XVA 版本 1 格式（ova.xml 及其关联文件）导出并存储在本地的 VM、模板和快照。

从 XVA 或 ova.xml 文件导入 VM 时，所涉及的步骤与使用新建 VM 向导创建和置备新 VM 时的步骤相同，例如指定主服务器，以及为新 VM 配置存储和网络连接；有关其中每个步骤的详细信息，请参阅创建新 VM。

重要提示 如果 VM 是从具有不同 CPU 类型的其他服务器导出的，则该 VM 在导入后并不一定能够运行。例如，对于在带有 Intel® VT CPU 的服务器上创建的 Windows VM，如果在导出后将其导入带有 AMD-VTM CPU 的服务器中，则该 VM 可能无法运行。

过程

  1. 通过执行以下操作之一打开导入向导：
    • 在资源窗格中，单击鼠标右键，然后选择快捷菜单上的导入。
    • 在文件菜单上，选择导入。
  2. 在该向导的第一页上，找到要导入的 XVA（或 ova.xml）文件，然后单击下一步。

    如果在文件名框中输入 URL 位置 (http | https | file | ftp)，则在单击下一步时，将打开下载软件包对话框，您必须指定 XenCenter 主机上将存储所复制文件的文件夹。

  3. 在主服务器页面上，指定要用来放置新 VM 的位置：
    • 要将所导入的 VM 放置在池中而不为其分配主服务器，请在列表中选择目标池，然后单击下一步。
    • 要将所导入的 VM 放置在池中并将其分配给特定的主服务器（或者将其放在独立服务器上），请选择服务器，然后单击下一步继续操作。
  4. 在存储页面上，选择要用来放置所导入虚拟磁盘的存储库 (SR)，然后单击下一步继续操作。
  5. 在网络连接页面上，将导入的 VM 中的虚拟网络接口映射到目标池中的目标网络。此页面上列表中显示的网络和 MAC 地址作为初始（导出）VM 定义的一部分存储在导出文件中。要将传入的虚拟网络接口映射到目标网络，请从目标网络列的列表中选择网络。

    单击下一步继续操作。

  6. 在导入向导的最后一页上，检查已选择的配置选项。

    要在导入过程完毕并置备新 VM 后立即启动所导入的 VM，请选中导入后启动 VM 复选框。

  7. 单击完成，以开始导入所选文件并关闭该向导。

导入进度显示在 XenCenter 窗口底部的状态栏中以及日志选项卡上。

导入过程可能需要一些时间，具体取决于所导入 VM 的虚拟磁盘的大小、可用网络带宽以及 XenCenter 主机的磁盘接口速度。当新导入的 VM 可用时，将显示在资源窗格中。


将 VM 导出为 OVF/OVA

可以使用 XenCenter 的导出向导将一个或多个 VM 导出为 OVF 或 OVA 包。导出 VM 前，必须将其关闭或挂起。

请注意，必须具有“池管理员”RBAC 角色才能将 VM 导出为 OVF/OVA 包。导出向导将在启动时执行检查，以确保您具有“池管理员”角色，然后才允许您继续操作。有关 RBAC 角色的详细信息，请参阅 RBAC 概述。

过程

  1. 打开导出向导：选择要导出的 VM 所在的池或服务器，然后在 VM 菜单上单击导出。
  2. 在该向导的第一页上，输入导出文件的名称，指定要保存导出文件的文件夹，从格式列表中选择 OVF/OVA 包(*.ovf, *.ova)，然后单击下一步。
  3. 选择要导出的 VM，然后单击下一步。
  4. 在 EULA 页面上，可以在软件包中添加先前准备的最终用户许可协议 (EULA) 文档（.rtf 或 .txt）。要在文本编辑器中查看 EULA 的内容，请在列表中选择 EULA，然后单击查看。

    如果不希望在软件包中包括 EULA，只需单击下一步继续操作。

  5. 在高级选项页面上，指定任何清单文件、签名和输出文件选项，或者只单击下一步继续操作：
    1. 要为软件包创建清单文件，请选中创建清单复选框。

      清单文件可提供软件包中其他文件的清单或列表，用于确保最初在创建软件包时包含的文件与软件包到达时所包含的文件相同。导入文件时，将使用校验和来验证在创建软件包后文件是否发生过更改。

    2. 要在软件包中添加数字签名，请选中签署 OVF 包复选框，通过浏览找到证书，然后在私钥密码框中输入与该证书相关联的私钥。导入具有签名的软件包时，用户可以使用证书的公钥来验证数字签名，从而验证软件包创建者的身份。请使用已由受信任证书机构创建并导出为 .pem 或 .pfx 文件的 X.509 证书，该文件中包含清单文件的签名及用来创建该签名的证书。
    3. 要将所选 VM 输出为 OVA 格式的单个 (tar) 文件，请选中创建 OVA 包复选框。有关不同文件格式的详细信息，请参阅开放虚拟化格式（OVF 和 OVA）。
    4. 要压缩软件包中包括的虚拟硬盘映像（.VHD 文件），请选中压缩 OVF 文件复选框。

      默认情况下，当您创建设备软件包时，导出的虚拟硬盘映像所占用的空间量与分配给 VM 的空间量相同。例如，如果为 VM 分配了 26 GB 空间，则该 VM 的硬盘映像也将占用 26 GB 空间，而不考虑该 VM 实际是否需要这么多的空间。请注意，如果压缩 VHD 文件，会增加完成导出过程所需要的时间，导入包含压缩 VHD 文件的软件包时，所需要的时间也会增加，因为导入向导在导入这些文件时必须将所有 VHD 映像解压。

    如果创建 OVA 包和压缩 OVF 文件选项均处于选中状态，将生成压缩的 OVA 文件 *.ova.gz。

  6. 在传输 VM 设置页面上，为用来执行导出过程的临时 VM（“传输 VM”）配置网络连接选项。单击下一步继续操作。
  7. 在该向导的最后一页上，检查在前面的页面上选择的设置。要让向导验证导出的软件包，请选中导出完成时进行验证复选框。

    单击完成，以开始导出所选 VM 并关闭该向导。

导出过程可能需要一些时间，具体取决于虚拟磁盘的大小、可用网络带宽以及 XenCenter 主机的磁盘接口速度。进度将显示在 XenCenter 窗口底部的状态栏中以及日志选项卡上。

要取消正在进行的导出操作，请单击日志选项卡，在事件列表中找到该导出事件，然后单击取消按钮。


将 VM 导出为 XVA

通过导出向导，可以将单个 VM 导出为 XVA 文件。导出 VM 前，必须将其关闭或挂起。

注意：如果 VM 是从具有不同 CPU 类型的其他服务器导出的，则该 VM 在导入后并不一定能够运行。例如，对于在带有 Intel® VT CPU 的服务器上创建的 Windows VM，如果在导出后将其导入带有 AMD-VTM CPU 的服务器中，则该 VM 可能无法运行。

过程

  1. 选择要导出的 VM，然后单击 VM 菜单上的导出。
  2. 在该向导的第一页上，输入导出文件的名称，指定要保存导出文件的文件夹，从格式列表中选择 XVA 文件(*.xva)，然后单击下一步。
  3. 在虚拟机页面上的列表中，要导出的 VM 处于选定状态。导出为 XVA 时，在该列表中只能选择一个 VM。单击下一步继续操作。
  4. 在该向导的最后一页上，检查在前面的页面上选择的设置。要使向导验证导出的 XVA 文件，请选中完成时验证导出复选框。

    单击完成，以开始导出所选 VM 并关闭该向导。

导出过程可能需要一些时间，具体取决于 VM 虚拟磁盘的大小、可用网络带宽以及 XenCenter 主机的磁盘接口速度。进度将显示在 XenCenter 窗口底部的状态栏中以及日志选项卡上。

要取消正在进行的导出操作，请单击日志选项卡，在事件列表中找到该导出事件，然后单击取消按钮。


VM 快照

主题
关于快照
生成 VM 快照
还原到快照
从快照创建新 VM
从快照创建新模板
将快照导出到文件
删除快照


关于快照

HelpIDs:TabPageSnapshots 1032

虚拟机快照是运行中的虚拟机 (VM) 在某个时间点的记录。生成 VM 的快照时，其存储信息（硬盘驱动器上的数据）和元数据（配置信息）也会同时保存。如有必要，在生成快照时会暂时停止 IO，以确保捕获具有自我一致性的磁盘映像。

与 VM 导出不同，创建快照时无需事先关闭 VM。快照类似于普通的 VM 模板，但是其中包含原始 VM 的所有存储和配置信息（包括网络连接信息）。快照是一种快捷的模板创建方式，可以导出作为备份并在之后进行还原，也可以用来快速创建新的 VM。

虽然所有存储类型都支持快照，但对基于 LVM 的存储类型（XenServer 5.5 或更高版本）而言，如果存储库是使用早期版本的 XenServer 创建的，则必须将其升级，而且卷必须采用默认格式；请参阅升级旧 SR。

快照类型

XenCenter 支持全部三种类型的 VM 快照：仅磁盘快照、静态快照以及磁盘和内存快照。有关详细信息，请参阅生成 VM 快照。

仅磁盘快照
仅磁盘快照存储 VM 的配置信息（元数据）和磁盘（存储），并允许导出和还原这些信息以作为备份。此类快照具有崩溃状态一致性，适用于所有 VM 类型（包括 Linux VM）。
静态快照
静态快照利用 Windows 卷影复制服务 (VSS) 生成具有应用一致性的实时快照。VSS 框架帮助支持 VSS 的应用程序（例如 Microsoft Exchange 或 Microsoft SQL Server）在生成快照前将数据刷新到磁盘并做好快照的准备。因此，还原静态快照相对要安全一些，但在生成静态快照时，可能会对系统性能产生较大的影响。如果负载过重，还可能会失败，因此生成此类快照可能需要进行多次尝试。
有关操作系统对静态快照的支持的信息，以及有关静态快照在 XenServer 中实现方式的详细信息，请参阅《XenServer 管理员指南》。

重要提示 XenServer VSS 提供程序用于使来宾文件系统处于静默状态，以便为快照做好准备，它将作为 XenServer Tools 的一部分进行安装，但是默认情况下并未启用。要启用 VSS 提供程序，请按照《XenServer 虚拟机用户指南》中的说明操作。

磁盘和内存快照
磁盘和内存快照除了保存 VM 的元数据和磁盘外，还保存 VM 的内存状态 (RAM)。还原到磁盘和内存快照不需要重新启动 VM，生成此类快照时，VM 可以处于运行状态，也可以处于挂起状态。如果正在升级或修补软件，或者要测试新应用程序，但同时又希望能有机会返回到虚拟机的当前（更改前）状态 (RAM)，磁盘和内存快照会非常有用。

只有 Citrix XenServer 企业版或更高版本才提供磁盘和内存快照。要了解有关不同 XenServer 版本中可用功能的详细信息，请单击此处。

访问孤立快照

请注意，即使在生成 VM 的快照之后删除了原始 VM，也仍然可以访问这些快照：在资源窗格的“文件夹视图”中，单击展开类型组，然后展开快照组查看所有可用的快照。


生成 VM 快照

  1. 在资源窗格中选择 VM，然后单击快照选项卡。
  2. 单击生成快照按钮。

    或者

    • 在“属性”窗格中单击鼠标右键，然后单击生成快照。
    • 在 VM 菜单上，单击生成快照。
  3. 输入新快照的名称和可选说明。
  4. 在快照模式下，选择要创建的快照的类型：
    • 要创建仅磁盘快照，请选择生成虚拟机磁盘快照。
    • 要创建静态快照，请选择生成虚拟机磁盘快照，然后单击生成快照前使 VM 静止。
    • 要创建磁盘和内存快照，请选择生成虚拟机磁盘和内存快照。
  5. 单击确定开始创建新快照。进度将显示在状态栏和日志选项卡中。

创建新快照之后，新创建的快照将显示在 VM 的快照选项卡上以及资源窗格（文件夹视图）的“快照”组下：

仅磁盘快照
磁盘和内存快照


还原到快照

通过还原到快照，可以将 VM 还原为创建快照时的状态。将放弃自生成快照以来对 VM 进行的所有更改，并失去 VM 的当前状态。

还原到快照对话框中的一个选项可用来在还原早期快照之前生成当前 VM 状态的新快照，从而可以在需要时将 VM 轻松地还原到当前状态。

  1. 在快照选项卡上，选择快照，然后单击还原到。

    如果要还原的快照是计划快照（使用“VM 保护和恢复”功能自动创建的快照），需要在快照选项卡上显示计划快照，然后才能进行选择：单击视图，然后单击计划快照。

  2. 如果要在将 VM 还原到早期快照之前生成 VM 当前状态的新快照，请选中相应的复选框。
  3. 单击是。


从快照创建新 VM

从快照创建新 VM 的过程与使用新建 VM 向导从常规 VM 模板创建 VM 的过程完全相同。

从快照创建新 VM

  1. 在快照选项卡上，选择要使用的快照，单击鼠标右键，然后单击快捷菜单上的从快照新建 VM。

    新建 VM 向导随即打开，并在模板页面上显示预先选择的快照。

  2. 按照新建 VM 向导中的步骤创建新 VM。请参阅创建新 VM。

从孤立快照创建新 VM

如果用来创建快照的原始 VM 已删除，则可以按如下方式选择快照并启动新建 VM 向导：

  1. 在资源窗格中，切换到文件夹视图。
  2. 单击展开类型组，然后展开快照组。
  3. 选择快照，单击鼠标右键，然后单击快捷菜单上的从快照新建 VM。


从快照创建新模板

VMSnapshotPage 6530

尽管不能直接复制 VM 快照，但可以从快照创建新的 VM 模板，然后使用该模板来创建快照副本。模板是“黄金映像”（在创建新 VM 时用作主副本的普通 VM）。以所需方式设置 VM 并生成其快照后，可以将该快照另存为一个新模板，并使用该模板为同一资源池中进行了特殊配置的 VM 创建副本。请注意，如果这样操作，将不保存快照的内存状态。

将快照另存为新模板

  1. 在快照选项卡上，选择快照，单击鼠标右键，然后单击快捷菜单上的从快照创建模板。
  2. 输入新模板的名称，然后单击确定。

成功创建新模板后，它将作为自定义模板显示在资源窗格中以及新建 VM 向导的模板页面上。

将孤立快照另存为新模板

如果用来创建快照的原始 VM 已删除，则可以按如下方式将该快照另存为新模板：

  1. 在资源窗格中，切换到文件夹视图。
  2. 单击展开类型组，然后展开快照组。
  3. 选择快照，单击鼠标右键，然后单击快捷菜单上的从快照创建模板。


将快照导出到文件

在导出 VM 快照时，它会作为 VM 模板保存在本地计算机上的一个 XVA 文件中。该模板中包含此快照的完整副本（包括磁盘映像），随后可以将其导入，并用来在相同或不同的资源池中创建新的 VM。

将快照导出到文件

  1. 在快照选项卡上，选择快照，单击操作，然后单击导出到文件。
  2. 通过浏览找到要在其中创建 XVA 文件的文件夹，输入文件名，然后单击保存开始导出。

导出孤立快照

如果用来创建快照的原始 VM 已删除，则可以按如下方式导出快照：

  1. 在资源窗格中，切换到文件夹视图。
  2. 单击展开类型组，然后展开快照组。
  3. 选择快照，单击鼠标右键，然后选择快捷菜单上的将快照导出为模板。
  4. 通过浏览找到要在其中创建 XVA 文件的文件夹，输入文件名，然后单击保存开始导出。


删除快照

删除快照

  1. 在快照选项卡上，选择快照，然后单击删除。
  2. 单击确定进行确认。

删除孤立快照

如果用来创建快照的原始 VM 已删除，则可以按如下方式删除快照：

  1. 在资源窗格中，切换到文件夹视图。
  2. 单击展开类型组，然后展开快照组。
  3. 选择快照，单击鼠标右键，然后单击快捷菜单上的删除快照。


XenServer vApp

主题
管理 vApp
创建 vApp
修改 vApp
删除 vApp
启动和关闭 vApp
导出和导入 vApp


管理 vApp

XenServer vApp 是由一个或多个相关虚拟机 (VM) 组成的逻辑组，可以作为单个实体来管理。vApp 中的 VM 不必驻留在一台主机服务器上，将按照通常的规则分布在池中。

启动 vApp 时，其中包含的 VM 将按照用户定义的顺序启动，使彼此依赖的 VM 可以自动排成序列。这意味着在整个服务需要重新启动时（例如，在软件更新时），您不需要手动安排相关 VM 的启动顺序。

在灾难恢复情况下，vApp 功能尤其有用，您可以选择将位于同一个存储库 (SR) 上或者与同一个服务级别协议相关的所有 VM 组合在一起。

使用“管理 vApp”对话框

通过 XenCenter 的管理 vApp 对话框，可以创建、删除、修改、启动和关闭 vApp，也可以在所选池内导入和导出 vApp。在列表中选择某个 vApp 时，其中包含的 VM 会列在右侧的详细信息窗格中。

控件 | 功能
新建 vApp | 打开新建 vApp 向导。请参阅创建 vApp。
删除 | 删除选定的 vApp。该 vApp 中的 VM 不会随之删除。
属性 | 打开所选 vApp 的属性对话框。在该对话框中，可以更改所选 vApp 的名称或说明，在 vApp 中添加或删除 VM，更改 VM 的启动顺序和延迟间隔。请参阅修改 vApp。
启动 | 按照指定的顺序启动所选 vApp 中的所有 VM，启动序列由每个 VM 上设置的启动顺序和延迟间隔值确定。请参阅启动和关闭 vApp。
关闭 | 关闭所选 vApp 中的所有 VM。请参阅启动和关闭 vApp。
导入 | 打开 XenCenter 的导入向导并将 OVF/OVA 包作为 vApp 导入。请参阅导出和导入 vApp。
导出 | 打开导出向导并将 vApp 导出为 OVF/OVA 包。请参阅导出和导入 vApp。


创建 vApp

要创建新的 vApp，请使用管理 vApp 对话框。

  1. 选择池，然后从池菜单中，单击管理 vApp。

    或者，在资源窗格中单击鼠标右键，然后单击快捷菜单上的管理 vApp。

  2. 在管理 vApp 对话框左上角，单击新建 vApp...。
  3. 输入新 vApp 的名称和（可选）说明，然后单击下一步。

    可以根据自己的喜好选择任何名称，但通常最好使用描述性的名称。尽管建议您避免为多个 vApp 使用相同的名称，但并不是必须要这样做，XenCenter 不会针对 vApp 名称实施唯一性约束。对于包含空格的名称，不必使用引号。

  4. 选择要包括在新 vApp 中的虚拟机，然后单击下一步。

    可以使用搜索框仅列出名称中包含指定字符串的 VM。

  5. 为该 vApp 中的 VM 指定启动顺序，然后单击下一步。
    值 | 说明
    启动顺序 | 指定各个 VM 在 vApp 中的启动顺序，使某些 VM 先于其他 VM 重新启动。启动顺序值为 0（零）的 VM 将首先启动，启动顺序值为 1 的 VM 接着启动，然后是启动顺序值为 2 的 VM，以此类推。
    尝试在以下时间后启动下一个 VM | 这是一段延迟时间间隔，用于指定从启动 VM 到尝试启动启动序列中下一组 VM（即，启动顺序更靠后的 VM）之间的等待时间。

    请注意，vApp 中 VM 的关闭顺序始终与所配置的启动顺序相反。

  6. 在该向导的最后一页上，可以检查 vApp 配置。单击上一步返回并修改任何设置，或者单击完成创建新的 vApp 并关闭该向导。


修改 vApp

要更改 vApp 的名称或说明、在 vApp 中添加或删除 VM 以及更改 vApp 中各 VM 的启动顺序，请使用管理 vApp 对话框。

  1. 选择池，然后在池菜单上，单击管理 vApp。

    或者，在资源窗格中单击鼠标右键，然后单击快捷菜单上的管理 vApp。

  2. 选择该 vApp，然后单击 [image] 属性以打开其属性对话框。
  3. 单击常规选项卡以更改该 vApp 的名称或说明。
  4. 单击虚拟机选项卡以在该 vApp 中添加或删除 VM。
  5. 单击 VM 启动顺序选项卡以更改 vApp 中各 VM 的启动顺序和延迟间隔值。
    控件 | 说明
    启动顺序 | 指定各个 VM 在 vApp 中的启动顺序，使某些 VM 先于其他 VM 重新启动。启动顺序值为 0（零）的 VM 将首先启动，启动顺序值为 1 的 VM 接着启动，然后是启动顺序值为 2 的 VM，以此类推。
    尝试在以下时间后启动下一个 VM | 这是一段延迟时间间隔，用于指定从启动 VM 到尝试启动启动序列中下一组 VM（即，启动顺序更靠后的 VM）之间的等待时间。

    请注意，vApp 中 VM 的关闭顺序始终与所配置的启动顺序相反。

  6. 单击确定，以保存更改并关闭属性对话框。


删除 vApp

要从池中删除 vApp，请使用管理 vApp 对话框。

  1. 选择池，然后在池菜单上，单击管理 vApp。

    或者，在资源窗格中单击鼠标右键，然后单击快捷菜单上的管理 vApp。

  2. 在列表中选择要删除的 vApp，然后单击 [image] 删除。

该 vApp 中的 VM 不会随之删除。


启动和关闭 vApp

要启动或关闭 vApp，请使用可从池菜单中访问的管理 vApp 对话框。

启动 vApp 时，其中的所有 VM 都将自动按顺序启动。为每个 VM 指定的启动顺序和延迟间隔值控制着整个启动序列；可以在首次创建 vApp 时设置这些值，也可以随时从 vApp 属性对话框或各个 VM 的属性对话框更改这些值。

vApp 中 VM 的关闭顺序始终与所配置的启动顺序相反。

启动 vApp

  1. 打开管理 vApp 对话框：选择该 vApp 中各 VM 所在的池，然后在池菜单上单击管理 vApp。

    或者，在资源窗格中单击鼠标右键，然后单击快捷菜单上的管理 vApp。

  2. 选择该 vApp，然后单击 [image] 启动以启动其中包含的所有 VM。

关闭 vApp

  1. 打开管理 vApp 对话框：选择该 vApp 中各 VM 所在的池，然后在池菜单上单击管理 vApp。

    或者，在资源窗格中单击鼠标右键，然后单击快捷菜单上的管理 vApp。

  2. 选择该 vApp，然后单击 [image] 关闭以关闭其中包含的所有 VM。

    将对所有 VM 尝试执行软关闭；如果此操作不可行，则将执行强制关闭。要详细了解有关 VM 软关闭和强制关闭的详细信息，请参阅关闭 VM。


导出和导入 vApp

导出 vApp

vApp 可以导出为 OVF/OVA 包。

  1. 打开管理 vApp 对话框：在池菜单上，单击管理 vApp。
  2. 在列表中选择要导出的 vApp，然后单击 [image] 导出。
  3. 按照将 VM 导出为 OVF/OVA 中描述的过程操作。

导出 vApp 可能需要一些时间。

导入 vApp

OVF/OVA 包可以作为 vApp 导入。

  1. 打开管理 vApp 对话框：在池菜单上，单击管理 vApp。
  2. 单击 [image] 导入以打开导入向导。
  3. 按照从 OVF/OVA 导入 VM 中描述的过程操作。

导入完毕时，新的 vApp 将显示在管理 vApp 对话框的 vApp 列表中。


保护 VM

显示所有文字

保护 VM 和 vApp

XenServer 提供了一系列用来保护 VM 和 vApp 的功能。

VM 保护和恢复 (VMPR) – 计划快照

XenServer VM 保护和恢复 (VMPR) 功能通过定期按计划生成 VM 快照来防止各 VM 丢失，当原始 VM 损坏或不可访问时，可以将这些快照重新导入 XenCenter 中并使用快照重新创建该 VM。

阅读更多信息：关于 VM 保护和恢复；创建 VM 保护策略；管理 VM 保护策略；从快照恢复 VM

高可用性

XenServer 高可用性功能可以确保 VM 能够自动在池中的备用服务器上重新启动，以防止关键 VM 因池中某一服务器发生故障而导致停机，从而最大程度地减少服务中断。池数据库不断在所有节点之间复制，并且备份到检测信号 SR 上的共享存储中，从而进一步提高了安全性。

阅读更多信息：关于 XenServer 高可用性；高可用性要求；VM 启动设置；配置高可用性；禁用高可用性；更改高可用性设置

灾难恢复 (DR)

XenServer 灾难恢复 (DR) 功能可以防止主数据站点中的多台服务器丢失。启用灾难恢复后，不断通过镜像存储复制池数据库，如果主站点中出现灾难，VM 和 vApp 可以从镜像存储恢复到辅助 (DR) 站点上的池中。

阅读更多信息：关于 XenServer DR；配置 DR；故障转移；故障恢复；测试故障转移


VM 保护和恢复 (VMPR)

主题
关于 VM 保护和恢复
创建 VM 保护策略
管理 VM 保护策略
从计划快照恢复 VM


关于 VM 保护和恢复

XenServer 的 VM 保护和恢复 (VMPR) 功能提供了一个简单的关键服务 VM 备份和还原实用程序。系统将自动生成定期计划快照，并用来还原相应的 VM。

VMPR 依托池级别的 VM 保护策略而运行，这些策略定义池中选定 VM 的快照计划。启用策略后，将在每小时、每天或每周的预定时间生成指定 VM 的快照。如果进行了相应配置，这些快照还可以自动存档到远程 CIFS 或 NFS 共享位置，从而使安全性得到提升。

在一个池中可以启用多个 VMPR 策略，这些策略可以覆盖不同的 VM 并且可以制定不同的计划。每次只能将一个 VM 分配到一个策略中。

XenCenter 提供了一系列工具，可帮助您使用 VMPR 功能：

  • 要定义 VMPR 策略，请使用新建 VM 保护策略向导。
  • 要针对池启用、禁用、编辑和删除 VMPR 策略，可以使用 VM 保护策略对话框。
  • 要编辑策略，请从 VM 保护策略对话框打开该策略的属性对话框。
  • 要从计划快照恢复 VM，只需在快照选项卡上选择该快照，然后将 VM 还原到该快照。
  • 要从存档的计划快照恢复 VM，请导入该快照，创建新的自定义 VM 模板，然后通过该模板创建新的 VM。

Citrix XenServer 高级版或更高版本中提供 VMPR 功能。要了解有关不同 XenServer 版本中可用功能的详细信息，请单击此处。


创建 VM 保护策略

NewPolicyWizard_ArchivesnapshotsPane 6535, NewPolicyWizard_EmailalertsPane 6535, NewPolicyWizard_FinishPane 6535, NewPolicyWizard_PolicyNamePane 6535, NewPolicyWizard_SnapshotfrequencyPane 6535, NewPolicyWizard_SnapshottypePane 6535, NewPolicyWizard_VirtualMachinesPane 6535

使用新建 VM 保护策略向导可以创建 VM 保护策略，用来确定池中要生成快照的 VM、要创建的快照的类型（仅磁盘快照或磁盘和内存快照）以及快照和存档计划。还可以使用该向导为快照和存档事件警报配置电子邮件通知。

打开新建 VM 保护策略向导：在池菜单上，单击 VM 保护策略以打开 VM 保护策略对话框，然后单击新建启动该向导。

选择要保护的 VM

池中所有的 VM 都列在该向导页上。如果某个 VM 已经包含在 VM 保护策略中，则会显示该策略的名称。VM 每次只能分配给一个策略，因此，如果将 VM 分配给新策略，其将从当前的策略中删除（系统会要求您确认此操作）。

选择快照类型

计划的 VM 快照可以是仅磁盘快照，也可以是磁盘和内存快照。

  • 仅磁盘快照存储 VM 的磁盘（存储）和元数据。它们具有崩溃状态一致性，适用于所有 VM 类型（包括 Linux VM）。
  • 磁盘和内存快照保存 VM 的磁盘（存储）、元数据及其当前内存状态 (RAM)。请注意，此类快照可能会非常大。

设置快照计划和保留期

快照计划选项：

  • 每小时快照 - 在每小时的指定时间生成指定 VM 的快照。
  • 每天快照 - 在每天的指定时间生成指定 VM 的快照。
  • 每周快照 - 在每周的指定天数的指定时间生成指定 VM 的快照。可以选择一天或多天。

快照保留策略

在要保留的快照数下，指定要保留的计划快照的数量。当生成的计划快照的数量超过该值时，系统将自动删除最早的快照。

注意：最大计划快照数上限为 10。

设置存档计划

如果需要，计划快照会自动存档到远程 CIFS 或 NFS 共享位置。您可以定义一个独立于快照计划的每日或每周存档计划，或者只是在生成计划快照之后立即将其存档（在生成每个计划快照后存档选项）。您所定义的存档计划的存档频率不能高于快照计划的频率。

存档命名约定

存档文件夹的名称由 VM 名称和 VM UUID 的前 16 位字符组成。例如：

VM 名称 | VM UUID | 存档文件夹名称
Win7_Test_1 | cb53200c-bbd8-4c12-a076-e2eb29b38f06 | Win7_Test_1-cb53200c-bbd8-4c

放在存档文件夹中的已存档计划快照采用 YYYYMMDD-HHMM.xva 格式命名。例如：

20100624-1830.xva
20100624-1836.xva
20100625-0031.xva

配置电子邮件警报

针对任何计划快照或存档操作生成系统警报时，系统会发送电子邮件通知。默认情况下，VMPR 事件电子邮件通知处于关闭状态。


管理 VM 保护策略

VMProtectionPoliciesDialog 6536

要针对池启用、禁用、编辑和删除 VM 保护策略，可以使用 VM 保护策略对话框：在池菜单上，单击 VM 保护策略。

启用 VM 保护策略

启用 VM 保护策略时，该策略将“打开”：随后将在计划的时间生成并存档（如果同时进行了相应配置）指定 VM 的自动快照。计划快照将继续生成，直至该策略被禁用。

启用策略：

  1. 在资源窗格中，选择池或池中的任何服务器或 VM，然后在池菜单上，选择 VM 保护策略。
  2. 从该池中定义的策略列表内选择一个策略，然后单击启用。

禁用 VM 保护策略

如果要停止生成自动 VM 快照，可以使用 VM 保护策略对话框禁用 VM 保护策略：已经禁用的策略可以随时再次启用。

禁用策略：

  1. 在资源窗格中，选择池或池中的任何服务器或 VM，然后在池菜单上，选择 VM 保护策略。
  2. 从该池中定义的策略列表中选择策略，然后单击禁用。

编辑 VM 保护策略

可以更改 VMPR 策略，例如添加更多的 VM 或者更改快照计划：

  1. 在资源窗格中，选择池或池中的任何服务器或 VM，然后在池菜单上，选择 VM 保护策略。
  2. 从该池中定义的策略列表内选择策略，单击属性并转至所需的选项卡：
    选项卡 | 内容
    受保护的 VM | 在该选项卡上添加或删除 VM。VM 每次只能 分配给一个策略中，因此，如果将 VM 分配给新策略，其将从当前的策略中删除。
    快照类型 | 更改将创建的快照的类型。
    快照计划 | 更改用于生成 VM 快照的计划，以及更改快照的保留策略。
    存档选项 | 打开和关闭自动存档功能并设置存档计划。
    电子邮件警报 | 为计划快照或存档操作的系统警报配置电子邮件通知。
  3. 单击确定，以保存更改并关闭属性窗口。

删除 VM 保护策略

删除 VM 保护策略：

  1. 在资源窗格中，选择池或池中的任何服务器或 VM，然后在池菜单上，选择 VM 保护策略。
  2. 从该池中定义的策略列表内选择策略，然后单击删除。


从快照恢复 VM

从计划快照恢复 VM

要从计划快照恢复 VM，只需将 VM 还原到指定的快照即可。

  1. 选择 VM，然后单击快照选项卡。
  2. 显示计划快照（默认情况下计划快照不显示在该选项卡上）：单击视图，然后单击计划快照。
  3. 选择要将 VM 还原到的计划快照，然后单击还原到。
  4. 如果要在将 VM 还原到计划快照之前生成 VM 当前状态的新快照，请选中相应的复选框。
  5. 单击是将 VM 还原到选定的快照。

从存档快照恢复 VM

要从存档的计划快照恢复 VM，请按照下列步骤操作：

  1. 在本地装载 CIFS 或 NFS 存档共享目标。
  2. 按照从 XVA 导入 VM 中的说明，使用导入向导从目标导入存档 XVA 文件。该操作将创建新的自定义 VM 模板。
  3. 按照创建新 VM 中的说明，使用新建 VM 向导基于新模板创建新的 VM。

有关存档文件夹和存档快照的命名方式的信息，请参阅存档命名约定。


高可用性

主题
关于 XenServer 高可用性
高可用性要求
VM 重新启动设置
配置高可用性
禁用高可用性
更改高可用性设置


关于 XenServer 高可用性

HADropInNtolAlert 7007, MessageAlert_HA_POOL_DROP_IN_PLAN_EXISTS_FOR 7007, HAOvercommittedAlert 7008, MessageAlert_HA_POOL_OVERCOMMITTED 7008

XenServer 高可用性功能允许在基础硬件出现故障或任何托管服务器丢失时自动重新启动虚拟机。高可用性功能可以确保重要的 VM 始终在资源池中运行。启用高可用性功能后，如果一个服务器出现故障，其 VM 将智能地在同一个池中的其他服务器上重新启动，使基本服务在系统或组件出现故障的情况下得以还原，从而最大程度减少服务中断。如果池主服务器出现故障，XenServer 高可用性功能会自动选择一个新服务器来接替主服务器，以便您可以继续管理该池。池中的任何服务器都可以充当主服务器，池数据库不断在所有节点之间进行复制，而且还会备份到检测信号 SR 上的共享存储中，从而提高安全性。

XenServer 高可用性功能包括两个主要方面：可靠地检测服务器故障；计算故障计划以实现快速恢复。下面将详细介绍这两个方面。

Citrix XenServer 高级版或更高版本中提供 XenServer 高可用性功能。要了解有关不同 XenServer 版本中可用功能的详细信息，请单击此处。

通过检测信号判断可用性

您需要远程对服务器暂时消失与灾难性故障加以区分，因此可靠地检测服务器故障比较困难。如果我们错误地认定主服务器已发生故障并选择一个新的主服务器来替代它，则在原始主服务器恢复启动后，可能会出现意外的结果。同样，如果资源池均等地分为两个部分，则当出现网络问题时，我们只需要确保其中的一个部分能够访问共享存储，而不是确保这两个部分能够同时访问共享存储。XenServer 通过提供以下两个机制来解决所有这些问题：存储检测信号和网络检测信号。

如果在池中启用高可用性功能，应指定 iSCSI、光纤通道或 NFS 存储库作为检测信号 SR。XenServer 自动在该 SR 中创建几个小型虚拟磁盘。第一个磁盘是共享仲裁磁盘，由资源池中的各个服务器使用。每个服务器都在共享磁盘中为自己分配一个唯一的区块，并定期向该区块中写入数据以指示服务器处于活动状态。当高可用性功能启动时，所有服务器通过网络和存储通道交换数据，以说明它们通过这两个通道可以看到的服务器，即哪些 I/O 路径有效，哪些 I/O 路径无效。这些活动性信息会一直交换，直到达到某个固定点，并且池中的所有服务器对于彼此就所见内容达成的协议表示满意。出现这种情况时，高可用性功能处于启用状态，并且资源池受到保护。对于较大的池来说，这一高可用性置备过程可能需要几分钟时间，但只有在首次启用高可用性功能时才需要进行此过程。

一旦高可用性功能处于活动状态，每个服务器都会定期向检测信号虚拟磁盘中写入存储更新，并通过管理接口写入网络数据包。应确保绑定网络适配器以保证可靠性，并且存储接口使用动态多路径（如果支持），这两点非常重要。这样可以确保任何单个适配器或连线故障不会导致出现任何可用性问题。

服务器防护

对于高可用性功能而言，最坏的情形是服务器被视为脱机，而实际上它正在等待将数据写入共享存储，因为这种情况会导致持久性数据的损坏。为避免这种情况，XenServer 使用服务器防护功能，即，服务器自动关机并被阻止访问池中的任何共享资源。这样可防止在自动故障转移期间，在将受保护的虚拟机移动到池中其他运行正常的服务器时，出现故障的服务器向任何共享磁盘写入内容而破坏所存储数据的一致性。

除非满足下列任一条件，否则在出现任何检测信号故障时服务器都将进行自我防护（即，关闭电源并重新启动）。

  • 针对所有服务器存在存储检测信号，但是网络已进行分区（此时存在两组服务器）。在这种情况下，最大网络分区中的所有成员服务器仍保持运行状态，较小网络分区中的服务器将进行自我防护。此处假设 VM 已经因网络中断而被隔离，而且应在网络连接正常的服务器上重新启动。如果各个网络分区的大小完全相等，则只有其中一个分区将根据稳定选择功能进行自我防护。
  • 如果存储检测信号消失，但是网络检测信号仍存在，则服务器会检查它们能否通过网络看到所有其他服务器。如果能够看到，则这些服务器仍保持运行状态，但前提是存储检测信号已消失。这样做不会损害 VM 的安全，但是任何网络小问题都会导致服务器进行防护，因为这意味着这两种检测信号都已经消失。

故障容量规划

检测信号系统为我们提供了可靠的服务器故障通知，现在我们继续执行高可用性的第二个步骤：故障容量规划。

一个资源池由多个（例如 16 个）服务器组成，每个服务器上的内存量和正在运行的 VM 数可能各不相同。为了确保任何单个服务器故障都不会导致其 VM 在其他服务器上无法重新启动（例如，由于任何其他服务器上的内存不足），XenServer 高可用性功能将动态计算故障计划，从而计算出在发生任何服务器故障时将执行的操作。除了处理单个服务器的故障外，XenServer 高可用性功能还可以处理池中多个服务器丢失的情况（例如，网络分区故障导致丢失整组服务器）。

除了计算将执行的操作外，故障计划还考虑池中可以容忍的服务器故障数。在计算池的高可用性计划时，有两个重要的考虑因素：

  • 最大故障容量。即允许的最大故障服务器数，超过该值后，资源将不足以运行池中所有受保护的 VM。XenServer 在计算此值时考虑池中 VM 的重启优先级和池的配置（服务器数量以及服务器上的 CPU 和内存容量）。
  • 服务器故障限制。该值作为高可用性配置的一部分在高可用性计划中进行定义，用来指定池中允许的服务器故障数。例如，在由 16 个服务器组成的资源池中，如果将服务器故障限制设置为 3，则 XenServer 计算出的故障转移方案将允许任意 3 个服务器出现故障，而这时仍然能够运行池中所有受保护的 VM。可以将服务器故障限制配置为小于最大故障容量的值，这会降低池被过度使用的可能性。这在启用了 RBAC 的环境中非常有用，例如，可允许没有池操作员权限的 RBAC 用户在不违反高可用性计划的情况下将更多 VM 联机；请参阅下面的高可用性和基于角色的访问控制 (RBAC)。

当最大故障容量值小于指定的服务器故障限制值时，将生成系统警报。

过度使用防护

首次对池启用高可用性时，将基于当时可用的资源计算故障计划。XenServer 高可用性功能会动态计算新故障计划，以响应对池造成影响的事件（例如，启动新的 VM）。如果由于池中的资源不足（例如，可用内存不足，或者对虚拟磁盘和网络进行的更改影响了哪些 VM 可以在哪些服务器上重新启动）而导致无法计算新计划，则池被过度使用。

在池被过度使用时，使用高可用性重启优先级来确定应启动的 VM。在高可用性配置对话框或配置高可用性向导中为要保护的 VM 配置重启优先级时，您可以查看正在动态重新计算的池的最大故障容量，从而根据业务需求尝试使用不同的 VM 重启优先级组合，并了解最大故障容量是否适合于池中关键的 VM 所需的保护级别。

如果您尝试启动或恢复 VM 而该操作将导致池被过度使用，则将在 XenCenter 中显示一个警告。如果配置了一个电子邮件地址，系统还可能会向该电子邮件地址发送警告消息。您将能够取消该操作或者仍然继续操作，但继续操作会导致池被过度使用。

处理启用了高可用性的池

高可用性功能的最佳做法是，在启用了高可用性功能的情况下不对池进行配置更改，而应当实施“2am 保护”，在出现问题后在管理员不在现场的情况下重新启动服务器。如果您主动对池中的配置进行更改（例如应用软件更新），应在执行这些更改期间禁用高可用性功能。

  • 如果您尝试从 XenCenter 关闭受保护的 VM，XenCenter 将允许您首先将该 VM 从池故障计划中删除，然后再将其关闭。这样可以确保不会因意外的 VM 关闭而导致停机，而当您确实需要停止受保护的 VM 时，仍然可以将其停止。
  • 在启用高可用性功能的情况下，如果您需要重新启动服务器，XenCenter 会自动使用 VM 重启优先级来确定这样做是否会违反池故障计划。如果不会影响池故障计划，则服务器将会正常关闭。如果与池故障计划冲突，但最大故障容量大于 1，XenCenter 允许您将池的服务器故障限制减小 1。这样做会降低池的整体可靠性，但却始终确保能够容忍至少一个服务器故障。当服务器重新启动时，系统将自动重新计算池故障计划，并还原原始的服务器故障限制（如果适用）。
  • 使用安装更新向导安装软件更新时，将自动对池禁用高可用性功能，直到更新安装完毕。在安装更新期间，您需要手动监视池，以确保服务器故障不会中断池的运行。
  • 启用高可用性功能后，某些影响 VM 重启计划的操作可能会被禁用，例如从池中删除服务器。要执行这些操作，应当先暂时禁用高可用性功能或者关闭受保护的 VM，然后再继续操作。

高可用性和基于角色的访问控制 (RBAC)

在实现了基于角色的访问控制 (RBAC) 的 XenServer 环境中，并非所有用户都有权更改池的高可用性配置设置。例如，有权启动 VM 的用户（VM 操作员）没有足够的权限来针对启用了高可用性的池调整故障转移容量。例如，如果启动某个 VM 会将所允许的最大服务器故障数减少到小于当前的最大故障容量，则 VM 操作员将无法启动该 VM。只有池管理员或池操作员级别的用户才能够配置所允许的服务器故障数。

在这种情况下，启用高可用性的用户（具有“池管理员”或“池操作员”角色）可以将服务器故障限制设置为实际上小于所允许的最大故障数的值。这会创建容错容量，从而确保权限较低的用户能够启动新的 VM 并降低池的故障转移容量，而不会威胁故障计划。


高可用性要求

为资源池配置高可用性功能前，必须确保池中所有服务器和虚拟机满足以下要求：

  • 必须提供共享存储，其中包括至少一个大小为 356 MB 或更大的 iSCSI、光纤通道或 NFS LUN，供检测信号 SR 使用。如果使用 NetApp 或 EqualLogic 存储阵列，则应在阵列上手动置备一个 iSCSI LUN，供检测信号 SR 使用。
  • 如果启用高可用性功能，强烈建议为池中的服务器使用绑定的管理接口，并且为检测信号 SR 使用多路径存储。
  • 所有服务器上都必须安装充足的许可证。Citrix XenServer 高级版或更高版本中提供 XenServer 高可用性功能。
  • 要通过高可用性功能保护的所有虚拟机必须具有灵活性。这意味着：
    • 虚拟磁盘必须位于共享存储上。可以使用任何类型的共享存储；只有存储检测信号要求使用 iSCSI、光纤通道或 NFS LUN，而对于虚拟磁盘存储，可以根据个人喜好使用这些类型的 LUN，对此没有强制性要求。
    • 虚拟网络接口必须位于池级别的网络中。
    • 不应配置与任何本地 DVD 驱动器的连接。

    对于不具有灵活性的 VM（例如，带有从服务器映射的物理 CD 驱动器），只能分配在可能时重新启动高可用性重启优先级，因为这些 VM 绑定到一个服务器。


VM 重新启动设置

如果出现故障的服务器多于计划的故障数量，将开始执行高可用性恢复操作。高可用性重启优先级用于确定哪些 VM 将重新启动，而各 VM 的启动顺序则由其启动顺序值和延迟间隔值确定，从而确保首先重新启动最重要的 VM。

高可用性重启优先级

高可用性重启优先级指定将根据池的高可用性故障计划而重新启动哪些 VM：

值 | 说明
重新启动 | 如果池中有足够的可用资源，则保证重新启动具有此优先级的 VM。它们将先于优先级为在可能时重新启动的 VM 而重新启动。在计算故障计划时，将考虑具有此重启优先级的所有 VM。如果不存在可使具有此优先级的 VM 可靠地重新启动的计划，则池将被视为过度使用。
在可能时重新启动 | 在计算故障计划时，不考虑具有此重启优先级的 VM，但当运行这些 VM 的服务器出现故障时，将尝试进行一次重新启动。此次重新启动尝试将在所有更高优先级的 VM 重新启动后进行，如果启动尝试失败，则将不再进行重试。此设置对于测试/开发 VM 非常有用，在同时包含一些必须始终运行的重要 VM 的池中，这些 VM 不必始终保持运行，但最好能保持运行。
不重新启动 | 不尝试重新启动具有此优先级的 VM。

重启顺序

重启顺序指定各个 VM 在高可用性恢复操作期间的启动顺序，使某些 VM 先于其他 VM 重新启动。重启顺序值为 0（零）的 VM 将首先启动，重启顺序值为 1 的 VM 接着启动，然后是重启顺序值为 2 的 VM，以此类推。

延迟间隔（尝试在以下时间后启动下一个 VM）

VM 属性尝试在以下时间后启动下一个 VM 用于指定从启动 VM 到尝试启动启动序列中下一组 VM（即，重启顺序紧随其后的 VM）之间的等待时间。


配置高可用性

HAWizard 4500

可以使用配置高可用性向导为资源池启用高可用性功能。该向导将引导您逐步完成高可用性配置过程，根据可用资源和您指定的高可用性重启优先级计算池的服务器故障限制。

要打开配置高可用性向导：在 XenCenter 中，选择池，单击高可用性选项卡，然后单击配置高可用性。

或者：

  • 在池菜单中，单击高可用性。
  • 在资源窗格中单击鼠标右键，然后在快捷菜单中单击高可用性。

为池配置高可用性

  1. 确保满足高可用性要求中列出的高可用性要求。
  2. 打开配置高可用性向导，在向导第一页上单击下一步，以通过扫描该池查找可用作该池检测信号 SR 的共享 iSCSI、光纤通道或 NFS LUN。如果未找到合适的 SR，需要先配置一个适当的新存储才能继续操作。
  3. 从检测信号 SR 页面上的列表中选择一个 SR，然后单击下一步。
  4. 从高可用性计划页面上的列表中，选择一个或多个 VM 并设置所需的 VM 启动设置。有关这些选项的详细信息，请参阅 VM 启动设置。

    要选择多个相邻虚拟机，请单击要选择的第一个虚拟机，在列表中向下滚动，并在按住 SHIFT 键的同时单击您希望选择的最后一个虚拟机。要在列表中选择不相邻的几个虚拟机，请单击第一个虚拟机，按住 CTRL 键，然后单击要选择的其他虚拟机。

    选项 | 说明
    高可用性重启优先级 为每个 VM 选择重启优先级：
    • 选择重新启动可确保在池中有足够资源时重新启动选定的 VM。
    • 如果不一定要自动重新启动 VM，请选择在可能时重新启动。
    • 如果您不希望自动重新启动 VM，请选择不重新启动。
    启动顺序 | 指定各个 VM 在高可用性恢复操作期间的启动顺序，使某些 VM 先于其他 VM 启动。启动顺序值为 0（零）的 VM 将首先启动，启动顺序值为 1 的 VM 接着启动，然后是启动顺序值为 2 的 VM，以此类推。
    尝试在以下时间后启动下一个 VM | 这是一段延迟时间间隔，用于指定从启动 VM 到尝试启动启动序列中下一组 VM（即，启动顺序更靠后的 VM）之间的等待时间。
  5. 在高可用性计划页面的服务器故障限制下，可以设置此高可用性计划中允许的服务器故障数。此值应小于或等于池的最大故障容量（此处表示为最大值）。

    如果最大值为 0（零），则池被过度使用，除非调整高可用性重启优先级或者在池中提供更多的资源，否则将无法继续进入该向导的下一页；请参阅增加池的最大故障容量。

    完成高可用性计划的配置后，单击下一步。

  6. 在该向导的最后一页上，检查高可用性配置设置。单击后退返回并更改任何设置，或者单击完成启用高可用性并关闭该向导。


禁用高可用性

HADisable 4501

启用高可用性后，某些影响虚拟机重新启动方案的操作（例如从池中删除服务器）可能会被禁用。要执行这些操作，可以暂时禁用高可用性。

禁用高可用性

  1. 在资源窗格中选择池，单击高可用性选项卡，然后单击禁用高可用性。
  2. 单击确定进行确认。

系统将存储为池中每个 VM 所指定的 VM 启动设置，如果以后重新启用高可用性功能，这些启动设置将会恢复。


更改高可用性设置

HaNtolZero 3500, TabPageHA 1095

为池启用高可用性功能后，可以从配置高可用性对话框中更改 VM 启动设置并调整池的服务器故障限制。

更改高可用性重启优先级和 VM 启动顺序设置

  1. 在资源窗格中选择所需的池，单击高可用性选项卡，然后单击配置高可用性。

    或者：

    • 在池菜单中，单击高可用性。
    • 在资源窗格中单击鼠标右键，然后在快捷菜单中单击高可用性。
  2. 在列表中选择一个或多个 VM，并设置所需的 VM 启动设置。有关这些选项的详细信息，请参阅 VM 启动设置。

    要选择多个相邻虚拟机，请单击要选择的第一个虚拟机，在列表中向下滚动，并在按住 SHIFT 键的同时单击您希望选择的最后一个虚拟机。要在列表中选择不相邻的几个虚拟机，请单击第一个虚拟机，按住 CTRL 键，然后单击要选择的其他虚拟机。

    选项 | 说明
    高可用性重启优先级 为每个 VM 选择重启优先级：
    • 选择重新启动可确保在池中有足够资源时重新启动选定的 VM。
    • 如果不一定要自动重新启动 VM，请选择在可能时重新启动。
    • 如果您不希望自动重新启动 VM，请选择不重新启动。
    启动顺序 | 指定各个 VM 在高可用性恢复操作期间的启动顺序，使某些 VM 先于其他 VM 启动。启动顺序值为 0（零）的 VM 将首先启动，启动顺序值为 1 的 VM 接着启动，然后是启动顺序值为 2 的 VM，以此类推。
    尝试在以下时间后启动下一个 VM | 这是一段延迟时间间隔，用于指定从启动 VM 到尝试启动启动序列中下一组 VM（即，启动顺序更靠后的 VM）之间的等待时间。
  3. 单击确定，以应用更改并关闭对话框。

更改池的服务器故障限制

  1. 在资源窗格中选择池，单击高可用性选项卡，然后单击配置高可用性。

    或者：

    • 在池菜单中，单击高可用性。
    • 在资源窗格中单击鼠标右键，然后在快捷菜单中单击高可用性。
  2. 在服务器故障限制下，输入允许的服务器故障数。此值应小于或等于池的最大故障容量（此处表示为最大值）。

    如果最大容量为 0（零），则池将被过度使用，除非调整高可用性重启优先级或者在池中提供更多的资源，否则将无法保存所做的更改；请参阅增加池的最大故障容量。

  3. 单击确定，以应用更改并关闭对话框。

增加池的最大故障容量

要增加池的最大故障容量，需要执行以下一项或多项操作：

  • 降低某些 VM 的高可用性重启优先级。
  • 增大服务器上的 RAM 量，或者向池中添加更多的服务器以增加池的容量。
  • 减少在某些 VM 上配置的内存量。
  • 关闭非必要的 VM。


灾难恢复

显示所有文字

灾难恢复 (DR)

主题
关于 XenServer DR
配置 DR
故障转移
故障恢复
测试故障转移


关于 XenServer DR

XenServer 灾难恢复 (DR) 功能旨在允许您从导致整个池或站点被禁用或破坏的灾难性硬件故障中恢复虚拟机和 vApp。为应对单服务器故障，可以使用 XenServer 高可用性功能在同一池中的备用服务器上重新启动 VM。

了解 XenServer DR

XenServer DR 的工作方式是，将恢复业务关键 VM 和 vApp 时所需要的所有信息存储到存储库中，然后将这些存储库从主（生产）环境复制到备份环境中。当主站点上受保护的池关闭时，可以从复制的存储中恢复该池中的 VM 和 vApp，并在辅助 (DR) 站点上重新创建，从而最大程度降低应用程序或用户的停机时间。

当恢复后的 VM 在 DR 池中启动并运行后，也必须将 DR 池元数据保存到复制的存储中，这样当主站点恢复联机后，恢复的 VM 和 vApp 将可以还原到主站点中。

注意：XenServer DR 只适用于 LVM over HBA 或 LVM over iSCSI 存储类型。

XenServer VM 由两个组件构成：

  • 由 VM 使用的虚拟磁盘，存储在 VM 所在池中的已配置存储库 (SR) 中。
  • 描述 VM 环境的元数据。此数据是在原始 VM 不可用或损坏的情况下重新创建 VM 时所需要的全部信息。大多数元数据配置数据都是在 VM 创建时写入的，只有在您对 VM 配置进行更改时才会更新这些数据。对于池中的 VM，此元数据的副本存储在池中的每个服务器上。

在 DR 环境中，将根据池元数据（关于池中所有 VM 和 vApp 的配置信息）在辅助 (DR) 站点上重新创建 VM。每个 VM 的元数据包括其名称、说明和通用唯一标识符 (UUID) 以及其内存、虚拟 CPU 和网络及存储配置。此外还包括 VM 的启动选项（启动顺序、延迟间隔和高可用性重启优先级）；在高可用性或 DR 环境中重新启动 VM 时，将使用这些选项。例如，当在灾难恢复期间恢复 VM 时，vApp 中的各个 VM 将在 DR 池中按照 VM 元数据中指定的顺序以及指定的延迟间隔来重新启动。

XenServer DR 要求

许可证 | XenServer 铂金版
软件版本 | XenServer 6.0 或更高版本
访问权限 | 必须以根用户身份登录，或者具有池操作员或更高权限的角色。

灾难恢复基础结构

要使用 XenServer DR，需要在主站点和辅助站点上都设置适当的 DR 基础结构：

  • 用于池元数据和 VM 所用虚拟磁盘的存储都必须从主（生产）环境复制到备份环境中。存储复制（例如，使用镜像）最好通过存储解决方案进行处理，并且因设备而异。
  • 当 VM 和 vApp 恢复到 DR 站点上的池中并且启动并运行之后，还必须对包含 DR 池元数据和虚拟磁盘的 SR 进行复制，这样，当主站点恢复联机后，恢复的 VM 和 vApp 将可以还原到主站点（故障恢复）。
  • DR 站点的硬件基础结构不必与主站点匹配，但 XenServer 环境的发行版本和修补程序级别必须相同，并且应在目标池中配置充足的资源，以允许重新创建和启动所有故障转移的 VM。

重要提示 XenCenter 和灾难恢复向导不控制任何存储阵列功能。灾难恢复功能的用户必须保证将池元数据以及发生灾难时将重新启动的 VM 所用的存储复制到备份站点中。某些存储阵列包含镜像功能，可以自动执行复制：如果使用这些功能，则在恢复站点上重新启动 VM 之前，必须禁用镜像功能（破坏镜像）。

使用灾难恢复向导进行故障转移、故障恢复和测试故障转移

灾难恢复向导简化了故障转移（将受保护的 VM 和 vApp 恢复到辅助站点）和故障恢复（将 VM 和 vApp 还原到主站点）过程。这两个过程所涉及的步骤概括如下：

故障转移 故障恢复
  1. 在辅助 DR 站点上选择 VM 和 vApp 将恢复到的目标池。
  2. 提供详细信息，指示来自主站点的复制 SR 所在的存储目标。
  3. 该向导扫描目标并列出从中找到的所有 SR。

    现在选择 SR，其中包含要恢复的 VM 和 vApp 的元数据和虚拟磁盘。

  4. 该向导扫描这些 SR 并列出找到的所有 VM 和 vApp。

    现在，选择要恢复到 DR 站点的 VM 和 vApp，并指定您希望这些 VM 和 vApp 在恢复后是由向导立即自动启动，还是等待您手动启动。

  5. 向导执行一些预检，以确保所选的 VM 和 vApp 能够恢复到目标 DR 池，例如，向导检查选定 VM 和 vApp 所需的所有存储是否可用。
  6. 当预检完成并解决了任何问题后，故障转移过程开始。所选 VM 和 vApp 从复制的存储导出到 DR 池。

    故障转移到此完成。
  1. 在主站点上，选择要将当前运行在 DR 站点上的 VM 和 vApp 还原到的目标池。
  2. 提供详细信息，指示来自 DR 站点的复制 SR 所在的存储目标。
  3. 该向导扫描目标并列出找到的所有 SR。

    现在选择 SR，其中包含要还原的 VM 和 vApp 的元数据和虚拟磁盘。

  4. 该向导扫描这些 SR 并列出找到的所有 VM 和 vApp。

    现在，选择要还原到主站点的 VM 和 vApp，并指定您希望这些 VM 和 vApp 在恢复后是由向导立即自动启动，还是等待您手动启动。

  5. 向导随后将执行多项预检查，确保选定的 VM 和 vApp 能够恢复到主站点上的目标池。例如，向导将检查选定 VM 和 vApp 需要的所有存储是否可用。
  6. 当预检完成并解决了任何问题后，故障恢复过程开始。运行在 DR 站点上的所选 VM 和 vApp 从复制的存储导出到主站点上的选定池中。

    故障恢复到此完成。

如果灾难恢复向导在两个或更多位置（例如，主站点上的存储，DR 站点上的存储以及要导入数据的池）找到同一个 VM 的信息，将确保只使用每个 VM 的最新信息。

提示：如果在 SR 的名称中说明 VM 和 vApp 与 SR 以及 SR 与 LUN 的映射关系，从复制的存储恢复 VM 和 vApp 时会更加方便。

还可以使用灾难恢复向导运行测试故障转移，从而对灾难恢复系统进行不间断的测试。在测试故障转移中，所有步骤与故障转移基本相同，但 VM 和 vApp 在恢复到 DR 站点后将以暂停状态启动，并在测试完成后执行清理，以删除在 DR 站点上重新创建的所有 VM、vApp 和存储。请参阅测试故障转移。

XenServer DR 术语

术语 | 定义
vApp | 作为单个实体进行管理的相关 VM 的逻辑组。
站点 | 包含 XenServer 资源池、存储和硬件设备的物理组。
主站点 | 运行在发生灾难时必须受保护的 VM 或 vApp 的物理站点。
辅助站点，DR 站点 | 在发生灾难时用作主站点的恢复位置的物理站点。
故障转移 | 当主站点发生灾难时在辅助（恢复）站点上恢复 VM 和 vApp 的过程。
故障恢复 | 将 VM 和 vApp 从辅助（恢复）站点还原到主站点的过程。
测试故障转移 | 故障转移“试运行”；VM 和 vApp 从复制的存储恢复到辅助（恢复）站点上的池中，但并不实际启动。可以运行测试故障转移来检查 DR 的配置是否正确以及您的处理过程是否有效。
池元数据 | 关于池中的 VM 和 vApp 的信息（例如其名称和说明）以及 VM 的配置信息，包括 UUID、内存、虚拟 CPU、网络和存储配置以及启动选项（启动顺序、延迟间隔和高可用性重启优先级）。在 DR 中，池元数据用于在辅助站点上的恢复池中重新创建主站点上的 VM 和 vApp。

Citrix XenServer 铂金版提供 XenServer 灾难恢复功能。要了解有关不同 XenServer 版本中可用功能的详细信息，请单击此处。


配置 DR

使用 XenCenter 的配置 DR 对话框，可指定将用于存储池元数据（关于池中所有 VM 和 vApp 的配置信息）的存储库。每当对池中的 VM 或 vApp 配置进行更改时，此元数据都会得到更新。

为主池配置 DR

  1. 在主站点上，选择要保护的池，并在池菜单中指向灾难恢复，然后单击配置。
  2. 最多可选择 8 个用来存储池元数据的 SR。在此存储中需要有少量空间用来存储一个新 LUN，其中将包含池恢复信息。

    注意：XenServer DR 只适用于 LVM over HBA 或 LVM over iSCSI 存储类型。

  3. 单击确定。

重要提示 直到包含池元数据和池中 VM 所用虚拟磁盘的 SR 从生产环境复制到备份环境，您的 XenServer DR 环境才算配置完整。存储复制（例如，使用镜像）最好通过存储解决方案进行处理，并且因设备而异；不能在 XenCenter 内对其进行配置。


故障转移

故障转移是指当主站点发生灾难时在辅助（恢复）站点上恢复 VM 和 vApp 的过程。要故障转移重要的 VM 和 vApp，可以使用灾难恢复向导。

重要提示 灾难恢复向导不控制任何存储阵列功能。在您尝试故障转移到恢复站点之前，必须禁止对元数据存储以及要重新启动的 VM 所用的存储进行复制（镜像）。

将 VM 和 vApp 故障转移到辅助站点

  1. 在 XenCenter 中，选择辅助池，并在池菜单中单击灾难恢复以打开灾难恢复向导。
  2. 选择故障转移，然后单击下一步。

    注意：如果通过将光纤通道共享存储与 LUN 镜像功能结合使用的方式将数据复制到辅助站点，则在尝试恢复数据前，必须中断镜像，以使辅助站点具有读/写访问权限。

  3. 选择存储库 (SR)，其中包含要恢复的 VM 和 vApp 的池元数据。

    默认情况下，此向导页面上的列表显示池中当前连接的所有 SR。要扫描查找更多 SR，可选择查找存储库，然后选择要扫描的存储类型：

    1. 要扫描所有可用的硬件 HBA SR，请选择查找硬件 HBA SR。
    2. 要扫描软件 iSCSI SR，请选择查找软件 iSCSI SR，然后在对话框中输入目标主机、IQN 和 LUN 详细信息。

    在向导中选择了所需 SR 后，单击下一步继续。

  4. 选择要恢复的 VM 和 vApp，然后选择适当的恢复后的电源状态选项，以指定您希望这些 VM 和 vApp 是在恢复后立即由向导自动启动，还是等到故障转移完成后由您手动启动。

    单击下一步继续进入下一个向导页面，开始执行故障转移预检。

  5. 向导在开始进行故障转移前会执行一些预检，例如，通过预检确保所选 VM 和 vApp 所需要的所有存储都可用。如果此时缺少任何存储，可以在此页面单击连接 SR，以找到并连接相关 SR。

    解决预检页面上的任何问题，然后单击故障转移开始恢复过程。

  6. 将显示一个进度页面，指示每个 VM 和 vApp 的恢复是否成功。

    故障转移可能需要一些时间，具体取决于要恢复的 VM 和 vApp 的数量，在此期间，将从复制的存储导出 VM 和 vApp 的元数据，在主池中重新创建 VM 和 vApp，将包含虚拟磁盘的 SR 连接到重新创建的 VM，并启动 VM（如果指定）。

  7. 完成故障转移后，单击下一步查看摘要报告。在摘要报告页面上单击完成关闭向导。

当主站点再次可用并且您希望恢复在该站点上运行 VM 时，需要再次执行灾难恢复向导，但这一次需要在第一页上选择故障恢复选项。请参阅故障恢复。


故障恢复

故障恢复是指在主站点经过灾难性事件后恢复联机时，将 VM 和 vApp 从复制的存储还原到主（生产）站点上的池中的过程。要将 VM 和 vApp 故障恢复到主站点，可以使用灾难恢复向导。

重要提示 灾难恢复向导不控制任何存储阵列功能。在您尝试故障恢复到主站点之前，必须禁止对元数据存储以及要还原的 VM 所用的存储进行复制（镜像）。

将 VM 和 vApp 故障恢复到主站点

  1. 在 XenCenter 中，选择主站点上的目标池，并在池菜单中单击灾难恢复以打开灾难恢复向导。
  2. 选择故障恢复，然后单击下一步。

    注意：如果通过将光纤通道共享存储与 LUN 镜像功能结合使用的方式将数据复制到 DR 站点，则在尝试恢复数据前，必须中断镜像，以使主站点具有读/写访问权限。

  3. 选择存储库 (SR)，其中包含要还原到主站点的 VM 和 vApp 的池元数据。

    默认情况下，此向导页面上的列表显示池中当前连接的所有 SR。要扫描查找更多 SR，可选择查找存储库，然后选择要扫描的存储类型：

    1. 要扫描所有可用的硬件 HBA SR，请选择查找硬件 HBA SR。
    2. 要扫描软件 iSCSI SR，请选择查找软件 iSCSI SR，然后在对话框中输入目标主机、IQN 和 LUN 详细信息。

    在向导中选择了所需 SR 后，单击下一步继续。

  4. 选择要还原的 VM 和 vApp，然后选择适当的恢复后的电源状态选项，以指定您希望这些 VM 和 vApp 是在还原后立即由向导自动启动，还是等到故障恢复完成后由您手动启动。

    单击下一步继续进入下一个向导页面，开始执行故障恢复预检。

  5. 向导在开始进行故障恢复前会执行一些预检，例如，通过预检确保所选 VM 和 vApp 所需要的所有存储都可用。如果此时缺少任何存储，可以在此页面单击连接 SR，以找到并连接相关 SR。

    解决预检页面上的任何问题，然后单击故障恢复开始恢复过程。

  6. 将显示一个进度页面，指示每个 VM 和 vApp 的还原是否成功。故障恢复过程可能会需要一些时间，具体取决于要还原的 VM 和 vApp 的数量。
  7. 完成故障恢复后，单击下一步查看摘要报告。在摘要报告页面上单击完成关闭向导。


测试故障转移

故障转移测试是灾难恢复计划中不可或缺的一个组成部分。 可以使用灾难恢复向导对灾难恢复系统执行不间断测试。在测试故障转移期间，所有步骤与故障转移过程基本相同，但 VM 和 vApp 在恢复到 DR 站点后不会启动，而是处于暂停状态。在测试故障转移结束时，将自动删除在 DR 站点上重新创建的所有 VM、vApp 和存储。

在初始配置 DR 以及在支持 DR 的池中进行了重要的配置更改之后，建议您执行测试故障转移，以验证故障转移是否仍正确发挥作用。

对 VM 和 vApp 故障转移到辅助站点执行测试

  1. 在 XenCenter 中，选择辅助池，并在池菜单中单击灾难恢复以打开灾难恢复向导。
  2. 选择测试故障转移，然后单击下一步。

    注意：如果通过将光纤通道共享存储与 LUN 镜像功能结合使用的方式将数据复制到辅助站点，则在尝试恢复数据前，必须中断镜像，以使辅助站点具有读/写访问权限。

  3. 选择存储库 (SR)，其中包含要恢复的 VM 和 vApp 的池元数据。

    默认情况下，此向导页面上的列表显示池中当前连接的所有 SR。要扫描查找更多 SR，可选择查找存储库，然后选择要扫描的存储类型：

    1. 要扫描所有可用的硬件 HBA SR，请选择查找硬件 HBA SR。
    2. 要扫描软件 iSCSI SR，请选择查找软件 iSCSI SR，然后在对话框中输入目标主机、IQN 和 LUN 详细信息。

    在向导中选择了所需 SR 后，单击下一步继续。

  4. 选择要恢复的 VM 和 vApp，然后单击下一步继续进入下一个向导页面，开始故障转移预检。
  5. 在开始测试故障转移过程之前，向导将执行一些预检，例如，通过预检确保所选 VM 和 vApp 所需要的所有存储都可用。
    1. 检查存储是否可用。如果缺少任何存储，可在此页面上单击连接 SR，以找到并连接相关 SR。
    2. 确认未对目标 DR 池启用高可用性。为避免在主池和 DR 池上同时运行相同的 VM，必须对辅助池禁用高可用性，以确保在恢复后高可用性功能不会自动启动恢复后的 VM 和 vApp。要对辅助池禁用高可用性，只需在此页上单击禁用高可用性即可。（如果此时禁用高可用性，在测试故障转移过程结束时将自动重新启用该功能。）

    解决预检页面上的任何问题，然后单击故障转移开始测试故障转移。

  6. 将显示一个进度页面，指示每个 VM 和 vApp 的恢复是否成功。

    故障转移可能需要一些时间，具体取决于要恢复的 VM 和 vApp 的数量，在此期间，将从复制的存储恢复 VM 和 vApp 的元数据，在 DR 池中重新创建 VM 和 vApp，将包含虚拟磁盘的 SR 连接到重新创建的 VM。

    恢复后的 VM 将置于暂停状态：在测试故障转移期间，这些 VM 在辅助站点上不会启动。

  7. 确认测试故障转移成功执行后，在向导中单击下一步，使向导在 DR 站点上执行清理工作：
    • 将删除测试故障转移期间恢复的 VM 和 vApp。
    • 将断开测试故障转移期间恢复的存储。
    • 如果在预检阶段为执行测试故障转移而禁用了 DR 池的高可用性功能，将自动重新启用高可用性。

    向导将显示清理过程的进度。

  8. 单击完成关闭向导。


访问控制 (RBAC)

显示所有文字

访问控制（AD 和 RBAC）

主题
管理用户
RBAC 概述
RBAC 角色和权限定义
加入域并添加用户
为用户和组分配角色
计算 RBAC 角色
审核对 XenServer 进行的更改


管理用户

首次安装 XenServer 时，会自动将一个用户帐户添加到 XenServer 中。此帐户是本地超级用户 (LSU)（或称根用户），由 XenServer 计算机在本地进行身份验证。您可以通过在 XenCenter 的用户选项卡上添加 Active Directory 帐户，来创建其他用户。（请注意，此处的“用户”一词是指具有 XenServer 帐户的任何人，即管理 XenServer 的任何人，而与这些人的角色级别无关。）如果您希望在服务器或池上具有多个用户帐户，则必须使用 Active Directory 用户帐户进行身份验证。这样，XenServer 用户将可以使用其 Windows 域凭据登录池中的服务器。

注意：不支持混合身份验证池（也就是说，不能将池中的某些服务器配置为使用 Active Directory，而某些服务器则不使用）。

所有版本的 XenServer 都可以从 Active Directory 添加用户帐户。但是，只有 XenServer 企业版和铂金版允许通过基于角色的访问控制 (RBAC) 功能，根据用户的角色为这些 Active Directory 帐户分配不同的权限等级。如果在您的环境中未使用 Active Directory，则只能使用 LSU 帐户。

首次添加用户帐户时分配给用户的权限因 XenServer 版本而异：

  • 在 XenServer 和 XenServer 高级版中创建（添加）新用户时，XenServer 会自动为帐户授予该版本所提供的所有功能的访问权限。
  • 在 XenServer 企业版和铂金版中创建新用户时，XenServer 不会自动为新创建的用户帐户分配角色。因此，在您为这些帐户分配角色之前，它们对 XenServer 池没有任何访问权限。

XenServer 环境中的 AD 身份验证

虽然 XenServer 基于 Linux，但 XenServer 允许您将 Active Directory 帐户用作 XenServer 用户帐户。为此，XenServer 会将 Active Directory 凭据传递到 Active Directory 域控制器。

添加到 XenServer 后，Active Directory 用户和组即成为 XenServer 使用者，在 XenCenter 中通常简单地称之为用户。在 XenServer 中注册使用者后，用户/组在登录时会通过 Active Directory 进行身份验证，并且不需要用域名来限定其用户名。

注意：默认情况下，如果您未限定用户名（例如，输入 mydomain\myuser 或 myser@mydomain.com），XenCenter 始终会尝试使用用户当前加入的域将用户登录到 Active Directory 身份验证服务器。LSU 帐户属例外情况，对于 LSU 帐户，XenCenter 始终首先在本地（即在 XenServer 上）进行身份验证。

外部身份验证工作流程如下：

  1. 将连接服务器时提供的凭据传递到 Active Directory 域控制器，进行身份验证。
  2. 域控制器对凭据进行检查。如果凭据无效，身份验证立即失败。
  3. 如果凭据有效，将查询 Active Directory 控制器，以获取与凭据相关联的使用者标识符和组成员身份。
  4. 如果使用者标识符与 XenServer 中存储的某个标识符相匹配，即可成功完成身份验证。

您加入域后，可以为池启用 Active Directory 身份验证。但是，当池加入域后，只有该域（或与该域具有信任关系的域）中的用户才能连接该池。


RBAC 概述

通过 XenServer 基于角色的访问控制 (RBAC)，可以为 Active Directory 用户和组分配预定义的角色（或称 XenServer 权限集）。这些权限用于控制 XenServer 用户（即管理 XenServer 的人员）对服务器和池所拥有的访问级别：RBAC 在池级别配置和部署。由于用户通过分配的角色获取权限，因此您只需要为用户或其所在的组分配角色。

为 XenServer 用户帐户使用 Active Directory 帐户

通过 RBAC，您可以对不同用户组可执行的操作进行限制，从而降低缺乏经验的用户进行灾难性意外更改的可能性。分配 RBAC 角色还有助于防止资源池在未经授权的情况下被更改，从而确保合规性。为了便于检查合规性和进行审核，RBAC 还提供了审核日志功能及其相应的 Workload Balancing 池审核追踪报告。

RBAC 基于 Active Directory 提供身份验证服务。具体而言，XenServer 会保留基于 Active Directory 用户和组帐户的授权用户列表。因此，您必须将池加入域并添加 Active Directory 帐户，然后才能分配角色。

只有 Citrix XenServer 企业版或更高版本才提供 RBAC 功能。要了解有关不同 XenServer 版本中可用功能的详细信息，请单击此处。

如果您没有上述版本，可以从 Active Directory 添加用户。但是，所有用户都将具有池管理员角色。

RBAC 流程

实施 RBAC 并为用户或组分配角色的标准流程如下：

  1. 加入域。
  2. 添加 Active Directory 用户或组到池中。
  3. 为用户或组分配（或修改）RBAC 角色。

本地超级用户

本地超级用户 (LSU)（或称根用户）是用于系统管理的特殊用户帐户，具有完全权限。在 XenServer 中，本地超级用户是安装时的默认帐户。LSU 通过 XenServer 而非外部身份验证服务进行身份验证。这意味着，如果外部身份验证服务失败，LSU 仍可以登录并管理系统。LSU 始终可以通过 SSH 访问 XenServer 物理服务器。

RBAC 角色

XenServer 附带六个预定义角色，这些角色旨在对应于 IT 组织中的不同职能。

  • 池管理员。此角色是权限最大的可用角色。池管理员对所有 XenServer 功能和设置都具有完全访问权限。池管理员可以执行所有操作（包括角色和用户管理），可以授予对 XenServer 控制台的访问权限。Citrix 建议的最佳做法是将此角色分配给极有限的用户。

    注意：本地超级用户（根用户）始终具有池管理员角色。池管理员角色与本地根用户具有相同的权限。

  • 池操作员。获得此角色的人员可以管理池范围的资源（包括创建存储、管理服务器、管理修补程序和创建池）。池操作员可以配置池资源。池操作员还对以下功能具有完全访问权限：高可用性、Workload Balancing 和修补程序管理。池操作员不能添加用户或修改角色。
  • 虚拟机超级管理员（VM 超级管理员）。此角色具有完全的 VM 和模板管理权限。他们可以选择 VM 的启动位置，并且对动态内存控制功能和 VM 快照功能具有完全访问权限。此外，他们还可以设置主服务器并选择工作负载的运行位置。分配此角色后，被授权人将具有足够的权限来置备虚拟机，以供 VM 操作员使用。
  • 虚拟机管理员（VM 管理员）。此角色可以管理 VM 和模板，并且可以访问必要的存储来完成这些任务。但是，此角色依赖于 XenServer 来选择工作负载的运行位置，并且必须使用模板中的动态内存控制和主服务器设置。（此角色无法访问动态内存控制功能、生成快照、设置主服务器或选择工作负载的运行位置。）
  • 虚拟机操作员（VM 操作员）。此角色可以使用池中的 VM 并管理这些 VM 的基本生命周期。如果有足够的可用硬件资源，VM 操作员可以与 VM 控制台交互并启动或停止 VM。同样，VM 操作员也可以执行生命周期的启动和停止操作。VM 操作员角色不能创建或销毁 VM，也不能更改 VM 属性或服务器属性。
  • 只读。此角色只能查看资源池和性能数据。

有关每个角色所关联的权限的信息，请参阅 RBAC 角色和权限定义。有关 RBAC 如何为用户计算所应用角色的信息，请参阅计算 RBAC 角色。

注意：如果在创建新用户帐户时没有为其分配角色，XenServer 会自动为其分配池管理员角色。但是，在 XenServer 企业版和铂金版中，当您创建新用户时，XenServer 不会自动为新创建的用户帐户分配角色。您必须单独为新帐户分配角色。

从旧版本 XenServer 升级

RBAC 支持功能自 XenServer 5.6 版本起引入。在升级到 XenServer 5.6 或更高版本时，系统会为在 XenServer 早期版本中创建的任何用户帐户分配池管理员角色。这样做是为了实现向后兼容。从早期版本的 XenServer 进行升级时，应重新访问与每个用户帐户相关联的角色，以确保角色仍然适用。


RBAC 角色和权限定义

每个角色的可用权限

下表汇总了每个角色的可用权限。有关每种权限可执行的操作的详细信息，请参阅权限定义。

权限 | 池管理员 | 池操作员 | VM 超级管理员 | VM 管理员 | VM 操作员 | 只读
分配/修改角色 | X |  |  |  |  |
登录（物理）服务器控制台（通过 SSH 和 XenCenter） | X |  |  |  |  |
服务器备份/还原 | X |  |  |  |  |
导入/导出 OVF/OVA 包；导入磁盘映像 | X |  |  |  |  |
注销活动的用户连接 | X | X |  |  |  |
创建和解除警报 | X | X |  |  |  |
取消任何用户的任务 | X | X |  |  |  |
池管理 | X | X |  |  |  |
VM 高级操作 | X | X | X |  |  |
VM 创建/销毁操作 | X | X | X | X |  |
VM 更改 CD 介质 | X | X | X | X | X |
VM 更改电源状态 | X | X | X | X | X |
查看 VM 控制台 | X | X | X | X | X |
XenCenter 视图管理操作 | X | X | X | X | X |
取消自己的任务 | X | X | X | X | X | X
阅读审核日志 | X | X | X | X | X | X
配置、初始化、启用、禁用 WLB | X | X |  |  |  |
应用 WLB 优化建议 | X | X |  |  |  |
修改 WLB 报告订阅 | X | X |  |  |  |
接受 WLB 放置建议 | X | X | X |  |  |
显示 WLB 配置 | X | X | X | X | X | X
生成 WLB 报告 | X | X | X | X | X | X
连接池并阅读所有池元数据 | X | X | X | X | X | X

权限定义

下表提供了有关权限的其他详细信息：

权限 允许被授权人执行的操作 理由/备注
分配/修改角色
  • 添加和删除用户
  • 添加和删除用户的角色
  • 启用和禁用 Active Directory 集成（加入域）

此权限允许用户为自己授予任何权限或执行任何任务。

警告：此角色允许用户禁用 Active Directory 集成以及从 Active Directory 添加的所有使用者。

登录服务器控制台
  • 通过 SSH 访问服务器控制台
  • 通过 XenCenter 访问服务器控制台
警告：具备对根 shell 的访问权限后，被授权人可以自由地重新配置整个系统（包括 RBAC）。
服务器备份/还原
VM 创建/销毁操作
  • 备份和还原服务器
  • 备份和还原池元数据

具备还原备份的能力后，被授权人可以还原 RBAC 配置更改。

导入/导出 OVF/OVA 包；导入磁盘映像
  • 导入 OVF 和 OVA 包
  • 导入磁盘映像
  • 将 VM 导出为 OVF/OVA 包
注销活动的用户连接
  • 将已登录用户断开连接
创建/解除警报

警告：具有此权限的用户可以解除整个池的警报。

注意：查看警报的能力属于连接池并读取所有池元数据权限。

取消任何用户的任务
  • 取消任何用户正在运行的任务
此权限允许用户请求 XenServer 取消由任何用户启动并且正在执行的任务。
池管理
  • 设置池属性（命名、默认 SR）
  • 启用、禁用和配置高可用性
  • 设置每个 VM 的高可用性重启优先级
  • 配置 DR、执行 DR 故障转移、故障恢复以及测试故障转移操作
  • 启用、禁用和配置 Workload Balancing (WLB)
  • 在池中添加和删除服务器
  • 紧急转换到主节点
  • 紧急主节点寻址
  • 紧急恢复从属节点
  • 指定新的主节点
  • 管理池和服务器证书
  • 修补
  • 设置服务器属性
  • 配置服务器日志记录
  • 启用和禁用服务器
  • 关闭、重新启动和打开服务器
  • 系统状态报告
  • 应用许可证
  • 因 WLB、维护模式或高可用性而将服务器上的所有其他 VM 实时迁移到其他服务器
  • 配置服务器管理接口
  • 禁用服务器管理
  • 删除故障转储
  • 添加、编辑和删除网络
  • 添加、编辑和删除 PBD/PIF/VLAN/Bond/SR
 此权限包括维护池所需执行的所有操作。注意：如果管理接口无法使用，则除本地根用户登录外，其他登录均无法通过身份验证。
VM 高级操作
  • 调整 VM 内存（通过动态内存控制）
  • 创建包含内存数据的 VM 快照、生成 VM 快照及回滚 VM
  • 迁移 VM
  • 启动 VM，包括指定物理服务器
  • 恢复 VM
此权限为被授权人提供足够的权限，使其能够在对所选 XenServer 服务器不满意时在其他服务器上启动 VM。
VM 创建/销毁操作
  • 安装和删除 VM
  • 克隆/复制 VM
  • 添加、删除和配置虚拟磁盘/CD 设备
  • 添加、删除和配置虚拟网络设备
  • 导入/导出 XVA 文件
  • VM 配置更改
VM 更改 CD 介质
  • 弹出当前的 CD
  • 插入新 CD
VM 更改电源状态
  • 启动 VM（自动放置）
  • 关闭 VM
  • 重新启动 VM
  • 挂起 VM
  • 恢复 VM（自动放置）
 此权限不包括启动、恢复和迁移，这三项操作属于 VM 高级操作权限。
查看 VM 控制台
  • 查看 VM 控制台并与之交互
此权限不允许用户查看服务器控制台。
配置、初始化、启用、禁用 WLB
  • 配置 WLB
  • 初始化 WLB 和更改 WLB 服务器
  • 启用 WLB
  • 禁用 WLB
如果用户的角色不具有此权限，则此功能不可见。
应用 WLB 优化建议
  • 应用 WLB 选项卡中显示的所有优化建议
修改 WLB 报告订阅
  • 更改生成的 WLB 报告或其接收者
接受 WLB 放置建议
  • 选择一种服务器 Workload Balancing 放置建议（“星级”建议）
显示 WLB 配置
  • 查看 WLB 选项卡上显示的池 WLB 设置
生成 WLB 报告
  • 查看和运行 WLB 报告，其中包括“池审核追踪”报告
XenCenter 视图管理操作
  • 创建和修改全局 XenCenter 文件夹
  • 创建和修改全局 XenCenter 自定义字段
  • 创建和修改全局 XenCenter 搜索

文件夹、自定义字段和搜索在访问池的所有用户之间共享

取消自己的任务
  • 允许用户取消自己的任务
阅读审核日志
  • 下载 XenServer 审核日志
连接池并阅读所有池元数据
  • 登录池
  • 查看池元数据
  • 查看历史性能数据
  • 查看登录的用户
  • 查看用户和角色
  • 查看任务
  • 查看消息
  • 注册和接收事件


加入域并添加用户

为用户或组帐户分配 RBAC 角色前，必须通过 RBAC 将帐户添加到 XenServer 中。这需要执行两项任务：

  1. 将池或服务器加入域中。该域可以是用户或组所属的域，也可以是位于同一个 Active Directory 林中或者与用户所在域具有信任关系的域。
  2. 将用户的 Active Directory 帐户或组添加到 XenServer 中。

在免费 XenServer 产品和 XenServer 高级版中，在将用户的 Active Directory 帐户或组添加到 XenServer 中后，系统会自动为用户分配一个固定的角色：池管理员。在 XenServer 企业版和更高版本中，则必须手动为用户或组分配角色。

要更改域，请离开当前的域，然后加入新域。

将 XenServer 或池加入域

  1. 在资源窗格中，选择要为其中的用户赋予权限的池或服务器。
  2. 单击用户选项卡。
  3. 单击加入域。
  4. 输入 Active Directory 凭据，该凭据应具有足够的权限来将服务器添加到要加入的域中。必须以完全限定名称 (FQDN) 而不是 NetBIOS 名称来指定要加入的域。例如，输入 your_domain.net 而不是 your_domain。

将 Active Directory 用户或组添加到池中

  1. 加入用户所在域后，请在用户选项卡中，单击添加。
  2. 在添加用户对话框中，输入一个或多个用户名或组名。多个名称以逗号分隔。

    要指定其他受信任域（而非当前所加入的域）中的用户，请提供域名及用户名（例如，other_domain\jsmith）或输入完全限定域名 (FQDN)（例如，jsmith@other_domain.com）。

  3. 单击授予访问权限。
  4. 在 XenServer 企业版和更高版本中，按照为用户和组分配角色中的说明为帐户分配角色并授予访问权限。

离开域

注意：在离开域（即，禁用 Active Directory 身份验证，并断开池或服务器与其所属域的连接）时，通过 Active Directory 凭据向池或服务器进行身份验证的所有用户也将断开连接。

  1. 在资源窗格中，选择要与所属 Active Directory 域断开连接的池或服务器。
  2. 单击离开域并选择是继续操作。
  3. 输入 Active Directory 凭据，该凭据应具有足够的权限在要离开的域中禁用服务器。
  4. 决定是否在 Active Directory 服务器中禁用计算机帐户，然后单击以下选项之一：
    • 禁用。从域中删除池或服务器，并在 Active Directory 数据库中禁用服务器或池主服务器的计算机帐户。
    • 忽略。如果您未填写用户名/密码，或者您不知道具有足够权限来从 Active Directory 数据库中删除服务器或池主服务器计算机帐户的帐户，请选择此选项。（此选项将从域中删除池或服务器，但将服务器或池主服务器的计算机帐户保留在 Active Directory 中。）


为用户和组分配角色

所有 XenServer 用户都必须具有 RBAC 角色。添加新用户后，系统会自动为新用户分配“池管理员”角色。在 XenServer 企业版和更高版本中，当您添加新用户时，XenServer 不会自动为新添加的用户帐户分配角色。您必须单独为新帐户分配角色。

加入关联的域后，您必须先将用户或组的 Active Directory 帐户添加到 XenServer 中，然后才能为用户或组分配角色，如加入域并添加 RBAC 用户中所述。

可以通过以下方法之一为用户分配其他角色：

  1. 在 XenCenter 的选择角色对话框中更改分配给用户的角色。此操作需要分配/修改角色权限，该权限仅适用于池管理员。
  2. 在 Active Directory 中修改用户的所属组成员身份（使用户成为具有其他角色的组的成员）。

如果管理员有时候间接为用户应用多个角色（例如，使用户成为多个组的成员），XenServer 会将为其分配的最高角色的权限授予该用户。

为用户或组更改或分配角色

  1. 在资源窗格中，选择包含该用户或组的池或服务器。
  2. 单击用户选项卡。
  3. 在具有访问权限的用户和组窗格中，选择要分配权限的用户或组。
  4. 单击更改角色。
  5. 在选择角色对话框中，选择要应用的角色，然后单击保存。有关每个角色所关联的权限的信息，请参阅 RBAC 角色和权限定义。

    提示：分配角色时，可以在按住 CTRL 键的同时选择用户帐户，从而同时选择多个用户。

  6. （可选）更改角色时，如果用户当前已登录到池并且您希望他们立即收到新权限，请单击注销用户 。此操作将断开该用户在池中的所有会话，以便该用户以修改后的角色接收新会话。

注意：更改角色时，要使新角色生效，用户必须先注销，然后重新登录。您可以通过单击注销用户按钮将此用户强制注销。（强制注销操作需要注销活动用户连接权限，该权限适用于池管理员或池操作员）。


计算 RBAC 角色

在我登录时，XenServer 如何计算用于该会话的角色？

  1. Active Directory 服务器对使用者进行身份验证。在身份验证期间，Active Directory 还将确定该使用者是否属于 Active Directory 中的任何其他包含组。
  2. 然后，XenServer 将确认已经为 (a) 使用者 (b) 使用者所属的任何 Active Directory 组分配了角色。
  3. XenServer 为使用者应用最高级别的权限。由于使用者可以是多个 Active Directory 组的成员，因此，使用者会继承关联角色的所有权限。

在上图中，由于使用者 2（组 2）是池操作员，而用户 1 是组 2 的成员，因此，使用者 3（用户 1）尝试登录时，会同时继承使用者 3（VM 操作员）和组 2（池操作员）的角色。由于池操作员角色的级别更高，因此，使用者 3（用户 1）的最终角色是池操作员而非 VM 操作员。


审核更改

在 XenServer 中，XenServer 审核日志默认情况下处于启用状态，该日志将记录由已知用户执行的具有副作用（成功或失败）的任何操作。其中包括：

  • 执行该操作的用户的名称。如果无法获得该用户的名称，XenServer 会改为记录其用户 ID。
  • 该操作所针对的服务器的名称。
  • 该操作的状态 - 操作是否成功以及是否经过授权。如果该操作失败，则将记录错误代码。

默认情况下，XenServer 的审核日志记录功能始终处于启用状态。可以使用 XenServer syslog 命令将审核日志复制到安全位置，从而备份审核日志。syslog 命令可以从 CLI 访问，在《XenServer 管理员指南》中进行了介绍。

尽管 Citrix 强烈建议关注审核工作的客户实施基于角色的访问控制，但是审核日志本身既不需要用户具有 RBAC 角色，也不需要 Active Directory 集成。

XenServer 将记录池级别的操作，并在池主服务器上为每个池创建一个日志。

要显示审核日志，可以使用两种可选方法。您可以：

  • 生成池审核追踪报告（在 Workload Balancing 报告词汇表中介绍），但前提是要启用 Workload Balancing。
  • 在任何文本编辑器中打开审核日志，以显示日志内容。审核日志存储在池主服务器上。


监视系统性能

主题
关于性能监视
查看性能数据
配置性能图表
配置性能警报


关于性能监视

使用 XenCenter 中的性能选项卡可以实时监视各个资源池的性能统计信息，以及以图表形式显示虚拟机和物理机的性能趋势。

  • 可以查看最长 12 个月的性能数据，并可将数据放大，以便更清楚地查看活动高峰。
    要了解更多信息，请参阅查看性能数据。
  • 默认情况下，显示 CPU、内存、网络和磁盘 I/O 的图表包含在该选项卡中，但您可以添加更多性能数据并更改图表外观。
    要了解更多信息，请参阅配置性能图表。
  • 可以使 XenCenter 在托管服务器或虚拟机上的 CPU、网络 I/O 或磁盘 I/O 使用率超出指定阈值时，生成性能警报。
    要了解更多信息，请参阅配置性能警报。

请注意，只有安装了 XenServer 半虚拟化驱动程序 (XenServer Tools) 的虚拟机才可以获得全部性能数据。

Citrix XenServer 高级版或更高版本中提供高级性能报告和警报功能。要了解有关不同 XenServer 版本中可用功能的详细信息，请单击此处。


查看性能数据

TabPagePerformance 1090

性能选项卡以图表形式显示选定服务器或虚拟机的性能数据。

对于服务器，可以查看以下内容：

  • CPU、内存和网络 I/O 使用率数据，如果需要，可以添加显示其他资源使用情况数据的图表。例如，可以添加控制域负载图表：等于过去 5 分钟在 XenServer 控制域 (dom0) 内排队的进程数平均值 (Linux loadavg)。
  • 服务器上托管的所有 VM 的生命周期事件显示在 VM 生命周期事件窗格中。

对于虚拟机，默认情况下所显示的图表中会显示 CPU、内存、网络 I/O 和磁盘使用率数据。

使用该选项卡底部的摘要图，可以快速查看计算机上发生的事件摘要，并可以调整在其他图表中显示的时间范围，以显示更长期或更短期的数据，或者显示早期的数据。

要在该选项卡中添加其他类型的性能数据或者更改图表外观，请参阅配置性能图表。

查看长期或短期数据

默认情况下显示前 10 分钟的数据。要查看更长期或更短期的数据，请执行以下操作之一：

  • 要查看上一小时、前 24 小时、上周、上月或去年的可用性能数据，请单击缩放，然后选择 1 小时、1 天、1 周、1 月或 1 年。
  • 要重新调整图表中显示的时间段，可以在摘要图中，将鼠标指针指向示例面积图边缘的垂直拆分条。当鼠标指针变为双向箭头 [image] 时，向右或向左拖动垂直拆分条。例如：

查看不同时段的数据

要移动图表中显示的数据的时间范围，可以指向任意图表，当指针变为移动光标 [image] 时，只需将图表或摘要图中的示例面积图向左或向右拖动。例如：

查看服务器上 VM 的生命周期事件数据

要查看服务器上托管的 VM 的生命周期事件，可以使用 VM 生命周期事件列表。

  • 每个事件都有一个含有该生命周期事件的完整消息的工具提示（“虚拟机“apollo”已启动”）。
  • 可以使用光标键在列表的项中导航。
  • 双击图表或按 ENTER 键可以将图表缩放到选定生命周期事件发生时的大小。
  • 选择（单击或用光标键突出显示）一个事件可以突出显示图表本身的生命周期事件。

请注意，要查看比前 24 小时更长时间的性能数据，需要使用 Citrix XenServer 高级版或更高版本。要了解有关不同 XenServer 版本中可用功能的详细信息，请单击此处。


配置性能图表

ConfigureGraphsDialogVM 6820, ConfigureGraphsDialogHost 6821

添加新图表

  1. 在性能选项卡上，单击操作，然后单击新建图表。此时将显示新建图表对话框。
  2. 在名称字段中输入图表的名称。
  3. 从数据源列表中，选中图表中要包含的数据源对应的复选框。
  4. 单击保存。

编辑图表

  1. 导航到性能选项卡，然后选择要编辑的图表。
  2. 单击操作，然后单击编辑图表。
  3. 在图表详细信息窗口中进行必要的更改，然后单击确定。

删除图表

  1. 从性能选项卡上显示的图表列表中，选择要删除的图表。
  2. 单击操作，然后单击删除图表。
  3. 单击是确认删除。

对图表重新排序

  1. 导航到性能选项卡，然后选择要重新排序的图表。
  2. 单击上移或下移选项卡从当前位置移动图表。

更改图表中的数据源颜色

  1. 导航到性能选项卡。
  2. 双击要更改数据源颜色的图表。此时将显示图表详细信息对话框。
  3. 单击所需数据源对应的彩色复选框，然后从颜色选取器中选择新的颜色。
  4. 单击确定进行确认。

更改图表类型

可以采用线图或面积图的形式来显示性能图表中的数据：

线图：

面积图：

要更改图表类型，请执行以下操作：

  1. 在工具菜单中，单击选项，然后单击图表选项卡。
  2. 要以线图形式查看性能数据，请单击线图单选按钮。
  3. 要以面积图形式查看性能数据，请单击面积图单选按钮。
  4. 单击确定保存更改。


配置性能警报

可以将 XenCenter 配置为当托管服务器或虚拟机上的 CPU、网络 I/O 或磁盘 I/O 使用率超出指定阈值时，生成警报。默认情况下，警报重复间隔为 60 分钟，但您也可以配置此间隔。

性能警报将显示在系统警报窗口中（单击 XenCenter 窗口右上角的系统警报可以访问该窗口）。此外，还可以通过电子邮件接收性能警报及其他严重系统警报：请参阅 XenCenter 系统警报。

配置性能警报

  1. 在资源窗格中选择服务器或虚拟机，单击常规选项卡，然后单击属性。
  2. 单击警报选项卡，然后：
    • 要请求服务器或虚拟机的 CPU 性能警报，请选中生成 CPU 使用率警报复选框，然后设置将触发该警报的 CPU 使用率和时间阈值。
    • 要请求服务器或虚拟机的网络性能警报，请选中生成网络使用率警报复选框，然后设置将触发该警报的网络 I/O 使用率和时间阈值。
    • 要请求虚拟机的磁盘使用率性能警报，请选中生成磁盘使用率警报复选框，然后设置将触发该警报的磁盘 I/O 使用率和时间阈值。
    • 要更改警报重复间隔，请在警报重复间隔框中输入分钟数。达到警报阈值并生成一个警报后，只有在经过警报重复间隔时间，才会生成其他警报。
  3. 单击确定，以保存更改并关闭对话框。


更新和升级

主题
关于软件更新和升级
更新托管服务器 –“安装更新”向导
升级托管服务器 –“滚动池升级”向导
更新 XenCenter
自动更新通知


关于软件更新和升级

HelpIDs:GuiOutOfDateAlert 7006

软件升级是 XenServer 主要独立版本的升级。通过升级添加新功能或新技术，或者替换不再受支持的版本。软件更新将更新 XenServer 的主要版本，但不将其升级到下一个主要版本。

默认情况下，XenCenter 配置为定期自动检查 XenServer 和 XenCenter 的新更新和升级版本，当有新的可用更新或产品版本时，您将收到通知。建议您安装所有已发布的更新。您可以随时检查可用更新，并验证是否正在运行最新版本的 XenServer 和 XenCenter，方法是选择工具 > 检查更新选项。

对 XenServer 主机应用更新

XenServer 更新以文件扩展名为 .xsupdate（对于运行早期版本 XenServer 的嵌入服务器为 .xsoem）的文件形式提供。下载 XenServer 更新（包括关键更新、修补程序和安全更新）后，可以将更新快速应用到托管服务器。有关详细信息，请参阅更新托管服务器。

更新所用版本的 XenCenter

XenCenter 更新以 Windows 安装程序 (.msi) 包的形式提供，可以使用下载管理器进行下载和安装；请参阅更新 XenCenter。

升级 XenServer 主机

要升级 XenServer 主机，请使用滚动池升级向导。可以使用此向导升级池中的多台服务器，同时最大程度减少针对所运行 VM 造成的服务中断。在依次对每台服务器应用升级时，VM 会自动迁移到其他可用服务器上。此向导也可用于升级单台服务器。

请参阅升级托管服务器。

注意：如果出于任何原因，滚动池升级向导无法将 VM 迁移回池主服务器，则池升级将停止，使池处于部分得到升级的状态。Citrix 建议您退出滚动池升级向导，并解决引起迁移问题的原因，然后将 VM 手动迁移回池主服务器，再重新启动滚动池升级向导继续池升级。


更新托管服务器

HelpIDs:PatchingWizard_ApplyUpdatePane 6315, PatchingWizard_SelectPatchPane 6315, PatchingWizard_SelectServersPane 6315, PatchingWizard_UpdateModePane 6315, PatchingWizard_UpdatePrechecksPane 6315, SelectVMsToSuspendDialog 6281

XenServer 更新以文件扩展名为 .xsupdate（对于运行早期版本 XenServer 的嵌入服务器为 .xsoem）的文件形式提供。您必须始终同时更新池中的所有服务器。在常规操作中，不支持运行同时包含更新服务器和未更新服务器的池，因为这时池中服务器之间的通信可能会中断或者无法正常进行。

重要提示 - 您必须在安装更新前重新启动所有服务器，然后验证服务器的配置，例如检查 VM 是否启动以及存储是否可访问。这是因为某些配置更改只有在服务器重新启动后才会生效，因此，重新启动可能会解决导致更新失败的配置问题。

您可以采用以下方法之一将更新安装到托管服务器上：

  • 检查更新窗口提供了用于检查可用更新、下载更新和将更新应用到托管服务器的自动化机制。
  • 安装更新
    • 向导将引导您逐步完成整个过程，将之前下载的更新应用到托管服务器上。

    注意：您可以使用检查更新窗口将更新应用到正在运行 XenServer 6.0 或更高版本的服务器上。要将更新应用到正在运行 XenServer 5.6 Service Pack 2 或早期版本的服务器上，请参阅使用“安装更新”向导应用更新。

    使用“检查更新”窗口应用更新

    1. 从 XenCenter 菜单中，选择工具，然后选择检查更新。此时将显示检查更新窗口。
    2. 从更新列表中选择所需更新，然后单击下载并安装按钮。
      该操作将解压缩更新，然后在预检查页面上打开安装更新向导，此时已将更新文件加载到向导中，且相关服务器处于选定状态。

      注意：除其他更新之外，检查更新窗口还会列出所有 XenServer 新版本。有关使用“滚动池升级”向导升级 XenServer 主机的信息，请参阅升级托管服务器。

    3. 该向导将执行多项更新预检查，以验证更新是否可以实际应用到选定服务器，并显示结果。单击全部解决解决阻止应用更新的问题。
    4. 单击下一步。
    5. 通过安装更新向导，可以在自动模式或手动模式下安装软件更新：

      • 在自动模式下，向导会自动从每台服务器迁移 VM，将服务器置于维护模式，应用更新，重新启动服务器，然后将这些 VM 重新迁移回更新后的服务器。在预检阶段为应用更新而执行的任何操作（例如关闭高可用性）都将还原。
      • 在手动模式下，向导将尝试应用更新而不为您执行任何安装后的操作。需要执行的更新后操作的列表将显示在向导的更新模式页面上；单击保存到文件可将该列表复制到文本编辑器中；在向导关闭后，您可以将此列表将作为有用的任务核对表。
    6. 单击安装更新可开始在所选服务器上安装更新。请注意，如果在手动模式下更新，在更新完成时，需要手动重新启动所有已更新的服务器。

    使用“安装更新”向导应用更新

    使用安装更新向导可以将同一个更新同时应用于多台服务器。确保在打开安装更新向导之前已下载所需更新。按照以下说明下载更新。

    下载可用更新

    1. 从 XenCenter 菜单中，选择工具，然后选择检查更新。此时将显示检查更新窗口，其中会显示可用 XenServer 和 XenCenter 更新的列表。
    2. 从列表中选择所需更新，然后单击 Web 页面链接。此时将在浏览器中打开更新页面。
    3. 单击下载按钮，然后将文件保存到首选位置。

    下载 XenServer 软件更新（或“修补程序”）后，可以使用安装更新向导将这些更新安装到托管服务器上。

    打开安装更新向导：从 XenCenter 菜单中，选择工具，然后选择安装更新。按照屏幕上的说明将更新应用到托管服务器。


升级托管服务器

您可以使用滚动池升级向导，将 XenServer 主机（池中的主机或者独立主机）从 XenServer 5.6 或更高版本升级到更新版本。有关如何升级早期版本 XenServer 的信息，请参阅《XenServer 安装指南》。

该向导将引导您完成升级过程并自动组织升级路径。升级池时，将从池主服务器开始依次升级池中的每个主机。开始升级前，向导会执行一系列预检，以确保暂时禁用某些池级别的功能（例如高可用性和 WLB），并确保池中每个主机都已做好升级准备（例如，每个主机的 CD/DVD 驱动器都已清空）。每次只有一个主机处于脱机状态，在每个主机上安装升级版本前，将自动从主机中迁移出所有正运行的 VM。

向导可以在手动或自动模式下运行：

  • 在手动模式下，必须依次在每个 XenServer 主机上手动运行 XenServer 安装程序并按主机串行控制台上的屏幕说明操作。升级开始后，XenCenter 会立即提示您插入 XenServer 安装介质或者为要升级的每个主机指定一个 PXE 引导服务器。
  • 在自动模式下，向导会使用 HTTP、NFS 或 FTP 服务器上的网络安装文件依次升级每个主机，而不需要您插入安装介质、手动重新启动或者在每个主机上逐步执行安装程序。

您也可以使用滚动池升级向导升级独立主机（即不在池中的主机）。

重要提示 升级前的准备工作

升级 XenServer 主机池需要进行认真规划。在进行升级规划时，一定要记住以下几点：

  • VM 只能从运行早期版本 XenServer 的 XenServer 主机迁移到运行相同或更高版本 XenServer 的主机（例如，从 5.5 版本迁移到 5.5 版本或者从 5.5 版本迁移到 5.6 版本）。不能将 VM 从升级后的主机迁移到运行早期版本 XenServer 的主机（例如，从 5.6 版本迁移到 5.5 版本）。请务必在 XenServer 主机上留出相应的空间。
  • Citrix 强烈建议在非必要的情况下不要运行混合模式的池（即一个池中共存多个 XenServer 版本），这是因为在升级过程中，此类池将在降级状态下操作。
  • 升级期间，关键的控制操作不可用，不应尝试执行这些操作。尽管 VM 继续正常工作，但除迁移外的其他 VM 操作（例如，关闭、复制和导出）均不可用。具体来说，执行与存储相关的操作（例如添加、删除虚拟磁盘或调整虚拟磁盘大小）是不安全的。
  • 向导始终优先升级主节点主机。在执行升级之前，不要使用 XenCenter 将主服务器置于维护模式，因为这样操作将导致主服务器变更。
  • 使用 pool-dumpdatabase xe CLI 命令备份现有池的状态（请参阅《XenServer 管理员指南》）。这样，您可以将部分完成的滚动升级还原回其原始状态，而不会丢失任何 VM 数据。由于不能将 VM 从升级的 XenServer 主机迁移到运行早期版本 XenServer 的 XenServer 主机，所以，如果出于某种原因需要还原该滚动升级，则可能需要关闭 VM。
  • 确保主机未过度置备，即主机具有足够的内存来执行升级。在升级过程中最好将任何非关键的 VM 挂起。
  • 尽管滚动池升级向导会检查是否执行了以下操作，但您可以选择在开始升级前执行这些操作：
    • 清空池中 VM 的 CD/DVD 驱动器。有关详细信息和说明，请参阅《XenServer 安装指南》。
    • 禁用高可用性。
    • 通过与 Workload Balancing 断开连接禁用 WLB。

使用滚动池升级向导升级 XenServer 主机

  1. 打开滚动池升级向导：在工具菜单上，选择滚动池升级。
  2. 阅读“准备工作”信息，然后单击下一步继续操作。
  3. 选择要升级的池和/或个别主机，然后单击下一步。
  4. 选择自动模式或手动模式，具体取决于您是计划从 HTTP、NFS 或 FTP 服务器上的网络安装文件自动升级，还是打算从 CD/DVD 或服务器通过 PXE 引导手动升级。

    注意：如果选择手动模式，则必须依次在每个 XenServer 主机上运行 XenServer 安装程序并按主机串行控制台上的屏幕说明操作。升级开始后，XenCenter 会立即提示您插入 XenServer 安装介质或者为要升级的每个主机指定一个 PXE 引导服务器。

    选择升级模式后，单击运行预检。

  5. 按照建议解决任何失败的升级预检问题。如果希望 XenCenter 自动解决所有失败的预检问题，请单击全部解决。

    解决所有预检问题后，单击下一步继续操作。

  6. 准备 XenServer 安装介质：
    • 如果选择自动模式，请输入安装介质的详细信息。选择 HTTP、NFS 或 FTP，然后指定路径、用户名和密码（如果适用）。
    • 如果选择手动模式，请记下升级计划和说明。

    单击启动升级开始进行升级。

  7. 升级开始后，向导会引导您完成升级每台主机所需执行的任何操作。按照说明操作，直到升级完池中的所有主机。
  8. 升级完毕后，向导会显示一个摘要。单击完成关闭向导。

升级之后

RBAC 支持功能自 XenServer 5.6 版本起引入。在升级到 XenServer 5.6 或更高版本时，系统会为在 XenServer 早期版本中创建的任何用户帐户分配池管理员角色。这样做是为了实现向后兼容。从早期版本的 XenServer 进行升级时，应重新访问与每个用户帐户相关联的角色，以确保角色仍然适用。


更新 XenCenter

正在执行操作。请不要检查。

如果配置了自动更新通知，您会不定期地收到 XenCenter 有新更新的通知。XenCenter 更新以 Windows 安装程序 (.msi) 包的形式提供，可以从 Citrix XenServer 更新页面下载。

您可以随时手动检查新的 XenCenter 版本，方法是从 XenCenter 菜单中选择工具，然后选择检查更新选项。此时将打开一个窗口，其中会显示可用更新的详细信息。

下载并安装新版本 XenCenter

  1. 从 XenCenter 菜单中，选择工具，然后选择检查更新。此时将显示可用更新的列表。
  2. 选择所需 XenCenter 更新，然后单击下载链接。此时将在 Web 浏览器中打开 Citrix XenServer 下载页面。
  3. 单击获取有用资源部分的链接打开“Citrix XenServer 有用资源”页面。
  4. 在下载列表中查找 XenCenter 对应的条目，然后单击下载。
  5. 如果这是您首次下载 XenCenter 更新，则需要安装 Akamai 下载管理器，下载 XenCenter 更新需要使用该软件。出现提示时，接受下载管理器安全证书，然后单击安装，以安装下载管理器。
  6. 单击立即下载下载 XenCenter MSI 文件。
  7. 通过浏览找到要用来放置新 XenCenter MSI 的文件夹，然后单击保存打开下载管理器并开始下载 MSI 文件。
  8. 退出当前的 XenCenter 会话。
  9. 下载完毕（下载管理器中显示的进度为 100%）时，请单击启动开始安装新版本的 XenCenter。
  10. XenCenter 安装完毕时，单击退出，以关闭下载管理器。


自动更新通知

可以将 XenCenter 配置为定期检查可用的 XenServer 和 XenCenter 更新及新产品版本。

配置自动更新通知

  1. 在工具菜单上，单击选项，然后单击更新选项卡。
  2. 选择检查新版本 XenServer，使 XenCenter 定期检查新版本的 XenServer 并在有新版本时向您发出通知。
  3. 选择检查 XenServer 更新，使 XenCenter 定期检查可用的 XenServer 更新并在有更新时向您发出通知。
  4. 选择检查新 XenCenter 版本，使 XenCenter 定期检查可用的新版本 XenCenter 并在有新版本时向您发出通知。
  5. 单击确定，以应用所做的更改并关闭选项对话框。


故障排除

VM 恢复模式
主题
XenCenter 系统警报
XenCenter 事件日志
创建服务器状态报告
解决 SR 连接问题
VM 恢复模式


XenCenter 系统警报

可以在系统警报窗口中查看各种不同类型的警报，其中包括：

  • 性能警报。当托管服务器或虚拟机上 CPU、网络 I/O 或磁盘 I/O 使用率超出指定的阈值时，可能会生成性能警报。请参阅配置性能警报。
  • 高可用性状态警报。对于池高可用性状态的变化（例如当池出现过度使用情况时），可能会生成警报。
  • 软件更新警报。当 XenServer 或 XenCenter 存在更新或新版本时，可能会生成警报。
  • 许可证过期警报。当托管服务器上的 XenServer 许可证接近到期日期或者已经过期时，将生成警报。

对于某些警报，可以通过单击警报列表下方的一个警报操作链接来解决引发警报的问题。

查看系统警报

要打开系统警报窗口，请执行以下操作之一：

  • 在工具菜单上，单击系统警报。
  • 单击工具栏上的系统警报按钮：

  • 如果工具栏处于隐藏状态，XenCenter 窗口的右上角将显示一个小的系统警报按钮，您可以单击此按钮来打开相应的对话框，例如：

过滤“系统警报”窗口中显示的警报

可以对系统警报窗口中所列的警报应用过滤器，例如，仅查看来自特定池或服务器的警报，或者仅查看在特定时间段内生成的警报。

  • 要仅查看来自特定服务器的警报，请单击 [image] 过滤服务器，然后单击该服务器的名称。要删除过滤器，请再次从过滤器列表中选择该服务器。
  • 要按时间/日期过滤警报，请单击 [image] 过滤日期，然后从列表中选择日期范围，或者单击自定义并通过指定开始和结束日期/时间来定义自己的日期范围。

刷新警报列表

如果新警报是在系统警报对话框处于打开状态时生成的，则可以单击 [image] 刷新更新警报列表。

导出警报

警报可以导出为逗号分隔 (.csv) 格式的文件，以便在外部应用程序中进行查看和分析。

要从 XenCenter 中导出系统警报，请在系统警报窗口中，单击 [image] 全部导出，然后指定文件名和位置。

解除系统警报

要解除或删除单个警报，请选择警报，然后单击 [image] 解除

要解除或删除当前所有的警报，请单击 [image] 全部解除。

通过电子邮件接收警报通知

可以将 XenCenter 配置为在生成系统警报时发送电子邮件通知，这些警报可以针对池中的任何服务器和虚拟机或者针对独立的服务器及其虚拟机。

Citrix XenServer 高级版或更高版本中提供高级警报功能。要了解有关不同 XenServer 版本中可用功能的详细信息，请单击此处。

如果打开电子邮件通知功能，在生成优先级为 5 或更高的警报时，系统将向您发送电子邮件通知。（您可以通过 XenServer xe 命令行接口 [CLI] 为不同类型的警报分配优先级。有关详细信息，请参阅《XenServer 管理员指南》。）

打开电子邮件通知

  1. 在资源窗格中选择池或独立服务器，单击常规选项卡，然后单击属性。
  2. 在属性对话框中，单击电子邮件选项选项卡。
  3. 选中发送电子邮件警报通知复选框，然后输入详细的交付地址信息。
  4. 单击确定，以保存更改并关闭对话框。


XenCenter 事件日志

XenCenter 维护一个可帮助进行故障排除的事件日志。可以通过单击日志选项卡来查看当前 XenCenter 会话中事件的摘要。XenCenter 事件更详细的永久记录存储在配置文件文件夹下的日志文件中，可以使用该文件对 XenCenter 会话期间可能出现的任何问题进行故障排除。

查看当前会话中的事件

要查看当前 XenCenter 会话中事件的摘要，请单击日志选项卡。要在单独的窗口中查看事件数据，请在窗口菜单上单击日志窗口。

  • 要过滤所显示的信息，请使用该选项卡或窗口顶部的复选框：选中某个复选框可显示相应类型的事件；清除复选框可隐藏相应类型的事件。
  • 要从日志选项卡删除所有非活动的日志条目，请单击清除并通过单击确定进行确认。

    请注意，此操作只是将日志条目从日志选项卡中清除，而不会将其从永久性 XenCenter 事件日志文件中删除。

查看 XenCenter 事件日志文件

使用 XenCenter 时，将生成永久性的 XenCenter 日志文件 (syslog)。此文件包括使用 XenCenter 时执行的所有操作以及出现的所有错误的完整描述，还包含事件的信息性记录，以便提供在 XenCenter 中和托管资源上发生的各种操作的审核追踪。

XenCenter 日志文件存储在 %appdata%\Citrix\XenCenter 中。

在诊断 XenServer 环境中的问题时，XenCenter 的日志输出是非常有价值的信息。要快速查找 XenCenter 日志文件（例如，需要将文件通过电子邮件发送给支持组织时），可以在 XenCenter 中单击帮助 > 查看应用程序日志文件。


创建服务器状态报告

通过服务器状态报告向导，可以方便地收集所安装的特定 XenServer 的综合快照并将其打包，以进行故障排除。通过其中的选项，可以包括或排除所选服务器的一系列不同配置文件和日志文件。

服务器状态报告可以打包为一个 zip 文件，该文件可以存储和/或通过电子邮件发送。所生成的报告大小因选择包括的项目而异。该 zip 文件包括：

  • 每台服务器对应的一个文件夹（其中包含您在向导中选择的报告类型）
  • XenCenter 日志文件

生成服务器状态报告

在工具菜单上，单击获取服务器状态报告并按服务器状态报告向导中的步骤操作：

  1. 选择服务器。选择要收集报告数据的服务器。

    将列出所有可用的托管服务器。如果某个服务器未列出，您可以通过单击添加新服务器将该服务器添加到列表中。

  2. 选择报告内容。选择要包括在报告中的数据，然后单击下一步。
  3. 编译报告。此页面显示报告的编译进度并报告所有的数据收集问题。在报告编译完成后，单击下一步。
  4. 报告目标位置。通过浏览找到将保存报告的文件夹，然后单击完成，以将报告文件保存到指定文件夹中并关闭该向导。


解决 SR 连接问题

RepairSRDialog 6160

为了将存储库提供给服务器使用，必须在服务器与 SR 之间建立连接。此连接在软件中由物理块设备 (PBD) 提供。PBD 可存储用于将给定 SR 映射到服务器的信息。必须将 PBD 连接到或插入服务器，SR 才能使用。如果因任何原因将 PBD 拔出，SR 都将无法再供服务器使用，资源窗格中将出现一个表示存储已断开的图标 [image] 。

您可以使用修复存储库工具诊断并解决一些常见的 SR 连接问题。在资源窗格中，选择存储资源，单击鼠标右键，然后在快捷菜单上单击修复存储库。

或者，在存储菜单上，单击修复存储库。

此时将列出可用的存储库，您可以看到这些存储库的状态。

  • 已连接。SR 与服务器之间的连接正常，由 SR 提供的存储当前可用。
  • 已拔出。PBD 当前已拔出，因此存储不可用。
  • 缺少连接。找不到 PBD，因此存储不可用。

单击修复，使 XenCenter 尝试修复存储。进度和结果将显示在修复存储库对话框中。


VM 恢复模式

如果半虚拟化 Linux VM 出现严重问题，您可以尝试在恢复模式下启动它。该过程会暂时启用 HVM 模式，并将 CD 驱动器设置为首先引导，便于您引导拯救 CD 或拯救 PXE，然后调查问题的原因。

要在恢复模式下启动 VM，请执行以下操作：

  1. 选择要在恢复模式下启动的 VM。
  2. 从主菜单中，选择 VM > 启动/关闭 > 在恢复模式下启动。

注意：您应该连接常规操作系统拯救 CD，从其引导 VM，然后从拯救 CD 修复 VM。

要了解有关 HVM 和半虚拟化模式的详细信息，请参阅关于 VM。


版权信息

版权和商标信息

版权所有 © 2012 Citrix Systems, Inc.

Citrix、Citrix XenServer、Xen、Xen 徽标、XenCenter、XenMotion 是 Citrix Systems, Inc. 在美国和其他国家/地区的商标和/或注册商标。

所有其他商标和注册商标均归其各自所有者所有。

本软件包含以下第三方软件库：

  • Log4Net
  • #ziplib
  • XML-RPC.NET
  • FormFontFixer
  • NMock

Log4Net

Log4Net is part of the Apache Logging Services project (http://logging.apache.org/log4net/) and is licensed under the Apache License, Version 2.0; you may not use this software except in compliance with the License.You may view a copy of the License at http://www.apache.org/licenses/LICENSE-2.0 or by clicking here.

#ziplib - The Zip, GZip, BZip2 and Tar Implementation For .NET

Copyright ©2000-2007 IC#Code (webmaster@icsharpcode.net)

#ZipLib is released under the GNU General Public License (GLP) with the Classpath exception.You may view a copy of the GPL at http://www.opensource.org/licenses/gpl-2.0.php or by clicking here.

XML-RPC.NET

XML-RPC.NET - XML-RPC for .NET v2.1.0 Copyright (C) 2001-2006 Charles Cook (chascook@gmail.com)

XML-RPC.NET is licensed with MIT X11 license:

Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the "Software"), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions:

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.

FormFontFixer by TeX HeX

Copyright (c) 2008, TeX HeX (http://www.texhex.info/)

All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

  • Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
  • Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.
  • Neither the name of the Xteq Systems (http://www.xteq.com/) nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

NMock

Copyright (c) 2002, Joe Walnes, Chris Stevenson, Owen Rogers.All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

  • Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
  • Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.
  • The names of the contributors may not be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.


Apache License

Version 2.0, January 2004
http://www.apache.org/licenses/

TERMS AND CONDITIONS FOR USE, REPRODUCTION, AND DISTRIBUTION

1. Definitions

2. Grant of Copyright License

3. Grant of Patent License

4. Redistribution

5. Submission of Contributions

6. Trademarks

7. Disclaimer of Warranty

8. Limitation of Liability

9. Accepting Warranty or Additional Liability

1. Definitions.

"License" shall mean the terms and conditions for use, reproduction, and distribution as defined by Sections 1 through 9 of this document.

"Licensor" shall mean the copyright owner or entity authorized by the copyright owner that is granting the License.

"Legal Entity" shall mean the union of the acting entity and all other entities that control, are controlled by, or are under common control with that entity. For the purposes of this definition, "control" means (i) the power, direct or indirect, to cause the direction or management of such entity, whether by contract or otherwise, or (ii) ownership of fifty percent (50%) or more of the outstanding shares, or (iii) beneficial ownership of such entity.

"You" (or "Your") shall mean an individual or Legal Entity exercising permissions granted by this License.

"Source" form shall mean the preferred form for making modifications, including but not limited to software source code, documentation source, and configuration files.

"Object" form shall mean any form resulting from mechanical transformation or translation of a Source form, including but not limited to compiled object code, generated documentation, and conversions to other media types.

"Work" shall mean the work of authorship, whether in Source or Object form, made available under the License, as indicated by a copyright notice that is included in or attached to the work (an example is provided in the Appendix below).

"Derivative Works" shall mean any work, whether in Source or Object form, that is based on (or derived from) the Work and for which the editorial revisions, annotations, elaborations, or other modifications represent, as a whole, an original work of authorship. For the purposes of this License, Derivative Works shall not include works that remain separable from, or merely link (or bind by name) to the interfaces of, the Work and Derivative Works thereof.

"Contribution" shall mean any work of authorship, including the original version of the Work and any modifications or additions to that Work or Derivative Works thereof, that is intentionally submitted to Licensor for inclusion in the Work by the copyright owner or by an individual or Legal Entity authorized to submit on behalf of the copyright owner. For the purposes of this definition, "submitted" means any form of electronic, verbal, or written communication sent to the Licensor or its representatives, including but not limited to communication on electronic mailing lists, source code control systems, and issue tracking systems that are managed by, or on behalf of, the Licensor for the purpose of discussing and improving the Work, but excluding communication that is conspicuously marked or otherwise designated in writing by the copyright owner as "Not a Contribution."

"Contributor" shall mean Licensor and any individual or Legal Entity on behalf of whom a Contribution has been received by Licensor and subsequently incorporated within the Work.

2. Grant of Copyright License. Subject to the terms and conditions of this License, each Contributor hereby grants to You a perpetual, worldwide, non-exclusive, no-charge, royalty-free, irrevocable copyright license to reproduce, prepare Derivative Works of, publicly display, publicly perform, sublicense, and distribute the Work and such Derivative Works in Source or Object form.

3. Grant of Patent License. Subject to the terms and conditions of this License, each Contributor hereby grants to You a perpetual, worldwide, non-exclusive, no-charge, royalty-free, irrevocable (except as stated in this section) patent license to make, have made, use, offer to sell, sell, import, and otherwise transfer the Work, where such license applies only to those patent claims licensable by such Contributor that are necessarily infringed by their Contribution(s) alone or by combination of their Contribution(s) with the Work to which such Contribution(s) was submitted. If You institute patent litigation against any entity (including a cross-claim or counterclaim in a lawsuit) alleging that the Work or a Contribution incorporated within the Work constitutes direct or contributory patent infringement, then any patent licenses granted to You under this License for that Work shall terminate as of the date such litigation is filed.

4. Redistribution. You may reproduce and distribute copies of the Work or Derivative Works thereof in any medium, with or without modifications, and in Source or Object form, provided that You meet the following conditions:

  1. You must give any other recipients of the Work or Derivative Works a copy of this License; and

  2. You must cause any modified files to carry prominent notices stating that You changed the files; and

  3. You must retain, in the Source form of any Derivative Works that You distribute, all copyright, patent, trademark, and attribution notices from the Source form of the Work, excluding those notices that do not pertain to any part of the Derivative Works; and

  4. If the Work includes a "NOTICE" text file as part of its distribution, then any Derivative Works that You distribute must include a readable copy of the attribution notices contained within such NOTICE file, excluding those notices that do not pertain to any part of the Derivative Works, in at least one of the following places: within a NOTICE text file distributed as part of the Derivative Works; within the Source form or documentation, if provided along with the Derivative Works; or, within a display generated by the Derivative Works, if and wherever such third-party notices normally appear. The contents of the NOTICE file are for informational purposes only and do not modify the License. You may add Your own attribution notices within Derivative Works that You distribute, alongside or as an addendum to the NOTICE text from the Work, provided that such additional attribution notices cannot be construed as modifying the License.

You may add Your own copyright statement to Your modifications and may provide additional or different license terms and conditions for use, reproduction, or distribution of Your modifications, or for any such Derivative Works as a whole, provided Your use, reproduction, and distribution of the Work otherwise complies with the conditions stated in this License.

5. Submission of Contributions. Unless You explicitly state otherwise, any Contribution intentionally submitted for inclusion in the Work by You to the Licensor shall be under the terms and conditions of this License, without any additional terms or conditions. Notwithstanding the above, nothing herein shall supersede or modify the terms of any separate license agreement you may have executed with Licensor regarding such Contributions.

6. Trademarks. This License does not grant permission to use the trade names, trademarks, service marks, or product names of the Licensor, except as required for reasonable and customary use in describing the origin of the Work and reproducing the content of the NOTICE file.

7. Disclaimer of Warranty. Unless required by applicable law or agreed to in writing, Licensor provides the Work (and each Contributor provides its Contributions) on an "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied, including, without limitation, any warranties or conditions of TITLE, NON-INFRINGEMENT, MERCHANTABILITY, or FITNESS FOR A PARTICULAR PURPOSE. You are solely responsible for determining the appropriateness of using or redistributing the Work and assume any risks associated with Your exercise of permissions under this License.

8. Limitation of Liability. In no event and under no legal theory, whether in tort (including negligence), contract, or otherwise, unless required by applicable law (such as deliberate and grossly negligent acts) or agreed to in writing, shall any Contributor be liable to You for damages, including any direct, indirect, special, incidental, or consequential damages of any character arising as a result of this License or out of the use or inability to use the Work (including but not limited to damages for loss of goodwill, work stoppage, computer failure or malfunction, or any and all other commercial damages or losses), even if such Contributor has been advised of the possibility of such damages.

9. Accepting Warranty or Additional Liability. While redistributing the Work or Derivative Works thereof, You may choose to offer, and charge a fee for, acceptance of support, warranty, indemnity, or other liability obligations and/or rights consistent with this License. However, in accepting such obligations, You may act only on Your own behalf and on Your sole responsibility, not on behalf of any other Contributor, and only if You agree to indemnify, defend, and hold each Contributor harmless for any liability incurred by, or claims asserted against, such Contributor by reason of your accepting any such warranty or additional liability.


GNU GENERAL PUBLIC LICENSE

                 Version 2, June 1991

   TERMS AND CONDITIONS FOR COPYING, DISTRIBUTION AND MODIFICATION

  0. This License applies to any program or other work which contains
a notice placed by the copyright holder saying it may be distributed
under the terms of this General Public License.  The "Program", below,
refers to any such program or work, and a "work based on the Program"
means either the Program or any derivative work under copyright law:
that is to say, a work containing the Program or a portion of it,
either verbatim or with modifications and/or translated into another
language.  (Hereinafter, translation is included without limitation in
the term "modification".)  Each licensee is addressed as "you".

Activities other than copying, distribution and modification are not
covered by this License; they are outside its scope.  The act of
running the Program is not restricted, and the output from the Program
is covered only if its contents constitute a work based on the
Program (independent of having been made by running the Program).
Whether that is true depends on what the Program does.

  1. You may copy and distribute verbatim copies of the Program's
source code as you receive it, in any medium, provided that you
conspicuously and appropriately publish on each copy an appropriate
copyright notice and disclaimer of warranty; keep intact all the
notices that refer to this License and to the absence of any warranty;
and give any other recipients of the Program a copy of this License
along with the Program.

You may charge a fee for the physical act of transferring a copy, and
you may at your option offer warranty protection in exchange for a fee.

  2. You may modify your copy or copies of the Program or any portion
of it, thus forming a work based on the Program, and copy and
distribute such modifications or work under the terms of Section 1
above, provided that you also meet all of these conditions:

    a) You must cause the modified files to carry prominent notices
    stating that you changed the files and the date of any change.

    b) You must cause any work that you distribute or publish, that in
    whole or in part contains or is derived from the Program or any
    part thereof, to be licensed as a whole at no charge to all third
    parties under the terms of this License.

    c) If the modified program normally reads commands interactively
    when run, you must cause it, when started running for such
    interactive use in the most ordinary way, to print or display an
    announcement including an appropriate copyright notice and a
    notice that there is no warranty (or else, saying that you provide
    a warranty) and that users may redistribute the program under
    these conditions, and telling the user how to view a copy of this
    License.  (Exception: if the Program itself is interactive but
    does not normally print such an announcement, your work based on
    the Program is not required to print an announcement.)

These requirements apply to the modified work as a whole.  If
identifiable sections of that work are not derived from the Program,
and can be reasonably considered independent and separate works in
themselves, then this License, and its terms, do not apply to those
sections when you distribute them as separate works.  But when you
distribute the same sections as part of a whole which is a work based
on the Program, the distribution of the whole must be on the terms of
this License, whose permissions for other licensees extend to the
entire whole, and thus to each and every part regardless of who wrote it.

Thus, it is not the intent of this section to claim rights or contest
your rights to work written entirely by you; rather, the intent is to
exercise the right to control the distribution of derivative or
collective works based on the Program.

In addition, mere aggregation of another work not based on the Program
with the Program (or with a work based on the Program) on a volume of
a storage or distribution medium does not bring the other work under
the scope of this License.

  3. You may copy and distribute the Program (or a work based on it,
under Section 2) in object code or executable form under the terms of
Sections 1 and 2 above provided that you also do one of the following:

    a) Accompany it with the complete corresponding machine-readable
    source code, which must be distributed under the terms of Sections
    1 and 2 above on a medium customarily used for software interchange; or,

    b) Accompany it with a written offer, valid for at least three
    years, to give any third party, for a charge no more than your
    cost of physically performing source distribution, a complete
    machine-readable copy of the corresponding source code, to be
    distributed under the terms of Sections 1 and 2 above on a medium
    customarily used for software interchange; or,

    c) Accompany it with the information you received as to the offer
    to distribute corresponding source code.  (This alternative is
    allowed only for noncommercial distribution and only if you
    received the program in object code or executable form with such
    an offer, in accord with Subsection b above.)

The source code for a work means the preferred form of the work for
making modifications to it.  For an executable work, complete source
code means all the source code for all modules it contains, plus any
associated interface definition files, plus the scripts used to
control compilation and installation of the executable.  However, as a
special exception, the source code distributed need not include
anything that is normally distributed (in either source or binary
form) with the major components (compiler, kernel, and so on) of the
operating system on which the executable runs, unless that component
itself accompanies the executable.

If distribution of executable or object code is made by offering
access to copy from a designated place, then offering equivalent
access to copy the source code from the same place counts as
distribution of the source code, even though third parties are not
compelled to copy the source along with the object code.

  4. You may not copy, modify, sublicense, or distribute the Program
except as expressly provided under this License.  Any attempt
otherwise to copy, modify, sublicense or distribute the Program is
void, and will automatically terminate your rights under this License.
However, parties who have received copies, or rights, from you under
this License will not have their licenses terminated so long as such
parties remain in full compliance.

  5. You are not required to accept this License, since you have not
signed it.  However, nothing else grants you permission to modify or
distribute the Program or its derivative works.  These actions are
prohibited by law if you do not accept this License.  Therefore, by
modifying or distributing the Program (or any work based on the
Program), you indicate your acceptance of this License to do so, and
all its terms and conditions for copying, distributing or modifying
the Program or works based on it.

  6. Each time you redistribute the Program (or any work based on the
Program), the recipient automatically receives a license from the
original licensor to copy, distribute or modify the Program subject to
these terms and conditions.  You may not impose any further
restrictions on the recipients' exercise of the rights granted herein.
You are not responsible for enforcing compliance by third parties to
this License.

  7. If, as a consequence of a court judgment or allegation of patent
infringement or for any other reason (not limited to patent issues),
conditions are imposed on you (whether by court order, agreement or
otherwise) that contradict the conditions of this License, they do not
excuse you from the conditions of this License.  If you cannot
distribute so as to satisfy simultaneously your obligations under this
License and any other pertinent obligations, then as a consequence you
may not distribute the Program at all.  For example, if a patent
license would not permit royalty-free redistribution of the Program by
all those who receive copies directly or indirectly through you, then
the only way you could satisfy both it and this License would be to
refrain entirely from distribution of the Program.

If any portion of this section is held invalid or unenforceable under
any particular circumstance, the balance of the section is intended to
apply and the section as a whole is intended to apply in other
circumstances.

It is not the purpose of this section to induce you to infringe any
patents or other property right claims or to contest validity of any
such claims; this section has the sole purpose of protecting the
integrity of the free software distribution system, which is
implemented by public license practices.  Many people have made
generous contributions to the wide range of software distributed
through that system in reliance on consistent application of that
system; it is up to the author/donor to decide if he or she is willing
to distribute software through any other system and a licensee cannot
impose that choice.

This section is intended to make thoroughly clear what is believed to
be a consequence of the rest of this License.

  8. If the distribution and/or use of the Program is restricted in
certain countries either by patents or by copyrighted interfaces, the
original copyright holder who places the Program under this License
may add an explicit geographical distribution limitation excluding
those countries, so that distribution is permitted only in or among
countries not thus excluded.  In such case, this License incorporates
the limitation as if written in the body of this License.

  9. The Free Software Foundation may publish revised and/or new versions
of the General Public License from time to time.  Such new versions will
be similar in spirit to the present version, but may differ in detail to
address new problems or concerns.

Each version is given a distinguishing version number.  If the Program
specifies a version number of this License which applies to it and
"any later version", you have the option of following the terms and conditions
either of that version or of any later version published by the Free
Software Foundation.  If the Program does not specify a version number of
this License, you may choose any version ever published by the Free Software
Foundation.

  10. If you wish to incorporate parts of the Program into other free
programs whose distribution conditions are different, write to the author
to ask for permission.  For software which is copyrighted by the Free
Software Foundation, write to the Free Software Foundation; we sometimes
make exceptions for this.  Our decision will be guided by the two goals
of preserving the free status of all derivatives of our free software and
of promoting the sharing and reuse of software generally.

                NO WARRANTY

  11. BECAUSE THE PROGRAM IS LICENSED FREE OF CHARGE, THERE IS NO WARRANTY
FOR THE PROGRAM, TO THE EXTENT PERMITTED BY APPLICABLE LAW.  EXCEPT WHEN
OTHERWISE STATED IN WRITING THE COPYRIGHT HOLDERS AND/OR OTHER PARTIES
PROVIDE THE PROGRAM "AS IS" WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESSED
OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE.  THE ENTIRE RISK AS
TO THE QUALITY AND PERFORMANCE OF THE PROGRAM IS WITH YOU.  SHOULD THE
PROGRAM PROVE DEFECTIVE, YOU ASSUME THE COST OF ALL NECESSARY SERVICING,
REPAIR OR CORRECTION.

  12. IN NO EVENT UNLESS REQUIRED BY APPLICABLE LAW OR AGREED TO IN WRITING
WILL ANY COPYRIGHT HOLDER, OR ANY OTHER PARTY WHO MAY MODIFY AND/OR
REDISTRIBUTE THE PROGRAM AS PERMITTED ABOVE, BE LIABLE TO YOU FOR DAMAGES,
INCLUDING ANY GENERAL, SPECIAL, INCIDENTAL OR CONSEQUENTIAL DAMAGES ARISING
OUT OF THE USE OR INABILITY TO USE THE PROGRAM (INCLUDING BUT NOT LIMITED
TO LOSS OF DATA OR DATA BEING RENDERED INACCURATE OR LOSSES SUSTAINED BY
YOU OR THIRD PARTIES OR A FAILURE OF THE PROGRAM TO OPERATE WITH ANY OTHER
PROGRAMS), EVEN IF SUCH HOLDER OR OTHER PARTY HAS BEEN ADVISED OF THE
POSSIBILITY OF SUCH DAMAGES.