Workload Balancing 概述

Workload Balancing 是一种 XenServer 设备，可以将虚拟机重定位到资源池中最适合其工作负载的服务器，从而实现池的负载平衡。 例如，Workload Balancing 可以：

  • 在一个 XenServer 资源池中的各主机间平衡虚拟机工作负载
  • 确定用来启动虚拟机的最佳主机
  • 确定用来启动已关闭虚拟机的最佳主机
  • 在您将主机置于维护模式时，为该主机的每个虚拟机确定最佳主机
注: 工作负载平衡是一项仅在 XenServer Enterprise、XenServer Desktop+ 和 XenServer Desktop Edition 中提供的高级功能。 要了解有关 XenServer 6.5 许可的详细信息，请参阅许可概述 (XenServer 6.5)。 要购买 XenServer 许可证，请单击此处。

Workload Balancing 可以根据您选择的优先顺序自动完成这些任务，或者提示您接受其优化、合并和放置建议。 您还可以将 Workload Balancing 配置为在使用率低的时间段自动关闭主机（例如在夜间关闭主机以节能）。

Workload Balancing 将评估虚拟机工作负载在池中的利用率，当某个主机达到一项阈值时，会将虚拟机重定位到该池中的其他主机。

为确保重新平衡和放置建议能够满足环境的需求，您可以将 Workload Balancing 配置为根据资源性能优化工作负载，或者配置为实现密度最大化。 可以将这些优化模式配置为在预定义的时间自动切换，或者始终保持不变。 为提高精细程度，可以调整各个资源指标（CPU、网络和内存）的权重。

Workload Balancing 提供有关主机和池运行状况、优化和虚拟机性能的历史报告，以及虚拟机移动历史记录，以帮助您完成容量规划。


Workload Balancing 入门

您可以下载 Workload Balancing 虚拟设备，并使用以下过程启动并运行：

  1. 通过 citrix.com 的我的账户，下载 Workload Balancing 虚拟设备软件包。
  2. 在 XenCenter 中，依次单击文件和导入，按照屏幕上的说明导入 Workload Balancing 虚拟设备。
  3. 使用 Workload Balancing 配置向导配置 Workload Balancing 虚拟设备；导入虚拟设备后，该向导将显示在 XenCenter 中该设备的控制台选项卡上。
  4. 将您的池连接到该 Workload Balancing 虚拟设备，如连接 Workload Balancing 中所述。

    有关这些步骤的详细信息，请参阅《Workload Balancing 快速入门》。

注: 当您的 XenServer 主机获得了 XenServer Enterprise、XenServer Desktop+ 或 XenServer Desktop Edition 的许可后，“属性”窗格中将显示“WLB”选项卡。 要了解有关 XenServer 6.5 许可的详细信息，请参阅许可概述 (XenServer 6.5)。 要购买 XenServer 许可证，请单击此处。


Workload Balancing 基本概念

Workload Balancing 获取虚拟机和物理主机上的资源性能数据， 并将这些数据与您设置的首选项相结合，以提供优化和放置建议。 Workload Balancing 将性能数据存储在内部数据库中：Workload Balancing 运行时间越长，所提供的建议就越精确。

Workload Balancing 将就虚拟机工作负载在池中的移动提供建议，以获得最大的效率，这里的效率是指性能或密度，具体取决于您的目标。 在 Workload Balancing 环境中：

  • 性能指主机上物理资源的使用率（例如，主机上 CPU、内存和网络的使用率）。 将 Workload Balancing 设置为实现性能最大化时，它提供的虚拟机放置建议将确保每个虚拟机获得最多的可用资源。
  • 密度指主机上虚拟机的数量。 将 Workload Balancing 优化模式设置为密度最大化时，它提出的建议将在确保虚拟机保持足够计算能力的前提下，将这些虚拟机放置在尽可能少的主机上，从而减少池中开启的主机数量。

Workload Balancing 允许您修改放置（性能或密度）、电源管理、自动化、指标加权和性能阈值的设置。

Workload Balancing 与高可用性设置不发生冲突；高可用性设置始终优先。


连接 Workload Balancing

在导入 Workload Balancing 虚拟设备并运行 Workload Balancing 配置向导后，必须将要监视的池连接到 Workload Balancing。 为此，请使用 XenCenter 中的“连接 WLB 服务器”对话框，或者使用 xe 命令。

注: 当您的 XenServer 主机获得了 XenServer Enterprise、XenServer Desktop+ 或 XenServer Desktop Edition 的许可后，“属性”窗格中将显示“WLB”选项卡。 要了解有关 XenServer 6.5 许可的详细信息，请参阅许可概述 (XenServer 6.5)。 要购买 XenServer 许可证，请单击此处。

必备条件

要完成后续的 XenCenter 过程，需要以下信息：

  • Workload Balancing 虚拟设备的 IP 地址或完全限定域名 (FQDN) 以及端口号。
  • 您希望 Workload Balancing 监视的资源池（即池主服务器）的凭据。
  • 在 Workload Balancing 设备上创建的帐户的凭据。 该帐户通常称为 Workload Balancing 用户帐户。 XenServer 使用此帐户与 Workload Balancing 通信。 （此帐户是 Workload Balancing 配置期间您在 Workload Balancing 虚拟设备上创建的帐户。）

如果要在连接 Workload Balancing 服务器时指定 Workload Balancing 虚拟设备的 FQDN（在“连接 WLB 服务器”对话框中），必须先手动将其主机名添加到您的 DNS 中。 如果要配置受信任证书机构颁发的证书，Citrix 建议指定未过期的 FQDN 或 IP 地址。

首次连接 Workload Balancing 时，它将使用默认的阈值和设置来平衡工作负载。 默认情况下自动功能（例如自动优化模式、电源管理和自动化）处于禁用状态。

重要: 在 Workload Balancing 运行一段时间之后，如果您没有收到最佳放置建议，Citrix 强烈建议您对性能阈值进行评估，如评估优化阈值的效力中所述。 为获得最优的 Workload Balancing 建议，务必为您的环境设置正确的阈值。

连接 Workload Balancing 虚拟设备

  1. 在 XenCenter 的资源窗格中，选择 XenCenter > your-resource-pool（您的资源池）。
  2. 在属性窗格中，单击 WLB 选项卡。 注意，在获得 XenServer 主机的许可后，“属性”窗格上将显示 WLB 选项卡。 要了解有关 XenServer 许可的详细信息，请参阅关于 XenServer 许可。
  3. 在 WLB 选项卡中，单击连接。 此时将显示连接 WLB 服务器对话框。
  4. 在服务器地址部分的对话框中，输入以下内容：
    • 在地址框中，键入新 Workload Balancing 服务器的 IP 地址或 FQDN。 例如，输入 WLB-appliance-computername.yourdomain.net 作为 FQDN。
    • 在端口框中输入端口号。 XenServer 使用此端口与 Workload Balancing 通信。

      默认情况下，XenServer 通过端口 8012 连接 Workload Balancing（具体而言，是指 Web 服务主机服务）。 如果您在 Workload Balancing 配置期间更改了端口号，则必须在端口框中输入该端口号。

      重要: 除非您在 Workload Balancing 配置期间更改了默认端口，否则请勿更改默认端口号。 配置期间指定的端口号、在任何防火墙中指定的端口号以及连接 WLB 服务器对话框中指定的端口号必须一致。
  5. 在 WLB 服务器凭据部分，输入 XenServer 连接 Workload Balancing 虚拟设备时将使用的用户名（例如 wlbuser）和密码。 该帐户必须是在 Workload Balancing 配置期间创建的帐户。 默认情况下，此帐户的用户名为 wlbuser。
  6. 在 XenServer 凭据部分，输入所配置池的用户名和密码。 Workload Balancing 将使用这些凭据连接该池中的每个主机。 要使用当前登录 XenServer 所使用的凭据，请选中使用当前 XenCenter 凭据复选框。 如果已经使用基于角色的访问控制 (RBAC) 功能为帐户分配了权限，请确保这些权限足够使用 Workload Balancing。 请参阅 RBAC 角色和权限定义。
  7. 连接到 Workload Balancing 设备后，如果要更改阈值设置或者更改为特定资源指定的优先级，请参阅编辑 Workload Balancing 设置。


基本任务简介

Workload Balancing 是一种功能强大的 XenServer 组件，具有许多用于在环境中优化工作负载的功能，例如主机电源管理、优化模式切换计划功能以及报告运行功能。 此外，您还可以调整 Workload Balancing 在提供优化建议时使用的条件。

但是，当您刚开始使用 Workload Balancing 时，可能需要每天（或定期）使用 Workload Balancing 执行两项主要任务：

  • 确定用来启动虚拟机的最佳主机
  • 接受 Workload Balancing 优化建议

有关获取和配置 Workload Balancing 虚拟设备的信息，请参阅《Workload Balancing 快速入门》。

确定用来启动 VM 的最佳主机

另请参阅为 VM 的初始放置、迁移和恢复选择最优服务器。

当您需要重新启动已关闭的虚拟机以及将虚拟机迁移到其他主机时，Workload Balancing 可以提供有关主机的建议，确定在哪个主机上启动 VM（VM 放置）更为方便。 此功能也可以在 XenDesktop 环境中使用。

接受 Workload Balancing 建议

另请参阅接受优化建议。

Workload Balancing 运行一段时间后，将开始提供有关环境改进方法的建议。 例如，如果您的目标是提高主机上 VM 的密度（通过适当的设置），Workload Balancing 将就如何将多个虚拟机合并到一台主机上提出建议。 如果未在自动化模式下运行，您可以选择应用此建议或直接将其忽略。

这些任务以及在 XenCenter 中执行这些任务的方法将在后面的各节中更深入地介绍。 另一个常用的任务是环境中工作负载情况的运行报告，如生成并管理 Workload Balancing 报告。

重要: 在 Workload Balancing 运行一段时间之后，如果您没有收到最佳放置建议，Citrix 强烈建议您对性能阈值进行评估，如《Workload Balancing 管理员指南》中所述。 对 Workload Balancing 设置适用于所用环境的正确阈值至关重要，否则其建议可能会不适用或者不会在正确的时间提供。


为 VM 的初始放置、迁移和恢复选择最佳服务器

启用 Workload Balancing 并启动处于脱机状态的虚拟机后，XenCenter 会提供建议以帮助您确定资源池中用于启动虚拟机的最优物理主机。 由于最优主机以星形符号指示，因此这些建议又称为星级建议。

由于 host17 是用来启动 VM 的最优主机，因此其旁边显示更多的实心星形符号。host16 旁边没有显示任何实心星形符号，表明此主机不是推荐主机，但是由于它处于启用状态，因此用户也可以选择该主机。host18 由于内存不足而处于灰显状态，因此用户无法选择该主机。

放置的实现

启用 Workload Balancing 后，XenCenter 会利用星级来指示用于启动虚拟机的最优主机，当您希望启动已关闭或挂起的虚拟机以及希望将该虚拟机迁移到不同服务器（迁移和维护模式）时，都会获得这样的最优主机建议。

如果在启用 Workload Balancing 的情况下使用这些功能，将在物理主机旁显示星级，从而以这种方式提供主机建议。 五个空星会表示服务器的等级最低（最差）。 在虚拟机无法启动或迁移到主机时，主机名称将呈灰显，且其无法接受 VM 的原因将显示在旁边。

通常，如果您在 Workload Balancing 推荐的主机上启动虚拟机（即，通过一项放置功能选择星级最高的主机），则 Workload Balancing 的工作效率更高，提出的优化建议更加有效，并且提出建议的频率也更低。

最优的含义

术语最优是指最适合托管工作负载的物理服务器。 Workload Balancing 在确定哪一个主机是工作负载的最优选择时会考虑以下几个因素：

  • 池中每个主机上的可用资源量。 当池在性能最大化模式下运行时，Workload Balancing 会尽量在该池中的各主机之间均衡分配虚拟机，以使所有虚拟机都能达到良好的性能。 当池在密度最大化模式下运行时，Workload Balancing 会在确保虚拟机有足够资源的同时，尽可能密集地将虚拟机放置到主机上。
  • 池运行时所采用的优化模式（性能最大化或密度最大化）。 当池在性能最大化模式下运行时，Workload Balancing 会尽可能将虚拟机放置在可用资源最多且资源类型符合 VM 需求的主机上。 在密度最大化模式下时，Workload Balancing 会尽可能将虚拟机放置在已经运行虚拟机的主机上，以使虚拟机在尽可能少的主机上运行。
  • VM 所需资源的数量和类型。 在 Workload Balancing 监视虚拟机一段时间后，将使用收集的 VM 指标根据虚拟机所需的资源类型提出放置建议。 例如，如果 VM 需要，Workload Balancing 可能会选择一个可用 CPU 较少但可用内存较多的主机（基于其过去的性能历史记录）。 但应注意的是，Workload Balancing 只有在确定当前主机面临资源压力的情况下才会提出建议。

在最佳服务器上启动虚拟机

  1. 在 XenCenter 的资源窗格中，选择要启动的虚拟机。
  2. 在 VM 菜单上，选择在服务器上启动，然后选择以下选项之一：
    • 最优服务器。 最佳服务器是指最能满足所启动虚拟机的资源要求的物理主机。 Workload Balancing 根据服务器性能指标的历史记录和您的放置策略来确定最佳服务器。 最佳服务器是星级最高的服务器。
    • “最优服务器”命令下列出的带有星级的一台服务器。 五颗星代表最值得推荐的（最佳）服务器，五颗空星代表最不值得推荐的服务器。

在最佳服务器上恢复虚拟机

  1. 在 XenCenter 的资源窗格中，选择要恢复的已挂起虚拟机。
  2. 在 VM 菜单上，选择在服务器上恢复，然后选择以下选项之一：
    • 最优服务器。 最佳服务器是指最能满足所启动虚拟机的资源要求的物理主机。 Workload Balancing 根据服务器性能指标的历史记录和您的放置策略来确定最佳服务器。 最佳服务器是星级最高的服务器。
    • “最优服务器”命令下列出的带有星级的一台服务器。 五颗星代表最值得推荐的（最佳）服务器，五颗空星代表最不值得推荐的服务器。


接受优化建议

Workload Balancing 将就虚拟机的迁移方法提供建议，用以优化环境。 优化建议显示在 XenCenter 的 WLB 选项卡中。

此图是“优化建议”列表的屏幕拍图，此列表显示在“WLB”选项卡上。 “原因”列显示建议的目的。 “操作”列显示就优化建议而提供的更改措施建议。 此屏幕拍图显示针对虚拟机 HA-prot-VM-7 和主机 host17.domain4.bedford4.ctx4 的优化建议。

优化建议的基础

这些优化建议基于：

  • 所选的放置策略（即放置优化模式），如调整优化模式中所述
  • 资源的性能指标，例如物理主机的 CPU、内存和网络利用率
  • 资源池中主机的角色。 提出放置建议时，只有在没有其他主机能够接受工作负载时，Workload Balancing 才会考虑池主服务器。 （同样，如果池在密度最大化模式下运行，则 Workload Balancing 在决定虚拟机填入各主机的顺序时，会最后考虑池主服务器。）

在优化建议中，将显示 Workload Balancing 建议重定位的虚拟机的名称、虚拟机当前所在主机的名称，以及 Workload Balancing 建议作为虚拟机新宿主的主机的名称。 优化建议中还将显示 Workload Balancing 建议移动虚拟机的原因（例如，显示“CPU”表示为了提高 CPU 使用率）。

在您接受优化建议后，XenServer 会重定位所有建议优化的虚拟机。

提示: 您可以通过在 XenCenter 中选择资源池并查看 WLB 选项卡的配置部分，来找到资源池的优化模式。

接受优化建议

  1. 在资源窗格中，选择要显示建议的池，然后单击 WLB 选项卡。 在选中的资源池中，如果有任何针对虚拟机的优化建议，这些建议都会显示在 WLB 选项卡中。
  2. 要接受建议，请单击应用建议。 XenServer 会开始将优化建议部分中列出的所有虚拟机移动到推荐的服务器中。

    单击应用建议之后，可以依次单击通知和事件选项卡，以显示虚拟机迁移的进度。

了解 WLB 建议的优先级低于高可用性

如果在同一个池中同时启用了 Workload Balancing 和 XenServer 高可用性功能，了解这两项功能的交互方式非常有用。 根据设计，Workload Balancing 不会影响高可用性功能。 如果在 Workload Balancing 建议与高可用性设置之间存在冲突，高可用性设置始终优先。 在实际应用中，这意味着：

  • 超出配置高可用性对话框允许的故障数框中指定的故障数时，Workload Balancing 将不会自动关闭任何主机。
    • 但是，Workload Balancing 建议关闭的主机数仍有可能多于允许的主机故障数。 （例如，当高可用性配置为仅允许一个主机故障时，Workload Balancing 仍会提出关闭两个主机的建议。） 但是，当您尝试应用该建议时，XenCenter 可能显示一条错误消息，指出不再保证实现高可用性。
    • 当 Workload Balancing 在自动化模式下运行并启用了电源管理功能时，任何超出允许的主机故障数的建议都将被忽略。 在此情况下，如果您查看 Workload Balancing 日志，将会看到一条消息，说明由于启用了高可用性而未应用电源管理建议。


使用 Workload Balancing 报告

本主题提供关于 Workload Balancing 历史报告的一般性信息，并概要介绍有关这些报告的更多信息的查找位置。

要生成 Workload Balancing 报告，必须先导入 Workload Balancing 设备并且将池连接到该设备。

简介

Workload Balancing 提供关于三类对象的报告：物理主机、资源池和虚拟机。 在较高级别上，Workload Balancing 提供两种类型的报告：

  • 按日期显示信息的历史报告
  • “汇总”式报告

Workload Balancing 提供一些用于审核目的的报告，以便您做出相关决策，例如确定虚拟机的移动次数。

报告类型

Workload Balancing 提供关于池、主机和 VM 的多种不同报告。 有关详细信息，请参阅 Workload Balancing 报告词汇表。

生成报告

Workload Balancing 允许您生成报告、将报告导出为 PDF 或电子表格，以及打印报告。 有关详细信息，请参阅生成并管理 Workload Balancing 报告。


使用 Workload Balancing 报告完成任务

Workload Balancing 报告可以帮助您执行容量规划、确定虚拟机运行状况以及评估所配置阈值级别的效力。

评估性能阈值的效力

可以使用“池运行状况”报告来评估优化阈值的效力。 Workload Balancing 提供了默认阈值设置。 但是，您可能需要调整这些阈值的默认设置，以提供适合所用环境的值。 如果没有根据所用环境将阈值调整为正确的级别，Workload Balancing 的建议可能不适用于该环境。

排除管理更改的故障

使用“池审核追踪”报告不仅可以确定有问题的更改来自哪里（即用户帐户），而且还可以确定该用户执行的事件或任务。


生成并管理 Workload Balancing 报告

本主题提供有关工作负载报告用法的基本说明，包括如何生成、导航、打印和导出报告。

生成 Workload Balancing 报告

  1. 在 XenCenter 的资源窗格中，选择 your-resource-pool（您的资源池）。
  2. 从池菜单中，选择查看工作负载报告。
    提示: 也可以通过在 WLB 选项卡上单击报告按钮来显示“工作负载报告”屏幕。
  3. 从“工作负载报告”屏幕的左侧窗格中选择一份报告。
  4. 选择报告期的开始日期和结束日期。 根据您所选择的报告，您可能需要指定其他参数，例如主机、用户和对象。
  5. 单击运行报告。 报告将在报告窗口中显示。

在 Workload Balancing 报告中导航

生成报告之后，您可以使用报告中的工具栏按钮来导航和执行某些任务。 要显示工具栏按钮的名称，请将鼠标指针停在工具栏图标上。

报告工具栏按钮：

文档结构图。 用于显示文档结构图，帮助您在大型报告中导航。
前一页/后一页。 用于在报告中向前或向后移动一页。
返回到父报告。 当与分层报告结合使用时，用于返回到父报告。
注: 此按钮仅适用于分层报告，例如池运行状况报告。
停止呈现。 停止生成报告。
打印。 用于打印报告，并指定常规打印选项，例如打印机、页数和份数。
打印布局。 用于在打印报告前显示报告预览。 要退出“打印布局”，请再次单击打印布局按钮。
页面设置。 用于指定打印选项，例如纸张大小、页面方向和页边距。
导出。 用于以 Acrobat (.pdf) 文件格式或以带 .xls 扩展名的 Excel 文件格式导出报告。
查找。 用于在报告中搜索一个词语，例如虚拟机的名称。

打印 Workload Balancing 报告

打印报告之前，必须首先生成报告。

  1. （可选） 要预览打印的文档，请单击 [image] 打印布局。
  2. （可选） 要更改纸张大小/来源、页面方向或页边距，请单击 [image] 页面设置。
  3. 单击 [image] 打印。

导出 Workload Balancing 报告

可以采用 Microsoft Excel 和 Adobe Acrobat (.pdf) 格式导出报告。

生成报告后，单击 [image] 导出并选择以下格式之一：

  • Excel
  • Acrobat (.pdf) 文件
注: 导出报告时所包含的数据量可能因导出格式而异。 导出为 Excel 格式的报告包含可供报告使用的所有数据，其中包括“明细”数据，而在 XenCenter 中显示的报告或导出为 .pdf 的报告仅包含在生成报告时所选择的数据。


Workload Balancing 报告词汇表

本主题提供关于以下 Workload Balancing 报告的信息。

计费使用分析

可以使用“计费使用分析”报告（计费报告）确定组织内的特定部门对某资源（如物理服务器）的使用量。 具体而言，该报告显示池中所有虚拟机的信息，包括其可用性和资源使用情况。 由于该报告提供虚拟机可用性（“运行时间”）信息，因而可以帮助您证明与服务级别协议的符合性及可用性。

计费报告可帮助您实施简单的计费解决方案，并简化收费方式。 要对使用特定资源的客户收费，可以生成此报告，将其另存为 Excel 格式，然后通过自定义电子表格的数据来加入单价，或者将 Excel 数据导入到计费系统中。

如果确定将要对使用虚拟机的内部或外部客户收费，可以考虑在虚拟机命名约定中加入部门或客户名称。 这样会使计费报告更易于阅读。

在某些情况下，计费报告中的资源报告以各虚拟机的物理资源分配量为基础。

同样，由于 XenServer 允许您分配固定的内存量或者由系统自动分配内存量，因此该报告中的平均内存数据以当前分配给虚拟机的内存量为基础，而无论采用固定内存分配方式还是自动调整内存分配量（动态内存控制）。

计费报告包含以下数据列：

  • VM Name（VM 名称）。 该行各列数据所对应的虚拟机的名称。
  • VM Uptime（VM 运行时间）。 虚拟机开启（更确切地说，是 XenCenter 中该虚拟机旁显示绿色图标）的分钟数。
  • vCPU Allocation（VCPU 分配）。 在虚拟机上配置的虚拟 CPU 的数目。 每个虚拟 CPU 将获得相等份额的主机物理 CPU。 例如，如果在一个包含两个物理 CPU 的主机上配置了八个虚拟 CPU，并且此列的值为“1”，则该值相当于主机总处理能力的 2/16。
  • Minimum CPU Usage (%)（最低 CPU 使用率(%)）。 在报告期间内所记录的最低虚拟 CPU 使用率值。 该值以虚拟机虚拟 CPU 容量的百分比来表示，该容量以分配给虚拟机的虚拟 CPU 数为基础。 例如，在您创建虚拟机时，如果为其分配了一个虚拟 CPU，则最低 CPU 使用率表示 XenServer 所记录的最低虚拟 CPU 使用率百分比（即使该使用率只持续了很短的时间）。 如果为该虚拟机分配了两个虚拟 CPU，则此列中的值表示这两个虚拟 CPU 总容量的最低使用率 (%)。

    从根本上说，CPU 使用率百分比表示虚拟 CPU 所处理的最低记录工作负载。 例如，如果为虚拟机分配一个虚拟 CPU，而主机上的物理 CPU 为 2.4 GHz，则该虚拟机将获得 2.4 GHz 的 1/8。 这意味着，如果该虚拟机获得的容量为 0.3GHz (300MHz)，而其最低 CPU 使用率为 20%，则在报告期间内该虚拟机最低使用 60MHz 的物理主机 CPU。

  • Maximum CPU Usage (%)（最高 CPU 使用率(%)）。 在报告期间内虚拟机所占用的虚拟 CPU 容量的最高百分比。 占用的 CPU 容量是基于分配给虚拟机的虚拟 CPU 容量的百分比。 例如，创建虚拟机时，如果为其分配了一个虚拟 CPU，则最高 CPU 使用率表示在报告期间内所记录的最高虚拟 CPU 使用率百分比。 如果为该虚拟机分配了两个虚拟 CPU，则此列中的值表示基于这两个虚拟 CPU 总容量的最高使用率。
  • Average CPU Usage (%)（平均 CPU 使用率(%)）。 Average CPU Usage (%)（平均 CPU 使用率(%)）。 在报告期间内所用虚拟机虚拟 CPU 容量的平均量 (%)。 CPU 容量是分配给虚拟机的虚拟 CPU 容量。 如果为该虚拟机分配两个虚拟 CPU，则此列中的值表示这两个虚拟 CPU 总容量的平均使用率。
  • Total Storage Allocation (GB)（总存储分配(GB)）。 运行报告时分配给虚拟机的磁盘空间量。 通常，此磁盘空间是您在创建虚拟机时为其分配的磁盘空间量，除非对其进行了修改。
  • Virtual NIC Allocation（虚拟 NIC 分配）。 分配给虚拟机的虚拟接口 (VIF) 的数目。
  • Current Minimum Dynamic Memory (MB)（当前最低动态内存(MB)）。
    • Fixed memory allocation（固定内存分配）。 如果为虚拟机分配了固定大小的内存（例如 1024 MB），以下各列中都将显示此内存量：“Current Minimum Dynamic Memory (MB)”（当前最低动态内存(MB)）、“Current Maximum Dynamic Memory (MB)”（当前最高动态内存(MB)）、“Current Assigned Memory (MB)”（当前分配内存(MB)）以及“Average Assigned Memory (MB)”（平均分配内存(MB)）。
    • Dynamic memory allocation（动态内存分配）。 如果将 XenServer 配置为根据范围自动调整虚拟机的内存（即启用了动态内存控制），则此列中将显示为该范围指定的最低内存量。 例如，如果在 XenCenter 的“内存设置”对话框中为该虚拟机选择了“自动在此范围内分配内存”选项，然后指定此范围的最低内存量为 1024MB，最高内存量为 2048MB，则 1024MB 将显示在“Current Minimum Dynamic Memory (MB)”（当前最低动态内存 (MB)）列中。
  • Current Maximum Dynamic Memory (MB)（当前最高动态内存(MB)）。
    • Dynamic memory allocation（动态内存分配）。 如果将 XenServer 设置为根据范围自动调整 VM 的内存，则此列中将显示为该范围指定的最高内存量。 例如，如果您指定的内存范围为最低 1024MB、最高 2048MB，则 2048MB 将显示在“Current Maximum Dynamic Memory (MB)”（当前最高动态内存 (MB)）列中。
    • Fixed memory allocation（固定内存分配）。 如果为 VM 分配了固定大小的内存（例如 1024 MB），以下各列中都将显示此内存量：“Current Minimum Dynamic Memory (MB)”（当前最低动态内存(MB)）、“Current Maximum Dynamic Memory (MB)”（当前最高动态内存(MB)）、“Current Assigned Memory (MB)”（当前分配内存(MB)）以及“Average Assigned Memory (MB)”（平均分配内存(MB)）。
  • Current Assigned Memory (MB)（当前分配内存(MB)）。
    • Dynamic memory allocation（动态内存分配）。 配置了动态内存控制时，此值表示在报告运行时 XenServer 分配给虚拟机的内存量。
    • Fixed memory allocation（固定内存分配）。 如果为虚拟机分配了固定大小的内存（例如 1024 MB），以下各列中都将显示此内存量：“Current Minimum Dynamic Memory (MB)”（当前最低动态内存(MB)）、“Current Maximum Dynamic Memory (MB)”（当前最高动态内存(MB)）、“Current Assigned Memory (MB)”（当前分配内存(MB)）以及“Average Assigned Memory (MB)”（平均分配内存(MB)）。
    注: 如果在运行此报告之前刚刚更改了虚拟机的内存分配，则该列中的值将反映您配置的新内存分配。
  • Average Assigned Memory (MB)（平均分配内存(MB)）。
    • Dynamic memory allocation（动态内存分配）。 如果配置动态内存控制，则该值表示在报告期间 XenServer 分配给虚拟机的平均内存量。
    • Fixed memory allocation（固定内存分配）。 如果为虚拟机分配了固定大小的内存（例如 1024 MB），以下各列中都将显示此内存量：“Current Minimum Dynamic Memory (MB)”（当前最低动态内存(MB)）、“Current Maximum Dynamic Memory (MB)”（当前最高动态内存(MB)）、“Current Assigned Memory (MB)”（当前分配内存(MB)）以及“Average Assigned Memory (MB)”（平均分配内存(MB)）。
    注: 如果在运行此报告之前刚刚更改了虚拟机的内存分配，该列中显示的值可能不会改变。 此列中的值反映的是一段时间内的平均值。
  • Average Network Reads (BPS)（平均网络读取量(BPS)）。 虚拟机在报告期间接收的平均数据量（比特/秒）。
  • Average Network Writes (BPS)（平均网络写入量(BPS)）。 虚拟机在报告期间发送的平均数据量（比特/秒）。
  • Average Network Usage (BPS)（平均网络使用量(BPS)）。 平均网络读取量和平均网络写入量的总和（比特/秒）。 例如，如果虚拟机在报告期间平均每秒发送 1,027 比特，而平均每秒接收 23,831 比特，则平均网络使用量将是这两个值的总和：24,858 比特/秒。
  • Total Network Usage (BPS)（网络使用总量(BPS)）。 在报告期间发生的所有网络读写事务的总量（比特/秒）。

主机运行状况历史记录

此报告显示特定主机上与阈值相关的资源（CPU、内存、网络读取和网络写入）性能。

彩色线（红色、绿色和黄色）代表不同的阈值。 可以结合使用主机的此报告和池运行状况报告，来确定特定主机的性能对整体池运行状况的影响。 编辑性能阈值时，可以通过此报告深入了解主机性能。

可以通过日均或时均方式显示资源使用情况。 时均方式可以让您了解一天中最忙的几个小时，它显示某一时段内的平均资源使用情况。

要查看按小时分组的报告数据，请展开主机运行状况历史记录标题栏下的 + Click to view report data grouped by house for the time period（+ 单击以查看该时段内按小时分组的报告数据）。

Workload Balancing 将显示所设置时段内每小时的平均值。 数据点基于该时段内所有日期该小时的平均利用率。 例如，在 2009 年 5 月 1 日到 2009 年 5 月 15 日的报告中，“平均 CPU 使用率”数据点表示全部 15 天中每天 12:00 的资源使用情况加总后的平均值。 就是说，如果 CPU 在 5 月 1 日正午 12:00 的使用率是 82%，在 5 月 2 日正午 12:00 的使用率是 88%，在所有其他日期中正午 12:00 的使用率都是 75%，那么正午 12:00 的平均使用率显示为 76.3%。

池优化性能历史记录

优化性能报告显示针对池的平均资源使用情况进行的优化事件（即，在优化资源池时发生的事件）。 具体来说，它将显示 CPU、内存、网络读取和网络写入的资源使用情况。

虚线表示在所选日期期间内池的平均利用率。 蓝色条指示进行池优化的日期。

此报告可以帮助您确定 Workload Balancing 在您的环境中是否正常工作。 可以使用此报告查看导致优化事件的原因（即，Workload Balancing 提供优化建议前的资源使用情况）。

此报告显示每天的平均资源使用情况；而不显示峰值利用率（例如当系统处于紧张状态时）。 如果 Workload Balancing 没有提供优化建议，您还可以使用此报告查看资源池的性能情况。

一般来说，在优化事件后，资源使用情况应降低或保持不变。 如果在优化后资源使用情况未出现改进，请考虑重新调整阈值。 此外，请考虑资源池是否有过多虚拟机，以及在您指定的时段内是否添加或删除了新的虚拟机。

池审核追踪

此报告显示 XenServer 审核日志的内容；该 XenServer 功能用于在日志中记录执行未经授权的操作及选择已授权操作的尝试，包括导入/导出、主机和池备份以及来宾系统和主机控制台访问操作。 当使用基于角色的访问控制功能为 XenServer 管理员指定具有不同角色的用户帐户时，此报告可提供更有用的信息。 有关审核日志功能的信息，请参阅《Workload Balancing 管理员指南》中的审核日志文档。

重要: 要运行审核日志报告，必须启用审核日志记录功能。 默认情况下，在 Workload Balancing 虚拟设备中始终启用审核日志。

增强的池审核追踪功能使您能够指定审核日志报告的精度。 您也可以搜索审核追踪日志并按特定用户、对象和时间过滤这些日志。 默认情况下，池审核追踪精度设置为最低。 此选项可捕获有限数量的特定用户和对象类型的数据。 您可以随时根据您报告中所需的详细级别修改设置。 例如，将用户友好的审核日志报告的精度设置为中。 如果您需要非常详细的报告，可以将此选项设置为最大。

要修改池审核追踪精度设置，请执行以下操作：

  1. 在基础结构视图中选择池，单击 WLB 选项卡，然后单击设置。
  2. 在左侧窗格中，单击高级。
  3. 在“高级”页面上，单击池审核追踪报告精度下拉列表，然后从列表中选择一个选项。
    重要: 根据您的审核日志要求选择精度。 例如，如果您将审核日志报告精度设置为最低，则审核报告只能捕获有限数量的特定用户和对象类型的数据。 如果您将精度设置为中，则报告可以提供用户友好的审核日志报告。 如果您选择将精度设置为最大，则报告将包含有关审核日志报告的详细信息。 注意，将审核日志报告设置为“最大”会使 Workload Balancing 服务器使用更多磁盘空间和内存。
  4. 单击确定，确认您的更改。

此报告显示以下内容：

  • Time（时间）。 XenServer 记录用户操作的时间。
  • User Name（用户名）。 创建会话（在该会话中执行操作）的人员的名称。 在某些情况下，此项内容可以是用户 ID。
  • Event Object（事件对象）。 作为操作主体的对象（例如虚拟机）。
  • Event Action（事件操作）。 发生的操作。 有关这些操作的定义，请参阅审核日志事件名称。
  • Access（访问权限）。 用户是否有权执行操作。
  • Object Name（对象名称）。 对象的名称（例如，虚拟机的名称）。
  • Object UUID（对象 UUID）。 对象的 UUID（例如，虚拟机的 UUID）。
  • Succeeded（成功）。 此列提供操作的状态（即，操作是否成功）。

池运行状况

池运行状况报告显示资源池及其主机在四个不同阈值范围（临界阈值、高阈值、中阈值和低阈值）所花费时间的百分比。 您可以使用池运行状况报告来评估性能阈值的效力。

关于本报告的几点解释：

  • 不论您选择哪种放置策略，平均中阈值（蓝色）的资源利用率都是最佳资源利用率。 同样，饼图中的蓝色部分指示主机使用资源的最佳时间量。
  • 平均低阈值百分比（绿色）的资源利用率不一定是正值。 低资源利用率是否为正取决于放置策略。 例如，如果放置策略为“Maximum Density”（密度最大化），而且资源使用情况大多时间为绿色，那么 Workload Balancing 可能不适合该主机或池上虚拟机的最大数量。 如果是这种情况，您应调整性能阈值，直到大部分资源利用率下降到平均中（蓝色）阈值范围内。
  • 平均临界阈值百分比（红色）的资源利用率指示平均资源利用率达到或超过临界阈值的时间量。

如果双击表示主机资源使用情况的饼图，XenCenter 将显示该主机上相应资源（例如 CPU）的“主机运行状况历史记录”报告。 单击返回到父报告工具栏按钮将使您返回到“池运行状况历史记录”报告。 注意：此按钮仅适用于分层报告，例如池运行状况报告。

如果您发现大多数报告结果都不在平均中阈值范围内，您可能需要为此资源池调整临界阈值。 Workload Balancing 提供默认的阈值设置，但这些默认设置并非在所有环境中都有效。 如果不将阈值调整到适合所用环境的正确级别，Workload Balancing 的优化和放置建议可能不适用。 有关详细信息，请参阅更改临界阈值。

注: 高、中和低阈值范围都以临界阈值为基础。

池运行状况历史记录

此报告提供池中所有物理主机的资源利用率随时间变化的线图。 通过此报告，您可以了解资源利用率的趋势 - 是否相对于所设定的阈值（临界、高、中和低）趋向于增加。 通过监视该报告中数据点的趋势，您可以评估性能阈值的效力。

Workload Balancing 会根据您设置的临界阈值来推断阈值范围。 虽然与“池运行状况”报告相似，但“池运行状况历史记录”报告显示的是资源在某一特定日期的平均利用率，而不是处于某个阈值范围的总时长。

除“平均可用内存”图外，数据点的平均值在任何时候都不应越过临界阈值线（红色）。 对于“平均可用内存”图，数据点的平均值在任何时候都不应在临界阈值线（位于图表底部）之下。 由于此图显示可用内存，因此临界阈值为低值，这与其他资源不同。

关于本报告的几点解释：

  • 当表中的“平均使用率”线接近“平均中阈值”（蓝色）线时，它表示池的资源利用率处于最佳状态，而无论配置哪种放置策略。
  • 接近“平均低阈值”（绿色）的资源利用率不一定为正值。 低资源利用率是否为正取决于放置策略。 例如，如果您的放置策略是“Maximum Density”（密度最大化），而大部分日期的平均利用率线与绿线重合或低于绿线，那么 Workload Balancing 可能未尽可能密集地在该池上放置虚拟机。 如果是这种情况，您应调整池的临界阈值，直到其大部分资源利用率下降到平均中（蓝色）阈值范围内。
  • 当“平均使用率”线与“平均临界阈值百分比”（红色）相交时，这表示平均资源利用率达到或超过该资源临界阈值的天数。

如果您发现图中的大多数数据点都不在平均中阈值范围内，但您又对此池的性能很满意，您可能需要调整该池的临界阈值。 有关详细信息，请参阅更改临界阈值。

池优化历史记录

利用池优化历史记录报告可以按时间顺序查看 Workload Balancing 优化活动。

优化活动以图形和表格形式进行汇总。 深入表格内部的日期字段时，将显示当日执行的每个池优化的详细信息。

利用此报告可以查看以下信息：

  • VM Name（VM 名称）。 Workload Balancing 优化的虚拟机的名称。
  • Reason（原因）。 进行优化的原因。
  • Status（状态）。 优化是否成功。
  • From Host（来源主机）。 最初托管虚拟机的物理服务器。
  • To Host（目标主机）。 虚拟机移动到的物理服务器。
  • Time（时间）。 发生优化的时间。
提示: 还可以通过在 WLB 选项卡上单击查看历史记录链接来生成“池优化历史记录”报告。

虚拟机移动历史记录

此线图显示一段时间内虚拟机在一个资源池中的移动次数。 它将指示移动是否源于优化建议，以及虚拟机移动到哪个主机。 此报告还将指示进行优化的原因。 您可以使用此报告审核池中发生移动的次数。

关于本报告的几点解释：

  • 图表左侧的数值代表可能的移动次数，该值基于资源池中虚拟机的数量。
  • 展开报告日期部分中的 + 号，可以查看特定日期移动的详细情况。

虚拟机性能历史记录

此报告显示在您指定的时段内特定主机上每个虚拟机的性能数据。 Workload Balancing 的性能数据基于为虚拟机分配的虚拟资源数量。 例如，如果虚拟机的平均 CPU 使用率为 67%，这意味着在您指定的时段内，虚拟机平均占用了 67% 的虚拟 CPU。

该报告的初始视图显示在指定的时段内资源利用率的平均值。

展开 + 号后，将显示各资源的线图。 可以使用这些图来查看资源利用率随时间变化的趋势。

该报告显示 CPU 使用率、可用内存和网络读取/写入的数据。


审核日志事件

审核日志报告会记录 XenServer 事件、事件对象和操作，包括导入/导出、主机和池备份以及来宾和主机控制台访问。 下表定义了 XenServer 审核日志和池审核追踪报告中经常出现的典型事件，它还指定了这些事件的精度。

在池审核追踪报告中，“事件操作”列中列出的事件适用于池、VM 或主机。 要确定事件应用的对象，请参阅该报告中的事件对象和对象名称列。 有关更多事件定义，请参阅《Citrix XenServer 管理 API 指南》。 要了解更多有关池审核追踪精度设置的详细信息，请参阅 高级设置。

池审核追踪精度 | 事件操作 | 用户操作
最低 | VM.start | 启动虚拟机。
最低 | VM.copy | 复制指定的 VM，从而创建新 VM。
最低 | host.reboot | 重新启动 XenServer 主机。
最低 | host.disable | 将主机置于无法启动任何新 VM 的状态。
最低 | pool.join | 指示主机加入新池。
最低 | pool.join_force | 指示（强制）主机加入新池。
中 | SR.destroy | 毁坏存储库。
中 | SR.create | 创建一个新的存储库。
中 | VDI.snapshot | 生成 VDI 的一个只读快照，返回引用给快照。
中 | VDI.clone | 生成 VDI 的一个完全相同的副本，返回引用给新磁盘。
中 | VIF.plug | 热插拔指定的 VIF，将它动态连接到运行中的 VM。
中 | VIF.unplug | 热插拔指定的 VIF，动态断开它与运行中的 VM 的连接。
最大 | auth.get_subject_identifier | 查询外部目录服务，从人类可识别的主题名称获取字符串形式的主题标识符。
最大 | task.cancel | 请求取消任务。
最大 | VBD.insert | 将新的介质插入设备。
最大 | VIF.get_by_uuid | 引用含有指定 UUID 的 VIF 实例。
最大 | VDI.get_sharable | 获得给定 VDI 的可共享字段。
最大 | SR.get_all | 返回系统已知的所有 SR 的列表。
最大 | pool.create_new_blob | 为与此池相关的已命名二进制数据大对象创建一个占位符。
最大 | host.send_debug_keys | 将给定字符串作为调试密钥注入到 Xen 中。
最大 | VM.get_boot_record | 返回一个描述 VM 动态状态的记录，在 VM 启动和更新时初始化，以反映运行时配置变化，例如 CPU 热插拔。


编辑 Workload Balancing 设置

连接到 Workload Balancing 虚拟设备后，可以编辑 Workload Balancing 在计算放置和优化建议所使用的设置。 可以执行如下的任务：
  • 调整优化模式
  • 设置自动化和电源管理
  • 更改临界阈值
  • 调整指标加权
  • 从建议中排除主机
  • 高级设置
注: 连接或重新连接到 Workload Balancing 后，在更改设置之前应至少等待六十秒，直到 Workload Balancing (/var/log/wlb/LogFile.log) 显示检测完成。

Workload Balancing 设置的应用方式

Workload Balancing 设置共同应用于池中的所有虚拟机和主机。

如果网络阈值与环境中的硬件相符，初始时可以考虑使用 Workload Balancing 中的大多数默认设置。

在 Workload Balancing 启用一段时间后，Citrix 建议评估性能阈值，并确定是否需要编辑这些阈值。 例如，以下情况下应考虑调整阈值：
  • 获得的优化建议并不是您需要的。 这种情况下请尝试调整阈值，直到 Workload Balancing 能够给出适当的优化建议。
  • 在您认为网络带宽不足时未能获得建议， 请尝试降低网络临界阈值，直到 Workload Balancing 能够给出优化建议。

在编辑阈值前，您会发现，为池中的每台物理主机生成主机运行状况历史记录报告是很方便的。

可以使用 XenCenter 中的 Workload Balancing Configuration 属性或者 XE 命令修改配置设置。

要更新 XenServer 与 Workload Balancing 服务器通信时所使用的凭据，请参阅更新 Workload Balancing 凭据。

有关调整 Workload Balancing 设置的更详细指导，请参阅《Workload Balancing 管理员指南》。

显示 Workload Balancing 设置对话框

  1. 在 XenCenter 的资源窗格中，选择 your-resource-pool（您的资源池）。
  2. 在属性窗格中，单击 WLB 选项卡。
  3. 在 WLB 选项卡中，单击设置。


调整优化模式

Workload Balancing 根据您选择的放置策略（称为优化模式）提出建议，以重新平衡（或称优化）环境中的虚拟机工作负载。

密度最大化和性能最大化模式

可以选择以下两种优化模式之一：
  • 性能最大化。 （默认设置。） Workload Balancing 尝试在资源池中的所有物理主机上平均分布工作负载。 目标是最大限度地降低所有主机上 CPU、内存和网络的压力。 如果您选择了“最高性能”放置策略，Workload Balancing 将在一台虚拟机达到“最高”阈值时提出优化建议。

  • 密度最大化。 Workload Balancing 尝试在一台物理主机上安装尽可能多的虚拟机。 目标是最大限度地减少需要联机的物理主机数量。

    如果选择“密度最大化”放置策略，可以指定与“性能最大化”相似的规则。 但是，Workload Balancing 会使用这些规则来确定如何将这些虚拟机装进一个主机中。 如果选择“密度最大化”放置策略，Workload Balancing 将在一台虚拟机达到“临界”阈值时提供优化建议。

Workload Balancing 还允许您始终应用这些优化模式（固定模式），或者按指定的时段在各模式之间进行切换（排定模式）。

固定

固定优化模式将 Workload Balancing 设置为始终执行特定的优化行为，即尝试实现最佳性能或者尝试实现最高密度。

排定

计划优化模式允许您安排 Workload Balancing 根据一天中的具体时间应用不同的优化模式。 例如，在白天，当有用户处于连接状态时，可以将 Workload Balancing 配置为优化性能，而在夜晚，为了节约能源，可以将 Workload Balancing 指定为以密度最大化为目的进行优化。

配置“排定”优化模式时，Workload Balancing 会在指定时段开始时（星期几以及具体时间）自动切换为相应优化模式。

设置所有时段的优化模式

  • 在资源窗格中选择池，单击 WLB 选项卡，然后单击设置。
  • 在左侧窗格中，单击优化模式。
  • 选择固定，然后选择以下优化模式之一：
    • 性能最大化。 （默认设置。） 尝试在资源池中的所有物理主机上平均分布工作负载。 目标是最大限度地降低所有主机上 CPU、内存和网络的压力。
    • 密度最大化。 尝试在一台物理主机上安装尽可能多的虚拟机。 目标是最大限度地减少需要联机的物理主机数量。 （请注意，Workload Balancing 将考虑合并后 VM 的性能，并在主机上的某项资源达到临界阈值时，提出提高性能的建议。）

指定优化模式自动切换的时间

  • 在资源窗格中选择池，单击 WLB 选项卡，然后单击设置。
  • 在左侧窗格中，单击优化模式。
  • 选择排定。
  • 单击添加新项以打开优化模式计划程序对话框。
  • 在更改为列表框中选择一种优化模式：
    • 性能最大化。 尝试在资源池中的所有物理主机上平均分布工作负载。 目标是最大限度地降低所有主机上 CPU、内存和网络的压力。
    • 密度最大化。 尝试在一台物理主机上安装尽可能多的虚拟机。 目标是最大限度地减少需要联机的物理主机数量。
  • 选择希望 Workload Balancing 开始以此模式运行的星期和时间。
  • 创建更多的计划模式切换（即“任务”），直至达到所需的数量。 如果只计划一个任务，Workload Balancing 将切换到该模式，而永远不会切换回原来的模式。
  • 单击确定。

删除或暂停计划的优化模式任务

  1. 在资源窗格中选择池，单击 WLB 选项卡，然后单击设置。
  2. 单击优化模式。
  3. 选择一项排定的任务，并单击以下选项之一：
    • 永久删除任务。 单击删除按钮。
    • 暂时停止任务运行。 在任务上单击鼠标右键，然后单击禁用。

    要重新启用某项任务，请在计划模式更改列表中的该任务上单击鼠标右键。

编辑计划的优化模式任务

  1. 在资源窗格中选择池，单击 WLB 选项卡，然后单击设置。
  2. 选择一项计划的任务。
  3. 单击编辑。
  4. 在更改为框中，选择其他模式，或者根据需要进行其他更改。


自动优化和管理电源

可以将 Workload Balancing 配置为自动接受优化建议（自动化），并自动打开或关闭服务器（电源管理）。

自动接受优化建议

可以将 Workload Balancing 配置为代表您自动接受优化建议，并自动执行其建议的优化操作。 您可以使用此功能（称为自动化）自动应用任何建议，包括提高性能或关闭主机的建议。 但是，要在虚拟机使用率下降时关闭主机，必须配置自动化功能、电源管理功能和密度最大化模式。

默认情况下，Workload Balancing 不自动接受优化建议。 如果希望 Workload Balancing 自动接受建议，必须启用“自动化”功能。 否则，Workload Balancing 仍然会提示您手动接受建议。

如果建议与高可用性设置冲突，则 Workload Balancing 不会自动将这些建议应用于主机或虚拟机。 如果应用 Workload Balancing 优化建议将导致池被过度使用，XenCenter 将询问您是否要继续应用建议。 如果启用“自动化”功能，Workload Balancing 应用的电源管理建议的数量不会超出“高可用性”计划中允许的主机故障数量。

可以调整 Workload Balancing 在自动化模式下应用建议的方式。 有关详细信息，请参阅高级设置。

启用电源管理

术语电源管理是指开启或关闭物理主机电源的能力。 在 Workload Balancing 环境中，此术语是指根据池的总工作负载开启或关闭该池中的主机。

在主机上配置 Workload Balancing 电源管理需要满足以下条件：
  • 主机服务器的硬件具有远程开/关机功能
  • 为该主机配置主机启动功能
  • 已将该主机明确选择为参与 (Workload Balancing) 电源管理
此外，如果希望 Workload Balancing 自动关闭主机，还需要进行以下配置：
  • 将 Workload Balancing 配置为自动应用建议
  • 将 Workload Balancing 配置为自动应用电源管理建议

启用了电源管理功能并且池处于密度最大化模式时，如果 Workload Balancing 检测到未使用的资源，会提出关闭主机的建议，直到消除池中的所有过剩容量。 如果 Workload Balancing 检测到池中的主机容量不足以关闭服务器，会建议将服务器保持打开状态，直到该池的工作负载降低到足以关闭服务器的水平。 如果您将 Workload Balancing 配置为自动关闭额外服务器，它会自动应用这些建议，其结果与手动模式相同。

主机设置为参与电源管理时，Workload Balancing 会根据需要提出开/关机建议。 如果启用用于自动应用电源管理建议的选项，应在池级别启用。 但可以指定希望池中的哪些主机参与电源管理。

了解电源管理行为

Workload Balancing 在提出开启或关闭主机的建议之前，会选择虚拟机要转移（即“填充”）到的主机。 按以下顺序进行转移：
  1. 填充池主服务器，因为该主机无法关闭。
  2. 填充包含最多虚拟机的主机。
  3. 在后续主机中选择运行最多虚拟机的主机来填充。

当 Workload Balancing 填充池主服务器时，会为该服务器假定一个低（内部）阈值。 Workload Balancing 使用这些低阈值作为缓冲，来防止池主服务器过载。

Workload Balancing 按照此顺序填充主机以提高密度。

此图解释了在密度最大化模式下在主机上合并 VM 时，XenServer 将尝试首先填充池主服务器，然后填充负载最高的服务器，最后填充负载最低的服务器。

当池处于密度最大化模式时，如果 Workload Balancing 检测到性能问题，它会通过建议在已开启的主机之间迁移工作负载，尝试解决该问题。 如果 Workload Balancing 通过这种方法不能解决该问题，它会尝试打开主机。 （Workload Balancing 在决定要打开的主机时，所应用的标准与“性能最大化”优化模式相同。）

当 Workload Balancing 在性能最大化模式下运行时，只要池中所有主机上的资源利用率未降至高阈值以下，Workload Balancing 就会提出开启主机的建议。

在迁移一个或多个虚拟机时，如果 Workload Balancing 确定提高容量对池的整体性能有益，它会自动开启主机，或者建议开启主机。
重要: 除非主机是由 Workload Balancing 关闭的，否则 Workload Balancing 绝不会建议您将其打开。

针对电源管理和 VM 整合设计环境

如果要配置自动 VM 合并和电源管理功能，在对 XenServer 的实施进行规划时，应考虑工作负载设计。 例如，您可能需要：

  • 将不同类型的工作负载放置在不同的池中。 如果您的环境中包含不同类型的工作负载（例如，用户应用程序与域控制器）或者更适用于某些硬件类型的应用程序类型，则应考虑是否需要将托管这些工作负载的虚拟机放置在不同的池中。

    由于电源管理和 VM 合并在池级别进行管理，因此设计的池中应包含要以相同比率合并的工作负载，并需要考虑多项因素，例如高级设置主题中讨论的因素。

  • 从 Workload Balancing 排除主机。 某些主机可能需要始终处于开启状态。 有关详细信息，请参阅从建议中排除主机。

自动应用优化建议

  1. 在 XenCenter 的资源窗格中，依次选择 XenCenter > your-resource-pool（您的资源池）。
  2. 在属性窗格中，单击 WLB 选项卡。
  3. 在 WLB 选项卡中，单击 Configure WLB（配置 WLB）。
  4. 在左侧窗格中，单击自动化。
  5. 选中以下一个或多个复选框：
    • 自动应用优化建议。 如果选中此选项，则无需手动接受优化建议。 Workload Balancing 会自动接受提供的优化和放置建议。
    • 自动应用电源管理建议。 此选项的行为因池的优化模式而异：
      • 性能最大化模式。 当启用了自动应用电源管理建议时，如果可以通过开启主机来提高主机性能，Workload Balancing 将自动开启主机。
      • 密度最大化模式。 当启用了自动应用电源管理建议时，Workload Balancing 将在资源利用率降到低阈值以下时，自动关闭主机（即 Workload Balancing 在资源利用率较低的时段自动关闭主机）。
  6. 执行以下操作之一：
    • 如果要配置电源管理功能，请单击自动化/电源管理并继续。
    • 如果不希望配置电源管理并且已完成自动化功能的配置，请单击确定。

选择要进行电源管理的服务器

  1. 在“电源管理”部分，选择希望 Workload Balancing 自动开启和关闭的主机。
    注: 如果在选择要获得电源管理建议的主机时未选中自动应用电源管理建议复选框，Workload Balancing 会提出电源管理建议，但不会自动应用这些建议。
  2. 单击 OK（确定）。 如果资源池中的所有物理服务器均不支持远程电源管理，Workload Balancing 会显示所有主机均不支持电源管理消息。


更改临界阈值

本主题将介绍修改默认临界阈值的方法，并说明设置的临界阈值如何改变高、中、低阈值。

这些信息仅作为更改阈值时的参考。 要了解本主题中所讨论的概念，务必在《Workload Balancing 管理员指南》所提供的更全面的参考环境中阅读这些内容。

概述

评估利用率时，Workload Balancing 将日常平均值与四个阈值（低、中、高和临界）进行比较。在指定临界阈值（或接受默认值）后，Workload Balancing 将相对于池中的临界阈值设置其他阈值。 可能需要通过更改临界阈值来控制触发优化建议的时机。

Workload Balancing 可为资源池中的物理主机评估 CPU、内存、网络读取和网络写入利用率。

通过评估以下内容，Workload Balancing 可以确定是否提出重定位工作负载的建议，以及确定物理主机是否适合虚拟机工作负载：
  • 物理主机上是否有资源达到临界阈值
  • （如果达到临界阈值）为资源指定的重要性
注: 为防止数据虚高，Workload Balancing 将评估资源的日常平均值，并对利用率峰值进行平滑处理。

有关详细信息，请参阅《Workload Balancing 管理员指南》。

Workload Balancing 将根据资源的历史平均利用率是否超出阈值来决定是否生成建议。 如《Workload Balancing 管理员指南》中所述，如果在性能最大化模式下超出高阈值，或者在密度最大化模式下低于低阈值和临界阈值，将触发 Workload Balancing 建议。 为资源指定新临界阈值后，Workload Balancing 会相对于新临界阈值重置该资源的其他阈值。 （为了简化用户界面，通过 XenCenter 只能更改临界阈值。）

阈值的默认设置

下表显示了 Workload Balancing 阈值的默认值：
设置 | 默认值 | 高 | 中 | 低
CPU 使用率 | 90% | 76.5% | 45% | 22.5%
可用内存 | 51 MB | 63.75 MB | 510GB | 1020GB
网络读取 | 25 MB/秒 | 21.25 MB/秒 | 12.5 MB/秒 | 6.25 MB/秒
网络写入 | 25 MB/秒 | 21.25 MB/秒 | 12.5 MB/秒 | 6.25 MB/秒
在计算“高”、“中”和“低”资源指标的值时，Workload Balancing 会将临界阈值的新值与以下因数相乘：
  • 高阈值因数：0.85
  • 中阈值因数：0.50
  • 低阈值因数：0.25
在计算可用内存的阈值时，Workload Balancing 会将临界阈值与以下因数相乘：
  • 高阈值因数：1.25
  • 中阈值因数：10.0
  • 低阈值因数：20.0

这意味着，如果您将池的 CPU 使用率临界阈值提高至 95%，Workload Balancing 会自动将高、中和低阈值分别重置为 80.75%、47.5% 和 23.75%。

要对特定阈值执行此计算，请将阈值因数与您为该资源输入的临界阈值相乘：

高、中或低阈值 = 临界阈值 * 阈值因数

例如，如果您将“网络读取”的临界阈值更改为 40 MB/秒，并且想知道其低阈值，可以用 40 乘以 0.25，得出 10 MB/秒。 要得到中阈值，可以用 40 乘以 0.50，依此类推。

为防止池主服务器过载，Workload Balancing 会自动将池主服务器的临界阈值设置得较低。

其他阈值如何触发建议

尽管临界阈值可以触发许多建议，但其他阈值也可以触发建议，如下所述：

高阈值。
  • 性能最大化。 超出高阈值会触发将虚拟机重定位到资源利用率较低的主机的优化建议。
  • 密度最大化。 如果将虚拟机移动到主机会导致该主机上任何资源的利用率超出高阈值，Workload Balancing 将不会提出将该虚拟机放置到该主机的建议。
低阈值。
  • 性能最大化。 Workload Balancing 不会因低阈值而触发建议。

  • 密度最大化。 当某个指标值降到低阈值以下时，它会向 Workload Balancing 发出信号，告知主机利用率偏低，并触发将虚拟机合并到更少主机上的优化建议。 Workload Balancing 将持续提出将虚拟机移动到某个主机的建议，直至该主机某个资源的指标值达到高阈值为止。

    但是，如果在重定位某个虚拟机后，该虚拟机所在新主机上的某种资源的利用率超出其临界阈值，Workload Balancing 将临时使用与性能最大化负载平衡算法相类似的算法来为虚拟机查找新主机。 Workload Balancing 将持续使用此算法来提出移动虚拟机的建议，直到池中各主机上的资源利用率都降至高阈值以下。

更改临界阈值

  1. 在资源窗格中选择池，单击 WLB 选项卡，然后单击设置。
  2. 在左侧窗格中，选择临界阈值。

  3. 在临界阈值页面中，接受临界阈值框中的值或输入一个新值。 在提供虚拟机放置和池优化建议时，Workload Balancing 会使用这些阈值。 Workload Balancing 会努力将主机的资源利用率保持在设定的临界阈值以下。


调整指标加权

注: 在调整指标加权之前，Citrix 建议您阅读《Workload Balancing 管理员指南》中关于优化和合并过程的内容。 本帮助主题中的信息是该指南所含信息的一部分，仅作为更改用户界面时的参考。

Workload Balancing 使用指标加权（一种指定资源重要性的方法）确定应该首先优化的主机。

确定首先处理的主机和 VM 时，Workload Balancing 对指标加权的使用方式因优化模式（密度最大化或性能最大化）而异。

Workload Balancing 处理优化建议时，将创建优化顺序。 确定此顺序时，Workload Balancing 将最重要资源拥有最高指标值的主机排在最优先处理的位置，资源的重要性通过指标加权页面排定。

通常，指标加权主要在池处于性能最大化模式时使用。 但是，当 Workload Balancing 处于密度最大化模式时，如果某个资源超出其临界阈值，也会使用指标加权。

在性能最大化模式下应用指标加权的方式

在性能最大化模式下，Workload Balancing 使用指标加权确定：(a) 首先处理哪些主机的性能；(b) 建议首先迁移哪些 VM。

例如，如果将“网络写入”排定为 Workload Balancing 应考虑的最重要资源，即您将指标加权滑块移动到最右端（更重要），而将所有其他滑块移动到中间，则 Workload Balancing 将首先在每秒网络写入量最多的主机上解决性能问题（即提供优化建议）。

在密度最大化模式下应用指标加权的方式

在密度最大化模式下，Workload Balancing 仅在某个主机达到临界阈值时使用指标加权，然后 Workload Balancing 应用一种与性能最大化模式类似的算法，直到没有任何主机超出临界阈值。 使用与性能最大化模式类似的算法时，Workload Balancing 按照与性能最大化模式相同的方式，使用指标加权来确定优化顺序。

如果两个或更多主机的资源超出其临界阈值，Workload Balancing 将首先验证您为每个资源设置的重要性，然后据此确定要优先进行优化的主机，以及该主机上要优先重定位的 VM。

例如，池中包含主机 A 和主机 B，二者分别处于以下状态：
  • 主机 A 上的 CPU 使用率超出了 CPU 临界阈值，而 CPU 使用率的指标加权设置在滑块最右端（更重要）。
  • 主机 B 上的内存利用率超出了内存临界阈值，而内存利用率的指标加权设置在滑块最左端（不太重要）。

Workload Balancing 将提出首先优化主机 A 的建议，因为该主机上达到临界阈值的资源是权重值最高的资源。 在 Workload Balancing 确定需要处理主机 A 的性能后，便开始为该主机上的 VM 提出放置建议，首先从 CPU 使用率最高的 VM 开始，因为 CPU 使用率是权重值最高的资源。

Workload Balancing 在提出优化主机 A 的建议后，将提出主机 B 的优化建议。 当它为主机 B 上的 VM 提出放置建议时，将首先处理 CPU 使用率，因为 CPU 使用率具有最高权重。

如果有其他需要优化的主机，Workload Balancing 将处理 CPU 使用率排在第三位的主机的性能。

默认情况下，所有指标加权设置在滑块的最远点（更重要）。
注: 指标加权是相对值。 这意味着如果所有指标设置为相同级别，那么即使该级别为不太重要，它们的权重也是相同的。 比起为每个指标设置的实际权重，各指标之间的关系更重要。

编辑指标加权系数

  1. 在资源窗格中选择池，单击 WLB 选项卡，然后单击设置。
  2. 在左侧窗格中，选择指标加权。
  3. 在指标加权页面中，根据需要调整各资源旁的滑块。

    如果将滑块移向不太重要，表明在该资源池中，确保虚拟机始终具有最高数量的可用该资源不太重要。


从建议中排除主机

配置 Workload Balancing 时，可以指定从 Workload Balancing 优化和放置建议（包括“启动”放置建议）中排除特定的物理主机。

何时排除主机

以下情况下可能需要从建议中排除主机：
  • 要在密度最大化模式下运行池、合并及关闭主机，但希望某些特定主机不实施该行为。
  • 两个虚拟机工作负载始终需要在同一主机上运行（例如，它们是互补的应用程序或工作负载）。
  • 不希望移动某些工作负载（例如，域控制器或 SQL Server）。
  • 您需要对主机执行维护，而不希望将虚拟机放置在该主机上。
  • 工作负载性能的重要性高过专用硬件的成本。
  • 特定主机上正在运行高优先级的工作负载（虚拟机），而您并不希望使用高可用性功能来为这些虚拟机确定优先级。
  • 主机中的硬件对于池中的其他工作负载并不是最优选择。

无论指定固定优化模式还是计划优化模式，即使切换优化模式，已排除的主机仍会被排除。 因此，如果您只希望阻止 Workload Balancing 自动关闭某个主机，则应考虑不为该主机启用（或取消选择）电源管理功能，如自动优化和管理电源中所述。

从放置和优化建议中排除主机

  1. 在资源窗格中选择池，单击 WLB 选项卡，然后单击设置。
  2. 在左侧窗格中，选择排除的主机。
  3. 在排除的主机页面中，选择您不希望 Workload Balancing 提出备用放置和优化建议的主机。


高级设置

高级对话框中的设置主要用于调整 Workload Balancing 在自动化模式下运行时应用建议的方式。
重要:

在 Workload Balancing 运行一段时间之后，如果您没有收到最佳放置建议，Citrix 强烈建议您对性能阈值进行评估，如《Workload Balancing 管理员指南》中所述。 根据环境为 Workload Balancing 设置正确的阈值至关重要，否则它可能无法提供适当的建议。

概述：设置保守或主动的自动化建议

在自动化模式下运行时，提供优化和合并建议的频率以及自动应用这些建议的时间由多种因素决定，包括：
  • 您所指定的、Workload Balancing 在应用其他优化建议之前等待的时间
  • Workload Balancing 在自动应用某个建议之前必须达到的建议数
  • 在自动应用优化前建议必须达到的严重级别
  • Workload Balancing 在自动应用建议之前需要的建议（建议移动的虚拟机，目标主机）一致性级别

VM 迁移时间间隔

可以指定上次移动特定虚拟机后（无论是何原因），Workload Balancing 必须等待多久（分钟）才能生成包含该特殊虚拟机的其他优化建议。

建议间隔用于防止 Workload Balancing 由于不实的原因（例如，利用率短暂达到峰值）生成建议。

如果配置了“自动化”功能，则修改建议间隔时务必要非常小心。 如果出现导致持续、反复出现尖峰的问题，则提高频率（即设置更低的间隔值）会产生大量建议，从而发生多次重新定位。
注: Workload Balancing 需要等待一段时间才会考虑将最近重新平衡的服务器纳入启动放置、恢复及维护模式的建议，而设置建议间隔不会对这段等待时间产生影响。

建议计数

Workload Balancing 每两分钟进行一次检查，判断能否为正在监视的池生成建议。 启用“自动化”功能时，可以指定 Workload Balancing 必须提供多少次一致的建议才能自动应用该建议。 为此，需要配置一项称为“建议计数”的设置。 “建议计数”和“优化主动性”设置用于调整在环境中自动应用程序建议的方式。

如概述部分所述，Workload Balancing 利用建议的相似性来：a) 确认是否真正需要提供建议；b) 确定目标主机是否在较长时间内有足够稳定的性能来接受重定位的虚拟机（而无需在不久后将其再次从主机移出）。 Workload Balancing 使用“建议计数”值来确定在 Workload Balancing 自动应用建议之前必须重复提出该建议的次数。

Workload Balancing 按如下所述使用此设置：
  1. 每次 Workload Balancing 生成满足一致性要求（由“优化主动性”设置指定）的建议时，Workload Balancing 都会将“建议计数”值递增。 如果该建议不满足一致性要求，Workload Balancing 可能会将“建议计数”重置为零，具体取决于《Workload Balancing 管理员指南》中所述的因素。
  2. 当 Workload Balancing 生成符合“建议计数”值（在“建议”文本框中指定）且足够数量的一致建议时，它将自动应用建议。
如果您选择修改此设置，应根据环境的不同来设置该值。 请考虑以下情形：
  • 如果您环境中的服务器负载和活动急速增加，可能需要增大“建议计数”的值。 Workload Balancing 每两分钟生成一次建议。 举例来说，如果将此间隔设置为“3”，则在六分钟后，Workload Balancing 将自动应用建议。
  • 如果您环境中的服务器负载和活动逐渐增加，则可能需要减小“建议计数”的值。

在 Workload Balancing 重定位虚拟机时，接受建议会占用系统资源，并对性能产生影响。 增大“建议计数”的值会增加在 Workload Balancing 应用建议之前必须出现的匹配建议的数目，从而促使 Workload Balancing 应用更保守、稳定的建议，并且降低错误移动虚拟机的可能性。 但应注意，“建议计数”的默认设置较为保守。

由于调整此设置可能会对环境产生影响，Citrix 建议在更改此设置时要极其小心，最好反复测试并更改此值，或者在 Citrix 技术支持人员的指导下进行。

建议严重性

所有优化建议都包含一个严重性级别（严重、高、中、低），用于指示建议的重要程度。 Workload Balancing 根据多项因素的组合确定该严重级别，这些因素包括您设置的配置选项，例如阈值和指标调整、可供工作负载使用的资源以及资源使用情况历史记录。

如果将 Workload Balancing 配置为自动应用优化建议，则可以设置在 Workload Balancing 自动应用优化建议之前应与该建议相关联的最低严重级别。

优化主动性

在自动化模式下运行时，为了提供更多的保证，Workload Balancing 针对自动接受优化规定了一致性条件，以避免由于高峰和异常而移动虚拟机。 在自动化模式下，Workload Balancing 不会接受所生成的第一个建议， 而是一直等到主机或虚拟机持续出现一致行为时才自动应用建议。 “持续出现一致行为”这句话是指某个主机是否持续触发建议，以及该主机上的相同虚拟机是否持续触发建议等等因素。

Workload Balancing 通过使用一致性条件以及规定同一个建议提出次数（即建议计数）的条件来判断行为是否一致。 您可以使用优化的主动性设置来配置希望 Workload Balancing 应用一致性条件的严格程度。

虽然 Citrix 设计优化主动性设置主要是为了进行演示，但您可以使用该设置来控制在 Workload Balancing 应用优化建议之前环境中需要达到的稳定程度。 默认情况下配置为最稳定的设置（低主动性）。 在此上下文中，术语“稳定”是指建议的更改具有持续的相似性，如本部分内容所介绍。

Workload Balancing 最多使用四个条件来确定一致性。 必须满足的条件数因您在优化的主动性设置中设定的级别而异。 级别越低（例如“低”或“中”），Workload Balancing 接受建议的主动性就越低。 换言之，当主动性设置为“低”时，Workload Balancing 对于满足一致性条件的要求更加严格（或者说更具限制性或更不主动）。

例如，如果主动性级别设置为“低”，则 Workload Balancing 要求在自动应用建议之前，每个“低”值条件都符合在“建议”框中（用于指定“建议计数”值）指定的次数。

例如，如果在建议框中将“建议计数”设置为“3”，则 Workload Balancing 将一直等到满足《Workload Balancing 管理员指南》中针对低值所列的所有条件并且连续三次重复提出建议时，才会应用该建议。 这样有助于确保虚拟机确实需要移动，而且 Workload Balancing 推荐的目标主机在较长时间内具有持续稳定的资源利用率。 这样可以降低最近移动过的虚拟机由于移动后主机性能发生改变而又从主机移出的可能性。 默认情况下，此项设置设为保守设置（“低”）以促进稳定性。

Citrix 建议不要通过增加优化的主动性值来提高主机优化频率。 如果您觉得您的主机优化速度不够快或频率不够高，请尝试调整临界阈值，如更改临界阈值中所述。

有关与不同主动性级别相关的一致性条件的详细信息，请参阅《Workload Balancing 管理员指南》。

如果您发现 Workload Balancing 自动应用优化建议的频率不够高，则需要增大主动性设置的值。 但 Citrix 强烈建议您在进行上述调整之前，先查阅《Workload Balancing 管理员指南》中的相关信息。

配置虚拟机建议时间间隔

  1. 在基础结构视图中选择池，单击 WLB 选项卡，然后单击设置。
  2. 在左侧窗格中，单击高级。
  3. 在 VM 迁移时间间隔部分，执行以下一项或多项操作：

    - 在分钟(等待时间)框内，键入希望 Workload Balancing 在对刚刚重新平衡的服务器提出其他优化建议之前等待的时间（分钟）。

    - 在建议计数框内，键入希望 Workload Balancing 在自动应用优化建议之前提出的优化建议的数量。

    - 从建议严重性列表中，选择自动应用优化之前的最低严重级别。

    - 从优化主动性列表中，指定 Workload Balancing 如何主动地自动应用优化建议。

池审核追踪精度

Workload Balancing 使您能够指定要在池审核追踪报告中收集的数据量。 此功能还允许您搜索审核追踪日志并按特定用户、对象和时间对这些日志进行过滤。

默认情况下，池审核追踪精度设置为最低。 此选项可捕获有限数量的特定用户和对象类型的数据。 您可以随时根据您报告中所需的详细级别修改设置。 例如，将用户友好的审核日志报告的精度设置为中。 如果您需要非常详细的报告，可以将此选项设置为最大。
重要: 将池审核追踪精度设置为“最大”会使 Workload Balancing 服务器使用更多磁盘空间和内存。 如果您选择将精度设置为“最大”，则建议您仔细监控 WLB 服务器的磁盘空间、内存使用率和 CPU 使用率。 如果您认为 WLB 服务器存在资源压力，您应将精度设置更改为“中”或“最低”，或考虑扩展您 WLB 服务器的内存或硬盘大小。

有关详细信息，请参阅 Workload Balancing 报告词汇表 和 审核日志事件。


管理 Workload Balancing

您可能会对 Workload Balancing 执行一些管理任务，这些任务包括：
  • 与 Workload Balancing 断开连接
  • 更改池使用的 Workload Balancing 虚拟设备
  • 更改 Workload Balancing 或 XenServer 用来进行通信的凭据
还可以使用 Workload Balancing 服务命令管理 Workload Balancing 虚拟设备。 这些命令可用于确定 Workload Balancing 虚拟设备状态、更改用户帐户以及提高日志记录详细程度。 有关这些命令的信息，请参阅《Workload Balancing 管理员指南》。
注: 有关将 Workload Balancing 配置为使用其他证书或将 XenServer 配置为验证证书身份的信息，请参阅《Workload Balancing 管理员指南》。


与 Workload Balancing 断开连接

如果希望 Workload Balancing 停止监视池，必须通过与 Workload Balancing 服务器断开连接的方式为池禁用 Workload Balancing。

断开池与 Workload Balancing 虚拟设备的连接时，Workload Balancing 会从 Workload Balancing 数据库中永久删除关于该池的信息，并停止收集该池的数据。 这意味着如果希望使用同一个 Workload Balancing 虚拟设备再次管理该池，必须在连接 WLB 服务器对话框中重新输入该设备的信息。
重要: 如果只想暂时停止 Workload Balancing，请单击 WLB 选项卡，然后单击暂停按钮。

断开与 Workload Balancing 的连接

  1. 在 XenCenter 的资源窗格中，选择要停止 Workload Balancing 的资源池。
  2. 从池菜单中，选择断开 Workload Balancing 服务器连接。 此时将显示断开 Workload Balancing 服务器连接对话框。
  3. 单击断开连接以停止 Workload Balancing 对池的监视。
    注: 如果断开了池与 Workload Balancing 虚拟设备的连接，要对该池重新启用 Workload Balancing，必须重新连接到该设备。


将池重新配置为使用其他 WLB 设备

可以将一个池重新配置为使用其他 Workload Balancing 虚拟设备。

但是，为了防止原来的 Workload Balancing 设备意外地继续保持已配置状态并收集该池的数据，在将该池连接到新的 Workload Balancing 设备之前，必须将其与原来的 Workload Balancing 设备断开连接。

一旦池与原来的 Workload Balancing 设备断开连接，就可以通过指定新的 Workload Balancing 设备名重新连接该池。

使用其他 Workload Balancing 设备

  1. 对于要使用其他 Workload Balancing 设备的池，从池菜单中，选择断开 Workload Balancing 服务器连接，然后在出现提示时单击断开连接。 有关说明，请参阅与 Workload Balancing 断开连接。
  2. 在 WLB 选项卡中，单击连接。 此时将显示连接 WLB 服务器对话框。
  3. 在地址框中，键入新 Workload Balancing 设备的 IP 地址或主机名 (FQDN)。
    如果新 Workload Balancing 设备使用不同凭据，还必须输入新凭据。
    注: 必须输入在初次将池连接到 Workload Balancing 时通常会输入的所有信息。 有关信息，请参阅连接 Workload Balancing。


更新 Workload Balancing 凭据

完成初始配置后，如果需要更新 XenServer 与 Workload Balancing 设备用来通信的凭据，可以按照以下三步过程操作：
  1. 如下面所述断开与 Workload Balancing 的连接。
  2. 通过编辑 WlbConfig 文件（在 Workload Balancing 虚拟设备的控制台中运行 WlbConfig 命令）更改 WLB 凭据。 有关详细信息，请参阅《Workload Balancing 管理员指南》。
  3. 如下面所述重新启用 Workload Balancing 并指定新凭据。
在以下情况下您可能要执行这些步骤：
  • 如果需要更改 XenServer 用来与 Workload Balancing 进行通信的用户帐户
  • 如果您收到一条错误消息，说明 Workload Balancing 凭据不再有效
  • 如果服务不可用

如果要修改阈值设置，并更改指定给特定资源的优先级，请参阅编辑 Workload Balancing 设置。

断开与 Workload Balancing 的连接

  1. 在 XenCenter 的资源窗格中，选择要停止 Workload Balancing 的资源池。
  2. 从池菜单中，选择断开 Workload Balancing 服务器连接。 此时将显示断开 Workload Balancing 服务器连接对话框。
  3. 单击断开连接以永久停止 Workload Balancing 对池的监视。

重新启用 Workload Balancing 并指定新凭据

  1. 完成全部进度之后，单击连接。 此时将显示连接 WLB 服务器对话框。
  2. 单击更新凭据。
  3. 在服务器地址部分，根据需要修改以下内容：
    • 在地址框中，键入 Workload Balancing 设备的 IP 地址或 FQDN。
    • （可选） 如果在 Workload Balancing 配置期间更改了端口号，请输入该端口号。 XenServer 使用您在此框中以及 Workload Balancing 配置期间指定的端口号来连接 Workload Balancing。
      默认情况下，XenServer 通过端口 8012 连接 Workload Balancing。
      注: 除非您在 Workload Balancing 设置期间更改了此端口号，否则请勿对其进行编辑。 安装期间指定的端口号值与 Workload Balancing 配置对话框中指定的值必须匹配。
  4. 在 WLB 服务器凭据部分，输入运行 XenServer 的计算机在连接 Workload Balancing 服务器时使用的用户名（例如 wlbuser）和密码。
  5. 在 XenServer 凭据部分中，输入所配置池的用户名和密码（通常为池主服务器的密码）。 Workload Balancing 将使用这些凭据连接该池中运行 XenServer 的计算机。 要使用当前登录 XenServer 所使用的凭据，请选中使用当前 XenCenter 凭据复选框。


在启用 Workload Balancing 的状态下进入维护模式

启用 Workload Balancing 后，如果将物理主机脱机以进行维护（即通过进入维护模式来挂起服务器），XenServer 会自动将该主机上运行的虚拟机迁移到最优服务器上（如果可用）。 XenServer 会根据 Workload Balancing 的建议（性能数据、放置策略和性能阈值）迁移这些虚拟机。

如果没有可用的最佳服务器，进入维护模式对话框中会显示单击此处挂起 VM 字样。 在这种情况下，Workload Balancing 不会提供放置建议，因为所有主机都没有足够的资源来运行此虚拟机。 您可以将此虚拟机挂起，或者退出“维护模式”，并将同一资源池中另一台主机上的一个虚拟机挂起。 这样，当您再次进入进入维护模式对话框时，Workload Balancing 可能会列出一台适合迁移的候选主机。
注: 如果您将一台服务器脱机以进行维护，而且 Workload Balancing 处于启用状态，则进入维护模式对话框的右上角会显示“Workload Balancing”字样。

在启用 Workload Balancing 的状态下进入维护模式

  1. 在资源窗格中选择服务器，然后执行以下操作之一：
    • 单击鼠标右键，在快捷菜单中单击进入维护模式。
    • 在服务器菜单中，单击进入维护模式。
  2. 单击进入维护模式。 服务器上运行的虚拟机会根据 Workload Balancing 的性能数据、放置策略和性能阈值，自动迁移到最优主机上。

使服务器退出维护模式

  1. 在资源窗格中选择服务器，然后执行以下操作之一：
    • 单击鼠标右键，在快捷菜单中单击退出维护模式。
    • 在服务器菜单中，单击退出维护模式。
  2. 单击退出维护模式。

    在服务器退出维护模式之后，XenServer 会自动将该服务器的原始虚拟机还原到该服务器。


Workload Balancing 故障排除

尽管通常情况下 Workload Balancing 都会顺畅地运行，但本帮助系统仍包含了一系列与故障排除相关的主题，以便在您遇到问题时为您提供指导。 《Workload Balancing 管理员指南》中提供了更多故障排除主题。

下面是关于解决 Workload Balancing 常规问题的几点提示：

常规故障排除提示

执行故障排除时，首先应查看 Workload Balancing 日志。 该日志位于 Workload Balancing 设备上的以下位置（默认位置）：

/var/log/wlb

另外，您还可以在 XenCenter 的“导航”窗格中查看事件日志，依次单击通知和事件可了解更多信息。

错误消息

Workload Balancing 将在 XenCenter 中的警报视图上显示错误消息，在某些情况下，还会以对话框形式显示在屏幕上。


Workload Balancing 凭据输入问题

如果在配置连接 WLB 服务器对话框时无法使 Workload Balancing 接受设备的用户帐户和密码，请尝试以下操作：
  • 确保 Workload Balancing 设备已导入且配置正确，并且已通过 service workloadbalancing start 命令运行所有其服务。
  • 按照 Workload Balancing 启动问题中的指导进行检查，以确保您输入的凭据正确无误。
  • 如果输入 Workload Balancing FQDN 遇到困难，请输入 Workload Balancing 服务器的 IP 地址。

可以在地址框中输入 Workload Balancing 设备的主机名，但该名称必须是完全限定的域名 (FQDN)。 例如，yourcomputername.yourdomain.net。


Workload Balancing 启动问题

如果在导入和配置 Workload Balancing 设备后，收到一条错误消息，指出 XenServer 与 Workload Balancing 无法互相连接，原因可能是您在连接 WLB 服务器对话框中输入了错误的凭据。 要解决此问题，请尝试：
  • 确认您在连接 WLB 服务器对话框中输入的凭据与您在 Workload Balancing 服务器和 XenServer 上创建的凭据一致。
  • 确认您在连接 WLB 服务器对话框中输入的 Workload Balancing 设备的 IP 地址或 FQDN 正确无误。
  • 确认您在 Workload Balancing 配置期间创建的 Workload Balancing 帐户的帐户凭据与您在连接 WLB 服务器对话框中输入的凭据一致。


Workload Balancing 连接错误

如果在 WLB 选项卡上的“Workload Balancing 状态”行中收到连接错误消息，可能需要为该资源池重新配置 Workload Balancing。

单击 WLB 选项卡上的连接按钮，然后再次输入服务器凭据。

出现此错误通常是因为更改了 WLB 虚拟设备或池主服务器的凭据，或者更改了 WLB 虚拟设备的名称。


Workload Balancing 服务器的更改问题

如果在将资源池连接到其他 Workload Balancing 虚拟设备时，没有先断开该池与原始 Workload Balancing 设备的连接，则原来的和新的 Workload Balancing 设备都会监视该池。

要解决此问题，可以关闭并删除原来的 Workload Balancing 设备，或者手动停止 Workload Balancing 服务（分析、数据收集器和 Web 服务），使该设备不再监视池。

Citrix 建议不要使用 pool-initialize-wlb xe 命令删除或更改 Workload Balancing 服务器配置。


关于 XenServer 许可

XenServer 使用与其他 Citrix 产品相同的许可过程。 XenServer 需要许可证服务器。 有关如何安装和运行 Citrix Licensing 的详细信息，请参阅 Citrix eDocs Web 站点。

购买 XenServer 支持后，您将拥有 .LIC 许可证密钥。 许可证密钥应安装在：

  • 运行 Citrix 许可证服务器软件的 Windows Server，或者
  • 基于 Linux 的 Citrix 许可证服务器虚拟设备

XenServer Licensing 取决于主机上已安装的 XenServer 版本。 请参阅下表了解有关各种 XenServer 版本中许可概念的详细信息。

版本 | 主题
XenServer v6.5 | 许可概述 (XenServer 6.5) 在 XenServer 6.5 中管理许可证
XenServer v6.2.0 | 许可概述 (XenServer v6.2.0) 管理 XenServer v6.2.0 中的许可证
XenServer v6.1.0 及更早版本 | 许可概述（XenServer v6.1.0 及更早版本） 管理 XenServer 6.1.0 及更早版本的许可证 激活免费 XenServer 产品


管理 XenServer v6.2.0 中的许可证

本主题包含有关如何管理 XenServer 6.2.0 版本的许可证的信息。

安装 XenServer 时，将在未许可的状态中启动程序。 如果未获许可，其功能将不受任何限制，也就是说，XenServer 6.2.0 中的所有可用功能都可免费使用。 但是，您将需要 Citrix XenServer 按插槽数或 Citrix XenServer for XenDesktop 许可证，以便能够：

  • 获得 Citrix 的技术支持
  • 使用 XenCenter 管理控制台应用修补程序

XenServer 主机按填充的插槽数进行许可，池中的所有主机都必须处于已许可的状态。 已许可主机和未许可主机的混合池将被当做是所有主机都未获许可。

分配 XenServer 许可证

  1. 在工具菜单中，单击许可证管理器。
  2. 选择要分配许可证的的主机或池，然后单击分配许可证。
  3. 在应用许可证对话框中，选择要从许可证服务器申请的许可证的类型：
    • Citrix XenServer 按插槽数：选择此选项可激活按填充插槽数的许可模式。 此许可证类型适用于 XenServer 6.2.0 版。
    • Citrix XenServer for XenDesktop：选择该选项可以从许可证服务器请求现有的 Citrix XenServer for XenDesktop 许可证。
  4. 输入许可证服务器详细信息，然后单击确定。
    注: 默认情况下，许可证服务器使用端口 27000 与 Citrix 产品进行通信。 如果更改了许可证服务器上的默认端口，请在端口号框中输入合适的端口号。 有关因冲突而更改端口号的详细信息，请参阅 Citrix eDocs 中的许可使用本产品主题。

XenCenter 将联系指定的 Citrix V6 许可证服务器，并为指定服务器请求许可证。 如果成功，将签出一个许可证，并更新在 XenCenter 许可证管理器中显示的信息。 如果无法联系上许可证服务器，服务器将进入 30 天的许可宽限期。

注: 申请或应用许可证时，有关 XenServer 版本和许可证类型的信息可能会传送到 Citrix。 Citrix 不会收集或接收与任何系统用户、环境中运行的虚拟机或 XenServer 部署环境相关的任何其他信息。 请求许可过程中传送到 Citrix 的有限信息将依照 Citrix 隐私政策进行处理，您可以在 http://www.citrix.com/privacy 查看该隐私政策的副本。

从免费版升级到 XenServer 6.2.0

从免费版升级到 XenServer 6.2.0 版本的主机或池后，您虽未获得 XenServer 的许可证，但可使用其完整功能。 但是，XenCenter 的状态将显示为不受支持，即无法使用 XenCenter 应用修补程序或其他更新。 如果您选择购买许可证，在为主机或池分配新许可证之后，其状态将显示为已许可，许可证类型将显示为 Citrix XenServer 按插槽数版本。

从高级版、企业版或铂金版升级到 XenServer 6.2.0

从付费版升级到 XenServer 6.2.0 版本的主机或池后，您虽未获得 XenServer 的许可证，但可使用其完整功能。 但是，XenCenter 的状态将显示为不受支持，即无法使用 XenCenter 应用修补程序或更新。 在这些情况下，您将需要：

  1. 将您现有按主机数的许可证更换为按插槽数的许可证
  2. 将新的许可证文件添加到许可证服务器上
  3. 将许可证应用到 XenServer 主机或池

应用许可证后，您的主机或池将显示为已许可，许可证类型将显示为 Citrix XenServer 按插槽数版本。

释放 XenServer 许可证

  1. 在工具菜单中，单击许可证管理器。
  2. 选择主机或池，然后单击释放许可证。


在 XenServer 6.5 中管理许可证

本主题包含有关在 XenServer 6.5 中管理许可证的信息。

必须许可池中的所有主机。 可以使用 XenCenter 中的许可证管理器对话框管理 XenServer 许可证。 许可证管理器允许您：
  • 将 XenServer 许可证分配到托管服务器。 分配许可证时，XenServer 会联系 Citrix 许可证服务器，并请求指定类型的许可证。 如果有可用许可证，则会将该许可证从许可证服务器中签出。
  • 释放 XenServer 许可证。 释放许可证时，XenServer 会联系 Citrix 许可证服务器，并将许可证签入服务器。
重要: Citrix XenServer 6.5 许可需要 Citrix 许可证服务器 v11.12.1 或更高版本。 可以从 Citrix Licensing 页面下载许可证服务器。

分配 XenServer 许可证

  1. 在工具菜单中，单击许可证管理器。
  2. 选择要分配许可证的的主机或池，然后单击分配许可证。
  3. 在应用许可证对话框中，选择要从许可证服务器中申请的许可证版本。 有关不同 XenServer 版本的详细信息，请参阅许可概述 (XenServer 6.5)。
  4. 输入许可证服务器详细信息，然后单击确定。
    注: 默认情况下，许可证服务器使用端口 27000 与 Citrix 产品进行通信。 如果更改了许可证服务器上的默认端口，请在端口号框中输入合适的端口号。 有关因冲突而更改端口号的详细信息，请参阅 Citrix eDocs 中的许可使用本产品主题。

XenCenter 将联系指定的 Citrix 许可证服务器，并为指定服务器请求许可证。 如果成功，则将签出一个许可证，并更新在 XenCenter 许可证管理器中显示的信息。 如果无法联系上许可证服务器，服务器将进入 30 天的许可宽限期。

注: 申请或应用许可证时，有关 XenServer 版本和许可证类型的信息可能会传送到 Citrix。 Citrix 不会收集或接收与任何系统用户、环境中运行的虚拟机或 XenServer 部署环境相关的任何其他信息。 请求许可过程中传送到 Citrix 的有限信息将依照 Citrix 隐私政策进行处理，您可以在 http://www.citrix.com/privacy 查看该隐私政策的副本。

释放 XenServer 许可证

  1. 在工具菜单中，单击许可证管理器。
  2. 选择主机或池，然后单击释放许可证。


管理 XenServer 6.1.0 及更早版本的许可证

XenServer 高级版、企业版和铂金版与其他 Citrix 产品共享相同的许可模式，每个主机服务器需要的许可证将安装在单独的 Citrix Licensing 服务器上。 有关如何安装和运行 Citrix Licensing 的详细信息，请参阅 Citrix eDocs 中的许可使用本产品。

可以使用 XenCenter 的许可证管理器管理 XenServer 高级版、企业版和铂金版：在工具菜单中，单击许可证管理器。 通过许可证管理器，您可以：

  • 将 XenServer 许可证 分配到托管服务器。 分配许可证时，XenCenter 会联系 Citrix 许可证服务器，并请求指定类型的许可证。 如果有可用许可证，则会将该许可证从许可证服务器中签出。
  • 释放 XenServer 许可证。 释放许可证时，XenCenter 会联系 Citrix 许可证服务器，并将许可证签入服务器。

XenServer 资源池中的每个主机服务器必须分别进行许可。 例如，如果在一个资源池中支持四个 XenServer 主机，则必须为其中的每一个主机分配一个许可证。 尽管可以在同一池中混合不同版本的 XenServer 主机，但是务必注意，许可证级别最低的主机决定了池中所有成员可用的功能。 例如，在高级版和铂金版主机混合而成的池中，将只启用高级版主机的功能。 因此，如果将某个主机更改为使用级别更低的许可证，可以有效地在池中禁用某些功能。

分配 XenServer 许可证

  1. 打开许可证管理器：在工具菜单上，单击许可证管理器。
  2. 选择一个或多个服务器，然后单击分配许可证。
  3. 在分配许可证对话框中，选择要从许可证服务器申请的许可证的类型：
    • Citrix XenServer 高级版：这种许可证可以激活 XenCenter 内的特定管理功能，包括高可用性、VM 保护和恢复 (VMPR)、动态内存控制、实时警报和有关 VM 性能的历史报告。
    • Citrix XenServer 企业版：这种许可证在高级版功能的基础上增加了与现有存储基础结构集成的 Workload Balancing 和 StorageLink 自动化功能。
    • Citrix XenServer 铂金版：这种许可证可激活在 XenCenter 外部进行管理的功能，如 Provisioning Services 和 Lab Management。 Lab Management 和 Stage Management 的许可证可以从 citrix.com 中我的账户随 Citrix Lab Manager 安装 ISO 一起另行下载；Lab Management 许可证可从 Lab Manager 管理控制台内应用。
    • Citrix XenServer for XenDesktop：选择该选项可以从许可证服务器请求现有的 Citrix XenServer for XenDesktop 许可证。 获得该许可证后，您可以使用 XenServer 企业版来根据需要托管桌面 VM 和所有 XenDesktop 基础结构 VM，其中包括 XenDesktop 主机和 XenApp 主机。
  4. 输入许可证服务器详细信息，然后单击确定。

XenCenter 将联系指定的 Citrix V6 许可证服务器，并为指定服务器请求许可证。 如果成功，将签出一个许可证，并更新在 XenCenter 许可证管理器中显示的信息。 如果无法联系上许可证服务器，服务器将进入 30 天的许可宽限期。

注: 激活免费 XenServer 产品或者申请/应用付费版本的许可证时，有关 XenServer 服务器版本和许可证类型的信息可能会传送到 Citrix。 Citrix 不会收集或接收与任何系统用户、环境中运行的虚拟机或 XenServer 部署环境相关的任何其他信息。 请求许可过程中传送到 Citrix 的有限信息将依照 Citrix 隐私政策进行处理，您可以在 http://www.citrix.com/privacy 查看该隐私政策的副本。

释放 XenServer 许可证

  1. 打开许可证管理器：在工具菜单上，单击许可证管理器。
  2. 选择服务器，然后单击释放许可证。


激活免费 XenServer 产品

要激活免费的 XenServer 产品，需要对主机服务器应用激活密钥（有时也称为“许可证密钥”）。 激活过程大致如下：

  1. 向 Citrix 申请激活密钥。 之后您将通过电子邮件收到激活密钥文件 license.xslic。
  2. 将激活密钥应用到要激活的免费 XenServer 产品所在的服务器。

要应用激活密钥，只需在 Windows 资源管理器中双击密钥文件，然后选择要应用密钥文件的服务器即可，或者也可以在 XenCenter 中使用许可证管理器来应用密钥。

注: 激活免费 XenServer 产品时，有关 XenServer 服务器版本和许可证类型的信息可能会传送到 Citrix。 Citrix 不会收集或接收与任何系统用户、环境中运行的虚拟机或 XenServer 部署环境相关的任何其他信息。 请求许可过程中传送到 Citrix 的有限信息将依照 Citrix 隐私政策进行处理，您可以在 http://www.citrix.com/privacy 查看该隐私政策的副本。

申请激活密钥

  1. 打开许可证管理器：在工具菜单上，单击许可证管理器。
  2. 选择一个或多个运行免费 XenServer 产品的服务器，单击激活免费版 XenServer，然后单击申请激活密钥。

    此时将打开一个 Web 浏览器，并进入 Citrix XenServer 激活 Web 页面，其中记录了所选服务器的详细激活信息，您需要在此页面中填写联系信息和电子邮件地址。

    如果 XenCenter 无法连接到 XenServer 激活服务器，系统将询问您是否要将所选主机服务器的详细激活信息保存到文件中。 如果选择保存，您可以在以后恢复 Internet 连接时，将该文件导入 XenServer 激活服务器中。

填写激活表单后，您将通过电子邮件收到每个免费 XenServer 产品的激活密钥。 例如：

然后您需要将相应的密钥文件应用到每个 XenServer 主机，以激活这些主机。

在 XenCenter 中应用激活密钥

开始操作前，确保可以从运行 XenCenter 的计算机访问激活密钥文件，并且已将相关服务器连接（添加）到托管资源集中。

  1. 打开许可证管理器：在工具菜单上，单击许可证管理器。
  2. 选择运行免费 XenServer 产品的服务器，单击激活免费版 XenServer，然后单击应用激活密钥。
  3. 找到激活密钥文件 (license.xslic)，然后单击打开。

通过密钥文件应用激活密钥

  1. 在 Windows 资源管理器中找到激活密钥文件 (license.xslic)，然后双击该文件。
  2. 在应用激活密钥对话框中，选择要激活的免费 XenServer 产品所在的服务器，然后单击应用。


许可概述（XenServer v6.1.0 及更早版本）

注: 如果您运行的是 XenServer 6.2.0 版本，请参阅许可概述 (XenServer v6.2.0)。

Citrix XenServer 免费版包含创建虚拟基础结构所需的所有功能，可以免费使用。 XenServer 免费版可以免费用在生产环境中，没有任何约束条件或时间限制；您只需在首次安装后的 30 天内激活产品，向 Citrix 登记您使用该产品的意图。 激活是一个简单的过程，仅需几分钟时间。 有关激活 XenServer 免费版的信息，请参阅激活免费 XenServer 产品。

三个付费 XenServer 版本 — 高级版、企业版和铂金版 — 提供了一套管理和自动化功能，对免费 Citrix XenServer 平台的功能进行了扩展。 有关不同版本 XenServer 中可用功能的更多信息，请单击此处。

Citrix Licensing

本产品的所有付费版本都采用 Citrix 集中许可的方式，而且与其他 Citrix 组件一样，必须使用 Citrix 许可证服务器分配许可证。 所有 XenServer 版本的许可证都必须安装在单独的一台 Citrix Licensing 服务器上，并使用 Citrix 许可证管理控制台进行维护和控制。 通过这种方法，XenServer 可以和其他 Citrix 产品共享相同的许可模式，并且可以在其他 Citrix 产品之间共享该许可服务器。 有关如何安装及运行 Citrix Licensing 的详细信息，请查看 Citrix eDocs Web 站点上的在线文档。

有关管理许可证的信息，请参阅管理 XenServer 6.1.0 及更早版本的许可证。

许可证宽限期

Citrix V6 Licensing 内置了超时技术。 如果 XenServer 主机无法连接许可证服务器（例如，由于许可证服务器硬件或软件出现故障，或者网络出现故障），则会有 30 天宽限期，允许 XenServer 主机继续运行，就像仍在与许可证服务器通信一样。 XenServer 主机签出启动许可证后，XenServer 与许可证服务器每五分钟交换一次“检测信号”消息，以告知对方其仍处于启动及运行状态。 如果 XenServer 和许可证服务器无法发送或接收检测信号，XenServer 会进入许可宽限期，并通过缓存的信息自行完成许可授予。 30 天的宽限期过后，XenServer 会停止接受连接。 XenServer 与许可证服务器之间重新建立通信后，宽限期将重置。 要产生宽限期，XenServer 与许可证服务器必须至少曾经成功通信一次。

隐私声明

激活免费 XenServer 产品或者申请/应用付费版本的许可证时，有关 XenServer 服务器版本和许可证类型的信息可能会传送到 Citrix。 Citrix 不会收集或接收与任何系统用户、环境中运行的虚拟机或 XenServer 部署环境相关的任何其他信息。 请求许可过程中传送到 Citrix 的有限信息将依照 Citrix 隐私政策进行处理，您可以在 http://www.citrix.com/privacy 查看该隐私政策的副本。


许可概述 (XenServer v6.2.0)

安装 XenServer 时，将在未许可的状态中启动程序。 如果未获许可，其功能将不受任何限制，但使用 XenCenter 的修补程序的应用程序例外。 要获取 Citrix 技术支持，必须许可使用 XenServer 主机。

XenServer 主机按填充的插槽数进行许可，池中的所有主机都必须处于已许可的状态。 已许可主机和未许可主机的混合池将被当做是所有主机都未获许可。 有关在 XenServer v6.2.0 中管理许可证的详细信息，请参阅管理 XenServer v6.2.0 中的许可证。

各个 XenServer 版本的许可

XenServer 使用与其他 Citrix 产品相同的许可过程。 XenServer 需要许可证服务器。 购买 XenServer 支持后，您将拥有 .LIC 许可证密钥。 许可证密钥应安装在：
  • 运行 Citrix 许可证服务器软件的 Windows Server，或者
  • 基于 Linux 的 Citrix 许可证服务器虚拟设备
重要: XenServer 按插槽数 6.2 版需要使用 Citrix License Server 11.6.1 或更高版本。

许可证过期

XenServer 按插槽数许可证版本过期时：

  • 该版本将还原为完整功能但未许可的 XenServer
  • XenCenter 将其显示为 Citrix XenServer Per-Socket Edition Expired（Citrix XenServer 按插槽数版本已过期）
  • 将无法使用 XenCenter 应用修补程序或其他更新
  • 您将无法再获得此主机或池的 Citrix 技术支持，除非您再购买一份许可证

许可证宽限期

Citrix V6 Licensing 内置了超时技术。 如果 XenServer 主机无法连接许可证服务器（例如，由于许可证服务器硬件或软件出现故障，或者网络出现故障），则会有 30 天宽限期，允许 XenServer 主机继续运行，就像仍在与许可证服务器通信一样。 XenServer 主机签出启动许可证后，XenServer 与许可证服务器每五分钟交换一次“检测信号”消息，以告知对方其仍处于启动及运行状态。 如果 XenServer 和许可证服务器无法发送或接收检测信号，XenServer 会进入许可宽限期，并通过缓存的信息自行完成许可授予。 30 天的宽限期过后，XenServer 会停止接受连接。 XenServer 与许可证服务器之间重新建立通信后，宽限期将重置。 要产生宽限期，XenServer 与许可证服务器必须至少曾经成功通信一次。


许可概述 (XenServer 6.5)

XenServer 6.5 提供四种商用版本：

  • Standard
  • Enterprise
  • Desktop
  • Desktop+

Standard Edition 是我们的入门级商用产品，如果客户希望使用强大的高性能虚拟化平台，但不需要 Enterprise Edition 提供的高级功能，而同时仍希望获得全面的 Citrix 支持和维护保障，本版本提供的一系列功能可以满足此类客户的需求。

Enterprise Edition 是我们的高级产品，已针对服务器、桌面和云工作负载进行了优化。 除 Standard Edition 外，本版本还提供对 Boot Storm Guard（内存中读取缓存）、动态工作负载平衡、通过 NVIDIA GRID 实现的 GPU 虚拟化 (vGPU)、VMware vSphere 到 XenServer 转换实用程序、Intel Secure Measured Boot (TXT) 和导出资源数据的访问。

Desktop Edition 仅面向购买了 XenApp 或 XenDesktop 的客户，本版本中包含之前面向 XenApp 或 XenDesktop 客户的所有 XenServer 功能。 这些功能包括 Standard Edition 不提供的功能，即：动态工作负载平衡、通过 NVIDIA GRID 实现的 GPU 虚拟化 (vGPU)、VMware vSphere 到 XenServer 转换实用程序、Intel Secure Measured Boot (TXT) 以及全面的 Citrix 支持和维护。

Desktop+ Edition 仅面向购买了 XenApp 或 XenDesktop Platinum Edition 的客户；除 Desktop Edition 中提供的功能外，本版本还提供对 Boot Storm Guard（内存中读取缓存）的访问。

注: 可以从 Standard Edition 升级到 Enterprise Edition。 有关 XenServer 6.5 许可的详细信息，请参阅 XenServer 6.5 许可常见问题解答。 要购买 XenServer 6.5 许可证，请单击此处。

Citrix Licensing

XenServer 使用的许可过程与其他 Citrix 产品相同，因此，需要在许可证服务器上安装有效的许可证。 可以从 Citrix Licensing 页面下载许可证服务器。 购买 XenServer 版本需要的许可证后，您将收到一个 .LIC 许可证密钥。 许可证密钥应安装在：
  • 运行 Citrix 许可证服务器软件的 Windows Server，或者
  • 基于 Linux 的 Citrix 许可证服务器虚拟设备
如果为 XenServer 主机分配了许可证，XenServer 会联系指定的 Citrix 许可证服务器，并为指定的服务器请求许可证。 如果成功，则将签出一个许可证，并且 XenCenter 许可证管理器将显示与许可使用主机时所依据的 XenServer 版本有关的信息。
重要: Citrix XenServer 6.5 许可需要 Citrix 许可证服务器 11.12.1 或更高版本。

各个 XenServer 版本的许可

必须许可池中的所有主机。 如果运行的 XenServer 池中包含获得不同 XenServer 版本许可的主机，获得最低版本许可的主机将决定对池中的所有成员可用的主机。 已许可主机和未许可主机的混合池将被当做是所有主机都未获许可。 有关在 XenServer 6.5 中管理许可证的信息，请参阅在 XenServer 6.5 中管理许可证。

许可证过期

XenCenter 在您的许可证即将过期时向您发出通知。 您应在其过期之前购买许可证。 XenServer 许可证过期时：

  • XenCenter 许可证管理器将显示状态为未获许可。
  • 在购买另一个许可证之前，您无法再访问许可的功能，也无法再接收 Citrix 向池中的任何主机提供的技术支持。

许可证宽限期

Citrix Licensing 内置了超时技术。 XenServer 主机签出启动许可证后，XenServer 和许可证服务器将每五分钟交换一次“检测信号”消息，以相互表明自身仍正常运行。 例如，如果 XenServer 主机由于许可证服务器硬件、软件或网络故障无法联系许可证服务器，服务器将进入为期 30 天的许可宽限期。 宽限期期间，XenServer 将通过缓存的信息对自身进行许可，并且允许主机继续运行，就像仍与许可证服务器通信一样。 宽限期为 30 天，宽限期到期后，XenServer 将还原到未获许可状态。 XenServer 与许可证服务器之间重新建立通信后，宽限期将重置。

注: 宽限期只有在 XenServer 与许可证服务器至少成功通信一次后才会发生。


为用户和组分配角色

所有 XenServer 用户都必须具有 RBAC 角色。 在 XenServer v6.2 和 v6.5 中，必须首先将角色分配给新创建的用户，这些用户才能使用帐户。 请注意，XenServer 不会自动将角色分配给新创建的用户。 因此，在您为这些帐户分配角色之前，它们对 XenServer 池没有任何访问权限。

将角色分配给 XenServer 6.1.0 和更早版本中的用户

在 XenServer 6.1.0 和更早版本中，添加新用户时，会自动为其分配池管理员角色。 在 XenServer Enterprise 和更高版本中，当您添加新用户时，XenServer 不会自动为新添加的用户帐户分配角色。 您必须单独为新帐户分配角色。

注: 加入关联的域后，您必须先将用户或组的 Active Directory 帐户添加到 XenServer 中，然后才能为用户或组分配角色，如加入域并添加 RBAC 用户中所述。

可以通过以下方法之一为用户分配其他角色：

  1. 在 XenCenter 的选择角色对话框中更改分配给用户的角色。 此操作需要分配/修改角色权限，该权限仅适用于池管理员。
  2. 在 Active Directory 中修改用户的所属组成员身份（使用户成为具有其他角色的组的成员）。

如果管理员有时候间接为用户应用多个角色（例如，使用户成为多个组的成员），XenServer 会将为其分配的最高角色的权限授予该用户。

为用户或组更改或分配角色

  1. 在资源窗格中，选择包含该用户或组的池或服务器。
  2. 单击用户选项卡。
  3. 在具有访问权限的用户和组窗格中，选择要分配权限的用户或组。
  4. 单击更改角色。
  5. 在选择角色对话框中，选择要应用的角色并单击保存。 有关每个角色所关联的权限的信息，请参阅 RBAC 角色和权限定义。
    提示: 分配角色时，可以在按住 CTRL 键的同时选择用户帐户，从而同时选择多个用户。
  6. （可选） 更改角色时，如果用户当前已登录到池并且您希望他们立即收到新权限，请单击注销用户。 此操作将断开该用户在池中的所有会话，以便该用户以修改后的角色接收新会话。
    注: 更改角色时，要使新角色生效，用户必须先注销，然后重新登录。 您可以通过单击注销用户按钮将此用户强制注销。 （强制注销操作需要注销活动用户连接权限，该权限适用于池管理员或池操作员）。


审核更改

在 XenServer 中，XenServer 审核日志默认情况下处于启用状态，该日志将记录由已知用户执行的具有副作用（成功或失败）的任何操作。 其中包括：

  • 执行该操作的用户的名称。 如果无法获得该用户的名称，XenServer 会改为记录其用户 ID。
  • 该操作所针对的服务器的名称。
  • 该操作的状态 - 操作是否成功以及是否经过授权。如果该操作失败，则将记录错误代码。

默认情况下将启用审核日志记录功能。 可以使用 XenServer syslog 命令将审核日志复制到安全位置，从而备份审核日志。 syslog 命令可以从 CLI 访问，在《XenServer 管理员指南》中进行了介绍。

尽管 Citrix 强烈建议关注审核工作的客户实施基于角色的访问控制，但是审核日志本身既不需要用户具有 RBAC 角色，也不需要 Active Directory 集成。

XenServer 将记录池级别的操作，并在池主服务器上为每个池创建一个日志。

要显示审核日志，可以使用两种可选方法。 可以执行以下操作：

  • 生成池审核追踪报告（如果已启用 Workload Balancing）。
  • 在任何文本编辑器中打开审核日志，以显示日志内容。 审核日志存储在池主服务器上。


计算 RBAC 角色

在我登录时，XenServer 如何计算用于该会话的角色？

  1. Active Directory 服务器对使用者进行身份验证。 在身份验证期间，Active Directory 还将确定该使用者是否属于 Active Directory 中的任何其他包含组。
  2. 然后，XenServer 将确认已经为 (a) 使用者 (b) 使用者所属的任何 Active Directory 组分配了角色。
  3. XenServer 为使用者应用最高级别的权限。 由于使用者可以是多个 Active Directory 组的成员，因此，使用者会继承关联角色的所有权限。

在上图中，由于使用者 2（组 2）是池操作员，而用户 1 是组 2 的成员，因此，使用者 3（用户 1）尝试登录时，会同时继承使用者 3（VM 操作员）和组 2（池操作员）角色。 由于池操作员角色级别更高，因此，使用者 3（用户 1）的最终角色是池操作员而非 VM 操作员。


加入域并添加用户

为用户或组帐户分配 RBAC 角色前，必须通过 RBAC 将帐户添加到 XenServer 中。 这需要执行两项任务：

  1. 将池或服务器加入域中。 该域可以是用户或组所属的域，也可以是位于同一个 Active Directory 林中或者与用户所在域具有信任关系的域。
  2. 将用户的 Active Directory 帐户或组添加到 XenServer 中。

在免费 XenServer 产品和 XenServer 高级版中，在将用户的 Active Directory 帐户或组添加到 XenServer 中后，系统会自动为用户分配一个固定的角色：池管理员。 在 XenServer Enterprise 和更高版本中，必须手动为用户或组分配角色。

要更改域，请离开当前的域，然后加入新域。

将 XenServer 或池加入域

  1. 在资源窗格中，选择要为其中的用户赋予权限的池或服务器。
  2. 单击用户选项卡。
  3. 单击加入域。
  4. 输入 Active Directory 凭据，该凭据应具有足够的权限来将服务器添加到要加入的域中。 必须以完全限定的域名 (FQDN) 而不是 NetBIOS 名称来指定要加入的域。 例如，输入 your_domain.net 而不是 your_domain。

将 Active Directory 用户或组添加到池中

  1. 加入用户所在域后，请在用户选项卡中，单击添加。
  2. 在添加用户对话框中，输入一个或多个用户名或组名。 多个名称以逗号分隔。 要指定其他可信域（而非当前所加入的域）中的用户，请提供域名及用户名（例如，other_domain\jsmith）或输入完全限定的域名 (FQDN)（例如，jsmith@other_domain.com）。
  3. 单击授予访问权限。
  4. 按照将角色分配给用户和组进行操作，向帐户分配一种角色并授予访问权限。

离开域

注: 退出域（即，禁用 Active Directory 身份验证，并断开池或服务器与其域之间的连接）时，通过 Active Directory 凭据进行身份验证以连接到池或服务器的所有用户均会断开连接 。
  1. 在资源窗格中，选择要与所属 Active Directory 域断开连接的池或服务器。
  2. 单击离开域并选择是继续。
  3. 输入 Active Directory 凭据，该凭据应具有足够的权限在要离开的域中禁用服务器。
  4. 决定是否在 Active Directory 服务器中禁用计算机帐户，然后单击以下选项之一：
    • 禁用。 从域中删除池或服务器，并在 Active Directory 数据库中禁用服务器或池主服务器的计算机帐户。
    • 忽略。 如果您未填写用户名/密码，或者您不知道具有足够权限来从 Active Directory 数据库中删除服务器或池主服务器计算机帐户的帐户，请选择此选项。 （此选项将从域中删除池或服务器，但将服务器或池主服务器的计算机帐户保留在 Active Directory 中。）


RBAC 概述

通过基于角色的访问控制 (RBAC) 功能，可以为 Active Directory 用户和组分配预定义的角色（或称 XenServer 权限集）。 这些权限用于控制 XenServer 用户（即管理 XenServer 的人员）对服务器和池所拥有的访问级别：RBAC 在池级别配置和部署。 由于用户通过分配的角色获取权限，因此您只需要为用户或其所在的组分配角色。

为 XenServer 用户帐户使用 Active Directory 帐户

通过 RBAC，您可以对不同用户组可执行的操作进行限制，从而降低缺乏经验的用户进行灾难性意外更改的可能性。 分配 RBAC 角色还有助于防止资源池在未经授权的情况下被更改，从而确保合规性。 为了便于检查合规性和进行审核，RBAC 还提供了审核日志功能及其相应的 Workload Balancing 池审核追踪报告。

RBAC 基于 Active Directory 提供身份验证服务。 具体而言，XenServer 会保留基于 Active Directory 用户和组帐户的授权用户列表。 因此，您必须将池加入域并添加 Active Directory 帐户，然后才能分配角色。

RBAC 流程

实施 RBAC 并为用户或组分配角色的标准流程如下：

  1. 加入域。
  2. 将 Active Directory 用户或组添加到池。
  3. 分配（或修改）用户或组的 RBAC 角色。

本地超级用户

本地超级用户 (LSU) 或 root 用户是一个用于系统管理的特殊用户帐户，具有完全权限。 在 XenServer 中，本地超级用户是安装时的默认帐户。 LSU 通过 XenServer 而非外部身份验证服务进行身份验证。 这表示如果外部身份验证服务失败，LSU 仍可登录并管理系统。 LSU 始终可以通过 SSH 访问 XenServer 物理服务器。

RBAC 角色

XenServer 附带六个预定义角色，这些角色旨在对应于 IT 组织中的不同职能。

  • 池管理员。 此角色是权限最大的可用角色。 池管理员对所有 XenServer 功能和设置都具有完全访问权限。 池管理员可以执行所有操作（包括角色和用户管理）， 可以授予对 XenServer 控制台的访问权限。 Citrix 建议的最佳做法是将此角色分配给极有限的用户。
    注: 本地超级用户（root 用户）将始终具有池管理员角色。 池管理员角色与本地 root 用户具有相同的权限。
  • 池操作员。 获得此角色的人员可以管理池范围的资源（包括创建存储、管理服务器、管理修补程序和创建池）。 池操作员可以配置池资源。 池操作员还对以下功能具有完全访问权限：高可用性、Workload Balancing 和修补程序管理。 池操作员不能添加用户或修改角色。
  • 虚拟机超级管理员(VM 超级管理员)。 此角色具有完全的 VM 和模板管理权限。 他们可以选择 VM 的启动位置， 并且对动态内存控制功能和 VM 快照功能具有完全访问权限。 此外，他们还可以设置主服务器并选择工作负载的运行位置。 分配此角色后，被授权人将具有足够的权限来置备虚拟机，以供 VM 操作员使用。
  • 虚拟机管理员(VM 管理员)。 此角色可以管理 VM 和模板，并且可以访问必要的存储来完成这些任务。 但是，此角色依赖于 XenServer 来选择工作负载的运行位置，并且必须使用模板中的动态内存控制和主服务器设置。 （此角色无法访问动态内存控制功能、生成快照、设置主服务器或选择工作负载的运行位置。）
  • 虚拟机操作员（VM 操作员）。 此角色可以使用池中的 VM 并管理这些 VM 的基本生命周期。 如果有足够的可用硬件资源，VM 操作员可以与 VM 控制台交互并启动或停止 VM。 同样，VM 操作员也可以执行生命周期的启动和停止操作。 VM 操作员角色不能创建或销毁 VM，也不能更改 VM 属性或服务器属性。
  • 只读。 此角色只能查看资源池和性能数据。

有关每个角色所关联的权限的信息，请参阅 RBAC 角色和权限定义。 有关 RBAC 如何为用户计算所应用角色的信息，请参阅计算 RBAC 角色。

注: 创建新用户时，必须先向新创建的用户分配一个角色，之后才能使用该帐户。 请注意，XenServer 不会自动将角色分配给新创建的用户。

从旧版本 XenServer 升级

RBAC 支持功能自 XenServer 5.6 版本起引入。 在升级到 XenServer 5.6 或更高版本时，系统会为在 XenServer 早期版本中创建的任何用户帐户分配池管理员角色。 执行此操作的原因是存在向后兼容。 从早期版本的 XenServer 进行升级时，应重新访问与每个用户帐户相关联的角色，以确保角色仍然适用。


RBAC 角色和权限定义

适用于每个角色的权限

下表汇总了每个角色适用的权限。 有关每种权限可执行的操作的详细信息，请参阅下一部分。

权限 | 池管理员 | 池操作员 | VM 超级管理员 | VM 管理员 | VM 操作员 | 只读
分配/修改角色 | X |  |  |  |  |
登录到（物理）服务器控制台（通过 SSH 和 XenCenter） | X |  |  |  |  |
服务器备份/还原 | X |  |  |  |  |
导入/导出 OVF/OVA 包；导入磁盘映像 | X |  |  |  |  |
设置每个插槽的核心数 | X |  |  |  |  |
使用 XenServer Conversion Manager 转换 VM | X |  |  |  |  |
交换机端口锁定 | X | X |  |  |  |
注销活动的用户连接 | X | X |  |  |  |
创建和取消警报 | X | X |  |  |  |
取消任何用户的任务 | X | X |  |  |  |
池管理 | X | X |  |  |  |
Storage XenMotion | X | X | X |  |  |
VM 高级操作 | X | X | X |  |  |
VM 创建/销毁操作 | X | X | X | X |  |
VM 更改 CD 介质 | X | X | X | X | X |
VM 更改电源状态 | X | X | X | X | X |
查看 VM 控制台 | X | X | X | X | X |
XenCenter 视图管理操作 | X | X | X | X | X |
取消自己的任务 | X | X | X | X | X | X
阅读审核日志 | X | X | X | X | X | X
配置、初始化、启用、禁用 WLB | X | X |  |  |  |
应用 WLB 优化建议 | X | X |  |  |  |
修改 WLB 报告订阅 | X | X |  |  |  |
接受 WLB 放置建议 | X | X | X |  |  |
显示 WLB 配置 | X | X | X | X | X | X
生成 WLB 报告 | X | X | X | X | X | X
连接到池并阅读所有池元数据 | X | X | X | X | X | X
配置 vGPU | X | X |  |  |  |
查看 vGPU 配置 | X | X | X | X | X | X

权限的定义

下表提供了有关权限的其他详细信息：

权限 允许被授权人执行的操作 说明/备注
分配/修改角色
  • 添加和删除用户
  • 添加和删除用户的角色
  • 启用和禁用 Active Directory 集成（加入域）

此权限允许用户向自己授予任何权限或执行任何任务。

警告：此角色允许用户禁用 Active Directory 集成以及从 Active Directory 添加的所有使用者。

登录到服务器控制台
  • 通过 SSH 访问服务器控制台
  • 通过 XenCenter 访问服务器控制台
警告：具备对 root shell 的访问权限之后，被授权人可以随意重新配置整个系统（包括 RBAC）。

服务器备份/还原 VM 创建/销毁操作

  • 备份和还原服务器
  • 备份和还原池元数据
还原备份的能力使被授权人能够还原 RBAC 配置更改。
导入/导出 OVF/OVA 包；导入磁盘映像
  • 导入 OVF 和 OVA 包
  • 导入磁盘映像
  • 将 VM 导出为 OVF/OVA 包
设置每个插槽的核心数
  • 为 VM 的虚拟 CPU 设置每个插槽的核心数
此权限允许用户为 VM 的虚拟 CPU 指定拓扑。
使用 XenServer Conversion Manager 转换 VM
  • 将 VMware VM 转换为 XenServer VM
此权限允许用户将工作负载从 VMware 转换为 XenServer，方法是将 VMware VM 的批处理作业复制到 XenServer 环境。
交换机端口锁定
  • 控制网络中的流量
此权限允许用户默认阻止网络中的所有流量，或定义允许 VM 从中发送流量的特定 IP 地址。
注销活动的用户连接
  • 断开已登录用户的连接的能力
创建/取消警报
  • 将 XenCenter 配置为当资源使用情况超过特定阈值时生成警报
  • 从“警报”视图中删除警报

警告：具有此权限的用户可以取消整个池的警报。

注意：查看警报的能力属于连接到池并读取所有池元数据权限的一部分。

取消任何用户的任务
  • 取消任何用户正在运行的任务
此权限允许用户请求 XenServer 取消任何用户启动的正在执行的任务。
池管理
  • 设置池属性（命名、默认 SR）
  • 启用、禁用和配置高可用性功能
  • 设置每个 VM 高可用性功能重新启动优先级
  • 配置 DR、执行 DR 故障转移、故障恢复以及测试故障转移操作
  • 启用、禁用和配置 Workload Balancing (WLB)
  • 在池中添加和删除服务器
  • 紧急转换到主服务器
  • 紧急主服务器地址
  • 紧急恢复从属服务器
  • 指定新的主服务器
  • 管理池和服务器证书
  • 修补
  • 设置服务器属性
  • 配置服务器日志记录
  • 启用和禁用服务器
  • 关闭、重新引导和打开服务器
  • 重新启动 toolstack
  • 系统状态报告
  • 应用许可证
  • 因 WLB、维护模式或高可用性功能而将服务器上的所有其他 VM 实时迁移到其他服务器
  • 配置服务器管理接口
  • 禁用服务器管理
  • 删除故障转储
  • 添加、编辑和删除网络
  • 添加、编辑和删除 PBD/PIF/VLAN/Bond/SR
分配/修改角色
Storage XenMotion
  • 将 VM 从一个主机迁移到另一个主机
  • 将虚拟磁盘 (VDI) 从一个 SR 迁移到另一个 SR
VM 高级操作
  • 调整 VM 内存（通过动态内存控制）
  • 创建包含内存数据的 VM 快照、生成 VM 快照及回滚 VM
  • 迁移 VM
  • 启动 VM，包括指定物理服务器
  • 恢复 VM
登录到服务器控制台
VM 创建/销毁操作
  • 安装和删除 VM
  • 克隆/复制 VM
  • 添加、删除和配置虚拟磁盘/CD 设备
  • 添加、删除和配置虚拟网络设备
  • 导入/导出 XVA 文件
  • VM 配置更改

服务器备份/还原 VM 创建/销毁操作

VM 更改 CD 介质
  • 弹出当前的 CD
  • 插入新 CD
导入/导出 OVF/OVA 包；导入磁盘映像
VM 更改电源状态
  • 启动 VM（自动放置）
  • 关闭 VM
  • 重新引导 VM
  • 挂起 VM
  • 恢复 VM（自动放置）
注销活动的用户连接
查看 VM 控制台
  • 查看 VM 控制台并与之交互
创建/取消警报
配置、初始化、启用、禁用 WLB
  • 配置 WLB
  • 初始化 WLB 和更改 WLB 服务器
  • 启用 WLB
  • 禁用 WLB
应用 WLB 优化建议
  • 应用“WLB”选项卡中显示的所有优化建议
修改 WLB 报告订阅
  • 更改生成的 WLB 报告或其接收者
接受 WLB 放置建议
  • 选择其中一种服务器 Workload Balancing 放置建议（“星级”建议）
显示 WLB 配置
  • 查看如“WLB”选项卡上显示的池 WLB 设置
生成 WLB 报告
  • 查看和运行 WLB 报告，包括“Pool Audit Trail”（池审核追踪）报告
XenCenter 视图管理操作
  • 创建和修改全局 XenCenter 文件夹
  • 创建和修改全局 XenCenter 自定义字段
  • 创建和修改全局 XenCenter 搜索
查看 VM 控制台
取消自己的任务
  • 允许用户取消自己的任务
阅读审核日志
  • 下载 XenServer 审核日志
应用 WLB 优化建议
连接到池并阅读所有池元数据
  • 登录到池
  • 查看池元数据
  • 查看历史性能数据
  • 查看登录的用户
  • 查看用户和角色
  • 查看任务
  • 查看消息
  • 注册和接收事件
修改 WLB 报告订阅
配置 vGPU
  • 指定池范围内的放置策略
  • 将 vGPU 分配给 VM
  • 从 VM 中删除 vGPU
  • 修改允许的 vGPU 类型
  • 创建、销毁或分配 GPU 组
查看 vGPU 配置
  • 查看 GPU、GPU 放置策略和 vGPU 分配。