XenCenter 入门

通过 XenCenter，您可以从 Windows 桌面计算机管理 XenServer 环境并部署、管理和监视虚拟机。 要了解这些内容，只需单击下面的主题。

添加新服务器 | 连接 XenServer 主机服务器并将其添加到 XenCenter 中的托管资源列表中。
创建共享存储 | 创建 XenServer 存储库 (SR) 以提供可以在托管服务器之间共享的存储。
创建新池 | 使用新建池向导将多个托管服务器组合成一个具有共享存储的资源池。
创建虚拟机 | 使用新建 VM 向导创建新的虚拟机 (VM)。
管理用户 | 添加 Active Directory (AD) 用户帐户并通过基于角色的访问控制 (RBAC) 功能分配不同的访问级别，从而配置访问控制。

有关 Citrix XenServer 和 XenCenter 系统要求的信息，请参阅《XenServer 安装指南》。


启动或退出 XenCenter

启动 XenCenter

要启动 XenCenter 会话，请执行以下操作之一：

  • 在开始菜单，选择：开始 > 所有程序 > Citrix > Citrix XenCenter。
  • 双击 Citrix XenCenter 桌面快捷方式。

如果在先前的会话中将 XenCenter 配置为在启动时还原服务器连接，并且设置了主密码，系统将提示您在继续操作前输入该密码。 要了解有关如何设置服务器重新连接首选项的详细信息，请参阅 存储服务器连接状态。

请注意，每个用户只能运行一个 XenCenter 会话。

退出 XenCenter

退出当前 XenCenter 会话：在文件菜单上单击退出。

如果在您退出时有处于运行状态的服务器和 VM，这些服务器和 VM 在 XenCenter 应用程序窗口关闭后仍将继续运行。

如果有任何正在运行的 XenCenter 任务（例如导入或导出 VM），在您尝试退出时系统将发出警告。 您可以选择继续退出（在这种情况下未完成的任务可能不会成功完成），或者等到未完成的任务完成后再退出。


卸载 XenCenter

要卸载 XenCenter，可以使用 Windows 控制面板：

  • Windows XP：在控制面板中，打开添加或删除程序，从列表中选择 Citrix XenCenter，然后单击删除。
  • Windows Vista 和 Windows 7：在“控制面板”中的“程序”下，单击卸载程序，从列表中选择 Citrix XenCenter，然后单击卸载。

请注意，卸载 XenCenter 应用程序时，不会删除 XenCenter 用户配置数据和日志文件。 日志文件和用户配置数据存储在以下文件夹中：

%appdata%\Citrix\XenCenter


浏览 XenCenter 工作区

主题

  • XenCenter 窗口概述
  • 工具栏
  • 资源窗格
  • 选项卡
  • 键盘快捷方式
  • 更改 XenCenter 选项
  • 隐藏对象


XenCenter 窗口概述

参考号 | 名称 | 说明
1 | 菜单栏 | 包含管理服务器、池、SR、VM 和模板所需的所有命令。
2 | 工具栏 | 用于快速访问常用菜单命令的子集。 请参阅 工具栏。
3 | 资源窗格 | 列出当前从 XenCenter 管理的所有服务器、池、VM、模板和 SR。 请参阅 资源窗格
4 | 导航窗格 | 列出所有导航按钮。 单击某个按钮可在资源窗格中查看托管资源的对应视图。
5 | 状态栏 | 显示关于当前任务的进度信息。
6 | 属性选项卡 | 查看及设置选定资源的属性。 请参阅 选项卡。


工具栏

通过 XenCenter 工具栏，可以快速访问某些最常见的 XenCenter 任务（例如，连接新服务器和创建新 VM）。

使用工具栏上的“后退”和“前进”按钮

工具栏上的后退和前进按钮的作用与浏览器上的“后退”和“前进”按钮相同，用于在资源视图之间快速切换。

  • 要显示上一个资源视图，请单击后退。
  • 要显示下一个资源视图（如果使用过“后退”），请单击前进。
  • 要显示在此会话中曾使用的某个资源视图，请单击“后退”或“前进”按钮旁的 [image] 箭头，然后从列表中选择所需的视图。

显示和隐藏工具栏

XenCenter 窗口默认显示工具栏。 但是，如果需要在 XenCenter 窗口中为控制台的显示留出更多空间，可以隐藏工具栏。 要隐藏工具栏，请执行以下操作之一：

  • 在工具栏上的任何位置单击鼠标右键，然后在快捷菜单上单击显示工具栏复选框以删除复选标记。
  • 在视图菜单中，单击以删除工具栏复选标记。
注: 对 XenCenter 工具栏可见性进行的任何更改都是持久性的更改，会在会话之间保留。


资源窗格

资源窗格将显示有关托管资源（服务器、池、VM 和存储）的详细信息。 您可以按资源的物理位置或属性（例如文件夹、标记或自定义字段）查看资源。 “资源”窗格中的视图取决于您在“导航”窗格中单击的按钮。 请参阅以下部分中的表格，了解“导航”窗格中各种按钮的相关信息。

您可以在资源窗格上方的搜索框中键入单词或短语，按资源名称执行简单的文本搜索。 键入搜索内容后，将显示匹配的资源。 要删除查询并再次查看所有资源，请单击“搜索”框右侧的 x 按钮。

您也可以将以前保存的搜索查询应用于“资源”窗格。 XenCenter 中包含几个保存的有用搜索，便于您按网络、操作系统、电源状态、vApp 成员身份和 XenServer Tools 状态进行搜索。 您也可以随时在该列表中创建和添加自己的自定义搜索。有关详细信息，请参阅创建搜索查询和保存的搜索。 要向“资源”窗格的内容应用保存的搜索，请单击“导航”窗格中的保存的搜索并从列表中选择一条搜索查询。

下表列出了“导航”窗格中可用的多个选项。

导航按钮 | 说明
基础结构 | 按资源的物理位置（即它们所属的主机或池）显示资源
对象 | 按类别（例如池、服务器、VM、模板等）显示资源
组织视图 | 按文件夹、标记、自定义字段或 vApp 显示资源
保存的搜索 | 按所选搜索条件显示资源
通知 | 显示将警报、更新和事件集为一体的通知视图

有关导航按钮的详细信息，请参阅导航窗格。


导航窗格

XenCenter 的“导航”窗格提供了可查看和访问托管资源的各种选项。 导航按钮基础结构、对象、组织视图、保存的搜索和通知提供了一种快速查看和管理资源的方式。

以下部分对“导航”窗格中的按钮进行了概述：

基础结构

此为默认视图。 “基础结构”视图按资源的物理位置显示资源的树视图。 该视图按服务器、VM、模板和存储资源所属的池或服务器提供了这些服务器、VM、模板和存储资源的列表。

对象

单击对象可按类别查看资源（例如池、服务器、VM 等）的列表。展开节点可查看每个类别中的项目。

组织视图

XenCenter 允许您将资源分组以方便管理。 默认情况下，XenCenter 提供以下类型的组织视图：

  • 对象(按文件夹)
  • 对象(按标记)
  • 对象(按自定义字段)
  • vApp

对象(按文件夹)

选择此选项可按文件夹查看资源。 您可以创建文件夹，以便按位置、功能、资源类型等对您的资源进行分组。需要注意的是，将资源分组到文件夹中只是概念性分组，而不是物理性分组。如果您选择按文件夹对资源分组，这些资源并不会实际移动到相应的文件夹中。

有关创建和管理文件夹以组织资源的详细信息，请参阅使用文件夹。

对象(按标记)

选择此选项可按您之前定义的标记查看资源。 标记是您所指定的标签，用于根据您定义的条件查看资源。 单个资源可以包含多个标记。 例如，包含标记“生产”的服务器也可以标记为“研发”。

有关在 XenCenter 中创建和管理标记的详细信息，请参阅使用标记。

对象(按自定义字段)

选择此选项可按您之前定义的自定义字段查看资源。 通过 XenCenter，可向您的资源添加自定义字段并提供一个值，以便更高效地管理您的资源。 您只需为池中的服务器、VM 或任何其他资源添加自定义字段并为该字段赋值。 然后在构建搜索查询时，即可使用自定义字段值。

有关创建和使用自定义字段的信息，请参阅使用自定义字段。

vApp

选择此选项可按 VM 所属的 vApp 查看 VM。 vApp 是一组 VM，包含一个或多个 VM，可作为单个实体进行管理。 有关 vApp 的详细信息，请参阅管理 vApp。

保存的搜索

单击此按钮并从列表中选择一个选项可查看与搜索条件匹配的资源。 默认情况下，XenCenter 包含若干已保存的搜索，允许您搜索自己的资源。 您可以随时在此列表中创建和添加自己的查询。

有关 XenCenter 中的搜索功能的详细信息，请参阅搜索资源。

通知

单击此按钮可进入通知视图。 通知视图允许用户在一个集中的位置查看所有通知并执行特定操作来解决相应的通知问题。 该视图包含警报、更新和事件视图。

警报

警报视图显示由 XenCenter 生成的系统警报列表。 您可以按各种选项过滤警报并执行特定操作来解决相应的警报问题。 有关详细信息，请参阅XenCenter 警报。

更新

选择此选项可查看可用的 XenServer 和 XenCenter 更新的列表。 有关详细信息，请参阅更新托管服务器。

事件

选择此选项可查看当前 XenCenter 会话中所有事件的摘要。 有关详细信息，请参阅XenCenter 事件日志。


选项卡

XenCenter 采用基于选项卡的导航方式，保证您无需同时打开和关闭许多窗口即可快速访问托管资源。 在任何时候，可用的选项卡都取决于在资源窗格中选择的内容；例如，大部分资源都有一个常规选项卡，而高可用性和 WLB 选项卡仅在选择池的情况下才可用，快照选项卡仅在选择 VM 的情况下才可用。

控制台

通过该选项卡，可以在 VM 或托管服务器上运行控制台会话。

另请参阅运行远程控制台会话，以了解 XenCenter 中支持的不同类型的远程 VM 控制台。

控制台控件 | 操作
切换到远程桌面 切换到默认桌面 | 在不同类型的 Windows 远程控制台之间切换
切换到图形控制台 切换到文本控制台 | 在不同类型的 Linux 远程控制台之间切换。 切换到图形控制台时，您可能需要首先输入 VNC 密码。
发送 Ctrl-Alt-Del | 向远程控制台发送 Ctrl+Alt+Del 键序列。 默认情况下，在使用远程控制台时，大多数键盘快捷方式都会传输到服务器或虚拟机。 但是，如果您尝试在远程控制台上直接键入 Ctrl+Alt+Del 键序列，本地系统始终会截获并阻止发送该序列。
取消停靠 (Alt+Shift+U) | 取消控制台选项卡在浮动窗口中的停靠。 要从浮动控制台窗口关闭或重新启动服务器、安装 XenServer Tools、关闭、重新启动或挂起虚拟机，请单击该窗口左上角的 [image] ，然后单击相应的命令。 要使用其他键盘快捷方式停靠和取消停靠控制台，请转至 XenCenter 的选项对话框：单击工具 > 选项。
查找控制台 | 打开已最小化的浮动控制台窗口，或者将隐藏在其他窗口后面的浮动控制台窗口置于最前面。
重新停靠 (Alt+Shift+U) 重新连接控制台 | 将浮动控制台窗口重新停靠到控制台选项卡。
缩放 | 缩放远程控制台屏幕，使其恰好放在控制台选项卡或窗口内，以便您可以方便地查看远程控制台上的所有内容。 取消选中该复选框可按正常大小显示远程控制台屏幕。 默认情况下，当您取消停靠控制台或者在不同类型的控制台（例如，VNC 和文本控制台）之间切换时，将保留在控制台选项卡中所使用的缩放设置，但是否保留这些设置是可以配置的。 要更改此设置，请转至选项对话框的控制台选项卡。
全屏 (Ctrl+Enter) | 以全屏模式显示控制台。 按 Ctrl+Alt 可退出全屏模式；要使用其他键序列，请转至 XenCenter 的更改 XenCenter 选项对话框。 当在全屏模式下将鼠标指向屏幕顶部的中心时，将显示连接栏，其中将显示所处理的 VM 或服务器的名称，并且包含两个控件：“Pin”（锁定）按钮用于永久打开连接栏，Restore down（还原）按钮用于退出全屏模式。

可以在选项对话框中控制许多控制台设置。 例如，默认情况下，本地计算机上的文本剪贴板将共享给远程控制台，这样，您剪切或复制的项目将放置在该剪贴板上并且可以粘贴到本地计算机或远程控制台上。 您可以从 XenCenter 的选项对话框关闭剪贴板共享功能并更改许多其他控制台设置；请参阅更改 XenCenter 选项。

常规

在常规选项卡上，可以查看所选虚拟机、服务器、资源池、模板或存储库的常规属性；单击属性可设置或更改属性。

您可以将此窗格中显示的任何值快速复制到 Windows 剪贴板中，以粘贴到其他位置（例如粘贴到文本编辑器中），方法是在该值上单击鼠标右键，然后单击快捷菜单上的复制。

GPU

当 XenCenter 连接到包含可用 GPU 的池或主机时，您可以查看此选项卡。

GPU 选项卡允许您查看或编辑 GPU 放置策略、查看可用的 GPU 和 vGPU 类型。 GPU 将根据支持的 vGPU 类型进行分组。 可以使用编辑选定 GPU 选项修改特定 GPU 上允许的 vGPU 类型。 每个组中的水平条表示物理 GPU，显示在该 GPU 上运行的 VM 的相关信息。

有关详细信息，请参阅配置 vGPU和更改池属性。

注: vGPU 是一项仅在 XenServer Enterprise、XenServer Desktop+ 和 XenServer Desktop Edition 中提供的高级功能。 有关 XenServer 6.5 许可的信息，请参阅许可概述 (XenServer 6.5)。 要购买 XenServer 许可证，请单击此处。

高可用性

在池的高可用性选项卡上，可以执行以下操作：

  • 使用配置高可用性按钮启用高可用性。
  • 使用配置高可用性按钮更改池的高可用性配置。
  • 禁用（关闭）高可用性。

当高可用性处于启用状态时，可以在高可用性选项卡上查看当前的高可用性状态（故障容量和服务器故障限制）以及所选检测信号 SR 的状态。

请参阅配置高可用性、禁用高可用性和更改高可用性设置。

主页

通过主页选项卡，可向托管服务器列表添加服务器、打开 XenCenter 帮助系统或打开浏览器窗口以查找有关 XenServer 和其他 Citrix 产品的更多信息。

内存

您可以在内存选项卡上启用动态内存控制 (DMC) 和配置动态内存限制。 VM 可以采用静态内存分配，也可以配置为使用 DMC。动态内存控制允许随着服务器上内存要求的变化而即时调整分配给 VM 的内存量，而不必重新启动 VM。

请参阅关于 VM 内存配置、动态内存控制 (DMC)和配置 DMC。

网络连接

网络连接选项卡显示了所选池、服务器或 VM 上配置的网络列表。 在该选项卡中还可以集中访问或修改网络设置。

请参阅关于 XenServer 网络 和查看和更改网络属性。

NIC

在 NIC 选项卡上，可以查看有关所选服务器上物理网络接口卡 (NIC) 的详细信息并配置 NIC 绑定。

NIC 绑定（或称“NIC 成组”）可以将两个或更多物理 NIC 视为一个 NIC 使用：如果绑定中的一个 NIC 出现故障，服务器的网络流量将自动通过第二个 NIC 进行路由，确保了服务器的管理连通性，从而提高了服务器恢复能力。 请参阅 配置 NICs。

注: 您必须使用 vSwitch 作为网络堆栈才能绑定四个 NIC。 使用 Linux 桥接时只能绑定两个 NIC。

性能

在性能选项卡上，可以查看 VM 和托管服务器的性能数据。 请注意，只有在安装了 XenServer Tools 时，才能查看 VM 的完整性能数据。

该选项卡提供整个资源池性能的实时监视统计数据，并以图表方式显示虚拟机和物理机性能的趋势。 默认情况下，该选项卡上提供显示 CPU、内存、网络和磁盘 I/O 情况的图表。 单击操作可添加更多性能数据并更改图表的外观。 有关详细信息，请参阅配置性能图表。

当托管服务器、虚拟机或存储库上的 CPU、内存使用率、网络、存储吞吐量或 VM 磁盘活动超出指定阈值时，可生成性能警报。 有关详细信息，请参阅配置性能警报。

搜索

在资源窗格中选择顶层 XenCenter 项目（池或服务器），然后单击搜索选项卡，以对托管资源执行复杂搜索。 可以基于对象类型、文件夹和属性（例如名称、说明、标记、高可用性状态或重启优先级以及电源状态）构造查询。

请参阅创建搜索查询、将搜索结果过滤和分组、保存的搜索和导出和导入搜索。

快照

在快照选项卡上，可以创建、删除和导出 VM 快照、将 VM 还原到所选快照以及使用现有快照创建新的 VM 和模板。

请参阅 VM 快照。

存储器

在存储选项卡上，可以查看所选虚拟机、服务器、资源池或存储库的存储配置。 此选项卡上显示的设置取决于当前在资源窗格中选择的资源类型。

所选资源 | “存储”选项卡上显示的内容 | 了解详情
VM 和模板 | 显示有关 VM 上每个虚拟磁盘的信息，其中包括虚拟磁盘的大小和位置（虚拟磁盘所在的 SR）、数据访问状态和磁盘访问优先级。 要编辑某个虚拟磁盘的设置，请在列表中选择该虚拟磁盘，然后单击“属性”。 单击“添加”可添加新磁盘，单击“连接”可连接现有磁盘。 | 配置虚拟存储
服务器和池 | 显示可用存储库的列表以及有关可用存储库 (SR) 的类型、大小、可用空间和共享状态的摘要信息。 要编辑某个 SR 的名称或说明，请在列表中选择该 SR，然后单击“属性”。 单击“添加”可添加 SR，单击“分离”可分离所选 SR。 | 管理存储库 (SR)
存储库 | 显示所选 SR 上虚拟磁盘或 ISO 的列表。 单击添加可添加新的虚拟磁盘。 | 添加虚拟磁盘

用户

在用户选项卡上，可以通过 AD 用户帐户置备和基于角色的访问控制 (RBAC) 来为 XenServer 用户和组配置基于角色的访问权限。 在该选项卡上，可以将池或服务器加入 Active Directory (AD) 域、将 AD 用户或组添加到池中以及为用户和组分配角色。

请参阅 管理用户。

WLB

在 WLB 选项卡上，可以访问关键的 Workload Balancing 功能（包括配置、优化建议和状态）。

注: 工作负载平衡是一项仅在 XenServer Enterprise、XenServer Desktop+ 和 XenServer Desktop Edition 中提供的高级功能。 有关 XenServer 6.5 许可的信息，请参阅许可概述 (XenServer 6.5)。 要购买 XenServer 许可证，请单击此处。


资源状态图标

在 XenCenter 中，托管资源（服务器（主机）、虚拟机、存储和模板）的当前状态在资源窗格和其他位置会以不同的图标表示：

服务器

已连接并且正在正常运行的服务器。
暂时未连接到 XenCenter 的服务器（例如，由于服务器正在重新启动或者已挂起）。
已断开连接的服务器（例如，由于服务器已关闭）。
当前处于维护模式的服务器。 请参阅在维护模式下运行。
由于系统故障而创建了故障转储文件的服务器。 故障转储文件位于服务器 /var 目录下的 crash 文件夹中。 故障转储文件可以为技术支持工程师提供有助于诊断 XenServer 相关问题的宝贵信息，还可以包含在 XenCenter 中使用获取服务器状态报告实用程序生成的服务器状态报告中。 有关此功能的详细信息，请参阅创建服务器状态报告。

从服务器的 /var 目录中删除故障转储文件后，XenCenter 中显示的服务器状态图标将还原为正常状态。
有可用更新的服务器。 请参阅更新托管服务器。
运行的 XenServer 版本早于池主服务器所用版本的服务器。 请参阅更新托管服务器。

虚拟机、VM 模板和 vApp

正在正常运行的虚拟机。
当前已挂起的虚拟机。
当前不可用的虚拟机（例如，由于虚拟机正在重新启动或者已挂起）。
当前未运行的虚拟机（例如，由于虚拟机已关闭）。
当前正在迁移的虚拟机。 请参阅迁移虚拟机。
XenServer VM 模板。
自定义（用户定义）VM 模板。
XenServer vApp。 请参阅管理 vApp。

VM 快照

VM 的仅磁盘快照。
计划的 VM 仅磁盘快照。
VM 的磁盘和内存快照。
计划的 VM 磁盘和内存快照。

存储器

存储库。
池的默认存储库。
当前未连接的存储库。
当前不可用的存储库。 请参阅解决 SR 连接问题。
需要升级的存储库。 请参阅升级旧 SR。
虚拟磁盘。
虚拟磁盘快照。 这是虚拟机磁盘的快照，在生成 VM 快照时创建。 有关生成 VM 快照的信息，请参阅 VM 快照。要了解有关磁盘快照的详细信息，请参阅《XenServer 管理员指南》。


键盘快捷方式

可以使用键盘和鼠标在 XenCenter 中进行导航及执行任务。 例如，可以使用箭头键在资源窗格中的项目之间及各菜单之间导航。

菜单导航

要开启或关闭菜单模式，请按 F10 或 Alt 键。在菜单模式下，可以使用键盘进行菜单导航。

向右键、

向左键

 在菜单栏中导航，依次选择各个菜单。
向上箭头、

向下箭头

 依次选择每个菜单命令。
Enter | 激活选定命令。
Esc | 取消选定命令并关闭菜单。
带下划线的字母（访问键） 使用带下划线的字母可选择特定菜单和菜单命令。

例如，要复制虚拟机，通过先按 Alt 或 F10 键，然后按 M 键，再按 C 键即可选择 VM 菜单然后复制 VM。

在 Windows XP 和 Windows Vista 中，默认情况下带下划线的字母处于隐藏状态，直到您按下 F10 或 Alt 键。 要更改此设置以始终显示带下划线的字母：

  • 在 Windows XP 的控制面板中，双击显示，然后单击外观选项卡。 单击效果，并清除直到我按 Alt 键之前，请隐藏有下划线的字母供键盘使用复选框。
  • 在 Windows Vista 和 Windows 7 的控制面板中，单击轻松访问，然后在轻松访问中心标题下，单击更改键盘的工作方式。向下滚动到选项页面的底部，然后在使键盘快捷方式使用更容易，选择给键盘快捷方式和访问键加下划线复选框。
快捷键 | 使用快捷键组合激活特定菜单命令。

使用快捷键

有了快捷键，您可以使用键盘（而不是鼠标）快速执行任务。 例如，按 Ctrl+N 键打开新建 VM 向导，这与在 VM 菜单中单击新建 VM 效果相同。 有些快捷键显示在菜单中和工具栏的工具提示中。 使用数字小键盘时，请确保 Num Lock 处于关闭状态。

F1 | 显示联机帮助
Alt+F4 | 退出 XenCenter 并关闭 XenCenter 窗口
Ctrl+Alt | 在控制台的全屏模式与窗口模式之间切换
Ctrl+B | 启动选定的 VM
Ctrl+C | 将选定文本复制到 Windows 剪贴板
Ctrl+E | 关闭选定的 VM
Ctrl+N | 打开新建 VM 向导
Ctrl+R | 重新启动选定 VM
Ctrl+V | 从 Windows 剪贴板粘贴选定文本
Ctrl+X | 将选定文本剪切到 Windows 剪贴板
Ctrl+Y | 挂起或恢复选定 VM
Ctrl+Z | 撤销上次文本编辑操作


更改 XenCenter 选项

可以更改影响 XenCenter 工作环境的一些设置。 在工具菜单上，单击选项，单击某个选项卡并更改设置，然后单击确定保存更改。

安全设置

选项 | 说明 | 默认值
找到新 SSL 证书时警告我 | 如果选中该复选框，每当在托管服务器上找到新的 SSL（安全套接字层）安全证书时，XenCenter 都会显示一条警告消息。 如果您不希望在连接托管服务器时显示找到新证书的警告消息，可清除该复选框。 | 禁用
SSL 证书更改时警告我 | 如果您不希望在连接托管服务器时显示找到已修改证书的警告消息，可清除该复选框。 如果选中该复选框，每当在托管服务器上找到已修改证书时，XenCenter 都会显示一条警告消息。 | 启用

另请参阅：连接服务器和断开服务器连接。

更新设置

选项 | 说明 | 默认值
检查新版本 XenServer | 如果选中该复选框，XenCenter 将定期检查是否有可用的新版本 XenServer，如果发现新版本，将向您发出通知。 清除该复选框可以禁用定期检查功能。 | 启用
检查 XenServer 更新 | 如果选中该复选框，XenCenter 将定期检查是否有可用的 XenServer 更新，如果发现新更新，将向您发出通知。 清除该复选框可以禁用定期检查功能。 | 启用
检查新 XenCenter 版本 | 如果选中该复选框，XenCenter 将定期检查是否有可用的新版本 XenCenter，如果发现新版本，将向您发出通知。 清除该复选框可以禁用定期检查功能。 | 启用

另请参阅：关于软件更新、更新托管服务器、更新 XenCenter。

性能图表设置

选项 | 说明
区域图 | 如果您希望以区域图形式查看性能选项卡上显示的性能数据，请单击该单选按钮。 例如：
折线图 | 如果您希望以折线图形式查看性能选项卡上显示的性能数据，请单击该单选按钮。 例如：
另请参阅：监视系统性能。

控制台设置

选项 | 说明 | 默认值
与远程控制台共享剪贴板内容 | 如果选中该复选框，将与远程控制台共享本地文本剪贴板内容。 剪切或复制的项目将放置在剪贴板上，并且粘贴到本地计算机或远程控制台上。 | 启用
全屏模式 | 用于来回切换控制台全屏模式的键盘快捷方式。 | Ctrl+Enter
停靠/取消停靠 | 用于从 XenCenter 窗口取消停靠控制台选项卡以及重新停靠该选项卡的键盘快捷方式。 | Alt+Shift+U
释放键盘和鼠标 | 当 VM 中的操作系统捕获键盘和鼠标光标供来宾操作系统使用时，您所执行的全部击键、鼠标移动和按钮单击操作都将转到该 VM。 为了将键盘和鼠标的所有权返还给主机操作系统，XenCenter 在键盘上保留了一个特殊键：即主机键。 默认情况下，主机键是键盘上的右 Ctrl 键。 可以使用此功能更改此默认设置。 | 右 Ctrl 键
将控制台取消停靠时保留当前缩放设置 | 如果选中该复选框，可在控制台停靠和取消停靠时使用相同的控制台缩放设置。 | 启用
切换回默认控制台时保留当前缩放设置 | 如果选中该复选框，在不同控制台类型（例如，VNC/文本控制台）之间切换时，将保持相同的控制台缩放设置。 | 启用
向远程桌面控制台发送 Windows 键组合 | 如果选中该复选框，XenCenter 会将从键盘输入的任何 Windows 键组合发送到远程桌面控制台。 | 启用
从远程桌面控制台接收声音 | 如果选中该复选框，XenCenter 将在本地计算机（运行 XenCenter 的计算机）上播放来自远程桌面控制台上运行的应用程序的声音。 | 启用
远程桌面控制台变为可用时自动切换到该控制台 | 如果选中该复选框，每当远程桌面控制台可用时，XenCenter 都会自动从使用标准图形控制台切换为使用远程桌面控制台。 | 启用
直接连接服务器的控制台会话 | 如果选中该复选框，在打开远程桌面控制台会话时，XenCenter 将连接到远程服务器上的现有控制台，而不是创建新的虚拟控制台会话。 | 启用
启用远程桌面控制台扫描 | 如果选中该复选框，XenCenter 将自动扫描 RDP 连接。 清除该复选框可以禁止 XenCenter 自动扫描（轮询）RDP 端口（例如，在有防火墙阻止 RDP 通信时）。 请注意，如果启用该选项，即使自动切换到远程桌面选项处于禁用状态，XenCenter 仍将继续扫描 RDP 端口，因此您可以在 RDP 可用时立即切换到 RDP。 | 启用

对 Windows 远程桌面控制台设置进行的更改都将在重新启动 XenCenter 后生效。

另请参阅：运行远程控制台会话。

连接设置

选项 | 说明 | 默认值
代理服务器 XenCenter 可以配置为直接连接托管服务器，或者使用代理服务器进行连接。 可以使用 Internet Explorer 代理服务器设置，也可以另外指定代理服务器。
  • 选择不使用代理服务器时，XenCenter 将直接连接托管服务器而不使用代理服务器。
  • 选择使用 Internet Explorer 的代理服务器设置时，将使用与 Internet Explorer 相同的代理设置。
  • 如果您希望 XenCenter 连接到指定的代理服务器，并使用 HTTP CONNECT 与服务器间建立安全的 SSL 隧道，请选择使用此代理服务器。 输入代理服务器地址以及要使用的端口号。

要请求直接连接本地资源而不通过代理服务器进行连接，请选中为本地地址绕过代理服务器复选框。 要请求通过代理服务器进行所有连接，请清除该复选框。

本地地址是指 LAN 或 Intranet 地址，语法上通过不含句点 (.) 来进行识别，比如 URI http://webserver/ 和 http://localhost/。

不使用代理服务器
连接超时 | 可以通过调整等待连接超时的秒数，指定在尝试与托管服务器建立连接时等待的时长。 如果您不希望由于网络问题而收到大量虚假警报，则不应将此值设置得过低。 | 20 秒

另请参阅：连接服务器和断开服务器连接。

“保存和还原”设置

通过该选项卡上的设置，可以指定是否希望存储托管服务器的登录凭据，并在启动每个 XenCenter 会话时使用这些凭据自动重新连接所有托管服务器。 您也可以在此处设置主密码来保护存储的登录凭据。

选项 | 说明 | 默认值
保存并在启动时还原服务器连接状态 | 可以在 XenCenter 会话之间存储所有托管服务器的登录凭据（用户名和密码），并在启动每个新 XenCenter 会话时使用凭据自动重新连接这些服务器。 选中此复选框时，XenCenter 将在每个会话结束时记住所有托管服务器的连接状态，并在启动下一个会话时尝试还原连接状态。 | 禁用
需要主密码 | 如果启用保存并在启动时还原服务器连接状态，可以使用主密码来保护存储的登录凭据，以确保这些凭据的安全；在启动每个会话时，系统将在自动还原与托管服务器的连接之前，提示您输入此主密码。 | 禁用
更改主密码 | 单击该项可以更改当前主密码；系统将提示您输入当前密码，然后输入新的主密码并进行确认。 |

插件设置

插件是可选组件，可以添加到 XenCenter 中以扩展其功能。 使用 XenCenter 插件可以在主窗口中添加自定义菜单项甚至整个选项卡。 例如，通过插件的形式，ISV 可以将自己的产品与 XenCenter 相集成，而最终用户可以将产品与公司现有清单管理功能集成。 菜单项可以在客户端计算机上运行 Microsoft PowerShell 脚本，甚至可以运行任意可执行文件。 选项卡用 Web 页面来填充，并且可以由网络上的其他服务或 VM 调用。

选项 | 说明 | 默认值
插件组件 XenCenter 插件包含以下组件：
  • XML 配置文件。
  • 每个受支持区域的资源 DLL。
  • 应用程序及其所需的任何资源。

插件组件应放入 XenCenter 安装文件夹的 plugins 子文件夹。 这些组件将在启动 XenCenter 时加载。 例如，如果使用默认 XenCenter 安装目录，则插件将位于：

C:\Program
Files\Citrix\XenCenter\plugins
\<your_organization_name>\<your_plugin_name>
 禁用
查看可用插件 | 要查看 XenCenter 中当前可用插件的列表，以及启用或禁用各个插件，请在工具菜单中单击选项。 此时将显示选项对话框。 从左侧窗格中的选项列表中，单击插件。 | 启用
创建插件 | 要了解如何创建 XenCenter 插件，请参阅 XenCenter 插件 Web 页面。 您可以通过在帮助菜单中单击联机 XenCenter 插件，随时从 XenCenter 访问该 Web 页面。


隐藏对象

通过将键 HideFromXenCenter=true 添加到 XenServer API 中对象的 other_config 参数，可以从 XenCenter 隐藏网络、PIF 和 VM。 例如，如果某些 VM 不应由环境中的一般用户直接使用，则可以将其隐藏。 用该键标记的对象称为隐藏对象，默认情况下，这些对象不在 XenCenter 中的任何位置显示。

要使隐藏的对象在 XenCenter 中可见，请在视图菜单中单击隐藏对象。 要再次隐藏这些对象，请在视图菜单中清除隐藏对象的复选标记。

请参阅《XenServer 软件开发工具包指南》，了解有关使用 HideFromXenCenter 键标记对象的详细信息。


组织资源

XenCenter 提供了许多不同的方法来组织物理资源和虚拟资源，您可以使用最合适的方法。
  • 使用文件夹
  • 使用标记
  • 使用自定义字段


使用文件夹

文件夹是一个容器，可用来以对环境有意义的方式将任何托管资源分组；例如，可以为贵组织中的每个分支机构创建一个文件夹。 文件夹可以包含来自 XenServer 环境中任何位置的、任何类型的资源。 对资源的访问与引用这些资源的文件夹无关。

XenCenter 中的文件夹组织方式是概念性方式，而不是物理性方式。资源实际上并不位于文件夹中，因此，将资源放入文件夹中时，并不影响资源的物理位置。 例如，将 VM 放入某个文件夹时，并不会将其主机服务器也放入该文件夹；将服务器放入某个文件夹时，并不会将该服务器上的所有 VM 和存储资源也放入该文件夹。

文件夹还可以用在搜索查询中，例如，可以通过“包含于”/“不包含于”关系及文件夹的下拉层次结构按文件夹进行搜索。 请参阅创建搜索查询。

资源当前所在的文件夹显示在资源的常规选项卡和属性对话框中，因此，您随时可以查看资源的文件夹信息。 还可以使用常规选项卡将资源移入其他文件夹中或从某个文件夹中删除。

创建新文件夹

创建新文件夹的最简单方法是通过“资源”窗格。 在“导航”窗格中，单击组织视图，然后选择对象(按文件夹)。 在“资源”窗格中单击文件夹组，单击鼠标右键，然后选择快捷菜单上的新建文件夹。 键入新文件夹的名称，选择将存储文件夹元数据的服务器，然后单击创建。

您还可以从常规选项卡为任何资源创建新文件夹：

  1. 在“资源”窗格中，选择池、服务器、SR、虚拟机或模板，单击常规选项卡，然后单击属性。
  2. 在属性对话框的常规选项卡上，单击文件夹框中的更改。
  3. 在更改文件夹对话框中，单击在此文件夹中按钮，然后单击新建文件夹。
  4. 输入新文件夹的名称，选择将存储文件夹元数据的服务器，然后单击创建。
  5. 单击移动以应用更改，然后在属性对话框上单击确定。

将资源移入和移出文件夹

将资源移入文件夹的最简单方法是将其从“资源”窗格或搜索选项卡拖放到所需文件夹上。 资源只能存在于一个文件夹中，因此，如果资源已位于其他文件夹中，则将其拖放到其他文件夹时会将其移动。

还可以使用常规选项卡将资源移入其他文件夹中或从某个文件夹中删除。

  1. 在“资源”窗格中，选择要放入文件夹中的池、服务器、SR、虚拟机或模板，单击常规选项卡，然后单击属性。
  2. 在属性对话框的常规选项卡上，单击文件夹框中的更改。
  3. 要将资源从其当前所在的文件夹中删除，请选择不在任何文件夹中。
  4. 要将资源移动到其他文件夹中，请选择在此文件夹中并从列表中选择一个文件夹或子文件夹。
  5. 要将资源放入新文件夹中，请单击新建文件夹，键入新文件夹的名称，选择将存储文件夹元数据的服务器，然后单击创建。
  6. 单击移动以应用更改，然后在属性对话框上单击确定。

重命名文件夹

  1. 在“资源”窗格中，选择文件夹，单击鼠标右键，然后从快捷菜单中选择重命名文件夹。
  2. 键入新名称。

删除文件夹

请注意，删除文件夹时并不会实际删除文件夹中的资源：资源将返回到其常规集合中。

  1. 在“资源”窗格中，选择文件夹，单击鼠标右键，然后从快捷菜单中选择删除文件夹。
  2. 单击是确认。
所有内容都将从该文件夹中移出，然后该文件夹被删除。


使用标记

通过标记，您可以按新方法标识资源。 标记类似于关键字或标签，可以根据对您来说比较重要的条件（例如应用程序、位置、成本中心、所有者或生命周期阶段），在 XenCenter 中使用标记重新排列资源的视图。

您可以在需要时构建标记并且可以使用任意多个标记，您还可以基于自己的标记构建搜索，例如“all Windows 7 test machines located in Cambridge”。

单击资源的常规选项卡可以查看当前分配给该资源的标记，也可以添加和删除标记。

创建新标记

  1. 在资源窗格中，选择一个资源，单击其常规选项卡，然后单击属性。
  2. 在属性对话框的常规选项卡上，单击编辑标记。
  3. 在新标记框中键入单词或短语，然后单击创建。
  4. 新标记将自动分配给所选资源。 要删除该标记，请清除复选框。
  5. 单击确定。
  6. 在属性对话框上，单击确定应用更改。

删除标记

  1. 在“导航”窗格中，选择组织视图，然后选择对象(按标记)。 “标记”组将显示在“资源”窗格中。
  2. 选择要删除的标记，单击鼠标右键，然后单击删除标记。 该标记将从当前带有该标记的所有资源中删除。

标记资源

向资源分配现有标记的最简单方法是，将资源拖放到“资源”窗格中的标记上。 您可以从“资源”窗格的“标记”组或搜索选项卡上的搜索结果列表中拖放资源。

您还可以使用编辑标记对话框为资源分配现有标记或新标记：

  1. 在资源窗格中，选择要标记的池、服务器、SR、虚拟机或模板，单击常规选项卡，然后单击属性。
  2. 在属性对话框的常规选项卡上，单击编辑标记。
    • 要创建新标记并将其添加到所选资源，请在编辑标记框中键入单词或短语，然后单击创建。
    • 要添加现有标记，请在标记列表中单击选中该标记的复选框，然后单击确定。
  3. 在属性对话框上，单击确定应用更改。

取消资源的标记

要取消标记资源（从资源中删除标记），请在导航窗格中单击组织视图，然后单击对象(按标记)。 选择要取消标记的资源，单击鼠标右键，然后选择取消标记对象。

还可以使用编辑标记对话框取消标记资源：

  1. 在“资源”窗格中，选择要取消标记的池、服务器、SR、虚拟机或模板，单击常规选项卡，然后单击属性。
  2. 在属性对话框的常规选项卡上，单击编辑标记。
  3. 在标记列表中清除标记的复选框，然后单击确定。
  4. 在属性对话框上，单击确定应用更改。


使用自定义字段

通过自定义字段，可以为资源添加结构化信息，这些信息随后可帮助您更有效地查找和管理资源。

例如，可以按物理位置标识所有主机，或者标记所有虚拟机上运行的成本中心和应用程序。 您只需为池中的服务器、VM 或任何其他资源添加自定义字段并为该字段赋值。 然后在构建搜索查询时，即可使用自定义字段值。

自定义字段在池级别共享。 在常规选项卡和资源属性对话框的自定义字段选项卡上为池中的任何资源设置自定义字段后，该字段将可供池中的所有其他资源使用。

在“导航”窗格中，单击组织视图，然后选择对象(按自定义字段) 以按自定义字段查看您的托管资源。

创建新的自定义字段

  1. 在“资源”窗格中，选择任意资源，单击常规选项卡，然后单击属性。
  2. 在自定义字段选项卡上，单击编辑自定义字段。
  3. 单击添加，为自定义字段键入一个名称并选择字段类型。
  4. 单击确定应用更改。

为资源的自定义字段赋值

  1. 在“资源”窗格中，选择该资源，单击常规选项卡，然后单击属性。
  2. 在属性对话框中的自定义字段选项卡上，输入自定义字段的值。
  3. 单击确定。
该资源的常规选项卡将显示为其设置的所有自定义字段。

删除自定义字段

  1. 在“资源”窗格中，选择该资源，单击常规选项卡，然后单击属性。
  2. 在属性对话框中的自定义字段选项卡上，单击编辑自定义字段。
  3. 从列表中选择自定义字段，然后单击删除。
  4. 单击是确认。


搜索资源

使用 XenCenter 可对托管资源执行复杂搜索。 默认情况下，XenCenter 中包含若干搜索，便于您按标记搜索资源，以及按网络、操作系统、电源状态、vApp 和 XenServer Tools 状态搜索 VM。 您也可以随时在该列表中创建和添加自己的自定义搜索。 搜索选项卡上的视图取决于您在“导航”窗格中选择的选项。 从“导航”窗格中选择一个视图，然后单击搜索选项卡开始您的搜索查询。 “搜索”选项卡中还会显示标题以突出显示您的搜索查询所选取的资源。

您也可以在资源窗格上方的搜索框中键入单词或短语，按资源名称执行简单的文本搜索。 键入搜索内容后，将显示匹配的资源。 要删除查询并再次查看所有资源，请单击“搜索”框右侧的 x 按钮。 有关详细信息，请参考以下主题：
  • 创建搜索查询
  • 将搜索结果过滤和分组
  • 导出和导入搜索
  • 保存的搜索


创建搜索查询

通过搜索选项卡，可以基于对象类型、文件夹和属性（例如名称、说明、标记、高可用性状态或重启优先级以及电源状态）构造查询。

创建新搜索查询

  1. 在搜索选项卡上，单击新建搜索。
  2. 在搜索内容下，选择要搜索的资源类型或资源组合。 除资源类型（例如服务器、VM 和存储库）外，此列表中还包含一些常见的资源类型组合，以及用于搜索所有资源的选项。

    要定义自己的搜索类别，请单击自定义并选择要搜索的资源类型。

    在搜索内容下选择某个选项后，将立即应用该搜索，结果将立即显示在搜索选项卡的下半部分。

  3. 单击保存以保存该搜索查询。
  4. 在名称框中键入搜索查询的标题。
  5. 单击位置列表选择将保存搜索查询元数据的服务器，然后选择服务器。
  6. 单击保存。

注意：

  • 在搜索选项卡上双击某个搜索结果时，将显示该资源的常规选项卡。
  • 要将搜索进一步细化，可以为搜索结果应用过滤器。 有关详细信息，请参阅将搜索结果过滤和分组。 选择某个过滤器选项后，将立即应用相应的过滤器，并且结果将立即更新。
  • 要立即将搜索结果放入文件夹中，请选择组织视图，然后选择对象(按文件夹)。 执行搜索查询，选择搜索结果，然后将结果拖到“资源”窗格的文件夹上。 注意，资源只能存在于一个文件夹中，因此，如果该资源已位于其他文件夹中，则会将其移动。 有关详细信息，请参阅使用文件夹。
  • 要立即标记搜索结果，请选择组织视图，然后选择对象(按标记)。 执行搜索查询，选择搜索结果，然后将结果拖入“资源”窗格的标记上。 有关使用标记的详细信息，请参阅使用标记。


将搜索结果过滤和分组

可以为选定的搜索类别应用过滤器，以将搜索进一步细化。 可用的过滤器适用于要搜索的资源类型。

例如，在搜索服务器时，可以按服务器名称、地址（服务器的 IP 地址）、服务器所在的池以及服务器上的 VM 过滤搜索结果。 在搜索虚拟磁盘时，可以使用多种条件（例如，虚拟磁盘是否为共享磁盘、虚拟磁盘所在的存储库）过滤搜索结果。

过滤搜索结果

  1. 单击过滤器正下方的按钮，然后从列表中选择过滤器类别：

    您只能选择适用于要搜索的资源的过滤器。

  2. 如果适用，请选择一个运算符（例如是、包含或启动时间），然后输入一个值。 在此处选择某个选项后，过滤器将立即应用于搜索结果，结果将立即更新。
  3. 要添加更多过滤器，请单击过滤器正下方的过滤器按钮，然后从列表中选择一个多过滤器类别：

  4. 要删除过滤器，请单击搜索选项卡右侧的删除按钮。

将搜索结果分组

  1. 在分组方式下，从下拉列表中选择要应用的分组选项。 在此处选择某个选项后，将立即应用分组，结果将立即更新。
  2. 要为搜索结果添加其他分组类别，请单击更多，然后选择要添加的分组类别。
  3. 要删除分组，请单击分组按钮，然后选择删除分组。


保存的搜索

XenCenter 中包含若干保存的有用搜索，便于您按标记搜索资源，以及按网络、操作系统、电源状态、vApp 和 XenServer Tools 状态搜索 VM。 任何时候均可单击搜索选项卡上的编辑搜索按钮来修改这些搜索查询。

您也可以随时在该列表中创建和添加自己的自定义搜索。有关详细信息，请参阅创建搜索查询。 自定义搜索显示在 XenCenter“导航”窗格中的保存的搜索列表顶部。

应用保存的搜索

  • 要在“资源”窗格中运行保存的搜索，请在 XenCenter“导航”窗格中从保存的搜索列表选择一个搜索。 搜索结果将列在资源窗格中。
  • 要在搜索选项卡上运行保存的搜索，请单击保存的搜索，然后从列表中选择一个保存的搜索查询。

删除保存的搜索

在搜索选项卡上，依次单击保存的搜索和删除，然后从列表中选择一个保存的搜索查询。 单击是确认。


导出和导入搜索

使用 XenCenter 可将搜索查询保存为 XenSearch (.xensearch) 文件。 导出并保存搜索查询时，只会保存搜索查询，而不会保存结果。

导出当前的搜索

  1. 在搜索选项卡上，单击导出。
  2. 输入文件名称和位置，然后单击保存。

导入搜索

  1. 在搜索选项卡上，单击导入。 或者，在 XenCenter 的文件菜单上，选择导入搜索。
  2. 通过浏览找到所导出的搜索文件（文件扩展名为 .xensearch），然后单击打开。 导入的搜索将会立即执行，在搜索选项卡上显示结果。

要将导入的搜索保存为新的自定义搜索，请单击保存，然后指定该搜索查询的名称，并选择将存储该搜索查询元数据的位置。 单击保存进行确认。


关于 XenServer 许可

XenServer 使用与其他 Citrix 产品相同的许可过程。 XenServer 需要许可证服务器。 有关如何安装和运行 Citrix Licensing 的详细信息，请参阅 Citrix eDocs Web 站点。

购买 XenServer 支持后，您将拥有 .LIC 许可证密钥。 许可证密钥应安装在：

  • 运行 Citrix 许可证服务器软件的 Windows Server，或者
  • 基于 Linux 的 Citrix 许可证服务器虚拟设备

XenServer Licensing 取决于主机上已安装的 XenServer 版本。 请参阅下表了解有关各种 XenServer 版本中许可概念的详细信息。

版本 | 主题
XenServer v6.5 | 许可概述 (XenServer 6.5) 在 XenServer 6.5 中管理许可证
XenServer v6.2.0 | 许可概述 (XenServer v6.2.0) 管理 XenServer v6.2.0 中的许可证
XenServer v6.1.0 及更早版本 | 许可概述（XenServer v6.1.0 及更早版本） 管理 XenServer 6.1.0 及更早版本的许可证 激活免费 XenServer 产品


许可概述 (XenServer 6.5)

XenServer 6.5 提供四种商用版本：

  • Standard
  • 企业应用程序
  • 桌面
  • Desktop+

Standard Edition 是我们的入门级商用产品，如果客户希望使用强大的高性能虚拟化平台，但不需要 Enterprise Edition 提供的高级功能，而同时仍希望获得全面的 Citrix 支持和维护保障，本版本提供的一系列功能可以满足此类客户的需求。

Enterprise Edition 是我们的高级产品，已针对服务器、桌面和云工作负载进行了优化。 除 Standard Edition 外，本版本还提供对 Boot Storm Guard（内存中读取缓存）、动态工作负载平衡、通过 NVIDIA GRID 实现的 GPU 虚拟化 (vGPU)、VMware vSphere 到 XenServer 转换实用程序、Intel Secure Measured Boot (TXT) 和导出资源数据的访问。

Desktop Edition 仅面向购买了 XenApp 或 XenDesktop 的客户，本版本中包含之前面向 XenApp 或 XenDesktop 客户的所有 XenServer 功能。 这些功能包括 Standard Edition 不提供的功能，即：动态工作负载平衡、通过 NVIDIA GRID 实现的 GPU 虚拟化 (vGPU)、VMware vSphere 到 XenServer 转换实用程序、Intel Secure Measured Boot (TXT) 以及全面的 Citrix 支持和维护。

Desktop+ Edition 仅面向购买了 XenApp 或 XenDesktop Platinum Edition 的客户；除 Desktop Edition 中提供的功能外，本版本还提供对 Boot Storm Guard（内存中读取缓存）的访问。

注: 可以从 Standard Edition 升级到 Enterprise Edition。 有关 XenServer 6.5 许可的详细信息，请参阅 XenServer 6.5 许可常见问题解答。 要购买 XenServer 6.5 许可证，请单击此处。

Citrix Licensing

XenServer 使用的许可过程与其他 Citrix 产品相同，因此，需要在许可证服务器上安装有效的许可证。 可以从 Citrix Licensing 页面下载许可证服务器。 购买 XenServer 版本需要的许可证后，您将收到一个 .LIC 许可证密钥。 许可证密钥应安装在：
  • 运行 Citrix 许可证服务器软件的 Windows Server，或者
  • 基于 Linux 的 Citrix 许可证服务器虚拟设备
如果为 XenServer 主机分配了许可证，XenServer 会联系指定的 Citrix 许可证服务器，并为指定的服务器请求许可证。 如果成功，则将签出一个许可证，并且 XenCenter 许可证管理器将显示与许可使用主机时所依据的 XenServer 版本有关的信息。
重要: Citrix XenServer 6.5 许可需要 Citrix 许可证服务器 11.12.1 或更高版本。

各个 XenServer 版本的许可

必须许可池中的所有主机。 如果运行的 XenServer 池中包含获得不同 XenServer 版本许可的主机，获得最低版本许可的主机将决定对池中的所有成员可用的主机。 已许可主机和未许可主机的混合池将被当做是所有主机都未获许可。 有关在 XenServer 6.5 中管理许可证的信息，请参阅在 XenServer 6.5 中管理许可证。

许可证过期

XenCenter 在您的许可证即将过期时向您发出通知。 您应在其过期之前购买许可证。 XenServer 许可证过期时：

  • XenCenter 许可证管理器将显示状态为未获许可。
  • 在购买另一个许可证之前，您无法再访问许可的功能，也无法再接收 Citrix 向池中的任何主机提供的技术支持。

许可证宽限期

Citrix Licensing 内置了超时技术。 XenServer 主机签出启动许可证后，XenServer 和许可证服务器将每五分钟交换一次“检测信号”消息，以相互表明自身仍正常运行。 例如，如果 XenServer 主机由于许可证服务器硬件、软件或网络故障无法联系许可证服务器，服务器将进入为期 30 天的许可宽限期。 宽限期期间，XenServer 将通过缓存的信息对自身进行许可，并且允许主机继续运行，就像仍与许可证服务器通信一样。 宽限期为 30 天，宽限期到期后，XenServer 将还原到未获许可状态。 XenServer 与许可证服务器之间重新建立通信后，宽限期将重置。

注: 要产生宽限期，XenServer 与许可证服务器必须至少曾经成功通信一次。


在 XenServer 6.5 中管理许可证

本主题包含有关在 XenServer 6.5 中管理许可证的信息。

必须许可池中的所有主机。 可以使用 XenCenter 中的许可证管理器对话框管理 XenServer 许可证。 许可证管理器允许您：
  • 将 XenServer 许可证分配到托管服务器。 分配许可证时，XenServer 会联系 Citrix 许可证服务器，并请求指定类型的许可证。 如果有可用许可证，则会将该许可证从许可证服务器中签出。
  • 释放 XenServer 许可证。 释放许可证时，XenServer 会联系 Citrix 许可证服务器，并将许可证签入服务器。
重要: Citrix XenServer 6.5 许可需要 Citrix 许可证服务器 v11.12.1 或更高版本。 可以从 Citrix Licensing 页面下载许可证服务器。

分配 XenServer 许可证

  1. 在工具菜单中，单击许可证管理器。
  2. 选择要分配许可证的的主机或池，然后单击分配许可证。
  3. 在应用许可证对话框中，选择要从许可证服务器中申请的许可证版本。 有关不同 XenServer 版本的详细信息，请参阅许可概述 (XenServer 6.5)。
  4. 输入许可证服务器详细信息，然后单击确定。
    注: 默认情况下，许可证服务器使用端口 27000 与 Citrix 产品进行通信。 如果更改了许可证服务器上的默认端口，请在端口号框中输入合适的端口号。 有关因冲突而更改端口号的详细信息，请参阅 Citrix eDocs 中的许可使用本产品主题。

XenCenter 将联系指定的 Citrix 许可证服务器，并为指定服务器请求许可证。 如果成功，则将签出一个许可证，并更新在 XenCenter 许可证管理器中显示的信息。 如果无法联系上许可证服务器，服务器将进入 30 天的许可宽限期。

注: 申请或应用许可证时，有关 XenServer 版本和许可证类型的信息可能会传送到 Citrix。 Citrix 不会收集或接收与任何系统用户、环境中运行的虚拟机或 XenServer 部署环境相关的任何其他信息。 请求许可过程中传送到 Citrix 的有限信息将依照 Citrix 隐私政策进行处理，您可以在 http://www.citrix.com/privacy 查看该隐私政策的副本。

释放 XenServer 许可证

  1. 在工具菜单中，单击许可证管理器。
  2. 选择主机或池，然后单击释放许可证。


许可概述 (XenServer v6.2.0)

安装 XenServer 时，将在未许可的状态中启动程序。 如果未获许可，其功能将不受任何限制，但使用 XenCenter 的修补程序的应用程序例外。 要获取 Citrix 技术支持，必须许可使用 XenServer 主机。

XenServer 主机按填充的插槽数进行许可，池中的所有主机都必须处于已许可的状态。 已许可主机和未许可主机的混合池将被当做是所有主机都未获许可。 有关在 XenServer v6.2.0 中管理许可证的详细信息，请参阅管理 XenServer v6.2.0 中的许可证。

各个 XenServer 版本的许可

XenServer 使用与其他 Citrix 产品相同的许可过程。 XenServer 需要许可证服务器。 购买 XenServer 支持后，您将拥有 .LIC 许可证密钥。 许可证密钥应安装在：
  • 运行 Citrix 许可证服务器软件的 Windows Server，或者
  • 基于 Linux 的 Citrix 许可证服务器虚拟设备
重要: XenServer 按插槽数 6.2 版需要使用 Citrix License Server 11.6.1 或更高版本。

许可证过期

XenServer 按插槽数许可证版本过期时：

  • 该版本将还原为完整功能但未许可的 XenServer
  • XenCenter 将其显示为 Citrix XenServer Per-Socket Edition Expired（Citrix XenServer 按插槽数版本已过期）
  • 将无法使用 XenCenter 应用修补程序或其他更新
  • 您将无法再获得此主机或池的 Citrix 技术支持，除非您再购买一份许可证

许可证宽限期

Citrix V6 Licensing 内置了超时技术。 如果 XenServer 主机无法连接许可证服务器（例如，由于许可证服务器硬件或软件出现故障，或者网络出现故障），则会有 30 天宽限期，允许 XenServer 主机继续运行，就像仍在与许可证服务器通信一样。 XenServer 主机签出启动许可证后，XenServer 与许可证服务器每五分钟交换一次“检测信号”消息，以告知对方其仍处于启动及运行状态。 如果 XenServer 和许可证服务器无法发送或接收检测信号，XenServer 会进入许可宽限期，并通过缓存的信息自行完成许可授予。 30 天的宽限期过后，XenServer 会停止接受连接。 XenServer 与许可证服务器之间重新建立通信后，宽限期将重置。 要产生宽限期，XenServer 与许可证服务器必须至少曾经成功通信一次。


管理 XenServer v6.2.0 中的许可证

本主题包含有关如何管理 XenServer 6.2.0 版本的许可证的信息。

安装 XenServer 时，将在未许可的状态中启动程序。 如果未获许可，其功能将不受任何限制，也就是说，XenServer 6.2.0 中的所有可用功能都可免费使用。 但是，您将需要 Citrix XenServer 按插槽数或 Citrix XenServer for XenDesktop 许可证，以便能够：

  • 获得 Citrix 的技术支持
  • 使用 XenCenter 管理控制台应用修补程序

XenServer 主机按填充的插槽数进行许可，池中的所有主机都必须处于已许可的状态。 已许可主机和未许可主机的混合池将被当做是所有主机都未获许可。

分配 XenServer 许可证

  1. 在工具菜单中，单击许可证管理器。
  2. 选择要分配许可证的的主机或池，然后单击分配许可证。
  3. 在应用许可证对话框中，选择要从许可证服务器申请的许可证的类型：
    • Citrix XenServer 按插槽数：选择此选项可激活按填充插槽数的许可模式。 此许可证类型适用于 XenServer 6.2.0 版。
    • Citrix XenServer for XenDesktop：选择该选项可以从许可证服务器请求现有的 Citrix XenServer for XenDesktop 许可证。
  4. 输入许可证服务器详细信息，然后单击确定。
    注: 默认情况下，许可证服务器使用端口 27000 与 Citrix 产品进行通信。 如果更改了许可证服务器上的默认端口，请在端口号框中输入合适的端口号。 有关因冲突而更改端口号的详细信息，请参阅 Citrix eDocs 中的许可使用本产品主题。

XenCenter 将联系指定的 Citrix V6 许可证服务器，并为指定服务器请求许可证。 如果成功，将签出一个许可证，并更新在 XenCenter 许可证管理器中显示的信息。 如果无法联系上许可证服务器，服务器将进入 30 天的许可宽限期。

注: 申请或应用许可证时，有关 XenServer 版本和许可证类型的信息可能会传送到 Citrix。 Citrix 不会收集或接收与任何系统用户、环境中运行的虚拟机或 XenServer 部署环境相关的任何其他信息。 请求许可过程中传送到 Citrix 的有限信息将依照 Citrix 隐私政策进行处理，您可以在 http://www.citrix.com/privacy 查看该隐私政策的副本。

从免费版升级到 XenServer 6.2.0

从免费版升级到 XenServer 6.2.0 版本的主机或池后，您虽未获得 XenServer 的许可证，但可使用其完整功能。 但是，XenCenter 的状态将显示为不受支持，即无法使用 XenCenter 应用修补程序或其他更新。 如果您选择购买许可证，在为主机或池分配新许可证之后，其状态将显示为已许可，许可证类型将显示为 Citrix XenServer 按插槽数版本。

从高级版、企业版或铂金版升级到 XenServer 6.2.0

从付费版升级到 XenServer 6.2.0 版本的主机或池后，您虽未获得 XenServer 的许可证，但可使用其完整功能。 但是，XenCenter 的状态将显示为不受支持，即无法使用 XenCenter 应用修补程序或更新。 在这些情况下，您将需要：

  1. 将您现有按主机数的许可证更换为按插槽数的许可证
  2. 将新的许可证文件添加到许可证服务器上
  3. 将许可证应用到 XenServer 主机或池

应用许可证后，您的主机或池将显示为已许可，许可证类型将显示为 Citrix XenServer 按插槽数版本。

释放 XenServer 许可证

  1. 在工具菜单中，单击许可证管理器。
  2. 选择主机或池，然后单击释放许可证。


许可概述（XenServer v6.1.0 及更早版本）

注: 如果您运行的是 XenServer 6.2.0 版本，请参阅许可概述 (XenServer v6.2.0)。

Citrix XenServer 免费版包含创建虚拟基础结构所需的所有功能，可以免费使用。 XenServer 免费版可以免费用在生产环境中，没有任何约束条件或时间限制；您只需在首次安装后的 30 天内激活产品，向 Citrix 登记您使用该产品的意图。 激活是一个简单的过程，仅需几分钟时间。 有关激活 XenServer 免费版的信息，请参阅激活免费 XenServer 产品。

三个付费 XenServer 版本 — 高级版、企业版和铂金版 — 提供了一套管理和自动化功能，对免费 Citrix XenServer 平台的功能进行了扩展。 有关不同版本 XenServer 中可用功能的更多信息，请单击此处。

Citrix Licensing

本产品的所有付费版本都采用 Citrix 集中许可的方式，而且与其他 Citrix 组件一样，必须使用 Citrix 许可证服务器分配许可证。 所有 XenServer 版本的许可证都必须安装在单独的一台 Citrix Licensing 服务器上，并使用 Citrix 许可证管理控制台进行维护和控制。 通过这种方法，XenServer 可以和其他 Citrix 产品共享相同的许可模式，并且可以在其他 Citrix 产品之间共享该许可服务器。 有关如何安装及运行 Citrix Licensing 的详细信息，请查看 Citrix eDocs Web 站点上的在线文档。

有关管理许可证的信息，请参阅管理 XenServer 6.1.0 及更早版本的许可证。

许可证宽限期

Citrix V6 Licensing 内置了超时技术。 如果 XenServer 主机无法连接许可证服务器（例如，由于许可证服务器硬件或软件出现故障，或者网络出现故障），则会有 30 天宽限期，允许 XenServer 主机继续运行，就像仍在与许可证服务器通信一样。 XenServer 主机签出启动许可证后，XenServer 与许可证服务器每五分钟交换一次“检测信号”消息，以告知对方其仍处于启动及运行状态。 如果 XenServer 和许可证服务器无法发送或接收检测信号，XenServer 会进入许可宽限期，并通过缓存的信息自行完成许可授予。 30 天的宽限期过后，XenServer 会停止接受连接。 XenServer 与许可证服务器之间重新建立通信后，宽限期将重置。 要产生宽限期，XenServer 与许可证服务器必须至少曾经成功通信一次。

隐私声明

激活免费 XenServer 产品或者申请/应用付费版本的许可证时，有关 XenServer 服务器版本和许可证类型的信息可能会传送到 Citrix。 Citrix 不会收集或接收与任何系统用户、环境中运行的虚拟机或 XenServer 部署环境相关的任何其他信息。 请求许可过程中传送到 Citrix 的有限信息将依照 Citrix 隐私政策进行处理，您可以在 http://www.citrix.com/privacy 查看该隐私政策的副本。


管理 XenServer 6.1.0 及更早版本的许可证

XenServer 高级版、企业版和铂金版与其他 Citrix 产品共享相同的许可模式，每个主机服务器需要的许可证将安装在单独的 Citrix Licensing 服务器上。 有关如何安装和运行 Citrix Licensing 的详细信息，请参阅 Citrix eDocs 中的许可使用本产品。

可以使用 XenCenter 的许可证管理器管理 XenServer 高级版、企业版和铂金版：在工具菜单中，单击许可证管理器。 通过许可证管理器，您可以：

  • 将 XenServer 许可证 分配到托管服务器。 分配许可证时，XenCenter 会联系 Citrix 许可证服务器，并请求指定类型的许可证。 如果有可用许可证，则会将该许可证从许可证服务器中签出。
  • 释放 XenServer 许可证。 释放许可证时，XenCenter 会联系 Citrix 许可证服务器，并将许可证签入服务器。

XenServer 资源池中的每个主机服务器必须分别进行许可。 例如，如果在一个资源池中支持四个 XenServer 主机，则必须为其中的每一个主机分配一个许可证。 尽管可以在同一池中混合不同版本的 XenServer 主机，但是务必注意，许可证级别最低的主机决定了池中所有成员可用的功能。 例如，在高级版和铂金版主机混合而成的池中，将只启用高级版主机的功能。 因此，如果将某个主机更改为使用级别更低的许可证，可以有效地在池中禁用某些功能。

分配 XenServer 许可证

  1. 打开许可证管理器：在工具菜单上，单击许可证管理器。
  2. 选择一个或多个服务器，然后单击分配许可证。
  3. 在分配许可证对话框中，选择要从许可证服务器申请的许可证的类型：
    • Citrix XenServer 高级版：这种许可证可以激活 XenCenter 内的特定管理功能，包括高可用性、VM 保护和恢复 (VMPR)、动态内存控制、实时警报和有关 VM 性能的历史报告。
    • Citrix XenServer 企业版：这种许可证在高级版功能的基础上增加了与现有存储基础结构集成的 Workload Balancing 和 StorageLink 自动化功能。
    • Citrix XenServer 铂金版：这种许可证可激活在 XenCenter 外部进行管理的功能，如 Provisioning Services 和 Lab Management。 Lab Management 和 Stage Management 的许可证可以从 citrix.com 中我的账户随 Citrix Lab Manager 安装 ISO 一起另行下载；Lab Management 许可证可从 Lab Manager 管理控制台内应用。
    • Citrix XenServer for XenDesktop：选择该选项可以从许可证服务器请求现有的 Citrix XenServer for XenDesktop 许可证。 获得该许可证后，您可以使用 XenServer 企业版来根据需要托管桌面 VM 和所有 XenDesktop 基础结构 VM，其中包括 XenDesktop 主机和 XenApp 主机。
  4. 输入许可证服务器详细信息，然后单击确定。

XenCenter 将联系指定的 Citrix V6 许可证服务器，并为指定服务器请求许可证。 如果成功，将签出一个许可证，并更新在 XenCenter 许可证管理器中显示的信息。 如果无法联系上许可证服务器，服务器将进入 30 天的许可宽限期。

注: 激活免费 XenServer 产品或者申请/应用付费版本的许可证时，有关 XenServer 服务器版本和许可证类型的信息可能会传送到 Citrix。 Citrix 不会收集或接收与任何系统用户、环境中运行的虚拟机或 XenServer 部署环境相关的任何其他信息。 请求许可过程中传送到 Citrix 的有限信息将依照 Citrix 隐私政策进行处理，您可以在 http://www.citrix.com/privacy 查看该隐私政策的副本。

释放 XenServer 许可证

  1. 打开许可证管理器：在工具菜单上，单击许可证管理器。
  2. 选择服务器，然后单击释放许可证。


激活免费 XenServer 产品

要激活免费的 XenServer 产品，需要对主机服务器应用激活密钥（有时也称为“许可证密钥”）。 激活过程大致如下：

  1. 向 Citrix 申请激活密钥。 之后您将通过电子邮件收到激活密钥文件 license.xslic。
  2. 将激活密钥应用到要激活的免费 XenServer 产品所在的服务器。

要应用激活密钥，只需在 Windows 资源管理器中双击密钥文件，然后选择要应用密钥文件的服务器即可，或者也可以在 XenCenter 中使用许可证管理器来应用密钥。

注: 激活免费 XenServer 产品时，有关 XenServer 服务器版本和许可证类型的信息可能会传送到 Citrix。 Citrix 不会收集或接收与任何系统用户、环境中运行的虚拟机或 XenServer 部署环境相关的任何其他信息。 请求许可过程中传送到 Citrix 的有限信息将依照 Citrix 隐私政策进行处理，您可以在 http://www.citrix.com/privacy 查看该隐私政策的副本。

申请激活密钥

  1. 打开许可证管理器：在工具菜单上，单击许可证管理器。
  2. 选择一个或多个运行免费 XenServer 产品的服务器，单击激活免费版 XenServer，然后单击申请激活密钥。

    此时将打开一个 Web 浏览器，并进入 Citrix XenServer 激活 Web 页面，其中记录了所选服务器的详细激活信息，您需要在此页面中填写联系信息和电子邮件地址。

    如果 XenCenter 无法连接到 XenServer 激活服务器，系统将询问您是否要将所选主机服务器的详细激活信息保存到文件中。 如果选择保存，您可以在以后恢复 Internet 连接时，将该文件导入 XenServer 激活服务器中。

填写激活表单后，您将通过电子邮件收到每个免费 XenServer 产品的激活密钥。 例如：

然后您需要将相应的密钥文件应用到每个 XenServer 主机，以激活这些主机。

在 XenCenter 中应用激活密钥

开始操作前，确保可以从运行 XenCenter 的计算机访问激活密钥文件，并且已将相关服务器连接（添加）到托管资源集中。

  1. 打开许可证管理器：在工具菜单上，单击许可证管理器。
  2. 选择运行免费 XenServer 产品的服务器，单击激活免费版 XenServer，然后单击应用激活密钥。
  3. 找到激活密钥文件 (license.xslic)，然后单击打开。

通过密钥文件应用激活密钥

  1. 在 Windows 资源管理器中找到激活密钥文件 (license.xslic)，然后双击该文件。
  2. 在应用激活密钥对话框中，选择要激活的免费 XenServer 产品所在的服务器，然后单击应用。


获取帮助

可以在多个不同位置查找所需要的关于使用 XenServer 的信息：

  • XenServer 产品文档。 面向 XenServer 管理员和开发人员的综合参考文档：在 XenServer 产品 CD 中以 PDF 格式提供，并且通过 Citrix 知识中心的 XenServer 部分在线提供。
  • Citrix 知识中心。 如果已连接到 Internet，可以在线浏览或搜索知识库文章和技术说明，以及最新的 XenServer 产品文档。 有关详细信息，请参阅 Citrix 知识中心。
  • XenCenter 联机帮助。 XenCenter 包含上下文相关的帮助系统，可以根据您在应用程序中所处的位置以及尝试执行的操作提供相应帮助。
主题


帮助窗口

XenCenter 帮助显示在 HTML 帮助窗口中：

  • 窗口左侧是一个导航窗格，其中包含目录、搜索和收藏夹选项卡。
  • 窗口右侧是主题窗格。 该窗格显示选定的帮助主题或默认帮助主题。
  • 顶部是工具栏。

使用帮助工具栏

隐藏导航窗格，仅显示主题窗格，以节省屏幕空间。
显示导航窗格。 只有当先前使用了隐藏功能时，此按钮才可用。
显示上次查看的主题。
显示下一个主题（如果先前使用了后退功能）。
打印主题。

使用“目录”选项卡

单击目录选项卡可列出帮助主题：

文件夹图标用于启动一个新的主题。 如果文件夹处于折叠状态，单击加号可将其展开以列出其中的各个主题，单击减号可将其再次折叠。

主题图标代表单个帮助主题。 单击主题图标或其标题可将该主题显示在主题窗格中。

当前在主题窗格中查看的主题会在目录中突出显示。 转到其他主题时，目录将根据需要展开，以指示您在帮助系统中所处的位置。

使用“搜索”选项卡

可以在帮助系统的所有文本内容中搜索单词或短语。 可以在先前的结果中进行搜索、匹配相似的单词或仅搜索主题标题。 有关详细信息，请参阅搜索帮助。

使用“收藏夹”选项卡

  • 要创建收藏帮助主题列表，请找到要作为收藏主题的帮助主题，单击收藏夹选项卡，然后单击添加。
  • 要返回到收藏主题，单击收藏夹选项卡，选择主题，然后单击显示。
  • 要重命名收藏主题，请在列表中的该主题上单击鼠标右键，在快捷菜单中单击重命名，然后为收藏项键入新名称。
  • 要删除收藏主题，请选择该主题，然后单击删除。


搜索帮助

可以在帮助系统的所有文本内容中搜索单词或短语。 可以在先前的结果中进行搜索、匹配相似的单词或仅搜索主题标题。

  1. 单击搜索选项卡，然后键入要查找的单词或短语。
  2. 要仅在主题标题中进行搜索，请选中只搜索标题复选框。 将搜索所有主题文件，包括目录中未列出的任何主题文件。
  3. 要仅在最近找到的主题组中搜索，请选中搜索以前的结果复选框。 要在帮助系统的所有文件中进行搜索，请清除该复选框。
  4. 单击列出主题，然后双击所需主题，或选择主题并单击显示。

提示

  • 搜索不区分大小写，因此可以使用大写或小写字符键入搜索内容。
  • 可以搜索任意字母 (a-z) 和数字 (0-9) 的组合。
  • 搜索过程中将忽略除了双引号之外的标点符号，如句点、冒号、分号、逗号和连字符。
  • 使用双引号可搜索短语。 例如，“服务器 root 用户密码”将查找包含短语服务器 root 用户密码的主题，而服务器 root 用户密码查找包含单词服务器、root 用户和密码的主题，但不要求这些词连成一个短语。
  • 使用通配符表达式可搜索一个或更多个字符：使用星号搜索零个或更多个字符，使用问号搜索单个字符。


打印帮助主题

打印当前主题

  1. 展开所有部分：选中主题顶部的显示所有文字复选框，或单击主题并按 Alt+X。
  2. 在主题窗格中单击鼠标右键，然后在快捷菜单中单击打印。 或者，在工具栏中单击打印，单击打印选择的主题，然后单击确定。
  3. 在打印对话框中，设置所需的打印机选项，然后单击打印。

可以选择打印“目录”选项卡中显示的一组主题。 但请注意以下几点：

  • 打印主题时所有部分都会展开。
  • 所打印主题的格式与屏幕上显示的格式在外观上不完全相同。
  • 图像的打印位置可能不正确，会遮盖邻近的文字。

打印一组主题

  1. 在“目录”选项卡中，在包含待打印主题的手册上单击鼠标右键，然后在快捷菜单中单击打印，或在工具栏上单击打印。
  2. 单击打印选择的标题和所有副标题，然后单击确定。
  3. 在打印对话框中，设置所需的打印机选项，然后单击打印。


管理服务器

连接和断开连接
  • 添加新服务器
  • 断开服务器连接
  • 重新连接服务器
  • 重新启动服务器
  • 关闭服务器
  • 重新启动 Toolstack
  • 配置主机开机
  • 远程开启服务器
  • 在维护模式下运行
  • 导出和导入托管服务器列表
  • 更改服务器属性
  • 存储服务器连接状态
  • 备份和还原服务器
  • 从 XenCenter 删除服务器
配置网络连接
  • 关于 XenServer 网络
  • 添加新网络
  • 删除网络
  • 查看和更改网络属性
  • 配置 NICs
  • 配置 IP 地址


连接服务器和断开服务器连接

  • 添加新服务器
  • 断开服务器连接
  • 重新连接服务器
  • 重新启动服务器
  • 关闭服务器
  • 重新启动 Toolstack
  • 配置主机开机
  • 远程开启服务器
  • 在维护模式下运行
  • 存储服务器连接状态


添加新服务器

为了从 XenCenter 监视和管理服务器上的活动，首先需将其标识为托管”资源。 首次连接服务器时（通过工具栏上的添加新服务器或服务器菜单），该服务器会添加到 XenCenter 窗口左侧的资源窗格中。 该服务器的默认存储库（如果配置）及其任何物理 CD 或 DVD 驱动器也可能会显示在此窗格中。 之后可以将托管服务器断开连接、重新连接、关闭或置于维护模式，在从 XenCenter 删除该服务器前，始终可从资源窗格对其进行访问。

首次使用 XenCenter 连接服务器时，将显示保存和还原连接状态对话框。 在此对话框中，可以设置相关首选项，以存储服务器连接信息并在每个 XenCenter 会话启动时自动还原服务器连接；请参阅存储服务器连接状态。

向 XenCenter 中添加服务器

  1. 单击添加新服务器。 或者：
    • 在服务器菜单中，单击添加。
    • 在资源窗格中，选择最顶层的 XenCenter 条目，单击鼠标右键，然后在快捷菜单中单击添加。
    • 在 XenCenter 主页上，单击添加新服务器按钮：
  2. 在服务器框中，输入要添加的服务器的 IP 地址或 DNS 名称。 例如：182.31.32.28 或 belt.orion.com。
    提示: 通过在服务器框中输入用分号分隔的名称或 IP 地址，可以添加具有相同登录凭据的多个服务器。
  3. 键入在 XenServer 安装期间设置的用户名（例如 root）和密码。 如果在 XenServer 环境中启用了 Active Directory (AD) 授权，可以在此处输入 AD 凭据。 有关详细信息，请参阅RBAC 概述。
  4. 单击添加。将显示连接进度监视器：要取消连接，请单击取消。

安全证书

可以将 XenCenter 配置为每当连接托管服务器时发现新的或修改的 SSL（安全套接字层）安全证书，就显示一条警告消息。 单击查看证书可查看安全证书。 要阻止生成 SSL 证书警告，可使用 XenCenter 选项对话框中的安全设置选项卡。


断开服务器连接

断开连接的服务器仍然是托管服务器，且在“资源”窗格中仍然可用，其状态图标为：

您可以快速查看当前断开连接的服务器，方法是：在“导航”窗格中切换到对象视图，然后单击已断开连接的服务器。

  • 要断开服务器连接，在资源窗格中选择该服务器，然后在服务器菜单中单击连接/断开连接，然后单击断开连接。 您可以随时重新连接到已断开连接的服务器。 有关详细信息，请参阅重新连接服务器。
  • 要从资源窗格中删除断开连接的服务器，请参阅从 XenCenter 删除服务器。


重新连接服务器

在 XenCenter 中添加服务器后，无论该服务器的状态如何（连接或断开，正常运行或处于维护模式），在整个当前 XenCenter 会话中都可以通过资源窗格访问该服务器。

要重新连接断开的托管服务器，只需在资源窗格中双击该服务器，或者单击鼠标右键，然后在快捷菜单中单击连接。 在当前 XenCenter 会话期间，系统将记住服务器连接信息，因此如果要使用同一个用户帐户重新连接，无需在同一个 XenCenter 会话中多次输入相同的登录凭据。

也可以使用不同的登录凭据（例如使用 AD 登录凭据而非本地根帐户）重新连接已连接的服务器。

使用不同的登录凭据重新连接已连接的服务器

  1. 在资源窗格中选择服务器。
  2. 在服务器菜单上，单击连接/断开连接然后选择重新连接身份。 或者执行以下操作之一：
    • 在资源窗格中单击鼠标右键，并在快捷菜单中选择重新连接身份。
    • 在服务器菜单上，单击连接/断开连接然后选择重新连接身份。
  3. 输入新的用户名和密码。 如果在 XenServer 环境中启用了 Active Directory 授权，可以在此处输入 AD 凭据。 请参阅 RBAC 概述。
  4. 单击确定。


重新启动服务器

在 XenCenter 中重新启动服务器时，将首先关闭所有在其中运行的虚拟机 (VM)，随后将该服务器断开连接并重新启动。 如果服务器是某个池的成员，在服务器重新启动时，将处理关机时断开的连接，池也将恢复。 如果关闭另一个池成员（非主服务器），其他池成员和主服务器将继续发挥作用。 如果关闭主服务器，池将无法正常工作，直到主服务器重新启动并恢复联机状态（此时其他成员将重新连接并与主服务器同步），或者直到使其他某个成员成为主服务器（可以通过 XenServer xe 命令行接口 (CLI) 来实现）。

请注意，安装了 XenServer Tools 的 VM（“半虚拟化”VM）将在您重新启动主机服务器时正常关闭，但在 HVM 模式下运行的 VM（即未安装 XenServer Tools 的 VM）将通过强制关机进行关闭；为避免出现此情况，应在所有 HVM 虚拟机上 安装 XenServer Tools。

服务器重新启动后，XenCenter 将自动尝试重新连接该服务器。 重新连接服务器后，您需要重新启动之前在该服务器中运行的任何 VM，除非这些 VM 配置为在主机服务器重新启动时自动启动（请参阅更改 VM 属性）。

重新启动服务器

请在“资源”窗格中选择服务器，然后在工具栏上单击重新启动。


关闭服务器

在 XenCenter 中关闭服务器时，将首先关闭在其中运行的所有虚拟机 (VM)，随后将该服务器断开连接并关闭。 如果服务器是某个池的成员，在服务器重新启动时，将处理关机时断开的连接，池也将恢复。 如果关闭另一个池成员（非主服务器），其他池成员和主服务器将继续发挥作用。 如果关闭主服务器，池将无法正常工作，直到主服务器重新启动并恢复联机状态（此时其他成员将重新连接并与主服务器同步），或者直到使其他某个成员成为主服务器（可以通过 XenServer xe 命令行接口 (CLI) 来实现）。

请注意，安装了 XenServer Tools 的 VM（“半虚拟化”VM）将正常关闭，但在 HVM 模式下运行的 VM（即未安装 XenServer Tools 的 VM）将通过强制关机进行关闭；为避免出现此情况，应在所有 HVM 虚拟机上安装 XenServer Tools。

重新启动服务器后，需要再次与之连接。请参阅重新连接服务器。

关闭服务器

在“资源”窗格中选择服务器，然后在工具栏上单击关闭。

服务器关闭后，其状态在资源窗格中变为已断开连接 [image] 。


重新启动 Toolstack

通过重新启动 Toolstack 选项，您可以重新启动 XenServer Management Toolstack（也称为 xapi）。 该 toolstack 可控制 VM 生命周期操作、主机和 VM 网络连接、VM 存储、用户身份验证，并允许管理 XenServer 资源池。xapi 提供公开记录的 XenAPI 管理接口，以供管理 VM 和资源池的所有工具使用。

注: 在某些情况下，重新启动 Toolstack 选项可以用于对 XenServer 问题进行故障排除。 但是，客户在使用此选项时应极其小心，因为错误的用法可能会导致意外的结果。

重新启动 Toolstack

  1. 在“资源”窗格中选择服务器。
  2. 在“服务器”菜单中，单击重新启动 Toolstack。
  3. 单击是确认。
注: 在池主服务器上运行重新启动 Toolstack 选项时，XenCenter 将失去与池的连接。 失去连接后等待 30 秒，然后手动重新连接。


配置主机开机

通过 XenServer 主机开机功能，您可以手动开启或关闭远程主机（服务器）。 要使用该功能，需要执行以下步骤：

  1. 确保主机支持远程电源控制（即，主机具有局域网唤醒功能、DRAC 或 iLO 卡，或使用自定义脚本）。 请参阅主机开机功能必备条件。
  2. 按照启用或禁用主机开机功能所述启用主机开机功能。 要对 iLO 和 DRAC 处理器执行此过程，需要使用在处理器固件中设置的处理器凭据。

对服务器配置主机开机功能后，就可以从 XenCenter 开启该服务器，方法是选择该服务器，然后在“服务器”菜单中单击“开机”。

如果安装并配置了 Workload Balancing，还可以将 XenServer 配置为在 VM 合并或恢复联机后自动开启或关闭主机。 这一功能称为“电源管理”。

主机开机功能必备条件

要启用主机开机功能，主机服务器必须具有以下电源控制解决方案之一：

  • 支持 局域网唤醒(WOL) 的网卡。
  • Dell Remote Access Controller (DRAC)。 要将 XenServer 与 DRAC 结合使用，需要遵循以下步骤：
    1. 安装 Dell 补充软件包。
    2. 在装有远程访问控制器的主机服务器上安装 RACADM 命令行实用程序。
    3. 启用 DRAC 及其接口。 RACADM 通常包含在 DRAC 管理软件中。 有关详细信息，请参阅 Dell 的 DRAC 文档。
  • Hewlett-Packard Integrated Lights-Out (iLO)。 要将 XenServer 与 iLO 结合使用，必须在主机上启用 iLO 并将其连接到网络。 有关详细信息，请参阅 HP 的 iLO 文档。
  • 基于 Xen-API 的自定义开机脚本，允许通过 XenServer 开关机。 对于 DRAC 和 iLO，可以使用加密功能（通过指定密钥 power_on_password_secret）帮助您更安全地存储密码。 有关详细信息，请参阅《XenServer 管理员指南》。

启用或禁用主机开机功能

可以通过主机的属性窗口对单个主机服务器启用主机开机功能，或者通过池的属性窗口对多个服务器启用主机开机功能。

  1. 选择服务器或池，并打开其属性对话框：在服务器或池菜单上，单击属性。
  2. 单击开机选项卡，在开机模式下，选择所需选项：
    已禁用 | 选择该选项可关闭主机开机功能。
    局域网唤醒(WoL) | 要使用此选项，主机必须配备支持局域网唤醒功能的网卡。
    HP Integrated Light-Out (iLO) | 要使用此选项，必须在主机上启用 iLO 并将其连接到网络。 有关详细信息，请参阅 HP 的 iLO 文档。
    Dell Remote Access Controller (DRAC) | 要使用此选项，主机服务器上必须安装有 Dell 补充软件包以获得 DRAC 支持。 有关详细信息，请参阅 Dell 的 DRAC 文档。
    自定义开机脚本 | 可以使用自定义 Python Linux 脚本从远程位置开启 XenServer 主机的电源。 有关创建脚本（包括受支持键/值对的列表）的信息，请参阅《XenServer 管理员指南》。
  3. 如果选择了 HP iLO 或 Dell DRAC，请输入以下信息：
    IP 地址 | 您指定用来与电源控制卡通信的 IP 地址。 或者，您可以输入配置 iLO 或 DRAC 的网络接口的域名。
    用户名 | 此键为与管理处理器相关联的 iLO 或 DRAC 用户名，您可能已更改其出厂时的默认设置，也可能未更改。
    密码 | 与用户名相关联的密码。
  4. 如果选择了自定义开机脚本，请输入所创建的自定义脚本的文件名和路径，然后在配置选项下，输入要用来配置脚本的键/值对。 通过单击或使用 Tab 键可在字段间移动。

    指定自定义脚本的文件名时，无需指定 .py 扩展名。

  5. 单击确定，以保存配置更改并关闭属性窗口。

完成配置后，可以配置并运行 Workload Balancing 自动化和主机开机功能。


远程开启服务器

通过“主机开机”功能，您可以从 XenCenter 远程开启托管服务器。 要使用该功能，服务器必须支持远程电源控制（LAN 唤醒功能、DRAC 或 iLO 卡或者自定义开机脚本），并且必须在每个服务器的属性中都启用了主机开机功能（可以在池级别一次为多个服务器同时启用该功能）。

有关设置和启用此功能所需操作的信息，请参阅配置主机开机。

配置了主机开机功能后，选择服务器，然后执行以下操作之一：

  1. 在服务器菜单上，单击开机。
  2. 单击鼠标右键并选择开机。


在维护模式下运行

您可能出于多种原因而需要将托管服务器脱机，例如滚动升级虚拟化软件、添加或测试与新网络的连接、诊断基础硬件问题或添加与新存储系统的连接。 在 XenCenter 中，可以通过将服务器置于维护模式使其暂时脱机。 如果服务器位于资源池中，则将其置于维护模式时，所有运行的 VM 将自动从该服务器迁移到同一池中的其他服务器。 如果该服务器是池主服务器，还将为池选择一个新的主服务器。

启用 Workload Balancing 后，该服务器上运行的虚拟机将根据 Workload Balancing 建议（性能数据、放置策略和性能阈值），自动迁移到其最优服务器上（如果可用）。

当服务器处于维护模式时，您无法在该服务器上创建或启动任何 VM。

将服务器置于维护模式

  1. 在资源窗格中选择服务器，然后执行以下操作之一：
    • 单击鼠标右键，在快捷菜单中单击进入维护模式。
    • 在服务器菜单中，单击进入维护模式。
  2. 单击进入维护模式。
如果所有正在运行的 VM 都已成功迁移出该服务器，则在“资源”窗格中，该服务器的状态变为 [image] 。

使服务器退出维护模式

  1. 在资源窗格中选择服务器，然后执行以下操作之一：
    • 单击鼠标右键，在快捷菜单中单击退出维护模式。
    • 在“服务器”菜单中，单击退出维护模式。
  2. 单击退出维护模式。


存储服务器连接状态

可以在 XenCenter 会话之间存储所有托管服务器的登录凭据（用户名和密码），并在启动每个新 XenCenter 会话时使用凭据自动重新连接这些服务器。 启用该功能后，XenCenter 将在每个会话结束时记住所有托管服务器的连接状态，并尝试在下一个会话启动时还原连接状态。 如果在上一个会话结束时与某个服务器处于连接状态，将自动与该服务器重新连接，而不会提示您输入详细的服务器登录信息；如果在上一会话结束时与某个服务器断开连接，则不会自动重新连接该服务器。

如果选择关闭自动重新连接功能，则每次打开 XenCenter 时都需要为每个托管服务器输入用户名和密码来重新连接这些服务器。

注: 系统管理员可能会禁用服务器登录凭据的保存功能，因此该功能可能不可用。

您可以选择利用主密码来保护存储的登录凭据，以确保这些凭据的安全；在启动每个会话时，系统将在还原与托管服务器的连接之前，提示您输入此主密码。

打开或关闭自动重新连接功能

  1. 打开 XenCenter 选项对话框：在工具菜单上，单击选项。
  2. 单击保存和还原选项卡，然后选中或清除保存并在启动时还原服务器连接状态复选框。

使用主密码

如果选择在 XenCenter 中存储服务器登录凭据，还可以设置一个主密码；在自动还原与托管服务器的连接之前，必须输入此密码。 您可以在 XenCenter 选项对话框的保存和还原选项卡中设置、删除和更改主密码。

请注意，如果丢失或忘记主密码，将无法恢复。 如果出现这种情况，需要再次连接每个托管服务器，然后设置新的主密码。

设置主密码：

  1. 打开 XenCenter 选项对话框：在工具菜单上，单击选项。
  2. 单击保存和还原选项卡。
  3. 确保选中保存并在启动时还原服务器连接状态复选框。
  4. 在主密码下，选中需要主密码复选框，然后输入密码并确认，单击确定。 请记住，密码区分大小写。

更改主密码：

  1. 打开 XenCenter 选项对话框：在工具菜单上，单击选项。
  2. 单击保存和还原选项卡。
  3. 在主密码下，单击更改主密码。
  4. 输入现有主密码，然后输入新的主密码并确认，单击确定。

清除主密码：

  1. 打开 XenCenter 选项对话框：在工具菜单上，单击选项。
  2. 单击保存和还原选项卡。
  3. 在主密码下，清除需要主密码复选框。
  4. 如果提示输入密码，输入当前主密码并确认，然后单击确定。


备份和还原服务器

可以将托管服务器备份到 XenServer 备份文件 (.xbk) 中，当出现硬件故障时，可以使用该文件还原服务器。 请注意，这种方法只备份服务器本身，而不会备份可能在该服务器上运行的任何 VM。

建议您经常备份服务器，以便能够从可能发生的服务器和/或软件故障进行恢复。 在 XenCenter 中备份服务器时，应注意以下几点：

  • 不应在 XenServer 控制域 (dom0) 上创建备份。 有关 XenServer 控制域的详细信息，请参阅《XenServer 管理员指南》。
  • XenServer 备份文件可能非常大。

要还原服务器，可以在 XenCenter 中选择并还原备份文件，然后通过 XenServer 安装 CD 重新启动该服务器，以完成还原。

备份服务器配置和软件

  1. 在资源窗格中选择服务器，然后在“服务器”菜单中单击备份。
  2. 通过浏览找到用于保存备份文件的文件夹并输入文件名，然后单击保存开始备份。
备份过程可能需要一段时间。 依次单击通知和事件可查看进度。

通过备份还原服务器软件和配置

  1. 在资源窗格中选择服务器，然后在服务器菜单中单击从备份还原。
  2. 通过浏览找到备份文件，然后单击打开开始还原。
  3. 在主机服务器上，重新启动至主机安装 CD，然后选择 Restore from backup（从备份还原）。


从 XenCenter 删除服务器

如果从 XenCenter 中删除托管服务器，将停止对该服务器的所有管理和监视活动。 但这样做不会影响该服务器上运行的活动，也不会删除其中安装的任何 VM。 删除服务器只是断开 XenCenter 与服务器及其 VM 之间的连接，并从 XenCenter 删除其所有足迹。

要删除服务器，请在资源窗格中选择服务器，然后在服务器菜单中单击从 XenCenter 中删除。

要将删除的服务器放回托管资源列表中，需要通过首次连接该服务器时所用的方法再次将其添加到 XenCenter 中。请参阅添加新服务器。


配置网络连接

  • 关于 XenServer 网络
  • 添加新网络
  • 删除网络
  • 查看和更改网络属性
  • 配置 NICs
  • 配置 IP 地址


关于 XenServer 网络

每个托管服务器都有一个或多个网络。 XenServer 网络是虚拟的以太网交换机，它可以连接到外部接口（带或不带 VLAN 标记），或者是单个服务器或池内部完全虚拟的网络。

在物理服务器上安装 XenServer 后，系统将为该服务器上的每个物理 NIC 创建一个网络。 该网络在虚拟机上的虚拟网络接口 (VIF) 与主机服务器上网络接口卡 (NIC) 所关联的物理网络接口 (PIF) 之间起到桥接的作用。

将托管服务器移至资源池中时，这些默认网络将合并，这样，设备名称相同的所有物理 NIC 都将连接到同一个网络。 通常，只有当您希望创建内部网络、使用现有 NIC 设置新 VLAN 或创建 NIC 绑定时，才需要添加一个新网络。 您最多可以为每个托管服务器配置 16 个网络，或者最多配置 8 个绑定的网络接口。

可以使用巨型帧来优化存储流量的性能。 可以在新建网络向导中为新服务器网络设置最大传输单元 (MTU)，或者在属性窗口中为现有网络设置最大传输单元，以允许使用巨型帧。 MTU 值的允许范围为 1500 到 9216。

网络类型

在 XenCenter 内创建新网络时，有四种不同的物理（服务器）网络类型可供选择。

单服务器专用网络

这种网络类型属于内部网络，与物理网络接口没有关联，仅在指定服务器上的虚拟机之间提供连接，不与外部连接。

跨服务器专用网络

这种网络类型属于池级别的网络，在一个池中的各 VM 之间提供专用连接，但不与外部连接。 跨服务器专用网络将单服务器专用网络的隔离属性与跨资源池的功能结合在一起， 从而可以对连接跨服务器专用网络的 VM 使用 VM 的各种灵活功能（如 XenMotion 实时迁移和 Workload Balancing (WLB)）。 尽管 VLAN 也提供类似功能，但与 VLAN 不同的是，跨服务器专用网络通过使用通用路由封装 (GRE) IP 隧道协议提供隔离功能，而无需配置物理交换机结构。 要创建跨服务器专用网络，必须满足以下条件：

  • 池中的所有服务器必须使用 XenServer 5.6 Feature Pack 1 或更高版本；
  • 池中的所有服务器必须使用 OpenVSwitch 来进行网络连接；
  • 池必须配置了 vSwitch Controller，用来处理 vSwitch 连接所需的初始化和配置任务（必须在 XenCenter 外部完成）。

外部网络

这种类型的网络与物理网络接口关联，在虚拟机与外部网络之间起到桥接作用，从而使 VM 能够通过服务器的物理网络接口卡连接外部资源。

绑定网络

此类网络的构成方式是绑定两个或更多 NIC，创建一个高性能的通道，将 VM 与外部网络连接起来。 支持以下三种绑定模式：

  • 主动-主动 - 在此模式下，将在两个绑定的 NIC 之间平衡流量。 如果绑定的一个 NIC 出现故障，则主机的所有网络流量将自动通过另一个 NIC 进行路由。 此模式可以在绑定的两个物理 NIC 之间实现虚拟机流量的负载平衡。
  • 主动-被动（主动-备份）- 只有一个绑定的 NIC 处于活动状态；当且仅当活动 NIC 发生故障时，非活动 NIC 才变为活动状态，从而实现热备用功能。
  • 链路聚合控制协议 (LACP) 绑定 - 该模式提供主动-主动型绑定，将在绑定的 NIC 之间平衡流量。 与 Linux 桥接环境中的主动-主动型绑定不同，LACP 可以对所有流量类型实现负载平衡。 该模式下的两个可用选项为：
    • LACP 与基于源 MAC 地址的负载平衡功能绑定 - 在该模式下，根据发起流量的 VM 的 MAC 地址选择传出 NIC。 使用该选项可以在同一主机上有多个 VM 的环境中平衡流量。 如果 VIF 的数量少于 NIC，此选项则不适用：因为无法在 NIC 之间分割流量，所以无法实现最佳负载平衡。
    • LACP 与基于源和目标的 IP 和端口的负载平衡功能绑定 - 在这种模式下，源 IP 地址、源端口号、目标 IP 地址和目标端口号用于在 NIC 之间路由流量。 该选项非常适合在 NIC 数量超过 VIF 数量的环境中平衡 VM 的流量。 例如，只将一个虚拟机配置为使用三个 NIC 的绑定。

备注

  • 您必须将 vSwitch 配置为网络堆栈，才能查看 XenCenter 中的 LACP 绑定选项，并创建新的 LACP 绑定。 此外，交换机还必须支持 IEEE 802.3ad 标准。
  • 主动-主动和主动-被动绑定类型适用于 vSwitch 和 Linux 桥接。
  • vSwitch 作为网络堆栈时，您可以绑定两个、三个或四个 NIC，而 Linux 桥接作为网络堆栈时，您只能绑定两个 NIC。

有关 XenServer 中 NIC 绑定支持的详细信息，请参阅《XenServer 管理员指南》。


添加新网络

要在池中或独立服务器上创建新网络，请使用新建网络向导执行以下操作：在资源窗格中选择服务器或池，单击网络连接选项卡，然后单击添加网络。

添加新的外部网络

外部网络与物理网络接口卡 (NIC) 关联，在虚拟机与外部网络之间起到桥接作用，从而使 VM 可以通过 NIC 连接到外部资源。
  1. 打开新建网络向导。
  2. 在向导的第一页中，选择外部网络，然后单击下一步。
  3. 为新网络输入名称和可选的说明，然后单击下一步。
  4. 在网络设置页面上，为新网络配置 NIC、VLAN 和 MTU 设置：
    1. 从 NIC 列表中选择物理网络接口卡 (NIC)。
    2. 在 VLAN 框中，为新的虚拟网络分配编号。
    3. 要使用巨型帧，请将最大传输单位 (MTU) 设置为介于 1500 到 9216 之间的一个值。
  5. 选中自动将此网络添加到新虚拟机复选框，以将新网络添加到使用新建 VM 向导创建的任何新 VM 中。
  6. 单击完成，以创建新网络并关闭向导。

添加新的单服务器专用网络

单服务器专用网络属于内部网络，与物理网络接口没有关联，仅在指定服务器上的虚拟机之间提供连接，不连接池中其他服务器上的 VM，也不与外部连接。
  1. 打开新建网络向导。
  2. 在向导的第一页中，选择单服务器专用网络，然后单击下一步。
  3. 为新网络输入名称和可选的说明，然后单击下一步。
  4. 在网络设置页面上，选中自动将此网络添加到新虚拟机复选框，以将新网络添加到使用新建 VM 向导创建的任何新 VM 中。
  5. 单击完成，以创建新网络并关闭向导。

添加新的跨服务器专用网络

跨服务器专用网络属于池级别的网络，在池中的 VM 之间提供专用连接，但不与外部连接。 要创建跨服务器专用网络，必须满足以下条件：

  • 池中的所有服务器必须使用 XenServer 5.6 Feature Pack 1 或更高版本；
  • 池中的所有服务器必须使用 Open vSwitch 来进行网络连接；
  • 池必须配置了 vSwitch Controller，用来处理 vSwitch 连接所需的初始化和配置任务（必须在 XenCenter 外部完成）。
  1. 打开新建网络向导。
  2. 在向导的第一页中，选择跨服务器专用网络，然后单击下一步。
  3. 为新网络输入名称和可选的说明，然后单击下一步。
  4. 在网络设置页面上，从管理接口列表中选择新网络要使用的接口。
  5. 选中自动将此网络添加到新虚拟机复选框，以将新网络添加到使用新建 VM 向导创建的任何新 VM 中。
  6. 单击完成，以创建新网络并关闭向导。

添加新的绑定网络

此类网络的构成方式是将两个或更多 NIC 绑定到一起，创建一个高性能的通道，将 VM 与外部网络连接起来。

注: 如果可能，请尽量在创建初始资源池的过程中先创建 NIC 绑定，然后再将其他服务器加入池或创建 VM。 这样，在服务器加入池时，系统可以将绑定配置自动复制到其中，从而减少了所需的步骤。
  1. 打开新建网络向导。
  2. 在向导的第一页中，选择绑定网络，然后单击下一步。
  3. 在绑定成员页面上，选择要绑定到一起的 NIC。 要选择某 NIC，请在列表中选中其复选框。 在列表中最多可以选择四个 NIC。 清除复选框可取消选择 NIC。
  4. 在绑定模式下，选择绑定类型：
    • 选择主动-主动可配置主动-主动型绑定，这种绑定类型可以在绑定的 NIC 之间平衡流量，如果其中一个绑定的 NIC 出现故障，主机服务器的网络流量将自动通过另一个 NIC 进行路由。
    • 选择主动-被动可配置主动-被动型绑定，在这种绑定类型中，流量仅通过其中一个绑定的 NIC 传输。 在此模式下，仅当活动 NIC 出现故障时（例如，丢失网络连接），另一个 NIC 才会处于活动状态。
    • 选择 LACP 与基于源 MAC 地址的负载平衡功能绑定可配置 LACP 绑定，这种绑定类型根据发起流量的 VM 的 MAC 地址选择传出 NIC。 使用该选项可以在同一主机上有多个 VM 的环境中平衡流量。 如果虚拟接口 (VIF) 的数量少于 NIC，此选项则不适用：因为无法在 NIC 之间分割流量，所以无法实现最佳负载平衡。
    • 选择 LACP 与基于源和目标的 IP 和端口的负载平衡功能绑定可配置 LACP 绑定，在该模式下，源 IP 地址、源端口号、目标 IP 地址和目标端口号用于在 NIC 之间分配流量。 使用此选项可以在 NIC 数量超过 VIF 数量的环境中平衡来自 VM 的流量。
    注意：
    • 您必须将 vSwitch 配置为网络堆栈，才能查看 XenCenter 中的 LACP 绑定选项，并创建新的 LACP 绑定。 此外，交换机还必须支持 IEEE 802.3ad 标准。
    • 主动-主动和主动-被动绑定类型适用于 vSwitch 和 Linux 桥接。
    • vSwitch 作为网络堆栈时，您可以绑定两个、三个或四个 NIC，而 Linux 桥接作为网络堆栈时，您只能绑定两个 NIC。
  5. 要使用巨型帧，请将最大传输单位 (MTU) 设置为介于 1500 到 9216 之间的一个值。
  6. 选中自动将此网络添加到新虚拟机复选框，以将新网络添加到使用新建 VM 向导创建的任何新 VM 中。
  7. 单击完成，以创建新网络并关闭向导。
有关详细信息，请参阅配置 NIC。


删除网络

  1. 在资源窗格中选择服务器或池，然后单击网络连接选项卡。
  2. 在网络连接选项卡上，在列表中选择要删除的网络，然后单击删除网络。


查看和更改网络属性

查看服务器的当前网络配置

单击服务器的网络连接选项卡，以查看该服务器上当前配置的所有网络，以及有关每个网络的信息：

名称 | 网络的名称。
说明 | （可选）网络的说明。
NIC | 网络所使用的物理网络接口卡 (NIC)、NIC 绑定或内部虚拟网络。
VLAN | 对于外部网络，该列显示虚拟 LAN (VLAN) 标记。
自动 | 该列指示网络是否会自动添加到使用新建 VM 向导所创建的任何新虚拟机中。
链接状态 | 网络的链接状态：连接或断开。
MAC | 网络适配器 (NIC) 的介质访问控制地址。 这是一个特定网络适配器的唯一标识符。
MTU | 最大传输单元值介于 1500 与 9216 之间时，允许使用巨型帧。

更改服务器的网络配置

在 XenCenter 网络连接选项卡上，选择网络并单击属性。 除了名称、说明、文件夹、标记和自定义字段属性外，还可以在网络设置选项卡上更改下列网络配置设置：

选项 | 说明
绑定模式 该配置选项仅显示在绑定网络中。
  • 选择主动-主动可配置主动-主动型绑定，这种绑定类型可以在绑定的 NIC 之间平衡流量，如果其中一个绑定的 NIC 出现故障，主机服务器的网络流量将自动通过另一个 NIC 进行路由。
  • 选择主动-被动可配置主动-被动型绑定，在这种绑定类型中，流量仅通过其中一个绑定的 NIC 传输。 在此模式下，仅当活动 NIC 出现故障时（例如，丢失网络连接），另一个 NIC 才会处于活动状态。
  • 选择 LACP 与基于源 MAC 地址的负载平衡功能绑定可配置 LACP 绑定，这种绑定类型根据发起流量的 VM 的 MAC 地址选择传出 NIC。 使用该选项可以在同一主机上有多个 VM 的环境中平衡流量。 如果虚拟接口 (VIF) 的数量少于 NIC，此选项则不适用：因为无法在 NIC 之间分割流量，所以无法实现最佳负载平衡。
  • 选择 LACP 与基于源和目标的 IP 和端口的负载平衡功能绑定可配置 LACP 绑定，在该模式下，源 IP 地址、源端口号、目标 IP 地址和目标端口号用于在 NIC 之间分配流量。 使用该选项可以在 NIC 数量超过 VIF 数量的环境中平衡流量。

注意：

  • 您必须将 vSwitch 配置为网络堆栈，才能查看 XenCenter 中的 LACP 绑定选项，并创建新的 LACP 绑定。 此外，交换机还必须支持 IEEE 802.3ad 标准。
  • 主动-主动和主动-被动绑定类型适用于 vSwitch 和 Linux 桥接。
  • vSwitch 作为网络堆栈时，您可以绑定两个、三个或四个 NIC，而 Linux 桥接作为网络堆栈时，您只能绑定两个 NIC。

有关详细信息，请参阅配置 NIC。
MTU | 要使用巨型帧，请将最大传输单位 (MTU) 设置为介于 1500 到 9216 之间的任意值。
自动将此网络添加到新虚拟机 | 如果选中该复选框，网络会自动添加到使用新建 VM 向导所创建的新 VM 中。


配置 NIC

XenServer 根据相关的网络、虚拟网络接口、服务器网络和绑定配置，按需要自动对 NIC 进行管理。 通过 NIC 选项卡查看可用的 NIC、配置 NIC 绑定并将 NIC 专用于特定功能。

NIC 绑定可以将两个或更多物理 NIC 当作一个 NIC 使用，从而提高服务器的弹性。 可以将两个或更多 NIC 绑定在一起，创建一个高性能通道，将 VM 与外部网络连接起来。 支持以下三种绑定模式：

主动-主动
此模式可以在绑定的两个物理 NIC 之间实现虚拟机流量的负载平衡。 如果绑定的一个 NIC 出现故障，则主机的所有网络流量将自动通过另一个 NIC 进行路由。
主动-被动（主动-备份）。
该模式可以提供故障转移功能。 只有一个绑定的 NIC 处于活动状态；当且仅当活动 NIC 发生故障时，非活动 NIC 才变为活动状态。
链路聚合控制协议 (LACP) 绑定
该模式提供主动-主动绑定，将在绑定的 NIC 之间实现平衡流量。 与 Linux 桥接环境中的主动-主动型绑定不同，LACP 可以对所有流量类型实现负载平衡。
注: 您必须将 vSwitch 配置为网络堆栈，才能查看 XenCenter 中的 LACP 绑定选项，并创建新的 LACP 绑定。 此外，交换机还必须支持 IEEE 802.3ad 标准。 交换机必须包含为主机上的每个 LACP 绑定配置的单独的 LAG 组。 有关创建 LAG 组的更多详细信息，请参阅《XenServer 管理员指南》。

当您使用 XenCenter 绑定单独的 NIC 时，即创建一个新的 NIC：这称为绑定主对象，而被绑定的 NIC 称为从属 NIC。然后可以将 NIC 绑定连接到 XenServer 网络，以实现虚拟机流量和服务器管理功能。 在 XenCenter 中，可以从 NIC 选项卡或从服务器的网络连接选项卡创建 NIC 绑定（网络类型 = 绑定网络）。

查看可用 NIC

对于服务器上每个可用的 NIC，将在 NIC 选项卡上显示以下设备属性：

NIC | 标识物理网络接口卡或内部虚拟网络。
MAC | NIC 的介质访问控制地址。
链接状态 | NIC 的连接状态：连接或断开。
速度 | NIC 的数据传输速率。
双工 | NIC 的双工模式：“全”或“半”
供应商、设备 | NIC 供应商和设备名称。
PCI 总线路径 | 传递设备的 PCI 总线路径。

在 XenServer 主机上添加新的物理接口（例如，新的以太网控制器）时，该接口可能不会显示在 NIC 选项卡的列表中。 如果出现这种情况，可以在 NIC 选项卡上单击重新扫描，强制 XenServer 扫描新的接口卡。

创建新的 NIC 绑定

  1. 确保您想要绑定在一起的 NIC（绑定从属对象）未在使用中：在创建绑定之前，必须关闭任何其虚拟网络接口使用绑定从属对象的 VM。 创建绑定后，您需要将虚拟网络接口重新连接至相应的网络。
  2. 在资源窗格中选择服务器，然后单击 NIC 选项卡并单击创建绑定。
  3. 选择想要绑定在一起的 NIC。 要选择某 NIC，请在列表中选中其复选框。 在列表中最多可以选择四个 NIC。 清除复选框可取消选择 NIC。 为了保持灵活安全的网络，当 vSwitch 是网络堆栈时，您可以绑定两个、三个或四个 NIC，而当 Linux 桥接是网络堆栈时，则只能绑定两个 NIC。
  4. 在绑定模式下，选择绑定类型：
    • 选择主动-主动可配置主动-主动型绑定，这种绑定类型可以在绑定的 NIC 之间平衡流量，如果其中一个绑定的 NIC 出现故障，主机服务器的网络流量将自动通过另一个 NIC 进行路由。

    • 选择主动-被动可配置主动-被动型绑定，在这种绑定类型中，流量仅通过其中一个绑定的 NIC 传输。 在此模式下，仅当活动 NIC 出现故障时（例如，丢失网络连接），另一个 NIC 才会处于活动状态。

    • 选择 LACP 与基于源 MAC 地址的负载平衡功能绑定可配置 LACP 绑定，这种绑定类型根据发起流量的 VM 的 MAC 地址选择传出 NIC。 使用该选项可以在同一主机上有多个 VM 的环境中平衡流量。 如果虚拟接口 (VIF) 的数量少于 NIC，此选项则不适用：因为无法在 NIC 之间分割流量，所以无法实现最佳负载平衡。

    • 选择 LACP 与基于源和目标的 IP 和端口的负载平衡功能绑定可配置 LACP 绑定，在该模式下，源 IP 地址、源端口号、目标 IP 地址和目标端口号用于在 NIC 之间分配流量。 使用此选项可以在 NIC 数量超过 VIF 数量的环境中平衡来自 VM 的流量。

      注: LACP 绑定仅适用于 vSwitch，而主动-主动和主动-被动绑定模式适用于 vSwitch 和 Linux 桥接。

      有关 XenServer 中 NIC 绑定支持的详细信息，请参阅《XenServer 管理员指南》。

  5. 要使用巨型帧，请将最大传输单位 (MTU) 设置为介于 1500 到 9216 之间的一个值。
  6. 要将新绑定的网络自动添加到使用新建 VM 向导创建的任何新 VM，请选中该复选框。
  7. 单击创建以创建 NIC 绑定并关闭对话框。

当创建新绑定后，XenCenter 会自动将管理接口和辅助接口从绑定从属对象移至绑定主对象。

请注意，不允许将管理接口属于某绑定的服务器加入池。 您需要重新配置该服务器的管理接口，将其移回物理 NIC，然后该服务器才能加入池。

删除 NIC 绑定

如果将服务器还原到非绑定配置，应注意下列要求：

  • 与创建绑定过程一样，在解除绑定之前，必须先关闭其虚拟网络接口使用该绑定的所有虚拟机。 还原为非绑定配置后，需要将这些虚拟网络接口重新连接到适当网络。

  • 在删除绑定之前，必须先使用管理接口对话框将管理接口移至其他 NIC，否则将与服务器（包括 XenCenter）断开连接。

删除绑定

  1. 在资源窗格中选择服务器然后单击 NIC 选项卡。
  2. 单击删除绑定。

将 NIC 专用于特定功能

您可以向 NIC 分配 IP 地址并将 NIC 专用于特定功能，例如存储或其他类型的网络流量。 有关详细信息，请参阅配置 IP 地址。


配置 IP 地址

托管服务器上用作管理接口的 NIC 最初在 XenServer 安装期间指定。 在 XenCenter 中，XenServer xe 命令行接口 (CLI) 以及独立计算机上运行的其他任何管理软件都通过管理接口的 IP 地址连接到服务器。

如果一个服务器有两个或更多 NIC，您可以选择一个不同的 NIC 或 NIC 绑定用作其管理接口。 您可以为 NIC 分配 IP 地址（也称为配置辅助接口），并将 NIC 专用于执行特定功能，例如存储或其他类型的网络流量。 请注意，不支持在 VLAN 网络上使用管理接口。

还要注意，当新服务器加入池时，该服务器将自动继承池主服务器的网络配置（包括网络和绑定信息）。 但是，加入的服务器的管理接口不会变为与主服务器相同，因此需要在加入后重新对其进行配置，以使用与池主服务器相同的绑定。 还应注意，管理接口正在绑定的服务器不可以加入池，因此，如果要加入池，必须重新配置该服务器的管理接口，并将其移回物理 NIC。

下面几节提供了使用配置 IP 地址对话框在 XenCenter 中为 NIC 分配 IP 地址以及更改服务器或池的管理接口的说明。

为 NIC 分配静态 IP 地址

您可以使用 XenCenter 为 NIC 配置 IP 地址来执行特定功能，例如存储流量。 为 NIC 配置 IP 地址时，本质上是在创建辅助接口。

为了保持网络的灵活性和安全性，您可以创建辅助接口来将网络流量分段，这些管理接口使用专用 NIC 建立单独的网络，用于服务器管理、应用程序生产流量和存储流量，等等。 在默认 XenServer 网络连接配置中，基于 IP 的存储设备的所有网络流量都通过用于管理接口的 NIC 进行。 另请务必注意，辅助接口从管理接口继承 DNS 服务器设置。

要为 NIC 分配 IP 地址来执行特定功能，需要有适当的网络配置，以确保 NIC 用于所需流量。 例如，要将 NIC 专用于存储流量，您必须为新创建的接口分配 IP 地址，该地址 (a) 与存储控制器在同一子网中（如果适用）；(b) 与管理接口在不同子网中；(c) 不与任何其他辅助接口在同一子网中。 此外，还必须将 NIC、存储目标、交换机和/或 VLAN 配置为只能通过分配的 NIC 访问目标。 这样就可以使用标准的 IP 路由来控制流量在托管服务器内多个 NIC 之间的路由。

要为 NIC 分配 IP 地址并创建辅助接口，请执行以下操作：

  1. 在服务器或池的网络连接选项卡中，在 IP 地址配置下单击配置。
  2. 单击添加 IP 地址。
  3. 输入新辅助接口的名称。
  4. 从网络列表中选择 XenServer 网络。
  5. 配置新接口的网络连接设置：
    • 要使用自动化的动态主机配置协议 (DHCP) 自动分配网络设置（包括 IP 地址、子网掩码和网关），请选中使用 DHCP 自动获取网络设置。
    • 要手动配置网络连接设置，请单击使用以下设置，然后输入所需值。 您必须输入 IP 地址和子网掩码，但网关设置为可选项。
  6. 要配置更多接口，请再次单击添加 IP 地址，然后重复执行上述配置步骤。
  7. 完成后，单击确定保存配置选择。
    注: 如果您选择手动配置网络设置，系统会提示您确认设置。 单击仍然重新配置进行确认。

删除辅助接口

  1. 在服务器或池的网络连接选项卡中，在 IP 地址配置下单击配置。
  2. 在对话框左侧已配置的接口列表中，选择要删除的接口，然后单击 Remove this Interface（删除此接口）。
  3. 单击确定保存配置选择。

更改管理接口

  1. 在服务器或池的网络连接选项卡中，在 IP 地址配置下单击配置。
  2. 在主选项卡上，从网络列表中选择 XenServer 网络。
  3. 配置管理接口的网络设置：
    • 要使用自动化的动态主机配置协议 (DHCP) 自动分配网络设置（包括 IP 地址、子网掩码、网关和 DNS 服务器），请选中使用 DHCP 自动获取网络设置。
    • 要手动配置网络设置，请单击使用以下设置，然后输入所需值。 您必须输入 IP 地址和子网掩码，但网关和 DNS 服务器设置为可选项。
  4. 完成后，单击确定保存配置选择。
    注: 如果您选择手动配置网络设置，系统会提示您确认设置。 单击仍然重新配置进行确认。


更改服务器属性

在“资源”窗格中选择任意已连接的服务器，然后单击常规选项卡查看其属性和当前状态。 单击属性可更改服务器的属性。

常规属性 - 名称、说明、文件夹和标记

您可以在服务器的“属性”对话框的“常规属性”选项卡上更改服务器的名称、说明、文件夹和标记。

  • 要更改服务器的名称，请在名称框中输入新名称。
  • 要更改其说明，请在说明框中输入新文本。
  • 要将服务器置于文件夹中或将其移至其他文件夹中，请在文件夹对话框中单击更改，然后选择一个文件夹。 有关使用文件夹的详细信息，请参阅使用文件夹。
  • 要对服务器进行标记或取消标记，以及创建和删除标记，请参阅使用标记。

iSCSI IQN（“常规”选项卡）

当服务器连接 iSCSI 存储库 (SR) 时，将使用服务器的 iSCSI IQN 来唯一标识该服务器。 XenServer 主机支持单个 iSCSI 发起程序，该发起程序在主机安装期间自动创建并配有一个随机 IQN。 单个发起程序可以用来同时连接多个 iSCSI 目标 (SR)。 有关 XenServer 的 iSCSI 存储支持功能的更多详细信息，请参阅《XenServer 管理员指南》。

重要: iSCSI 目标 (SR) 和池中的所有服务器必须设置不同的 IQN。 如果使用不唯一的 IQN 标识符，则数据会遭到破坏，并且/或者对目标的访问可能被拒绝。

更改托管服务器的 iSCSI IQN 值

注: 在更改服务器的 iSCSI IQN 值之前，必须断开所有现有的 SR。 还应注意，如果更改服务器的 IQN，在相应更新存储目标前，该服务器可能无法连接新的或现有的 SR。
  1. 在资源窗格中选择该服务器，单击常规选项卡，然后单击属性。
  2. 在属性对话框的常规选项卡上，在 iSCSI IQN 框中输入新值。
  3. 单击确定保存所做的更改并关闭对话框。

自定义字段

可以使用自定义字段为托管资源添加信息，使这些资源更易于搜索和组织。 有关如何为托管资源指定自定义字段的信息，请参阅使用自定义字段。

警报

使用该选项卡可针对服务器的 CPU、内存使用率和网络活动配置性能警报。 有关详细信息，请参阅配置性能警报。

电子邮件选项（独立服务器）

使用该选项卡可以针对独立服务器上生成的系统警报配置电子邮件通知。 对于池中的服务器，该功能在池级别配置。 有关如何通过电子邮件接收警报通知的信息，请参阅XenCenter 警报。

多路径

光纤通道和 iSCSI 存储库支持动态存储多路径功能，可以通过服务器“属性”对话框中的“多路径”选项卡启用此功能。

有关启用和禁用多路径的信息，请参阅 存储多路径。

开机（独立服务器）

使用该选项卡可配置 XenServer 主机开机功能，以允许远程开启托管服务器。 有关配置此功能的详细信息，请参阅配置主机开机。 对于池中的服务器，该功能在池级别配置。

日志目标位置

XenServer 系统日志消息可以存储在本地服务器上，也可以存储在远程服务器上。

远程服务器必须运行 syslogd 后台程序，以接收日志并将它们正确地聚合。 syslog 后台程序是 Linux 和 Unix 的所有版本的标准部件，Windows 和其他操作系统可以使用第三方版本。 还应将远程服务器配置为允许从池中的主机远程连接，并正确配置其防火墙。

查看或更改 XenServer 日志目标位置

  1. 在资源窗格中选择该服务器，单击常规选项卡，然后单击属性。
  2. 在属性对话框中单击日志目标位置选项卡，然后：
    • 要在本地存储 XenServer 日志消息，请单击本地。
    • 要在其他服务器上存储 XenServer 日志消息，请单击远程并输入路径名。
  3. 单击确定保存所做的更改并关闭对话框。

GPU

vGPU 是一项仅在 XenServer Enterprise、XenServer Desktop+ 和 XenServer Desktop Edition 中提供的高级功能。 使用 XenServer Enterprise、XenServer Desktop+ 或 Desktop Edition 许可证对 XenServer 主机进行了许可，并且主机具有支持各种 vGPU 类型的 GPU 时，将显示“GPU”选项卡。 此选项卡允许您设置主机范围的策略以将 VM 分配给可用的 GPU，从而实现密度最大化或性能最大化。 根据您的要求选择一个选项。

注: 只有在针对不同的 GPU 组使用不同的设置时（即配置某些特定的 GPU 组以实现密度最大化，同时配置其他的 GPU 组以实现性能最大化），GPU 选项卡才会显示混合设置。 客户需要注意，无法使用 XenCenter 设置或编辑“混合”设置。 如果您希望对不同的 GPU 组使用不同的设置，应使用 xe 命令行接口。


导出和导入托管服务器列表

可以将托管服务器列表从 XenCenter 导出到配置文件中，然后将该文件导入到其他计算机上运行的 XenCenter 会话中。 此功能非常有用，例如可以帮助您将托管服务器列表从台式机复制到便携式计算机，而无需在新计算机上手动添加很长的服务器列表。

每个托管 VM 的 IP 地址/DNS 名称、端口和显示名称都以 XML 格式保存在文件扩展名为 .config 的 XenCenter 配置文件中。 登录凭据将不存储。

导出托管服务器列表

  1. 在文件菜单上，单击导出服务器列表。
  2. 指定导出文件的名称和位置，然后单击保存。

导入服务器列表

  1. 在文件菜单上，单击导入服务器列表。
  2. 找到 XenCenter 配置文件，然后单击打开。

    服务器将显示在 XenCenter 的资源窗格中，状态为已断开连接 [image] 。

  3. 在资源窗格中，双击每个导入的服务器以与之连接。


管理池

  • 关于资源池
  • 池要求
  • 创建新池
  • 向池中添加服务器
  • 从池中删除服务器
  • 从池中销毁服务器
  • 导出资源数据
  • 迁移虚拟机
  • 更改池属性
  • 更改 root 用户密码
  • 删除池


关于资源池

通过使用 Citrix XenServer 池，可以将多个服务器及其连接的共享存储作为一个统一的资源进行查看，以便能够根据虚拟机资源需求和业务优先级灵活部署虚拟机。 一个池中最多可以包含 16 个服务器，这些服务器都运行同一版本的 XenServer 软件（具有相同的修补程序级别），而且具有广泛的硬件兼容性 - 有关硬件和配置必备条件的详细信息，请参阅 池要求。

池中的一个服务器被指定为池主服务器，为池中的所有服务器提供单一联系点，以根据需要将通信路由到池中的其他成员。

如果池主服务器关闭，则在池主服务器重新启动并恢复联机状态之前，或者在指定其他某个成员作为新的池主服务器之前，池将不可用。 如果需要，资源池的每个成员都将包含担任主服务器角色所需的所有信息。 在启用高可用性的池中，如果主服务器已关闭，则将自动指定新的池主服务器。


池要求

创建池或将服务器加入现有池前，应确保池中的所有服务器满足下面介绍的要求。

硬件要求

XenServer 资源池中的所有服务器必须具有广泛兼容的 CPU，也就是说：
  • 所有服务器上的所有 CPU 都来自同一家 CPU 供应商（Intel 或 AMD）。 具体而言，就是不能混用 AMD-V 和 Intel VT CPU。
  • 所有 CPU 必须具有相同的功能集。 要在同一个池中加入具有不同 CPU 的服务器，可以通过 CPU 屏蔽来隐藏不兼容的功能。
  • 要运行 HVM (Windows) 虚拟机，所有 CPU 都必须启用虚拟化功能。

使用 CPU 屏蔽（异类池）

在基础 CPU 功能不同的服务器之间，不能进行实时的 VM 迁移。 但是，较新一代的 CPU 能够隐藏（“屏蔽”）软件可见处理器功能的差异，从而使具有不同基础硬件功能的 CPU 看上去相同。使用 CPU 屏蔽时，仅公开资源池中所有处理器都支持的功能，使 VM 可以在处理器功能可能不同的服务器之间安全地实现实时迁移。

此功能由 Intel Virtualization Technology FlexMigration (Intel VT FlexMigration) 和 AMD-V Extended Migration 技术提供。

将新服务器放入 XenServer 资源池时，将对现有 CPU 和新加入 CPU 上的功能集进行比较，如果发现彼此兼容，则允许新服务器加入池中。 在确定 CPU 兼容性时，仅考虑公开的 CPU 功能。 如果启用 CPU 屏蔽功能，在新 CPU 上将仅公开旧服务器的 CPU 上存在的功能，其他/更新的功能将被屏蔽。 这样，如果新服务器的 CPU 支持实时迁移，则该服务器将可以放入“功能更少的”旧服务器所在的资源池中。 （这种类型的池称为异类池。）

如果不启用 CPU 屏蔽功能，池中的所有服务器必须具有相同的 CPU，也就是说，CPU 具有完全相同的功能集（这称为同类池）。 XenCenter 不允许将具有不同基础处理器功能的服务器放在同一个资源池中。如果在池中的现有服务器上检测到与新服务器不同的 CPU 功能集，XenCenter 将自动尝试使用 CPU 屏蔽功能。

其他要求

除上述的硬件必备条件外，加入池的服务器还需要满足许多其他配置方面的必备条件：

  • 服务器必须具有静态 IP 地址（在服务器本地配置或者使用 DHCP 服务器上的相应配置）。 这同样适用于提供 NFS 或 iSCSI 存储的服务器。
  • 服务器的系统时钟必须与池主服务器同步（例如，通过 NTP）。
  • 服务器不能是某个现有资源池的成员。
  • 服务器上不能有任何正运行或挂起的 VM，其 VM 中不能有任何正在执行的操作（例如关机或导出）；必须先关闭所有 VM，然后服务器才能加入池中。
  • 不能为服务器配置任何共享存储。
  • 服务器不能有绑定的管理接口。 将服务器加入池中之前，需要重新配置该服务器的管理接口并将其移回到物理 NIC，然后在服务器成功加入池中后立即重新进行配置；请参阅配置 IP 地址。
  • 服务器与池中的服务器必须运行相同版本的 XenServer 软件，修补程序级别也必须相同。
  • 为服务器配置的补充软件包必须与池中现有服务器相同。 补充软件包用于将附加软件安装到 XenServer 控制域 dom0 中。 为防止在池中出现不一致的用户体验，有必要在池中的所有服务器上安装相同修订版的相同补充软件包。
  • 服务器必须与池中的现有服务器具有相同的 XenServer 产品许可证版本。 例如，不能将免费 XenServer 系统添加到使用 XenServer 高级版或更高版本许可证的服务器所在的资源池中。 如果尝试将运行免费 XenServer 版本的服务器添加到包含已授权服务器的池中，您将有机会从 Citrix 许可证服务器为加入的服务器分配一个许可证（如果有可用的许可证）。 有关详细信息，请参阅管理许可证。

共享池存储

创建资源池时，尽管从技术角度而言并不一定要求池具有共享存储库，但只有在池具有一个或多个共享存储库时，池的优势（例如，在最合适的服务器上运行 VM 以及在服务器之间迁移 VM）才会体现出来。

除非具有共享存储，否则我们建议您不要尝试创建池。 添加共享存储后，可以通过复制 VM 将磁盘位于本地存储中的任何现有 VM 移动到共享存储中。

当具有共享 SR 的服务器成为池主服务器时，该 SR 将成为池的共享 SR。 如果新的池主服务器没有任何共享存储，则必须为池创建新的共享 SR：请参阅创建新 SR。


创建新池

在尝试创建新池之前，请确保要加入新池的所有服务器都满足池要求中列出的要求。

创建新池

  1. 通过单击工具栏上的新建池，打开“新建池”对话框。
  2. 输入新池的名称和可选说明；该名称将显示在资源窗格中。
  3. 从主服务器列表中选择服务器，以指定池主服务器。
  4. 从其他成员列表中，选择要放入新池的其他服务器。 将列出所有可用的托管服务器。 如果某个服务器未列出，您可以通过单击添加新服务器将该服务器添加到列表中。 如果某个托管服务器未列出，可能是因为该服务器不满足池要求中列出的一项或多项加入池的要求。
  5. 单击创建池创建新池并关闭对话框。
如果池主服务器已经有一个共享存储库 (SR)，此存储库将成为池的共享 SR。 如果新的池主服务器没有任何共享存储，则必须为池创建新的共享 SR：请参阅创建新 SR。

其他池配置步骤

要配置新池，请使用属性选项卡：
  1. 要将共享存储添加到池中，请参阅创建新 SR。
  2. 要将更多服务器添加到池中，请参阅向池中添加服务器。


向池中添加服务器

向资源池中添加任何新服务器之前，请确保要加入的服务器满足池要求中所列出的硬件和配置要求。
重要: 在尝试将服务器添加到池中之前，应首先备份该服务器上托管的所有虚拟机。

向现有池添加服务器

  1. 在资源窗格中，选择服务器，然后执行以下操作之一：
    • 将所选服务器拖动到资源窗格中的目标池上。
    • 在服务器菜单中，单击添加到池，然后单击目标池。
    • 单击鼠标右键，并在快捷菜单中单击添加到池，然后单击目标池。
  2. 单击确定进行确认。

服务器加入池后，即会在资源窗格中作为池成员显示，例如：

当您将服务器添加到池中时，XenCenter 将尽可能尝试解决任何池配置问题：

  • 必须在与池主服务器相同的级别许可加入服务器。 不能将服务器添加到主服务器具有不同许可证类型的池。 例如，在 XenServer 6.5 中，如果将使用 Standard 许可证版本的服务器添加到主服务器获得了 Enterprise Edition 许可的池，系统将提示您升级加入服务器的许可证以匹配主服务器的许可证。 如果没有可用许可证，则不能将服务器添加到池。

    加入池后，可以更改任意池成员的许可证。 使用最低版本许可证的服务器决定了池中所有成员可以使用的功能。 有关许可的详细信息，请参阅关于 XenServer 许可。

  • 如果池主服务器已加入某个域中，系统会提示您为要加入池的服务器配置 Active Directory (AD)。 当系统提示您为要加入的服务器提供凭据时，请输入池所加入的域的 AD 凭据。 这些凭据必须具有足够的权限才能将服务器添加到域中。

请注意，可能会有其他硬件或配置问题阻止服务器成功加入池：有关资源池必备条件的详细信息，请参阅池要求。

当新服务器加入池中时，该服务器将自动继承池主服务器的网络配置（包括网络和绑定信息）。 但是，加入的服务器的管理接口不会变为与主服务器相同，因此需要在加入后重新对其进行配置，以使用与池主服务器相同的绑定。 有关如何执行此操作的信息，请参阅更改管理接口。

向新池添加服务器

可以使用新建池向导将托管服务器添加到新池中。 该服务器将成为新池中的主服务器。
  1. 在资源窗格中，选择该服务器。
  2. 单击鼠标右键，并在快捷菜单中单击添加到池，然后单击新建池。
  3. 使用新建池对话框创建新池。 请参阅创建新池。


从池中删除服务器

重要: 从资源池中删除服务器时，存储在本地磁盘（本地存储）上的所有 VM 数据都将清除。 如果本地虚拟磁盘上有重要数据，在删除服务器前，必须先将这些磁盘移动到同一资源池内的共享存储库中。
  1. 将本地磁盘上存储的所有数据移动到同一资源池内的共享存储库中；请参阅移动虚拟磁盘。
  2. 关闭服务器上运行的所有 VM；请参阅关闭 VM。
  3. 在资源窗格中，选择服务器，然后执行以下操作之一：
    • 单击鼠标右键，然后在资源窗格快捷菜单中单击从池中删除服务器。
    • 在池菜单中，单击删除服务器。


从池中销毁服务器

重要: 从资源池中销毁服务器将在不明确与指定的 XenServer 主机联系的情况下将该主机忘记，并将其连同本地 SR、DVD 驱动器以及可移动存储一起永久删除。 使用该选项可以销毁无法联系或实际已出现故障的服务器。 另请注意，销毁服务器的操作无法撤消。
  1. 在资源窗格中，选择服务器，然后执行以下操作之一：
    • 单击鼠标右键，然后在资源窗格快捷菜单中选择销毁。
    • 在服务器菜单中，单击销毁。
  2. 单击是，销毁进行确认。


导出资源数据

导出资源数据可为您的池生成一份资源数据报告，并可将该报告导出为 .xls 或 .csv 文件。 此报告提供有关池内各种资源（例如服务器、网络、存储、虚拟机、VDI 和 GPU）的详细信息。 该功能允许管理员根据各种工作负载（例如 CPU、存储和网络）跟踪、计划和分配资源。

注: 导出资源数据是一项仅在 XenServer Enterprise Edition 中提供的高级功能。 有关 XenServer 6.5 许可的信息，请参阅许可概述 (XenServer 6.5)。 要购买 XenServer 许可证，请单击此处。

下表提供了报告内包含的资源和各种类型的资源数据的列表。

资源 资源数据

服务器

  • 名称
  • 池主服务器
  • UUID
  • 地址
  • CPU 使用率
  • 网络（平均/最大 KB/秒）
  • 已用内存
  • 存储器
  • 运行时间
  • 说明

网络

  • 名称
  • 链接状态
  • MAC
  • MTU
  • VLAN
  • 类型
  • 位置

VDI Edition

  • 名称
  • 类型
  • UUID
  • 大小
  • 存储器
  • 说明

存储器

  • 名称
  • 类型
  • UUID
  • 大小
  • 位置
  • 说明

VM

  • 名称
  • 电源状态
  • 运行平台
  • 地址
  • MAC
  • NIC
  • 操作系统
  • 存储器
  • 已用内存
  • CPU 使用率
  • UUID
  • 运行时间
  • 模板
  • 说明

GPU

注: 仅当有 GPU 与您的 XenServer 主机连接时才有关于 GPU 的信息。
  • 名称
  • 服务器
  • PCI 总线路径
  • UUID
  • 电源使用
  • 温度
  • 已用内存
  • 计算机利用率

导出资源数据：

  1. 在 XenCenter 的“导航”窗格中，单击基础结构，然后单击相应的池。
  2. 在 XenCenter 菜单中，单击池，然后选择导出资源数据。
  3. 浏览到您希望保存报告的位置，然后单击保存。


更改池属性

在资源窗格中选择任何资源池，然后单击常规选项卡，即可查看其属性和当前状态。 单击常规选项卡上的属性可更改池的属性。

常规属性 - 名称、说明、文件夹和标记

在常规属性选项卡上，可以更改池的名称和说明，将池放入文件夹中，以及管理池的标记。

  • 要更改池的名称，请在名称框中输入新名称。
  • 要更改其说明，请在说明框中输入新文本。
  • 要将池放入文件夹中或者将其移至其他文件夹中，请单击“文件夹”框中的“更改”，然后选择文件夹。 有关使用文件夹的详细信息，请参阅使用文件夹。
  • 要对池进行标记和取消标记，以及创建标记和删除标记，请参阅使用标记。

自定义字段

可以使用自定义字段为托管资源添加信息，使这些资源更易于搜索和组织。 有关如何为托管资源指定自定义字段的信息，请参阅使用自定义字段。

电子邮件选项

使用该选项卡可为池中任何服务器或 VM 上生成的系统警报配置电子邮件通知。 有关如何设置警报电子邮件通知的详细信息，请参阅 XenCenter 警报。

开机

通过开机功能，可以为支持电源管理的服务器配置电源管理首选项，使这些服务器可以根据池的总工作负载（通过 Workload Balancing）自动关闭和打开电源。

  • 在该选项卡顶部的服务器列表中，选择要配置电源管理的服务器。
  • 在开机模式下，为选定的服务器指定“开机”设置（已禁用、LAN 唤醒、HP iLO、DRAC 或自定义脚本）。

  • 在配置选项下，根据选择的开机模式选项，指定 IP 地址和凭据或者主机开机脚本的键值对。

有关主机开机功能配置的必备条件及不同可用配置选项的详细信息，请参阅配置主机开机。

GPU

vGPU 是一项仅在 XenServer Enterprise、XenServer Desktop+ 和 XenServer Desktop Edition 中提供的高级功能。 池中的 XenServer 主机获得了 XenServer Enterprise、XenServer Desktop+ 或 XenServer Desktop Edition 的许可，并且池具有支持各种 vGPU 类型的 GPU 时，将显示“GPU”选项卡。 此选项卡允许您设置池范围的策略以将 VM 分配给可用的 GPU，从而实现密度最大化或性能最大化。 根据您的要求选择一个选项。

只有在针对不同的 GPU 组使用不同的设置时，“GPU”选项卡才会显示混合设置。 即配置池内的某些特定 GPU 组以实现密度最大化，同时配置其余的 GPU 组以实现性能最大化。 客户需要注意，无法使用 XenCenter 设置或编辑“混合”设置。 如果您希望对不同的 GPU 组使用不同的设置，应使用 xe 命令行接口。


更改 root 用户密码

您可以更改池的 root 用户密码（即用于池中所有服务器的密码），方法是：在资源窗格中选择该池或池中的任何服务器，然后单击池菜单或服务器菜单上的更改服务器密码。

要更改独立服务器的 root 用户密码：在资源窗格中选择服务器，从服务器菜单中单击密码，然后单击更改。

如果 XenCenter 配置为在会话之间保存服务器登录凭据，则系统将记住新密码；有关详细信息，请参阅存储服务器连接状态。


删除池

可以将仅包含一个托管服务器的资源池（单例池）删除，从而有效地使该服务器成为独立服务器。

要删除某个池，请在资源窗格中选择该池，然后执行以下操作之一：

  • 单击鼠标右键，然后在资源窗格快捷菜单中单击删除。
  • 在池菜单中，单击删除。


管理存储库 (SR)

  • 关于 XenServer SRs
  • 创建新 SR
  • 删除 SR
  • 重新连接 SR
  • 存储多路径
  • 回收释放的空间
  • 实时 LUN 扩展
  • 更改 SR 属性
  • 升级旧 SR


关于 XenServer SR

XenServer 存储库 (SR) 是一种存储容器，用于存储虚拟磁盘。 存储库和虚拟磁盘都是磁盘上独立于 XenServer 而存在的持久对象。 SR 可以在资源池中的各服务器之间共享，可以存在于不同类型的内部和外部物理存储设备（包括本地磁盘设备和共享网络存储）上。 使用新建存储库向导创建新的存储库时，可以使用许多不同的存储类型。根据所选择的存储类型，可以在 XenCenter 中配置许多高级存储功能，其中包括：

  • 动态多路径。 在光纤通道和 iSCSI SR 上，可以使用轮询模式负载平衡来配置存储多路径。 有关详细信息，请参阅存储多路径。
  • 精简置备。 在 NetApp 和 Dell EqualLogic SR 上，可以选择所使用的空间管理类型。 默认情况下，所分配的空间采用密集置备方式，并且在文件管理器上全面实施所有虚拟分配保证措施，从而保证虚拟磁盘永远不出现空间不足的情况，并且不会因此发生磁盘写入失败。 精简置备可以提高磁盘的利用率，因为只有当 VM 需要空间时（即 VM 写入时）才分配物理容量，从而实现可用存储的过度置备并最大程度地利用存储资产。
  • 回收释放的空间。 在基于精简置备块的 SR 上，您可以释放一些未使用的空间（例如 LUN 中已删除的 VDI）。 回收的空间随后可由存储库重新使用。 有关详细信息，请参阅回收释放的空间。
  • 实时 LUN 扩展。 实时 LUN 扩展允许您增加 LUN 的大小而不会出现任何 VM 停机的情况。 有关详细信息，请参阅实时 LUN 扩展。

配置服务器或池时，可以指定用来存储故障转储数据和已挂起 VM 映像的默认 SR，该 SR 将用作新虚拟磁盘的默认 SR。 在池级别，默认 SR 必须是共享 SR。 在资源池中创建的任何新虚拟磁盘、故障转储文件或已挂起 VM 映像都将存储在池的默认 SR 中，从而提供了一种物理服务器故障恢复机制。 对于独立服务器，默认 SR 可以是本地 SR，也可以是共享 SR。 在独立服务器中添加共享存储时，共享存储将自动成为该服务器的默认 SR。

请注意，可以通过 XenServer xe 命令行接口 (CLI) 针对 VM、故障转储数据和已挂起 VM 使用其他 SR。 有关详细信息，请参阅《XenServer 管理员指南》。


创建新 SR

要创建新的存储库，请单击工具栏上的新建存储。

或者执行以下操作之一：

  • 在所选池或服务器的存储选项卡上，单击新建 SR。
  • 在“存储”菜单上，单击新建 SR。

在新建存储库向导的第一页选择物理存储类型，然后按照向导中的步骤操作，该向导将引导您完成该存储类型的配置过程。 向导中的可用设置集取决于您在第一页选择的存储系统供应商/型号。 单击下面的链接可以了解有关创建不同类型 SR 的详细信息。

SR 创建步骤

新建存储库向导将引导您完成新 SR 的创建过程：

  1. 在类型页面上，选择基础存储的类型：
    选项 | 说明 | 阅读更多信息
    NFS VHD | 在 NFS VHD SR 中，VM 映像以精简置备的 VHD 格式文件存储在共享 NFS 目标上。 通过 TCP/IP 支持 NFS V3 的现有 NFS 服务器可以直接用作虚拟磁盘的存储库。 可以将 NFS SR 共享，使虚拟磁盘位于 NFS VHD 存储库中的任何 VM 都可以在同一个资源池中的各服务器之间迁移。 | NFS VHD 存储
    软件 iSCSI | 软件 iSCSI SR 在通过 iSCSI 与 SAN 连接的 LUN 上使用共享逻辑卷管理器 (LVM)。系统通过使用 open-iSCSI 软件 iSCSI 发起程序或使用受支持的 iSCSI 主机总线适配器 (HBA)，来支持 iSCSI。 | 软件 iSCSI 存储
    硬件 HBA | 硬件 HBA SR 通过 HBA 连接到光纤通道 (FC)、以太网光纤通道 (FCoE) 或共享串联 SCSI (SAS) LUN。 在运行新建存储库向导之前，需要执行必要的配置以公开 LUN：该向导将自动探查可用的 LUN 并显示找到的所有 LUN 的列表。 | 硬件 HBA 存储
    StorageLink 技术 使用此选项，可以配置 StorageLink SR，以便对 NetApp/IBM N 系列或 Dell EqualLogic PS 系列阵列中的自动光纤/发起程序和阵列配置功能进行本机访问。 适用于给定 StorageLink SR 的功能取决于阵列的功能。
    重要: StorageLink 技术已从 XenServer 6.5 及更高版本中删除。 依赖于 StorageLink 技术的应用程序、代码或用法在 XenServer 6.5 及更高版本中将无法运行。 有关将现有的虚拟磁盘 (VDI) 从 StorageLink 技术 SR 迁移到 iSCSI 或光纤通道 SR 的相关信息，请参阅 CTX141433。
            StorageLink 存储
    Windows 文件共享 (CIFS) | CIFS ISO SR 处理以 ISO 格式文件存储且作为 Windows (CIFS) 共享提供的 CD 映像。 这种类型的 SR 对于创建共享 ISO 库（例如，VM 安装映像）非常有用。 | ISO 存储
    NFS ISO | NFS ISO SR 处理以 ISO 格式文件存储且作为 NFS 共享提供的 CD 映像。 这种类型的 SR 对于创建共享 ISO 库（例如，VM 安装映像）非常有用。 | ISO 存储
  2. 在名称页面上，输入新 SR 的名称。 默认情况下，向导将为该 SR 自动生成一个说明，其中包括您在执行该向导的过程中所选配置选项的摘要。 要输入自己的说明，请清除自动生成说明复选框并在说明框中键入说明。
  3. 在位置页面上，输入基础存储阵列的位置并设置配置设置。 此页面及后续向导页面上提供的选项取决于您在该向导第一页选择的存储类型。
  4. 单击完成，以创建新的 SR 并关闭向导。


NFS VHD 存储

在 NFS VHD 存储库中，VM 映像以精简置备的 VHD 格式文件存储在共享 NFS 目标上。 通过 TCP/IP 支持 NFS V3 的现有 NFS 服务器可以直接用作虚拟磁盘的存储库。 可以将 NFS SR 共享，使虚拟磁盘位于 NFS VHD 存储库中的任何 VM 都可以在同一个资源池中的各服务器之间迁移。

由于 NFS 存储库 (SR) 上的虚拟磁盘采用稀疏格式创建，因此您必须确保在 SR 上为所有必需的虚拟磁盘保留足够的磁盘空间。

配置 NFS VHD SR

  1. 打开新建存储库向导：单击工具栏上的新建存储库。
  2. 选择 作为物理存储类型，然后单击下一步。
  3. 在名称页面上，输入新 SR 的名称。 默认情况下，向导将为该 SR 自动生成一个说明，其中包括您在执行该向导的过程中所选配置选项的摘要。 要输入自己的说明，请清除自动生成说明复选框并在说明框中键入说明。 单击下一步继续操作。
  4. 在位置页面上，指定 NFS 存储目标的详细信息：
    共享名称

    服务器的 IP 地址或 DNS 名称和路径。 例如，server:/ShareName，其中 server 是服务器计算机的 DNS 名称或 IP 地址，ShareName 是文件夹或文件名及路径。

    必须将配置为 NFS 服务器导出池中所有服务器的指定路径。

    高级选项

    可以在此处输入任何其他配置选项。
  5. 单击扫描，让向导在指定位置扫描现有的 NFS SR。
  6. 如果找到现有 SR 并且这些 SR 尚未连接，可以选择其中一个并将其作为新存储库进行连接：单击重新连接现有 SR，在列表中选择该 SR，然后单击完成。
  7. 如果未找到现有 SR，只需单击完成，以完成新 SR 的配置并关闭该向导。


软件 iSCSI 存储

软件 iSCSI SR 在通过 iSCSI 与 SAN 连接的 LUN 上使用共享逻辑卷管理器 (LVM)。系统通过使用 open-iSCSI 软件 iSCSI 发起程序或使用受支持的 iSCSI 主机总线适配器 (HBA)，来支持 iSCSI。

请注意，系统为 iSCSI 存储库提供动态多路径支持。 默认情况下，多路径功能采用轮询模式的负载平衡，因此在正常操作期间，两个路由通道上都具有活动通信。 在 XenCenter 中，可以通过服务器“属性”对话框上的“多路径”选项卡启用和禁用存储多路径功能。请参阅存储多路径。

创建软件 iSCSI SR

  1. 打开新建存储库向导：单击工具栏上的新建存储库。 或者：
    • 在所选池或服务器的存储选项卡上，单击新建 SR。
    • 在存储菜单上，单击新建 SR。
    • 在资源窗格中，选择服务器或池，单击鼠标右键，然后单击快捷菜单上的新建 SR。
  2. 选择软件 iSCSI 作为物理存储类型，然后单击下一步。
  3. 在名称页面上，输入新 SR 的名称。 默认情况下，向导将为该 SR 自动生成一个说明，其中包括您在执行该向导的过程中所选配置选项的摘要。 要输入自己的说明，请清除自动生成说明复选框并在说明框中键入说明。 单击下一步继续操作。
  4. 在位置页面上，指定 iSCSI 目标的详细信息：
    目标主机 iSCSI 目标的 IP 地址或 DNS 名称。
    使用 CHAP 如果 iSCSI 目标配置为使用 CHAP 身份验证方式，请选中“使用 CHAP ”复选框并填写以下详细信息：
    • CHAP 用户：连接目标时应使用的 CHAP 身份验证用户名凭据。
    • CHAP 密码：连接目标时应使用的 CHAP 身份验证密码凭据。
    目标 IQN 要指定 iSCSI 目标 IQN，请单击“检测 IQN”按钮，然后从“目标 IQN”列表中选择 IQN。
    重要: 重要提示：iSCSI 目标和池中的所有服务器不得设置相同的 IQN。 每个 iSCSI 目标和启动器必须具有唯一的 IQN。 如果使用不唯一的 IQN 标识符，则数据会遭到破坏，并且/或者对目标的访问可能被拒绝。
    目标 LUN 要指定将创建存储库的 LUN，请单击“检测 LUN”按钮，然后从“目标 LUN”列表中选择 LUN。

    每个 iSCSI 存储库必须整个位于单个逻辑单元号上，不能跨多个 LUN。 如果该 LUN 已经包含一个 SR，可以使用现有 SR，也可以用新的 SR 替换现有 SR（这样做会销毁磁盘上的所有数据）。

  5. 单击完成，以完成新 SR 的配置并关闭该向导。


硬件 HBA 存储

硬件 HBA SR 通过 HBA 连接到光纤通道 (FC)、以太网光纤通道 (FCoE) 或共享串联 SCSI (SAS) LUN。 在运行新建存储库向导之前，需要执行必要的配置以公开 LUN：该向导将自动探查可用的 LUN 并显示找到的所有 LUN 的列表。

系统为光纤通道和 iSCSI 存储库提供动态多路径支持。 要启用存储多路径，请在服务器的属性对话框上打开多路径选项卡。请参阅存储多路径。

创建硬件 HBA SR

  1. 打开新建存储库向导：单击工具栏上的新建存储库。 或者：
    • 在所选池或服务器的存储选项卡上，单击新建 SR。
    • 在存储菜单上，单击新建 SR。
    • 在资源窗格中，选择服务器或池，单击鼠标右键，然后单击快捷菜单上的新建 SR。
  2. 选择硬件 HBA 作为物理存储类型，然后单击下一步。
  3. 在名称页面上，输入新 SR 的名称。 默认情况下，向导将为该 SR 自动生成一个说明，其中包括您在执行该向导的过程中所选配置选项的摘要。 要输入自己的说明，请清除自动生成说明复选框并在说明框中键入说明。 单击下一步前进到位置页面。
  4. 该向导将扫描可用的 LUN，然后显示一个页面，其中列出找到的所有 LUN。 从列表中选择一个 LUN，然后单击创建。
    注: 如果您所选的 LUN 上存在现有存储库，将显示一条警告消息。 查看详细信息并单击重新连接以使用现有的 SR，或者单击格式化删除现有的 SR 并创建一个新 SR。 如果您更倾向于选择其他 LUN，请单击取消并从列表中选择一个 LUN。
  5. 摘要页面将显示与新 SR 有关的信息。 阅读该信息，然后单击完成以完成 SR 创建过程。


StorageLink 存储

重要: StorageLink 技术已从 XenServer 6.5 及更高版本中删除。 依赖于 StorageLink 技术的应用程序、代码或用法在 XenServer 6.5 及更高版本中将无法运行。 有关从 StorageLink SR 将现有虚拟磁盘 (VDI) 迁移到 iSCSI 或光纤通道 SR 的信息，请参阅 CTX141433。

StorageLink SR 可以实现对高性能存储的直接访问，使 XenServer 环境中的 VM 充分利用各种阵列端企业存储服务的优势（例如复制、重复数据删除、精简置备、快照和克隆、数据保护和性能优化）。

StorageLink SR 使用存储适配器通过光纤通道或 iSCSI 访问采用各种常见存储技术（包括 NAS 和 SAN）的不同存储阵列。 适用于给定 StorageLink SR 的功能取决于基础阵列的功能。 在同一存储阵列硬件上，StorageLink SR 可以与其他 SR 类型共存，并且可以在同一个资源池内定义多个 StorageLink SR。

根据您的环境和目标，StorageLink 可以提供以下三项优势：

  • StorageLink SR 使用存储管理软件访问存储。
  • StorageLink 可以简化存储配置过程。 例如，从 XenCenter 中创建 StorageLink SR 时，StorageLink 将自动为您创建 LUN、卷和发起程序组。 这意味着您无需使用存储管理软件，即可创建这些对象。 但是，您需要在运行 XenCenter SR 向导之前创建聚合。
  • 创建的每个 VDI 都有自己的 LUN。 所有 StorageLink SR 都采用“每个 VDI 对应于一个 LUN”的模式，即为每个虚拟磁盘 (VDI) 置备一个新 LUN。

默认情况下，基于块设备的 XenServer 存储将插入磁盘上的逻辑卷管理器，可以是逻辑上连接的设备（LVM 类型的 SR），也可以是通过光纤通道（LVMoHBA 类型的 SR）、iSCSI（LVMoISCSI 类型的 SR）或 SAS（LVMoHBA 类型的 SR）连接的 SAN LUN。 使用 StorageLink 配置 SR 时，LUN 将作为 VDI 直接映射到虚拟机。 因此，阵列存储抽象与管理阵列级存储置备的环境的 VDI 存储抽象相匹配。

注: XenDesktop 不支持 StorageLink SR。

StorageLink SR 创建方法

创建 StorageLink SR 的方法包括以下两种：使用 StorageLink 创建卷（默认）或者提前创建卷。 使用 StorageLink 创建 SR 的默认方法可能并非在所有环境中都最优。

StorageLink 创建卷（默认）
使用 StorageLink 创建 SR 的标准（默认）方法是，在 SR 创建向导中选择聚合，然后使用 StorageLink 自动为您创建卷和 LUN。 采用这种方法时，每个 VDI 都会获得唯一卷中的一个 LUN。 但是，如果要在环境中创建多个 VDI，这种方法可能并不理想，因为您会创建多个卷。 某些存储供应商对每个存储阵列上卷的数量建议了上限。 同样，使用 StorageLink 创建 SR 时，卷名称由系统自动生成，因此这些名称并不易读或有意义，这样会使管理复杂化。 另外，采用这种方法时，您不能使用重复数据删除减少卷中通用数据（例如操作系统或应用程序）占用的空间。
预先创建的卷
使用 StorageLink 创建 SR 的最佳做法是，通过在 XenCenter SR 向导中选择“全部显示”按钮指定之前创建的卷。 如果采用这种方法，每个虚拟磁盘都会获得一个 LUN。但是，不会出现多个名称无意义的卷。
使用 StorageLink SR 向导创建 SR 时指定之前创建的卷可以简化卷的管理。 在此情形中，每个 VDI 将在选定的卷中获得 LUN。 但是，您不会拥有过多并且可能无法管理的卷（即，一个卷对应一个 VDI）。 使用此方法，您可以创建大量 VDI。 您还可以为这些卷创建更有意义的用户友好型名称，而不使用自动生成的名称。 此方法还可提供更加高效的存储，因为它支持您使用重复数据删除，原因在于共享通用数据（如相同的操作系统或应用程序）的虚拟磁盘映像可能存储在同一个卷中。

为 NetApp 阵列创建 StorageLink SR

StorageLink 创建 SR（以及关联的 LUN 和卷）时，StorageLink 将自动为 Linux 操作系统创建发起程序组。 不建议为其他操作系统手动配置发起程序组。

要使用 StorageLink 创建光纤通道 SR，您应当在 NetApp 存储控制器的初始发现阶段具有存储的 iSCSI 许可证，或者应当运行 ONTAP 8.1。 如果这两种方法都不适用，请按照创建新 SR 中的说明，采用标准 SR 创建过程（不使用 StorageLink）创建 SR。

注: 要使用 StorageLink 连接到 NetApp 存储阵列，在使用 XenCenter 的“新建 SR”向导之前，您必须在存储阵列上启用 httpd。

创建 StorageLink SR

注: 如以下所示，在 XenCenter 中配置 Storagelink（Dell EqualLogic 和 NetApp）SR 的操作过程适用于运行 XenServer 6.0 或更高版本的服务器。
  1. 打开新建存储库向导：单击工具栏上的新建存储库。

    或者：

    • 在所选池或服务器的存储选项卡上，单击新建 SR。
    • 在存储菜单上，单击新建 SR。
    • 在资源窗格中，选择服务器或池，单击鼠标右键，然后单击快捷菜单上的新建 SR。
  2. 选择 StorageLink 技术作为物理存储类型，然后单击下一步。
  3. 在名称页面上，输入新 SR 的名称。 默认情况下，向导将为该 SR 自动生成一个说明，其中包括您在执行该向导的过程中所选配置选项的摘要。 要输入自己的说明，请清除自动生成说明复选框并在说明框中键入说明。

    单击下一步继续操作。

  4. 在存储适配器页面上，选择一种可用的存储系统适配器，然后单击下一步继续操作。
  5. 在存储系统页面上，选择将为该 SR 托管存储的存储系统：
    1. 在阵列目标框中，输入阵列管理控制台的主机名或 IP 地址。
    2. 在凭据下，输入要用来连接阵列管理控制台的用户名和密码。
    3. 单击检测，以在目标阵列中扫描存储系统。 检测完毕后，从存储系统列表中选择一个存储系统，然后单击下一步继续操作。
  6. 在设置页面上，定义 SR 设置；每个新 SR 的可用设置集取决于存储系统供应商/型号以及所选存储池的配置。
    存储池 | 确定指定存储系统内用于分配存储的存储池。 对于某些类型的存储系统，可以使用“全部显示”复选框在此处列出所有存储池
    RAID 类型 | 选择存储阵列支持的、用于 SR 的 RAID 等级
    置备类型 | 设置置备类型（默认值密集，或精简）
    置备选项 | 设置置备选项（例如，重复数据删除）
    协议 | 设置用来将托管服务器连接到存储的存储协议（“iSCSI”、“光纤通道”或“自动”供系统选择）。
    使用 CHAP 身份验证 | 如果服务器配置为使用 CHAP 身份验证方式，请选中该复选框并填写要使用的用户名和密码
  7. 单击完成，以完成新 StorageLink SR 的配置并关闭该向导。

使用 StorageLink 为光纤通道创建 SR 和 LUN

  1. 在 XenCenter 的资源窗格中，在池上单击鼠标右键，然后选择新建 SR。
  2. 选择 StorageLink 技术，然后单击下一步。
  3. 在名称页面上为 SR 输入有意义的名称，然后单击下一步。
  4. 在存储适配器页面上选择 NetApp/IBM N 系列存储适配器，然后单击下一步。
  5. 在存储系统页面上，执行以下操作：
    1. 在阵列目标框中，输入存储控制器的 IP 地址。 StorageLink 最初通过 IP 与存储进行通信。
    2. 在凭据部分，输入存储的用户名和密码，然后单击检测。
  6. 在存储系统框中显示 NetApp 控制器之后，单击下一步。
  7. 在设置页面上，指定配置 LUN 的位置和方式：
    1. 从存储池框中，选择要从中创建 LUN 的聚合。
      注: NetApp 不建议在 aggr0 聚合中创建 LUN，因为该聚合要为系统文件预留。
    2. 在 RAID 类型框中，选择希望存储格式化 LUN 所采用的 RAID 级别。 RAID6 相当于 NetApp 的 RAID-DP RAID 类型。
    3. 在置备类型框中，选择“密集置备”或“精简置备”。 如果希望存储根据使用情况分配空间，请选中“精简置备”复选框。
    4. 在置备选项框中，选择无或重复数据删除。
    5. 在协议框中，选择光纤通道。
  8. 单击完成创建 SR 和 LUN。 StorageLink 创建 SR 和 LUN 之后，SR 将显示在资源窗格中。


ISO 存储

这种类型的 SR 对于创建共享 ISO 库（例如，VM 安装映像）非常有用。 系统提供了两种 ISO SR 类型，来处理以 ISO 格式文件存储的 CD 映像：
  • NFS ISO SR 类型处理以 ISO 格式文件存储且作为 NFS 共享提供的 CD 映像。
  • CIFS ISO SR 类型处理以 ISO 格式文件存储且作为 Windows (CIFS) 共享提供的 CD 映像。

配置新 ISO SR

  1. 打开新建存储库向导：单击工具栏上的新建存储库。
  2. 在 ISO 库下，选择 NFS ISO 或 CIFS ISO 作为存储类型，然后单击下一步。
  3. 在名称页面上，输入新 SR 的名称。 默认情况下，向导将为该 SR 自动生成一个说明，其中包括您在执行该向导的过程中所选配置选项的摘要。 要输入自己的说明，请清除自动生成说明复选框并在说明框中键入说明。

    单击下一步继续操作。

  4. 在位置页面上，指定 ISO 存储目标的详细信息：
    共享名称 | 例如，server:/ShareName (NFS) 或 \\server\ShareName (CIFS)，其中 server 是服务器计算机的 DNS 名称或 IP 地址，ShareName 是文件夹或文件名。
    使用其他用户名 | （仅限 CIFS 共享）如果要使用其他用户名连接 CIFS 服务器，请选中此复选框，然后输入您的登录用户名和密码。
  5. 单击完成，以完成新 SR 的配置并关闭该向导。


删除 SR

通过 XenCenter，可以临时或永久删除存储库：
  • 分离。 分离存储库时，存储设备与池或服务器之间的关联将会断开，存储库的虚拟磁盘将变得无法访问。 虚拟磁盘的内容和虚拟机用来访问虚拟磁盘的元数据信息将会保留。 需要临时将存储库置于脱机状态（例如，为了进行维护）时，可以使用分离。 已分离的 SR 随后可以重新连接；请参阅重新连接 SR。
  • 忘记。 忘记某个 SR 时，该 SR 上虚拟磁盘的内容将会保留，但用来将虚拟机连接到其中的虚拟磁盘的信息将永久删除。 该 SR 将从资源窗格中删除。

    “忘记”操作无法撤消。

  • 销毁。 销毁 SR 会永久删除 SR 的内容，并将 SR 从资源窗格中删除。

    “销毁”操作无法撤消。 有关如何销毁 SR 的信息，请参阅《XenServer 管理员指南》。

注: 如果存储库包含当前正在运行的虚拟机的虚拟磁盘，则您不能将其删除。

分离存储库

  1. 在资源窗格中选择 SR，然后单击存储选项卡。
  2. 注意当前连接到任何虚拟机的虚拟磁盘。
  3. 将虚拟磁盘与虚拟机分离。 有关详细信息，请参阅分离虚拟磁盘。
  4. 在资源窗格中选择 SR，然后执行以下操作之一：
    • 单击鼠标右键，然后在资源窗格快捷菜单中单击分离。
    • 在存储菜单上，单击分离。
  5. 单击是确认。

忘记存储库

在尝试忘记 SR 之前，必须分离某些类型的存储库，例如 iSCSI。
重要:

SR 忘记操作无法撤消。 用来将 VM 连接到 SR 上虚拟磁盘的信息将永久删除。

要忘记 SR，请执行以下步骤：

  1. 在资源窗格中选择 SR，然后执行以下操作之一：
    • 单击鼠标右键，然后在资源窗格快捷菜单中单击忘记。
    • 在存储菜单上，单击忘记。
  2. 单击是，忘记进行确认。


重新连接 SR

已分离的存储设备与任何池或服务器都没有关联，但是存储在其中的数据都将保留。 将存储库重新连接到托管服务器时，需要按照添加新存储库时所用的方式提供存储配置信息。

重新连接已分离的 SR

  1. 在资源窗格中选择已分离的 SR，然后执行以下操作之一：
    • 单击鼠标右键，然后在资源窗格快捷菜单上单击重新连接存储库。
    • 在存储菜单上，单击重新连接存储库。
  2. 按照添加新存储库时所用的方式输入所需的配置信息。 请参阅：
    • NFS VHD 存储
    • 软件 iSCSI 存储
    • 硬件 HBA 存储
    • StorageLink 存储
    • ISO 存储
  3. 单击完成，以完成 SR 的配置并关闭该向导。


存储多路径

系统为光纤通道和 iSCSI 存储库提供动态多路径支持。 默认情况下，多路径功能采用轮询模式的负载平衡，因此在正常操作期间，两个路由通道上都具有活动通信。 在 XenCenter 中，可以通过服务器属性对话框上的多路径选项卡启用和禁用存储多路径功能。

启用多路径前：

  • 确认存储服务器上提供了多个可用目标。
  • 必须将服务器置于维护模式；这样可以确保在进行更改前迁移正在运行的、其虚拟磁盘在受影响存储库中的所有虚拟机。
  • 必须在池中的每个主机上配置多路径。 对于每个主机上相应的 NIC，所有线路连接和子网配置（对于 iSCSI）必须相符。 （例如，必须将所有 NIC 3 配置为使用同一子网。 有关详细信息，请参阅配置 IP 地址。

有关详细深入的多路径信息，请参阅《配置 XenServer 的 iSCSI 多路径支持指南》和《XenServer 管理员指南》。

启用多路径

  1. 在资源窗格中，选择服务器，然后将其置于维护模式。 在 XenCenter 迁移任何活动虚拟机和拔出现有存储时，会出现短暂的延迟；如果服务器是池主服务器，在分配新的池主服务器时，它将暂时断开连接并从“资源”窗格中消失。 当该服务器以 [image] 图标重新出现在资源窗格中时，请继续执行下一步操作。
  2. 在常规选项卡上，单击属性，然后单击多路径选项卡。
  3. 要启用多路径，请选中在此服务器上启用多路径复选框。 要禁用多路径，请清除该复选框。
  4. 单击确定，以应用新设置并关闭该对话框。 在 XenCenter 保存新的存储配置时，会出现短暂的延迟。
  5. 使服务器退出维护模式：在资源窗格中选择该服务器，单击鼠标右键，然后单击退出维护模式。


回收释放的空间

XenCenter 中的回收释放的空间选项允许您在由存储阵列精简置备的 LUN 上释放一些未使用的块（例如 SR 中已删除的虚拟磁盘）。 释放后，回收的空间随后可由该阵列重新使用。 回收释放的空间操作只适用于在阵列上精简置备的基于 LVM 的 SR（即 iSCSI、光纤通道或本地 LVM）。 此功能在基于文件的 SR（例如 NFS 和 Ext3）上并未启用，因为这些 SR 类型不需要执行手动空间回收操作。

回收释放的空间：

  1. 选择基础结构视图，然后单击包含 SR 的主机或池。
  2. 单击存储选项卡。
  3. 从列表中选择该 SR，然后单击回收释放的空间。 注意：回收释放的空间是一项密集型操作，可能会影响存储阵列的性能。 您只应在阵列需要回收空间时才执行此操作。 Citrix 建议您将此项工作安排在非阵列需求高峰期进行。
  4. 单击是确认该操作。 要查看此操作的状态，请单击通知，然后单击事件。


实时 LUN 扩展

为了满足容量要求，可能需要为存储阵列添加容量，以增加为 XenServer 主机置备的 LUN 大小。 实时 LUN 扩展允许您无需分离存储库 (SR) 或使池中的主机或虚拟机脱机，即可增加 LUN 的大小，并使用新获得的空间。 软件 iSCSI 和硬件 HBA SR 类型支持此功能。

警告: 无法收缩或截断 LUN。 减小存储阵列中的 LUN 大小可能导致数据丢失。

要扩展 LUN 的大小，需要：

  1. 向存储阵列添加额外的存储。
  2. 选择基础架构视图，然后在该 SR 上单击。
  3. 单击“属性”窗格中的存储选项卡。
  4. 单击重新扫描。 此操作会重新扫描 SR，之后将添加任何额外容量并使其可用。


更改 SR 属性

通过属性对话框，您可以修改 SR 的详细信息并对其进行有效地管理（通过使用文件夹、标记、自定义字段等对资源进行组织）。此外，还可以通过该对话框配置存储吞吐量超过特定限制时发出警报。

要查看存储库的详细信息，请在资源窗格中选择服务器或池，然后单击存储选项卡。 将显示有关本地存储库和共享存储库的信息，其中包括 SR 的名称、说明、存储类型、使用情况和大小。 从列表中选择 SR，然后单击属性。

常规

在“常规”选项卡上，可以更改 SR 的名称和说明并管理 SR 的文件夹和标记：

  • 要更改 SR 的名称，请在名称框中输入新名称。
  • 要更改其说明，请在说明框中输入新文本。
  • 要将 SR 放入文件夹中或者将其移至其他文件夹中，请单击“文件夹”框中的“更改”，然后选择文件夹。 有关使用文件夹的详细信息，请参阅使用文件夹。
  • 要对 SR 进行标记或取消标记，以及创建标记或删除标记，请参阅使用标记。

自定义字段

可以使用“自定义字段”定义或修改有关 SR 的附加信息。 该选项卡可帮助您搜索和有效地组织存储库。 有关如何为托管资源指定自定义字段的信息，请参阅使用自定义字段。

警报

可以使用“警报”选项卡来配置物理块设备 (PBD) 上的总读写存储吞吐量活动超过指定限制时发出警报。 选中生成存储吞吐量警报复选框并设置触发警报的存储吞吐量和时间阈值。

注: 物理块设备 (PBD) 代表特定 XenServer 主机与连接的 SR 之间的接口。 当 PBD 上的总读/写 SR 吞吐量活动超过您指定的阈值时，与 PBD 连接的主机上将生成警报。 与其他主机警报不同，此警报必须在相关 SR 上进行配置。


升级旧 SR

自 XenServer 5.5 起，LVM 存储库开始采用 Microsoft 的 VHD 技术，支持快速克隆和快照功能。

在 XenCenter 中，通过 XenServer xe 命令行接口 (CLI)，可以将在早期版本的 XenServer 中创建的 LVM 存储库快速而简便地升级到 LVHD 格式。 在常规和搜索选项卡中，可以升级的 SR 将以该 SR 需要升级消息进行标记。

请注意，存储升级操作无法撤消。

将 LVM 存储升级到 LVHD 格式

选择 SR 并执行以下操作之一：

  • 在资源窗格中，单击鼠标右键，然后选择快捷菜单上的升级存储库。
  • 在存储菜单中选择升级。
  • 单击常规和搜索选项卡上的该 SR 需要升级消息。


创建 VM

主题

  • 关于 VM 和模板
  • 创建新 VM（新建 VM 向导）
    • 模板和 BIOS 选项
    • VM 名称和说明
    • 操作系统安装介质
    • 主服务器
    • CPU 和内存配置
    • 虚拟磁盘配置
    • 配置虚拟网络接口
    • 完成新 VM 的创建
  • 快速（无人值守）创建 VM
  • 创建新模板
  • 复制 VM 和模板


关于 VM 和模板

虚拟机 (VM) 是在宿主物理计算机上运行的软件容器（有时称为“来宾”），其行为与物理计算机本身一样。 VM 由操作系统、CPU、内存 (RAM)、网络资源和软件应用程序组成。

模板是封装到文件中的虚拟机，通过模板可以快速部署新的 VM。 每个模板都包含安装元数据，即创建具有特定来宾操作系统、最佳存储、CPU、内存和虚拟网络配置的新 VM 所需的设置信息。

在 XenCenter 中可以通过若干不同的方式创建新 VM：

  • 新建 VM 向导将指导您逐步完成从模板或快照创建新 VM 的过程，允许您配置操作系统、CPU、存储、网络连接和其他参数。
  • 您可以绕过新建 VM 向导，基于可指定所有必需的 VM 配置参数的自定义 VM 模板创建“即时 VM”。 您只需选择 XenCenter 中预先配置的模板，然后单击鼠标右键并单击从模板创建即时 VM。这种无人值守的 VM 安装模式对于部署大量相同的 VM 非常有用。
  • 您可以复制（或“克隆”）现有 VM。
  • 可以导入先前导出的 VM。

XenServer PV 驱动程序 - XenServer Tools

XenServer 环境中的 VM 可以完全虚拟化 (HVM) 或半虚拟化：

  • 在 HVM（硬件辅助虚拟化或硬件虚拟机）模式下，VM 完全虚拟化，可以在支持虚拟化的硬件上以接近本机处理器的速度运行，而无需对来宾操作系统进行任何修改。
  • 在半虚拟化（非 HVM）模式下，来宾操作系统经过调整和优化，可以在虚拟环境中运行，而不依赖于基础处理器的能力。 这种模式具有更佳的性能和更高的灵活性。

半虚拟化 (PV) 驱动程序适用于 Windows 和 Linux VM，能够增强磁盘和网络性能。 这些驱动程序在 XenServer Tools 软件包中提供，应安装到所有的新建 VM 上，请参阅安装 XenServer Tools。 VM 迁移和历史性能数据跟踪等 XenServer 功能只能在安装 XenServer Tools 的 VM 上使用。

在之前的 XenServer 版本中，所有受支持的 Linux 发行版都在 PV 模式下运行，所有受支持的 Windows 版本在 HVM 模式下运行。 在 XenServer 6.5 中，以下新增的受支持 Linux 发行版将在 HVM 模式下运行：

  • RHEL 7
  • CentOS 7
  • Oracle Linux 7
  • Ubuntu 14.04

这些 VM 可以利用新处理器中的 x86 虚拟容器技术来提高性能。 从这些 VM 访问网络和存储将使用内核中内置的驱动程序在 PV 模式下运行。 有关将现有 Linux VM 升级到 HVM 模式下现在支持的版本的信息，请参阅《XenServer 虚拟机用户指南》中的更新 Linux 内核和来宾实用程序部分。

使用模板

XenServer 提供了若干不同的模板，这些模板中包含在新 VM 上安装特定来宾操作系统时所需的所有配置设置。 您还可以创建自己的自定义模板并为其配置相应的来宾操作系统、内存、CPU、存储和网络设置，可以使用这些模板创建新的 VM。 有关本版本支持的模板/操作系统的列表以及 Windows 和 Linux 上不同安装机制的详细信息，请参阅《XenServer 虚拟机用户指南》。

您可以在资源窗格中查看产品随附的 XenServer 模板以及自己创建的任何自定义模板。

  • XenServer 模板图标 XenServer 模板
  • 自定义模板图标 自定义模板

您可以控制是否在“资源”窗格中显示 XenServer 模板和自定义模板：

  • 在 XenCenter 的导航窗格中，单击基础结构按钮。

    此操作将在“资源”窗格中显示托管资源的树视图。

  • 要显示标准 XenServer VM 模板，请在视图菜单上单击 XenServer 模板；要隐藏 XenServer 模板，请再次单击以删除复选标记。
  • 要显示自定义 VM 模板，请在视图菜单上单击自定义模板；要隐藏自定义模板，请再次单击以删除复选标记。


创建新 VM

新建 VM 向导将逐步引导您完成创建新虚拟机 (VM) 的过程。 要启动新建 VM 向导，在工具栏上单击新建 VM。

或者执行以下操作之一：

  • 按 Ctrl+N。
  • 在 VM 菜单上，单击新建 VM。
  • 在资源窗格中选择一个服务器，单击鼠标右键，然后在快捷菜单中单击新建 VM。

使用向导，您可以完全以您希望的方式配置新的 VM，调整 CPU、存储和网络资源等各种配置参数。 根据您在向导第一页选择的 VM 模板，您在后面几页看到的 VM 配置选项略有不同，显示的安装选项针对每个来宾操作系统进行了定制。 单击帮助，或在任一向导页面按 F1，以了解之后要执行的操作的详细信息。

在实现了基于角色的访问控制 (RBAC) 的 XenServer 环境中，新建 VM 向导启动时将执行检查，以确保您的角色具有允许您创建新 VM 的足够权限。 如果您的 RBAC 角色没有足够的权限，例如 VM 操作员或只读角色，您将无法继续创建 VM。 有关详细信息，请参阅 RBAC 概述。

VM 创建步骤的概述

“新建 VM”向导将引导您完成以下创建新 VM 的步骤：

  1. 选择一个模板。

    第一步是选择 VM 模板。 模板包含创建具有特定来宾操作系统、最佳存储、CPU、内存和虚拟网络配置的新 VM 所需的设置信息。 系统提供了很多不同的模板，您也可以添加自己的自定义模板。 有关此步骤的详细信息，请参阅模板和 BIOS 选项。

  2. 为新的 VM 命名。

    然后给新 VM 命名，也可以提供一个说明。 系统不会检查 VM 名称在 XenCenter 中的唯一性，因此如果您为它们指定一个有意义且好记的名称，可以更轻松地管理不同的 VM。 有关此步骤的详细信息，请参阅 VM 名称和说明。

  3. 指定操作系统安装介质。

    过程的第三步是指定操作系统安装介质的类型和位置。 Windows 操作系统可以从 ISO 库、物理 DVD/CD 驱动器中的安装介质（CD 或 DVD-ROM）或网络引导上安装。 Linux 操作系统可以从网络安装存储库安装。 有关此步骤的详细信息，请参阅操作系统安装介质。

  4. 选择一个主服务器。

    这是可选步骤，但是您可以为新的 VM 选择主服务器。 如有可能，XenServer 将一直尝试在该指定主服务器上启动 VM。 有关此步骤的详细信息，请参阅主服务器。

  5. 配置 CPU 和内存。

    接下来，您可以为新的 VM 分配虚拟 CPU (vCPU)，指定拓扑（也就是指定您希望向 vCPU 显示的每个插槽的核心数量），并分配内存。 这些设置可以稍后调整，即创建新的 VM 后。 有关此步骤的详细信息，请参阅 CPU 和内存配置。

  6. 分配虚拟图形处理器 (vGPU)。
    注: vGPU 是一项仅在 XenServer Enterprise、XenServer Desktop+ 和 XenServer Desktop Edition 中提供的高级功能。 有关 XenServer 6.5 许可的信息，请参阅许可概述 (XenServer 6.5)。 要购买 XenServer 许可证，请单击此处。

    如果池中的 XenServer 主机获得了 XenServer Enterprise、XenServer Desktop+ 和 XenServer Desktop Edition 的许可，并且您的服务器启用了 GPU，“新建 VM”向导会提示您将 vGPU 分配给 VM。 这使 VM 能够使用 GPU 的处理能力，为 CAD/CAM、GIS 和医学成像应用等高端 3D 专业图形应用提供更好的支持。 有关此步骤的详细信息，请参阅 虚拟 GPU。

  7. 配置存储。

    下一步是为新 VM 配置一些虚拟磁盘。 向导会自动配置至少一个虚拟磁盘，您选择的模板可能会包含更多的虚拟磁盘。 有关此步骤的详细信息，请参阅虚拟磁盘配置。

  8. 配置网络连接。

    置备新 VM 的最后一步是配置网络连接。 每个 VM 上最多可以配置 4 个虚拟网络接口。 有关此步骤的详细信息，请参阅配置虚拟网络接口。

  9. 完成新 VM 的创建。

    在向导的最后一页，您可以检查您所选的全部配置选项。 选中“Start VM automatically”（自动启动 VM）复选框，可以使新 VM 在创建完成后自动启动。


VM 模板和 BIOS 选项

XenServer 随附很多不同的 VM 模板，并且可以通过不同的方法使用它们来创建新的 VM。 每个模板都包含安装元数据，即创建具有特定来宾操作系统、最佳存储、CPU、内存和虚拟网络配置的新 VM 所需的设置信息。

有关每个 XenServer 版本上受支持的来宾操作系统的完整列表，请参阅《XenServer 虚拟机用户指南》。

您还可以创建配置有相应来宾操作系统、内存、CPU、存储和网络设置的自定义模板，并且使用它们来创建新的 VM；请参阅创建新的模板。

选择 BIOS 选项

XenServer VM 可以具有通用 BIOS 或特定 BIOS：

  • 具有通用 BIOS：VM 具有通用 XenServer BIOS 字符串；
  • 具有定制 BIOS：VM 具有池中特定服务器的 BIOS 字符串的副本；
  • 没有 BIOS 字符串：如果 VM 在首次启动时未设置 BIOS 字符串，则会向该 VM 中插入标准的 XenServer BIOS 字符串，该 VM 将具有通用 BIOS。

使用新建 VM 向导创建新的 VM 时，您可以从相同池的 OEM 服务器中将 BIOS 字符串复制到新 VM。 如果需要，稍后您可以将 Windows 的分销商可选套件（BIOS 锁定）OEM 版安装在 VM 上。 从其复制 BIOS 字符串的 OEM 服务器将被指定为新的 VM 的主服务器。

具有定制 BIOS 的 VM 可以迁移、导入和导出至具有相同 BIOS 字符串和不同 BIOS 字符串的服务器上。

重要: 任何 EULA 都规定了如何使用安装的所有 BIOS 锁定操作系统，您必须遵守其中的规定。


VM 名称和说明

在名称对话框中输入新 VM 的名称。 可以根据自己的喜好选择任何名称，但通常最好使用描述性的名称。 尽管建议您避免为多个 VM 使用相同的名称，但并不是必须要这样做，XenCenter 不会针对 VM 名称实施唯一性约束。

如果您为不同的 VM 提供一个有意义且好记的名称，可以更轻松地管理这些 VM，例如一个描述 VM 操作系统（Windows 7 64 位 JA）、应用程序软件 (Citrix XenServer Web Self Service v1.0 (Build 9057)) 或角色 (db-server、Outlook Server、Windows 7 Test) 的名称，有助于您以后进行识别。

对于包含空格的名称，不必使用引号。

您也可以在向导的这一页上提供 VM 的更详细说明（可选）。


操作系统安装介质

新建 VM 向导中安装介质页面上的可用操作系统安装介质选项取决于在向导第一页上所选的操作系统/模板。

选项 说明 模板
从 ISO 库或 DVD 驱动器安装 选择从 ISO 库或 DVD 驱动器安装，并从下拉列表中选择 ISO 映像或 DVD 驱动器。

如果您要使用的 ISO 映像未在此处列出，可以单击新建 ISO 库，并使用新建存储库向导创建新的 ISO SR。 创建新的 ISO SR 之后，您可以从此处的可用 ISO 库列表中选择。

请注意，如果此处未列出 ISO 映像，您需要通过创建外部 NFS 或 SMB/CIFS 共享目录将 ISO 提供给服务器，如《XenServer 虚拟机用户指南》中所述。

Windows 和 Linux
从网络启动 选择此选项以使用适用于 Windows 的 PXE/网络引导和 Other install media（其他安装介质）模板。

选择此选项可将网络置于新 VM 的引导顺序的顶部。

Windows
从 URL 安装 CentOS、SUSE Linux Enterprise Server 和 Red Hat Linux 操作系统可以从网络安装存储库中安装。 选择从 URL 安装并输入 URL，URL 必须包含采用以下格式的服务器 IP 地址和存储库路径：
nfs://server/path
ftp://server/path
http://server/path

例如：nfs://10.10.32.10/SLES10，其中 10.10.32.10 是 NFS 服务器的 IP，/SLES10 是安装存储库的位置。

如有需要，还可以选择性地提供其他操作系统引导参数。

Linux


主服务器

主服务器是可以为池中的 VM 提供资源的服务器。 为 VM 指定了主服务器时，如有可能，XenServer 将一直尝试在该服务器上启动 VM，如果此操作不可行，将自动选择同一池中的备用服务器。

  • 要在新建 VM 向导中为 VM 指定主服务器，单击 Use this server as the VM's home server（使用此服务器作为 VM 的主服务器）并从列表中选择一个服务器。
  • 如果不想指定主服务器，单击 Automatically select a home server with available resources（使用可用资源自动选择主服务器）；VM 将使用最合适的可用服务器上的资源。

如果您正在创建 BIOS 定制 VM，从其复制 BIOS 字符的 OEM 服务器将被自动选为新 VM 的主服务器。

您可以在“VM's Properties”（VM 的属性）对话框中更改 VM 的主服务器配置；请参阅更改 VM 属性。

Workload Balancing (WLB) 注意事项

在启用 Workload Balancing (WLB) 的池中，指定的主服务器将不用于启动、重新启动、恢复或迁移 VM， 而是由 WLB 分析 XenServer 资源池指标并提供优化建议，从而为 VM 指定最佳服务器。


VM CPU 和内存分配

当您创建新的 VM 时，您可以分配虚拟 CPU，指定您希望向 VM 的 vCPU 显示的每插槽核心数，并为新 VM 设置初始内存资源。 在新建 VM 后，可以随时更改设置。

选项 说明
vCPU 的数量 输入您希望分配给新 VM 的虚拟 CPU (vCPU) 的数量。

为确保新 VM 能够发挥最佳性能，您分配给 VM 的 vCPU 的数量不应超过服务器上物理 CPU 的数量。

注: 如果需要，也可以在以后更改此值。 有关更多信息，请参阅更改 VM 属性：CPU。 有关 VM 上所支持 vCPU 的最大数量的信息，请参阅《XenServer 配置限制》文档。
拓扑 指定 vCPU 的拓扑。

默认情况下，XenServer 为每个 vCPU 的每个插槽分配一个核心。 例如，分配 4 个 vCPU 将显示为 4 个插槽，每个插槽 1 个核心。 单击拓扑下拉列表，更改此设置并从列表中选择一个选项。

注: 每插槽核心数的设置取决于服务器上的插槽数以及安装的操作系统。 一些操作系统对 CPU 的数量有限制。 在设置此选项时，您应遵从操作系统的要求。
内存 输入要分配给 VM 的内存量。

根据来宾操作系统的类型，XenServer 模板提供典型的 VM 配置并设置了合理的内存默认值。 在决定最初为新 VM 分配的内存量时，还应考虑以下注意事项：

  • 将在 VM 上运行的应用程序种类。
  • 将使用相同内存资源的其他虚拟机。
  • 服务器上将与虚拟机一起运行的应用程序。

创建新 VM 后，可以在 VM 的内存选项卡上调整内存分配量。在该选项卡上，还可以启用动态内存控制 (DMC)，以允许在同一个池中的各 VM 之间动态地重新分配内存。 有关详细信息，请参阅配置 VM 内存文件夹中的帮助主题。


虚拟 GPU

XenCenter 使您能够在创建 VM 期间为新的 VM 指派分配 GPU (vGPU)。 这使 VM 能够使用 GPU 的处理能力，为 CAD/CAM、GIS 和医学成像应用等高端 3D 专业图形应用提供更好的支持。

注: vGPU 是一项仅在 XenServer Enterprise、XenServer Desktop+ 和 XenServer Desktop Edition 中提供的高级功能。 有关 XenServer 6.5 许可的信息，请参阅许可概述 (XenServer 6.5)。 要购买 XenServer 许可证，请单击此处。

GPU 类型下拉列表显示可用的 GPU、支持的 vGPU 类型、分辨率和每 vGPU 的最大显示屏数量。 从列表中选择 vGPU 的类型，为 VM 分配一个特定的 vGPU。 或者，选择在整个 GPU 中直通，允许 VM 使用 GPU 的全部处理能力。

注: 如果需要，可在稍后修改 GPU 或 vGPU 选择。 有关详细信息，请参阅更改 VM 属性。


虚拟存储配置

使用新建 VM 向导创建的虚拟机至少有一个虚拟磁盘，选定的 VM 模板也可能包括其他虚拟磁盘。 VM 最多可以有 7 个虚拟磁盘以及 1 个虚拟 CD-ROM。

您可以从新建 VM 向导中的存储页面添加更多虚拟磁盘、删除虚拟磁盘并更改虚拟磁盘的大小和位置。

选项 | 说明
使用这些虚拟磁盘 选择此选项以使用列出的虚拟磁盘。
  • 要添加更多虚拟磁盘，请单击添加并指定名称、大小和位置 (SR)；请参阅添加虚拟磁盘。
  • 要删除虚拟磁盘，请单击删除。
  • 要将虚拟磁盘移至不同的 SR，请在列表中将其选中并单击属性，然后从位置列表中选择 SR。
  • 要增大或缩小虚拟磁盘，请在列表中将其选中并单击属性，然后在大小框中输入一个新的值。
  • 要更改虚拟磁盘的名称或说明，请在列表中将其选中并单击属性，然后输入新的文本。
使用存储级别的快速磁盘克隆 如果您用来创建新 VM 的模板或快照中的任一虚拟磁盘在同一 SR 上，将出现此复选框。 选中此复选框可使用硬件级别的克隆功能，将磁盘从模板/快照复制到新 VM 中。 使用存储级别的快速磁盘克隆可以非常快速地创建新的 VM。

此选项仅在使用远程 NFS 共享存储或基于 VHD 的本地存储的 VM 上受支持。
创建通过网络启动的无盘 VM | 如果您之前在向导的 OS Installation media（操作系统安装介质）页面上选择了从网络启动选项，可以选择此选项使新 VM 成为无盘 VM。


虚拟网络配置

您可以从新建 VM 向导的网络连接页面配置最多 4 个虚拟网络接口。 要配置 4 个以上接口，请在创建后转至 VM 的网络连接选项卡并从中添加接口。

默认情况下，一个自动创建的随机 MAC 地址将用于所有虚拟网络接口。 要输入不同的 MAC 地址，请单击属性，并使用 aa:bb:cc:dd:ee:ff 格式的十六进制字符，在虚拟接口属性对话框中输入新的地址。

  • 要添加新的虚拟网络接口，请单击添加。
  • 要删除虚拟网络接口，请在列表中将其选中，然后单击删除。
  • 要更改虚拟磁盘的物理网络、MAC 地址或服务质量 (QoS) 优先级，请将其选中并单击属性。 请参阅更改虚拟网络接口属性

如有需要，您稍后可以使用“网络连接”选项卡更改 VM 的虚拟网络连接配置；请参阅配置 VM 网络连接文件夹中的“帮助”主题。


完成新 VM 的创建

在新建 VM 向导的最后一页上，选中自动启动 VM 复选框，可确保新 VM 在安装之后立即启动。

创建新 VM 的过程需要花费一些时间，具体用时取决于模板的大小以及目标服务器与 XenCenter 之间的网络连接速度和带宽。 您可以在 XenCenter 状态栏和通知的事件视图上查看进度。

注: 在创建新的 VM 后，您应安装 XenServer Tools，以确保获得最优的 I/O 性能：请参阅安装 XenServer Tools。


快速（无人值守）创建 VM

要基于自定义 VM 模板创建多个相同 VM 的用户可以绕过新建 VM 向导，而直接使用 XenCenter 中的快速创建功能：
  1. 创建一个自定义 VM 模板，该模板为新 VM 提供所需的全部配置参数。 请参阅创建新模板。
  2. 在资源窗格中选择该自定义模板，在模板菜单上指向根据所选项创建 VM，然后单击快速创建。 或者，在资源窗格中单击鼠标右键，然后单击快捷菜单上的快速创建。
系统随后将使用该模板中指定的所有配置设置创建和置备新 VM。


创建新模板

在 XenCenter 中可以通过多种不同的方式创建新的自定义模板：

  • 通过复制现有模板；请参阅复制 VM 和模板。
  • 通过将现有 VM 转换为新模板。
  • 通过将 VM 快照的副本保存为新模板。
  • 通过导入先前从现有模板或 VM 快照导出的 XVA 文件形式的模板。

将现有 VM 转换为模板

请注意，使用此方法创建新模板时，VM 的磁盘将复制到新模板中，原始 VM 将不再存在。 请注意，当前位于 vApp 中的 VM 不能转换为模板。
  1. 按关闭 VM 中的说明关闭该 VM。
  2. 在资源窗格中选择 VM，单击鼠标右键，然后单击“转换为模板”。
  3. 单击转换进行确认。 可以在 XenCenter 窗口底部的状态栏上以及通知下方的事件视图上查看转换进度。
转换完毕时，该 VM 将从资源窗格中消失，并作为新的自定义模板重新出现。 新的自定义模板随后可以像任何其他模板一样用来创建新的 VM。

将快照副本保存为新模板

  1. 在快照选项卡上，选择快照，单击鼠标右键，然后单击快捷菜单上的从快照创建模板。
  2. 输入新模板的名称，然后单击确定。
成功创建新模板后，它将作为自定义模板显示在资源窗格中以及新建 VM 向导的模板页面上。

从 XVA 文件导入模板

可以使用导入向导来将先前导出为 XVA 文件的 VM 模板和快照导入到 XenCenter 中：在文件菜单上，单击导入，在该向导的第一页上选择包含该模板的 XVA 文件，然后按照从 XVA 导入 VM 的相同步骤操作；请参阅从 XVA 导入 VM。

导入进度将显示在 XenCenter 窗口底部的状态栏中以及通知的事件视图上。 导入过程可能需要一些时间，具体取决于模板的大小以及 XenCenter 与安装模板的服务器之间的网络连接速度和带宽。 当新导入的模板可用时，将作为自定义模板显示在资源窗格中。 新模板与最初导出的模板具有相同的配置属性。 要更改新模板的配置属性，请使用该模板的属性窗口。


复制 VM 和模板

可以通过复制（克隆）现有 VM 或模板来创建新的 VM 和模板。 XenServer 使用完整复制和快速克隆这两种机制来复制 VM 和模板：

  • 完整复制生成 VM 磁盘的完整副本。
  • 快速克隆（写入时复制）仅将修改的数据块写入磁盘，使用硬件级别的克隆功能将现有 VM 中的磁盘复制到新 VM。 只有采用文件作为后端的 VM 才支持此模式。 “写入时复制”旨在节省磁盘空间并实现快速克隆，但会略微降低正常的磁盘性能。

只能在同一个资源池中直接复制 VM。 要将 VM 复制到其他池中的服务器，需要导出 VM，然后再将其导入目标服务器。

复制（克隆）VM

重要: 在复制 Windows VM 前，应使用 Windows 实用程序 sysprep 确保安全 ID (SID) 的唯一性。 如果不先执行建议的系统准备步骤就复制 VM，会导致发生 SID 重复及其他问题。 有关克隆 VM 和运行 sysprep 的说明，请参阅《XenServer 虚拟机用户指南》。
  1. 如果要复制的 VM 是 Windows VM，请按照《XenServer 虚拟机用户指南》中的说明运行 sysprep 实用程序。
  2. 如果该 VM 正在运行，则必须在复制前关闭。
  3. 在资源窗格中选择该 VM，单击 VM 菜单，然后单击复制 VM。
  4. 输入新 VM 的名称和（可选）有意义的说明。
  5. 选择复制模式：快速克隆或完整复制。
  6. 如果选择完整复制作为复制模式，请选择将用来放置所复制的 VM 虚拟磁盘的存储库 (SR)。 如果将 VM 从本地存储移动到共享存储，请确保在此处选择共享 SR。
  7. 单击复制。

复制（克隆）模板

  1. 在资源窗格中选择该模板，单击模板菜单，然后单击复制模板。
  2. 输入新模板的名称和（可选）有意义的说明。
  3. 选择复制模式：快速克隆或完整复制。
  4. 如果选择完整复制作为复制模式，请选择将用来放置所复制的虚拟磁盘的 SR。
  5. 单击复制。


配置 VM

主题

  • 安装 XenServer Tools
  • 配置 VM 内存
    • 关于 VM 内存配置
    • 动态内存控制 (DMC)
    • 配置 DMC
  • 配置 VM 存储
    • 关于虚拟磁盘
    • 添加虚拟磁盘
    • 连接虚拟磁盘
    • 分离虚拟磁盘
    • 移动虚拟磁盘
    • 删除虚拟磁盘
    • 更改虚拟磁盘属性
  • 配置 VM 网络连接
    • 关于虚拟网络接口
    • 添加虚拟网络接口
    • 激活/取消激活虚拟网络接口
    • 删除虚拟网络接口
    • 更改虚拟网络接口属性
  • 更改 VM 属性


安装 XenServer Tools

XenServer Tools 提供了高性能的 Windows 驱动程序和管理代理，增强了 XenServer VM 的磁盘和网络性能。 有关详细信息，请参阅 XenServer PV 驱动程序 - XenServer Tools。

要使用 xe CLI 或 XenCenter，必须在每个虚拟机（Windows 和 Linux）上安装 XenServer Tools，如果不安装这些工具，将会显著降低 VM 的性能。 不安装这些工具的情况下，您将无法执行以下所有操作：

  • 彻底关闭、重新启动或挂起 VM。
  • 在 XenCenter 中查看 VM 性能数据。
  • 迁移正在运行的 VM（通过 XenMotion）。
  • 创建静态快照或带有内存（检查点）的快照，或者还原到快照。
  • 调整运行中的 Linux VM 上的 vCPU 数量（对于 Windows VM，需要重新启动才能使更改生效）。
重要: 不支持在未安装 XenServer Tools 的情况下运行 VM。

确定 VM 上是否安装了 XenServer Tools

可以通过查看 VM 常规选项卡上报告的虚拟化状态，来确定 VM 上是否安装了 XenServer Tools。

  • 已优化(已安装 n.n 版本) - 安装了最新版本的 XenServer Tools。
  • 未安装 XenServer Tools - VM 上当前未安装 XenServer Tools。 可以单击此状态消息，以从 XenServer Tools ISO 安装最新版本。
  • 工具已过期(已安装 x.y 版本) - VM 上安装了早期版本 XenServer 中的旧版 XenServer Tools。 对于 Windows VM，可以通过单击此状态消息，切换到 VM 控制台，加载 Tools ISO 并启动 Tools 安装向导；对于 Linux VM，可以通过单击此状态文本，切换到 VM 控制台并加载 Tools ISO，然后您可以装载 ISO 并手动运行安装程序，如下所述。

在 Windows VM 上安装 XenServer Tools

重要: 请注意，安装 XenServer Tools 会导致虚拟机 CD/DVD 驱动器中的介质弹出。 如果虚拟机的 CD/DVD 驱动器正在使用（例如，正在从 CD 安装操作系统），请不要尝试安装 XenServer Tools。
  1. 在资源窗格中选择 VM，单击鼠标右键，然后单击快捷菜单上的安装 XenServer Tools。 或者，在 VM 菜单上，单击“安装 XenServer Tools”。
  2. 单击消息框上的安装 XenServer Tools 以转至 VM 的控制台并开始进行安装。
  3. 如果针对 VM 的 CD 驱动器启用了自动播放功能，则片刻之后安装过程将自动启动。 如果未启用自动播放功能，请双击 CD 驱动器开始安装 XenServer Tools。
  4. 按照屏幕上的说明操作，并在出现提示时重新启动 VM。

在 Linux VM 上安装 XenServer Tools

  1. 在资源窗格中选择 VM，单击鼠标右键，然后单击快捷菜单上的安装 XenServer Tools。 或者，在 VM 菜单上，单击“安装 XenServer Tools”。
  2. 单击消息框上的安装 XenServer Tools 以转至 VM 的控制台。
  3. 以 root 用户身份将映像装载到 VM 中：
    mount /dev/xvdd /mnt
  4. 以 root 用户身份执行安装脚本：
    /mnt/Linux/install.sh
  5. 如果内核已经升级，或 VM 已从上一版本升级，请立即重新引导 VM。

请注意，连接到 Linux VM 的 CD-ROM 驱动器和 ISO 显示为 /dev/xvdd，而不是 /dev/cdrom。 原因是它们不是真正的 CD-ROM 设备，而是普通设备。 XenCenter 弹出 CD 时，将从 VM 中热拔出该设备，该设备将不再显示。 这与 Windows VM 不同，对于 Windows VM，CD 会保留在 VM 中，但处于空白状态。


配置 VM 内存

主题

  • 关于 VM 内存配置
  • 动态内存控制 (DMC)
  • 配置 DMC


关于 VM 内存配置

首次创建 VM 时，会为其分配固定数量的内存。 要增大 XenServer 环境中物理内存的利用率，可以使用动态内存控制 (DMC)，这是一种能够在 VM 之间动态重新分配内存的内存管理功能。

XenCenter 中的内存选项卡将显示 VM 和服务器中内存的使用率和配置信息。

  • 对于服务器，将显示可用内存总量和当前内存使用率，您可以查看内存在托管 VM 之间的分配情况。
  • 对于 VM，除了当前内存使用率外，还可以查看 VM 的内存配置信息（即，DMC 是否启用、当前动态最小值和最大值），以及编辑 DMC 配置设置。

在内存选项卡上，具有相同内存配置的 VM 将组合在一起，以便您可以方便地查看和配置各 VM 和各组 VM 的内存设置。


动态内存控制 (DMC)

XenServer DMC（有时称为“动态内存优化”、“内存过载”或“内存膨胀”）的工作原理是：自动调整正在运行的 VM 的内存，使分配给每个 VM 的内存量保持在指定的最小内存值与最大内存值之间，确保性能并允许每台服务器具有更大的 VM 密度。

如果不启用 DMC，则当服务器满载时，启动更多 VM 会因“内存不足”错误而失败。 要减少现有 VM 内存分配，为更多 VM 释放空间，您必须编辑每个 VM 的内存分配，然后重新启动 VM。 启用 DMC 之后，即使在服务器满载时，XenServer 仍能通过在 VM 定义的内存范围内自动减少正在运行的 VM 的当前内存分配来尝试回收内存。

动态和静态内存范围

对于每个 VM，可以设置一个动态内存范围，在此范围内，可以添加/删除 VM 的内存而无需重新启动 VM。 可以在 VM 运行期间调整动态范围，而无需重新启动 VM。 XenServer 始终保证为 VM 分配的内存量保持在动态范围内。 例如，如果最小动态内存设置为 512 MB，最大动态内存设置为 1024 MB，则 VM 的动态内存范围 (DMR) 将为 512 - 1024 MB，在此范围内，VM 将正常运行。 通过 DMC，XenServer 可确保始终为每个 VM 分配指定 DMR 范围内的内存量。

如果主机服务器的内存充足，所有运行中的 VM 将获得最大动态内存级别；如果主机的内存不足，所有运行中的 VM 将获得最小动态内存级别。 如果需要在“满载”的服务器上启动新 VM，则正在运行的 VM 会为新 VM 的启动“腾出”自己的内存。 获得所需额外内存的方法是：在现有运行中 VM 的预定义动态范围内按比例腾出内存。

XenServer 支持的许多操作系统不完全支持动态添加或删除内存。 因此，XenServer 必须在 VM 引导时声明 VM 需要占用的最大内存量，以允许来宾操作系统相应调整其页表和其他内存管理结构的大小。 这在 XenServer 中引入了静态内存范围的概念。 在 VM 运行期间无法调整静态内存范围，在下次重新启动 VM 前，动态范围始终限定在静态内存范围内。 请注意，最小静态内存（静态内存范围的下限）是管理员的一项保护措施，其值等于操作系统在 XenServer 上运行所需要的最小内存量。

重要: 静态最低级别设置为每个操作系统支持的级别，因此 Citrix 建议您不要对其进行更改，有关更多详细信息，请参阅《XenServer 管理员指南》。 请将最大静态内存设置为高于最大动态内存，这样设置后，当您以后需要为 VM 分配更多内存时，无需重新启动即可进行分配。

DMC 内存限制

设置 DMC 值时，XenCenter 强制实施以下限制：

  • 最小动态内存值不能低于最小静态内存值。
  • 最小动态内存值不能高于最大动态内存值。
  • 最大动态内存值不能高于最大静态内存值。

可以将 VM 的内存属性更改为满足这些限制条件（需经过验证检查）的任何值。 除了这些限制外，对于特定操作系统，Citrix 仅支持某些 VM 内存配置。详细信息在《XenServer 管理员指南》中介绍。


配置 DMC

启用 DMC

  1. 在资源窗格中选择任一 VM 或服务器，然后单击内存选项卡。
  2. 对于要配置 DMC 的一个或一组 VM，单击相应的编辑按钮。
  3. 对于当前内存配置相同的多个 VM，选择要配置的 VM，然后单击下一步。
  4. 单击自动在此范围内分配内存选项，然后通过使用滑块或直接键入具体值，来设置所需的最大和最小动态内存范围值。
  5. 单击确定，以应用更改并关闭对话框。

禁用 DMC

  1. 在资源窗格中选择任一 VM 或主机服务器，然后单击内存选项卡。
  2. 对于要配置的一个或一组 VM，单击相应的编辑按钮。
  3. 对于当前内存配置相同的多个 VM，选择要配置的 VM，然后单击下一步。
  4. 单击设置固定内存选项并指定要分配的内存量。
  5. 单击确定，以应用更改并关闭对话框。


配置虚拟存储

在资源窗格中选择该 VM，单击存储选项卡，即可查看和更改其虚拟存储设置。

主题：

  • 关于虚拟磁盘
  • 添加虚拟磁盘
  • 连接虚拟磁盘
  • 分离虚拟磁盘
  • 移动虚拟磁盘
  • 删除虚拟磁盘
  • 更改虚拟磁盘属性


关于虚拟磁盘

XenServer VM 上的存储由虚拟磁盘提供。 虚拟磁盘是磁盘上独立于所连接的 VM 而存在的持久对象。 虚拟磁盘存储在 XenServer 存储库 (SR) 上，可以根据需要与相同或不同的 VM 连接、分离和重新连接。 可以在创建 VM 时（使用新建 VM 向导）创建新虚拟磁盘，也可以在创建 VM 后从 VM 的存储选项卡添加新虚拟磁盘。

半虚拟化的 VM（即，安装了 XenServer Tools 的 VM）上的虚拟磁盘可以“热插拔”，即，您不需要先关闭 VM 就可以添加、删除、连接和分离虚拟磁盘。 在 HVM 模式下运行的 VM（即，未安装 XenServer Tools 的 VM）必须先关闭才能执行上述任何操作；为了避免出现这种情况，应在所有 HVM 虚拟机上安装 XenServer Tools。

在 XenCenter 中 VM 的存储选项卡上，可以执行以下操作：

  • 添加新虚拟磁盘。
  • 配置虚拟磁盘 - 更改虚拟磁盘的大小、位置、读/写模式和其他配置参数。
  • 将现有的虚拟磁盘连接到 VM。
  • 分离虚拟磁盘，以保留虚拟磁盘及其中的所有数据。
  • 将虚拟磁盘移动到指定的存储库。
  • 删除虚拟磁盘，从而永久销毁虚拟磁盘及其中存储的任何数据。


添加虚拟磁盘

要添加新虚拟磁盘，请使用添加虚拟磁盘对话框。

重要: 如果 VM 在 HVM 模式（即未安装 XenServer Tools）下运行，则需要先将其关闭，然后才能添加虚拟磁盘；为了避免出现这种情况，应在所有 HVM 虚拟机上安装 XenServer Tools。

过程：

  1. 执行下列任一操作以打开添加虚拟磁盘对话框：
    • 在资源窗格中选择该 VM 或 SR，单击存储选项卡，然后单击添加。
    • 在存储菜单上，单击虚拟磁盘，然后单击新建虚拟磁盘。
    • 在新建 VM 向导的存储页面上，单击添加。
  2. 输入新虚拟磁盘的名称以及可选说明。
  3. 输入新虚拟磁盘的大小。 应确保在用来存储虚拟磁盘的存储库 (SR) 中为新虚拟磁盘留出足够空间。
  4. 选择用来存储新虚拟磁盘的 SR。
  5. 单击创建添加新虚拟磁盘并关闭该对话框。


连接虚拟磁盘

可以通过连接现有虚拟磁盘的方式在 VM 中添加存储。
  1. 在资源窗格中选择该 VM，单击存储选项卡，然后单击连接。 或者，在存储菜单上，单击虚拟磁盘，然后单击连接虚拟磁盘。
  2. 从列表中选择虚拟磁盘。
  3. 要将对虚拟磁盘的访问权限设置为只读，请选中以只读方式连接复选框。 这样做可以防止在多个 VM 访问磁盘时磁盘数据被覆盖或更改，并且允许虚拟磁盘连接多个 VM。 要允许对虚拟磁盘进行写访问，请清除该复选框。
  4. 单击连接。
    提示: 如果基础 SR 出现问题，有时会导致连接的虚拟磁盘被取消激活（“拔出”）。 如果出现这种情况，应在 VM 的存储选项卡中选择该虚拟磁盘并单击激活将其重新激活。


分离虚拟磁盘

将虚拟磁盘与 VM 分离时，虚拟磁盘及其中的所有数据都将保留，但是该虚拟磁盘将不再供 VM 使用；分离的存储设备以后可以重新连接同一 VM、连接其他 VM，也可以移动到其他存储库 (SR) 中。

如果满足下列所有条件，则无需先关闭（“热拔出”）VM 就可以分离虚拟磁盘：

  • VM 未挂起。
  • VM 必须已安装 XenServer Tools。
  • 虚拟磁盘不是系统磁盘。
  • 必须取消激活虚拟磁盘才能彻底将其分离。 请注意，术语“取消激活”与“拔出”意思相同，在《XenServer 管理员指南》和 CLI 中，针对该操作使用的术语是“拔出”。

如果不满足上述任一条件，则必须先关闭 VM，然后才能分离虚拟磁盘。

过程：

  1. 在资源窗格中选择 VM，然后单击存储选项卡。
  2. 从列表中选择虚拟磁盘，单击取消激活，然后单击分离。
  3. 单击确定确认该操作。


移动虚拟磁盘

虚拟磁盘可以从一个存储库 (SR) 移动或迁移到同一池中的其他 SR。 其中包括：

  • 当前未连接到任何 VM 的虚拟磁盘。
  • 连接到未在运行的 VM 的虚拟磁盘。
  • 连接到正在运行的 VM 的虚拟磁盘（使用 Storage XenMotion）。

请注意，您可以将本地存储中的虚拟磁盘移至其他服务器上的共享存储中，但是不能将其移至其他服务器上的本地存储中。

关于 Storage XenMotion

使用 Storage XenMotion，您无需先关闭 VM 即可移动虚拟磁盘，从而能够执行一些管理操作，例如：

  • 将 VM 从便宜的本地存储移至由阵列支持的快速且有弹性的存储。
  • 将 VM 从开发环境移至生产环境。
  • 当 VM 受存储容量限制时，在存储层之间移动 VM。
  • 执行存储阵列升级。

注意，下面列出了 Storage XenMotion 的一些限制：

  • 无法迁移具有多个快照的虚拟磁盘。
  • 位于 StorageLink SR 上的虚拟磁盘无法迁移。
    重要: StorageLink 技术已从 XenServer 6.5 及更高版本中删除。 依赖于 StorageLink 技术的应用程序、代码或用法在 XenServer 6.5 及更高版本中将无法运行。 有关从 StorageLink SR 将现有虚拟磁盘 (VDI) 迁移到 iSCSI 或光纤通道 SR 的信息，请参阅 CTX141433。

移动虚拟磁盘

  1. 在 XenCenter 的资源窗格中，选择虚拟磁盘当前存储到的 SR，然后单击存储选项卡。 要找到虚拟磁盘，请执行以下操作：
    • 在 XenCenter 的资源窗格中，选择要移动的虚拟磁盘连接到的 VM。
    • 单击存储选项卡，然后确定虚拟磁盘当前存储到的 SR。
  2. 从虚拟磁盘列表中，选择要移动的一个或多个虚拟磁盘，然后单击移动。 或者，在选定的虚拟磁盘上单击鼠标右键，然后从快捷菜单中选择移动虚拟磁盘。
  3. 在移动虚拟磁盘对话框中，选择要将虚拟磁盘移动至的目标 SR。 确保该目标 SR 具有可容纳另一个虚拟磁盘的充足空间：可用空间在可用 SR 列表中显示。
  4. 单击移动以移动虚拟磁盘。


删除虚拟磁盘

如果满足下列所有条件，则无需先关闭 VM 就可以删除虚拟磁盘：

  • VM 未挂起。
  • VM 必须已安装 XenServer Tools。
  • 虚拟磁盘不是系统磁盘。
  • 必须首先取消激活虚拟磁盘。 请注意，术语“取消激活”与“拔出”意思相同，在《XenServer 管理员指南》和 CLI 中，针对该操作使用的术语是“拔出”。

如果不满足上述任一条件，则必须先关闭 VM，然后才能删除虚拟磁盘。

重要: 删除虚拟磁盘时，将永久删除该磁盘，从而销毁其中存储的任何数据。

过程：

  1. 在 VM 的存储选项卡上，从列表中选择虚拟磁盘，单击取消激活，然后单击删除。
  2. 单击确定确认删除操作。


更改虚拟磁盘属性

要更改某个虚拟磁盘的属性，请单击 VM 的存储选项卡，然后选择该虚拟磁盘并单击属性。

常规属性 - 名称、说明、文件夹和标记

名称 | 虚拟磁盘的名称
说明 | 虚拟磁盘的说明（可选）
文件夹 | 虚拟磁盘所在的资源文件夹的名称（如果适用）。
标记 | 已经用于该虚拟磁盘的一系列标记。

自定义字段

在“自定义字段”选项卡上，可以为虚拟磁盘指定新的自定义字段、更改已指定给虚拟磁盘的任何现有自定义字段的值，以及删除自定义字段。

有关添加、设置、修改和删除自定义字段的信息，请参阅使用自定义字段。

磁盘大小和位置

在该选项卡上设置虚拟磁盘的大小并选择虚拟磁盘所在的存储库。

设备选项

虚拟磁盘属性对话框中的最后一个选项卡，可用来为虚拟磁盘设置某些设备选项。

模式 | 可以更改对虚拟磁盘的读/写权限，例如，通过更改权限防止用于备份目的的虚拟磁盘上的数据被覆盖。
设备位置 | 该虚拟磁盘在驱动器序列中所占的位置。
磁盘访问优先级 | 对于某些虚拟磁盘，还可以调整磁盘 I/O 优先级（服务质量，简称 QoS）。 该设置仅适用于基于 LVM 的存储库（即本地存储库、共享 iSCSI 存储库或硬件 HBA 存储库）上的虚拟磁盘。 有关调整 QoS 设置以及 QoS 控件如何处理不同存储类型的详细信息，请参阅《XenServer 管理员指南》。


配置 VM 网络连接

主题：

  • 关于虚拟网络接口
  • 添加虚拟网络接口
  • 激活/取消激活虚拟网络接口
  • 删除虚拟网络接口
  • 更改虚拟网络接口属性


关于虚拟网络接口

每个虚拟机 (VM) 可以有一个或多个充当虚拟 NIC 的虚拟网络接口。

虚拟网络接口具有以下属性：

网络 | 虚拟网络接口的（物理）网络位置。
MAC 地址 | 虚拟网络接口的 MAC 地址。
QoS 限制 | 可选 I/O 优先级服务质量设置 (QoS)（为了实现最大网络传输率）。 当内存资源较少时，按照这种方式使用 I/O 限制会降低内存处理速度，但由于避免了崩溃的发生，因而有助于提高系统的稳定性。

您可以在 VM 的网络连接选项卡上查看其所有虚拟网络接口。 在该选项卡上，可以添加新的虚拟网络接口，还可以编辑、激活、取消激活和删除现有的虚拟网络接口。


添加虚拟网络接口

  1. 通过执行以下操作之一打开添加虚拟接口对话框：
    • 在资源窗格中选择 VM，单击网络连接选项卡，然后单击添加接口。
    • 在新建 VM 向导的网络页面上，单击添加。
  2. 从网络列表中选择一个网络位置。
  3. 指定 MAC 地址，可以使用基于 NIC MAC 地址自动创建的 MAC 地址，也可以手动输入 MAC 地址：
    • 要使用自动生成的 MAC 地址，请单击自动生成 MAC 地址。
    • 要明确输入 MAC 地址，请单击使用此 MAC 地址并按照 XY:XX:XX:XX:XX:XX 形式输入地址，其中 X 是任何十六进制数字，Y 是 2、6、A 或 E。
  4. 要设置可选的 I/O 优先级服务质量 (QoS) 设置以实现最大网络传输率，请选中此复选框并输入以千字节/秒 (kB/s) 为单位的值。 如果池配置为使用 vSwitch Controller，则添加虚拟接口对话框中的 QoS 选项将不可用；在这种情况下，应在需要时使用 vSwitch Controller 配置 QoS 设置。
  5. 单击添加。


激活/取消激活虚拟网络接口

满足以下所有条件时，可以在运行的 VM 上激活或取消激活虚拟网络接口：

  • VM 未挂起。
  • VM 必须已安装 XenServer Tools。

要激活（“插入”）或取消激活（“拔出”）虚拟网络接口，请在 VM 的网络连接选项卡上，选择该接口，然后单击标有激活或取消激活的按钮。


删除虚拟网络接口

如果满足以下所有条件，您无需关闭 VM（“热拔出”）即可从 VM 中删除虚拟网络接口：

  • VM 未挂起。
  • VM 必须已安装 XenServer Tools。

如果上面的一项或两项条件未满足，您必须先关闭 VM，然后才能删除虚拟网络接口。

删除虚拟网络接口：

  1. 在资源窗格中选择 VM，然后单击网络连接选项卡。
  2. 在网络连接选项卡上的列表中，选择虚拟网络接口，然后单击删除。


更改虚拟网络接口属性

要更改虚拟网络接口的属性，请通过执行以下操作之一打开虚拟接口属性对话框：

  • 单击 VM 的网络连接选项卡，选择虚拟网络接口，然后单击属性。
  • 在新建 VM 向导的网络页面上，单击属性。

可以更改虚拟网络接口的网络位置和 MAC 地址，也可以为虚拟网络接口设置 I/O 优先级。

网络 | 虚拟网络接口的网络位置。
MAC 地址 | 虚拟网络接口的 MAC 地址可以自动生成，您也可以按照 XY:XX:XX:XX:XX:XX 形式手动输入 MAC 地址，其中 X 是任何十六进制数字，Y 是 2、6、A 或 E。
启用 QoS 限制 | 通过选择此选项并输入以千字节/秒 (kB/s) 为单位的值，可以设置可选的 I/O 优先级服务质量 (QoS) 设置以实现最大网络传输率。 当内存资源较少时，按照这种方式使用 I/O 限制会降低内存处理速度，但由于避免了崩溃的发生，因而有助于提高系统的稳定性。 如果池配置为使用 vSwitch Controller，则此处的 QoS 选项将不可用；在这种情况下，应在需要时使用 vSwitch Controller 配置 QoS 设置。


配置 vGPU

根据特定 GPU 上支持的 vGPU 类型对 GPU 进行分组。 XenCenter 使您能够修改每个 GPU 允许的 vGPU 类型，这样便可根据您的需求对 GPU 进行分组。

要修改特定 GPU 上允许的 vGPU 类型，请执行以下操作：

  1. 在“资源”窗格中选择“池”，并导航到 GPU 选项卡。
  2. 使用 GPU 旁边的复选框选择要修改的 GPU。 记住，GPU 选项卡上的每个水平条都表示一个物理 GPU。
  3. 单击编辑选定 GPU。 GPU 窗口中将显示一个 vGPU 类型列表。 它包含特定于每个 vGPU 类型的信息，例如每个 GPU 所允许的 vGPU 的数量、最大分辨率、每个 vGPU 的最大显示屏数以及视频 RAM。
  4. 根据您的要求修改选择内容，并单击确定。 如果您希望在整个 GPU 中直通，请选择“在整个 GPU 中直通“。


更改 VM 属性

在资源窗格中选择虚拟机，然后单击常规选项卡，即可查看其属性。 可以在 VM 的属性对话框中更改其中的许多属性：单击常规选项卡右上角的属性按钮。

常规属性 - 名称、说明、文件夹和标记

在常规属性选项卡上，可以更改 VM 的名称和说明，将 VM 放入文件夹中，并管理 VM 的标记。

  • 要更改 VM 的名称，请在名称框中输入新名称。
  • 要更改 VM 的说明，请在说明框中输入新文本。
  • 要将 VM 放入文件夹中或者将其移至其他文件夹中，请单击文件夹框中的更改，然后选择文件夹。 有关使用文件夹的详细信息，请参阅使用文件夹。
  • 要对 VM 进行标记或取消标记，以及创建标记或删除标记，请参阅使用标记。

自定义字段

可以使用自定义字段为托管资源添加信息，使这些资源更易于搜索和组织。 有关如何为托管资源指定自定义字段的信息，请参阅使用自定义字段。

CPU

在 CPU 选项卡上，您可以调整分配给 VM 的虚拟 CPU 的数量，为 vCPU 设置每插槽核心数，并指定 vCPU 的优先级。 注意，您应在关闭 VM 后再修改这些设置。

vCPU 的数量

要修改分配给 VM 的虚拟 CPU 的数量，请更改 vCPU 数框中的数字。 为了确保 VM 实现最佳性能，vCPU 的数量不应超过主机服务器上物理 CPU 的数量。

拓扑

默认情况下，XenCenter 为每个 vCPU 的每个插槽分配一个核心。 拓扑下拉列表显示了每插槽核心数的有效组合。 从列表中选择一个选项，修改此设置。

根据您所选择的 vCPU 的数量，XenCenter 将显示一个选项列表，这些选项中 vCPU 的数量将可以被每插槽核心数整除。 例如，如果您为 VM 指定 8 个 vCPU，则每插槽的核心数可以是 1、2、4 或 8。 如果您指定 5 个 vCPU，则每插槽核心数只能是 1 或 5。

此虚拟机的 vCPU 优先级

vCPU 优先级是指在安排主机 CPU 期间为每个 VM 的 vCPU 指定的相对于同一主机服务器上运行的所有其他 VM 的优先级。 要调整 VM 的 vCPU 优先级，请移动 vCPU 滑块。

根据来宾操作系统的类型，XenServer 模板提供典型的 VM 配置并设置了合理的内存默认值。 在决定为 VM 分配的内存量时，还应考虑以下注意事项：

  • 将在 VM 上运行的应用程序种类。
  • 将使用相同内存资源的其他虚拟机。
  • 服务器上将与虚拟机一起运行的应用程序。

引导选项

该选项卡上提供的引导选项可能因来宾操作系统而异。 例如，在某些 VM 上，可以更改引导顺序，或者指定其他引导参数。

  • 要更改引导顺序，请在引导顺序列表中选择一个项目，然后单击上移或下移。
  • 要指定其他引导参数，请在操作系统启动参数框中输入这些参数。 例如，在 Debian VM 上，可以输入 single 以在单用户模式下引导 VM。

启动选项

在该选项卡上，可以为选定的 VM 调整启动顺序、启动延迟间隔和高可用性重启优先级。

值 | 说明
启动顺序 | 指定各个 VM 在 vApp 内或在高可用性恢复操作期间的启动顺序，使某些 VM 先于其他 VM 启动。 启动顺序值为 0（零）的 VM 将首先启动，启动顺序值为 1 的 VM 接着启动，然后是启动顺序值为 2 的 VM，依此类推。
尝试在以下时间后启动下一个 VM | 这是一段延迟时间间隔，用于指定从启动 VM 到尝试启动启动序列中下一组 VM（即，启动顺序更靠后的 VM）之间的等待时间。 该值将应用于 vApp 中的 VM，以及高可用性恢复操作期间的各个 VM。
高可用性重启优先级 在启用了高可用性的池中，该值指定在基础硬件出现故障或者 VM 的主机服务器丢失时，哪些 VM 将自动重新启动。
  • 如果池中有足够的资源，将保证高可用性重启优先级为重新启动的 VM 重新启动。 它们将先于优先级为在可能时重新启动的 VM 而重新启动。
  • 在计算故障计划时，不考虑高可用性重启优先级为在可能时重新启动的 VM，但当运行这些 VM 的服务器出现故障时，将尝试进行一次重新启动。 此次重新启动尝试将在所有优先级更高的 VM 重新启动后进行，如果启动尝试失败，将不再重试。
  • 高可用性重启优先级为不重新启动的 VM 将不会自动重新启动。

有关这些设置的详细信息，请参阅 VM 启动设置。

警报

在警报选项卡上，可以为 VM 的 CPU 使用率、网络和磁盘活动配置性能警报。

有关配置警报的信息，请参阅配置性能警报。

主服务器

在 VM 属性对话框的主服务器选项卡上，可以指定为 VM 提供资源的服务器。 如果可能，VM 将在该服务器上启动；否则将自动选择同一个池中的备用服务器。 要了解有关主服务器的详细信息，请参阅创建新 VM。

请注意，在启用了 Workload Balancing (WLB) 的池中，不能设置主服务器。 而是由 XenCenter 分析 XenServer 资源池指标并提供优化建议，从而为 VM 指定最佳服务器。 您可以决定系统在提出这些建议时考虑资源性能还是硬件密度，可以调整各个资源指标（CPU、网络、内存和磁盘）的加权，以使放置建议和临界阈值符合环境的需求。

GPU（仅限 Windows VM）

在 VM 的 GPU 属性选项卡上，可以为 Windows VM 分配专用的图形处理器 (GPU) 或虚拟 GPU (vGPU)，从而可以从 VM 直接访问图形硬件。 这使 VM 能够利用 GPU 的处理能力，为 CAD/CAM、GIS 和医学成像应用程序等高端 3D 专业图形应用程序提供更好的支持。

GPU 类型列表显示可用 GPU 和 vGPU 类型。 从下拉列表中选择一个 vGPU 类型，为 VM 分配一个特定的 vGPU 类型。 或者，选择在整个 GPU 中直通，允许 VM 使用 GPU 的全部处理能力。

注: vGPU 是一项仅在 XenServer Enterprise、XenServer Desktop+ 和 XenServer Desktop Edition 中提供的高级功能。 有关 XenServer 6.5 许可的信息，请参阅许可概述 (XenServer 6.5)。 要购买 XenServer 许可证，请单击此处。

高级选项（优化）

在高级选项选项卡上，可以调整分配给具有辅助硬件的 VM 的重影内存量。 在 Citrix XenApp 等某些专用应用程序工作负载中，需要具有额外的重影内存才能获得最佳性能。 此内存视为开销项，在核算 VM 内存时，此内存与常规的内存分开计算。

  • 要优化运行 Citrix XenApp 的 VM 的性能，请单击针对 Citrix XenApp 进行优化。
  • 要手动调整 VM 的重影内存分配，请单击手动优化，然后在重影内存系数框中输入一个值。
  • 要还原重影内存的默认设置，请选中针对一般用途进行优化选项。


管理 VM

主题

  • 启动 VM
  • 挂起和恢复 VM
  • 关闭 VM
  • 重新启动 VM
  • 运行远程控制台会话
  • 迁移 VM
  • 删除 VM


启动 VM

对于池中的 VM，可以根据所选主机服务器上的可用资源选择 VM 的启动位置。 所选服务器取决于 VM 和池的配置方式：

  • 在启用了 Workload Balancing (WLB) 的池中，该功能会提供一些建议来帮助您选择可能最适合 VM 工作负载的物理服务器。
  • 在未配置 Workload Balancing 的池中，可以选择在 VM 的主服务器上或者池中的任何其他服务器上（取决于该服务器上的可用存储）启动 VM。 要了解有关主服务器的详细信息，请参阅创建新 VM。

当 VM 启动并运行时，在“资源”窗格中，其状态指示器将变为 [image] 。

在特定服务器上启动 VM

  1. 在资源窗格中选择该 VM。
  2. 单击鼠标右键，单击在服务器上启动，然后在快捷菜单上选择所需的服务器。 或者，在 VM 菜单上，单击在服务器上启动，然后在子菜单上选择所需的服务器。

在最优服务器或主服务器上启动 VM

在资源窗格中选择该 VM，然后在工具栏上单击 [image] 启动。

或者执行以下操作之一：

  • 在资源窗格中单击鼠标右键，然后在快捷菜单上选择启动。
  • 在 VM 菜单上，单击启动。

在启用了 WLB 的池中，该操作将在最优服务器上启动 VM。

在未配置 Workload Balancing 的池中，该操作将在 VM 所在的主服务器上启动该 VM；如果未设置主服务器，则将在第一台可用服务器上启动。


挂起和恢复 VM

挂起 VM 时，其当前状态存储在默认存储库 (SR) 上的一个文件中。 通过这种方式，当您关闭 VM 的主机服务器并在以后重新启动后，将可以恢复 VM，使其回到最初的运行状态。

注: 在其他类型的服务器上创建的已挂起 VM 可能无法恢复。 例如，在使用 Intel VT CPU 的服务器上创建的 VM 可能无法在使用 AMD-V CPU 的服务器上恢复。

挂起 VM

  1. 如果当前的默认 SR 已分离，请选择新的默认 SR。
  2. 在资源窗格中选择该 VM，然后在工具栏上单击 [image] 挂起。 或者：
    • 单击鼠标右键，在快捷菜单中单击挂起。
    • 在 VM 菜单上，单击挂起。
    当 VM 挂起时，在资源窗格中其状态指示器将变为 [image] 。

恢复已挂起的 VM

通常可以为池中的 VM 选择恢复位置。 所选服务器取决于 VM 和池的配置方式：

  • 在启用了 Workload Balancing (WLB) 的池中，该功能会提供一些建议来帮助您选择可能最适合 VM 工作负载的物理服务器。
  • 在未配置 Workload Balancing 的池中，可以选择在 VM 的主服务器上或者池中的任何其他服务器（取决于该服务器上的可用存储）上恢复 VM。 要了解有关为 VM 指定主服务器的详细信息，请参阅主服务器。

当挂起的 VM 成功恢复之后，在资源窗格中其状态指示器将变为 [image] 。

在特定服务器上恢复已挂起的 VM

  1. 在资源窗格中选择该 VM。
  2. 单击鼠标右键，单击在服务器上恢复，然后在快捷菜单上选择所需的服务器。 或者，在 VM 菜单上，单击在服务器上恢复，然后在子菜单上选择所需的服务器。

在最优服务器或主服务器上恢复 VM

在资源窗格中选择该 VM，然后在工具栏上单击 [image] 恢复。

或者执行以下操作之一：

  • 在资源窗格中单击鼠标右键，然后在快捷菜单上选择恢复。
  • 在 VM 菜单上，单击恢复。

在启用了 WLB 的池中，该操作将在最优服务器上启动 VM。

在未配置 Workload Balancing 的池中，该操作将在 VM 所在的主服务器上启动该 VM；如果未设置主服务器或者指定的服务器不可用，则将在第一台可用服务器上启动。


关闭 VM

您可能出于多种原因而需要关闭正在运行的 VM，例如，要释放其资源或者要重新配置其虚拟网络硬件或虚拟磁盘存储。 可以通过 VM 的控制台或者使用 XenCenter 关闭 VM。 XenCenter 提供两种关闭 VM 的方法：

  • 软关闭以正常方式关闭 VM，所有正在运行的进程将逐个停止。
  • 强制关闭执行硬关闭，相当于拔出物理服务器。 强制关闭可能不会始终关闭所有正在运行的进程，如果用这种方式关闭 VM，可能会有丢失数据的风险。 只有在无法执行软关闭时，才能使用强制关闭。

在 HVM 模式下运行的 VM（即，未安装 XenServer Tools 的 VM）只能使用强制关闭方式关闭；为避免出现这种情况，应在所有 HVM 虚拟机上安装 XenServer Tools。

执行软关闭

在“资源”窗格中选择 VM，然后在工具栏上单击 [image] 关闭。

或者：

  • 单击鼠标右键，然后在资源窗格的快捷菜单中单击关闭。
  • 在 VM 菜单上，单击关闭。

要在 VM 的浮动控制台窗口中关闭 VM，请单击 [image] ，然后单击关闭。

停止运行中的进程时，VM 的控制台上将显示关闭消息。 当完成关闭时，资源窗格中的 VM 状态指示器将变为 [image] 。

执行强制关闭

在资源窗格中选择 VM，然后在工具栏上单击 [image] 强制关闭。

或者：

  • 单击鼠标右键，然后在资源窗格的快捷菜单中单击强制关闭。
  • 在 VM 菜单上，单击强制关闭。

要在 VM 的浮动控制台窗口中强制关闭 VM，请单击 [image] ，然后单击强制关闭。

当完成关闭时，资源窗格中的 VM 状态指示器将变为 [image] 。


重新启动 VM

在 XenCenter 中，可以通过两种不同的方法重新启动 VM：

  • 软重启以正常方式关闭 VM，然后重新启动。
  • 强制重启是硬重启，在不执行任何关机程序的情况下重新启动 VM。 这种方式相当于将物理服务器上的插头拔出、再重新插入，然后重新打开服务器。

如非绝对必要（例如，在出现严重错误的情况下强制重新恢复系统），请不要执行强制重启。

在 HVM 模式下运行的 VM（即，未安装 XenServer Tools 的 VM）只能使用强制重启方式重新启动；为避免出现这种情况，应在所有 HVM 虚拟机上安装 XenServer Tools。

正常重新启动 VM

在资源窗格中选择 VM，然后在工具栏上单击 [image] 重新启动。

或者：

  • 单击鼠标右键，然后在资源窗格的快捷菜单中单击重新启动。
  • 在 VM 菜单上，单击重新启动。

VM 将关闭并重新启动。 完成该过程后，资源窗格中的 VM 状态指示器将恢复为 [image] 。

执行强制重启

在资源窗格中选择 VM，然后在工具栏上单击 [image] 强制重启。

或者：

  • 单击鼠标右键，然后在资源窗格的快捷菜单中单击强制重启。
  • 在 VM 菜单上，单击强制重启。

VM 将立即关闭并重新启动。 完成该过程后，资源窗格中的 VM 状态指示器将恢复为 [image] 。


运行远程控制台会话

要在 VM 上打开远程控制台会话，请选择该 VM，然后单击控制台选项卡。

Linux VM

在 Linux VM 上，可以使用文本控制台或图形控制台运行控制台会话。 图形控制台采用 VNC 技术，并要求在虚拟机上安装和配置 VNC 服务器和 X 显示管理器。 有关为 Linux 虚拟机配置 VNC 的信息，请参阅《XenServer 虚拟机用户指南》。

要在两种类型的远程控制台之间切换，请使用控制台选项卡上的切换到图形控制台/切换到文本控制台按钮。

Windows VM

Windows VM 上的控制台会话可以使用标准图形控制台或远程桌面控制台，这两种控制台均支持完全的键盘和鼠标交互。 标准图形控制台使用 XenServer 开发的内置 VNC 技术提供对虚拟机控制台的远程访问，而远程桌面控制台则使用 RDP（远程桌面协议）技术。 可以随时使用 XenCenter 控制台选项卡上的切换到远程桌面/切换到默认桌面按钮，在标准图形控制台和远程桌面控制台之间切换。

要使用远程桌面控制台连接，必须满足以下要求：

  • 必须在虚拟机上启用远程桌面 - 有关如何在 Windows 虚拟机上启用远程桌面的信息，请参阅《XenServer 虚拟机用户指南》。
  • 必须安装 XenServer Tools。
  • 虚拟机必须具有网络接口，并且能够连接到 XenCenter。

远程桌面控制台环境受许多不同 XenCenter 设置的影响：

  • Windows 组合键发送到远程桌面控制台。
  • 在本地计算机上播放来自远程桌面控制台上运行的应用程序的声音。
  • 默认情况下，打开远程桌面控制台会话时，将与远程服务器上的控制台会话建立连接，而不是创建虚拟控制台会话。
  • XenCenter 自动扫描 RDP 连接，并在该连接变为可用状态时自动切换到远程桌面控制台。

可以通过 XenCenter 选项对话框中的控制台选项卡更改这些设置和其他远程桌面控制台设置；请参阅更改 XenCenter 选项。


迁移虚拟机

使用 Storage XenMotion，可以将正在运行的虚拟机从一台服务器移动到同一个资源池中的另一台服务器，而几乎不会造成任何服务中断。 目标服务器的选择取决于 VM 和池的配置方式。

通过 XenCenter，您可以使用移动 VM 对话框，将当前未在运行的 VM 移至同一池中的新存储。 要移动 VM，请执行以下操作：从 XenCenter 菜单中，单击 VM，然后单击移动 VM。 选择要将 VM 移动至的存储库，然后单击移动。

关于使用 XenMotion 和 Storage XenMotion 迁移 VM

XenMotion

XenMotion 在所有版本的 XenServer 中都提供，当 VM 磁盘位于由两个主机共享的存储中时，使用 XenMotion 可以将正在运行的 VM 从一个主机移至另一个主机。 这样可支持 Workload Balancing (WLB)、高可用性和滚动池升级 (RPU) 等池维护功能以自动移动 VM。 这些功能可实现工作负载调整、基础结构恢复以及服务器软件升级，而不会导致任何 VM 停机。 由于存储只能由同一池中的主机共享，因此 VM 只能在同一池中移动。

Storage XenMotion

当 VM 不位于由两个主机共享的存储中时，使用 Storage XenMotion 也可以将 VM 从一个主机移至另一个主机。 因此，可以迁移保存在本地存储上的 VM，而不会导致停机，并且可以将 VM 从一个池移至另一个池。 这样，系统管理员可以：

  • 在 XenServer 池之间重新平衡 VM（例如从开发环境到生产环境）。
  • 在不导致任何 VM 停机的情况下，升级和更新独立 XenServer 主机。
  • 升级 XenServer 主机硬件。
注: 将 VM 从一个主机移至另一个主机时会保留 VM 状态。 状态信息包括定义和标识 VM 的信息以及历史性能指标（如 CPU 和网络使用情况）。

使用 Storage XenMotion，您还可以将虚拟磁盘从一个存储库 (SR) 移至同一池中的其他 SR。 有关详细信息，请参阅移动虚拟磁盘。

兼容性要求

当通过 XenMotion 或 Storage XenMotion 迁移 VM 时，新 VM 主机必须满足以下兼容性要求，才能继续进行迁移：

  • 必须在要迁移的每个 VM 上安装 XenServer Tools。
  • 必须在目标主机上安装与源主机上相同版本或更高版本的 XenServer。
  • 对于 Storage XenMotion，如果源主机与目标主机上的 CPU 不同，目标主机提供的全套功能必须至少与源主机的 CPU 相同。 否则，将无法在 AMD 和 Intel 处理器之间移动 VM。
  • 对于 Storage XenMotion，无法迁移具有多个快照的 VM。
  • 对于 Storage XenMotion，无法迁移连接有六个以上 VDI 的 VM。
  • 目标主机必须具有充足的空闲内存容量或者能够使用动态内存控制释放出充足的容量。 如果内存不足，将无法完成迁移。
  • 对于 Storage XenMotion，目标存储必须具有充足的可用磁盘空间（用于 VM 及其快照），从而可以保存传入的 VM。 如果空间不足，将无法完成迁移。

XenMotion 和 Storage XenMotion 限制

XenMotion 和 Storage XenMotion 具有以下限制：

  • 在 XenDesktop 部署中不得使用 Storage XenMotion。
  • 无法迁移使用 PCI 传递功能的 VM。
  • 在迁移期间，VM 性能会降低。
  • 对于 Storage XenMotion，在尝试进行 VM 迁移之前，具有高可用性或 Work Load Balancing (WLB) 保护的池应该先禁用高可用性和 WLB。
  • 完成 VM 迁移的时间取决于 VM 的内存占用量及其活动，此外，通过 Storage XenMotion 迁移的 VM 还会受到 VDI 及其存储活动大小的影响。
  • StorageLink SR 上带有 VDI 的 VM 无法迁移。
    重要: StorageLink 技术已从 XenServer 6.5 及更高版本中删除。 依赖于 StorageLink 技术的应用程序、代码或用法在 XenServer 6.5 及更高版本中将无法运行。 有关从 StorageLink SR 将现有虚拟磁盘 (VDI) 迁移到 iSCSI 或光纤通道 SR 的信息，请参阅 CTX141433。

迁移 VM

  1. 在资源窗格中选择 VM，然后执行以下操作之一：
    • 单击鼠标右键，在快捷菜单中单击迁移至服务器，然后单击迁移 VM 向导。
    • 在 VM 菜单上，单击迁移至服务器，然后单击迁移 VM 向导。
  2. 从目标位置下拉列表中选择独立服务器或池。
  3. 从主服务器列表中选择服务器，从而为 VM 分配主服务器，然后单击下一步。
  4. 在存储选项卡中指定将用来放置所迁移的 VM 的虚拟磁盘的存储库，然后单击下一步。
    • 将迁移的所有虚拟磁盘置于同一个 SR 上单选按钮默认情况下处于选中状态，并显示目标池中的默认共享 SR。
    • 从存储库下拉列表中，单击将迁移的虚拟磁盘置于指定的 SR 上以指定 SR。 此选项支持您为迁移的 VM 上的每个虚拟磁盘选择不同的 SR。
  5. 从存储网络下拉列表中，选择要用于 VM 虚拟磁盘实时迁移的目标池中的网络，然后单击下一步。
    注: 由于性能原因，建议您不要将管理网络用于实时迁移。
  6. 检查配置设置，然后单击完成开始迁移 VM。


删除 VM

删除虚拟机会将其配置和文件系统从服务器中删除。 删除 VM 时，可以选择同时删除与该 VM 相连的任何虚拟磁盘以及该 VM 的任何快照，也可以选择保留它们。

删除 VM：

  1. 关闭 VM。
  2. 在资源面板中选择已停止的 VM，单击鼠标右键，然后单击快捷菜单上的删除。 或者，在 VM 菜单上，单击删除。
  3. 要删除所连接的虚拟磁盘，请选中与之对应的复选框。
    重要: 存储在 VM 的虚拟磁盘驱动器中的所有数据都将丢失。
  4. 要删除 VM 的快照，请选中与之对应的复选框。
  5. 单击删除。

    完成删除操作后，该 VM 将从资源窗格中删除。

    注: 已经删除了父 VM 的 VM 快照（“孤立快照”）仍可以通过资源窗格进行访问，也可以将其导出、删除以及用来创建新的 VM 和模板。 要在资源窗格中查看快照，请单击“导航”窗格中的对象，然后在“资源”窗格中展开快照组。


导入和导出 VM

主题

  • 关于 VM 导入和导出
  • 开放虚拟化格式（OVF 和 OVA）
  • 磁盘映像格式（VHD 和 VMDK）
  • 从 OVF/OVA 导入 VM
  • 导入磁盘映像
  • 从 XVA 导入 VM
  • 将 VM 导出为 OVF/OVA
  • 将 VM 导出为 XVA


关于 VM 导入和导出

VM 可以从 OVF/OVA 包、磁盘映像和 XenServer XVA 文件导入， 可以使用 OVF/OVA 包和 XenServer XVA 文件形式导出。 在 XenCenter 中，可以使用导入和导出向导来导入和导出 VM。 XenCenter 使用传输 VM 来传输磁盘映像的内容。

导入在 XenCenter 以外的其他虚拟机管理程序（例如 Hyper-V 或 VMware）上创建的 VM 时，必须使用“操作系统修复”工具确保所导入的 VM 能够在 XenServer 上引导。

支持的导入和导出格式

格式 | 说明
开放虚拟化格式（OVF 和 OVA） | OVF 是用于打包和分发由一个或多个虚拟机组成的虚拟设备的开放标准。 有关 XenCenter 对 OVF 和 OVA 文件格式的支持功能的详细信息，请参阅开放虚拟化格式（OVF 和 OVA）。
磁盘映像格式（VHD 和 VMDK） | 可以使用导入向导导入虚拟硬盘 (VHD) 和虚拟机磁盘 (VMDK) 格式的磁盘映像文件。 当仅有一个可用虚拟磁盘映像，但没有与其关联的 OVF 元数据时，您可能需要导入磁盘映像。 有关受支持的磁盘映像格式的详细信息，请参阅磁盘映像格式（VHD 和 VMDK）
XenServer XVA 格式 | XVA 是基于 Xen 的虚拟机管理程序所专有的格式，用来将单个 VM 打包为单个文件存档（包括描述符和磁盘映像）。 其文件扩展名为 .xva。
XenServer XVA 版本 1 (ova.xml) | XVA 版本 1 是用于将单个 VM 打包为一组文件（包括描述符和磁盘映像）的格式。 描述符文件（称为 ova.xml）用来指定单个 VM 的虚拟硬件。 磁盘映像采用文件目录格式。 目录名对应于描述符中的引用名称。 磁盘映像的每个 GB 区块对应一个文件。 每个文件的基本名称包含十进制的块编号。 文件中包含磁盘映像的一个区块，采用原始二进制格式，并以 gzip 格式压缩。

使用哪种格式？

使用 OVF/OVA 可以：
  • 与支持 OVF 的其他虚拟机管理程序共享 XenServer vApp 和 VM。
  • 保存多个 VM。
  • 保护 vApp 或 VM 不被损坏和篡改。
  • 包括许可协议。
  • 通过将 OVF 包存储到 OVA 文件中来简化 vApp 的分发。
使用 XVA 可以：
  • 与 6.0 以下版本的 XenServer 共享 VM。
  • 通过命令行接口 (CLI) 使用脚本导入和导出 VM。

操作系统修复

XenCenter 包含一个高级的虚拟机管理程序互操作性功能（操作系统修复），该功能旨在确保导入 XenServer 的各个 VM 具有基本级别的互操作性。 从 OVF/OVA 包和磁盘映像导入在其他虚拟机管理程序上创建的 VM 时，将需要使用“操作系统修复”。

“操作系统修复”将启用对于在 XenServer 中完成引导非常关键的引导设备，并禁用用于 XenServer 以外的其他虚拟机管理程序的任何服务（也称为工具），从而将来宾操作系统配置为在 XenServer 中引导。 来宾操作系统包括 XenServer 支持的所有 Windows 版本以及一些 Linux 版本。 请注意，“操作系统修复”不会将来宾操作系统从一个虚拟机管理程序转换到另一个虚拟机管理程序。

“操作系统修复”以自动引导的 ISO 映像形式提供，该映像连接到所导入 VM 的 DVD 驱动器，它将在 VM 首次启动时执行必要的配置更改，然后关闭 VM。 下次启动新 VM 时，引导设备将重置，VM 将按正常方式启动。

要针对所导入的磁盘映像和 OVF/OVA 包使用“操作系统修复”，可以在 XenCenter 导入向导的操作系统修复设置页面上启用该功能，然后指定将存储所复制的修复 ISO 的位置，以供 XenServer 使用。

操作系统修复的要求

“操作系统修复”需要一个具有 40 MB 可用空间和 256 MB 虚拟内存的 ISO SR。

传输 VM

传输 VM 是内置 VM，它仅在导入或导出虚拟磁盘映像期间运行，用以在磁盘映像文件位置与 XenServer 存储库 (SR) 之间传输映像内容。 每导入或导出一个磁盘映像，会运行一个传输 VM。 如果导入或导出具有多个磁盘映像的 VM 或 vApp，则一次仅传输一个磁盘映像。

您需要在导入和导出向导中为传输 VM 配置网络连接设置。

传输 VM 的要求

XenServer 运行一个传输 VM 时，要求如下：
虚拟 CPU | 1
虚拟内存 | 256 MB
存储器 | 8 MB
网络连接 | 可从 XenServer 主机访问的网络 - 通常为管理网络。 静态或动态 IP 地址。 （Citrix 建议使用动态 IP 地址。）

默认传输协议为 iSCSI，这种情况下要求在 XenCenter 主机上安装 iSCSI 发起程序。 也可以使用 RawVDI 作为备用传输协议。有关详细信息，请参阅《XenServer 虚拟机用户指南》。

导入 VM：概述

导入 VM 时，将有效地创建新的 VM，该过程涉及到的许多步骤与使用新建 VM 向导创建和置备新 VM 时的步骤相同，例如指定主服务器，以及为新 VM 配置存储和网络连接；有关其中每个步骤的详细信息，请参阅创建新 VM。

导入向导将引导您通过以下步骤导入 VM：
  1. 选择导入文件。

    第一步是找到并选择要导入的 VM 所在的文件。

    对于当前未在本地 XenCenter 主机上的文件，可以在文件名框中输入 URL 位置 (http | https | file | ftp)。 单击下一步后，下载文件对话框将打开，您可以在其中指定 XenCenter 主机上要存储所复制的文件的文件夹。 文件下载完毕后，导入向导将进入下一页。

  2. （仅限 VHD 和 VMDK 导入）为新 VM 指定名称并分配 vCPU 和内存资源。

    从 VHD 或 VMDK 文件导入时，需要为新 VM 指定名称并分配一些虚拟 CPU (vCPU) 和内存。 创建新 VM 后，所有这些值都可以进行调整。 有关此步骤的详细信息，请参阅 VM CPU 和内存分配。 在 XenCenter 内不会检查 VM 名称是否唯一，因此，为不同的 VM 指定有意义且好记的名称可以方便对 VM 进行管理；有关详细信息，请参阅 VM 名称和说明。

  3. （仅限 OVF/OVA）检查/接受 EULA。

    如果要导入的软件包中包括任何 EULA，请接受这些 EULA，然后单击下一步继续操作。 如果该软件包中不包含 EULA，则该向导将跳过此步骤而直接进入下一页。

  4. 选择位置/主服务器。

    选择要用来放置所导入 VM 的目标池或独立服务器。 要为传入的 VM 指定主服务器，请在列表中选择服务器。

  5. 配置存储。

    然后，选择要用来放置所导入 VM 中虚拟磁盘的存储库 (SR)：

    对于 XVA 格式的 VM，请选择将用来放置所导入 VM 中所有虚拟磁盘的 SR。

    对于 OVF/OVA 包中或磁盘映像文件中的 VM，可以将所导入的所有虚拟磁盘放在同一个 SR 上，也可以将各个虚拟磁盘放在不同的 SR 上。

  6. 配置网络连接。

    然后，将所导入 VM 中的虚拟网络接口映射到目标池/独立服务器中的目标网络。

  7. （仅限 OVF/OVA）安全性验证。

    如果为所选 OVF/OVA 包配置了证书或清单文件等安全功能，则需要指定必要的信息。

  8. （仅限 OVF/OVA 和磁盘映像）配置“操作系统修复”和“传输 VM”设置。

    如果导入的 VM 是在 XenServer 以外的其他虚拟机管理程序上构建的，您将需要配置“操作系统修复”功能，以允许所导入的 VM 在 XenServer 上正确引导。 您还需要为传输 VM（在从磁盘映像和 OVF/OVA 包导入/导出 VM 时所使用的一个临时 VM）配置网络连接。

  9. 完成新 VM 的创建。

    在导入向导的最后一页上，可以检查已选择的所有配置选项。 从 XVA 导入时，可以选中自动启动 VM 复选框，以便在创建新 VM 后立即将其启动。

    单击完成，以完成所选 VM 的导入并关闭该向导。

导出 VM：概述

选择要导出的 VM，然后打开导出向导：在 VM 菜单上单击导出。

  1. 指定导出文件的详细信息。

    在该向导的第一页上，输入导出文件的名称，指定要保存导出文件的文件夹，然后从格式列表中选择导出文件格式：

    选择 XVA 文件(*.xva) 可将所选 VM 导出到 XVA 文件中。 使用此格式只能导出单个 VM。

    选择 OVF/OVA 包(*.ovf, *.ova) 可将所选 VM 导出为 OVF 或 OVA 包。

  2. 确认已选择要导出的 VM。

    在该向导的下一页上，可以修改 VM 选择集，例如，在要导出的 VM 集中添加更多 VM 或者取消选择其他 VM。 请注意，在导出为 XVA 时，只能选择一个 VM。

  3. （仅限 OVF/OVA）配置 EULA、“高级选项”和“传输 VM”设置。

    将 VM 导出为 OVF 或 OVA 包时，可以配置若干其他设置。 有关详细信息，请参阅 将 VM 导出为 OVF/OVA。

  4. 完成 VM 的导出。

    在该向导的最后一页上，检查在前面的向导页面上选择的设置。 要让向导验证导出文件，请选中导出完成时进行验证复选框。

    单击完成，以开始导出所选 VM 并关闭该向导。


开放虚拟化格式（OVF 和 OVA）

OVF 是由分布式管理任务组 (DMTF) 指定的开放标准，用于打包和分发由一个或多个虚拟机 (VM) 组成的虚拟设备。

OVF 包中包含用于描述虚拟机的元数据和文件元素、以及对于 OVF 包中应用程序的部署和操作至关重要的其他信息。 其文件扩展名为 .ovf。

开放式虚拟设备 (OVA) 是一个 OVF 包，采用单个文件存档形式，其文件扩展名为 .ova。

请注意，在实施了基于角色的访问控制 (RBAC) 的 XenServer 环境中，只有具有“池管理员”RBAC 角色的用户才可以导入和导出 OVF 和 OVA 包。 有关 RBAC 角色的详细信息，请参阅 RBAC 概述。

OVF 包中的内容

OVF 包中始终包含一个描述符文件 (*.ovf)，此外可能还包括若干其他文件。

文件类型 | 说明
描述符 | 描述符用于指定服务对虚拟硬件的要求，并且还包括其他信息，例如虚拟磁盘的说明、服务本身、来宾操作系统、许可协议 (EULA)、在设备中启动和停止 VM 的说明以及服务安装说明。 描述符文件的扩展名为 .ovf。
清单 | 清单文件是软件包中每个文件的 SHA-1 摘要，可以用来检测任何损坏，以验证软件包的内容。 清单文件的扩展名为 .mf。
签名 | 签名是用软件包所含 X.509 证书中的公钥进行签名的清单文件摘要，用于对软件包作者进行验证。 签名文件的扩展名为 .cert。
虚拟磁盘 | OVF 不指定磁盘映像格式。 OVF 包中包含组成虚拟磁盘的文件（格式由导出虚拟磁盘所用的虚拟化产品定义）。 XenServer 生成的 OVF 包具有动态 VHD 格式的磁盘映像；VMware 产品和 Virtual Box 生成的 OVF 包具有经过流技术优化的 VMDK 格式的虚拟磁盘。

OVA 包是一个磁带存档 (tar) 格式的单个存档文件，包含组成 OVF 包的文件。

应使用哪种格式？

OVF 包包含一系列未压缩的文件，对于需要访问文件中各个磁盘映像的用户而言较为方便，而 OVA 包只是一个大型文件。 尽管您可以压缩此文件，但它不像一系列文件（如 OVF）那样灵活。

OVA 更适用于适合只使用一个文件的特定应用场合（例如创建用于 Web 下载的软件包），这种情况下软件包更易于处理。 与 OVF 相比，导出和导入 OVA 包所需的时间更长。

使用操作系统修复

使用 OVF 作为打包方法时，不能保证软件包中所包含的虚拟机能够跨虚拟机管理程序实现兼容。 在一个虚拟机管理程序上创建的 OVF 包可能无法自动在其他虚拟机管理程序上工作。 出现这种情况的原因有多种，其中包括：不同虚拟机管理程序对于 OVF 规范、来宾操作系统设备、驱动程序及实施有不同的解释。

XenCenter 包含一个高级的虚拟机管理程序互操作性功能（操作系统修复），该功能旨在确保导入 XenServer 的 OVF 包具有基本级别的互操作性。 对于所导入的创建于其他虚拟机管理程序上的 VM ，必须运行“操作系统修复”，以确保这些 VM 能够在 XenServer 上正确引导。

有关“操作系统修复”功能的详细信息，请参阅关于 VM 导入和导出。

有关 OVF 的详细信息

有关 OVF 的详细信息，请参阅 Citrix 知识中心 Web 站点和 DMTF Web 站点上的以下文档：

Overview of the Open Virtualization Format（开放虚拟化格式概述）

Open Virtualization Format Specification（开放虚拟化格式规范）


磁盘映像格式（VHD 和 VMDK）

使用导入向导，您可以将磁盘映像导入到资源池或作为 VM 的特定主机。

当仅有一个可用虚拟磁盘映像，但没有与其关联的 OVF 元数据时，您可能需要导入磁盘映像。 可能发生这种情况的情形包括：
  • 无法读取 OVF 元数据。 但是，仍然可以导入磁盘映像。
  • 您拥有的一个虚拟磁盘未在 OVF 软件包中定义。
  • 要从中移动的平台无法创建 OVF 设备（例如，较旧的平台或映像）。
  • 要导入的较旧的 VMware 设备缺少 OVF 信息。
  • 要导入没有任何 OVF 信息的独立 VM 设备

如有可能，Citrix 建议您导入包含 OVF 元数据的设备软件包，并且不要只导入单个磁盘映像。 OVF 数据提供了导入向导从磁盘映像重新创建 VM 时所需的信息，包括与 VM 相关联的磁盘映像的数量、处理器、存储以及内存要求等。 如果缺少此信息，尝试重新创建 VM 时可能会更加复杂，并且更易于出错。

请注意，在实施了基于角色的访问控制 (RBAC) 的 XenServer 环境中，只有具有“池管理员”RBAC 角色的用户才可以导入磁盘映像。 有关 RBAC 角色的详细信息，请参阅 RBAC 概述。

支持的磁盘映像格式

可以使用 XenCenter 的导入向导导入以下磁盘映像格式：
格式 | 说明
虚拟硬盘 (VHD) | VHD 是由 Microsoft 制定的一组虚拟磁盘映像格式，是 Microsoft 开放规范许可的一部分。 其文件扩展名为 .vhd。 XenCenter 导入和导出动态 VHD 格式，该格式是精简置备的虚拟磁盘映像，只有在使用时才分配空间。
虚拟机磁盘 (VMDK) | VMDK 是一组由 VMware 指定的虚拟磁盘映像格式。 其文件扩展名为 .vmdk。 XenCenter 将导入经过流技术优化的 VMDK 格式和 monolithicFlat VMDK 格式。 经过流技术优化的 VMDK 是由 VMware 和 Virtual Box 虚拟机管理程序生成的 OVF 包所使用的格式。 MonolithicFlat VMDK 是一种常见的、可供 VMware 管理客户端下载的虚拟磁盘格式。

使用操作系统修复

XenCenter 包含一个高级的虚拟机管理程序互操作性功能（操作系统修复），该功能旨在确保在 XenServer 以外的其他虚拟机管理程序上创建的 VM 具有基本级别的互操作性。 在从创建于其他虚拟机管理程序上的磁盘映像导入 VM 时，必须运行“操作系统修复”，以确保这些 VM 能够在 XenServer 上正确引导。

有关详细信息，请参阅关于 VM 导入和导出。


从 OVF/OVA 导入 VM

可以使用导入向导来导入已保存为 OVF/OVA 文件的虚拟机 (VM)。 该向导将引导您完成在 XenCenter 中创建新 VM 时所需要的许多通用步骤：指定主服务器；为新 VM 配置存储和网络连接；以及在 OVF 导入过程中所需要的一些其他步骤，其中包括：
  • 指定安全设置（如果 OVF 包中包括证书或清单文件）。
  • 配置关于 VM 导入和导出的网络连接。
  • 指定操作系统修复设置（如果要导入的 VM 是在 XenServer 以外的其他虚拟机管理程序上构建的）。

有关在创建新 VM 时所涉及的各步骤的概述，请参阅创建新 VM。

使用 XenCenter 导入 OVF 包时，该软件包将显示为 vApp。 导入完成后，新的 VM 将显示在 XenCenter 的“资源”窗格中，而新的 vApp 显示在 管理 vApp（管理 vApp）对话框中。

必备条件

  • 需要具有“池管理员”RBAC 角色才能导入 OVF/OVA 包。 导入向导将执行检查，以确保您在目标池中具有“池管理员”角色，然后才允许您继续操作。 有关 RBAC 角色的详细信息，请参阅 RBAC 概述。
  • 如果导入的 OVF 包经过压缩或者包含压缩文件，则 XenServer 主机上需要有额外的可用磁盘空间来解压缩这些文件。

导入 OVF 包

  1. 打开导入向导：在文件菜单上，选择导入。
  2. 在该向导的第一页上，找到要导入的文件（文件扩展名为 .ovf、.ova 或 .ova.gz），然后单击下一步继续操作。
    • 如果选择压缩的 OVA 文件 (*.ova.gz)，则在单击下一步时，该文件将解压为一个 OVA 文件，原 *.ova.gz 文件将被删除。
    • 如果您在文件名框中输入 URL 位置 (http | https | file | ftp)，则在单击下一步时，将打开下载软件包对话框，您必须指定 XenCenter 主机上将存储所复制软件包的文件夹。
  3. 检查/接受 EULA。

    如果要导入的软件包中包括任何 EULA，请接受这些 EULA，然后单击下一步继续操作。 如果该软件包中不包含 EULA，则该向导将跳过此步骤而直接进入下一页。

  4. 指定 VM 位置和主服务器。 在“位置”页面上，从“将 VM 导入”列表中选择用来放置所导入 VM 的池或独立服务器，然后为 VM 分配一个主服务器（可选）：
    • 要为 VM 指定主服务器，请从主服务器列的列表中选择服务器。 XenServer 将始终尽可能尝试在 VM 的主服务器上启动 VM。 有关为新 VM 分配主服务器的详细信息，请参阅主服务器。
    • 如果不希望指定主服务器，请从主服务器列的列表中选择不分配主服务器。

      单击下一步继续操作。

  5. 为导入的 VM 配置存储。 在存储页面上，选择一个或多个要用来放置所导入磁盘映像的存储库 (SR)，然后单击下一步继续操作。
    • 要将导入的所有磁盘映像放在同一个 SR 上，请选择 Place all imported VMs on this target SR（将导入的所有 VM 放在此目标 SR 上），然后从列表中选择一个 SR。
    • 要将传入 VM 的磁盘映像放在不同的 SR 上，请单击 Place imported VMs on the specified SR targets（将导入的 VM 放在指定的目标 SR 上），然后针对每个虚拟磁盘，从列表中的 SR 列选择目标 SR。
  6. 为导入的 VM 配置网络连接。 在网络连接页面上，将导入的 VM 中的虚拟网络接口映射到目标池中的目标网络。 此页面上传入 VM 列表中显示的网络和 MAC 地址作为初始（已导出）VM 定义的一部分存储在导出文件中。 要将传入的虚拟网络接口映射到目标网络，请从目标网络列的列表中选择网络。

    单击下一步继续操作。

  7. 指定安全设置。 如果为所选 OVF/OVA 包配置了证书或清单文件等安全功能，请在“安全”页面上指定必要的信息，然后单击“下一步”继续操作。 此页面上显示的选项因 OVF 包上配置的安全功能而异：
    • 如果该软件包具有签名，此处将显示验证数字签名复选框；如果您希望验证签名，请单击此复选框。 单击查看证书可显示用来对软件包进行签名的证书。 如果证书显示为不受信任，有可能是根证书或证书颁发机构在本地计算机上不受信任。
    • 如果软件包中包括清单文件，此处将显示验证清单文件内容复选框。 如果选中该复选框，向导将验证软件包中的文件列表。
    请注意，如果软件包具有数字签名，系统会自动验证关联的清单文件，因此，验证清单文件内容复选框不会出现在安全页面上。
    重要: VMware Workstation 7.1 生成的 OVF 设备将包含具有无效 SHA-1 哈希的清单文件。 如果在从该来源导入设备时选择验证清单文件，导入操作将会失败。
  8. 启用操作系统修复功能。 如果所导入软件包中的 VM 是在 XenServer 以外的其他虚拟机管理程序上构建的，请选中使用操作系统修复复选框，并选择可以存储所复制的修复 ISO 的 ISO SR，以供 XenServer 使用。 有关此功能的详细信息，请参阅“操作系统修复”。

    如果未列出所需的 ISO 库，请单击新建 ISO 库创建新的 ISO SR；有关使用此选项的详细信息，请参阅 ISO 存储。

    单击下一步继续操作。

  9. 配置 Transfer VM 网络连接。 在传输 VM 设置页面上，配置关于 VM 导入和导出的网络连接设置，然后单击下一步继续操作。
    • 从目标池或独立服务器可用网络接口的列表中选择网络。
    • 要使用自动化的动态主机配置协议 (DHCP) 自动分配网络设置（包括 IP 地址、子网掩码和网关），请选中使用 DHCP 自动获取网络设置。
    • 要手动配置网络连接设置，请单击使用以下网络设置并输入 IP 地址、子网掩码和网关。
  10. 在完成页面上，检查所有的导入设置，然后单击完成，以开始执行导入过程并关闭该向导。

    导入进度将显示在 XenCenter 窗口底部的状态栏中以及通知的事件视图上。

    导入过程可能需要一些时间，具体取决于所导入虚拟磁盘的大小、可用网络带宽以及 XenCenter 主机的磁盘接口速度。 导入完成后，新导入的 VM 将显示在资源窗格中，而新的 vApp 显示在 管理 vApp 对话框中。

    注: 使用 XenCenter 导入包含 Windows 操作系统的 OVF 包之后，必须设置 platform 参数。 此参数随 OVF 软件包中包含的 Windows 版本而异：

    • 对于 Windows Vista、Server 2008 及更高版本，请将 platform 参数设置为 device_id=0002。 例如：

      xe vm-param-set uuid=<VM UUID> platform:device_id=0002

    • 对于所有其他 Windows 版本，请将 platform 参数设置为 viridian=true。 例如：

      xe vm-param-set uuid=<VM UUID> platform:viridian=true

    尝试启动导入的 VM 时出错

    如果无法引导从 OVF 包导入的 VM，请尝试在不使用“操作系统修复”功能的情况下重新导入该软件包：在导入向导的操作系统修复设置页面上，清除使用操作系统修复复选框（有关此功能的详细信息，请参阅关于 VM 导入和导出。）


导入磁盘映像

通过使用 XenCenter 导入向导，可以将磁盘映像导入资源池或特定主机中，从而创建新的 VM。 该向导将引导您完成在 XenCenter 中创建新 VM 时所需要的许多通用步骤：指定主服务器；为新 VM 配置存储和网络连接；以及在导入过程中所需要的一些其他步骤，其中包括：
  • 配置关于 VM 导入和导出的网络连接。
  • 指定关于 VM 导入和导出的设置（如果要导入的磁盘映像是在 XenServer 以外的其他虚拟机管理程序上构建的）。

导入磁盘映像的要求

需要具有“池管理员”RBAC 角色才能导入磁盘映像。 导入向导将执行检查，以确保您在目标池中具有“池管理员”角色，然后才允许您继续操作。 有关 RBAC 角色的详细信息，请参阅 RBAC 概述。

过程

  • 打开导入向导：在文件菜单上，选择导入。
  • 在该向导的第一页上，找到要导入的磁盘映像文件，然后单击下一步继续操作。

    如果您在文件名框中输入 URL 位置 (http | https | file | ftp)，则在单击下一步时，将打开下载软件包对话框，您必须指定 XenCenter 主机上将存储所复制磁盘映像的文件夹。

  • 指定 VM 名称并分配 CPU 和内存资源。

    在 VM 定义页面上，输入将从所导入磁盘映像创建的新 VM 的名称，并分配 CPU 和初始内存资源。 有关这些字段的说明，请参阅 VM CPU 和内存分配。

    单击下一步继续操作。

  • 指定用来放置新 VM 的位置并选择主服务器。
    在位置页面上，选择要用来放置新 VM 的位置，为其分配主服务器（可选），然后单击下一步继续操作。
    • 在将 VM 导入列表中，单击池或独立服务器。
    • 要为该 VM 指定主服务器，请从主服务器列的列表中选择服务器。 XenServer 将始终尽可能尝试在 VM 的主服务器上启动 VM。 有关为新 VM 分配主服务器的详细信息，请参阅主服务器。
    • 如果不希望指定主服务器，请从主服务器列的列表中选择不分配主服务器。
  • 为新 VM 配置存储。

    在存储页面上，选择要用来放置所导入虚拟磁盘的存储库 (SR)，然后单击下一步继续操作。

  • 为新 VM 配置网络连接。

    在网络连接页面上，在目标池/独立服务器中为新 VM 的虚拟网络接口选择目标网络。

    单击下一步继续操作。

  • 启用操作系统修复功能。

    如果要导入的磁盘映像是在 XenServer 以外的其他虚拟机管理程序上构建的，请选中使用操作系统修复复选框，并选择可以存储所复制的修复 ISO 的 ISO SR，以供 XenServer 使用。 有关此功能的详细信息，请参阅关于 VM 导入和导出。

  • 配置 Transfer VM 网络连接。
    在传输 VM 设置页面上，配置关于 VM 导入和导出的网络连接设置，然后单击下一步继续操作。
    • 从目标池或独立服务器可用网络接口的列表中选择网络。
    • 要使用自动化的动态主机配置协议 (DHCP) 自动分配网络设置（包括 IP 地址、子网掩码和网关），请选中使用 DHCP 自动获取网络设置。
    • 要手动配置网络连接设置，请单击使用以下网络设置并输入 IP 地址、子网掩码和网关。
  • 在完成页面上，检查所有的导入设置，然后单击完成，以开始执行导入过程并关闭该向导。

    导入进度将显示在 XenCenter 窗口底部的状态栏中以及通知的事件视图上。

    导入过程可能需要一些时间，具体取决于所导入虚拟磁盘的大小、可用网络带宽以及 XenCenter 主机的磁盘接口速度。 导入完毕后，新导入的 VM 将显示在资源窗格中。
    注: 使用 XenCenter 导入包含 Windows 操作系统的磁盘映像之后，必须设置 platform 参数。 参数的设置因磁盘映像中所含 Windows 版本不同而异：

    • 对于 Windows Vista、Server 2008 及更高版本，请将 platform 参数设置为 device_id=0002。 例如：

      xe vm-param-set uuid=<VM UUID> platform:device_id=0002

    • 对于所有其他 Windows 版本，请将 platform 参数设置为 viridian=true。 例如：

      xe vm-param-set uuid=<VM UUID> platform:viridian=true


从 XVA 导入 VM

通过 XenCenter 的导入向导，可以导入先前以 XVA 格式（文件扩展名为 .xva）或 XVA 版本 1 格式（文件扩展名为 ova.xml 及其关联文件）导出并存储在本地的 VM、模板和快照。

从 XVA 或 ova.xml 文件导入 VM 时，所涉及的步骤与使用新建 VM 向导创建和置备新 VM 时的步骤相同，例如指定主服务器，以及为新 VM 配置存储和网络连接；有关其中每个步骤的详细信息，请参阅创建新 VM。
重要: 如果 VM 是从具有不同 CPU 类型的其他服务器导出的，则该 VM 在导入后并不一定能够运行。 例如，如果在包含支持 Intel VT 的 CPU 的服务器上创建了一个 Windows VM，在将其导出后再导入到包含 AMD-V CPU 的服务器上时，该 VM 可能无法运行。

过程

  1. 通过执行以下操作之一打开导入向导：
    • 在资源窗格中，单击鼠标右键，然后选择快捷菜单上的导入。
    • 在文件菜单中，选择导入。
  2. 在该向导的第一页上，找到要导入的 XVA（或 ova.xml）文件，然后单击下一步。 如果您在文件名框中输入 URL 位置 (http | https | file | ftp)，则在单击下一步时，将打开下载软件包对话框，您必须指定 XenCenter 主机上用于保存该文件的文件夹。
  3. 在主服务器页面上，指定要用来放置新 VM 的位置：
    • 要将所导入的 VM 放置在池中而不为其分配主服务器，请在列表中选择目标池，然后单击下一步。
    • 要将所导入的 VM 放置在池中并将其分配给特定的主服务器（或者将其放在独立服务器上），请选择服务器，然后单击下一步继续操作。
  4. 在存储页面上，选择要用来放置所导入虚拟磁盘的存储库 (SR)，然后单击下一步继续操作。
  5. 在网络连接页面上，将导入的 VM 中的虚拟网络接口映射到目标池中的目标网络。 此页面上列表中显示的网络和 MAC 地址作为初始（导出）VM 定义的一部分存储在导出文件中。 要将传入的虚拟网络接口映射到目标网络，请从目标网络列的列表中选择网络。

    单击下一步继续操作。

  6. 在导入向导的最后一页上，检查已选择的配置选项。 要在导入过程完毕并置备新 VM 后立即启动所导入的 VM，请选中导入后启动 VM 复选框。
  7. 单击完成，以开始导入所选文件并关闭该向导。

    导入进度将显示在 XenCenter 窗口底部的状态栏中以及通知的事件视图上。

    导入过程可能需要一些时间，具体取决于所导入 VM 的虚拟磁盘的大小、可用网络带宽以及 XenCenter 主机的磁盘接口速度。 当新导入的 VM 可用时，将显示在资源窗格中。


将 VM 导出为 OVF/OVA

可以使用 XenCenter 的导出向导将一个或多个 VM 导出为 OVF 或 OVA 包。 要打开向导，请选择要导出的 VM，然后单击 VM 菜单上的导出。 请注意，导出 VM 前，必须将其关闭或挂起。

请注意，必须具有“池管理员”RBAC 角色才能将 VM 导出为 OVF/OVA。 导出向导将在启动时执行检查，以确保您具有“池管理员”角色，然后才允许您继续操作。 有关 RBAC 角色的详细信息，请参阅 RBAC 概述。

过程

  1. 打开导出向导：选择要导出的 VM 所在的池或服务器，然后在 VM 菜单上单击导出。
  2. 在该向导的第一页上，输入导出文件的名称，指定将保存导出文件的文件夹，然后从格式列表中选择 OVF/OVA 包(*.ovf, *.ova)，然后单击下一步。
  3. 选择要导出的 VM，然后单击下一步。
  4. 在 EULA 页面上，可以在软件包中添加先前准备的最终用户许可协议 (EULA) 文档（.rtf 或 .txt）。 要在文本编辑器中查看 EULA 的内容，请在列表中选择 EULA，然后单击查看。 如果不希望在软件包中包括 EULA，只需单击下一步继续操作。
  5. 在“高级选项”页面上，指定清单、签名和输出文件选项，或者直接单击“下一步”继续操作。
    1. 要为软件包创建清单，请选中创建清单复选框。 清单文件可提供软件包中其他文件的清单或列表，用于确保最初在创建软件包时包含的文件与软件包到达时所包含的文件相同。 导入文件时，将使用校验和来验证在创建软件包后文件是否发生过更改。
    2. 要为软件包添加数字签名，请选中签署 OVF 包复选框，通过浏览找到证书，然后在私钥密码对话框中输入与该证书相关联的私钥。 导入具有签名的软件包时，用户可以使用证书的公钥来验证数字签名，从而验证软件包创建者的身份。 请使用已由受信任的证书颁发机构创建并导出为 .pem 或 .pfx 文件的 X.509 证书，该文件中包含清单文件的签名及用来创建该签名的证书。
    3. 要将选定的 VM 输出为 OVA 格式的单个 (tar) 文件，请选中创建 OVA 包复选框。 有关不同文件格式的详细信息，请参阅开放虚拟化格式（OVF 和 OVA）。
    4. 要压缩软件包中包括的虚拟硬盘映像（.VHD 文件），请选中压缩 OVF 文件复选框。 默认情况下，当您创建设备软件包时，导出的虚拟硬盘映像所占用的空间量与分配给 VM 的空间量相同。 例如，如果为 VM 分配了 26 GB 空间，则该 VM 的硬盘映像也将占用 26 GB 空间，而不考虑该 VM 实际是否需要这么多的空间。 请注意，压缩 VHD 文件会增加完成导出过程所需要的时间，导入包含压缩 VHD 文件的软件包时，所需要的时间也会增加，因为导入向导在导入这些文件时必须将所有 VHD 映像解压。
    如果创建 OVA 包和压缩 OVF 文件选项均处于选中状态，将生成一个压缩的 OVA 文件 *.ova.gz。
  6. 在传输 VM 设置页面上，为用来执行导出过程的临时 VM（“传输 VM”）配置网络连接选项。 单击下一步继续操作。
  7. 在该向导的最后一页上，检查在前面的页面上选择的设置。 要让向导验证导出的软件包，请选中导出完成时进行验证复选框。 单击完成，以开始导出所选 VMs 并关闭该向导。

    导出过程可能需要一些时间，具体取决于虚拟磁盘的大小、可用网络带宽以及 XenCenter 主机的磁盘接口速度。 导出进度将显示在 XenCenter 窗口底部的状态栏中以及通知下的事件视图中。

    要取消正在进行的导出操作，请依次单击通知和事件，在事件列表中找到该导出事件，然后单击取消。


将 VM 导出为 XVA

通过导出向导，可以将单个 VM 导出为 XVA 文件。 导出 VM 前，必须将其关闭或挂起。
注: 如果 VM 是从具有不同 CPU 类型的其他服务器导出的，则该 VM 在导入后并不一定能够运行。 例如，如果在包含支持 Intel VT 的 CPU 的服务器上创建了一个 Windows VM，在将其导出后再导入到包含 AMD-V CPU 的服务器上时，该 VM 可能无法运行。

过程

  1. 选择要导出的 VM，然后单击 VM 菜单上的导出。
  2. 在该向导的第一页上，输入导出文件的名称，指定要保存导出文件的文件夹，然后从格式列表中选择 XVA 文件 (*.xva)，然后单击下一步。
  3. 在虚拟机页面上的列表中，要导出的 VM 处于选定状态。 导出为 XVA 时，在该列表中只能选择一个 VM。 单击下一步继续操作。
  4. 在该向导的最后一页上，检查在前面的页面上选择的设置。 要让向导验证导出的 XVA 文件，请选中导出完成时进行验证复选框。 单击完成，以开始导出所选 VM 并关闭该向导。

    导出过程可能需要一些时间，具体取决于 VM 虚拟磁盘的大小、可用网络带宽以及 XenCenter 主机的磁盘接口速度。 进度将显示在 XenCenter 窗口底部的状态栏中以及通知的事件视图上。

    要取消正在进行的导出操作，请依次单击通知和事件，在事件列表中找到该导出事件，然后单击取消。


VM 快照

主题

  • 关于快照
  • 生成 VM 快照
  • 还原到快照
  • 从快照创建新 VM
  • 从快照创建新模板
  • 将快照导出到文件
  • 删除快照


关于快照

虚拟机快照是运行中的虚拟机 (VM) 在某个时间点的记录。 生成 VM 的快照时，其存储信息（硬盘驱动器上的数据）和元数据（配置信息）也会同时保存。 如有必要，在生成快照时会暂时停止 I/O，以确保捕获具有自我一致性的磁盘映像。

与 VM 导出不同，创建快照时无需事先关闭 VM。 快照类似于普通的 VM 模板，但是其中包含原始 VM 的所有存储和配置信息（包括网络连接信息）。 快照是一种快捷的模板创建方式，可以导出作为备份并在之后进行还原，也可以用来快速创建新的 VM。

虽然所有存储类型都支持快照，但对基于 LVM 的存储类型（XenServer 5.5 或更高版本）而言，如果存储库是使用早期版本的 XenServer 创建的，则必须将其升级，而且卷必须采用默认格式；请参阅升级旧 SR。

快照类型

XenCenter 支持全部三种类型的 VM 快照：仅磁盘快照、静态快照以及磁盘和内存快照。 有关详细信息，请参阅生成 VM 快照。

仅磁盘快照

仅磁盘快照存储 VM 的配置信息（元数据）和磁盘（存储），并允许导出和还原这些信息以作为备份。 此类快照具有崩溃状态一致性，适用于所有 VM 类型（包括 Linux VM）。

静态快照

静态快照利用 Windows 卷影复制服务 (VSS) 生成具有应用一致性的实时快照。 VSS 框架帮助可识别 VSS 的应用程序（例如 Microsoft Exchange 或 Microsoft SQL Server）在生成快照前将数据刷新到磁盘并为快照做好准备。 因此，还原静态快照比较安全，但当生成静态快照时，这些快照可能会对系统性能产生更大的影响。 如果负载过重，还可能会失败，因此生成此类快照可能需要进行多次尝试。

有关操作系统对静态快照的支持的信息，以及有关静态快照在 XenServer 中实现方式的详细信息，请参阅《XenServer 管理员指南》。
重要: XenServer VSS 提供程序用于使来宾文件系统处于静默状态，以便为快照做好准备，它将作为 XenServer Tools 的一部分进行安装，但是默认情况下并未启用。 要启用 VSS 提供程序，请按照《XenServer 虚拟机用户指南》中的说明操作。

磁盘和内存快照

磁盘和内存快照除了保存 VM 的元数据和磁盘外，还保存 VM 的内存状态 (RAM)。 还原到磁盘和内存快照不需要重新启动 VM，生成此类快照时，VM 可以处于运行状态，也可以处于挂起状态。 如果正在升级或修补软件，或者要测试新应用程序，但同时又希望能有机会返回到 VM 的当前（更改前）状态 (RAM)，磁盘和内存快照会非常有用。

访问孤立快照

如果您生成 VM 的快照，并在随后删除原始 VM，则您仍可以在“资源”窗格中访问这些快照。 在“导航”窗格中切换到对象视图，然后展开快照组，查看所有可用的快照。


生成 VM 快照

执行以下步骤，生成虚拟机的快照：

  1. 在资源窗格中选择 VM，然后单击快照选项卡。
  2. 单击生成快照按钮。 或者
    • 在属性窗格中单击鼠标右键，然后单击生成快照。
    • 在 VM 菜单上，单击生成快照。
  3. 输入新快照的名称和可选说明。
  4. 在快照模式下，选择要创建的快照的类型：
    • 要创建仅磁盘快照，请选择生成虚拟机磁盘快照。

    • 要创建静态快照，请选择生成虚拟机磁盘快照，然后单击生成快照前使 VM 静止。

    • 要创建磁盘和内存快照，请选择生成虚拟机磁盘和内存快照。
  5. 单击确定开始创建新快照。 进度将显示在状态栏中以及通知的事件视图上。

    创建新快照之后，新创建的快照将显示在 VM 的快照选项卡上以及文件夹视图资源窗格中的“快照”组下：

    • 仅磁盘快照

    • 磁盘和内存快照


还原到快照

通过还原到快照，可以将 VM 还原为创建快照时的状态。 将放弃自生成快照以来对 VM 进行的所有更改，并失去 VM 的当前状态。

还原到快照对话框中的一个选项可用来在还原早期快照之前生成当前 VM 状态的新快照，从而可以在需要时将 VM 轻松地还原到当前状态。

  1. 在快照选项卡上，选择快照，然后单击还原到。

    如果要还原到计划快照（使用 VM 保护和恢复功能自动创建的快照），需要在快照选项卡上显示计划快照，然后才能进行选择：单击视图，然后单击计划快照。

  2. 如果要在将 VM 还原到早期快照之前生成 VM 当前状态的新快照，请选中相应的复选框。
  3. 单击是。


从快照创建新 VM

从快照创建新 VM 的过程与使用新建 VM 向导从常规 VM 模板创建 VM 的过程完全相同。

从快照创建新 VM

  1. 在快照选项卡上，选择要使用的快照，单击鼠标右键，然后在快捷菜单上单击从快照新建 VM。

    新建 VM 向导随即打开，并显示在模板页面上预先选择的快照。

  2. 按照新建 VM 向导中的步骤创建新 VM。 请参阅创建新 VM。

从孤立快照创建新 VM

如果用来创建快照的原始 VM 已删除，可以按如下方式选择快照并启动新建 VM 向导：

  1. 在资源窗格中，切换到“文件夹”视图。
  2. 单击展开类型组，然后展开快照组。
  3. 选择快照，单击鼠标右键，然后在快捷菜单上单击从快照新建 VM。


从快照创建新模板

尽管不能直接复制 VM 快照，但可以从快照创建新的 VM 模板，然后使用该模板来创建快照副本。 模板是“黄金映像”- 在创建新 VM 时用作主副本的普通 VM。 以所需方式设置 VM 并生成其快照后，可以将该快照另存为一个新模板，并使用该模板为同一资源池中进行了特殊配置的 VM 创建副本。 请注意，如果这样操作，将不保存快照的内存状态。

将快照另存为新模板

  1. 在快照选项卡上，选择快照，单击鼠标右键，然后单击快捷菜单上的从快照创建模板。
  2. 输入新模板的名称，然后单击确定。 成功创建新模板后，它将作为自定义模板显示在资源窗格中以及新建 VM 向导的模板页面上。

将孤立快照另存为新模板

如果用来创建快照的原始 VM 已删除，则可以按如下方式将该快照另存为新模板：

  1. 在资源窗格中，切换到“文件夹”视图。
  2. 单击展开类型组，然后展开快照组。
  3. 选择快照，单击鼠标右键，然后在快捷菜单上单击从快照创建模板。


将快照导出到文件

在导出 VM 快照时，它会作为 VM 模板保存在本地计算机上的一个 XVA 文件中。 该模板中包含此快照的完整副本（包括磁盘映像），随后可以将其导入，并用来在相同或不同的资源池中创建新的 VM。

将快照导出到文件

  1. 在快照选项卡上，选择快照，单击操作，然后单击导出到文件。
  2. 通过浏览找到要在其中创建 XVA 文件的文件夹，输入文件名，然后单击保存开始导出。

导出孤立快照

如果用来创建快照的原始 VM 已删除，则可以按如下方式导出快照：

  1. 在资源窗格中，切换到“文件夹”视图。
  2. 单击展开类型组，然后展开快照组。
  3. 选择快照，单击鼠标右键，然后在快捷菜单上选择将快照导出为模板。
  4. 通过浏览找到要在其中创建 XVA 文件的文件夹，输入文件名，然后单击保存开始导出。


删除快照

删除快照

  1. 在快照选项卡上，选择快照，然后单击删除。
  2. 单击确定进行确认。

删除孤立快照

如果用来创建快照的原始 VM 已删除，则可以按如下方式删除快照：

  1. 在资源窗格中，切换到“文件夹”视图。
  2. 单击展开类型组，然后展开快照组。
  3. 选择快照，单击鼠标右键，然后在快捷菜单上单击删除快照。


XenServer vApp

主题

  • 管理 vApp
  • 创建 vApp
  • 修改 vApp
  • 删除 vApp
  • 启动和关闭 vApp
  • 导出和导入 vApp


管理 vApp

XenServer vApp 是由一个或多个相关虚拟机 (VM) 组成的逻辑组，可以作为单个实体来管理。 vApp 中的 VM 不必驻留在一台主机服务器上，将按照通常的规则分布在池中。

启动 vApp 时，其中包含的 VM 将按照用户定义的顺序启动，使彼此依赖的 VM 可以自动排成序列。 这意味着在整个服务需要重新启动时（例如，在软件更新时），您不需要手动安排相关 VM 的启动顺序。

使用“管理 vApp”对话框

使用 XenCenter 的管理 vApp 对话框，可以在选定池内创建、删除、修改、启动、关闭、导入和导出 vApp。 当您在列表中选择某个 vApp 时，其中包含的 VM 会列在右侧的详细信息窗格中。
控件 | 功能
新建 vApp | 打开新建 vApp 向导。 请参阅创建 vApp。
删除 | 删除选定的 vApp。 该 vApp 中的 VM 将不会删除。
属性 | 打开所选 vApp 的属性对话框。 在该对话框中，可以更改所选 vApp 的名称或说明，在 vApp 中添加或删除 VM，更改 VM 的启动顺序和延迟间隔。 请参阅修改 vApp。
开始 | 按照指定的顺序启动所选 vApp 中的所有 VM，启动序列由每个 VM 上设置的启动顺序和延迟间隔值确定。 请参阅启动和关闭 vApp。
关闭 | 关闭所选 vApp 中的所有 VM。 请参阅启动和关闭 vApp。
导入 | 打开导入向导并将 OVF/OVA 包作为 vApp 导入。 请参阅导出和导入 vApp。
导出 | 打开“导出”向导并将 vApp 导出为 OVF/OVA 包。 请参阅导出和导入 vApp。


创建 vApp

要创建新的 vApp，可使用“管理 vApp”对话框。

  1. 选择池，然后在池菜单上，单击管理 vApp。

    或者，在资源窗格中单击鼠标右键，然后单击快捷菜单上的管理 vApp。

  2. 在“管理 vApp”对话框左上角，单击新建 vApp...。
  3. 输入新 vApp 的名称和（可选）说明，然后单击下一步。 可以根据自己的喜好选择任何名称，但通常最好使用描述性的名称。 尽管建议您避免为多个 vApp 使用相同的名称，但并不是必须要这样做，XenCenter 不会针对 vApp 名称实施唯一性约束。 对于包含空格的名称，不必使用引号。
  4. 选择要包含在新 vApp 中的虚拟机，然后单击下一步。 可以使用搜索框仅列出名称中包含指定字符串的 VM。
  5. 为该 vApp 中的 VM 指定启动顺序，然后单击下一步。
    值 | 说明
    启动顺序 | 指定各个 VM 在 vApp 中的启动顺序，使某些 VM 先于其他 VM 重新启动。 启动顺序值为 0（零）的 VM 将首先启动，启动顺序值为 1 的 VM 接着启动，然后是启动顺序值为 2 的 VM，以此类推。
    尝试在以下时间后启动下一个 VM | 这是一段延迟时间间隔，用于指定从启动 VM 到尝试启动启动序列中下一组 VM（即，启动顺序更靠后的 VM）之间的等待时间。

    请注意，vApp 中 VM 的关闭顺序始终与所配置的启动顺序相反。

  6. 在该向导的最后一页上，可以检查 vApp 配置。 单击上一步返回并修改任何设置，或者单击完成创建新的 vApp 并关闭向导。


修改 vApp

要更改 vApp 的名称或说明、在 vApp 中添加或删除 VM 以及更改 vApp 中 VM 的启动顺序，请使用管理 vApp 对话框。

  1. 选择池，然后在池菜单上，单击管理 vApp。

    或者，在资源窗格中单击鼠标右键，然后单击快捷菜单上的管理 vApp。

  2. 选择 vApp，然后单击 [image] 属性打开其属性对话框
  3. 单击常规选项卡，以更改该 vApp 的名称或说明。
  4. 单击虚拟机选项卡以在该 vApp 中添加或删除 VM。
  5. 单击 VM 启动顺序以更改该 vApp 中各个 VM 的启动顺序和延迟间隔值。

    控件

            说明
    启动顺序 | 指定各个 VM 在 vApp 中的启动顺序，使某些 VM 先于其他 VM 重新启动。 启动顺序值为 0（零）的 VM 将首先启动，启动顺序值为 1 的 VM 接着启动，然后是启动顺序值为 2 的 VM，以此类推。
    尝试在以下时间后启动下一个 VM | 这是一段延迟时间间隔，用于指定从启动 VM 到尝试启动启动序列中下一组 VM（即，启动顺序更靠后的 VM）之间的等待时间。

    请注意，vApp 中 VM 的关闭顺序始终与所配置的启动顺序相反。

  6. 单击确定保存所做的更改并关闭属性对话框。


删除 vApp

要从池中删除 vApp，请使用管理 vApp 对话框。

  1. 选择池，然后在池菜单上，单击管理 vApp。

    或者，在资源窗格中单击鼠标右键，然后单击快捷菜单上的管理 vApp。

  2. 在列表中选择要删除的 vApp，然后单击 [image] 删除。

    该 vApp 中的 VM 将不会删除。


启动和关闭 vApp

要启动或关闭 vApp，请使用管理 vApp 对话框，可以从池菜单进入该对话框。

在启动 vApp 时，其中所有的 VM 都将自动按顺序启动。 为每个 VM 指定的启动顺序值和延迟间隔值控制着启动序列；这些值可以在首次创建 vApp 时设置，并随时从 vApp 的属性对话框或从各个 VM 的属性对话框进行更改。

vApp 中 VM 的关闭顺序始终与所配置的启动顺序相反。

启动 vApp

  1. 打开管理 vApp 对话框：选择该 vApp 中的 VM 所在的池，在池菜单上，单击管理 vApp。

    或者，在资源窗格中单击鼠标右键，然后单击快捷菜单上的管理 vApp。

  2. 选择该 vApp，然后单击 [image] 启动来启动其中包含的所有 VM。

关闭 vApp

  1. 打开管理 vApp 对话框：选择该 vApp 中的 VM 所在的池，在池菜单上，单击管理 vApp。

    或者，在“资源”窗格中单击鼠标右键，然后单击快捷菜单上的管理 vApp。

  2. 选择该 vApp，然后单击 [image] 关闭来关闭该 vApp 中的所有 VM。 系统将尝试对所有 VM 执行软关闭，如果不可行，将执行强制关闭。 要了解有关 VM 软关闭和强制关闭的详细信息，请参阅关闭 VM。


导出和导入 vApp

导出 vApp

vApp 可以导出为 OVF/OVA 包。

  1. 打开管理 vApp 对话框：在池菜单上，单击管理 vApp。
  2. 在列表中选择要导出的 vApp，然后单击 [image] 导出。
  3. 请按照将 VM 导出为 OVF/OVA 中所述的步骤执行操作。

    导出 vApp 可能需要一段时间。

导入 vApp

OVF/OVA 包可以作为 vApp 导入。

  1. 打开管理 vApp 对话框：在池菜单上，单击管理 vApp。
  2. 单击 [image] 导入打开导入向导。
  3. 请按照从 OVF/OVA 导入 VM 中所述的步骤执行操作。

    在导入完成时，新的 vApp 将出现在管理 vApp 对话框内的 vApp 列表中。


保护 VM 和 vApp

XenServer 提供了一系列用来保护 VM 和 vApp 的功能。

VM 保护和恢复 (VMPR) - 计划快照

XenServer VM 保护和恢复 (VMPR) 功能通过定期按计划生成 VM 快照来防止各 VM 丢失，当原始 VM 损坏或不可访问时，可以将这些快照重新导入 XenCenter 中并使用快照重新创建该 VM。

阅读更多信息：关于 VM 保护和恢复；创建 VM 保护策略；管理 VM 保护策略；从快照恢复 VM

重要: VMPR 及其功能已从 XenServer 6.2.0 及更高版本中删除。 依赖于 VMPR 的应用程序、代码或用法在 XenServer 6.2.0 及更高版本中将无法运行。 VM 快照功能及依赖于 VM 快照的功能（VMPR 除外）不受影响。 有关详细信息，请参阅 CTX137335。

高可用性 (HA)

XenServer 高可用性功能可以确保 VM 能够自动在池中的备用服务器上重新启动，以防止关键 VM 因池中某一服务器发生故障而导致停机，从而最大程度地减少服务中断。 池数据库不断在所有节点之间复制，并且备份到检测信号 SR 上的共享存储中，从而进一步提高了安全性。

阅读更多信息：关于 XenServer 高可用性；高可用性要求；VM 启动设置；配置高可用性；禁用高可用性；更改高可用性设置

灾难恢复 (DR)

XenServer 灾难恢复 (DR) 功能可以防止主数据站点中的多台服务器丢失。 启用灾难恢复后，不断通过镜像存储复制池数据库，如果主站点中出现灾难，VM 和 vApp 可以从镜像存储恢复到辅助 (DR) 站点上的池中。

阅读更多信息：关于 XenServer DR；配置 DR；故障转移；故障恢复；测试故障转移


VM 保护和恢复 (VMPR)

重要: VMPR 及其功能已从 XenServer 6.2.0 及更高版本中删除。 依赖于 VMPR 的应用程序、代码或用法在 XenServer 6.2.0 及更高版本中将无法运行。 VM 快照功能及依赖于 VM 快照的功能（VMPR 除外）不受影响。 有关详细信息，请参阅 CTX137335。

主题：

  • 关于 VM 保护和恢复
  • 创建 VM 保护策略
  • 管理 VM 保护策略
  • 从计划快照恢复 VM


关于 VM 保护和恢复

重要: VMPR 及其功能已从 XenServer 6.2.0 及更高版本中删除。 依赖于 VMPR 的应用程序、代码或用法在 XenServer 6.2.0 及更高版本中将无法运行。 VM 快照功能及依赖于 VM 快照的功能（VMPR 除外）不受影响。 有关详细信息，请参阅 CTX137335。

VM 保护和恢复 (VMPR) 功能为关键的服务 VM 提供了一个简单的备份和还原实用程序。 系统将自动生成定期计划快照，并用来还原相应的 VM。

VMPR 依托池级别的 VM 保护策略而运行，这些策略定义池中选定 VM 的快照计划。 启用策略后，将在每小时、每天或每周的预定时间生成指定 VM 的快照。 如果进行了相应配置，这些快照还可以自动存档到远程 CIFS 或 NFS 共享位置，从而提供额外安全性。

在一个池中可以启用多个 VMPR 策略，这些策略可以覆盖不同的 VM 并且可以制定不同的计划。 每次只能将一个 VM 分配到一个策略。

XenCenter 提供了一系列工具，可帮助您使用 VMPR 功能：

  • 要定义 VMPR 策略，请使用新建 VM 保护策略向导。
  • 要针对池启用、禁用、编辑和删除 VMPR 策略，可以使用 VM 保护策略对话框。
  • 要编辑策略，请从 VM 保护策略对话框中打开该策略的“属性”对话框。
  • 要从计划快照恢复 VM，只需在快照选项卡上选择该快照，然后将 VM 还原到该快照。
  • 要从存档的计划快照恢复 VM，请导入该快照，创建新的自定义 VM 模板，然后通过该模板创建新的 VM。


创建 VM 保护策略

重要: VMPR 及其功能已从 XenServer 6.2.0 及更高版本中删除。 依赖于 VMPR 的应用程序、代码或用法在 XenServer 6.2.0 及更高版本中将无法运行。 VM 快照功能及依赖于 VM 快照的功能（VMPR 除外）不受影响。 有关详细信息，请参阅 CTX137335。

使用新建 VM 保护策略向导可以创建 VM 保护策略，用来确定池中要生成快照的 VM、要创建的快照的类型（仅磁盘快照或磁盘和内存快照）以及快照和存档计划。 还可以使用该向导为快照和存档事件警报配置电子邮件通知。

打开新建 VM 保护策略向导：在池菜单上单击“VM 保护策略”打开 VM 保护策略对话框，然后单击新建启动向导。

选择要保护的 VM

池中所有的 VM 都列在该向导页上。 如果某个 VM 已经包含在 VM 保护策略中，则会显示该策略的名称。 VM 每次只能分配给一个策略，因此，如果将某个 VM 分配给新策略，它将从当前的策略中删除（系统会要求您确认此操作）。

选择快照类型

计划的 VM 快照可以是仅磁盘快照，也可以是磁盘和内存快照。

  • 仅磁盘快照存储 VM 的磁盘（存储）和元数据。 它们具有崩溃状态一致性，可以在所有 VM 类型（包括 Linux VM）上执行。
  • 磁盘和内存快照保存 VM 的磁盘（存储）、元数据及其当前内存状态 (RAM)。 请注意，此类快照可能会非常大。

设置快照计划和保留期限

快照计划选项：

  • 每小时快照在每小时的指定时间生成指定 VM 的快照。
  • 每天快照在每天的指定时间生成指定 VM 的快照。
  • 每周快照在每周的指定日期的指定时间生成指定 VM 的快照。 可以选择一天或多天。

快照保留策略

在要保留的快照数下，指定要保留的计划快照的数量。 当生成的计划快照的数量超过该值时，系统将自动删除最早的快照。

注: 最大计划快照数上限为 10。

设置存档计划

如果需要，计划快照会自动存档到远程 CIFS 或 NFS 共享位置。 您可以定义一个独立于快照计划的每日或每周存档计划，或者只是在生成计划快照之后立即将其存档（在生成每个计划快照后存档选项）。 您所定义的存档计划的存档频率不能高于快照计划的频率。

存档命名约定

存档文件夹的名称由 VM 名称和 VM UUID 的前 16 位字符组成。 例如：

VM 名称 | VM UUID | 存档文件夹名称
Win7_Test_1 | cb53200c-bbd8-4c12-a076-e2eb29b38f06 | Win7_Test_1-cb53200c-bbd8-4c

放在存档文件夹中的已存档计划快照采用 YYYYMMDD-HHMM.xva 格式命名。 例如：

20100624-1830.xva
20100624-1836.xva
20100625-0031.xva

配置电子邮件警报

针对任何计划快照或存档操作生成系统警报时，系统会发送电子邮件通知。 默认情况下，VMPR 事件电子邮件通知处于关闭状态。


管理 VM 保护策略

重要: VMPR 及其功能已从 XenServer 6.2.0 及更高版本中删除。 依赖于 VMPR 的应用程序、代码或用法在 XenServer 6.2.0 及更高版本中将无法运行。 VM 快照功能及依赖于 VM 快照的功能（VMPR 除外）不受影响。 有关详细信息，请参阅 CTX137335。

要针对池启用、禁用、编辑和删除 VM 保护策略，可以使用 VM 保护策略对话框：在“池”菜单上，单击 VM 保护策略。

启用 VM 保护策略

启用 VM 保护策略时，该策略将“打开”：随后将在计划的时间生成并存档（如果同时进行了相应配置）指定 VM 的自动快照。 计划快照将继续生成，直至该策略被禁用。

启用策略：

  1. 在资源窗格中，选择池或池中的任何服务器或 VM，然后在池菜单上，选择 VM 保护策略。
  2. 从该池中定义的策略列表中选择一个策略，然后单击启用。

禁用 VM 保护策略

如果要停止生成自动 VM 快照，可以使用“VM 保护策略”对话框禁用 VM 保护策略：已经禁用的策略可以随时再次启用。

禁用策略：

  1. 在资源窗格中，选择池或池中的任何服务器或 VM，然后在池菜单上，选择 VM 保护策略。
  2. 从该池中定义的策略列表中选择策略，然后单击禁用。

编辑 VM 保护策略

可以更改 VMPR 策略，例如添加更多的 VM 或者更改快照计划：

  1. 在资源窗格中，选择池或池中的任何服务器或 VM，然后在池菜单上，选择 VM 保护策略。
  2. 从该池中定义的策略列表内选择策略，单击属性并转至所需的选项卡：
    选项卡 | 目录
    受保护的 VM | 在该选项卡上添加或删除 VM。 VM 每次只能分配给一个策略，因此，如果将 VM 分配给新策略，它将从当前策略中删除。
    快照类型 | 更改将创建的快照的类型。
    快照计划 | 更改用于生成 VM 快照的计划，以及更改快照的保留策略。
    存档选项 | 打开和关闭自动存档功能并设置存档计划。
    电子邮件警报 | 为计划快照或存档操作的系统警报配置电子邮件通知。
  3. 单击确定保存所做的更改并关闭属性窗口。

删除 VM 保护策略

要删除 VM 保护策略，请执行以下操作：

  1. 在资源窗格中，选择池或池中的任何服务器或 VM，然后在池菜单上，选择 VM 保护策略。
  2. 从该池中定义的策略列表中选择策略，然后单击删除。


从快照恢复 VM

从计划快照恢复 VM

重要: VMPR 及其功能已从 XenServer 6.2.0 及更高版本中删除。 依赖于 VMPR 的应用程序、代码或用法在 XenServer 6.2.0 及更高版本中将无法运行。 VM 快照功能及依赖于 VM 快照的功能（VMPR 除外）不受影响。 有关详细信息，请参阅 CTX137335。

要从计划快照恢复 VM，只需将 VM 还原到指定的快照即可。

  1. 选择 VM，然后单击快照选项卡。
  2. 显示计划快照（默认情况下计划快照不显示在该选项卡上）：单击视图，然后单击计划快照。
  3. 选择要将 VM 还原到的计划快照，然后单击还原到。
  4. 如果要在将 VM 还原到计划快照之前生成 VM 当前状态的新快照，请选中相应的复选框。
  5. 单击是将 VM 还原到选定的快照。

从存档快照恢复 VM

要从存档的计划快照恢复 VM，请按照下列步骤操作：

  1. 在本地装载 CIFS 或 NFS 存档共享目标。
  2. 按照从 XVA 导入 VM 中的说明，使用导入向导从目标导入存档 XVA 文件。 该操作将创建新的自定义 VM 模板。
  3. 按照创建新 VM 中的说明，使用新建 VM 向导基于新模板创建新的 VM。

    有关存档文件夹和存档快照的命名方式的信息，请参阅存档命名约定。


高可用性

主题：

  • 关于 XenServer 高可用性
  • 高可用性要求
  • VM 重新启动设置
  • 配置高可用性
  • 禁用高可用性
  • 更改高可用性设置


关于 XenServer 高可用性

XenServer 高可用性功能允许在基础硬件出现故障或任何托管服务器丢失时自动重新启动虚拟机。 高可用性功能可以确保重要的 VM 始终在资源池中运行。 启用高可用性功能后，如果一个服务器出现故障，其 VM 将智能地在同一个池中的其他服务器上重新启动，使基本服务在系统或组件出现故障的情况下得以还原，从而最大程度减少服务中断。 如果池主服务器出现故障，XenServer 高可用性功能会自动选择一个新服务器来接替主服务器，以便您可以继续管理该池。 池中的任何服务器都可以充当主服务器，池数据库不断在所有节点之间进行复制，而且还会备份到检测信号 SR 上的共享存储中，从而提高安全性。

XenServer 高可用性功能包括两个主要方面：可靠地检测服务器故障；计算故障计划以实现快速恢复。下面将详细介绍这两个方面。

通过检测信号判断可用性

您需要远程对服务器暂时消失与灾难性故障加以区分，因此可靠地检测服务器故障比较困难。 如果我们错误地认定主服务器已发生故障并选择一个新的主服务器来替代它，则在原始主服务器恢复启动后，可能会出现意外的结果。 同样，如果资源池均等地分为两个部分，则当出现网络问题时，我们只需要确保其中的一个部分能够访问共享存储，而不是确保这两个部分能够同时访问共享存储。 XenServer 通过提供以下两个机制来解决所有这些问题：存储检测信号和网络检测信号。

如果在池中启用高可用性功能，应指定 iSCSI、光纤通道或 NFS 存储库作为检测信号 SR。 XenServer 自动在该 SR 中创建几个小型虚拟磁盘。 第一个磁盘是共享仲裁磁盘，由资源池中的每个服务器使用。 每个服务器都在共享磁盘中为自己分配一个唯一的区块，并定期向该区块中写入数据以指示服务器处于活动状态。 当高可用性功能启动时，所有服务器通过网络和存储通道交换数据，以说明它们通过这两个通道可以看到的服务器，即哪些 I/O 路径有效，哪些 I/O 路径无效。 这些信息会一直交换，直到达到某个固定点，并且池中的所有服务器对于彼此就所见内容达成的协议表示满意。 出现这种情况时，高可用性功能处于启用状态，并且资源池受到保护。 对于较大的池来说，这一高可用性置备过程可能需要几分钟时间，但只有在首次启用高可用性功能时才需要进行此过程。

一旦高可用性功能处于活动状态，每个服务器都会定期向检测信号虚拟磁盘中写入存储更新，并通过管理接口写入网络数据包。 应确保绑定网络适配器以保证恢复能力，并且存储接口使用动态多路径（如果支持），这两点非常重要。 这样可以确保任何单个适配器或连线故障不会导致出现任何可用性问题。

服务器防护

对于高可用性功能而言，最坏的情形是服务器被视为脱机，而实际上它正在等待将数据写入共享存储，因为这种情况会导致持久性数据的损坏。 为避免这种情况，XenServer 使用服务器防护功能，即，服务器自动关机并被阻止访问池中的任何共享资源。 这样可防止在自动故障转移期间，在将受保护的虚拟机移动到池中其他运行正常的服务器时，出现故障的服务器向任何共享磁盘写入内容而破坏所存储数据的一致性。

除非满足下列任一条件，否则在出现任何检测信号故障时服务器都将进行自我防护（即，关闭电源并重新启动）。

  • 针对所有服务器存在存储检测信号，但是网络已进行分区（此时存在两组服务器）。 在这种情况下，最大网络分区中的所有成员服务器仍保持运行状态，较小网络分区中的服务器将进行自我防护。 此处假设 VM 已经因网络中断而被隔离，而且应在网络连接正常的服务器上重新启动。 如果各个网络分区的大小完全相等，则只有其中一个分区将根据稳定选择功能进行自我防护。
  • 如果存储检测信号消失，但是网络检测信号仍存在，则服务器会检查它们能否通过网络看到所有其他服务器。 如果能够看到，则这些服务器仍保持运行状态，但前提是存储检测信号已消失。 这样做不会损害 VM 的安全，但是任何网络小问题都会导致服务器进行防护，因为这意味着这两种检测信号都已经消失。

故障容量规划

检测信号系统为我们提供了可靠的服务器故障通知，现在我们继续执行高可用性的第二个步骤：故障容量规划。

一个资源池由多个（例如 16 个）服务器组成，每个服务器上的内存量和正在运行的 VM 数可能各不相同。 为了确保任何单个服务器故障都不会导致其 VM 在其他服务器上无法重新启动（例如，由于任何其他服务器上的内存不足），XenServer 高可用性功能将动态计算故障计划，从而计算出在发生任何服务器故障时将执行的操作。 除了处理单个服务器的故障外，XenServer 高可用性功能还可以处理池中多个服务器丢失的情况（例如，网络分区故障导致丢失整组服务器）。

除了计算将执行的操作外，故障计划还考虑池中可以容忍的服务器故障数。 在计算池的高可用性计划时，有两个重要的考虑因素：

  • 最大故障容量。 即允许的最大故障服务器数，超过该值后，资源将不足以运行池中所有受保护的 VM。XenServer 在计算此值时考虑池中 VM 的重启优先级和池的配置（服务器数量以及服务器上的 CPU 和内存容量）。
  • 服务器故障限制。 该值作为高可用性配置的一部分在高可用性计划中进行定义，用来指定池中允许的服务器故障数。 例如，在由 16 个服务器组成的资源池中，如果将服务器故障限制设置为 3，则 XenServer 计算出的故障转移方案将允许任意 3 个服务器出现故障，而这时仍然能够运行池中所有受保护的 VM。 可以将服务器故障限制配置为小于最大故障容量的值，这会降低池被过度使用的可能性。 这在启用了 RBAC 的环境中非常有用，例如，可允许没有池操作员权限的 RBAC 用户在不违反高可用性计划的情况下将更多 VM 联机；请参阅下面的高可用性和基于角色的访问控制 (RBAC)。

当最大故障容量值小于指定的服务器故障限制值时，将生成系统警报。

过度使用防护

首次对池启用高可用性时，将基于当时可用的资源计算故障计划。 XenServer 高可用性功能会动态计算新故障计划，以响应对池造成影响的事件（例如，启动新的 VM）。 如果由于池中的资源不足（例如，可用内存不足，或者对虚拟磁盘和网络进行的更改影响了哪些 VM 可以在哪些服务器上重新启动）而导致无法计算新计划，则池被过度使用。

在池被过度使用时，使用高可用性重启优先级来确定应启动的 VM。 在高可用性配置对话框或配置高可用性向导中为要保护的 VM 配置重启优先级时，您可以查看正在动态重新计算的池的最大故障容量，从而根据业务需求尝试使用不同的 VM 重启优先级组合，并了解最大故障容量是否适合于池中关键的 VM 所需的保护级别。

如果您尝试启动或恢复 VM 而该操作将导致池被过度使用，则将在 XenCenter 中显示一个警告。 如果配置了一个电子邮件地址，系统还可能会向该电子邮件地址发送警告消息。 您将能够取消该操作或者仍然继续操作，但继续操作会导致池被过度使用。

处理启用了高可用性的池

高可用性功能的最佳做法是，在启用了高可用性功能的情况下不对池进行配置更改， 而应当实施“2am 保护”，在出现问题后在管理员不在现场的情况下重新启动服务器。 如果您主动对池中的配置进行更改（例如应用软件更新），应在执行这些更改期间禁用高可用性功能。

  • 如果您尝试从 XenCenter 关闭受保护的 VM，XenCenter 将允许您首先将该 VM 从池故障计划中删除，然后再将其关闭。 这样可以确保不会因意外的 VM 关闭而导致停机，而当您确实需要停止受保护的 VM 时，仍然可以将其停止。
  • 在启用高可用性功能的情况下，如果您需要重新启动服务器，XenCenter 会自动使用 VM 重启优先级来确定这样做是否会违反池故障计划。 如果不会影响池故障计划，则服务器将会正常关闭。 如果与池故障计划冲突，但最大故障容量大于 1，XenCenter 允许您将池的服务器故障限制减小 1。 这样做会降低池的整体恢复能力，但却始终确保能够应对至少一个服务器故障。 当服务器重新启动时，系统将自动重新计算池故障计划，并还原原始的服务器故障限制（如果适用）。
  • 使用安装更新向导安装软件更新时，将自动对池禁用高可用性功能，直到更新安装完毕。 在安装更新期间，您需要手动监视池，以确保服务器故障不会中断池的运行。
  • 启用高可用性功能后，可能禁用某些会影响重新启动 VM 的方案的操作，例如从池中移除服务器。 要执行这些操作，应当先暂时禁用高可用性功能或者关闭受保护的 VM，然后再继续操作。

高可用性和基于角色的访问控制 (RBAC)

在实现了基于角色的访问控制 (RBAC) 的 XenServer 环境中，并非所有用户都有权更改池的高可用性配置设置。 例如，有权启动 VM 的用户（VM 操作员）没有足够的权限来针对启用了高可用性的池调整故障转移容量。 例如，如果启动某个 VM 会将所允许的最大服务器故障数减少到小于当前的最大故障容量，则 VM 操作员将无法启动该 VM。 只有池管理员或池操作员级别的用户才能够配置所允许的服务器故障数。

在这种情况下，启用高可用性的用户（具有“池管理员”或“池操作员”角色）可以将服务器故障限制设置为实际上小于所允许的最大故障数的值。 这会创建容错容量，从而确保权限较低的用户能够启动新的 VM 并降低池的故障转移容量，而不会威胁故障计划。


高可用性要求

为资源池配置高可用性功能前，必须确保池中所有服务器和虚拟机满足以下要求：

  • 必须提供共享存储，其中包括至少一个大小为 356 MiB 或更大的 iSCSI、光纤通道或 NFS LUN，供检测信号 SR 使用。 如果使用 NetApp 或 EqualLogic 存储阵列，则应在阵列上手动置备一个 iSCSI LUN，供检测信号 SR 使用。
  • 如果启用高可用性功能，强烈建议为池中的服务器使用绑定的管理接口，并且为检测信号 SR 使用多路径存储。
  • 所有服务器上都必须安装充足的许可证。
  • 要通过高可用性功能保护的所有虚拟机必须具有灵活性。 这意味着：
    • 虚拟磁盘必须位于共享存储上。 可以使用任何类型的共享存储；只有存储检测信号要求使用 iSCSI、光纤通道或 NFS LUN，而对于虚拟磁盘存储，可以根据个人喜好使用这些类型的 LUN，对此没有强制性要求。
    • 虚拟网络接口必须位于池级别的网络中。
    • 不应配置与任何本地 DVD 驱动器的连接。

    对于不具有灵活性的 VM（例如，带有从服务器映射的物理 CD 驱动器），只能分配在可能时重新启动高可用性重启优先级，因为这些 VM 绑定到一个服务器。


VM 重新启动设置

如果出现故障的服务器多于计划的故障数量，将开始执行高可用性恢复操作。 高可用性重启优先级用于确定哪些 VM 将重新启动，而各 VM 的启动顺序则由其启动顺序值和延迟间隔值确定，从而确保首先重新启动最重要的 VM。

高可用性重启优先级

高可用性重启优先级指定将根据池的高可用性故障计划而重新启动哪些 VM：

值 | 说明
重新启动 | 如果池中有足够的可用资源，则保证重新启动具有此优先级的 VM。 它们将先于优先级为在可能时重新启动的 VM 而重新启动。 在计算故障计划时，将考虑具有此重启优先级的所有 VM。 如果不存在可使具有此优先级的 VM 可靠地重新启动的计划，则池将被视为过度使用。
在可能时重新启动 | 在计算故障计划时，不考虑具有此重启优先级的 VM，但当运行这些 VM 的服务器出现故障时，将尝试进行一次重新启动。 此次重新启动尝试将在所有优先级更高的 VM 重新启动后进行，如果启动尝试失败，将不再重试。 此设置对于测试/开发 VM 非常有用，在同时包含一些必须始终运行的重要 VM 的池中，这些 VM 不必始终保持运行，但最好能保持运行。
不重新启动 | 不尝试重新启动具有此优先级的 VM。

启动顺序

启动顺序指定各个 VM 在高可用性恢复操作期间的启动顺序，使某些 VM 先于其他 VM 启动。 启动顺序值为 0（零）的 VM 将首先启动，启动顺序值为 1 的 VM 接着启动，然后是启动顺序值为 2 的 VM，依此类推。

延迟间隔（尝试在以下时间后启动下一个 VM）

VM 属性尝试在以下时间后启动下一个 VM 用于指定从启动 VM 到尝试启动启动序列中下一组 VM（即，启动顺序紧随其后的 VM）之间的等待时间。


配置高可用性

可使用配置高可用性向导为资源池启用高可用性。 该向导将引导您逐步完成高可用性配置过程，根据可用资源和您指定的高可用性重启优先级计算池的服务器故障限制。

要打开配置高可用性向导：在 XenCenter 中，选择池，单击高可用性选项卡，然后单击配置高可用性。

或者：

  • 在池菜单上，单击高可用性。
  • 在资源窗格中单击鼠标右键，然后在快捷菜单中单击高可用性。

为池配置高可用性：

  1. 确保满足高可用性要求中列出的高可用性要求。
  2. 打开配置高可用性向导，在向导第一页上单击下一步，以通过扫描该池查找可用作该池检测信号 SR 的共享 iSCSI、光纤通道或 NFS LUN。 如果未找到合适的 SR，需要先配置一个适当的新存储才能继续操作。
  3. 从检测信号 SR 页面上的列表中选择一个 SR，然后单击下一步。
  4. 从高可用性计划页面上的列表中，选择一个或多个 VM 并设置所需的 VM 启动设置。 有关这些选项的详细信息，请参阅 VM 启动设置。 要选择多个相邻虚拟机，请单击要选择的第一个虚拟机，在列表中向下滚动，并在按住 SHIFT 键的同时单击您希望选择的最后一个虚拟机。 要在列表中选择不相邻的几个虚拟机，请单击第一个虚拟机，按住 CTRL 键，然后单击要选择的其他虚拟机。
    选项 | 说明
    高可用性重启优先级 为每个 VM 选择重启优先级：
    • 选择重新启动可确保在池中有足够资源时重新启动选定的 VM。
    • 如果不一定要自动重新启动 VM，请选择在可能时重新启动。
    • 如果您不希望自动重新启动 VM，请选择不重新启动。
    启动顺序 | 指定各个 VM 在高可用性恢复操作期间的启动顺序，使某些 VM 先于其他 VM 启动。 启动顺序值为 0（零）的 VM 将首先启动，重新启动顺序值为 1 的 VM 接着启动，然后是启动顺序值为 2 的 VM，依此类推。
    尝试在以下时间后启动下一个 VM | 这是一段延迟时间间隔，用于指定从启动 VM 到尝试启动启动序列中下一组 VM（即，启动顺序更靠后的 VM）之间的等待时间。
  5. 在高可用性计划页面的服务器故障限制下，可以设置此高可用性计划中允许的服务器故障数。 此值应小于或等于池的最大故障容量（此处表示为最大）。 如果最大为 0（零），则池被过度使用，除非调整高可用性重启优先级或者在池中提供更多的资源，否则将无法继续进入该向导的下一页；请参阅增加池的最大故障容量。 完成高可用性计划的配置后，单击下一步。
  6. 在该向导的最后一页上，检查高可用性配置设置。 单击后退返回并更改任何设置，或者单击完成启用高可用性并关闭该向导。


禁用高可用性

启用高可用性后，某些影响虚拟机重新启动方案的操作（例如从池中删除服务器）可能会被禁用。 要执行这些操作，可以暂时禁用高可用性。

禁用高可用性：

  1. 在资源窗格中选择池，单击高可用性选项卡，然后单击禁用高可用性。
  2. 单击确定进行确认。 系统将存储为池中每个 VM 所指定的 VM 启动设置，如果以后重新启用高可用性功能，这些启动设置将会恢复。


更改高可用性设置

为池启用高可用性功能后，可以从配置高可用性对话框中更改 VM 启动设置并调整池的服务器故障限制。

更改高可用性重启优先级和 VM 启动顺序设置

  1. 在资源窗格中选择池，单击高可用性选项卡，然后单击配置高可用性。 或者：
    • 在池菜单上，单击高可用性。
    • 在资源窗格中单击鼠标右键，然后在快捷菜单中单击高可用性。
  2. 在列表中选择一个或多个 VM，并设置所需的 VM 启动设置。 有关这些选项的详细信息，请参阅 VM 启动设置。 要选择多个相邻虚拟机，请单击要选择的第一个虚拟机，在列表中向下滚动，并在按住 SHIFT 键的同时单击您希望选择的最后一个虚拟机。 要在列表中选择不相邻的几个虚拟机，请单击第一个虚拟机，按住 CTRL 键，然后单击要选择的其他虚拟机。
    选项 | 说明
    高可用性重启优先级 为每个 VM 选择重启优先级：
    • 选择重新启动可确保在池中有足够资源时重新启动选定的 VM。
    • 如果不一定要自动重新启动 VM，请选择在可能时重新启动。
    • 如果您不希望自动重新启动 VM，请选择不重新启动。
    启动顺序 | 指定各个 VM 在高可用性恢复操作期间的启动顺序，使某些 VM 先于其他 VM 启动。 启动顺序值为 0（零）的 VM 将首先启动，启动顺序值为 1 的 VM 接着启动，然后是启动顺序值为 2 的 VM，依此类推。
    尝试在以下时间后启动下一个 VM | 这是一段延迟时间间隔，用于指定从启动 VM 到尝试启动启动序列中下一组 VM（即，启动顺序更靠后的 VM）之间的等待时间。
  3. 单击确定，以应用更改并关闭对话框。

更改池的服务器故障限制

  1. 在资源窗格中选择池，单击高可用性选项卡，然后单击配置高可用性。 或者：
    • 在池菜单上，单击高可用性。
    • 在资源窗格中单击鼠标右键，然后在快捷菜单中单击高可用性。
  2. 在服务器故障限制下，输入允许的服务器故障数。 此值应小于或等于池的最大故障容量（此处表示为最大）。 如果最大为 0（零），则池被过度使用，除非调整高可用性重启优先级或者在池中提供更多的资源，否则将无法保存所做的更改；请参阅增加池的最大故障容量。
  3. 单击确定，以应用更改并关闭对话框。

增加池的最大故障容量

要增加池的最大故障容量，需要执行以下一项或多项操作：

  • 降低某些 VM 的高可用性重启优先级。
  • 增大服务器上的 RAM 量，或者向池中添加更多的服务器以增加池的容量。
  • 减少在某些 VM 上配置的内存量。
  • 关闭非必要的 VM。


灾难恢复 (DR)

主题：

  • 关于 XenServer DR
  • 配置 DR
  • 故障转移
  • 故障恢复
  • 测试故障转移


关于 XenServer DR

XenServer 灾难恢复 (DR) 功能旨在允许您从导致整个池或站点被禁用或破坏的灾难性硬件故障中恢复虚拟机和 vApp。 为应对单服务器故障，可以使用 XenServer 高可用性功能在同一池中的备用服务器上重新启动 VM。

了解 XenServer DR

XenServer DR 的工作方式是，将恢复业务关键 VM 和 vApp 时所需要的所有信息存储到存储库中，然后将这些存储库从主（生产）环境复制到备份环境中。 当主站点上受到保护的池出现故障时，可以从复制的存储恢复该池中的 VM 和 vApp 并在辅助 (DR) 站点上重新创建，从而最大限度地减少对应用程序或用户造成的停机时间。

当恢复后的 VM 在 DR 池中启动并运行后，还必须将 DR 池元数据保存到复制的存储中，这样当主站点恢复联机后，恢复的 VM 和 vApp 才可以还原到主站点中。

注: XenServer DR 只适用于 LVM over HBA 或 LVM over iSCSI 存储类型。

XenServer VM 由两个组件构成：

  • 由 VM 使用的虚拟磁盘，存储在 VM 所在池中配置的存储库 (SR) 中。
  • 描述 VM 环境的元数据。 即在原始 VM 不可用或损坏时重新创建 VM 所需的全部信息。 大多数元数据配置数据会在创建 VM 时写入，而且仅在对 VM 配置进行了更改时才会更新。 对于池中的 VM，此元数据的副本存储在池中的每个服务器上。

在 DR 环境中，会根据池元数据（有关池中所有 VM 和 vApp 的配置信息）在辅助 (DR) 站点上重新创建 VM。 每个 VM 的元数据都包含其名称、说明、通用唯一标识符 (UUID)、内存、虚拟 CPU、网络连接配置和存储配置。 此外还包括 VM 的启动选项（启动顺序、延迟间隔和高可用性重新启动优先级），在高可用性或 DR 环境中重新启动 VM 时，将使用这些选项。 例如，在灾难恢复期间恢复 VM 时，vApp 中的 VM 将按照 VM 元数据中指定的顺序，以指定的延迟间隔在 DR 池中重新启动。

XenServer DR 要求

软件版本 | XenServer 6.0 或更高版本
访问 | 必须以根用户身份登录，或者具有池操作员或更高权限的角色。

灾难恢复基础结构

要使用 XenServer DR，需要在主站点和辅助站点上都设置适当的 DR 基础结构：

  • 用于池元数据和 VM 所用虚拟磁盘的存储都必须从主（生产）环境复制到备份环境。 存储复制（例如，使用镜像）最好通过存储解决方案进行处理，并且因设备而异。
  • 当 VM 和 vApp 恢复到 DR 站点上的池中并且启动并运行后，还必须复制包含 DR 池元数据和虚拟磁盘的 SR，以便恢复后的 VM 和 vApp 在主站点重新联机后立即还原到主站点（故障恢复）。
  • DR 站点的硬件基础结构不必与主站点匹配，但 XenServer 环境的发行版本和修补程序级别必须相同，并且应在目标池中配置充足的资源，以允许重新创建和启动所有故障转移的 VM。
重要: XenCenter 和灾难恢复向导不控制任何存储阵列功能。 灾难恢复功能的用户必须保证将池元数据以及发生灾难时将重新启动的 VM 所用的存储复制到备份站点中。 某些存储阵列包含可自动实现复制的“镜像”功能：如果使用这些功能，则在恢复站点上重新启动 VM 之前，务必禁用镜像功能（“断开镜像”）。

使用灾难恢复向导进行故障转移、故障恢复和测试故障转移

灾难恢复向导简化了故障转移（将受保护的 VM 和 vApp 恢复到辅助站点）和故障恢复（将 VM 和 vApp 还原到主站点）过程。 这两个过程所涉及的步骤概括如下：

故障转移 故障恢复
  1. 在辅助 DR 站点上选择 VM 和 vApp 将恢复到的目标池。
  2. 提供详细信息，指示来自主站点的复制 SR 所在的存储目标。
  3. 该向导扫描目标并列出从中找到的所有 SR。

    现在选择 SR，其中包含要恢复的 VM 和 vApp 的元数据和虚拟磁盘。

  4. 该向导扫描这些 SR 并列出找到的所有 VM 和 vApp。

    现在，选择要恢复到 DR 站点的 VM 和 vApp，并指定您希望这些 VM 和 vApp 在恢复后是由向导立即自动启动，还是等待您手动启动。

  5. 向导执行一些预检，以确保所选的 VM 和 vApp 能够恢复到目标 DR 池，例如，向导检查选定 VM 和 vApp 所需的所有存储是否可用。
  6. 当预检完成并解决了任何问题后，故障转移过程开始。 所选 VM 和 vApp 从复制的存储导出到 DR 池。

    故障转移到此完成。

  1. 在主站点上，选择要将当前运行在 DR 站点上的 VM 和 vApp 还原到的目标池。
  2. 提供详细信息，指示来自 DR 站点的复制 SR 所在的存储目标。
  3. 该向导扫描目标并列出找到的所有 SR。

    现在选择 SR，其中包含要还原的 VM 和 vApp 的元数据和虚拟磁盘。

  4. 该向导扫描这些 SR 并列出找到的所有 VM 和 vApp。

    现在，选择要还原到主站点的 VM 和 vApp，并指定您希望这些 VM 和 vApp 在恢复后是由向导立即自动启动，还是等待您手动启动。

  5. 向导随后将执行多项预检查，确保选定的 VM 和 vApp 能够恢复到主站点上的目标池。例如，向导将检查选定 VM 和 vApp 需要的所有存储是否可用。
  6. 当预检完成并解决了任何问题后，故障恢复过程开始。 运行在 DR 站点上的所选 VM 和 vApp 从复制的存储导出到主站点上的选定池中。

    故障恢复到此完成。

如果灾难恢复向导在两个或更多位置（例如，主站点上的存储，DR 站点上的存储以及要导入数据的池）找到同一个 VM 的信息，将确保只使用每个 VM 的最新信息。

提示: 如果 SR 的命名方式反映 VM 和 vApp 与 SR 以及 SR 与 LUN 的映射关系，将可以更为方便地从复制的存储恢复 VM 和 vApp。

还可以使用灾难恢复向导运行测试故障转移，以便对灾难恢复系统进行非中断性测试。 在测试故障转移中，所有步骤与故障转移基本相同，但 VM 和 vApp 在恢复到 DR 站点后将以暂停状态启动，并在测试完成后执行清理，以删除在 DR 站点上重新创建的所有 VM、vApp 和存储。 请参阅测试故障转移。

XenServer DR 术语

vApp
作为单个实体进行管理的相关 VM 的逻辑组。
站点
包含 XenServer 资源池、存储和硬件设备的物理组。
主站点
运行在发生灾难时必须受保护的 VM 或 vApp 的物理站点。
辅助站点，DR 站点
在发生灾难时用作主站点的恢复位置的物理站点。
故障转移
当主站点发生灾难时在辅助（恢复）站点上恢复 VM 和 vApp 的过程。
故障恢复
将 VM 和 vApp 从辅助（恢复）站点还原到主站点的过程。
测试故障转移
故障转移“试运行”；VM 和 vApp 从复制的存储恢复到辅助（恢复）站点上的池中，但并不实际启动。 可以运行测试故障转移来检查 DR 的配置是否正确以及您的处理过程是否有效。
池元数据
关于池中的 VM 和 vApp 的信息（例如其名称和说明）以及 VM 的配置信息，包括 UUID、内存、虚拟 CPU、网络和存储配置以及启动选项 - 启动顺序、延迟间隔和高可用性重新启动优先级。 在 DR 中，池元数据用于在辅助站点上的恢复池中重新创建主站点上的 VM 和 vApp。


配置 DR

使用 XenCenter 的配置 DR 对话框可指定用来存储池元数据（有关池中所有 VM 和 vApp 的配置信息）的存储库 (SR)。 每当您对池中的 VM 或 vApp 配置进行更改时，池元数据都将进行更新。

为主池配置 DR：

  1. 在主站点上，选择要保护的池，并在池菜单中指向灾难恢复，然后单击配置。
  2. 最多选择 8 个用来存储池元数据的 SR。 在该存储上需要少量空间来创建新 LUN，用以包含池恢复信息。
    注: XenServer DR 只适用于 LVM over HBA 或 LVM over iSCSI 存储类型。
  3. 单击确定。
    重要: 直到包含池元数据和池中 VM 所用虚拟磁盘的 SR 从生产环境复制到备份环境，您的 XenServer DR 环境才算配置完整。 存储复制（例如，使用镜像）最好通过存储解决方案进行处理，并且因设备而异；不能在 XenCenter 内对其进行配置。


故障转移

故障转移是指当主站点发生灾难时在辅助（恢复）站点上恢复 VM 和 vApp 的过程。 要对关键 VM 和 vApp 进行故障转移，请使用灾难恢复向导。

重要: 灾难恢复向导不控制任何存储阵列功能。 在您尝试故障转移到恢复站点之前，必须禁止对元数据存储以及要重新启动的 VM 所用的存储进行复制（镜像）。

将 VM 和 vApp 故障转移到辅助站点：

  1. 在 XenCenter 中选择辅助池，在池菜单上，单击灾难恢复以打开灾难恢复向导。
  2. 选择故障转移，然后单击下一步。
    注: 如果您结合使用光纤通道共享存储和 LUN 镜像将数据复制到辅助站点，则在尝试恢复数据之前，必须断开镜像，以使辅助站点具有读/写访问权限。
  3. 选择要恢复的 VM 和 vApp 的池元数据所在的存储库 (SR)。 默认情况下，此向导页面上的列表显示池中当前连接的所有 SR。 要扫描查找更多的 SR，请选择查找存储库，然后选择要扫描的存储类型：
    • 要扫描所有可用的硬件 HBA SR，请选择查找硬件 HBA SR。
    • 要扫描软件 iSCSI SR，请选择查找软件 iSCSI SR，然后在出现的对话框中输入目标主机、IQN 和 LUN 详细信息。
    在该向导中选择了所需的 SR 之后，单击下一步继续操作。
  4. 选择要恢复的 VM 和 vApp，然后选择相应的恢复后的电源状态选项，以指定您希望 VM 和 vApp 是在恢复之后由向导立即自动启动，还是在故障转移完成后由您手动启动。 单击下一步前进到下一个向导页面，开始进行故障转移预检。
  5. 向导在开始进行故障转移前会执行一些预检，例如，通过预检确保所选 VM 和 vApp 所需要的所有存储都可用。 如果此时缺少任何存储，您可以单击此页面上的连接 SR 以查找并连接相关 SR。 解决预检页面上的任何问题，然后单击故障转移开始执行恢复过程。
  6. 将出现一个进度页，显示每个 VM 和 vApp 的恢复是否成功。 故障转移可能需要一些时间，具体取决于要恢复的 VM 和 vApp 的数量，在此期间，将从复制的存储导出 VM 和 vApp 的元数据，在主池中重新创建 VM 和 vApp，将包含虚拟磁盘的 SR 连接到重新创建的 VM，并启动 VM（如果指定）。
  7. 当故障转移完成时，单击下一步查看摘要报告。 单击摘要报告页面上的完成关闭向导。

    当您的主站点再次可用时，如果您想重新运行该站点上的 VM，您需要再次运行灾难恢复向导，但这次需在第一页上选择故障恢复选项；请参阅故障恢复。


故障恢复

故障恢复是指在主站点经过灾难性事件后恢复联机时，将 VM 和 vApp 从复制的存储还原到主（生产）站点上的池中的过程。 要将 VM 和 vApp 故障恢复到主站点，请使用灾难恢复向导。

重要: 灾难恢复向导不控制任何存储阵列功能。 在您尝试故障恢复到主站点之前，必须禁止对元数据存储以及要还原的 VM 所用的存储进行复制（镜像）。

将 VM 和 vApp 故障恢复到主站点：

  1. 在 XenCenter 中，选择主站点上的目标池，然后在池菜单中单击灾难恢复以打开灾难恢复向导。
  2. 选择故障恢复，然后单击下一步。
    注: 如果通过将光纤通道共享存储与 LUN 镜像功能结合使用的方式将数据复制到 DR 站点，则在尝试恢复数据前，必须中断镜像，以使主站点具有读/写访问权限。
  3. 选择存储库 (SR)，其中包含要还原到主站点的 VM 和 vApp 的池元数据。 默认情况下，此向导页面上的列表显示池中当前连接的所有 SR。 要扫描查找更多的 SR，请选择查找存储库，然后选择要扫描的存储类型：
    • 要扫描所有可用的硬件 HBA SR，请选择查找硬件 HBA SR。
    • 要扫描软件 iSCSI SR，请选择查找软件 iSCSI SR，然后在出现的对话框中输入目标主机、IQN 和 LUN 详细信息。
    在该向导中选择所需的 SR 之后，单击下一步继续操作。
  4. 选择要还原的 VM 和 vApp，然后选择相应的恢复后的电源状态选项，以指定您希望这些 VM 和 vApp 是在还原之后由向导立即自动启动，还是等到故障恢复完成后由您手动启动。 单击下一步前进到下一个向导页面，开始进行故障恢复预检。
  5. 此向导会在开始进行故障恢复之前执行一些预检（例如，确保选定 VM 和 vApp 所需的所有存储均可用）。 如果此时缺少任何存储，您可以单击此页面上的连接 SR 以查找并连接相关 SR。 解决预检页面上的任何问题，然后单击故障恢复开始执行恢复过程。
  6. 将显示一个进度页面，指示每个 VM 和 vApp 的还原是否成功。 故障恢复过程可能会需要一些时间，具体取决于要还原的 VM 和 vApp 的数量。
  7. 当故障恢复完成时，单击下一步查看摘要报告。 单击摘要报告页面上的完成关闭向导。


测试故障转移

故障转移测试是灾难恢复规划中不可或缺的部分。 您可以使用灾难恢复向导对灾难恢复系统执行非中断性测试。 在测试故障转移期间，所有步骤与故障转移过程基本相同，但 VM 和 vApp 在恢复到 DR 站点后不会启动，而是处于暂停状态。 在测试故障转移过程结束时，在 DR 站点上重新创建的所有 VM、vApp 和存储都将自动恢复。

在完成初始 DR 配置后，以及在启用 DR 的池中进行重要的配置更改后，我们建议您通过执行测试故障转移来验证故障转移是否仍能正常进行。

对 VM 和 vApp 执行以辅助站点为目标的测试故障转移：

  1. 在 XenCenter 中选择辅助池，在池菜单上，单击灾难恢复以打开灾难恢复向导。
  2. 选择测试故障转移，然后单击下一步。
    注: 如果您结合使用光纤通道共享存储和 LUN 镜像将数据复制到辅助站点，则在尝试恢复数据之前，必须断开镜像，以使辅助站点具有读/写访问权限。
  3. 选择要恢复的 VM 和 vApp 的池元数据所在的存储库 (SR)。 默认情况下，此向导页面上的列表显示池中当前连接的所有 SR。 要扫描查找更多的 SR，请选择查找存储库，然后选择要扫描的存储类型：
    • 要扫描所有可用的硬件 HBA SR，请选择查找硬件 HBA SR。
    • 要扫描软件 iSCSI SR，请选择查找软件 iSCSI SR，然后在出现的对话框中输入目标主机、IQN 和 LUN 详细信息。
    在该向导中选择了所需的 SR 之后，单击下一步继续操作。
  4. 选择要恢复的 VM 和 vApp，然后单击下一步前进到下一个向导页面，开始进行故障转移预检。
  5. 此向导会在开始进行测试故障转移过程之前执行一些预检（例如，确保选定 VM 和 vApp 所需的所有存储均可用）。
    1. 检查存储是否可用。 如果缺少任何存储，您可以单击此页面上的连接 SR 以查找并连接相关 SR。
    2. 检查在目标 DR 池上是否启用了高可用性。 为了避免同一个 VM 在主池和 DR 池中同时运行，必须对辅助池禁用高可用性，以确保 VM 和 vApp 在恢复之后不会由高可用性功能自动启动。 要对辅助池禁用高可用性，只需单击此页面上的禁用高可用性。 （如果此时高可用性处于禁用状态，则它会在测试故障转移过程结束时自动重新启用。）
    解决预检页面上的任何问题，然后单击故障转移开始执行测试故障转移。
  6. 将出现一个进度页，显示每个 VM 和 vApp 的恢复是否成功。 故障转移可能需要一些时间，具体取决于要恢复的 VM 和 vApp 的数量，在此期间，将从复制的存储恢复 VM 和 vApp 的元数据，在 DR 池中重新创建 VM 和 vApp，将包含虚拟磁盘的 SR 连接到重新创建的 VM。 恢复后的 VM 将被置于暂停状态：在测试故障转移期间，它们将不会在辅助站点上启动。
  7. 如果测试故障转移成功执行，请单击向导中的下一步，使向导在 DR 站点上进行清理：
    • 删除在测试故障转移期间恢复的 VM 和 vApp。
    • 分离在测试故障转移期间恢复的存储。
    • 如果在预检阶段为了允许进行测试故障转移而对 DR 池禁用了高可用性功能，则高可用性功能会自动重新启用。
    向导将显示清理过程的进度。
  8. 单击完成关闭向导。


访问控制（AD 和 RBAC）

主题

  • 管理用户
  • RBAC 概述
  • RBAC 角色和权限定义
  • 加入域并添加用户
  • 为用户和组分配角色
  • 计算 RBAC 角色
  • 审核对 XenServer 进行的更改


管理用户

首次安装 XenServer 时，会自动将一个用户帐户添加到 XenServer 中。 此帐户是本地超级用户 (LSU) 或 root 用户，由 XenServer 计算机在本地进行身份验证。 您可以通过在 XenCenter 的用户选项卡上添加 Active Directory 帐户，来创建其他用户。 （请注意，此处的“用户”一词是指具有 XenServer 帐户的任何人，即管理 XenServer 主机的任何人，而与这些人的角色级别无关。） 如果您希望在服务器或池上具有多个用户帐户，则必须使用 Active Directory 用户帐户进行身份验证。 这样，XenServer 用户将可以使用其 Windows 域凭据登录池中的服务器。

注: 不支持混合身份验证池（即，不能将池中的某些服务器配置为使用 Active Directory，而另一些不使用）。

管理 XenServer v6.2 和 v6.5 中的用户

在 XenServer v6.2 和 v6.5 中创建新用户时，必须首先将角色分配给新创建的用户，这些用户才能使用帐户。 请注意，XenServer 不会自动将角色分配给新创建的用户。 因此，在您为这些帐户分配角色之前，它们对 XenServer 池没有任何访问权限。

利用基于角色的访问控制 (RBAC) 功能，您可以根据用户角色为 Active Directory 帐户分配不同的权限等级。 如果在您的环境中未使用 Active Directory，则只能使用 LSU 帐户。

管理 XenServer v6.1.0 及更早版本中的用户

XenServer 的所有版本均可从 Active Directory 添加用户帐户。 但是，只有 XenServer 企业版和铂金版允许通过基于角色的访问控制 (RBAC) 功能，根据用户的角色为这些 Active Directory 帐户分配不同的权限等级。 如果在您的环境中未使用 Active Directory，则只能使用 LSU 帐户。

首次添加用户帐户时分配给用户的权限因 XenServer 版本的不同而有所差别：

  • 在 XenServer 免费版和 XenServer Advanced Edition 中创建（添加）新用户时，XenServer 会自动授予帐户访问该版本中提供的所有功能所需的权限。
  • 在 XenServer Enterprise 和 Platinum Edition 中创建新用户时，XenServer 不会自动为新创建的用户帐户分配角色。 因此，在您为这些帐户分配角色之前，它们对 XenServer 池没有任何访问权限。

XenServer 环境中的 AD 身份验证

虽然 XenServer 基于 Linux，但 XenServer 允许您将 Active Directory 帐户用作 XenServer 用户帐户。 为此，XenServer 会将 Active Directory 凭据传递到 Active Directory 域控制器。

添加到 XenServer 后，Active Directory 用户和组即成为 XenServer 使用者，在 XenCenter 中通常简单地称之为用户。 将使用者注册到 XenServer 后，用户/组在登录时会通过 Active Directory 进行身份验证，并且不需要用域名来限定其用户名。

注: 默认情况下，如果您未限定用户名（例如，输入 mydomain\myuser 或 myser@mydomain.com），XenCenter 始终会尝试使用用户当前加入的域将用户登录到 Active Directory 身份验证服务器。 LSU 帐户属例外情况，对于 LSU 帐户，XenCenter 始终首先在本地（即在 XenServer 上）对其进行身份验证。

外部身份验证工作流程如下：

  1. 将连接到服务器时提供的凭据传递到 Active Directory 域控制器，进行身份验证。
  2. 域控制器对凭据进行检查。 如果凭据无效，身份验证立即失败。
  3. 如果凭据有效，会对 Active Directory 控制器进行查询，以获取与凭据相关联的使用者标识符和组成员。
  4. 如果使用者标识符与 XenServer 中存储的某个标识符相匹配，即可成功完成身份验证。

您加入域后，可以为池启用 Active Directory 身份验证。 但是，池加入域后，只有该域（或与该域具有信任关系的域）中的用户才能连接到该池。


RBAC 概述

通过基于角色的访问控制 (RBAC) 功能，可以为 Active Directory 用户和组分配预定义的角色（或称 XenServer 权限集）。 这些权限用于控制 XenServer 用户（即管理 XenServer 的人员）对服务器和池所拥有的访问级别：RBAC 在池级别配置和部署。 由于用户通过分配的角色获取权限，因此您只需要为用户或其所在的组分配角色。

为 XenServer 用户帐户使用 Active Directory 帐户

通过 RBAC，您可以对不同用户组可执行的操作进行限制，从而降低缺乏经验的用户进行灾难性意外更改的可能性。 分配 RBAC 角色还有助于防止资源池在未经授权的情况下被更改，从而确保合规性。 为了便于检查合规性和进行审核，RBAC 还提供了审核日志功能及其相应的 Workload Balancing 池审核追踪报告。

RBAC 基于 Active Directory 提供身份验证服务。 具体而言，XenServer 会保留基于 Active Directory 用户和组帐户的授权用户列表。 因此，您必须将池加入域并添加 Active Directory 帐户，然后才能分配角色。

RBAC 流程

实施 RBAC 并为用户或组分配角色的标准流程如下：

  1. 加入域。
  2. 将 Active Directory 用户或组添加到池。
  3. 分配（或修改）用户或组的 RBAC 角色。

本地超级用户

本地超级用户 (LSU) 或 root 用户是一个用于系统管理的特殊用户帐户，具有完全权限。 在 XenServer 中，本地超级用户是安装时的默认帐户。 LSU 通过 XenServer 而非外部身份验证服务进行身份验证。 这表示如果外部身份验证服务失败，LSU 仍可登录并管理系统。 LSU 始终可以通过 SSH 访问 XenServer 物理服务器。

RBAC 角色

XenServer 附带六个预定义角色，这些角色旨在对应于 IT 组织中的不同职能。

  • 池管理员。 此角色是权限最大的可用角色。 池管理员对所有 XenServer 功能和设置都具有完全访问权限。 池管理员可以执行所有操作（包括角色和用户管理）， 可以授予对 XenServer 控制台的访问权限。 Citrix 建议的最佳做法是将此角色分配给极有限的用户。
    注: 本地超级用户（root 用户）将始终具有池管理员角色。 池管理员角色与本地 root 用户具有相同的权限。
  • 池操作员。 获得此角色的人员可以管理池范围的资源（包括创建存储、管理服务器、管理修补程序和创建池）。 池操作员可以配置池资源。 池操作员还对以下功能具有完全访问权限：高可用性、Workload Balancing 和修补程序管理。 池操作员不能添加用户或修改角色。
  • 虚拟机超级管理员(VM 超级管理员)。 此角色具有完全的 VM 和模板管理权限。 他们可以选择 VM 的启动位置， 并且对动态内存控制功能和 VM 快照功能具有完全访问权限。 此外，他们还可以设置主服务器并选择工作负载的运行位置。 分配此角色后，被授权人将具有足够的权限来置备虚拟机，以供 VM 操作员使用。
  • 虚拟机管理员(VM 管理员)。 此角色可以管理 VM 和模板，并且可以访问必要的存储来完成这些任务。 但是，此角色依赖于 XenServer 来选择工作负载的运行位置，并且必须使用模板中的动态内存控制和主服务器设置。 （此角色无法访问动态内存控制功能、生成快照、设置主服务器或选择工作负载的运行位置。）
  • 虚拟机操作员（VM 操作员）。 此角色可以使用池中的 VM 并管理这些 VM 的基本生命周期。 如果有足够的可用硬件资源，VM 操作员可以与 VM 控制台交互并启动或停止 VM。 同样，VM 操作员也可以执行生命周期的启动和停止操作。 VM 操作员角色不能创建或销毁 VM，也不能更改 VM 属性或服务器属性。
  • 只读。 此角色只能查看资源池和性能数据。

有关每个角色所关联的权限的信息，请参阅 RBAC 角色和权限定义。 有关 RBAC 如何为用户计算所应用角色的信息，请参阅计算 RBAC 角色。

注: 创建新用户时，必须先向新创建的用户分配一个角色，之后才能使用该帐户。 请注意，XenServer 不会自动将角色分配给新创建的用户。

从旧版本 XenServer 升级

RBAC 支持功能自 XenServer 5.6 版本起引入。 在升级到 XenServer 5.6 或更高版本时，系统会为在 XenServer 早期版本中创建的任何用户帐户分配池管理员角色。 执行此操作的原因是存在向后兼容。 从早期版本的 XenServer 进行升级时，应重新访问与每个用户帐户相关联的角色，以确保角色仍然适用。


RBAC 角色和权限定义

适用于每个角色的权限

下表汇总了每个角色适用的权限。 有关每种权限可执行的操作的详细信息，请参阅下一部分。

权限 | 池管理员 | 池操作员 | VM 超级管理员 | VM 管理员 | VM 操作员 | 只读
分配/修改角色 | X |  |  |  |  |
登录到（物理）服务器控制台（通过 SSH 和 XenCenter） | X |  |  |  |  |
服务器备份/还原 | X |  |  |  |  |
导入/导出 OVF/OVA 包；导入磁盘映像 | X |  |  |  |  |
设置每个插槽的核心数 | X |  |  |  |  |
使用 XenServer Conversion Manager 转换 VM | X |  |  |  |  |
交换机端口锁定 | X | X |  |  |  |
注销活动的用户连接 | X | X |  |  |  |
创建和取消警报 | X | X |  |  |  |
取消任何用户的任务 | X | X |  |  |  |
池管理 | X | X |  |  |  |
Storage XenMotion | X | X | X |  |  |
VM 高级操作 | X | X | X |  |  |
VM 创建/销毁操作 | X | X | X | X |  |
VM 更改 CD 介质 | X | X | X | X | X |
VM 更改电源状态 | X | X | X | X | X |
查看 VM 控制台 | X | X | X | X | X |
XenCenter 视图管理操作 | X | X | X | X | X |
取消自己的任务 | X | X | X | X | X | X
阅读审核日志 | X | X | X | X | X | X
配置、初始化、启用、禁用 WLB | X | X |  |  |  |
应用 WLB 优化建议 | X | X |  |  |  |
修改 WLB 报告订阅 | X | X |  |  |  |
接受 WLB 放置建议 | X | X | X |  |  |
显示 WLB 配置 | X | X | X | X | X | X
生成 WLB 报告 | X | X | X | X | X | X
连接到池并阅读所有池元数据 | X | X | X | X | X | X
配置 vGPU | X | X |  |  |  |
查看 vGPU 配置 | X | X | X | X | X | X

权限的定义

下表提供了有关权限的其他详细信息：

权限 允许被授权人执行的操作 说明/备注
分配/修改角色
  • 添加和删除用户
  • 添加和删除用户的角色
  • 启用和禁用 Active Directory 集成（加入域）

此权限允许用户向自己授予任何权限或执行任何任务。

警告：此角色允许用户禁用 Active Directory 集成以及从 Active Directory 添加的所有使用者。

登录到服务器控制台
  • 通过 SSH 访问服务器控制台
  • 通过 XenCenter 访问服务器控制台
警告：具备对 root shell 的访问权限之后，被授权人可以随意重新配置整个系统（包括 RBAC）。

服务器备份/还原 VM 创建/销毁操作

  • 备份和还原服务器
  • 备份和还原池元数据
还原备份的能力使被授权人能够还原 RBAC 配置更改。
导入/导出 OVF/OVA 包；导入磁盘映像
  • 导入 OVF 和 OVA 包
  • 导入磁盘映像
  • 将 VM 导出为 OVF/OVA 包
设置每个插槽的核心数
  • 为 VM 的虚拟 CPU 设置每个插槽的核心数
此权限允许用户为 VM 的虚拟 CPU 指定拓扑。
使用 XenServer Conversion Manager 转换 VM
  • 将 VMware VM 转换为 XenServer VM
此权限允许用户将工作负载从 VMware 转换为 XenServer，方法是将 VMware VM 的批处理作业复制到 XenServer 环境。
交换机端口锁定
  • 控制网络中的流量
此权限允许用户默认阻止网络中的所有流量，或定义允许 VM 从中发送流量的特定 IP 地址。
注销活动的用户连接
  • 断开已登录用户的连接的能力
创建/取消警报
  • 将 XenCenter 配置为当资源使用情况超过特定阈值时生成警报
  • 从“警报”视图中删除警报

警告：具有此权限的用户可以取消整个池的警报。

注意：查看警报的能力属于连接到池并读取所有池元数据权限的一部分。

取消任何用户的任务
  • 取消任何用户正在运行的任务
此权限允许用户请求 XenServer 取消任何用户启动的正在执行的任务。
池管理
  • 设置池属性（命名、默认 SR）
  • 启用、禁用和配置高可用性功能
  • 设置每个 VM 高可用性功能重新启动优先级
  • 配置 DR、执行 DR 故障转移、故障恢复以及测试故障转移操作
  • 启用、禁用和配置 Workload Balancing (WLB)
  • 在池中添加和删除服务器
  • 紧急转换到主服务器
  • 紧急主服务器地址
  • 紧急恢复从属服务器
  • 指定新的主服务器
  • 管理池和服务器证书
  • 修补
  • 设置服务器属性
  • 配置服务器日志记录
  • 启用和禁用服务器
  • 关闭、重新引导和打开服务器
  • 重新启动 toolstack
  • 系统状态报告
  • 应用许可证
  • 因 WLB、维护模式或高可用性功能而将服务器上的所有其他 VM 实时迁移到其他服务器
  • 配置服务器管理接口
  • 禁用服务器管理
  • 删除故障转储
  • 添加、编辑和删除网络
  • 添加、编辑和删除 PBD/PIF/VLAN/Bond/SR
分配/修改角色
Storage XenMotion
  • 将 VM 从一个主机迁移到另一个主机
  • 将虚拟磁盘 (VDI) 从一个 SR 迁移到另一个 SR
VM 高级操作
  • 调整 VM 内存（通过动态内存控制）
  • 创建包含内存数据的 VM 快照、生成 VM 快照及回滚 VM
  • 迁移 VM
  • 启动 VM，包括指定物理服务器
  • 恢复 VM
登录到服务器控制台
VM 创建/销毁操作
  • 安装和删除 VM
  • 克隆/复制 VM
  • 添加、删除和配置虚拟磁盘/CD 设备
  • 添加、删除和配置虚拟网络设备
  • 导入/导出 XVA 文件
  • VM 配置更改

服务器备份/还原 VM 创建/销毁操作

VM 更改 CD 介质
  • 弹出当前的 CD
  • 插入新 CD
导入/导出 OVF/OVA 包；导入磁盘映像
VM 更改电源状态
  • 启动 VM（自动放置）
  • 关闭 VM
  • 重新引导 VM
  • 挂起 VM
  • 恢复 VM（自动放置）
注销活动的用户连接
查看 VM 控制台
  • 查看 VM 控制台并与之交互
创建/取消警报
配置、初始化、启用、禁用 WLB
  • 配置 WLB
  • 初始化 WLB 和更改 WLB 服务器
  • 启用 WLB
  • 禁用 WLB
应用 WLB 优化建议
  • 应用“WLB”选项卡中显示的所有优化建议
修改 WLB 报告订阅
  • 更改生成的 WLB 报告或其接收者
接受 WLB 放置建议
  • 选择其中一种服务器 Workload Balancing 放置建议（“星级”建议）
显示 WLB 配置
  • 查看如“WLB”选项卡上显示的池 WLB 设置
生成 WLB 报告
  • 查看和运行 WLB 报告，包括“Pool Audit Trail”（池审核追踪）报告
XenCenter 视图管理操作
  • 创建和修改全局 XenCenter 文件夹
  • 创建和修改全局 XenCenter 自定义字段
  • 创建和修改全局 XenCenter 搜索
查看 VM 控制台
取消自己的任务
  • 允许用户取消自己的任务
阅读审核日志
  • 下载 XenServer 审核日志
应用 WLB 优化建议
连接到池并阅读所有池元数据
  • 登录到池
  • 查看池元数据
  • 查看历史性能数据
  • 查看登录的用户
  • 查看用户和角色
  • 查看任务
  • 查看消息
  • 注册和接收事件
修改 WLB 报告订阅
配置 vGPU
  • 指定池范围内的放置策略
  • 将 vGPU 分配给 VM
  • 从 VM 中删除 vGPU
  • 修改允许的 vGPU 类型
  • 创建、销毁或分配 GPU 组
查看 vGPU 配置
  • 查看 GPU、GPU 放置策略和 vGPU 分配。


加入域并添加用户

为用户或组帐户分配 RBAC 角色前，必须通过 RBAC 将帐户添加到 XenServer 中。 这需要执行两项任务：

  1. 将池或服务器加入域中。 该域可以是用户或组所属的域，也可以是位于同一个 Active Directory 林中或者与用户所在域具有信任关系的域。
  2. 将用户的 Active Directory 帐户或组添加到 XenServer 中。

在免费 XenServer 产品和 XenServer 高级版中，在将用户的 Active Directory 帐户或组添加到 XenServer 中后，系统会自动为用户分配一个固定的角色：池管理员。 在 XenServer Enterprise 和更高版本中，必须手动为用户或组分配角色。

要更改域，请离开当前的域，然后加入新域。

将 XenServer 或池加入域

  1. 在资源窗格中，选择要为其中的用户赋予权限的池或服务器。
  2. 单击用户选项卡。
  3. 单击加入域。
  4. 输入 Active Directory 凭据，该凭据应具有足够的权限来将服务器添加到要加入的域中。 必须以完全限定的域名 (FQDN) 而不是 NetBIOS 名称来指定要加入的域。 例如，输入 your_domain.net 而不是 your_domain。

将 Active Directory 用户或组添加到池中

  1. 加入用户所在域后，请在用户选项卡中，单击添加。
  2. 在添加用户对话框中，输入一个或多个用户名或组名。 多个名称以逗号分隔。 要指定其他可信域（而非当前所加入的域）中的用户，请提供域名及用户名（例如，other_domain\jsmith）或输入完全限定的域名 (FQDN)（例如，jsmith@other_domain.com）。
  3. 单击授予访问权限。
  4. 按照将角色分配给用户和组进行操作，向帐户分配一种角色并授予访问权限。

离开域

注: 退出域（即，禁用 Active Directory 身份验证，并断开池或服务器与其域之间的连接）时，通过 Active Directory 凭据进行身份验证以连接到池或服务器的所有用户均会断开连接 。
  1. 在资源窗格中，选择要与所属 Active Directory 域断开连接的池或服务器。
  2. 单击离开域并选择是继续。
  3. 输入 Active Directory 凭据，该凭据应具有足够的权限在要离开的域中禁用服务器。
  4. 决定是否在 Active Directory 服务器中禁用计算机帐户，然后单击以下选项之一：
    • 禁用。 从域中删除池或服务器，并在 Active Directory 数据库中禁用服务器或池主服务器的计算机帐户。
    • 忽略。 如果您未填写用户名/密码，或者您不知道具有足够权限来从 Active Directory 数据库中删除服务器或池主服务器计算机帐户的帐户，请选择此选项。 （此选项将从域中删除池或服务器，但将服务器或池主服务器的计算机帐户保留在 Active Directory 中。）


为用户和组分配角色

所有 XenServer 用户都必须具有 RBAC 角色。 在 XenServer v6.2 和 v6.5 中，必须首先将角色分配给新创建的用户，这些用户才能使用帐户。 请注意，XenServer 不会自动将角色分配给新创建的用户。 因此，在您为这些帐户分配角色之前，它们对 XenServer 池没有任何访问权限。

将角色分配给 XenServer 6.1.0 和更早版本中的用户

在 XenServer 6.1.0 和更早版本中，添加新用户时，会自动为其分配池管理员角色。 在 XenServer Enterprise 和更高版本中，当您添加新用户时，XenServer 不会自动为新添加的用户帐户分配角色。 您必须单独为新帐户分配角色。

注: 加入关联的域后，您必须先将用户或组的 Active Directory 帐户添加到 XenServer 中，然后才能为用户或组分配角色，如加入域并添加 RBAC 用户中所述。

可以通过以下方法之一为用户分配其他角色：

  1. 在 XenCenter 的选择角色对话框中更改分配给用户的角色。 此操作需要分配/修改角色权限，该权限仅适用于池管理员。
  2. 在 Active Directory 中修改用户的所属组成员身份（使用户成为具有其他角色的组的成员）。

如果管理员有时候间接为用户应用多个角色（例如，使用户成为多个组的成员），XenServer 会将为其分配的最高角色的权限授予该用户。

为用户或组更改或分配角色

  1. 在资源窗格中，选择包含该用户或组的池或服务器。
  2. 单击用户选项卡。
  3. 在具有访问权限的用户和组窗格中，选择要分配权限的用户或组。
  4. 单击更改角色。
  5. 在选择角色对话框中，选择要应用的角色并单击保存。 有关每个角色所关联的权限的信息，请参阅 RBAC 角色和权限定义。
    提示: 分配角色时，可以在按住 CTRL 键的同时选择用户帐户，从而同时选择多个用户。
  6. （可选） 更改角色时，如果用户当前已登录到池并且您希望他们立即收到新权限，请单击注销用户。 此操作将断开该用户在池中的所有会话，以便该用户以修改后的角色接收新会话。
    注: 更改角色时，要使新角色生效，用户必须先注销，然后重新登录。 您可以通过单击注销用户按钮将此用户强制注销。 （强制注销操作需要注销活动用户连接权限，该权限适用于池管理员或池操作员）。


计算 RBAC 角色

在我登录时，XenServer 如何计算用于该会话的角色？

  1. Active Directory 服务器对使用者进行身份验证。 在身份验证期间，Active Directory 还将确定该使用者是否属于 Active Directory 中的任何其他包含组。
  2. 然后，XenServer 将确认已经为 (a) 使用者 (b) 使用者所属的任何 Active Directory 组分配了角色。
  3. XenServer 为使用者应用最高级别的权限。 由于使用者可以是多个 Active Directory 组的成员，因此，使用者会继承关联角色的所有权限。

在上图中，由于使用者 2（组 2）是池操作员，而用户 1 是组 2 的成员，因此，使用者 3（用户 1）尝试登录时，会同时继承使用者 3（VM 操作员）和组 2（池操作员）角色。 由于池操作员角色级别更高，因此，使用者 3（用户 1）的最终角色是池操作员而非 VM 操作员。


审核更改

在 XenServer 中，XenServer 审核日志默认情况下处于启用状态，该日志将记录由已知用户执行的具有副作用（成功或失败）的任何操作。 其中包括：

  • 执行该操作的用户的名称。 如果无法获得该用户的名称，XenServer 会改为记录其用户 ID。
  • 该操作所针对的服务器的名称。
  • 该操作的状态 - 操作是否成功以及是否经过授权。如果该操作失败，则将记录错误代码。

默认情况下将启用审核日志记录功能。 可以使用 XenServer syslog 命令将审核日志复制到安全位置，从而备份审核日志。 syslog 命令可以从 CLI 访问，在《XenServer 管理员指南》中进行了介绍。

尽管 Citrix 强烈建议关注审核工作的客户实施基于角色的访问控制，但是审核日志本身既不需要用户具有 RBAC 角色，也不需要 Active Directory 集成。

XenServer 将记录池级别的操作，并在池主服务器上为每个池创建一个日志。

要显示审核日志，可以使用两种可选方法。 可以执行以下操作：

  • 生成池审核追踪报告（如果已启用 Workload Balancing）。
  • 在任何文本编辑器中打开审核日志，以显示日志内容。 审核日志存储在池主服务器上。


Workload Balancing 概述

Workload Balancing 是一种 XenServer 设备，可以将虚拟机重定位到资源池中最适合其工作负载的服务器，从而实现池的负载平衡。 例如，Workload Balancing 可以：

  • 在一个 XenServer 资源池中的各主机间平衡虚拟机工作负载
  • 确定用来启动虚拟机的最佳主机
  • 确定用来启动已关闭虚拟机的最佳主机
  • 在您将主机置于维护模式时，为该主机的每个虚拟机确定最佳主机
注: 工作负载平衡是一项仅在 XenServer Enterprise、XenServer Desktop+ 和 XenServer Desktop Edition 中提供的高级功能。 要了解有关 XenServer 6.5 许可的详细信息，请参阅许可概述 (XenServer 6.5)。 要购买 XenServer 许可证，请单击此处。

Workload Balancing 可以根据您选择的优先顺序自动完成这些任务，或者提示您接受其优化、合并和放置建议。 您还可以将 Workload Balancing 配置为在使用率低的时间段自动关闭主机（例如在夜间关闭主机以节能）。

Workload Balancing 将评估虚拟机工作负载在池中的利用率，当某个主机达到一项阈值时，会将虚拟机重定位到该池中的其他主机。

为确保重新平衡和放置建议能够满足环境的需求，您可以将 Workload Balancing 配置为根据资源性能优化工作负载，或者配置为实现密度最大化。 可以将这些优化模式配置为在预定义的时间自动切换，或者始终保持不变。 为提高精细程度，可以调整各个资源指标（CPU、网络和内存）的权重。

Workload Balancing 提供有关主机和池运行状况、优化和虚拟机性能的历史报告，以及虚拟机移动历史记录，以帮助您完成容量规划。


Workload Balancing 入门

您可以下载 Workload Balancing 虚拟设备，并使用以下过程启动并运行：

  1. 通过 citrix.com 的我的账户，下载 Workload Balancing 虚拟设备软件包。
  2. 在 XenCenter 中，依次单击文件和导入，按照屏幕上的说明导入 Workload Balancing 虚拟设备。
  3. 使用 Workload Balancing 配置向导配置 Workload Balancing 虚拟设备；导入虚拟设备后，该向导将显示在 XenCenter 中该设备的控制台选项卡上。
  4. 将您的池连接到该 Workload Balancing 虚拟设备，如连接 Workload Balancing 中所述。

    有关这些步骤的详细信息，请参阅《Workload Balancing 快速入门》。

注: 当您的 XenServer 主机获得了 XenServer Enterprise、XenServer Desktop+ 或 XenServer Desktop Edition 的许可后，“属性”窗格中将显示“WLB”选项卡。 要了解有关 XenServer 6.5 许可的详细信息，请参阅许可概述 (XenServer 6.5)。 要购买 XenServer 许可证，请单击此处。


Workload Balancing 基本概念

Workload Balancing 获取虚拟机和物理主机上的资源性能数据， 并将这些数据与您设置的首选项相结合，以提供优化和放置建议。 Workload Balancing 将性能数据存储在内部数据库中：Workload Balancing 运行时间越长，所提供的建议就越精确。

Workload Balancing 将就虚拟机工作负载在池中的移动提供建议，以获得最大的效率，这里的效率是指性能或密度，具体取决于您的目标。 在 Workload Balancing 环境中：

  • 性能指主机上物理资源的使用率（例如，主机上 CPU、内存和网络的使用率）。 将 Workload Balancing 设置为实现性能最大化时，它提供的虚拟机放置建议将确保每个虚拟机获得最多的可用资源。
  • 密度指主机上虚拟机的数量。 将 Workload Balancing 优化模式设置为密度最大化时，它提出的建议将在确保虚拟机保持足够计算能力的前提下，将这些虚拟机放置在尽可能少的主机上，从而减少池中开启的主机数量。

Workload Balancing 允许您修改放置（性能或密度）、电源管理、自动化、指标加权和性能阈值的设置。

Workload Balancing 与高可用性设置不发生冲突；高可用性设置始终优先。


连接 Workload Balancing

在导入 Workload Balancing 虚拟设备并运行 Workload Balancing 配置向导后，必须将要监视的池连接到 Workload Balancing。 为此，请使用 XenCenter 中的“连接 WLB 服务器”对话框，或者使用 xe 命令。

注: 当您的 XenServer 主机获得了 XenServer Enterprise、XenServer Desktop+ 或 XenServer Desktop Edition 的许可后，“属性”窗格中将显示“WLB”选项卡。 要了解有关 XenServer 6.5 许可的详细信息，请参阅许可概述 (XenServer 6.5)。 要购买 XenServer 许可证，请单击此处。

必备条件

要完成后续的 XenCenter 过程，需要以下信息：

  • Workload Balancing 虚拟设备的 IP 地址或完全限定域名 (FQDN) 以及端口号。
  • 您希望 Workload Balancing 监视的资源池（即池主服务器）的凭据。
  • 在 Workload Balancing 设备上创建的帐户的凭据。 该帐户通常称为 Workload Balancing 用户帐户。 XenServer 使用此帐户与 Workload Balancing 通信。 （此帐户是 Workload Balancing 配置期间您在 Workload Balancing 虚拟设备上创建的帐户。）

如果要在连接 Workload Balancing 服务器时指定 Workload Balancing 虚拟设备的 FQDN（在“连接 WLB 服务器”对话框中），必须先手动将其主机名添加到您的 DNS 中。 如果要配置受信任证书机构颁发的证书，Citrix 建议指定未过期的 FQDN 或 IP 地址。

首次连接 Workload Balancing 时，它将使用默认的阈值和设置来平衡工作负载。 默认情况下自动功能（例如自动优化模式、电源管理和自动化）处于禁用状态。

重要: 在 Workload Balancing 运行一段时间之后，如果您没有收到最佳放置建议，Citrix 强烈建议您对性能阈值进行评估，如评估优化阈值的效力中所述。 为获得最优的 Workload Balancing 建议，务必为您的环境设置正确的阈值。

连接 Workload Balancing 虚拟设备

  1. 在 XenCenter 的资源窗格中，选择 XenCenter > your-resource-pool（您的资源池）。
  2. 在属性窗格中，单击 WLB 选项卡。 注意，在获得 XenServer 主机的许可后，“属性”窗格上将显示 WLB 选项卡。 要了解有关 XenServer 许可的详细信息，请参阅关于 XenServer 许可。
  3. 在 WLB 选项卡中，单击连接。 此时将显示连接 WLB 服务器对话框。
  4. 在服务器地址部分的对话框中，输入以下内容：
    • 在地址框中，键入新 Workload Balancing 服务器的 IP 地址或 FQDN。 例如，输入 WLB-appliance-computername.yourdomain.net 作为 FQDN。
    • 在端口框中输入端口号。 XenServer 使用此端口与 Workload Balancing 通信。

      默认情况下，XenServer 通过端口 8012 连接 Workload Balancing（具体而言，是指 Web 服务主机服务）。 如果您在 Workload Balancing 配置期间更改了端口号，则必须在端口框中输入该端口号。

      重要: 除非您在 Workload Balancing 配置期间更改了默认端口，否则请勿更改默认端口号。 配置期间指定的端口号、在任何防火墙中指定的端口号以及连接 WLB 服务器对话框中指定的端口号必须一致。
  5. 在 WLB 服务器凭据部分，输入 XenServer 连接 Workload Balancing 虚拟设备时将使用的用户名（例如 wlbuser）和密码。 该帐户必须是在 Workload Balancing 配置期间创建的帐户。 默认情况下，此帐户的用户名为 wlbuser。
  6. 在 XenServer 凭据部分，输入所配置池的用户名和密码。 Workload Balancing 将使用这些凭据连接该池中的每个主机。 要使用当前登录 XenServer 所使用的凭据，请选中使用当前 XenCenter 凭据复选框。 如果已经使用基于角色的访问控制 (RBAC) 功能为帐户分配了权限，请确保这些权限足够使用 Workload Balancing。 请参阅 RBAC 角色和权限定义。
  7. 连接到 Workload Balancing 设备后，如果要更改阈值设置或者更改为特定资源指定的优先级，请参阅编辑 Workload Balancing 设置。


基本任务简介

Workload Balancing 是一种功能强大的 XenServer 组件，具有许多用于在环境中优化工作负载的功能，例如主机电源管理、优化模式切换计划功能以及报告运行功能。 此外，您还可以调整 Workload Balancing 在提供优化建议时使用的条件。

但是，当您刚开始使用 Workload Balancing 时，可能需要每天（或定期）使用 Workload Balancing 执行两项主要任务：

  • 确定用来启动虚拟机的最佳主机
  • 接受 Workload Balancing 优化建议

有关获取和配置 Workload Balancing 虚拟设备的信息，请参阅《Workload Balancing 快速入门》。

确定用来启动 VM 的最佳主机

另请参阅为 VM 的初始放置、迁移和恢复选择最优服务器。

当您需要重新启动已关闭的虚拟机以及将虚拟机迁移到其他主机时，Workload Balancing 可以提供有关主机的建议，确定在哪个主机上启动 VM（VM 放置）更为方便。 此功能也可以在 XenDesktop 环境中使用。

接受 Workload Balancing 建议

另请参阅接受优化建议。

Workload Balancing 运行一段时间后，将开始提供有关环境改进方法的建议。 例如，如果您的目标是提高主机上 VM 的密度（通过适当的设置），Workload Balancing 将就如何将多个虚拟机合并到一台主机上提出建议。 如果未在自动化模式下运行，您可以选择应用此建议或直接将其忽略。

这些任务以及在 XenCenter 中执行这些任务的方法将在后面的各节中更深入地介绍。 另一个常用的任务是环境中工作负载情况的运行报告，如生成并管理 Workload Balancing 报告。

重要: 在 Workload Balancing 运行一段时间之后，如果您没有收到最佳放置建议，Citrix 强烈建议您对性能阈值进行评估，如《Workload Balancing 管理员指南》中所述。 对 Workload Balancing 设置适用于所用环境的正确阈值至关重要，否则其建议可能会不适用或者不会在正确的时间提供。


为 VM 的初始放置、迁移和恢复选择最佳服务器

启用 Workload Balancing 并启动处于脱机状态的虚拟机后，XenCenter 会提供建议以帮助您确定资源池中用于启动虚拟机的最优物理主机。 由于最优主机以星形符号指示，因此这些建议又称为星级建议。

由于 host17 是用来启动 VM 的最优主机，因此其旁边显示更多的实心星形符号。host16 旁边没有显示任何实心星形符号，表明此主机不是推荐主机，但是由于它处于启用状态，因此用户也可以选择该主机。host18 由于内存不足而处于灰显状态，因此用户无法选择该主机。

放置的实现

启用 Workload Balancing 后，XenCenter 会利用星级来指示用于启动虚拟机的最优主机，当您希望启动已关闭或挂起的虚拟机以及希望将该虚拟机迁移到不同服务器（迁移和维护模式）时，都会获得这样的最优主机建议。

如果在启用 Workload Balancing 的情况下使用这些功能，将在物理主机旁显示星级，从而以这种方式提供主机建议。 五个空星会表示服务器的等级最低（最差）。 在虚拟机无法启动或迁移到主机时，主机名称将呈灰显，且其无法接受 VM 的原因将显示在旁边。

通常，如果您在 Workload Balancing 推荐的主机上启动虚拟机（即，通过一项放置功能选择星级最高的主机），则 Workload Balancing 的工作效率更高，提出的优化建议更加有效，并且提出建议的频率也更低。

最优的含义

术语最优是指最适合托管工作负载的物理服务器。 Workload Balancing 在确定哪一个主机是工作负载的最优选择时会考虑以下几个因素：

  • 池中每个主机上的可用资源量。 当池在性能最大化模式下运行时，Workload Balancing 会尽量在该池中的各主机之间均衡分配虚拟机，以使所有虚拟机都能达到良好的性能。 当池在密度最大化模式下运行时，Workload Balancing 会在确保虚拟机有足够资源的同时，尽可能密集地将虚拟机放置到主机上。
  • 池运行时所采用的优化模式（性能最大化或密度最大化）。 当池在性能最大化模式下运行时，Workload Balancing 会尽可能将虚拟机放置在可用资源最多且资源类型符合 VM 需求的主机上。 在密度最大化模式下时，Workload Balancing 会尽可能将虚拟机放置在已经运行虚拟机的主机上，以使虚拟机在尽可能少的主机上运行。
  • VM 所需资源的数量和类型。 在 Workload Balancing 监视虚拟机一段时间后，将使用收集的 VM 指标根据虚拟机所需的资源类型提出放置建议。 例如，如果 VM 需要，Workload Balancing 可能会选择一个可用 CPU 较少但可用内存较多的主机（基于其过去的性能历史记录）。 但应注意的是，Workload Balancing 只有在确定当前主机面临资源压力的情况下才会提出建议。

在最佳服务器上启动虚拟机

  1. 在 XenCenter 的资源窗格中，选择要启动的虚拟机。
  2. 在 VM 菜单上，选择在服务器上启动，然后选择以下选项之一：
    • 最优服务器。 最佳服务器是指最能满足所启动虚拟机的资源要求的物理主机。 Workload Balancing 根据服务器性能指标的历史记录和您的放置策略来确定最佳服务器。 最佳服务器是星级最高的服务器。
    • “最优服务器”命令下列出的带有星级的一台服务器。 五颗星代表最值得推荐的（最佳）服务器，五颗空星代表最不值得推荐的服务器。

在最佳服务器上恢复虚拟机

  1. 在 XenCenter 的资源窗格中，选择要恢复的已挂起虚拟机。
  2. 在 VM 菜单上，选择在服务器上恢复，然后选择以下选项之一：
    • 最优服务器。 最佳服务器是指最能满足所启动虚拟机的资源要求的物理主机。 Workload Balancing 根据服务器性能指标的历史记录和您的放置策略来确定最佳服务器。 最佳服务器是星级最高的服务器。
    • “最优服务器”命令下列出的带有星级的一台服务器。 五颗星代表最值得推荐的（最佳）服务器，五颗空星代表最不值得推荐的服务器。


接受优化建议

Workload Balancing 将就虚拟机的迁移方法提供建议，用以优化环境。 优化建议显示在 XenCenter 的 WLB 选项卡中。

此图是“优化建议”列表的屏幕拍图，此列表显示在“WLB”选项卡上。 “原因”列显示建议的目的。 “操作”列显示就优化建议而提供的更改措施建议。 此屏幕拍图显示针对虚拟机 HA-prot-VM-7 和主机 host17.domain4.bedford4.ctx4 的优化建议。

优化建议的基础

这些优化建议基于：

  • 所选的放置策略（即放置优化模式），如调整优化模式中所述
  • 资源的性能指标，例如物理主机的 CPU、内存和网络利用率
  • 资源池中主机的角色。 提出放置建议时，只有在没有其他主机能够接受工作负载时，Workload Balancing 才会考虑池主服务器。 （同样，如果池在密度最大化模式下运行，则 Workload Balancing 在决定虚拟机填入各主机的顺序时，会最后考虑池主服务器。）

在优化建议中，将显示 Workload Balancing 建议重定位的虚拟机的名称、虚拟机当前所在主机的名称，以及 Workload Balancing 建议作为虚拟机新宿主的主机的名称。 优化建议中还将显示 Workload Balancing 建议移动虚拟机的原因（例如，显示“CPU”表示为了提高 CPU 使用率）。

在您接受优化建议后，XenServer 会重定位所有建议优化的虚拟机。

提示: 您可以通过在 XenCenter 中选择资源池并查看 WLB 选项卡的配置部分，来找到资源池的优化模式。

接受优化建议

  1. 在资源窗格中，选择要显示建议的池，然后单击 WLB 选项卡。 在选中的资源池中，如果有任何针对虚拟机的优化建议，这些建议都会显示在 WLB 选项卡中。
  2. 要接受建议，请单击应用建议。 XenServer 会开始将优化建议部分中列出的所有虚拟机移动到推荐的服务器中。

    单击应用建议之后，可以依次单击通知和事件选项卡，以显示虚拟机迁移的进度。

了解 WLB 建议的优先级低于高可用性

如果在同一个池中同时启用了 Workload Balancing 和 XenServer 高可用性功能，了解这两项功能的交互方式非常有用。 根据设计，Workload Balancing 不会影响高可用性功能。 如果在 Workload Balancing 建议与高可用性设置之间存在冲突，高可用性设置始终优先。 在实际应用中，这意味着：

  • 超出配置高可用性对话框允许的故障数框中指定的故障数时，Workload Balancing 将不会自动关闭任何主机。
    • 但是，Workload Balancing 建议关闭的主机数仍有可能多于允许的主机故障数。 （例如，当高可用性配置为仅允许一个主机故障时，Workload Balancing 仍会提出关闭两个主机的建议。） 但是，当您尝试应用该建议时，XenCenter 可能显示一条错误消息，指出不再保证实现高可用性。
    • 当 Workload Balancing 在自动化模式下运行并启用了电源管理功能时，任何超出允许的主机故障数的建议都将被忽略。 在此情况下，如果您查看 Workload Balancing 日志，将会看到一条消息，说明由于启用了高可用性而未应用电源管理建议。


使用 Workload Balancing 报告

本主题提供关于 Workload Balancing 历史报告的一般性信息，并概要介绍有关这些报告的更多信息的查找位置。

要生成 Workload Balancing 报告，必须先导入 Workload Balancing 设备并且将池连接到该设备。

简介

Workload Balancing 提供关于三类对象的报告：物理主机、资源池和虚拟机。 在较高级别上，Workload Balancing 提供两种类型的报告：

  • 按日期显示信息的历史报告
  • “汇总”式报告

Workload Balancing 提供一些用于审核目的的报告，以便您做出相关决策，例如确定虚拟机的移动次数。

报告类型

Workload Balancing 提供关于池、主机和 VM 的多种不同报告。 有关详细信息，请参阅 Workload Balancing 报告词汇表。

生成报告

Workload Balancing 允许您生成报告、将报告导出为 PDF 或电子表格，以及打印报告。 有关详细信息，请参阅生成并管理 Workload Balancing 报告。


使用 Workload Balancing 报告执行任务

Workload Balancing 报告可以帮助您执行容量规划、确定虚拟机运行状况以及评估所配置阈值级别的效力。

评估性能阈值的效力

可以使用“池运行状况”报告来评估优化阈值的效力。 Workload Balancing 提供了默认阈值设置。 但是，您可能需要调整这些阈值的默认设置，以提供适合所用环境的值。 如果没有根据所用环境将阈值调整为正确的级别，Workload Balancing 的建议可能不适用于该环境。

排除管理更改的故障

使用“池审核追踪”报告不仅可以确定有问题的更改来自哪里（即用户帐户），而且还可以确定该用户执行的事件或任务。


生成并管理 Workload Balancing 报告

本主题提供有关工作负载报告用法的基本说明，包括如何生成、导航、打印和导出报告。

生成 Workload Balancing 报告

  1. 在 XenCenter 的资源窗格中，选择 your-resource-pool（您的资源池）。
  2. 从池菜单中，选择查看工作负载报告。
    提示: 也可以通过在 WLB 选项卡上单击报告按钮来显示“工作负载报告”屏幕。
  3. 从“工作负载报告”屏幕的左侧窗格中选择一份报告。
  4. 选择报告期的开始日期和结束日期。 根据您所选择的报告，您可能需要指定其他参数，例如主机、用户和对象。
  5. 单击运行报告。 报告将在报告窗口中显示。

在 Workload Balancing 报告中导航

生成报告之后，您可以使用报告中的工具栏按钮来导航和执行某些任务。 要显示工具栏按钮的名称，请将鼠标指针停在工具栏图标上。

报告工具栏按钮：

文档结构图。 用于显示文档结构图，帮助您在大型报告中导航。
前一页/后一页。 用于在报告中向前或向后移动一页。
返回到父报告。 当与分层报告结合使用时，用于返回到父报告。
注: 此按钮仅适用于分层报告，例如池运行状况报告。
停止呈现。 停止生成报告。
打印。 用于打印报告，并指定常规打印选项，例如打印机、页数和份数。
打印布局。 用于在打印报告前显示报告预览。 要退出“打印布局”，请再次单击打印布局按钮。
页面设置。 用于指定打印选项，例如纸张大小、页面方向和页边距。
导出。 用于以 Acrobat (.pdf) 文件格式或以带 .xls 扩展名的 Excel 文件格式导出报告。
查找。 用于在报告中搜索一个词语，例如虚拟机的名称。

打印 Workload Balancing 报告

打印报告之前，必须首先生成报告。

  1. （可选） 要预览打印的文档，请单击 [image] 打印布局。
  2. （可选） 要更改纸张大小/来源、页面方向或页边距，请单击 [image] 页面设置。
  3. 单击 [image] 打印。

导出 Workload Balancing 报告

可以采用 Microsoft Excel 和 Adobe Acrobat (.pdf) 格式导出报告。

生成报告后，单击 [image] 导出并选择以下格式之一：

  • Excel
  • Acrobat (.pdf) 文件
注: 导出报告时所包含的数据量可能因导出格式而异。 导出为 Excel 格式的报告包含可供报告使用的所有数据，其中包括“明细”数据，而在 XenCenter 中显示的报告或导出为 .pdf 的报告仅包含在生成报告时所选择的数据。


Workload Balancing 报告词汇表

本主题提供关于以下 Workload Balancing 报告的信息。

计费使用分析

可以使用“计费使用分析”报告（计费报告）确定组织内的特定部门对某资源（如物理服务器）的使用量。 具体而言，该报告显示池中所有虚拟机的信息，包括其可用性和资源使用情况。 由于该报告提供虚拟机可用性（“运行时间”）信息，因而可以帮助您证明与服务级别协议的符合性及可用性。

计费报告可帮助您实施简单的计费解决方案，并简化收费方式。 要对使用特定资源的客户收费，可以生成此报告，将其另存为 Excel 格式，然后通过自定义电子表格的数据来加入单价，或者将 Excel 数据导入到计费系统中。

如果确定将要对使用虚拟机的内部或外部客户收费，可以考虑在虚拟机命名约定中加入部门或客户名称。 这样会使计费报告更易于阅读。

在某些情况下，计费报告中的资源报告以各虚拟机的物理资源分配量为基础。

同样，由于 XenServer 允许您分配固定的内存量或者由系统自动分配内存量，因此该报告中的平均内存数据以当前分配给虚拟机的内存量为基础，而无论采用固定内存分配方式还是自动调整内存分配量（动态内存控制）。

计费报告包含以下数据列：

  • VM Name（VM 名称）。 该行各列数据所对应的虚拟机的名称。
  • VM Uptime（VM 运行时间）。 虚拟机开启（更确切地说，是 XenCenter 中该虚拟机旁显示绿色图标）的分钟数。
  • vCPU Allocation（VCPU 分配）。 在虚拟机上配置的虚拟 CPU 的数目。 每个虚拟 CPU 将获得相等份额的主机物理 CPU。 例如，如果在一个包含两个物理 CPU 的主机上配置了八个虚拟 CPU，并且此列的值为“1”，则该值相当于主机总处理能力的 2/16。
  • Minimum CPU Usage (%)（最低 CPU 使用率(%)）。 在报告期间内所记录的最低虚拟 CPU 使用率值。 该值以虚拟机虚拟 CPU 容量的百分比来表示，该容量以分配给虚拟机的虚拟 CPU 数为基础。 例如，在您创建虚拟机时，如果为其分配了一个虚拟 CPU，则最低 CPU 使用率表示 XenServer 所记录的最低虚拟 CPU 使用率百分比（即使该使用率只持续了很短的时间）。 如果为该虚拟机分配了两个虚拟 CPU，则此列中的值表示这两个虚拟 CPU 总容量的最低使用率 (%)。

    从根本上说，CPU 使用率百分比表示虚拟 CPU 所处理的最低记录工作负载。 例如，如果为虚拟机分配一个虚拟 CPU，而主机上的物理 CPU 为 2.4 GHz，则该虚拟机将获得 2.4 GHz 的 1/8。 这意味着，如果该虚拟机获得的容量为 0.3GHz (300MHz)，而其最低 CPU 使用率为 20%，则在报告期间内该虚拟机最低使用 60MHz 的物理主机 CPU。

  • Maximum CPU Usage (%)（最高 CPU 使用率(%)）。 在报告期间内虚拟机所占用的虚拟 CPU 容量的最高百分比。 占用的 CPU 容量是基于分配给虚拟机的虚拟 CPU 容量的百分比。 例如，创建虚拟机时，如果为其分配了一个虚拟 CPU，则最高 CPU 使用率表示在报告期间内所记录的最高虚拟 CPU 使用率百分比。 如果为该虚拟机分配了两个虚拟 CPU，则此列中的值表示基于这两个虚拟 CPU 总容量的最高使用率。
  • Average CPU Usage (%)（平均 CPU 使用率(%)）。 Average CPU Usage (%)（平均 CPU 使用率(%)）。 在报告期间内所用虚拟机虚拟 CPU 容量的平均量 (%)。 CPU 容量是分配给虚拟机的虚拟 CPU 容量。 如果为该虚拟机分配两个虚拟 CPU，则此列中的值表示这两个虚拟 CPU 总容量的平均使用率。
  • Total Storage Allocation (GB)（总存储分配(GB)）。 运行报告时分配给虚拟机的磁盘空间量。 通常，此磁盘空间是您在创建虚拟机时为其分配的磁盘空间量，除非对其进行了修改。
  • Virtual NIC Allocation（虚拟 NIC 分配）。 分配给虚拟机的虚拟接口 (VIF) 的数目。
  • Current Minimum Dynamic Memory (MB)（当前最低动态内存(MB)）。
    • Fixed memory allocation（固定内存分配）。 如果为虚拟机分配了固定大小的内存（例如 1024 MB），以下各列中都将显示此内存量：“Current Minimum Dynamic Memory (MB)”（当前最低动态内存(MB)）、“Current Maximum Dynamic Memory (MB)”（当前最高动态内存(MB)）、“Current Assigned Memory (MB)”（当前分配内存(MB)）以及“Average Assigned Memory (MB)”（平均分配内存(MB)）。
    • Dynamic memory allocation（动态内存分配）。 如果将 XenServer 配置为根据范围自动调整虚拟机的内存（即启用了动态内存控制），则此列中将显示为该范围指定的最低内存量。 例如，如果在 XenCenter 的“内存设置”对话框中为该虚拟机选择了“自动在此范围内分配内存”选项，然后指定此范围的最低内存量为 1024MB，最高内存量为 2048MB，则 1024MB 将显示在“Current Minimum Dynamic Memory (MB)”（当前最低动态内存 (MB)）列中。
  • Current Maximum Dynamic Memory (MB)（当前最高动态内存(MB)）。
    • Dynamic memory allocation（动态内存分配）。 如果将 XenServer 设置为根据范围自动调整 VM 的内存，则此列中将显示为该范围指定的最高内存量。 例如，如果您指定的内存范围为最低 1024MB、最高 2048MB，则 2048MB 将显示在“Current Maximum Dynamic Memory (MB)”（当前最高动态内存 (MB)）列中。
    • Fixed memory allocation（固定内存分配）。 如果为 VM 分配了固定大小的内存（例如 1024 MB），以下各列中都将显示此内存量：“Current Minimum Dynamic Memory (MB)”（当前最低动态内存(MB)）、“Current Maximum Dynamic Memory (MB)”（当前最高动态内存(MB)）、“Current Assigned Memory (MB)”（当前分配内存(MB)）以及“Average Assigned Memory (MB)”（平均分配内存(MB)）。
  • Current Assigned Memory (MB)（当前分配内存(MB)）。
    • Dynamic memory allocation（动态内存分配）。 配置了动态内存控制时，此值表示在报告运行时 XenServer 分配给虚拟机的内存量。
    • Fixed memory allocation（固定内存分配）。 如果为虚拟机分配了固定大小的内存（例如 1024 MB），以下各列中都将显示此内存量：“Current Minimum Dynamic Memory (MB)”（当前最低动态内存(MB)）、“Current Maximum Dynamic Memory (MB)”（当前最高动态内存(MB)）、“Current Assigned Memory (MB)”（当前分配内存(MB)）以及“Average Assigned Memory (MB)”（平均分配内存(MB)）。
    注: 如果在运行此报告之前刚刚更改了虚拟机的内存分配，则该列中的值将反映您配置的新内存分配。
  • Average Assigned Memory (MB)（平均分配内存(MB)）。
    • Dynamic memory allocation（动态内存分配）。 如果配置动态内存控制，则该值表示在报告期间 XenServer 分配给虚拟机的平均内存量。
    • Fixed memory allocation（固定内存分配）。 如果为虚拟机分配了固定大小的内存（例如 1024 MB），以下各列中都将显示此内存量：“Current Minimum Dynamic Memory (MB)”（当前最低动态内存(MB)）、“Current Maximum Dynamic Memory (MB)”（当前最高动态内存(MB)）、“Current Assigned Memory (MB)”（当前分配内存(MB)）以及“Average Assigned Memory (MB)”（平均分配内存(MB)）。
    注: 如果在运行此报告之前刚刚更改了虚拟机的内存分配，该列中显示的值可能不会改变。 此列中的值反映的是一段时间内的平均值。
  • Average Network Reads (BPS)（平均网络读取量(BPS)）。 虚拟机在报告期间接收的平均数据量（比特/秒）。
  • Average Network Writes (BPS)（平均网络写入量(BPS)）。 虚拟机在报告期间发送的平均数据量（比特/秒）。
  • Average Network Usage (BPS)（平均网络使用量(BPS)）。 平均网络读取量和平均网络写入量的总和（比特/秒）。 例如，如果虚拟机在报告期间平均每秒发送 1,027 比特，而平均每秒接收 23,831 比特，则平均网络使用量将是这两个值的总和：24,858 比特/秒。
  • Total Network Usage (BPS)（网络使用总量(BPS)）。 在报告期间发生的所有网络读写事务的总量（比特/秒）。

主机运行状况历史记录

此报告显示特定主机上与阈值相关的资源（CPU、内存、网络读取和网络写入）性能。

彩色线（红色、绿色和黄色）代表不同的阈值。 可以结合使用主机的此报告和池运行状况报告，来确定特定主机的性能对整体池运行状况的影响。 编辑性能阈值时，可以通过此报告深入了解主机性能。

可以通过日均或时均方式显示资源使用情况。 时均方式可以让您了解一天中最忙的几个小时，它显示某一时段内的平均资源使用情况。

要查看按小时分组的报告数据，请展开主机运行状况历史记录标题栏下的 + Click to view report data grouped by house for the time period（+ 单击以查看该时段内按小时分组的报告数据）。

Workload Balancing 将显示所设置时段内每小时的平均值。 数据点基于该时段内所有日期该小时的平均利用率。 例如，在 2009 年 5 月 1 日到 2009 年 5 月 15 日的报告中，“平均 CPU 使用率”数据点表示全部 15 天中每天 12:00 的资源使用情况加总后的平均值。 就是说，如果 CPU 在 5 月 1 日正午 12:00 的使用率是 82%，在 5 月 2 日正午 12:00 的使用率是 88%，在所有其他日期中正午 12:00 的使用率都是 75%，那么正午 12:00 的平均使用率显示为 76.3%。

池优化性能历史记录

优化性能报告显示针对池的平均资源使用情况进行的优化事件（即，在优化资源池时发生的事件）。 具体来说，它将显示 CPU、内存、网络读取和网络写入的资源使用情况。

虚线表示在所选日期期间内池的平均利用率。 蓝色条指示进行池优化的日期。

此报告可以帮助您确定 Workload Balancing 在您的环境中是否正常工作。 可以使用此报告查看导致优化事件的原因（即，Workload Balancing 提供优化建议前的资源使用情况）。

此报告显示每天的平均资源使用情况；而不显示峰值利用率（例如当系统处于紧张状态时）。 如果 Workload Balancing 没有提供优化建议，您还可以使用此报告查看资源池的性能情况。

一般来说，在优化事件后，资源使用情况应降低或保持不变。 如果在优化后资源使用情况未出现改进，请考虑重新调整阈值。 此外，请考虑资源池是否有过多虚拟机，以及在您指定的时段内是否添加或删除了新的虚拟机。

池审核追踪

此报告显示 XenServer 审核日志的内容；该 XenServer 功能用于在日志中记录执行未经授权的操作及选择已授权操作的尝试，包括导入/导出、主机和池备份以及来宾系统和主机控制台访问操作。 当使用基于角色的访问控制功能为 XenServer 管理员指定具有不同角色的用户帐户时，此报告可提供更有用的信息。 有关审核日志功能的信息，请参阅《Workload Balancing 管理员指南》中的审核日志文档。

重要: 要运行审核日志报告，必须启用审核日志记录功能。 默认情况下，在 Workload Balancing 虚拟设备中始终启用审核日志。

增强的池审核追踪功能使您能够指定审核日志报告的精度。 您也可以搜索审核追踪日志并按特定用户、对象和时间过滤这些日志。 默认情况下，池审核追踪精度设置为最低。 此选项可捕获有限数量的特定用户和对象类型的数据。 您可以随时根据您报告中所需的详细级别修改设置。 例如，将用户友好的审核日志报告的精度设置为中。 如果您需要非常详细的报告，可以将此选项设置为最大。

要修改池审核追踪精度设置，请执行以下操作：

  1. 在基础结构视图中选择池，单击 WLB 选项卡，然后单击设置。
  2. 在左侧窗格中，单击高级。
  3. 在“高级”页面上，单击池审核追踪报告精度下拉列表，然后从列表中选择一个选项。
    重要: 根据您的审核日志要求选择精度。 例如，如果您将审核日志报告精度设置为最低，则审核报告只能捕获有限数量的特定用户和对象类型的数据。 如果您将精度设置为中，则报告可以提供用户友好的审核日志报告。 如果您选择将精度设置为最大，则报告将包含有关审核日志报告的详细信息。 注意，将审核日志报告设置为“最大”会使 Workload Balancing 服务器使用更多磁盘空间和内存。
  4. 单击确定，确认您的更改。

此报告显示以下内容：

  • Time（时间）。 XenServer 记录用户操作的时间。
  • User Name（用户名）。 创建会话（在该会话中执行操作）的人员的名称。 在某些情况下，此项内容可以是用户 ID。
  • Event Object（事件对象）。 作为操作主体的对象（例如虚拟机）。
  • Event Action（事件操作）。 发生的操作。 有关这些操作的定义，请参阅审核日志事件名称。
  • Access（访问权限）。 用户是否有权执行操作。
  • Object Name（对象名称）。 对象的名称（例如，虚拟机的名称）。
  • Object UUID（对象 UUID）。 对象的 UUID（例如，虚拟机的 UUID）。
  • Succeeded（成功）。 此列提供操作的状态（即，操作是否成功）。

池运行状况

池运行状况报告显示资源池及其主机在四个不同阈值范围（临界阈值、高阈值、中阈值和低阈值）所花费时间的百分比。 您可以使用池运行状况报告来评估性能阈值的效力。

关于本报告的几点解释：

  • 不论您选择哪种放置策略，平均中阈值（蓝色）的资源利用率都是最佳资源利用率。 同样，饼图中的蓝色部分指示主机使用资源的最佳时间量。
  • 平均低阈值百分比（绿色）的资源利用率不一定是正值。 低资源利用率是否为正取决于放置策略。 例如，如果放置策略为“Maximum Density”（密度最大化），而且资源使用情况大多时间为绿色，那么 Workload Balancing 可能不适合该主机或池上虚拟机的最大数量。 如果是这种情况，您应调整性能阈值，直到大部分资源利用率下降到平均中（蓝色）阈值范围内。
  • 平均临界阈值百分比（红色）的资源利用率指示平均资源利用率达到或超过临界阈值的时间量。

如果双击表示主机资源使用情况的饼图，XenCenter 将显示该主机上相应资源（例如 CPU）的“主机运行状况历史记录”报告。 单击返回到父报告工具栏按钮将使您返回到“池运行状况历史记录”报告。 注意：此按钮仅适用于分层报告，例如池运行状况报告。

如果您发现大多数报告结果都不在平均中阈值范围内，您可能需要为此资源池调整临界阈值。 Workload Balancing 提供默认的阈值设置，但这些默认设置并非在所有环境中都有效。 如果不将阈值调整到适合所用环境的正确级别，Workload Balancing 的优化和放置建议可能不适用。 有关详细信息，请参阅更改临界阈值。

注: 高、中和低阈值范围都以临界阈值为基础。

池运行状况历史记录

此报告提供池中所有物理主机的资源利用率随时间变化的线图。 通过此报告，您可以了解资源利用率的趋势 - 是否相对于所设定的阈值（临界、高、中和低）趋向于增加。 通过监视该报告中数据点的趋势，您可以评估性能阈值的效力。

Workload Balancing 会根据您设置的临界阈值来推断阈值范围。 虽然与“池运行状况”报告相似，但“池运行状况历史记录”报告显示的是资源在某一特定日期的平均利用率，而不是处于某个阈值范围的总时长。

除“平均可用内存”图外，数据点的平均值在任何时候都不应越过临界阈值线（红色）。 对于“平均可用内存”图，数据点的平均值在任何时候都不应在临界阈值线（位于图表底部）之下。 由于此图显示可用内存，因此临界阈值为低值，这与其他资源不同。

关于本报告的几点解释：

  • 当表中的“平均使用率”线接近“平均中阈值”（蓝色）线时，它表示池的资源利用率处于最佳状态，而无论配置哪种放置策略。
  • 接近“平均低阈值”（绿色）的资源利用率不一定为正值。 低资源利用率是否为正取决于放置策略。 例如，如果您的放置策略是“Maximum Density”（密度最大化），而大部分日期的平均利用率线与绿线重合或低于绿线，那么 Workload Balancing 可能未尽可能密集地在该池上放置虚拟机。 如果是这种情况，您应调整池的临界阈值，直到其大部分资源利用率下降到平均中（蓝色）阈值范围内。
  • 当“平均使用率”线与“平均临界阈值百分比”（红色）相交时，这表示平均资源利用率达到或超过该资源临界阈值的天数。

如果您发现图中的大多数数据点都不在平均中阈值范围内，但您又对此池的性能很满意，您可能需要调整该池的临界阈值。 有关详细信息，请参阅更改临界阈值。

池优化历史记录

利用池优化历史记录报告可以按时间顺序查看 Workload Balancing 优化活动。

优化活动以图形和表格形式进行汇总。 深入表格内部的日期字段时，将显示当日执行的每个池优化的详细信息。

利用此报告可以查看以下信息：

  • VM Name（VM 名称）。 Workload Balancing 优化的虚拟机的名称。
  • Reason（原因）。 进行优化的原因。
  • Status（状态）。 优化是否成功。
  • From Host（来源主机）。 最初托管虚拟机的物理服务器。
  • To Host（目标主机）。 虚拟机移动到的物理服务器。
  • Time（时间）。 发生优化的时间。
提示: 还可以通过在 WLB 选项卡上单击查看历史记录链接来生成“池优化历史记录”报告。

虚拟机移动历史记录

此线图显示一段时间内虚拟机在一个资源池中的移动次数。 它将指示移动是否源于优化建议，以及虚拟机移动到哪个主机。 此报告还将指示进行优化的原因。 您可以使用此报告审核池中发生移动的次数。

关于本报告的几点解释：

  • 图表左侧的数值代表可能的移动次数，该值基于资源池中虚拟机的数量。
  • 展开报告日期部分中的 + 号，可以查看特定日期移动的详细情况。

虚拟机性能历史记录

此报告显示在您指定的时段内特定主机上每个虚拟机的性能数据。 Workload Balancing 的性能数据基于为虚拟机分配的虚拟资源数量。 例如，如果虚拟机的平均 CPU 使用率为 67%，这意味着在您指定的时段内，虚拟机平均占用了 67% 的虚拟 CPU。

该报告的初始视图显示在指定的时段内资源利用率的平均值。

展开 + 号后，将显示各资源的线图。 可以使用这些图来查看资源利用率随时间变化的趋势。

该报告显示 CPU 使用率、可用内存和网络读取/写入的数据。


审核日志事件

审核日志报告会记录 XenServer 事件、事件对象和操作，包括导入/导出、主机和池备份以及来宾和主机控制台访问。 下表定义了 XenServer 审核日志和池审核追踪报告中经常出现的典型事件，它还指定了这些事件的精度。

在池审核追踪报告中，“事件操作”列中列出的事件适用于池、VM 或主机。 要确定事件应用的对象，请参阅该报告中的事件对象和对象名称列。 有关更多事件定义，请参阅《Citrix XenServer 管理 API 指南》。 要了解更多有关池审核追踪精度设置的详细信息，请参阅 高级设置。

池审核追踪精度 | 事件操作 | 用户操作
最低 | VM.start | 启动虚拟机。
最低 | VM.copy | 复制指定的 VM，从而创建新 VM。
最低 | host.reboot | 重新启动 XenServer 主机。
最低 | host.disable | 将主机置于无法启动任何新 VM 的状态。
最低 | pool.join | 指示主机加入新池。
最低 | pool.join_force | 指示（强制）主机加入新池。
中 | SR.destroy | 毁坏存储库。
中 | SR.create | 创建一个新的存储库。
中 | VDI.snapshot | 生成 VDI 的一个只读快照，返回引用给快照。
中 | VDI.clone | 生成 VDI 的一个完全相同的副本，返回引用给新磁盘。
中 | VIF.plug | 热插拔指定的 VIF，将它动态连接到运行中的 VM。
中 | VIF.unplug | 热插拔指定的 VIF，动态断开它与运行中的 VM 的连接。
最大 | auth.get_subject_identifier | 查询外部目录服务，从人类可识别的主题名称获取字符串形式的主题标识符。
最大 | task.cancel | 请求取消任务。
最大 | VBD.insert | 将新的介质插入设备。
最大 | VIF.get_by_uuid | 引用含有指定 UUID 的 VIF 实例。
最大 | VDI.get_sharable | 获得给定 VDI 的可共享字段。
最大 | SR.get_all | 返回系统已知的所有 SR 的列表。
最大 | pool.create_new_blob | 为与此池相关的已命名二进制数据大对象创建一个占位符。
最大 | host.send_debug_keys | 将给定字符串作为调试密钥注入到 Xen 中。
最大 | VM.get_boot_record | 返回一个描述 VM 动态状态的记录，在 VM 启动和更新时初始化，以反映运行时配置变化，例如 CPU 热插拔。


编辑 Workload Balancing 设置

连接到 Workload Balancing 虚拟设备后，可以编辑 Workload Balancing 在计算放置和优化建议所使用的设置。 可以执行如下的任务：
  • 调整优化模式
  • 设置自动化和电源管理
  • 更改临界阈值
  • 调整指标加权
  • 从建议中排除主机
  • 高级设置
注: 连接或重新连接到 Workload Balancing 后，在更改设置之前应至少等待六十秒，直到 Workload Balancing (/var/log/wlb/LogFile.log) 显示检测完成。

Workload Balancing 设置的应用方式

Workload Balancing 设置共同应用于池中的所有虚拟机和主机。

如果网络阈值与环境中的硬件相符，初始时可以考虑使用 Workload Balancing 中的大多数默认设置。

在 Workload Balancing 启用一段时间后，Citrix 建议评估性能阈值，并确定是否需要编辑这些阈值。 例如，以下情况下应考虑调整阈值：
  • 在尚不需要时获得优化建议。 这种情况下，请尝试调整阈值，直到 Workload Balancing 开始提供适当的优化建议。
  • 当您认为网络带宽不足时未获得建议。 这种情况下，请尝试降低网络临界阈值，直到 Workload Balancing 开始提供优化建议。

您会发现，在编辑阈值前，为池中的每台物理主机生成主机运行状况历史记录报告将便于您进行编辑。

可以使用 XenCenter 中的 Workload Balancing Configuration 属性或者 XE 命令修改配置设置。

要更新 XenServer 与 Workload Balancing 服务器通信时所使用的凭据，请参阅更新 Workload Balancing 凭据。

有关调整 Workload Balancing 设置的更详细指导，请参阅《Workload Balancing 管理员指南》。

显示 Workload Balancing 设置对话框

  1. 在 XenCenter 的资源窗格中，选择 your-resource-pool（您的资源池）。
  2. 在属性窗格中，单击 WLB 选项卡。
  3. 在 WLB 选项卡中，单击设置。


调整优化模式

Workload Balancing 根据您选择的放置策略（称为优化模式）提出建议，以重新平衡（或称优化）环境中的虚拟机工作负载。

密度最大化和性能最大化模式

可以选择以下两种优化模式之一：
  • 性能最大化。 （默认设置。） Workload Balancing 尝试在资源池中的所有物理主机上平均分布工作负载。 目标是最大限度地降低所有主机上 CPU、内存和网络的压力。 如果选择性能最大化放置策略，Workload Balancing 将在某个虚拟机达到高阈值时提出优化建议。

  • 密度最大化。 Workload Balancing 尝试在一台物理主机上启动尽可能多的虚拟机。 目标是最大限度地减少需要联机的物理主机数量。

    如果选择密度最大化放置策略，可以指定与性能最大化相似的规则。 但是，Workload Balancing 会使用这些规则来确定如何将这些虚拟机尽量放入一个主机中。 如果选择密度最大化放置策略，Workload Balancing 将在某台虚拟机达到临界阈值时提出优化建议。

Workload Balancing 还允许您始终应用这些优化模式（固定模式），或者按指定的时段在各模式之间进行切换（排定模式）。

固定

固定优化模式将 Workload Balancing 设置为始终执行特定的优化行为，即尝试实现最佳性能或者尝试实现最高密度。

计划

计划优化模式允许您安排 Workload Balancing 根据一天中的具体时间应用不同的优化模式。 例如，在白天，当有用户处于连接状态时，可以将 Workload Balancing 配置为优化性能，而在夜晚，为了节约能源，可以将 Workload Balancing 指定为以密度最大化为目的进行优化。

配置“排定”优化模式时，Workload Balancing 会在指定时段开始时（星期几以及具体时间）自动切换为相应优化模式。

设置所有时段的优化模式

  • 在资源窗格中选择池，单击 WLB 选项卡，然后单击设置。
  • 在左侧窗格中，单击优化模式。
  • 选择固定，然后选择以下优化模式之一：
    • 性能最大化。 （默认设置。） 尝试在资源池中的所有物理主机上平均分布工作负载。 目标是最大限度地降低所有主机上 CPU、内存和网络的压力。
    • 密度最大化。 尝试在一台物理主机上安装尽可能多的虚拟机。 目标是最大限度地减少需要联机的物理主机数量。 （请注意，Workload Balancing 将考虑合并后 VM 的性能，并在主机上的某项资源达到临界阈值时，提出提高性能的建议。）

指定优化模式自动切换的时间

  • 在资源窗格中选择池，单击 WLB 选项卡，然后单击设置。
  • 在左侧窗格中，单击优化模式。
  • 选择排定。
  • 单击添加新项以打开优化模式计划程序对话框。
  • 在更改为列表框中选择一种优化模式：
    • 性能最大化。 尝试在资源池中的所有物理主机上平均分布工作负载。 目标是最大限度地降低所有主机上 CPU、内存和网络的压力。
    • 密度最大化。 尝试在一台物理主机上安装尽可能多的虚拟机。 目标是最大限度地减少需要联机的物理主机数量。
  • 选择希望 Workload Balancing 开始以此模式运行的星期和时间。
  • 创建更多的计划模式切换（即“任务”），直至达到所需的数量。 如果只计划一个任务，Workload Balancing 将切换到该模式，而永远不会切换回原来的模式。
  • 单击确定。

删除或暂停计划的优化模式任务

  1. 在资源窗格中选择池，单击 WLB 选项卡，然后单击设置。
  2. 单击优化模式。
  3. 选择一项计划的任务，并单击以下选项之一：
    • 永久删除任务。 单击删除按钮。
    • 暂时停止任务运行。 在任务上单击鼠标右键，然后单击禁用。

    要重新启用某项任务，请在计划模式更改列表中的该任务上单击鼠标右键。

编辑计划的优化模式任务

  1. 在资源窗格中选择池，单击 WLB 选项卡，然后单击设置。
  2. 选择一项计划的任务。
  3. 单击编辑。
  4. 在更改为框中，选择其他模式，或者根据需要进行其他更改。


自动优化和管理电源

可以将 Workload Balancing 配置为自动接受优化建议（自动化），并自动打开或关闭服务器（电源管理）。

自动接受优化建议

可以将 Workload Balancing 配置为代表您自动接受优化建议，并自动执行其建议的优化操作。 您可以使用此功能（称为自动化）自动应用任何建议，包括提高性能或关闭主机的建议。 但是，要在虚拟机使用率下降时关闭主机，必须配置自动化功能、电源管理功能和密度最大化模式。

默认情况下，Workload Balancing 不自动接受优化建议。 如果希望 Workload Balancing 自动接受建议，必须启用“自动化”功能。 否则，Workload Balancing 仍然会提示您手动接受建议。

如果建议与高可用性设置冲突，则 Workload Balancing 不会自动将这些建议应用于主机或虚拟机。 如果应用 Workload Balancing 优化建议将导致池被过度使用，XenCenter 将询问您是否要继续应用建议。 如果启用“自动化”功能，Workload Balancing 应用的电源管理建议的数量不会超出“高可用性”计划中允许的主机故障数量。

可以调整 Workload Balancing 在自动化模式下应用建议的方式。 有关详细信息，请参阅高级设置。

启用电源管理

术语电源管理是指开启或关闭物理主机电源的能力。 在 Workload Balancing 环境中，此术语是指根据池的总工作负载开启或关闭该池中的主机。

在主机上配置 Workload Balancing 电源管理需要满足以下条件：
  • 主机服务器的硬件具有远程开/关机功能
  • 为该主机配置主机启动功能
  • 已将该主机明确选择为参与 (Workload Balancing) 电源管理
此外，如果希望 Workload Balancing 自动关闭主机，还需要进行以下配置：
  • 将 Workload Balancing 配置为自动应用建议
  • 将 Workload Balancing 配置为自动应用电源管理建议

启用了电源管理功能并且池处于密度最大化模式时，如果 Workload Balancing 检测到未使用的资源，会提出关闭主机的建议，直到消除池中的所有过剩容量。 如果 Workload Balancing 检测到池中的主机容量不足以关闭服务器，会建议将服务器保持打开状态，直到该池的工作负载降低到足以关闭服务器的水平。 如果您将 Workload Balancing 配置为自动关闭额外服务器，它会自动应用这些建议，其结果与手动模式相同。

主机设置为参与电源管理时，Workload Balancing 会根据需要提出开/关机建议。 如果启用用于自动应用电源管理建议的选项，应在池级别启用。 但可以指定希望池中的哪些主机参与电源管理。

了解电源管理行为

Workload Balancing 在提出开启或关闭主机的建议之前，会选择虚拟机要转移（即“填充”）到的主机。 按以下顺序进行转移：
  1. 填充池主服务器，因为该主机无法关闭。
  2. 填充包含最多虚拟机的主机。
  3. 在后续主机中选择运行最多虚拟机的主机来填充。

当 Workload Balancing 填充池主服务器时，会为该服务器假定一个低（内部）阈值。 Workload Balancing 使用这些低阈值作为缓冲，来防止池主服务器过载。

Workload Balancing 按照此顺序填充主机以提高密度。

此图解释了在密度最大化模式下在主机上合并 VM 时，XenServer 将尝试首先填充池主服务器，然后填充负载最高的服务器，最后填充负载最低的服务器。

当池处于密度最大化模式时，如果 Workload Balancing 检测到性能问题，它会通过建议在已开启的主机之间迁移工作负载，尝试解决该问题。 如果 Workload Balancing 通过这种方法不能解决该问题，它会尝试打开主机。 （Workload Balancing 在决定要打开的主机时，所应用的标准与“性能最大化”优化模式相同。）

当 Workload Balancing 在性能最大化模式下运行时，只要池中所有主机上的资源利用率未降至高阈值以下，Workload Balancing 就会提出开启主机的建议。

在迁移一个或多个虚拟机时，如果 Workload Balancing 确定提高容量对池的整体性能有益，它会自动开启主机，或者建议开启主机。
重要: 除非主机是由 Workload Balancing 关闭的，否则 Workload Balancing 绝不会建议您将其打开。

针对电源管理和 VM 整合设计环境

如果要配置自动 VM 合并和电源管理功能，在对 XenServer 的实施进行规划时，应考虑工作负载设计。 例如，您可能需要：

  • 将不同类型的工作负载放置在不同的池中。 如果您的环境中包含不同类型的工作负载（例如，用户应用程序与域控制器）或者更适用于某些硬件类型的应用程序类型，则应考虑是否需要将托管这些工作负载的虚拟机放置在不同的池中。

    由于电源管理和 VM 合并在池级别进行管理，因此设计的池中应包含要以相同比率合并的工作负载，并需要考虑多项因素，例如高级设置主题中讨论的因素。

  • 从 Workload Balancing 排除主机。 某些主机可能需要始终处于开启状态。 有关详细信息，请参阅从建议中排除主机。

自动应用优化建议

  1. 在 XenCenter 的资源窗格中，依次选择 XenCenter > your-resource-pool（您的资源池）。
  2. 在属性窗格中，单击 WLB 选项卡。
  3. 在 WLB 选项卡中，单击 Configure WLB（配置 WLB）。
  4. 在左侧窗格中，单击自动化。
  5. 选中以下一个或多个复选框：
    • 自动应用优化建议。 如果选中此选项，则无需手动接受优化建议。 Workload Balancing 会自动接受提供的优化和放置建议。
    • 自动应用电源管理建议。 此选项的行为因池的优化模式而异：
      • 性能最大化模式。 当启用了自动应用电源管理建议时，如果可以通过开启主机来提高主机性能，Workload Balancing 将自动开启主机。
      • 密度最大化模式。 当启用了自动应用电源管理建议时，Workload Balancing 将在资源利用率降到低阈值以下时，自动关闭主机（即 Workload Balancing 在资源利用率较低的时段自动关闭主机）。
  6. 执行以下操作之一：
    • 如果要配置电源管理功能，请单击自动化/电源管理并继续。
    • 如果不希望配置电源管理并且已完成自动化功能的配置，请单击确定。

选择要进行电源管理的服务器

  1. 在“电源管理”部分，选择希望 Workload Balancing 自动开启和关闭的主机。
    注: 如果在选择要获得电源管理建议的主机时未选中自动应用电源管理建议复选框，Workload Balancing 会提出电源管理建议，但不会自动应用这些建议。
  2. 单击确定。 如果资源池中的所有物理服务器均不支持远程电源管理，Workload Balancing 会显示所有主机均不支持电源管理消息。


更改临界阈值

本主题将介绍修改默认临界阈值的方法，并说明设置的临界阈值如何改变高、中、低阈值。

这些信息仅作为更改阈值时的参考。 要了解本主题中所讨论的概念，务必在《Workload Balancing 管理员指南》所提供的更全面的参考环境中阅读这些内容。

概述

评估利用率时，Workload Balancing 将日常平均值与四个阈值（低、中、高和临界）进行比较。在指定临界阈值（或接受默认值）后，Workload Balancing 将相对于池中的临界阈值设置其他阈值。 可能需要通过更改临界阈值来控制触发优化建议的时机。

Workload Balancing 可为资源池中的物理主机评估 CPU、内存、网络读取和网络写入利用率。

通过评估以下内容，Workload Balancing 可以确定是否提出重定位工作负载的建议，以及确定物理主机是否适合虚拟机工作负载：
  • 物理主机上是否有资源达到临界阈值
  • （如果达到临界阈值）为资源指定的重要性
注: 为防止数据虚高，Workload Balancing 将评估资源的日常平均值，并对利用率峰值进行平滑处理。

有关详细信息，请参阅《Workload Balancing 管理员指南》。

Workload Balancing 将根据资源的历史平均利用率是否超出阈值来决定是否生成建议。 如《Workload Balancing 管理员指南》中所述，如果在性能最大化模式下超出高阈值，或者在密度最大化模式下低于低阈值和临界阈值，将触发 Workload Balancing 建议。 为资源指定新临界阈值后，Workload Balancing 会相对于新临界阈值重置该资源的其他阈值。 （为了简化用户界面，通过 XenCenter 只能更改临界阈值。）

阈值的默认设置

下表显示了 Workload Balancing 阈值的默认值：
设置 | 默认值 | 高 | 中 | 低
CPU 使用率 | 90% | 76.5% | 45% | 22.5%
可用内存 | 51 MB | 63.75 MB | 510GB | 1020GB
网络读取 | 25 MB/秒 | 21.25 MB/秒 | 12.5 MB/秒 | 6.25 MB/秒
网络写入 | 25 MB/秒 | 21.25 MB/秒 | 12.5 MB/秒 | 6.25 MB/秒
在计算“高”、“中”和“低”资源指标的值时，Workload Balancing 会将临界阈值的新值与以下因数相乘：
  • 高阈值因数：0.85
  • 中阈值因数：0.50
  • 低阈值因数：0.25
在计算可用内存的阈值时，Workload Balancing 会将临界阈值与以下因数相乘：
  • 高阈值因数：1.25
  • 中阈值因数：10.0
  • 低阈值因数：20.0

这意味着，如果您将池的 CPU 使用率临界阈值提高至 95%，Workload Balancing 会自动将高、中和低阈值分别重置为 80.75%、47.5% 和 23.75%。

要对特定阈值执行此计算，请将阈值因数与您为该资源输入的临界阈值相乘：

高、中或低阈值 = 临界阈值 * 阈值因数

例如，如果您将“网络读取”的临界阈值更改为 40 MB/秒，并且想知道其低阈值，可以用 40 乘以 0.25，得出 10 MB/秒。 要得到中阈值，可以用 40 乘以 0.50，依此类推。

为防止池主服务器过载，Workload Balancing 会自动将池主服务器的临界阈值设置得较低。

其他阈值如何触发建议

尽管临界阈值可以触发许多建议，但其他阈值也可以触发建议，如下所述：

高阈值。
  • 性能最大化。 超出高阈值会触发将虚拟机重定位到资源利用率较低的主机的优化建议。
  • 密度最大化。 如果将虚拟机移动到主机会导致该主机上任何资源的利用率超出高阈值，Workload Balancing 将不会提出将该虚拟机放置到该主机的建议。
低阈值。
  • 性能最大化。 Workload Balancing 不会因低阈值而触发建议。

  • 密度最大化。 当某个指标值降到低阈值以下时，它会向 Workload Balancing 发出信号，告知主机利用率偏低，并触发将虚拟机合并到更少主机上的优化建议。 Workload Balancing 将持续提出将虚拟机移动到某个主机的建议，直至该主机某个资源的指标值达到高阈值为止。

    但是，如果在重定位某个虚拟机后，该虚拟机所在新主机上的某种资源的利用率超出其临界阈值，Workload Balancing 将临时使用与性能最大化负载平衡算法相类似的算法来为虚拟机查找新主机。 Workload Balancing 将持续使用此算法来提出移动虚拟机的建议，直到池中各主机上的资源利用率都降至高阈值以下。

更改临界阈值

  1. 在资源窗格中选择池，单击 WLB 选项卡，然后单击设置。
  2. 在左侧窗格中，选择临界阈值。

  3. 在临界阈值页面中，接受临界阈值框中的值或输入一个新值。 在提供虚拟机放置和池优化建议时，Workload Balancing 会使用这些阈值。 Workload Balancing 会努力将主机的资源利用率保持在设定的临界阈值以下。


调整指标加权

注: 在调整指标加权之前，Citrix 建议您阅读《Workload Balancing 管理员指南》中关于优化和合并过程的内容。 本帮助主题中的信息是该指南所含信息的一部分，仅作为更改用户界面时的参考。

Workload Balancing 使用指标加权（一种指定资源重要性的方法）确定应该首先优化的主机。

确定首先处理的主机和 VM 时，Workload Balancing 对指标加权的使用方式因优化模式（密度最大化或性能最大化）而异。

Workload Balancing 处理优化建议时，将创建优化顺序。 确定此顺序时，Workload Balancing 将最重要资源拥有最高指标值的主机排在最优先处理的位置，资源的重要性通过指标加权页面排定。

通常，指标加权主要在池处于性能最大化模式时使用。 但是，当 Workload Balancing 处于密度最大化模式时，如果某个资源超出其临界阈值，也会使用指标加权。

在性能最大化模式下应用指标加权的方式

在性能最大化模式下，Workload Balancing 使用指标加权确定：(a) 首先处理哪些主机的性能；(b) 建议首先迁移哪些 VM。

例如，如果将“网络写入”排定为 Workload Balancing 应考虑的最重要资源，即您将指标加权滑块移动到最右端（更重要），而将所有其他滑块移动到中间，则 Workload Balancing 将首先在每秒网络写入量最多的主机上解决性能问题（即提供优化建议）。

在密度最大化模式下应用指标加权的方式

在密度最大化模式下，Workload Balancing 仅在某个主机达到临界阈值时使用指标加权，然后 Workload Balancing 应用一种与性能最大化模式类似的算法，直到没有任何主机超出临界阈值。 使用与性能最大化模式类似的算法时，Workload Balancing 按照与性能最大化模式相同的方式，使用指标加权来确定优化顺序。

如果两个或更多主机的资源超出其临界阈值，Workload Balancing 将首先验证您为每个资源设置的重要性，然后据此确定要优先进行优化的主机，以及该主机上要优先重定位的 VM。

例如，池中包含主机 A 和主机 B，二者分别处于以下状态：
  • 主机 A 上的 CPU 使用率超出了 CPU 临界阈值，而 CPU 使用率的指标加权设置在滑块最右端（更重要）。
  • 主机 B 上的内存利用率超出了内存临界阈值，而内存利用率的指标加权设置在滑块最左端（不太重要）。

Workload Balancing 将提出首先优化主机 A 的建议，因为该主机上达到临界阈值的资源是权重值最高的资源。 在 Workload Balancing 确定需要处理主机 A 的性能后，便开始为该主机上的 VM 提出放置建议，首先从 CPU 使用率最高的 VM 开始，因为 CPU 使用率是权重值最高的资源。

Workload Balancing 在提出优化主机 A 的建议后，将提出主机 B 的优化建议。 当它为主机 B 上的 VM 提出放置建议时，将首先处理 CPU 使用率，因为 CPU 使用率具有最高权重。

如果有其他需要优化的主机，Workload Balancing 将处理 CPU 使用率排在第三位的主机的性能。

默认情况下，所有指标加权设置在滑块的最远点（更重要）。
注: 指标加权是相对值。 这意味着如果所有指标设置为相同级别，那么即使该级别为不太重要，它们的权重也是相同的。 比起为每个指标设置的实际权重，各指标之间的关系更重要。

编辑指标加权系数

  1. 在资源窗格中选择池，单击 WLB 选项卡，然后单击设置。
  2. 在左侧窗格中，选择指标加权。
  3. 在指标加权页面中，根据需要调整各资源旁的滑块。

    如果将滑块移向不太重要，表明在该资源池中，确保虚拟机始终具有最高数量的可用该资源不太重要。


从建议中排除主机

配置 Workload Balancing 时，可以指定从 Workload Balancing 优化和放置建议（包括“启动”放置建议）中排除特定的物理主机。

何时排除主机

以下情况下可能需要从建议中排除主机：
  • 要在密度最大化模式下运行池、合并及关闭主机，但希望某些特定主机不实施该行为。
  • 两个虚拟机工作负载始终需要在同一主机上运行（例如，它们是互补的应用程序或工作负载）。
  • 不希望移动某些工作负载（例如，域控制器或 SQL Server）。
  • 您需要对主机执行维护，而不希望将虚拟机放置在该主机上。
  • 工作负载性能的重要性高过专用硬件的成本。
  • 特定主机上正在运行高优先级的工作负载（虚拟机），而您并不希望使用高可用性功能来为这些虚拟机确定优先级。
  • 主机中的硬件对于池中的其他工作负载并不是最优选择。

无论指定固定优化模式还是计划优化模式，即使切换优化模式，已排除的主机仍会被排除。 因此，如果您只希望阻止 Workload Balancing 自动关闭某个主机，则应考虑不为该主机启用（或取消选择）电源管理功能，如自动优化和管理电源中所述。

从放置和优化建议中排除主机

  1. 在资源窗格中选择池，单击 WLB 选项卡，然后单击设置。
  2. 在左侧窗格中，选择排除的主机。
  3. 在排除的主机页面中，选择您不希望 Workload Balancing 提出备用放置和优化建议的主机。


高级设置

高级对话框中的设置主要用于调整 Workload Balancing 在自动化模式下运行时应用建议的方式。
重要:

在 Workload Balancing 运行一段时间之后，如果您没有收到最佳放置建议，Citrix 强烈建议您对性能阈值进行评估，如《Workload Balancing 管理员指南》中所述。 根据环境为 Workload Balancing 设置正确的阈值至关重要，否则它可能无法提供适当的建议。

概述：设置保守或主动的自动化建议

在自动化模式下运行时，提供优化和合并建议的频率以及自动应用这些建议的时间由多种因素决定，包括：
  • 您所指定的、Workload Balancing 在应用其他优化建议之前等待的时间
  • Workload Balancing 在自动应用某个建议之前必须达到的建议数
  • 在自动应用优化前建议必须达到的严重级别
  • Workload Balancing 在自动应用建议之前需要的建议（建议移动的虚拟机，目标主机）一致性级别

VM 迁移时间间隔

可以指定上次移动特定虚拟机后（无论是何原因），Workload Balancing 必须等待多久（分钟）才能生成包含该特殊虚拟机的其他优化建议。

建议间隔用于防止 Workload Balancing 由于不实的原因（例如，利用率短暂达到峰值）生成建议。

如果配置了“自动化”功能，则修改建议间隔时务必要非常小心。 如果出现导致持续、反复出现尖峰的问题，则提高频率（即设置更低的间隔值）会产生大量建议，从而发生多次重新定位。
注: Workload Balancing 需要等待一段时间才会考虑将最近重新平衡的服务器纳入启动放置、恢复及维护模式的建议，而设置建议间隔不会对这段等待时间产生影响。

建议计数

Workload Balancing 每两分钟进行一次检查，判断能否为正在监视的池生成建议。 启用“自动化”功能时，可以指定 Workload Balancing 必须提供多少次一致的建议才能自动应用该建议。 为此，需要配置一项称为“建议计数”的设置。 “建议计数”和“优化主动性”设置用于调整在环境中自动应用程序建议的方式。

如概述部分所述，Workload Balancing 利用建议的相似性来：a) 确认是否真正需要提供建议；b) 确定目标主机是否在较长时间内有足够稳定的性能来接受重定位的虚拟机（而无需在不久后将其再次从主机移出）。 Workload Balancing 使用“建议计数”值来确定在 Workload Balancing 自动应用建议之前必须重复提出该建议的次数。

Workload Balancing 按如下所述使用此设置：
  1. 每次 Workload Balancing 生成满足一致性要求（由“优化主动性”设置指定）的建议时，Workload Balancing 都会将“建议计数”值递增。 如果该建议不满足一致性要求，Workload Balancing 可能会将“建议计数”重置为零，具体取决于《Workload Balancing 管理员指南》中所述的因素。
  2. 当 Workload Balancing 生成符合“建议计数”值（在“建议”文本框中指定）且足够数量的一致建议时，它将自动应用建议。
如果您选择修改此设置，应根据环境的不同来设置该值。 请考虑以下情形：
  • 如果您环境中的服务器负载和活动急速增加，可能需要增大“建议计数”的值。 Workload Balancing 每两分钟生成一次建议。 举例来说，如果将此间隔设置为“3”，则在六分钟后，Workload Balancing 将自动应用建议。
  • 如果您环境中的服务器负载和活动逐渐增加，则可能需要减小“建议计数”的值。

在 Workload Balancing 重定位虚拟机时，接受建议会占用系统资源，并对性能产生影响。 增大“建议计数”的值会增加在 Workload Balancing 应用建议之前必须出现的匹配建议的数目，从而促使 Workload Balancing 应用更保守、稳定的建议，并且降低错误移动虚拟机的可能性。 但应注意，“建议计数”的默认设置较为保守。

由于调整此设置可能会对环境产生影响，Citrix 建议在更改此设置时要极其小心，最好反复测试并更改此值，或者在 Citrix 技术支持人员的指导下进行。

建议严重性

所有优化建议都包含一个严重性级别（严重、高、中、低），用于指示建议的重要程度。 Workload Balancing 根据多项因素的组合确定该严重级别，这些因素包括您设置的配置选项，例如阈值和指标调整、可供工作负载使用的资源以及资源使用情况历史记录。

如果将 Workload Balancing 配置为自动应用优化建议，则可以设置在 Workload Balancing 自动应用优化建议之前应与该建议相关联的最低严重级别。

优化主动性

在自动化模式下运行时，为了提供更多的保证，Workload Balancing 针对自动接受优化规定了一致性条件，以避免由于高峰和异常而移动虚拟机。 在自动化模式下，Workload Balancing 不会接受所生成的第一个建议， 而是一直等到主机或虚拟机持续出现一致行为时才自动应用建议。 “持续出现一致行为”这句话是指某个主机是否持续触发建议，以及该主机上的相同虚拟机是否持续触发建议等等因素。

Workload Balancing 通过使用一致性条件以及规定同一个建议提出次数（即建议计数）的条件来判断行为是否一致。 您可以使用优化的主动性设置来配置希望 Workload Balancing 应用一致性条件的严格程度。

虽然 Citrix 设计优化主动性设置主要是为了进行演示，但您可以使用该设置来控制在 Workload Balancing 应用优化建议之前环境中需要达到的稳定程度。 默认情况下配置为最稳定的设置（低主动性）。 在此上下文中，术语“稳定”是指建议的更改具有持续的相似性，如本部分内容所介绍。

Workload Balancing 最多使用四个条件来确定一致性。 必须满足的条件数因您在优化的主动性设置中设定的级别而异。 级别越低（例如“低”或“中”），Workload Balancing 接受建议的主动性就越低。 换言之，当主动性设置为“低”时，Workload Balancing 对于满足一致性条件的要求更加严格（或者说更具限制性或更不主动）。

例如，如果主动性级别设置为“低”，则 Workload Balancing 要求在自动应用建议之前，每个“低”值条件都符合在“建议”框中（用于指定“建议计数”值）指定的次数。

例如，如果在建议框中将“建议计数”设置为“3”，则 Workload Balancing 将一直等到满足《Workload Balancing 管理员指南》中针对低值所列的所有条件并且连续三次重复提出建议时，才会应用该建议。 这样有助于确保虚拟机确实需要移动，而且 Workload Balancing 推荐的目标主机在较长时间内具有持续稳定的资源利用率。 这样可以降低最近移动过的虚拟机由于移动后主机性能发生改变而又从主机移出的可能性。 默认情况下，此项设置设为保守设置（“低”）以促进稳定性。

Citrix 建议不要通过增加优化的主动性值来提高主机优化频率。 如果您觉得您的主机优化速度不够快或频率不够高，请尝试调整临界阈值，如更改临界阈值中所述。

有关与不同主动性级别相关的一致性条件的详细信息，请参阅《Workload Balancing 管理员指南》。

如果您发现 Workload Balancing 自动应用优化建议的频率不够高，则需要增大主动性设置的值。 但 Citrix 强烈建议您在进行上述调整之前，先查阅《Workload Balancing 管理员指南》中的相关信息。

配置虚拟机建议时间间隔

  1. 在基础结构视图中选择池，单击 WLB 选项卡，然后单击设置。
  2. 在左侧窗格中，单击高级。
  3. 在 VM 迁移时间间隔部分，执行以下一项或多项操作：

    - 在分钟(等待时间)框内，键入希望 Workload Balancing 在对刚刚重新平衡的服务器提出其他优化建议之前等待的时间（分钟）。

    - 在建议计数框内，键入希望 Workload Balancing 在自动应用优化建议之前提出的优化建议的数量。

    - 从建议严重性列表中，选择自动应用优化之前的最低严重级别。

    - 从优化主动性列表中，指定 Workload Balancing 如何主动地自动应用优化建议。

池审核追踪精度

Workload Balancing 使您能够指定要在池审核追踪报告中收集的数据量。 此功能还允许您搜索审核追踪日志并按特定用户、对象和时间对这些日志进行过滤。

默认情况下，池审核追踪精度设置为最低。 此选项可捕获有限数量的特定用户和对象类型的数据。 您可以随时根据您报告中所需的详细级别修改设置。 例如，将用户友好的审核日志报告的精度设置为中。 如果您需要非常详细的报告，可以将此选项设置为最大。
重要: 将池审核追踪精度设置为“最大”会使 Workload Balancing 服务器使用更多磁盘空间和内存。 如果您选择将精度设置为“最大”，则建议您仔细监控 WLB 服务器的磁盘空间、内存使用率和 CPU 使用率。 如果您认为 WLB 服务器存在资源压力，您应将精度设置更改为“中”或“最低”，或考虑扩展您 WLB 服务器的内存或硬盘大小。

有关详细信息，请参阅 Workload Balancing 报告词汇表 和 审核日志事件。


管理 Workload Balancing

您可能会对 Workload Balancing 执行一些管理任务，这些任务包括：
  • 与 Workload Balancing 断开连接
  • 更改池使用的 Workload Balancing 虚拟设备
  • 更改 Workload Balancing 或 XenServer 用来进行通信的凭据
还可以使用 Workload Balancing 服务命令管理 Workload Balancing 虚拟设备。 这些命令可用于确定 Workload Balancing 虚拟设备状态、更改用户帐户以及提高日志记录详细程度。 有关这些命令的信息，请参阅《Workload Balancing 管理员指南》。
注: 有关将 Workload Balancing 配置为使用其他证书或将 XenServer 配置为验证证书身份的信息，请参阅《Workload Balancing 管理员指南》。


与 Workload Balancing 断开连接

如果希望 Workload Balancing 停止监视池，必须通过与 Workload Balancing 服务器断开连接的方式为池禁用 Workload Balancing。

断开池与 Workload Balancing 虚拟设备的连接时，Workload Balancing 会从 Workload Balancing 数据库中永久删除关于该池的信息，并停止收集该池的数据。 这意味着如果希望使用同一个 Workload Balancing 虚拟设备再次管理该池，必须在连接 WLB 服务器对话框中重新输入该设备的信息。
重要: 如果只想暂时停止 Workload Balancing，请单击 WLB 选项卡，然后单击暂停按钮。

断开与 Workload Balancing 的连接

  1. 在 XenCenter 的资源窗格中，选择要停止 Workload Balancing 的资源池。
  2. 从池菜单中，选择断开 Workload Balancing 服务器连接。 此时将显示断开 Workload Balancing 服务器连接对话框。
  3. 单击断开连接以停止 Workload Balancing 对池的监视。
    注: 如果断开了池与 Workload Balancing 虚拟设备的连接，要对该池重新启用 Workload Balancing，必须重新连接到该设备。


将池重新配置为使用其他 WLB 设备

可以将一个池重新配置为使用其他 Workload Balancing 虚拟设备。

但是，为了防止原来的 Workload Balancing 设备意外地继续保持已配置状态并收集该池的数据，在将该池连接到新的 Workload Balancing 设备之前，必须将其与原来的 Workload Balancing 设备断开连接。

一旦池与原来的 Workload Balancing 设备断开连接，就可以通过指定新的 Workload Balancing 设备名重新连接该池。

使用其他 Workload Balancing 设备

  1. 对于要使用其他 Workload Balancing 设备的池，从池菜单中，选择断开 Workload Balancing 服务器连接，然后在出现提示时单击断开连接。 有关说明，请参阅与 Workload Balancing 断开连接。
  2. 在 WLB 选项卡中，单击连接。 此时将显示连接 WLB 服务器对话框。
  3. 在地址框中，键入新 Workload Balancing 设备的 IP 地址或主机名 (FQDN)。
    如果新 Workload Balancing 设备使用不同凭据，还必须输入新凭据。
    注: 必须输入在初次将池连接到 Workload Balancing 时通常会输入的所有信息。 有关信息，请参阅连接 Workload Balancing。


更新 Workload Balancing 凭据

完成初始配置后，如果需要更新 XenServer 与 Workload Balancing 设备用来通信的凭据，可以按照以下三步过程操作：
  1. 如下面所述断开与 Workload Balancing 的连接。
  2. 通过编辑 WlbConfig 文件（在 Workload Balancing 虚拟设备的控制台中运行 WlbConfig 命令）更改 WLB 凭据。 有关详细信息，请参阅《Workload Balancing 管理员指南》。
  3. 如下面所述重新启用 Workload Balancing 并指定新凭据。
在以下情况下您可能要执行这些步骤：
  • 如果需要更改 XenServer 用来与 Workload Balancing 进行通信的用户帐户
  • 如果您收到一条错误消息，说明 Workload Balancing 凭据不再有效
  • 如果服务不可用

如果要修改阈值设置，并更改指定给特定资源的优先级，请参阅编辑 Workload Balancing 设置。

断开与 Workload Balancing 的连接

  1. 在 XenCenter 的资源窗格中，选择要停止 Workload Balancing 的资源池。
  2. 从池菜单中，选择断开 Workload Balancing 服务器连接。 此时将显示断开 Workload Balancing 服务器连接对话框。
  3. 单击断开连接以永久停止 Workload Balancing 对池的监视。

重新启用 Workload Balancing 并指定新凭据

  1. 完成全部进度之后，单击连接。 此时将显示连接 WLB 服务器对话框。
  2. 单击更新凭据。
  3. 在服务器地址部分，根据需要修改以下内容：
    • 在地址框中，键入 Workload Balancing 设备的 IP 地址或 FQDN。
    • （可选） 如果在 Workload Balancing 配置期间更改了端口号，请输入该端口号。 XenServer 使用您在此框中以及 Workload Balancing 配置期间指定的端口号来连接 Workload Balancing。
      默认情况下，XenServer 通过端口 8012 连接 Workload Balancing。
      注: 除非您在 Workload Balancing 设置期间更改了此端口号，否则请勿对其进行编辑。 安装期间指定的端口号值与 Workload Balancing 配置对话框中指定的值必须匹配。
  4. 在 WLB 服务器凭据部分，输入运行 XenServer 的计算机在连接 Workload Balancing 服务器时使用的用户名（例如 wlbuser）和密码。
  5. 在 XenServer 凭据部分中，输入所配置池的用户名和密码（通常为池主服务器的密码）。 Workload Balancing 将使用这些凭据连接该池中运行 XenServer 的计算机。 要使用当前登录 XenServer 所使用的凭据，请选中使用当前 XenCenter 凭据复选框。


在启用 Workload Balancing 的状态下进入维护模式

启用 Workload Balancing 后，如果将物理主机脱机以进行维护（即通过进入维护模式来挂起服务器），XenServer 会自动将该主机上运行的虚拟机迁移到最优服务器上（如果可用）。 XenServer 会根据 Workload Balancing 的建议（性能数据、放置策略和性能阈值）迁移这些虚拟机。

如果没有可用的最佳服务器，进入维护模式对话框中会显示单击此处挂起 VM 字样。 在这种情况下，Workload Balancing 不会提供放置建议，因为所有主机都没有足够的资源来运行此虚拟机。 您可以将此虚拟机挂起，或者退出“维护模式”，并将同一资源池中另一台主机上的一个虚拟机挂起。 这样，当您再次进入进入维护模式对话框时，Workload Balancing 可能会列出一台适合迁移的候选主机。
注: 如果您将一台服务器脱机以进行维护，而且 Workload Balancing 处于启用状态，则进入维护模式对话框的右上角会显示“Workload Balancing”字样。

在启用 Workload Balancing 的状态下进入维护模式

  1. 在资源窗格中选择服务器，然后执行以下操作之一：
    • 单击鼠标右键，在快捷菜单中单击进入维护模式。
    • 在服务器菜单中，单击进入维护模式。
  2. 单击进入维护模式。 服务器上运行的虚拟机会根据 Workload Balancing 的性能数据、放置策略和性能阈值，自动迁移到最优主机上。

使服务器退出维护模式

  1. 在资源窗格中选择服务器，然后执行以下操作之一：
    • 单击鼠标右键，在快捷菜单中单击退出维护模式。
    • 在服务器菜单中，单击退出维护模式。
  2. 单击退出维护模式。

    在服务器退出维护模式之后，XenServer 会自动将该服务器的原始虚拟机还原到该服务器。


Workload Balancing 故障排除

尽管通常情况下 Workload Balancing 都会顺畅地运行，但本帮助系统仍包含了一系列与故障排除相关的主题，以便在您遇到问题时为您提供指导。 《Workload Balancing 管理员指南》中提供了更多故障排除主题。

下面是关于解决 Workload Balancing 常规问题的几点提示：

常规故障排除提示

执行故障排除时，首先应查看 Workload Balancing 日志。 该日志位于 Workload Balancing 设备上的以下位置（默认位置）：

/var/log/wlb

另外，您还可以在 XenCenter 的“导航”窗格中查看事件日志，依次单击通知和事件可了解更多信息。

错误消息

Workload Balancing 将在 XenCenter 中的警报视图上显示错误消息，在某些情况下，还会以对话框形式显示在屏幕上。


Workload Balancing 凭据输入问题

如果在配置连接 WLB 服务器对话框时无法使 Workload Balancing 接受设备的用户帐户和密码，请尝试以下操作：
  • 确保 Workload Balancing 设备已导入且配置正确，并且已通过 service workloadbalancing start 命令运行所有其服务。
  • 按照 Workload Balancing 启动问题中的指导进行检查，以确保您输入的凭据正确无误。
  • 如果输入 Workload Balancing FQDN 遇到困难，请输入 Workload Balancing 服务器的 IP 地址。

可以在地址框中输入 Workload Balancing 设备的主机名，但该名称必须是完全限定的域名 (FQDN)。 例如，yourcomputername.yourdomain.net。


Workload Balancing 启动问题

如果在导入和配置 Workload Balancing 设备后，收到一条错误消息，指出 XenServer 与 Workload Balancing 无法互相连接，原因可能是您在连接 WLB 服务器对话框中输入了错误的凭据。 要解决此问题，请尝试：
  • 确认您在连接 WLB 服务器对话框中输入的凭据与您在 Workload Balancing 服务器和 XenServer 上创建的凭据一致。
  • 确认您在连接 WLB 服务器对话框中输入的 Workload Balancing 设备的 IP 地址或 FQDN 正确无误。
  • 确认您在 Workload Balancing 配置期间创建的 Workload Balancing 帐户的帐户凭据与您在连接 WLB 服务器对话框中输入的凭据一致。


Workload Balancing 连接错误

如果在 WLB 选项卡上的“Workload Balancing 状态”行中收到连接错误消息，可能需要为该资源池重新配置 Workload Balancing。

单击 WLB 选项卡上的连接按钮，然后再次输入服务器凭据。

出现此错误通常是因为更改了 WLB 虚拟设备或池主服务器的凭据，或者更改了 WLB 虚拟设备的名称。


Workload Balancing 服务器的更改问题

如果在将资源池连接到其他 Workload Balancing 虚拟设备时，没有先断开该池与原始 Workload Balancing 设备的连接，则原来的和新的 Workload Balancing 设备都会监视该池。

要解决此问题，可以关闭并删除原来的 Workload Balancing 设备，或者手动停止 Workload Balancing 服务（分析、数据收集器和 Web 服务），使该设备不再监视池。

Citrix 建议不要使用 pool-initialize-wlb xe 命令删除或更改 Workload Balancing 服务器配置。


监视系统性能

主题

  • 关于性能监视
  • 查看性能数据
  • 配置性能图表
  • 配置性能警报


关于性能监视

使用 XenCenter 中的性能选项卡提供整个资源池性能的实时监视统计数据，并以图表方式显示虚拟机和物理机性能的趋势。

  • 可以查看最长 12 个月的性能数据，并可将数据放大，以便更清楚地查看活动高峰。 要了解更多信息，请参阅查看性能数据。
  • 默认情况下，该选项卡上提供显示 CPU、内存、网络和磁盘 I/O 情况的图表。 但是，您可以添加更多性能数据并更改图表外观。 要了解更多信息，请参阅配置性能图表。
  • 当托管服务器、虚拟机或存储库上的 CPU、内存使用率、网络、存储吞吐量或 VM 磁盘活动超出指定阈值时，可生成性能警报。 有关详细信息，请参阅配置性能警报。
注: 只有安装了 XenServer 半虚拟化驱动程序 (XenServer Tools) 的虚拟机才可以获得全部性能数据。


查看性能数据

性能选项卡以图表形式显示选定服务器或虚拟机的性能数据。

对于服务器，可以查看以下内容：

  • CPU、内存和网络 I/O 使用率数据，如果需要，可以添加显示其他资源使用情况数据的图表。 例如，可以添加控制域负载：这是过去 5 分钟在 XenServer 控制域 (dom0) 内排队的进程数平均值 (Linux loadavg)。
  • 服务器上托管的所有 VM 的生命周期事件将显示在 VM 生命周期事件窗格中。

对于虚拟机，默认显示的图表将包含 CPU、内存、网络 I/O 和磁盘使用情况数据。

使用该选项卡底部的摘要图，可以快速查看计算机上发生的事件摘要，并可以调整在其他图表中显示的时间范围，以显示更长或更短期限内的数据，或者显示更早期限的数据。

要在该选项卡中添加其他类型的性能数据或者更改图表外观，请参阅配置性能图表。

查看更长或更短期限的数据

默认显示此前 10 分钟的数据。 要查看更长或更短期限内的数据，请执行以下操作之一：

  • 要查看上一小时、前 24 小时、上周、上月或去年的可用性能数据，请单击缩放，然后选择 1 小时、1 天、1 周、1 月或 1 年。
  • 要重新调整图表中显示的时间段，可以在摘要图中，将鼠标指针指向示例区域边缘的垂直拆分条。 当鼠标指针变为双向箭头 [image] 时，向右或向左拖动垂直拆分条。 例如：

查看不同时段的数据

要移动图表中显示的数据的时间范围，可以指向任意图表，当指针变为移动光标 [image] 时，只需将图表或摘要图中的示例区域图向左或向右拖动。 例如：

查看服务器上 VM 的生命周期事件数据

要查看服务器上托管的 VM 的生命周期事件，可以使用 VM 生命周期事件列表。

  • 每个事件都有一个含有该生命周期事件的完整消息的工具提示（“虚拟机‘Sierra’已启动”）。
  • 可以使用光标键在列表的项中导航。
  • 双击图表或按 Enter 键可以将图表缩放到发生选定生命周期事件的时点。
  • 选择（单击或用光标键突出显示）一个事件可以突出显示图表本身的生命周期事件。


配置性能图表

添加新图表

  1. 在性能选项卡上，单击操作，然后单击新建图表。 此时将显示新建图表对话框。
  2. 在名称字段中输入图表的名称。
  3. 从数据源列表中，选中图表中要包含的数据源所对应的复选框。
  4. 单击保存。

编辑图表

  1. 导航到性能选项卡，然后选择要编辑的图表。
  2. 单击操作，然后单击编辑图表。
  3. 在图表详细信息窗口中进行必要的更改，然后单击确定。

删除图表

  1. 从性能选项卡上显示的图表列表中，选择要删除的图表。
  2. 单击操作，然后单击删除图表。
  3. 单击是确认删除操作。

对图表重新排序

  1. 导航到性能选项卡，然后选择要重新排序的图表。
  2. 单击上移或下移选项卡从当前位置移动图表。

更改图表中的数据源颜色

  1. 导航到性能选项卡。
  2. 双击要更改数据源颜色的图表。 此时将显示图表详细信息对话框。
  3. 单击所需数据源对应的彩色复选框，然后从颜色选取器中选择新的颜色。
  4. 单击确定进行确认。

更改图表类型

可以采用折线图或区域图的形式来显示性能图表中的数据：

折线图：

区域图：

要更改图表类型，请执行以下操作：

  1. 在工具菜单中，单击选项，然后单击图表选项卡。
  2. 要以折线图形式查看性能数据，请单击折线图单选按钮。
  3. 要以区域图形式查看性能数据，请单击区域图单选按钮。
  4. 单击确定保存更改。


配置性能警报

当托管服务器、虚拟机或存储库上的 CPU、内存使用率、网络、存储吞吐量或 VM 磁盘活动超出指定阈值时，可生成性能警报。 默认情况下，警报重复间隔为 60 分钟，但您也可以修改此间隔。

性能警报将在警报视图中显示（通过单击左侧窗格的通知按钮即可访问）。 另外，您可以将性能警报和其他警报一起通过电子邮件发送给自己：请参阅XenCenter 警报。

配置性能警报：

  1. 在资源窗格中选择服务器、虚拟机或存储库，单击常规选项卡，然后单击属性。
  2. 单击警报选项卡，然后：
    • 要请求服务器或虚拟机的 CPU 性能警报，请选中生成 CPU 使用率警报复选框，然后设置将触发该警报的 CPU 使用率和时间阈值。
    • 要请求服务器或虚拟机的网络性能警报，请选中生成网络使用率警报复选框，然后设置将触发该警报的网络使用率和时间阈值。
    • 要请求服务器内存性能警报，请选中生成内存使用率警报复选框，然后设置将触发该警报的内存使用率和时间阈值。
    • 要请求虚拟机的磁盘使用情况性能警报，请选中生成磁盘使用情况警报复选框，然后设置将触发该警报的磁盘使用情况和时间阈值。
    • 要请求存储库的存储吞吐量警报，请选中生成存储吞吐量警报复选框，然后设置将触发该警报的存储吞吐量和时间阈值。
      注: 当物理块设备 (PBD) 上的读/写存储吞吐量活动超过指定的限制时，此选项将生成警报。 PBD 用作特定 XenServer 主机与连接的 SR 之间的接口。 当 PBD 上的总读/写 SR 吞吐量活动超过您指定的阈值时，与 PBD 连接的主机上将生成警报。 与其他主机警报不同，此警报必须在相关 SR 上进行配置。
    • 要更改警报重复间隔，请在警报重复间隔框中输入分钟数。 达到警报阈值并生成一个警报后，只有在已耗完警报重复间隔时间后，才会生成另一个警报。
  3. 单击确定保存更改。


更新和升级

主题

  • 关于软件更新和升级
  • 更新托管服务器 -“安装更新”向导
  • 升级托管服务器 -“滚动池升级”向导
  • 更新 XenCenter
  • 自动更新通知


关于软件更新和升级

软件升级是 XenServer 主要独立版本的升级。 通过升级添加新功能或新技术，或者替换不再受支持的版本。 软件更新将更新 XenServer 的主要版本，但不将其升级到下一个主要版本。

默认情况下，XenCenter 配置为定期自动检查 XenServer 和 XenCenter 的新更新和升级版本，当有新的可用更新或产品版本时，您将收到通知。 建议您安装所有已发布的更新。 您可以随时手动检查可用更新，并验证您运行的 XenServer 和 XenCenter 是否都是最新版本。 要执行此操作，请选择通知 > 更新，然后单击刷新。

对 XenServer 主机应用更新

XenServer 更新以文件扩展名为 .xsupdate（对于运行早期版本 XenServer 的嵌入服务器为 .xsoem）的文件形式提供。 下载 XenServer 更新（包括关键更新、修补程序和安全更新）后，可以将更新快速应用到托管服务器。有关详细信息，请参阅更新托管服务器。

更新所用版本的 XenCenter

XenCenter 的更新以 XenCenterSetup.exe 文件的形式提供，可使用“下载管理器”进行下载和安装；请参阅更新 XenCenter。

升级 XenServer 主机

使用滚动池升级向导升级 XenServer 主机。 可以使用此向导升级池中的多台服务器，同时最大程度减少针对所运行 VM 造成的服务中断。 在依次对每台服务器应用升级时，VM 会自动迁移到其他可用服务器上。 此向导也可用于升级单台服务器。

请参阅升级托管服务器。

注: 如果出于任何原因，滚动池升级向导无法将 VM 迁移回池主服务器，则池升级将停止，使池处于部分得到升级的状态。 Citrix 建议您退出滚动池升级向导，并解决引起迁移问题的原因，然后将 VM 手动迁移回池主服务器，再重新启动滚动池升级向导继续池升级。


更新托管服务器

XenServer 的更新可以通过修补程序或 Service Pack 的方式提供。 修补程序通常提供对一个或多个特定问题的缺陷修复，而 Service Pack 中包含累积的缺陷修复，有时包含改进功能和增强功能。 必须特别注意随每个更新发布的发行说明。 每个更新可能具有独特的安装说明，特别是对于准备操作和更新后操作。

注意: 对主机应用更新之前，应特别注意以下事项：
  1. 与执行任何其他维护操作一样，请在应用更新之前备份您的数据。 有关备份过程，请参阅《XenServer 管理员指南》。
  2. 建议您在安装更新之前重新启动所有服务器，然后验证其配置，例如，检查 VM 是否启动以及存储是否可访问。 这是因为有些配置更改只有在重新启动主机后才能生效，因此，重新启动可以发现可能会导致更新失败的配置问题。
  3. 将 XenServer 主机的池升级到新版本时，必须在应用任何修补程序或更新之前升级池中的每个主机，并确保池正在运行。
  4. 在短时间内更新池中的所有主机：运行混合模式池（包含更新的主机和未更新的主机的池）不属于受支持的配置。 应安排执行此操作，以将池在混合模式下运行的时间缩至最短。
  5. 按顺序更新池中的所有主机，请始终先更新池主服务器。
  6. 对池中的所有主机应用更新后，应在重新启动 XenServer 主机之前更新所需的任何驱动程序磁盘。

对托管服务器应用更新

使用安装更新向导可以将同一个更新同时应用到多个主机。 该向导会自动将 VM 迁离每个主机，将主机置于维护模式，应用更新，在需要时重新启动主机，然后重新将 VM 迁回更新后的主机。 在预检阶段为应用更新而执行的任何操作（例如关闭高可用性）都将还原。

本部分提供使用下载并安装选项自动应用更新的说明。 此选项将提取更新文件，并在选择了相关服务器的情况下打开安装更新向导。

如果您更倾向于下载更新文件并使用安装更新向导应用更新，请参阅自动下载并应用更新部分。

  1. 在 XenCenter 导航窗格中，单击通知，然后单击更新。 此时将显示可用更新的列表。

    注意：

    • 默认情况下，XenCenter 会定期检查 XenServer 和 XenCenter 更新。 单击刷新可手动检查可用更新。
    • 除其他更新之外，更新视图还会列出所有可用的 XenServer 新版本。 有关使用“滚动池升级”向导升级 XenServer 主机的信息，请参阅升级托管服务器。
  2. 从“更新”列表中选择所需的更新，然后单击下载并安装。 此操作将提取更新，并在选择了相关服务器的选择服务器页面上打开安装更新向导。 如果您想更改正在更新的池或主机，请取消选中复选框。 不能更新的所有主机或池将显示为灰色。
    重要: Citrix 强烈建议客户阅读随每个更新发布的发行说明。 要在浏览器中打开发行说明，请单击下载并安装下拉列表，然后选择转至 Web 页面。
  3. 查看服务器选择，然后单击下一步继续。
  4. 安装更新向导将执行多项更新预检查，以验证更新是否可以在选定服务器上应用并显示结果。 按照屏幕上的建议进行操作以解决任何失败的更新预检查。 如果希望 XenCenter 自动解决所有失败的预检，请单击全部解决。
  5. 单击下一步。
  6. 选择更新模式。 检查屏幕上显示的信息，然后选择恰当的模式。
    注: 如果在此阶段单击取消，安装更新向导将还原更改，并从主机中删除更新文件。
  7. 选择安装更新以继续进行安装。 “安装更新”向导将显示更新进度，同时显示在更新池中的每个主机时 XenCenter 执行的主要操作。
  8. 应用更新后，单击完成关闭“安装更新”向导。
  9. 如果选择执行更新后任务，请立即执行。

手动安装并应用更新

XenCenter 允许您将更新下载到本地计算机，并使用安装更新向导应用更新。 为此，您需要：

  1. 从 XenCenter 导航窗格选择通知，然后选择更新。 此时将显示可用的 XenServer 和 XenCenter 更新列表。
  2. 从列表中选择所需的更新。
  3. 单击下载并安装下拉列表，然后选择转至 Web 页面。 此时会在浏览器中打开修补程序更新页面。
  4. 单击下载将文件下载到首选位置。
  5. 在 XenCenter 菜单中，依次选择工具和安装更新。
  6. 阅读“准备工作”页面上显示的信息，然后单击下一步。
  7. 单击添加上载更新。 浏览到保存了更新文件的位置，然后单击打开。
  8. 选择更新，然后单击下一步。
  9. 选择要应用修补程序的服务器，然后单击下一步。
  10. 按照上述步骤 4 到 9 中的说明进行操作，完成更新过程。


升级托管服务器

可以使用池滚动升级向导升级 XenServer 主机（即池中的主机）或独立主机升级到新版本。

该向导会引导您完成升级过程并自动组织升级路径。 对于池来说，池中的每个主机都将从池主服务器开始依次升级。 在开始升级之前，该向导会执行一系列预检，以确保某些池级别的功能（如高可用性和 WLB）暂时被禁用，而且池中的每个主机都做好了升级准备，例如，每个主机的 CD/DVD 驱动器均已清空。 一次只有一个主机处于脱机状态，在将升级安装到每个主机之前，任何正在运行的 VM 都自动从该主机迁出。

该向导可以在手动或自动模式下运行：

  • 在手动模式下，必须依次在每个 XenServer 主机上手动运行 XenServer 安装程序并按主机串行控制台上的屏幕说明操作。 升级开始后，XenCenter 会立即提示您插入 XenServer 安装介质或者为要升级的每个主机指定一个 PXE 启动服务器。
  • 在自动模式下，该向导会使用 HTTP、NFS 或 FTP 服务器上的网络安装文件依次升级每个主机，而不要求您插入安装介质、手动重新启动或者在每个主机上逐步执行安装程序。

您也可以使用滚动池升级向导升级独立主机（即不在池中的主机）。

重要提示：升级准备

升级 XenServer 主机池需要进行认真规划。 在规划升级时，一定要注意以下几点：

  • VM 只能从运行早期版本 XenServer 的 XenServer 主机迁移到运行相同或更高版本 XenServer 的主机（例如，从 6.2 版本迁移到 6.2 版本或者从 6.2 版本迁移到 6.5 版本）。 不能将 VM 从升级后的主机迁移到运行早期版本 XenServer 的主机（例如，从 6.5 版本迁移到 6.2 版本）。 请务必在 XenServer 主机上留出相应的空间。
  • Citrix 强烈建议在非必要的情况下不要运行混合模式的池（即一个池中共存多个 XenServer 版本），这是因为在升级过程中，此类池将在降级状态下操作。
  • 升级期间，关键的控制操作不可用，不应尝试执行这些操作。 尽管 VM 继续正常工作，但除迁移外的其他 VM 操作（例如，关闭、复制和导出）均不可用。 具体来说，执行与存储相关的操作（例如添加、删除虚拟磁盘或调整虚拟磁盘大小）是不安全的。
  • 向导始终优先升级主节点主机。 在执行升级之前，不要使用 XenCenter 将主服务器置于维护模式，因为这样操作将导致主服务器变更。
  • 请使用 pool-dumpdatabase xe CLI 命令对现有池的状态进行备份；请参阅《XenServer 管理员指南》。 这允许您将部分完成的滚动升级还原到其原始状态而不会丢失任何 VM 数据。 由于不能将 VM 从升级的 XenServer 主机迁移到运行早期版本 XenServer 的 XenServer 主机，所以，如果出于某种原因需要还原该滚动升级，则可能需要关闭 VM。
  • 确保主机未过度置备，即主机具有足够的内存来执行升级。 在升级过程中最好将任何非关键的 VM 挂起。
  • 尽管滚动池升级向导会检查是否执行了以下操作，但您可以选择在开始升级前执行这些操作：
    • 清空池中 VM 的 CD/DVD 驱动器。 有关详细信息和说明，请参阅《XenServer 安装指南》。
    • 禁用高可用性。
    • 禁用 WLB

使用“滚动池升级”向导升级 XenServer 主机

  1. 打开“滚动池升级”向导：在工具菜单上，选择滚动池升级。
  2. 阅读准备工作信息，然后单击下一步继续操作。
  3. 选择要升级的池和/或单个主机，然后单击下一步。
  4. 选择自动模式或手动模式，具体取决于您计划从 HTTP、NFS 或 FTP 服务器上的网络安装文件自动升级，还是从 CD/DVD 或服务器通过 PXE 启动手动升级。
    注: 如果选择手动模式，则必须依次在每个 XenServer 主机上运行 XenServer 安装程序，并按照主机串行控制台上的屏幕说明操作。 升级开始后，XenCenter 会立即提示您插入 XenServer 安装介质或者为要升级的每个主机指定一个 PXE 启动服务器。

    选择升级模式后，单击运行预检。

  5. 按照建议解决任何失败的升级预检。 如果希望 XenCenter 自动解决所有失败的预检，请单击全部解决。 解决所有预检后，单击下一步继续操作。
  6. 准备 XenServer 安装介质：
    • 如果选择自动模式，请输入安装介质的详细信息。 选择 HTTP、NFS 或 FTP，然后指定适当的路径、用户名和密码。
    • 如果选择手动模式，应注意升级计划和说明。
    单击启动升级开始进行升级。
  7. 升级开始后，向导会引导您完成升级每台主机所需执行的任何操作。 按照说明操作，直到池中的所有主机均已升级。
  8. 在升级完成之后，该向导会立即显示一个摘要。 单击完成关闭向导。


更新 XenCenter

如果配置了 automatic update notification（自动更新通知），您会不定期地收到 XenCenter 有新更新的通知。 XenCenter 的更新以 XenCenterSetup.exe 文件的形式提供，可从 Citrix XenServer 更新页面下载。

要随时手动检查 XenCenter 新版本，请选择通知 > 更新，然后单击刷新。

下载并安装新版本 XenCenter：

  1. 从 XenCenter 导航窗格选择通知，然后选择更新。 此时将显示可用更新的列表。
  2. 从列表中选择所需的 XenCenter 更新，然后单击转至 Web 页面。 此时将在 Web 浏览器中打开 Citrix XenServer 更新页面。
  3. 单击 Download（下载）。 如果这是您首次下载 XenServer 更新，则需要安装 Akamai 下载管理器。 出现提示时接受“下载管理器”安全证书，然后单击 Install（安装），以安装“下载管理器”。
  4. 单击 Download Now（立即下载）下载 XenCenterSetup.exe 文件。
  5. 通过浏览找到要保存新文件的文件夹，然后单击保存打开“下载管理器”并开始下载。
  6. 退出当前的 XenCenter 会话。
  7. 下载完毕（下载管理器中显示的进度为 100%）时，请单击启动开始安装新版本的 XenCenter。
  8. XenCenter 安装完毕时，单击退出，以关闭下载管理器。


自动更新通知

可以将 XenCenter 配置为定期检查可用的 XenServer 和 XenCenter 更新及新产品版本。

配置自动更新通知：

  1. 在工具菜单上，单击选项，然后单击更新选项卡。
  2. 选择检查新版本 XenServer 使 XenCenter 定期检查新版本的 XenServer 并在有新版本时向您发出通知。
  3. 选择检查 XenServer 更新，使 XenCenter 定期检查可用的 XenServer 更新并在有更新时向您发出通知。
  4. 选择检查新 XenCenter 版本，使 XenCenter 定期检查可用的新版本 XenCenter 并在有新版本时向您发出通知。
  5. 单击确定保存所做的更改并关闭“选项”对话框。


疑难解答

主题

  • XenCenter 警报
  • XenCenter 事件日志
  • 创建服务器状态报告
  • 解决 SR 连接问题
  • VM 恢复模式


XenCenter 警报

您可以在 XenCenter 中查看不同类型的警报，方法是单击通知，然后单击警报。

警报视图会显示各种不同类型的警报，例如：

  • 性能警报。 当托管服务器、虚拟机或存储库上的 CPU、内存使用率、网络、存储吞吐量或 VM 磁盘活动超出指定阈值时，可能会生成性能警报。 有关配置性能警报的信息，请参阅配置性能警报。
  • 高可用性状态警报。 对于池高可用性状态的变化（例如当池出现过度使用情况时），可能会生成警报。
  • 许可证过期警报。 当托管服务器上的 XenServer 许可证接近到期日期或者已经过期时，将生成警报。

使用警报

XenCenter 具有强大的过滤功能。 您可以过滤“警报”选项卡上显示的警报，以便只查看来自特定池或服务器的警报，或者只查看特定时间段内生成的警报。 对于某些警报，可以快速解决导致生成该警报的问题。 下表列出了警报视图中可用的多个选项。

选项 | 说明
按严重程度过滤 按严重程度过滤警报

默认情况下，“警报”选项卡中会显示所有严重级别的警报。 要查看特定严重程度的警报，可单击按严重程度过滤，然后从列表中取消选择其他严重级别。 单击全部显示可查看所有警报。

按位置过滤 按引发警报的源过滤警报

默认情况下，将显示连接到 XenCenter 的所有主机的警报。 要停止显示特定主机的警报，请单击下拉列表，然后取消选择该主机。 再次单击该主机可切换您的选择。

按日期过滤 根据发生时间过滤警报

默认情况下，将显示当前 XenCenter 会话的所有警报。 单击下拉列表，然后从列表中选择一个日期范围。 另外，单击自定义可通过指定开始和结束日期/时间来定义您自己的日期范围。 单击全部显示可查看所有警报。

刷新 | 如果打开“警报”选项卡时有新警报生成，那么这些警报可能不会出现在列表中。 单击刷新可查看更新后的列表。
全部导出 | 将警报导出为逗号分隔 (.csv) 格式的文件，以便在外部应用程序中进行查看和分析。
全部解除 从警报视图中删除警报

要解除或删除所有警报，请单击全部解除。 要解除一组特定警报，请从列表中选择所需警报，然后单击消除选定对象。

操作 允许您对显示的警报执行特定操作。 “操作”下拉列表将显示可用于所选警报的所有操作。

从列表中选择一个警报，然后单击与该警报相关的操作项目进行解决。 例如，单击：

  • 警报设置可管理主机 CPU、内存使用率、网络活动和存储吞吐量的警报。 此操作将打开主机属性对话框。
  • 复制可将有关该警报的信息复制到剪贴板。
  • 解除可解除该警报。
  • 转至 Web 页面可在 Web 浏览器中打开更新页面。
  • 高可用性设置可管理高可用性警报。 此操作将打开配置高可用性对话框。
  • 帮助可打开与警报有关的帮助主题。
  • 许可证管理器可管理您的许可证。 此操作将打开许可证管理器对话框。
  • 查看日志文件可打开日志的存储目录。

通过电子邮件接收警报通知

可以将 XenCenter 配置为在针对池中的任何服务器和虚拟机或者针对独立的服务器及其虚拟机生成警报时发送电子邮件通知。

如果打开电子邮件通知功能，在生成优先级为 3 或更高的警报时，系统将向您发送电子邮件通知。 （您可以通过 XenServer xe 命令行接口 (CLI) 为不同类型的警报分配优先级。有关详细信息，请参阅《XenServer 管理员指南》。）

打开电子邮件通知

  1. 在基础结构视图中选择一个池或独立的服务器。
  2. 单击常规选项卡，然后单击属性。
  3. 在属性对话框中单击电子邮件选项选项卡。
  4. 选中发送电子邮件警报通知复选框，然后键入详细的交付地址信息。
    注: 您应输入不需要身份验证的 SMTP 服务器的详细信息。 通过需要身份验证的 SMTP 服务器发送的电子邮件将不会进行发送。 有关使用需要身份验证的 SMTP 服务器来接收电子邮件通知的说明，请参阅《XenServer 管理员指南》。
  5. 单击确定保存所做的更改并关闭对话框。


XenCenter 事件日志

XenCenter 维护一个可帮助进行故障排除的事件日志。 依次单击通知和事件可以查看当前 XenCenter 会话中事件的摘要。 有关 XenCenter 事件的更详细的永久记录存储在配置文件文件夹下的日志文件中，可以使用此文件对 XenCenter 会话期间可能出现的任何问题进行故障排除。

查看当前会话中的事件

要查看当前 XenCenter 会话的事件摘要，请依次单击通知和事件。

查看 XenCenter 事件日志文件

使用 XenCenter 时，将生成永久性的 XenCenter 日志文件 (syslog)。 此文件包括使用 XenCenter 时执行的所有操作以及出现的所有错误的完整描述， 还包含事件的信息性记录，以便提供在 XenCenter 中和托管资源上发生的各种操作的审核追踪。

XenCenter 日志文件存储在 %appdata%\Citrix\XenCenter 中。

在诊断 XenServer 环境中的问题时，XenCenter 的日志输出是非常有价值的信息。 要快速找到 XenCenter 日志文件（例如，当您需要用电子邮件将其发送给技术支持组织时），请在 XenCenter 菜单中单击帮助，然后单击查看 XenCenter 日志文件。

处理当前会话中的事件

使用 XenCenter 可以过滤当前会话中的事件并执行特定操作来处理这些事件。 下表列出了事件视图中提供的各个选项。

选项 说明
按状态过滤 按事件的进度过滤事件

默认情况下会显示当前 XenCenter 会话的所有事件。 从下拉列表选择某个特定状态可切换选择。

按位置过滤 按事件的来源过滤事件

默认情况下会显示连接到 XenCenter 的所有主机的事件。 要停止显示特定主机的事件，请单击下拉列表，然后取消选择该主机。 再次单击该主机可切换选择。

按日期过滤 根据事件发生的时间过滤事件

默认情况下会显示当前 XenCenter 会话的所有事件。 单击下拉列表，然后从列表中选择一个日期范围。 另外，单击自定义可通过指定开始和结束日期/时间来定义您自己的日期范围。

全部解除 从“事件”视图中删除事件

要解除或删除当前所有的事件，请单击全部解除。 要解除特定的一组事件，请从列表中选择所需事件，然后单击消除选定对象。

操作 允许您对显示的事件执行特定操作
从列表中选择一个事件，然后单击：
  • 解除可解除该事件
  • 转至可导航到事件所源于的主机。 选择此操作项会将您定位到“基础结构”视图
  • 复制可将有关该事件的信息复制到剪贴板


创建服务器状态报告

通过服务器状态报告向导，可以方便地收集所安装的特定 XenServer 的综合快照并将其打包，以进行故障排除。 通过其中的选项，可以包括或排除所选服务器的一系列不同配置文件和日志文件。

服务器状态报告可以打包为一个 zip 文件，该文件可以存储和/或通过电子邮件发送。 所生成的报告大小因选择包括的项目而异。 该 zip 文件包括：

  • 每台服务器对应的一个文件夹（其中包含您在向导中选择的报告类型）
  • XenCenter 日志文件

生成服务器状态报告

在工具菜单上，单击服务器状态报告并按服务器状态报告向导中的步骤操作：

  1. 选择服务器。 选择要收集报告数据的服务器。

    将列出所有可用的托管服务器。 如果某个服务器未列出，您可以通过单击添加新服务器将该服务器添加到列表中。

  2. 选择报告内容。 选择要包括在报告中的数据，然后单击下一步。
  3. 编译报告。 此页面显示报告的编译进度并报告所有的数据收集问题。 在报告编译完成后，单击下一步。
  4. 报告目标位置。 通过浏览找到将保存报告的文件夹，然后单击完成，以将报告文件保存到指定文件夹中并关闭该向导。


解决 SR 连接问题

为了将存储库提供给服务器使用，必须在服务器与 SR 之间建立连接。 此连接在软件中由物理块设备 (PBD) 提供。PBD 可存储用于将给定 SR 映射到服务器的信息。 必须将 PBD 连接到或插入服务器，SR 才能使用。 如果因任何原因将 PBD 拔出，SR 都将无法再供服务器使用，资源窗格中将出现一个表示存储已断开的图标 [image] 。

您可以使用修复存储库工具诊断并解决一些常见的 SR 连接问题。 在资源窗格中，选择存储资源，单击鼠标右键，然后在快捷菜单上单击修复存储库。

或者，在存储菜单上，单击修复存储库。

此时将列出可用的存储库，您可以看到这些存储库的状态。

  • 已连接。 SR 与服务器之间的连接正常，由 SR 提供的存储当前可用。
  • 已拔出。 PBD 当前已拔出，因此存储不可用。
  • 缺少连接。 找不到 PBD，因此存储不可用。

单击修复，使 XenCenter 尝试修复存储。 进度和结果将显示在修复存储库对话框中。


VM 恢复模式

如果半虚拟化 Linux VM 出现严重问题，您可以尝试在恢复模式下启动它。 该过程会暂时启用 HVM 模式，并将 CD 驱动器设置为首先引导，便于您引导拯救 CD 或拯救 PXE，然后调查问题的原因。

要在恢复模式下启动 VM，请执行以下操作：

  • 选择要在恢复模式下启动的 VM。
  • 从主菜单中，选择 VM > 启动/关闭 > 在恢复模式下启动。
    注: 您应该连接常规操作系统拯救 CD，从其引导 VM，然后从拯救 CD 修复 VM。

要了解有关 HVM 和半虚拟化模式的详细信息，请参阅关于 VM 和模板。