ワークロードバランスについて

ワークロードバランスは、リソースプール内の最適なサーバーに仮想マシンを移行することでプールのワークロードを分散させるためのXenServerの機能で、ワークロードバランス仮想アプライアンスにより提供されます。ワークロードバランスでは、以下のようにワークロードが最適化されます。

  • 仮想マシンのワークロードをリソースプール内のサーバー間で分散させる。
  • 仮想マシンを起動するときに、最適なサーバーを決定する。
  • シャットダウンした仮想マシンを起動するときに、最適なサーバーを決定する。
  • サーバーを保守モードにするときに、そのサーバー上の各仮想マシンの移行先として最適なサーバーを決定する。

ワークロードバランス機能は、Citrix XenServer Enterprise Editionおよびそれ以上のエディションで使用可能です。XenServerの各エディションについて詳しくは、ここを参照してください。

ワークロードバランスによるワークロードの最適化や集約化は、自動的に実行されるようにしたり、管理者が選択的に実行できるようにしたりできます。また、特定のスケジュールに従ってサーバーの電源が自動的に切断されるように設定することもできます（夜間の使用電力を抑える場合など）。

ワークロードバランスは、プール内の仮想マシンの負荷を評価し、いずれかのしきい値に達した場合にそのサーバー上の仮想マシンを同一プール内のほかのサーバーに移行します。

ワークロードバランスでは、最適化の対象としてパフォーマンスまたは密度を選択できます。これらの最適化モードは、特定のスケジュールに従って自動的に切り替えることもできます。また、各リソース負荷の測定基準（CPU、ネットワーク、メモリ、およびディスク）のしきい値および重要度を調節して、環境に適した最適化が行われるように設定できます。

リソースプールの能力を評価するには、ワークロードバランスの履歴レポートを参照して、リソースプールやホストのヘルス状態、最適化や仮想マシンのパフォーマンス、および仮想マシンの移行履歴を確認します。

関連項目


ワークロードバランス：はじめに

ワークロードバランス機能を使用するには、ワークロードバランス仮想アプライアンスをダウンロードして、以下の手順に従ってセットアップします。

  1. MyCitrix.comからワークロードバランス仮想アプライアンスパッケージをダウンロードして、XenCenterを使ってインポートします。
  2. インポートした仮想アプライアンスの［コンソール］タブに表示されるウィザードの手順に従って、ワークロードバランス仮想アプライアンスを設定します。
  3. 「ワークロードバランスに接続する」の説明に従って、リソースプールをワークロードバランス仮想アプライアンスに接続します。

    これらの手順について詳しくは、『ワークロードバランスクイックスタート』を参照してください。

    ワークロードバランス機能は、Citrix XenServer Enterprise Editionおよびそれ以上のエディションで使用可能です。XenServerの各エディションについて詳しくは、ここを参照してください。


ワークロードバランスの基本概念

ワークロードバランスでは、仮想マシンと物理マシンのリソースパフォーマンスに関するデータが収集されます。これらのデータと管理者による設定に基づいて、リソースプールを最適化するために仮想マシンをどのサーバーに再配置（移行）するかが計算され、推奨項目として提示されます。ワークロードバランスでは、パフォーマンスデータが内部データベースに格納されます。このため、ワークロードバランスの動作期間が長くなると、より正確な推奨項目が提供されるようになります。

ワークロードバランスによる推奨項目では、リソースプールの稼働効率（パフォーマンスまたは密度）を最適化するために、仮想マシンのワークロードをプール内でどのように再配置するかが示されます。ワークロードバランスでは、以下のいずれかの最適化モードを選択できます。

  • パフォーマンス：サーバー上の物理リソース（CPU、メモリ、ネットワーク、およびディスク）の使用効率を最適化します。ワークロードバランスでパフォーマンスの最適化を選択すると、各仮想マシンが使用できるリソースの量が最大になるように再配置の推奨項目が作成されます。
  • 密度：サーバー上で実行される仮想マシンの数を最適化します。ワークロードバランスで密度の最適化を選択すると、仮想マシンの計算能力を維持したまま、1台のサーバー上により多くの仮想マシンを配置して、リソースプール内で稼働するサーバーの数を最小化できます。

管理者は、最適化モード（パフォーマンスまたは密度）、電源管理機能、自動処理機能、測定基準の重要度、およびパフォーマンスしきい値を設定してワークロードバランスの動作を制御できます。

ワークロードバランスにより、高可用性機能の動作が影響を受けることはありません。両機能の設定が競合する場合は、常に高可用性機能の設定が優先されます。


ワークロードバランスに接続する

ワークロードバランス仮想アプライアンスをインポートして、ウィザードの手順に従って設定したら、リソースプールをその仮想アプライアンスに接続します。これを行うには、XenCenterの［WLBサーバーへの接続］ダイアログボックスまたはXEコマンドを使用します。

要件

XenCenterでワークロードバランス仮想アプライアンスに接続するには、以下の情報が必要です。

  • ワークロードバランス仮想アプライアンスのIPアドレスまたは完全修飾ドメイン名（FQDN）、およびポート。
  • ワークロードバランスで監視するリソースプール（プールマスタ）の資格情報。
  • ワークロードバランス仮想アプライアンス上で作成したアカウントの情報。このアカウントは、「ワークロードバランスユーザーアカウント」と呼ばれます。このアカウントを使用して、XenServerがワークロードバランスと通信します（このアカウントは、ワークロードバランス仮想アプライアンスの設定時に作成します）。

［WLBサーバーへの接続］ダイアログボックスでワークロードバランス仮想アプライアンスのFQDNを指定する場合は、事前に仮想アプライアンスのホスト名をDNSに追加しておく必要があります。信頼された機関からの証明書を使用する場合は、有効期限のないFQDNまたはIPアドレスを使用してください。

ワークロードバランスに接続した直後では、デフォルトのしきい値および設定に基づいてワークロードが最適化されます。自動最適化モード、電源管理、および自動処理などの自動化機能は、デフォルトでは無効になっています。

重要：ワークロードバランスをしばらく使用して意図したとおりに推奨項目が生成されない場合は、パフォーマンスしきい値の設定を再評価することを強くお勧めします。「パフォーマンスしきい値設定の評価」を参照してください。運用環境に合ったしきい値を設定することで、より適切な推奨項目が作成されるようになります。

ワークロードバランス仮想アプライアンスに接続するには

  1. XenCenterのリソースペインで、リソースプールを選択します。
  2. プロパティペインの［WLB］タブをクリックします。
  3. ［WLB］タブの［設定］をクリックします。

    4. ［WLBサーバーへの接続］ダイアログボックスが開きます。

  4. ［サーバーのアドレス］セクションで、以下の情報を入力します。
    • ［アドレス］ボックスに、ワークロードバランスサーバーのIPアドレスまたはFQDNを入力します。FQDNとは、「WLB-appliance-computername.yourdomain.net」などのアドレスを指します。
    • ［ポート］ボックスにポート番号を入力します。このポートを使用して、XenServerがワークロードバランスと通信します

      デフォルトでは、XenServerはワークロードバランスサーバー（この場合はWeb Service Hostサービス）にポート8012で接続します。ワークロードバランス仮想アプライアンスの設定時にポートを変更した場合は、［ポート］ボックスにそのポート番号を入力します。

      重要：ワークロードバランス仮想アプライアンスの設定時にポート番号を変更していない場合は、ここで変更しないでください。［WLBサーバーへの接続］ダイアログボックスで指定するポート番号は、仮想アプライアンスの設定時に指定したもの（およびファイアウォールで指定されたもの）と一致する必要があります。

  5. ［WLBサーバーの資格情報］で、ユーザー名（wlbuserなど）とパスワードを入力します。これらの情報は、XenServerがワークロードバランス仮想アプライアンスに接続するときに使用されます。

    これらの資格情報は、ワークロードバランス仮想アプライアンスの設定時に作成したものである必要があります。デフォルトのユーザー名は、wlbuserです。

  6. ［XenServerの資格情報］セクションで、手順1.で選択したプールにアクセスするためのユーザー名とパスワードを入力します。これらの情報は、ワークロードバランス仮想アプライアンスがリソースプールの各サーバーに接続するときに使用されます。

    ログイン中のXenServerと同じ資格情報を使用するには、［現在のXenCenterの資格情報を使用する］チェックボックスをオンにします。役割ベースのアクセス制御（RBAC）で役割を割り当てたアカウントを使用する場合は、そのアカウントにワークロードバランス機能の管理許可が付与されていることを確認してください。詳しくは、「RBAC役割の定義とアクセス権」を参照してください。

  7. ワークロードバランス仮想アプライアンスに接続したら、必要に応じてパフォーマンスしきい値や特定のリソースの優先度を変更できます。詳しくは、「ワークロードバランス設定の変更」を参照してください。


ワークロードバランスの基本タスク

ワークロードバランスは、電源管理、最適化モードのスケジュール化、レポート生成など、XenServer環境のワークロードを最適化するための多くの機能を持つ、強力なXenServerコンポーネントです。管理者は、各リソース負荷の測定基準を微調整して、適切な最適化推奨項目が生成されるようにワークロードバランス機能を設定できます。

ワークロードバランスが有効なリソースプールでは、管理者は日常的に以下の2つの基本タスクを実行することになります。

  • 仮想マシンの起動に最適なサーバーを決定する。
  • ワークロードバランスにより提示された推奨項目を適用する

ワークロードバランスを使用するために必要なワークロードバランス仮想アプライアンスの入手および設定について詳しくは、『ワークロードバランスクイックスタート』を参照してください。

仮想マシンの起動に最適なサーバーを決定する

「仮想マシンの初期配置、移行、および再開に適したサーバーの選択」も参照してください。

ワークロードバランスが有効なリソースプールでは、シャットダウンまたは一時停止状態の仮想マシンを起動するとき、または仮想マシンを移行するときに、最適なサーバーが推奨項目として示されます。この機能は、XenDesktop環境でも有用です。

ワークロードバランスの推奨項目を適用する

「最適化推奨項目の適用」も参照してください。

ワークロードバランスをしばらく使用すると、環境を最適化するための推奨項目が生成されるようになります。たとえば、サーバー上の仮想マシン密度を最適化するようにワークロードバランスを設定すると、実行されている仮想マシンをより少ない数のサーバー上に集約するための推奨項目が生成されます。自動モードを有効にしていない場合、生成された推奨項目を適用するかどうかを管理者が選択できます。

これらの基本タスクについては、このヘルプの該当トピックで詳しく説明されています。これらのタスクに加えて、環境のワークロードに関するレポート生成も頻繁に使用される機能です。この機能については、「ワークロードバランスレポートの生成と管理」を参照してください。

重要：ワークロードバランスをしばらく使用して意図したとおりに推奨項目が生成されない場合は、パフォーマンスしきい値の設定を再評価することを強くお勧めします。方法については、『ワークロードバランス管理者ガイド』を参照してください。運用環境に合ったしきい値を設定することで、より適切な最適化推奨項目が作成されるようになります。


仮想マシンの初期配置、移行、および再開に適したサーバーの選択

ワークロードバランスが有効なリソースプールでは、オフライン状態の仮想マシンを再起動するときに、推奨起動サーバーとして最適な物理サーバーがXenCenterにより提示されます。推奨起動サーバーは、星の数で示されます。

仮想マシンの推奨起動サーバーとして、host17が星の数で示されています。サーバーhost16には星が表示されておらず、仮想マシンの起動サーバーとして推奨されていません。ただし、このサーバーは選択可能なので、必要に応じて仮想マシンを起動することができます。host18には十分なメモリがないため、選択できない状態になっています。

仮想マシンの再配置

ワークロードバランスが有効なリソースプールでは、シャットダウンまたは一時停止状態の仮想マシンを起動するとき、または仮想マシンを移行するときに、最適なサーバーをXenCenterで確認できます。

この機能では、推奨ホストの評価が星の数で示されます。ホスト名の横に白抜きの星（☆）が5つ表示される場合は、仮想マシンのホストとして最も不適切であることを意味します。仮想マシンの起動または移行先のサーバーとして使用できないサーバーの名前はメニューで淡色表示され、選択できません。

通常、ワークロードバランスで推奨されたサーバー上で仮想マシンを起動すると、より効率的に推奨項目が生成され、不要な推奨項目が生成されなくなります。

推奨起動サーバーとは

推奨起動サーバーとは、ワークロードのホストとして最適な物理サーバーを指します。ワークロードバランスは、以下の点を考慮して推奨起動サーバーを決定します。

  • プール内の各サーバーで使用可能なリソース量。最適化モードとしてパフォーマンスの最大化が選択されている場合、すべての仮想マシンが良好なパフォーマンスで動作するように、各サーバー上にバランス良く仮想マシンを配置しようとします。密度の最大化が選択されている場合は、仮想マシンのリソースを維持したまま、サーバー上により多くの仮想マシンを配置しようとします。
  • プールで選択されている最適化モード（パフォーマンスの最大化または密度の最大化）。パフォーマンスの最大化が選択されている場合、その仮想マシンが必要とするリソースの負荷が最も低いサーバーにその仮想マシンを配置しようとします。密度の最大化が選択されている場合は、既に多くの仮想マシンをホストしているサーバーに仮想マシンを配置して、仮想マシンの実行サーバーの数を少なくしようとします。
  • その仮想マシンが必要とするリソースの量。ワークロードバランスは、収集した仮想マシンの測定値を使用して、その仮想マシンが必要とするリソースの種類に応じて推奨起動サーバーを決定します。たとえば、メモリリソースを必要とする仮想マシンについては、使用可能なCPUリソース量よりも空きメモリ量を優先して起動サーバーを決定します。ただし、推奨起動サーバーの決定は、その仮想マシンを現在実行しているサーバーでリソース負荷が高いことが検出された場合にのみ行われます。

仮想マシンを最適なサーバーで起動するには

  1. XenCenterのリソースペインで、起動する仮想マシンを選択します。
  2. ［VM］メニューの［起動サーバー］を選択し、以下のいずれかを選択します。
    • 最適なサーバー：選択した仮想マシンで要求されるリソースを持つ、ホストとして最も適したサーバーです。ワークロードバランスでは、パフォーマンス測定値の履歴レコードと選択されている最適化モードに基づいて最適なサーバーが決定されます。最適なサーバーの名前には、最も多くの星が表示されます。
    • ［最適なサーバー］の下に表示されるサーバー：5つの星が表示されるサーバーは最も推奨されるサーバー（最適なサーバー）を示し、5つの白抜きの星が表示されるサーバーは推奨されないサーバーを示します。

仮想マシンを最適なサーバーで再開するには

  1. XenCenterのリソースペインで、再開する仮想マシンを選択します。
  2. ［VM］メニューの［再開サーバー］を選択し、以下のいずれかを選択します。
    • 最適なサーバー：選択した仮想マシンで要求されるリソースを持つ、ホストとして最も適したサーバーです。ワークロードバランスでは、パフォーマンス測定値の履歴レコードと選択されている最適化モードに基づいて最適なサーバーが決定されます。最適なサーバーの名前には、最も多くの星が表示されます。
    • ［最適なサーバー］の下に表示されるサーバー：5つの星が表示されるサーバーは最も推奨されるサーバー（最適なサーバー）を示し、5つの白抜きの星が表示されるサーバーは推奨されないサーバーを示します。


最適化推奨項目の適用

ワークロードバランスでは、リソースプールを最適化するために仮想マシンをどのように再配置（移行）すべきであるかというアドバイスが推奨項目として生成されます。この推奨項目は、XenCenterの［WLB］タブに表示されます。

この図は、［WLB］タブに表示される推奨項目を示しています。［理由］列には、その推奨項目の目的が示されます。［操作］列には、最適化を達成するために推奨される操作の内容が示されます。この場合、仮想マシンHA-prot-VM-7およびサーバーhost17.domain4.bedford4.ctx4に対する推奨項目が表示されています。

最適化推奨項目の基本

ワークロードバランスでは、以下の条件に基づいて推奨項目が生成されます。

  • 管理者が設定する最適化モード（「最適化モードの変更」を参照）。
  • 物理サーバー上のCPU、メモリ、ネットワーク、およびディスクについて収集されたパフォーマンス測定値。
  • リソースプール内でのサーバーの役割。プールマスタ上にワークロードを配置する推奨項目は、ほかのサーバー上への配置が不可能な場合のみ生成されます（同様に、最適化モードとして密度の最大化が選択されているプールでは、仮想マシンの移行先としてプールマスタが選択されるのは最後になります）。

最適化推奨項目では、再配置すべき仮想マシン、その仮想マシンを実行しているホスト、および推奨される新しいホストが示されます。また、仮想マシンの再配置が推奨される理由（CPU使用率の場合は「CPU」など）も示されます。

推奨項目を適用すると、その内容に基づいてすべての仮想マシンが自動的に移行されます。

ヒント：リソースプールに設定されている最適化モードを確認するには、XenCenterでそのリソースプールを選択して、［WLB］タブの［設定］セクションを参照します。

最適化推奨項目を適用するには

  1. リソースペインでリソースプールを選択して、［WLB］タブをクリックします。選択したリソースプールの最適化が必要な場合は、［最適化の推奨項目］に内容が表示されます。
  2. 推奨項目を適用するには、［すべて実行］をクリックします。［最適化の推奨項目］の推奨項目に基づいて、すべての仮想マシンが移行されます。

    ［すべて実行］をクリックしたら、［ログ］タブで仮想マシンの移行状況を確認できます。

高可用性環境でのワークロードバランス

ワークロードバランス機能とXenServer高可用性機能が有効なリソースプールでは、これらの2つの機能が相互にどのように影響するかを理解する必要があります。ワークロードバランスは、高可用性機能と競合しないように設計されています。ワークロードバランスで生成される推奨項目と高可用性設定が競合する場合は、常に高可用性機能の設定が優先されます。つまり、以下のようになります。

  • ［高可用性の設定］ダイアログボックスの［許可する障害数］ボックスの値を超える数のサーバーは、ワークロードバランスにより自動的に電源が切断されることはありません。
    • ただし、電源を切断することが推奨項目として提示される場合があります。たとえば、高可用性で許可する障害数として1が設定されている場合に、ワークロードバランスにより2台のサーバーのシャットダウンが推奨されることがあります。この推奨項目を適用しようとすると、「高可用性が保証されなくなる」という内容のエラーメッセージが表示されます。
    • 自動モードでワークロードバランスが動作する場合は、電源管理を有効にしても、高可用性で許可する障害数を超える数の推奨項目は無視されます。この場合、ワークロードバランスのログファイルに「高可用性が有効なため電源管理推奨項目を適用できない」という内容のメッセージが記録されます。


ワークロードバランスレポート

ここでは、ワークロードバランスの履歴レポートと、これらのレポートに関する追加情報の参照先について説明します。

ワークロードバランスレポートを生成するには、ワークロードバランス仮想アプライアンスをインポートして、リソースプールをその仮想アプライアンスに接続しておく必要があります。

はじめに

ワークロードバランスでは、物理サーバー、リソースプール、および仮想マシンに関する、以下の2種類のレポートが作成されます。

  • 日別データを表示する履歴レポート
  • ロールアップスタイルのレポート

ワークロードバランスでは、仮想マシンの移行回数などを記録した監査用のレポートも作成できます。

レポートの種類

ワークロードバランスでは、リソースプール、サーバー、および仮想マシンに関するいくつかの種類のレポートを生成できます。詳しくは、「ワークロードバランスレポートの種類について」を参照してください。

レポートの生成

ワークロードバランスでは、レポートを生成して、PDFやスプレッドシートとしてエクスポートしたり印刷したりできます。詳しくは、「ワークロードバランスレポートの生成と管理」を参照してください。


ワークロードバランスレポートの使用

ワークロードバランスレポートを使用すると、リソースプールの能力を評価したり、仮想マシンのヘルス状態を確認したり、設定したパフォーマンスしきい値の効果を評価したりできます。

パフォーマンスしきい値設定の評価

プールヘルスレポートを使用して、設定したしきい値の効果を評価できます。ワークロードバランスでは各パフォーマンスしきい値にデフォルト値が設定されますが、環境によっては調整が必要な場合があります。これを行わないと、ワークロードバランスで適切な推奨項目が生成されません。

管理者による変更に対するトラブルシューティング

管理者による変更により何らかの問題が発生した場合は、プール監査記録レポートを参照して変更担当者（変更した管理者のユーザーアカウント）や変更内容を確認します。


ワークロードバランスレポートの生成と管理

ここでは、ワークロードバランス機能のレポートの生成、サブスクリプション、表示、印刷、およびエクスポートなど、基本的な使用方法について説明します。

ワークロードバランスレポートを生成するには

  1. XenCenterのリソースペインで、リソースプールを選択します。
  2. ［プール］メニューの［ワークロードレポートを表示］を選択します。

    ヒント：［WLB］タブの［レポート］をクリックすることでも［ワークロードレポート］ダイアログボックスを開くことができます。

  3. ［ワークロードレポート］ダイアログボックスの［レポート］ペインの一覧で、生成するレポートの種類を選択します。
  4. ［開始日］および［終了日］を使用して、レポート期間を指定します。選択したレポートの種類によっては、［ホスト］ボックスの一覧でレポート対象のサーバーを選択します。
  5. ［レポートの実行］をクリックします。ワークロードバランスレポートが生成されます。

ワークロードバランスレポートを使用するには

レポートを生成したら、ツールバーのボタンを使用してさまざまなタスクを実行できます。ツールバーのボタンの名前は、マウスポインタをそのボタンに合わせると表示されます。

レポートツールバーのボタン
ドキュメントマップ：サイズの大きなレポートを表示するときに便利なドキュメントマップが開きます。
ページ操作：レポートの次のページや前のページ、または特定のページを表示できます。
元のレポートに戻る：ドリルスルーレポートから元のレポートに戻ります。注：このボタンは、プールヘルス履歴レポートなどのドリルスルーレポートでのみ使用可能になります。
生成停止：レポートの生成処理をキャンセルします。
印刷：レポートを印刷します。ページ数や部数など、標準的な印刷オプションを指定できます。
印刷レイアウト：レポートの印刷プレビューを表示します。印刷プレビューを閉じるには、再度［印刷レイアウト］をクリックします。
ページ設定：用紙サイズ、印刷の向き、余白などの印刷オプションを指定できます。
エクスポート：Acrobat（PDF）形式またはExcel（XLS）形式のファイルとしてレポートをエクスポートします。
検索：仮想マシンの名前など、特定の文字列を検索できます。

ワークロードバランスレポートを印刷するには

レポートを印刷するには、まずそのレポートを実行します。

  1. （オプション） [image] ［印刷レイアウト］をクリックして、レポートの印刷プレビューを確認します。
  2. （オプション） [image] ［ページ設定］をクリックして、用紙サイズ、印刷の向き、余白などの印刷オプションを指定します。
  3. ［印刷］をクリックします。

ワークロードバランスレポートをエクスポートするには

ワークロードバランスレポートは、Acrobat（PDF）形式またはExcel（XLS）形式のファイルとしてエクスポートできます。

レポートを生成したら、 [image] ［エクスポート］をクリックし、以下のいずれかのオプションを選択します。

  • Excel
  • Acrobat（PDF）ファイル

注：レポートをエクスポートする場合のデータ量は、エクスポート形式により異なります。Excel形式にエクスポートするレポートには、「ドリルダウン」データーを含め、すべてのデータが含まれます。XenCenterで表示するレポートおよびPDF形式にエクスポートするレポートには、レポート生成時に選択したデータしか含まれません。


ワークロードバランスレポートの種類について

ここでは、ワークロードバランスの各レポートについて説明します。

チャージバック使用解析

このレポートでは、組織内の特定の部署で使用されたリソース（物理サーバーなど）の量を確認できます。具体的には、リソースプール内のすべての仮想マシンのアベイラビリティやリソース使用などの情報が含まれます。このレポートには仮想マシンのアベイラビリティ（「アップタイム」）が含まれるため、SLA（Service Level Agreement：サービス品質保証契約）に役立てることができます。

このレポートを使用して、課金用のシンプルなチャージバックソリューションを実装できます。特定リソースの使用代金を顧客に課金するには、レポートを生成してExcelデータとして保存し、そのスプレッドシートをカスタマイズしたり、課金システムにインポートしたりできます。

組織内の部署または外部の顧客に仮想マシンの使用料を請求する場合は、仮想マシンの名前に部署や顧客の名前を含めることを検討します。これにより、チャージバック使用解析レポートが読みやすくなります。

このレポートのリソース関連のデータは、個々の仮想マシンへの物理リソースの割り当てにより異なる場合があります。

同様に、XenServerではメモリ割り当てを固定したり動的メモリ制御（DMC）機能で自動化したりできるため、メモリの平均データはそのときに仮想マシンに割り当てられているメモリ量により異なります。

チャージバック使用解析レポートには、以下のデータ列が含まれます。

  • VM名：仮想マシンの名前です。
  • VMアップタイム：仮想マシンの実行時間（XenCenterで緑色のアイコンで表示される時間）を分単位で示したものです。
  • VCPU割り当て：その仮想マシンに割り当てられている仮想CPUの数です。各仮想CPUには、そのサーバーの物理CPUから均等に割り当てられます。たとえば、2つの物理CPUを持つサーバーで合計8つの仮想CPUを仮想マシンに割り当てた場合、この列の「1」はそのサーバーの全体的な処理能力の2/16を示します。
  • 最小CPU使用率（%）：レポート期間内に記録された仮想CPU使用率の最小値です。この値はその仮想マシンの仮想CPUの能力に対するパーセンテージで示され、仮想CPUの能力はその仮想マシンに割り当てられている仮想CPUの数に基づきます。たとえば、仮想マシンの作成時に1つの仮想CPUを割り当てた場合、その仮想CPU使用率の最小値が（たとえその継続時間が1秒間であっても）XenServerにより記録され、最小CPU使用率として示されます。仮想マシンに2つの仮想CPUを割り当てた場合は、それらの合計能力に対する最小使用率が示されます。

    この最小CPU使用率は、仮想CPUが処理した最小ワークロードを示します。たとえば、2.4GHzの物理CPUを持つサーバーで8つの仮想マシンをホストする場合、1つの仮想マシンに1つのCPUを割り当てると、2.4GHzの1/8、つまり0.3GHz（300MHz）の能力が割り当てられます。ここで最小CPU使用率が20%であった場合、この仮想マシンでの物理サーバーCPUの最小使用量が60MHzであったことを示します。

  • 最大CPU使用率（%）：レポート期間内に記録された仮想CPU使用率の最大値です。この値はその仮想マシンの仮想CPUの能力に対するパーセンテージで示され、仮想CPUの能力はその仮想マシンに割り当てられている仮想CPUの数に基づきます。たとえば、仮想マシンの作成時に1つの仮想CPUを割り当てた場合、その仮想CPU使用率の最大値がXenServerにより記録され、最大CPU使用率として示されます。仮想マシンに2つの仮想CPUを割り当てた場合は、それらの合計能力に対する最大使用率が示されます。
  • 平均CPU使用率（%）：レポート期間内に記録された仮想CPU使用率の平均値です。この値はその仮想マシンの仮想CPUの能力に対するパーセンテージで示され、仮想CPUの能力はその仮想マシンに割り当てられている仮想CPUの数に基づきます。仮想マシンに2つの仮想CPUを割り当てた場合は、それらの合計能力に対する平均使用率が示されます。
  • ストレージ割り当て合計（GB）：レポート期間内にその仮想マシンに割り当てられていたディスク容量です。通常、この値は仮想マシンの作成時に割り当てたディスクのサイズを示します（作成後に変更していない場合）。
  • 仮想NIC割り当て：仮想マシンに割り当てられている仮想インターフェイス（VIF）の数です。
  • 現在の最小動的メモリ（MB）：
    • 固定メモリ割り当て：仮想マシンに特定のメモリ量（1024MBなど）を割り当てた場合、以下の列には同じ値が表示されます。現在の最小動的メモリ（MB）、現在の最大動的メモリ（MB）、現在のメモリ割り当て（MB）、および平均メモリ割り当て（MB）。
    • 動的メモリ割り当て：仮想マシンに動的メモリ範囲を割り当てて自動的に調整されるようにした場合（つまり動的メモリ制御を有効にした場合）は、その範囲の最小メモリ量がこの列に表示されます。たとえば、XenCenterの［メモリ設定］ダイアログボックスで［自動的に割り当てるメモリ範囲を指定する］オプションを選択し、最小メモリとして1024MB、最大メモリとして2048MBを指定した場合、［現在の最小動的メモリ（MB）］として「1024MB」が表示されます。
  • 現在の最大動的メモリ（MB）：
    • 動的メモリ割り当て：仮想マシンに動的メモリ範囲を割り当てて自動的に調整されるようにした場合は、その範囲の最大メモリ量がこの列に表示されます。たとえば、最小メモリとして1024MB、最大メモリとして2048MBを指定した場合、［現在の最大動的メモリ（MB）］として「2048MB」が表示されます。
    • 固定メモリ割り当て：仮想マシンに特定のメモリ量（1024MBなど）を割り当てた場合、以下の列には同じ値が表示されます。現在の最小動的メモリ（MB）、現在の最大動的メモリ（MB）、現在のメモリ割り当て（MB）、および平均メモリ割り当て（MB）。
  • 現在のメモリ割り当て（MB）：
    • 動的メモリ割り当て：動的メモリ制御を有効にした場合、レポート期間内に仮想マシンに割り当てられていたメモリ量が表示されます。
    • 固定メモリ割り当て：仮想マシンに特定のメモリ量（1024MBなど）を割り当てた場合、以下の列には同じ値が表示されます。現在の最小動的メモリ（MB）、現在の最大動的メモリ（MB）、現在のメモリ割り当て（MB）、および平均メモリ割り当て（MB）。

      注：仮想マシンのメモリ割り当てを変更した直後にこのレポートを実行した場合、この列には変更後の値が表示されます。

  • 平均メモリ割り当て（MB）：
    • 動的メモリ割り当て：動的メモリ制御を有効にした場合、レポート期間内に仮想マシンに割り当てられていたメモリ量の平均値が表示されます。
    • 固定メモリ割り当て：仮想マシンに特定のメモリ量（1024MBなど）を割り当てた場合、以下の列には同じ値が表示されます。現在の最小動的メモリ（MB）、現在の最大動的メモリ（MB）、現在のメモリ割り当て（MB）、および平均メモリ割り当て（MB）。

      注：仮想マシンのメモリ割り当てを変更した直後にこのレポートを実行した場合、この列の値に変更内容が反映されない場合があります。この列には、指定した期間での平均値が表示されます。

  • 平均ネットワーク読み取り（bps）：レポート期間内に仮想マシンが受信したデータ量（1秒あたりのビット数）の平均値です。
  • 平均ネットワーク書き込み（bps）：レポート期間内に仮想マシンが送信したデータ量（1秒あたりのビット数）の平均値です。
  • 平均ネットワーク使用（bps）：平均ネットワーク読み取りと平均ネットワーク書き込みの合計データ量（1秒あたりのビット数）です。たとえば、レポート期間内に仮想マシンが平均1,027bpsのデータを送信し、平均23,831bpsのデータを受信した場合、平均ネットワーク使用の値は24,858bpsになります。
  • ネットワーク使用合計（bps）：レポート期間内に行われたネットワーク読み取りおよび書き込みトランザクションの合計値です。

ホストヘルス履歴

このレポートでは、特定のサーバー上のリソース（CPU、メモリ、ネットワーク読み取り、およびネットワーク書き込み）のしきい値に対するパフォーマンスが示されます。

各しきい値は、色つきの線（赤、緑、黄色）で示されます。このレポートとプールヘルスレポートを使用して、特定サーバーのパフォーマンスがリソースプールのパフォーマンスにどう影響しているかを評価できます。パフォーマンスしきい値を変更する場合は、このレポートでサーバーのパフォーマンスを確認します。

リソース使用のデータは、日別または時間別の平均値として表示できます。時間別の平均値では、その日のピーク時刻を確認できます。

時間別のデータを表示するには、［ホストヘルス履歴］タイトルバーの下の［クリックして特定期間内の時間別レポートデータを表示します］をクリックします。

このレポートには、指定した期間の時間別平均値が表示されます。つまり、データポイントは、指定期間のすべての日の特定時刻の平均使用量に基づいています。たとえば、2009年5月1日から2009年5月15日までのレポートの場合、［平均CPU使用率］のデータポイントはこの15日間の午後12時のリソース使用の平均を示します。つまり、5月1日の午後12時のCPU使用率が82%、5月2日の午後12時が88%、残りの日の午後12時がすべて75%だった場合、午後12時の平均値として76.3%が表示されます。

注：ワークロードバランスでは、パフォーマンス測定値に急激な増加があっても平滑化されます。

プールの最適化パフォーマンス履歴

このレポートでは、最適化イベント（つまり管理者がリソースプールを最適化したとき）がリソースプールの平均リソース使用に対して示されます。このレポートに表示されるリソース使用は、CPU、メモリ、ネットワーク読み取り、およびネットワーク書き込みです。

点線は、指定した期間のプール内の平均リソース使用を示します。青いバーは、プールを最適化した日を示します。

このレポートを使用して、設定したワークロードバランスが意図したとおりに動作しているかどうかを評価できます。また、何が最適化イベントの原因になっているか（つまりワークロードバランスの推奨項目生成前のリソース使用）を確認できます。

このレポートには、その日の平均リソース使用が表示され、システムに高負荷がかかった場合などのピーク時のデータは表示されません。また、ワークロードバランスの推奨項目を適用しなかった場合のプールのパフォーマンスを確認することもできます。

通常、最適化イベントの後はリソース使用が低下または安定化しなければなりません。最適化してもリソース使用が改善しない場合は、しきい値の調整を検討します。また、リソースプール内の仮想マシンが多すぎないかどうか、指定した期間に仮想マシンの追加や削除がなかったかどうかを確認してください。

プール監査記録

このレポートには、XenServerの監査ログの内容が表示されます。この監査ログには、インポートやエクスポート、サーバーやプールのバックアップ、仮想マシンやサーバーのコンソールへのアクセスなどの操作が記録されます（許可されていない操作を実行しようとした場合も記録されます）。役割ベースのアクセス制御機能で各XenServer管理者に役割を割り当てた環境では、このレポートでより詳しい情報を取得することができます。監査ログ機能については、『ワークロードバランス管理者ガイド』を参照してください。

重要：監査ログレポートを実行するには、監査ログ機能を有効にする必要があります。デフォルトでは、ワークロードバランス仮想アプライアンスの監査ログ機能が常に有効になっています。ただし、この監査ログには特定のオブジェクトやアクションに対する一定量のデータしか記録されません。

このレポートに表示される内容は以下のとおりです。

  • 時間：ユーザーアクションの記録日時です。
  • イベントアクション：アクションの内容です。詳しくは、「監査記録でのイベント名」を参照してください。
  • ユーザー名：そのアクションを実行したときのセッションを作成した管理者のユーザーアカウントです。ユーザーIDが表示される場合もあります。
  • アクセス：その管理者に当該アクションの実行が許可されていたかどうかが示されます。
  • イベントオブジェクト：アクションの対象オブジェクト（仮想マシンなど）です。
  • オブジェクト名：対象オブジェクトの名前（仮想マシン名など）です。
  • 成功：アクションの実行結果（成功したかどうか）を示します。

プールヘルス

プールヘルスレポートには、リソースプールおよびそのサーバーでの時間およびリソースの使用率が表示されます。これらの情報は、限界しきい値、高しきい値、中しきい値、および低しきい値の平均パーセンテージで示されます。このレポートを使用して、設定したしきい値の効果を評価できます。

このレポートの内容は以下のとおりです。

  • ［中しきい値の平均］（青）は、最適化モードの設定にかかわらず、好ましいリソース使用を示します。同様に、円グラフの青い部分は、そのサーバーのリソース使用が良好だった期間を示します。
  • ［低しきい値の平均（%）］（緑）は、必ずしも好ましいリソース使用を示すとは限りません。低しきい値のリソース使用が好ましいかどうかは、最適化モードの設定によって異なります。たとえば、最適化モードとして［密度を最大化］を選択したリソースプールで、ほとんどの期間のリソース使用が緑で示される場合、ワークロードバランスでサーバーまたはプールの仮想マシンの密度が最大化されていないことが考えられます。この場合は、リソース使用の多くが［中しきい値の平均］（青）で示されるようになるまで、パフォーマンスしきい値を調整します。
  • ［限界しきい値の平均（%）］（赤）は、平均リソース使用が限界しきい値以上になった期間を示します。

サーバーのリソース使用の円グラフをダブルクリックすると、そのサーバーのリソース（CPUなど）についてのホストヘルス履歴レポートが表示されます。プールヘルス履歴レポートに戻るには、ツールバーの［元のレポートに戻る］ボタンをクリックします。注：このボタンは、プールヘルス履歴レポートなどのドリルスルーレポートでのみ使用可能になります。

このレポートで示される値の大半が［中しきい値の平均］の範囲に収まらない場合は、このリソースプールのパフォーマンスしきい値を調整します。ワークロードバランスでは各パフォーマンスしきい値にデフォルト値が設定されますが、環境によっては調整が必要な場合があります。これを行わないと、ワークロードバランスで適切な推奨項目が生成されません。詳しくは、「しきい値の変更」を参照してください。

注：高、中、および低しきい値の範囲は、限界しきい値に基づいて自動的に決定されます。

プールヘルス履歴

このレポートでは、リソースプール内のすべての物理サーバーのリソース使用が線グラフで示されます。これにより、しきい値（限界、高、中、および低）に関して、リソースの使用傾向を確認できます。このレポートのデータポイントの傾向を監視することで、設定したパフォーマンスしきい値の効果を評価できます。

ワークロードバランスでは、管理者設定した限界しきい値に基づいて、高、中、および低しきい値の範囲が決定されます。プールヘルスレポートが各しきい値状態で動作した期間を示すのに対し、プールヘルス履歴レポートは日別の平均リソース使用量を示します。

［平均空きメモリ］グラフを除き、データポインタの平均値が限界しきい値（赤線）以下に維持される必要があります。［平均空きメモリ］グラフの場合は、データポインタの平均値が限界しきい値（グラフの最下部）以上に維持される必要があります。これは、このグラフが空きメモリを示すためで、ほかのリソースのしきい値とは異なり、許容最小値を限界しきい値として設定するためです。

このレポートの内容は以下のとおりです。

  • 平均使用量のグラフが［中しきい値の平均］（青線）に近い場合、最適化モードの設定にかかわらず、適切なリソース使用を示します。
  • ［低しきい値の平均］（緑）に近い場合は、必ずしも好ましいリソース使用を示すとは限りません。低しきい値のリソース使用が好ましいかどうかは、最適化モードの設定によって異なります。たとえば、最適化モードとして［密度を最大化］を選択したリソースプールで、平均使用量のグラフが多くの日で緑線以下の場合、ワークロードバランスでプールの仮想マシンの密度が最大化されていないことが考えられます。この場合は、リソース使用の多くが［中しきい値の平均］（青）で示されるようになるまで、パフォーマンスしきい値を調整します。
  • リソースの平均使用のグラフが［限界しきい値の平均（%）］（赤）と交差する個所は、リソースの平均使用が限界しきい値以上になった日を示します。

グラフのデータポイントのうち大半が［中しきい値の平均］範囲外に表示され、それでもプールで良好なパフォーマンスが得られる場合は、パフォーマンスしきい値の調整を検討します。詳しくは、「しきい値の変更」を参照してください。

プールの最適化履歴

プールの最適化履歴レポートでは、ワークロードバランスによる最適化処理の内容が時系列で示されます。

最適化処理は、グラフおよび表で示されます。表の［日付］列の［+］をクリックすると、その日に実行された最適化処理の詳細が表示されます。

このレポートの内容は以下のとおりです。

  • VM名：ワークロードバランスにより最適化された仮想マシンの名前です。
  • 理由：最適化の理由です。
  • 状態：最適化処理が成功したかどうかを示します。
  • 移動元：仮想マシンの移行元の物理サーバーです。
  • 移動先：仮想マシンの移行先の物理サーバーです。
  • 時間：最適化処理の実行時刻です。

ヒント：プールの最適化履歴レポートは、［WLB］タブの［履歴を表示］をクリックすることでも生成できます。

仮想マシン移動履歴

この線グラフでは、リソースプールでの仮想マシンの移動（移行）数が示されます。仮想マシンの移行が推奨項目を適用した結果なのかどうか、および移行先のサーバーが表示されます。また、このレポートでは移行理由も示されます。このレポートを使用して、リソースプールの仮想マシンの移行を監査できます。

このレポートの内容は以下のとおりです。
  • グラフの左側の数値は、リソースプール内の仮想マシンの数に基づく、可能な移行数を示します。
  • レポートの［日付］列の［+］をクリックすると、その日に実行された移行処理の詳細が表示されます。

仮想マシンパフォーマンス履歴

このレポートでは、特定サーバー上の各仮想マシンのパフォーマンスデータが示されます。ワークロードバランスでは、仮想マシンに割り当てられた仮想リソースの量に基づいてパフォーマンスデータが評価されます。たとえば、仮想マシンの［平均CPU使用率］が67%である場合は、特定期間にその仮想マシンで平均67%の仮想CPUが使用されたことを示します。

このレポートの初期表示では、指定した期間でのリソース使用の平均値が示されます。

［+］をクリックすると、各リソースの線グラフが表示されます。これにより、特定期間でのリソースの使用傾向を確認できます。

このレポートには、CPU使用率、空きメモリ、ネットワーク読み取り/書き込み、およびディスク読み取り/書き込みのデータが表示されます。


監査記録でのイベント名

次の表は、XenServer監査記録レポートおよびプール監査記録レポートに出力されるイベントを示しています。イベントに関するより詳しい情報については、「Citrix XenServer Management API」（英文）を参照してください。

プール監査記録レポートの［イベントアクション］列には、プール、仮想マシン、またはサーバーに関するイベントが出力されます。何に関するイベント化を確認するには、［イベントオブジェクト］列と［オブジェクト名］列を参照してください。

イベントアクション | ユーザーアクション
SR.destroy | ストレージリポジトリの破棄
VM.start | 仮想マシンの起動
http/get_audit_log | 監査ログの取得
reboot | サーバーの再起動
disable | サーバーの無効化（追加の仮想マシンを起動できない状態）
migrate | すべての仮想マシンのほかのサーバーへの移行（可能な場合）
suspend | 仮想マシンを停止してその状態をディスクに保存
hard_shutdown | 特定の仮想マシンの強制シャットダウン
hard_reboot | 特定の仮想マシンの強制再起動
start_on | 特定の仮想マシンの特定サーバー上での起動
snapshot_with_quiesce | 特定の仮想マシンの休止スナップショットを作成して新規仮想マシンを作成
enable_ha | 高可用性モードの有効化
copy | 特定の仮想マシンを複製して新規仮想マシンを作成
disable_ha | 高可用性モードの無効化
join_force | 新規プールへのサーバーの（強制）追加
join | 新規プールへのサーバーの追加
shutdown | 特定の仮想マシンのシャットダウン
pool_migrate | 仮想マシンのほかのサーバー上への移行
pool.retrieve_wlb_recommendations | このプールのワークロードバランス推奨項目の取得


ワークロードバランス設定の変更

ワークロードバランス仮想アプライアンスに接続したら、再配置や最適化の推奨項目を計算するための設定を変更できます。以下の設定を変更できます。

  • 最適化モードの変更
  • 自動処理と電源管理の設定
  • しきい値の変更
  • 測定基準の重要度の変更
  • 推奨項目からのサーバーの除外
  • 詳細設定

注：ワークロードバランス仮想アプライアンスへの接続または再接続直後に設定を変更する場合は、60秒以上（ログ/var/log/wlb/LogFile.logに検出の完了が示されます）待機する必要があります。

ワークロードバランス設定が適用されるしくみ

ワークロードバランスの設定は、リソースプールに属するすべてのホストおよび仮想マシンに適用されます。

ネットワークやディスクのパフォーマンスがその環境のハードウェアに適したものである場合は、まずデフォルトの設定でワークロードバランスを使用します。

ワークロードバランス機能をしばらく運用した後で、パフォーマンスのしきい値を評価して、必要に応じて変更することをお勧めします。たとえば、以下の場合に設定の変更を検討します。

  • 最適化の推奨項目が必要以上に生成される。この場合、適切な推奨項目が生成されるようになるまでしきい値を調整します。
  • ネットワーク帯域幅が十分でないにもかかわらず推奨項目が生成されない。この場合、適切な推奨項目が生成されるようになるまでネットワークのしきい値を下げます。

しきい値を変更する前に、リソースプール内の各物理サーバーについてホストヘルス履歴レポートを作成すると便利です。

設定を変更するには、XenCenterの［ワークロードバランス設定］ダイアログボックスや、xeコマンドラインインターフェイスを使用します。

XenServerとワークロードバランスサーバーとの通信で使用される資格情報を変更する方法については、「ワークロードバランスの資格情報の変更」を参照してください。

ワークロードバランス設定の情勢について詳しくは、『ワークロードバランス管理者ガイド』を参照してください。

［ワークロードバランス設定］ダイアログボックスを開くには

  1. XenCenterのリソースペインで、リソースプールを選択します。
  2. プロパティペインの［WLB］タブをクリックします。
  3. ［WLB］タブの［設定］をクリックします。


最適化モードの変更

ワークロードバランスでは、仮想マシンの実行によるワークロードを再配置（つまり最適化）するための推奨項目が生成されます。この推奨項目は、管理者が選択する最適化モードに基づいて計算されます。

パフォーマンスの最大化と密度の最大化

最適化モードには、以下の2つがあります。

  • パフォーマンスを最大化：（デフォルト）リソースプール内のすべての物理サーバー上に仮想マシンを均等に配置します。これにより、すべてのサーバーのCPU、メモリ、およびネットワーク負荷を最小化できます。この最適化モードでは、仮想マシンが高しきい値に達すると最適化の推奨項目が生成されます。
  • 密度を最大化：1台の物理サーバー上に可能な限り多くの仮想マシンを配置します。これにより、リソースプール内で稼働する物理サーバーの数を最小化できます。

    この最適化モードでは、［パフォーマンスを最大化］を選択した場合と同様のしきい値を使用できます。ただし、これらのしきい値は、1台のサーバにどれだけ多くの仮想マシンを配置できるかを評価するために使用されます。この最適化モードでは、仮想マシンが限界しきい値に達すると最適化の推奨項目が生成されます。

これらの最適化モードは、永続的に適用（固定）したり、特定のスケジュールに基づいて適用（スケジュール指定）したりできます。

固定

最適化モードを固定すると、選択したモード（パフォーマンスの最大化または密度の最大化）が常に使用されます。

スケジュール指定

最適化モードのスケジュールを指定すると、指定したスケジュールに基づいてモードを切り替えることができます。たとえば、多くのエンドユーザーが作業する日中にパフォーマンスを最大化するモードを適用し、使用電力を抑えるために夜間は密度を最大化するモードを適用できます。

最適化モードのスケジュールを指定すると、その期間（曜日および時刻）に最適化モードが自動的に切り替わります。

常時適用する最適化モードを設定するには

  1. リソースペインでプールを選択して［WLB］タブをクリックし、［設定］をクリックします。
  2. ダイアログボックス左側の［最適化モード］をクリックします。
  3. ［固定］をクリックして、以下のいずれかの最適化モードを選択します。
    • パフォーマンスを最大化：（デフォルト）リソースプール内のすべての物理サーバー上に仮想マシンを均等に配置します。これにより、すべてのサーバーのCPU、メモリ、およびネットワーク負荷を最小化できます。
    • 密度を最大化：1台の物理サーバー上に可能な限り多くの仮想マシンを配置します。これにより、リソースプール内で稼働する物理サーバーの数を最小化できます。ただし、ワークロードバランスでは、集約された仮想マシンのパフォーマンスも考慮され、サーバーが限界しきい値に達すると、パフォーマンスを改善するための推奨項目が生成されます。

最適化モードを切り替えるスケジュールを指定するには

  1. リソースペインでプールを選択して［WLB］タブをクリックし、［設定］をクリックします。
  2. ダイアログボックス左側の［最適化モード］をクリックします。
  3. ［スケジュール指定］をクリックします。
  4. ［新規追加］をクリックします。［最適化モードのスケジュール］ダイアログボックスが開きます。
  5. ［モード］ボックスで最適化モードを選択します。
    • パフォーマンスを最大化：リソースプール内のすべての物理サーバー上に仮想マシンを均等に配置します。これにより、すべてのサーバーのCPU、メモリ、およびネットワーク負荷を最小化できます。
    • 密度を最大化：1台の物理サーバー上に可能な限り多くの仮想マシンを配置します。これにより、リソースプール内で稼働する物理サーバーの数を最小化できます。
  6. 選択した最適化モードに切り替える曜日および時刻を選択します。
  7. 必要に応じて、スケジュールを追加します。追加したスケジュールが1つのみの場合、そのスケジュールに基づいて切り替わった最適化モードが元に戻らなくなります。
  8. ［OK］をクリックします。

最適化モードのスケジュールを削除または一時停止するには

  1. リソースペインでプールを選択して［WLB］タブをクリックし、［設定］をクリックします。
  2. ［最適化モード］をクリックします。
  3. 変更するスケジュールを選択して、以下のいずれかを行います。
    • タスクを削除する：［削除］ボタンをクリックします。
    • タスクを一時的に停止する：タスクを右クリックして、［無効化］を選択します。
    無効にしたタスクを有効にするには、タスクを右クリックして［有効化］を選択します。

最適化モードのスケジュールを変更するには

  1. リソースペインでプールを選択して［WLB］タブをクリックし、［設定］をクリックします。
  2. ［最適化モード］をクリックし、既存のタスクを選択します。
  3. ［編集］をクリックします。
  4. ［最適化モードのスケジュール］ダイアログボックスで、必要な変更を行います。


自動処理による電源の最適化と管理

ワークロードバランスによる最適化推奨項目が自動的に適用されるように設定することができます（ワークロードバランスの自動処理機能）。また、サーバーの電源を自動的に投入したり切断したりすることもできます（電源管理機能）。

最適化推奨項目の自動適用

ワークロードバランスで生成された最適化推奨項目を、管理者の介在なしに自動的に適用することができます。この自動処理機能を使用すると、生成される推奨項目に基づいて、自動的にパフォーマンスを最適化したりサーバーの電源を切断したりできます。ただし、仮想マシンの使用が減少したときにサーバーの電源を落として消費電力を抑えるには、自動処理のほか、電源管理と密度の最大化モードを設定する必要があります。

ワークロードバランスのデフォルトでは、推奨項目が自動的に適用されることはありません。生成された推奨項目が自動的に適用（実行）されるようにするには、自動処理機能を有効にする必要があります。この機能を有効にしない場合、管理者が、生成された推奨項目を実行するかどうかを選択します。

ワークロードバランスで生成された推奨項目が高可用性の設定と競合する場合、その推奨項目は自動的には適用されません。推奨項目の適用によりプールがオーバーコミット状態になる場合は、それを適用するかどうかを確認するメッセージが表示されます。自動処理を有効にしても、高可用性で許可する障害数を超える数の電源管理推奨項目は無視され、自動的には適用されません。

自動モードのワークロードバランスで推奨項目がどのように適用されるかを変更することができます。詳しくは、「詳細設定」を参照してください。

電源管理の有効化

ワークロードバランスの電源管理機能は、リソースプールの全体的なワークロードに応じて物理サーバーの電源を投入したり切断したりするための機能です。

ワークロードバランスの電源管理機能を使用するには、以下の条件を満たす必要があります。

  • サーバーのハードウェアがリモートからの電源投入/切断をサポートしている。
  • サーバーのホスト電源投入機能が設定されている。
  • サーバーが電源管理の対象として明示的に選択されている。

また、この機能でサーバーの電源を自動的に切断する場合は、以下の設定を行う必要があります。

  • ワークロードバランスの推奨項目が自動的に適用されるように設定されている。
  • ワークロードバランスの電源管理推奨項目が自動的に適用されるように設定されている。

電源管理と密度の最大化モードを有効にすると、使用されていないリソースがワークロードバランスにより検出され、そのサーバーの電源を切断するための推奨項目が生成されます。サーバーの電源を切断するために必要なリソースがプールにない場合は、プールのワークロードが小さくなるまでそのサーバーを動作させておくことが推奨項目として提示されます。余剰サーバーの電源を自動的に切断するように設定した場合は、電源を切るための推奨項目が自動的に適用されます。

電源管理の対象サーバーを指定すると、そのサーバーの電源を投入したり切断したりするための推奨項目が生成されます。これらの電源管理推奨項目の自動処理を有効にする場合、リソースプール全体に適用されます。ただし、電源管理の対象サーバーは個別に選択できます。

電源管理のしくみ

ワークロードバランスによりサーバーの電源が切断される前に、そのサーバー上の仮想マシンの移行先サーバーが選択されます。移行先サーバーは、以下の順序で決定されます。

  1. プールマスタが最初の移行先サーバーになります。これは、プールマスタの電源が切断されることがないためです。
  2. 次に、より多くの仮想マシンを実行しているサーバーが選択されます。
  3. 以降、実行している仮想マシンの数が多いサーバーから順番に選択されます。

ワークロードバランスでプールマスタに仮想マシンを移行する場合、意図的に低いしきい値が使用されます。これにより、プールマスタが過負荷状態になるのを防ぎます。

次の図は、リソースプールでの仮想マシン密度を最大化するための以降順序を示しています。

この図では、最適化モードとして［密度を最大化］が選択されている場合の仮想マシンの移行順序を示しています。仮想マシンの集約先として、まずプールマスタが選択され、次に実行仮想マシン数の多いサーバー、最後に実行仮想マシン数の少ないサーバーが選択されます。

最適化モードとして密度の最大化が選択されているプールでパフォーマンスに関する問題が検出されると、電源投入済みのサーバー間での仮想マシンの移行を推奨して問題を解決しようとします。この方法でパフォーマンスが改善されない場合、シャットダウン状態のサーバーの電源を投入します。このとき、最適化モードとしてパフォーマンスの最大化が選択された場合と同じ条件に基づいて、電源投入するサーバーが決定されます。

最適化モードとしてパフォーマンスの最大化が選択されているリソースプールでは、すべてのサーバーのリソース使用が高しきい値を下回るまで、電源投入の推奨項目が生成されます。

仮想マシンを移行しているときに、オンライン状態のサーバーを増やすことでプール全体のパフォーマンスが改善するとワークロードバランスが判断した場合、自動的にサーバーの電源を投入したり、電源投入の推奨項目を生成したりします。

重要：ワークロードバランスでは、推奨項目により電源が切断されたサーバーに対してのみ、電源投入の推奨項目を生成します。

電源管理および仮想マシン集約のための環境設計

XenServerを実装して電源管理と仮想マシン集約を自動化する場合は、以下の点を考慮して環境を設計します。

  • 異なる種類のワークロードを個別のプールに配置する：異なる種類のワークロードを実行する場合は、それらの仮想マシンを個別のプールに配置することを検討します（たとえば、ユーザーアプリケーションとドメインコントローラの仮想マシンを分離したり、特定のハードウェアを使用するアプリケーションを専用のプールで実行したりするなど）。

    電源管理機能および仮想マシンの集約はプールレベルで管理されるため、「詳細設定」で説明されている点を考慮して、同じ比率で集約するワークロードが含まれるようにプールを設計する必要があります。

  • ワークロードバランスから除外するサーバーを指定する：特定のサーバーをワークロードバランスの対象から除外して、常に電源が投入された状態にしておくことができます。詳しくは、「推奨項目からのサーバーの除外」を参照してください。

最適化推奨項目を自動適用するには

  1. XenCenterのリソースペインで、リソースプールを選択します。
  2. プロパティペインの［WLB］タブをクリックします。
  3. ［WLB］タブの［設定］をクリックします。
  4. ダイアログボックス左側の［自動処理］をクリックします。
  5. 以下のオプションを設定します。
    • 最適化推奨項目を自動的に適用する：このチェックボックスをオンにすると、管理者の介在なしに最適化推奨項目を適用できます。ワークロードバランスにより自動的に最適化が行われ、仮想マシンが再配置されます。
    • 電源管理推奨項目を自動的に適用する：このチェックボックスによる動作は、リソースプールの最適化モードにより異なります。
      • パフォーマンスを最大化：［電源管理推奨項目を自動的に適用する］チェックボックスをオンにすると、サーバーのパフォーマンスを改善するためにオフラインサーバーの電源が自動的に投入されます。
      • 密度を最大化：［電源管理推奨項目を自動的に適用する］チェックボックスをオンにすると、自動的に余剰サーバー（リソース使用が低しきい値を下回るサーバー）の電源が切断されます。
  6. 以下のいずれかを行います。
    • ［電源管理推奨項目に含めるサーバー］で、電源管理の対象サーバーを選択します。詳しくは、下記「電源管理対象のサーバーを選択するには」を参照してください。
    • 電源管理を有効にしない場合は、［OK］をクリックして設定を確定します。

電源管理対象のサーバーを選択するには

  1. ［自動処理］ページの［電源管理推奨項目に含めるサーバー］の一覧で、ワークロードバランス機能で電源を投入/切断するサーバーを選択します。

    注：［電源管理推奨項目を自動的に適用する］チェックボックスをオフにしたままこの一覧でサーバーを選択した場合、それらのサーバーに対する電源管理推奨項目は自動的には適用されません。

  2. ［OK］をクリックします。

    リソースプール内にリモートからの電源管理をサポートするサーバーがない場合、ワークロードバランスの電源管理機能は動作しません。


しきい値の変更

ここでは、デフォルトの限界しきい値の変更方法と、高、中、および低しきい値がどのように変更されるかについて説明します。

これらの情報は、しきい値を変更するときのリファレンスとして提供されています。このトピックで説明されている概念を理解するには、『ワークロードバランス管理者ガイド』をよく読んでください。

概要

ワークロードバランスは、日別の平均値を4つのしきい値（低、中、高、および限界）と比較して、リソース使用を評価します。XenCenterでしきい値を指定（またはデフォルトのしきい値を使用）すると、その値は限界しきい値として設定され、それを基にほかの3つのしきい値が相対的に決定されます。最適化の推奨項目の生成を制御するために、限界しきい値を変更することができます。

ワークロードバランスでは、リソースプールの各物理サーバーのCPU、メモリ、ネットワーク読み取り、ネットワーク書き込み、ディスク読み取り、およびディスク書き込みの測定値が評価されます。

ワークロードの再配置を推奨項目として提示するか、および物理サーバーが仮想マシンのワークロードに適しているかは、以下を評価して決定されます。

  • 物理サーバー上のリソースの負荷が限界しきい値に達しているかどうか。
  • （限界しきい値に達していない場合は）各リソースの重要度。

注：ワークロードバランスでは、パフォーマンス測定値に急激な増加があっても平滑化され、日別の平均値が評価されます。

詳しくは、『ワークロードバランス管理者ガイド』を参照してください。

リソース負荷の履歴平均値がそのしきい値を超えると、ワークロードバランスで推奨項目が生成されます。『ワークロードバランス管理者ガイド』で説明されているように、パフォーマンスの最大化では高しきい値、密度の最大化では低しきい値または限界しきい値を超えたときに、推奨項目が生成されます。限界しきい値を変更すると、それに基づいてほかのしきい値が相対的に変更されます（XenCenter上で変更できるのは限界しきい値のみです）。

しきい値のデフォルト設定

次の表は、各しきい値のデフォルト値を示しています。

設定 | デフォルト値 | 高 | 中 | 低
CPU使用率 | 90% | 76.5% | 45% | 22.5%
空きメモリ | 51MB | 63.75MB | 510GB | 1020GB
ネットワーク読み取り | 25MB/秒 | 21.25MB/秒 | 12.5MB/秒 | 6.25MB/秒
ネットワーク書き込み | 25MB/秒 | 21.25MB/秒 | 12.5MB/秒 | 6.25MB/秒
ディスク読み取り | 25MB/秒 | 21.25MB/秒 | 12.5MB/秒 | 6.25MB/秒
ディスク書き込み | 26MB/秒 | 21.25MB/秒 | 12.5MB/秒 | 6.25MB/秒

限界しきい値を以下の数で乗じたものが高、中、および低しきい値として設定されます。

  • 高しきい値： 0.85
  • 中しきい値： 0.50
  • 低しきい値： 0.25

空きメモリのしきい値は、限界しきい値を以下の数で乗じたものが使用されます。

  • 高しきい値： 1.25
  • 中しきい値： 10.0
  • 低しきい値： 20.0

つまり、CPU使用率の限界しきい値を95%に変更した場合、高、中、および低しきい値がそれぞれ80.75%、47.5%、および23.75%に変更されます。

特定のしきい値についてこの計算を行うには、限界しきい値として指定した数値にこれらの数を乗じます。

高、中、または低しきい値 ＝ 限界しきい値 × 上記の数

たとえば、［ネットワーク読み取り］のしきい値を40MB/秒に変更した場合、低しきい値は40×0.25＝10MB/秒となり、中しきい値は40×0.50で計算できます。

プールマスタとして動作するサーバーが過負荷状態にならないように、プールマスタには自動的に低いしきい値が適用されます。

ほかのしきい値により生成される推奨項目

多くの推奨項目は限界しきい値に基づいて生成されますが、ほかのしきい値により推奨項目が生成される場合もあります。

高しきい値：

  • パフォーマンスを最大化：高しきい値を超えたときに、仮想マシンをリソース負荷の低いサーバー上に移行するための推奨項目が生成されます。
  • 密度を最大化：追加の仮想マシンによりサーバーのいずれかのリソース負荷が高しきい値を超える場合、そのサーバー上に仮想マシンを移行する推奨項目が生成されなくなります。

低しきい値：

  • パフォーマンスを最大化：推奨項目は生成されません。
  • 密度を最大化：リソース負荷が低しきい値を下回ると、仮想マシンをそのサーバー上に集約するための推奨項目が生成されます。そのサーバーのいずれかのリソース負荷が高しきい値に達するまで、仮想マシンの集約先としてそのサーバーの推奨が続行されます。

    仮想マシンの集約によりそのサーバーのリソース負荷が限界しきい値を超えた場合は、パフォーマンスの最大化の場合と同様のロードバランスアルゴリズムにより、仮想マシンの新しい集約先が検索されます。リソースプール内のすべてのサーバーのリソース負荷が高しきい値を下回るまで、このアルゴリズムによる推奨項目の生成が続行されます。

しきい値を変更するには

  1. リソースペインでプールを選択して［WLB］タブをクリックし、［設定］をクリックします。
  2. ダイアログボックス左側の［しきい値］をクリックします。
  3. ［しきい値］ページでは、各リソース使用量の限界しきい値を設定できます。

    ワークロードバランスでは、仮想マシンの推奨再配置先を計算するときに、これらの限界しきい値が使用されます。各サーバーのリソース使用がこれらのしきい値を超えないように、仮想マシンによるワークロードを分散できます。


測定基準の重要度の変更

注：測定基準の重要度を変更する前に、『ワークロードバランス管理者ガイド』を参照して、最適化および集約化のプロセスについて確認しておくことをお勧めします。このヘルプトピックでは、これらのプロセスについて詳しくは説明しません。

ワークロードバランスでは、リソースに重要度を割り当てる測定基準の重要度を使用して、最初に最適化するサーバーが決定されます。

ワークロードバランスでは、選択されている最適化モード（パフォーマンスの最大化または密度の最大化）に基づいて、どのホストや仮想マシンを先に最適化するを決定するときに各リソース測定基準の重要度が考慮されます。

推奨項目を生成するときに、高い重要度が割り当てられている測定基準の値が比較され、サーバーを最適化するための順番が決定されます。

測定基準の重要度は、最適化モードとしてパフォーマンスの最大化が選択されているリソースプールで主に使用されます。ただし、密度の最大化が選択されている場合でも、限界しきい値を超えた測定基準では、その重要度が考慮されます。

パフォーマンスを最大化する場合の測定基準の重要度

パフォーマンスの最大化が選択されているリソースプールでは、測定基準の重要度により、どのホストのパフォーマンスを先に最適化するか、およびどの仮想マシンを先に移行するかが決定されます。

たとえば、［ネットワーク書き込み］を［重要度：高］に設定し、ほかの測定基準のスライダを中央に設定（重要度：中）した場合、ネットワーク書き込みの値が最も高いホストが先に最適化の対象になります。

すべての測定基準の重要度が同じ場合（つまりすべての［測定基準の重要度］スライダが同じ位置にある）、CPU使用率、空きメモリの順に考慮されます。これは、これらのリソースに対する制約がホストのパフォーマンスに大きく影響するためです。

密度を最大化する場合の測定基準の重要度

密度の最大化が選択されているリソースプールでは、サーバーが限界しきい値に達した場合にのみ測定基準の重要度が考慮されます。その後、すべてのサーバーが限界しきい値を下回るまで、パフォーマンスを最大化する場合と同じアルゴリズムが使用されます。このアルゴリズムでは、測定基準の重要度に基づいて、サーバーを最適化するための順番が決定されます。

つまり、複数のサーバーで限界しきい値を超えている場合、その重要度がチェックされ、先に最適化するサーバーが決定されます。

たとえば、サーバーAとサーバーBで構成されるリソースプールを例に説明します。

  • CPU使用率に高い重要度が設定されており、サーバーAのCPU使用率が限界値を超えています。
  • メモリ使用に低い重要度が設定されており、サーバーBのメモリ使用が限界値を超えています。

この場合、高い重要度の測定基準が限界しきい値に達しているサーバーAが先に最適化の対象になります。次に、サーバーA上の仮想マシンのうち、CPU使用率の最も高いものを移行するための推奨項目が作成されます。

サーバーAに対する推奨項目を生成したら、サーバーBが最適化の対象になります。サーバーB上の仮想マシンに対しても、CPU使用率の最も高いものを移行するための推奨項目が作成されます。これは、このリソースプールでCPU使用率に対して高い重要度が設定されているためです。

リソースプールにほかのサーバーがある場合は、サーバーのCPU使用率が高いものから順に最適化が行われます。

デフォルトでは、すべての測定基準の重要度が最大（［重要度：高］）に設定されます。

注：測定基準の重要度は、相対的に処理されます。つまり、すべての測定基準の重要度が同じ場合、その重要度レベルは意味を持ちません。重要度の相対的な高低により、各測定基準の評価が決定されます。

測定基準の重要度を変更するには

  1. リソースペインでプールを選択して［WLB］タブをクリックし、［設定］をクリックします。
  2. ダイアログボックス左側の［測定基準の重要度］をクリックします。
  3. ［測定基準の重要度］ページでは、必要に応じて各リソースの重要度を調節できます。

    スライダを［重要度：低］側にドラッグすると、そのリソースの負荷は仮想マシンの再配置先の決定には影響しなくなります。


推奨項目からのサーバーの除外

ワークロードバランスを設定するときに、最適化および仮想マシン配置の推奨項目から除外する物理サーバーを指定できます。

なぜサーバーを除外するのか

以下の状況では、特定のサーバーを推奨項目の対象から除外することを検討します。

  • プールの最適化モードとして［密度を最大化］を使用するが、特定のサーバーをこの最適化（仮想マシンの集約化とサーバーのシャットダウン）から除外する場合。
  • 2つの仮想マシンワークロードを常に同一サーバー上で実行する必要がある場合（それらの仮想マシンが相補的な場合など）。
  • 移行すべきでないワークロードがある場合（ドメインコントローラやSQL Serverなど）。
  • サーバーの保守作業の間、仮想マシンの移行先サーバーから除外する場合。
  • ハードウェアのコストよりもワークロードのパフォーマンスの方が重要な場合。
  • 特定のサーバー上で優先度の高いワークロード（仮想マシン）を実行し、それらの仮想マシンに高可用性機能の優先度を設定したくない場合。
  • プール内のワークロードの実行に不適切なハードウェアを持つサーバーがある場合。

最適化モードのスケジュールを設定するかどうかに関係なく、最適化モードが変更されても除外サーバーは常に推奨項目の対象から除外されます。このため、サーバーの電源が自動的に切断されるのを防ぐためだけの場合は、そのサーバーに対する電源管理機能を無効にすることを検討します。方法については、「自動処理による電源の最適化と管理」を参照してください。

最適化および仮想マシン配置の推奨項目からサーバーを除外するには

  1. リソースペインでプールを選択して［WLB］タブをクリックし、［設定］をクリックします。
  2. ダイアログボックス左側の［除外ホスト］をクリックします。
  3. ［除外ホスト］ページで、ワークロードバランスの推奨項目から除外するホストサーバーを選択します。


詳細設定

［詳細］ページでは、主に自動モードで動作するワークロードバランスで推奨項目をどのように自動適用するかを設定します。

重要：ワークロードバランスをしばらく使用して意図したとおりに推奨項目が生成されない場合は、パフォーマンスしきい値の設定を再評価することを強くお勧めします。方法については、『ワークロードバランス管理者ガイド』を参照してください。運用環境に合ったしきい値を設定することで、より適切な最適化推奨項目が作成されるようになります。

概要：推奨項目の自動適用の積極度

自動モードで動作するワークロードバランスでは、最適化および集約化の推奨項目の頻度や自動適用の積極度が以下の複数の要因により決定されます。

  • 移行後の仮想マシンを次の推奨項目に含めるまでの時間（VM移行間隔）
  • 最適化推奨項目を自動的に適用するまでの作成回数（推奨項目の回数）
  • 推奨項目を自動適用するときの最低重要度レベル（最適化の重要度）
  • 推奨項目を自動適用するときの推奨項目の一貫性レベル（移動する仮想マシンや移動先サーバーとして同じものが推奨されるかどうか）

VM移行間隔

ワークロードバランスにより仮想マシンを移動した後で、その仮想マシンを含んだ新しい最適化推奨項目を生成するまでの時間を分単位で指定できます。

仮想マシンの移行間隔は、人為的な操作（一時的な高負荷時など）が原因で推奨項目が生成されるのを防ぐために設定します。

ワークロードバランスの自動処理機能を有効にした場合は、仮想マシンの移行間隔を特に慎重に決定する必要があります。継続的および反復的にサーバーの負荷が増加する環境で頻度を増やす（小さい値を設定する）と、多くの推奨項目が生成され、仮想マシンの再配置が頻繁に発生します。

注：この設定は、前回と同じサーバーを仮想マシンの起動または再開先サーバー、および保守モードの推奨項目に含むかどうかの決定には影響しません。

推奨項目の回数

ワークロードバランスでは、そのリソースプールで推奨項目の生成が必要かどうかが2分ごとにチェックされます。ワークロードバランスの自動処理機能では、推奨項目をいくつ生成したら自動的に適用するかを指定できます。これを行うには、［推奨項目の回数］を設定します。「推奨項目の回数］と［最適化の積極度］の設定により、推奨項目をどのように自動適用するかを微調整できます。

上記の概要で説明したように、ワークロードバランスでは、推奨項目の類似性に基づいてその推奨項目が必要かどうか、および仮想マシンの移行先サーバーのパフォーマンスが長時間安定しているかどうか（仮想マシンの再移行が発生しないように）が決定されます。［推奨項目の回数］では、推奨項目を自動適用するまでの作成回数を指定します。同じ推奨項目の生成がこの回数に達すると、その推奨項目が自動的に適用されます。

この設定は、以下のように使用されます。

  1. ［最適化の積極度］により決定される一貫性要件を満たす推奨項目が生成されるたびに、推奨項目の回数が増分されます。一貫性要件を満たさない推奨項目が生成されると、（『ワークロードバランス管理者ガイド』で説明されている要因によっては）推奨項目の回数が0にリセットされます。
  2. 一貫性要件を満たす推奨項目の生成が［推奨項目の回数］の値に達すると、その推奨項目が自動的に適用されます。

この設定を変更する場合は、その環境に最適な値を決定する必要があります。以下の点を考慮して設定します。

  • サーバーの負荷およびアクティビティが極端に急増する環境では、［推奨項目の回数］の値を大きくします。推奨項目の生成が必要かどうかは、2分ごとにチェックされます。推奨化項目を適用するまでの作成回数として3を設定すると、6分後に推奨項目が自動適用されます。
  • サーバーの負荷およびアクティビティが段階的に増加する環境では、［推奨項目の回数］の値を小さくします。

推奨項目を適用すると仮想マシンの再配置処理が発生し、システムリソースに負担がかかってパフォーマンスが影響を受けます。［推奨項目の回数］の値を大きくすると、推奨項目が自動適用されるまでに、同様の推奨項目が多く生成されることになります。つまり、より慎重で一貫した推奨項目だけが適用され、仮想マシンが不適切に移行される可能性が低くなります。デフォルトでは、このような値が設定されています。

この値の変更は運用環境への影響が大きいため、Citrixのサポート担当者からの指示がない限り、上記のオプションを変更しないことをお勧めします。変更する場合は、ワークロードバランスの動作について詳細にテストしてください。

最適化の重要度

すべての最適化推奨項目には、その推奨項目がどれだけ大切であるかを示す重要度レベル（最重要、高、中、低）が設定されます。この重要度レベルは、パフォーマンスしきい値や重要度などの設定と、ワークロードで使用可能なリソース、およびリソース使用履歴データに基づいて決定されます。

ワークロードバランスの推奨項目が自動的に適用されるように設定した場合、指定した最低重要度レベルを満たす推奨項目だけが適用されます。

最適化の積極度

自動モードで動作するワークロードバランスでは、一時的または異常な負荷の増加により仮想マシンの移行が行われないように、推奨項目の一貫性を判断するためのいくつかの基準が使用されます。自動モードでは、最初に生成された推奨項目は自動適用されません。サーバーや仮想マシンでその動作が継続的に発生することが検出されるまで、自動適用は行われません。つまり、同じサーバーや仮想マシンが原因で推奨項目が生成される場合、その推奨項目は一貫していると判断されます。

ワークロードバランスでは、一貫性を判断するための条件と、同じ推奨項目をいくつ生成したか（連続推奨数）により、その環境の動作の一貫性が決定されます。一貫性をどれだけ厳密に評価するかを制御するには、［最適化の積極度］を設定します。

この［最適化の積極度］設定は主にデモ用として設計されましたが、このオプションにより運用環境の安定性を制御することができます。デフォルトでは、積極度が低く設定されています。積極度を高くすると、推奨項目の類似性を評価するときの厳密度が低くなり、運用環境の安定性が低下します。

ワークロードバランスは、最大で4つの条件を使用して推奨項目の一貫性を判断します。使用される条件の数は、［最適化の積極度］で設定されている積極度レベルにより異なります。積極度レベルが［低］または［中］の場合、推奨項目は積極的には自動適用されません。つまり、積極度レベルが低いと最適化条件が厳密に評価され、それらに合致しないと自動適用は行われません。

たとえば、積極度レベルとして［低］を設定すると、このレベルの条件に合致する推奨項目の数が［推奨項目の回数］の値に達するまで、その推奨項目は自動適用されません。

たとえば、［推奨項目の回数］に「3」を設定した場合、低レベル用のすべての条件に合致する推奨項目（『ワークロードバランス管理者ガイド』参照）が連続して3回生成されたときに、その推奨項目が自動適用されます。これにより、長時間安定して動作しているサーバーに仮想マシンが移行されるようになり、移行されたばかりの仮想マシンが、そのサーバーのパフォーマンスが低下したために再移行されるという可能性が低くなります。デフォルトでは、積極度レベルとして［低］が設定されています。

［最適化の積極度］を高くしてサーバーの最適化頻度を上げることは、推奨されません。サーバーの最適化がより高速または頻繁に行われるようにするには、パフォーマンスしきい値の調整を検討します。詳しくは、「しきい値の変更」を参照してください。

各積極度レベルで推奨項目の一貫性を判断するときに使用される条件については、『ワークロードバランス管理者ガイド』を参照してください。

推奨項目の自動適用が意図したとおりに行われない場合は、積極度の設定を高くします。ただし、その前に『ワークロードバランス管理者ガイド』の内容を確認することを強く推奨します。

仮想マシン推奨項目の間隔を設定するには

  1. リソースペインでプールを選択して［WLB］タブをクリックし、［設定］をクリックします。
  2. ダイアログボックス左側の［詳細］をクリックします。
  3. ［詳細］ページで、以下の設定を行います。
    • ［VM移行間隔］で、移行後の仮想マシンを最適化推奨項目に含めるまでの時間を、分単位で指定します。
    • ［推奨項目の回数］で、最適化推奨項目が自動的に適用されるまでの作成回数を指定します。
    • ［最適化の重要度］で、最適化推奨項目の最低重要度レベルを指定します。このレベルに達すると、推奨項目が自動的に適用されます。
    • ［最適化の積極度］で、最適化推奨項目をどれだけ積極的に自動適用するかを指定します。


ワークロードバランスの管理

ワークロードバランスでは、以下の管理タスクが必要になることもあります。

  • ワークロードバランスから切断する。
  • プールのワークロードバランス仮想アプライアンスを変更する。
  • ワークロードバランスまたはXenServerで使用される資格情報を変更する。

ワークロードバランス仮想アプライアンスを管理するときに、ワークロードバランスサービスコマンドを使用することもできます。これらのコマンドでは、ワークロードバランス仮想アプライアンスの状態を確認したり、ユーザーアカウントを変更したり、より詳細な情報がログに記録されるようにしたりできます。これらのコマンドについて詳しくは、『ワークロードバランス管理者ガイド』を参照してください。

注：ワークロードバランスで別の証明書を使用したり、XenServerで証明書の同一性が検証されるように設定したりする方法については、『ワークロードバランス管理者ガイド』を参照してください。


ワークロードバランスから切断する

リソースプールのワークロードバランス機能を停止するには、ワークロードバランス仮想アプライアンスから切断してこの機能を無効にします。

リソースプールとワークロードバランス仮想アプライアンスとの接続を切断すると、そのリソースプールの情報がワークロードバランスデータベースから完全に削除されます。また、データコレクタの処理も停止します。このため、同じワークロードバランス仮想アプライアンスに再接続してこの機能を有効にするには、［WLBサーバーへの接続］ダイアログボックスでアプライアンスの情報を再入力する必要があります。

重要：ワークロードバランス機能を一時的に停止するには、［WLB］タブの［一時停止］をクリックします。

ワークロードバランスから切断するには

  1. XenCenterのリソースペインで、リソースプールを選択します。
  2. ［プール］メニューの［ワークロードバランスサーバーの切断］を選択します。［ワークロードバランスサーバーの切断］ダイアログボックスが開きます。
  3. ［切断］をクリックします。これにより、このプールでのワークロードバランス機能が停止します。
注：ワークロードバランス仮想アプライアンスから切断した後でこの機能を再度有効にするには、ワークロードバランス仮想アプライアンスに再接続する必要があります。


プールで使用するワークロードバランス仮想アプライアンスの変更

必要な場合は、リソースプールのワークロードバランス仮想アプライアンスを変更することができます。

変更後も古いワークロードバランス仮想アプライアンスによりプールのデータが収集されるのを防ぐため、新しい仮想アプライアンスに接続する前に古い仮想アプライアンスを切断しておく必要があります。

古いワークロードバランス仮想アプライアンスを切断したら、新しい仮想アプライアンスの名前を指定して接続します。

使用するワークロードバランス仮想アプライアンスを変更するには

  1. リソースペインでリソースプールを選択し、［プール］メニューの［ワークロードバランスサーバーの切断］を選択します。これにより確認のメッセージが表示されるので、［切断］をクリックします。詳しくは、「ワークロードバランスから切断する」を参照してください。
  2. ［WLB］タブの［設定］をクリックします。［WLBサーバーへの接続］ダイアログボックスが開きます。
  3. ［アドレス］ボックスに、新しいワークロードバランス仮想アプライアンスのIPアドレスまたはFQDNを入力します。

    新しい仮想アプライアンスで異なる資格情報を使用する場合は、その情報を入力します。

    4. 注：リソースプールでワークロードバランス仮想アプライアンスに初めて接続するときと同様に、すべての情報を入力する必要があります。詳しくは、「ワークロードバランスに接続する」を参照してください。


ワークロードバランスの資格情報の変更

XenServerとワークロードバランス仮想アプライアンス間の通信で使用される資格情報を変更するには、以下の3つの操作を行います。

  1. ワークロードバランスから切断します（下記手順を参照）。
  2. WlbConfigファイルを編集して資格情報を変更します。これを行うには、ワークロードバランス仮想アプライアンスのコンソールでWlbConfigコマンドを実行します。詳しくは、『ワークロードバランス管理者ガイド』を参照してください。
  3. ワークロードバランスを有効にして、新しい資格情報を指定します（下記手順を参照）。

以下の状況で、資格情報を変更できます。

  • XenServerがワークロードバランスと通信するときのユーザーアカウントを変更する必要がある。
  • ワークロードバランスの資格情報が無効になったというエラーメッセージが表示される。
  • サービスが使用できない。

ワークロードバランスのパフォーマンスしきい値や特定のリソースの優先度を変更する場合は、「ワークロードバランス設定の変更」を参照してください。

ワークロードバランスから切断するには

  1. XenCenterのリソースペインで、リソースプールを選択します。
  2. ［プール］メニューの［ワークロードバランスサーバーの切断］を選択します。［ワークロードバランスサーバーの切断］ダイアログボックスが開きます。
  3. ［切断］をクリックします。これにより、ワークロードバランス機能によるプールデータの収集が停止します。

ワークロードバランスを再有効化して新しい資格情報を指定するには

  1. 処理が完了するのを進行状況バーで確認し、［接続］をクリックします。

    ［WLBサーバーへの接続］ダイアログボックスが開きます。

  2. ［資格情報を変更する］をクリックします。
  3. ［サーバーのアドレス］セクションで、以下の情報を変更します。
    • ［アドレス］ボックスに、ワークロードバランス仮想アプライアンスのIPアドレスまたはFQDNを入力します。
    • （オプション）ワークロードバランス仮想アプライアンスの設定時にポートを変更した場合は、そのポート番号を入力します。このポートにより、XenServerとワークロードバランスが通信します。

      デフォルトでは、ポート8012が指定されています。

      注：ワークロードバランスのインストール時にポート番号を変更した場合のみ、ここでポート番号を変更してください。［ワークロードバランス設定］ダイアログボックスで指定するポート番号は、ワークロードバランスのインストールウィザードで指定したポート番号と同じである必要があります。

  4. ［WLBサーバーの資格情報］セクションで、XenServerでワークロードバランスサーバーに接続するときに使用するユーザー名（wlbuserなど）およびパスワードを入力します。
  5. ［XenServerの資格情報］セクションで、リソースプールにアクセスするためのユーザー名とパスワード（通常プールマスタのパスワード）を入力します。ワークロードバランスは、この情報を使用してリソースプールのサーバーに接続します。

    ログイン中のXenServerと同じ資格情報を使用するには、［現在のXenCenterの資格情報を使用する］チェックボックスをオンにします。


ワークロードバランスが有効なときの保守モード

ワークロードバランスが有効なリソースプールでは、物理サーバーを保守のためにオフラインにする（つまり保守モードに切り替える）と、そのサーバー上でホストされているすべての仮想マシンが自動的にほかの適切なサーバーに移行されます。仮想マシンの移行先ホストは、ワークロードバランスが最適化モードとパフォーマンスしきい値の設定、およびパフォーマンス測定値に基づいて計算した推奨項目により決定されます。

移行先サーバーが使用できない状態である場合は、［保守モードへの切り替え］ダイアログボックスに「ここをクリックしてVMを一時停止します」というメッセージが表示されます。この場合、十分なリソースを持つサーバーがないため、ワークロードバランスでは推奨再配置先が提示されません。管理者は、仮想マシンを一時停止するか、保守モードを終了してほかのサーバー上のワークロードを軽減する（仮想マシンを一時停止するなど）などの処置を行います。十分なリソースを持つほかのサーバーが使用可能になると、再度［保守モードへの切り替え］ダイアログボックスを開いたときに、推奨再配置先が提示されます。

注：ワークロードバランスが有効なリソースプールでサーバーを保守モードにすると、［保守モードへの切り替え］ダイアログボックスの右上に「ワークロードバランスが有効」が表示されます。

ワークロードバランスが有効なリソースプールでホストを保守モードにするには

  1. リソースペインでサーバーを選択して、次のいずれかを行います。
    • 右クリックして［保守モードへの切り替え］を選択します。
    • ［サーバー］メニューの［保守モードへの切り替え］を選択します。
  2. ［保守モードへの切り替え］をクリックします。

これにより、そのサーバー上で実行中のすべての仮想マシンが、最適化モードとパフォーマンスしきい値の設定、およびパフォーマンス測定値に基づいて決定される最適なサーバーに自動的に移行されます。

サーバーの保守モードを終了するには

  1. リソースペインでサーバーを選択して、次のいずれかを行います。
    • 右クリックして［保守モードからの切り替え］を選択します。
    • ［サーバー］メニューの［保守モードからの切り替え］を選択します。
  2. ［保守モードからの切り替え］をクリックします。

これにより、そのサーバーでホストされていたすべての仮想マシンが自動的に復元されます。


ワークロードバランスのトラブルシューティング

ここでは、ワークロードバランスの問題を解決するための手順について説明します。追加のトラブルシューティングについては、『ワークロードバランス管理者ガイド』を参照してください。

一般的な問題を解決するには、以下のヒントを参考にしてください。

一般的なトラブルシューティングのヒント

まず、ワークロードバランスのログファイルを参照します。デフォルトでは、ワークロードバランス仮想アプライアンスの以下の場所にログファイルが作成されます。

/var/log/wlb

また、XenCenterの［ログ］タブに表示される情報も参照してください。

エラーメッセージ

ワークロードバランス機能のエラーメッセージは、XenCenterの［ログ］タブ、および（一部のメッセージは）ダイアログボックス内に表示されます。


ワークロードバランスの資格情報入力時の問題

［WLBサーバーへの接続］ダイアログボックスで入力したワークロードバランス仮想マシンのユーザー名およびパスワードで接続できない場合は、以下の点を確認してください。

  • ワークロードバランス仮想アプライアンスがインポートされており、正しく設定されていることを確認します。また、すべてのサービスが実行されていることを確認します（サービスを実行するにはservice workloadbalancing startコマンドを実行します）。
  • 「ワークロードバランスの起動時の問題」を参照して、入力した資格情報が正しいことを確認します。
  • ワークロードバランスサーバーのFQDNを入力して問題が生じる場合は、IPアドレスを入力します。

    ［アドレス］ボックスには、ワークロードバランス仮想アプライアンスのホスト名を入力できますが、く完全修飾ドメイン名（FQDN）である必要があります。たとえば、yourcomputername.yourdomain.netと入力します。


ワークロードバランスの起動時の問題

ワークロードバランス仮想アプライアンスをインポートして設定した後にXenServerとワークロードバランスとの接続エラーが発生する場合は、［WLBサーバーへの接続］ダイアログボックスに不正な資格情報を入力したことが考えられます。この問題を解決するには、以下を行います。

  • ［WLBサーバーへの接続］ダイアログボックスに入力した資格情報と、ワークロードバランス仮想アプライアンスおよびXenServer上で作成したアカウントの情報が一致していることを確認します。
  • ［WLBサーバーへの接続］ダイアログボックスに入力した、ワークロードバランス仮想アプライアンスのIPアドレスまたはFQDNを確認します。
  • ［WLBサーバーへの接続］ダイアログボックスに入力した資格情報が、［WLBサーバーへの接続］ダイアログボックスに入力したものと一致することを確認します。


ワークロードバランスの接続エラー

XenCenterの［WLB］タブに接続エラーが表示される場合は、リソースプールのワークロードバランスを再設定してください。

これを行うには、［WLB］タブの［接続］をクリックして、サーバーの認証情報を再入力します。

通常、ワークロードバランス仮想アプライアンスやプールマスタの認証情報の変更や、ワークロードバランス仮想アプライアンスの名前の変更により、この問題が発生します。


ワークロードバランスサーバーの変更時の問題

リソースプールのワークロードバランスで使用するワークロードバランス仮想アプライアンスを変更するときに、元の仮想アプライアンスから切断してから新しい仮想アプライアンスに接続する必要があります。これを行わないと、両方の仮想アプライアンスでプールのデータが収集されます。

この問題を解決するには、変更前のワークロードバランス仮想アプライアンスをシャットダウンして削除します。または、その仮想アプライアンスがワークロードバランス機能を停止するように、手作業で各サービス（Analysis Engine、Data Collection Manager、およびWeb Services Host）を停止することもできます。

pool-initialize-wlbコマンドを使ってワークロードバランスを無効にしたり、ワークロードバランスサーバーを変更したりすることは推奨されません。


ワークロードバランスの使用

すべてのテキストを表示する

［WLB］タブ

ワークロードバランスとは

XenServerのワークロードバランス機能は、仮想アプライアンスにより提供されます。この仮想アプライアンスの機能は以下のとおりです。

  • 仮想マシンのワークロードをリソースプール内のサーバー間で分散させる。
  • 特定の時間（週末など）にワークロードを集約して余剰サーバーの電源を切る。
  • サーバーを1日の特定の時間にシャットダウンできるかどうかを判断する。
  • 仮想マシンの起動サーバーを決定する。
  • サーバーに障害が発生したり保守のためにオフラインにしたりするときに、仮想マシンの移行先を決定する。
  • 最適化、ワークロード、および監査アクションに対する履歴レポートを生成する。

ワークロードバランス機能を有効にするには、リソースプールをワークロードバランス仮想アプライアンスに接続します。［WLB］タブでは、ワークロードバランスの主要な機能（レポート、設定、最適化の推奨項目、状態など）にアクセスできます。

ワークロードバランス仮想アプライアンスをプールに追加する

ワークロードバランス機能は、Citrix XenServer Enterprise Editionおよびそれ以上のエディションで使用可能です。XenServerの各エディションについて詳しくは、ここを参照してください。

ワークロードバランス機能を使用できるXenServerエディションでこの機能を使用する場合は、ワークロードバランス仮想アプライアンスをダウンロードして、以下の手順に従ってセットアップします。

  1. MyCitrix.comからワークロードバランス仮想アプライアンスパッケージをダウンロードして、XenCenterを使ってインポートします。
  2. ウィザードの手順に従ってワークロードバランス仮想アプライアンスを設定します。このウィザードは、インポートした仮想アプライアンスの［コンソール］タブに表示されます。
  3. 「ワークロードバランスに接続する」の説明に従って、リソースプールをワークロードバランス仮想アプライアンスに接続します。

    これらの手順について詳しくは、『ワークロードバランスクイックスタート』を参照してください。

［WLB］タブのボタン

ワークロードバランスが有効になっていないプール（またはワークロードバランス仮想アプライアンスから切断されたプール）では、［WLB］タブに以下のボタンが表示されます。

接続
プールをワークロードバランス仮想アプライアンスに接続して、この機能を有効にします。ワークロードバランス仮想アプライアンスに接続すると、［設定］、［一時停止］または［再開］、および［レポート］ボタンが表示されます。ワークロードバランスへの接続について詳しくは、「ワークロードバランスに接続する」を参照してください。

ワークロードバランス仮想アプライアンスに接続すると、［WLB］タブに以下のボタンが表示されます。

設定
［ワークロードバランス設定］ダイアログボックスを開きます。このダイアログボックスでは、最適化モード（再配置モード）、自動処理、しきい値、測定基準の重要度、除外ホスト、および詳細を設定します。［設定］ボタンは、ワークロードバランスが有効になっているときにだけ表示されます。ワークロードバランス設定の詳細については、「ワークロードバランス設定の変更」を参照してください。
一時停止/再開
ワークロードバランス仮想アプライアンスに接続している場合、状況に応じて［一時停止］または［再開］ボタンが表示されます。［一時停止］をクリックすると、そのプールでのワークロードバランスの機能を一時的に停止することができます。ワークロードバランスを一時停止すると、［一時停止］ボタンが［再開］ボタンになります。
［再開］をクリックすると、一時停止中のワークロードバランスが再開されます。
レポート
［ワークロードバランスレポート］ダイアログボックスを開きます。ワークロードバランスレポートの使用については、「ワークロードバランスレポート」を参照してください。

［WLB］タブのセクション

［WLB］タブには、以下のセクションが表示されます。

設定
このセクションには、そのリソースプールのワークロードバランスが有効かどうか、およびワークロードバランスサーバーのIPアドレス、最適化モード、スケジュールで指定された最適化モードの次回切り替え日時、ワークロードバランスの自動処理、電源管理などの内容が表示されます。
最適化の推奨項目
このセクションには、リソースプールを最適化するために仮想マシンの再配置が必要な場合に、その内容が推奨項目として表示されます。［履歴を表示］をクリックすると、プールの最適化履歴レポートが生成され、プール内の仮想マシンの移行履歴が表示されます。
すべて実行
ワークロードバランスにより推奨項目が生成されると、［すべて実行］ボタンが使用可能になります。このボタンのクリックにより、［最適化の推奨項目］セクションに表示されているすべての推奨項目が適用されます。このボタンをクリックすると、最適化と再配置の処理が開始され、その進捗を［ログ］タブで確認できます。