XenCenterについて

XenCenterを使用すると、Windows®デスクトップマシンからXenServer環境を管理（仮想マシンの作成、管理、および監視）できます。 以下のトピックを参照してください。

新しいサーバーの追加 | XenServerホストサーバーに接続して、それらを管理対象としてXenCenterに追加します。
共有ストレージの作成 | XenServerストレージリポジトリ（SR）を作成します。ストレージリポジトリは、サーバー間で共有されるストレージを格納します。
新しいプールの作成 | ［新規プール］ウィザードを使用して、共有ストレージを持つリソースプールとしてサーバーをグループ化します。
仮想マシンの作成 | ［新規VM］ウィザードを使用して、新しい仮想マシン（VM）を作成します。
ユーザーの管理 | 役割ベースのアクセス制御（RBAC）機能を使用して、Active Directoryユーザーアカウントを追加して異なるアクセスレベルを割り当てます。

Citrix XenServerとXenCenterのシステム要件については、『XenServerインストールガイド』を参照してください。


XenCenterの起動と終了

XenCenterの起動

XenCenterのセッションを開始するには、次のいずれかを行います。

  • ［スタート］メニューで、［すべてのプログラム］>［Citrix］>［Citrix XenCenter］の順に選択します。
  • デスクトップ上の［Citrix XenCenter］アイコンをダブルクリックします。

XenCenterでサーバー接続を復元するオプションが有効になっていて、マスタパスワードが設定されている場合は、XenCenterセッションの開始時にマスタパスワードを入力するダイアログボックスが開きます。 サーバー接続を復元する機能については、「サーバーの接続状態の保存」を参照してください。

1ユーザーが複数のXenCenterセッションを実行できないことに注意してください。

XenCenterの終了

XenCenterの現在のセッションを終了するには、［ファイル］メニューの［終了］を選択します。

終了時に実行していたすべてのサーバーと仮想マシンは、XenCenterのアプリケーションウィンドウが閉じた後も引き続き稼動します。

仮想マシンのインポートやエクスポートなど、実行中のXenCenterタスクがある場合は、終了しようとすると警告メッセージが表示されます。 この場合、そのまま終了するか、未完了のタスクが完了するまで待機するかを選択できます。タスクの処理中にXenCenterを終了すると、そのタスクが正常に完了しない場合があります。


XenCenterのアンインストール

XenCenterをアンインストールするには、Windowsのコントロールパネルを使用します。

  • Windows XP：コントロールパネルの［プログラムの追加と削除］を開き、一覧から［Citrix XenCenter］を選択して［削除］をクリックします。
  • Windows VistaおよびWindows 7：コントロールパネルの［プログラムと機能］をクリックし、一覧から［Citrix XenCenter］を選択して［アンインストール］をクリックします。

XenCenterアプリケーションをアンインストールしても、XenCenterのユーザー設定データとログファイルは削除されないことに注意してください。 これらのファイルは、以下のフォルダに格納されます。

%appdata%\Citrix\XenCenter


XenServerのライセンスについて

XenServerでは、ほかのCitrix製品と同じライセンス処理が行われます。 このため、Citrixライセンスサーバーとして動作するサーバー上に、XenServer用のライセンスをインストールする必要があります。 Citrixライセンスサーバーのインストールと実行については、Citrix eDocsを参照してください。

XenServerのサポート契約を購入すると、 .LIC ライセンスキーが提供されます。 このライセンスキーを、以下のいずれかのライセンスサーバーにインストールします。

  • Citrixライセンスサーバーソフトウェアが動作するWindowsサーバー
  • LinuxベースのCitrixライセンスサーバー仮想アプライアンス

使用するXenServerのバージョンにより、必要なライセンスが異なります。

  • XenServer 6.2.0のライセンスについては、「ライセンスの概要（XenServer 6.2.0）」を参照してください。
  • XenServer 6.1.0およびそれ以前のバージョンのライセンスについては、「ライセンスの概要（XenServer 6.1.0およびそれ以前）」を参照してください。


ライセンスの概要（XenServer 6.2.0）

注： XenServer 6.1.0またはそれ以前のバージョン0を使用している場合は、「ライセンスの概要（XenServer 6.1.0およびそれ以前）」を参照してください。

インストールした直後のXenServerは、ライセンスが適用されていない状態で動作します。 この状態でも、Hotfixの適用を除き、機能や動作に制限はありません。 ただし、Citrixからのサポートを得るには、XenServerのライセンスが必要です。

XenServerのライセンスは、サーバー上のCPUソケットごとに必要で、プール内のすべてのサーバーに適用する必要があります。 ライセンス済みのサーバーとそうでないサーバーを同一プール内で混在させた場合、ライセンスが適用されていない状態として動作します。 XenServer 6.2.0のライセンスについては、「XenServer 6.2.0でのライセンスの管理」を参照してください。

XenServerエディションのライセンス

XenServerでは、ほかのCitrix製品と同じライセンス処理が行われます。 このため、Citrixライセンスサーバーとして動作するサーバー上に、XenServer用のライセンスをインストールする必要があります。 XenServerのサポート契約を購入すると、 .LIC ライセンスキーが提供されます。 このライセンスキーを、以下のいずれかのライセンスサーバーにインストールします。
  • Citrixライセンスサーバーソフトウェアが動作するWindowsサーバー
  • LinuxベースのCitrixライセンスサーバー仮想アプライアンス
重要： XenServer Per-Socket Edition 6.2を使用するには、CitrixライセンスサーバーがVersion 11.6.1以降である必要があります。

ライセンスの有効期限

XenServer Per-Socket Editionのライセンスの有効期限が切れると、以下のようになります。

  • XenServerがライセンス適用前の状態に戻りますが、すべての機能を使用できます。
  • XenCenterに［期限切れ］と表示されます。
  • XenCenterでHotfixなどの更新ソフトウェアを適用できなくなります。
  • 新しいライセンスを購入するまで、XenServerに関するCitrixのテクニカルサポートを受けることができなくなります。

ライセンスの猶予期間

Citrix V6ライセンスシステムには、タイムアウト機能が組み込まれています。 ライセンスサーバーのハードウェアまたはソフトウェアの問題、ネットワーク障害などの理由でXenServerホストがライセンスサーバーと通信できない場合、30日間の猶予期間に入ります。この期間中、XenServerホストは通常どおり動作します。 XenServerホストがスタートアップライセンスをチェックアウトすると、XenServerとライセンスサーバー間で5分ごとに「ハートビート」メッセージが交換されます。このメッセージにより、両者が正しく動作しており、接続が維持されていることが確認されます。 XenServerまたはライセンスサーバーでこのメッセージの送受信の失敗が検出されると、XenServerがライセンス猶予期間に入り、キャッシュ済みのライセンス情報に基づいて動作するようになります。 この猶予期間は30日間で、これが経過するとXenServerが接続を受け入れなくなります。 XenServerとライセンスサーバーとの通信が再確立されると、猶予期間の残り時間はリセットされます。 XenServerが猶予期間に入るためには、ライセンスサーバーとの接続が少なくとも1回確立されている必要があります。


XenServer 6.2.0でのライセンスの管理

このトピックでは、XenServer Version 6.2.0のライセンスを管理する方法について説明します。 XenServer 6.2.0よりも前のバージョンのライセンスについては、「XenServer 6.1.0およびそれ以前のバージョンでのライセンスの管理」を参照してください。

インストールした直後のXenServerは、ライセンスが適用されていない状態で動作します。 この状態でも、Hotfixの適用を除き、機能や動作に制限はありません。 ただし、Citrixからのサポートを得るには、XenServerのライセンスが必要です。

XenServerのライセンスは、サーバー上のCPUソケットごとに必要で、プール内のすべてのサーバーに適用する必要があります。 ライセンス済みのサーバーとそうでないサーバーを同一プール内で混在させた場合、ライセンスが適用されていない状態として動作します。

XenServerライセンスを割り当てるには

  1. ［ツール］メニューの［ライセンスマネージャ］を選択します。
  2. ライセンスを割り当てるホストまたはプールを選択し、［ライセンスの割り当て］をクリックします。
  3. ［ライセンスの適用］ダイアログボックスで、ライセンスサーバーから割り当てるライセンスの種類を選択します。
    • Citrix XenServer Per-Socket：サーバー上の動作CPUソケットごとにライセンスを適用するには、このオプションを選択します。 このライセンスモデルは、XenServer Version 6.2.0以降の製品で使用します。
    • Citrix XenServer for XenDesktop：既存のCitrix XenServer for XenDesktopライセンスを適用するには、このオプションを選択します。
  4. ライセンスサーバーの詳細を指定して、［OK］をクリックします。
    注： ライセンスサーバーは、デフォルトでポート27000を使用してCitrix製品と通信します。 ライセンスサーバー上でデフォルト以外のポート番号を使用している場合は、［ライセンスサーバー］のポート番号を変更します。 ポート番号の変更手順について詳しくは、Citrix eDocsの「製品ライセンスの有効化 」を参照してください。

XenCenterは、指定されたCitrix V6ライセンスサーバーと通信し、必要なライセンスを要求します。 ライセンスの要求に成功すると、ライセンスがチェックアウトされ、XenCenterのライセンスマネージャの表示が更新されます。 ライセンスサーバーと通信できない場合は、サーバーが30日間のライセンス猶予期間に入ります。

注： ライセンスを要求または適用するときに、XenServerのバージョンおよびライセンスの種類に関する情報がCitrix社に送信される場合があります。 そのほかの情報（システムのユーザーの情報、環境で実行される仮想マシンの情報、XenServer環境の情報など）は収集されません。 ライセンス処理に付随してCitrix社により収集される情報は、Citrix社での個人情報保護ポリシーに基づいて慎重に処理されます。詳しくは、http://www.citrix.com/privacyを参照してください。

無償版からXenServer 6.2.0へのアップグレード

無償版のサーバーやプールをXenServer 6.2.0にアップグレードすると、XenServerの全機能が使用可能になりますが、ライセンスが適用されていない状態で動作します。 この場合、XenCenterにライセンスの状態として［サポートされません］と表示され、XenCenterでHotfixなどの更新ソフトウェアを適用できません。 ライセンスを購入してサーバーやプールに新しいライセンスを割り当てると、ライセンスの状態として［ライセンス済み］と表示され、［ライセンスの種類］に［Citrix XenServer Per-Socket Edition］と表示されます。

Advanced Edition、Enterprise Edition、またはPlatinum EditionからXenServer 6.2.0へのアップグレード

有償版のサーバーやプールをXenServer 6.2.0にアップグレードすると、XenServerの全機能が使用可能になりますが、ライセンスが適用されていない状態で動作します。 この場合、XenCenterにライセンスの状態として［サポートされません］と表示され、XenCenterでHotfixなどの更新ソフトウェアを適用できません。 この場合、以下の手順で新しいライセンスを適用します。

  1. 既存のサーバー単位のライセンスをCPUソケット単位のライセンスに交換します。
  2. 新しいライセンスファイルをライセンスサーバーに追加します。
  3. 既存のサーバーまたはプールに新しいライセンスを適用します。

新しいライセンスを適用すると、ライセンスの状態として［ライセンス済み］と表示され、［ライセンスの種類］に［Citrix XenServer Per-Socket Edition］と表示されます。

XenServerライセンスの割り当てを解除するには

  1. ［ツール］メニューの［ライセンスマネージャ］を選択します。
  2. ホストまたはプールを選択し、［ライセンスの割り当て解除］をクリックします。


ライセンスの概要（XenServer 6.1.0およびそれ以前）

注： XenServer Version 6.2.0を使用している場合は、「ライセンスの概要（XenServer 6.2.0）」を参照してください。

無償のCitrix XenServer Free Editionには、仮想マシンインフラストラクチャの作成に必要なすべての機能が用意されています。 XenServer Free Editionは無償で提供され、業務での使用においても制限や使用期限はありません。ただし、製品を使用する意図があることを示すため、初回インストール後30日以内に製品をアクティブ化する必要があります。 アクティブ化の手続きは簡単で、数分で完了します。 XenServer Free Editionのアクティブ化については、「無償のXenServer製品のアクティブ化」を参照してください。

有償の3つのエディションであるXenServer Advanced Edition、Enterprise Edition、およびPlatinum Editionには、より高度な管理機能や自動化機能が追加されています。 XenServerの各エディションについて詳しくは、ここを参照してください。

Citrixライセンスサーバー

有償のXenServerエディションのライセンスは、Citrixライセンスサーバーにより一元管理されます。ほかのCitrix製品と同様に、Citrixライセンスサーバーで適切なライセンスを割り当てる必要があります。 Citrixライセンスサーバーとして動作する専用のサーバー上にXenServerのライセンスをインストールし、Citrixライセンス管理コンソールを使ってそれを管理します。 つまり、XenServerはほかのCitrix製品と同じライセンスモデルを使用するため、これらのCitrix製品とライセンスサーバーを共有することができます。 Citrix製品のライセンスおよびライセンスサーバーについて詳しくは、オンラインのドキュメントライブラリCitrix eDocsを参照してください。

ライセンスの管理については、「XenServer 6.1.0およびそれ以前のバージョンでのライセンスの管理」を参照してください。

ライセンスの猶予期間

Citrix V6ライセンスシステムには、タイムアウト機能が組み込まれています。 ライセンスサーバーのハードウェアまたはソフトウェアの問題、ネットワーク障害などの理由でXenServerホストがライセンスサーバーと通信できない場合、30日間の猶予期間に入ります。この期間中、XenServerホストは通常どおり動作します。 XenServerホストがスタートアップライセンスをチェックアウトすると、XenServerとライセンスサーバー間で5分ごとに「ハートビート」メッセージが交換されます。このメッセージにより、両者が正しく動作しており、接続が維持されていることが確認されます。 XenServerまたはライセンスサーバーでこのメッセージの送受信の失敗が検出されると、XenServerがライセンス猶予期間に入り、キャッシュ済みのライセンス情報に基づいて動作するようになります。 この猶予期間は30日間で、これが経過するとXenServerが接続を受け入れなくなります。 XenServerとライセンスサーバーとの通信が再確立されると、猶予期間の残り時間はリセットされます。 XenServerが猶予期間に入るためには、ライセンスサーバーとの接続が少なくとも1回確立されている必要があります。

個人情報の保護

無償のCitrix XenServer製品をアクティブ化したり、有償のXenServerエディションのライセンスを入手/適用したりするときに、XenServerのバージョンおよびライセンスの種類に関する情報がCitrix社に送信される場合があります。 そのほかの情報（システムのユーザーの情報、環境で実行される仮想マシンの情報、XenServer環境の情報など）は収集されません。 ライセンス処理に付随してCitrix社により収集される情報は、Citrix社での個人情報保護ポリシーに基づいて慎重に処理されます。詳しくは、http://www.citrix.com/privacyを参照してください。


無償のXenServer製品のアクティブ化

無償のXenServer製品をアクティブ化するには、ホストサーバーにアクティブ化キー（「ライセンスキー」とも呼ばれます）を適用する必要があります。 これを行うには、以下の手順に従います。

  1. まず、Citrixにアクティブ化キーを要求します。 アクティブ化キーファイルlicense.xslicがメールで送信されます。
  2. 無償のXenServer製品のホストサーバーにアクティブ化キーを適用します。

アクティブ化キーを適用するには、Windowsエクスプローラでアクティブ化キーファイルをダブルクリックして適用先のサーバーを選択するか、XenCenterのライセンスマネージャを使用します。

注： 無償のCitrix XenServer製品をアクティブ化するときに、XenServerのバージョンおよびライセンスの種類に関する情報がCitrix社に送信される場合があります。 そのほかの情報（システムのユーザーの情報、環境で実行される仮想マシンの情報、XenServer環境の情報など）は収集されません。 ライセンス処理に付随してCitrix社により収集される情報は、Citrix社での個人情報保護ポリシーに基づいて慎重に処理されます。詳しくは、http://www.citrix.com/privacyを参照してください。

アクティブ化キーを要求するには

  1. ライセンスマネージャを開きます。ライセンスマネージャを開くには、［ツール］メニューの［ライセンスマネージャ］を選択します。
  2. 無償のXenServer製品が動作するサーバーを選択し、［無償のXenServerのアクティブ化］、［アクティブ化キーの取得］の順にクリックします。

    Webブラウザが起動して、XenServerアクティブ化用のCitrix Webページが開きます。このページでは、選択したサーバーのアクティブ化の詳細が記録されます。また、管理者の連絡先やメールアドレスを記入する必要があります。

    Citrix XenServerアクティブ化ページに接続できない場合は、選択したサーバーのアクティブ化情報をファイルに保存することができます。 後でCitrix XenServerアクティブ化ページに接続できるようになったら、このファイルをアクティブ化サーバーにインポートできます。

アクティブ化に必要な情報を入力したら、選択した各XenServer製品のアクティブ化キーファイルが、入力したメールアドレス宛てに送信されます。 下図はその例です。

アクティブ化キーファイルを受信したら、それを各XenServerホストにインストールします。これにより、XenServerホストがアクティブ化されます。

XenCenterでアクティブ化キーを適用するには

まず、XenCenterを実行しているコンピュータからアクティブ化キーファイルにアクセスできることを確認します。また、アクティブ化対象のサーバーをXenCenterに追加しておく必要があります。

  1. ライセンスマネージャを開きます。ライセンスマネージャを開くには、［ツール］メニューの［ライセンスマネージャ］を選択します。
  2. 無償のXenServer製品が動作するサーバーを選択し、［無償のXenServerのアクティブ化］、［アクティブ化キーの適用］の順にクリックします。
  3. アクティブ化キーファイル（license.xslic）を参照し、［開く］をクリックします。

アクティブ化キーファイルでアクティブ化キーを適用するには

  1. Windowsエクスプローラでアクティブ化キーファイル（license.xslic）をダブルクリックします。
  2. ［アクティブ化キーの適用］ダイアログボックスで無償のXenServer製品が動作するサーバーを選択し、［適用］をクリックします。


XenServer 6.1.0およびそれ以前のバージョンでのライセンスの管理

XenServer Advanced、Enterprise、およびPlatinum Editionでは、XenAppなどほかのCitrix製品と同じライセンスモデルが使用されます。このため、Citrixライセンスサーバーとして動作するサーバー上に、各XenServerホスト用のライセンスをインストールする必要があります。 Citrixライセンスサーバーのインストールと実行については、Citrix eDocsを参照してください。

XenServer 6.2.0のライセンスについては、「XenServer 6.2.0でのライセンスの管理」を参照してください。

XenServer Advanced、Enterprise、およびPlatinum Editionのライセンス設定は、XenCenterのライセンスマネージャで行います。［ツール］メニューの［ライセンスマネージャ］を選択します。 ライセンスマネージャでは、以下のライセンス設定を行います。

  • ライセンスの割り当て：XenServerライセンスを特定のサーバーに割り当てます。 XenCenterは、指定された種類のライセンスをCitrixライセンスサーバーに要求し、 割り当て可能なライセンスがある場合はそれをライセンスサーバーからチェックアウトします。
  • ライセンスの割り当て解除：ホストサーバーに割り当てられたXenServerライセンスをリリースします。 これにより、XenCenterがCitrixライセンスサーバーと通信し、ライセンスをチェックインします。

ライセンスは、リソースプール内のすべてのホストサーバーについて個別に割り当てる必要があります。 たとえば、リソースプールで4つのXenServerホストを運用する場合、4つの異なるライセンスを各ホストに割り当てる必要があります。 異なるエディションのXenServerを同一リソースプール内で混在させることもできますが、そのプールで一番低いレベルのライセンスにより、すべてのプールメンバで使用できる機能が決定されることに注意してください。 たとえば、AdvancedレベルのホストとPlatinumレベルのホストが混在するプールでは、Advancedレベルの機能しか使用できません。 このため、プール内の任意のホストでライセンスレベルを下げると、結果的にそのプールで一部の機能が無効になります。

XenServerライセンスを割り当てるには

  1. ライセンスマネージャを開きます。ライセンスマネージャを開くには、［ツール］メニューの［ライセンスマネージャ］を選択します。
  2. 対象のサーバーを選択して、［ライセンスの割り当て］をクリックします。
  3. ［ライセンスの適用］ダイアログボックスで、ライセンスサーバーに要求するライセンスの種類を選択します。
    • Citrix XenServer Advanced Edition：このライセンスでは、高可用性（HA）、仮想マシンの保護と回復（VMPR）、動的メモリ制御、仮想マシンパフォーマンスのリアルタイムアラートおよび履歴レポートなどの機能がXenCenterに追加されます。
    • Citrix XenServer Enterprise Edition：このライセンスでは、Advanced Editionの機能に加えて、ワークロードバランスによる自動処理、および既存のストレージインフラストラクチャとStorageLinkとの統合機能が使用可能になります。
    • Citrix XenServer Platinum Edition：このライセンスでは、プロビジョニングサービスやラボ管理など、XenCenter以外のツールで管理される機能が使用可能になります。 ラボ管理（Lab Management）およびステージ管理（Stage Management）用のライセンスは、Citrix Lab ManagerインストールISOと同様にMyCitrix.comからダウンロードできます。ラボ管理用のライセンスは、Lab Manager管理コンソールを使用して適用します。
    • Citrix XenServer for XenDesktop：既存のCitrix XenServer for XenDesktopライセンスを適用するには、このオプションを選択します。 このライセンスにより、XenServer Enterprise Editionを使ってデスクトップ仮想マシンと、XenDesktopホストやXenAppホストを含むすべてのXenDesktopインフラストラクチャ仮想マシンを運用できるようになります。
  4. ライセンスサーバーの詳細を指定して、［OK］をクリックします。

XenCenterは、指定されたCitrix V6ライセンスサーバーと通信し、必要なライセンスを要求します。 ライセンスの要求に成功すると、ライセンスがチェックアウトされ、XenCenterのライセンスマネージャの表示が更新されます。 ライセンスサーバーと通信できない場合は、サーバーが30日間のライセンス猶予期間に入ります。

注： 無償のCitrix XenServer製品をアクティブ化したり、有償のXenServerエディションのライセンスを入手/適用したりするときに、XenServerのバージョンおよびライセンスの種類に関する情報がCitrix社に送信される場合があります。 そのほかの情報（システムのユーザーの情報、環境で実行される仮想マシンの情報、XenServer環境の情報など）は収集されません。 ライセンス処理に付随してCitrix社により収集される情報は、Citrix社での個人情報保護ポリシーに基づいて慎重に処理されます。詳しくは、http://www.citrix.com/privacyを参照してください。

XenServerライセンスの割り当てを解除するには

  1. ライセンスマネージャを開きます。ライセンスマネージャを開くには、［ツール］メニューの［ライセンスマネージャ］を選択します。
  2. 対象のサーバーを選択して、［ライセンスの割り当て解除］を選択します。


XenCenterワークスペースについて

トピック

  • XenCenterウィンドウの概要
  • ツールバー
  • リソースペイン
  • タブ
  • キーボードショートカットの使用
  • XenCenterの設定の変更
  • 隠しオブジェクト


XenCenterウィンドウの概要

番号 | 名前 | 説明
1 | メニューバー | サーバー、リソースプール、ストレージリポジトリ、仮想マシン、およびテンプレートの管理に必要なすべてのコマンドを実行できます。
2 | ツールバー | 使用頻度の高いメニューコマンドをすばやく実行できます。 「ツールバー」を参照してください。
3 | リソースペイン | XenCenterで管理しているすべてのサーバー、リソースプール、仮想マシン、テンプレート、およびストレージリポジトリが一覧表示されます。 「リソースペイン」を参照してください。
4 | ステータスバー | 実行中のタスクの進行状況が表示されます。
5 | プロパティタブ | 選択したリソースについてのプロパティを表示したり設定したりできます。 「タブ」を参照してください。


ツールバー

XenCenterのツールバーを使用すると、新しいサーバーの追加や新しい仮想マシンの作成など、利用度の高いメニューコマンドにすばやくアクセスできます。

ツールバーの［戻る］ボタンと［進む］ボタン

ツールバーの ［戻る］ボタンと ［進む］ボタンは、Webブラウザの［戻る］ボタンおよび［進む］ボタンのように機能します。これらのボタンをクリックして、リソースの表示をすばやく変更できます。

  • 以前のリソース表示に戻るには、［戻る］をクリックします。
  • ［戻る］をクリックした後で次のリソース表示に移るには、［進む］をクリックします。
  • 現在のセッションで表示したビューのいずれかに移動するには、［戻る］または［進む］の隣の [image] 矢印をクリックして、一覧から表示するビューを選択します。

ツールバーの表示/非表示

ツールバーを非表示にして、たとえば［XenCenter］ウィンドウの［コンソール］タブの表示領域を最大化できます。 ツールバーを非表示にするには、次のいずれかを実行します。

  • ツールバーの任意の場所を右クリックして、ショートカットメニューの［ツールバーを表示］を選択解除します。
  • ［表示］メニューで、［ツールバー］を選択します。

ツールバーの表示/非表示の設定は、XenCenterを終了しても保持されます。

XenCenterのシステムアラート

［XenCenter］ウィンドウ右上のシステムアラート通知領域で、システムアラートが生成されていないかどうかすばやく確認できます。 ここをクリックすると、［システムアラート］ウィンドウが開きます。このウィンドウでは、現在のシステムアラートの全一覧を表示して、アラートに対処することができます。

ツールバーを非表示にしている場合は、［XenCenter］ウィンドウ右上のボタンを使って、システムアラートの件数を確認したり［システムアラート］ウィンドウを開いたりできます。

詳しくは、「XenCenterシステムアラート」を参照してください。


リソースペイン

リソースペインには、管理対象のリソース（サーバー、リソースプール、仮想マシン、およびストレージ）が表示されます。 ここでは、各リソースを物理的な場所に基づいて表示したり（サーバービュー）、フォルダ、タグ、カスタムフィールドなどのプロパティに基づいて表示したり（フォルダビュー）できます。 詳しくは、以下の説明を参照してください。

リソースペイン上部の［検索］ボックスにテキストを入力して、簡易検索を実行できます。 入力した文字を含むリソースがリソースペインに表示されます。 検索クエリを解除してすべてのリソースを表示するには、［検索］ボックス右側の［x］をクリックします。

リソースペインの［ビュー］ボックスでは、保存済みの検索クエリを選択して適用できます。 XenCenterには便利な保存済み検索クエリがいくつか組み込まれています。これらを使用して、ネットワーク、オペレーティングシステム、電源状態、vApp、およびXenServer Toolsのインストール状態などを基にリソースを検索できます。 また、必要に応じて独自の検索クエリを作成して、保存済み検索の一覧に追加できます。詳しくは、「検索クエリの作成」および「保存済みの検索」を参照してください。 保存済みの検索クエリをリソースペインに適用するには、［ビュー］ボックスの一覧で検索クエリを選択します。

サーバービュー – 物理的な場所によるリソース表示

サーバービューに切り替えるには、リソースペイン上部の［ビュー］ボックスの右側にある下向き矢印ボタンをクリックして、［サーバービュー］を選択します。

サーバービューでは、物理および仮想リソースが物理的な場所に基づいて表示されます。 リソースペインでリソースプールのエントリを開くと、そのプールに含まれるすべてのサーバーが表示されます。さらにサーバーを開くと、そのサーバーがホストする仮想マシンおよびストレージが表示されます。

サーバービューでは、ローカルストレージや仮想マシンテンプレート（標準テンプレートおよびカスタムテンプレート）も表示されます。これらのリソースは、必要に応じて非表示に設定できます。 リソースペインのサーバービューをカスタマイズするには、XenCenterの［表示］メニューで［サーバービュー］を選択し、 サブメニューで表示または非表示にする項目を設定します。

フォルダビュー – カテゴリ（フォルダ、タグ、vApp、オブジェクトの種類、およびカスタムフィールド）によるリソース表示

フォルダビューに切り替えるには、リソースペイン上部の［ビュー］ボックスの右側にある下向き矢印ボタンをクリックして、［フォルダビュー］を選択します。

フォルダビューでは、フォルダ、タグ、またはカスタムフィールドを使ってリソースを分類できます。 フォルダビューでのリソースの表示は概念的であり、物理的なものではありません。このため、地理的な設置場所に関係なくリソースをフォルダやタグに移動できます。

フォルダについて詳しくは、「フォルダの使用」を参照してください。


タブ

XenCenterは、ウィンドウを開いたり閉じたりせずに管理対象のリソースにアクセスできるように、いくつかのタブで構成されています。 リソースペインで選択するリソースにより、異なるタブが表示されます。たとえば、［全般］タブはほとんどのリソースで表示され、［高可用性］タブや［WLB］タブはプールを選択したときに表示されます。また、［スナップショット］タブは、仮想マシンを選択したときにのみ表示されます。

［コンソール］タブ

このタブでは、仮想マシンまたはサーバーのコンソールセッションを実行できます。

XenCenterでサポートされる、仮想マシンのリモートコンソールの種類については、「リモートコンソールセッションの実行」を参照してください。

コントロール | 操作
リモートデスクトップに切り替える デフォルトデスクトップに切り替える | Windowsのリモートコンソールの種類を切り替えます。
グラフィックコンソールに切り替える テキストコンソールに切り替える | Linuxのリモートコンソールの種類を切り替えます。 グラフィックコンソールに切り替えるときに、VNCパスワードの入力が求められる場合があります。
Ctrl+Alt+Del の送信 | リモートコンソールにCtrl+Alt+Delキーシーケンスを送信します。 リモートコンソールの使用時には、デフォルトでほとんどのキーボードショートカットがサーバーまたは仮想マシンに送信されます。 ただし、リモートコンソールでCtrl+Alt+Delキーを押しても、ローカルシステムによりこのキーシーケンスが取得されるため、リモートコンソールに送信されません。
切り離す（Alt+Shift+U） | コンソール画面を［コンソール］タブから切り離して、独立した浮動ウィンドウで表示します。 この浮動ウィンドウでサーバーをシャットダウンおよび再起動したり、XenServer Toolsをインストールしたり、仮想マシンを再起動または一時停止したりするには、ウィンドウ左上の [image] をクリックしてコマンドを選択します。 コンソール画面を切り離したり元に戻したりするときのショートカットキーを変更するには、XenCenterの［オプション］ダイアログボックス（［ツール］>［オプション］）を使用します。
コンソールを表示 | コンソールの浮動ウィンドウが最小化されていたり、ほかのウィンドウの背後に隠れていたりするときに、前面に表示します。
元に戻す（Alt+Shift+U） コンソールを固定 | 浮動ウィンドウのコンソール画面を［コンソール］タブに戻します。
ウィンドウに合わせる | コンソール画面を［コンソール］タブや浮動ウィンドウのサイズに合わせて拡大または縮小します。 このチェックボックスをオフにすると、コンソール画面が実際のサイズで表示されます。 XenCenterの［コンソール］タブで使用される画面サイズ設定は、コンソールを切り離すときおよびコンソールの種類を切り替えるとき（VNCコンソールとテキストコンソールの切り替えなど）に保持されます。 このデフォルトの設定を変更するには、［オプション］ダイアログボックスの［コンソール］ページを使用します。
全画面（Ctrl+Enter） | コンソールを全画面モードで表示します。 全画面モードを終了するには、Ctrl+Altキーを押します。この設定を変更する方法については、「XenCenterの設定の変更」を参照してください。 全画面モードでは、画面上部中央に接続バーが表示されます。ここには、実行している仮想マシンまたはサーバーの名前が表示されます。また、［ピン（接続バーを常に表示する）］ボタンをクリックして接続バーを表示したままにしたり、［全画面モードの終了］ボタンをクリックして全画面モードを終了したりできます。

コンソールの設定は、XenCenterの［オプション］ダイアログボックスで行います。 たとえば、ローカルコンピュータのテキストクリップボードがデフォルトでリモートコンソールと共有されるため、切り取ったりコピーしたりした項目をクリップボード経由でローカルコンピュータやリモートコンソールに貼り付けることができます。 クリップボードの共有を無効にしたり、ほかのコンソール設定を変更したりするには、XenCenterの［オプション］ダイアログボックスを使用します。詳しくは、「XenCenterの設定の変更」を参照してください。

［全般］タブ

［全般］タブでは、選択した仮想マシン、サーバー、リソースプール、テンプレート、またはストレージリポジトリの全般的なプロパティを表示します。［プロパティ］をクリックすると、プロパティの設定および変更を行うための［プロパティ］ダイアログボックスが開きます。

このペインに表示される値をWindowsクリップボードにコピーして、テキストエディタなどに貼り付けることができます。値をコピーするには、その値を右クリックして［コピー］を選択します。

［高可用性］タブ

プールの［高可用性］タブでは、以下の操作を行えます。

  • ［高可用性の設定］ボタンを使用して、高可用性を有効にする。
  • ［高可用性の設定］ボタンを使用して、プールの高可用性設定を変更する。
  • 高可用性を無効にする。

高可用性を有効にすると、［高可用性］タブに現在の高可用性の状態（プールの最大許容障害数およびサーバー障害の制限）と、選択したハートビートストレージリポジトリの状態が表示されます。

「高可用性の設定」、「高可用性の無効化」、および「高可用性設定の変更」を参照してください。

［ホーム］タブ

XenCenterの［ホーム］タブでは、ホストサーバーをXenCenterの管理対象として追加したり、XenCenterのヘルプを参照したり、XenServerやほかのCitrix製品に関するWebページを開いたりできます。

［ログ］タブ

［ログ］タブでは、選択したリソースプール、サーバー、または仮想マシンについて、そのXenCenterセッション中に記録されたイベントの概要を確認できます。 タブ上部のチェックボックスを使用して、表示される情報を選択できます。 デフォルトでは、エラー、アラート、アクション、および情報のイベントが表示されます。

［ログ］タブの使用方法とXenCenterのイベントログファイルの表示について詳しくは、「XenCenterのイベントログ」を参照してください。

［メモリ］タブ

［メモリ］タブでは、動的メモリ制御（DMC）を有効にして動的メモリの上限値を設定できます。 仮想マシンには、特定の量のメモリを割り当てたり、動的メモリ制御（DMC：Dynamic Memory Control）が使用されるように設定したりできます。動的メモリ制御では、仮想マシンに割り当てられるメモリの量がサーバーでのメモリ要件に応じて動的に調整されます。このときに仮想マシンを再起動する必要もありません。

「仮想マシンのメモリ設定について」、「動的メモリ制御（DMC：Dynamic Memory Control）」、および「動的メモリ制御（DMC）の設定」を参照してください。

［NIC］タブ

［NIC］タブでは、選択したサーバーの物理ネットワークインターフェイスカード（NIC）の詳細を表示したり、NICボンディングを設定したりします。

NICをボンディング（または「チーミング」）して複数の物理NICを1つのNICのように使用することで、サーバーの耐障害性を向上させることができます。ボンディングしたNICのどちらかに障害が発生した場合、サーバーのネットワークトラフィックは自動的にもう1つのNICにルーティングされます。これにより、サーバーの接続性が保証されます。 「NICの設定」を参照してください。

注： 4つのNICを使用してボンディングを作成するには、ネットワークスタックとしてvSwitchを使用する必要があります。 Linuxブリッジネットワークスタックの場合、ボンディングを構成できるNICは2つまでです。

［パフォーマンス］タブ

［パフォーマンス］タブでは、サーバーや仮想マシンのパフォーマンスデータを表示します。 パフォーマンスに関するすべてのデータを表示するには、仮想マシンにXenServer Toolsをインストールする必要があります。

このタブでは、リソースプールの全体的なパフォーマンス統計値をリアルタイムで監視でき、仮想マシンおよび物理マシンのパフォーマンスの傾向を視覚的に確認することができます。 デフォルトでは、CPU、メモリ、ネットワーク入出力、およびディスク入出力に関するデータが表示されます。 ほかのパフォーマンスデータを追加したり、グラフの形式を変更したりするには、［操作］をクリックします。 詳しくは、「パフォーマンスグラフの設定」を参照してください。

サーバー、仮想マシン、またはストレージリポジトリで、CPU、メモリ使用、ネットワーク使用、ストレージスループット、または仮想マシンのディスク使用が特定のしきい値を超過した場合に、アラートが生成されるように設定できます。 詳しくは、「パフォーマンスアラートの設定」を参照してください。

［検索］タブ

詳細な条件を指定してリソースを検索するには、リソースペインでプールまたはサーバーを選択し、［検索］タブをクリックします。 このタブでは、オブジェクトの種類、フォルダ、および属性（名前、説明、タグ、高可用性の状態または再起動優先度、電源の状態など）に基づいて検索条件を定義できます。

「検索クエリの作成」、「検索結果のフィルタやグループ化」、「保存済みの検索」、および「検索のエクスポートとインポート」を参照してください。

［スナップショット］タブ

［スナップショット］タブでは、スナップショットを作成、削除、またはエクスポートしたり、仮想マシンを特定のスナップショットの状態に復元したり、既存のスナップショットから仮想マシンやテンプレートを作成したりできます。

「仮想マシンスナップショット」を参照してください。

［ストレージ］タブ

［ストレージ］タブでは、選択した仮想マシン、サーバー、リソースプール、またはストレージリポジトリに関する情報を表示します。 このタブに表示される設定は、リソースペインで現在選択しているリソースの種類によって異なります。

選択したリソース | ［ストレージ］タブに表示される項目 | 参照先
仮想マシンおよびテンプレート | 仮想マシンの各仮想ディスクに関する情報が表示されます。サイズ、場所（その仮想ディスクを格納しているストレージリポジトリ）、データアクセスの状態、およびディスクアクセスの優先度が含まれます。 仮想ディスクの設定を編集するには、一覧でディスクを選択して［プロパティ］をクリックします。 新しいディスクを追加するには［追加］をクリックし、既存のディスクを接続するには［接続］をクリックします。 | 仮想ストレージの設定
サーバーおよびプール | 使用できるストレージリポジトリの一覧が表示されます。種類、サイズ、空き容量、および共有状態の概要が含まれます。 ストレージリポジトリの名前または説明を変更するには、一覧でストレージリポジトリを右クリックして［プロパティ］を選択します。 ストレージリポジトリを追加するには［新規SR］をクリックし、ストレージデバイスの接続を解除するには一覧でストレージリポジトリを右クリックして［接続解除］をクリックします。 | ストレージリポジトリ（SR）の管理
ストレージリポジトリ | 選択したストレージリポジトリ上の仮想ディスクまたはISOの一覧が表示されます。 新しい仮想ディスクを追加するには［追加］をクリックします。 | 仮想ディスクの追加

［タグ］タブ

［タグ］タブは、リソースペインで最上位レベルの［XenCenter］を選択すると表示されます。このタブでは、リソースに適用されているすべてのタグがタグクラウドとして表示されます。使用回数の多いタグはクラウド内で大きく表示されます。 タグクラウドでタグをクリックすると、そのタグが適用されているすべてのリソースが［検索］タブに表示されます。

「タグの使用」を参照してください。

［ユーザー］タブ

［ユーザー］タブでは、役割ベースのアクセス制御（RBAC）機能を使用して、Active Directoryのユーザーおよびグループアカウントに役割ベースのアクセスを設定します。 ここでは、プールやサーバーをActive Directoryドメインに追加したり、Active Directoryのユーザーまたはグループをプールに追加したり、ユーザーおよびグループに役割を割り当てたりできます。

「ユーザーの管理」を参照してください。

［WLB］タブ

［WLB］タブでは、ワークロードバランスの主要な機能（設定、最適化の推奨項目、状態など）にアクセスできます。

重要： ワークロードバランス機能（WLB）は、XenServer Version 6.2およびこれ以降のバージョンでは削除されています。 WLBの機能を使用するアプリケーションやコードなどは、XenServer Version 6.2およびこれ以降のバージョンでは使用できません。 詳しくは、CTX137333を参照してください。


リソースの状態アイコン

XenCenterのリソースペインなどでは、サーバー（ホスト）、仮想マシン、ストレージ、およびテンプレートの状態がアイコンで示されます。

サーバー

XenCenterで接続済みで、正常に実行されています。
再起動中または一時停止処理中など、一時的に接続できない状態です。
シャットダウンしたサーバーなど、切断された状態です。
保守モードです。 「保守モードでの実行」を参照してください。
システム障害が発生し、クラッシュダンプファイルが生成されています。 クラッシュダンプファイルは、サーバーの/varディレクトリのcrashフォルダに生成されます。 クラッシュダンプファイルは、サポート担当者がXenServer関連の問題を診断するときの手がかりになる貴重な情報を提供します。XenCenterの［サーバーの状態レポートの作成］ユーティリティを使用すると、クラッシュダンプファイルの内容を含んだ状態レポートを作成できます。 この機能について詳しくは、「サーバーの状態レポートの作成」を参照してください。

サーバーの/varディレクトリからクラッシュダンプファイルを削除すると、XenCenterに表示されるサーバーの状態が通常に戻ります。
適用可能なアップデートがあります。 「サーバーのアップデート」を参照してください。
プールマスタより古いバージョンのXenServerが実行されています。 「サーバーのアップデート」を参照してください。

仮想マシン、仮想マシンテンプレート、およびvApp

正常に実行されている仮想マシンです。
一時停止状態の仮想マシンです。
再起動中または一時停止処理中など、一時的に使用できない状態の仮想マシンです。
実行されていない仮想マシンです（シャットダウンした仮想マシンなど）。
移行中の仮想マシンです。 「仮想マシンの移行」を参照してください。
XenServer仮想マシンテンプレートです。
カスタムの（ユーザー定義の）仮想マシンテンプレートです。
XenServer vAppです。 「vAppの管理」を参照してください。

仮想マシンスナップショット

ディスクのみの仮想マシンスナップショットです。
スケジュールで作成されたディスクのみの仮想マシンスナップショットです。
ディスクとメモリの仮想マシンスナップショットです。
スケジュールで作成されたディスクとメモリの仮想マシンスナップショットです。

ストレージ

ストレージリポジトリです。
リソースプールのデフォルトストレージリポジトリです。
接続されていないストレージリポジトリです。
現在使用できない状態のストレージリポジトリです。 「ストレージリポジトリの接続の問題を解決する」を参照してください。
アップグレードが必要なストレージリポジトリです。 「ストレージリポジトリのアップグレード」を参照してください。
仮想ディスクです。
仮想ディスクのスナップショットです。 これは仮想マシンのディスクのスナップショットで、仮想マシンのスナップショットと一緒に作成されます。 仮想マシンのスナップショットについては、「仮想マシンスナップショット」を参照してください。また、ディスクのスナップショットについては、『XenServer管理者ガイド』を参照してください。


キーボードショートカットの使用

XenCenter内を移動したりタスクを実行したりするために、マウスの代わりにキーボードを使用できます。 たとえば、矢印キーを使用して、リソースペインとメニューの項目間を移動できます。

メニューの操作

メニューモードのオン/オフを切り替えるには、F10キーかAltキーを押します。メニューモードでは、キーボードを使用してメニューを操作できます。

→、

←

 メニューバー内を移動し、順次、各メニューを選択します。
↑、

↓

 順次、各メニューコマンドを選択します。
Enter | 選択したコマンドを実行します。
Esc | 選択したコマンドをキャンセルし、メニューを閉じます。
下線付きの文字（アクセスキー） 下線付きの文字を使用して、特定のメニューおよびメニューコマンドを選択できます。

たとえば、仮想マシンをコピーするには、AltキーまたはF10キーを押してから、Mキー、次にCキーを押すと、［VM］メニューの［VMのコピー］が選択されます。

Windowsのバージョンによっては、F10キーまたはAltキーを押すまでアクセスキーの下線が表示されません。 アクセスキーの下線が常に表示されるようにするには、次の操作を行います。

  • Windows XPでは、コントロールパネルで［画面］をダブルクリックし、次に［デザイン］タブをクリックします。 ［効果］をクリックして、［Altキーを押さないときはキーボードナビゲーションの下線を表示しない］チェックボックスをオフにします。
  • Windows VistaおよびWindows 7では、コントロールパネルで［コンピュータの簡単操作］をクリックし、次に［コンピュータの簡単操作センター］の［キーボードの動作の変更］をクリックします。オプションページの下部までスクロールし、［ショートカットキーを使いやすくします］の［ショートカットキーとアクセスキーに下線を表示します］チェックボックスをオンにします。
ショートカットキー | ショートカットキーの組み合わせを使用して、特定のメニューコマンドを実行できます。

ショートカットキーの使用

マウスの代わりにキーボードでショートカットキーを使用すると、タスクを迅速に実行できます。 たとえば、Ctrl+Nキーを押すと［新規VM］ウィザードが開きます。これは、［VM］メニューの［新規VM］を選択した場合と同様です。 一部のショートカットキーはメニューとツールバーのツールチップに表示されます。 数字キーパッドのキーを使用する場合は、NumLockがオフになっていることを確認してください。

F1 | オンラインヘルプを表示します。
Alt+F4 | XenCenterを終了して［XenCenter］ウィンドウを閉じます。
Ctrl+Alt | コンソールの全画面モードと標準画面モードを切り替えます。
Ctrl+B | 選択した仮想マシンを起動します。
Ctrl+C | 選択したテキストをWindowsクリップボードにコピーします。
Ctrl+E | 選択した仮想マシンをシャットダウンします。
Ctrl+N | ［新規VM］ウィザードを開きます。
Ctrl+R | 選択した仮想マシンを再起動します。
Ctrl+V | Windowsクリップボードにコピーしたテキストを貼り付けます。
Ctrl+X | 選択したテキストを切り取り、Windowsクリップボードにコピーします。
Ctrl+Y | 選択した仮想マシンを一時停止または再開します。
Ctrl+Z | 最後のテキスト編集操作を元に戻します。


XenCenterの設定の変更

XenCenterの作業環境に影響を与えるさまざまな設定を変更できます。 ［ツール］メニューの［オプション］を選択し、ダイアログボックスの各ページで必要に応じて設定を変更します。変更を保存するには、［OK］をクリックします。

セキュリティ

オプション | 説明 | デフォルト値
新しいSSL証明書が検出されたら警告する | このチェックボックスをオンにすると、管理対象サーバー上で新しいSSL（Secure Sockets Layer）セキュリティ証明書が見つかったときに、XenCenterに警告メッセージが表示されます。 管理対象サーバーに接続するときに見つかる新しい証明書について、警告メッセージを表示したくない場合はこのチェックボックスをオフにします。 | オフ
SSL証明書が変更されたら警告する | 管理対象サーバーに接続するときに見つかる変更された証明書について、警告メッセージを表示したくない場合はこのチェックボックスをオフにします。 このチェックボックスをオンにすると、管理対象サーバー上で変更された証明書が見つかったときに、XenCenterに警告メッセージが表示されます。 | オン

参照先：サーバーの接続と切断

アップデート

オプション | 説明 | デフォルト値
XenServerの新しいバージョンを確認する | このチェックボックスをオンにすると、XenCenterで新しいバージョンのXenServerが使用できるかどうかを定期的に確認し、ダウンロードできるようになったときにメッセージが表示されます。 定期的な確認を無効にするには、このチェックボックスをオフにします。 | オフ
XenServerのアップデートを確認する | このチェックボックスをオンにすると、XenCenterでXenServerのアップデートが使用できるかどうかを定期的に確認し、ダウンロードできるようになったときにメッセージが表示されます。 定期的な確認を無効にするには、このチェックボックスをオフにします。 | オン
XenCenterの新しいバージョンを確認する | このチェックボックスをオンにすると、XenCenterで新しいバージョンのXenCenterが使用できるかどうかを定期的に確認し、ダウンロードできるようになったときにメッセージが表示されます。 定期的な確認を無効にするには、このチェックボックスをオフにします。 | オン

参照先：ソフトウェアのアップデートとアップグレードについて、サーバーのアップデート、XenCenterのアップデート

グラフ

オプション | 説明
面グラフ | このオプションをクリックすると、［パフォーマンス］タブのパフォーマンスデータが面グラフで表示されます。 下図はその例です。
折れ線グラフ | このオプションをクリックすると、［パフォーマンス］タブのパフォーマンスデータが折れ線グラフで表示されます。 下図はその例です。
参照先：システムパフォーマンスの監視

コンソール

オプション | 説明 | デフォルト値
クリップボードのデータをリモートコンソールと共有する | このチェックボックスをオンにすると、ローカルコンピュータのテキストクリップボードの内容をリモートコンソールで共有できます。 切り取ったりコピーしたりした項目をクリップボードに入れ、ローカルコンピュータやリモートコンソールに貼り付けることができます。 | オン
全画面モード | コンソールの全画面モードと標準画面モードを切り替えるためのキーボードショートカットです。 | Ctrl+Enter
固定/切り離し | ［コンソール］タブ上のコンソール画面を［XenCenter］ウィンドウから切り離したり固定したりするためのキーボードショートカットです。 | Alt+Shift+U
キーボードとマウスのリリース | ユーザーのキーボードやマウスからの入力を仮想マシン上のオペレーティングシステムが認識すると、それらの入力はすべて仮想マシン（ゲストオペレーティングシステム）に対して送信されます。 XenCenterでは、ショートカットキーを使用して、キーボードやマウスからの入力をホストオペレーティングシステムに切り替えることができます。このショートカットキーをホストキーと呼びます。 デフォルトのホストキーは、キーボード右側のCtrlキーです。 ここでは、ほかのキーを割り当てることができます。 | 右Ctrl
ウィンドウを切り離しても表示比率を保持する | このチェックボックスをオンにすると、コンソールを固定したり切り離したりするときに［ウィンドウに合わせる］の設定が保持されます。 | オン
デフォルトコンソールに切り替えても画面サイズを保持する | このチェックボックスをオンにすると、コンソールの種類を切り替えるとき（VNCコンソールとテキストコンソールの切り替えなど）に［ウィンドウに合わせる］の設定が保持されます。 | オン
Windowsのキーの組み合わせをリモートデスクトップコンソールに送る | このチェックボックスをオンにすると、キーボードで入力したWindowsのキーの組み合わせがXenCenterからリモートデスクトップコンソールに送信されます。 | オン
リモートデスクトップコンソールのサウンドを再生する | このチェックボックスをオンにすると、リモートデスクトップコンソールで実行中のアプリケーションのサウンドが、XenCenterが動作するローカルコンピュータ上で再生されます。 | オン
リモートデスクトップコンソールに自動的に切り替える | このチェックボックスをオンにすると、リモートデスクトップコンソールを使用できるときは、自動的に標準のグラフィックコンソールからリモートデスクトップコンソールに切り替わります。 | オン
サーバーのコンソール セッションに直接接続する | このチェックボックスをオンにすると、XenCenterでリモートデスクトップコンソールセッションを開くとき、新しい仮想コンソールセッションを作成する代わりに、リモートサーバー上の既存のコンソールセッションに接続します。 | オン
リモートデスクトップコンソールのスキャンを有効にする | このチェックボックスをオンにすると、XenCenterでRDP接続が検索されます。 ファイアウォールでRDPトラフィックを遮断している環境などでは、このチェックボックスをオフにします。これにより、RDPポートがスキャン（ポーリング）されなくなります。 このチェックボックスをオンにすると、［リモートデスクトップコンソールに自動的に切り替える］チェックボックスがオフの場合でも、XenCenterでRDPポートがスキャンされます。このため、RDP接続が可能になり次第、すぐに切り替えることができます。 | オン

Windowsリモートデスクトップコンソールの設定に加えた変更は、XenCenterを再起動すると有効になります。

参照先：リモートコンソールセッションの実行

接続

オプション | 説明 | デフォルト値
プロキシサーバー XenCenterでは、管理対象サーバーに直接接続したり、プロキシサーバーを介して接続したりできます。 プロキシサーバーを使用する場合は、Internet Explorerのプロキシサーバーの設定を使用したり、独自のプロキシサーバーを指定したりできます。
  • プロキシサーバーを使用せず、管理対象サーバーに直接接続するには、［プロキシサーバーを使用しない］をクリックします。
  • Internet Explorerと同じプロキシ設定を使用するには、［Internet Explorerのプロキシサーバー設定を適用する］をクリックします。
  • 特定のプロキシサーバーに接続して、HTTP CONNECTを使用してサーバーへの安全なSSLトンネルを確立するには、［以下のプロキシサーバーを使用する］をクリックします。 さらに、使用するプロキシサーバーのアドレスとポートを入力します。

［ローカルアドレスにはプロキシサーバーを使用しない］チェックボックスをオンにすると、ローカルリソースに接続する場合はプロキシサーバーを使用せずに直接接続されます。 すべてのリソースにプロキシサーバーを経由して接続するには、このチェックボックスをオフにします。

ローカルアドレスとはLANまたはイントラネット上のアドレスのことで、http://webserver/やhttp://localhost/のように、URIにピリオド（.）が含まれません。

 プロキシサーバーを使用しない
接続タイムアウト | 接続タイムアウトの待機時間を秒単位で調節して、管理対象サーバーに接続を試行するときの待機時間を指定できます。 この値を小さくしすぎると、ネットワーク関連の問題により待機時間が長くなったときに、誤ったアラートを大量に受信することになります。 | 20秒

参照先：サーバーの接続と切断

保存と復元

ここでは、各サーバーへの資格情報を保存しておき、XenCenterセッションの開始時にそれらのサーバーとの接続を自動的に復元するかどうかを設定します。 また、マスタパスワードを設定して、資格情報を保護することもできます。

オプション | 説明 | デフォルト値
接続状態を保存してセッション開始時に復元する | すべての管理対象サーバーの資格情報（ユーザー名とパスワード）をXenCenterセッションの終了後も保持して、次回以降のXenCenterセッション開始時に自動的に再接続できます。 このチェックボックスをオンにすると、各セッションの終了時にすべての管理対象サーバーの接続状態がXenCenterに保存され、次のセッションの開始時に接続の復元が試行されます。 | オフ
マスタパスワードを要求する | ［接続状態を保存してセッション開始時に復元する］チェックボックスをオンにした場合、保存した資格情報を保護するためのマスタパスワードを設定できます。各セッションの開始時にこのマスタパスワードを入力すると、管理対象サーバーへの接続が復元されます。 | オフ
マスタパスワードの変更 | マスタパスワードを変更するには、このボタンをクリックします。現在のマスタパスワードを入力し、新しいパスワードを入力および確認入力します。 |

プラグイン

XenCenterにオプションのプラグインを追加して、機能を拡張することができます。 プラグインを使用すると、XenCenterのメインウィンドウにカスタムのメニューやタブを追加できます。 たとえば、自社製品をXenCenterに統合する、または組織で使用している既存のインベントリ管理システムに統合するなどの目的でプラグインを開発できます。 メニュー項目では、クライアントマシン上のMicrosoft PowerShellスクリプトや任意の実行可能ファイルを実行できます。 タブはWebページとして作成され、ネットワークや仮想マシン上のサービスと一緒に動作させることができます。

オプション | 説明 | デフォルト値
プラグインのコンポーネント XenCenterのプラグインは、以下のコンポーネントで構成されます。
  • XML設定ファイル。
  • 各ロケールに対応したリソースDLL。
  • アプリケーションおよび必要なリソース。

プラグインのコンポーネントは、XenCenterのインストール先フォルダのpluginsサブフォルダ内に保存されている必要があります。 このサブフォルダ内のコンポーネントは、XenCenterの起動時にロードされます。 XenCenterのデフォルトでは、以下の場所にプラグインを配置します。

C:\Program
Files\Citrix\XenCenter\plugins
\<your_organization_name>\<your_plugin_name>
 オフ
使用可能なプラグインの表示 | XenCenterで使用可能なプラグインの一覧を表示したり、各プラグインの有効/無効を切り替えたりするには、［ツール］メニューから［オプション］を選択して ［オプション］ダイアログボックスを開き、 このダイアログボックスの左側で［プラグイン］をクリックします。 | オン
プラグインの作成 | XenCenterのプラグインの開発について詳しくは、CitrixのWebページの「XenCenter Plugins」を参照してください。 XenCenterからこのページにアクセスするには、［ヘルプ］メニューから［XenCenterプラグインオンライン］を選択します。


隠しオブジェクト

ネットワーク、物理ネットワークインターフェイス、および仮想マシンは、そのオブジェクトのXenServer APIパラメータother_configにHideFromXenCenter=trueキーを追加することで、XenCenterで非表示にすることができます。 たとえば、一般のユーザーが直接使用すべきでない仮想マシンがXenCenterに表示されないように設定できます。 このキーを追加したオブジェクトは隠しオブジェクトになり、XenCenterに表示されなくなります。

XenCenterで隠しオブジェクトを表示するには、［表示］メニューで［隠しオブジェクト］を選択します。 隠しオブジェクトを非表示にするには、［表示］メニューで［隠しオブジェクト］を選択解除します。

HideFromXenCenterキーによるオブジェクトのフラグ付けについて詳しくは、『XenServerソフトウェア開発キットガイド』を参照してください。


リソースのフォルダビュー

XenCenterには、物理および仮想リソースを整理するためのいくつかの方法が用意されており、目的に応じて選択できます。
  • フォルダの使用
  • タグの使用
  • カスタムフィールドの使用


フォルダの使用

リソースペインでは、2種類の表示形式（ビュー）を使用できます。

  • ［サーバービュー］では、すべてのリソースがリソースプール、サーバーの順に階層的に一覧表示されます。
  • ［フォルダビュー］では、物理および仮想リソースが、フォルダ、リソースの種類、タグ、およびカスタムフィールドごとに分類されて表示されます。 このビューでは、リソースをドラッグしてフォルダに追加したりタグ付けしたりできます。

サーバービューとフォルダビューを切り替えるには、リソースペイン上部の［ビュー］ボックスの右側にある下向き矢印ボタンをクリックして、［フォルダビュー］または［サーバービュー］を選択します。

フォルダビューの使用

XenServer環境で管理しているすべてのリソースは、必要に応じてフォルダで自由にグループ化して管理できます。たとえば、各支社用のフォルダを作成して、リソースを分類することができます。 フォルダには、XenServer環境の任意の場所にあるあらゆる種類のリソースを追加できます。 リソースをフォルダで分類しても、個々のリソースは、そのリソースを含んでいるフォルダに関係なく個別にアクセスできます。

XenCenterで作成するフォルダは概念的であり、物理的なものではありません。つまり、フォルダに追加したリソースはそのフォルダ内に物理的に移動するのではなく、地理的な設置場所に関係なくリソースをフォルダ分けできます。 たとえば、仮想マシンをフォルダに追加しても、その仮想マシンのホストサーバーが自動的に同じフォルダに追加されるわけではありません。同様に、サーバーをフォルダに追加しても、そのサーバー上のすべての仮想マシンやストレージリポジトリが同じフォルダに追加されるわけではありません。

フォルダビューでは、タグやカスタムフィールドをリソースに簡単に追加できます。リソースに既存のタグを追加するには、リソースを選択し、［タグ］グループの目的のタグまでドラッグします。 同様に、リソースに既存のカスタムフィールドを追加するには、リソースを選択し、［カスタムフィールド］グループの目的のカスタムフィールドの値までドラッグします。 フォルダビューでは、ネットワークおよび仮想ディスクを選択することはできません。このため、これらのリソースにタグやカスタムフィールドを追加するには、［全般］タブを使用します。詳しくは、「タグの使用」および「カスタムフィールドの使用」を参照してください。

リソースを検索するときに、フォルダを条件として指定することもできます。たとえば、特定のフォルダに含まれているリソース、特定のフォルダまたはそのサブフォルダに含まれているリソース、またはいずれのフォルダにも含まれていないリソースを検索できます。 「検索クエリの作成」を参照してください。

リソースがいずれかのフォルダに含まれている場合、そのリソースの［全般］タブと［プロパティ］ダイアログボックスで、どのフォルダに含まれているのかを確認できます。 また、ほかのフォルダに移動したり、所属フォルダを［<なし>］に変更したりできます。

新しいフォルダを作成するには

リソースペインで新しいフォルダを作成するには、フォルダビューで［フォルダ］グループを右クリックして［新規フォルダ］を選択します。 フォルダの名前を入力し、フォルダメタデータの格納先サーバーを選択して、［作成］をクリックします。

各リソースの［全般］タブでフォルダを作成することもできます。

  1. リソースペインでプール、サーバー、ストレージリポジトリ、仮想マシン、またはテンプレートを選択し、［全般］タブの［プロパティ］をクリックします。
  2. ［プロパティ］ダイアログボックスの［全般］ページで、［フォルダ］ボックスの［変更］をクリックします。
  3. ［フォルダの変更］ダイアログボックスで、［新規フォルダ］をクリックします。
  4. フォルダの名前を入力し、フォルダメタデータの格納先サーバーを選択して、［作成］をクリックします。
  5. ［移動］をクリックすると、リソースが移動し、［フォルダの変更］ダイアログボックスが閉じます。

リソースをフォルダに移動したりフォルダから削除したりするには

リソースをフォルダに移動する最も簡単な方法は、リソースペインまたは［検索］タブでそのリソースを選択し、リソースペインの既存のフォルダにドラッグします。 1つのリソースが複数のフォルダに属することはありません。このため、ほかのフォルダにリソースを追加した場合、それまで属していたフォルダからそのリソースは削除されます。

［全般］タブでは、リソースをほかのフォルダに移動したり、いずれのフォルダにも含まれないように変更したりすることもできます。

  1. リソースペインでプール、サーバー、ストレージリポジトリ、仮想マシン、またはテンプレートを選択し、［全般］タブの［プロパティ］をクリックします。
  2. ［プロパティ］ダイアログボックスの［全般］ページで、［フォルダ］ボックスの［変更］をクリックします。
  3. リソースがいずれのフォルダにも含まれないように変更するには、［フォルダに含めない］をクリックします。
  4. リソースをほかのフォルダに移動するには、［以下のフォルダに移動］をクリックして、一覧から移動先のフォルダまたはサブフォルダを選択します。
  5. リソースを新しいフォルダに移動するには、［新規フォルダ］をクリックします。フォルダの名前を入力し、フォルダメタデータの格納先サーバーを選択して、［作成］をクリックします。
  6. ［移動］をクリックすると、リソースが移動し、［フォルダの変更］ダイアログボックスが閉じます。

フォルダの名前を変更するには

  1. フォルダビューでフォルダを右クリックし、ショートカットメニューの［フォルダの名前変更］を選択します。
  2. 新しい名前を入力します。

フォルダを削除するには

フォルダを削除しても、そのフォルダに含まれるリソースは削除されません。削除したフォルダ内のリソースは、いずれのフォルダにも含まれなくなります。

  1. フォルダビューでフォルダを右クリックし、ショートカットメニューの［フォルダの削除］を選択します。
  2. 確認のメッセージが表示されるので、［はい］をクリックします。
選択したフォルダ内のリソースはフォルダ外に移動され、フォルダが削除されます。


タグの使用

リソースにタグを追加すると、それを基にリソースを分類したり検索したりできます。 XenCenterで追加するタグはそのリソースに関連付けるキーワードまたはラベルであり、XenCenterでのリソース表示をアプリケーション、設置場所、コストセンター、所有者、ライフサイクルの状態など、目的に応じて分類して表示できます。

必要に応じてさまざまなタグを作成でき、数に制限はありません。タグを作成してリソースに関連付けたら、それらを指定してリソースを検索できます。たとえば、札幌支社に配置されているすべてのWindows 7テスト仮想マシンを検索できるようにタグを設定できます。

現在リソースに適用されているタグを表示する、または新しいタグを追加するには、そのリソースの［全般］タブをクリックします。

新しいタグを作成するには

  1. リソースペインでリソースを選択して、［全般］タブの［プロパティ］をクリックします。
  2. ［プロパティ］ダイアログボックスの［全般］ページで、［タグの編集］をクリックします。
  3. ［タグの編集］ダイアログボックスの［新規タグ］ボックスにタグを入力して、［作成］をクリックします。
  4. タグが作成され、選択したリソースに自動的に適用されます。 タグの適用を解除するには、［タグの編集］ダイアログボックスでそのタグのチェックボックスをオフにします。
  5. ［OK］をクリックして変更を適用し、［タグの編集］ダイアログボックスを閉じます。

タグを削除するには

  1. リソースペインをフォルダビューに切り替えます。
  2. ［タグ］グループを展開します。
  3. 削除するタグを右クリックして、［タグの削除］を選択します。
タグが削除され、そのタグが適用されていたすべてのリソースから、そのタグの適用が解除されます。

リソースにタグを付けるには

リソースに既存のタグを追加するには、フォルダビューのリソースペインでリソースを選択し、目的のタグまでドラッグします。 また、［検索］タブの検索結果をフォルダビューのリソースペインにドラッグすることもできます。

既存のタグの適用や新しいタグの作成は、［タグの編集］ダイアログボックスからも行えます。

  1. リソースペインで、タグを付けるプール、サーバー、ストレージリポジトリ、仮想マシン、またはテンプレートを選択して、［全般］タブの［プロパティ］をクリックします。
  2. ［プロパティ］ダイアログボックスの［全般］ページで、［タグの編集］をクリックします。
    • 選択したリソースに新しいタグを適用するには、［タグの編集］ダイアログボックスの［新規タグ］ボックスにタグを入力して、［作成］をクリックします。
    • 選択したリソースに既存のタグを適用するには、［タグの編集］ダイアログボックスの一覧でそのタグのチェックボックスをオンにします。
  3. ［OK］をクリックして変更を適用し、［タグの編集］ダイアログボックスを閉じます。

リソースのタグ付けを解除するには

リソースに適用したタグを解除（削除）するには、フォルダビューのリソースペインでそのリソースを右クリックして、［オブジェクトのタグ解除］を選択します。

タグ付けの解除は、［タグの編集］ダイアログボックスからも行えます。

  1. リソースペインで、タグ付けを解除するプール、サーバー、ストレージリポジトリ、仮想マシン、またはテンプレートを選択して、［全般］タブの［プロパティ］をクリックします。
  2. ［プロパティ］ダイアログボックスの［全般］ページで、［タグの編集］をクリックします。
  3. ［タグの編集］ダイアログボックスの一覧で、そのタグのチェックボックスをオフにします。
  4. ［OK］をクリックして変更を適用し、［タグの編集］ダイアログボックスを閉じます。

タグクラウドを表示するには

割り当て済みのすべてのタグをタグクラウドとして表示できます。使用回数の多いタグはクラウド内で大きく表示されます。 下図はその例です。

XenCenterのタグクラウドを表示するには、リソースペインで最上位の［XenCenter］を選択して［タグ］タブをクリックします。

タグクラウド内のタグをクリックすると、そのタグが割り当てられているすべてのリソースの一覧が［検索］タブに表示されます。


カスタムフィールドの使用

リソースにカスタムフィールドを定義すると、構造的な情報を追加して、リソースを効率的に検索したり管理したりできます。

たとえば、すべてのサーバーに設置場所の情報を追加したり、コストセンターごとにラベル付けしたり、インストール済みアプリケーションの情報を仮想マシンに追加したりできます。 これを行うには、サーバー、仮想マシン、またはリソースプール内のそのほかのリソースにカスタムフィールドを追加して、適切な値を入力します。 これらのカスタムフィールドの値を使って、検索クエリを作成することもできます。

カスタムフィールドは、プールレベルで共有されます。 つまり、プール内の任意のリソースに追加したカスタムフィールドは、そのプール内のすべてのリソースで使用可能になり、［全般］タブやリソースの［プロパティ］ダイアログボックス（［カスタムフィールド］ページ）に表示されます。

新しいカスタムフィールドを作成するには

  1. リソースを選択し、［全般］タブの［プロパティ］をクリックして［プロパティ］ダイアログボックスを開きます。
  2. ［プロパティ］ダイアログボックスの［カスタムフィールド］ページで、［カスタムフィールドの編集］をクリックします。
  3. ［追加］をクリックして、名前を入力して種類を選択してから［OK］をクリックします。

既存のカスタムフィールドに値を入力するには

  1. リソースを選択し、［全般］タブの［プロパティ］をクリックして［プロパティ］ダイアログボックスを開きます。
  2. ［プロパティ］ダイアログボックスの［カスタムフィールド］ページで、必要な値を入力します。
  3. ［OK］をクリックします。
カスタムフィールドに入力した値は、そのリソースの［全般］タブに表示されます。

カスタムフィールドを削除するには

  1. リソースを選択し、［全般］タブの［プロパティ］をクリックして［プロパティ］ダイアログボックスを開きます。
  2. ［プロパティ］ダイアログボックスの［カスタムフィールド］ページで、［カスタムフィールドの編集］をクリックします。
  3. 削除するカスタムフィールドを選択して、［削除］をクリックします。


リソースの検索

詳細な条件を指定してリソースを検索するには、リソースペインでプールまたはサーバーを選択し、［検索］タブをクリックします。

リソースペイン上部の［検索］ボックスにテキストを入力して、簡易検索を実行することもできます。 入力した文字を含むリソースがリソースペインに表示されます。 検索クエリを解除してすべてのリソースを表示するには、［検索］ボックス右側の［x］をクリックします。
  • 検索クエリの作成
  • 検索結果のフィルタやグループ化
  • 検索のエクスポートとインポート
  • 保存済みの検索


検索クエリの作成

［検索］タブでは、オブジェクトの種類、フォルダ、および属性（名前、説明、タグ、高可用性の状態または再起動優先度、および電源の状態）に基づいて検索クエリを定義できます。

  • ［検索］タブの検索結果をダブルクリックすると、そのリソースの［全般］タブが開きます。
  • 検索されたリソースを簡単にフォルダに追加することもできます。リソースペインをフォルダビューにして、検索結果でリソースを選択し、それを目的のフォルダにドラッグします。 1つのリソースが複数のフォルダに属することはありません。このため、ほかのフォルダにリソースを追加した場合、それまで属していたフォルダからそのリソースは削除されます。 詳しくは、「フォルダの使用」を参照してください。
  • 検索されたリソースに簡単にタグを追加することもできます。リソースペインをフォルダビューにして、検索結果でリソースを目的のタグにドラッグします。 タグの使用について詳しくは、「タグの使用」を参照してください。

新しい検索クエリを作成するには

  1. ［検索］タブで［検索オプション］、［カスタム検索］の順にクリックします。
  2. ［検索対象］の一覧で、検索するリソースの種類を指定します。 この一覧では、サーバー、仮想マシン（VM）、ストレージリポジトリ（SR）など、特定の種類のリソースを指定したり、リソースの種類の組み合わせを指定したり、すべてのリソースを検索対象として指定したりできます。

    検索対象として、独自の組み合わせを定義する場合は、［カスタム］を選択して、目的のリソースのチェックボックスをオンにします。

    ［検索対象］を選択すると、すぐに検索が実行され、［検索］タブの下部に検索結果が一覧表示されます。

検索をさらに絞り込むには、必要に応じてフィルタを適用します。 「検索結果のフィルタやグループ化」を参照してください。 選択したフィルタはすぐに適用され、検索結果に反映されます。

検索クエリを保存するには

  1. ［検索］タブで［検索オプション］、［現在の検索の保存］の順にクリックします。
  2. ［名前］ボックスに、保存する検索クエリの名前を入力します。
  3. ［場所］ボックスの一覧で、検索クエリのメタデータの格納先サーバーを選択します。
  4. ［保存］をクリックします。


検索結果のフィルタやグループ化

選択した検索カテゴリにフィルタを適用して、検索をさらに絞り込むことができます。 ［検索］タブでは、検索対象として指定したリソースに対して適切なフィルタが選択可能になります。

たとえば、検索対象として［サーバー］を指定した場合、サーバーの名前、アドレス、所属プール、ホストしている仮想マシンなどをフィルタとして適用できます。 また、検索対象として［仮想ディスク］を指定した場合は、共有されているかどうか、およびその仮想ディスクを格納しているストレージリポジトリなどをフィルタとして適用できます。

検索結果にフィルタを適用するには

  1. ［検索］タブの［フィルタ］にあるボタンをクリックして、適用するフィルタを選択します。

    検索対象として指定したリソースに基づいて、選択可能なフィルタが決定されます。

  2. 必要に応じて、［＝］、［以下を含む］、［以下を含まない］などを選択して、値を入力します。 選択したフィルタはすぐに適用され、検索結果に反映されます。
  3. 複数のフィルタを定義する場合は、［フィルタ］にあるボタンをクリックして、［以下のすべてが合致する］、［以下のいずれかが合致する］、または［以下のすべてに合致しない］を選択します。

フィルタを削除するには、［検索］タブのフィルタの右端に表示されている［-］ボタンをクリックします。

検索結果をグループ化するには

  1. ［検索］タブの［グループ］にあるボタンをクリックして、適用するグループオプションを選択します。 選択したグループはすぐに適用され、検索結果に反映されます。
  2. グループを追加するには、［グループの追加］をクリックして、一覧からグループを選択します。
  3. グループを削除するには、そのグループのボタンをクリックして［グループの削除］を選択します。


保存済みの検索

XenCenterには便利な保存済み検索クエリがいくつか組み込まれています。これらを使用して、ネットワーク、オペレーティングシステム、電源状態、およびXenServer Toolsのインストール状態などを基にリソースを検索できます。 また、必要に応じて独自の検索クエリを作成して、保存済み検索の一覧に追加できます。詳しくは、「検索クエリの作成」を参照してください。 保存済み検索は、リソースペインの［ビュー］ボックスの一覧の下部に表示されます。

保存済み検索クエリを適用するには

  • リソースペインで保存済み検索クエリを実行するには、［ビュー］ボックスの一覧で検索クエリを選択します。 リソースペインに検索結果が表示されます。
  • ［検索］タブで保存済み検索クエリを実行するには、［検索オプション］、［保存済み検索の適用］の順にクリックします。 サブメニューで検索クエリを選択すると、［検索］タブに結果が表示されます。

保存済みの検索を削除するには

［検索］タブで［検索オプション］、［保存済み検索の削除］の順にクリックします。 サブメニューで削除する検索クエリを選択し、確認のダイアログボックスで［OK］をクリックします。


検索のエクスポートとインポート

XenCenterで設定した検索クエリは、XenSearchファイル（.xensearch）として保存できます。 保存されるのは検索クエリのみで、検索結果は保存されません。

現在の検索クエリをエクスポートするには

  1. ［検索］タブで［検索オプション］、［ファイルにエクスポート］の順にクリックします。
  2. エクスポートファイルの名前と場所を入力して、［保存］をクリックします。

検索クエリをインポートするには

  1. ［検索］タブで［検索オプション］、［インポート］の順にクリックします。 または、［ファイル］メニューの［検索のインポート］を選択します。
  2. エクスポート済みの検索ファイル（拡張子.xensearch）を参照して［開く］をクリックします。 インポートした検索クエリはすぐに実行され、［検索］タブに結果が表示されます。

インポートした検索クエリをいつでも実行できるように保存するには、［検索オプション］、［現在の検索の保存］の順にクリックします。


ヘルプの参照

XenServerの使用に関する情報は、さまざまな場所から入手できます。

  • XenServer製品ドキュメント： XenServerの管理者と開発者を対象にしたPDF形式の総合的なリファレンスドキュメントは、XenServerのインストールメディアに収録されています。また、Citrix Knowledge CenterのXenServerのセクションからオンラインで参照することもできます。
  • Citrix Knowledge Center： インターネットに接続できる環境では、最新のXenServer製品ドキュメント、ナリッジベース、および技術情報を参照したり検索したりできます。 詳しくは、Citrix Knowledge Centerを参照してください。
  • XenCenterオンラインヘルプ： XenCenterには、ユーザーが表示しているウィンドウやダイアログボックス、および実行しようとしている操作に応じて適切な支援を提供する、状況依存のヘルプシステムが組み込まれています。
トピック


ヘルプウィンドウ

XenCenterのヘルプは、HTMLヘルプウィンドウに表示されます。

  • ウィンドウの左側はナビゲーションペインで、［目次］、［検索］、および［お気に入り］の各タブがあります。
  • ウィンドウの右側はトピックペインです。 ここには、選択したヘルプトピック、またはデフォルトのヘルプトピックが表示されます。
  • 上部には、ツールバーがあります。

ヘルプツールバーの使用

ナビゲーションペインを非表示にし、トピックペインのみを表示して、画面上のスペースを節約できます。
ナビゲーションペインを表示します。 このボタンは、［非表示］アイコンを使用してナビゲーションペインが非表示になっている場合にのみ使用できます。
直前に開いていたトピックに戻ります。
次のトピックに進みます（［戻る］アイコンを使用した後）。
トピックを印刷します。

［目次］タブの使用

ヘルプトピックを一覧表示するには、［目次］タブをクリックします。

ブックアイコンごとに異なるサブジェクトがまとめられています。 ブックが閉じている場合、［+］をクリックして展開して個々のトピックを一覧表示できます。再度ブックを閉じるには、［-］をクリックします。

トピックアイコンは、個々のヘルプトピックを示します。 トピックアイコンまたはそのタイトルをクリックすると、トピックペインにそのトピックが表示されます。

トピックペインに表示されているトピックは、［目次］タブ内でハイライト表示されます。 別のトピックに移動すると、必要に応じてブックが展開され、そのトピックがハイライト表示されます。

［検索］タブの使用

ヘルプシステム内のすべてのテキストを対象に、単語やフレーズを検索することができます。 また、検索対象を直前の検索結果、類似語、またはトピックのタイトルのみに限定することもできます。 詳しくは、「ヘルプの検索」を参照してください。

［お気に入り］タブの使用

  • お気に入りのヘルプトピックの一覧を作成するには、一覧に追加するトピックを表示して、［お気に入り］タブ下部の［追加］をクリックします。
  • お気に入りトピックを表示するには、［お気に入り］タブをクリックし、そのトピックを選択して［表示］をクリックします。
  • お気に入りトピックの名前を変更するには、一覧でトピックを右クリックして［名前の変更］を選択し、トピックの新しい名前を入力します。
  • お気に入りトピックを削除するには、一覧でそのトピックを選択し、［削除］をクリックします。


ヘルプの検索

ヘルプシステム内のすべてのテキストを対象に、単語やフレーズを検索することができます。 また、検索対象を直前の検索結果、類似語、またはトピックのタイトルのみに限定することもできます。

  1. ［検索］タブをクリックし、検索する単語またはフレーズを入力します。
  2. トピックタイトルのみを対象にして検索するには、［タイトルのみ検索］チェックボックスをオンにします。 目次に一覧表示されていないトピックを含む、すべてのトピックファイルが検索されます。
  3. 直近の検索結果に含まれるトピックのみを対象にして検索するには、［以前の結果から検索］チェックボックスをオンにします。 ヘルプシステム内のすべてのファイルを検索するには、このチェックボックスをオフにします。
  4. ［検索開始］をクリックし、表示するトピックをダブルクリックするか、トピックを選択して［表示］をクリックします。

ヒント

  • 検索では大文字と小文字が区別されないため、検索項目の入力には大文字と小文字のどちらも使用できます。
  • 文字と数字の任意の組み合わせを検索できます。
  • 検索時には、ピリオド、コロン、セミコロン、コンマ、ハイフンなどの、二重引用符以外の句読点は無視されます。
  • フレーズを検索する場合は、二重引用符で囲みます。 たとえば、「"ルートパスワード"」と入力すると、「ルートパスワード」というフレーズを含むトピックが検索されます。その一方で、「ルート パスワード」と入力すると、1つのまとまったフレーズとは限らず、「ルート」または「パスワード」という単語を含むトピックが検索されます。
  • ワイルドカード表現を使用して、1つ以上の文字を検索できます。ゼロ以上の文字を検索する場合はアスタリスク（*）を使用し、1つの文字を検索する場合は疑問符（?）を使用します。


ヘルプトピックの印刷

現在のトピックを印刷するには

  1. トピックの上部にある［すべてのテキストを表示する］チェックボックスをオンにするか、トピック内をクリックしてAlt+Xキーを押します。
  2. トピック内を右クリックして［印刷］を選択します。 または、ツールバーの［印刷］をクリックし、さらに［選択されたトピックの印刷］をクリックして、最後に［OK］をクリックします。
  3. ［印刷］ダイアログボックスで必要なプリンタオプションを設定し、［印刷］をクリックします。

［目次］タブのブックに含まれる一覧のトピックを印刷できます。 ただし、次の点に注意してください。

  • トピックは、すべてのセクションが展開された状態で印刷されます。
  • 印刷されるトピックの書式は、画面上に表示されるとおりではありません。
  • 画像が正しくない場所に印刷され、周辺のテキストを覆い隠すことがあります。

ブックのすべてのトピックを印刷するには

  1. ［目次］タブで印刷するトピックを含むブックを右クリックして［印刷］を選択するか、ツールバーの［印刷］ をクリックします。
  2. ［選択された見出しおよびすべてのサブトピックを印刷］をクリックし、［OK］をクリックします。
  3. ［印刷］ダイアログボックスで必要なプリンタオプションを設定し、［印刷］をクリックします。


サーバーの管理

接続と切断
  • 新しいサーバーの追加
  • サーバーの切断
  • サーバーの再接続
  • サーバーの再起動
  • サーバーのシャットダウン
  • ツールスタックの再起動
  • ホスト電源投入の設定
  • リモートからのサーバーの電源投入
  • 保守モードでの実行
  • サーバー一覧のエクスポートとインポート
  • サーバープロパティの変更
  • サーバーの接続状態の保存
  • サーバーのバックアップと復元
  • XenCenterからのサーバーの削除
ネットワークの設定
  • XenServerのネットワークについて
  • 新しいネットワークの追加
  • ネットワークの削除
  • ネットワークプロパティの表示と変更
  • NICの設定
  • IPアドレスの設定


サーバーの接続と切断

  • 新しいサーバーの追加
  • サーバーの切断
  • サーバーの再接続
  • サーバーの再起動
  • サーバーのシャットダウン
  • ツールスタックの再起動
  • ホスト電源投入の設定
  • リモートからのサーバーの電源投入
  • 保守モードでの実行
  • サーバーの接続状態の保存


新しいサーバーの追加

XenCenterでサーバー上のアクティビティを監視して管理するには、XenCenterでの管理対象リソースとしてそのサーバーを追加する必要があります。 XenCenterでサーバーに初めて接続するとき（ツールバーまたは［サーバー］メニューの［新規サーバーの追加］）に、XenCenter左側のリソースペインにそのサーバーが追加されます。 サーバーのデフォルトのストレージリポジトリ（設定されている場合）および物理CDまたはDVDドライブもここに表示されます。 管理対象としてサーバーを追加すると、XenCenterから削除するまでリソースペインに表示され、必要に応じて切断、再接続、シャットダウン、保守モードへの切り替えなどを実行できます。

新しいサーバーへの初回接続時に、［接続状態の保存と復元］ダイアログボックスが開きます。 ここで、サーバーの接続情報を保持して、XenCenter起動時にそれらの接続が自動的に復元されるように設定できます。詳しくは、「サーバーの接続状態の保存」を参照してください。

XenCenterにサーバーを追加するには

  1. ［サーバーの追加］をクリックします。
    または、次のいずれかを行います。
    • ［サーバー］メニューの［追加］を選択します。
    • リソースペインで最上位レベルの［XenCenter］を右クリックして、［追加］を選択します。
    • XenCenterの［ホーム］タブで［追加する］アイコンをクリックします。
  2. ［サーバー］ボックスに、追加するサーバーのIPアドレスまたはDNS名 （182.31.32.28またはbelt.orion.comなど）を入力します。
    ヒント： ［サーバー］ボックスでは、複数のサーバーの名前やIPアドレスをセミコロンで区切って入力できます。ただし、それらのサーバーには同一の資格情報でログインできなければなりません。
  3. XenServerのインストール時に設定したユーザー名（「root」など）とパスワードを入力します。 Active Directory（AD）認証を有効にしたXenServer環境では、ここにActive Directoryの認証情報を入力できます。 詳しくは、「役割ベースのアクセス制御（RBAC）の概要」を参照してください。
  4. ［追加］をクリックします。接続の進行状況が表示されます。接続をキャンセルするには、［キャンセル］をクリックします。

セキュリティ証明書

XenCenterでサーバーに接続したときに新規または変更されたSSL（Secure Sockets Layer）セキュリティ証明書が見つかった場合に、警告メッセージが表示されるように設定できます。 セキュリティ証明書を表示するには［証明書の表示］をクリックします。 SSL証明書に関する警告が表示されないようにするには、XenCenterの［オプション］ダイアログボックスの［セキュリティ］ページを使用します。


サーバーの切断

サーバーを切断しても管理対象外になることはなく、XenCenterのリソースペインに [image] アイコンで表示されます。

切断したサーバーを確認するには、リソースペインの表示モードを［フォルダビュー］に切り替えて、［切断済みサーバー］を開きます。

  • サーバーを切断するには、リソースペインでそのサーバーを選択し、［サーバー］メニューで［接続/切断］、［切断］の順に選択します。 切断したサーバーにはいつでも再接続できます。詳しくは、「サーバーの再接続」を参照してください。
  • リソースペインから切断済みサーバーを削除する手順については、「XenCenterからのサーバーの削除」を参照してください。


サーバーの再接続

XenCenterにサーバーを追加すると、リソースペインにそのサーバーが表示され、接続、切断、正常実行、または保守モードなどのサーバーの状態にかかわらず、XenCenterからサーバーを削除するまで、そのXenCenterセッションで維持されます。

XenCenterから切断したサーバーに再接続するには、リソースペインでそのサーバーをダブルクリックするか、右クリックして［接続］を選択します。 サーバーの接続情報はそのXenCenterセッションを終了するまで保持されるので、同じユーザーアカウントでサーバーに再接続する場合、ログイン用の資格情報を再入力する必要はありません。

また、接続済みのサーバーにほかのアカウントで再接続することもできます。たとえば、ローカルのルートアカウントで接続していたサーバーにActive Directoryアカウントで再接続する場合などがこれに当たります。

異なるアカウントで再接続するには

  1. リソースペインでサーバーを選択します。
  2. ［サーバー］メニューで、［接続/切断］、［別のアカウントで再接続］の順に選択します。 または、次のいずれかを行います。
    • リソースペインで仮想マシンを右クリックして、［別のアカウントで再接続］を選択します。
    • ［サーバー］メニューで、［接続/切断］、［別のアカウントで再接続］の順に選択します。
  3. 新しいユーザー名とパスワードを入力します。 Active Directory認証を有効にしたXenServer環境では、ここにActive Directoryの認証情報を入力できます。 詳しくは、「役割ベースのアクセス制御（RBAC）の概要」を参照してください。
  4. ［OK］をクリックします。


サーバーの再起動

XenCenterでサーバーを再起動するコマンドを選択すると、そのサーバー上で実行中のすべての仮想マシンがシャットダウンし、サーバーが切断された後で再起動します。 サーバーがリソースプールのメンバである場合、シャットダウン時に接続が失われますが、サーバーが再起動すると、プールにより接続が復元されます。 プールメンバ（プールマスタでないサーバー）をシャットダウンした場合、ほかのメンバとマスタは機能し続けます。 プールマスタをシャットダウンした場合は、そのマスタが再起動されてオンライン状態に戻り、ほかのメンバがマスタと再接続して同期化するまで、またはほかのメンバのいずれかを（XenServer xeコマンドラインインターフェイス（CLI）を使って）マスタに設定するまで、リソースプールは機能しません。

XenServer Toolsがインストールされた仮想マシン（準仮想化仮想マシン）は正常にシャットダウンされますが、HVMモードで実行中の仮想マシン（XenServer Toolsがインストールされていない仮想マシン）では強制シャットダウンが実行されます。これを避けるには、すべてのHVM仮想マシンにXenServer Toolsをインストールする必要があります（「XenServer Toolsのインストール」参照）。

サーバーを再起動すると、XenCenterからサーバーへの再接続が自動的に試行されます。 サーバーに再接続したら、ホストサーバーの再起動時に自動的に起動する設定の仮想マシンを除き、サーバー上で実行していた仮想マシンを起動する必要があります（「仮想マシンプロパティの変更」を参照してください）。

サーバーを再起動するには

リソースペインで仮想マシンを選択して、ツールバーの［再開］をクリックします。


サーバーのシャットダウン

XenCenterでサーバーをシャットダウンするコマンドを選択すると、そのサーバー上で実行中のすべての仮想マシンがシャットダウンし、サーバーが切断された後でシャットダウンします。 サーバーがリソースプールのメンバである場合、シャットダウン時に接続が失われますが、サーバーが再起動すると、プールにより接続が復元されます。 プールメンバ（プールマスタでないサーバー）をシャットダウンした場合、ほかのメンバとマスタは機能し続けます。 プールマスタをシャットダウンした場合は、そのマスタが再起動されてオンライン状態に戻り、ほかのメンバがマスタと再接続して同期化するまで、またはほかのメンバのいずれかを（XenServer xeコマンドラインインターフェイス（CLI）を使って）マスタに設定するまで、リソースプールは機能しません。

XenServer Toolsがインストールされた仮想マシン（準仮想化仮想マシン）は正常にシャットダウンされますが、HVMモードで実行中の仮想マシン（XenServer Toolsがインストールされていない仮想マシン）では強制シャットダウンが実行されます。これを避けるには、すべてのHVM仮想マシンにXenServer Toolsをインストールする必要があります。

サーバーを再度起動したら、XenCenterで再接続する必要があります。詳しくは、「サーバーの再接続」を参照してください。

サーバーをシャットダウンするには

リソースペインでサーバーを選択して、ツールバーの ［シャットダウン］をクリックします。

サーバーをシャットダウンすると、リソースペインでそのサーバーの状態インジケータが［切断］ [image] に変わります。


ツールスタックの再起動

［ツールスタックの再起動］オプションを使用すると、XenServerの管理ツールスタック（「xapi」とも呼ばれます）を再起動できます。 このツールスタックは、XenServerのリソースプールを管理するときの仮想マシンのライフサイクル操作、ホストと仮想マシンのネットワーク設定、仮想マシンのストレージ管理、ユーザー認証などを制御します。xapiにより提供されるXenAPI管理インターフェイスについてはドキュメントが公開されており、このインターフェイスは仮想マシンやリソースプールを管理するためのすべてのツールで使用されます。

注： XenServerの問題を解決するために［ツールスタックの再起動］オプションを使用する場合もあります。 ただし、このオプションの使用を誤ると、予期されない問題が発生する場合があります。

ツールスタックを再起動するには

  1. リソースペインでサーバーを選択します。
  2. ［サーバー］メニューの［ツールスタックの再起動］を選択します。
  3. ［はい］をクリックして確定します。
注： ［ツールスタックの再起動］オプションをプールマスタに対して実行すると、XenCenterとそのリソースプールとの接続が切断されます。 この場合、30秒ほど待機してから手作業で再接続してください。


ホスト電源投入の設定

XenServerのホスト電源投入機能を使用すると、サーバーの電源をリモートから投入したり切断したりできます。 この機能を使用するには、以下の手順を実行する必要があります。

  1. サーバーがリモートからの電源制御をサポートしていること（つまりWake-on-LAN機能、DRACまたはiLOカード、またはカスタムスクリプトが設定されていること）を確認します。 詳しくは、「ホスト電源投入の要件」を参照してください。
  2. 「ホスト電源投入を有効または無効にするには」の手順に従って、ホスト電源投入機能を有効にします。 iLOおよびDRACプロセッサでこの手順を実行するには、プロセッサのファームウェアに設定されている資格情報が必要です。

ホスト電源投入を有効にしたサーバーの電源を投入するには、XenCenter上でそのサーバーを選択して、［サーバー］メニューの［電源投入］を選択します。

ワークロードバランスが有効なXenServer環境では、仮想マシンの移行や再起動に応じて、サーバーの電源が自動的に投入または切断されるように設定することもできます。 この機能は、「電源管理」と呼ばれます。

ホスト電源投入の要件

ホスト電源投入機能を有効にするには、以下のいずれかの電源管理ソリューションが必要です。

  • Wake On LAN（WOL）をサポートするネットワークカード。
  • Dell Remote Access Controller（DRAC）。 XenServerでDRACを使用するには、以下の手順に従います。
    1. Dellサプリメンタルパックをインストールする。
    2. DRACのサーバーにRACADMコマンドラインユーティリティをインストールする。
    3. DRACおよびそのインターフェイスを有効にする。 通常、RACADMはDRAC管理ソフトウェアに含まれています。 詳しくは、Dell社のDRACドキュメントを参照してください。
  • Hewlett-Packard Integrated Lights-Out（iLO）。 XenServerでiLOを使用するには、そのサーバー上のiLOを有効にして、ネットワークに接続する必要がります。 詳しくは、HP社のiLOドキュメントを参照してください。
  • XenServerホストの電源を投入または切断するための、Xen APIに基づいたカスタムスクリプト。 DRACおよびiLOでは、キーpower_on_password_secretを指定することで、パスワードを安全に格納することができます。 詳しくは、『XenServer管理者ガイド』を参照してください。

ホスト電源投入を有効または無効にするには

ホスト電源投入機能をサーバー単位で有効にするにはそのサーバーの［プロパティ］ダイアログボックスを使用し、プール全体で有効にするにはプールの［プロパティ］ダイアログボックスを使用します。

  1. サーバーまたはプールを選択して、［プロパティ］ダイアログボックスを開きます。これを行うには、［サーバー］または［プール］メニューから［プロパティ］を選択します。
  2. ［電源投入］ページの［電源投入モード］で、いずれかのオプションを選択します。
    無効 | ホスト電源投入機能が無効になります。
    Wake-on-LAN（WoL） | このオプションを使用するには、サーバーにWake-on-LANが有効なネットワークカードが必要です。
    HP Integrated Lights-Out（iLO） | このオプションを使用するには、そのサーバー上のiLOを有効にして、ネットワークに接続する必要がります。 詳しくは、HP社のiLOドキュメントを参照してください。
    Dell Remote Access Controller（DRAC） | このオプションを使用するには、サーバーにDellサプリメンタルパックをインストールしておく必要があります。 詳しくは、Dell社のDRACドキュメントを参照してください。
    カスタムの電源投入スクリプト | カスタムのPython Linuxスクリプトを使用して、XenServerホストの電源をリモートから投入したり切断（シャットダウン）したりできます。 スクリプトの作成方法、およびサポートされるキー/値ペアの一覧については、『XenServer管理者ガイド』を参照してください。
  3. HP iLOまたはDell DRACを選択した場合は、以下の情報を入力します。
    IPアドレス | 電源管理カードとの通信で使用されるIPアドレスです。 iLOまたはDRACが設定されたネットワークインターフェイスのドメイン名を入力することもできます。
    ユーザー名 | 管理プロセッサに関連付けられたiLOまたはDRACのユーザー名です。工場出荷時のものから変更されている場合があります。
    パスワード | 上記のユーザー用のパスワードです。
  4. ［カスタムの電源投入スクリプト］オプションを選択した場合は、作成済みのスクリプトのパスおよびファイル名を入力します。また、［設定オプション］にスクリプトで使用するキーおよび値を入力します。 フィールド間を移動するには、マウスでクリックするかTabキーを押します。

    カスタムスクリプトのファイル名を指定するときに、拡張子.pyを入力する必要はありません。

  5. ［OK］をクリックして変更を保存し、［プロパティ］ダイアログボックスを閉じます。

ホスト電源投入を有効にしたら、ワークロードバランスの自動処理とホスト電源投入を設定して実行できます。


リモートからのサーバーの電源投入

ホスト電源投入機能を使用すると、リモートのサーバーの電源をXenCenterから投入できるようになります。 この機能を使用するには、サーバーがリモートからの電源制御をサポートしており（つまりWake-on-LAN機能、DRACまたはiLOカード、またはカスタムスクリプトが設定されている）、各サーバー（またはプール全体）の［プロパティ］ダイアログボックスで電源投入が有効になっている必要があります。

この機能の設定について詳しくは、「ホスト電源投入の設定」を参照してください。

ホスト電源投入機能を有効にしたら、サーバーを選択して以下のいずれかの操作を行います。

  1. ［サーバー］メニューの［電源投入］を選択します。
  2. サーバーを右クリックして［電源投入］を選択します。


保守モードでの実行

仮想化ソフトウェアのアップグレード、新しいネットワークへの接続の追加やテスト、サーバーが動作するハードウェアの問題の診断、または新しいストレージシステムへの接続の追加など、さまざまな理由により管理対象サーバーをオフラインにしなければならなくなることがあります。 XenCenterでは、保守モードにすることでサーバーを一時的にオフラインにすることができます。 リソースプールにあるサーバーを保守モードに切り替えると、そのサーバー上のすべての実行中の仮想マシンが自動的に同一プール内の別のサーバーに移行されます。 プールマスタとして動作するサーバーを保守モードにする場合は、そのリソースプールの新しいプールマスタが選出されます。

ワークロードバランスが有効なリソースプールでは、保守モードに切り替えたサーバー上でホストされているすべての仮想マシンが（最適化モードとパフォーマンスしきい値の設定、およびパフォーマンス測定値に基づいて決定される）最適なサーバーに移行されます。

保守モードのサーバー上で仮想マシンを作成したり起動したりすることはできません。

サーバーを保守モードに切り替えるには

  1. リソースペインでサーバーを選択して、次のいずれかを行います。
    • 右クリックして［保守モードへの切り替え］を選択します。
    • ［サーバー］メニューの［保守モードへの切り替え］を選択します。
  2. ［保守モードへの切り替え］をクリックします。
サーバーで実行されていたすべての仮想マシンがほかのサーバー上に正しく移行されると、リソースペインでそのサーバーの状態インジケータが [image] に変わります。

サーバーの保守モードを終了するには

  1. リソースペインでサーバーを選択して、次のいずれかを行います。
    • 右クリックして［保守モードからの切り替え］を選択します。
    • ［サーバー］メニューの［保守モードからの切り替え］を選択します。
  2. ［保守モードからの切り替え］をクリックします。


サーバーの接続状態の保存

すべての管理対象サーバーの資格情報（ユーザー名とパスワード）をXenCenterセッションの終了後も保持して、次回以降のXenCenterセッション開始時に自動的に再接続できます。 この機能を有効にすると、各セッションの終了時にすべての管理対象サーバーの接続状態がXenCenterに保存され、次のセッションの開始時に接続の復元が試行されます。 以前のセッションの終了時にサーバーが接続していた場合は自動的に再接続され、資格情報の入力ダイアログボックスは開きません。以前のセッションの終了時にサーバーが切断していた場合は、自動的に再接続されることはありません。

自動再接続機能が無効な場合は、XenCenterを開くたびに、各サーバーのユーザー名とパスワードを入力して管理対象サーバーに再接続する必要があります。

注： システム管理者は認証情報の保存を無効に設定することができます。そのため、この機能を使用できない場合があります。

マスタパスワードを設定すると、資格情報を保護できます。各セッションの開始時にこのマスタパスワードを入力すると、管理対象サーバーへの接続が復元されます。

自動再接続を有効または無効にするには

  1. XenCenterの［オプション］ダイアログボックスを開きます。これを行うには、［ツール］メニューの［オプション］を選択します。
  2. ［保存と復元］ページで、［接続状態を保存してセッション開始時に復元する］チェックボックスをオンまたはオフにします。

マスタパスワードの使用

XenCenterでサーバーへの自動再接続を有効するときに、保存した管理対象サーバーの資格情報を保護するマスタパスワードを設定することもできます。XenCenterセッションを開始するときにサーバーに再接続するには、マスタパスワードの入力が必要になります。 マスタパスワードの設定、変更、および無効化を行うには、XenCenterの［オプション］ダイアログボックスの［保存と復元］ページを使用します。

紛失したり忘れたりしたマスタパスワードは、復元できません。 マスタパスワードがわからなくなった場合は、各サーバーに手作業で接続し、新しいマスタパスワードを設定する必要があります。

マスタパスワードを設定するには

  1. XenCenterの［オプション］ダイアログボックスを開きます。これを行うには、［ツール］メニューの［オプション］を選択します。
  2. ［保存と復元］ページを開きます。
  3. ［接続状態を保存してセッション開始時に復元する］チェックボックスがオンになっていることを確認します。
  4. ［マスタパスワード］で、［マスタパスワードを要求する］チェックボックスをオンにして、マスタパスワードを入力および確認入力し、［OK］をクリックします。 パスワードの大文字と小文字は区別されます。

マスタパスワードを変更するには

  1. XenCenterの［オプション］ダイアログボックスを開きます。これを行うには、［ツール］メニューの［オプション］を選択します。
  2. ［保存と復元］ページを開きます。
  3. ［マスタパスワード］で、［マスタパスワードの変更］をクリックします。
  4. 現在のマスタパスワードを入力し、新しいパスワードを入力および確認入力し、［OK］をクリックします。

マスタパスワードを削除するには

  1. XenCenterの［オプション］ダイアログボックスを開きます。これを行うには、［ツール］メニューの［オプション］を選択します。
  2. ［保存と復元］ページを開きます。
  3. ［マスタパスワード］で、［マスタパスワードを要求する］チェックボックスをオフにします。
  4. 現在のマスタパスワードを入力および確認入力し、［OK］をクリックします。


サーバーのバックアップと復元

XenCenterでは、サーバーをXenServerバックアップファイル（.xbk）としてバックアップしておき、ハードウェア障害後などに復元することができます。 ただし、これによりバックアップされるのはサーバーのみで、そのサーバー上の仮想マシンはバックアップされません。

サーバーやソフトウェアの障害に備えて、サーバーを頻繁にバックアップすることをお勧めします。 XenCenterでサーバーをバックアップするときは、次のことに注意してください。

  • XenServerのコントロールドメイン（ドメイン0）にバックアップを作成しないでください。 XenServerのコントロールドメインについて詳しくは、『XenServer管理者ガイド』を参照してください。
  • XenServerバックアップファイルのサイズは非常に大きくなることがあります。

サーバーを復元するには、XenCenterでバックアップファイルを選択して復元します。その後、XenServerのインストールメディアからサーバーを再起動して復元を完了します。

サーバー設定とソフトウェアをバックアップするには

  1. リソースペインでサーバーを選択して、［サーバー］メニューの［バックアップ］を選択します。
  2. バックアップファイルを作成するフォルダを参照してファイル名を入力し、［保存］をクリックしてバックアップを開始します。
バックアップにはしばらく時間がかかる可能性があります。 バックアップの進行状況を確認するには［ログ］タブをクリックします。

サーバー設定とソフトウェアをバックアップから復元するには

  1. リソースペインでサーバーを選択して、［サーバー］メニューの［バックアップから復元］を選択します。
  2. バックアップファイルを参照し、［開く］をクリックして復元を開始します。
  3. XenServerのインストールメディアを使用してホストサーバーを再起動し、［Restore from backup］を選択します。


XenCenterからのサーバーの削除

XenCenterからサーバーを削除すると、そのサーバーに関するすべての管理および監視アクティビティが停止します。 XenCenterからサーバーを削除しても、そのサーバーで実行中のアクティビティに影響はなく、インストールされている仮想マシンも削除されません。 サーバーを削除しても、単にXenCenterとサーバーおよびその仮想マシンの間の接続が切断され、関連する情報がXenCenterから削除されるだけです。

サーバーを削除するには、リソースペインでサーバーを選択して、［サーバー］メニューの［XenCenterから削除］を選択します。

削除したサーバーを管理対象リソースの一覧に戻すには、そのサーバーをXenCenterに追加し直す必要があります。


ネットワークの設定

  • XenServerのネットワークについて
  • 新しいネットワークの追加
  • ネットワークの削除
  • ネットワークプロパティの表示と変更
  • NICの設定
  • IPアドレスの設定


XenServerのネットワークについて

管理対象のサーバーには、1つ以上のネットワークが設定されます。 XenServerのネットワークは、外部インターフェイスに（VLANタグ付きまたはVLANタグなしで）接続したり、特定のサーバーやリソースプール内部のみを接続したりする仮想イーサネットスイッチです。

XenServerを物理サーバーにインストールするときに、そのサーバーの物理NICごとにネットワークが作成されます。 これらのネットワークは、仮想マシン上の仮想ネットワークインターフェイス（VIF）と、ホストサーバー上のネットワークインターフェイスカード（NIC）に関連付けられた物理ネットワークインターフェイス（PIF）との間のブリッジとして機能します。

サーバーをリソースプールに移動すると、これらのデフォルトネットワークがマージされ、同じデバイス名を持つすべての物理NICが同じネットワークに接続されるようになります。 通常、内部ネットワークを作成する、既存のNICを使用して新しいVLANを設定する、またはNICボンディングを作成するときにのみ、新しいネットワークを追加します。 各サーバーでは、最大16のネットワーク（または最大8組のボンディングしたネットワークインターフェイス）を設定できます。

ジャンボフレームは、ストレージトラフィックのパフォーマンスを最適化するために使用される機能です。 ジャンボフレームを使用するには、XenCenterの［新規ネットワーク］ウィザードや既存のネットワークの［プロパティ］ダイアログボックスで、MTU（Maximum Transmission Unit）を設定します。 設定可能なMTU値は、1500～9216です。

ネットワークの種類

XenCenterで新規ネットワークを作成する場合、4種類の物理（サーバー）ネットワークから選択できます。

単一サーバーのプライベートネットワーク

物理ネットワークインターフェイスに関連付けられない内部ネットワークです。この種類のネットワークでは、そのサーバー上の仮想マシン間の接続が提供され、外部には接続できません。

サーバー間のプライベートネットワーク

リソースプールレベルのプライベートネットワークです。この種類のネットワークでは、そのリソースプール内の仮想マシン間の接続が提供され、外部には接続できません。 サーバー間のプライベートネットワークは、単一サーバーのプライベートネットワークの独立性と、リソースプール全体での接続性を兼ね備えています。 このネットワークでは、XenMotionによるライブマイグレーションや仮想マシンのワークロードバランス（WLB）などのアジリティ機能も使用できます。 VLANでも同様の機能が提供されますが、サーバー間のプライベートネットワークでGRE（Generic Routing Encapsulation）IPトンネリングプロトコルを使用すると、物理スイッチファブリックを設定しなくても、ネットワークを隔離させることができます。 サーバー間のプライベートネットワークを作成するには、以下の条件を満たす必要があります。

  • リソースプール内のすべてのサーバーでXenServer Version 5.6 Feature Pack 1以降が動作している。
  • リソースプール内のすべてのサーバーでOpen vSwitchによるネットワークが設定されている。
  • vSwitch接続に必要な初期化および構成タスク（これらのタスクはXenCenterを使用せずに行う必要があります）を行うvSwitchコントローラがリソースプールに設定されいる。
    重要： vSwitchコントローラ仮想アプライアンスは、XenServer 6.2.0リリースでの使用が想定されていません。 XenServer 6.2.0にもこの機能が含まれていますが、将来的にはXenServerから完全に削除される予定です。 vSwitchコントローラの機能に依存するアプリケーションやコードなどを使用している場合は、ほかの方法への移行を検討してください。 詳しくは、CTX137336を参照してください。

外部ネットワーク

物理ネットワークインターフェイスに関連付けられ、仮想マシンと外部ネットワークとのブリッジとして機能するネットワークです。この種類のネットワークにより、仮想マシンがサーバーの物理ネットワークインターフェイスカード経由で外部リソースに接続できるようになります。

ボンディングしたネットワーク

複数のネットワークインターフェイスカードを「束ね」て単一の高性能チャネルを形成するネットワークで、仮想マシンと外部ネットワーク間の接続が提供されます。 以下の3つのボンディングモードがサポートされています。

  • アクティブ/アクティブモード：このモードでは、ボンディングされたNIC間でトラフィックが分散されます。 ボンディング内の一方のNICに障害が発生した場合、ホストサーバーのネットワークトラフィックは自動的に他方のNIC経由で転送されます。 このモードにより、ボンディングされた物理NICによる仮想マシントラフィックの負荷分散が提供されます。
  • アクティブ/パッシブ（Active-Backup）モード：このモードでは、ボンディングされたNICのうち一方のみがアクティブになります。非アクティブなNICが使用されるのは、アクティブなNICに障害が発生した場合のみです。このモードにより、ホットスタンバイによる冗長化が提供されます。
  • LACP（Link Aggregation Control Protocol）モード：このモードでは、ボンディングされたNIC間でトラフィックが分散されるアクティブ/アクティブボンディングが提供されます。 Linuxブリッジ環境でのアクティブ/アクティブボンディングとは異なり、LACPボンディングではすべての種類のトラフィック負荷が分散されます。 このモードには、2つのオプションがあります。
    • LACP - 送信元のMACアドレスによる負荷分散：このモードでは、送信元の仮想マシンのMACアドレスに基づいてトラフィックの送信NICが選択されます。 同一ホスト上でいくつかの仮想マシンが動作する環境では、このオプションによるトラフィック分散を使用します。 VIFの数がNICよりも少ない場合、このハッシュアルゴリズムは適していません。トラフィックを複数のNICに分散できないため、適切な負荷分散は提供されません。
    • LACP - 送信元/送信先のポートとIPによる負荷分散：このモードでは、送信元のIPアドレスとポート番号、および送信先のIPアドレスとポート番号に基づいてトラフィックがNIC間で分散されます。 このオプションは、VIFの数がNICよりも少ない環境で仮想マシンからのトラフィック負荷を分散させる場合に適しています。 たとえば、3つのNICによるボンディングを単一の仮想マシンだけで使用する場合はこのオプションを使用します。

備考

  • XenCenterでLACPボンディングのオプションを表示したりLACPボンディングを作成したりするには、ネットワークスタックとしてvSwitchを設定する必要があります。 また、IEEE 802.3ad標準をサポートするスイッチを使用する必要があります。
  • アクティブ/アクティブモードおよびアクティブ/パッシブモードのボンディングは、vSwitchおよびLinuxブリッジの両方で使用できます。
  • ネットワークスタックとしてvSwitchを使用する場合は、最大で4つのNICを使用してボンディングを作成できます。Linuxブリッジネットワークスタックの場合、ボンディングを構成できるNICは2つまでです。

XenServerでのNICボンディングのサポートについて詳しくは、『XenServer管理者ガイド』を参照してください。


新しいネットワークの追加

リソースプールまたはスタンドアロンサーバーで新しいネットワークを作成するには、［新規ネットワーク］ウィザードを使用します。リソースペインでサーバーまたはプールを選択して、［ネットワーク］タブをクリックし、［ネットワークの追加］をクリックします。

外部ネットワークを作成するには

外部ネットワークは、物理ネットワークインターフェイスカード（NIC）に関連付けられ、仮想マシンと外部ネットワークとのブリッジとして機能するネットワークです。これにより、仮想マシンから、サーバーのNICを介して外部ネットワークリソースに接続できるようになります。
  1. ［新規ネットワーク］ウィザードを開きます。
  2. ウィザードの最初のページで［外部ネットワーク］をクリックし、［次へ］をクリックします。
  3. 新しいネットワークの名前と説明を入力し、［次へ］をクリックします。
  4. ［ネットワーク設定］ページで、作成するネットワークのNIC、VLAN、およびMTUを設定します。
    1. ［NIC］ドロップダウンリストで、物理ネットワークインターフェイスカード（NIC）を選択します。
    2. ［VLAN］ボックスで、作成する仮想ネットワークの数を指定します。
    3. ジャンボフレームを使用する場合は、MTU（Maximum Transmission Unit）の値を1500から9216の範囲で指定します。
  5. ［このネットワークを新規VMに自動的に追加する］チェックボックスをオンにすると、［新規VM］ウィザードで作成する仮想マシンにこのネットワークが自動的に追加されます。
  6. ［完了］をクリックすると、新しいネットワークが作成され、ウィザードが閉じます。

単一サーバーのプライベートネットワークを作成するには

単一サーバーのプライベートネットワークは、物理ネットワークインターフェイスに関連付けられない内部ネットワークです。この種類のネットワークでは、そのサーバー上の仮想マシン間の接続が提供され、リソースプール内のほかのサーバー上の仮想マシンや外部ネットワークには接続できません。
  1. ［新規ネットワーク］ウィザードを開きます。
  2. ウィザードの最初のページで［単一サーバーのプライベートネットワーク］をクリックし、［次へ］をクリックします。
  3. 新しいネットワークの名前と説明を入力し、［次へ］をクリックします。
  4. ［ネットワーク設定］ページの［このネットワークを新規VMに自動的に追加する］チェックボックスをオンにすると、［新規VM］ウィザードで作成する仮想マシンにこのネットワークが自動的に追加されます。
  5. ［完了］をクリックすると、新しいネットワークが作成され、ウィザードが閉じます。

サーバー間のプライベートネットワークを作成するには

サーバー間のプライベートネットワークは、リソースプールレベルのプライベートネットワークです。この種類のネットワークでは、そのリソースプール内の仮想マシン間の接続が提供され、外部ネットワークには接続できません。 サーバー間のプライベートネットワークを作成するには、以下の条件を満たす必要があります。

  • リソースプール内のすべてのサーバーでXenServer Version 5.6 Feature Pack 1以降が動作している。
  • リソースプール内のすべてのサーバーでOpen vSwitchによるネットワークが設定されている。
  • vSwitch接続に必要な初期化および構成タスク（これらのタスクはXenCenterを使用せずに行う必要があります）を行うvSwitchコントローラがリソースプールに設定されいる。
    重要： vSwitchコントローラ仮想アプライアンスは、XenServer 6.2.0リリースでの使用が想定されていません。 XenServer 6.2.0にもこの機能が含まれていますが、将来的にはXenServerから完全に削除される予定です。 vSwitchコントローラの機能に依存するアプリケーションやコードなどを使用している場合は、ほかの方法への移行を検討してください。 詳しくは、CTX137336を参照してください。
  1. ［新規ネットワーク］ウィザードを開きます。
  2. ウィザードの最初のページで［サーバー間のプライベートネットワーク］をクリックし、［次へ］をクリックします。
  3. 新しいネットワークの名前と説明を入力し、［次へ］をクリックします。
  4. ［ネットワーク設定］ページの［管理インターフェイス］ボックスの一覧で、新しいネットワークで使用するインターフェイスを選択します。
  5. ［このネットワークを新規VMに自動的に追加する］チェックボックスをオンにすると、［新規VM］ウィザードで作成する仮想マシンにこのネットワークが自動的に追加されます。
  6. ［完了］をクリックすると、新しいネットワークが作成され、ウィザードが閉じます。

ボンディングネットワークを作成するには

複数のネットワークインターフェイスカードを「束ね」て単一の高性能チャネルを形成するボンディングネットワークでは、仮想マシンと外部ネットワーク間の接続が提供されます。

注： リソースプールでのNICボンディングの作成は、リソースプールにサーバーを追加したり仮想マシンを作成したりした後ではなく、リソースプールの初期作成時に行ってください。 これにより、プールに追加するサーバーにボンディング設定が自動的に適用されるため、必要な手順を減らすことができます。
  1. ［新規ネットワーク］ウィザードを開きます。
  2. ウィザードの最初のページで［ボンディングしたネットワーク］をクリックし、［次へ］をクリックします。
  3. ［ボンディングメンバ］ページで、ボンディングを構成するNICを選択します。 一覧で、ボンディングに追加するNICのチェックボックスをオンにします。 最大で4つのNICを選択できます。 ボンディングに追加しないNICのチェックボックスはオフにします。
  4. ［ボンディングモード］で、ボンディングの種類を指定します。
    • トラフィックが両方のNICに均等に分散されるアクティブ/アクティブモードを指定するには、［アクティブ/アクティブ］をクリックします。このモードでは、ボンディング内の一方のNICに障害が発生した場合、ホストサーバーのネットワークトラフィックが自動的に他方のNIC経由で転送されます。
    • トラフィックが一方のNICのみで転送されるアクティブ/パッシブモードを指定するには、［アクティブ/パッシブ］をクリックします。 このモードでは、ボンディングされたNICのうち一方のみがアクティブになり、そのNICがネットワークから切断されるなど、障害が発生した場合のみ2つ目のNICが使用されます。
    • 送信元の仮想マシンのMACアドレスに基づいてトラフィックの送信NICが選択されるLACPボンディングを作成するには、［LACP - 送信元のMACアドレスによる負荷分散］をクリックします。 同一ホスト上でいくつかの仮想マシンが動作する環境では、このオプションによるトラフィック分散を使用します。 仮想インターフェイス（VIF）の数がNICよりも少ない場合、このハッシュアルゴリズムは適していません。トラフィックを複数のNICに分散できないため、適切な負荷分散は提供されません。
    • 送信元のIPアドレスとポート番号、および送信先のIPアドレスとポート番号に基づいてトラフィックがNIC間で分散されるLACPボンディングを作成するには、［LACP - 送信元/送信先のポートとIPによる負荷分散］をクリックします。 このオプションは、VIFの数がNICよりも少ない環境で仮想マシンからのトラフィック負荷を分散させる場合に適しています。
    備考：
    • XenCenterでLACPボンディングのオプションを表示したりLACPボンディングを作成したりするには、ネットワークスタックとしてvSwitchを設定する必要があります。 また、IEEE 802.3ad標準をサポートするスイッチを使用する必要があります。
    • アクティブ/アクティブモードおよびアクティブ/パッシブモードのボンディングは、vSwitchおよびLinuxブリッジの両方で使用できます。
    • ネットワークスタックとしてvSwitchを使用する場合は、最大で4つのNICを使用してボンディングを作成できます。Linuxブリッジネットワークスタックの場合、ボンディングを構成できるNICは2つまでです。
  5. ジャンボフレームを使用する場合は、MTU（Maximum Transmission Unit）の値を1500から9216の範囲で指定します。
  6. ［このネットワークを新規VMに自動的に追加する］チェックボックスをオンにすると、［新規VM］ウィザードで作成する仮想マシンにこのネットワークが自動的に追加されます。
  7. ［完了］をクリックすると、新しいネットワークが作成され、ウィザードが閉じます。
詳しくは「NICの設定」を参照してください。


ネットワークの削除

  1. リソースペインでサーバーまたはプールを選択して、［ネットワーク］タブをクリックします。
  2. ［ネットワーク］タブで一覧内のネットワークを選択し、［ネットワークの削除］をクリックします。


ネットワークプロパティの表示と変更

サーバーの現在のネットワーク構成を表示するには

サーバーの［ネットワーク］タブには、そのサーバー上に構成されているすべてのネットワークが表示されます。

名前 | ネットワークの名前です。
説明 | （オプション）ネットワークの説明です。
NIC | 物理ネットワークインターフェイスカード（NIC）、NICボンディング、または内部仮想ネットワークです。
VLAN | 外部ネットワークでは、この列に仮想LAN（VLAN）タグが表示されます。
自動 | この列には、［新規VM］ウィザードを使用して作成する新しい仮想マシンにネットワークが自動的に追加されるかどうかが表示されます。
接続状態 | ネットワークの接続状態（接続または切断）です。
MAC | ネットワークアダプタ（NIC）のMAC（Media Access Control：メディアアクセス制御）アドレスです。 これはネットワークアダプタに固有の識別子です。
MTU | ジャンボフレームを使用するために設定するMTU（Maximum Transmission Unit）値で、1500～9216の数値が表示されます。

サーバーのネットワーク構成を変更するには

XenCenterの［ネットワーク］タブでネットワークを選択し、［プロパティ］をクリックします。 ネットワークの名前、説明、フォルダ、タグ、およびカスタムフィールドなどの設定のほか、［ネットワーク設定］ページでは以下の設定を変更できます。

オプション | 説明
ボンディングモード このオプションは、ボンディングしたネットワークでのみ表示されます。
  • トラフィックが両方のNICに均等に分散されるアクティブ/アクティブモードを指定するには、［アクティブ/アクティブ］をクリックします。このモードでは、ボンディング内の一方のNICに障害が発生した場合、ホストサーバーのネットワークトラフィックが自動的に他方のNIC経由で転送されます。
  • トラフィックが一方のNICのみで転送されるアクティブ/パッシブモードを指定するには、［アクティブ/パッシブ］をクリックします。 このモードでは、ボンディングされたNICのうち一方のみがアクティブになり、そのNICがネットワークから切断されるなど、障害が発生した場合のみ2つ目のNICが使用されます。
  • 送信元の仮想マシンのMACアドレスに基づいてトラフィックの送信NICが選択されるLACPボンディングを作成するには、［LACP - 送信元のMACアドレスによる負荷分散］をクリックします。 同一ホスト上でいくつかの仮想マシンが動作する環境では、このオプションによるトラフィック分散を使用します。 仮想インターフェイス（VIF）の数がNICよりも少ない場合、このハッシュアルゴリズムは適していません。トラフィックを複数のNICに分散できないため、適切な負荷分散は提供されません。
  • 送信元のIPアドレスとポート番号、および送信先のIPアドレスとポート番号に基づいてトラフィックがNIC間で分散されるLACPボンディングを作成するには、［LACP - 送信元/送信先のポートとIPによる負荷分散］をクリックします。 このオプションは、VIFの数がNICよりも少ない環境でトラフィック負荷を分散させる場合に適しています。

備考：

  • XenCenterでLACPボンディングのオプションを表示したりLACPボンディングを作成したりするには、ネットワークスタックとしてvSwitchを設定する必要があります。 また、IEEE 802.3ad標準をサポートするスイッチを使用する必要があります。
  • アクティブ/アクティブモードおよびアクティブ/パッシブモードのボンディングは、vSwitchおよびLinuxブリッジの両方で使用できます。
  • ネットワークスタックとしてvSwitchを使用する場合は、最大で4つのNICを使用してボンディングを作成できます。Linuxブリッジネットワークスタックの場合、ボンディングを構成できるNICは2つまでです。

詳しくは「NICの設定」を参照してください。
MTU | ジャンボフレームを使用する場合は、MTU（Maximum Transmission Unit）の値を1500から9216の範囲で指定します。
このネットワークを新規VMに自動的に追加する | ［新規VM］ウィザードで新しい仮想マシンを作成するときにこのネットワークが自動的に追加されるようにするには、このチェックボックスをオンにします。


NICの設定

XenServerでは、関連するネットワーク、仮想ネットワークインターフェイス、サーバーネットワーク、およびボンディング設定に基づいて、NICが必要に応じて自動的に管理されます。 ［NIC］タブでは、使用可能なNICを表示したり、NICボンディングを作成したり、NICに特定の機能を割り当てたりできます。

NICをボンディングして複数の物理NICを1つのNICのように使用することによって、サーバーの耐障害性を向上させることができます。 NICボンディングにより、仮想マシンとネットワークの間に単一の高性能チャネルを作成できます。 以下の3つのボンディングモードがサポートされています。

アクティブ/アクティブモード
このモードにより、ボンディングされた物理NICによる仮想マシントラフィックの負荷分散が提供されます。 ボンディング内の一方のNICに障害が発生した場合、ホストサーバーのネットワークトラフィックは自動的に他方のNIC経由で転送されます。
アクティブ/パッシブ（Active-Backup）モード
このモードにより、フェイルオーバー機能が提供されます。 ボンディングされたNICのうち一方のみがアクティブになり、そのNICに障害が発生した場合のみ2つ目のNICが使用されます。
LACP（Link Aggregation Control Protocol）モード
このモードでは、ボンディングされたNIC間でトラフィックが分散されるアクティブ/アクティブボンディングが提供されます。 Linuxブリッジ環境でのアクティブ/アクティブボンディングとは異なり、LACPボンディングではすべての種類のトラフィック負荷が分散されます。
注： XenCenterでLACPボンディングのオプションを表示したりLACPボンディングを作成したりするには、ネットワークスタックとしてvSwitchを設定する必要があります。 また、IEEE 802.3ad標準をサポートするスイッチを使用する必要があります。 このスイッチには、ホスト上のLACPボンディングごとに個別のLAG（リンクアグリゲーショングループ）が設定されている必要があります。 LAGの作成について詳しくは、『XenServer管理者ガイド』を参照してください。

これをボンドマスタと呼び、ボンディングを構成する各NICをNICスレーブと呼びます。このNICボンディングをXenServerのネットワークに接続して、仮想マシンのトラフィックやサーバー管理に使用できます。 XenCenterでNICボンディングを作成するには、サーバーの［NIC］タブまたは［ネットワーク］タブ（新規ネットワークウィザードで［ボンディングしたネットワーク］を選択）を使用します。

使用可能なNICの表示

サーバーの［NIC］タブでは、各NICについて次のデバイスプロパティが表示されます。

NIC | 物理ネットワークインターフェイスカード（NIC）または内部仮想ネットワークを示します。
MAC | NICのMAC（Media Access Control：メディアアクセス制御）アドレスです。
接続状態 | NICの接続状態（接続または切断）です。
速度 | NICのデータ転送レートです。
二重 | NICの二重モード（全二重モードまたは半二重モード）です。
ベンダ、デバイス | NICベンダとデバイス名です。
PCIバスのパス | パススルーデバイスのPCIバスのパスです。

XenServerホストに新しいイーサネットコントローラなどの物理インターフェイスを追加した後で、［NIC］タブの一覧にそのNICが表示されない場合があります。 この場合、［NIC］タブの［再スキャン］をクリックします。これにより、XenServerにより新しいNICが検出されます。

新しいNICボンディングを作成するには

  1. ボンディングを構成するNIC（NICスレーブ）が使用中でないことを確認します。対象のNICスレーブを仮想ネットワークインターフェイスとして使用している仮想マシンがある場合は、それらの仮想マシンをすべてシャットダウンします。 その後で仮想マシンの仮想ネットワークインターフェイスを適切なネットワークに再接続する必要があります。
  2. リソースペインでサーバーを選択して、［NIC］タブの［ボンディングの作成］をクリックします。
  3. ボンディングするNICを選択します。 一覧で、ボンディングに追加するNICのチェックボックスをオンにします。 最大で4つのNICを選択できます。 ボンディングに追加しないNICのチェックボックスはオフにします。 ネットワークスタックとしてvSwitchを使用する場合は、最大で4つのNICを使用してボンディングを作成できます。Linuxブリッジネットワークスタックの場合、ボンディングを構成できるNICは2つまでです。
  4. ［ボンディングモード］で、ボンディングの種類を指定します。
    • トラフィックが両方のNICに均等に分散されるアクティブ/アクティブモードを指定するには、［アクティブ/アクティブ］をクリックします。このモードでは、ボンディング内の一方のNICに障害が発生した場合、ホストサーバーのネットワークトラフィックが自動的に他方のNIC経由で転送されます。

    • トラフィックが一方のNICのみで転送されるアクティブ/パッシブモードを指定するには、［アクティブ/パッシブ］をクリックします。 このモードでは、ボンディングされたNICのうち一方のみがアクティブになり、そのNICがネットワークから切断されるなど、障害が発生した場合のみ2つ目のNICが使用されます。

    • 送信元の仮想マシンのMACアドレスに基づいてトラフィックの送信NICが選択されるLACPボンディングを作成するには、［LACP - 送信元のMACアドレスによる負荷分散］をクリックします。 同一ホスト上でいくつかの仮想マシンが動作する環境では、このオプションによるトラフィック分散を使用します。 仮想インターフェイス（VIF）の数がNICよりも少ない場合、このハッシュアルゴリズムは適していません。トラフィックを複数のNICに分散できないため、適切な負荷分散は提供されません。

    • 送信元のIPアドレスとポート番号、および送信先のIPアドレスとポート番号に基づいてトラフィックがNIC間で分散されるLACPボンディングを作成するには、［LACP - 送信元/送信先のポートとIPによる負荷分散］をクリックします。 このオプションは、VIFの数がNICよりも少ない環境で仮想マシンからのトラフィック負荷を分散させる場合に適しています。

      注： LACPボンディングは、vSwitchでのみ使用できます。アクティブ/アクティブモードおよびアクティブ/パッシブモードのボンディングは、vSwitchおよびLinuxブリッジの両方で使用できます。

      XenServerでのNICボンディングのサポートについて詳しくは、『XenServer管理者ガイド』を参照してください。

  5. ジャンボフレームを使用する場合は、MTU（Maximum Transmission Unit）の値を1500から9216の範囲で指定します。
  6. ［新規VM］ウィザードで作成する新しい仮想マシンにこのボンディングネットワークを自動的に追加するには、［このネットワークを新規VMに自動的に追加する］チェックボックスをオンにします。
  7. ［作成］をクリックします。NICボンディングが作成され、ダイアログボックスが閉じます。

新しいボンディングが作成されると、管理インターフェイスおよびセカンダリインターフェイスがボンドスレーブからボンドマスタに移動します。

ボンディング上に管理インターフェイスを持つサーバーはリソースプールに追加できないことに注意してください。 プールに追加するには、サーバーの管理インターフェイスを再設定して物理NIC上に戻す必要があります。

NICボンディングの削除

サーバーのNICボンディング設定を削除する場合、次の要件に注意してください。

  • ボンディングを作成するときのように、ボンディングを削除する前に、そのボンディングを使用する仮想ネットワークインターフェイスを持つすべての仮想マシンをシャットダウンする必要があります。 NICボンディングを削除した後で、これらの仮想ネットワークインターフェイスを適切なネットワークに再接続します。

  • ボンディングを削除する前に、［管理インターフェイス］ダイアログボックスを使用して管理インターフェイスを別のNICに移動します。そうしないと、XenCenterを含めサーバーへの接続が切断されます。

ボンディングを削除するには

  1. リソースペインでサーバーを選択して、［NIC］タブをクリックします。
  2. ［ボンディングの削除］をクリックします。

特定機能専用のNICの設定

NICにIPアドレスを割り当てて、ストレージやそのほかの種類のネットワークトラフィックなど、特定の機能専用にすることができます。 詳しくは、「IPアドレスの設定」を参照してください。


IPアドレスの設定

管理対象サーバーの管理インターフェイスとして使用するNICは、XenServerのインストール時に最初に指定します。 別のコンピュータ上で動作するXenCenterやXenServer xeコマンドラインインターフェイス（CLI）などの管理ソフトウェアは、いずれも管理インターフェイスのIPアドレスを介してサーバーに接続します。

サーバーに複数のNICが搭載されている場合は、別のNICまたはNICボンディングを選択して管理インターフェイスとして使用できます。 IPアドレスをNICに割り当てて、NICをストレージやそのほかの種類のネットワークトラフィックなどの特定機能専用にすることもできます（「セカンダリインターフェイス」と呼ばれます）。 VLANネットワーク上に管理インターフェイスを配置することはサポートされないことに注意してください。

リソースプールに新しいサーバーを追加すると、ネットワークとボンディングの情報を含むプールマスタのネットワーク設定がそのサーバーに自動的に継承されることにも注意してください。 ただし、追加するサーバーの管理インターフェイスがプールマスタと一致するように変更されることはありません。したがって、プールマスタと同じボンディングを使用するには、サーバーを追加した後で再設定する必要があります。 また、ボンディング上に管理インターフェイスを持つサーバーはリソースプールに追加できないことにも注意してください。このため、プールに追加するには、サーバーの管理インターフェイスを再設定して物理NIC上に戻す必要があります。

以下のセクションでは、XenCenterの［IPアドレスの設定］ダイアログボックスで単一のNICにIPアドレスを割り当てて、サーバーまたはプールの管理インターフェイスを変更する手順について説明します。

NICにIPアドレスを割り当てるには

ストレージなどの特定機能専用のNICを設定するには、XenCenterを使用してそのNICにIPアドレスを割り当てます。 NICにIPアドレスを割り当てるということは、セカンダリインターフェイスを作成することを意味します。

柔軟で安全なネットワークを簡単に保守するために、専用のNICを使用するセカンダリインターフェイスを作成して、ネットワークトラフィックをセグメント化することができます。これにより、たとえば、サーバー管理、アプリケーション生成トラフィック、およびストレージトラフィックのそれぞれに別個のネットワークを構築することができます。 XenServerのデフォルトのネットワーク設定では、IPベースのストレージデバイスへのネットワークトラフィックはすべて、管理インターフェイスのNICから発信されます。 セカンダリインターフェイスでは、管理インターフェイスのDNSサーバー設定が継承されることに注意してください。

NICにIPアドレスを割り当てるには、NICが確実にその機能のトラフィックに使用されるようにネットワークを適切に設定する必要があります。 たとえば、NICをストレージトラフィック専用にするには、使用するストレージコントローラと同じサブネットに属し、管理インターフェイスやほかのセカンダリインターフェイスとは異なるサブネットに属しているIPアドレスを割り当てる必要があります。 また、ストレージターゲットにそのNICからしかアクセスできないように、NIC、ストレージターゲット、スイッチ、およびVLANを設定する必要があります。 これにより、管理対象サーバーに搭載されている複数のNIC間でのトラフィックのルーティングを、標準的なIPルーティングを使用して制御できます。

NICにIPアドレスを割り当ててセカンダリインターフェイスを作成するには、以下のタスクを行います。

  1. リソースプールまたはサーバーの［ネットワーク］タブで、［IPアドレス設定］の［設定］をクリックします。
  2. ［IPアドレスの追加］をクリックします。
  3. 作成するセカンダリインターフェイスの名前を入力します。
  4. ［ネットワーク］ボックスの一覧からXenServerネットワークを選択します。
  5. 以下のネットワーク設定を行います。
    • ネットワーク設定（IPアドレス、サブネットマスク、ゲートウェイなど）をDHCP（Dynamic Host Configuration Protocol）で自動的に割り当てる場合は、［設定をDHCPで自動取得する］をクリックします。
    • ネットワーク設定を手作業で割り当てる場合は、［以下の設定を使用する］をクリックして、必要な値を入力します。 IPアドレスおよびサブネットマスクは必須の指定項目で、ゲートウェイの指定は任意です。
  6. 追加のインターフェイスを作成する場合は、再度［IPアドレス設定］をクリックして上記の手順を繰り返します。
  7. 完了したら、［OK］をクリックして設定を保存します。
    注： ネットワーク設定を手作業で割り当てる場合、設定内容を確認するメッセージが表示されます。 この場合は、内容を確認して［再設定する］をクリックします。

セカンダリインターフェイスを削除するには

  1. リソースプールまたはサーバーの［ネットワーク］タブで、［IPアドレス設定］の［設定］をクリックします。
  2. 設定済みのインターフェイスの一覧でインターフェイスを選択し、［このインターフェイスを削除］をクリックします。
  3. ［OK］をクリックして設定を保存します。

管理インターフェイスを変更するには

  1. リソースプールまたはサーバーの［ネットワーク］タブで、［IPアドレス設定］の［設定］をクリックします。
  2. ［管理］ページの［ネットワーク］ボックスの一覧からXenServerネットワークを選択します。
  3. 以下のネットワーク設定を行います。
    • ネットワーク設定（IPアドレス、サブネットマスク、ゲートウェイ、DNSサーバー）をDHCP（Dynamic Host Configuration Protocol）で自動的に割り当てる場合は、［設定をDHCPで自動取得する］をクリックします。
    • ネットワーク設定を手作業で割り当てる場合は、［以下の設定を使用する］をクリックして、必要な値を入力します。 IPアドレスおよびサブネットマスクは必須の指定項目で、ゲートウェイおよびDNSの指定は任意です。
  4. 完了したら、［OK］をクリックして設定を保存します。
    注： ネットワーク設定を手作業で割り当てる場合、設定内容を確認するメッセージが表示されます。 この場合は、内容を確認して［再設定する］をクリックします。


サーバープロパティの変更

リソースペインで任意の接続済みのサーバーを選択して［全般］タブをクリックすると、そのプロパティと現在の状態が表示されます。 サーバープロパティを変更するには、［全般］タブの［プロパティ］をクリックします。

全般プロパティ - 名前、説明、フォルダ、タグ

サーバーの［プロパティ］ダイアログボックスの［全般］ページでは、サーバーの名前、説明、フォルダ、およびタグを表示したり変更したりできます。

  • サーバー名を変更するには［名前］ボックスに新しい名前を入力します。
  • 説明を変更するには、［説明］ボックスにテキストを入力します。
  • サーバーのフォルダを変更するには、［フォルダ］ボックスの［変更］をクリックして、移動先を指定します。 フォルダの使用について詳しくは、「フォルダの使用」を参照してください。
  • サーバーのタグ付けについて詳しくは、「タグの使用」を参照してください。

iSCSI IQN（［全般］ページ）

サーバーのiSCSI IQNは、iSCSIストレージリポジトリ（SR）に接続するときに、そのサーバーを識別するために使用されます。 XenServerホストでは、ホストのインストール時にランダムなIQNで自動的に作成される単一のiSCSIイニシエータがサポートされます。 この単一のイニシエータを使用して、同時に複数のiSCSIターゲット（SR）に接続できます。 XenServerでのiSCSIストレージのサポートについて詳しくは、『XenServer管理者ガイド』を参照してください。

重要： iSCSIターゲット（SR）およびリソースプール内のすべてのサーバーで、異なるIQNが設定されている必要があります。 IQNが重複していると、データが破損したりアクセスが拒否されたりする場合があります。

サーバーのiSCSI IQN値を変更するには

注： サーバーのiSCSI IQN値を変更する前に、既存のすべてのストレージリポジトリの接続を解除しておく必要があります。 また、IQNの変更によりサーバーが新規または既存のストレージリポジトリに接続できなくなる場合があります。この場合、ストレージリポジトリ側でも適切な変更が必要です。
  1. リソースペインでサーバーを選択して、［全般］タブの［プロパティ］をクリックします。
  2. ［プロパティ］ダイアログボックスの［全般l］タブで、［iSCSI IQN］ボックスに新しい値を入力します。
  3. ［OK］をクリックして変更を保存し、ダイアログボックスを閉じます。

カスタムフィールド

カスタムフィールドを使用すると、管理対象のリソースに情報を追加して、リソースを簡単に検索したり分類したりできます。 カスタムフィールドの使用について詳しくは、「カスタムフィールドの使用」を参照してください。

アラート

このタブでは、サーバーのCPU、メモリ、およびネットワークの使用状況に関するパフォーマンスアラートを設定します。 詳しくは、「パフォーマンスアラートの設定」を参照してください。

メールオプション（スタンドアロンサーバー）

このタブでは、スタンドアロンサーバーで生成されるシステムアラートのメールでの送信先を設定します。 リソースプールに属するサーバーの場合は、プールのプロパティで設定します。 メールによる通知の設定について詳しくは、「XenCenterシステムアラート」を参照してください。

StorageLink Gateway（XenServer 5.6 FP1のスタンドアロンサーバーのみ）

スタンドアロンのXenServer 5.6 Feature Pack 1サーバーからさまざまなストレージアレイにアクセスするときにStorageLink Gatewayサービスを使用している環境では、ここでStorageLink Gatewayサーバーの設定を変更したり接続をテストしたりできます。 1台のStorageLink Gatewayサーバーで複数のリソースプールやスタンドアロンサーバーにストレージを提供している場合は、［すべてのプールとスタンドアロンサーバーでこのStorageLinkサーバーの資格情報を使用する］を選択すると、同じ資格情報が使用されるようになります。

リソースプール内のXenServer 5.6 Feature Pack 1サーバーについては、StorageLink Gatewayストレージ機能の設定をプールレベル（［プール］>［プロパティ］）で行います。

マルチパス

ファイバチャネルおよびiSCSIのストレージリポジトリでは、ストレージの動的なマルチパスがサポートされます。この設定はサーバーの［プロパティ］ダイアログボックスの［マルチパス］タブで有効にできます。

マルチパスを有効にしたり無効にしたりする方法については、「ストレージのマルチパスを有効にする」を参照してください。

電源投入（スタンドアロンサーバー）

このタブでは、サーバーの電源をリモートから制御するためのXenServerホスト電源投入機能について設定します。 この機能の設定について詳しくは、「ホスト電源投入の設定」を参照してください。 リソースプールに属するサーバーの場合は、プールのプロパティで設定します。

ログの記録先

XenServerのシステムログメッセージは、ローカルサーバーまたはリモートサーバーに保存できます。

リモートサーバーでログを受信し正しく集約するには、syslogdデーモンを実行する必要があります。 syslogdデーモンはLinuxとUNIXの標準的な機能で、Windowsやそのほかのオペレーティングシステムで使用できるサードパーティ製のバージョンもあります。 リモートサーバーは、プール内のサーバーから接続できるように、適切なファイアウォール設定をしておく必要があります。

XenServerのログの記録先を表示または変更するには

  1. リソースペインでサーバーを選択して、［全般］タブの［プロパティ］をクリックします。
  2. ［プロパティ］ダイアログボックスの［ログの記録先］タブをクリックし、以下のいずれかを行います。
    • XenServerのログメッセージをローカルに格納する場合は、［ローカル］をクリックします。
    • XenServerのログメッセージを別のサーバーに格納する場合は、［リモート］をクリックしてパス名を入力します。
  3. ［OK］をクリックして変更を保存し、ダイアログボックスを閉じます。


サーバー一覧のエクスポートとインポート

XenCenterで管理しているサーバーの一覧を設定ファイルとしてエクスポートして、ほかのコンピュータ上のXenCenterにインポートできます。 たとえば、デスクトップコンピュータからエクスポートしたサーバー一覧をラップトップ上のXenCenterにインポートすれば、すべてのサーバーを手作業で追加しなくても、簡単に作業を続行できます。

エクスポートしたXenCenter設定ファイルには拡張子「.config」が付き、各サーバーのIPアドレス、DNS名、ポート、および表示名がXML形式で記述されます。 ただし、ログイン用の資格情報はエクスポートされません。

サーバー一覧をエクスポートするには

  1. ［ファイル］メニューから、［サーバー一覧のエクスポート］を選択します。
  2. エクスポート先の場所およびファイル名を指定して、［保存］をクリックします。

サーバー一覧をインポートするには

  1. ［ファイル］メニューから、［サーバー一覧のインポート］を選択します。
  2. インポートするXenCenter設定ファイルを指定して、［開く］をクリックします。

    XenCenterのリソースペインにサーバーが追加され、切断状態のアイコン [image] で示されます。

  3. インポートされたサーバーをリソースペインでダブルクリックすると、各サーバーに接続できます。


リソースプールの管理

  • リソースプールについて
  • リソースプールの要件
  • 新しいプールの作成
  • プールへのサーバーの追加
  • プールからのサーバーの削除
  • プールからのサーバーの破棄
  • 仮想マシンの移行
  • プールの削除
  • プールプロパティの変更
  • ルートパスワードの変更


リソースプールについて

Citrix XenServerのリソースプール（プール）を作成すると、複数のサーバーとそれらの共有ストレージを単一リソースとして管理できます。リソースプールでは、リソース要求や業務上の優先度に応じて、仮想マシン環境を柔軟に展開できます。 1つのプールには、互換性のあるハードウェアを持ち、同じバージョンのXenServerソフトウェア（適用されたパッチも含む）を実行するサーバーを最大で16台まで追加できます。互換性のあるハードウェアやシステム要件については、「リソースプールの要件」を参照してください。

リソースプールでは、1台のサーバーがプールマスタとして動作します。プールマスタは、プール内のすべてのサーバーを代表する単一接続ポイントになり、通信を必要に応じて個々のメンバホストに転送します。

プールマスタをシャットダウンした場合は、そのマスタが再起動してオンライン状態に復帰するまで、または管理者がほかのメンバのいずれかを新しいプールマスタとして指定するまで、リソースプールは機能しません。 リソースプールの各メンバには、必要に応じてプールマスタの役割を引き継ぐための情報がすべて格納されています。 高可用性が有効なプールでは、プールマスタがシャットダウンされると新しいプールマスタが自動的に選出されます。


リソースプールの要件

新しいリソースプールを作成したり、既存のリソースプールにサーバーを追加したりする前に、プールのすべてのサーバーが以下の要件を満たしていることを確認してください。

ハードウェア要件

XenServerのリソースプール内のすべてのサーバーが、以下の互換性のあるCPUを搭載している必要があります。
  • すべてのサーバーのすべてのCPUが、同じベンダ（IntelまたはAMD）のものである。 特に、AMD-VとIntel VTは同一プール内で混在できません。
  • すべてのCPUが同じ機能セットを備えている。 異なる機能セットを備えたCPUが動作するサーバーを同じリソースプールに追加するには、CPUマスキングと呼ばれる機能を使って互換性のない機能を「マスク」できます。
  • HVM（Windows）仮想マシンを実行する場合は、すべてのCPUで仮想化が有効になっている。

CPUマスキングの使用（異種混在型プール）

異なる機能セットを備えたCPUが動作するサーバー間で仮想マシンのライブマイグレーションを行うことはできません。 ただし、最近のCPUに搭載されている、CPU機能の相違を隠して（「マスク」して）ソフトウェア側に提供する技術（CPUマスキング）を利用することで、異なるハードウェア機能を同一であるかのように扱うことができます。このCPUマスキングを使用すると、リソースプール内のすべてのCPUでサポートされる機能だけが有効になり、異なる機能セットを備えたCPUが動作するサーバー間での仮想マシンのライブマイグレーションが可能になります。

この機能は、Intel® Virtualization Technology FlexMigration（Intel® VT FlexMigration）技術およびAMD-V Extended Migration技術により提供されています。

XenServerのリソースプールに新しいサーバーを追加する場合、リソースプール内のCPUおよび新しいサーバーのCPUの機能セットが比較され、互換性が確認されるとサーバーの追加が許可されます。 この互換性チェックでは、CPUで有効になっている機能セットだけが比較されます。 新旧CPUが比較される場合、旧型のCPUで提供される機能だけがCPUマスキングにより新しいCPUで有効になり、新しいCPUにのみ搭載されているそのほかの新機能は「マスク」されます。 これにより、より新しいCPUが搭載されたサーバーを、旧型の（より低機能な）サーバーが動作するリソースプールに追加できるようになります。 このようなリソースプールは、異種混在型プールと呼ばれます。

CPUマスキングを使用しない場合は、リソースプール内のすべてのサーバーで同じ機能セットを備えたCPUが動作している必要があります。このようなリソースプールは、同種型プールと呼ばれます。 XenCenterでは、異なる機能セットのCPUが動作するサーバーをリソースプールに追加することはできません。追加するサーバーでリソースプールと異なる機能セットのCPUが検出されると、自動的にCPUマスキングの使用が試行されます。

そのほかの要件

上記のハードウェア要件に加えて、リソースプールに追加するサーバーは以下の要件を満たしている必要があります。

  • 静的なIPアドレスを保持している（サーバー上またはDHCPサーバー上で固定アドレスが指定されている）。 これは、共有NFSまたはiSCSIストレージを提供するサーバーにも当てはまります。
  • システムの時計がプールマスタの時計と同期している（Network Time Protocolを使用している場合など）。
  • 既存のほかのリソースプールに属していない。
  • プールに追加するサーバー上に実行中または一時停止状態の仮想マシンがない。また、仮想マシンのシャットダウンやエクスポートなど、処理中の操作がない。
  • 共有ストレージが設定されていない。
  • 管理インターフェイスのボンディングが設定されていない。 ボンディングが設定されている場合は、そのサーバーの管理インターフェイスを再設定して、物理NIC上に戻します。必要な場合は、サーバーをプールに追加した後で、ボンディングを再設定できます。詳しくは、「IPアドレスの設定」を参照してください。
  • 実行するXenServerソフトウェアのバージョンおよびパッチレベルが、プールの既存のサーバーと同じである。
  • プールの既存のサーバーと同じサプリメンタルパックがインストールされている。 サプリメンタルパックは、XenServerのコントロールドメイン（dom0）にアドオンソフトウェアをインストールするときに使用されます。 プールでのユーザーエクスペリエンスを一貫させるため、すべてのサーバーに同じサプリメンタルパックの同じリビジョンをインストールする必要があります。
  • リソースプール内の既存のサーバーと同じエディションのXenServer製品ライセンスがインストールされている。 たとえば、XenServer Advanced Editionまたはそれ以上のエディションが動作しているリソースプールに、無償のXenServerシステムを追加することはできません。 これを行うと、Citrixライセンスサーバーから適切なライセンスを割り当てるためのメッセージが表示されます。 詳しくは、「ライセンスの管理」を参照してください。

共有プールストレージ

リソースプールには、1つ以上の共有ストレージリポジトリを設定します。これはリソースプールにおける厳格な技術的要件ではありませんが、共有ストレージリポジトリを設定すると、仮想マシンの実行サーバーを動的に選択したり、サーバー間で仮想マシンを動的に移行したりすることが可能になります。

共有リポジトリを設定するまで、リソースプールを作成しないことをお勧めします。 共有ストレージを追加したら、ローカルストレージ上にディスクを持つ仮想マシンを共有ストレージに移動できます。

共有ストレージリポジトリを持つサーバーがプールマスタとして動作する場合、そのリポジトリがプールの共有ストレージリポジトリになります。 プールマスタに共有ストレージリポジトリがない場合は、そのリソースプールで使用される共有ストレージリポジトリを作成する必要があります。詳しくは、「新しいストレージリポジトリの作成」を参照してください。


新しいプールの作成

新しいプールを作成する前に、新しいプールに配置するすべてのサーバーについて「リソースプールの要件」に記載されている要件が満たされていることを確認します。

新しいプールを作成するには

  1. ［新規プール］をクリックして、［新規プールの作成］ダイアログボックスを開きます。
  2. 新しいリソースプールの名前と説明を入力します。ここで入力した名前がリソースペインに表示されます。
  3. ［マスタ］ボックスの一覧で、プールマスタとして動作するサーバーを選択します。
  4. ［そのほかの追加メンバ］ボックスの一覧で、リソースプールに追加するサーバーを選択します。 ここには、使用できるすべての管理対象サーバーが一覧表示されます。 サーバーが一覧に表示されない場合は、［新規サーバーの追加］をクリックして追加できます。 ただし、管理対象サーバーが一覧に含まれていない場合は、「リソースプールの要件」に記載されている要件を満たしていないことが理由である可能性もあります。
  5. ［プールの作成］をクリックします。新しいリソースプールが作成され、ダイアログボックスが閉じます。
既にプールマスタに共有ストレージリポジトリがある場合は、このリポジトリがプールの共有ストレージリポジトリになります。 プールマスタに共有ストレージリポジトリがない場合は、そのリソースプールで使用される共有ストレージリポジトリを作成する必要があります。詳しくは、「新しいストレージリポジトリの作成」を参照してください。

追加のプール設定手順

新しいプールを設定するには、プロパティタブを使用します。
  1. プールに共有ストレージを追加する手順については、「新しいストレージリポジトリの作成」を参照してください。
  2. プールに複数のサーバーを追加する手順については、「プールへのサーバーの追加」を参照してください。


プールへのサーバーの追加

リソースプールに新しいサーバーを追加する場合は、事前に「リソースプールの要件」を参照し、ハードウェアや構成の要件を満たしていることを確認してください。
重要： サーバーをプールに追加する前に、そのサーバーでホストされているすべての仮想マシンをバックアップしてください。

既存のプールにサーバーを追加するには

  1. リソースペインでサーバーを選択して、次のいずれかを行います。
    • 選択したサーバーを、リソースペインのリソースプール上にドラッグします。
    • ［サーバー］メニューの［プールに追加］を選択し、対象のプールを選択します。
    • サーバーを右クリックして［プールに追加］を選択し、対象のプールを選択します。
  2. ［OK］をクリックして確定します。

サーバーをプールに追加すると、そのサーバーはプールのメンバとして次のようにリソースペインに表示されます。

サーバーをプールに追加するときに以下の問題が生じても、可能な場合はXenCenterにより解決が試行されます。

  • 追加するサーバーのライセンスレベルが、プールマスタのものと同じである必要があります（両者がEnterpriseレベルであるなど）。 プールマスタとライセンスレベルが異なる場合（プールマスタがEnterpriseレベルで新しいサーバーがPlatinumレベルであるなど）、そのサーバーをプールに追加することはできません。

    プールマスタがAdvanced、Enterprise、またはPlatinumレベルの場合、無償のXenServer製品が動作するサーバーを追加すると、適切なライセンスレベルへのアップグレードを確認するメッセージが表示されます。 ここでアップグレードしないと、そのサーバーはプールに追加できません。 使用可能なライセンスがない場合、そのサーバーはプールに追加できません。

    サーバーをプールに追加した後、プールメンバのライセンスを変更することができます。 ただし、そのプールで一番低いレベルのライセンスにより、すべてのプールメンバで使用できる機能が決定されます。 ライセンスについて詳しくは、「ライセンスの管理」を参照してください。

  • プールマスタがドメインに属している場合、そのプールにサーバーを追加するときに、そのサーバーのActive Directoryを設定するためのメッセージが表示されます。 追加するサーバーの資格情報を入力するときは、そのプールのActive Directoryドメイン用の資格情報を使用します。 ただし、サーバーをドメインに追加するための権限が必要です。

サーバーをプールに追加するときに、そのほかのハードウェアまたは構成上の問題が発生する場合があります。リソースプールの要件について詳しくは、「リソースプールの要件」を参照してください。

リソースプールに新しいサーバーを追加すると、ネットワークとボンディングの情報を含むプールマスタのネットワーク設定がそのサーバーに自動的に継承されます。 ただし、追加するサーバーの管理インターフェイスがプールマスタと一致するように変更されることはありません。したがって、プールマスタと同じボンディングを使用するには、サーバーを追加した後で再設定する必要があります。 この手順については、「管理インターフェイスを変更するには」を参照してください。

新しいプールにサーバーを追加するには

［新規プール］ウィザードを使用して、管理対象サーバーを新しいプールに配置します。 以下の手順でサーバーを新しいプールに追加すると、そのサーバーがプールマスタになります。
  1. リソースペインでサーバーを選択します。
  2. サーバーを右クリックして［プールに追加］を選択し、［新規プール］を選択します。
  3. ［新規プールの作成］ダイアログボックスを使用して、リソースプールを作成します。 詳しくは、「新規プールの作成」を参照してください。


プールからのサーバーの削除

重要： サーバーをリソースプールから削除すると、そのローカルディスク（ローカルストレージ）に格納されているすべての仮想マシンデータが消去されます。 サーバーのローカルディスクに重要なデータがある場合は、プール内の共有ストレージリポジトリ上に仮想ディスクを移動してからサーバーを削除してください。
  1. サーバーのローカルディスク上のデータを、同じリソースプールの共有ストレージリポジトリ上に移動します。手順については、「仮想ディスクの移動」を参照してください。
  2. そのサーバー上で実行されている仮想マシンをすべてシャットダウンします。手順については、「仮想マシンのシャットダウン」を参照してください。
  3. リソースペインでサーバーを選択して、次のいずれかを行います。
    • リソースペインで右クリックして［プールからのサーバーの削除］を選択します。
    • ［プール］メニューの［サーバーの削除］を選択します。


プールからのサーバーの破棄

重要： リソースプールからサーバーを破棄すると、そのXenServerホストがローカルストレージ、DVDドライブ、およびリムーバブルストレージと共にプールから完全に削除されます。 このオプションは、接続できなくなったり物理的な障害が発生したりしたサーバーに対して使用してください。 この操作を元に戻すことはできません。
  1. リソースペインでサーバーを選択して、次のいずれかを行います。
    • 右クリックして［破棄］を選択します。
    • ［サーバー］メニューの［破棄］を選択します。
  2. ［破棄する］をクリックして確定します。


プールの削除

リソースプールを削除する場合、そのプールが1台のホストサーバーのみで構成されている必要があります（シングルトンプール）。この場合、プールの削除によりサーバーがスタンドアロンサーバーに切り替わります。

リソースプールを削除するには、リソースペインでリソースプールを選択して、次のいずれかを行います。

  • 右クリックして［プールの削除］を選択します。
  • ［プール］メニューの［プールの削除］を選択します。


プールプロパティの変更

リソースペインで任意のリソースプールを選択して［全般］タブをクリックすると、そのプロパティと現在の状態が表示されます。 プールのプロパティを変更するには、［全般］タブの［プロパティ］をクリックします。

全般プロパティ - 名前、説明、フォルダ、タグ

［プロパティ］ダイアログボックスの［全般］ページでは、プールの名前、説明、フォルダ、およびタグを表示したり変更したりできます。

  • プール名を変更するには［名前］ボックスに新しい名前を入力します。
  • 説明を変更するには、［説明］ボックスにテキストを入力します。
  • プールのフォルダを変更するには、［フォルダ］ボックスの［変更］をクリックして、移動先を指定します。 フォルダの使用について詳しくは、「フォルダの使用」を参照してください。
  • プールのタグ付けについて詳しくは、「タグの使用」を参照してください。

カスタムフィールド

カスタムフィールドを使用すると、管理対象のリソースに情報を追加して、リソースを簡単に検索したり分類したりできます。 カスタムフィールドの使用について詳しくは、「カスタムフィールドの使用」を参照してください。

メールオプション

プール内のいずれかのサーバーおよび仮想マシンに対するシステムアラートが生成されたときに、通知メールが送信されるように設定できます。 メールによる通知の設定について詳しくは、「XenCenterシステムアラート」を参照してください。

StorageLink Gateway（XenServer 5.6 FP1のプールのみ）

XenServer 5.6 Feature Pack 1のリソースプールからさまざまなストレージアレイにアクセスするときにStorageLink Gatewayサービスを使用している環境では、ここでStorageLink Gatewayサーバーの設定を変更したり接続をテストしたりできます。 1台のStorageLink Gatewayサーバーで複数のリソースプールやスタンドアロンサーバーにストレージを提供している場合は、［すべてのプールとスタンドアロンサーバーでこのStorageLinkサーバーの資格情報を使用する］を選択すると、同じ資格情報が使用されるようになります。

スタンドアロンサーバーについては、StorageLink Gatewayストレージ機能の設定はサーバーレベル（［サーバー］>［プロパティ］）で行います。

電源投入

XenServerの電源投入機能では、サーバーがリモートからの電源管理をサポートする場合に、リソースプールの全体的なワークロードに応じて物理サーバーの電源を投入したり切断したりするための電源投入モードを設定できます（ワークロードバランス機能の1つ）。

  • ページ上部の一覧から、電源投入を設定するサーバーを選択します。
  • ［電源投入モード］で、電源投入モード（無効、Wake-on-LAN、HP iLO、DRAC、またはカスタムスクリプト）を選択します。

  • ［設定オプション］では、［電源投入モード］で選択したオプションに応じて、IPアドレスと資格情報、または電源投入スクリプトのキーおよび値を指定します。

ホスト電源投入機能の要件および設定オプションについて詳しくは、「ホスト電源投入の設定」を参照してください。


ルートパスワードの変更

リソースプールのルートパスワードは、そのプールのすべてのサーバーで使用されるパスワードです。このルートパスワードを変更するには、リソースペインでプールまたはプール内の任意のサーバーを選択し、［プール］メニューまたは［サーバー］メニューの［サーバーパスワードの変更］を選択します。

スタンドアロンサーバーのルートパスワードを変更する場合は、リソースペインでそのサーバーを選択し、［サーバー］メニューで［パスワード］、［変更］の順に選択します。

サーバーにログインするための資格情報をXenCenterセッションの終了後も保持するオプションが有効な場合は、ここで変更したパスワードが保持されます。詳しくは、「サーバーの接続状態の保存」を参照してください。


ストレージリポジトリ（SR）の管理

  • XenServerのストレージリポジトリについて
  • 新しいストレージリポジトリの作成
  • ストレージリポジトリの削除
  • ストレージリポジトリの再接続
  • ストレージのマルチパスを有効にする
  • ストレージリポジトリプロパティの変更
  • ストレージリポジトリのアップグレード


XenServerのストレージリポジトリについて

XenServerのストレージリポジトリ（SR）は、仮想ディスクを格納するストレージコンテナです。 ストレージリポジトリおよび仮想ディスクは、XenServerに依存せずに存在する永続的なディスク上のオブジェクトです。 ストレージリポジトリはリソースプール内のサーバー間で共有でき、ローカルディスクデバイスと共有ネットワークストレージを含む、内蔵および外付けのさまざまな種類の物理ストレージデバイス上に設定することができます。 ［新規ストレージリポジトリ］ウィザードでは、さまざまな種類のストレージを使用して新しいストレージリポジトリを作成できます。ストレージの種類により、以下のストレージ機能を設定できます。

  • 動的なマルチパス： ファイバチャネルおよびiSCSIのストレージリポジトリでは、ラウンドロビンモードの負荷分散を使用してストレージをマルチパス化できます。 詳しくは、「ストレージのマルチパスを有効にする」を参照してください。
  • シンプロビジョニング： NetApp、Dell EqualLogic、およびStorageLinkのストレージリポジトリでは、容量管理の種類を選択できます。 デフォルトでは、仮想マシンのディスク領域が不足しないように、そして仮想割り当てがファイラ上で完全に保証されるように、シックプロビジョニングという方法で領域が割り当てられます。 ディスク使用効率の高い シンプロビジョニングでは、仮想マシンからの要求に応じて物理領域が割り当てられるため、実際に使用可能なストレージよりも多くの容量をプロビジョニングでき、ストレージ資産を最大限に活用できます。
    重要： StorageLinkテクノロジのサポート機能は、XenServer 6.2.0リリースでの使用が想定されていません。 XenServer 6.2.0にもこの機能が含まれていますが、将来的にはXenServerから完全に削除される予定です。 この機能のサポートは、XenServer Version 6.1.0のサポートマイルストーンに基づいて提供されます。 詳しくは、CTX137337を参照してください。

サーバーまたはリソースプールを設定するときに、デフォルトのストレージリポジトリを指定します。このリポジトリはクラッシュダンプデータと一時停止状態の仮想マシンのイメージの格納先になり、新しい仮想ディスクのデフォルトのストレージリポジトリになります。 プールのデフォルトストレージリポジトリは、共有ストレージリポジトリである必要があります。 新しい仮想ディスク、クラッシュダンプファイル、またはリソースプールに作成された一時停止状態の仮想マシンのイメージは、プールのデフォルトストレージリポジトリに格納され、物理サーバーの障害からの復元手段を提供します。 スタンドアロンサーバーの場合、デフォルトストレージリポジトリはローカルでも共有でも構いません。 スタンドアロンサーバーに共有ストレージを追加すると、その共有ストレージが自動的にそのサーバーのデフォルトのストレージリポジトリになります。

XenServer xeコマンドラインインターフェイス（CLI）では、仮想マシン、クラッシュダンプデータ、および一時停止イメージをほかのストレージリポジトリに格納することができます。 詳しくは、『XenServer管理者ガイド』を参照してください。


新しいストレージリポジトリの作成

重要： StorageLinkテクノロジのサポート機能は、XenServer 6.2.0リリースでの使用が想定されていません。 XenServer 6.2.0にもこの機能が含まれていますが、将来的にはXenServerから完全に削除される予定です。 この機能のサポートは、XenServer Version 6.1.0のサポートマイルストーンに基づいて提供されます。 詳しくは、CTX137337を参照してください。

新しいストレージリポジトリを作成するには、［新規ストレージリポジトリ］ウィザードを使用します。このウィザードを開くには、ツールバーの［新規ストレージ］をクリックします。

または、次のいずれかを行います。

  • 選択したプールまたはサーバーの［ストレージ］タブで、［新規SR］をクリックします。
  • ［ストレージ］メニューの［新規SR］を選択します。

［新規ストレージリポジトリ］ウィザードの最初のページで、ストレージの種類として物理ストレージを選択し、ウィザードの手順に従ってストレージを設定します。 ウィザードに表示される設定オプションは、ストレージシステムのベンダやモデルにより異なります。 さまざまな種類のストレージリポジトリを作成する方法については、以下の各リンクをクリックしてください。

ストレージリポジトリの作成手順

［新規ストレージリポジトリ］ウィザードでは、ストレージリポジトリの作成手順が順に示されます。

  1. ［種類］ページでは、作成するストレージの種類を選択します。
    オプション | 説明 | 参照先
    NFS VHD | NFS VHDストレージリポジトリでは、共有されたNFSターゲット上の、シンプロビジョニングのVHD形式のファイルとして仮想マシンイメージが格納されます。 NFS V3 over TCP/IPをサポートする既存のNFSサーバーは、そのまま仮想ディスクのストレージリポジトリとして使用できます。 NFSストレージリポジトリを共有すると、NFS VHDストレージリポジトリに仮想ディスクを持つすべての仮想マシンが同一リソースプール内のサーバー間で移行可能になります。 | NFS VHDストレージ
    ソフトウェアiSCSI | ソフトウェアiSCSIストレージリポジトリでは、iSCSIベースのSAN接続ストレージボリューム上で共有された論理ボリュームマネージャ（LVM）が使用されます。iSCSIは、open-iSCSIのソフトウェアiSCSIイニシエータまたはiSCSI HBA（Host Bus Adapter：ホストバスアダプタ）によりサポートされます。 | ソフトウェアiSCSIストレージ
    ハードウェア HBA | ハードウェアHBAストレージリポジトリは、ファイバチャネル（FC）、ファイバチャネルオーバーイーサネット（FCoE）、または共有Serial Attached SCSI（SAS）のLUNにHBAを介して接続します。 この種類のストレージリポジトリを作成するには、LUNを提供するための作業を行ってから［新規ストレージリポジトリ］ウィザードを実行する必要があります。これにより、ウィザードが自動的にLUNを検出して、それを一覧に表示します。 | ハードウェアHBAストレージ
    StorageLinkテクノロジ このオプションでは、NetApp/IBM N SeriesまたはDell EqualLogic PS SeriesアレイにStorageLinkストレージリポジトリを作成できます。このストレージリポジトリでは、ファブリック/イニシエータおよびアレイの自動構成機能へのネイティブアクセスが提供されます。 実際に使用できる機能は、使用するアレイ製品により異なります。
    重要： StorageLinkテクノロジのサポート機能は、XenServer 6.2.0リリースでの使用が想定されていません。 XenServer 6.2.0にもこの機能が含まれていますが、将来的にはXenServerから完全に削除される予定です。 この機能のサポートは、XenServer Version 6.1.0のサポートマイルストーンに基づいて提供されます。 詳しくは、CTX137337を参照してください。
            StorageLinkストレージ（XenServer 5.6 FP1）
    Windowファイル共有（CIFS） | CIFS ISOストレージリポジトリは、Windows（CIFS）共有上のISOファイルとして格納されたCDイメージで使用します。 仮想マシンのインストールイメージなどの共有ISOライブラリを作成する場合に便利です。 | ISOストレージ
    NFS ISO | NFS ISOストレージリポジトリは、NFS共有上のISOファイルとして格納されたCDイメージで使用します。 仮想マシンのインストールイメージなどの共有ISOライブラリを作成する場合に便利です。 | ISOストレージ
  2. ［名前］ページでは、作成するストレージリポジトリの名前を入力します。 デフォルトでは、選択したオプションに基づいて説明が自動生成されます。 独自の説明を作成するには、［SR設定（IPアドレスやLUNなど）から説明を自動生成する］チェックボックスをオフにして、［説明］ボックスに説明を入力します。
  3. ［場所］ページでは、ストレージリポジトリの作成先となるストレージアレイの場所を入力し、必要なオプションを設定します。 このページおよび以降のページで表示されるオプションは、ウィザードの最初のページで選択したストレージの種類により異なります。
  4. ［完了］をクリックすると、新しいストレージリポジトリが作成され、ウィザードが閉じます。


NFS VHDストレージ

NFS VHDストレージリポジトリでは、仮想マシンイメージは、共有されたNFSターゲット上の、シンプロビジョニングされたVHD形式のファイルとして格納されます。 NFS V3 over TCP/IPをサポートする既存のNFSサーバーは、そのまま仮想ディスクのストレージリポジトリとして使用できます。 NFSストレージリポジトリを共有すると、NFS VHDストレージリポジトリに仮想ディスクを持つすべての仮想マシンが同一リソースプール内のサーバー間で移行可能になります。

NFSストレージリポジトリ上の仮想ディスクはスパースで作成されるため、このストレージリポジトリ上にすべての仮想ディスクに対して十分なディスク容量があることを確認する必要があります。

NFS VHDストレージリポジトリを設定するには

  1. ［新規ストレージリポジトリ］ウィザードを開きます。これを行うには、ツールバーの［新規ストレージ］をクリックします。
  2. 物理ストレージの種類として、 ［NFS VHD］をクリックし、［次へ］をクリックします。
  3. ［名前］ページでは、作成するストレージリポジトリの名前を入力します。 デフォルトでは、選択したオプションに基づいて説明が自動生成されます。 独自の説明を作成するには、［説明を自動生成する］チェックボックスをオフにして、［説明］ボックスに説明を入力します。 ［次へ］をクリックして続行します。
  4. ［場所］ページでは、NFSストレージターゲットの詳細を指定します。
    共有名

    サーバーのIPアドレスまたはDNS名とパスです。 <server>:/<ShareName>形式で共有名を入力します。ここで、<server>はサーバーのDNS名またはIPアドレスで、<ShareName>はフォルダやファイルの名前またはパスです。

    指定したパスがプール内のすべてのサーバーにエクスポートされるようにNFSサーバーを設定する必要があります。

    高度なオプション

    追加の設定オプションをここに入力できます。
  5. 指定した場所に既存のNFSストレージリポジトリがあるかどうかスキャンするには、［スキャン］をクリックします。
  6. 未接続の既存のストレージリポジトリが見つかった場合は、新しいストレージリポジトリとして1つ選択して接続することができます。［既存のSRを再接続する］をクリックしてボックスの一覧からストレージリポジトリを選択し、［完了］をクリックします。
  7. 既存のストレージリポジトリが見つからない場合は、［完了］をクリックして新しいストレージリポジトリの設定を完了し、ウィザードを閉じます。


ソフトウェアiSCSIストレージ

ソフトウェアiSCSIストレージリポジトリでは、iSCSIプロトコルによるSAN接続LUN上の共有LVM（論理ボリュームマネージャ）が使用されます。iSCSIは、Open-iSCSIのソフトウェアiSCSIイニシエータまたはiSCSI HBA（Host Bus Adapter：ホストバスアダプタ）によりサポートされます。

iSCSIストレージリポジトリでは、動的なマルチパスがサポートされます。 デフォルトでは、マルチパスでラウンドロビンモードの負荷分散が使用されるため、通常の運用で両方の経路にアクティブなトラフィックが流れます。 ストレージのマルチパスは、サーバーの［プロパティ］ダイアログボックスの［マルチパス］タブで有効または無効にします。詳しくは、「ストレージのマルチパスを有効にする」を参照してください。

ソフトウェアiSCSIストレージリポジトリを作成するには

  1. ［新規ストレージリポジトリ］ウィザードを開きます。これを行うには、ツールバーの［新規ストレージ］をクリックします。 または、次のいずれかを行います。
    • 選択したプールまたはサーバーの［ストレージ］タブで、［新規SR］をクリックします。
    • ［ストレージ］メニューの［新規SR］を選択します。
    • リソースペインでサーバーまたはプールを右クリックして、［新規SR］を選択します。
  2. 物理ストレージの種類として、［ソフトウェアiSCSI］をクリックし、［次へ］をクリックします。
  3. ［名前］ページでは、作成するストレージリポジトリの名前を入力します。 デフォルトでは、選択したオプションに基づいて説明が自動生成されます。 独自の説明を作成するには、［SR設定（IPアドレスやLUNなど）から説明を自動生成する］チェックボックスをオフにして、［説明］ボックスに説明を入力します。 ［次へ］をクリックして続行します。
  4. ［場所］ページでは、iSCSIターゲットの詳細を指定します。
    ターゲットホスト iSCSIターゲットのIPアドレスまたはDNS名です。
    CHAPを使用する iSCSIターゲットがCHAP認証を使用するように設定されている場合は、［CHAPを使用する］チェックボックスをオンにして詳細を入力します。
    • CHAPユーザー：ターゲットに接続するときに適用する必要のあるCHAP認証のユーザー名です。
    • CHAPシークレット：ターゲットに接続するときに適用する必要のあるCHAP認証のパスワードです。
    ターゲットIQN iSCSIターゲットIQNを指定するには、［IQNの検出］をクリックして［ターゲットIQN］ボックスの一覧からIQNを選択します。
    重要： iSCSIターゲットおよびリソースプール内のすべてのサーバーで、異なるIQNが設定されている必要があります。 すべてのiSCSIターゲットおよびイニシエータで固有のIQNを使用することは必須であり、 IQNが重複していると、データが破損したりアクセスが拒否されたりする場合があります。
    ターゲットLUN ストレージリポジトリの作成先となるLUNを指定するには、［LUNの検出］をクリックして［ターゲットLUN］ボックスの一覧からLUNを選択します。

    各iSCSIストレージリポジトリは全体が単一のLUNに含まれる必要があり、複数のLUNにまたがることはできません。 LUNに既にストレージリポジトリが含まれる場合は、既存のストレージリポジトリを使用するか、既存のストレージリポジトリを新しいものと置き換えることができます。後者の場合はディスク上のデータが破棄されます。
  5. ［完了］をクリックして新しいストレージリポジトリの設定を完了し、ウィザードを閉じます。


ハードウェアHBAストレージ

ハードウェアHBAストレージリポジトリは、ファイバチャネル（FC）、ファイバチャネルオーバーイーサネット（FCoE）、または共有Serial Attached SCSI（SAS）のLUNにHBAを介して接続します。 この種類のストレージリポジトリを作成するには、LUNを提供するための作業を行ってから［新規ストレージリポジトリ］ウィザードを実行する必要があります。これにより、ウィザードが自動的にLUNを検出して、それを一覧に表示します。

ファイバチャネルおよびiSCSIのストレージリポジトリでは、動的なマルチパスがサポートされます。 マルチパスを有効にするには、サーバーの［プロパティ］ダイアログボックスの［マルチパス］ページを開きます。詳しくは、「ストレージのマルチパスを有効にする」を参照してください。

ハードウェアHBAストレージリポジトリを作成するには

  1. ［新規ストレージリポジトリ］ウィザードを開きます。これを行うには、ツールバーの［新規ストレージ］をクリックします。 または、次のいずれかを行います。
    • 選択したプールまたはサーバーの［ストレージ］タブで、［新規SR］をクリックします。
    • ［ストレージ］メニューの［新規SR］を選択します。
    • リソースペインでサーバーまたはプールを右クリックして、［新規SR］を選択します。
  2. 物理ストレージの種類として、［ハードウェアHBA］をクリックし、［次へ］をクリックします。
  3. ［名前］ページでは、作成するストレージリポジトリの名前を入力します。 デフォルトでは、選択したオプションに基づいて説明が自動生成されます。 独自の説明を作成するには、［説明を自動生成する］チェックボックスをオフにして、［説明］ボックスに説明を入力します。 ［次へ］をクリックして続行します。
  4. 使用できるLUNが検索され、見つかったすべてのLUNが表示されます。 一覧から、使用するLUNを選択します。
  5. ［完了］をクリックして新しいストレージリポジトリの設定を完了し、ウィザードを閉じます。


StorageLinkストレージ（XenServer 5.6 FP1）

XenServer 5.6 Feature Pack 1が動作するリソースプールおよびスタンドアロンサーバーでは、StorageLinkストレージリポジトリを作成できます。このストレージリポジトリでは、既存のNetwork Appliance™（NetApp）やDell EqualLogic™のストレージインフラストラクチャ、またはCitrix StorageLink Gateway（CSLG）を使用して、さまざまなストレージシステムにアクセスできます。

重要： ここでの説明は、XenServer 5.6 Feature Pack 1が動作するリソースプールおよびスタンドアロンサーバーにのみ適用されます。より新しいバージョンのXenServerでは、異なる手順でStorageLinkストレージリポジトリを作成します。XenServer 5.6 Feature Pack 1よりも新しいバージョンでDell EqualLogicおよびNetAppストレージを構成する手順については、「StorageLinkストレージ」を参照してください。

Citrix StorageLink Gatewayへの接続

StorageLinkサービスのインストールや設定は、XenCenterを使用せずに行います。詳しくは、StorageLinkのドキュメントを参照してください。

これらの手順は、XenServer 5.6 Feature Pack 1が動作するリソースプールおよびスタンドアロンサーバーにのみ適用されます。

StorageLink Gatewayサービスへの接続情報の詳細は、プールの［プロパティ］ダイアログボックス（スタンドアロンサーバーの場合はサーバーの［プロパティ］ダイアログボックス）で表示および変更できます。

StorageLink Gatewayに接続するには

  1. リソースペインでプールまたはスタンドアロンサーバーを選択して、［全般］タブの［プロパティ］をクリックします。

    または、次のいずれかを行います。

    • リソースペインでプールまたはスタンドアロンサーバーを右クリックして、［プロパティ］を選択します。
    • プールでは、［プール］メニューの［プロパティ］を選択します。
    • サーバーでは、［サーバー］メニューの［プロパティ］を選択します。
  2. ダイアログボックスの［Citrix StorageLink Gateway］ページを開き、StorageLink Gatewayサービスを実行しているサーバーのホスト名またはIPアドレス、ユーザー名（デフォルトでadminが設定されており、これを変更することはできません）、およびパスワード（デフォルトでstoragelink）を入力します。
  3. 入力した接続情報をテストするには、［接続のテスト］をクリックします。 Gatewayへの接続が確立されている場合、ダイアログボックスの［接続のテスト］の右側に「成功」というメッセージが表示されます。
  4. 1台のStorageLink Gatewayサーバーで複数のリソースプールやスタンドアロンサーバーにストレージを提供している場合は、［すべてのプールとスタンドアロンサーバーでこのStorageLinkサーバーの資格情報を使用する］を選択すると、すべてのプールやサーバーで同じ資格情報が使用されるようになります。
  5. ［OK］をクリックして、変更を保存し、［プロパティ］ダイアログボックスを閉じます。

StorageLinkストレージリポジトリの作成

これらの手順は、XenServer 5.6 Feature Pack 1が動作するリソースプールおよびスタンドアロンサーバーにのみ適用されます。

StorageLinkストレージリポジトリでは、Citrix StorageLink Gatewayサービスにより、さまざまなiSCSIおよびファイバチャネルアレイへのネイティブアクセスと、ファブリック/イニシエータおよびアレイの自動管理機能が提供されます。 実際に使用できる機能は、使用するアレイ製品により異なります。 1つのストレージアレイ上で、CSLGとほかの種類のストレージリポジトリを共存させることができます。また、1つのリソースプールに複数のCSLGストレージリポジトリを定義することもできます。

  1. ［新規ストレージリポジトリ］ウィザードを開きます。これを行うには、ツールバーの［新規ストレージ］をクリックします。
  2. 物理ストレージの種類として、［StorageLinkテクノロジ］をクリックし、［次へ］をクリックします。
  3. ［名前］ページでは、作成するストレージリポジトリの名前を入力します。 デフォルトでは、選択したオプションに基づいて説明が自動生成されます。 独自の説明を作成するには、［SR設定（IPアドレスやLUNなど）から説明を自動生成する］チェックボックスをオフにして、［説明］ボックスに説明を入力します。

    ［次へ］をクリックして続行します。

  4. ［ストレージシステム］ページでは、使用するストレージシステムを選択します。

    リソースプールでStorageLink Gatewayへの接続が設定済みの場合：

    1. StorageLinkサーバー上の既存のストレージシステムを使用するには、［ストレージシステム］ボックスの一覧でそれを選択します。
    2. この一覧にStorageLinkサーバー上のストレージシステムを追加するには、［追加］をクリックします。開いたダイアログボックスでストレージアダプタを選択し、ホスト名またはIPアドレス、CIMOM名前空間（SIMS-S準拠のストレージシステムの場合）、ポート番号、ユーザー名、およびパスワードを入力して［OK］をクリックします。

    リソースプールでStorageLink Gatewayへの接続が未設定の場合：

    1. ［Citrix StorageLink Gatewayサーバー接続を設定する］をクリックします。
    2. ［プロパティ］ダイアログボックスで、接続に必要な情報を入力します。StorageLink Gatewayサービスを実行しているサーバーのホスト名またはIPアドレス、ユーザー名（デフォルトでadminが設定されており、これを変更することはできません）、およびパスワード（デフォルトでstoragelink）を入力します。

      これにより、［ストレージシステム］ボックスの一覧でこのストレージシステムを選択できるようになります。

  5. 次のページでは、StorageLinkストレージリポジトリの設定を定義します。表示されるオプションは、使用するストレージシステムのベンダ、モデル、およびストレージプールの構成により異なります。
    場所 | 新しいストレージリポジトリを配置するサーバーを指定します。
    ストレージプール | 新しいストレージリポジトリを配置するStorageLinkストレージプールを指定します。 NetAppなど一部のストレージでは、［すべて表示］チェックボックスをオンにしてすべてのストレージプールを表示することもできます。
    RAIDの種類 | ストレージリポジトリで使用するRAIDレベルを指定します（ストレージアレイでサポートされている必要があります）。
    プロビジョニングの種類 | プロビジョニングの種類（デフォルト、シック、またはシン）を指定します。
    プロビジョニングオプション | プロビジョニングオプション（重複排除など）を指定します。
    プロトコル | ホストサーバーをストレージに接続するときに使用されるストレージプロトコル（iSCSI、ファイバチャネル、または自動）を指定します。［自動］を選択すると、システムにより自動的にプロトコルが選択されます。
    CHAP認証を使用する | CHAP認証を行うサーバーでは、このチェックボックスをオンにして、ユーザー名およびパスワードを入力します。
  6. ［完了］をクリックして新しいストレージリポジトリの設定を完了し、ウィザードを閉じます。

Dell EqualLogicストレージリポジトリの設定（直接接続）

これらの手順は、XenServer 5.6 Feature Pack 1が動作するリソースプールおよびスタンドアロンサーバーにのみ適用されます。

XenServer Dell EqualLogicストレージリポジトリは、高性能かつスケーラブルなネットワーク接続ストレージを提供するDell EqualLogicTMファイラに接続します。 このストレージリポジトリでは、仮想ディスクがそれぞれLUNを1つずつ使用してファイラ上に格納されます。また、ストレージアレイを直接制御して、ファイラに搭載されているシンプロビジョニング、スナップショット、および高速複製の機能を使用できます。

  1. ［新規ストレージリポジトリ］ウィザードを開きます。これを行うには、ツールバーの［新規ストレージ］をクリックします。
  2. 物理ストレージの種類として、［StorageLinkテクノロジ］をクリックし、［次へ］をクリックします。
  3. ［名前］ページでは、作成するストレージリポジトリの名前を入力します。 デフォルトでは、選択したオプションに基づいて説明が自動生成されます。 独自の説明を作成するには、［SR設定（IPアドレスやLUNなど）から説明を自動生成する］チェックボックスをオフにして、［説明］ボックスに説明を入力します。

    ［次へ］をクリックして続行します。

  4. ［ストレージシステム］ページでは、［Dell EqualLogic］を選択して［次へ］をクリックします。
  5. ファイラに関する以下の情報を入力して、［次へ］をクリックします。
    名前 | 新しいストレージリポジトリの名前です。この名前はリソースペインに表示されます。
    Dell EqualLogicファイラアドレス | ファイラのIPアドレスまたはDNS名です。
    ユーザー名 | アレイ上のLUNを操作するために使用するログインユーザー名です。
    パスワード | アレイ上のLUNを操作するために使用するログインパスワードです。
    CHAPを使用する Dell EqualLogicファイラがCHAP認証を使用するように設定されている場合は、［CHAPを使用する］チェックボックスをオンにして詳細を入力します。
    • CHAPユーザー：ターゲットに接続するときに適用する必要のあるCHAP認証のユーザー名です。
    • CHAPシークレット：ターゲットに接続するときに適用する必要のあるCHAP認証のパスワードです。

    ［次へ］をクリックすると、ファイラがスキャンされ既存のストレージリポジトリが検索されます。

  6. ファイラ上に見つかった既存のストレージリポジトリを使用するには、［ファイラ上の既存のSRを再接続する］をクリックして一覧からストレージリポジトリを選択します。
  7. ファイラ上に新しいストレージリポジトリを作成するには、［指定したストレージプールにSRを作成する］をクリックして一覧からストレージプールを選択します。 使用できる各ストレージプールについて、合計サイズ、使用可能容量、ボリューム数、プールメンバ数などの情報が表示されます。
  8. EqualLogicのシンプロビジョニング機能を使用するには、［シンプロビジョニングを使用する］チェックボックスをオンにします。 デフォルトではシックプロビジョニングが使用されます。
  9. ［完了］をクリックして新しいストレージリポジトリの設定を完了し、ウィザードを閉じます。

NetAppストレージリポジトリの設定（直接接続）

これらの手順は、XenServer 5.6 Feature Pack 1が動作するリソースプールおよびスタンドアロンサーバーにのみ適用されます。

NetAppストレージシステムでは、ファイラ上での高速スナップショット機能および高速複製機能がサポートされるData ONTAP 7G Version 7.0以降が動作している必要があります。

NetAppストレージリポジトリを設定するには

  1. ［新規ストレージリポジトリ］ウィザードを開きます。これを行うには、ツールバーの［新規ストレージ］をクリックします。
  2. 物理ストレージの種類として、［StorageLinkテクノロジ］をクリックし、［次へ］をクリックします。
  3. ［名前］ページでは、作成するストレージリポジトリの名前を入力します。 デフォルトでは、選択したオプションに基づいて説明が自動生成されます。 独自の説明を作成するには、［SR設定（IPアドレスやLUNなど）から説明を自動生成する］チェックボックスをオフにして、［説明］ボックスに説明を入力します。

    ［次へ］をクリックして続行します。

  4. ［ストレージシステム］ページでは、［NetApp］を選択して［次へ］をクリックします。
  5. ［NetAppファイラ］ページでは、NetAppファイラの詳細を入力します。
    NetAppファイラアドレス | ストレージリポジトリを格納するNetAppサーバーのIPアドレスまたはホスト名です。
    ユーザー名 | ファイラ上のLUNを操作するために使用するログインユーザー名です。
    パスワード | ファイラ上のLUNを操作するために使用するログインパスワードです。
    CHAPを使用する NetAppファイラがCHAP認証を使用するように設定されている場合は、［CHAPを使用する］チェックボックスをオンにして詳細を入力します。
    • CHAPユーザー：CHAP認証に使用されるユーザー名です。
    • CHAPシークレット：CHAP認証に使用されるパスワードです。
  6. ［次へ］をクリックします。既存のストレージリポジトリのNetAppファイラがポーリングされ、アグリゲートされます。完了すると、［NetApp設定］ページが開きます。
  7. 既存のストレージリポジトリに再接続するか、既存のアグリゲートに新しいストレージリポジトリを作成するかを指定して、以下の情報を入力します。
    使用するFlexVolsの数（オプション） | 新しいストレージリポジトリに割り当てるFlexVolの数です。 1から32までのFlexVolを指定できます。デフォルトの値は8です。 ストレージリポジトリに使用するFlexVolの数が多いほど、同じFlexVolにデータが書き込まれる仮想マシンの数が減るため、スナップショットが効率的に作成されます。 また、1つのFlexVolで作成可能なスナップショットの数には上限（通常256）があります。 ただし、現在、ONTAP重複排除アルゴリズムは単一のFlexVolでしか動作しないため、多くのFlexVolを使用すると仮想マシン間の重複排除によるメリットが失われます。
    NetAppシンプロビジョニングを使用する（オプション） | NetAppシンプロビジョニングを使用する場合はこのチェックボックスをオンにします。 デフォルトではシックプロビジョニングが使用されます。 ファイラでONTAP重複排除がサポートされる場合は、［ONTAP重複排除を有効にする］チェックボックスもオンにできます。
  8. ［完了］をクリックして新しいストレージリポジトリの設定を完了し、ウィザードを閉じます。


StorageLinkストレージ

重要： StorageLinkテクノロジのサポート機能は、XenServer 6.2.0リリースでの使用が想定されていません。 XenServer 6.2.0にもこの機能が含まれていますが、将来的にはXenServerから完全に削除される予定です。 この機能のサポートは、XenServer Version 6.1.0のサポートマイルストーンに基づいて提供されます。 詳しくは、CTX137337を参照してください。

StorageLinkストレージリポジトリでは、高性能なストレージへの直接アクセスが提供されます。このため、XenServer環境の仮想マシンで、複製、重複排除、シンプロビジョニング、スナップショットおよび複製、データ保護、パフォーマンス最適化など、アレイにより提供されるエンタープライズレベルのストレージサービスを利用できます。

StorageLinkストレージリポジトリは、ストレージアダプタを使って、一般的なあらゆるストレージテクノロジ上のさまざまなストレージアレイにアクセスします。このストレージテクノロジには、ファイバチャネルまたはiSCSI上のNASやSANなどが含まれます。 StorageLinkストレージリポジトリで実際に使用できる機能は、使用するアレイ製品により異なります。 1つのストレージアレイ上で、StorageLinkとほかの種類のストレージリポジトリを共存させることができます。また、1つのリソースプールに複数のStorageLinkストレージリポジトリを定義することもできます。

環境や使用目的により異なりますが、StorageLinkには以下の長所があります。

  • StorageLinkストレージリポジトリでは、ストレージのアクセスにストレージ管理ソフトウェアが使用されます。
  • StorageLinkを使用すると、ストレージの設定プロセスが簡略化されます。 たとえば、XenCenterでStorageLinkストレージリポジトリを作成する場合、LUN、ボリューム、およびイニシエータグループが自動的に作成されます。 このため、管理者がストレージ管理ソフトウェアを使ってこれらの項目を作成する必要はありません。 ただし、事前にアグリゲートを作成しておく必要があります。
  • 作成されるすべてのVDIに独自のLUNが設定されます。 すべてのStorageLinkストレージリポジトリで、各仮想ディスク（VDI）に新しいLUNがプロビジョニングされるLUN-per-VDIモデルが使用されます。

デフォルトのXenServerブロックデバイスベースのストレージは、論理ボリュームマネージャ（LVM）をローカル接続のデバイス（LVMストレージリポジトリ）またはSAN接続のLUN（ファイバチャネル接続のLVMoHBAストレージリポジトリ、iSCSI接続のLVMoISCSIストレージリポジトリ、またはSAS接続のLVMoHBAストレージリポジトリ）のディスク上に挿入します。 StorageLinkを使用してストレージリポジトリを設定すると、LUNはVDIとして仮想マシンに直接マップされます。 この結果、抽象化されたVDIとアレイストレージが一致するため、アレイレベルでストレージプロビジョニングを管理する場合に便利です。

注： StorageLinkストレージリポジトリは、XenDesktopではサポートされません。

StorageLinkストレージリポジトリの作成方法

新しいストレージリポジトリの作成StorageLinkによるボリュームの自動作成を使用するか（デフォルト）、事前にボリュームを作成しておきます。 ただし、デフォルトの作成方法がすべての環境に最適であるとは限りません。

StorageLinkによるボリューム作成（デフォルト）
StorageLinkストレージリポジトリのデフォルトの作成方法では、新規ストレージリポジトリウィザードでアグリゲートを選択すると、StorageLinkによりボリュームとLUNが自動的に作成されます。 この方法でストレージリポジトリを作成すると、個別のボリュームのLUNが各VDIに設定されます。 ただし、多くのVDIを作成する環境でこの方法を使用すると、ボリューム数が多くなってしまします。 一部のストレージベンダでは、ストレージアレイ上に作成するボリュームの数に推奨最大値を設定しています。 また、このデフォルトの作成方法ではボリューム名が自動的に設定されるため、ボリューム管理が複雑になる場合があります。 さらに、共通のデータ（オペレーティングシステムやアプリケーションなど）により消費されるボリューム領域を排除する機能（重複排除）を使用することもできません。
ボリュームの事前作成
推奨されるStorageLinkストレージリポジトリの作成方法は、事前にボリュームを作成しておき、新規ストレージリポジトリウィザードで（［すべて表示］をクリックして）そのボリュームを選択することです。 この方法でも各仮想ディスクにLUNが設定されますが、自動生成の（意味のない）名前を持つボリュームが多く作成されるという問題を避けることができます。
事前にボリュームを作成してStorageLinkストレージリポジトリを作成すると、ボリューム管理が容易になります。 この方法では、選択したボリュームのLUNが各VDIに設定されます。 ただし、ボリューム数が多くなって管理不能になる状況を避けることができます。 この方法を使用すると、ボリューム数を増やさずに多くのVDIを作成できます。 また、各ボリュームにその内容を示すユーザーフレンドリな名前を設定することもできます。 事前にボリュームを作成しておく方法では、重複排除機能を使用して、複数の仮想ディスクイメージが持つ共通データ（オペレーティングシステムやアプリケーションなど）を同一ボリューム上に格納できるため、ストレージを効率的に使用できます。

NetAppアレイのStorageLinkストレージリポジトリの作成

StorageLinkでストレージリポジトリ（およびそのLUNとボリューム）を作成すると、Linuxオペレーティングシステムによるイニシエータグループが自動的に作成されます。 ほかのオペレーティングシステムを使用してイニシエータグループを設定することは推奨されません。

注： StorageLinkでファイバチャネルストレージリポジトリを作成するには、NetAppストレージコントローラの初回検出時にストレージ上にiSCSIライセンスが存在しているか、ONTAP 8.1を実行している必要があります。 これらのいずれかの条件が当てはまらない場合、「新しいストレージリポジトリの作成」で説明されている標準的な方法（StorageLinkを使用せずに）ストレージリポジトリを作成してください。

StorageLinkでNetAppストレージアレイに接続するには、ストレージアレイ上でhttpdを有効にしてから新規ストレージリポジトリウィザードを開始する必要があります。

リソースプールで、XenServer EnterpriseまたはXenServer Platinumが動作している必要があります。

注： ここで説明するXenCenterでのStoragelink（Dell EqualLogicおよびNetApp）ストレージリポジトリの作成手順は、XenServer Version 6.0以降が動作するサーバーにのみ適用されます。 XenServer Version 5.6 FP1での作成手順については、「StorageLinkストレージ（XenServer 5.6 FP1）」を参照してください。

StorageLinkストレージリポジトリを作成するには

  1. ［新規ストレージリポジトリ］ウィザードを開きます。これを行うには、ツールバーの［新規ストレージ］をクリックします。

    または、次のいずれかを行います。

    • 選択したプールまたはサーバーの［ストレージ］タブで、［新規SR］をクリックします。
    • ［ストレージ］メニューの［新規SR］を選択します。
    • リソースペインでサーバーまたはプールを右クリックして、［新規SR］を選択します。
  2. 物理ストレージの種類として、［StorageLinkテクノロジ］をクリックし、［次へ］をクリックします。
  3. ［名前］ページでは、作成するストレージリポジトリの名前を入力します。 デフォルトでは、選択したオプションに基づいて説明が自動生成されます。 独自の説明を作成するには、［SR設定（IPアドレスやLUNなど）から説明を自動生成する］チェックボックスをオフにして、［説明］ボックスに説明を入力します。

    ［次へ］をクリックして続行します。

  4. ［ストレージアダプタ］ページでは、使用するストレージシステムアダプタを選択して［次へ］をクリックします。
  5. ［ストレージシステム］ページでは、このストレージリポジトリのストレージをホストするストレージシステムを選択します。
    1. ［アレイターゲット］ボックスで、アレイの管理コンソールのホスト名またはIPアドレスを入力します。
    2. ［資格情報］で、アレイの管理コンソールに接続するためのユーザー名とパスワードを入力します。
    3. ［検出］をクリックして、ストレージシステムのターゲットアレイを検出します。 検出が完了したら、［ストレージシステム］ボックスの一覧でストレージシステムを選択し、［次へ］をクリックします。
  6. ［設定］ページでは、ストレージリポジトリの設定を定義します。表示されるオプションは、使用するストレージシステムのベンダ、モデル、およびストレージプールの構成により異なります。
    ストレージプール | ストレージ割り当てに使用するストレージシステム内のストレージプールを識別するための情報です。 一部のストレージシステムでは、［すべて表示］チェックボックスをオンにしてすべてのストレージプールを表示することもできます。
    RAIDの種類 | ストレージリポジトリで使用するRAIDレベルを指定します（ストレージアレイでサポートされている必要があります）。
    プロビジョニングの種類: プロビジョニングの種類（デフォルト、シック、またはシン）を指定します。
    プロビジョニングオプション | プロビジョニングオプション（重複排除など）を指定します。
    プロトコル | ホストサーバーをストレージに接続するときに使用されるストレージプロトコル（iSCSI、ファイバチャネル、または自動）を指定します。［自動］を選択すると、システムにより自動的にプロトコルが選択されます。
    CHAP認証を使用する | CHAP認証を行うサーバーでは、このチェックボックスをオンにして、ユーザー名およびパスワードを入力します。
  7. ［完了］をクリックして新しいストレージリポジトリの設定を完了し、ウィザードを閉じます。

StorageLinkでファイバチャネルのストレージリポジトリとLUNを作成するには

  1. リソースペインでプールを右クリックして、［新規SR］を選択します。
  2. ［StorageLink Web］をクリックして、［次へ］をクリックします。
  3. ［名前］ボックスにストレージリポジトリの名前を入力して、［次へ］をクリックします。
  4. ［ストレージアダプタ］ページで［NetApp/IBM N Series Storage Adapter］を選択して、［次へ］をクリックします。
  5. ［ストレージシステム］ページで、以下を行います。
    1. ［アレイターゲット］ボックスに、ストレージコントローラのIPアドレスを入力します。 StorageLinkは、まずIPを使ってストレージと通信します。
    2. ［資格情報］でストレージにアクセスするためのユーザー名とパスワードを入力して、［検出］をクリックします。
  6. ［ストレージシステム］ボックスにNetAppコントローラが表示されたら、［次へ］をクリックします。
  7. ［設定］ページで、LUNの設定を行います。
    1. ［ストレージプール］ボックスで、LUNを作成するアグリゲートを選択します。
      注： NetApp社では、システムファイル用に予約されているaggr0アグリゲート上にLUNを作成することを推奨していません。
    2. ［RAIDの種類］ボックスで、LUNをフォーマットするRAIDレベルを選択します。 「RAID6」は、NetAppのRAID-DP RAIDに相当します。
    3. ［プロビジョニングの種類］ボックスで、シックプロビジョニングまたはシンプロビジョニングを選択します。 使用量に応じてストレージに領域を割り当てるには、［NetAppシンプロビジョニングを使用する］チェックボックスをオンにします。
    4. ［プロビジョニングオプション］ボックスで、［なし］または［重複排除］を選択します。
    5. ［プロトコル］ボックスで、［ファイバチャネル］を選択します。
  8. ［完了］をクリックします。これにより、ストレージリポジトリとLUNが作成されます。 StorageLinkによりストレージリポジトリとLUNが作成されると、そのストレージリポジトリがリソースペインに表示されます。


ISOストレージ

仮想マシンのインストールイメージなどの共有ISOライブラリを作成する場合に便利です。 ISOファイル形式のCDイメージを格納するためのストレージリポジトリとして、以下の2種類のISOストレージを作成できます。
  • NFS ISOストレージリポジトリは、NFS共有上のISOファイルとして格納されたCDイメージで使用します。
  • CIFS ISOストレージリポジトリは、Windows（CIFS）共有上のISOファイルとして格納されたCDイメージで使用します。

ISOストレージリポジトリを設定するには

  1. ［新規ストレージリポジトリ］ウィザードを開きます。これを行うには、ツールバーの［新規ストレージ］をクリックします。
  2. ストレージの種類として、［ISOライブラリ］の［Windowsファイル共有（CIFS）］または［NFS ISO］をクリックし、［次へ］をクリックします。
  3. ［名前］ページでは、作成するストレージリポジトリの名前を入力します。 デフォルトでは、選択したオプションに基づいて説明が自動生成されます。 独自の説明を作成するには、［説明を自動生成する］チェックボックスをオフにして、［説明］ボックスに説明を入力します。

    ［次へ］をクリックして続行します。

  4. ［場所］ページでは、ISOストレージターゲットの詳細を指定します。
    共有名 | \\<server>\<ShareName>（CIFS）または<server>:/<ShareName>（NFS）形式で共有名を入力します。ここで、<server>はサーバーのDNS名またはIPアドレス、<ShareName>はフォルダまたはファイルの名前を指します。
    異なるユーザー名を使用する | （CIFSのみ）別のユーザー名を使用してCIFSサーバーに接続する場合は、このチェックボックスをオンにしてからログインユーザー名とパスワードを入力します。
  5. ［完了］をクリックして新しいストレージリポジトリの設定を完了し、ウィザードを閉じます。


ストレージリポジトリの削除

XenCenterを使用して、ストレージリポジトリを一時的または恒久的に削除できます。
  • 接続の解除： ストレージリポジトリの接続を解除すると、ストレージデバイスとプールまたはサーバーの間の関連付けが削除され、仮想ディスクにアクセスできなくなります。 仮想ディスクの内容と、仮想ディスクにアクセスするために仮想マシンで使用されるメタ情報は保持されます。 保守などのためにストレージリポジトリを一時的にオフラインにする必要があるときに 接続を解除します。 接続を解除したストレージリポジトリは後で再接続できます。詳しくは、「ストレージリポジトリの再接続」を参照してください。
  • 接続の消去： ストレージリポジトリの接続を消去すると、ストレージリポジトリ上の仮想ディスクの内容は保持されますが、仮想ディスクにアクセスするために仮想マシンで使用される情報は完全に削除されます。 このストレージリポジトリは、リソースペインからも削除されます。

    ［接続の消去］操作は取り消せません。

  • 破棄： ストレージリポジトリを破棄すると、そのストレージリポジトリの内容が完全に削除され、リソースペインにそのストレージリポジトリが表示されなくなります。

    ［破棄］操作は取り消せません。 ストレージリポジトリの破棄方法については、『XenServer管理者ガイド』を参照してください。

注： 実行中の仮想マシンの仮想ディスクを格納しているストレージリポジトリは削除できません。

ストレージリポジトリの接続を解除するには

  1. リソースペインでストレージリポジトリを選択して、［ストレージ］タブをクリックします。
  2. すべての仮想マシンに接続されている仮想ディスクの一覧が表示されます。
  3. 仮想マシンから仮想ディスクの接続を解除します。 詳しくは、「仮想ディスクの接続解除」を参照してください。
  4. リソースペインでストレージリポジトリを選択して、次のいずれかを行います。
    • リソースペインで右クリックして、［接続解除］を選択します。
    • ［ストレージ］メニューの［接続解除］を選択します。
  5. ［はい］をクリックして確定します。

ストレージリポジトリの接続を消去するには

iSCSIなど、一部の種類のストレージリポジトリでは、ストレージリポジトリを消去する前に接続を解除する必要があります。
重要：

ストレージリポジトリの接続の消去操作は取り消せません。 そのストレージリポジトリ上の仮想ディスクを仮想マシンに接続するための情報は、完全に削除されます。

ストレージリポジトリを消去するには、以下の手順に従います。

  1. リソースペインでストレージリポジトリを選択して、次のいずれかを行います。
    • リソースペインで右クリックして、［接続の消去］を選択します。
    • ［ストレージ］メニューの［接続の消去］を選択します。
  2. ［消去する］をクリックして確定します。


ストレージリポジトリの再接続

ストレージリポジトリとの接続を解除すると、プールやサーバーとストレージデバイスとの関連付けは削除されますが、デバイス上のデータは保持されます。 XenCenterでサーバーにストレージリポジトリを再接続するときは、新しいストレージリポジトリを追加するときと同様に、ストレージ設定情報を入力する必要があります。

接続解除済みのストレージリポジトリを再接続するには

  1. リソースペインで接続が解除されているストレージリポジトリを選択して、次のいずれかを行います。
    • リソースペインで右クリックして、［ストレージリポジトリの再接続］を選択します。
    • ［ストレージ］メニューの［ストレージリポジトリの再接続］を選択します。
  2. 新しいストレージリポジトリを追加するときと同様に、必要な設定情報を入力します。 詳しくは、以下のトピックを参照してください。
    • NFS VHDストレージ
    • ソフトウェアiSCSIストレージ
    • ハードウェアHBAストレージ
    • StorageLinkストレージ
    • ISOストレージ
  3. ［完了］をクリックしてストレージリポジトリの設定を完了し、ウィザードを閉じます。


ストレージのマルチパスを有効にする

ファイバチャネルおよびiSCSIのストレージリポジトリでは、動的なマルチパスがサポートされます。 デフォルトでは、マルチパスでラウンドロビンモードの負荷分散が使用されるため、通常の運用で両方の経路にアクティブなトラフィックが流れます。 ストレージのマルチパスは、サーバーの［プロパティ］ダイアログボックスの［マルチパス］タブで有効または無効にします。

マルチパスを有効にする前に次の作業を行います。

  • ストレージサーバーで複数のターゲットが使用できることを確認します。
  • サーバーを保守モードにしておく必要があります。これにより、実行中のすべての仮想マシンが移行され、仮想ディスクを格納しているストレージリポジトリをマルチパス化できる状態になります。
  • マルチパスの設定は、プール内の各ホスト上で行う必要があります。 実際のケーブル接続やサブネット設定（iSCSIの場合）は、各ホスト上のNICと一致している必要があります （たとえば、すべてのホストのNIC 3に同じサブネットが設定されているなど。 詳しくは、「IPアドレスの設定」を参照してください）。

マルチパス設定の技術的な情報については、『Configuring iSCSI Multipathing Support for XenServer』ガイドおよび『XenServer管理者ガイド』を参照してください。

マルチパスを有効にするには

  1. リソースペインでサーバーを選択して、保守モードに切り替えます。 アクティブな仮想マシンの移行と既存のストレージのアンプラグが完了するまで少し時間がかかります。サーバーがプールマスタの場合はXenCenterから切断され、新しいプールマスタが選出されるまで一時的にリソースペインに表示されなくなります。 リソースペインに アイコン アイコン付きでサーバーが再表示されたら、次の手順に進みます。
  2. ［全般］タブで［プロパティ］をクリックして、［マルチパス］タブをクリックします。
  3. マルチパスを有効にするには、［このサーバーのマルチパスを有効にする］チェックボックスをオンにします。 マルチパスを無効にするには、このチェックボックスをオフにします。
  4. ［OK］をクリックして新しい設定を適用し、ダイアログボックスを閉じます。 新しいストレージ設定の保存が完了するまで少し時間がかかります。
  5. サーバーを保守モードから切り替えます。リソースペインでサーバーを右クリックして、［保守モードからの切り替え］を選択します。


ストレージリポジトリプロパティの変更

ストレージの［プロパティ］ダイアログボックスでは、ストレージの詳細を変更したり、フォルダ、タグ、カスタムフィールドなどを使用してリソースを整理したりできます。また、ストレージのスループット量が特定のしきい値を超えたときにアラートが生成されるように設定することもます。

ストレージリポジトリの詳細を表示するには、リソースペインでサーバーまたはリソースプールを選択して、［ストレージ］タブをクリックします。 ローカルストレージおよび共有ストレージの名前、説明、種類、使用量、サイズなどの情報が表示されます。 一覧でストレージリポジトリを選択して、［プロパティ］をクリックします。

全般

［全般］ページでは、ストレージリポジトリの名前、説明、フォルダ、およびタグを表示したり変更したりできます。

  • ストレージリポジトリ名を変更するには［名前］ボックスに新しい名前を入力します。
  • 説明を変更するには、［説明］ボックスにテキストを入力します。
  • ストレージリポジトリのフォルダを変更するには、［フォルダ］ボックスの［変更］をクリックして、移動先を指定します。 フォルダの使用について詳しくは、「フォルダの使用」を参照してください。
  • ストレージリポジトリのタグ付けについて詳しくは、「タグの使用」を参照してください。

カスタムフィールド

カスタムフィールドを使用すると、そのストレージリポジトリを簡単に検索したり分類したりできるように、任意の情報を追加できます。 カスタムフィールドを作成して、ストレージリポジトリを検索したり分類したりするための情報を追加します。 カスタムフィールドの使用について詳しくは、「カスタムフィールドの使用」を参照してください。

アラート

［アラート］ページでは、PBD（Physical Block Device：物理ブロックデバイス）上の読み取りおよび書き込み時の総スループット量が特定のしきい値を超えたときにストレージスループットアラートが生成されるように設定できます。 ［ストレージスループットアラートを有効にする］チェックボックスをオンにして、スループットの上限値および許容時間を指定します。

注： PBDは、XenServerホストとそのストレージリポジトリ間のインターフェイスです。 PBD上の読み取りおよび書き込み時の総スループット量が指定のしきい値を超えると、そのPBDが接続されているホスト上でアラートが生成されます。 ほかのホストアラートとは異なり、このアラートはストレージリポジトリに対して設定します。


ストレージリポジトリのアップグレード

XenServer 5.5以降では、LVMストレージリポジトリでMicrosoft社のVHDテクノロジを使用して、高速な複製とスナップショット機能を提供します。

以前のバージョンのXenServerで作成したLVMストレージリポジトリは、XenCenterやXenServer xeコマンドラインインターフェイス（CLI）を使用して簡単にLVHD形式にアップグレードできます。 アップグレード可能なストレージリポジトリには、XenCenterの［全般］タブと［検索］タブで「このSRはアップグレードが必要です」というメッセージが表示されます。

アップグレードしたストレージリポジトリをダウングレードすることはできません。

LVMストレージをLVHD形式にアップグレードするには

リソースペインでストレージリポジトリを選択して、次のいずれかを行います。

  • ストレージリポジトリを右クリックして［ストレージリポジトリをアップグレード］を選択します。
  • ［ストレージ］メニューの［アップグレード］を選択します。
  • ［全般］タブまたは［検索］タブで、「このSRはアップグレードが必要です」というメッセージをクリックします。


仮想マシンの作成

トピック

  • 仮想マシンとテンプレートについて
  • 新規仮想マシンの作成（新規VMウィザード）
    • テンプレートとBIOSオプション
    • 仮想マシンの名前と説明
    • オペレーティングシステムのインストールメディア
    • ホームサーバー
    • CPUとメモリの設定
    • 仮想ディスクの設定
    • 仮想ネットワークインターフェイスの設定
    • 仮想マシン作成の完了
  • 仮想マシンの高速（無人）作成
  • 新規テンプレートの作成
  • 仮想マシンとテンプレートのコピー


仮想マシンとテンプレートについて

仮想マシン（VM：Virtual Machine）とは、物理コンピュータ上で実行され、物理コンピュータと同じように振る舞うソフトウェアコンテナ（「ゲスト」と呼ばれることもあります）を指します。 仮想マシンは、オペレーティングシステム、CPU、メモリ（RAM）、ネットワークリソース、およびアプリケーションソフトウェアにより構成されます。

テンプレートは、ファイルにカプセル化された仮想マシンを指します。テンプレートを使用すると、新しい仮想マシンを高速に配備できます。 各テンプレートには、特定のゲストオペレーティングシステムで新しい仮想マシンを作成するために必要なインストールメタデータと、最適なストレージ、CPU、メモリ、および仮想ネットワークの設定が含まれています。

XenCenterでは、いくつかの方法で仮想マシンを作成できます。

  • ［新規VM］ウィザードを使用する。このウィザードでは、テンプレートまたはスナップショットから仮想マシンを作成する手順が順に示されます。これには、オペレーティングシステム、CPU、ストレージ、ネットワーク、およびほかのパラメータの設定が含まれます。
  • カスタムの仮想マシンテンプレートを使用する。このテンプレートには必要なパラメータ設定がすべて含まれているため、［新規VM］ウィザードを使用せずに仮想マシンを作成できます。 これを行うには、XenCenterでカスタムテンプレートを右クリックして、［テンプレートからの高速VM］を選択します。この方法は、管理者の介在が不要なため、同じ仮想マシンを大量に作成するときに便利です。
  • 既存の仮想マシンをコピー（クローン）する。
  • 事前にエクスポートしておいた仮想マシンをインポートする。

XenServer PVドライバ – XenServer Tools

XenServer環境での仮想マシンには、完全に仮想化（HVM）されたものと準仮想化されたものの2種類があります。

  • HVM（Hardware Virtual MachineまたはHardware-assisted Virtualization）モードの仮想マシンは完全に仮想化され、ゲストオペレーティングシステムの設定を変更しなくても、仮想化に対応したハードウェアの本来のプロセッサ速度に近い速度で実行できます。
  • 準仮想化（非HVM）モードでは、ゲストオペレーティングシステムが仮想化環境での実行用に調整および最適化されるため、処理速度がプロセッサの性能に影響されません。 その結果、パフォーマンスが向上し、優れた柔軟性が得られます。

Windows仮想マシンおよびLinux仮想マシンに準仮想化ドライバをインストールして、ディスクとネットワークのパフォーマンスを向上させることができます。 これらのドライバはXenServer Toolsパッケージに収録されており、すべての仮想マシンにインストールする必要があります。詳しくは、「XenServer Toolsのインストール」を参照してください。 仮想マシンの移行やパフォーマンスの履歴データ追跡などのXenServer機能は、XenServer Toolsがインストールされた仮想マシンでしか使用できません。

テンプレートの使用

XenServerには多くのテンプレートが付属しており、新しい仮想マシンにさまざまなゲストオペレーティングシステムをインストールするために必要なすべての構成が設定されています。 適切なゲストオペレーティングシステム、メモリ、CPU、ストレージ、およびネットワーク設定を使用して独自のカスタムテンプレートを作成して、それを使用して新しい仮想マシンを作成することもできます。 このリリースでサポートされるWindowsおよびLinuxのテンプレート/オペレーティングシステムの一覧、および仮想マシンへのインストール方法の詳細については、『XenServer仮想マシンユーザーガイド』を参照してください。

XenServerの付属のテンプレートおよびカスタムのテンプレートは、XenCenterのリソースペインに表示されます。

  • XenServerテンプレートアイコン XenServerテンプレート
  • カスタムテンプレートアイコン カスタムテンプレート

リソースペインのサーバービューでは、XenServerの付属のテンプレートおよびカスタムのテンプレートを非表示にすることができます。

  • 標準XenServer仮想マシンテンプレートを表示するには、［表示］メニューの［サーバービュー］をクリックし、［XenServerテンプレート］を選択します。標準テンプレートを非表示にするには、このコマンドを選択解除します。
  • カスタムの仮想マシンテンプレートを表示するには、［表示］メニューの［サーバービュー］をクリックし、［カスタムテンプレート］を選択します。カスタムテンプレートを非表示にするには、このコマンドを選択解除します。


新規仮想マシンの作成

［新規VM］ウィザードでは、仮想マシン（VM）の作成手順が順に示されます。 ［新規VM］ウィザードを開始するには、ツールバーで ［新規VM］をクリックします。

または、次のいずれかを行います。

  • Ctrl+Nキーを押します。
  • ［VM］メニューの［新規VM］を選択します。
  • リソースペインでサーバーを右クリックし、［新規VM］を選択します。

このウィザードでは、CPU、ストレージ、ネットワークなどの設定パラメータを選択しながら、目的に応じた仮想マシンを作成できます。 ウィザードの最初のページで選択する仮想マシンテンプレートに応じて、異なる設定オプションが以降のページで表示されます。これは、インストールオプションが各ゲストオペレーティングシステム用に最適化されているためです。 操作方法について詳しくは、ウィザードの各ページで ［ヘルプ］をクリックするか、F1キーを押します。

役割ベースのアクセス制御（RBAC）が実装されたXenServer環境では、［新規VM］ウィザードを開始したときに、仮想マシンを作成するための権限があるかどうかがチェックされます。 VMオペレータや読み取り専用の役割が付与された管理者など、必要な権限がない場合、このウィザードで仮想マシンを作成することはできません。 詳しくは、「役割ベースのアクセス制御（RBAC）の概要」を参照してください。

仮想マシンの作成手順の概要

［新規VM］ウィザードでは、以下の手順が表示されます。

  1. テンプレートを選択する。

    まず、仮想マシンテンプレートを選択します。 各テンプレートには、特定のゲストオペレーティングシステムで新しい仮想マシンを作成するために必要な情報と、最適なストレージ、CPU、メモリ、および仮想ネットワークの設定が含まれています。 XenServerには多くのテンプレートが付属しており、必要に応じて独自のカスタムテンプレートを追加できます。 この手順について詳しくは、「テンプレートとBIOSオプション」を参照してください。

  2. 新しい仮想マシンの名前を入力する。

    次に、新しい仮想マシンの名前と、必要に応じて説明を入力します。 XenCenterでは、仮想マシン名が重複しているかどうかがチェックされません。このため、仮想マシンの内容を表すわかりやすい名前を使用してください。 この手順について詳しくは、「仮想マシンの名前と説明」を参照してください。

  3. オペレーティングシステムのインストールメディアを指定する。

    次に、オペレーティングシステムのインストールメディアの種類および場所を指定します。 Windowsオペレーティングシステムの場合、ISOライブラリ、物理DVD/CDドライブ内のインストールメディア（CDまたはDVD-ROM）、またはネットワーク上のブートサーバーからインストールできます。 Linuxオペレーティングシステムは、ネットワーク上のインストールリポジトリからインストールできます。 この手順について詳しくは、「オペレーティングシステムのインストールメディア」を参照してください。

  4. ホームサーバーを選択する。

    必要に応じて、新しい仮想マシンのホームサーバーを指定できます。 ホームサーバーとは、仮想マシンのデフォルトの起動サーバーを指します。 この手順について詳しくは、「ホームサーバー」を参照してください。

  5. CPUとメモリを設定する。

    次に、新しい仮想マシンに割り当てるVCPU（Virtual CPU：仮想CPU）の数とメモリの量を指定します。 これらの値は、仮想マシンの作成後に変更することもできます。 この手順について詳しくは、「仮想マシンのCPUとメモリの設定」を参照してください。

  6. ストレージを設定する。

    次に、新しい仮想マシンの仮想ディスクを設定します。 ウィザードにより、自動的に1つの仮想ディスクが設定されます。選択したテンプレートによっては、複数の仮想ディスクが設定される場合もあります。 この手順について詳しくは、「仮想ディスクの設定」を参照してください。

  7. ネットワークを設定する。

    最後に、ネットワークを設定します。 各仮想マシンには、最大で4つの仮想ネットワークインターフェイスを設定できます。 この手順について詳しくは、「仮想ネットワークの設定」を参照してください。

  8. 仮想マシン作成を完了する。

    ウィザードの最後のページでは、選択した設定内容を確認できます。 新しい仮想マシンを直ちに起動するには、［VMを自動的に起動する］チェックボックスをオンにします。


仮想マシンテンプレートとBIOSオプション

XenServerにはさまざまな仮想マシンテンプレートが付属しており、いくつかの方法で新しい仮想マシンを作成できます。 各テンプレートには、特定のゲストオペレーティングシステムで新しい仮想マシンを作成するために必要なインストールメタデータと、最適なストレージ、CPU、メモリ、および仮想ネットワークの設定が含まれています。

XenServerの各リリースでサポートされるゲストオペレーティングシステムの一覧については、『XenServer仮想マシンユーザーガイド』を参照してください。

適切なゲストオペレーティングシステム、メモリ、CPU、ストレージ、およびネットワーク設定を使用して独自のカスタムテンプレートを作成して、それを使用して新しい仮想マシンを作成することもできます。詳しくは、「新規テンプレートの作成」を参照してください。

BIOSオプションの選択

XenServerでは、BIOS汎用またはBIOS固有の仮想マシンを作成できます。

  • BIOS汎用。汎用のXenServer BIOS文字列を持つ仮想マシンです。
  • BIOSカスタマイズ済み。プール内の特定サーバーのBIOS文字列がコピーされた仮想マシンです。
  • BIOS文字列なし。BIOS文字列が設定されていない仮想マシンの初回起動時に、標準的なXenServer BIOS文字列がコピーされ、BIOS汎用の仮想マシンになります。

［新規VM］ウィザードで仮想マシンを作成するときに、同一プール内のOEMサーバーからBIOS文字列をコピーできます。 これにより、BIOSでロックされたReseller Option Kit OEMバージョンのWindowsをインストールできるようになります。 この場合、BIOS文字列のコピー元のOEMサーバーが、新しい仮想マシンのホームサーバーになります。

BIOSカスタマイズ済みの仮想マシンは、同じBIOS文字列のサーバーおよび異なるBIOS文字列のサーバーに移行、インポート、およびエクスポートできます。

重要： BIOSでロックされたオペレーティングシステムを使用するには、専用のライセンス契約書に同意する必要があります。


仮想マシンの名前と説明

［名前］ボックスに、新しい仮想マシンの名前を入力します。 vAppの内容を示す名前を指定すると便利です。 複数の仮想マシンに同じ名前を使用することも可能ですが、重複しないわかりやすい名前を指定することをお勧めします。

たとえば、仮想マシンのオペレーティングシステムを示す名前（Windows 7 64-bit JA）、インストールされているアプリケーションを示す名前（Citrix XenServer Web Self Service v1.0（Build 9057））、または役割を示す名前（db-server Outlook Server Windows 7 Test）などを指定すると便利です。

また、スペースを含む名前を引用符で囲む必要はありません。

必要に応じて、より詳細な情報を説明として入力することもできます。


オペレーティングシステムのインストールメディア

［新規VM］ウィザードの［インストールメディア］ページに表示されるオプションは、このウィザードの最初のページで選択したオペレーティングシステムやテンプレートにより異なります。

オプション 説明 テンプレート
インストール元ISOライブラリまたはDVDドライブ ［インストール元ISOライブラリまたはDVDドライブ］をクリックして、一覧から使用するISOイメージまたはDVDドライブを選択します。

インストールするISOイメージが一覧に表示されない場合は、［新規ISOライブラリ］をクリックします。［新規ストレージリポジトリ］ウィザードが起動し、ISOストレージリポジトリを作成できます。 新しいISOストレージリポジトリを作成すると、一覧からそのISOライブラリを選択できるようになります。

一覧にISOイメージが表示されない場合は、サーバーからアクセス可能なNFSまたはSMB/CIFS共有を作成し、そこにISOイメージを配置しておく必要があります。詳しくは、『XenServer仮想マシンユーザーガイド』を参照してください。

 Windows®およびLinux
ネットワークから起動する Windows仮想マシンやOther install mediaテンプレートでネットワークPXEブートを使用する場合は、このオプションを選択します。

このオプションを選択すると、新しい仮想マシンの起動順序の最上位に［ネットワーク］が設定されます。

 Windows
インストール元URL CentOS、SUSE Linux Enterprise Server、およびRed Hat Linuxオペレーティングシステムは、ネットワークリポジトリからインストールできます。 ［インストール元URL］をクリックして、URLを入力します。URLには、以下の形式でサーバーのIPアドレスとリポジトリのパスが含まれている必要があります。
nfs://server/path
ftp://server/path
http://server/path

たとえば、「nfs://10.10.32.10/SLES10」のように入力します。ここで、10.10.32.10はNFSサーバーのIPアドレスで、/SLES10はインストールリポジトリの場所です。

必要な場合は、オペレーティングシステムの起動パラメータを指定できます。

 Linux


ホームサーバー

ホームサーバーとは、プール内の仮想マシンにリソースを提供するサーバーを指します。 仮想マシンのホームサーバーを指定すると、常にそのサーバー上での起動が試行されます。ホームサーバー上でその仮想マシンを起動できない場合は、同じプール内のほかのサーバーが自動的に選択されます。

  • ［新規VM］ウィザードで仮想マシンのホームサーバーを指定するには、［ホームサーバーを指定する］をクリックして、一覧からサーバーを選択します。
  • ホームサーバーを指定しない場合は、［ホームサーバーを指定しない］をクリックします。これにより、最適なサーバー上のリソースを使用して仮想マシンが起動します。

BIOSカスタマイズ済みの仮想マシンを作成する場合、BIOS文字列のコピー元のOEMサーバーが自動的にホームサーバーとして設定されます。

仮想マシンのホームサーバーを変更するには、仮想マシンの［プロパティ］ダイアログボックスを使用します。詳しくは、「仮想マシンプロパティの変更」を参照してください。

ワークロードバランス機能（WLB）に関する注意事項

ワークロードバランス機能（WLB）が有効なリソースプールでは、仮想マシンの起動、再起動、再開、および移行にホームサーバーは使用されません。 代わりに、XenServerリソースプールの負荷測定基準と最適化の推奨項目に基づいて、最適なサーバー上で仮想マシンが起動、再起動、再開、および移行されます。

重要： ワークロードバランス機能（WLB）は、XenServer Version 6.2およびこれ以降のバージョンでは削除されています。 WLBの機能を使用するアプリケーションやコードなどは、XenServer Version 6.2およびこれ以降のバージョンでは使用できません。 詳しくは、CTX137333を参照してください。


仮想マシンのCPUとメモリの設定

新しい仮想マシンを作成するときに、その仮想マシンに割り当てるCPUの数と初期メモリの量を指定できます。 これらの値は、仮想マシンのインストール後に必要に応じて変更できます。

オプション 説明
VCPUの数 新しい仮想マシンに割り当てるVCPU（Virtual CPU：仮想CPU）の数を入力します。

仮想マシンには、最大8個のVCPUを設定できます。 サーバーで使用可能な物理CPUの数は、このページに表示されます。新しい仮想マシンのパフォーマンスを最大限に発揮させるには、割り当てるVCPUの数を、ホストサーバーに搭載されている物理CPUの数以下にしてください。

この値は、必要に応じて後で変更することができます。 詳しくは、「仮想マシンプロパティの変更：CPU」を参照してください。

メモリ 仮想マシンに割り当てるメモリ量を入力します。

XenServerのテンプレートを使用すると、ゲストオペレーティングシステムの種類に基づいて、標準的な仮想マシン構成と適切なデフォルトのメモリ量が設定されます。 新しい仮想マシンに割り当てる初期メモリ量を決定するときは、次の注意事項について考慮する必要もあります。

  • 仮想マシンで実行するアプリケーションの種類。
  • 同じメモリリソースを使用するほかの仮想マシン。
  • 仮想マシンと同時にサーバーで実行するアプリケーション。

作成済みの仮想マシンに割り当てられているメモリ量を変更するには、その仮想マシンの［メモリ］タブを使用します。ここでは、同一プール内の仮想マシン間でメモリを動的に再割り当てできる動的メモリ制御（DMC：Dynamic Memory Control）を有効にすることもできます。 詳しくは、「仮想マシンのメモリ設定」の各トピックを参照してください。


仮想ストレージの設定

［新規VM］ウィザードで作成する仮想マシンには、1つ以上の仮想ディスクが追加され、選択した仮想マシンテンプレートからも追加の仮想ディスクが提供される場合があります。 仮想マシンには、仮想CD-ROMを含めて、最大7つの仮想ディスクを設定できます。

［新規VM］ウィザードの［ストレージ］ページでは、仮想ディスクの追加、削除、およびサイズと場所の変更ができます。

オプション | 説明
以下の仮想ディスクを使用する 使用する仮想ディスクを一覧から選択します。
  • 仮想ディスクを追加するには、［追加］をクリックして名前、サイズ、および場所（ストレージリポジトリ）を指定します。詳しくは、「仮想ディスクの追加」を参照してください。
  • 仮想ディスクを削除するには、［削除］をクリックします。
  • 既存の仮想ディスクをほかのストレージリポジトリ上に移動するには、その仮想ディスクを選択して［プロパティ］をクリックし、［場所］ボックスでストレージリポジトリを選択します。
  • 仮想ディスクのサイズを変更するには、その仮想ディスクを選択して［プロパティ］をクリックし、［サイズ］ボックスで値を変更します。
  • 仮想ディスクの名前や説明を変更するには、その仮想ディスクを選択して［プロパティ］をクリックし、新しい名前や説明を入力します。
ストレージレベルの高速ディスククローンを使用する このチェックボックスは、仮想マシンの作成に使用するテンプレートやスナップショットの仮想ディスクが、新しい仮想マシンの仮想ディスクと同じストレージリポジトリ上にある場合に表示されます。 このチェックボックスをオンにすると、テンプレートやスナップショットから仮想マシンにディスクをコピーするときに、ハードウェアレベルのコピー機能が使用されます。 ストレージレベルの高速ディスククローン処理により、新しい仮想マシンが高速に作成されます。

このオプションは、 リモートの共有NFSストレージまたはローカルのVHDベースのストレージを使用する仮想マシンでのみサポートされます。
ネットワークから起動するディスクレスVMを作成する | ウィザードの［インストールメディア］ページで［ネットワークから起動する］オプションを選択した場合は、ディスクを持たない仮想マシンを作成できます。


仮想ネットワークの設定

［新規VM］ウィザードの［ネットワーク］ページでは、最大4つの仮想ネットワークインターフェイスを設定できます。 5つ以上の仮想ネットワークインターフェイスが必要な場合は、仮想マシンの作成後、仮想マシンの［ネットワーク］タブで追加できます。

仮想ネットワークインターフェイスでは、デフォルトで自動生成のランダムなMACアドレスが設定されます。 特定のMACアドレスを指定するには、［プロパティ］をクリックし、［仮想インターフェイスプロパティ］ダイアログボックスで［MACアドレスを指定する］をクリックして、「aa:bb:cc:dd:ee:ff」形式で16進数値のアドレスを入力します。

  • 新しい仮想ネットワークインターフェイスを追加するには、［追加］をクリックします。
  • 仮想ネットワークインターフェイスを削除するには、一覧から選択して［削除］をクリックします。
  • 仮想ネットワークインターフェイスの物理ネットワーク、MACアドレス、およびQoS上限値を変更するには、一覧から選択して［プロパティ］をクリックします。 詳しくは、「仮想ネットワークインターフェイスプロパティの変更」を参照してください。

既存の仮想マシンの仮想ネットワーク設定を変更するには、その仮想マシンの［ネットワーク］タブを使用します。詳しくは、「仮想マシンネットワークの設定」の各トピックを参照してください。


仮想マシン作成の完了

インストールの完了時に新しい仮想マシンを直ちに起動するには、［新規VM］ウィザードの最後のページにある［VMを自動的に起動する］チェックボックスをオンにします。

テンプレートのサイズ、およびホストサーバーとXenCenterの間のネットワーク接続の速度と帯域幅によっては、仮想マシンの作成に時間がかかる場合があります。 進行状況は［XenCenter］ウィンドウの下部のステータスバーおよび［ログ］タブに表示されます。

注： 新しい仮想マシンが作成されたら、XenServer Toolsをインストールします。これにより、入出力のパフォーマンスが最適化されます。詳しくは、「XenServer Toolsのインストール」を参照してください。


仮想マシンの高速（無人）作成

カスタムの仮想マシンテンプレートに基づいた同じ仮想マシンを複数作成するには、［新規VM］ウィザードを使用せずに、XenCenterの高速作成機能を使用します。
  1. 必要な設定パラメータを指定して、カスタムの仮想マシンテンプレートを作成します。 詳しくは、「新規テンプレートの作成」を参照してください。
  2. リソースペインでカスタムテンプレートを選択して、［テンプレート］メニューで［選択項目からのVM作成］、［高速作成］の順に選択します。 また、リソースペインで右クリックして、［高速作成］を選択することもできます。
テンプレートに指定されているすべての設定パラメータに基づいて、新しい仮想マシンが作成され、プロビジョニングされます。


新規テンプレートの作成

XenCenterでは、次の方法でカスタムテンプレートを作成できます。

  • 既存のテンプレートをコピーする。詳しくは、「仮想マシンとテンプレートのコピー」を参照してください。
  • 既存の仮想マシンをテンプレートに変換する。
  • 仮想マシンのスナップショットを新しいテンプレートとして保存する。
  • 既存のテンプレートまたはスナップショットからXVAファイルとしてエクスポートされたテンプレートをインポートする。

既存の仮想マシンをテンプレートに変換するには

この方法でテンプレートを新規に作成する場合、仮想マシンのディスクの内容が新しいテンプレートにコピーされ、元の仮想マシンが削除されることに注意してください。 また、vAppに追加されている仮想マシンは、テンプレートに変換できません。
  1. 仮想マシンをシャットダウンします。方法については「仮想マシンのシャットダウン」を参照してください。
  2. リソースペインで仮想マシンを右クリックして［テンプレートへの変換］を選択します。
  3. ［OK］をクリックして確定します。 変換の進行状況は［XenCenter］ウィンドウの下部のステータスバーおよび［ログ］タブに表示されます。
変換が完了すると、リソースペインから仮想マシンが削除され、新しいカスタムテンプレートとして表示されます。 この新しいカスタムテンプレートをほかのテンプレートと同じように使用して、新しい仮想マシンを作成できます。

スナップショットを新しいテンプレートとして保存するには

  1. ［スナップショット］タブでスナップショットを選択し、右クリックして［スナップショットからテンプレートを作成］を選択します。
  2. 新しいテンプレートの名前を入力して、［OK］をクリックします。
作成されたテンプレートは、リソースペイン（および［新規VM］ウィザードの［テンプレート］ページ）にカスタムテンプレートとして表示されます。

XVAファイルからテンプレートをインポートするには

仮想マシンのテンプレートやスナップショットは、XVAファイルとしてエクスポートできます。XenCenterの［インポート］ウィザードでは、XVAファイルをテンプレートとしてインポートできます。このウィザードを開くには、［ファイル］メニューの［インポート］をクリックします。ウィザードの最初のページで、インポートするテンプレートのXVAファイルを選択します。後は、XVAファイルから仮想マシンをインポートするときと同じ手順に従って操作します。詳しくは、「XVAからのインポート」を参照してください。

インポートの進行状況は［XenCenter］ウィンドウの下部のステータスバーおよび［ログ］タブにも表示されます。 テンプレートのサイズ、およびXenCenterとサーバーの間のネットワーク接続の速度と帯域幅によって、インポート処理に時間がかかる場合があります。 新しくインポートしたテンプレートが使用できるようになると、リソースペインにカスタムテンプレートとして表示されます。 新しいテンプレートの設定プロパティは、エクスポート元のテンプレートの設定プロパティと同じです。 設定プロパティを変更するには、テンプレートの［プロパティ］ダイアログボックスを使用します。


仮想マシンとテンプレートのコピー

既存の仮想マシンやテンプレートをコピー（複製またはクローン）して、新しい仮想マシンを作成できます。 XenServerには、仮想マシンやテンプレートをコピーする方法として2つのメカニズムが用意されています。1つは完全コピーであり、もう1つは高速複製です。

  • 完全コピー：仮想マシンディスクの完全なコピーが作成されます。
  • 高速複製（コピーオンライトモード）：既存の仮想マシンから新しい仮想マシンへのディスクのコピーをハードウェアレベルで行い、変更のあったブロックのみがディスクに書き込まれます。 このモードは、ファイルバック仮想マシンのみをサポートしています。 コピーオンライトモードはディスクのスペースを節約し、高速複製ができるように設計されていますが、通常のディスクパフォーマンスをわずかに低下させる場合があります。

仮想マシンを直接コピーできるのは、同一プール内のみです。 ほかのプール内のサーバーに仮想マシンをコピーするには、仮想マシンをエクスポートしてから、そのサーバー上にインポートします。

仮想マシンをコピーするには

重要： Windows仮想マシンを複製する前にWindowsユーティリティのsysprepを使用して、セキュリティID（SID）がほかのマシンのものと重複しないようにする必要があります。 推奨されるシステムの準備作業をせずに仮想マシンを複製すると、SIDの重複などの問題を引き起こすことがあります。 仮想マシンの複製方法およびsysprepの実行方法について詳しくは、『XenServer仮想マシンユーザーガイド』を参照してください。
  1. Windows仮想マシンを複製する場合は、『XenServer仮想マシンユーザーガイド』の説明に従ってsysprepユーティリティを実行します。
  2. 仮想マシンが実行中の場合は、まずシャットダウンします。
  3. リソースペインで仮想マシンを選択して、［VM］メニューの［VMのコピー］を選択します。
  4. 新しい仮想マシンの名前と、必要に応じて説明を入力します。
  5. コピーモードとして、［高速複製］または［完全コピー］を選択します。
  6. コピーモードとして［完全コピー］を選択した場合は、複製される仮想ディスクの配置先ストレージリポジトリを選択します。 仮想マシンをローカルドライブから共有ストレージに移動する場合は、ここで共有ストレージリポジトリを選択する必要があります。
  7. ［コピー］をクリックします。

テンプレートをコピーするには

  1. リソースペインでテンプレートを選択して、［テンプレート］メニューの［コピー］を選択します。
  2. 新しいテンプレートの名前と、必要に応じて説明を入力します。
  3. コピーモードとして、［高速複製］または［完全コピー］を選択します。
  4. コピーモードとして［完全コピー］を選択した場合は、複製される仮想ディスクの配置先ストレージリポジトリを選択します。
  5. ［コピー］をクリックします。


仮想マシンの設定

トピック

  • XenServer Toolsのインストール
  • 仮想マシンのメモリ設定
    • 仮想マシンのメモリ設定について
    • 動的メモリ制御（DMC：Dynamic Memory Control）
    • 動的メモリ制御（DMC）の設定
  • 仮想マシンのストレージ設定
    • 仮想ディスクについて
    • 仮想ディスクの追加
    • 仮想ディスクの接続
    • 仮想ディスクの接続解除
    • 仮想ディスクの移動
    • 仮想ディスクの削除
    • 仮想ディスクプロパティの変更
  • 仮想マシンのネットワーク設定
    • 新しい仮想ネットワークインターフェイスの追加
    • 仮想ネットワークインターフェイスのアクティブ化/非アクティブ化
    • 仮想ネットワークインターフェイスの削除
    • 仮想ネットワークインターフェイスプロパティの変更
  • 仮想マシンプロパティの変更


XenServer Toolsのインストール

XenServer Toolsにより、XenServer仮想マシンのディスクとネットワークのパフォーマンスを強化する、高性能なWindowsドライバおよび管理エージェントが提供されます。 詳しくは、「XenServer PVドライバ – XenServer Tools」を参照してください。

xe CLIやXenCenterを使用するには、すべての仮想マシン（WindowsおよびLinux）にXenServer Toolsをインストールする必要があります。これにより、仮想マシンのパフォーマンスも向上します。 このツールがインストールされていない仮想マシンでは、以下の操作を実行できません。

  • 仮想マシンを正しくシャットダウン、再起動、または一時停止する。
  • XenCenterで仮想マシンのパフォーマンスデータを表示する。
  • 実行中の仮想マシンを移行する（XenMotion）。
  • 休止スナップショットまたはメモリを含んだスナップショット（チェックポイント）を作成したり、スナップショットを復元したりする。
  • 実行中のLinux仮想マシンの仮想CPUの数を変更する（Windows仮想マシンの場合は再起動が必要）。
重要： XenServer Toolsをインストールせずに仮想マシンを実行することはサポートされません。

XenServer Toolsがインストールされているかどうかを確認する

仮想マシンにXenServer Toolsがインストールされているかどうかを確認するには、仮想マシンの［全般］タブの［仮想化の状態］フィールドを表示します。

  • 最適化済み（Version n.nインストール済み）：最新のXenServer Toolsがインストールされています。
  • XenServer Tools未インストール：XenServer Toolsがまだインストールされていません。 このメッセージをクリックすると、最新のXenServer ToolsをXenServer Tools ISOからインストールできます。
  • Toolsの旧バージョン（Version x.yインストール済み）：以前のバージョンのXenServerリリースで提供されていたXenServer Toolsがインストールされています。 Windows仮想マシンでは、このメッセージをクリックすると仮想マシンのコンソール画面を開き、XenServer Tools ISOがロードされ、インストールウィザードが起動します。Linux仮想マシンでは、このメッセージをクリックすると仮想マシンのコンソール画面を開き、XenServer Tools ISOがロードされます。管理者は、このISOイメージをマウントし、インストールを実行する必要があります（詳しくは以下を参照）。

Windows仮想マシンへのXenServer Toolsのインストール

重要： XenServer Toolsをインストールするときに、仮想マシンのCD/DVDドライブにあるメディアはイジェクトされます。 CDからオペレーティングシステムをインストールしている間など、仮想マシンのCD/DVDドライブが使用中の場合は、XenServer Toolsをインストールしないでください。
  1. リソースペインで仮想マシンを右クリックし、［XenServer Toolsのインストール］をクリックします。 または、［VM］メニューの［XenServer Toolsのインストール］を選択します。
  2. 確認のメッセージが表示されるので、［XenServer Toolsのインストール］をクリックします。これにより仮想マシンのコンソールが開き、XenServer Toolsのインストールを開始できる状態になります。
  3. 仮想マシンのCDドライブで自動実行が有効になっている場合は、しばらくすると自動的にインストールが開始されます。 自動実行が有効になっていない場合は、CDドライブをダブルクリックしてXenServer Toolsのインストールを開始します。
  4. 画面の指示に従って操作し、確認メッセージが表示されたら仮想マシンを再起動します。

Linux仮想マシンへのXenServer Toolsのインストール

  1. リソースペインで仮想マシンを右クリックし、［XenServer Toolsのインストール］をクリックします。 または、［VM］メニューの［XenServer Toolsのインストール］を選択します。
  2. 確認のメッセージが表示されるので、［XenServer Toolsのインストール］をクリックします。これにより仮想マシンのコンソールが開きます。
  3. ルートユーザーとして次のコマンドを実行して、仮想マシンにイメージをマウントします。
    mount /dev/xvdd /mnt
  4. ルートユーザーとして次のインストールスクリプトを実行します。
    /mnt/Linux/install.sh
  5. カーネルまたは仮想マシンをアップグレードした場合は、ここで仮想マシンを再起動します。

Linux仮想マシンにマウントするCD-ROMドライブおよびISOイメージは、/dev/cdromではなく/dev/xvddと表示されます。 これは、真のCD-ROMデバイスではなく、通常のデバイスであるためです。 XenCenterやCLIでCDをイジェクトすると、このデバイスは仮想マシンからホットアンプラグされ、表示されなくなります。 一方、Windows仮想マシンではLinuxの場合と異なり、CDは空の状態で仮想マシン内に残ります。


仮想マシンのメモリ設定

トピック

  • 仮想マシンのメモリ設定について
  • 動的メモリ制御（DMC：Dynamic Memory Control）
  • 動的メモリ制御（DMC）の設定


仮想マシンのメモリ設定について

仮想マシンを作成するときに、特定のメモリ量を割り当てることができます。 動的メモリ制御（DMC：Dynamic Memory Control）機能を使用すると、仮想マシン間での動的なメモリ再割り当てが可能になり、XenServer環境での物理メモリ使用を効率化できます。

XenCenterの［メモリ］タブには、仮想マシンやサーバーのメモリ使用量や設定に関する情報が表示されます。

  • サーバーの場合は、使用可能なメモリの合計と現在のメモリ使用量が表示され、そのサーバー上の仮想マシンにどのように割り当てられているかを確認できます。
  • 仮想マシンの場合は、現在のメモリ使用量に加え、DMCが有効かどうか、および動的最小/最大メモリの設定値などの情報が表示され、ここで値を変更することができます。

［メモリ］タブでは、同じメモリ設定の仮想マシンがグループ化されます。このため、個々の仮想マシンや仮想マシンのグループのメモリ管理を簡単に行えます。


動的メモリ制御（DMC：Dynamic Memory Control）

XenServerの動的メモリ制御（DMC。「メモリの動的最適化」、「メモリオーバーコミット」、または「Memory Ballooning」とも呼ばれます）では、実行中の仮想マシンのメモリが自動的に調節されます。この機能では、各仮想マシンに割り当てられたメモリ量を特定の範囲内で増減して、パフォーマンスを維持しながらサーバーあたりの仮想マシン密度を向上させることができます。

DMCが無効な場合、サーバー上に使用可能なメモリがないときに追加の仮想マシンを起動しようとすると、メモリ不足によるエラーが発生します。 この問題を解決するには、既存の仮想マシンに割り当てたメモリ量を減らして、各仮想マシンを再起動しなければなりません。 DMCを有効にすると、サーバー上に使用可能なメモリがない場合でも、実行中の仮想マシンのメモリ割り当て量が（管理者が設定した範囲内で）減らされて、追加の仮想マシン用に解放されます。

動的または静的なメモリ範囲

管理者は、各仮想マシンについて動的メモリ範囲を設定できます。これは、仮想マシンを再起動せずに増減できるメモリ量の範囲を指します。 管理者は、実行中の仮想マシンについてこのメモリ範囲を調節でき、仮想マシンを再起動する必要はありません。 XenServerでは、仮想マシンに割り当てられるメモリがこの動的メモリ範囲内で維持されます。 たとえば、動的最小メモリ量を512MB、動的最大メモリ量を1024MBに設定した場合、この仮想マシンの動的メモリ範囲は（DMR）は512～1024MBになり、この範囲内で仮想マシンが動作します。 XenServerのDMCを有効にすると、各仮想マシンのメモリが常にこのDMR内で調整されます。

ホストサーバーに十分な量のメモリがある場合、すべての実行中の仮想マシンに動的最大メモリ量が割り当てられます。 使用可能なメモリがないサーバー上で追加の仮想マシンの起動が必要になると、実行中のほかの仮想マシンのメモリが解放されます。 追加の仮想マシン用に必要なメモリは、実行中の各仮想マシンから、指定されたメモリ範囲内で均等に再割り当てされます。

XenServerがサポートするオペレーティングシステムの中には、メモリの動的な増減をサポートしないものがあります。 このため、仮想マシンの起動時に最大メモリ量を割り当てて、ゲストオペレーティングシステムがページテーブルやほかのメモリ管理ストラクチャを用意できるようにする必要があります。 XenServerでこれを行うには、静的メモリ範囲という概念を使用します。 静的メモリ範囲は、仮想マシンの実行中に増減できないメモリ範囲です。動的メモリ範囲は、常に静的メモリ範囲内でなければならないなどの制約を受けます。 静的最小メモリ量（静的メモリ範囲の最小値）には、XenServer上でそのオペレーティングシステムが動作するために必要な最低限のメモリ量が設定されています。

重要： 静的最小メモリ量にはそのオペレーティングシステムで必要な最低限のメモリ量が設定されているため、この値を変更しないことをお勧めします。詳しくは、『XenServer管理者ガイド』を参照してください。 静的最大メモリ量に動的最大メモリ量よりも大きな値を設定すると、仮想マシンにより多くのメモリを割り当てなければならなくなったときに、その仮想マシンを再起動しなくても割り当て量を増やすことができます。

動的メモリ制御の制限事項

XenCenterでDMCの値を設定する場合、以下の制限事項に注意してください。

  • 動的最小メモリ量には、静的最小メモリ量よりも大きな値を設定する必要があります。
  • 動的最小メモリ量には、動的最大メモリ量よりも小さな値を設定する必要があります。
  • 動的最大メモリ量には、静的最大メモリ量よりも小さな値を設定する必要があります。

仮想マシンのメモリプロパティを設定するときは、上記の条件を満たす任意の値を指定できますが、検証チェックが行われます。 さらに、オペレーティングシステムによっては、特定のメモリ構成だけがサポートされています。詳しくは、『XenServer管理者ガイド』を参照してください。


動的メモリ制御（DMC）の設定

動的メモリ制御を有効にするには

  1. リソースペインで仮想マシンまたはサーバーを選択し、［メモリ］タグをクリックします。
  2. 設定する仮想マシンの［編集］ボタンをクリックします。
  3. 同じメモリ構成を持つ複数の仮想マシンの場合は、それらの仮想マシンを選択して［次へ］をクリックします。
  4. ［自動的に割り当てるメモリ範囲を指定する］をクリックして、スライダまたはテキストボックスを使用して、動的メモリ範囲の最小値および最大値を設定します。
  5. ［OK］をクリックして変更を適用し、ダイアログボックスを閉じます。

動的メモリ制御を無効にするには

  1. リソースペインで仮想マシンまたはサーバーを選択し、［メモリ］タグをクリックします。
  2. 設定する仮想マシンの［編集］ボタンをクリックします。
  3. 同じメモリ構成を持つ複数の仮想マシンの場合は、それらの仮想マシンを選択して［次へ］をクリックします。
  4. ［割り当てるメモリサイズを指定する］をクリックして、メモリ量を指定します。
  5. ［OK］をクリックして変更を適用し、ダイアログボックスを閉じます。


仮想ストレージの設定

仮想マシンの仮想ストレージ設定を表示したり変更したりするには、リソースペインで仮想マシンを選択して［ストレージ］タブをクリックします。

トピック：

  • 仮想ディスクについて
  • 仮想ディスクの追加
  • 仮想ディスクの接続
  • 仮想ディスクの接続解除
  • 仮想ディスクの移動
  • 仮想ディスクの削除
  • 仮想ディスクプロパティの変更


仮想ディスクについて

XenServerの仮想マシンで使用するストレージは、仮想ディスクにより提供されます。 仮想ディスクは、接続された仮想マシンに依存せずに存在する永続的なディスク上のオブジェクトです。 仮想ディスクはXenServerのストレージリポジトリ（SR）上に格納され、必要に応じて仮想マシンに接続（アタッチ）、接続解除（デタッチ）、および再接続（リアタッチ）できます。 新しい仮想ディスクは、仮想マシンの作成時（［新規VM］ウィザード）に作成したり、既存の仮想マシンの［ストレージ］タブで作成したりできます。

準仮想化仮想マシン（XenServer Toolsがインストールされた仮想マシン）上の仮想ディスクは「ホットプラグ」できます。つまり、仮想マシンをシャットダウンしなくても、仮想ディスクを追加、削除、接続、および接続解除できます。 HVMモードで実行中の仮想マシン（XenServer Toolsがインストールされていない仮想マシン）では、これらの操作を行う前に仮想マシンをシャットダウンする必要があります。これを避けるには、すべてのHVM仮想マシンにXenServer Toolsをインストールする必要があります。

仮想マシンの［ストレージ］タブでは、次のことを実行できます。

  • 新しい仮想ディスクを追加する。
  • 仮想ディスクを設定する。仮想ディスクのサイズ、場所、読み取り/書き込みモードなどの設定パラメータを変更します。
  • 仮想マシンに既存の仮想ディスクを接続する。
  • 仮想ディスクを接続解除する。仮想ディスクおよびそのデータは保持されます。
  • ほかのストレージリポジトリに仮想ディスクを移動する。
  • 仮想ディスクを削除する。仮想ディスクおよびそのデータが完全に削除されます。


仮想ディスクの追加

新しい仮想ディスクを追加するには、［仮想ディスクの追加］ダイアログボックスを使用します。

重要： HVMモード（XenServer Tools未インストール）で実行中の仮想マシンで仮想ディスクを追加する場合は、事前に仮想マシンをシャットダウンしておく必要があります。これを避けるには、すべてのHVM仮想マシンにXenServer Toolsをインストールする必要があります。

手順：

  1. 次のいずれかを実行して、［仮想ディスクの追加］ダイアログボックスを開きます。
    • リソースペインで仮想マシンまたはストレージリポジトリを選択して、［ストレージ］タブの［追加］をクリックします。
    • ［ストレージ］メニューから、［仮想ディスク］、［新規仮想ディスク］の順に選択します。
    • ［新規VM］ウィザードの［ストレージ］ページで、［追加］をクリックします。
  2. 新しい仮想ディスクの名前と、任意で説明を入力します。
  3. 新しい仮想ディスクのサイズを入力します。 仮想ディスクを格納するストレージリポジトリに、そのディスクに十分な容量があることを確認する必要があります。
  4. 新しい仮想ディスクを格納するストレージリポジトリを選択します。
  5. ［追加］をクリックして新しい仮想ディスクを作成し、ダイアログボックスを閉じます。


仮想ディスクの接続

仮想マシンに既存の仮想ディスクを接続（アタッチ）して、ストレージを追加できます。
  1. リソースペインで仮想マシンを選択して、［ストレージ］タブの［接続］をクリックします。 ［ストレージ］メニューから、［仮想ディスク］、［仮想ディスクの接続］の順に選択します。
  2. 一覧から仮想ディスクを選択します。
  3. 仮想ディスクへのアクセスを読み取り専用に設定するには、［読み取り専用として接続］チェックボックスをオンにします。 複数の仮想マシンがディスクにアクセスしたときに、データが上書きされたり変更されたりすることを防ぎ、仮想ディスクを複数の仮想マシンに接続することができます。 仮想ディスクへの書き込みアクセスを許可するには、チェックボックスをオフにします。
  4. ［接続］をクリックします。
    ヒント： 仮想ディスクを格納するストレージリポジトリの問題により、その仮想ディスクが非アクティブ化（アンプラグ）される場合があります。 この場合、仮想ディスクを再接続できます。これを行うには、仮想マシンの［ストレージ］タブでその仮想ディスクを選択し、［アクティブ化］をクリックします。


仮想ディスクの接続解除

仮想ディスクと仮想マシンの接続を解除（デタッチ）すると、仮想ディスクとそのすべてのデータが保持されますが、仮想マシンから仮想ディスクを利用することはできなくなります。接続を解除したストレージデバイスは、後で再接続したり、別の仮想マシンに接続したり、ほかのストレージリポジトリに移動したりできます。

次の条件がすべて満たされる場合は、仮想マシンをシャットダウンせずに仮想ディスクを接続解除できます。

  • 仮想マシンが一時停止状態でない。
  • 仮想マシンにXenServer Toolsがインストールされている。
  • 仮想ディスクがシステムディスクではない。
  • 仮想ディスクが非アクティブ化されている。アクティブな仮想ディスクは、正しく接続解除できない場合があります。 「非アクティブ化」とは「アンプラグ」と同義で、『XenServer管理者ガイド』やCLIでは「unplug」という語が使用されている場合があります。

これらのいずれかの条件が満たされない場合は、仮想マシンをシャットダウンしてから仮想ディスクを接続解除する必要があります。

手順：

  1. リソースペインで仮想マシンを選択して、［ストレージ］タブをクリックします。
  2. 一覧で仮想ディスクを選択して［非アクティブ化］をクリックし、さらに［接続解除］をクリックします。
  3. ［OK］をクリックして操作を確定します。


仮想ディスクの移動

ストレージリポジトリ上の仮想ディスクは、同一プール内のほかのストレージリポジトリに移動（移行）することができます。 以下の仮想ディスクを移動できます。

  • 仮想マシンに接続されていない仮想ディスク。
  • 停止中の仮想マシンに接続されている仮想ディスク。
  • 実行中の仮想マシンに接続されている仮想ディスク（ストレージXenMotion機能）。

ローカルストレージ上の仮想ディスクをほかのサーバーの共有ストレージに移動することはできますが、ほかのサーバーのローカルストレージに移動することはできません。

ストレージXenMotionについて

ストレージXenMotionを使用すると、仮想マシンをシャットダウンしなくても、その仮想ディスクを移動できます。これにより、以下のタスクが可能になります。

  • 安価なローカルストレージに格納されている仮想マシンを、高速で耐障害性の高いストレージアレイに移動する。
  • 仮想マシンを開発環境から実務環境に移動する。
  • ストレージ容量による制限がある場合に、仮想マシンをストレージ階層間で移動する。
  • ストレージアレイをアップグレードする。

現行のストレージXenMotionには、以下の制限事項があります。

  • XenServerに統合されたStorageLinkのストレージリポジトリ上にある仮想ディスクは移行できません。
  • 複数のスナップショットを持つ仮想ディスクは移行できません。

仮想ディスクを移動するには

  1. XenCenterのリソースペインで、仮想ディスクが格納されているストレージリポジトリを選択して［ストレージ］タブをクリックします。 仮想ディスクの場所を確認するには
    • リソースペインで、その仮想ディスクが接続されている仮想マシンを選択します。
    • ［ストレージ］タブをクリックして、仮想ディスクを格納しているストレージリポジトリを確認します。
  2. ［仮想ディスク］の一覧で、移動する仮想ディスクを選択して［移動］をクリックします。 または、仮想ディスクを右クリックして［仮想ディスクの移動］を選択します。
  3. ［仮想ディスクの移動］ダイアログボックスで、移動先のストレージリポジトリを選択します。 一覧には、各ストレージリポジトリの空き容量が表示されます。移動先のストレージリポジトリ上に十分なディスク容量があることを確認してください。
  4. ［移動］をクリックして仮想ディスクを移動します。


仮想ディスクの削除

次の条件がすべて満たされる場合は、仮想マシンをシャットダウンせずに仮想ディスクを削除できます。

  • 仮想マシンが一時停止状態でない。
  • 仮想マシンにXenServer Toolsがインストールされている。
  • 仮想ディスクがシステムディスクではない。
  • 仮想ディスクが非アクティブ化されている。 「非アクティブ化」とは「アンプラグ」と同義で、『XenServer管理者ガイド』やCLIでは「unplug」という語が使用されている場合があります。

これらのいずれかの条件が満たされない場合は、仮想マシンをシャットダウンしてから仮想ディスクを削除する必要があります。

重要： 仮想ディスクを削除すると、そのディスクは完全に削除され、保存されているデータも破棄されます。

手順：

  1. 仮想マシンの［ストレージ］タブの一覧で仮想ディスクを選択して、［非アクティブ化］をクリックし、さらに［削除］をクリックします。
  2. ［OK］をクリックして削除を確定します。


仮想ディスクプロパティの変更

仮想ディスクのプロパティを変更するには、仮想マシンの［ストレージ］タブの一覧で仮想ディスクを選択し、［プロパティ］をクリックします。

全般プロパティ - 名前、説明、フォルダ、タグ

名前 | 仮想ディスクの名前です。
説明 | 仮想ディスクの説明です（オプション）。
フォルダ | 仮想ディスクがフォルダで管理されている場合はそのフォルダ名です。
タグ | 仮想ディスクに割り当てられているタグです。

カスタムフィールド

［プロパティ］ダイアログボックスの［カスタムフィールド］ページでは、仮想ディスクに新しいカスタムフィールドを定義したり、既存のカスタムフィールドの値を変更したり、カスタムフィールドを削除したりできます。

カスタムフィールドの追加、設定、変更、および削除については、「カスタムフィールドの使用」を参照してください。

サイズと場所

仮想ディスクのサイズや格納先ストレージリポジトリを指定します。

デバイスオプション

仮想ディスクの［プロパティ］ダイアログボックスの最後のページでは、その仮想マシンのデバイスオプションを設定します。

モード | 仮想ディスクの読み取り/書き込み許可を変更できます。たとえば、バックアップ用のディスクに対する書き込みを禁止することができます。
デバイスの場所 | 仮想ディスクの、ドライブシーケンスにおける場所（ポジション）です。
ディスクアクセス優先度 | 一部の仮想ディスクでは、ディスク入出力優先度（QoS：サービス品質）も設定できます。 これは、LVMベース（ローカル）、共有iSCSI、またはハードウェアHBAのストレージリポジトリ上の仮想ディスクでのみ設定できます。 QoS設定の調整、およびストレージの種類に応じたQoS制御のしくみについて詳しくは、『XenServer管理者ガイド』を参照してください。


仮想マシンネットワークの設定

トピック：

  • 仮想ネットワークインターフェイスについて
  • 新しい仮想ネットワークインターフェイスの追加
  • 仮想ネットワークインターフェイスのアクティブ化/非アクティブ化
  • 仮想ネットワークインターフェイスの削除
  • 仮想ネットワークインターフェイスプロパティの変更


仮想ネットワークインターフェイスについて

各仮想マシンには、仮想ネットワークインターフェイスカードとして動作するいくつかの仮想ネットワークインターフェイスを追加できます。

仮想ネットワークインターフェイスには、以下のプロパティがあります。

ネットワーク | 仮想ネットワークインターフェイスの物理的なネットワークの場所です。
MACアドレス | 仮想ネットワークインターフェイスのMACアドレスです。
QoS制限 | 入出力優先度のQoS（Quality of Service：サービス品質）設定で、ネットワークの最大転送レートを指定します。 メモリリソースが少ないときにこの方法で入出力を調整すると、メモリ処理が低速になり、クラッシュを防止することでシステムの安定化に役立ちます。

仮想マシンに追加されているすべての仮想ネットワークインターフェイスは、仮想マシンの［ネットワーク］タブで確認できます。 このタブでは、新しい仮想ネットワークインターフェイスを追加したり、既存のものを編集、アクティブ化、非アクティブ化、および削除したりできます。


新しい仮想ネットワークインターフェイスの追加

  1. 次のいずれかを実行して、［仮想インターフェイスの追加］ダイアログボックスを開きます。
    • リソースペインで仮想マシンを選択して、［ネットワーク］タブの［インターフェイスの追加］をクリックします。
    • ［新規VM］ウィザードの［ネットワーク］ページで、［追加］をクリックします。
  2. ［ネットワーク］ボックスの一覧からネットワークの場所を選択します。
  3. MACアドレスを指定します。NICのMACアドレスに基づいて自動的に作成されるMACアドレスを使用するか、手作業で入力します。
    • 生成されたMACアドレスを使用するには、［MACアドレスを自動生成する］をクリックします。
    • 明示的にMACアドレスを入力するには、［MACアドレスを指定する］をクリックして、アドレスを「XY:XX:XX:XX:XX:XX」形式で入力します（Xは16進数値、Yは2、6、A、またはEを示します）。
  4. ネットワーク最大転送レートについて、入出力優先度のQoS（Quality of Service：サービス品質）を設定するには、［QoS制限を有効にする］チェックボックスをオンにして、キロバイト毎秒単位で値を入力します。 vSwitchコントローラが設定されたリソースプールでは、［仮想インターフェイスの追加］ダイアログボックスのQoSオプションを使用できません。QoSを設定するには、vSwitchコントローラを使用する必要があります。
    重要： vSwitchコントローラ仮想アプライアンスは、XenServer 6.2.0リリースでの使用が想定されていません。 XenServer 6.2.0にもこの機能が含まれていますが、将来的にはXenServerから完全に削除される予定です。 vSwitchコントローラの機能に依存するアプリケーションやコードなどを使用している場合は、ほかの方法への移行を検討してください。 詳しくは、CTX137336を参照してください。
  5. ［追加］をクリックします。


仮想ネットワークインターフェイスのアクティブ化/非アクティブ化

次の条件がすべて満たされる場合は、仮想マシンをシャットダウンせずに仮想ネットワークインターフェイスをアクティブ化または非アクティブ化できます。

  • 仮想マシンが一時停止状態でない。
  • 仮想マシンにXenServer Toolsがインストールされている。

仮想ネットワークインターフェイスをアクティブ化（プラグ）または非アクティブ化（アンプラグ）するには、仮想マシンの［ネットワーク］タブでインターフェイスを選択し、［アクティブ化］または［非アクティブ化］をクリックします。


仮想ネットワークインターフェイスの削除

次の条件がすべて満たされる場合は、仮想マシンをシャットダウンせずに仮想ネットワークインターフェイスを削除（ホットアンプラグ）できます。

  • 仮想マシンが一時停止状態でない。
  • 仮想マシンにXenServer Toolsがインストールされている。

これらの条件が満たされない場合は、仮想マシンをシャットダウンしてから仮想ネットワークインターフェイスを削除する必要があります。

仮想ネットワークインターフェイスを削除するには

  1. リソースペインで仮想マシンを選択し、［ネットワーク］タブをクリックします。
  2. ［ネットワーク］タブの一覧で仮想ネットワークインターフェイスを選択し、［インターフェイスの削除］をクリックします。


仮想ネットワークインターフェイスプロパティの変更

仮想ネットワークインターフェイスのプロパティを変更するには、次のいずれかを実行して［仮想インターフェイスプロパティ］ダイアログボックスを開きます。

  • 仮想マシンの［ネットワーク］タブをクリックし、仮想ネットワークインターフェイスを選択して［プロパティ］をクリックします。
  • ［新規VM］ウィザードの［ネットワーク］ページで、［プロパティ］をクリックします。

［仮想インターフェイスプロパティ］ダイアログボックスでは、ネットワークの場所、MACアドレス、およびQoS上限値（入出力優先度）を変更できます。

ネットワーク | 仮想ネットワークインターフェイスのネットワークの場所です。
MACアドレス | 仮想ネットワークインターフェイスのMACアドレスは、自動的に生成されるものを使用したり、「XY:XX:XX:XX:XX:XX」形式（Xは任意の16進数値でYは2、6、A、またはEのいずれか）で指定したりできます。
QoS制限を有効にする | ネットワーク最大転送レートについて、入出力優先度のQoS（Quality of Service：サービス品質）を設定するには、このチェックボックスをオンにして、キロバイト毎秒単位で値を入力します。 メモリリソースが少ないときにこの方法で入出力を調整すると、メモリ処理が低速になり、クラッシュを防止することでシステムの安定化に役立ちます。 vSwitchコントローラが設定されたリソースプールでは、このQoSオプションを使用できません。QoSを設定するには、vSwitchコントローラを使用する必要があります。
重要： vSwitchコントローラ仮想アプライアンスは、XenServer 6.2.0リリースでの使用が想定されていません。 XenServer 6.2.0にもこの機能が含まれていますが、将来的にはXenServerから完全に削除される予定です。 vSwitchコントローラの機能に依存するアプリケーションやコードなどを使用している場合は、ほかの方法への移行を検討してください。 詳しくは、CTX137336を参照してください。


仮想マシンプロパティの変更

リソースペインで仮想マシンを選択して［全般］タブをクリックすると、そのプロパティが表示されます。 これらのプロパティの多くは、その仮想マシンの［プロパティ］ダイアログボックスで変更できます。このダイアログボックスを開くには、［全般］タブで［プロパティ］をクリックします。

全般プロパティ - 名前、説明、フォルダ、タグ

［プロパティ］ダイアログボックスの［全般］ページでは、仮想マシンの名前、説明、フォルダ、およびタグを表示したり変更したりできます。

  • 仮想マシン名を変更するには［名前］ボックスに新しい名前を入力します。
  • 説明を変更するには、［説明］ボックスにテキストを入力します。
  • 仮想マシンのフォルダを変更するには、［フォルダ］ボックスの［変更］をクリックして、移動先を指定します。 フォルダの使用について詳しくは、「フォルダの使用」を参照してください。
  • 仮想マシンのタグ付けについて詳しくは、「タグの使用」を参照してください。

カスタムフィールド

カスタムフィールドを使用すると、管理対象のリソースに情報を追加して、リソースを簡単に検索したり分類したりできます。 カスタムフィールドの使用について詳しくは、「カスタムフィールドの使用」を参照してください。

CPU

［プロパティ］ダイアログボックスの［CPU］ページでは、仮想マシンに割り当てた仮想CPU（VCPU）の数や優先度を変更できます。 仮想マシンには、最大8個の仮想CPU（VCPU）を設定できます。 仮想マシンのパフォーマンスを最大限に発揮させるには、割り当てる仮想CPUの数を、ホストサーバーに搭載されている物理CPUの数以下にしてください。 VCPU優先度はCPUのスケジューリング時に各CPUに割り当てられる優先度で、そのホストサーバー上で実行されるほかのすべての仮想マシンと相対的に扱われます。

［VCPUの数］ボックスで、仮想CPUの数を指定します。

VCPU優先度を変更するには、スライダをドラッグします。

XenServerのテンプレートを使用すると、ゲストオペレーティングシステムの種類に基づいて、標準的な仮想マシン構成と適切なデフォルトのメモリ量が設定されます。 仮想マシンに割り当てるメモリ量を決定するときは、次の注意事項について考慮する必要もあります。

  • 仮想マシンで実行するアプリケーションの種類。
  • 同じメモリリソースを使用するほかの仮想マシン。
  • 仮想マシンと同時にサーバーで実行するアプリケーション。

起動オプション

このページに表示される起動オプションは、ゲストオペレーティングシステムにより異なる場合があります。 たとえば、起動デバイスの順序を変更したり、追加の起動パラメータを指定したりできます。

  • 起動順序を変更するには、［起動順序］ボックスの一覧で項目を選択して、［上に移動］または［下に移動］をクリックします。
  • 追加の起動パラメータを指定するには、［OS起動パラメータ］ボックスに入力します。 たとえば、Debian仮想マシンの起動パラメータとして、singleと入力すると、仮想マシンがシングルユーザーモードで起動します。

高可用性オプション

このページでは、仮想マシンの起動順序、起動間隔、および高可用性再起動優先度を変更します。

値 | 説明
起動順序 | vApp、または高可用性による回復処理での仮想マシンの起動順序を指定します。 起動順序として0を指定すると、その仮想マシンが最初に起動します。次に1を指定した仮想マシンが起動し、2、3と続きます。
次のVM起動までの間隔 | 起動順序の値でグループ化される仮想マシンの起動間隔を指定します。たとえば、15秒を設定した場合、起動順序0の仮想マシンが起動した後、15秒後に起動順序1の仮想マシンが起動します。 このオプションは、vAppに含まれている仮想マシン、および高可用性により回復される仮想マシンに適用されます。
高可用性再起動優先度 このオプションは、高可用性が有効なプールでハードウェアや個々のサーバーに障害が発生した場合に、どの仮想マシンを自動的に再起動するかを指定します。
  • 高可用性再起動優先度として［再起動］が設定されている仮想マシンは、プール内のリソースが不足している場合を除いて再起動が保証されます。 これらの仮想マシンは、［可能なら再起動］が設定された仮想マシンよりも先に起動されます。
  • ［可能なら再起動］が設定された仮想マシンはフェイルオーバープランの計算時に考慮されませんが、ホストサーバーの障害発生時に1度だけ再起動が試行されます。 この再起動は、より高い再起動優先度のすべての仮想マシンが起動した後で試行されます。また、このときに再起動に失敗すると、再試行は行われません。
  • ［再起動しない］が設定された仮想マシンの再起動は、自動的には試行されません。

これらの設定ついて詳しくは、「仮想マシンの再起動設定」を参照してください。

アラート

［プロパティ］ダイアログボックスの［アラート］ページでは、サーバーのCPU、ネットワーク、およびディスクの使用状況についてパフォーマンスアラートを設定します。

アラートの設定について詳しくは、「パフォーマンスアラートの設定」を参照してください。

ホームサーバー

［プロパティ］ダイアログボックスの［ホームサーバー］ページでは、仮想マシンにリソースを提供するサーバーを指定できます。 これにより、そのホームサーバー上で仮想マシンが起動します。ホームサーバー上での起動が不可能な場合は、そのリソースプール内のほかのサーバーが自動的にホストとして選択されます。 ホームサーバーについて詳しくは、「新規仮想マシンの作成」を参照してください。

ワークロードバランス機能（WLB）が有効なリソースプールでは、ホームサーバーを指定できません。 代わりに、XenServerリソースプールの負荷測定基準と最適化の推奨項目に基づいて、最適なサーバー上で仮想マシンが起動、再起動、再開、および移行されます。 ワークロードバランスによる最適化では、リソースのパフォーマンスを重視するか1サーバー上でホストする仮想マシンの数を重視するかを選択できます。また、各リソース負荷の測定基準（CPU、ネットワーク、メモリ、およびディスク）のしきい値および重要度を調節して、環境に適した最適化が行われるように設定できます。

GPU（Windows仮想マシンのみ）

［プロパティ］ダイアログボックスの［GPU］ページでは、Windows仮想マシンに、GPU（Graphics Processing Unit）を割り当てることができます。これにより、仮想マシンからグラフィックハードウェアに直接アクセスできます。 このGPUパススルー機能を使用すると、GPUのすべての処理能力を仮想マシンで利用できるため、CAD/CAM、GIS、および医療用画像処理アプリケーションなどの高度な3Dグラフィックアプリケーションのサポートが向上します。

GPUパススルーを有効にするには、［GPUの種類］ボックスの一覧でGPUを選択します。この一覧には、そのプールで使用可能なGPUが表示されます。

高度なオプション（最適化）

［プロパティ］ダイアログボックスの［高度なオプション］ページでは、ハードウェア支援型の仮想マシンに割り当てられるシャドウメモリの量を調節できます。 Citrix XenAppなどの特化したアプリケーションの処理負荷で最高のパフォーマンスを得るには、追加のシャドウメモリが必要です。 このメモリはオーバーヘッドとみなされ、仮想マシンに適切なメモリの通常の算出量とは別に扱われます。

  • Citrix XenAppが動作する仮想マシンのパフォーマンスを最適化するには、［Citrix XenApp用に最適化する］をクリックします。
  • 仮想マシンのシャドウメモリの割り当てを手作業で調節するには、［最適化方法を指定する］をクリックして［シャドウメモリ乗数］ボックスに数値を入力します。
  • シャドウメモリをデフォルト設定に戻すには、［一般的な環境用に最適化する］をクリックします。


仮想マシンの管理

トピック

  • 仮想マシンの起動
  • 仮想マシンの一時停止と再開
  • 仮想マシンのシャットダウン
  • 仮想マシンの再起動
  • リモートコンソールセッションの実行
  • 仮想マシンの移行
  • 仮想マシンの削除


仮想マシンの起動

リソースプールでは、使用可能なリソースの条件を満たす限り、任意のサーバーを選択して仮想マシンを起動できます。 仮想マシンのホストサーバーの選択方法は、仮想マシンとリソースプールの設定により異なります。

  • ワークロードバランス機能（WLB）が有効なリソースプールでは、各物理サーバーのワークロードが評価され、仮想マシンの最適なホストサーバーが推奨項目として提示されます。
  • ワークロードバランス機能が無効なリソースプールでは、ホームサーバーやプール内のほかのサーバー上で仮想マシンを起動できます（必要なストレージがサーバーにある場合）。 ホームサーバーについて詳しくは、「新規仮想マシンの作成」を参照してください。

仮想マシンが起動して実行状態になると、リソースペインでその仮想マシンの状態インジケータが [image] に変わります。

特定のサーバーで仮想マシンを起動するには

  1. リソースペインで仮想マシンを選択します。
  2. 右クリックして［起動サーバー］を選択し、起動サーバーを選択します。 または、［VM］メニューの［起動サーバー］を選択し、サブメニューから起動サーバーを選択します。

最適なサーバーまたはホームサーバーで仮想マシンを起動するには

リソースペインで仮想マシンを選択して、ツールバーの［ [image] 起動］をクリックします。

または、次のいずれかを行います。

  • リソースペインで仮想マシンを右クリックして、［起動］を選択します。
  • ［VM］メニューの［起動］を選択します。

ワークロードバランスが有効なリソースプールでは、これにより最適なサーバー上で仮想マシンが起動します。

ワークロードバランスが設定されていないリソースプールでは、これによりホームサーバー（ホームサーバーが設定されていない場合は使用可能な最初のサーバー）上で仮想マシンが起動します。


仮想マシンの一時停止と再開

仮想マシンを一時停止すると、その状態がデフォルトのストレージリポジトリ上にファイルとして保存されます。 この方法で仮想マシンを一時停止してからそのホストサーバーをシャットダウンし、ホストサーバーを再起動してから仮想マシンを元の実行状態に戻すことができます。

注： 一時停止にした仮想マシンが種類の異なるサーバーで作成されたものである場合、再開できない可能性があります。 たとえば、Intel VTが有効なCPUが搭載されたサーバー上で作成された仮想マシンは、AMD-Vが搭載されたサーバーで再開できない可能性があります。

仮想マシンを一時停止するには

  1. デフォルトのストレージリポジトリが接続解除されている場合は、新しいデフォルトストレージリポジトリを選択します。
  2. リソースペインで仮想マシンを選択して、ツールバーの［ [image] 一時停止］をクリックします。 または、次のいずれかを行います。
    • 右クリックして［一時停止］を選択します。
    • ［VM］メニューの［一時停止］を選択します。
    仮想マシンが一時停止状態になり、リソースペインでその仮想マシンの状態インジケータが [image] に変わります。

一時停止状態の仮想マシンを再開するには

通常、リソースプールでは、仮想マシンの再開先サーバーを選択できます。 仮想マシンのホストサーバーの選択方法は、仮想マシンとリソースプールの設定により異なります。

  • ワークロードバランス機能（WLB）が有効なリソースプールでは、各物理サーバーのワークロードが評価され、仮想マシンの最適なホストサーバーが推奨項目として提示されます。
  • ワークロードバランス機能が無効なリソースプールでは、ホームサーバーやプール内のほかのサーバー上で仮想マシンを再開できます（必要なストレージがサーバーにある場合）。 仮想マシンのホームサーバーについて詳しくは、「ホームサーバー」を参照してください。

一時停止状態の仮想マシンが正常に再開すると、リソースペインでその仮想マシンの状態インジケータが [image] に変わります。

特定のサーバーで仮想マシンを再開するには

  1. リソースペインで仮想マシンを選択します。
  2. 右クリックして［再開サーバー］を選択し、ホストサーバーを選択します。 または、［VM］メニューの［再開サーバー］を選択し、サブメニューからホストサーバーを選択します。

最適なサーバーまたはホームサーバーで仮想マシンを自動的に再開するには

リソースペインで仮想マシンを選択して、ツールバーの［ [image] 再開］をクリックします。

または、次のいずれかを行います。

  • リソースペインで仮想マシンを右クリックして、［再開］を選択します。
  • ［VM］メニューの［再開］を選択します。

ワークロードバランスが有効なリソースプールでは、これにより最適なサーバー上で仮想マシンが起動します。

ワークロードバランスが設定されていないリソースプールでは、これによりホームサーバー上で仮想マシンが起動します。ホームサーバーが設定されていない場合、およびホームサーバーが動作していない場合は、使用可能な最初のサーバー上で仮想マシンが起動します。


仮想マシンのシャットダウン

サーバーリソースを解放したり、仮想マシンネットワークハードウェアや仮想ディスクストレージを再構成したりするなど、さまざまな理由で仮想マシンのシャットダウンが必要になることがあります。 仮想マシンのコンソールまたはXenCenterを使用して、仮想マシンをシャットダウンできます。 XenCenterでは2つの方法で仮想マシンをシャットダウンできます。

  • ソフトシャットダウンでは、仮想マシンを通常の方法でシャットダウンします。実行中のプロセスは個別に停止されます。
  • 強制シャットダウンでは、仮想マシンを強制的にシャットダウンします。物理サーバーの電源プラグを抜くのと同等です。 実行中のプロセスを正しく停止できない場合があるため、この方法で仮想マシンをシャットダウンするとデータが失われる可能性があります。 ソフトシャットダウンができない場合に限り、強制シャットダウンを使用します。

HVMモードで実行中の（つまりXenServer Toolsが未インストールの）仮想マシンは、強制シャットダウンでのみシャットダウンできます。これを避けるには、すべてのHVM仮想マシンにXenServer Toolsをインストールする必要があります。

ソフトシャットダウンを実行するには

リソースペインで仮想マシンを選択して、ツールバーの ［ [image] シャットダウン］をクリックします。

または、次のいずれかを行います。

  • リソースペインで右クリックして、［シャットダウン］を選択します。
  • ［VM］メニューの［シャットダウン］を選択します。

コンソールの浮動ウィンドウから仮想マシンをシャットダウンすることもできます。 をクリックして［シャットダウン］をクリックします。

仮想マシンのコンソールに、実行中プロセスの停止と共にシャットダウンメッセージが表示されます。 シャットダウンが完了すると、リソースペインでその仮想マシンの状態インジケータが [image] に変わります。

強制シャットダウンを実行するには

リソースペインで仮想マシンを選択して、ツールバーの［ [image] 強制シャットダウン］をクリックします。

または、次のいずれかを行います。

  • リソースペインで右クリックして、［強制シャットダウン］を選択します。
  • ［VM］メニューの［強制シャットダウン］を選択します。

コンソールの浮動ウィンドウから仮想マシンを強制シャットダウンすることもできます。 をクリックして［強制シャットダウン］をクリックします。

シャットダウンが完了すると、リソースペインでその仮想マシンの状態インジケータが [image] に変わります。


仮想マシンの再起動

XenCenterで仮想マシンを再起動する方法には、以下の2種類があります。

  • ソフト再起動では、仮想マシンのシャットダウンと再起動が順番に行われます。
  • 強制再起動では、シャットダウン手順を実行せずに強制的に仮想マシンを再起動します。 これは、物理サーバーの電源プラグを抜いてから電源を入れるのと同等の操作です。

重大なエラーなどが発生し、強制的にシステムを起動する場合に限り、最終手段として強制再起動を使用します。

HVMモードで実行中の（XenServer Toolsが未インストールの）仮想マシンは、強制再起動でのみ再起動できます。これを避けるには、すべてのHVM仮想マシンにXenServer Toolsをインストールする必要があります。

仮想マシンを完全に再起動するには

リソースペインで仮想マシンを選択して、ツールバーの［ [image] 再起動］をクリックします。

または、次のいずれかを行います。

  • リソースペインで右クリックして、［再起動］を選択します。
  • ［VM］メニューの［再起動］を選択します。

仮想マシンがシャットダウンされ、再起動されます。 このプロセスが完了すると、リソースペインでその仮想マシンの状態インジケータが [image] に変わります。

強制再起動を実行するには

リソースペインで仮想マシンを選択して、ツールバーの［ [image] 強制再起動］をクリックします。

または、次のいずれかを行います。

  • リソースペインで右クリックして、［強制再起動］を選択します。
  • ［VM］メニューの［強制再起動］を選択します。

仮想マシンが直ちにシャットダウンされ、再起動されます。 このプロセスが完了すると、リソースペインでその仮想マシンの状態インジケータが [image] に変わります。


リモートコンソールセッションの実行

仮想マシンのリモートデスクトップコンソールセッションを開くには、仮想マシンを選択して［コンソール］タブをクリックします。

Linux仮想マシン

Linux仮想マシンでは、テキストコンソールまたはグラフィックコンソールを使用できます。 グラフィックコンソールではVNC技術が使用されます。コンソールを使用するには、VNCサーバーとXディスプレイマネージャを仮想マシンにインストールし、設定しておく必要があります。 Linux仮想マシンのVNCを設定する方法については、『XenServer仮想マシンユーザーガイド』を参照してください。

リモートコンソールの種類を切り替えるには、［コンソール］タブの［グラフィックコンソールに切り替える/テキストコンソールに切り替える］ボタンを使用します。

Windows仮想マシン

Windows仮想マシンでは、標準のグラフィックコンソールまたはリモートデスクトップコンソールを使用できます。どちらのコンソールでも、キーボードとマウスの使用がサポートされます。 標準のグラフィックコンソールでは、Citrix XenServerに組み込まれているVNC技術により仮想マシンコンソールへのリモートアクセスが提供されます。リモートデスクトップコンソールでは、RDP（Remote Desktop Protocol）技術が使用されます。 標準のグラフィックコンソールとリモートデスクトップコンソールを切り替えるには、［コンソール］タブの［リモートデスクトップに切り替える/デフォルトデスクトップに切り替える］ボタンを使用します。

リモートデスクトップ接続を使用するには、次の要件を満たす必要があります。

  • 仮想マシン上でリモートデスクトップを有効にする必要があります。Windows仮想マシン上でリモートデスクトップを有効にする手順については、『XenServer仮想マシンユーザーガイド』を参照してください。
  • XenServer Toolsをインストールする必要があります。
  • 仮想マシンにネットワークインターフェイスがあり、XenCenterに接続できる必要があります。

XenCenterのさまざまな設定が、リモートデスクトップコンソールの動作に影響します。

  • Windowsのキーの組み合わせは、リモートデスクトップコンソールに送信されます。
  • リモートデスクトップコンソール上のアプリケーションでのサウンドは、ローカルコンピュータ上で再生されます。
  • デフォルトで、リモートデスクトップコンソールセッションを開くと、仮想コンソールセッションが作成されるのではなく、リモートサーバー上のコンソールセッションへの接続が1つ作成されます。
  • XenCenter では、RDP接続が自動的にスキャンされます。このため、RDP接続が使用可能になった場合に自動的にリモートデスクトップコンソールに切り替わるように設定できます。

リモートデスクトップコンソールに関する設定は、［オプション］ダイアログボックスの［コンソール］タブで変更できます。詳しくは、「XenCenterの設定の変更」を参照してください。


仮想マシンの移行

ストレージXenMotion機能を使用して、実質的にサービスを中断することなく、実行中の仮想マシンを同じリソースプール内のサーバーの間で移動できます。 仮想マシンの移行先ホストサーバーの選択方法は、仮想マシンとリソースプールの設定により異なります。

XenCenterの［VMの移動］ダイアログボックスでは、停止中の仮想マシンをプール内のほかのストレージに移動できます。 仮想マシンを移動するには、停止中の仮想マシンを選択して、［VM］メニューの［VMの移動］を選択します。 移動先のストレージリポジトリを選択して、［移動］をクリックします。

XenMotionおよびストレージXenMotionによる仮想マシンの移行について

XenMotion

XenMotionは、共有ストレージ上の仮想マシンを、そのストレージを共有するほかのホストに実行したまま移行する機能で、XenServerのすべてのバージョンで使用できます。 これにより、ワークロードバランス、高可用性、およびプールのローリングアップグレードなどのプール保守機能で仮想マシンを自動的に移動できるようになります。 これらのプール保守機能は、ワークロードの分散、インフラストラクチャの耐障害性、およびサーバーソフトウェアのアップグレード機能を、仮想マシンを停止させることなく提供します。 ストレージを共有できるのは同一プールに属するホストのみなので、仮想マシンの移行も同一プール内に限られます。

ストレージXenMotion

ストレージXenMotionでは、ストレージを共有していないホスト間でも仮想マシンを移行できます。 つまり、ローカルストレージ上で実行中の仮想マシンを、ほかのプール内のホストに移行することもできます。 これにより、以下のことが可能になります。

  • 仮想マシンをXenServerプール間で再配置する（開発環境から実務環境に移行するなど）。
  • スタンドアロンのXenServerホストを、仮想マシンのダウンタイムなしにアップグレードまたはアップデートする。
  • XenServerホストのハードウェアをアップグレードする。
注： ホスト間で移行される仮想マシンの状態情報は保持されます。 この情報には、仮想マシンを識別するための情報のほか、CPUやネットワークなどのパフォーマンス測定値の履歴が含まれます。

ストレージXenMotionでは、ストレージリポジトリ上の仮想ディスクを、同一プール内のほかのストレージリポジトリに移動することもできます。 詳しくは、「仮想ディスクの移動」を参照してください。

互換性に関する要件

XenMotionまたはストレージXenMotionで仮想マシンを移行する場合、以下の互換性に関する要件を満たしている必要があります。

  • 移行する各仮想マシンにXenServer Toolsがインストールされている必要があります。
  • 移行先のホストで、移行元ホストと同等またはそれ以降のバージョンのXenServerが動作している必要があります。
  • ストレージXenMotionでは、移行元ホストと移行先ホストでCPUが異なる場合に移行元ホストのすべてのCPU機能を移行先ホストがサポートしている必要があります。 このため、たとえばAMD社製プロセッサのホストからIntel社製プロセッサのホストに仮想マシンを移行することはほぼ不可能です。
  • ストレージXenMotionでは、複数のスナップショットを持つ仮想マシンを移行できません。
  • ストレージXenMotionでは、7つ以上のVDIを持つ仮想マシンを移行できません。
  • 移行先のホストで、動的メモリ制御機能が有効な場合も含め、十分な空きメモリ領域が必要です。 十分なメモリを割り当てられない場合、移行処理が完了しません。
  • ストレージXenMotionでは、移行先のホストに十分な空きディスク領域が必要です（移行する仮想マシンおよびスナップショット用）。 十分な領域がない場合、移行処理が完了しません。

XenMotionおよびストレージXenMotionの制限事項

XenMotionおよびストレージXenMotionには、以下の制限事項があります。

  • ストレージXenMotionは、XenDesktop環境では使用できません。
  • 仮想マシンのVDIがXenServerに統合されたStorageLinkのストレージリポジトリ上にある場合、その仮想マシンは移行できません。
  • PCIパススルー機能を使用した仮想マシンは移行できません。
  • 移行時に仮想マシンのパフォーマンスが低下することがあります。
  • ストレージXenMotionでは、高可用性やワークロードバランス機能を無効にしてから仮想マシンを移行する必要があります。
  • 仮想マシンの移行にかかる時間は、仮想マシンのメモリサイズやその仮想マシンで処理中のタスクにより異なります。また、ストレージXenMotionの場合は、VDIのサイズやストレージで処理中のタスクによっても異なります。

仮想マシンを移行するには

  1. リソースペインで仮想マシンを選択して、次のいずれかを行います。
    • 右クリックして［移行先サーバー］を選択し、［VMの移行ウィザード］を選択します。
    • ［VM］メニューから、［移行先サーバー］、［VMの移行ウィザード］の順に選択します。
    • フォルダビューのリソースペインで、仮想マシンを移行先サーバー上にドラッグします。 仮想マシンをドラッグして移行するには、リソースペインをフォルダビューに切り替える必要があります。
  2. ［移行先］ボックスの一覧から、スタンドアロンサーバーまたはプールを選択します。
  3. ［ホームサーバー］ボックスの一覧で仮想マシンのホームサーバーを選択して、［次へ］をクリックします。
  4. ［ストレージ］ページで仮想マシンの仮想ディスクを配置するストレージリポジトリを選択して、［次へ］をクリックします。
    • ［すべての仮想ディスクを同一SR上に移行する］オプションがデフォルトで選択され、移行先プールのデフォルトの共有ストレージリポジトリが表示されます。
    • ［仮想ディスクの移行先SRを指定する］をクリックして、［ストレージリポジトリ］ボックスの一覧でストレージリポジトリを選択します。 このオプションでは、移行する仮想マシンの仮想ディスクごとに異なるストレージリポジトリを選択できます。
  5. ［ストレージネットワーク］ボックスの一覧で、仮想マシンの仮想ディスクのライブマイグレーションで使用される移行先プールのネットワークを選択して、［次へ］をクリックします。
    注： パフォーマンス上の理由から、管理ネットワークをライブマイグレーションで使用しないことをお勧めします。
  6. 選択した内容を確認し、［完了］をクリックして移行を実行します。


仮想マシンの削除

仮想マシンを削除すると、その設定とファイルシステムもサーバーから削除されます。 仮想マシンを削除するときに、その仮想マシンに接続されていた仮想ディスクや、その仮想マシンから作成したスナップショットを削除するかどうかを指定できます。

仮想マシンを削除するには

  1. 仮想マシンをシャットダウンします。
  2. リソースペインで停止した仮想マシンを右クリックして、［VMの削除］を選択します。 または、［VM］メニューの［VMの削除］を選択します。
  3. 接続済みの仮想ディスクも削除する場合は、そのチェックボックスをオンにします。
    重要： その仮想ディスクに格納されているデータはすべて失われます。
  4. スナップショットも削除する場合は、そのチェックボックスをオンにします。
  5. ［削除］をクリックします。

    操作が完了すると、リソースペインから仮想マシンが削除されます。

    作成元の仮想マシンが削除されているスナップショット（「孤立したスナップショット」）をエクスポートまたは削除したり、仮想マシンやテンプレートの作成に使用したりするには、リソースペインをフォルダビューに切り替えます。 孤立したものを含むすべてのスナップショットは、［種類］ノードの［スナップショット］に表示されます。


仮想マシンのインポートとエクスポート

トピック

  • 仮想マシンのインポートとエクスポートについて
  • Open Virtualization Format（OVFとOVA）
  • ディスクイメージ形式（VHDとVMDK）
  • OVF/OVAからのインポート
  • ディスクイメージのインポート
  • XVAからのインポート
  • OVF/OVAとしてのエクスポート
  • XVAとしてのエクスポート


仮想マシンのインポートとエクスポートについて

XenCenterでは、OVF/OVAパッケージ、ディスクイメージ、およびXenServer XVAファイルから仮想マシンをインポートできます。 また、仮想マシンをOVF/OVAパッケージおよびXenServer XVAファイルとしてエクスポートできます。 仮想マシンのインポートおよびエクスポートには、XenCenterの［インポート］ウィザードと［エクスポート］ウィザードを使用します。 XenCenterでは、ディスクイメージの内容を転送するときに、Transfer VMが使用されます。

Hyper-VやVMwareなど、XenServer以外のハイパーバイザーで作成された仮想マシンをインポートする場合は、その仮想マシンがXenServer上で正しく起動するように、オペレーティングシステムの修復機能を使用する必要があります。

インポートとエクスポートでサポートされる形式

形式 | 説明
Open Virtualization Format（OVFとOVA） | OVFは、いくつかの仮想マシンで構成される仮想アプライアンスをパッケージ化および配布するためのオープンスタンダードです。 XenCenterでのOVFファイルおよびOVAファイルのサポートについて詳しくは、「Open Virtualization Format（OVFとOVA）」を参照してください。
ディスクイメージ形式（VHDとVMDK） | ［インポート］ウィザードでは、VHD（Virtual Hard Disk）およびVMDK（Virtual Machine Disk）形式のディスクイメージファイルをインポートできます。 この形式では、OVFメタデータがない仮想ディスクイメージをインポートできます。 サポートされるディスクイメージの形式について詳しくは、「ディスクイメージ形式（VHDとVMDK） 」を参照してください。
XenServer XVA形式 | XVAはXenハイパーバイザー独自の形式で、単一の仮想マシンを記述子とディスクイメージの単一ファイルアーカイブとしてパッケージ化します。 このファイルの拡張子は、.xvaです。
XenServer XVA Version 1（ova.xml） | XVA Version 1は、単一の仮想マシンを記述子とディスクイメージを含んだファイルセットとしてパッケージ化します。 記述子（ova.xml）により、その仮想マシンの仮想ハードウェアが定義されます。 ディスクイメージ形式は、一連のファイルを含んだディレクトリによって表わされます。 このディレクトリの名前は、記述子に定義されている参照名に対応しています。 ディスクイメージの1GBのチャンクごとに、1ファイルが作成されます。 このファイルの名前には10進数のチャンク番号が使用され、 ディスクイメージの各ブロックがgzipで圧縮されたローバイナリ形式で格納されます。

各ファイル形式の用途

OVF/OVA形式のファイルは、以下の用途に使用されます。
  • XenServerのvAppおよび仮想マシンを、OVFをサポートするほかのハイパーバイザーと共有する。
  • 複数の仮想マシンを保存する。
  • vAppまたは仮想マシンを破損や改ざんから保護する
  • ライセンス契約を追加する。
  • OVFパッケージをOVAに格納してvAppを配布しやすくする。
XVA形式のファイルは、以下の用途に使用されます。
  • 仮想マシンを、以前のバージョンのXenServerと共有する。
  • コマンドラインインターフェイス（CLI）でスクリプトを実行して仮想マシンをインポートまたはエクスポートする。

オペレーティングシステムの修復

XenCenterのオペレーティングシステムの修復機能では、XenServerにインポートした仮想マシンの互換性の問題を解決することができます。 XenServer以外のハイパーバイザー上で作成した仮想マシンをOVF/OVAパッケージとディスクイメージからインポートする場合に、この機能を使用します。

インポートした仮想マシンのオペレーティングシステムでは、オペレーティングシステムの修復機能により、XenServer上での起動に必要な起動デバイスが有効になり、ほかのハイパーバイザーで使用されるサービス（ツールとも呼ばれます）が無効になります。 対象となるゲストオペレーティングシステムには、XenServerでサポートされるすべてのバージョンのWindowsと、Linuxの一部のディストリビューションが含まれます。 オペレーティングシステムの修復機能は、ゲストオペレーティングシステムをほかのハイパーバイザー用に変換するためのものではありません。

オペレーティングシステムの修復機能は、インポートした仮想マシンのDVDドライブに挿入された自動起動ISOイメージとして提供されます。仮想マシンの初回起動時に、この自動起動イメージにより適切な修復が行われ、仮想マシンがシャットダウンされます。 同時に起動デバイスの設定がリセットされるため、これ以降は設定されているデバイスの順序に従って仮想マシンが起動します。

インポートしたディスクイメージおよびOVF/OVAパッケージでオペレーティングシステムの修復機能を使用するには、XenCenterの［インポート］ウィザードの［OSの修復設定］ページでこの機能を有効にして、Fixup ISOのコピー先を指定します。

オペレーティングシステムの修復機能の要件

オペレーティングシステムの修復機能を使用するには、40MBの空き容量を持つISOストレージリポジトリと、256MBの仮想メモリが必要です。

Transfer VM

Transfer VMは、仮想ディスクイメージのインポートまたはエクスポート時にのみ実行される、XenCenter組み込みの仮想マシンです。この仮想マシンにより、仮想ディスクイメージの内容がディスクイメージとXenServerストレージリポジトリ間で転送されます。 ディスクイメージをインポートまたはエクスポートするたびに、1つのTransfer VMが実行されます。 複数のディスクイメージを持つ仮想マシンやvAppをインポートまたはエクスポートする場合でも、同時に転送されるディスクイメージは1つのみです。

［インポート］ウィザードおよび［エクスポート］ウィザードでは、Transfer VM用のネットワーク設定を行う必要があります。

Transfer VMの要件

1つのTransfer VMの実行に必要なXenServerの要件は、以下のとおりです。
仮想CPU | 1
仮想メモリ | 256MB
ストレージ | 8MB
ネットワーク | XenServerホストから接続可能なネットワーク。通常は管理ネットワーク 静的または動的IPアドレス （動的IPアドレス推奨）

デフォルトでは、転送プロトコルとしてiSCSIが使用されます。このため、XenCenterホスト上にiSCSIイニシエータが必要です。 転送プロトコルとしてRawVDIを使用することもできます。詳しくは、『XenServer仮想マシンユーザーガイド』を参照してください。

仮想マシンのインポート：概要

仮想マシンのインポートでは、ホームサーバーを指定したりストレージやネットワークを設定したりするなど、実質的に［新規VM］ウィザードで新しい仮想マシンを作成する場合と同じ手順が必要になります。これらの手順については、「新規仮想マシンの作成」を参照してください。

［インポート］ウィザードでは、以下の手順により仮想マシンをインポートします。
  1. インポートするファイルを指定する。

    最初に、インポートする仮想マシンを含んでいるファイルを選択します。

    XenCenterホスト上にローカルに存在しないファイルを指定するには、［ファイル名］ボックスにURL（http、https、file、ftp）を入力します。 ［次へ］をクリックすると、［パッケージのダウンロード］ダイアログボックスが開きます。ここでは、ファイルのダウンロード先となるXenCenterホスト上のフォルダを指定します。 ファイルのダウンロードが完了すると、［インポート］ウィザードの次のページが開きます。

  2. （VHDおよびVMDKのみ）新しい仮想マシンの名前と、割り当てるCPUの数とメモリの量を指定する。

    VHDまたはVMDKファイルからのインポートでは、新しい仮想マシンの名前を入力して、仮想CPU（vCPU）とメモリを割り当てる必要があります。 これらの値は、仮想マシンの作成後に変更することもできます。 この手順について詳しくは、「仮想マシンのCPUとメモリの設定」を参照してください。 XenCenterでは、仮想マシン名が重複しているかどうかがチェックされません。このため、仮想マシンの内容を表すわかりやすい名前を使用してください。詳しくは、「仮想マシンの名前と説明」を参照してください。

  3. （OVF/OVAのみ）EULAを確認して同意する。

    インポートするパッケージにライセンス契約書（EULA）が含まれている場合は、内容を確認して同意し、［次へ］をクリックします。 パッケージにEULAが含まれていない場合、この手順は不要です。

  4. 場所/ホームサーバーを選択する。

    仮想マシンのインポート先のプールまたはスタンドアロンサーバーを選択します。 また、一覧からホームサーバーを選択します。

  5. ストレージを設定する。

    次に、インポートする仮想マシンの仮想ディスクを格納するストレージリポジトリを選択します。

    XVA形式の仮想マシンでは、インポートする仮想マシンのすべての仮想ディスクを1つのストレージリポジトリに格納します。

    OVF/OVAパッケージやディスクイメージファイルの仮想マシンでは、インポートするすべての仮想ディスクを1つのストレージリポジトリに格納したり、それぞれ個別のストレージリポジトリに格納したりできます。

  6. ネットワークを設定する。

    次に、インポートする仮想マシンの仮想ネットワークインターフェイスを、インポート先のプールまたはスタンドアロンサーバーのネットワークに割り当てます。

  7. （OVF/OVAのみ）セキュリティを検証する。

    インポートするOVF/OVAパッケージに証明書やマニフェストなどのセキュリティが設定されている場合は、必要な情報を指定する必要があります。

  8. （OVF/OVAおよびディスクイメージのみ）オペレーティングシステムの修復とTransfer VMを設定する。

    XenServer以外のハイパーバイザーで作成された仮想マシンをインポートする場合は、XenServer上で正しく実行できるように、オペレーティングシステムの修復機能を有効にします。 また、OVF/OVAパッケージやディスクイメージからのインポートやエクスポートで使用される一時的な仮想マシン（Transfer VM）のネットワークを設定します。

  9. 仮想マシン作成を完了する。

    ［インポート］ウィザードの最後のページでは、選択した設定内容を確認できます。 XVAからのインポートでは、［VMを自動的に起動する］チェックボックスをオンにして、インポートした仮想マシンが自動的に起動するように設定できます。

    ［完了］をクリックしてインポートを実行し、ウィザードを閉じます。

仮想マシンのエクスポート：概要

エクスポートする仮想マシンを選択して、［エクスポート］ウィザードを開きます。これを行うには、［VM］メニューの［エクスポート］を選択します。

  1. エクスポートするファイルの詳細を指定する。

    ウィザードの最初のページでで、ファイル名およびエクスポート先を指定して、［形式］ボックスの一覧でファイル形式を選択します。

    仮想マシンをXVAファイルとしてエクスポートするには、［XVAファイル（*.xva）］を選択します。 この形式にエクスポートできるのは、単一の仮想マシンを選択した場合のみです。

    仮想マシンをOVFまたはOVAパッケージとしてエクスポートするには、[ OVF/OVAパッケージ（*.ovf, *.ova）］を選択します。

  2. エクスポートする仮想マシンを確認する。

    ウィザードの次のページでは、エクスポートする仮想マシンの選択を変更できます。たとえば、OVFまたはOVAパッケージとしてエクスポートする仮想マシンを追加したり削除したりできます。 XVAファイルとしてエクスポートする場合、この一覧で選択できる仮想マシンは1つのみです。

  3. （OVF/OVAのみ）EULA、高度なオプション、およびTransfer VMを設定する。

    仮想マシンをOVFまたはOVAパッケージとしてエクスポートする場合は、いくつかの追加オプションを設定できます。 詳しくは、「OVF/OVAとしてのエクスポート」を参照してください。

  4. 仮想マシンのエクスポートを完了する。

    ウィザードの最後のページで、エクスポート内容を確認します。 エクスポートしたファイルを検証するには、［完了時にエクスポートを検証する］チェックボックスをオンにします。

    ［完了］をクリックしてエクスポートを実行し、ウィザードを閉じます。


Open Virtualization Format（OVFとOVA）

OVFは、Distributed Management Task Force（DMTF）により策定された、いくつかの仮想マシンで構成される仮想アプライアンスをパッケージ化および配布するためのオープンスタンダードです。

OVFパッケージは、仮想マシンを定義するファイルエレメントとメタデータ、およびそのパッケージ内のアプリケーションの配備および動作に必要な追加情報で構成されます。 ファイル拡張子は.ovfです。

OVA（Open Virtual Appliance）は単一のファイルアーカイブにまとめられたOVFパッケージで、拡張子は.ovaです。

役割ベースのアクセス制御（RBAC）が実装されたXenServer環境では、プール管理者の役割を持つユーザーだけがOVFおよびOVAパッケージをインポートできます。 詳しくは、「役割ベースのアクセス制御（RBAC）の概要」を参照してください。

OVFパッケージとは

OVFパッケージには、常に記述子ファイル（*.ovf）が含まれます。そのほかにも、以下のファイルが含まれる場合があります。

ファイルの種類 | 説明
記述子 | 記述子ファイルにより、その仮想マシンの仮想ハードウェアが定義されます。また、このファイルには仮想ディスク、サービス、およびゲストオペレーティングシステムに関する記述や、ライセンス契約書（EULA）、アプライアンス内の仮想マシンの起動および停止手順、サービスのインストール手順などの情報が含まれます。 記述子ファイルの拡張子は、.ovfです。
マニフェスト | パッケージに含まれる各ファイルのSHA-1ダイジェスト値で、パッケージの破損を検出します。 マニフェストファイルの拡張子は、.mfです。
署名 | パッケージに含まれるX.509証明書の公開キーで署名されたマニフェストのダイジェスト値で、パッケージの所有者の検証に使用されます。 署名ファイルの拡張子は、.certです。
仮想ディスク | OVFは、ディスクイメージの形式についての仕様ではありません。 OVFパッケージには仮想ディスクを構成するファイルが含まれますが、その形式は仮想ディスクをエクスポートした仮想化製品により異なります。 XenServerで作成するOVFパッケージでは、Dynamic VHD形式のディスクイメージが使用されます。VMware製品やVirtual BoxのOVFパッケージでは、ストリーム最適化のVMDK形式が使用されます。

OVAパッケージは、OVFパッケージを構成するファイルを含んだ単一のTAR（Tape Archive）形式のアーカイブファイルです。

各ファイル形式の用途

OVFパッケージに含まれる一連のファイルは圧縮されていないため、ファイル内の個々のディスクイメージにアクセスするユーザーにとっては便利な形式です。一方、OVAパッケージは、サイズの大きな単体のファイルです。 このファイルを圧縮することもできますが、OVFパッケージのように柔軟に個々のファイルにアクセスすることはできません。

Webサイトからのダウンロードで配布する場合など、単一ファイルのパッケージを作成するにはOVA形式を使用します。 OVAパッケージのインポートおよびエクスポートには、OVFパッケージよりも時間がかかります。

オペレーティングシステムの修復機能の使用

OVF形式のパッケージでは、異なるハイパーバイザー間での仮想マシンの互換性が保証されません。 異なるハイパーバイザー上で作成されたOVFパッケージをインポートしても、そのままでは正しく動作しない場合があります。 インポートした仮想マシンが正しく動作しない原因として、OVF仕様の解釈、ゲストオペレーティングシステムデバイス、ハイパーバイザー固有のドライバなど、さまざまな理由が考えられます。

XenCenterのオペレーティングシステムの修復機能では、XenServerにインポートしたOVFパッケージの互換性の問題を解決することができます。 XenServer以外のハイパーバイザー上で作成された仮想マシンをインポートする場合は、XenServer上で正しく起動するように、オペレーティングシステムの修復機能を使用する必要があります。

オペレーティングシステムの修復機能について詳しくは、「仮想マシンのインポートとエクスポートについて」を参照してください。

OVFに関するそのほかの情報

OVFについて詳しくは、以下のCitrix Knowledge CenterおよびDMTFのWebサイトを参照してください。

「OVF（Open Virtualization Format）の概要」

『Open Virtualization Format Specification』（英文）


ディスクイメージ形式（VHDとVMDK）

［インポート］ウィザードを使用すると、ディスクイメージを仮想マシンとしてリソースプールや特定のサーバー上にインポートできます。

この形式では、OVFメタデータがない仮想ディスクイメージをインポートできます。 以下の状況でこのウィザードを使用します。
  • OVFメタデータを持たない ディスクイメージをインポートする場合。
  • OVFパッケージで定義されていない仮想ディスクをインポートする場合。
  • OVFアプライアンスの作成をサポートしないプラットフォームから移行する場合（古いプラットフォームやイメージなど）。
  • OVF情報を持たないVMwareアプライアンスをインポートする場合。
  • OVF情報を持たない単独の仮想マシンをインポートする場合。

OVFメタデータが使用可能な場合は、単独のディスクイメージではなく、OVFメタデータを含んでいるアプライアンスパッケージをインポートすることをお勧めします。 OVFメタデータにより、ディスクイメージから仮想マシンを再構成するために必要な情報（仮想マシンに関連付けられているディスクイメージ数、プロセッサ、ストレージ、およびメモリ要件など）が提供されます。 この情報がない場合、仮想マシンの再構成手順が複雑になるため、インポートエラーが発生しやすくなります。

役割ベースのアクセス制御（RBAC）が実装されたXenServer環境では、プール管理者の役割を持つユーザーだけがディスクイメージをインポートできます。 詳しくは、「役割ベースのアクセス制御（RBAC）の概要」を参照してください。

サポートされるディスクイメージ形式

XenCenterの［インポート］ウィザードでは、以下の形式のディスクイメージをインポートできます。
形式 | 説明
VHD（Virtual Hard Disk：仮想ハードディスク） | VHDは、Microsoft社がOpen Specification Promiseに基づいて策定した一連の仮想ディスクイメージ形式です。 このファイルの拡張子は、.vhdです。 XenCenterでは動的VHD形式で仮想ディスクが作成されます。これはシンディスクとしてプロビジョニングされる仮想ディスクイメージで、使用時にのみ領域が割り当てられます。
VMDK（Virtual Machine Disk：仮想マシンディスク） | VMDKは、VMware®社が策定した一連の仮想ディスクイメージ形式です。 このファイルの拡張子は、.vmdkです。 XenCenterでは、ストリーム最適化のモノリシックフラットVMDK形式をインポートできます。 ストリーム最適化のVMDKは、VMwareおよびVirtual Boxのハイパーバイザー用OVFパッケージで使用される形式です。 モノリシックフラットVMDKは、VMware管理クライアントでのダウンロードで一般的に使用される仮想ディスク形式です。

オペレーティングシステムの修復機能の使用

XenCenterには、XenServer以外のハイパーバイザー上で作成された仮想マシンの互換性の問題を解決するオペレーティングシステムの修復機能が用意されています。 このような仮想マシンをインポートする場合は、XenServer上で正しく起動するように、オペレーティングシステムの修復機能を使用する必要があります。

詳しくは、「仮想マシンのインポートとエクスポートについて」を参照してください。


OVF/OVAからのインポート

OVF/OVAファイルとして保存されている仮想マシンをXenServer環境にインポートするには、XenCenterの［インポート］ウィザードを使用します。 XenCenterで仮想マシンを作成するときに必要な手順の多くが、このウィザードでも表示されます。つまり、ホームサーバーを指定したり、ストレージやネットワークを設定したりするための手順が表示されます。また、インポートに特有なものとして、以下の手順が表示されます。
  • OVFパッケージに証明書やマニフェストが含まれている場合に、セキュリティ設定を指定する。
  • Transfer VM（「仮想マシンのインポートとエクスポートについて」参照）のネットワークを設定する。
  • XenServer以外のハイパーバイザーで作成された仮想マシンをインポートする場合に、オペレーティングシステムの修復機能を設定する。

新規仮想マシンを作成するときの手順については、「新規仮想マシンの作成」を参照してください。

XenCenterでインポートしたOVFパッケージは、vAppとして表示されます。 インポートが完了すると、XenCenterのリソースペインに新しい仮想マシンが追加され、［vAppの管理］ダイアログボックスにvAppが追加されます。

要件

  • OVF/OVAパッケージをインポートするには、プール管理者の役割が必要です。 このため、［インポート］ウィザードを開始したときに、インポート先リソースプールに対するプール管理者の役割があるかどうかがチェックされます。 詳しくは、「役割ベースのアクセス制御（RBAC）の概要」を参照してください。
  • 圧縮されたOVFパッケージをインストールする場合、XenServerホスト上に圧縮ファイルを展開するためのディスク領域が必要です。

OVFパッケージをインポートするには

  1. ［インポート］ウィザードを開きます。これを行うには、［ファイル］メニューの［インポート］を選択します。
  2. ウィザードの最初のページで、インポートするパッケージ（拡張子.ovf、.ova、または.ova.gzのファイル）を選択し、［次へ］をクリックします。
    • 圧縮されたOVAファイル（拡張子*.ova.gz）を選択した場合、［次へ］をクリックするとOVAファイルとして展開され、元の*.ova.gzファイルは削除されます。
    • ［ファイル名］ボックスにURL（http、https、file、ftp）を入力した場合は、［次へ］をクリックすると［パッケージのダウンロード］ダイアログボックスが開きます。ここでは、パッケージのダウンロード先となるXenCenterホスト上のフォルダを指定します。
  3. EULAの内容を確認して、同意します。

    インポートするパッケージにライセンス契約書（EULA）が含まれている場合は、内容を確認して同意し、［次へ］をクリックします。 パッケージにEULAが含まれていない場合、この手順は不要です。

  4. 仮想マシンのインポート先を指定して、ホームサーバーを指定します。 ［場所］ページの［VMのインポート先］ボックスの一覧で、新しい仮想マシンのインポート先プールまたはスタンドアロンサーバーを選択し、必要に応じてホームサーバーを指定します。
    • ホームサーバーを指定するには、［ホームサーバー］列でサーバーを選択します。 ホームサーバーとは、仮想マシンのデフォルトの起動サーバーを指します。 新規仮想マシンにホームサーバーを指定する方法について詳しくは、「ホームサーバー」を参照してください。
    • ホームサーバーを指定しない場合は、［ホームサーバー］列で［ホームサーバーを割り当てない］を選択します。

      ［次へ］をクリックして続行します。

  5. インポートする仮想マシンのストレージを設定します。 ［ストレージ］ページでは、インポートする仮想マシンのディスクイメージの格納先となるストレージリポジトリを選択して［次へ］をクリックします。
    • インポートするすべてのディスクイメージを同じストレージリポジトリ上に配置する場合は、［インポートするすべての仮想ディスクをこのSRに配置する］をクリックして、一覧からストレージリポジトリを選択します。
    • インポートするディスクイメージをいくつかのストレージリポジトリ上に分けて配置する場合は、［インポートする各仮想ディスクを以下のSRに配置する］をクリックして、一覧の［SR］列で配置するストレージリポジトリを選択します。
  6. インポートする仮想マシンのネットワークを設定します。 ［ネットワーク］ページでは、インポートする仮想マシンの仮想ネットワークインターフェイスを、インポート先プールのネットワークに割り当てます。 このページの一覧に表示されるネットワークおよびMACアドレスは、エクスポートされた元の仮想マシンのファイル内に定義されています。 仮想ネットワークインターフェイスをターゲットネットワークに割り当てるには、［マップするネットワーク］列のドロップダウンリストでネットワークを選択します。

    ［次へ］をクリックして続行します。

  7. セキュリティ設定を指定します。 インポートするOVF/OVAパッケージに証明書やマニフェストなどのセキュリティが設定されている場合は、［セキュリティ］ページで必要な情報を指定して［次へ］をクリックします。 このページに表示されるオプションは、インポートするOVFパッケージに設定されているセキュリティ機能によって異なります。
    • 署名されたパッケージでは、［デジタル署名の検証］チェックボックスが表示されます。署名を検証するには、このチェックボックスをオンにします。 ［証明書の表示］をクリックすると、パッケージの署名に使用された証明書が表示されます。 証明書を信頼できない場合、ルート証明書または証明書の発行機関がローカルコンピュータで信頼されていないことを示します。
    • マニフェストを含んでいるパッケージでは、［マニフェストの検証］チェックボックスが表示されます。 パッケージに含まれているファイルの一覧を検証するには、このチェックボックスをオンにします。
    デジタル署名が追加されたパッケージで署名を検証すると、マニフェストも自動的に検証されます。このため、［セキュリティ］ページに［マニフェストの検証］チェックボックスは表示されません。
    重要： VMware Workstation 7.1で作成するOVFアプライアンスには、無効なSHA-1ハッシュを含んだマニフェストが追加されます。 このため、このようなアプライアンスのインポート時にマニフェストの検証を行うと、インポートに失敗します。
  8. オペレーティングシステムの修復機能を有効にします。 XenServer以外のハイパーバイザーで作成された仮想マシンを含んでいるパッケージをインポートする場合は、［オペレーティングシステムの修復（Fixup）を使用する］チェックボックスをオンにして、Fixup ISOのコピー先となるISOストレージリポジトリを指定します。 この機能について詳しくは、「オペレーティングシステムの修復」を参照してください。

    使用するISOライブラリが一覧に表示されない場合は、［新規ISOライブラリ］をクリックして新しいISOストレージリポジトリを作成できます。詳しくは、「ISOストレージ」を参照してください。

    ［次へ］をクリックして続行します。

  9. Transfer VMのネットワークを設定します。 ［Transfer VMの設定］ページでは、Transfer VM（「仮想マシンのインポートとエクスポートについて」参照）のネットワークを設定して［次へ］をクリックします。
    • インポート先のプールまたはスタンドアロンサーバーのネットワークインターフェイスの一覧で、使用するネットワークを選択します。
    • ネットワーク設定（IPアドレス、サブネットマスク、ゲートウェイなど）をDHCP（Dynamic Host Configuration Protocol）で自動的に割り当てる場合は、［設定をDHCPで自動取得する］をクリックします。
    • ネットワーク設定を手作業で割り当てる場合は、［以下のネットワーク設定を使用する］をクリックして、IPアドレス、サブネットマスク、およびゲートウェイを指定します。
  10. ［完了］ページでは、選択した設定内容を確認し、［完了］をクリックしてインポートを実行し、ウィザードを閉じます。

    インポートの進行状況は［XenCenter］ウィンドウの下部のステータスバーおよび［ログ］タブにも表示されます。

    仮想ディスクのサイズ、ネットワーク帯域幅、およびXenCenterホストのディスクインターフェイスの性能によっては、インポートに時間がかかる場合があります。 インポートが完了すると、インポートされた仮想マシンがリソースペインに追加され、［vAppの管理］ダイアログボックスにvAppが追加されます。

    注： XenCenterを使ってWindowsオペレーティングシステムがインストールされたOVFパッケージをインポートした後で、platformパラメータを設定する必要があります。 設定する値は、インストールされているWindowsのバージョンによって異なります。

    • Windows Vista、Windows Server 2008、およびこれ以降のバージョンでは、platformパラメータにdevice_id=0002を設定します。 たとえば、次のコマンドを実行します。

      xe vm-param-set uuid=<VM UUID> platform:device_id=0002

    • そのほかのバージョンのWindowsでは、platformパラメータにviridian=trueを設定します。 たとえば、次のコマンドを実行します。

      xe vm-param-set uuid=<VM UUID> platform:viridian=true

    インポートした仮想マシンの起動時のエラー

    OVFパッケージからインポートした仮想マシンが起動しない場合は、オペレーティングシステムの修復機能を無効にして再インポートしてください。これを行うには、［インポート］ウィザードの［OSの修復設定］ページで、［オペレーティングシステムの修復（Fixup）を使用する］チェックボックスをオフにします（この機能について詳しくは、「仮想マシンのインポートとエクスポートについて」を参照してください。


ディスクイメージのインポート

XenCenterの［インポート］ウィザードを使用すると、ディスクイメージをリソースプールや特定のサーバー上に新規仮想マシンとしてインポートできます。 XenCenterで仮想マシンを作成するときに必要な手順の多くが、このウィザードでも表示されます。つまり、ホームサーバーを指定したり、ストレージやネットワークを設定したりするための手順が表示されます。また、インポートに特有なものとして、以下の手順が表示されます。
  • Transfer VM（「仮想マシンのインポートとエクスポートについて」参照）のネットワークを設定する。
  • XenServer以外のハイパーバイザーで作成されたディスクイメージをインポートする場合に、オペレーティングシステムの修復機能（「仮想マシンのインポートとエクスポートについて」参照）を設定する。

ディスクイメージをインポートするときの要件

ディスクイメージをインポートするには、プール管理者の役割が必要です。 このため、［インポート］ウィザードを開始したときに、インポート先リソースプールに対するプール管理者の役割があるかどうかがチェックされます。 詳しくは、「役割ベースのアクセス制御（RBAC）の概要」を参照してください。

手順

  • ［インポート］ウィザードを開きます。これを行うには、［ファイル］メニューの［インポート］を選択します。
  • ウィザードの最初のページで、インポートするディスクイメージファイルを選択して［次へ］をクリックします。

    ［ファイル名］ボックスにURL（http、https、file、ftp）を入力した場合は、［次へ］をクリックすると［パッケージのダウンロード］ダイアログボックスが開きます。ここでは、ディスクイメージのダウンロード先となるXenCenterホスト上のフォルダを指定します。

  • 仮想マシンの名前と、割り当てるCPUの数とメモリの量を指定します。

    ［VM定義］ページでは、インポートするディスクイメージから作成される新しい仮想マシンの名前と、割り当てるCPUの数とメモリの量を指定します。 詳しくは、「仮想マシンのCPUとメモリの設定」を参照してください。

    ［次へ］をクリックして続行します。

  • 仮想マシンのインポート先およびホームサーバーを指定します。
    ［場所］ページでは、新しい仮想マシンのインポート先および必要に応じてホームサーバーを指定して［次へ］をクリックします。
    • ［VMのインポート先］ボックスの一覧で、プールまたはスタンドアロンサーバーを選択します。
    • ホームサーバーを指定するには、［ホームサーバー］列でサーバーを選択します。 ホームサーバーとは、仮想マシンのデフォルトの起動サーバーを指します。 新規仮想マシンにホームサーバーを指定する方法について詳しくは、「ホームサーバー」を参照してください。
    • ホームサーバーを指定しない場合は、［ホームサーバー］列で［ホームサーバーを割り当てない］を選択します。
  • 新規仮想マシンのストレージを設定します。

    ［ストレージ］ページでは、インポートする仮想ディスクの格納先となるストレージリポジトリを選択して［次へ］をクリックします。

  • 新規仮想マシンのネットワークを設定します。

    ［ネットワーク］ページでは、インポート先のプールまたはスタンドアロンサーバーのネットワークを選択して、新規仮想マシンの仮想ネットワークインターフェイスに割り当てます。

    ［次へ］をクリックして続行します。

  • オペレーティングシステムの修復機能を有効にします。

    XenServer以外のハイパーバイザーで作成されたディスクイメージをインポートする場合は、［オペレーティングシステムの修復（Fixup）を使用する］チェックボックスをオンにして、Fixup ISOのコピー先となるISOストレージリポジトリを指定します。 この機能について詳しくは、「仮想マシンのインポートとエクスポートについて」を参照してください。

  • Transfer VMのネットワークを設定します。
    ［Transfer VMの設定］ページでは、Transfer VM（「仮想マシンのインポートとエクスポートについて」参照）のネットワークを設定して［次へ］をクリックします。
    • インポート先のプールまたはスタンドアロンサーバーのネットワークインターフェイスの一覧で、使用するネットワークを選択します。
    • ネットワーク設定（IPアドレス、サブネットマスク、ゲートウェイなど）をDHCP（Dynamic Host Configuration Protocol）で自動的に割り当てる場合は、［設定をDHCPで自動取得する］をクリックします。
    • ネットワーク設定を手作業で割り当てる場合は、［以下のネットワーク設定を使用する］をクリックして、IPアドレス、サブネットマスク、およびゲートウェイを指定します。
  • ［完了］ページでは、選択した設定内容を確認し、［完了］をクリックしてインポートを実行し、ウィザードを閉じます。

    インポートの進行状況は［XenCenter］ウィンドウの下部のステータスバーおよび［ログ］タブにも表示されます。

    仮想ディスクのサイズ、ネットワーク帯域幅、およびXenCenterホストのディスクインターフェイスの性能によっては、インポートに時間がかかる場合があります。 インポートが完了すると、リソースペインに新しい仮想マシンが追加されます。
    注： XenCenterを使ってWindowsオペレーティングシステムがインストールされたディスクイメージをインポートした後で、platformパラメータを設定する必要があります。 設定する値は、インストールされているWindowsのバージョンによって異なります。

    • Windows Vista、Windows Server 2008、およびこれ以降のバージョンでは、platformパラメータにdevice_id=0002を設定します。 たとえば、次のコマンドを実行します。

      xe vm-param-set uuid=<VM UUID> platform:device_id=0002

    • そのほかのバージョンのWindowsでは、platformパラメータにviridian=trueを設定します。 たとえば、次のコマンドを実行します。

      xe vm-param-set uuid=<VM UUID> platform:viridian=true


XVAからのインポート

XenCenterの［インポート］ウィザードでは、ローカルマシン上にXVA形式（拡張子.xvaのファイル）またはXVA Version 1形式（拡張子ova.xmlのファイルおよび関連ファイル）としてエクスポート済みの仮想マシン、テンプレート、およびスナップショットをインポートできます。

XVAファイルやova.xmlファイルからの仮想マシンのインポートでは、ホームサーバーを指定したりストレージやネットワークを設定したりするなど、実質的に［新規VM］ウィザードで新しい仮想マシンを作成する場合と同じ手順が必要になります。これらの手順については、「新規仮想マシンの作成」を参照してください。
重要： CPUの種類が異なる別のホストからエクスポートした仮想マシンをインポートしても、正しく実行できない場合があります。 たとえば、Intel® VTが有効なCPUが搭載されたサーバー上で作成され、エクスポートされたWindows仮想マシンは、AMD-Vが搭載されたサーバーにインポートしても、実行できない可能性があります。

手順

  1. インポートウィザードを開きます。これを行うには、以下のいずれかの操作を行います。
    • リソースペインでプールまたはホストを右クリックして、［インポート］を選択します。
    • ［ファイル］メニューの［インポート］を選択します。
  2. ウィザードの最初のページで、XVAファイル（またはova.xmlファイル）を選択して［次へ］をクリックします。 ［ファイル名］ボックスにURL（http、https、file、ftp）を入力した場合は、［次へ］をクリックすると［パッケージのダウンロード］ダイアログボックスが開きます。ここでは、ファイルのダウンロード先となるXenCenterホスト上のフォルダを指定します。
  3. ［ホームサーバー］ページでは、インポートする仮想マシンのホームサーバーを指定します。
    • ホームサーバーを指定しない場合は、一覧からインポート先のリソースプールを選択して［次へ］をクリックします。
    • リソースプールの特定のサーバーをホームサーバーとして指定する場合（またはスタンドアロンサーバー上にインポートする場合）は、サーバーを選択して［次へ］をクリックします。
  4. ［ストレージ］ページでは、インポートする仮想ディスクの格納先となるストレージリポジトリを選択して［次へ］をクリックします。
  5. ［ネットワーク］ページでは、インポートする仮想マシンの仮想ネットワークインターフェイスを、インポート先プールのネットワークに割り当てます。 このページの一覧に表示されるネットワークおよびMACアドレスは、エクスポートされた元の仮想マシンのファイル内に定義されています。 仮想ネットワークインターフェイスをターゲットネットワークに割り当てるには、［マップするネットワーク］列のドロップダウンリストでネットワークを選択します。

    ［次へ］をクリックして続行します。

  6. ［インポート］ウィザードの最後のページでは、選択した設定内容を確認できます。 インポート処理が終了して仮想マシンがプロビジョニングされた後にその仮想マシンが自動的に起動するようにするには、［インポート後にVMを起動する］チェックボックスをオンにします。
  7. ［完了］をクリックしてインポートを実行し、ウィザードを閉じます。

    インポートの進行状況は［XenCenter］ウィンドウの下部のステータスバーおよび［ログ］タブにも表示されます。

    仮想マシンの仮想ディスクのサイズ、ネットワーク帯域幅、およびXenCenterホストのディスクインターフェイスの性能によっては、インポートに時間がかかる場合があります。 新しくインポートした仮想マシンが利用できるようになると、リソースペインに表示されます。


OVF/OVAとしてのエクスポート

いくつかの仮想マシンをOVFまたはOVAパッケージとしてエクスポートするには、XenCenterの［エクスポート］ウィザードを使用します。 ただし、エクスポートする仮想マシンをシャットダウンまたは一時停止状態にしておく必要があります。

OVFおよびOVAパッケージをエクスポートするには、プール管理者の役割が必要です。 このため、［エクスポート］ウィザードを開始したときに、プール管理者の役割があるかどうかがチェックされます。 詳しくは、「役割ベースのアクセス制御（RBAC）の概要」を参照してください。

手順

  1. ［エクスポート］ウィザードを開きます。これを行うには、エクスポートする仮想マシンを含んでいるプールまたはサーバーを選択し、［VM］メニューの［エクスポート］を選択します。
  2. ウィザードの最初のページで、ファイル名およびエクスポート先を指定して、［形式］ボックスの一覧から［OVF/OVAパッケージ（*.ovf, *.ova）］を選択し、［次へ］をクリックします。
  3. エクスポートする仮想マシンを選択して、［次へ］をクリックします。
  4. ［EULA］ページでは、既存のライセンス契約書（EULA：End User Licensing Agreement）ドキュメント（RTFまたはTXTファイル）を選択して、それをパッケージに追加します。 EULAをテキストエディタで開くには、一覧でそのファイルを選択して［表示］をクリックします。 パッケージにEULAを追加しない場合は、そのまま［次へ］をクリックします。
  5. ［高度なオプション］ページでは、必要に応じてマニフェストや署名、および出力ファイルに関するオプションを選択し、［次へ］をクリックします。
    1. パッケージのマニフェストを作成するには、［マニフェストを作成する］チェックボックスをオンにします。 マニフェストとは、パッケージに含まれるすべてのファイルの一覧（インベントリ）を提供するファイルです。マニフェストを使用すると、配布するパッケージに含まれているファイルが、そのパッケージの作成時に含まれていたものと同じであることを証明できます。 ファイルのインポート時に、パッケージに含まれるファイルが改ざんされていないことを検証するためにチェックサムが使用されます。
    2. デジタル署名をパッケージを追加するには、［OVFパッケージに署名する］チェックボックスをオンにして、証明書のパスおよび秘密キーのパスワードを指定します。 デジタル署名されたパッケージをインポートするユーザーは、証明書の公開キーを使って署名を検証し、そのパッケージ作成者の同一性を確認できます。 デジタル署名を作成するには、信頼された機関から取得してPEMファイルまたはPFXファイルとしてエクスポートした既存のX.509証明書を使用します。このファイルには、マニフェストファイルのデジタル署名と、その署名を作成するときに使用した証明書が含まれています。
    3. 選択した仮想マシンをOVA形式の単一TARファイルとして出力するには、［OVAパッケージを作成する］チェックボックスをオンにします。 出力ファイルの形式について詳しくは、「Open Virtualization Format（OVFとOVA）」を参照してください。
    4. パッケージに含める仮想ハードディスクイメージ（VHDファイル）を圧縮するには、［OVFファイルを圧縮する］チェックボックスをオンにします。 アプライアンスパッケージを作成するときのデフォルトでは、仮想マシンに割り当てられているVHDイメージがそのままのサイズでエクスポートされます。 たとえば、26GBが割り当てられた仮想マシンの場合、実際に必要なディスク領域に関係なく、ハードディスクイメージも26GBになります。 VHDファイルを圧縮すると、エクスポート処理にかかる時間が長くなります。また、圧縮されたVHDファイルを含んでいるパッケージをインポートする場合も、［インポート］ウィザードですべてのVHDイメージを抽出する必要があるため、時間がかかります。
    ［OVAパッケージを作成する］チェックボックスとOVFファイルを圧縮する］チェックボックスの両方をオンにすると、圧縮されたOVAファイル（*.ova.gz）としてエクスポートされます。
  6. ［Transfer VMの設定］ページでは、エクスポート処理で使用される一時的な仮想マシン（Transfer VM）のネットワークオプションを設定します。 ［次へ］をクリックして続行します。
  7. ウィザードの最後のページで、エクスポート内容を確認します。 エクスポートしたパッケージを検証するには、［完了時にエクスポートを検証する］チェックボックスをオンにします。 ［完了］をクリックしてエクスポートを実行し、ウィザードを閉じます。

    仮想ディスクのサイズ、ネットワーク帯域幅、およびXenCenterホストのディスクインターフェイスの性能によっては、エクスポートに時間がかかる場合があります。 進行状況は［XenCenter］ウィンドウの下部のステータスバーおよび［ログ］タブに表示されます。

    進行中のエクスポートをキャンセルするには、［ログ］タブをクリックしてイベントの一覧からエクスポート処理を選択し、［キャンセル］をクリックします。


XVAとしてのエクスポート

［エクスポート］ウィザードを使用して、単一の仮想マシンをXVAファイルとしてエクスポートできます。 ただし、エクスポートする仮想マシンをシャットダウンまたは一時停止状態にしておく必要があります。
注： CPUの種類が異なる別のホストからエクスポートした仮想マシンをインポートしても、正しく実行できない場合があります。 たとえば、Intel® VTが有効なCPUが搭載されたサーバー上で作成され、エクスポートされたWindows仮想マシンは、AMD-Vが搭載されたサーバーにインポートしても、実行できない可能性があります。

手順

  1. エクスポートする仮想マシンを選択して、［VM］メニューの［エクスポート］を選択します。
  2. ウィザードの最初のページで、ファイル名およびエクスポート先を指定して、［形式］ボックスの一覧から［XVAファイル（*.xva）］を選択し、［次へ］をクリックします。
  3. ［仮想マシン］ページで、エクスポートする仮想マシンが選択されていることを確認します。 XVAファイルとしてエクスポートする場合、この一覧で選択できる仮想マシンは1つのみです。 ［次へ］をクリックして続行します。
  4. ウィザードの最後のページで、エクスポート内容を確認します。 エクスポートしたXVAファイルを検証するには、［完了時にエクスポートを検証する］チェックボックスをオンにします。 ［完了］をクリックしてエクスポートを実行し、ウィザードを閉じます。

    仮想マシンの仮想ディスクのサイズ、ネットワーク帯域幅、およびXenCenterホストのディスクインターフェイスの性能によっては、仮想マシンのエクスポートに時間がかかる場合があります。 進行状況は［XenCenter］ウィンドウの下部のステータスバーおよび［ログ］タブに表示されます。

    進行中のエクスポートをキャンセルするには、［ログ］タブをクリックしてイベントの一覧からエクスポート処理を選択し、［キャンセル］をクリックします。


仮想マシンスナップショット

トピック

  • スナップショットについて
  • 仮想マシンのスナップショットの作成
  • スナップショットへの復元
  • スナップショットから新しい仮想マシンを作成する
  • スナップショットから新しいテンプレートを作成する
  • スナップショットをファイルにエクスポートする
  • スナップショットの削除


スナップショットについて

仮想マシンのスナップショットとは、実行中の仮想マシンのある時点での状態を記録したものです。 仮想マシンのスナップショットを作成すると、そのストレージ情報（ハードドライブ上のデータ）やメタデータ（設定情報）も保存されます。 スナップショットを作成するときは、自己矛盾のないディスクイメージが保存されるように、必要に応じて一時的にデータ入出力が停止します。

仮想マシンのエクスポートとは異なり、スナップショット作成時に仮想マシンをシャットダウンさせておく必要はありません。 スナップショットは通常の仮想マシンテンプレートに類似していますが、仮想マシンのネットワーク情報を含め、すべてのストレージおよび設定情報が含まれる点が異なります。 スナップショット機能を利用して、バックアップとしてエクスポート可能なテンプレートを簡単に作成して元の状態を復元したり、新しい仮想マシンを高速に作成したりできます。

スナップショットは、すべての種類のストレージでサポートされますが、Version 5.5よりも古いバージョンのXenServerで作成したLVMベースのストレージリポジトリはアップグレードする必要があり、ボリュームがデフォルト形式でフォーマットされている必要があります。詳しくは、「ストレージリポジトリのアップグレード」を参照してください。

スナップショットの種類

XenCenterでは、ディスクのみのスナップショット、休止スナップショット、およびディスクとメモリを含んだスナップショットがサポートされています。 詳しくは、「仮想マシンのスナップショットの作成」を参照してください。

ディスクのみのスナップショット

仮想マシンの設定情報（メタデータ）とディスク（ストレージ）が保存されます。仮想マシンをバックアップする目的でエクスポートしたり復元したりできます。 この種類のスナップショットはクラッシュ整合状態であり、Linuxを含むすべての種類の仮想マシンで作成できます。

休止スナップショット

休止スナップショットでは、Windows Volume Shadow Copy Service（VSS）の機能を使用して、特定時点のアプリケーション整合スナップショットを作成できます。 VSSフレームワークにより、VSS対応のアプリケーション（Microsoft ExchangeやMicrosoft SQL Serverなど）では、スナップショット作成に備えてメモリ内のデータをディスク上に保存できます。 このため、休止スナップショットはより安全に復元できますが、スナップショット作成時のシステムパフォーマンスが影響を受ける場合があります。 また、負荷状態によってはスナップショット作成に失敗するため、複数回の試行が必要になる場合があります。

休止スナップショットのシステム要件、およびXenServerでの実装について詳しくは、『XenServer管理者ガイド』を参照してください。
重要： XenServer Toolsには、スナップショット作成時にゲストファイルシステムを停止するXenServer VSSプロバイダが含まれています。このプロバイダはデフォルトで無効になっています。 VSSプロバイダを有効にする方法については、『XenServer仮想マシンユーザーガイド』を参照してください。

ディスクおよびメモリのスナップショット

仮想マシンのメタデータおよびディスク（ストレージ）に加えて、仮想マシンのメモリ（RAM）の状態が保存されます。 この種類のスナップショットへの復元時に仮想マシンを再起動する必要はありません。また、このスナップショットは、実行中または一時停止中の仮想マシンで作成できます。 ディスクおよびメモリのスナップショットは、ソフトウェアのアップグレードやパッチの適用時、または新しいアプリケーションをテストするときに、現在の仮想マシンの状態に戻れるようにしたい場合に便利です。

孤立したスナップショットへのアクセス

仮想マシンのスナップショットを作成し、その後でその仮想マシンを削除しても、スナップショットが使用不能になることはありません。リソースペインをフォルダビューにすると、［種類］ノードの［スナップショット］に孤立したものを含むすべてのスナップショットが表示されます。


仮想マシンのスナップショットの作成

  • リソースペインで仮想マシンを選択して、［スナップショット］タブをクリックします。
  • ［スナップショットの作成］をクリックします。 または、次のいずれかを行います。
    • リソースペインで右クリックして、［スナップショットの作成］を選択します。
    • ［VM］メニューの［スナップショットの作成］を選択します。
  • 新しいスナップショットの名前と、任意で説明を入力します。
  • ［スナップショットモード］で、作成するスナップショットの種類を選択します。
    • ディスクのみのスナップショットを作成するには、［仮想マシンのディスクのスナップショット］をクリックします。

    • 休止スナップショットを作成するには、［仮想マシンのディスクのスナップショット］をクリックし、［VMを休止してからスナップショットを作成する］チェックボックスをオンにします。

    • ディスクとメモリのスナップショットを作成するには、［仮想マシンのディスクとメモリのスナップショット］をクリックします。
  • ［スナップショットの作成］をクリックします。 進行状況はXenCenter下部のステータスバーおよび［ログ］タブに表示されます。

    作成されたスナップショットは、その仮想マシンの［スナップショット］タブ、またはフォルダビューでは［スナップショット］ノードに表示されます。

    • ディスクのみのスナップショット

    • ディスクとメモリのスナップショット


スナップショットへの復元

スナップショットへの復元機能を使用すると、スナップショットを作成したときの状態に仮想マシンを戻すことができます。 スナップショット作成後にその仮想マシンに加えられた変更内容は破棄され、その仮想マシンの現在の状態は失われます。

［スナップショットへの復元］ダイアログボックスには、スナップショットを復元する前に、仮想マシンの現在の状態を別のスナップショットとして保存するためのオプションが表示されます。これにより、スナップショットを復元した後でも、復元前の状態の仮想マシンを簡単に再作成できます。

  1. ［スナップショット］タブでスナップショットを選択して、［復元］をクリックします。

    スケジュールにより作成されたスナップショット（仮想マシンの保護と回復機能により自動的に作成されたスナップショット）に復元する場合は、それらのスナップショットが［スナップショット］に表示されるようにしてから選択する必要があります。これを行うには、［表示］をクリックして［スケジュールによるスナップショット］を選択します。

  2. 仮想マシンの現在の状態を別のスナップショットとして保存するには、［現在のスナップショットを作成してから復元する］チェックボックスをオンにします。
  3. ［はい］をクリックします。


スナップショットから新しい仮想マシンを作成する

スナップショットからの仮想マシン作成とテンプレートからの仮想マシン作成は、まったく同じ処理です。どちらの場合も［新規VM］ウィザードを使用します。

スナップショットから新しい仮想マシンを作成するには

  1. ［スナップショット］タブでスナップショットを右クリックして、［スナップショットから新規VMを作成］を選択します。

    ［新規VM］ウィザードが開き、選択したスナップショットが［テンプレート］ページに表示されます。

  2. ［新規VM］ウィザードの手順に従って、新しい仮想マシンを作成します。 詳しくは、「新規仮想マシンの作成」を参照してください。

孤立したスナップショットから新しい仮想マシンを作成するには

スナップショット作成元の仮想マシンが削除されている場合は、以下の手順で［新規VM］ウィザードを開始できます。

  1. リソースペインをフォルダビューに切り替えます。
  2. ［種類］ノードの［スナップショット］を開きます。
  3. 目的のスナップショットを右クリックして、［スナップショットから新規VMを作成］を選択します。


スナップショットから新しいテンプレートを作成する

仮想マシンのスナップショットを直接コピーすることはできませんが、スナップショットから新しいテンプレートを作成して、それを使ってスナップショットのコピーを作成できます。 テンプレートは、仮想マシンの複製元（マスタコピー）として使用される通常の仮想マシンです。 仮想マシンをセットアップして必要に応じて構成を変更し、スナップショットを作成します。次に、そのスナップショットをテンプレートとして保存して、そのテンプレートから同一リソースプール内に同じ構成の仮想マシンを作成できます。 この場合、スナップショットのメモリの状態は保存されないので注意してください。

スナップショットを新しいテンプレートとして保存するには

  1. ［スナップショット］タブでスナップショットを選択し、右クリックして［スナップショットからテンプレートを作成］を選択します。
  2. 新しいテンプレートの名前を入力して、［OK］をクリックします。 作成されたテンプレートは、リソースペイン（および［新規VM］ウィザードの［テンプレート］ページ）にカスタムテンプレートとして表示されます。

孤立したスナップショットを新しいテンプレートとして保存するには

作成元の仮想マシンが削除されているスナップショットは、以下の手順でテンプレートとしてエクスポートできます。

  1. リソースペインをフォルダビューに切り替えます。
  2. ［種類］ノードの［スナップショット］を開きます。
  3. 目的のスナップショットを右クリックして、［スナップショットからテンプレートを作成］を選択します。


スナップショットをファイルにエクスポートする

仮想マシンのスナップショットをエクスポートすると、単一のXVAファイルの仮想マシンテンプレートとしてローカルコンピュータ上に保存されます。 このテンプレートには、ディスクイメージを含むスナップショットの完全なコピーが含まれます。ほかのリソースプールでこのテンプレートをインポートして、新しい仮想マシンを作成することができます。

スナップショットをファイルにエクスポートするには

  1. ［スナップショット］タブでスナップショットを選択して、［操作］をクリックして［ファイルにエクスポート］を選択します。
  2. XVAファイルを作成するフォルダを参照してファイル名を入力し、［保存］をクリックしてエクスポートを開始します。

孤立したスナップショットをエクスポートするには

スナップショット作成元の仮想マシンが削除されている場合は、以下の手順でスナップショットをエクスポートできます。

  1. リソースペインをフォルダビューに切り替えます。
  2. ［種類］ノードの［スナップショット］を開きます。
  3. 目的のスナップショットを右クリックして、［スナップショットをテンプレートとしてエクスポート］を選択します。
  4. XVAファイルを作成するフォルダを参照してファイル名を入力し、［保存］をクリックしてエクスポートを開始します。


スナップショットの削除

スナップショットを削除するには

  1. ［スナップショット］タブでスナップショットを選択して、［削除］をクリックします。
  2. ［OK］をクリックして確定します。

孤立したスナップショットを削除するには

スナップショット作成元の仮想マシンが削除されている場合は、以下の手順でスナップショットを削除できます。

  1. リソースペインをフォルダビューに切り替えます。
  2. ［種類］ノードの［スナップショット］を開きます。
  3. 目的のスナップショットを右クリックして、［スナップショットの削除］を選択します。


XenServer vApp

トピック

  • vAppの管理
  • vAppの作成
  • vAppの変更
  • vAppの削除
  • vAppの起動とシャットダウン
  • vAppのエクスポートとインポート


vAppの管理

XenServerのvAppは、関連する複数の仮想マシンを単一の管理対象として論理的にグループ化したものです。 vAppに含まれる仮想マシンは同一サーバー上で動作する必要はなく、通常の規則に従ってリソースプール内で移行されます。

vAppの起動時に、そのvAppに含まれる各仮想マシンが特定の順序に基づいて起動します。このため、ほかの仮想マシンに依存する仮想マシンが常に後から起動するように設定できます。 つまり、ソフトウェアのアップデート時など、システム全体の再起動が必要な場合に、管理者が依存関係を考慮しながら順番に仮想マシンを起動する必要はありません。

［vAppの管理］ダイアログボックスの使用

XenCenterの［vAppの管理］ダイアログボックスでは、リソースプール内で定義されているvAppを表示して、それらを変更、起動、停止、およびエクスポートしたり、新しいvAppを作成したりできます。 一覧でvAppを選択すると、そのvAppに含まれているすべての仮想マシンがダイアログボックス右側に表示されます。
コントロール | 機能
新規vApp | ［新規vApp］ウィザードを開きます。 詳しくは、「vAppの作成」を参照してください。
削除 | 選択したvAppを削除します。 vAppを削除しても、そのvAppに追加されている仮想マシンは削除されません。
プロパティ | 選択したvAppの［プロパティ］ダイアログボックスを開きます。 このダイアログボックスでは、vAppの名前や説明を変更したり、仮想マシンを追加または削除したり、仮想マシンの起動順序および起動間隔を変更したりできます。 詳しくは、「vAppの変更」を参照してください。
起動 | 選択したvAppのすべての仮想マシンを起動します。このとき、各仮想マシンに設定されている起動順序および起動間隔が適用されます。 詳しくは、「vAppの起動とシャットダウン」を参照してください。
シャットダウン | 選択したvAppのすべての仮想マシンをシャットダウンします。 詳しくは、「vAppの起動とシャットダウン」を参照してください。
インポート | ［インポート］ウィザードを開いて、OVF/OVAパッケージをvAppとしてインポートします。 詳しくは、「vAppのエクスポートとインポート」を参照してください。
エクスポート | ［エクスポート］ウィザードを開いて、選択したvAppをOVF/OVAパッケージとしてエクスポートします。 詳しくは、「vAppのエクスポートとインポート」を参照してください。


vAppの作成

新しいvAppを作成するには、［vAppの管理］ダイアログボックスを使用します。

  1. リソースペインでプールを選択して、［プール］メニューの［vAppの管理］を選択します。

    また、リソースペインでプールを右クリックして、［vAppの管理］を選択することもできます。

  2. ［vAppの管理］ダイアログボックス上部の［新規vApp］をクリックします。
  3. 新しいvAppの名前と、任意で説明を入力し、［次へ］をクリックします。 vAppの内容を示す名前を指定すると便利です。 複数のvAppに同じ名前を使用することも可能ですが、重複しないわかりやすい名前を指定することをお勧めします。 また、スペースを含む名前を引用符で囲む必要はありません。
  4. 新しいvAppに追加する仮想マシンを選択して、［次へ］をクリックします。 ［検索］ボックスを使用して、名前に特定の文字列が含まれる仮想マシンだけを一覧に表示することもできます。
  5. vAppに追加した仮想マシンの起動シーケンスを指定して、［次へ］をクリックします。
    値 | 説明
    起動順序 | vAppに追加した仮想マシンの起動順序を指定します。 起動順序として0を指定すると、その仮想マシンが最初に起動します。次に1を指定した仮想マシンが起動し、2、3と続きます。
    次のVM起動までの間隔 | 起動順序の値でグループ化される仮想マシンの起動間隔を指定します。たとえば、15秒を設定した場合、起動順序0の仮想マシンが起動した後、15秒後に起動順序1の仮想マシンが起動します。

    仮想マシンのシャットダウン順序は、起動順序とは逆になります。

  6. ウィザードの最後のページでvAppの設定内容を確認できます。 前のページに戻って設定を変更するには［前へ］をクリックします。［完了］をクリックすると、vAppが作成され、ウィザードが閉じます。


vAppの変更

vAppの名前や説明を変更したり、仮想マシンを追加または削除したり、仮想マシンの起動順序および起動間隔を変更したりするには、［vAppの管理］ダイアログボックスを使用します。

  1. リソースペインでプールを選択して、［プール］メニューの［vAppの管理］を選択します。

    また、リソースペインでプールを右クリックして、［vAppの管理］を選択することもできます。

  2. 一覧でvAppを選択し、［ [image] プロパティ］をクリックして［プロパティ］ダイアログボックスを開きます。
  3. ［全般］ページでは、vAppの名前および説明を変更します。
  4. ［仮想マシン］ページでは、vAppの仮想マシンを追加したり削除したりします。
  5. ［VM起動シーケンス］ページでは、vAppの各仮想マシンに設定されている起動順序および起動間隔を変更します。

    コントロール

            説明
    起動順序 | vAppに追加した仮想マシンの起動順序を指定します。 起動順序として0を指定すると、その仮想マシンが最初に起動します。次に1を指定した仮想マシンが起動し、2、3と続きます。
    次のVM起動までの間隔 | 起動順序の値でグループ化される仮想マシンの起動間隔を指定します。たとえば、15秒を設定した場合、起動順序0の仮想マシンが起動した後、15秒後に起動順序1の仮想マシンが起動します。

    仮想マシンのシャットダウン順序は、起動順序とは逆になります。

  6. ［OK］をクリックして変更を保存し、［プロパティ］ダイアログボックスを閉じます。


vAppの削除

vAppをリソースプールから削除するには、［vAppの管理］ダイアログボックスを使用します。

  1. リソースペインでプールを選択して、［プール］メニューの［vAppの管理］を選択します。

    また、リソースペインでプールを右クリックして、［vAppの管理］を選択することもできます。

  2. 削除するvAppを選択して、［ [image] 削除］をクリックします。

    vAppを削除しても、そのvAppに追加されている仮想マシンは削除されません。


vAppの起動とシャットダウン

vAppを起動したりシャットダウンしたりするには、［プール］メニューから開く［vAppの管理］ダイアログボックスを使用します。

vAppを起動すると、そのvAppに含まれているすべての仮想マシンが特定の順番で起動します。 このとき、各仮想マシンに設定されている起動順序および起動間隔が適用されます。これらの値は、vAppを作成するときに設定できます。また、vAppの［プロパティ］ダイアログボックスや、個々の仮想マシンの［プロパティ］ダイアログボックスで設定できます。

仮想マシンのシャットダウン順序は、起動順序とは逆になります。

vAppを起動するには

  1. ［vAppの管理］ダイアログボックスを開きます。これを行うには、リソースペインでプールを選択して、［プール］メニューの［vAppの管理］を選択します。

    また、リソースペインでプールを右クリックして、［vAppの管理］を選択することもできます。

  2. 一覧でvAppを選択し、［ [image] 起動］をクリックします。これにより、そのvAppに含まれているすべての仮想マシンが起動します。

vAppをシャットダウンするには

  1. ［vAppの管理］ダイアログボックスを開きます。これを行うには、リソースペインでプールを選択して、［プール］メニューの［vAppの管理］を選択します。

    また、リソースペインでプールを右クリックして、［vAppの管理］を選択することもできます。

  2. 一覧でvAppを選択し、［ [image] シャットダウン］をクリックします。これにより、そのvAppに含まれているすべての仮想マシンがシャットダウンします。 この場合、まずソフトシャットダウンが試行され、これが不可能な場合は強制シャットダウンが実行されます。 仮想マシンのソフトシャットダウンおよび強制シャットダウンについては、「仮想マシンのシャットダウン」を参照してください。


vAppのエクスポートとインポート

vAppをエクスポートするには

XenCenterでは、vAppをOVF/OVAパッケージとしてエクスポートできます。

  1. ［vAppの管理］ダイアログボックスを開きます。これを行うには、リソースペインでプールを選択して、［プール］メニューの［vAppの管理］を選択します。
  2. エクスポートするvAppを選択して、［ [image] エクスポート］をクリックします。
  3. 「OVF/OVAとしてのエクスポート」の手順に従って操作します。

    vAppのエクスポート処理には時間がかかる場合があります。

vAppをインポートするには

XenCenterでは、OVF/OVAパッケージをvAppとしてインポートできます。

  1. ［vAppの管理］ダイアログボックスを開きます。これを行うには、リソースペインでプールを選択して、［プール］メニューの［vAppの管理］を選択します。
  2. ［ [image] インポート］をクリックして［インポート］ウィザードを開きます。
  3. 「OVF/OVAからのインポート」の手順に従って操作します。

    インポートが完了すると、［vAppの管理］ダイアログボックスの一覧に新しいvAppが追加されます。


仮想マシンとvAppの保護

XenServerには、仮想マシンやvAppを保護するためにいくつかの機能が用意されています。

仮想マシンの保護と回復（VMPR） – スナップショットのスケジュール設定

XenServerの仮想マシンの保護と回復（VMPR：VM Protection and Recovery）機能では、仮想マシンのスナップショットが定期的に作成されるように設定できます。仮想マシンに問題が生じた場合は、作成されたスナップショットをXenCenterにインポートして、その仮想マシンを再作成できます。

詳しくは、「仮想マシンの保護と回復について」、「仮想マシン保護ポリシーの作成」、「仮想マシン保護ポリシーの管理」、および「スナップショットからの仮想マシンの回復」を参照してください。

重要： 仮想マシンの保護と回復機能（VMPR）は、XenServer Version 6.2およびこれ以降のバージョンでは削除されています。 VMPRの機能を使用するアプリケーションやコードなどは、XenServer Version 6.2およびこれ以降のバージョンでは使用できません。 ただし、仮想マシンのスナップショット機能やこれに依存するVMPR以外の機能は削除されていません。 詳しくは、CTX137335を参照してください。

高可用性（HA）

XenServerの高可用性（HA：High Availability）機能では、プール内の個々のサーバーに障害が発生した場合に、そのサーバー上の仮想マシンが同一プール内のほかのサーバー上で自動的に再起動されるように設定できます。これにより、サービスの中断を最小限に抑えながら重要なサービスを復元できます。 この機能では、プールのデータベースが常にすべてのノード間で複製され、さらにハートビートストレージリポジトリ上の共有ストレージにバックアップされます。

詳しくは、「XenServerの高可用性について」、「高可用性の要件」、「仮想マシンの再起動設定」、「高可用性の設定」、「高可用性の無効化」、および「高可用性設定の変更」を参照してください。

障害回復（DR）

XenServerの障害回復（DR：Disaster Recovery）機能では、プライマリサイトでの複数サーバーの障害から仮想マシンを保護できます。 この機能を有効にすると、プールのデータベースがストレージのミラー化により常に複製されます。プライマリサイトに障害が発生すると、ミラー化されたストレージから仮想マシンやvAppがセカンダリ（障害回復）サイトのプールに復元されます。

詳しくは、「XenServerの障害回復について」、「障害回復の設定」、「フェイルオーバー」、「フェイルバック」、および「フェイルオーバーテスト」を参照してください。


仮想マシンの保護と回復（VMPR）

重要： 仮想マシンの保護と回復機能（VMPR）は、XenServer Version 6.2およびこれ以降のバージョンでは削除されています。 VMPRの機能を使用するアプリケーションやコードなどは、XenServer Version 6.2およびこれ以降のバージョンでは使用できません。 ただし、仮想マシンのスナップショット機能やこれに依存するVMPR以外の機能は削除されていません。 詳しくは、CTX137335を参照してください。

トピック：

  • 仮想マシンの保護と回復について
  • 仮想マシン保護ポリシーの作成
  • 仮想マシン保護ポリシーの管理
  • スナップショットからの仮想マシンの回復


仮想マシンの保護と回復について

重要： 仮想マシンの保護と回復機能（VMPR）は、XenServer Version 6.2およびこれ以降のバージョンでは削除されています。 VMPRの機能を使用するアプリケーションやコードなどは、XenServer Version 6.2およびこれ以降のバージョンでは使用できません。 ただし、仮想マシンのスナップショット機能やこれに依存するVMPR以外の機能は削除されていません。 詳しくは、CTX137335を参照してください。

XenServerの仮想マシンの保護と回復（VMPR：VM Protection and Recovery）機能では、重要なサービスを提供する仮想マシンを保護するためのシンプルな手段が提供されます。 この機能では、定期的にスナップショットが自動作成されるように設定できます。これらのスナップショットを使用して、仮想マシンを回復（復元）することができます。

仮想マシンの保護と回復機能では、リソースプールレベルで保護ポリシーを作成し、特定の仮想マシンのスナップショット作成のスケジュールを定義します。 このポリシーを有効にすると、指定した時刻、曜日、または週に仮想マシンのスナップショットが作成されます。 また、作成されるスナップショットが、リモートのCIFSまたはNFS共有に自動的にアーカイブされるように設定することもできます。

仮想マシンの用途に応じていくつかの保護ポリシーを作成して、異なるスケジュールを定義できます。 1つの仮想マシンに同時に複数の保護ポリシーを割り当てることはできません。

XenCenterには、仮想マシンの保護と回復機能を使用するためのいくつかのツールが用意されています。

  • VMPRポリシーを作成するには、［新規VM保護ポリシー］ウィザードを使用します。
  • リソースプールのVMPRポリシーを有効/無効化、変更、および削除するには、［VM保護ポリシー］ダイアログボックスを使用します。
  • 保護ポリシーを変更するには、［VM保護ポリシー］ダイアログボックスから［プロパティ］ダイアログボックスを開きます。
  • 作成済みのスナップショットから仮想マシンを回復するには、［スナップショット］タブでそのスナップショットを選択し、スナップショットへの復元を行います。
  • アーカイブ済みのスナップショットから仮想マシンを回復するには、そのスナップショットをインポートし、カスタムの仮想マシンテンプレートを作成して、そのテンプレートから仮想マシンを作成します。


仮想マシン保護ポリシーの作成

重要： 仮想マシンの保護と回復機能（VMPR）は、XenServer Version 6.2およびこれ以降のバージョンでは削除されています。 VMPRの機能を使用するアプリケーションやコードなどは、XenServer Version 6.2およびこれ以降のバージョンでは使用できません。 ただし、仮想マシンのスナップショット機能やこれに依存するVMPR以外の機能は削除されていません。 詳しくは、CTX137335を参照してください。

［新規VM保護ポリシー］ウィザードでは、リソースプール内の仮想マシンを選択して、作成するスナップショットの種類（ディスクのみまたはディスクとメモリ）、およびスナップショットやアーカイブのスケジュールを指定します。 また、スナップショットやアーカイブイベントが発生したときのメール通知を設定することもできます。

［プール］メニューの［VM保護ポリシー］を選択して［VM保護ポリシー］ダイアログボックスを開き、［新規］をクリックします。

保護する仮想マシンの選択

ウィザードのこのページには、リソースプール内のすべての仮想マシンが表示されます。 既に保護ポリシーが割り当てられている仮想マシンに新しい保護ポリシーを割り当てようとすると、確認のためのメッセージが表示されます。 1つの仮想マシンに同時に複数の保護ポリシーを割り当てることはできません。このため、この仮想マシンに新しい保護ポリシーを割り当てると、既存の保護ポリシーの割り当てが解除されます。

スナップショットの種類の選択

このページでは、作成するスナップショットの種類（ディスクのみまたはディスクとメモリ）を選択します。

  • ディスクのみのスナップショット：仮想マシンのディスク（ストレージ）およびメタデータが保存されます。 このスナップショットはクラッシュ整合状態であり、Linux仮想マシンを含むすべての種類の仮想マシンで作成できます。
  • ディスクおよびメモリのスナップショット：仮想マシンのディスク（ストレージ）およびメタデータに加えて、仮想マシンのメモリ（RAM）が保存されます。 この種類のスナップショットのサイズは、非常に大きくなることがあります。

スナップショットのスケジュールと保持数の設定

スナップショットスケジュール

  • 毎時間作成する：毎時間の指定した時刻にスナップショットが作成されます。
  • 毎日作成する：毎日の指定した時刻にスナップショットが作成されます。
  • 毎週作成する：毎週の指定した曜日および時刻にスナップショットが作成されます。 複数の曜日を指定することもできます。

保持するスナップショット数

［保持するスナップショット数］では、上記のスケジュールで作成したスナップショットをいくつ保持するかを指定します。 ここで指定する最大数をスナップショットの数が超えると、古いものから自動的に削除されます。

注： ［保持するスナップショットの最大数］には、10までの値を設定できます。

アーカイブスケジュールの設定

このページでは、作成されたスナップショットがリモートのCIFSまたはNFS共有に自動的にアーカイブされるように設定します。 スナップショットスケジュールとは別に、毎日または毎週のアーカイブスケジュールを設定できます。また、スナップショットが作成されるたびにアーカイブすることもできます（［毎回アーカイブする］オプション）。 ただし、スナップショットのスケジュールよりも頻繁なアーカイブを設定することはできません。

アーカイブの命名規則

アーカイブフォルダ名には、仮想マシン名とそのUUIDの最初の16文字が使用されます。 たとえば、次のようになります。

仮想マシン名 | 仮想マシンのUUID | アーカイブフォルダ名
Win7_Test_1 | cb53200c-bbd8-4c12-a076-e2eb29b38f06 | Win7_Test_1-cb53200c-bbd8-4c

アーカイブフォルダに保存されるスナップショットには、「YYYYMMDD-HHMM.xva」形式のファイル名が使用されます。 たとえば、次のようになります。

20100624-1830.xva、20100624-1836.xva、20100625-0031.xvaなど

アラートメールの設定

このページでは、スケジュールによるスナップショットやアーカイブに関するシステムアラートが生成された場合に、通知メールが送信されるように設定します。 デフォルトでは、VMPRジョブの通知メールは無効になっています。


仮想マシン保護ポリシーの管理

重要： 仮想マシンの保護と回復機能（VMPR）は、XenServer Version 6.2およびこれ以降のバージョンでは削除されています。 VMPRの機能を使用するアプリケーションやコードなどは、XenServer Version 6.2およびこれ以降のバージョンでは使用できません。 ただし、仮想マシンのスナップショット機能やこれに依存するVMPR以外の機能は削除されていません。 詳しくは、CTX137335を参照してください。

リソースプールの仮想マシン保護ポリシーを有効/無効化、変更、および削除するには、［VM保護ポリシー］ダイアログボックスを使用します。このダイアログボックスを開くには、［プール］メニューの［VM保護ポリシー］を選択します。

仮想マシン保護ポリシーの有効化

仮想マシン保護ポリシーを有効にすると、そのポリシーに関連付けられた仮想マシンのスナップショットが指定されたスケジュールに基づいて作成され、アーカイブされます。 これらの処理は、そのポリシーを無効にするまで継続されます。

ポリシーを有効にするには

  1. リソースペインでリソースプール、またはプール内のサーバーや仮想マシンを選択して、［プール］メニューの［VM保護ポリシー］を選択します。
  2. 既存のポリシーを選択して、［有効化］をクリックします。

仮想マシン保護ポリシーの無効化

スケジュールによるスナップショット作成を停止するには、［VM保護ポリシー］ダイアログボックスでその仮想マシン保護ポリシーを無効にします。無効にしたポリシーは、必要に応じていつでも有効にできます。

ポリシーを無効にするには

  1. リソースペインでリソースプール、またはプール内のサーバーや仮想マシンを選択して、［プール］メニューの［VM保護ポリシー］を選択します。
  2. 既存のポリシーを選択して、［無効化］をクリックします。

仮想マシン保護ポリシーの変更

既存のVMPRポリシーを編集して、たとえば保護する仮想マシンを追加したり、スナップショットスケジュールを変更したりできます。

  1. リソースペインでリソースプール、またはプール内のサーバーや仮想マシンを選択して、［プール］メニューの［VM保護ポリシー］を選択します。
  2. 既存のポリシーを選択して、［プロパティ］をクリックします。［プロパティ］ダイアログボックスが開き、以下のページが表示されます。
    ページ | 内容
    保護するVM | 保護する仮想マシンを追加または削除します。 1つの仮想マシンに同時に複数の保護ポリシーを割り当てることはできません。このため、追加する仮想マシンにほかの保護ポリシーが割り当てられている場合、その割り当てが解除されます。
    スナップショットの種類 | 作成するスナップショットの種類を変更します。
    スケジュール | スナップショットの作成スケジュールおよび保持するスナップショット数を変更します。
    アーカイブオプション | スナップショットの自動アーカイブ機能を無効にしたり、スケジュールを変更したりします。
    アラートメール | スケジュールによるスナップショットやアーカイブに関するシステムアラートが生成された場合の通知メールの設定を変更します。
  3. ［OK］をクリックして変更を保存し、［プロパティ］ダイアログボックスを閉じます。

仮想マシン保護ポリシーの削除

仮想マシン保護ポリシーを削除するには、以下の手順に従います。

  1. リソースペインでリソースプール、またはプール内のサーバーや仮想マシンを選択して、［プール］メニューの［VM保護ポリシー］を選択します。
  2. 既存のポリシーを選択して、［削除］をクリックします。


スナップショットからの仮想マシンの回復

スナップショットから仮想マシンを回復するには

重要： 仮想マシンの保護と回復機能（VMPR）は、XenServer Version 6.2およびこれ以降のバージョンでは削除されています。 VMPRの機能を使用するアプリケーションやコードなどは、XenServer Version 6.2およびこれ以降のバージョンでは使用できません。 ただし、仮想マシンのスナップショット機能やこれに依存するVMPR以外の機能は削除されていません。 詳しくは、CTX137335を参照してください。

スケジュールで自動作成したスナップショットを使って仮想マシンを回復するには、スナップショットへの復元を行います。

  1. 仮想マシンを選択し、［スナップショット］タブをクリックします。
  2. デフォルトでは、スケジュールによるスナップショットが表示されません。これらが表示されるように設定するには、［表示］をクリックして［スケジュールによるスナップショット］を選択します。
  3. 復元するスナップショットを選択して、［復元］をクリックします。
  4. 仮想マシンの現在の状態を別のスナップショットとして保存するには、［現在のスナップショットを作成してから復元する］チェックボックスをオンにします。
  5. ［はい］をクリックします。選択したスナップショットの状態に仮想マシンが復元されます。

アーカイブされたスナップショットから仮想マシンを回復するには

アーカイブされたスナップショットを使って仮想マシンを回復するには、以下の手順に従います。

  1. アーカイブされたスナップショットを格納しているCIFSまたはNFS共有をローカルにマウントします。
  2. ［インポート］ウィザードを使用して、拡張子.xvaのファイルとしてアーカイブされているスナップショットをインポートします。詳しくは、「XVAからのインポート」を参照してください。 これにより、カスタムの仮想マシンテンプレートが作成されます。
  3. ［新規VM］ウィザードを使用して、作成された仮想マシンテンプレートから仮想マシンを作成します。詳しくは、「新規仮想マシンの作成」を参照してください。

    アーカイブ先のフォルダおよびファイルの名前について詳しくは、「アーカイブの命名規則」を参照してください。


高可用性

トピック：

  • XenServerの高可用性について
  • 高可用性の要件
  • 仮想マシンの再起動設定
  • 高可用性の設定
  • 高可用性の無効化
  • 高可用性設定の変更


XenServerの高可用性について

高可用性（HA：High Availability）により、リソースプール内のハードウェアや個々のサーバーに障害が発生した場合に、仮想マシンが自動的に再起動します。 この機能は、重要な仮想マシンがリソースプール内で常に動作することを保証するためのものです。 サーバーに障害が発生した場合、そのサーバー上の仮想マシンは、同じリソースプール内のほかのサーバー上で自動的に再起動します。これにより、システムやコンポーネントの障害発生時に、サービスの中断を最小限に抑えながら重要なサービスを復元できます。 プールマスタに障害が発生すると、別のサーバーがプールマスタとして動作を開始するため、管理者は引き続きそのプールを管理できます。 プール内のすべてのサーバーに、プールマスタとして選出される可能性があります。また、プールのデータベースは常にすべてのノード間で複製され、さらにハートビートストレージリポジトリ上にバックアップされます。

XenServerの高可用性には、以下で説明するように、サーバー障害を正確に検出するための機能と、フェイルオーバープランを計算するための機能があります。

可用性のためのハートビート

サーバーの障害を確実に検出することは、サーバーの一時的な消失と壊滅的な障害とをリモートから区別しなければならないため、非常に困難です。 プールマスタの障害を過って検出してほかのサーバーをプールマスタとして選出してしまうと、元のプールマスタが復帰したときに予期できない問題が発生する可能性があります。 また、ネットワークの問題によりリソースプールが2つに分割された場合に、どちらか一方だけが共有ストレージにアクセスするようにして、両方が同時にアクセスしないようにしなければなりません。 これらの問題を解決するために、XenServerにはストレージハートビートとネットワークハートビートの2つのメカニズムが組み込まれています。

リソースプールの高可用性を有効にするときに、iSCSI、ファイバチャネル、またはNFSのストレージリポジトリをハートビートストレージリポジトリとして指定します。 このストレージリポジトリ上には、いくつかの小さな仮想ディスクが作成されます。 これらの仮想ディスクの最初のディスクは、リソースプール内のすべてのサーバーにより、共有クォーラムディスクとして使用されます。 各サーバーは、この共有ディスク内の固有のブロックに割り当てられて、そこに定期的に書き込みを行います。これにより、そのサーバーが動作中であることが確認されます。 高可用性が開始されると、すべてのサーバーがネットワークチャネルおよびストレージチャネルを使ってデータを交換し、各サーバーが相互に両方のチャネルでアクセス可能であることが確認されます。この通信に問題が検出される場合は、どの入出力パスが動作していないかが示されます。 このデータ交換は特定の時間が経過して、プール内のすべてのサーバーで相互通信に問題がないことが確認されるまで継続されます。 データ交換が終了すると、高可用性が有効になり、プールが保護されます。 この準備処理は、大規模なリソースプールで数分かかることがありますが、高可用性を最初に有効にするときにのみ実行されます。

高可用性が有効になると、各サーバーは定期的にストレージ更新情報をハートビート仮想ディスクに書き込み、管理インターフェイスにネットワークパケットを送信します。 耐障害性を向上させるため、ネットワークアダプタをボンディングしたり、ストレージインターフェイスで動的マルチパスを使用したりすることはとても重要です。 これにより、単一アダプタの障害や書き込みの失敗が結果として可用性の問題になることを避けることができます。

サーバーの隔離

高可用性にとって最悪のシナリオは、オフラインとして認識されたサーバーが共有ストレージへの書き込みを続けることです。これにより、永続的なデータが破損することがあります。 これを避けるため、XenServerはそのサーバーを隔離します。つまり、そのサーバーは自動的にシャットダウンし、プール内のすべての共有リソースへのアクセスが停止します。 障害が発生したサーバーを隔離することで、仮想マシンをプール内のほかのサーバー上に移行している間に、そのサーバーが共有ディスクに書き込んだり、格納されているデータの一貫性を損なったりすることが回避されます。

ハートビートの問題が検出されると、サーバーが自動的に隔離（つまりシャットダウン後に再起動）されます。ただし、以下のいずれかが当てはまる場合、サーバーは隔離されません。

  • すべてのサーバーでストレージハートビートは正しく動作していますが、ネットワークが分割された場合（つまりプール内に2つのサーバーグループが存在する）。 この場合、規模が小さい方のグループのサーバーだけが隔離され、大きい方のグループのサーバーは継続して動作します。 これは、ネットワーク障害により仮想マシンが到達不能になったという想定の下で、ネットワークが機能しているサーバー上でその仮想マシンが再起動されるようにするためです。 分割されたサーバーグループの規模が同じ場合は、いずれか一方のグループだけが隔離されます。
  • ストレージハートビートに問題が生じ、ネットワークハートビートに問題がない場合。この場合、各サーバーがネットワーク経由でほかのすべてのサーバーにアクセスできるかどうかを確認します。 この状況が続く場合、ストレージハートビートサーバーがオフラインになったという想定の下で、各サーバーは動作を続けます。 これにより仮想マシンの安全性が損なわれることはありませんが、ネットワーク障害の場合は両方のハートビートが消失するため、サーバーの隔離が発生します。

リソースプールの能力の評価

ハートビートによる信頼性の高いサーバー障害検出の次は、リソースプールの能力評価について説明します。

搭載されているメモリの量や実行中の仮想マシンの数が異なる複数のサーバーで構成されるリソースプールで、 単一のサーバー障害によりそのサーバー上の仮想マシンをほかのサーバー上で再起動できないという状況にならないように、XenServerの高可用性機能ではフェイルオーバープランが動的に計算されます。このプランにより、サーバー障害が発生した場合にどのようなアクションを実行するかが決定されます。 この機能では、単一サーバーの障害だけでなく、ネットワークの問題などによりプールの複数のサーバーが到達不能になった場合も対処できます。

フェイルオーバープランでは、障害発生時に実行すべきアクションの決定に加えて、プール内でフェイルオーバーできるサーバー障害数が考慮されます。 フェイルオーバープランの計算には、以下の2つの項目が考慮されます。

  • 最大許容障害数： 保護対象のすべての仮想マシンに必要なリソースを維持したまま許容される最大サーバー障害数で、XenServerにより算出されます。このとき、プール内の仮想マシンの再起動優先度、およびプール構成（サーバー数およびCPUやメモリの条件）が考慮されます。
  • サーバー障害の制限： そのプールで許可するサーバー障害数で、高可用性の設定時に管理者が設定します。 たとえば、許可するサーバー障害の数として3を設定すると、そのリソースプール内の任意の3台のサーバー障害までは保護され、そのサーバー上の仮想マシンをほかのサーバー上で再起動するというフェイルオーバープランが計算されます。 管理者は、そのプールで許可するサーバー障害数として、XenServerにより算出される最大許容障害数よりも小さい値を設定します。これにより、プールがオーバーコミット状態になることを回避できます。 役割ベースのアクセス制御（RBAC）が有効な環境では、サーバー障害の制限の設定により、特定の管理者が起動できる仮想マシンの数を制御できます。これにより、プールオペレータとしての権限を持たない管理者でも、フェイルオーバープランに影響しない範囲で仮想マシンを起動できるようになります。詳しくは、下記「高可用性と役割ベースのアクセス制御（RBAC）」を参照してください。

XenServerにより算出される最大許容障害数が、管理者により設定されたサーバー障害の制限よりも小さくなると、システムアラートが生成されます。

オーバーコミット保護

プールの高可用性を有効にすると、その時のリソースに基づいてフェイルオーバープランが計算されます。 新しい仮想マシンの起動など、プールに変化が生じると、新しいフェイルオーバープランが動的に計算されます。 プール内のリソースの不足によりフェイルオーバープランを計算できない場合（空きメモリ領域が足りない場合や、どの仮想マシンをどのサーバーで再起動するかに影響する仮想ディスクとネットワークの変更が生じた場合など）は、プールがオーバーコミット状態になります。

プールがオーバーコミット状態になったときにどの仮想マシンを起動するかを制御するには、高可用性再起動優先度を設定します。 仮想マシンの再起動優先度を設定は、XenCenterの［高可用性設定］ダイアログボックスや［高可用性の設定］ウィザードで行います。このとき、プールの最大許容障害数が動的に再計算され表示されます。これにより、必要に応じてさまざまな再起動優先度設定を組み合わせたり、サーバー障害の制限の設定が適切かどうかを確認したりできます。

仮想マシンを起動または一時停止しようとしたときに、その操作によりプールがオーバーコミット状態になる場合は、XenCenterに警告が表示されます。 この警告メッセージがメールで送信されるように設定することもできます。 このとき、仮想マシンの起動や再開をキャンセルしたり、続行したりできます。操作を続行すると、プールがオーバーコミット状態になります。

高可用性が有効なプールの管理

リソースプールの高可用性を有効にしたまま、そのプールの構成を変更することは避けてください。 XenServerの高可用性機能は「午前2時の保護手段」であり、管理者の勤務時間外の障害に対処して仮想マシンを再起動するためのものです。 ソフトウェアアップデートの適用など、プール構成に変更を加える場合は、事前に高可用性を無効にします。

  • 保護された仮想マシンをXenCenterからシャットダウンしようとすると、その仮想マシンをフェイルオーバープランから削除してからシャットダウンするためのオプションが表示されます。 これにより、保護された仮想マシンを過ってシャットダウンしてしまうことが避けらると同時に、必要な場合はプールの高可用性を無効にしなくても仮想マシンをシャットダウンできます。
  • 高可用性が有効なプールのサーバーをXenCenterから再起動しようとすると、各仮想マシンの再起動優先度を考慮して、フェイルオーバープランが影響を受けるかどうかが決定されます。 フェイルオーバープランが影響を受けない場合、サーバーが通常どおりシャットダウンします。 フェイルオーバープランが影響を受けても、最大許容障害数が1よりも大きい場合は、サーバー障害の制限を1つ減らすかどうかを確認するメッセージが表示されます。 サーバー障害の制限を減らすとプールの全体的な耐障害性が低下しますが、少なくとも1台のサーバーの障害がフェイルオーバーされます。 サーバーの再起動が完了すると、フェイルオーバープランが自動的に再計算され、サーバー障害の制限が元の値に戻ります。
  • ［アップデートのインストール］ウィザードでソフトウェアアップデートをインストールする場合は、インストールが完了するまでプールの高可用性が自動的に無効になります。 ただし、アップデートをインストールしている間、プールでサーバー障害が発生していないかどうかを管理者自身が監視する必要があります。
  • 高可用性を有効にすると、プールからサーバーを削除するなど、フェイルオーバープランが影響を受けるような操作が無効になる場合があります。 このような操作を実行するには、一時的に高可用性を無効にするか、保護された仮想マシンをシャットダウンしておく必要があります。

高可用性と役割ベースのアクセス制御（RBAC）

役割ベースのアクセス制御（RBAC）が実装されたXenServer環境では、一部の管理者ユーザーはプールの高可用性設定を変更できません。 たとえば、仮想マシンの起動権限が付与された管理者（VMオペレータ）は、高可用性の許容障害数に影響するような操作を実行できません。 このため、このような管理者は、現在の最大許容障害数の値を減少させるような仮想マシンの起動を行うことはできません。 許可するサーバー障害の制限値を変更できるのは、プール管理者とプールオペレータレベルの管理者のみです。

プールの高可用性を有効にした管理者（つまりプール管理者とプールオペレータレベルの管理者）は、許可するサーバー障害の制限を（XenCenterにより算出された）最大許容障害数よりも少なく設定できます。 これにより、低い権限を持つ管理者もフェイルオーバープランに影響を与えずに新しい仮想マシンを起動できるようになります。


高可用性の要件

リソースプールで高可用性を設定する前に、プール内のすべてのサーバーと仮想マシンで以下の要件が満たされていることを確認する必要があります。

  • 356MiB以上のiSCSI、ファイバチャネル、またはNFSのLUNを少なくとも1つ含む共有ストレージが使用できる。 NetAppまたはEqualLogicのストレージリポジトリを使用する場合は、ハートビートストレージリポジトリに使用するアレイにiSCSIのLUNを手作業で準備する必要があります。
  • 高可用性を有効にする場合は、プール内のサーバーで管理インターフェイスをボンディングし、ハートビートストレージリポジトリにはマルチパスストレージを使用することを強くお勧めします。
  • すべてのサーバー上に適切なライセンスがインストールされている。
  • 高可用性で保護するすべての仮想マシンがアジャイルである。 これは、次のことを意味します。
    • 仮想ディスクが共有ストレージ （種類を問いません。iSCSI、ファイバチャネル、またはNFSのLUNはハートビートストレージでは必須条件ですが、仮想ディスクストレージとしても使用できます）上にある。
    • 仮想ネットワークインターフェイスがプール全体にわたるネットワーク上にある。
    • ローカルのDVDドライブへの接続が設定されていない。

    サーバーの物理CDドライブがマップされた仮想マシンなど、特定のサーバーから移動できない「非アジャイル」な仮想マシンには、高可用性優先度として［可能なら再起動］しか設定できません。


仮想マシンの再起動設定

想定以上の数のサーバー障害が発生すると、高可用性による回復処理が開始されます。 再起動される仮想マシンは高可用性再起動優先度に基づいて決定され、起動順序と起動間隔の設定に基づいて各仮想マシンが順次再起動されます。これにより、重要度の高い仮想マシンが最初に再起動されます。

高可用性再起動優先度

リソースプールのフェイルオーバープランで再起動される仮想マシンは、高可用性再起動優先度により決定されます。

値 | 説明
再起動 | この優先度の仮想マシンは、プール内のリソースが不足している場合を除いて再起動が保証されます。 これらの仮想マシンは、［可能なら再起動］が設定された仮想マシンよりも先に起動されます。 この優先度が設定されたすべての仮想マシンは、フェイルオーバープランの計算時に考慮されます。 この優先度が設定されたすべての仮想マシンを確実に再起動できないプールは、オーバーコミット状態になります。
可能なら再起動 | この優先度が設定された仮想マシンはフェイルオーバープランの計算時に考慮されませんが、ホストサーバーの障害発生時に1度だけ再起動が試行されます。 この再起動は、より高い再起動優先度のすべての仮想マシンが起動した後で試行されます。また、このときに再起動に失敗すると、再試行は行われません。 この再起動優先度は、常時稼働させておく必要のない、テスト/開発用の仮想マシンに適しています。
再起動しない | この優先度が設定された仮想マシンの再起動は試行されません。

起動順序

高可用性による回復処理での仮想マシンの起動順序は、起動順序により決定されます。 起動順序として0を指定すると、その仮想マシンが最初に起動します。次に1を指定した仮想マシンが起動し、2、3と続きます。

起動間隔（次のVM起動までの間隔）

仮想マシンプロパティの［次のVM起動までの間隔］では、起動順序の値でグループ化される仮想マシンの起動間隔を指定します。たとえば、起動間隔として15秒を設定した場合、起動順序0の仮想マシンが起動した後、15秒後に起動順序1の仮想マシンが起動します。


高可用性の設定

リソースプールの高可用性を有効にするには、［高可用性の設定］ウィザードを使用します。 このウィザードでは、手順を追って高可用性を設定できます。また、使用可能なリソースと、管理者が指定する高可用性再起動優先度に基づいて、最大許容障害数が算出されます。

［高可用性の設定］ウィザードを開くには、XenCenterでリソースプールを選択して、［高可用性］タブの［高可用性の設定］をクリックします。

または、次のいずれかを行います。

  • ［プール］メニューの［高可用性］を選択します。
  • リソースペインでプールを右クリックし、［高可用性］を選択します。

リソースプールの高可用性を設定するには

  1. 「高可用性の要件」に記載されている高可用性の要件が満たされていることを確認します。
  2. ［高可用性の設定］ウィザードの最初のページで［次へ］をクリックします。これにより、プールのハートビートストレージリポジトリとして使用可能なiSCSI、ファイバチャネル、またはNFSの共有LUNが検出されます。 適合するストレージリポジトリが見つからない場合は、適切な新しいストレージを設定するまでウィザードを続行できません。
  3. ［ハートビートSR］ページで、一覧からストレージリポジトリを選択して［次へ］をクリックします。
  4. ［高可用性プラン］ページで、一覧から仮想マシンを選択して、仮想マシンの起動オプションを選択します。 詳しくは、「仮想マシンの再起動設定」を参照してください。 複数の仮想マシンを選択するには、選択範囲の最初の仮想マシンをクリックしてスクロールします。そして、Shiftキーを押しながら選択範囲の最後の仮想マシンをクリックします。 一覧内で連続しない複数の仮想マシンを選択するには、最初の仮想マシンをクリックし、Ctrlキーを押しながら追加の仮想マシンをクリックします。
    オプション | 説明
    高可用性再起動優先度 各仮想マシンの再起動優先度を選択します。
    • ［再起動］を選択した仮想マシンは、プール内のリソースが不足している場合を除いて再起動が保証されされます。
    • 仮想マシンの自動再起動が不可欠でない場合は、［可能なら再起動］を選択します。
    • 仮想マシンを自動的に再起動しない場合は、［再起動しない］を選択します。
    起動順序 | 高可用性による回復処理での仮想マシンの起動順序を指定します。 起動順序として0を指定すると、その仮想マシンが最初に起動します。次に1を指定した仮想マシンが起動し、2、3と続きます。
    次のVM起動までの間隔 | 起動順序の値でグループ化される仮想マシンの起動間隔を指定します。たとえば、15秒を設定した場合、起動順序0の仮想マシンが起動した後、15秒後に起動順序1の仮想マシンが起動します。
  5. また、［高可用性プラン］ページの［サーバー障害の制限］で、この高可用性プランで許可するサーバー障害数を設定することもできます。 ここでは、XenServerにより算出される最大許容障害数（［最大］で示される）と同じまたはより小さい値を設定します。 最大許容障害数が0の場合、プールがオーバーコミット状態であることを示します。この場合、仮想マシンの再起動優先度を変更するかプールのリソースを増やさないと、ウィザードの次のページに進めません。詳しくは、「プールの最大許容障害数を増やすには」を参照してください。 設定が完了したら［次へ］をクリックします。
  6. ウィザードの最後のページで、高可用性の設定内容を確認できます。 前のページに戻って設定を変更するには［戻る］をクリックします。［完了］をクリックすると、高可用性が有効になり、ウィザードが閉じます。


高可用性の無効化

高可用性を有効にすると、プールからサーバーを削除するなど、仮想マシンのフェイルオーバープランを変更するような操作が無効になる場合があります。 このような操作を実行するには、一時的に高可用性を無効に設定します。

高可用性を無効にするには

  1. リソースペインでプールを選択して［高可用性］タブをクリックし、［高可用性の無効化］をクリックします。
  2. ［OK］をクリックして確定します。 各仮想マシンに設定した起動オプションは保持され、高可用性を有効にするとその設定が再適用されます。


高可用性設定の変更

プールの高可用性を有効にしたら、［高可用性の設定］ダイアログボックスで仮想マシンの起動設定や、プールで許可するサーバー障害の制限を変更できます。

高可用性再起動優先度および仮想マシンの起動オプションを変更するには

  1. リソースペインでプールを選択して［高可用性］タブをクリックし、［高可用性の設定］をクリックします。 または、次のいずれかを行います。
    • ［プール］メニューの［高可用性］を選択します。
    • リソースペインでプールを右クリックし、［高可用性］を選択します。
  2. 一覧で仮想マシンを選択し、起動設定を変更します。 詳しくは、「仮想マシンの再起動設定」を参照してください。 複数の仮想マシンを選択するには、選択範囲の最初の仮想マシンをクリックしてスクロールします。そして、Shiftキーを押しながら選択範囲の最後の仮想マシンをクリックします。 一覧内で連続しない複数の仮想マシンを選択するには、最初の仮想マシンをクリックし、Ctrlキーを押しながら追加の仮想マシンをクリックします。
    オプション | 説明
    高可用性再起動優先度 各仮想マシンの再起動優先度を選択します。
    • ［再起動］を選択した仮想マシンは、プール内のリソースが不足している場合を除いて再起動が保証されされます。
    • 仮想マシンの自動再起動が不可欠でない場合は、［可能なら再起動］を選択します。
    • 仮想マシンを自動的に再起動しない場合は、［再起動しない］を選択します。
    起動順序 | 高可用性による回復処理での仮想マシンの起動順序を指定します。 起動順序として0を指定すると、その仮想マシンが最初に起動します。次に1を指定した仮想マシンが起動し、2、3と続きます。
    次のVM起動までの間隔 | 起動順序の値でグループ化される仮想マシンの起動間隔を指定します。たとえば、15秒を設定した場合、起動順序0の仮想マシンが起動した後、15秒後に起動順序1の仮想マシンが起動します。
  3. ［OK］をクリックして変更を適用し、ダイアログボックスを閉じます。

プールのサーバー障害の制限値を変更するには

  1. リソースペインでプールを選択して［高可用性］タブをクリックし、［高可用性の設定］をクリックします。 または、次のいずれかを行います。
    • ［プール］メニューの［高可用性］を選択します。
    • リソースペインでプールを右クリックし、［高可用性］を選択します。
  2. ［サーバー障害の制限］で、そのプールで許可するサーバー障害数を設定します。 ここでは、XenServerにより算出される最大許容障害数（［最大］で示される）と同じまたはより小さい値を設定します。 最大許容障害数が0の場合、プールがオーバーコミット状態でることを示します。この場合、変更を保存するには高可用性再起動優先度を変更するか、プールで使用可能なリソースを増やす必要があります。詳しくは、「プールの最大許容障害数を増やすには」を参照してください。
  3. ［OK］をクリックして変更を適用し、ダイアログボックスを閉じます。

プールの最大許容障害数を増やすには

プールの最大許容障害数を増やすには、以下の作業が必要です。

  • 一部の仮想マシンの再起動優先度を下げる。
  • サーバーのRAMを増設するかプールにサーバーを追加する。
  • 一部の仮想マシンに割り当てられているメモリの量を減らす。
  • 重要でない仮想マシンをシャットダウンする。


障害回復（DR）

トピック：

  • XenServerの障害回復について
  • 障害回復の設定
  • フェイルオーバー
  • フェイルバック
  • フェイルオーバーテスト


XenServerの障害回復について

XenServerの障害回復（DR）機能は、壊滅的なハードウェア障害などによりそのプールやサイト全体が使用不能になった場合に、仮想マシン（VM）やvAppを回復できるように設計されています。 単一サーバーの障害からの回復については、XenServerの高可用性機能を使用して、同一プール内のほかのサーバー上で仮想マシンが再起動されるように設定できます。

XenServerの障害回復のしくみ

XenServerの障害回復では、仮想マシンやvAppを回復するために必要なすべての情報がストレージリポジトリ（SR）上に格納され、その情報が実務環境（プライマリサイト）からバックアップ環境（セカンダリサイト）に複製されます。 プライマリサイトのリソースプールが停止すると、複製されたストレージから仮想マシンやvAppが復元され、セカンダリサイト（障害回復サイト）上に再作成されます。

障害回復サイトのプールで仮想マシンが起動すると、そのプールのメタデータも複製されたストレージ上に格納されます。プライマリサイトがオンライン状態に復帰すると、セカンダリサイトで再作成された仮想マシンやvAppが、このメタデータに基づいてプライマリサイトに復元されます。

注： XenServerの障害回復機能で使用できるストレージは、HBA上のLVMまたはiSCSI上のLVMである必要があります。

XenServerの仮想マシンは、以下の2つのコンポーネントで構成されています。

  • 仮想マシンにより使用される仮想ディスク。その仮想マシンのリソースプールで構成されているストレージリポジトリ上に格納されます。
  • 仮想マシン環境の内容が記述されたメタデータ。 使用不能になったり破損したりした仮想マシンを再作成するために必要な情報は、このメタデータのみです。 通常、仮想マシンの作成時にメタデータ設定データが書き込まれ、仮想マシン構成を変更すると更新されます。 プール内の仮想マシンでは、メタデータのコピーがそのプール内のすべてのサーバー上に格納されます。

障害回復機能が有効な場合、プール内のすべての仮想マシンやvAppについての設定情報であるプールメタデータにより、仮想マシンがセカンダリサイト（障害回復サイト）上に再作成されます。 各仮想マシンのメタデータには、仮想マシンの名前と説明、固有の識別子であるUUID（Universally Unique Identifier）、メモリと仮想CPUの構成、およびネットワークとストレージの情報が記録されます。 また、高可用性または障害回復環境での仮想マシンの起動オプション（起動順序、起動間隔、および高可用性再起動優先度）も仮想マシンのメタデータに記録されます。 たとえば、障害発生時に仮想マシンをDRサイトのプールに再作成する場合、vAppに含まれる各仮想マシンはメタデータに記録されている順序および間隔で起動します。

XenServerの障害回復の要件

ソフトウェアのバージョン | XenServer 6.0以降
アクセス | ルートユーザーまたはプールオペレータ以上の権限が必要

障害回復インフラストラクチャ

XenServerの障害回復機能を使用するには、プライマリサイトおよびセカンダリサイトで特定のインフラストラクチャ要件を満たす必要があります。

  • プールメタデータおよび仮想マシンの仮想ディスクで使用されるストレージが、実務環境（プライマリサイト）からバックアップ環境（セカンダリサイト）に複製されている。 ストレージの複製（ミラー化など）は、使用するストレージソリューションにより行われ、その方法はデバイスによって異なります。
  • 障害回復サイトのプールで再作成された仮想マシンおよびvAppが起動した後で、障害回復プールのメタデータと仮想ディスクを格納するストレージリポジトリが複製されている。これにより、プライマリサイトがオンライン状態になったときに、これらの仮想マシンおよびvAppがプライマリサイトに復元（フェイルバック）されます。
  • 障害回復サイトのハードウェアインフラストラクチャは、プライマリサイトのものと同一である必要はありません。ただし、XenServerのバージョンおよびパッチレベルが一致しており、プライマリサイトすべての仮想マシンの再作成および実行に必要なリソースが障害回復プールに設定されている必要があります。
重要： XenCenterおよび［障害回復］ウィザードでは、ストレージアレイの機能を制御することはできません。 障害回復機能を使用する場合は、プールメタデータおよび仮想マシンのストレージがバックアップサイトに複製されるように設定しておく必要があります。 一部のストレージアレイには、自動的に複製するためのミラー化機能が用意されています。このような機能を使用する場合は、仮想マシンが障害回復サイト上で再起動する前に、ミラー化機能を無効にしておく必要があります。

障害回復ウィザードによるフェイルオーバー、フェイルバック、およびフェイルオーバーテスト

［障害回復］ウィザードを使用すると、フェイルオーバー（仮想マシンやvAppのセカンダリサイト上での回復）とファイルバック（仮想マシンやvAppのプライマリサイト上への復元）を簡単に設定できます。 これらの2つの設定は、以下の手順で行います。

フェイルオーバー フェイルバック
  1. まず、仮想マシンとvAppのフェイルオーバー先として、セカンダリの障害回復サイトのプールを選択します。
  2. 次に、プライマリサイトから複製されたストレージリポジトリを格納するストレージターゲットの詳細を指定します。
  3. ウィザードによりターゲットがスキャンされ、検出されたすべてのストレージリポジトリが表示されます。

    フェイルオーバーする仮想マシンとvAppのメタデータと仮想ディスクを格納しているストレージリポジトリを選択します。

  4. ウィザードによりストレージリポジトリがスキャンされ、検出されたすべての仮想マシンとvAppが表示されます。

    障害回復サイトにフェイルオーバーする仮想マシンとvAppを選択し、それらをフェイルオーバー後に自動的に起動するか手作業で起動するかを指定します。

  5. ウィザードによりいくつかの事前チェックが実行され、選択した仮想マシンやvAppがフェイルオーバー可能かどうかが検証されます。たとえば、仮想マシンやvAppの起動に必要なストレージが障害回復プールで使用可能かどうかがチェックされます。
  6. 最後に、事前チェックが完了し、すべての問題が解決されると、フェイルオーバーが実行されます。 選択した仮想マシンとvAppが、複製ストレージから障害回復プールにエクスポートされます。

    フェイルオーバーが完了します。

  1. まず、障害回復サイト上で実行されている仮想マシンとvAppのフェイルバック先として、プライマリサイトのプールを選択します。
  2. 次に、障害回復サイトから複製されたストレージリポジトリを格納するストレージターゲットの詳細を指定します。
  3. ウィザードによりターゲットがスキャンされ、検出されたすべてのストレージリポジトリが表示されます。

    フェイルバックする仮想マシンとvAppのメタデータと仮想ディスクを格納しているストレージリポジトリを選択します。

  4. ウィザードによりストレージリポジトリがスキャンされ、検出されたすべての仮想マシンとvAppが表示されます。

    プライマリサイトにフェイルバックする仮想マシンとvAppを選択し、それらをフェイルバック後に自動的に起動するか手作業で起動するかを指定します。

  5. ウィザードによりいくつかの事前チェックが実行され、選択した仮想マシンやvAppがフェイルバック可能かどうかが検証されます。たとえば、仮想マシンやvAppの起動に必要なストレージがプライマリサイトのプールで使用可能かどうかがチェックされます。
  6. 最後に、事前チェックが完了し、すべての問題が解決されると、フェイルバックが実行されます。 障害回復サイトで実行されている、選択した仮想マシンとvAppが、複製ストレージからプライマリサイトのプールにエクスポートされます。

    フェイルバックが完了します。

［障害回復］ウィザードにより同一仮想マシンについての複数の情報が検出された場合（プライマリサイトのストレージ、障害回復サイトのストレージ、およびインポート先のプールに同一仮想マシンのメタデータが見つかった場合など）は、最新の情報のみが使用されます。

ヒント： 仮想マシンやvAppとストレージリポジトリの対応、およびストレージリポジトリとLUNの対応を表すストレージリポジトリ名を使用すると、複製ストレージからの仮想マシンやvAppの回復がわかりやすくなります。

［障害回復］ウィザードでは、障害回復システムの設定を確認するために、フェイルオーバーテストを実行することもできます。 このテストでは、通常のフェイルオーバーと同じ処理が実行されますが、障害回復サイトにエクスポートされた仮想マシンやvAppは一時停止状態で起動します。さらに、テスト完了時にこれらの仮想マシンやvApp、および再作成されたストレージが障害回復サイトから消去されます。 「フェイルオーバーテスト」を参照してください。

用語について

vApp
関連する複数の仮想マシンを単一の管理対象として論理的にグループ化したものを指します。
サイト
XenServerリソースプール、ストレージ、およびハードウェア機材の物理的なグループを指します。
プライマリサイト
フェイルオーバー対象の仮想マシンやvAppを実行する物理サイトを指します。
セカンダリサイト、障害回復サイト
障害発生時にプライマリサイトのフェイルオーバー先として使用される物理サイトを指します。
フェイルオーバー
障害発生時にプライマリサイトの仮想マシンやvAppをセカンダリ（障害回復）サイト上で復元する処理を指します。
フェイルバック
仮想マシンやvAppをセカンダリ（障害回復）サイトからプライマリサイトに復元する処理を指します。
フェイルオーバーテスト
フェイルオーバーの「ドライラン」で、仮想マシンやvAppを複製ストレージからセカンダリ（障害回復）サイトのプールにエクスポートしますが、これらの仮想マシンは実際には起動しません。 フェイルオーバーテストにより、障害回復が効果的に設定されているかどうかを検証できます。
プールメタデータ
リソースプール内の仮想マシンおよびvAppに関する情報で、名前や説明、および仮想マシンについては固有の識別子であるUUID（Universally Unique Identifier）、メモリと仮想CPUの構成、およびネットワークとストレージの情報が記録されます。また、高可用性または障害回復環境での仮想マシンの起動オプション（起動順序、起動間隔、および高可用性再起動優先度）も仮想マシンのメタデータに記録されます。 プールメタデータは、障害回復機能でプライマリサイトの仮想マシンやvAppをセカンダリ（障害回復）サイトのプールで再作成するときに使用されます。


障害回復の設定

XenCenterの［障害回復の設定］ダイアログボックスを使用して、プール内のすべての仮想マシンやvAppについての設定情報であるプールメタデータの格納先ストレージリポジトリを指定します。 このメタデータは、管理者がプールの仮想マシンやvAppの設定を変更するたびに更新されます。

プライマリプールで障害回復を設定するには

  1. プライマリサイトでフェイルオーバー対象のリソースプールを選択し、［プール］メニューから［障害回復］、［設定］の順に選択します。
  2. プールメタデータの格納先として、最大で8つのストレージリポジトリを選択できます。 これらのストレージでは、プールの回復情報を保持する新規LUN用にいくらかの容量が必要になります。
    注： XenServerの障害回復機能で使用できるストレージは、HBA上のLVMまたはiSCSI上のLVMである必要があります。
  3. ［OK］をクリックします。
    重要： プールメタデータおよび仮想マシンの仮想ディスクで使用されるストレージが、実務環境（プライマリサイト）からバックアップ環境（セカンダリサイト）に複製されるまで、XenServer障害回復環境の設定は完了しません。 ストレージの複製（ミラー化など）は、使用するストレージソリューションにより行われ、その方法はデバイスによって異なります。XenCenterでストレージを複製することはできません。


フェイルオーバー

フェイルオーバーとは、プライマリサイト（実務環境）に障害が発生した場合に、仮想マシンやvAppをセカンダリ（障害回復）サイトで再作成する処理を指します。 仮想マシンやvAppをフェイルオーバーするには、［障害回復］ウィザードを使用します。

重要： 障害回復ウィザードでは、ストレージアレイの機能を制御することはできません。 メタデータストレージ、およびフェイルオーバーする仮想マシンで使用されるストレージの複製（ミラー化）は、セカンダリサイトへのフェイルオーバー時に無効にしておく必要があります。

仮想マシンやvAppをセカンダリサイトにフェイルオーバーするには

  1. XenCenterで、セカンダリサイトのフェイルオーバー先のリソースプールを選択し、［プール］メニューから［障害回復］、［障害回復ウィザード］の順に選択します。
  2. 実行する操作として［フェイルオーバー］をクリックし、［次へ］をクリックします。
    注： ファイバチャネル共有ストレージでLUNミラー化によるセカンダリサイトへのデータ複製を行っている場合は、回復を実行する前にミラー化を無効にする必要があります。これにより、セカンダリサイトからの読み取りおよび書き込みアクセスが可能になります。
  3. 回復対象の仮想マシンやvAppのプールメタデータを格納しているストレージリポジトリを選択します。 デフォルトでは、このウィザードの一覧にプール内で接続されているすべてのストレージリポジトリが表示されます。 ほかのストレージリポジトリを検出するには、［ストレージ リポジトリの検出］をクリックして、目的のストレージの種類を選択します。
    • ハードウェアHBAストレージリポジトリを検出するには、［ハードウェアHBA SRの検出］を選択します。
    • ソフトウェアiSCSIストレージリポジトリを検出するには、［ソフトウェアiSCSI SRの検出］を選択して、ターゲットホスト、IQN、およびLUNの情報を指定します。
    ストレージリポジトリを選択したら、［次へ］をクリックして次のページに進みます。
  4. フェイルオーバーする仮想マシンやvAppを選択して、［回復後の電源状態］で適切なオプションを選択します。これらのオプションでは、フェイルオーバーした仮想マシンやvAppを自動的に起動するかどうかを指定します。 ［次へ］をクリックして次のページに進み、事前チェックを開始します。
  5. このウィザードでは、対象の仮想マシンやvAppが正しくセカンダリサイトにフェイルオーバーされるように、事前にいくつかのチェックが実行されます。たとえば、選択した仮想マシンやvAppに必要なストレージが使用可能かどうかがチェックされます。 この時点でストレージが見つからない場合は、このページの［SRの接続］をクリックして適切なストレージリポジトリを接続できます。 事前チェックで見つかったすべての問題を解決したら、［フェイルオーバー］をクリックします。フェイルオーバー処理が開始されます。
  6. 進行状況のページに、各仮想マシンやvAppについてフェイルバックに成功したかどうかが表示されます。 選択した仮想マシンやvAppの数によっては、フェイルオーバー処理に時間がかかることがあります。この処理では、仮想マシンやvAppのメタデータが複製ストレージからエクスポートされ、それらの仮想マシンやvAppがセカンダリサイトのプールで再作成された後、仮想ディスクを格納しているストレージリポジトリが仮想マシンに接続され、最後に（指定されている場合は）再作成された仮想マシンが起動します。
  7. フェイルオーバーが完了したら、［次へ］をクリックして結果レポートを表示します。 結果レポートのページで［完了］をクリックして、ウィザードを終了します。

    プライマリサイトが障害から復帰した後、仮想マシンをプライマリサイトに復元するには、再度［障害回復］ウィザードを使用します。ただし、この場合は最初のページで［フェイルバック］オプションを選択します。詳しくは、「フェイルバック」を参照してください。


フェイルバック

フェイルバックとは、プライマリサイト（実務環境）が障害から復帰した後で、仮想マシンやvAppを複製ストレージからプライマリサイトに復元する処理を指します。 仮想マシンやvAppをプライマリサイトにフェイルバックするには、［障害回復］ウィザードを使用します。

重要： 障害回復ウィザードでは、ストレージアレイの機能を制御することはできません。 メタデータストレージ、および復元する仮想マシンで使用されるストレージの複製（ミラー化）は、プライマリサイトへのフェイルバック時に無効にしておく必要があります。

仮想マシンやvAppをプライマリサイトにフェイルバックするには

  1. XenCenterで、プライマリサイトのフェイルバック先のリソースプールを選択し、［プール］メニューから［障害回復］、［障害回復ウィザード］の順に選択します。
  2. 実行する操作として［フェイルバック］をクリックし、［次へ］をクリックします。
    注： DRサイトのファイバチャネル共有ストレージでLUNミラー化によるデータ複製を行っている場合は、フェイルバックを実行する前にミラー化を無効にする必要があります。これにより、プライマリサイトからの読み取りおよび書き込みアクセスが可能になります。
  3. フェイルバック対象の仮想マシンやvAppのプールメタデータを格納しているストレージリポジトリを選択します。 デフォルトでは、このウィザードの一覧にプール内で接続されているすべてのストレージリポジトリが表示されます。 ほかのストレージリポジトリを検出するには、［ストレージ リポジトリの検出］をクリックして、目的のストレージの種類を選択します。
    • ハードウェアHBAストレージリポジトリを検出するには、［ハードウェアHBA SRの検出］を選択します。
    • ソフトウェアiSCSIストレージリポジトリを検出するには、［ソフトウェアiSCSI SRの検出］を選択して、ターゲットホスト、IQN、およびLUNの情報を指定します。
    ストレージリポジトリを選択したら、［次へ］をクリックして次のページに進みます。
  4. フェイルバックする仮想マシンやvAppを選択して、［回復後の電源状態］で適切なオプションを選択します。これらのオプションでは、フェイルバックした仮想マシンやvAppを自動的に起動するかどうかを指定します。 ［次へ］をクリックして次のページに進み、事前チェックを開始します。
  5. このウィザードでは、対象の仮想マシンやvAppが正しくプライマリサイトにフェイルバックされるように、事前にいくつかのチェックが実行されます。たとえば、選択した仮想マシンやvAppに必要なストレージが使用可能かどうかがチェックされます。 この時点でストレージが見つからない場合は、このページの［SRの接続］をクリックして適切なストレージリポジトリを接続できます。 事前チェックで見つかったすべての問題を解決したら、［フェイルバック］をクリックします。フェイルバック処理が開始されます。
  6. 進行状況のページに、各仮想マシンやvAppについてフェイルバックに成功したかどうかが表示されます。 選択した仮想マシンやvAppの数によっては、フェイルバック処理に時間がかかることがあります。
  7. フェイルバックが完了したら、［次へ］をクリックして結果レポートを表示します。 結果レポートのページで［完了］をクリックして、ウィザードを終了します。


フェイルオーバーテスト

フェイルオーバーテストは、障害回復を計画するときに重要な機能です。 ［障害回復］ウィザードでは、障害回復システムの設定を確認するために、フェイルオーバーテストを実行できます。 このテストでは、通常のフェイルオーバーと同じ処理が実行されますが、障害回復サイトにエクスポートされた仮想マシンやvAppは一時停止状態で起動します。 テストが完了すると、これらの仮想マシンやvApp、および再作成されたストレージが障害回復サイトから自動的に消去されます。

障害回復の初回設定時、および障害回復が有効なプールの構成を大幅に変更したときに、フェイルオーバーテストを実行して障害回復が正しく機能することを確認することをお勧めします。

仮想マシンやvAppのフェイルオーバーテストを実行するには

  1. XenCenterで、セカンダリサイトのフェイルオーバー先のリソースプールを選択し、［プール］メニューから［障害回復］、［障害回復ウィザード］の順に選択します。
  2. 実行する操作として［フェイルオーバーテスト］をクリックし、［次へ］をクリックします。
    注： ファイバチャネル共有ストレージでLUNミラー化によるセカンダリサイトへのデータ複製を行っている場合は、回復を実行する前にミラー化を無効にする必要があります。これにより、セカンダリサイトからの読み取りおよび書き込みアクセスが可能になります。
  3. 回復対象の仮想マシンやvAppのプールメタデータを格納しているストレージリポジトリを選択します。 デフォルトでは、このウィザードの一覧にプール内で接続されているすべてのストレージリポジトリが表示されます。 ほかのストレージリポジトリを検出するには、［ストレージ リポジトリの検出］をクリックして、目的のストレージの種類を選択します。
    • ハードウェアHBAストレージリポジトリを検出するには、［ハードウェアHBA SRの検出］を選択します。
    • ソフトウェアiSCSIストレージリポジトリを検出するには、［ソフトウェアiSCSI SRの検出］を選択して、ターゲットホスト、IQN、およびLUNの情報を指定します。
    ストレージリポジトリを選択したら、［次へ］をクリックして次のページに進みます。
  4. フェイルオーバーする仮想マシンやvAppを選択し、［次へ］をクリックして次のページに進み、事前チェックを開始します。
  5. フェイルオーバーテストを実行する前に、対象の仮想マシンやvAppが正しくセカンダリサイトにフェイルオーバーされるように、事前にいくつかのチェックが実行されます。たとえば、選択した仮想マシンやvAppに必要なストレージが使用可能かどうかがチェックされます。
    1. ストレージが使用可能かどうかのチェック： 必要なストレージが見つからない場合は、このページの［SRの接続］をクリックして適切なストレージリポジトリを接続できます。
    2. 障害回復サイトのプールで高可用性が無効になっているかどうかのチェック： プライマリサイトと障害回復サイトの両方のプールで同じ仮想マシンが実行されないように、セカンダリサイトのプールで高可用性機能が無効になっている必要があります。これにより、再作成された仮想マシンやvAppが自動的に起動することを避けることができます。 セカンダリサイトのプールの高可用性を無効にするには、このページの［高可用性の無効化］をクリックします （ここで無効にした高可用性機能は、フェイルオーバーテストの完了時に自動的に有効になります）。
    事前チェックで見つかったすべての問題を解決したら、［フェイルオーバー］をクリックします。フェイルオーバーテストが開始されます。
  6. 進行状況のページに、各仮想マシンやvAppについてフェイルバックに成功したかどうかが表示されます。 選択した仮想マシンやvAppの数によっては、フェイルオーバー処理に時間がかかることがあります。この処理では、仮想マシンやvAppのメタデータが複製ストレージから回復され、それらの仮想マシンやvAppがセカンダリサイトのプールで再作成された後、仮想ディスクを格納しているストレージリポジトリが仮想マシンに接続されます。 フェイルオーバーテストでは、セカンダリサイトにフェイルオーバーされた仮想マシンは実行されず、一時停止状態になります。
  7. フェイルオーバーテストに成功したら、［次へ］をクリックします。これにより、障害回復サイトがクリーンアップされます。
    • フェイルオーバーにより再作成された仮想マシンやvAppが、ここで削除されます。
    • フェイルオーバーにより接続されたストレージが、ここで接続解除されます。
    • フェイルオーバーテストの事前チェック時にセカンダリサイトのプールの高可用性を無効にした場合は、ここで自動的に有効になります。
    障害回復サイトのクリーンアップ処理の進行状況がウィザードに表示されます。
  8. ［完了］をクリックしてウィザードを終了します。


アクセス制御（Active Directoryと役割ベースのアクセス制御）

トピック

  • ユーザーの管理
  • 役割ベースのアクセス制御（RBAC）の概要
  • RBAC役割の定義とアクセス権
  • ドメインへの参加とユーザーの追加
  • ユーザーおよびグループへの役割の割り当て
  • XenServerにログインしたユーザーのアクセス許可の決定プロセス
  • XenServerの監査履歴


ユーザーの管理

XenServerの初回インストール時に、管理者ユーザーのアカウントが自動的に追加されます。 このアカウントはローカルスーパーユーザー（LSU）またはrootと呼ばれ、そのXenServerコンピュータにより認証されるものです。 ほかのユーザーを追加するには、XenCenterの［ユーザー］タブを使用してActive Directoryアカウントを追加します （ここで「ユーザー」とは、その役割レベルにかかわらず、XenServerアカウントを持つXenServer管理者を指します）。 XenServerホストやプールに対して複数のユーザーアカウントを使用するには、Active Directoryユーザーアカウントで認証する必要があります。 これにより、リソースプール内のXenServerにWindowsドメインの資格情報でログインできるようになります。

注： リソースプールで複数の認証方法を使用することはサポートされていません。つまり、プール内の一部のホストでのみActive Directory認証を有効にして、ほかのホストで無効にすることはできません。

XenServer 6.2.0でのユーザーの管理

管理者ユーザーを作成した後で役割を割り当てないと、そのアカウントは使用できません。 役割が自動的に割り当てられないことに注意してください。 このため、これらのユーザーにXenServerリソースプールへのアクセスを許可するには、いずれかの役割を割り当てる必要があります。

役割ベースのアクセス制御（RBAC）機能を使用すると、管理者ユーザーとして追加したActive Directoryアカウントにさまざまなレベルのアクセス許可を割り当てることができます。 Active Directoryを使用しない環境では、ローカルスーバーユーザーのみを使用します。

XenServer 6.1.0およびそれ以前のバージョンでのユーザーの管理

XenServerのすべてのエディションで、Active Directoryアカウントを追加できます。 ただし、XenServer Enterprise EditionおよびPlatinum Editionの役割ベースのアクセス制御（RBAC）機能を使用すると、追加したActive Directoryアカウントにさまざまなレベルのアクセス許可を割り当てることができます。 Active Directoryを使用しない環境では、ローカルスーバーユーザーのみを使用します。

ユーザーアカウントを追加したときに割り当てられるアクセス許可は、XenServerのバージョンにより異なります。

  • XenServerおよびXenServer Advanced Edition：そのバージョンで使用可能なすべての機能に対するアクセス許可が新しいユーザーに付与されます。
  • XenServer Enterprise EditionおよびPlatinum Edition：追加されたユーザーアカウントに役割は自動的に割り当てられません。 このため、これらのユーザーにXenServerリソースプールへのアクセスを許可するには、いずれかの役割を割り当てる必要があります。

XenServer環境でのActive Directory認証

XenServerはLinuxベースのシステムですが、XenServerユーザーアカウントとしてActive Directoryアカウントを使用することができます。 このため、Active Directory資格情報がActive Directoryドメインコントローラに渡されます。

XenServerにActive Directoryのユーザーまたはグループアカウントを追加すると、これらのアカウントはXenServerのサブジェクトになります。サブジェクトは、XenCenterではユーザーとして表記されます。 サブジェクトがXenServerに登録されると、ユーザー/グループがログイン時にActive Directoryで認証されます。ドメイン名でユーザー名を修飾する必要はありません。

注： XenCenterでは、ユーザー名を修飾しない場合（つまり「mydomain\myuser」または「myuser@mydomain.com」形式を使用しない場合）、デフォルトで現在のActive Directoryドメインユーザーでのログインが試行されます。 ただし、ローカルスーバーユーザーでのログインは、常にローカルでの認証（つまりXenServerホスト上での認証）が試行されます。

外部認証プロセスは、以下のように機能します。

  1. XenServerホストに接続するときに提供された資格情報がActive Directoryドメインコントローラに渡され、認証が要求されます。
  2. Active Directoryドメインコントローラが、その資格情報を確認します。 資格情報が無効な場合は、ここで認証に失敗します。
  3. 資格情報が有効な場合は、Active Directoryドメインコントローラに照会され、その資格情報に関連付けられているサブジェクト識別子およびグループメンバシップが取得されます。
  4. 取得したサブジェクト識別子がXenServerに格納されているものと一致した場合は、認証が正しく完了します。

ドメインにXenServerを追加すると、そのリソースプールでのActive Directory認証が有効になります。 これにより、そのドメイン（および信頼関係のあるドメイン）のユーザーだけがリソースプールに接続できるようになります。


役割ベースのアクセス制御（RBAC）の概要

役割ベースのアクセス制御（RBAC：Role Based Access Control）機能では、XenServerの管理タスクの定義済みセットである役割を、Active Directoryのユーザーやグループアカウントを使用して特定のユーザー（つまりXenServer管理者）に割り当てることができます。 この役割により、その管理者がアクセスできるXenServerの機能が決定されます。役割ベースのアクセス制御は、個々のサーバーレベルではなくリソースプールレベルで適用されます。 各管理者には、そのユーザーアカウントまたはグループアカウントに割り当てられた役割によりアクセス許可が付与されます。

XenServerのユーザーアカウントとしてActive Directoryアカウントを使用する

役割ベースのアクセス制御では、管理者が実行可能な操作を、その管理者が属するグループに基づいて制御します。これにより、不適切な管理者による操作により壊滅的な問題が生じたり、意図しない変更が加えられたりすることを防ぐことができます。 また、法令遵守の観点から、許可を得ていない操作を禁止するためにこの機能を使用することもできます。 役割ベースのアクセス制御の監査ログ機能と、これに対応するワークロードバランスのプール監査記録レポートを、コンプライアンスおよび監査に役立てることもできます。

役割ベースのアクセス制御では、認証サービスとしてActive Directoryが使用されます。 XenServerは、認証されたユーザーの一覧をActive Directoryのユーザーおよびグループアカウントに基づいて管理します。 このため、役割を割り当てるには、事前にリソースプールをドメインに追加して、Active Directoryアカウントを追加しておく必要があります。

注： 役割ベースのアクセス制御機能は、Citrix XenServer Enterprise Editionおよびそれ以上のエディションで使用可能です。 XenServerの各エディションについて詳しくは、ここを参照してください。

これ以外のエディションでは、Active Directoryアカウントを追加することはできますが、 すべてのユーザーにプール管理者としての役割が適用されます。

役割ベースのアクセス制御の基本的な手順

役割ベースのアクセス制御を有効にしてユーザーやグループに役割を割り当てるには、以下の手順を行います。

  1. ドメインに参加する。
  2. Active Directoryのユーザーまたはグループをプールに追加する。
  3. ユーザーまたはグループにRBACの役割を割り当てる（または変更する）。

ローカルスーパーユーザー

ローカルスーパーユーザー（LSU）（root）は特別なシステム管理用アカウントであり、すべての権限およびアクセス許可を持ちます。 ローカルスーパーユーザーは、XenServerをインストールする時のデフォルトのアカウントです。 このアカウントはXenServerにより認証され、外部の認証サービスは使用されません。 つまり、外部の認証サービスに障害が生じた場合でも、ローカルスーパーユーザーとしてログインすればシステムを管理できます。 ローカルスーパーユーザーは、SSHを使用して物理XenServerホストに常にアクセスできます。

RBACの役割

XenServerには、異なる管理業務を担当する各IT部門に合わせて、あらかじめ6つの役割が用意されています。

  • プール管理者（Pool Admin）： 最も強力な権限を持つ役割です。 プール管理者には、XenServer のすべての機能および設定に対する完全なアクセス権が付与されます。 役割やほかの管理者の管理を含む、すべての管理タスクを実行できます。 このレベルの管理者は、XenServerのコンソール画面にアクセスできます。 この役割を割り当てる管理者の数は、最小限にとどめておくことをお勧めします。
    注： ローカルスーパーユーザー（root）には、常にプール管理者の役割が適用されます。 つまり、プール管理者にはローカルスーパーユーザーと同じ権限が設定されます。
  • プールオペレータ（Pool Operator）： ストレージの作成、サーバーの管理、パッチの適用、プールの作成など、プール全体のリソースを管理できる役割です。 プールオペレータは、プールのリソースを設定できます。 また、以下の機能に対する完全なアクセスが付与されます。高可用性（HA）、ワークロードバランス、およびパッチ管理。 プールオペレータは、管理者ユーザーを追加したり役割を変更したりすることはできません。
  • 仮想マシンパワー管理者（VM Power Admin）： 仮想マシンおよびテンプレートに対する完全な管理権限を持つ役割です。 このレベルの管理者には、 動的メモリ制御機能および仮想マシンのスナップショット機能への完全なアクセスが付与されます。 さらに、ホームサーバーを設定したり、仮想マシンをどのサーバー上で実行するかを決定したりすることもできます。 この役割が割り当てられた管理者には、仮想マシンオペレータに仮想マシンを提供するために必要な権限が付与されます。
  • 仮想マシン管理者（VM Admin）： 仮想マシンおよびテンプレートを管理でき、そのために必要なストレージにアクセスできる役割です。 ただし、仮想マシンをどのサーバー上で実行するかを決定したり、テンプレートに定義されている動的メモリ制御やホームサーバーの設定を変更したりすることはできません （動的メモリ制御機能の使用、スナップショット作成、ホームサーバーの設定、および仮想マシンの実行サーバーの選択はできません）。
  • 仮想マシンオペレータ（VM Operator）： リソースプール内の仮想マシンを使用して、基本的なライフサイクル操作を行うための役割です。 仮想マシンオペレータは仮想マシンのコンソール画面を操作でき、仮想マシンの起動や終了を実行できます（十分なハードウェアリソースが使用可能な場合）。 同様に、仮想マシンのライフサイクル操作を開始したり終了したりできます。 ただし、仮想マシンの作成や破棄、および仮想マシンのプロパティやサーバーリソースを変更することはできません。
  • 読み取りのみ（Read Only）： この役割では、リソースプールとパフォーマンスデータを表示することしかできません。

各役割で許可される管理タスクについては、「RBAC役割の定義とアクセス権」を参照してください。 また、ユーザーに適用される役割の決定方法については、「XenServerにログインしたユーザーのアクセス許可の決定プロセス」を参照してください。

注： 管理者として追加したユーザーアカウントに役割を割り当てない場合、自動的にプール管理者の役割が割り当てられます。 ただし、XenServer Enterprise EditionおよびPlatinum Editionでは、追加されたユーザーアカウントに役割は自動的に割り当てられません。 既存の管理者が個別に役割を割り当てる必要があります。

XenServerのアップグレード

役割ベースのアクセス制御は、XenServer Version 5.6以降でサポートされています。 これ以前のバージョンのXenServerで作成されたユーザーアカウントには、XenServer Version 5.6以降へのアップグレードによりプール管理者の役割が割り当てられます。 これは後方互換性を維持するための機能です。 このため、XenServerをアップグレードした後で、各ユーザーアカウントに適切な役割が割り当てられているかどうかを確認する必要があります。


RBAC役割の定義とアクセス権

各役割に付与されるアクセス権

XenServerの各役割に付与されるアクセス権（実行可能な管理タスク）は以下のとおりです。 各アクセス権について詳しくは、後述の「アクセス権の定義」を参照してください。

権限 | プール管理者 | プールオペレータ | VMパワー管理者 | VM管理者 | VMオペレータ | 読み取り専用
役割の割り当て/変更 | ○ |  |  |  |  |
物理サーバーのコンソールへのログイン（SSHおよびXenCenterの使用） | ○ |  |  |  |  |
サーバーのバックアップ/復元 | ○ |  |  |  |  |
OVF/OVAパッケージのインポート/エクスポートとディスクイメージのインポート | ○ |  |  |  |  |
接続中のユーザーのログアウト | ○ | ○ |  |  |  |
アラートの作成と解除 | ○ | ○ |  |  |  |
任意のユーザーのタスクのキャンセル | ○ | ○ |  |  |  |
プール管理 | ○ | ○ |  |  |  |
高度な仮想マシン操作 | ○ | ○ | ○ |  |  |
仮想マシンの作成/破棄操作 | ○ | ○ | ○ | ○ |  |
仮想マシンのCDメディアの変更 | ○ | ○ | ○ | ○ | ○ |
仮想マシンの電源状態の変更 | ○ | ○ | ○ | ○ | ○ |
仮想マシンコンソールの表示 | ○ | ○ | ○ | ○ | ○ |
XenCenterの表示管理操作 | ○ | ○ | ○ | ○ | ○ |
自分のタスクのキャンセル | ○ | ○ | ○ | ○ | ○ | ○
監査ログの表示 | ○ | ○ | ○ | ○ | ○ | ○
WLBの設定、初期化、有効化、および無効化 | ○ | ○ |  |  |  |
WLB最適化推奨項目の適用 | ○ | ○ |  |  |  |
WLBレポートサブスクリプションの変更 | ○ | ○ |  |  |  |
WLB配置推奨項目の承諾 | ○ | ○ | ○ |  |  |
WLB設定の表示 | ○ | ○ | ○ | ○ | ○ | ○
WLBレポートの生成 | ○ | ○ | ○ | ○ | ○ | ○
プールへの接続およびすべてのプールメタデータの読み取り | ○ | ○ | ○ | ○ | ○ | ○

アクセス権の定義

各アクセス権の内容は以下のとおりです。

アクセス権 許可されるタスク 説明
役割の割り当て/変更
  • ユーザーアカウントの追加と削除
  • ユーザーアカウントの役割の追加と削除
  • Active Directory統合機能の有効化および無効化（ドメインへの追加）

すべてのタスクの実行が許可されます。

警告：Active Directory統合機能およびActive Directoryから追加されたすべてのサブジェクトの無効化が許可されます。

サーバーコンソールへのログイン
  • SSHを使用したサーバーコンソールへのアクセス
  • XenCenterを使用したサーバーコンソールへのアクセス
警告：ルートシェルにアクセスできるため、RBACを含むシステム全体の再設定が独断的に可能になります。

サーバーのバックアップ/復元と仮想マシンの作成/破棄操作

  • サーバーのバックアップおよび復元
  • プールメタデータのバックアップおよび復元
バックアップからの復元が許可されるため、RBAC設定の変更を元に戻すことが可能です。
OVF/OVAパッケージのインポート/エクスポートとディスクイメージのインポート
  • OVFおよびOVAパッケージのインポート
  • ディスクイメージのインポート
  • OVF/OVAパッケージとしてのエクスポート
接続中のユーザーのログアウト
  • ログインしているユーザーの切断
アラートの作成/解除

警告：プール全体のアラートの解除が許可されます。

注：アラートの表示許可は、プールへの接続およびすべてのプールメタデータの読み取り権限に含まれます。

任意のユーザーのタスクのキャンセル
  • 任意のユーザーによるタスクのキャンセル
誰が実行したタスクかにかかわらず、実行中のXenServerタスクをキャンセルできます。
プール管理
  • プールプロパティ（名前、デフォルトSR）の設定
  • 高可用性の有効化、無効化、および設定
  • 各仮想マシンの再起動優先度の設定
  • 障害回復の設定、フェイルオーバー、フェイルバック、およびフェイルオーバーテストの実行
  • ワークロードバランス（WLB）の有効化、無効化、および設定
  • プールへのサーバーの追加とプールからの削除
  • メンバのマスタへの変換（pool-emergency-transition-to-master）
  • マスタアドレスの指定（pool-emergency-reset-master master-address）
  • マスタアドレスのメンバへの通知（pool-recover-slaves）
  • 新しいマスタの指定
  • プールおよびサーバー証明書の管理
  • パッチの適用
  • サーバープロパティの設定
  • サーバーのログ機能の設定
  • サーバーの有効化および無効化
  • サーバーのシャットダウン、再起動、および電源投入
  • ツールスタックの再起動
  • システム状態のレポート
  • ライセンスの適用
  • すべての仮想マシンのほかのサーバー上へのライブマイグレーション（WLB、保守モード、または高可用性での操作）
  • サーバーの管理インターフェイスの設定
  • サーバー管理の無効化
  • クラッシュダンプの削除
  • ネットワークの追加、変更、および削除
  • PBD/PIF/VLAN/ボンディング/ストレージリポジトリの追加、変更、および削除
役割の割り当て/変更
高度な仮想マシン操作
  • 仮想マシンメモリの調整（動的メモリ制御）
  • メモリを含んだスナップショット作成、スナップショット作成、および仮想マシンのロールバック
  • 仮想マシンの移行
  • 仮想マシンの起動（起動サーバーの指定を含む）
  • 仮想マシンの再開
サーバーコンソールへのログイン
仮想マシンの作成/破棄操作
  • 仮想マシンのインストールおよび削除
  • 仮想マシンの複製/コピー
  • 仮想ディスク/CDデバイスの追加、削除、および設定
  • 仮想ネットワークデバイスの追加、削除、および設定
  • XVAファイルのインポート/エクスポート
  • 仮想マシン設定の変更

サーバーのバックアップ/復元と仮想マシンの作成/破棄操作

仮想マシンのCDメディアの変更
  • CDのイジェクト
  • CDの挿入
OVF/OVAパッケージのインポート/エクスポートとディスクイメージのインポート
仮想マシンの電源状態の変更
  • 仮想マシンの起動（自動配置）
  • 仮想マシンのシャットダウン
  • 仮想マシンの再起動
  • 仮想マシンの一時停止
  • 仮想マシンの再開（自動配置）
接続中のユーザーのログアウト
仮想マシンコンソールの表示
  • 仮想マシンコンソールの表示と操作
アラートの作成/解除
WLBの設定、初期化、有効化、および無効化
  • WLBの設定
  • WLBの初期化とWLBの変更
  • WLBの有効化
  • WLBの無効化
任意のユーザーのタスクのキャンセル
WLB最適化推奨項目の適用
  • ［WLB］タブに表示されるすべての最適化推奨項目の適用
プール管理
WLBレポートサブスクリプションの変更
  • 生成するWLBレポートおよびその送信先の変更
高度な仮想マシン操作
WLB配置推奨項目の承諾
  • ワークロードの配置先として（「星」で）提示された推奨サーバーからの選択
仮想マシンの作成/破棄操作
WLB設定の表示
  • プールのWLB設定の表示（［WLB］タブ）
仮想マシンのCDメディアの変更
WLBレポートの生成
  • プール監査記録レポートを含むWLBレポートの表示および実行
仮想マシンの電源状態の変更
XenCenterの表示管理操作
  • グローバルXenCenterフォルダの作成および変更
  • XenCenterカスタムフィールドの作成および変更
  • グローバルXenCenter検索クエリの作成および変更
仮想マシンコンソールの表示
自分のタスクのキャンセル
  • 自分で実行したタスクのキャンセル
WLBの設定、初期化、有効化、および無効化
監査ログの表示
  • XenServer監査ログのダウンロード
WLB最適化推奨項目の適用
プールへの接続およびすべてのプールメタデータの読み取り
  • プールへのログイン
  • プールメタデータの表示
  • パフォーマンスの履歴データの表示
  • ログインユーザーの表示
  • ユーザーおよび役割の表示
  • タスクの表示
  • メッセージの表示
  • イベントの登録および受信
WLBレポートサブスクリプションの変更


ドメインへの参加とユーザーの追加

管理者のユーザーアカウントやグループアカウントにRBAC役割を割り当てるには、そのアカウントをXenServerに追加する必要があります。 これを行うには、以下の2つのタスクを実行します。

  1. プールまたはサーバーをドメインに追加する。 この場合、目的のユーザーやグループの所属ドメインか、そのドメインと同じActive Directoryフォレスト内にあるか信頼関係が設定されているドメインにプールやサーバーを追加する必要があります。
  2. ユーザーのActive DirectoryアカウントまたはグループをXenServerに追加する。

無償のXenServer製品およびXenServer Advanced Editionでは、ユーザーのActive DirectoryアカウントまたはグループをXenServerに追加すると、そのユーザーに自動的にプール管理者の役割が割り当てられます。 XenServer Enterprise Editionおよびそれ以上のエディションでは、管理者がユーザーやグループに役割を割り当てる必要があります。

ドメインを変更するには、現在のドメインから脱退して新しいドメインに参加する必要があります。

XenServerまたはプールをドメインに追加するには

  1. リソースペインで、アクセス許可を付与する対象プールまたはサーバーを選択します。
  2. ［ユーザー］タブをクリックします。
  3. ［ドメインに追加］をクリックします。
  4. サーバーを追加するためのActive Directory資格情報を入力します。 追加先のドメインを、NetBIOS名ではなく完全修飾ドメイン名（FQDN）で指定します。 たとえば、「your_domain」ではなく「your_domain.net」と入力します。

Active Directoryのユーザーまたはグループをプールに追加するには

  1. ユーザーのドメインにプールまたはサーバーを追加した後で、［ユーザー］タブの［追加］をクリックします。
  2. ［ユーザーの追加］ダイアログボックスで、ユーザーやグループの名前を入力します。 コンマで区切って複数の項目を入力できます。 信頼関係が設定されたほかのドメインのユーザーを指定するには、ドメイン名とユーザー名を「other_domain\jsmith」形式またはFQDN（「jsmith@other_domain.com」形式）で入力します。
  3. ［アクセスを付与］をクリックします。
  4. 「ユーザーおよびグループへの役割の割り当て」の説明に従って役割を割り当てて、XenServer Enterprise Editionおよびそれ以上のエディションでのアクセス許可を制御します。

XenServerまたはプールをドメインから削除するには

注： ドメインからホストやプールを削除する（つまりActive Directory認証を無効にしてプールまたはホストとドメインとの接続を切断する）と、Active Directoryの資格情報でログインした管理者ユーザーが切断されます。
  1. リソースペインで、Active Directoryドメインから削除するプールまたはサーバーを選択します。
  2. ［ドメインから削除］をクリックし、さらに［はい］をクリックします。
  3. サーバーを削除するためのActive Directory資格情報を入力します。
  4. Active Directoryサーバーでコンピュータアカウントを無効にするかどうかを指定します。
    • 無効化： プールまたはサーバーをドメインから削除して、そのプールマスタまたはサーバーのコンピュータアカウントをActive Directoryデータベース内で無効にします。
    • 無視： ユーザー名やパスワードを入力しなかった場合、またはActive Directoryデータベースからプールマスタやサーバーのコンピュータアカウントを削除するためのアカウント情報が不明な場合は、このオプションを選択します （これにより、プールまたはサーバーがドメインから削除され、そのプールマスタまたはサーバーのコンピュータアカウントがActive Directoryで無効になります）。


ユーザーおよびグループへの役割の割り当て

XenServerを管理するすべてのユーザーには、RBAC役割が割り当てられている必要があります。 XenServer 6.2.0では、管理者ユーザーを作成した後で役割を割り当てないと、そのアカウントは使用できません。 役割が自動的に割り当てられないことに注意してください。 このため、これらのユーザーにXenServerリソースプールへのアクセスを許可するには、いずれかの役割を割り当てる必要があります。

XenServer 6.1.0およびそれ以前のバージョンでの役割の割り当て

XenServer 6.1.0およびそれ以前のバージョンでは、新しい管理者を追加すると、プール管理者の役割が自動的に割り当てられます。 ただし、XenServer Enterprise Editionおよびそれ以上のエディションでは、追加された管理者に役割は自動的に割り当てられません。 既存の管理者が個別に役割を割り当てる必要があります。

注： ユーザーやグループに役割を割り当てるには、そのユーザーやグループをActive Directoryドメインに追加して、そのアカウントをXenServerに追加する必要があります。詳しくは、「ドメインへの参加とユーザーの追加」を参照してください。

ユーザーに割り当て済みの役割を変更するには、次のいずれかを行います。

  1. XenCenterの［役割の選択］ダイアログボックスで、ユーザーに割り当てる役割を変更します。 これを行うには役割の割り当て/変更権限が必要であり、この権限はプール管理者のみに付与されます。
  2. そのユーザーのグループメンバシップを変更して、必要な役割が割り当てられているActive Directoryグループにユーザーを追加します。

ユーザーが複数のグループに属している場合など、複数の役割が割り当てられたユーザーには、自動的により権限の強い役割が適用されます。

ユーザーやグループの役割を変更したり割り当てたりするには

  1. リソースペインで、ユーザーやグループを含んでいるリソースプールまたはサーバーを選択します。
  2. ［ユーザー］タブをクリックします。
  3. ［アクセスが付与されたユーザーおよびグループ］の一覧で、ユーザーまたはグループを選択します。
  4. ［役割の変更］をクリックします。
  5. ［役割の選択］ダイアログボックスで、ユーザーに割り当てる役割を選択して［保存］をクリックします。 各役割で許可される管理タスクについては、「RBAC役割の定義とアクセス権」を参照してください。
    ヒント： 一覧でユーザーを選択して役割を割り当てるときに、Ctrlキーを押しながら複数のユーザーを選択できます。
  6. （オプション） リソースプールにログオン済みのユーザーの役割を変更する場合、新しい役割をすぐに適用するには［ユーザーをログアウト］をクリックします。 これにより、そのユーザーのプールに対するすべてのセッションが切断されます。ユーザーがそのプールに再接続すると、新しい役割が適用されます。
    注： 新しい役割を適用するには、そのユーザーがログアウトして再ログインする必要があります。 ［ユーザーをログアウト］ボタンを使用すると、ユーザーを強制的にログアウトできます （ただしアクティブなユーザー接続のログアウト権限が必要であり、この権限はプール管理者とプールオペレータに付与されます）。


XenServerにログインしたユーザーのアクセス許可の決定プロセス

XenServerにログインしたユーザーのアクセス許可の決定プロセス

  1. Active Directoryサーバーがサブジェクトを認証します。 認証時に、そのサブジェクトがほかのActive Directoryグループに属しているかどうかもチェックされます。
  2. XenServerが、（a）そのサブジェクト、および所属する（b）Active Directoryグループにどの役割が割り当てられているかを検証します。
  3. XenServerが、そのサブジェクトに割り当てられている最も高いレベルのアクセス許可を適用します。 サブジェクトが複数のActive Directoryグループに属している場合は、割り当てられている役割のすべてのアクセス許可がそのサブジェクトに継承されます。

この図で、Subject 2（Group 2）はプールオペレータで、User 1はGroup 2に属しています。このため、Subject 3（User 1）がログインすると、Subject 3（VMオペレータ）およびGroup 2（プールオペレータ）の役割が継承されます。 ただし、プールオペレータの役割レベルの方が高いため、Subject 3（User 1）は（VMオペレータではなく）プールオペレータになります。


監査履歴

XenServerの監査ログはデフォルトで有効になっており、特定の管理者ユーザーにより実行される管理操作（成功したものおよび失敗したもの）が記録されます。 以下のものが含まれます。

  • 操作を実行した管理者のユーザー名。 ユーザー名を取得できない場合はユーザーIDが記録されます。
  • 操作の対象サーバーの名前。
  • 操作の実行状態。成功したか失敗したか。およびその操作の実行が許可されたかどうか。操作に失敗した場合はそのエラーコードが記録されます。

監査ログはデフォルトで有効になります。 監査ログをバックアップするには、XenServerのsyslogコマンドを使用してログを安全な場所にコピーします。 このコマンドはCLIで実行します。詳しくは、『XenServer管理者ガイド』を参照してください。

監査ログ機能を使用するために管理者に役割を割り当てたりActive Directoryを使用したりする必要はありませんが、役割ベースのアクセス制御（RBAC）を実装することをお勧めします。

XenServerの監査ログでは、プールに対する操作が記録され、そのプールのマスタ上にログファイルが作成されます。

監査ログを表示するには、2つの方法があります。

  • ワークロードバランスが有効な場合は、プール監査記録を生成する。
  • テキストエディタでログファイルを開く。 ログファイルはプールマスタ上に格納されています。


ワークロードバランスについて

重要： ワークロードバランス機能（WLB）は、XenServer Version 6.2およびこれ以降のバージョンでは削除されています。 WLBの機能を使用するアプリケーションやコードなどは、XenServer Version 6.2およびこれ以降のバージョンでは使用できません。 詳しくは、CTX137333を参照してください。

ワークロードバランスは、リソースプール内の最適なサーバーに仮想マシンを移行することでプールのワークロードを分散させるためのXenServerの機能で、ワークロードバランス仮想アプライアンスにより提供されます。 ワークロードバランスでは、以下のようにワークロードが最適化されます。

  • 仮想マシンのワークロードをリソースプール内のホスト間で分散させる。
  • 仮想マシンを起動するときに、最適なサーバーを決定する。
  • シャットダウンした仮想マシンを起動するときに、最適なサーバーを決定する。
  • サーバーを保守モードにしたときに、そのサーバー上の各仮想マシンの移行先として最適なサーバーを決定する。
注： ワークロードバランス機能は、Citrix XenServer Enterprise Editionおよびそれ以上のエディションで使用可能です。 XenServerの各エディションについて詳しくは、ここを参照してください。

ワークロードバランスによるワークロードの最適化や集約化は、自動的に実行されるようにしたり、管理者が選択的に実行できるようにしたりできます。 また、特定のスケジュールに従ってサーバーの電源が自動的に切断されるように設定することもできます（夜間の使用電力を抑える場合など）。

ワークロードバランスは、プール内の仮想マシンの負荷を評価し、いずれかのしきい値に達した場合にそのサーバー上の仮想マシンを同一プール内のほかのサーバーに移行します。

ワークロードバランスでは、最適化の対象としてパフォーマンスまたは密度を選択できます。 これらの最適化モードは、特定のスケジュールに従って自動的に切り替えることもできます。 また、各リソース負荷の測定基準（CPU、ネットワーク、メモリ、およびディスク）のしきい値および重要度を調節して、環境に適した最適化が行われるように設定できます。

リソースプールの能力を評価するには、ワークロードバランスの履歴レポートを参照して、リソースプールやホストのヘルス状態、最適化や仮想マシンのパフォーマンス、および仮想マシンの移行履歴を確認します。


ワークロードバランス：はじめに

重要： ワークロードバランス機能（WLB）は、XenServer Version 6.2およびこれ以降のバージョンでは削除されています。 WLBの機能を使用するアプリケーションやコードなどは、XenServer Version 6.2およびこれ以降のバージョンでは使用できません。 詳しくは、CTX137333を参照してください。

ワークロードバランス機能を使用できるXenServerエディションでこの機能を使用する場合は、ワークロードバランス仮想アプライアンスをダウンロードして、以下の手順に従ってセットアップします。

  1. MyCitrix.comからワークロードバランス仮想アプライアンスパッケージをダウンロードして、XenCenterを使ってインポートします。
  2. インポートした仮想アプライアンスの［コンソール］タブに表示されるウィザードの手順に従って、ワークロードバランス仮想アプライアンスを設定します。
  3. 「ワークロードバランスに接続する」の説明に従って、リソースプールをワークロードバランス仮想アプライアンスに接続します。

    これらの手順について詳しくは、『ワークロードバランスクイックスタート』を参照してください。

注： ワークロードバランス機能は、Citrix XenServer Enterprise Editionおよびそれ以上のエディションで使用可能です。 XenServerの各エディションについて詳しくは、ここを参照してください。


ワークロードバランスの基本概念

重要： ワークロードバランス機能（WLB）は、XenServer Version 6.2およびこれ以降のバージョンでは削除されています。 WLBの機能を使用するアプリケーションやコードなどは、XenServer Version 6.2およびこれ以降のバージョンでは使用できません。 詳しくは、CTX137333を参照してください。

ワークロードバランスでは、仮想マシンと物理マシンのリソースパフォーマンスに関するデータが収集されます。 これらのデータと管理者による設定に基づいて、リソースプールを最適化するために仮想マシンをどのサーバーに再配置（移行）するかが計算され、推奨項目として提示されます。 ワークロードバランスでは、パフォーマンスデータが内部データベースに格納されます。このため、ワークロードバランスの動作期間が長くなると、より正確な推奨項目が提供されるようになります。

ワークロードバランスによる推奨項目では、リソースプールの稼働効率（パフォーマンスまたは密度）を最適化するために、仮想マシンのワークロードをプール内でどのように再配置するかが示されます。 ワークロードバランスでは、以下のいずれかの最適化モードを選択できます。

  • パフォーマンス：サーバー上の物理リソース（CPU、メモリ、ネットワーク、およびディスク）の使用効率を最適化します。 ワークロードバランスでパフォーマンスの最適化を選択すると、各仮想マシンが使用できるリソースの量が最大になるように再配置の推奨項目が作成されます。
  • 密度：サーバー上で実行される仮想マシンの数を最適化します。 ワークロードバランスで密度の最適化を選択すると、仮想マシンの計算能力を維持したまま、1台のサーバー上により多くの仮想マシンを配置して、リソースプール内で稼働するサーバーの数を最小化できます。

管理者は、最適化モード（パフォーマンスまたは密度）、電源管理機能、自動処理機能、測定基準の重要度、およびパフォーマンスしきい値を設定してワークロードバランスの動作を制御できます。

ワークロードバランスにより、高可用性機能の動作が影響を受けることはありません。両機能の設定が競合する場合は、常に高可用性機能の設定が優先されます。


ワークロードバランスに接続する

重要： ワークロードバランス機能（WLB）は、XenServer Version 6.2およびこれ以降のバージョンでは削除されています。 WLBの機能を使用するアプリケーションやコードなどは、XenServer Version 6.2およびこれ以降のバージョンでは使用できません。 詳しくは、CTX137333を参照してください。

ワークロードバランス仮想アプライアンスをインポートして、ウィザードの手順に従って設定したら、リソースプールをその仮想アプライアンスに接続します。 これを行うには、XenCenterの［WLBサーバーへの接続］ダイアログボックスまたはXEコマンドを使用します。

要件

XenCenterでワークロードバランス仮想アプライアンスに接続するには、以下の情報が必要です。

  • ワークロードバランス仮想アプライアンスのIPアドレスまたは完全修飾ドメイン名（FQDN）、およびポート。
  • ワークロードバランスで監視するリソースプール（プールマスタ）の資格情報。
  • ワークロードバランス仮想アプライアンス上で作成したアカウントの情報。 このアカウントは、「ワークロードバランスユーザーアカウント」と呼ばれます。 このアカウントを使用して、XenServerがワークロードバランスと通信します （このアカウントは、ワークロードバランス仮想アプライアンスの設定時に作成します）。

［WLBサーバーへの接続］ダイアログボックスでワークロードバランス仮想アプライアンスのFQDNを指定する場合は、事前に仮想アプライアンスのホスト名をDNSに追加しておく必要があります。 信頼された機関からの証明書を使用する場合は、有効期限のないFQDNまたはIPアドレスを使用してください。

ワークロードバランスに接続した直後では、デフォルトのしきい値および設定に基づいてワークロードが最適化されます。 自動最適化モード、電源管理、および自動処理などの自動化機能は、デフォルトでは無効になっています。

重要： ワークロードバランスをしばらく使用して意図したとおりに推奨項目が生成されない場合は、パフォーマンスしきい値の設定を再評価することを強くお勧めします。「パフォーマンスしきい値設定の評価」を参照してください。 運用環境に合ったしきい値を設定することで、より適切な推奨項目が作成されるようになります。

ワークロードバランス仮想アプライアンスに接続するには

  1. XenCenterのリソースペインで、［XenCenter］ > <リソースプール名>の順に選択します。
  2. プロパティペインの［WLB］タブをクリックします。
  3. ［WLB］タブの［接続］をクリックします。 ［WLBサーバーへの接続］ダイアログボックスが開きます。
  4. ［サーバーのアドレス］セクションで、以下の情報を入力します。
    • ［アドレス］ボックスに、ワークロードバランスサーバーのIPアドレスまたはFQDNを入力します。 FQDNとは、「WLB-appliance-computername.yourdomain.net」などのアドレスを指します。
    • ［ポート］ボックスにポート番号を入力します。 このポートを使用して、XenServerがワークロードバランスと通信します

      デフォルトでは、XenServerはワークロードバランスサーバー（この場合はWeb Service Hostサービス）にポート8012で接続します。 ワークロードバランス仮想アプライアンスの設定時にポートを変更した場合は、［ポート］ボックスにそのポート番号を入力します。

      重要： ワークロードバランス仮想アプライアンスの設定時にポート番号を変更していない場合は、ここで変更しないでください。 ［WLBサーバーへの接続］ダイアログボックスで指定するポート番号は、仮想アプライアンスの設定時に指定したもの（およびファイアウォールで指定されたもの）と一致する必要があります。
  5. ［WLBサーバーの資格情報］で、ユーザー名（wlbuserなど）とパスワードを入力します。これらの情報は、XenServerがワークロードバランス仮想アプライアンスに接続するときに使用されます。 これらの資格情報は、ワークロードバランス仮想アプライアンスの設定時に作成したものである必要があります。 デフォルトのユーザー名は、wlbuserです。
  6. ［XenServerの資格情報］セクションで、手順1.で選択したプールにアクセスするためのユーザー名とパスワードを入力します。 これらの情報は、ワークロードバランス仮想アプライアンスがリソースプールの各サーバーに接続するときに使用されます。 ［現在のXenCenterの資格情報を使用する］チェックボックスをオンにすると、XenCenterでこのプールに接続したときの資格情報が適用されます。 役割ベースのアクセス制御（RBAC）で役割を割り当てたアカウントを使用する場合は、そのアカウントにワークロードバランス機能の管理許可が付与されていることを確認してください。 詳しくは、「RBAC役割の定義とアクセス権」を参照してください。
  7. ワークロードバランス仮想アプライアンスに接続したら、必要に応じてパフォーマンスしきい値や特定のリソースの優先度を変更できます。詳しくは、「ワークロードバランス設定の変更」を参照してください。


ワークロードバランスの基本タスク

重要： ワークロードバランス機能（WLB）は、XenServer Version 6.2およびこれ以降のバージョンでは削除されています。 WLBの機能を使用するアプリケーションやコードなどは、XenServer Version 6.2およびこれ以降のバージョンでは使用できません。 詳しくは、CTX137333を参照してください。

ワークロードバランスは、電源管理、最適化モードのスケジュール化、レポート生成など、XenServer環境のワークロードを最適化するための多くの機能を持つ、強力なXenServerコンポーネントです。 管理者は、各リソース負荷の測定基準を微調整して、適切な最適化推奨項目が生成されるようにワークロードバランス機能を設定できます。

ワークロードバランスが有効なリソースプールでは、管理者は日常的に以下の2つの基本タスクを実行することになります。

  • 仮想マシンの起動に最適なサーバーを決定する。
  • ワークロードバランスにより提示された推奨項目を適用する

ワークロードバランスを使用するために必要なワークロードバランス仮想アプライアンスの入手および設定について詳しくは、『ワークロードバランスクイックスタート』を参照してください。

仮想マシンの起動に最適なサーバーを決定する

「仮想マシンの初期配置、移行、および再開に適したサーバーの選択」も参照してください。

ワークロードバランスが有効なリソースプールでは、シャットダウンまたは一時停止状態の仮想マシンを起動するとき、または仮想マシンを移行するときに、最適なサーバーが推奨項目として示されます。 この機能は、XenDesktop環境でも有用です。

ワークロードバランスの推奨項目を適用する

「最適化推奨項目の適用」も参照してください。

ワークロードバランスをしばらく使用すると、環境を最適化するための推奨項目が生成されるようになります。 たとえば、サーバー上の仮想マシン密度を最適化するようにワークロードバランスを設定すると、実行されている仮想マシンをより少ない数のサーバー上に集約するための推奨項目が生成されます。 自動モードを有効にしていない場合、生成された推奨項目を適用するかどうかを管理者が選択できます。

これらの基本タスクについては、本書の該当トピックで詳しく説明されています。 これらのタスクに加えて、環境のワークロードに関するレポート生成も頻繁に使用される機能です。この機能については、「ワークロードバランスレポートの生成と管理」を参照してください。

重要： ワークロードバランスをしばらく使用して意図したとおりに推奨項目が生成されない場合は、パフォーマンスしきい値の設定を再評価することを強くお勧めします。方法については、『ワークロードバランス管理者ガイド』を参照してください。 運用環境に合ったしきい値を設定することで、より適切な最適化推奨項目が作成されるようになります。


仮想マシンの初期配置、移行、および再開に適したサーバーの選択

重要： ワークロードバランス機能（WLB）は、XenServer Version 6.2およびこれ以降のバージョンでは削除されています。 WLBの機能を使用するアプリケーションやコードなどは、XenServer Version 6.2およびこれ以降のバージョンでは使用できません。 詳しくは、CTX137333を参照してください。

ワークロードバランスが有効なリソースプールでは、オフライン状態の仮想マシンを再起動するときに、推奨起動サーバーとして最適な物理サーバーがXenCenterにより提示されます。 推奨起動サーバーは、星の数で示されます。

仮想マシンの推奨起動サーバーとして、host17が星の数で示されています。サーバーhost16には星が表示されておらず、仮想マシンの起動サーバーとして推奨されていません。ただし、このサーバーは選択可能なので、必要に応じて仮想マシンを起動することができます。host18には十分なメモリがないため、選択できない状態になっています。

仮想マシンの再配置

ワークロードバランスが有効なリソースプールでは、シャットダウンまたは一時停止状態の仮想マシンを起動するとき、または仮想マシンを移行するときに、最適なサーバーをXenCenterで確認できます。

この機能では、推奨ホストの評価が星の数で示されます。 ホスト名の横に白抜きの星（☆）が5つ表示される場合は、仮想マシンのホストとして最も不適切であることを意味します。 仮想マシンの起動または移行先のサーバーとして使用できないサーバーの名前はメニューで淡色表示され、選択できません。

通常、ワークロードバランスで推奨されたホスト上で仮想マシンを起動すると、より効率的に推奨項目が生成され、不要な推奨項目が生成されなくなります。

推奨起動サーバーとは

推奨起動サーバーとは、ワークロードのホストとして最適な物理サーバーを指します。 ワークロードバランスは、以下の点を考慮して推奨起動サーバーを決定します。

  • プール内の各サーバーで使用可能なリソース量。 最適化モードとしてパフォーマンスの最大化が選択されている場合、すべての仮想マシンが良好なパフォーマンスで動作するように、各ホスト上にバランス良く仮想マシンを配置しようとします。 密度の最大化が選択されている場合は、仮想マシンのリソースを維持したまま、サーバー上により多くの仮想マシンを配置しようとします。
  • プールで選択されている最適化モード（パフォーマンスの最大化または密度の最大化）。 パフォーマンスの最大化が選択されている場合、その仮想マシンが必要とするリソースの負荷が最も低いサーバーにその仮想マシンを配置しようとします。 密度の最大化が選択されている場合は、既に多くの仮想マシンをホストしているサーバーに仮想マシンを配置して、仮想マシンの実行サーバーの数を少なくしようとします。
  • その仮想マシンが必要とするリソースの量。 ワークロードバランスは、収集した仮想マシンの測定値を使用して、その仮想マシンが必要とするリソースの種類に応じて推奨起動サーバーを決定します。 たとえば、メモリリソースを必要とする仮想マシンについては、使用可能なCPUリソース量よりも空きメモリ量を優先して起動サーバーを決定します。 ただし、推奨起動サーバーの決定は、その仮想マシンを現在実行しているサーバーでリソース負荷が高いことが検出された場合にのみ行われます。

仮想マシンを最適なサーバーで起動するには

  1. XenCenterのリソースペインで、起動する仮想マシンを選択します。
  2. ［VM］メニューの［起動サーバー］を選択し、以下のいずれかを選択します。
    • 最適なサーバー： 選択した仮想マシンで要求されるリソースを持つ、ホストとして最も適したサーバーです。 ワークロードバランスでは、パフォーマンス測定値の履歴レコードと選択されている最適化モードに基づいて最適なサーバーが決定されます。 最適なサーバーの名前には、最も多くの星が表示されます。
    • ［最適なサーバー］の下に表示されるサーバー： 5つの星が表示されるサーバーは最も推奨されるサーバー（最適なサーバー）を示し、5つの白抜きの星が表示されるサーバーは推奨されないサーバーを示します。

仮想マシンを最適なサーバーで再開するには

  1. XenCenterのリソースペインで、再開する仮想マシンを選択します。
  2. ［VM］メニューの［再開サーバー］を選択し、以下のいずれかを選択します。
    • 最適なサーバー： 選択した仮想マシンで要求されるリソースを持つ、ホストとして最も適したサーバーです。 ワークロードバランスでは、パフォーマンス測定値の履歴レコードと選択されている最適化モードに基づいて最適なサーバーが決定されます。 最適なサーバーの名前には、最も多くの星が表示されます。
    • ［最適なサーバー］の下に表示されるサーバー： 5つの星が表示されるサーバーは最も推奨されるサーバー（最適なサーバー）を示し、5つの白抜きの星が表示されるサーバーは推奨されないサーバーを示します。


最適化推奨項目の適用

重要： ワークロードバランス機能（WLB）は、XenServer Version 6.2およびこれ以降のバージョンでは削除されています。 WLBの機能を使用するアプリケーションやコードなどは、XenServer Version 6.2およびこれ以降のバージョンでは使用できません。 詳しくは、CTX137333を参照してください。

ワークロードバランスでは、リソースプールを最適化するために仮想マシンをどのように再配置（移行）すべきであるかというアドバイスが推奨項目として生成されます。 この推奨項目は、XenCenterの［WLB］タブに表示されます。

この図は、［WLB］タブに表示される［最適化の推奨項目］の一覧を示しています。 ［理由］列には、その推奨項目の目的が示されます。 ［操作］列には、最適化を達成するために推奨される操作の内容が示されます。 この場合、仮想マシンHA-prot-VM-7およびサーバーhost17.domain4.bedford4.ctx4に対する推奨項目が表示されています。

最適化推奨項目の基本

ワークロードバランスでは、以下の条件に基づいて推奨項目が生成されます。

  • 管理者が設定する最適化モード（「最適化モードの変更」を参照）。
  • 物理サーバー上のCPU、メモリ、ネットワーク、およびディスクについて収集されたパフォーマンス測定値。
  • リソースプール内でのホストの役割。 プールマスタ上にワークロードを配置する推奨項目は、ほかのサーバー上への配置が不可能な場合のみ生成されます （同様に、最適化モードとして密度の最大化が選択されているプールでは、仮想マシンの移行先としてプールマスタが選択されるのは最後になります）。

最適化推奨項目では、再配置すべき仮想マシン、その仮想マシンを実行しているホスト、および推奨される新しいホストが示されます。 また、仮想マシンの再配置が推奨される理由（CPU使用率の場合は「CPU」など）も示されます。

推奨項目を適用すると、その内容に基づいてすべての仮想マシンが自動的に移行されます。

ヒント： リソースプールに設定されている最適化モードを確認するには、XenCenterでそのリソースプールを選択して、［WLB］タブの［設定］セクションを参照します。

最適化推奨項目を適用するには

  1. リソースペインでリソースプールを選択して、［WLB］タブをクリックします。 選択したリソースプールの最適化が必要な場合は、［最適化の推奨項目］に内容が表示されます。
  2. 推奨項目を適用するには、［すべて実行］をクリックします。 ［最適化の推奨項目］の推奨項目に基づいて、すべての仮想マシンが移行されます。

    ［すべて実行］をクリックしたら、［ログ］タブで仮想マシンの移行状況を確認できます。

高可用性環境でのワークロードバランス

ワークロードバランス機能とXenServer高可用性機能が有効なリソースプールでは、これらの2つの機能が相互にどのように影響するかを理解する必要があります。 ワークロードバランスは、高可用性機能と競合しないように設計されています。 ワークロードバランスで生成される推奨項目と高可用性設定が競合する場合は、常に高可用性機能の設定が優先されます。 つまり、以下のようになります。

  • ［高可用性の設定］ダイアログボックスの［許可する障害数］ボックスの値を超える数のホストは、ワークロードバランスにより自動的に電源が切断されることはありません。
    • ただし、電源を切断することが推奨項目として提示される場合があります。 たとえば、高可用性で許可する障害数として1が設定されている場合に、ワークロードバランスにより2台のホストのシャットダウンが推奨されることがあります。 この推奨項目を適用しようとすると、「高可用性が保証されなくなる」という内容のエラーメッセージが表示されます。
    • 自動モードでワークロードバランスが動作する場合は、電源管理を有効にしても、高可用性で許可する障害数を超える数の推奨項目は無視されます。 この場合、ワークロードバランスのログファイルに「高可用性が有効なため電源管理推奨項目を適用できない」という内容のメッセージが記録されます。


ワークロードバランスレポート

重要： ワークロードバランス機能（WLB）は、XenServer Version 6.2およびこれ以降のバージョンでは削除されています。 WLBの機能を使用するアプリケーションやコードなどは、XenServer Version 6.2およびこれ以降のバージョンでは使用できません。 詳しくは、CTX137333を参照してください。

ここでは、ワークロードバランスの履歴レポートと、これらのレポートに関する追加情報の参照先について説明します。

ワークロードバランスレポートを生成するには、ワークロードバランス仮想アプライアンスをインポートして、リソースプールをその仮想アプライアンスに接続しておく必要があります。

はじめに

ワークロードバランスでは、物理ホスト、リソースプール、および仮想マシンに関するレポートを生成できます。 以下の2種類のレポートが作成されます。

  • 日別データを表示する履歴レポート
  • ロールアップスタイルのレポート

ワークロードバランスでは、仮想マシンの移行回数などを記録した監査用のレポートも作成できます。

レポートの種類

ワークロードバランスでは、リソースプール、サーバー、および仮想マシンに関するいくつかの種類のレポートを生成できます。 詳しくは、「ワークロードバランスレポートの種類について」を参照してください。

レポートの生成

ワークロードバランスでは、レポートを生成して、PDFやスプレッドシートとしてエクスポートしたり印刷したりできます。 詳しくは、「ワークロードバランスレポートの生成と管理」を参照してください。


ワークロードバランスレポートの使用

重要： ワークロードバランス機能（WLB）は、XenServer Version 6.2およびこれ以降のバージョンでは削除されています。 WLBの機能を使用するアプリケーションやコードなどは、XenServer Version 6.2およびこれ以降のバージョンでは使用できません。 詳しくは、CTX137333を参照してください。

ワークロードバランスレポートを使用すると、リソースプールの能力を評価したり、仮想マシンのヘルス状態を確認したり、設定したパフォーマンスしきい値の効果を評価したりできます。

パフォーマンスしきい値設定の評価

プールヘルスレポートを使用して、設定したしきい値の効果を評価できます。 ワークロードバランスでは各パフォーマンスしきい値にデフォルト値が設定されますが、 環境によっては調整が必要な場合があります。 これを行わないと、ワークロードバランスで適切な推奨項目が生成されません。

管理者による変更に対するトラブルシューティング

管理者による変更により何らかの問題が発生した場合は、プール監査記録レポートを参照して変更担当者（変更した管理者のユーザーアカウント）や変更内容を確認します。


ワークロードバランスレポートの生成と管理

重要： ワークロードバランス機能（WLB）は、XenServer Version 6.2およびこれ以降のバージョンでは削除されています。 WLBの機能を使用するアプリケーションやコードなどは、XenServer Version 6.2およびこれ以降のバージョンでは使用できません。 詳しくは、CTX137333を参照してください。

ここでは、ワークロードバランス機能のレポートの生成、サブスクリプション、表示、印刷、およびエクスポートなど、基本的な使用方法について説明します。

ワークロードバランスレポートを生成するには

  1. XenCenterのリソースペインで、リソースプールを選択します。
  2. ［プール］メニューの［ワークロードレポートを表示］を選択します。
    ヒント： ［WLB］タブの［レポート］をクリックすることでも［ワークロードレポート］ダイアログボックスを開くことができます。
  3. ［ワークロードレポート］ダイアログボックスの［レポート］ペインの一覧で、生成するレポートの種類を選択します。
  4. ［開始日］および［終了日］を使用して、レポート期間を指定します。 選択したレポートの種類によっては、［ホスト］ボックスの一覧でレポート対象のホストを選択します。
  5. ［レポートの実行］をクリックします。 ワークロードバランスレポートが生成されます。

ワークロードバランスレポートを使用するには

レポートを生成したら、ツールバーのボタンを使用してさまざまなタスクを実行できます。 ツールバーのボタンの名前は、マウスポインタをそのボタンに合わせると表示されます。

レポートツールバーのボタン：

ドキュメントマップ： サイズの大きなレポートを表示するときに便利なドキュメントマップが開きます。
ページ操作： レポートの次のページや前のページ、または特定のページを表示できます。
元のレポートに戻る： ドリルスルーレポートから元のレポートに戻ります。
注： このボタンは、プールヘルス履歴レポートなどのドリルスルーレポートでのみ使用可能になります。
生成停止： レポートの生成処理をキャンセルします。
印刷： レポートを印刷します。ページ数や部数など、標準的な印刷オプションを指定できます。
印刷レイアウト： レポートの印刷プレビューを表示します。 印刷プレビューを閉じるには、再度［印刷レイアウト］をクリックします。
ページ設定： 用紙サイズ、印刷の向き、余白などの印刷オプションを指定できます。
エクスポート： Acrobat（PDF）形式またはExcel（XLS）形式のファイルとしてレポートをエクスポートします。
検索： 仮想マシンの名前など、特定の文字列を検索できます。

ワークロードバランスレポートを印刷するには

レポートを印刷するには、まずそのレポートを実行します。

  1. （オプション） ［ [image] 印刷レイアウト］をクリックして、レポートの印刷プレビューを確認します。
  2. （オプション） ［ [image] ページ設定］をクリックして、用紙サイズ、印刷の向き、余白などの印刷オプションを指定します。
  3. ［ [image] 印刷］をクリックします。

ワークロードバランスレポートをエクスポートするには

ワークロードバランスレポートは、Acrobat（PDF）形式またはExcel（XLS）形式のファイルとしてエクスポートできます。

レポートを生成したら、［ [image] エクスポート］をクリックし、以下のいずれかのオプションを選択します。

  • Excel
  • Acrobat（PDF）ファイル
注： レポートをエクスポートする場合のデータ量は、エクスポート形式により異なります。 Excel形式にエクスポートするレポートには、「ドリルダウン」データを含め、すべてのデータが含まれます。XenCenterで表示するレポートおよびPDF形式にエクスポートするレポートには、レポート生成時に選択したデータしか含まれません。


ワークロードバランスレポートの種類について

重要： ワークロードバランス機能（WLB）は、XenServer Version 6.2およびこれ以降のバージョンでは削除されています。 WLBの機能を使用するアプリケーションやコードなどは、XenServer Version 6.2およびこれ以降のバージョンでは使用できません。 詳しくは、CTX137333を参照してください。

ここでは、ワークロードバランスの各レポートについて説明します。

チャージバック使用解析

このレポートでは、組織内の特定の部署で使用されたリソース（物理サーバーなど）の量を確認できます。 具体的には、リソースプール内のすべての仮想マシンのアベイラビリティやリソース使用などの情報が含まれます。 このレポートには仮想マシンのアベイラビリティ（「アップタイム」）が含まれるため、SLA（Service Level Agreement：サービス品質保証契約）に役立てることができます。

このレポートを使用して、課金用のシンプルなチャージバックソリューションを実装できます。 特定リソースの使用代金を顧客に課金するには、レポートを生成してExcelデータとして保存し、そのスプレッドシートをカスタマイズしたり、課金システムにインポートしたりできます。

組織内の部署または外部の顧客に仮想マシンの使用料を請求する場合は、仮想マシンの名前に部署や顧客の名前を含めることを検討します。 これにより、チャージバック使用解析レポートが読みやすくなります。

このレポートのリソース関連のデータは、個々の仮想マシンへの物理リソースの割り当てにより異なる場合があります。

同様に、XenServerではメモリ割り当てを固定したり動的メモリ制御（DMC）機能で自動化したりできるため、メモリの平均データはそのときに仮想マシンに割り当てられているメモリ量により異なります。

チャージバック使用解析レポートには、以下のデータ列が含まれます。

  • VM名： 仮想マシンの名前です。
  • VMアップタイム： 仮想マシンの実行時間（XenCenterで緑色のアイコンで表示される時間）を分単位で示したものです。
  • VCPU割り当て： その仮想マシンに割り当てられている仮想CPUの数です。 各仮想CPUには、そのホストの物理CPUから均等に割り当てられます。 たとえば、2つの物理CPUを持つホストで合計8つの仮想CPUを仮想マシンに割り当てた場合、この列の「1」はそのホストの全体的な処理能力の2/16を示します。
  • 最小CPU使用率（%）： レポート期間内に記録された仮想CPU使用率の最小値です。 この値はその仮想マシンの仮想CPUの能力に対するパーセンテージで示され、仮想CPUの能力はその仮想マシンに割り当てられている仮想CPUの数に基づきます。 たとえば、仮想マシンの作成時に1つの仮想CPUを割り当てた場合、その仮想CPU使用率の最小値が（たとえその継続時間が1秒間であっても）XenServerにより記録され、最小CPU使用率として示されます。 仮想マシンに2つの仮想CPUを割り当てた場合は、それらの合計能力に対する最小使用率が示されます。

    この最小CPU使用率は、仮想CPUが処理した最小ワークロードを示します。 たとえば、2.4GHzの物理CPUを持つサーバーで8つの仮想マシンをホストする場合、1つの仮想マシンに1つのCPUを割り当てると、2.4GHzの1/8、 つまり0.3GHz（300MHz）の能力が割り当てられます。ここで最小CPU使用率が20%であった場合、この仮想マシンでの物理サーバーCPUの最小使用量が60MHzであったことを示します。

  • 最大CPU使用率（%）： レポート期間内に記録された仮想CPU使用率の最大値です。 この値はその仮想マシンの仮想CPUの能力に対するパーセンテージで示され、仮想CPUの能力はその仮想マシンに割り当てられている仮想CPUの数に基づきます。 たとえば、仮想マシンの作成時に1つの仮想CPUを割り当てた場合、その仮想CPU使用率の最大値がXenServerにより記録され、最大CPU使用率として示されます。 仮想マシンに2つの仮想CPUを割り当てた場合は、それらの合計能力に対する最大使用率が示されます。
  • 平均CPU使用率（%）： 平均CPU使用率（%）。 レポート期間内に記録された仮想CPU使用率の平均値です。 この値はその仮想マシンの仮想CPUの能力に対するパーセンテージで示され、仮想CPUの能力はその仮想マシンに割り当てられている仮想CPUの数に基づきます。 仮想マシンに2つの仮想CPUを割り当てた場合は、それらの合計能力に対する平均使用率が示されます。
  • ストレージ割り当て合計（GB）： レポート期間内にその仮想マシンに割り当てられていたディスク容量です。 通常、この値は仮想マシンの作成時に割り当てたディスクのサイズを示します（作成後に変更していない場合）。
  • 仮想NIC割り当て： 仮想マシンに割り当てられている仮想インターフェイス（VIF）の数です。
  • 現在の最小動的メモリ（MB）：
    • 固定メモリ割り当て： 仮想マシンに特定のメモリ量（1024MBなど）を割り当てた場合、以下の列には同じ値が表示されます。現在の最小動的メモリ（MB）、現在の最大動的メモリ（MB）、現在のメモリ割り当て（MB）、および平均メモリ割り当て（MB）。
    • 動的メモリ割り当て： 仮想マシンに動的メモリ範囲を割り当てて自動的に調整されるようにした場合（つまり動的メモリ制御を有効にした場合）は、その範囲の最小メモリ量がこの列に表示されます。 たとえば、XenCenterの［メモリ設定］ダイアログボックスで［自動的に割り当てるメモリ範囲を指定する］オプションを選択し、最小メモリとして1024MB、最大メモリとして2048MBを指定した場合、［現在の最小動的メモリ（MB）］として「1024MB」が表示されます。
  • 現在の最大動的メモリ（MB）：
    • 動的メモリ割り当て： 仮想マシンに動的メモリ範囲を割り当てて自動的に調整されるようにした場合は、その範囲の最大メモリ量がこの列に表示されます。 たとえば、最小メモリとして1024MB、最大メモリとして2048MBを指定した場合、［現在の最大動的メモリ（MB）］として「2048MB」が表示されます。
    • 固定メモリ割り当て： 仮想マシンに特定のメモリ量（1024MBなど）を割り当てた場合、以下の列には同じ値が表示されます。現在の最小動的メモリ（MB）、現在の最大動的メモリ（MB）、現在のメモリ割り当て（MB）、および平均メモリ割り当て（MB）。
  • 現在のメモリ割り当て（MB）：
    • 動的メモリ割り当て： 動的メモリ制御を有効にした場合、レポート期間内に仮想マシンに割り当てられていたメモリ量が表示されます。
    • 固定メモリ割り当て： 仮想マシンに特定のメモリ量（1024MBなど）を割り当てた場合、以下の列には同じ値が表示されます。現在の最小動的メモリ（MB）、現在の最大動的メモリ（MB）、現在のメモリ割り当て（MB）、および平均メモリ割り当て（MB）。
    注： 仮想マシンのメモリ割り当てを変更した直後にこのレポートを実行した場合、この列には変更後の値が表示されます。
  • 平均メモリ割り当て（MB）：
    • 動的メモリ割り当て： 動的メモリ制御を有効にした場合、レポート期間内に仮想マシンに割り当てられていたメモリ量の平均値が表示されます。
    • 固定メモリ割り当て： 仮想マシンに特定のメモリ量（1024MBなど）を割り当てた場合、以下の列には同じ値が表示されます。現在の最小動的メモリ（MB）、現在の最大動的メモリ（MB）、現在のメモリ割り当て（MB）、および平均メモリ割り当て（MB）。
    注： 仮想マシンのメモリ割り当てを変更した直後にこのレポートを実行した場合、この列の値に変更内容が反映されない場合があります。 この列には、指定した期間での平均値が表示されます。
  • 平均ネットワーク読み取り（bps）： レポート期間内に仮想マシンが受信したデータ量（1秒あたりのビット数）の平均値です。
  • 平均ネットワーク書き込み（bps）： レポート期間内に仮想マシンが送信したデータ量（1秒あたりのビット数）の平均値です。
  • 平均ネットワーク使用（bps）： 平均ネットワーク読み取りと平均ネットワーク書き込みの合計データ量（1秒あたりのビット数）です。 たとえば、レポート期間内に仮想マシンが平均1,027bpsのデータを送信し、平均23,831bpsのデータを受信した場合、平均ネットワーク使用の値は24,858bpsになります。
  • ネットワーク使用合計（bps）： レポート期間内に行われたネットワーク読み取りおよび書き込みトランザクションの合計値です。

ホストヘルス履歴

このレポートでは、特定のホスト上のリソース（CPU、メモリ、ネットワーク読み取り、およびネットワーク書き込み）のしきい値に対するパフォーマンスが示されます。

各しきい値は、色つきの線（赤、緑、黄色）で示されます。 このレポートとプールヘルスレポートを使用して、特定ホストのパフォーマンスがリソースプールのパフォーマンスにどう影響しているかを評価できます。 パフォーマンスしきい値を変更する場合は、このレポートでホストのパフォーマンスを確認します。

リソース使用のデータは、日別または時間別の平均値として表示できます。 時間別の平均値では、その日のピーク時刻を確認できます。

時間別のデータを表示するには、［ホストヘルス履歴］タイトルバーの下の［クリックして特定期間内の時間別レポートデータを表示します］をクリックします。

このレポートには、指定した期間の時間別平均値が表示されます。 つまり、データポイントは、指定期間のすべての日の特定時刻の平均使用量に基づいています。 たとえば、2009年5月1日から2009年5月15日までのレポートの場合、［平均CPU使用率］のデータポイントはこの15日間の午後12時のリソース使用の平均を示します。 つまり、5月1日の午後12時のCPU使用率が82%、5月2日の午後12時が88%、残りの日の午後12時がすべて75%だった場合、午後12時の平均値として76.3%が表示されます。

プールの最適化パフォーマンス履歴

このレポートでは、最適化イベント（つまり管理者がリソースプールを最適化したとき）がリソースプールの平均リソース使用に対して示されます。 このレポートに表示されるリソース使用は、CPU、メモリ、ネットワーク読み取り、およびネットワーク書き込みです。

点線は、指定した期間のプール内の平均リソース使用を示します。 青いバーは、プールを最適化した日を示します。

このレポートを使用して、設定したワークロードバランスが意図したとおりに動作しているかどうかを評価できます。 また、何が最適化イベントの原因になっているか（つまりワークロードバランスの推奨項目生成前のリソース使用）を確認できます。

このレポートには、その日の平均リソース使用が表示され、システムに高負荷がかかった場合などのピーク時のデータは表示されません。 また、ワークロードバランスの推奨項目を適用しなかった場合のプールのパフォーマンスを確認することもできます。

通常、最適化イベントの後はリソース使用が低下または安定化しなければなりません。 最適化してもリソース使用が改善しない場合は、しきい値の調整を検討します。 また、リソースプール内の仮想マシンが多すぎないかどうか、指定した期間に仮想マシンの追加や削除がなかったかどうかを確認してください。

プール監査記録

このレポートには、XenServerの監査ログの内容が表示されます。この監査ログには、インポートやエクスポート、サーバーやプールのバックアップ、仮想マシンやサーバーのコンソールへのアクセスなどの操作が記録されます（許可されていない操作を実行しようとした場合も記録されます）。 役割ベースのアクセス制御機能で各XenServer管理者に役割を割り当てた環境では、このレポートでより詳しい情報を取得することができます。 監査ログ機能については、『ワークロードバランス管理者ガイド』を参照してください。

重要： 監査ログレポートを実行するには、監査ログ機能を有効にする必要があります。 デフォルトでは、ワークロードバランス仮想アプライアンスの監査ログ機能が常に有効になっています。 ただし、この監査ログには特定のオブジェクトやアクションに対する一定量のデータしか記録されません。

このレポートに表示される内容は以下のとおりです。

  • 時間： ユーザーアクションの記録日時です。
  • イベントアクション： アクションの内容です。 詳しくは、「監査記録でのイベント名」を参照してください。
  • ユーザー名： そのアクションを実行したときのセッションを作成した管理者のユーザーアカウントです。 ユーザーIDが表示される場合もあります。
  • アクセス： その管理者に当該アクションの実行が許可されていたかどうかが示されます。
  • イベントオブジェクト： アクションの対象オブジェクト（仮想マシンなど）です。
  • オブジェクト名： 対象オブジェクトの名前（仮想マシン名など）です。
  • 成功： アクションの実行結果（成功したかどうか）を示します。

プールヘルス

プールヘルスレポートには、リソースプールおよびそのホストでの時間およびリソースの使用率が表示されます。これらの情報は、限界しきい値、高しきい値、中しきい値、および低しきい値の平均パーセンテージで示されます。 このレポートを使用して、設定したしきい値の効果を評価できます。

このレポートの内容は以下のとおりです。

  • ［中しきい値の平均］（青）は、最適化モードの設定にかかわらず、好ましいリソース使用を示します。 同様に、円グラフの青い部分は、そのサーバーのリソース使用が良好だった期間を示します。
  • ［低しきい値の平均（%）］（緑）は、必ずしも好ましいリソース使用を示すとは限りません。 低しきい値のリソース使用が好ましいかどうかは、最適化モードの設定によって異なります。 たとえば、最適化モードとして［密度を最大化］を選択したリソースプールで、ほとんどの期間のリソース使用が緑で示される場合、ワークロードバランスでホストまたはプールの仮想マシンの密度が最大化されていないことが考えられます。 この場合は、リソース使用の多くが［中しきい値の平均］（青）で示されるようになるまで、パフォーマンスしきい値を調整します。
  • ［限界しきい値の平均（%）］（赤）は、平均リソース使用が限界しきい値以上になった期間を示します。

サーバーのリソース使用の円グラフをダブルクリックすると、そのサーバーのリソース（CPUなど）についてのホストヘルス履歴レポートが表示されます。 プールヘルス履歴レポートに戻るには、ツールバーの［元のレポートに戻る］ボタンをクリックします。 注：このボタンは、プールヘルス履歴レポートなどのドリルスルーレポートでのみ使用可能になります。

このレポートで示される値の大半が［中しきい値の平均］の範囲に収まらない場合は、このリソースプールのパフォーマンスしきい値を調整します。 ワークロードバランスでは各パフォーマンスしきい値にデフォルト値が設定されますが、環境によっては調整が必要な場合があります。 これを行わないと、ワークロードバランスで適切な推奨項目が生成されません。 詳しくは、「しきい値の変更」を参照してください。

注： 高、中、および低しきい値の範囲は、限界しきい値に基づいて自動的に決定されます。

プールヘルス履歴

このレポートでは、リソースプール内のすべての物理サーバーのリソース使用が線グラフで示されます。 これにより、しきい値（限界、高、中、および低）に関して、リソースの使用傾向を確認できます。 このレポートのデータポイントの傾向を監視することで、設定したパフォーマンスしきい値の効果を評価できます。

ワークロードバランスでは、管理者設定した限界しきい値に基づいて、高、中、および低しきい値の範囲が決定されます。 プールヘルスレポートが各しきい値状態で動作した期間を示すのに対し、プールヘルス履歴レポートは日別の平均リソース使用量を示します。

［平均空きメモリ］グラフを除き、データポインタの平均値が限界しきい値（赤線）以下に維持される必要があります。 ［平均空きメモリ］グラフの場合は、データポインタの平均値が限界しきい値（グラフの最下部）以上に維持される必要があります。 これは、このグラフが空きメモリを示すためで、ほかのリソースのしきい値とは異なり、許容最小値を限界しきい値として設定するためです。

このレポートの内容は以下のとおりです。

  • 平均使用量のグラフが［中しきい値の平均］（青線）に近い場合、最適化モードの設定にかかわらず、適切なリソース使用を示します。
  • ［低しきい値の平均］（緑）に近い場合は、必ずしも好ましいリソース使用を示すとは限りません。 低しきい値のリソース使用が好ましいかどうかは、最適化モードの設定によって異なります。 たとえば、最適化モードとして［密度を最大化］を選択したリソースプールで、平均使用量のグラフが多くの日で緑線以下の場合、ワークロードバランスでプールの仮想マシンの密度が最大化されていないことが考えられます。 この場合は、リソース使用の多くが［中しきい値の平均］（青）で示されるようになるまで、パフォーマンスしきい値を調整します。
  • リソースの平均使用のグラフが［限界しきい値の平均（%）］（赤）と交差する個所は、リソースの平均使用が限界しきい値以上になった日を示します。

グラフのデータポイントのうち大半が［中しきい値の平均］範囲外に表示され、それでもプールで良好なパフォーマンスが得られる場合は、パフォーマンスしきい値の調整を検討します。 詳しくは、「しきい値の変更」を参照してください。

プールの最適化履歴

プールの最適化履歴レポートでは、ワークロードバランスによる最適化処理の内容が時系列で示されます。

最適化処理は、グラフおよび表で示されます。 表の［日付］列の［+］をクリックすると、その日に実行された最適化処理の詳細が表示されます。

このレポートの内容は以下のとおりです。

  • VM名： ワークロードバランスにより最適化された仮想マシンの名前です。
  • 理由： 最適化の理由です。
  • 状態： 最適化処理が成功したかどうかを示します。
  • 移動元： 仮想マシンの移行元の物理サーバーです。
  • 移動先： 仮想マシンの移行先の物理サーバーです。
  • 時間： 最適化処理の実行時刻です。
ヒント： プールの最適化履歴レポートは、［WLB］タブの［履歴を表示］をクリックすることでも生成できます。

仮想マシン移動履歴

この線グラフでは、リソースプールでの仮想マシンの移動（移行）数が示されます。 仮想マシンの移行が推奨項目を適用した結果なのかどうか、および移行先のサーバーが表示されます。 また、このレポートでは移行理由も示されます。 このレポートを使用して、リソースプールの仮想マシンの移行を監査できます。

このレポートの内容は以下のとおりです。

  • グラフの左側の数値は、リソースプール内の仮想マシンの数に基づく、可能な移行数を示します。
  • レポートの［日付］列の［+］をクリックすると、その日に実行された移行処理の詳細が表示されます。

仮想マシンパフォーマンス履歴

このレポートでは、特定ホスト上の各仮想マシンのパフォーマンスデータが示されます。 ワークロードバランスでは、仮想マシンに割り当てられた仮想リソースの量に基づいてパフォーマンスデータが評価されます。 たとえば、仮想マシンの［平均CPU使用率］が67%である場合は、特定期間にその仮想マシンで平均67%の仮想CPUが使用されたことを示します。

このレポートの初期表示では、指定した期間でのリソース使用の平均値が示されます。

［+］をクリックすると、各リソースの線グラフが表示されます。 これにより、特定期間でのリソースの使用傾向を確認できます。

このレポートには、CPU使用率、空きメモリ、ネットワーク読み取り/書き込み、およびディスク読み取り/書き込みのデータが表示されます。


監査記録でのイベント名

重要： ワークロードバランス機能（WLB）は、XenServer Version 6.2およびこれ以降のバージョンでは削除されています。 WLBの機能を使用するアプリケーションやコードなどは、XenServer Version 6.2およびこれ以降のバージョンでは使用できません。 詳しくは、CTX137333を参照してください。

次の表は、XenServer監査記録レポートおよびプール監査記録レポートに出力されるイベントを示しています。 イベントに関するより詳しい情報については、『Citrix XenServer Management API』（英文）を参照してください。

プール監査記録レポートの［イベントアクション］列には、プール、仮想マシン、またはサーバーに関するイベントが出力されます。 何に関するイベントかを確認するには、［イベントオブジェクト］列と［オブジェクト名］列を参照してください。

イベントアクション | ユーザーアクション
SR.destroy | ストレージリポジトリの破棄
VM.start | 仮想マシンの起動
http/get_audit_log | 監査ログの取得
reboot | サーバーの再起動
disable | サーバーの無効化（追加の仮想マシンを起動できない状態）
migrate | すべての仮想マシンのほかのサーバーへの移行（可能な場合）
suspend | 仮想マシンを停止してその状態をディスクに保存
hard_shutdown | 特定の仮想マシンの強制シャットダウン
hard_reboot | 特定の仮想マシンの強制再起動
start_on | 特定の仮想マシンの特定ホスト上での起動
snapshot_with_quiesce | 特定の仮想マシンの休止スナップショットを作成して新規仮想マシンを作成
enable_ha | 高可用性モードの有効化
copy | 特定の仮想マシンを複製して新規仮想マシンを作成
disable_ha | 高可用性モードの無効化
join_force | 新規プールへのホストの（強制）追加
join | 新規プールへのホストの追加
shutdown | 特定の仮想マシンのシャットダウン
pool_migrate | 仮想マシンのほかのホスト上への移行
pool.retrieve_wlb_recommendations | このプールのワークロードバランス推奨項目の取得


ワークロードバランス設定の変更

重要： ワークロードバランス機能（WLB）は、XenServer Version 6.2およびこれ以降のバージョンでは削除されています。 WLBの機能を使用するアプリケーションやコードなどは、XenServer Version 6.2およびこれ以降のバージョンでは使用できません。 詳しくは、CTX137333を参照してください。
ワークロードバランス仮想アプライアンスに接続したら、再配置や最適化の推奨項目を計算するための設定を変更できます。 以下の設定を変更できます。
  • 最適化モードの変更
  • 自動処理と電源管理の設定
  • しきい値の変更
  • 測定基準の重要度の変更
  • 推奨項目からのホストの除外
  • 詳細設定
注： ワークロードバランス仮想アプライアンスへの接続または再接続直後に設定を変更する場合は、60秒以上（ログ/var/log/wlb/LogFile.logに検出の完了が示されます）待機する必要があります。

ワークロードバランス設定が適用されるしくみ

ワークロードバランスの設定は、リソースプールに属するすべてのホストおよび仮想マシンに適用されます。

ネットワークやディスクのパフォーマンスがその環境のハードウェアに適したものである場合は、まずデフォルトの設定でワークロードバランスを使用します。

ワークロードバランス機能をしばらく運用した後で、パフォーマンスのしきい値を評価して、必要に応じて変更することをお勧めします。 たとえば、以下の場合に設定の変更を検討します。
  • 最適化の推奨項目が必要以上に生成される。 この場合、適切な推奨項目が生成されるようになるまでしきい値を調整します。
  • ネットワーク帯域幅が十分でないにもかかわらず推奨項目が生成されない。 この場合、適切な推奨項目が生成されるようになるまでネットワークのしきい値を下げます。

しきい値を変更する前に、リソースプール内の各物理サーバーについてホストヘルス履歴レポートを作成すると便利です。

設定を変更するには、XenCenterの［ワークロードバランス設定］ダイアログボックスや、xeコマンドラインインターフェイスを使用します。

XenServerとワークロードバランスサーバーとの通信で使用される資格情報を変更する方法については、「ワークロードバランスの資格情報の変更」を参照してください。

ワークロードバランス設定の情勢について詳しくは、『ワークロードバランス管理者ガイド』を参照してください。

［ワークロードバランス設定］ダイアログボックスを開くには

  1. XenCenterのリソースペインで、リソースプールを選択します。
  2. プロパティペインの［WLB］タブをクリックします。
  3. ［WLB］タブの［設定］をクリックします。


最適化モードの変更

重要： ワークロードバランス機能（WLB）は、XenServer Version 6.2およびこれ以降のバージョンでは削除されています。 WLBの機能を使用するアプリケーションやコードなどは、XenServer Version 6.2およびこれ以降のバージョンでは使用できません。 詳しくは、CTX137333を参照してください。

ワークロードバランスでは、仮想マシンの実行によるワークロードを再配置（つまり最適化）するための推奨項目が生成されます。この推奨項目は、管理者が選択する最適化モードに基づいて計算されます。

パフォーマンスの最大化と密度の最大化

最適化モードには、以下の2つがあります。
  • パフォーマンスを最大化： （デフォルト） リソースプール内のすべての物理ホスト上に仮想マシンを均等に配置します。 これにより、すべてのホストのCPU、メモリ、およびネットワーク負荷を最小化できます。 この最適化モードでは、仮想マシンが高しきい値に達すると最適化の推奨項目が生成されます。

  • 密度を最大化： 1台の物理サーバー上に可能な限り多くの仮想マシンを配置します。 これにより、リソースプール内で稼働する物理サーバーの数を最小化できます。

    この最適化モードでは、［パフォーマンスを最大化］を選択した場合と同様のしきい値を使用できます。 ただし、これらのしきい値は、1台のサーバーにどれだけ多くの仮想マシンを配置できるかを評価するために使用されます。 この最適化モードでは、仮想マシンが限界しきい値に達すると最適化の推奨項目が生成されます。

これらの最適化モードは、永続的に適用（固定）したり、特定のスケジュールに基づいて適用（スケジュール指定）したりできます。

固定

最適化モードを固定すると、選択したモード（パフォーマンスの最大化または密度の最大化）が常に使用されます。

スケジュール指定

最適化モードのスケジュールを指定すると、指定したスケジュールに基づいてモードを切り替えることができます。 たとえば、多くのエンドユーザーが作業する日中にパフォーマンスを最大化するモードを適用し、使用電力を抑えるために夜間は密度を最大化するモードを適用できます。

最適化モードのスケジュールを指定すると、その期間（曜日および時刻）に最適化モードが自動的に切り替わります。

常時適用する最適化モードを設定するには

  • リソースペインでプールを選択して［WLB］タブをクリックし、［設定］をクリックします。
  • ダイアログボックス左側の［最適化モード］をクリックします。
  • ［固定］をクリックして、以下のいずれかの最適化モードを選択します。
    • パフォーマンスを最大化： （デフォルト） リソースプール内のすべての物理ホスト上に仮想マシンを均等に配置します。 これにより、すべてのホストのCPU、メモリ、およびネットワーク負荷を最小化できます。
    • 密度を最大化： 1台の物理サーバー上に可能な限り多くの仮想マシンを配置します。 これにより、リソースプール内で稼働する物理サーバーの数を最小化できます。 ただし、ワークロードバランスでは、集約された仮想マシンのパフォーマンスも考慮され、ホストのリソースが限界しきい値に達すると、パフォーマンスを改善するための推奨項目が生成されます。

最適化モードを切り替えるスケジュールを指定するには

  • リソースペインでプールを選択して［WLB］タブをクリックし、［設定］をクリックします。
  • ダイアログボックス左側の［最適化モード］をクリックします。
  • ［スケジュール指定］をクリックします。
  • ［新規追加］をクリックします。［最適化モードのスケジュール］ダイアログボックスが開きます。
  • ［モード］ボックスで最適化モードを選択します。
    • パフォーマンスを最大化： リソースプール内のすべての物理ホスト上に仮想マシンを均等に配置します。 これにより、すべてのホストのCPU、メモリ、およびネットワーク負荷を最小化できます。
    • 密度を最大化： 1台の物理サーバー上に可能な限り多くの仮想マシンを配置します。 これにより、リソースプール内で稼働する物理サーバーの数を最小化できます。
  • 選択した最適化モードに切り替える曜日および時刻を選択します。
  • 必要に応じて、スケジュールを追加します。 追加したスケジュールが1つのみの場合、そのスケジュールに基づいて切り替わった最適化モードが元に戻らなくなります。
  • ［OK］をクリックします。

最適化モードのスケジュールを削除または一時停止するには

  1. リソースペインでプールを選択して［WLB］タブをクリックし、［設定］をクリックします。
  2. ［最適化モード］をクリックします。
  3. 変更するスケジュールを選択して、以下のいずれかを行います。
    • タスクを削除する： ［削除］ボタンをクリックします。
    • タスクを一時的に停止する： タスクを右クリックして、［無効化］を選択します。

    無効にしたタスクを有効にするには、タスクを右クリックして［有効化］を選択します。

最適化モードのスケジュールを変更するには

  1. リソースペインでプールを選択して［WLB］タブをクリックし、［設定］をクリックします。
  2. ［最適化モード］をクリックし、既存のタスクを選択します。
  3. ［編集］をクリックします。
  4. ［最適化モードのスケジュール］ダイアログボックスで、必要な変更を行います。


自動処理による電源の最適化と管理

重要： ワークロードバランス機能（WLB）は、XenServer Version 6.2およびこれ以降のバージョンでは削除されています。 WLBの機能を使用するアプリケーションやコードなどは、XenServer Version 6.2およびこれ以降のバージョンでは使用できません。 詳しくは、CTX137333を参照してください。

ワークロードバランスによる最適化推奨項目が自動的に適用されるように設定することができます（ワークロードバランスの自動処理機能）。また、サーバーの電源を自動的に投入したり切断したりすることもできます（電源管理機能）。

最適化推奨項目の自動適用

ワークロードバランスで生成された最適化推奨項目を、管理者の介在なしに自動的に適用することができます。 この自動処理機能を使用すると、生成される推奨項目に基づいて、自動的にパフォーマンスを最適化したりサーバーの電源を切断したりできます。 ただし、仮想マシンの使用が減少したときにホストの電源を落として消費電力を抑えるには、自動処理のほか、電源管理と密度の最大化モードを設定する必要があります。

ワークロードバランスのデフォルトでは、推奨項目が自動的に適用されることはありません。 生成された推奨項目が自動的に適用（実行）されるようにするには、自動処理機能を有効にする必要があります。 この機能を有効にしない場合、管理者が、生成された推奨項目を実行するかどうかを選択します。

ワークロードバランスで生成された推奨項目が高可用性の設定と競合する場合、その推奨項目は自動的には適用されません。 推奨項目の適用によりプールがオーバーコミット状態になる場合は、それを適用するかどうかを確認するメッセージが表示されます。 自動処理を有効にしても、高可用性で許可する障害数を超える数の電源管理推奨項目は無視され、自動的には適用されません。

自動モードのワークロードバランスで推奨項目がどのように適用されるかを変更することができます。 詳しくは、「詳細設定」を参照してください。

電源管理の有効化

ワークロードバランスの電源管理機能は、 リソースプールの全体的なワークロードに応じて物理ホストの電源を投入したり切断したりするための機能です。

ワークロードバランスの電源管理機能を使用するには、以下の条件を満たす必要があります。
  • サーバーのハードウェアがリモートからの電源投入/切断をサポートしている。
  • ホストの電源投入機能が設定されている。
  • ホストが電源管理の対象として明示的に選択されている。
また、この機能でサーバーの電源を自動的に切断する場合は、以下の設定を行う必要があります。
  • ワークロードバランスの推奨項目が自動的に適用されるように設定されている。
  • ワークロードバランスの電源管理推奨項目が自動的に適用されるように設定されている。

電源管理と密度の最大化モードを有効にすると、使用されていないリソースがワークロードバランスにより検出され、そのホストの電源を切断するための推奨項目が生成されます。 サーバーの電源を切断するために必要なリソースがプールにない場合は、プールのワークロードが小さくなるまでそのサーバーを動作させておくことが推奨項目として提示されます。 余剰サーバーの電源を自動的に切断するように設定した場合は、電源を切るための推奨項目が自動的に適用されます。

電源管理の対象ホストを指定すると、そのホストの電源を投入したり切断したりするための推奨項目が生成されます。 これらの電源管理推奨項目の自動処理を有効にする場合、リソースプール全体に適用されます。 ただし、電源管理の対象ホストは個別に選択できます。

電源管理のしくみ

ワークロードバランスによりホストの電源が切断される前に、そのサーバー上の仮想マシンの移行先ホストが選択されます。 移行先ホストは、以下の順序で決定されます。
  1. プールマスタが最初の移行先ホストになります。これは、プールマスタの電源が切断されることがないためです。
  2. 次に、より多くの仮想マシンを実行しているホストが選択されます。
  3. 以降、実行している仮想マシンの数が多いホストから順番に選択されます。

ワークロードバランスでプールマスタに仮想マシンを移行する場合、意図的に低いしきい値が使用されます。 これにより、プールマスタが過負荷状態になるのを防ぎます。

次の図は、リソースプールでの仮想マシン密度を最大化するための以降順序を示しています。

この図では、最適化モードとして［密度を最大化］が選択されている場合の仮想マシンの移行順序を示しています。仮想マシンの集約先として、まずプールマスタが選択され、次に実行仮想マシン数の多いサーバー、最後に実行仮想マシン数の少ないサーバーが選択されます。

最適化モードとして密度の最大化が選択されているプールでパフォーマンスに関する問題が検出されると、電源投入済みのホスト間での仮想マシンの移行を推奨して問題を解決しようとします。 この方法でパフォーマンスが改善されない場合、シャットダウン状態のホストの電源を投入します。 このとき、最適化モードとしてパフォーマンスの最大化が選択された場合と同じ条件に基づいて、電源投入するホストが決定されます。

最適化モードとしてパフォーマンスの最大化が選択されているリソースプールでは、すべてのホストのリソース使用が高しきい値を下回るまで、電源投入の推奨項目が生成されます。

仮想マシンを移行しているときに、オンライン状態のホストを増やすことでプール全体のパフォーマンスが改善するとワークロードバランスが判断した場合、自動的にホストの電源を投入したり、電源投入の推奨項目を生成したりします。
重要： ワークロードバランスでは、推奨項目により電源が切断されたホストに対してのみ、電源投入の推奨項目を生成します。

電源管理および仮想マシン集約のための環境設計

XenServerを実装して電源管理と仮想マシン集約を自動化する場合は、 以下の点を考慮して環境を設計します。

  • 異なる種類のワークロードを個別のプールに配置する： 異なる種類のワークロードを実行する場合は、それらの仮想マシンを個別のプールに配置することを検討します（たとえば、ユーザーアプリケーションとドメインコントローラの仮想マシンを分離したり、特定のハードウェアを使用するアプリケーションを専用のプールで実行したりするなど）。

    電源管理機能および仮想マシンの集約はプールレベルで管理されるため、「詳細設定」で説明されている点を考慮して、同じ比率で集約するワークロードが含まれるようにプールを設計する必要があります。

  • ワークロードバランスから除外するホストを指定する： 特定のホストをワークロードバランスの対象から除外して、常に電源が投入された状態にしておくことができます。 詳しくは、「推奨項目からのサーバーの除外」を参照してください。

最適化推奨項目を自動適用するには

  1. XenCenterのリソースペインで、［XenCenter］ノードからリソースプールを選択します。
  2. プロパティペインの［WLB］タブをクリックします。
  3. ［WLB］タブの［設定］をクリックします。
  4. ダイアログボックス左側の［自動処理］をクリックします。
  5. 以下のオプションを設定します。
    • 最適化推奨項目を自動的に適用する： このチェックボックスをオンにすると、管理者の介在なしに最適化推奨項目を適用できます。 ワークロードバランスにより自動的に最適化が行われ、仮想マシンが再配置されます。
    • 電源管理推奨項目を自動的に適用する： このチェックボックスによる動作は、リソースプールの最適化モードにより異なります。
      • パフォーマンスを最大化： ［電源管理推奨項目を自動的に適用する］チェックボックスをオンにすると、ホストのパフォーマンスを改善するためにオフラインホストの電源が自動的に投入されます。
      • 密度を最大化： ［電源管理推奨項目を自動的に適用する］チェックボックスをオンにすると、自動的に余剰サーバー（リソース使用が低しきい値を下回るサーバー）の電源が切断されます。
  6. 以下のいずれかを行います。
    • ［電源管理推奨項目に含めるサーバー］で、電源管理の対象サーバーを選択します。詳しくは、下記「電源管理対象のサーバーを選択するには」を参照してください。
    • 電源管理を有効にしない場合は、［OK］をクリックして設定を確定します。

電源管理対象のサーバーを選択するには

  1. ［自動処理］ページの［電源管理推奨項目に含めるサーバー］の一覧で、ワークロードバランス機能で電源を投入/切断するサーバーを選択します。
    注： ［電源管理推奨項目を自動的に適用する］チェックボックスをオフにしたままこの一覧でサーバーを選択した場合、それらのサーバーに対する電源管理推奨項目は自動的には適用されません。
  2. ［OK］をクリックします。 リソースプール内にリモートからの電源管理をサポートするサーバーがない場合、「電源管理機能をサポートするホストがありません」というメッセージが表示され、ワークロードバランスの電源管理機能は動作しません。


しきい値の変更

重要： ワークロードバランス機能（WLB）は、XenServer Version 6.2およびこれ以降のバージョンでは削除されています。 WLBの機能を使用するアプリケーションやコードなどは、XenServer Version 6.2およびこれ以降のバージョンでは使用できません。 詳しくは、CTX137333を参照してください。

ここでは、デフォルトの限界しきい値の変更方法と、高、中、および低しきい値がどのように変更されるかについて説明します。

これらの情報は、しきい値を変更するときのリファレンスとして提供されています。 このトピックで説明されている概念を理解するには、『ワークロードバランス管理者ガイド』をよく読んでください。

概要

ワークロードバランスは、日別の平均値を4つのしきい値（低、中、高、および限界）と比較して、リソース使用を評価します。XenCenterでしきい値を指定（またはデフォルトのしきい値を使用）すると、その値は限界しきい値として設定され、それを基にほかの3つのしきい値が相対的に決定されます。 最適化の推奨項目の生成を制御するために、限界しきい値を変更することができます。

ワークロードバランスでは、リソースプールの各物理サーバーのCPU、メモリ、ネットワーク読み取り、ネットワーク書き込み、ディスク読み取り、およびディスク書き込みの測定値が評価されます。

ワークロードの再配置を推奨項目として提示するか、および物理サーバーが仮想マシンのワークロードに適しているかは、以下を評価して決定されます。
  • 物理サーバー上のリソースの負荷が限界しきい値に達しているかどうか。
  • （限界しきい値に達していない場合は）各リソースの重要度。
注： ワークロードバランスでは、パフォーマンス測定値に急激な増加があっても平滑化され、日別の平均値が評価されます。

詳しくは、『ワークロードバランス管理者ガイド』を参照してください。

リソース負荷の履歴平均値がそのしきい値を超えると、ワークロードバランスで推奨項目が生成されます。 『ワークロードバランス管理者ガイド』で説明されているように、パフォーマンスの最大化では高しきい値、密度の最大化では低しきい値または限界しきい値を超えたときに、推奨項目が生成されます。 限界しきい値を変更すると、それに基づいてほかのしきい値が相対的に変更されます （XenCenter上で変更できるのは限界しきい値のみです）。

しきい値のデフォルト設定

次の表は、各しきい値のデフォルト値を示しています。
設定 | デフォルト値 | 高 | 中 | 低
CPU使用率 | 90% | 76.5% | 45% | 22.5%
空きメモリ | 51MB | 63.75MB | 510GB | 1020GB
ネットワーク読み取り | 25MB/秒 | 21.25MB/秒 | 12.5MB/秒 | 6.25MB/秒
ネットワーク書き込み | 25MB/秒 | 21.25MB/秒 | 12.5MB/秒 | 6.25MB/秒
ディスク読み取り | 25MB/秒 | 21.25MB/秒 | 12.5MB/秒 | 6.25MB/秒
ディスク書き込み | 26MB/秒 | 21.25MB/秒 | 12.5MB/秒 | 6.25MB/秒
限界しきい値を以下の数で乗じたものが高、中、および低しきい値として設定されます。
  • 高しきい値：0.85
  • 中しきい値：0.50
  • 低しきい値：0.25
空きメモリのしきい値は、限界しきい値を以下の数で乗じたものが使用されます。
  • 高しきい値：1.25
  • 中しきい値：10.0
  • 低しきい値：20.0

つまり、CPU使用率の限界しきい値を95%に変更した場合、高、中、および低しきい値がそれぞれ80.75%、47.5%、および23.75%に変更されます。

特定のしきい値についてこの計算を行うには、限界しきい値として指定した数値にこれらの数を乗じます。

高、中、または低しきい値 ＝ 限界しきい値 × 上記の数

たとえば、［ネットワーク読み取り］のしきい値を40MB/秒に変更した場合、低しきい値は40×0.25＝10MB/秒となり、 中しきい値は40×0.50で計算できます。

プールマスタとして動作するサーバーが過負荷状態にならないように、プールマスタには自動的に低いしきい値が適用されます。

ほかのしきい値により生成される推奨項目

多くの推奨項目は限界しきい値に基づいて生成されますが、ほかのしきい値により推奨項目が生成される場合もあります。

高しきい値：
  • パフォーマンスを最大化： 高しきい値を超えたときに、仮想マシンをリソース負荷の低いサーバー上に移行するための推奨項目が生成されます。
  • 密度を最大化： 追加の仮想マシンによりサーバーのいずれかのリソース負荷が高しきい値を超える場合、そのサーバー上に仮想マシンを移行する推奨項目が生成されなくなります。
低しきい値：
  • パフォーマンスを最大化： 推奨項目は生成されません。

  • 密度を最大化： リソース負荷が低しきい値を下回ると、仮想マシンをそのホスト上に集約するための推奨項目が生成されます。 そのサーバーのいずれかのリソース負荷が高しきい値に達するまで、仮想マシンの集約先としてそのサーバーの推奨が続行されます。

    仮想マシンの集約によりそのサーバーのリソース負荷が限界しきい値を超えた場合は、パフォーマンスの最大化の場合と同様のロードバランスアルゴリズムにより、仮想マシンの新しい集約先が検索されます。 リソースプール内のすべてのサーバーのリソース負荷が高しきい値を下回るまで、このアルゴリズムによる推奨項目の生成が続行されます。

しきい値を変更するには

  1. リソースペインでプールを選択して［WLB］タブをクリックし、［設定］をクリックします。
  2. ダイアログボックス左側の［しきい値］をクリックします。

  3. ［しきい値］ページでは、各リソース使用量の限界しきい値を設定できます。 ワークロードバランスでは、仮想マシンの推奨再配置先を計算するときに、これらの限界しきい値が使用されます。 各サーバーのリソース使用がこれらのしきい値を超えないように、仮想マシンによるワークロードを分散できます。


測定基準の重要度の変更

重要： ワークロードバランス機能（WLB）は、XenServer Version 6.2およびこれ以降のバージョンでは削除されています。 WLBの機能を使用するアプリケーションやコードなどは、XenServer Version 6.2およびこれ以降のバージョンでは使用できません。 詳しくは、CTX137333を参照してください。
注： 測定基準の重要度を変更する前に、『ワークロードバランス管理者ガイド』を参照して、最適化および集約化のプロセスについて確認しておくことをお勧めします。 このヘルプトピックでは、これらのプロセスについて詳しくは説明しません。

ワークロードバランスでは、リソースに重要度を割り当てる測定基準の重要度を使用して、最初に最適化するサーバーが決定されます。

ワークロードバランスでは、選択されている最適化モード（パフォーマンスの最大化または密度の最大化）に基づいて、どのホストや仮想マシンを先に最適化するを決定するときに各リソース測定基準の重要度が考慮されます。

推奨項目を生成するときに、ホストを最適化するための順番が算出されます。 この順番は、高い重要度が割り当てられている測定基準の値をホスト間で比較することで決定されます。

測定基準の重要度は、最適化モードとしてパフォーマンスの最大化が選択されているリソースプールで主に使用されます。 ただし、密度の最大化が選択されている場合でも、限界しきい値を超えた測定基準では、その重要度が考慮されます。

パフォーマンスを最大化する場合の測定基準の重要度

パフォーマンスの最大化が選択されているリソースプールでは、測定基準の重要度により、どのホストのパフォーマンスを先に最適化するか、およびどの仮想マシンを先に移行するかが決定されます。

たとえば、［ネットワーク書き込み］を［重要度：高］に設定し、ほかの測定基準のスライダを中央に設定（重要度：中）した場合、ネットワーク書き込みの値が最も高いホストが先に最適化の対象になります。

密度を最大化する場合の測定基準の重要度

密度の最大化が選択されているリソースプールでは、ホストが限界しきい値に達した場合にのみ測定基準の重要度が考慮されます。その後、すべてのホストが限界しきい値を下回るまで、パフォーマンスを最大化する場合と同じアルゴリズムが使用されます。 このアルゴリズムでは、測定基準の重要度に基づいて、ホストを最適化するための順番が決定されます。

つまり、複数のホストで限界しきい値を超えている場合、その重要度がチェックされ、先に最適化するホストが決定されます。

たとえば、ホストAとホストBで構成されるリソースプールを例に説明します。
  • CPU使用率に高い重要度が設定されており、サーバーAのCPU使用率が限界値を超えています。
  • メモリ使用に低い重要度が設定されており、サーバーBのメモリ使用が限界値を超えています。

この場合、高い重要度の測定基準が限界しきい値に達しているサーバーAが先に最適化の対象になります。 次に、サーバーA上の仮想マシンのうち、CPU使用率の最も高いものを移行するための推奨項目が作成されます。

サーバーAに対する推奨項目を生成したら、サーバーBが最適化の対象になります。 サーバーB上の仮想マシンに対しても、CPU使用率の最も高いものを移行するための推奨項目が作成されます。これは、このリソースプールでCPU使用率に対して高い重要度が設定されているためです。

リソースプールにほかのサーバーがある場合は、サーバーのCPU使用率が高いものから順に最適化が行われます。

デフォルトでは、すべての測定基準の重要度が最大（［重要度：高］）に設定されます。
注： 測定基準の重要度は、相対的に処理されます。 つまり、すべての測定基準の重要度が同じ場合、その重要度レベルは意味を持ちません。 重要度の相対的な高低により、各測定基準の評価が決定されます。

測定基準の重要度を変更するには

  1. リソースペインでプールを選択して［WLB］タブをクリックし、［設定］をクリックします。
  2. ダイアログボックス左側の［測定基準の重要度］をクリックします。
  3. ［測定基準の重要度］ページでは、必要に応じて各リソースの重要度を調節できます。

    スライダを［重要度：低］側にドラッグすると、そのリソースの負荷は仮想マシンの再配置先の決定には影響しなくなります。


推奨項目からのホストの除外

重要： ワークロードバランス機能（WLB）は、XenServer Version 6.2およびこれ以降のバージョンでは削除されています。 WLBの機能を使用するアプリケーションやコードなどは、XenServer Version 6.2およびこれ以降のバージョンでは使用できません。 詳しくは、CTX137333を参照してください。

ワークロードバランスを設定するときに、最適化および仮想マシン配置の推奨項目から除外する物理ホストを指定できます。

なぜサーバーを除外するのか

以下の状況では、特定のホストを推奨項目の対象から除外することを検討します。
  • プールの最適化モードとして［密度を最大化］を使用するが、特定のホストをこの最適化（仮想マシンの集約化とホストのシャットダウン）から除外する場合。
  • 2つの仮想マシンワークロードを常に同一ホスト上で実行する必要がある場合（それらの仮想マシンが相補的な場合など）。
  • 移行すべきでないワークロードがある場合（ドメインコントローラやSQL Serverなど）。
  • サーバーの保守作業の間、仮想マシンの移行先サーバーから除外する場合。
  • ハードウェアのコストよりもワークロードのパフォーマンスの方が重要な場合。
  • 特定のホスト上で優先度の高いワークロード（仮想マシン）を実行し、それらの仮想マシンに高可用性機能の優先度を設定したくない場合。
  • プール内のワークロードの実行に不適切なハードウェアを持つホストがある場合。

最適化モードのスケジュールを設定するかどうかに関係なく、最適化モードが変更されても除外サーバーは常に推奨項目の対象から除外されます。 このため、サーバーの電源が自動的に切断されるのを防ぐためだけの場合は、そのサーバーに対する電源管理機能を無効にすることを検討します。方法については、「自動処理による電源の最適化と管理」を参照してください。

最適化および仮想マシン配置の推奨項目からサーバーを除外するには

  1. リソースペインでプールを選択して［WLB］タブをクリックし、［設定］をクリックします。
  2. ダイアログボックス左側の［除外ホスト］をクリックします。
  3. ［除外ホスト］ページで、ワークロードバランスの推奨項目から除外するホストサーバーを選択します。


詳細設定

重要： ワークロードバランス機能（WLB）は、XenServer Version 6.2およびこれ以降のバージョンでは削除されています。 WLBの機能を使用するアプリケーションやコードなどは、XenServer Version 6.2およびこれ以降のバージョンでは使用できません。 詳しくは、CTX137333を参照してください。
［詳細］ページでは、主に自動モードで動作するワークロードバランスで推奨項目をどのように自動適用するかを設定します。
重要：

ワークロードバランスをしばらく使用して意図したとおりに推奨項目が生成されない場合は、パフォーマンスしきい値の設定を再評価することを強くお勧めします。方法については、『ワークロードバランス管理者ガイド』を参照してください。 運用環境に合ったしきい値を設定することで、より適切な最適化推奨項目が作成されるようになります。

概要：推奨項目の自動適用の積極度

自動モードで動作するワークロードバランスでは、最適化および集約化の推奨項目の頻度や自動適用の積極度が以下の複数の要因により決定されます。
  • 移行後の仮想マシンを次の推奨項目に含めるまでの時間（VM移行間隔）
  • 推奨項目を自動的に適用するまでの作成回数（推奨項目の回数）
  • 推奨項目を自動適用するときの最低重要度レベル（最適化の重要度）
  • 推奨項目を自動適用するときの推奨項目の一貫性レベル（移動する仮想マシンや移動先サーバーとして同じものが推奨されるかどうか）

VM移行間隔

ワークロードバランスにより仮想マシンを移動した後で、その仮想マシンを含んだ新しい最適化推奨項目を生成するまでの時間を分単位で指定できます。

仮想マシンの移行間隔は、人為的な操作（一時的な高負荷時など）が原因で推奨項目が生成されるのを防ぐために設定します。

ワークロードバランスの自動処理機能を有効にした場合は、仮想マシンの移行間隔を特に慎重に決定する必要があります。 継続的および反復的に負荷が増加する環境で頻度を増やす（小さい値を設定する）と、多くの推奨項目が生成され、仮想マシンの再配置が頻繁に発生します。
注： この設定は、前回と同じサーバーを仮想マシンの起動または再開先サーバー、および保守モードの推奨項目に含むかどうかの決定には影響しません。

推奨項目の回数

ワークロードバランスでは、そのリソースプールで推奨項目の生成が必要かどうかが2分ごとにチェックされます。 ワークロードバランスの自動処理機能では、推奨項目をいくつ生成したら自動的に適用するかを指定できます。 これを行うには、［推奨項目の回数］を設定します。 ［推奨項目の回数］と［最適化の積極度］の設定により、推奨項目をどのように自動適用するかを微調整できます。

上記の概要で説明したように、ワークロードバランスでは、推奨項目の類似性に基づいてその推奨項目が必要かどうか、および仮想マシンの移行先サーバーのパフォーマンスが長時間安定しているかどうか（仮想マシンの再移行が発生しないように）が決定されます。 ［推奨項目の回数］では、推奨項目を自動適用するまでの作成回数を指定します。同じ推奨項目の生成がこの回数に達すると、その推奨項目が自動的に適用されます。

この設定は、以下のように使用されます。
  1. ［最適化の積極度］により決定される一貫性要件を満たす推奨項目が生成されるたびに、推奨項目の回数が増分されます。 一貫性要件を満たさない推奨項目が生成されると、（『ワークロードバランス管理者ガイド』で説明されている要因によっては）推奨項目の回数が0にリセットされます。
  2. 一貫性要件を満たす推奨項目の生成が［推奨項目の回数］の値に達すると、その推奨項目が自動的に適用されます。
この設定を変更する場合は、その環境に最適な値を決定する必要があります。 以下の点を考慮して設定します。
  • サーバーの負荷およびアクティビティが極端に急増する環境では、［推奨項目の回数］の値を大きくします。 推奨項目の生成が必要かどうかは、2分ごとにチェックされます。 推奨化項目を適用するまでの作成回数として3を設定すると、6分後に推奨項目が自動適用されます。
  • サーバーの負荷およびアクティビティが段階的に増加する環境では、［推奨項目の回数］の値を小さくします。

推奨項目を適用すると仮想マシンの再配置処理が発生し、システムリソースに負担がかかってパフォーマンスが影響を受けます。 ［推奨項目の回数］の値を大きくすると、推奨項目が自動適用されるまでに、同様の推奨項目が多く生成されることになります。つまり、より慎重で一貫した推奨項目だけが適用され、仮想マシンが不適切に移行される可能性が低くなります。 デフォルトでは、このような値が設定されています。

この値の変更は運用環境への影響が大きいため、Citrixのサポート担当者からの指示がない限り、上記のオプションを変更しないことをお勧めします。変更する場合は、ワークロードバランスの動作について詳細にテストしてください。

最適化の重要度

すべての最適化推奨項目には、その推奨項目がどれだけ大切であるかを示す重要度レベル（最重要、高、中、低）が設定されます。 この重要度レベルは、パフォーマンスしきい値や重要度などの設定と、ワークロードで使用可能なリソース、およびリソース使用履歴データに基づいて決定されます。

ワークロードバランスの推奨項目が自動的に適用されるように設定した場合、指定した最低重要度レベルを満たす推奨項目だけが適用されます。

最適化の積極度

自動モードで動作するワークロードバランスでは、一時的または異常な負荷の増加により仮想マシンの移行が行われないように、推奨項目の一貫性を判断するためのいくつかの基準が使用されます。 自動モードでは、最初に生成された推奨項目は自動適用されません。 サーバーや仮想マシンでその動作が継続的に発生することが検出されるまで、自動適用は行われません。 つまり、同じサーバーや仮想マシンが原因で推奨項目が生成される場合、その推奨項目は一貫していると判断されます。

ワークロードバランスでは、一貫性を判断するための条件と、同じ推奨項目をいくつ生成したか（連続推奨数）により、その環境の動作の一貫性が決定されます。 一貫性をどれだけ厳密に評価するかを制御するには、［最適化の積極度］を設定します。

この［最適化の積極度］設定は主にデモ用として設計されましたが、このオプションにより運用環境の安定性を制御することができます。 デフォルトでは、積極度が低く設定されています。 積極度を高くすると、推奨項目の類似性を評価するときの厳密度が低くなり、運用環境の安定性が低下します。

ワークロードバランスは、最大で4つの条件を使用して推奨項目の一貫性を判断します。 使用される条件の数は、［最適化の積極度］で設定されている積極度レベルにより異なります。 積極度レベルが［低］または［中］の場合、推奨項目は積極的には自動適用されません。 つまり、積極度レベルが低いと最適化条件が厳密に評価され、それらに合致しないと自動適用は行われません。

たとえば、積極度レベルとして［低］を設定すると、このレベルの条件に合致する推奨項目の数が［推奨項目の回数］の値に達するまで、その推奨項目は自動適用されません。

たとえば、［推奨項目の回数］に「3」を設定した場合、低レベル用のすべての条件に合致する推奨項目（『ワークロードバランス管理者ガイド』参照）が連続して3回生成されたときに、その推奨項目が自動適用されます。 これにより、長時間安定して動作しているサーバーに仮想マシンが移行されるようになり、 移行されたばかりの仮想マシンが、そのサーバーのパフォーマンスが低下したために再移行されるという可能性が低くなります。 デフォルトでは、積極度レベルとして［低］が設定されています。

［最適化の積極度］を高くしてサーバーの最適化頻度を上げることは、推奨されません。 サーバーの最適化がより高速または頻繁に行われるようにするには、パフォーマンスしきい値の調整を検討します。詳しくは、「しきい値の変更」を参照してください。

各積極度レベルで推奨項目の一貫性を判断するときに使用される条件については、『ワークロードバランス管理者ガイド』を参照してください。

推奨項目の自動適用が意図したとおりに行われない場合は、積極度の設定を高くします。 ただし、その前に『ワークロードバランス管理者ガイド』の内容を確認することを強く推奨します。

仮想マシン推奨項目の間隔を設定するには

  1. リソースペインでプールを選択して［WLB］タブをクリックし、［設定］をクリックします。
  2. ダイアログボックス左側の［詳細］をクリックします。
  3. ［詳細］ページで、以下の設定を行います。

    ［VM移行間隔］で、移行後の仮想マシンを最適化推奨項目に含めるまでの時間を、分単位で指定します。

    ［推奨項目の回数］で、最適化推奨項目が自動的に適用されるまでの作成回数を指定します。

    ［最適化の重要度］で、最適化推奨項目の最低重要度レベルを指定します。このレベルに達すると、推奨項目が自動的に適用されます。

    ［最適化の積極度］で、最適化推奨項目をどれだけ積極的に自動適用するかを指定します。


ワークロードバランスの管理

重要： ワークロードバランス機能（WLB）は、XenServer Version 6.2およびこれ以降のバージョンでは削除されています。 WLBの機能を使用するアプリケーションやコードなどは、XenServer Version 6.2およびこれ以降のバージョンでは使用できません。 詳しくは、CTX137333を参照してください。
ワークロードバランスでは、以下の管理タスクが必要になることもあります。
  • ワークロードバランスからの切断
  • プールのワークロードバランス仮想アプライアンスの変更
  • ワークロードバランスまたはXenServerで使用される資格情報の変更
ワークロードバランス仮想アプライアンスを管理するときに、ワークロードバランスサービスコマンドを使用することもできます。 これらのコマンドでは、ワークロードバランス仮想アプライアンスの状態を確認したり、ユーザーアカウントを変更したり、より詳細な情報がログに記録されるようにしたりできます。 これらのコマンドについて詳しくは、『ワークロードバランス管理者ガイド』を参照してください。
注： ワークロードバランスで別の証明書を使用したり、XenServerで証明書の同一性が検証されるように設定したりする方法については、『ワークロードバランス管理者ガイド』を参照してください。


ワークロードバランスからの切断

重要： ワークロードバランス機能（WLB）は、XenServer Version 6.2およびこれ以降のバージョンでは削除されています。 WLBの機能を使用するアプリケーションやコードなどは、XenServer Version 6.2およびこれ以降のバージョンでは使用できません。 詳しくは、CTX137333を参照してください。

リソースプールのワークロードバランス機能を停止するには、ワークロードバランス仮想アプライアンスから切断してこの機能を無効にします。

リソースプールとワークロードバランス仮想アプライアンスとの接続を切断すると、そのリソースプールの情報がワークロードバランスデータベースから完全に削除されます。また、データコレクタの処理も停止します。 このため、同じワークロードバランス仮想アプライアンスに再接続してこの機能を有効にするには、［WLBサーバーへの接続］ダイアログボックスでアプライアンスの情報を再入力する必要があります。
重要： ワークロードバランス機能を一時的に停止するには、［WLB］タブの［一時停止］をクリックします。

ワークロードバランスから切断するには

  1. XenCenterのリソースペインで、リソースプールを選択します。
  2. ［プール］メニューの［ワークロードバランスサーバーの切断］を選択します。 ［ワークロードバランスサーバーの切断］ダイアログボックスが開きます。
  3. ［切断］をクリックします。これにより、このプールでのワークロードバランス機能が停止します。
    注： ワークロードバランス仮想アプライアンスから切断した後でこの機能を再度有効にするには、ワークロードバランス仮想アプライアンスに再接続する必要があります。


プールで使用するワークロードバランス仮想アプライアンスの変更

重要： ワークロードバランス機能（WLB）は、XenServer Version 6.2およびこれ以降のバージョンでは削除されています。 WLBの機能を使用するアプリケーションやコードなどは、XenServer Version 6.2およびこれ以降のバージョンでは使用できません。 詳しくは、CTX137333を参照してください。

必要な場合は、リソースプールのワークロードバランス仮想アプライアンスを変更することができます。

変更後も古いワークロードバランス仮想アプライアンスによりプールのデータが収集されるのを防ぐため、新しい仮想アプライアンスに接続する前に古い仮想アプライアンスを切断しておく必要があります。

古いワークロードバランス仮想アプライアンスを切断したら、新しい仮想アプライアンスの名前を指定して接続します。

使用するワークロードバランス仮想アプライアンスを変更するには

  1. リソースペインでリソースプールを選択し、［プール］メニューの［ワークロードバランスサーバーの切断］を選択します。これにより確認のメッセージが表示されるので、［切断］をクリックします。 詳しくは、「ワークロードバランスからの切断」を参照してください。
  2. ［WLB］タブの［接続］をクリックします。 ［WLBサーバーへの接続］ダイアログボックスが開きます。
  3. ［アドレス］ボックスに、新しいワークロードバランス仮想アプライアンスのIPアドレスまたはFQDNを入力します。
    新しい仮想アプライアンスで異なる資格情報を使用する場合は、その情報を入力します。
    注： リソースプールでワークロードバランス仮想アプライアンスに初めて接続するときと同様に、すべての情報を入力する必要があります。 詳しくは、「ワークロードバランスに接続する」を参照してください。


ワークロードバランスの資格情報の変更

重要： ワークロードバランス機能（WLB）は、XenServer Version 6.2およびこれ以降のバージョンでは削除されています。 WLBの機能を使用するアプリケーションやコードなどは、XenServer Version 6.2およびこれ以降のバージョンでは使用できません。 詳しくは、CTX137333を参照してください。
XenServerとワークロードバランス仮想アプライアンス間の通信で使用される資格情報を変更するには、以下の3つの操作を行います。
  1. ワークロードバランスから切断します（下記手順を参照）。
  2. WlbConfigファイルを編集して資格情報を変更します。これを行うには、ワークロードバランス仮想アプライアンスのコンソールでWlbConfigコマンドを実行します。 詳しくは、『ワークロードバランス管理者ガイド』を参照してください。
  3. ワークロードバランスを有効にして、新しい資格情報を指定します（下記手順を参照）。
以下の状況で、資格情報を変更できます。
  • XenServerがワークロードバランスと通信するときのユーザーアカウントを変更する必要がある。
  • ワークロードバランスの資格情報が無効になったというエラーメッセージが表示される。
  • サービスが使用できない。

ワークロードバランスのパフォーマンスしきい値や特定のリソースの優先度を変更する場合は、「ワークロードバランス設定の変更」を参照してください。

ワークロードバランスから切断するには

  1. XenCenterのリソースペインで、リソースプールを選択します。
  2. ［プール］メニューの［ワークロードバランスサーバーの切断］を選択します。 ［ワークロードバランスサーバーの切断］ダイアログボックスが開きます。
  3. ［切断］をクリックします。これにより、ワークロードバランスによるプールの監視が完全に停止します。

ワークロードバランスを再有効化して新しい資格情報を指定するには

  1. 処理が完了するのを進行状況バーで確認し、［接続］をクリックします。 ［WLBサーバーへの接続］ダイアログボックスが開きます。
  2. ［資格情報を変更する］をクリックします。
  3. ［サーバーのアドレス］セクションで、以下の情報を変更します。
    • ［アドレス］ボックスに、ワークロードバランス仮想アプライアンスのIPアドレスまたはFQDNを入力します。
    • （オプション） ワークロードバランス仮想アプライアンスの設定時にポートを変更した場合は、そのポート番号を入力します。 このポートにより、XenServerとワークロードバランスが通信します。
      デフォルトでは、ポート8012が指定されています。
      注： ワークロードバランス仮想アプライアンスの設定ウィザードでポート番号を変更した場合のみ、ここでポート番号を変更してください。 ［ワークロードバランス設定］ダイアログボックスで指定するポート番号は、ワークロードバランスのインストールウィザードで指定したポート番号と同じである必要があります。
  4. ［WLBサーバーの資格情報］セクションで、XenServerでワークロードバランスサーバーに接続するときに使用するユーザー名（wlbuserなど）およびパスワードを入力します。
  5. ［XenServerの資格情報］セクションで、リソースプールにアクセスするためのユーザー名とパスワード（通常プールマスタのパスワード）を入力します。 ワークロードバランスは、この情報を使用してリソースプールのサーバーに接続します。 ［現在のXenCenterの資格情報を使用する］チェックボックスをオンにすると、XenCenterでこのプールに接続したときの資格情報が適用されます。


ワークロードバランスが有効なときの保守モード

重要： ワークロードバランス機能（WLB）は、XenServer Version 6.2およびこれ以降のバージョンでは削除されています。 WLBの機能を使用するアプリケーションやコードなどは、XenServer Version 6.2およびこれ以降のバージョンでは使用できません。 詳しくは、CTX137333を参照してください。

ワークロードバランスが有効なリソースプールでは、物理サーバーを保守のためにオフラインにする（つまり保守モードに切り替える）と、そのサーバー上でホストされているすべての仮想マシンが自動的にほかの適切なサーバーに移行されます。 仮想マシンの移行先ホストは、ワークロードバランスが最適化モードとパフォーマンスしきい値の設定、およびパフォーマンス測定値に基づいて計算した推奨項目により決定されます。

移行先サーバーが使用できない状態である場合は、［保守モードへの切り替え］ダイアログボックスに「ここをクリックしてVMを一時停止します」というメッセージが表示されます。 この場合、十分なリソースを持つサーバーがないため、ワークロードバランスでは推奨再配置先が提示されません。 管理者は、仮想マシンを一時停止するか、保守モードを終了してほかのホスト上のワークロードを軽減する（仮想マシンを一時停止するなど）などの処置を行います。 十分なリソースを持つほかのホストが使用可能になると、再度［保守モードへの切り替え］ダイアログボックスを開いたときに、推奨再配置先が提示されます。
注： ワークロードバランスが有効なリソースプールでサーバーを保守モードにすると、［保守モードへの切り替え］ダイアログボックスの右上に「ワークロードバランスが有効」が表示されます。

ワークロードバランスが有効なリソースプールでホストを保守モードにするには

  1. リソースペインでサーバーを選択して、次のいずれかを行います。
    • 右クリックして［保守モードへの切り替え］を選択します。
    • ［サーバー］メニューの［保守モードへの切り替え］を選択します。
  2. ［保守モードへの切り替え］をクリックします。 これにより、そのサーバー上で実行中のすべての仮想マシンが、最適化モードとパフォーマンスしきい値の設定、およびパフォーマンス測定値に基づいて決定される最適なサーバーに自動的に移行されます。

サーバーの保守モードを終了するには

  1. リソースペインでサーバーを選択して、次のいずれかを行います。
    • 右クリックして［保守モードからの切り替え］を選択します。
    • ［サーバー］メニューの［保守モードからの切り替え］を選択します。
  2. ［保守モードからの切り替え］をクリックします。

    これにより、そのサーバーでホストされていたすべての仮想マシンが自動的に復元されます。


ワークロードバランスのトラブルシューティング

重要： ワークロードバランス機能（WLB）は、XenServer Version 6.2およびこれ以降のバージョンでは削除されています。 WLBの機能を使用するアプリケーションやコードなどは、XenServer Version 6.2およびこれ以降のバージョンでは使用できません。 詳しくは、CTX137333を参照してください。

ここでは、ワークロードバランスの問題を解決するための手順について説明します。 追加のトラブルシューティングについては、『ワークロードバランス管理者ガイド』を参照してください。

一般的な問題を解決するには、以下のヒントを参考にしてください。

一般的なトラブルシューティングのヒント

まず、ワークロードバランスのログファイルを参照します。 デフォルトでは、ワークロードバランス仮想アプライアンスの以下の場所にログファイルが作成されます。

/var/log/wlb

また、XenCenterの［ログ］タブに表示される情報も参照してください。

エラーメッセージ

ワークロードバランス機能のエラーメッセージは、XenCenterの［ログ］タブ、および（一部のメッセージは）ダイアログボックス内に表示されます。


ワークロードバランスの資格情報入力時の問題

重要： ワークロードバランス機能（WLB）は、XenServer Version 6.2およびこれ以降のバージョンでは削除されています。 WLBの機能を使用するアプリケーションやコードなどは、XenServer Version 6.2およびこれ以降のバージョンでは使用できません。 詳しくは、CTX137333を参照してください。
［WLBサーバーへの接続］ダイアログボックスで入力したワークロードバランス仮想マシンのユーザー名およびパスワードで接続できない場合は、以下の点を確認してください。
  • ワークロードバランス仮想アプライアンスがインポートされており、正しく設定されていることを確認します。また、すべてのサービスが実行されていることを確認します（サービスを実行するにはservice workloadbalancing startコマンドを実行します）。
  • 「ワークロードバランスの起動時の問題」を参照して、入力した資格情報が正しいことを確認します。
  • ワークロードバランスサーバーのFQDNを入力して問題が生じる場合は、IPアドレスを入力します。

［アドレス］ボックスには、ワークロードバランス仮想アプライアンスのホスト名を入力できますが、く完全修飾ドメイン名（FQDN）である必要があります。 たとえば、「yourcomputername.yourdomain.net」などの形式を使用します。


ワークロードバランスの起動時の問題

重要： ワークロードバランス機能（WLB）は、XenServer Version 6.2およびこれ以降のバージョンでは削除されています。 WLBの機能を使用するアプリケーションやコードなどは、XenServer Version 6.2およびこれ以降のバージョンでは使用できません。 詳しくは、CTX137333を参照してください。
ワークロードバランス仮想アプライアンスをインポートして設定した後にXenServerとワークロードバランスとの接続エラーが発生する場合は、［WLBサーバーへの接続］ダイアログボックスに不正な資格情報を入力したことが考えられます。 この問題を解決するには、以下を行います。
  • ［WLBサーバーへの接続］ダイアログボックスに入力した資格情報と、ワークロードバランス仮想アプライアンスおよびXenServer上で作成したアカウントの情報が一致していることを確認します。
  • ［WLBサーバーへの接続］ダイアログボックスに入力した、ワークロードバランス仮想アプライアンスのIPアドレスまたはFQDNを確認します。
  • ［WLBサーバーへの接続］ダイアログボックスに入力した資格情報が、［WLBサーバーへの接続］ダイアログボックスに入力したものと一致することを確認します。


ワークロードバランスの接続エラー

重要： ワークロードバランス機能（WLB）は、XenServer Version 6.2およびこれ以降のバージョンでは削除されています。 WLBの機能を使用するアプリケーションやコードなどは、XenServer Version 6.2およびこれ以降のバージョンでは使用できません。 詳しくは、CTX137333を参照してください。

XenCenterの［WLB］タブに接続エラーが表示される場合は、リソースプールのワークロードバランスを再設定してください。

これを行うには、［WLB］タブの［接続］をクリックして、サーバーの認証情報を再入力します。

通常、ワークロードバランス仮想アプライアンスやプールマスタの認証情報の変更や、ワークロードバランス仮想アプライアンスの名前の変更により、この問題が発生します。


ワークロードバランスサーバーの変更時の問題

重要： ワークロードバランス機能（WLB）は、XenServer Version 6.2およびこれ以降のバージョンでは削除されています。 WLBの機能を使用するアプリケーションやコードなどは、XenServer Version 6.2およびこれ以降のバージョンでは使用できません。 詳しくは、CTX137333を参照してください。

リソースプールのワークロードバランスで使用するワークロードバランス仮想アプライアンスを変更するときに、元の仮想アプライアンスから切断してから新しい仮想アプライアンスに接続する必要があります。これを行わないと、両方の仮想アプライアンスでプールのデータが収集されます。

この問題を解決するには、変更前のワークロードバランス仮想アプライアンスをシャットダウンして削除します。または、その仮想アプライアンスがワークロードバランス機能を停止するように、手作業で各サービス（Analysis Engine、Data Collection Manager、およびWeb Services Host）を停止することもできます。

pool-initialize-wlbコマンドを使ってワークロードバランスを無効にしたり、ワークロードバランスサーバーを変更したりすることは推奨されません。


システムパフォーマンスの監視

トピック

  • パフォーマンスの監視について
  • パフォーマンスグラフの表示
  • パフォーマンスグラフの設定
  • パフォーマンスアラートの設定


パフォーマンスの監視について

XenCenterの［パフォーマンス］タブでは、リソースプールの全体的なパフォーマンス統計値をリアルタイムで監視でき、仮想マシンおよび物理マシンのパフォーマンスの傾向を視覚的に確認することができます。

  • 過去12か月までさかのぼってパフォーマンスデータを表示でき、統計値が急増している部分などをクローズアップして表示することもできます。 詳しくは、「パフォーマンスグラフの表示」を参照してください。
  • デフォルトでは、CPU、メモリ、ネットワーク入出力、およびディスク入出力に関するデータが表示されます。 さらに、ほかのパフォーマンスデータを追加したり、グラフの形式を変更したりできます。 詳しくは、「パフォーマンスグラフの設定」を参照してください。
  • サーバー、仮想マシン、またはストレージリポジトリで、CPU、メモリ使用、ネットワーク使用、ストレージスループット、または仮想マシンのディスク使用が特定のしきい値を超過した場合に、アラートが生成されるように設定できます。 詳しくは、「パフォーマンスアラートの設定」を参照してください。
注： XenServer準仮想化ドライバ（XenServer Tools）がインストールされていない仮想マシンでは、一部のパフォーマンスデータが表示されません。


パフォーマンスグラフの表示

［パフォーマンス］タブには、選択したサーバーまたは仮想マシンのパフォーマンスデータがグラフ形式で表示されます。

サーバーを選択すると、以下のデータが表示されます。

  • CPU、メモリ、およびネットワーク入出力の使用状況を示すデータ。必要に応じて、ほかのリソースのデータを追加することもできます。 たとえば、コントロールドメインロードでは、XenServerのコントロールドメイン（dom0）内で直近の5分間にキューに入れられたプロセス数の平均（Linuxのloadavg）データが表示されます。
  • ［VMライフサイクルイベント］ペインには、そのサーバー上でホストされているすべての仮想マシンのライフサイクルイベント（起動、シャットダウン、一時停止など）が表示されます。

仮想マシンについては、CPU、メモリ、ネットワーク入出力、およびディスク入出力の使用状況を示すグラフがデフォルトで表示されます。

タブの下部の概要グラフを使用して、サーバーの状況をすばやく確認したり、ほかのグラフに表示されている期間を調整したりできます。データを表示する期間の短縮と延長や、以前の期間のデータの表示ができます。

［パフォーマンス］タブにほかの種類のパフォーマンスデータを追加したり、グラフの形式を変更したりするには、「パフォーマンスグラフの設定」を参照してください。

データを表示する期間を短縮したり延長したりするには

デフォルトでは、直近の10分間のデータが表示されます。 データを表示する期間を短縮または延長するには、次のいずれかを行います。

  • 直近の10分間、1時間、24時間、1週間、1か月、または1年間に収集されたパフォーマンスデータを表示するには、［ズーム］をクリックして［10分間］、［1時間］、［1日］、［1週間］、［1か月］、または［1年］を選択します。
  • 概要グラフ上で、データの収集期間を示す両端の垂直分割バーにポインタを合わせます。 ポインタが双方向矢印 [image] に変わったら、垂直分割バーを右または左に移動します。 下図はその例です。

以前の期間のデータを表示するには

グラフのデータ表示期間を移動するには、任意のグラフにポインタを合わせます。ポインタが移動カーソル [image] に変わったら、グラフを左右にドラッグします。また、概要グラフ上で、データの収集期間を示す期間を左右にドラッグすることもできます。 下図はその例です。

サーバー上の仮想マシンのライフサイクルイベントを表示するには

［VMライフサイクルイベント］ペインには、そのサーバー上でホストされているすべての仮想マシンで発生したライフサイクルイベント（起動、シャットダウン、一時停止など）が表示されます。

  • 各イベントにマウスポインタを合わせると、「仮想マシン‘apollo’が起動しました。」などの説明がツールチップとして表示されます。
  • マウスのほか、方向キーを押してイベント項目間を移動することもできます。
  • イベント項目上でダブルクリックしたりEnterキーを押したりすると、そのイベントが発生した時点のグラフが表示されます。
  • マウスまたは方向キーでイベント項目を選択すると、グラフ上のイベントのアイコンがハイライト表示されます。


パフォーマンスグラフの設定

新しいグラフを追加するには

  1. ［パフォーマンス］タブで、［操作］、［新規グラフ］の順にクリックします。 ［新規グラフ］ダイアログボックスが開きます。
  2. ［名前］ボックスにグラフの名前を入力します。
  3. データソースの一覧で、グラフに追加するデータソースのチェックボックスをオンにします。
  4. ［保存］をクリックします。

グラフを編集するには

  1. ［パフォーマンス］タブで、編集するグラフをクリックします。
  2. ［操作］、［グラフの編集］の順にクリックします。
  3. グラフの［詳細］ダイアログボックスで、必要な変更を行って［OK］をクリックします。

グラフを削除するには

  1. ［パフォーマンス］タブで、削除するグラフをクリックします。
  2. ［操作］、［グラフの削除］の順にクリックします。
  3. ［はい］をクリックして削除を確定します。

グラフを並べ替えるには

  1. ［パフォーマンス］タブで、移動するグラフをクリックします。
  2. ［上に移動］または［下に移動］をクリックします。

グラフ線の色を変更するには

  1. ［パフォーマンス］タブをクリックします。
  2. 変更するグラフをダブルクリックします。 グラフの［詳細］ダイアログボックスが開きます。
  3. データソースの一覧で、変更する色のボックス（一覧右端）をクリックして、新しい色を選択します。
  4. ［OK］をクリックして確定します。

グラフの種類を変更するには

パフォーマンスグラフ上のデータは線または面で表示できます。

折れ線グラフ

面グラフ

グラフの種類を変更するには、次の手順に従います。

  1. ［ツール］メニューの［オプション］を選択して、［グラフ］をクリックします。
  2. パフォーマンスデータを折れ線グラフで表示するには、［折れ線グラフ］をクリックします。
  3. パフォーマンスデータを面グラフで表示するには、［面グラフ］をクリックします。
  4. ［OK］をクリックして変更を保存します。


パフォーマンスアラートの設定

サーバー、仮想マシン、またはストレージリポジトリで、CPU、メモリ使用、ネットワーク使用、ストレージスループット、または仮想マシンのディスク使用が特定のしきい値を超過した場合に、アラートが生成されるように設定できます。 アラートのデフォルトの生成間隔は60分ですが、この間隔は必要に応じて変更できます。

パフォーマンスアラートを表示するには、［XenCenter］ウィンドウ右上の［システムアラート］をクリックして［システムアラート］ウィンドウを開きます。 また、パフォーマンスアラートを、ほかの重大なシステムアラートと一緒にメールで受信することもできます。詳しくは「XenCenterシステムアラート」を参照してください。

パフォーマンスアラートを設定するには

  1. リソースペインでサーバー、仮想マシン、またはストレージリポジトリを選択して、［全般］タブの［プロパティ］をクリックします。
  2. ［アラート］をクリックします。
    • サーバーまたは仮想マシンのCPU使用率パフォーマンスアラートが生成されるようにするには、［CPU使用率アラートを有効にする］チェックボックスをオンにして、アラートを起動するCPUの使用率と許容時間のしきい値を設定します。
    • サーバーまたは仮想マシンのネットワーク使用量パフォーマンスアラートが生成されるようにするには、［ネットワーク使用量アラートを有効にする］チェックボックスをオンにして、アラートを起動するネットワークの使用量と許容時間のしきい値を設定します。
    • サーバーのメモリ使用量パフォーマンスアラートが生成されるようにするには、［メモリ使用量アラートを有効にする］チェックボックスをオンにして、アラートを起動するメモリの使用量と許容時間のしきい値を設定します。
    • 仮想マシンのディスク使用量パフォーマンスアラートが生成されるようにするには、［ディスク使用量アラートを有効にする］チェックボックスをオンにして、アラートを起動するディスクの使用量と許容時間のしきい値を設定します。
    • ストレージリポジトリのスループットパフォーマンスアラートが生成されるようにするには、［ストレージスループットアラートを有効にする］チェックボックスをオンにして、アラートを起動するストレージスループットと許容時間のしきい値を設定します。
      注： ストレージスループットアラートは、PBD（Physical Block Device：物理ブロックデバイス）上の読み取りおよび書き込み時の総スループット量が指定のしきい値を超えると生成されます。 PBDは、XenServerホストとそのストレージリポジトリ間のインターフェイスです。 PBD上の読み取りおよび書き込み時の総スループット量が指定のしきい値を超えると、そのPBDが接続されているホスト上でアラートが生成されます。 ほかのホストアラートとは異なり、このアラートはストレージリポジトリに対して設定します。
    • アラートの送信間隔を変更するには、［アラートの送信間隔］ボックスに分単位で値を入力します。 しきい値に達してアラートが生成されると、送信間隔が経過するまでほかのアラートは生成されません。
  3. ［OK］をクリックして変更を保存します。


アップデートとアップグレード

トピック

  • ソフトウェアのアップデートとアップグレードについて
  • サーバーのアップデート – アップデートのインストールウィザード
  • サーバーのアップグレード – プールのローリングアップグレードウィザード
  • XenCenterのアップデート
  • アップデートの自動通知


ソフトウェアのアップデートとアップグレードについて

アップグレードとは、XenServerの次期メジャーバージョンへの更新を指します。 アップグレードにより、新しい機能や技術を追加したり、サポートされなくなったリリースを置き換えたりします。 アップデートとは、XenServerのメジャーバージョンを更新するものですが、次期メジャーバージョンに更新するものではありません。

XenCenterでは、デフォルトでXenServerとXenCenterのアップデートやアップグレードが自動的にチェックされ、新しいアップデートやバージョンが利用可能になるとメッセージが表示されます。 これらのアップデートをすべてインストールすることをお勧めします。 XenServerおよびXenCenterの新しいアップデートやバージョンのリリースについて確認するには、［ツール］ > ［アップデートの確認］を選択します。

XenServerのアップデートの適用

XenServerのアップデートは、拡張子.xsupdate（または古いバージョンのXenServerを実行する埋め込みサーバー用のアップデートの場合は.xsoem）のファイルで提供されます。 XenServerに関する重要な更新、Hotfix、およびセキュリティアップデートを含んでいるアップデートファイルをダウンロードしたら、各サーバーに簡単にインストールできます。詳しくは、「サーバーのアップデート」を参照してください。

XenCenterのアップデート

XenCenterのアップデートはWindows Installerパッケージ（MSIファイル）として提供され、XenCenterのダウンロードマネージャを使ってダウンロードおよびインストールできます。詳しくは、「XenCenterのアップデート」を参照してください。

サーバーのXenServerのアップグレード

サーバー上で動作するXenServerをアップグレードするには、［プールのローリングアップグレード］ウィザードを使用します。 このウィザードでは、実行されている仮想マシンの中断を最小限に抑えながら、リソースプール内のすべてのサーバーを順次アップグレードできます。 アップグレード対象のサーバー上で実行中の仮想マシンは、自動的にほかのサーバー上に移行されます。 このウィザードを使用して、スタンドアロンサーバーなど、サーバーを個別にアップグレードすることもできます。

詳しくは、「サーバーのアップグレード」を参照してください。

注： 何らかの理由により［プールのローリングアップグレード］ウィザードで仮想マシンをプールマスタ上に戻せない場合、プールのアップグレードが中断されます。これにより、プール内の一部のサーバーのみがアップグレードされた状態になります。 この問題を避けるため、［プールのローリングアップグレード］ウィザードを終了して移行の問題を解決し、仮想マシンをプールマスタ上に手作業で移行してから［プールのローリングアップグレード］ウィザードを再度起動してプールのアップグレードを完了してください。


サーバーのアップデート

XenServerのアップデートは、拡張子.xsupdate（または古いバージョンのXenServerを実行する埋め込みサーバー用のアップデートの場合は.xsoem）のファイルで提供されます。 リソースプール内のサーバーをアップデートするときは、すべてのサーバーを同時にアップデートしてください。アップデート済みのサーバーと未アップデートのサーバーを同じリソースプール内で運用すると、サーバー間の通信が正しく行われない場合があり、サポートされません。

重要： アップデートをインストールする前に、すべてのサーバーを再起動して、仮想マシンが正しく起動するかどうか、ストレージに正しくアクセスできるかどうかなど、各サーバーの設定を確認してください。 これにより、再起動するまで適用されない変更内容が原因でアップデートに失敗することを回避できます。

以下のいずれかの方法で、サーバーにアップデートをインストールします。

  • ［アップデートの確認］ウィンドウでは、リリース済みのアップデートの確認、ダウンロード、およびサーバーへのインストールを自動的に実行できます。
  • ［アップデートのインストール］ウィザードでは、ダウンロード済みのアップデートをサーバーにインストールするための手順が表示されます。
注： ［アップデートの確認］ウィンドウでは、XenServer Version 6.0以降が動作するサーバーをアップデートできます。 XenServer Version 5.6 Service Pack 2が動作するサーバーのアップデートについては、「アップデートのインストールウィザードを使用したアップデートの適用」を参照してください。

［アップデートの確認］ウィンドウを使用したアップデートの適用

  1. ［ツール］メニューの［アップデートの確認］を選択します。 ［アップデートの確認］ウィンドウが開きます。
  2. 一覧でアップデートを選択して、［ダウンロードしてインストール］をクリックします。 これにより、アップデートファイルが抽出され、［アップデートのインストール］ウィザードの［事前チェック］ページが開き、抽出されたアップデートファイルと対象のサーバーが表示されます。
    注： ［アップデートの確認］ウィンドウには、アップデートのほかXenServerの新しいバージョンも表示されます。 プールのローリングアップグレードウィザードによるXenServerホストのアップグレードについては、「サーバーのアップグレード」を参照してください。
  3. ［アップデートのインストール］ウィザードの［事前チェック］ページでは、選択したサーバーにアップデートをインストールできるかどうかを検証するアップデート前チェックが実行されます。 アップデートのインストールを妨げる問題が見つかった場合は、［すべて解決］をクリックして問題を解決します。
  4. ［次へ］をクリックします。
  5. ［アップデートのインストール］ウィザードでは、自動モードまたは手動モードを選択できます。
    • 自動モードでは、インストール先サーバーの仮想マシンが自動的に移行され、サーバーが保守モードに切り替わります。アップデートのインストール後、サーバーが再起動され、元の仮想マシンがそのサーバー上に戻されます。 アップデートの事前チェック時に実行された問題解決処理（高可用性の無効化など）も、すべて復元されます。
    • 手動モードでは、アップデートがインストールされるだけで、その後のタスクは管理者が行う必要があります。 必要なタスクは、ウィザードの［アップデートモード］ページに表示されます。［ファイルに保存］をクリックすると、タスクの一覧をテキストファイルとして保存できます。ウィザードを閉じた後は、このファイルを参照してタスクを実行できます。
  6. ［アップデートのインストール］をクリックすると、選択したサーバーへのインストールが開始されます。 手動モードでは、アップデートのインストール完了後にサーバーを再起動する必要があることに注意してください。

アップデートのインストールウィザードを使用したアップデートの適用

［アップデートのインストール］ウィザードでは、複数のサーバーに同じアップデートを同時にインストールできます。 ［アップデートのインストール］ウィザードを起動する前に、必要なアップデートファイルがダウンロード済みであることを確認します。 アップデートファイルをインストールするには、以下の手順に従います。

アップデートのダウンロード：

  1. ［ツール］メニューの［アップデートの確認］を選択します。 ［アップデートの確認］ウィンドウが開き、XenServerおよびXenCenterに対するリリース済みアップデートの一覧が表示されます。
  2. ダウンロードするアップデートを一覧で選択し、［Webページ］のリンクをクリックします。 Webブラウザが起動して、ダウンロード用のページが開きます。
  3. ［Download］をクリックして、アップデートファイルを任意の場所にダウンロードします。

    XenServerのアップデート（「パッチ」とも呼ばれます）をダウンロードしたら、XenCenterの［アップデートのインストール］ウィザードを使って各サーバーにインストールします。

    ［アップデートのインストール］ウィザードを開くには、［ツール］メニューの［アップデートのインストール］を選択します。 ウィザードに表示されるメッセージに従って、サーバーにアップデートを適用します。


サーバーのアップグレード

XenCenterの［プールのローリングアップグレード］ウィザードを使用すると、XenServer Version 5.6またはこれ以降が動作するサーバー（スタンドアロンサーバーおよびリソースプール内の各サーバー）を新しいバージョンにアップグレードできます。 より古いバージョンのXenServerからのアップグレードについては、『XenServerインストールガイド』を参照してください。

このウィザードでは、アップグレードパスが自動的に構成され、アップグレード手順が順番に表示されます。 リソースプールでは、プールマスタが最初にアップグレードされ、ほかのホストが順番にアップグレードされます。 アップグレードの前に、ウィザードによりいくつかの事前チェックが実行されます。これにより、高可用性やワークロードバランスなどのプールレベルの機能が一時的に無効になっており、個々のホストでアップグレードの準備が完了しているかどうか（各ホストのDVD/CDドライブが空かどうかなど）が確認されます。 ローリングアップグレードでは、プール内のホストが1台ずつオフラインになり、アップグレードがインストールされます。そのホスト上で実行中の仮想マシンは、自動的にほかのホスト上に移行されます。

このウィザードでは、アップグレードモードとして［手動モード］または［自動モード］を選択できます。

  • 手動モードでは、各サーバー上でXenServerインストーラを順次手作業で実行して、サーバーのシリアルコンソールに表示されるメッセージに従ってアップグレードします。 アップグレードが開始されると、アップグレード対象の各サーバーについて、XenServerインストールメディアの挿入またはPXEブートサーバーの指定を確認するメッセージがXenCenterに表示されます。
  • 自動モードでは、HTTP、NFS、またはFTPサーバー上のインストールファイルにより、プール内のすべてのサーバーが自動的にアップグレードされます。XenServerインストールメディアを挿入したり、サーバーを再起動したり、各サーバーのシリアルコンソールに表示されるメッセージに従って操作したりする必要はありません。

［プールのローリングアップグレード］ウィザードでは、リソースプールに属していないスタンドアロンサーバーをアップグレードすることもできます。

重要：アップグレードを行う前に

リソースプールのアップグレードは、慎重に計画する必要があります。 以下の点に注意してください。

  • アップグレード対象のサーバー上で実行されている仮想マシンは、同じまたはより新しいバージョンのXenServerが動作するサーバーにのみ移行可能です。たとえば、XenServer 5.5が動作するサーバー上の仮想マシンは、XenServer 5.5またはそれ以降のバージョンのXenServerが動作するサーバーに移行できます。 アップグレード済みのサーバーから、アップグレード前のサーバーに仮想マシンを移行することはできません（XenServer 5.6からXenServer 5.5など）。 仮想マシンを移行するための容量がサーバーにあることを確認してください。
  • 混在モード（XenServerの複数のバージョンが共存する状態）のプールを必要以上に継続運用することは極力避けるよう、強くお勧めします。ローリングアップグレード中のプールは、パフォーマンスが低下します。
  • アップグレードの間、一部の制御機能は使用できなくなります。 仮想マシンは通常どおり動作を続けますが、移行を除く主な仮想マシン操作（シャットダウン、コピー、エクスポートなど）を実行することは避けてください。 特に、仮想ディスクの追加、削除、またはサイズ変更などのストレージ関連の操作を行うと、予期せぬ問題が発生することがあります。
  • ウィザードでは、常にプールマスタが最初にアップグレードされます。 アップグレード時に、XenCenterでプールマスタを保守モードに切り替えないでください。プールマスタが保守モードになると、新しいプールマスタが選出されてしまいます。
  • CLIコマンドpool-dump-database（『XenServer管理者ガイド』を参照）を使用して、アップグレード前のプールをバックアップしてください。 これにより、仮想マシンデータを全く失うことなく、ローリングアップグレードを中断して元の状態に戻すことも可能になります。 アップグレード済みのサーバーからアップグレード前のサーバーに仮想マシンを移行することはできないため、何らかの理由でローリングアップグレードを元に戻す必要が生じた場合、仮想マシンのシャットダウンが必要になることがあります。
  • 各サーバーで、アップグレードに必要なメモリが使用可能であることを確認してください。 アップグレードの間、不要な仮想マシンをすべて一時停止状態にしておくことをお勧めします。
  • ［プールのローリングアップグレード］ウィザードでは、アップグレード前に以下の項目がチェックされますが、自分で確認することもできます。
    • プール内の各仮想マシンのCD/DVDドライブを空にする。 方法については、『XenServerインストールガイド』を参照してください。
    • 高可用性を無効にする。
    • ワークロードバランスを無効にする。

プールのローリングアップグレードウィザードでサーバーをアップグレードするには

  1. ［プールのローリングアップグレード］ウィザードを開きます。これを行うには、［ツール］メニューの［プールのローリングアップグレード］を選択します。
  2. ［はじめに］ページの注意事項を確認して、［次へ］をクリックします。
  3. アップグレードするリソースプールまたは個々のサーバーを選択して、［次へ］をクリックします。
  4. HTTP、NFS、またはFTPサーバー上のインストールファイルを使った自動アップグレードを行うか、CD/DVDドライブのインストールメディアまたはPXEブートサーバーを使った手動アップグレードを行うかにより、［自動モード］または［手動モード］を選択します。
    注： ［手動モード］を選択した場合、各サーバー上でXenServerインストーラを順次手作業で実行して、サーバーのシリアルコンソールに表示されるメッセージに従ってアップグレードする必要があります。 アップグレードが開始されると、アップグレード対象の各サーバーについて、XenServerインストールメディアの挿入またはPXEブートサーバーの指定を確認するメッセージがXenCenterに表示されます。

    アップグレードモードを選択したら、［事前チェックの実行］をクリックします。

  5. 事前チェックにより問題が見つかった場合は、適切な解決処置を行います。 ［すべて解決］をクリックすると、XenCenterにより問題の解決が試行されます。 すべての問題を解決したら、［次へ］をクリックします。
  6. XenServerインストールメディアを用意します。
    • ［自動モード］を選択した場合は、ネットワーク上のインストールメディアに接続するための情報を入力します。 ネットワークインストールファイルの場所として［HTTP］、［NFS］または［FTP］を選択して、パス、ユーザー名、およびパスワードを入力します。
    • ［手動モード］を選択した場合は、表示されるアップグレードプランおよび手順を確認します。
    ［アップグレードの開始］をクリックして、アップグレードを開始します。
  7. アップグレードを開始すると、各サーバーのアップグレードに必要な手順がウィザードに表示されます。 この手順に従って、プールのすべてのホストをアップグレードします。
  8. アップグレードが完了すると、ウィザードにその結果が表示されます。 ［完了］をクリックしてウィザードを終了します。

アップグレード後の確認事項

役割ベースのアクセス制御は、XenServer Version 5.6以降でサポートされています。 これ以前のバージョンのXenServerで作成されたユーザーアカウントには、XenServer Version 5.6以降へのアップグレードによりプール管理者の役割が割り当てられます。 これは後方互換性を維持するための機能です。 このため、XenServerをアップグレードした後で、各ユーザーアカウントに適切な役割が割り当てられているかどうかを確認する必要があります。


XenCenterのアップデート

アップデートの自動通知が有効な場合、XenCenterの新しいアップデートが見つかると、メッセージが表示されます。 XenCenterのアップデートはWindows installerパッケージ（MSIファイル）として提供され、「Citrix XenServer Updates」ページからダウンロードできます。

［ツール］メニューの［アップデートの確認］を選択して、いつでも新しいバージョンのXenCenterの有無を確認できます。 ［アップデートの確認］が開き、リリース済みアップデートの詳細が表示されます。

新しいバージョンのXenCenterをダウンロードしてインストールするには

  1. ［ツール］メニューの［アップデートの確認］を選択します。 リリース済みアップデートの詳細が表示されます。
  2. ダウンロードするXenCenterアップデートを選択して、［ダウンロード］リンクをクリックします。 Webブラウザが起動して、ダウンロード用のページが開きます。
  3. 「Get helpful resources」セクションのリンクをクリックして、Citrix XenServerの「Helpful Resources」ページを開きます。
  4. ダウンロード可能なツールの一覧で、XenCenterの［Download］リンクをクリックします。
  5. 初めてXenCenterのアップデートをダウンロードするときは、Akamai Download Managerをインストールする必要があります。 確認のダイアログボックスが表示されたらDownload Managerのセキュリティ証明書を受け入れ、［Install］をクリックしてDownload Managerをインストールします。
  6. ［Download Now］をクリックして、XenCenterのMSIファイルをダウンロードします。
  7. XenCenterの新しいMSIファイルを格納するフォルダを参照して選択します。［Save］をクリックし、Download Managerを開いてMSIファイルのダウンロードを開始します。
  8. 現在のXenCenterセッションを終了します。
  9. Download Managerに表示される進行状況が100%になりダウンロードが完了したら、［Launch］をクリックして新しいバージョンのXenCenterのインストールを開始します。
  10. XenCenterのインストールが完了したら、［Exit］をクリックしてDownload Managerを閉じます。


アップデートの自動通知

XenCenterは、XenServerとXenCenterのアップデートや新しいバージョンが使用できるかどうかを定期的に確認するように設定できます。

アップデートの自動通知を設定するには

  1. ［ツール］メニューの［オプション］を選択して、［アップデート］をクリックします。
  2. XenCenterで新しいバージョンのXenServerが使用できるかどうかを定期的に確認し、ダウンロードできるようになったときにメッセージを表示させるには、［XenServerの新しいバージョンを確認する］チェックボックスをオンにします。
  3. XenCenterでXenServerのアップデートが使用できるかどうかを定期的に確認し、ダウンロードできるようになったときにメッセージを表示させるには、［XenServerのアップデートを確認する］チェックボックスをオンにします。
  4. XenCenterで新しいバージョンのXenCenterが使用できるかどうかを定期的に確認し、ダウンロードできるようになったときにメッセージを表示させるには、［XenCenterの新しいバージョンを確認する］チェックボックスをオンにします。
  5. ［OK］をクリックして変更を適用し、［オプション］ダイアログボックスを閉じます。


トラブルシューティング

仮想マシンのリカバリモード

トピック

  • XenCenterシステムアラート
  • XenCenterのイベントログ
  • サーバーの状態レポートの作成
  • ストレージリポジトリの接続の問題を解決する
  • 仮想マシンのリカバリモード


XenCenterシステムアラート

XenCenterの［システムアラート］ウィンドウには、以下のさまざまなアラートが表示されます。

  • パフォーマンスアラート： サーバー、仮想マシン、またはストレージリポジトリで、CPU、メモリ使用、ネットワーク使用、ストレージスループット、または仮想マシンのディスク使用が特定のしきい値を超過した場合に、アラートが生成されるように設定できます。 アラートの設定について詳しくは、「パフォーマンスアラートの設定」を参照してください。
  • 高可用性状態のアラート： プールがオーバーコミットされたときなど、プールの高可用性状態が変化すると、アラートが生成されます。
  • ソフトウェアアップデートのアラート： XenServerまたはXenCenterのアップデートや新しいバージョンが使用できるようになると、アラートが生成されます。
  • ライセンスの有効期限のアラート： サーバー上のXenServerライセンスの失効日が近づくと、アラートが生成されます。

一部のアラートは、一覧の下の［アラートアクション］のリンクを使用して、問題を解決できる場合があります。

システムアラートを表示するには

［システムアラート］ウィンドウを開くには、次のいずれかを行います。

  • ［ツール］メニューの［システムアラート］を選択します。
  • ツールバーの［システムアラート］ボタンをクリックします。
    システムアラートボタン
  • ツールバーを非表示にしている場合は、［XenCenter］ウィンドウ右上の［システムアラート］ボタン（下図）をクリックします。
    システムアラートボタン

［システムアラート］ウィンドウのアラートにフィルタを適用するには

［システムアラート］ウィンドウのアラートの一覧にフィルタを適用して、特定のプールやサーバーのアラートだけを表示したり、特定の期間に生成されたアラートだけを表示したりできます。

  • 特定のサーバーのアラートだけを表示する：デフォルトでは、XenCenterが接続しているすべてのプールおよびサーバーのアラートが［システムアラート］ウィンドウに表示されます。 つまり、［ [image] サーバーでフィルタ］ドロップダウンリストですべてのプールおよびサーバーのアイコンがデフォルトで選択されています。 特定のサーバーのアラートだけを表示するには、［サーバーでフィルタ］をクリックして、対象外のプールやサーバーの選択を解除します。 たとえば、サーバーAとサーバーBで構成されるプールの場合、 サーバーAのアラートだけを表示するには、［サーバーでフィルタ］をクリックして、サーバーBをクリックします。 これによりサーバーBの選択が解除され、サーバーAのアラートだけが表示されます。
  • アラートの生成日や時刻を指定する：［ [image] 日数でフィルタ］をクリックして、期間を選択するか、［カスタム］を選択して期間を指定します。
  • アラートの重要度を指定する：デフォルトでは、すべての重要度レベルのアラートが［システムアラート］ウィンドウに表示されます。 特定の重要度のアラートだけを表示するには、［ [image] 重要度でフィルタ］をクリックして、対象外の重要度の選択を解除します。

アラートの一覧を更新するには

［システムアラート］ウィンドウが開いている間に発生したアラートを表示するには、［更新］をクリックして最新の情報を表示します。

アラートをエクスポートするには

アラートをコンマ区切りのテキストファイル（.csv）としてエクスポートして、外部アプリケーションで表示することができます。

アラートをエクスポートするには、XenCenterの［システムアラート］ウィンドウで ［ [image] すべてをエクスポート］をクリックし、ファイル名および保存先を指定します。

システムアラートをクリアするには

単一のアラートをクリア（一覧から削除）するには、そのアラートを選択して ［ [image] このアラートをクリア］をクリックします。

一覧のすべてのアラートをクリアするには、［ [image] すべてのアラートをクリア］をクリックします。

アラート通知メールを受信するには

XenCenterでは、プール内のいずれかのサーバーおよび仮想マシン、またはスタンドアロンサーバーとその仮想マシンに対するシステムアラートが生成されたときに、通知メールが送信されるように設定できます。

メール通知機能を有効にすると、重要度が3以上のアラートが生成されたときに通知メールが送信されます （XenServer xeコマンドラインインターフェイス（CLI）を使用して、さまざまな種類のアラートに優先度を割り当てることができます。詳しくは、『XenServer管理者ガイド』を参照してください）。

メール通知を有効にするには

  1. リソースペインでプールまたはスタンドアロンサーバーを選択して、［全般］タブの［プロパティ］をクリックします。
  2. ［プロパティ］ダイアログボックスの［メールオプション］タブをクリックします。
  3. ［アラートをメールで送信する］チェックボックスをオンにして、送信先アドレスの詳細を入力します。
    注： ここで指定するSMTPサーバーは、認証が不要なものである必要があります。 認証が必要なSMTPサーバーを指定すると、メールが送信されません。 認証が必要なSMTPサーバーでメールを送信する方法については、『XenServer管理者ガイド』を参照してください。
  4. ［OK］をクリックして変更を保存し、ダイアログボックスを閉じます。


XenCenterのイベントログ

XenCenterにはトラブルシューティングに役立つイベントログが保存されます。 現在のXenCenterセッションでイベントの概要を表示するには、［ログ］タブをクリックします。 XenCenterセッションで発生するイベントについてさらに詳しい永続的な記録が、プロファイルフォルダに格納されるログファイルに保存されます。この情報を使用して、XenCenterの使用中に発生した問題のトラブルシューティングを行えます。

現在のセッションでのイベントの表示

現在のXenCenterセッションでのイベントの概要を表示するには、［ログ］タブをクリックします。 独立したウィンドウでイベントデータを表示するには、［ウィンドウ］メニューの［ログウィンドウ］を選択します。

  • 表示される情報をフィルタするには、タブまたはウィンドウの上部にあるチェックボックスを使用します。表示するイベントの種類のチェックボックスはオンにします。非表示にするイベントの種類のチェックボックスはオフにします。
  • ［ログ］タブからすべての非アクティブなログエントリを削除するには［クリア］をクリックし、［OK］をクリックして確定します。

    この操作によりログエントリが削除されるのは［ログ］タブからのみであることに注意してください。XenCenterの永続的なイベントログファイルから削除されるわけではありません。

XenCenterイベントログの表示

XenCenterを使用すると、XenCenterの永続的なログファイル（syslog）が生成されます。 このファイルには、XenCenterの使用中の全操作とエラーの説明がすべて含まれます。 また、XenServerや管理リソース上で実行されたさまざまな操作の監査記録になる、イベントの情報ログも含まれます。

XenCenterのログファイルは、%appdata%\Citrix\XenCenterに作成されます。

XenCenterのログ出力は、XenServer環境での問題を診断する必要があるときに非常に役立ちます。 XenCenterのログファイルを開いたりメールで送信したりするときは、［ヘルプ］メニューの［アプリケーションログファイルの表示］を選択してログファイルを表示できます。


サーバーの状態レポートの作成

［サーバーの状態レポート］ウィザードを使用すると、XenServerシステムの状態に関する総合的なスナップショットを収集してパッケージ化することができます。この情報は、トラブルシューティング時に使用します。 選択したサーバーについて、さまざまな設定ファイルとログファイルを選択したり、選択から除外したりできるオプションがあります。

サーバーの状態レポートは単一のZIPファイルにパッケージ化して、保存したりメールで送信したりすることができます。 生成するレポートのサイズは、レポート対象の項目によって変わります。 ZIPファイルには次の項目が含まれます。

  • 各サーバーのフォルダ。ウィザードで選択した種類のレポートが含まれます。
  • XenCenterログファイル

サーバーの状態レポートを生成するには

［ツール］メニューの［サーバーの状態レポート］を選択して、［サーバーの状態レポート］ウィザードの画面の指示に従います。

  1. サーバーの選択： レポートデータを収集するサーバーを選択します。

    ここには、使用できるすべての管理対象サーバーが一覧表示されます。 サーバーが一覧に表示されない場合は、［新規サーバーの追加］をクリックして追加できます。

  2. レポートに含める内容の選択： レポートに含めるデータを選択して［次へ］をクリックします。
  3. レポートの作成： このページには、レポート作成の進行状況と、データの収集中に発生した問題が表示されます。 レポート作成が完了したら、［次へ］をクリックします。
  4. レポートの保存先： レポートを保存するフォルダを参照して検索し、［完了］をクリックします。これにより、レポートファイルが指定したフォルダに保存され、ウィザードが終了します。


ストレージリポジトリの接続の問題を解決する

サーバーでストレージリポジトリを使用するには、サーバーとストレージリポジトリの間に接続が存在している必要があります。 この接続は、PBD（Physical Block Device：物理ブロックデバイス）により提供されます。PBDには、ストレージリポジトリをサーバーにマップするための情報が格納されます。 ストレージリポジトリを使用するには、PBDをサーバーに接続（「アタッチ」または「プラグイン」）する必要があります。 何らかの理由でPBDがアンプラグされている場合は、サーバーでストレージリポジトリを使用できず、リソースペインに破損したストレージが [image] アイコンで表示されます。

ストレージリポジトリの修復ツールを使用すると、ストレージリポジトリの接続の問題を診断して、解決できる場合があります。 リソースペインでストレージリソースを右クリックして、［ストレージリポジトリの修復］を選択します。

または、［ストレージ］メニューの［ストレージリポジトリの修復］を選択します。

使用できるストレージリポジトリが一覧表示され、その状態を確認できます。

  • 接続： ストレージリポジトリとサーバーの間の接続は正常に機能しており、ストレージリポジトリにより提供されるストレージが現在使用できます。
  • アンプラグされました： PBDが現在アンプラグされているため、ストレージを使用できません。
  • 接続がありません： PBDが見つからないため、ストレージを使用できません。

ストレージの修復を試行するには［修復］をクリックします。 進行状況と結果が［ストレージリポジトリの修復］ダイアログボックスに表示されます。


仮想マシンのリカバリモード

準仮想化したLinux仮想マシンに深刻な問題が発生した場合、リカバリモードでの起動を試行できます。 これにより仮想マシンが一時的にHVMモードに切り替わり、CDドライブが最初の起動元に設定されます。これにより、リソースCDまたはレスキューPXEを起動して問題の原因を調査できます。

仮想マシンをリカバリモードで起動するには、以下の手順に従います。

  • リソースペインで仮想マシンを選択します。
  • ［VM］メニューで、［起動/シャットダウン］ > ［リカバリモードで起動］の順にクリックします。
    注： オペレーティングシステムに付属しているレスキューCDから仮想マシンを起動し、レスキューCDを使用して仮想マシンを復元します。

HVMモードと準仮想化モードについて詳しくは、「仮想マシンとテンプレートについて」を参照してください。