ワークロードバランスについて

ワークロードバランスは、リソースプール内の最適なサーバーに仮想マシンを移行することでプールのワークロードを分散させるためのXenServerの機能で、ワークロードバランス仮想アプライアンスにより提供されます。 ワークロードバランスでは、以下のようにワークロードが最適化されます。

  • 仮想マシンのワークロードをリソースプール内のホスト間で分散させる。
  • 仮想マシンを起動するときに、最適なサーバーを決定する。
  • シャットダウンした仮想マシンを起動するときに、最適なサーバーを決定する。
  • サーバーを保守モードにしたときに、そのサーバー上の各仮想マシンの移行先として最適なサーバーを決定する。
注： ワークロードバランス機能は、XenServer Enterprise Edition、XenServer Desktop+ Edition、またはXenServer Desktop Editionでのみ使用できます。 XenServer 6.5のライセンスについて詳しくは、「ライセンスの概要（XenServer 6.5）」を参照してください。 XenServerのライセンスを購入するには、ここをクリックしてください。

ワークロードバランスによるワークロードの最適化や集約化は、自動的に実行されるようにしたり、管理者が選択的に実行できるようにしたりできます。 また、特定のスケジュールに従ってサーバーの電源が自動的に切断されるように設定することもできます（夜間の使用電力を抑える場合など）。

ワークロードバランスは、プール内の仮想マシンの負荷を評価し、いずれかのしきい値に達した場合にそのサーバー上の仮想マシンを同一プール内のほかのサーバーに移行します。

ワークロードバランスでは、最適化の対象としてパフォーマンスまたは密度を選択できます。 これらの最適化モードは、特定のスケジュールに従って自動的に切り替えることもできます。 また、各リソース負荷の測定基準（CPU、ネットワーク、およびメモリ）のしきい値および重要度を調節して、環境に適した最適化が行われるように設定できます。

リソースプールの能力を評価するには、ワークロードバランスの履歴レポートを参照して、リソースプールやホストのヘルス状態、最適化や仮想マシンのパフォーマンス、および仮想マシンの移行履歴を確認します。


ワークロードバランス：はじめに

ワークロードバランス仮想アプライアンスをダウンロードして、以下の手順に従ってセットアップします。

  1. citrix.comのMy Accountから、ワークロードバランス仮想アプライアンスをダウンロードします。
  2. XenCenterの［ファイル］メニューから［インポート］を選択して、ウィザードの手順に従ってワークロードバランス仮想アプライアンスをインポートします。
  3. インポートした仮想アプライアンスの［コンソール］タブに表示されるウィザードの手順に従って、ワークロードバランス仮想アプライアンスを設定します。
  4. 「ワークロードバランスに接続する」の説明に従って、リソースプールをワークロードバランス仮想アプライアンスに接続します。

    これらの手順について詳しくは、『ワークロードバランスクイックスタート』を参照してください。

注： XenServer Enterprise Edition、XenServer Desktop+ Edition、またはXenServer Desktop Editionのライセンスが適用されたXenServerでは、XenCenterのプロパティペインに［WLB］タブが表示されます。 XenServer 6.5のライセンスについて詳しくは、「ライセンスの概要（XenServer 6.5）」を参照してください。 XenServerのライセンスを購入するには、ここをクリックしてください。


ワークロードバランスの基本概念

ワークロードバランスでは、仮想マシンと物理マシンのリソースパフォーマンスに関するデータが収集されます。 これらのデータと管理者による設定に基づいて、リソースプールを最適化するために仮想マシンをどのサーバーに再配置（移行）するかが計算され、推奨項目として提示されます。 ワークロードバランスでは、パフォーマンスデータが内部データベースに格納されます。このため、ワークロードバランスの動作期間が長くなると、より正確な推奨項目が提供されるようになります。

ワークロードバランスによる推奨項目では、リソースプールの稼働効率（パフォーマンスまたは密度）を最適化するために、仮想マシンのワークロードをプール内でどのように再配置するかが示されます。 ワークロードバランスでは、以下のいずれかの最適化モードを選択できます。

  • パフォーマンス：サーバー上の物理リソース（CPU、メモリ、およびネットワーク）の使用効率を最適化します。 ワークロードバランスでパフォーマンスの最適化を選択すると、各仮想マシンが使用できるリソースの量が最大になるように再配置の推奨項目が作成されます。
  • 密度：サーバー上で実行される仮想マシンの数を最適化します。 ワークロードバランスで密度の最適化を選択すると、仮想マシンの計算能力を維持したまま、1台のサーバー上により多くの仮想マシンを配置して、リソースプール内で稼働するサーバーの数を最小化できます。

管理者は、最適化モード（パフォーマンスまたは密度）、電源管理機能、自動処理機能、測定基準の重要度、およびパフォーマンスしきい値を設定してワークロードバランスの動作を制御できます。

ワークロードバランスにより、高可用性機能の動作が影響を受けることはありません。両機能の設定が競合する場合は、常に高可用性機能の設定が優先されます。


ワークロードバランスに接続する

ワークロードバランス仮想アプライアンスをインポートして、ウィザードの手順に従って設定したら、リソースプールをその仮想アプライアンスに接続します。 これを行うには、XenCenterの［WLBサーバーへの接続］ダイアログボックスまたはxeコマンドを使用します。

注： XenServer Enterprise Edition、XenServer Desktop+ Edition、またはXenServer Desktop Editionのライセンスが適用されたXenServerでは、XenCenterのプロパティペインに［WLB］タブが表示されます。 XenServer 6.5のライセンスについて詳しくは、「ライセンスの概要（XenServer 6.5）」を参照してください。 XenServerのライセンスを購入するには、ここをクリックしてください。

要件

XenCenterでワークロードバランス仮想アプライアンスに接続するには、以下の情報が必要です。

  • ワークロードバランス仮想アプライアンスのIPアドレスまたは完全修飾ドメイン名（FQDN）、およびポート。
  • ワークロードバランスで監視するリソースプール（プールマスタ）の資格情報。
  • ワークロードバランス仮想アプライアンス上で作成したアカウントの情報。 このアカウントは、「ワークロードバランスユーザーアカウント」と呼ばれます。 このアカウントを使用して、XenServerがワークロードバランスと通信します （このアカウントは、ワークロードバランス仮想アプライアンスの設定時に作成します）。

［WLBサーバーへの接続］ダイアログボックスでワークロードバランス仮想アプライアンスのFQDNを指定する場合は、事前に仮想アプライアンスのホスト名をDNSに追加しておく必要があります。 信頼された機関からの証明書を使用する場合は、有効期限のないFQDNまたはIPアドレスを使用してください。

ワークロードバランスに接続した直後では、デフォルトのしきい値および設定に基づいてワークロードが最適化されます。 自動最適化モード、電源管理、および自動処理などの自動化機能は、デフォルトでは無効になっています。

重要： ワークロードバランスをしばらく使用して意図したとおりに推奨項目が生成されない場合は、パフォーマンスしきい値の設定を再評価することを強くお勧めします。「パフォーマンスしきい値設定の評価」を参照してください。 運用環境に合ったしきい値を設定することで、より適切な推奨項目が作成されるようになります。

ワークロードバランス仮想アプライアンスに接続するには

  1. XenCenterのリソースペインで、［XenCenter］ > <リソースプール名>の順に選択します。
  2. プロパティペインの［WLB］タブをクリックします。 XenCenterのプロパティペインの［WLB］タブは、適切なライセンスが適用されたXenServerで表示されます。 XenServerのライセンスについて詳しくは、「XenServerのライセンスについて」を参照してください。
  3. ［WLB］タブの［接続］をクリックします。 ［WLBサーバーへの接続］ダイアログボックスが開きます。
  4. ［サーバーのアドレス］セクションで、以下の情報を入力します。
    • ［アドレス］ボックスに、ワークロードバランスサーバーのIPアドレスまたはFQDNを入力します。 FQDNとは、「WLB-appliance-computername.yourdomain.net」などのアドレスを指します。
    • ［ポート］ボックスにポート番号を入力します。 このポートを使用して、XenServerがワークロードバランスと通信します

      デフォルトでは、XenServerはワークロードバランスサーバー（この場合はWeb Service Hostサービス）にポート8012で接続します。 ワークロードバランス仮想アプライアンスの設定時にポートを変更した場合は、［ポート］ボックスにそのポート番号を入力します。

      重要： ワークロードバランス仮想アプライアンスの設定時にポート番号を変更していない場合は、ここで変更しないでください。 ［WLBサーバーへの接続］ダイアログボックスで指定するポート番号は、仮想アプライアンスの設定時に指定したもの（およびファイアウォールで指定されたもの）と一致する必要があります。
  5. ［WLBサーバーの資格情報］で、ユーザー名（wlbuserなど）とパスワードを入力します。これらの情報は、XenServerがワークロードバランス仮想アプライアンスに接続するときに使用されます。 これらの資格情報は、ワークロードバランス仮想アプライアンスの設定時に作成したものである必要があります。 デフォルトのユーザー名は、wlbuserです。
  6. ［XenServerの資格情報］セクションで、手順1.で選択したプールにアクセスするためのユーザー名とパスワードを入力します。 これらの情報は、ワークロードバランス仮想アプライアンスがリソースプールの各サーバーに接続するときに使用されます。 ［現在のXenCenterの資格情報を使用する］チェックボックスをオンにすると、XenCenterでこのプールに接続したときの資格情報が適用されます。 役割ベースのアクセス制御（RBAC）で役割を割り当てたアカウントを使用する場合は、そのアカウントにワークロードバランス機能の管理許可が付与されていることを確認してください。 詳しくは、「RBAC役割の定義とアクセス権」を参照してください。
  7. ワークロードバランス仮想アプライアンスに接続したら、必要に応じてパフォーマンスしきい値や特定のリソースの優先度を変更できます。詳しくは、「ワークロードバランス設定の変更」を参照してください。


ワークロードバランスの基本タスク

ワークロードバランスは、電源管理、最適化モードのスケジュール化、レポート生成など、XenServer環境のワークロードを最適化するための多くの機能を持つ、強力なXenServerコンポーネントです。 管理者は、各リソース負荷の測定基準を微調整して、適切な最適化推奨項目が生成されるようにワークロードバランス機能を設定できます。

ワークロードバランスが有効なリソースプールでは、管理者は日常的に以下の2つの基本タスクを実行することになります。

  • 仮想マシンの起動に最適なサーバーを決定する。
  • ワークロードバランスにより提示された推奨項目を適用する

ワークロードバランスを使用するために必要なワークロードバランス仮想アプライアンスの入手および設定について詳しくは、『ワークロードバランスクイックスタート』を参照してください。

仮想マシンの起動に最適なサーバーを決定する

「仮想マシンの初期配置、移行、および再開に適したサーバーの選択」も参照してください。

ワークロードバランスが有効なリソースプールでは、シャットダウンまたは一時停止状態の仮想マシンを起動するとき、または仮想マシンを移行するときに、最適なサーバーが推奨項目として示されます。 この機能は、XenDesktop環境でも有用です。

ワークロードバランスの推奨項目を適用する

「最適化推奨項目の適用」も参照してください。

ワークロードバランスをしばらく使用すると、環境を最適化するための推奨項目が生成されるようになります。 たとえば、サーバー上の仮想マシン密度を最適化するようにワークロードバランスを設定すると、実行されている仮想マシンをより少ない数のサーバー上に集約するための推奨項目が生成されます。 自動モードを有効にしていない場合、生成された推奨項目を適用するかどうかを管理者が選択できます。

これらの基本タスクについては、本書の該当トピックで詳しく説明されています。 これらのタスクに加えて、環境のワークロードに関するレポート生成も頻繁に使用される機能です。この機能については、「ワークロードバランスレポートの生成と管理」を参照してください。

重要： ワークロードバランスをしばらく使用して意図したとおりに推奨項目が生成されない場合は、パフォーマンスしきい値の設定を再評価することを強くお勧めします。方法については、『ワークロードバランス管理者ガイド』を参照してください。 運用環境に合ったしきい値を設定することで、より適切な最適化推奨項目が作成されるようになります。


仮想マシンの初期配置、移行、および再開に適したサーバーの選択

ワークロードバランスが有効なリソースプールでは、オフライン状態の仮想マシンを再起動するときに、推奨起動サーバーとして最適な物理サーバーがXenCenterにより提示されます。 推奨起動サーバーは、星の数で示されます。

仮想マシンの推奨起動サーバーとして、host17が星の数で示されています。サーバーhost16には星が表示されておらず、仮想マシンの起動サーバーとして推奨されていません。ただし、このサーバーは選択可能なので、必要に応じて仮想マシンを起動することができます。host18には十分なメモリがないため、選択できない状態になっています。

仮想マシンの再配置

ワークロードバランスが有効なリソースプールでは、シャットダウンまたは一時停止状態の仮想マシンを起動するとき、または仮想マシンを移行するときに、最適なサーバーをXenCenterで確認できます。

この機能では、推奨ホストの評価が星の数で示されます。 ホスト名の横に白抜きの星（☆）が5つ表示される場合は、仮想マシンのホストとして最も不適切であることを意味します。 仮想マシンの起動または移行先のサーバーとして使用できないサーバーの名前はメニューで淡色表示され、選択できません。

通常、ワークロードバランスで推奨されたホスト上で仮想マシンを起動すると、より効率的に推奨項目が生成され、不要な推奨項目が生成されなくなります。

推奨起動サーバーとは

推奨起動サーバーとは、ワークロードのホストとして最適な物理サーバーを指します。 ワークロードバランスは、以下の点を考慮して推奨起動サーバーを決定します。

  • プール内の各サーバーで使用可能なリソース量。 最適化モードとしてパフォーマンスの最大化が選択されている場合、すべての仮想マシンが良好なパフォーマンスで動作するように、各ホスト上にバランス良く仮想マシンを配置しようとします。 密度の最大化が選択されている場合は、仮想マシンのリソースを維持したまま、サーバー上により多くの仮想マシンを配置しようとします。
  • プールで選択されている最適化モード（パフォーマンスの最大化または密度の最大化）。 パフォーマンスの最大化が選択されている場合、その仮想マシンが必要とするリソースの負荷が最も低いサーバーにその仮想マシンを配置しようとします。 密度の最大化が選択されている場合は、既に多くの仮想マシンをホストしているサーバーに仮想マシンを配置して、仮想マシンの実行サーバーの数を少なくしようとします。
  • その仮想マシンが必要とするリソースの量。 ワークロードバランスは、収集した仮想マシンの測定値を使用して、その仮想マシンが必要とするリソースの種類に応じて推奨起動サーバーを決定します。 たとえば、メモリリソースを必要とする仮想マシンについては、使用可能なCPUリソース量よりも空きメモリ量を優先して起動サーバーを決定します。 ただし、推奨起動サーバーの決定は、その仮想マシンを現在実行しているサーバーでリソース負荷が高いことが検出された場合にのみ行われます。

仮想マシンを最適なサーバーで起動するには

  1. XenCenterのリソースペインで、起動する仮想マシンを選択します。
  2. ［VM］メニューの［起動サーバー］を選択し、以下のいずれかを選択します。
    • 最適なサーバー： 選択した仮想マシンで要求されるリソースを持つ、ホストとして最も適したサーバーです。 ワークロードバランスでは、パフォーマンス測定値の履歴レコードと選択されている最適化モードに基づいて最適なサーバーが決定されます。 最適なサーバーの名前には、最も多くの星が表示されます。
    • ［最適なサーバー］の下に表示されるサーバー： 5つの星が表示されるサーバーは最も推奨されるサーバー（最適なサーバー）を示し、5つの白抜きの星が表示されるサーバーは推奨されないサーバーを示します。

仮想マシンを最適なサーバーで再開するには

  1. XenCenterのリソースペインで、再開する仮想マシンを選択します。
  2. ［VM］メニューの［再開サーバー］を選択し、以下のいずれかを選択します。
    • 最適なサーバー： 選択した仮想マシンで要求されるリソースを持つ、ホストとして最も適したサーバーです。 ワークロードバランスでは、パフォーマンス測定値の履歴レコードと選択されている最適化モードに基づいて最適なサーバーが決定されます。 最適なサーバーの名前には、最も多くの星が表示されます。
    • ［最適なサーバー］の下に表示されるサーバー： 5つの星が表示されるサーバーは最も推奨されるサーバー（最適なサーバー）を示し、5つの白抜きの星が表示されるサーバーは推奨されないサーバーを示します。


最適化推奨項目の適用

ワークロードバランスでは、リソースプールを最適化するために仮想マシンをどのように再配置（移行）すべきであるかというアドバイスが推奨項目として生成されます。 この推奨項目は、XenCenterの［WLB］タブに表示されます。

この図は、［WLB］タブに表示される［最適化の推奨項目］の一覧を示しています。 ［理由］列には、その推奨項目の目的が示されます。 ［操作］列には、最適化を達成するために推奨される操作の内容が示されます。 この場合、仮想マシンHA-prot-VM-7およびサーバーhost17.domain4.bedford4.ctx4に対する推奨項目が表示されています。

最適化推奨項目の基本

ワークロードバランスでは、以下の条件に基づいて推奨項目が生成されます。

  • 管理者が設定する最適化モード（「最適化モードの変更」を参照）。
  • 物理サーバー上のCPU、メモリ、およびネットワークについて収集されたパフォーマンス測定値。
  • リソースプール内でのホストの役割。 プールマスタ上にワークロードを配置する推奨項目は、ほかのサーバー上への配置が不可能な場合のみ生成されます （同様に、最適化モードとして密度の最大化が選択されているプールでは、仮想マシンの移行先としてプールマスタが選択されるのは最後になります）。

最適化推奨項目では、再配置すべき仮想マシン、その仮想マシンを実行しているホスト、および推奨される新しいホストが示されます。 また、仮想マシンの再配置が推奨される理由（CPU使用率の場合は「CPU」など）も示されます。

推奨項目を適用すると、その内容に基づいてすべての仮想マシンが自動的に移行されます。

ヒント： リソースプールに設定されている最適化モードを確認するには、XenCenterでそのリソースプールを選択して、［WLB］タブの［設定］セクションを参照します。

最適化推奨項目を適用するには

  1. リソースペインでリソースプールを選択して、［WLB］タブをクリックします。 選択したリソースプールの最適化が必要な場合は、［最適化の推奨項目］に内容が表示されます。
  2. 推奨項目を適用するには、［すべて実行］をクリックします。 ［最適化の推奨項目］の推奨項目に基づいて、すべての仮想マシンが移行されます。

    ［すべて実行］をクリックしたら、［通知］ビューの［イベント］ページで仮想マシンの移行状況を確認できます。

高可用性環境でのワークロードバランス

ワークロードバランス機能とXenServer高可用性機能が有効なリソースプールでは、これらの2つの機能が相互にどのように影響するかを理解する必要があります。 ワークロードバランスは、高可用性機能と競合しないように設計されています。 ワークロードバランスで生成される推奨項目と高可用性設定が競合する場合は、常に高可用性機能の設定が優先されます。 つまり、以下のようになります。

  • ［高可用性の設定］ダイアログボックスの［許可する障害数］ボックスの値を超える数のホストは、ワークロードバランスにより自動的に電源が切断されることはありません。
    • ただし、電源を切断することが推奨項目として提示される場合があります。 たとえば、高可用性で許可する障害数として1が設定されている場合に、ワークロードバランスにより2台のホストのシャットダウンが推奨されることがあります。 この推奨項目を適用しようとすると、「高可用性が保証されなくなる」という内容のエラーメッセージが表示されます。
    • 自動モードでワークロードバランスが動作する場合は、電源管理を有効にしても、高可用性で許可する障害数を超える数の推奨項目は無視されます。 この場合、ワークロードバランスのログファイルに「高可用性が有効なため電源管理推奨項目を適用できない」という内容のメッセージが記録されます。


ワークロードバランスレポート

ここでは、ワークロードバランスの履歴レポートと、これらのレポートに関する追加情報の参照先について説明します。

ワークロードバランスレポートを生成するには、ワークロードバランス仮想アプライアンスをインポートして、リソースプールをその仮想アプライアンスに接続しておく必要があります。

はじめに

ワークロードバランスでは、物理ホスト、リソースプール、および仮想マシンに関するレポートを生成できます。 以下の2種類のレポートが作成されます。

  • 日別データを表示する履歴レポート
  • ロールアップスタイルのレポート

ワークロードバランスでは、仮想マシンの移行回数などを記録した監査用のレポートも作成できます。

レポートの種類

ワークロードバランスでは、リソースプール、サーバー、および仮想マシンに関するいくつかの種類のレポートを生成できます。 詳しくは、「ワークロードバランスレポートの種類について」を参照してください。

レポートの生成

ワークロードバランスでは、レポートを生成して、PDFやスプレッドシートとしてエクスポートしたり印刷したりできます。 詳しくは、「ワークロードバランスレポートの生成と管理」を参照してください。


ワークロードバランスレポートの使用

ワークロードバランスレポートを使用すると、リソースプールの能力を評価したり、仮想マシンのヘルス状態を確認したり、設定したパフォーマンスしきい値の効果を評価したりできます。

パフォーマンスしきい値設定の評価

プールヘルスレポートを使用して、設定したしきい値の効果を評価できます。 ワークロードバランスでは各パフォーマンスしきい値にデフォルト値が設定されますが、 環境によっては調整が必要な場合があります。 これを行わないと、ワークロードバランスで適切な推奨項目が生成されません。

管理者による変更に対するトラブルシューティング

管理者による変更により何らかの問題が発生した場合は、プール監査記録レポートを参照して変更担当者（変更した管理者のユーザーアカウント）や変更内容を確認します。


ワークロードバランスレポートの生成と管理

ここでは、ワークロードバランス機能のレポートの生成、サブスクリプション、表示、印刷、およびエクスポートなど、基本的な使用方法について説明します。

ワークロードバランスレポートを生成するには

  1. XenCenterのリソースペインで、リソースプールを選択します。
  2. ［プール］メニューの［ワークロードレポートを表示］を選択します。
    ヒント： ［WLB］タブの［レポート］をクリックすることでも［ワークロードレポート］ダイアログボックスを開くことができます。
  3. ［ワークロードレポート］ダイアログボックスの［レポート］ペインの一覧で、生成するレポートの種類を選択します。
  4. ［開始日］および［終了日］を使用して、レポート期間を指定します。 選択したレポートの種類によっては、［ホスト］、［ユーザー］、および［オブジェクト］などのパラメータを選択します。
  5. ［レポートの実行］をクリックします。 ワークロードバランスレポートが生成されます。

ワークロードバランスレポートを使用するには

レポートを生成したら、ツールバーのボタンを使用してさまざまなタスクを実行できます。 ツールバーのボタンの名前は、マウスポインタをそのボタンに合わせると表示されます。

レポートツールバーのボタン：

ドキュメントマップ： サイズの大きなレポートを表示するときに便利なドキュメントマップが開きます。
ページ操作： レポートの次のページや前のページ、または特定のページを表示できます。
元のレポートに戻る： ドリルスルーレポートから元のレポートに戻ります。
注： このボタンは、プールヘルス履歴レポートなどのドリルスルーレポートでのみ使用可能になります。
生成停止： レポートの生成処理をキャンセルします。
印刷： レポートを印刷します。ページ数や部数など、標準的な印刷オプションを指定できます。
印刷レイアウト： レポートの印刷プレビューを表示します。 印刷プレビューを閉じるには、再度［印刷レイアウト］をクリックします。
ページ設定： 用紙サイズ、印刷の向き、余白などの印刷オプションを指定できます。
エクスポート： Acrobat（PDF）形式またはExcel（XLS）形式のファイルとしてレポートをエクスポートします。
検索： 仮想マシンの名前など、特定の文字列を検索できます。

ワークロードバランスレポートを印刷するには

レポートを印刷するには、まずそのレポートを実行します。

  1. （オプション） ［ [image] 印刷レイアウト］をクリックして、レポートの印刷プレビューを確認します。
  2. （オプション） ［ [image] ページ設定］をクリックして、用紙サイズ、印刷の向き、余白などの印刷オプションを指定します。
  3. ［ [image] 印刷］をクリックします。

ワークロードバランスレポートをエクスポートするには

ワークロードバランスレポートは、Acrobat（PDF）形式またはExcel（XLS）形式のファイルとしてエクスポートできます。

レポートを生成したら、［ [image] エクスポート］をクリックし、以下のいずれかのオプションを選択します。

  • Excel
  • Acrobat（PDF）ファイル
注： レポートをエクスポートする場合のデータ量は、エクスポート形式により異なります。 Excel形式にエクスポートするレポートには、「ドリルダウン」データを含め、すべてのデータが含まれます。XenCenterで表示するレポートおよびPDF形式にエクスポートするレポートには、レポート生成時に選択したデータしか含まれません。


ワークロードバランスレポートの種類について

ここでは、ワークロードバランスの各レポートについて説明します。

チャージバック使用解析

このレポートでは、組織内の特定の部署で使用されたリソース（物理サーバーなど）の量を確認できます。 具体的には、リソースプール内のすべての仮想マシンのアベイラビリティやリソース使用などの情報が含まれます。 このレポートには仮想マシンのアベイラビリティ（「アップタイム」）が含まれるため、SLA（Service Level Agreement：サービス品質保証契約）に役立てることができます。

このレポートを使用して、課金用のシンプルなチャージバックソリューションを実装できます。 特定リソースの使用代金を顧客に課金するには、レポートを生成してExcelデータとして保存し、そのスプレッドシートをカスタマイズしたり、課金システムにインポートしたりできます。

組織内の部署または外部の顧客に仮想マシンの使用料を請求する場合は、仮想マシンの名前に部署や顧客の名前を含めることを検討します。 これにより、チャージバック使用解析レポートが読みやすくなります。

このレポートのリソース関連のデータは、個々の仮想マシンへの物理リソースの割り当てにより異なる場合があります。

同様に、XenServerではメモリ割り当てを固定したり動的メモリ制御（DMC）機能で自動化したりできるため、メモリの平均データはそのときに仮想マシンに割り当てられているメモリ量により異なります。

チャージバック使用解析レポートには、以下のデータ列が含まれます。

  • VM名： 仮想マシンの名前です。
  • VMアップタイム： 仮想マシンの実行時間（XenCenterで緑色のアイコンで表示される時間）を分単位で示したものです。
  • vCPU割り当て： その仮想マシンに割り当てられている仮想CPUの数です。 各仮想CPUには、そのホストの物理CPUから均等に割り当てられます。 たとえば、2つの物理CPUを持つホストで合計8つの仮想CPUを仮想マシンに割り当てた場合、この列の「1」はそのホストの全体的な処理能力の2/16を示します。
  • 最小CPU使用率（%）： レポート期間内に記録された仮想CPU使用率の最小値です。 この値はその仮想マシンの仮想CPUの能力に対するパーセンテージで示され、仮想CPUの能力はその仮想マシンに割り当てられている仮想CPUの数に基づきます。 たとえば、仮想マシンの作成時に1つの仮想CPUを割り当てた場合、その仮想CPU使用率の最小値が（たとえその継続時間が1秒間であっても）XenServerにより記録され、最小CPU使用率として示されます。 仮想マシンに2つの仮想CPUを割り当てた場合は、それらの合計能力に対する最小使用率が示されます。

    この最小CPU使用率は、仮想CPUが処理した最小ワークロードを示します。 たとえば、2.4GHzの物理CPUを持つサーバーで8つの仮想マシンをホストする場合、1つの仮想マシンに1つのCPUを割り当てると、2.4GHzの1/8、 つまり0.3GHz（300MHz）の能力が割り当てられます。ここで最小CPU使用率が20%であった場合、この仮想マシンでの物理サーバーCPUの最小使用量が60MHzであったことを示します。

  • 最大CPU使用率（%）： レポート期間内に記録された仮想CPU使用率の最大値です。 この値はその仮想マシンの仮想CPUの能力に対するパーセンテージで示され、仮想CPUの能力はその仮想マシンに割り当てられている仮想CPUの数に基づきます。 たとえば、仮想マシンの作成時に1つの仮想CPUを割り当てた場合、その仮想CPU使用率の最大値がXenServerにより記録され、最大CPU使用率として示されます。 仮想マシンに2つの仮想CPUを割り当てた場合は、それらの合計能力に対する最大使用率が示されます。
  • 平均CPU使用率（%）： 平均CPU使用率（%）。 レポート期間内に記録された仮想CPU使用率の平均値です。 この値はその仮想マシンの仮想CPUの能力に対するパーセンテージで示され、仮想CPUの能力はその仮想マシンに割り当てられている仮想CPUの数に基づきます。 仮想マシンに2つの仮想CPUを割り当てた場合は、それらの合計能力に対する平均使用率が示されます。
  • ストレージ割り当て合計（GB）： レポート期間内にその仮想マシンに割り当てられていたディスク容量です。 通常、この値は仮想マシンの作成時に割り当てたディスクのサイズを示します（作成後に変更していない場合）。
  • 仮想NIC割り当て： 仮想マシンに割り当てられている仮想インターフェイス（VIF）の数です。
  • 現在の最小動的メモリ（MB）：
    • 固定メモリ割り当て： 仮想マシンに特定のメモリ量（1024MBなど）を割り当てた場合、以下の列には同じ値が表示されます。現在の最小動的メモリ（MB）、現在の最大動的メモリ（MB）、現在のメモリ割り当て（MB）、および平均メモリ割り当て（MB）。
    • 動的メモリ割り当て： 仮想マシンに動的メモリ範囲を割り当てて自動的に調整されるようにした場合（つまり動的メモリ制御を有効にした場合）は、その範囲の最小メモリ量がこの列に表示されます。 たとえば、XenCenterの［メモリ設定］ダイアログボックスで［自動的に割り当てるメモリ範囲を指定する］オプションを選択し、最小メモリとして1024MB、最大メモリとして2048MBを指定した場合、［現在の最小動的メモリ（MB）］として「1024MB」が表示されます。
  • 現在の最大動的メモリ（MB）：
    • 動的メモリ割り当て： 仮想マシンに動的メモリ範囲を割り当てて自動的に調整されるようにした場合は、その範囲の最大メモリ量がこの列に表示されます。 たとえば、最小メモリとして1024MB、最大メモリとして2048MBを指定した場合、［現在の最大動的メモリ（MB）］として「2048MB」が表示されます。
    • 固定メモリ割り当て： 仮想マシンに特定のメモリ量（1024MBなど）を割り当てた場合、以下の列には同じ値が表示されます。現在の最小動的メモリ（MB）、現在の最大動的メモリ（MB）、現在のメモリ割り当て（MB）、および平均メモリ割り当て（MB）。
  • 現在のメモリ割り当て（MB）：
    • 動的メモリ割り当て： 動的メモリ制御を有効にした場合、レポート期間内に仮想マシンに割り当てられていたメモリ量が表示されます。
    • 固定メモリ割り当て： 仮想マシンに特定のメモリ量（1024MBなど）を割り当てた場合、以下の列には同じ値が表示されます。現在の最小動的メモリ（MB）、現在の最大動的メモリ（MB）、現在のメモリ割り当て（MB）、および平均メモリ割り当て（MB）。
    注： 仮想マシンのメモリ割り当てを変更した直後にこのレポートを実行した場合、この列には変更後の値が表示されます。
  • 平均メモリ割り当て（MB）：
    • 動的メモリ割り当て： 動的メモリ制御を有効にした場合、レポート期間内に仮想マシンに割り当てられていたメモリ量の平均値が表示されます。
    • 固定メモリ割り当て： 仮想マシンに特定のメモリ量（1024MBなど）を割り当てた場合、以下の列には同じ値が表示されます。現在の最小動的メモリ（MB）、現在の最大動的メモリ（MB）、現在のメモリ割り当て（MB）、および平均メモリ割り当て（MB）。
    注： 仮想マシンのメモリ割り当てを変更した直後にこのレポートを実行した場合、この列の値に変更内容が反映されない場合があります。 この列には、指定した期間での平均値が表示されます。
  • 平均ネットワーク読み取り（bps）： レポート期間内に仮想マシンが受信したデータ量（1秒あたりのビット数）の平均値です。
  • 平均ネットワーク書き込み（bps）： レポート期間内に仮想マシンが送信したデータ量（1秒あたりのビット数）の平均値です。
  • 平均ネットワーク使用（bps）： 平均ネットワーク読み取りと平均ネットワーク書き込みの合計データ量（1秒あたりのビット数）です。 たとえば、レポート期間内に仮想マシンが平均1,027bpsのデータを送信し、平均23,831bpsのデータを受信した場合、平均ネットワーク使用の値は24,858bpsになります。
  • ネットワーク使用合計（bps）： レポート期間内に行われたネットワーク読み取りおよび書き込みトランザクションの合計値です。

ホストヘルス履歴

このレポートでは、特定のホスト上のリソース（CPU、メモリ、ネットワーク読み取り、およびネットワーク書き込み）のしきい値に対するパフォーマンスが示されます。

各しきい値は、色つきの線（赤、緑、黄色）で示されます。 このレポートとプールヘルスレポートを使用して、特定ホストのパフォーマンスがリソースプールのパフォーマンスにどう影響しているかを評価できます。 パフォーマンスしきい値を変更する場合は、このレポートでホストのパフォーマンスを確認します。

リソース使用のデータは、日別または時間別の平均値として表示できます。 時間別の平均値では、その日のピーク時刻を確認できます。

時間別のデータを表示するには、［ホストヘルス履歴］タイトルバーの下の［クリックして特定期間内の時間別レポートデータを表示します］をクリックします。

このレポートには、指定した期間の時間別平均値が表示されます。 つまり、データポイントは、指定期間のすべての日の特定時刻の平均使用量に基づいています。 たとえば、2009年5月1日から2009年5月15日までのレポートの場合、［平均CPU使用率］のデータポイントはこの15日間の午後12時のリソース使用の平均を示します。 つまり、5月1日の午後12時のCPU使用率が82%、5月2日の午後12時が88%、残りの日の午後12時がすべて75%だった場合、午後12時の平均値として76.3%が表示されます。

プールの最適化パフォーマンス履歴

このレポートでは、最適化イベント（つまり管理者がリソースプールを最適化したとき）がリソースプールの平均リソース使用に対して示されます。 このレポートに表示されるリソース使用は、CPU、メモリ、ネットワーク読み取り、およびネットワーク書き込みです。

点線は、指定した期間のプール内の平均リソース使用を示します。 青いバーは、プールを最適化した日を示します。

このレポートを使用して、設定したワークロードバランスが意図したとおりに動作しているかどうかを評価できます。 また、何が最適化イベントの原因になっているか（つまりワークロードバランスの推奨項目生成前のリソース使用）を確認できます。

このレポートには、その日の平均リソース使用が表示され、システムに高負荷がかかった場合などのピーク時のデータは表示されません。 また、ワークロードバランスの推奨項目を適用しなかった場合のプールのパフォーマンスを確認することもできます。

通常、最適化イベントの後はリソース使用が低下または安定化しなければなりません。 最適化してもリソース使用が改善しない場合は、しきい値の調整を検討します。 また、リソースプール内の仮想マシンが多すぎないかどうか、指定した期間に仮想マシンの追加や削除がなかったかどうかを確認してください。

プール監査記録

このレポートには、XenServerの監査ログの内容が表示されます。この監査ログには、インポートやエクスポート、サーバーやプールのバックアップ、仮想マシンやサーバーのコンソールへのアクセスなどの操作が記録されます（許可されていない操作を実行しようとした場合も記録されます）。 役割ベースのアクセス制御機能で各XenServer管理者に役割を割り当てた環境では、このレポートでより詳しい情報を取得することができます。 監査ログ機能については、『ワークロードバランス管理者ガイド』を参照してください。

重要： 監査ログレポートを実行するには、監査ログ機能を有効にする必要があります。 デフォルトでは、ワークロードバランス仮想アプライアンスの監査ログ機能が常に有効になっています。

プール監査記録レポートでは、監査ログレポートに収集されるデータの詳細度を指定できます。 また、特定のユーザー、オブジェクト、および時間を指定して監査記録ログの内容を検索したりフィルタとして適用したりできます。 ［プール監査記録レポートのデータ量］は、デフォルトで［最小］に設定されています。 この設定により、ユーザーおよびオブジェクトの種類についての限定された量のデータが収集されます。 この設定は、レポートで必要な情報の詳細度に応じていつでも変更できます。 たとえば、［中］を設定すると、監査ログのユーザーフレンドリなレポートが生成されます。 詳細なレポートが必要な場合は、［最大］を設定します。

プール監査記録レポートのデータ量設定を変更するには

  1. ［インフラストラクチャ］ビューでプールを選択して［WLB］タブをクリックし、［設定］をクリックします。
  2. ダイアログボックス左側の［詳細］をクリックします。
  3. ［詳細］ページの［プール監査記録レポートのデータ量］のドロップダウンリストから、データ量のオプションを選択します。
    重要： レポートで必要な情報の詳細度に適したオプションを選択してください。 たとえば、［最小］を設定すると、特定のユーザーおよびオブジェクトの種類についての限定された量のデータのみが収集されます。 ［中］を設定すると、監査ログのユーザーフレンドリなレポートが生成されます。 ［最大］を設定すると、監査ログの詳細なレポートが生成されます。 ただし、これによりワークロードバランスサーバーでより多くのディスク領域およびメモリが消費される点に注意してください。
  4. ［OK］をクリックして変更を適用します。

このレポートに表示される内容は以下のとおりです。

  • 時間： ユーザーアクションの記録日時です。
  • ユーザー名： そのアクションを実行したときのセッションを作成した管理者のユーザーアカウントです。 ユーザーIDが表示される場合もあります。
  • イベントオブジェクト： アクションの対象オブジェクト（仮想マシンなど）です。
  • イベントアクション： アクションの内容です。 詳しくは、「監査記録でのイベント名」を参照してください。
  • アクセス： その管理者に当該アクションの実行が許可されていたかどうかが示されます。
  • オブジェクト名： 対象オブジェクトの名前（仮想マシン名など）です。
  • オブジェクトUUID： 対象オブジェクトのUUID（仮想マシンのUUIDなど）です。
  • 成功： アクションの実行結果（成功したかどうか）を示します。

プールヘルス

プールヘルスレポートには、リソースプールおよびそのホストでの時間およびリソースの使用率が表示されます。これらの情報は、限界しきい値、高しきい値、中しきい値、および低しきい値の平均パーセンテージで示されます。 このレポートを使用して、設定したしきい値の効果を評価できます。

このレポートの内容は以下のとおりです。

  • ［中しきい値の平均］（青）は、最適化モードの設定にかかわらず、好ましいリソース使用を示します。 同様に、円グラフの青い部分は、そのサーバーのリソース使用が良好だった期間を示します。
  • ［低しきい値の平均（%）］（緑）は、必ずしも好ましいリソース使用を示すとは限りません。 低しきい値のリソース使用が好ましいかどうかは、最適化モードの設定によって異なります。 たとえば、最適化モードとして［密度を最大化］を選択したリソースプールで、ほとんどの期間のリソース使用が緑で示される場合、ワークロードバランスでホストまたはプールの仮想マシンの密度が最大化されていないことが考えられます。 この場合は、リソース使用の多くが［中しきい値の平均］（青）で示されるようになるまで、パフォーマンスしきい値を調整します。
  • ［限界しきい値の平均（%）］（赤）は、平均リソース使用が限界しきい値以上になった期間を示します。

サーバーのリソース使用の円グラフをダブルクリックすると、そのサーバーのリソース（CPUなど）についてのホストヘルス履歴レポートが表示されます。 プールヘルス履歴レポートに戻るには、ツールバーの［元のレポートに戻る］ボタンをクリックします。 注：このボタンは、プールヘルス履歴レポートなどのドリルスルーレポートでのみ使用可能になります。

このレポートで示される値の大半が［中しきい値の平均］の範囲に収まらない場合は、このリソースプールのパフォーマンスしきい値を調整します。 ワークロードバランスでは各パフォーマンスしきい値にデフォルト値が設定されますが、環境によっては調整が必要な場合があります。 これを行わないと、ワークロードバランスで適切な推奨項目が生成されません。 詳しくは、「しきい値の変更」を参照してください。

注： 高、中、および低しきい値の範囲は、限界しきい値に基づいて自動的に決定されます。

プールヘルス履歴

このレポートでは、リソースプール内のすべての物理サーバーのリソース使用が線グラフで示されます。 これにより、しきい値（限界、高、中、および低）に関して、リソースの使用傾向を確認できます。 このレポートのデータポイントの傾向を監視することで、設定したパフォーマンスしきい値の効果を評価できます。

ワークロードバランスでは、管理者設定した限界しきい値に基づいて、高、中、および低しきい値の範囲が決定されます。 プールヘルスレポートが各しきい値状態で動作した期間を示すのに対し、プールヘルス履歴レポートは日別の平均リソース使用量を示します。

［平均空きメモリ］グラフを除き、データポインタの平均値が限界しきい値（赤線）以下に維持される必要があります。 ［平均空きメモリ］グラフの場合は、データポインタの平均値が限界しきい値（グラフの最下部）以上に維持される必要があります。 これは、このグラフが空きメモリを示すためで、ほかのリソースのしきい値とは異なり、許容最小値を限界しきい値として設定するためです。

このレポートの内容は以下のとおりです。

  • 平均使用量のグラフが［中しきい値の平均］（青線）に近い場合、最適化モードの設定にかかわらず、適切なリソース使用を示します。
  • ［低しきい値の平均］（緑）に近い場合は、必ずしも好ましいリソース使用を示すとは限りません。 低しきい値のリソース使用が好ましいかどうかは、最適化モードの設定によって異なります。 たとえば、最適化モードとして［密度を最大化］を選択したリソースプールで、平均使用量のグラフが多くの日で緑線以下の場合、ワークロードバランスでプールの仮想マシンの密度が最大化されていないことが考えられます。 この場合は、リソース使用の多くが［中しきい値の平均］（青）で示されるようになるまで、パフォーマンスしきい値を調整します。
  • リソースの平均使用のグラフが［限界しきい値の平均（%）］（赤）と交差する個所は、リソースの平均使用が限界しきい値以上になった日を示します。

グラフのデータポイントのうち大半が［中しきい値の平均］範囲外に表示され、それでもプールで良好なパフォーマンスが得られる場合は、パフォーマンスしきい値の調整を検討します。 詳しくは、「しきい値の変更」を参照してください。

プールの最適化履歴

プールの最適化履歴レポートでは、ワークロードバランスによる最適化処理の内容が時系列で示されます。

最適化処理は、グラフおよび表で示されます。 表の［日付］列の［+］をクリックすると、その日に実行された最適化処理の詳細が表示されます。

このレポートの内容は以下のとおりです。

  • VM名： ワークロードバランスにより最適化された仮想マシンの名前です。
  • 理由： 最適化の理由です。
  • 状態： 最適化処理が成功したかどうかを示します。
  • 移動元： 仮想マシンの移行元の物理サーバーです。
  • 移動先： 仮想マシンの移行先の物理サーバーです。
  • 時間： 最適化処理の実行時刻です。
ヒント： プールの最適化履歴レポートは、［WLB］タブの［履歴を表示］をクリックすることでも生成できます。

仮想マシン移動履歴

この線グラフでは、リソースプールでの仮想マシンの移動（移行）数が示されます。 仮想マシンの移行が推奨項目を適用した結果なのかどうか、および移行先のサーバーが表示されます。 また、このレポートでは移行理由も示されます。 このレポートを使用して、リソースプールの仮想マシンの移行を監査できます。

このレポートの内容は以下のとおりです。

  • グラフの左側の数値は、リソースプール内の仮想マシンの数に基づく、可能な移行数を示します。
  • レポートの［日付］列の［+］をクリックすると、その日に実行された移行処理の詳細が表示されます。

仮想マシンパフォーマンス履歴

このレポートでは、特定ホスト上の各仮想マシンのパフォーマンスデータが示されます。 ワークロードバランスでは、仮想マシンに割り当てられた仮想リソースの量に基づいてパフォーマンスデータが評価されます。 たとえば、仮想マシンの［平均CPU使用率］が67%である場合は、特定期間にその仮想マシンで平均67%の仮想CPUが使用されたことを示します。

このレポートの初期表示では、指定した期間でのリソース使用の平均値が示されます。

［+］をクリックすると、各リソースの線グラフが表示されます。 これにより、特定期間でのリソースの使用傾向を確認できます。

このレポートには、CPU使用率、空きメモリ、およびネットワーク読み取り/書き込みのデータが表示されます。


イベントの監査ログ

監査ログレポートには、XenServerのイベントやイベントオブジェクトだけでなく、インポート/エクスポート、サーバーやリソースプールのバックアップ、ゲストやサーバーのコンソールへのアクセスなどのアクションが記録されます。 次の表は、XenServer監査記録レポートおよびプール監査記録レポートに出力される主なイベントと、その出力データの量の一覧です。

プール監査記録レポートの［イベントアクション］列には、プール、仮想マシン、またはサーバーに関するイベントが出力されます。 何に関するイベントかを確認するには、［イベントオブジェクト］列と［オブジェクト名］列を参照してください。 イベントに関するより詳しい情報については、『Citrix XenServer Management API Guide』（英文）を参照してください。 プール監査記録レポートでの出力データ量の設定については、「詳細設定」を参照してください。

プール監査記録でのデータ量 | イベントアクション | ユーザーアクション
最小 | VM.start | 仮想マシンの起動
最小 | VM.copy | 特定の仮想マシンを複製して新規仮想マシンを作成
最小 | host.reboot | サーバーの再起動
最小 | host.disable | サーバーの無効化（追加の仮想マシンを起動できない状態）
最小 | pool.join | 新規プールへのホストの追加
最小 | pool.join_force | 新規プールへのホストの（強制）追加
中 | SR.destroy | ストレージリポジトリの破棄
中 | SR.create | 新規ストレージリポジトリの作成
中 | VDI.snapshot | VDIの読み取り専用スナップショットの作成。そのスナップショットの参照を返す
中 | VDI.clone | VDIの完全複製の作成。その新規ディスクの参照を返す
中 | VIF.plug | 特定VIFのホットプラグ。実行中の仮想マシンに動的に接続する
中 | VIF.unplug | 特定VIFのホットアンプラグ。実行中の仮想マシンから動的に接続解除する
最大 | auth.get_subject_identifier | 人間が判読できるサブジェクト名からサブジェクト識別子を文字列として取得するための外部ディレクトリサービス照会
最大 | task.cancel | タスクのキャンセルの要求
最大 | VBD.insert | デバイスへの新規メディアの挿入
最大 | VIF.get_by_uuid | 指定UUIDによるVIFインスタンスへの参照取得
最大 | VDI.get_sharable | VDIの共有可能フィールドの取得
最大 | SR.get_all | システムで既知の全ストレージリポジトリ一覧の取得
最大 | pool.create_new_blob | このリソースプールに関連付けられた名前付きバイナリBLOB用のプレースホルダ作成
最大 | host.send_debug_keys | デバッグキーとしての文字列のXenへの送信
最大 | VM.get_boot_record | 仮想マシンの動的状態レコードの取得。仮想マシンの起動時に初期化され、実行時の構成内容の変更（CPUホットプラグなど）により更新される


ワークロードバランス設定の変更

ワークロードバランス仮想アプライアンスに接続したら、再配置や最適化の推奨項目を計算するための設定を変更できます。 以下の設定を変更できます。
  • 最適化モードの変更
  • 自動処理と電源管理の設定
  • しきい値の変更
  • 測定基準の重要度の変更
  • 推奨項目からのホストの除外
  • 詳細設定
注： ワークロードバランス仮想アプライアンスへの接続または再接続直後に設定を変更する場合は、60秒以上（ログ/var/log/wlb/LogFile.logに検出の完了が示されます）待機する必要があります。

ワークロードバランス設定が適用されるしくみ

ワークロードバランスの設定は、リソースプールに属するすべてのホストおよび仮想マシンに適用されます。

ネットワークのパフォーマンスがその環境のハードウェアに適したものである場合は、まずデフォルトの設定でワークロードバランスを使用します。

ワークロードバランス機能をしばらく運用した後で、パフォーマンスのしきい値を評価して、必要に応じて変更することをお勧めします。 たとえば、以下の場合に設定の変更を検討します。
  • 最適化の推奨項目が必要以上に生成される。 この場合、適切な推奨項目が生成されるようになるまでしきい値を調整します。
  • ネットワーク帯域幅が十分でないにもかかわらず推奨項目が生成されない。 この場合、適切な推奨項目が生成されるようになるまでネットワークのしきい値を下げます。

しきい値を変更する前に、リソースプール内の各物理サーバーについてホストヘルス履歴レポートを作成すると便利です。

設定を変更するには、XenCenterの［ワークロードバランス設定］ダイアログボックスや、xeコマンドラインインターフェイスを使用します。

XenServerとワークロードバランスサーバーとの通信で使用される資格情報を変更する方法については、「ワークロードバランスの資格情報の変更」を参照してください。

ワークロードバランス設定の情勢について詳しくは、『ワークロードバランス管理者ガイド』を参照してください。

［ワークロードバランス設定］ダイアログボックスを開くには

  1. XenCenterのリソースペインで、リソースプールを選択します。
  2. プロパティペインの［WLB］タブをクリックします。
  3. ［WLB］タブの［設定］をクリックします。


最適化モードの変更

ワークロードバランスでは、仮想マシンの実行によるワークロードを再配置（つまり最適化）するための推奨項目が生成されます。この推奨項目は、管理者が選択する最適化モードに基づいて計算されます。

パフォーマンスの最大化と密度の最大化

最適化モードには、以下の2つがあります。
  • パフォーマンスを最大化： （デフォルト） リソースプール内のすべての物理ホスト上に仮想マシンを均等に配置します。 これにより、すべてのホストのCPU、メモリ、およびネットワーク負荷を最小化できます。 この最適化モードでは、仮想マシンが高しきい値に達すると最適化の推奨項目が生成されます。

  • 密度を最大化： 1台の物理サーバー上に可能な限り多くの仮想マシンを配置します。 これにより、リソースプール内で稼働する物理サーバーの数を最小化できます。

    この最適化モードでは、［パフォーマンスを最大化］を選択した場合と同様のしきい値を使用できます。 ただし、これらのしきい値は、1台のサーバーにどれだけ多くの仮想マシンを配置できるかを評価するために使用されます。 この最適化モードでは、仮想マシンが限界しきい値に達すると最適化の推奨項目が生成されます。

これらの最適化モードは、永続的に適用（固定）したり、特定のスケジュールに基づいて適用（スケジュール指定）したりできます。

固定

最適化モードを固定すると、選択したモード（パフォーマンスの最大化または密度の最大化）が常に使用されます。

スケジュール指定

最適化モードのスケジュールを指定すると、指定したスケジュールに基づいてモードを切り替えることができます。 たとえば、多くのエンドユーザーが作業する日中にパフォーマンスを最大化するモードを適用し、使用電力を抑えるために夜間は密度を最大化するモードを適用できます。

最適化モードのスケジュールを指定すると、その期間（曜日および時刻）に最適化モードが自動的に切り替わります。

常時適用する最適化モードを設定するには

  • リソースペインでプールを選択して［WLB］タブをクリックし、［設定］をクリックします。
  • ダイアログボックス左側の［最適化モード］をクリックします。
  • ［固定］をクリックして、以下のいずれかの最適化モードを選択します。
    • パフォーマンスを最大化： （デフォルト） リソースプール内のすべての物理ホスト上に仮想マシンを均等に配置します。 これにより、すべてのホストのCPU、メモリ、およびネットワーク負荷を最小化できます。
    • 密度を最大化： 1台の物理サーバー上に可能な限り多くの仮想マシンを配置します。 これにより、リソースプール内で稼働する物理サーバーの数を最小化できます。 ただし、ワークロードバランスでは、集約された仮想マシンのパフォーマンスも考慮され、ホストのリソースが限界しきい値に達すると、パフォーマンスを改善するための推奨項目が生成されます。

最適化モードを切り替えるスケジュールを指定するには

  • リソースペインでプールを選択して［WLB］タブをクリックし、［設定］をクリックします。
  • ダイアログボックス左側の［最適化モード］をクリックします。
  • ［スケジュール指定］をクリックします。
  • ［新規追加］をクリックします。［最適化モードのスケジュール］ダイアログボックスが開きます。
  • ［モード］ボックスで最適化モードを選択します。
    • パフォーマンスを最大化： リソースプール内のすべての物理ホスト上に仮想マシンを均等に配置します。 これにより、すべてのホストのCPU、メモリ、およびネットワーク負荷を最小化できます。
    • 密度を最大化： 1台の物理サーバー上に可能な限り多くの仮想マシンを配置します。 これにより、リソースプール内で稼働する物理サーバーの数を最小化できます。
  • 選択した最適化モードに切り替える曜日および時刻を選択します。
  • 必要に応じて、スケジュールを追加します。 追加したスケジュールが1つのみの場合、そのスケジュールに基づいて切り替わった最適化モードが元に戻らなくなります。
  • ［OK］をクリックします。

最適化モードのスケジュールを削除または一時停止するには

  1. リソースペインでプールを選択して［WLB］タブをクリックし、［設定］をクリックします。
  2. ［最適化モード］をクリックします。
  3. 変更するスケジュールを選択して、以下のいずれかを行います。
    • タスクを削除する： ［削除］ボタンをクリックします。
    • タスクを一時的に停止する： タスクを右クリックして、［無効化］を選択します。

    無効にしたタスクを有効にするには、タスクを右クリックして［有効化］を選択します。

最適化モードのスケジュールを変更するには

  1. リソースペインでプールを選択して［WLB］タブをクリックし、［設定］をクリックします。
  2. ［最適化モード］をクリックし、既存のタスクを選択します。
  3. ［編集］をクリックします。
  4. ［最適化モードのスケジュール］ダイアログボックスで、必要な変更を行います。


自動処理による電源の最適化と管理

ワークロードバランスによる最適化推奨項目が自動的に適用されるように設定することができます（ワークロードバランスの自動処理機能）。また、サーバーの電源を自動的に投入したり切断したりすることもできます（電源管理機能）。

最適化推奨項目の自動適用

ワークロードバランスで生成された最適化推奨項目を、管理者の介在なしに自動的に適用することができます。 この自動処理機能を使用すると、生成される推奨項目に基づいて、自動的にパフォーマンスを最適化したりサーバーの電源を切断したりできます。 ただし、仮想マシンの使用が減少したときにホストの電源を落として消費電力を抑えるには、自動処理のほか、電源管理と密度の最大化モードを設定する必要があります。

ワークロードバランスのデフォルトでは、推奨項目が自動的に適用されることはありません。 生成された推奨項目が自動的に適用（実行）されるようにするには、自動処理機能を有効にする必要があります。 この機能を有効にしない場合、管理者が、生成された推奨項目を実行するかどうかを選択します。

ワークロードバランスで生成された推奨項目が高可用性の設定と競合する場合、その推奨項目は自動的には適用されません。 推奨項目の適用によりプールがオーバーコミット状態になる場合は、それを適用するかどうかを確認するメッセージが表示されます。 自動処理を有効にしても、高可用性で許可する障害数を超える数の電源管理推奨項目は無視され、自動的には適用されません。

自動モードのワークロードバランスで推奨項目がどのように適用されるかを変更することができます。 詳しくは、「詳細設定」を参照してください。

電源管理の有効化

ワークロードバランスの電源管理機能は、 リソースプールの全体的なワークロードに応じて物理ホストの電源を投入したり切断したりするための機能です。

ワークロードバランスの電源管理機能を使用するには、以下の条件を満たす必要があります。
  • サーバーのハードウェアがリモートからの電源投入/切断をサポートしている。
  • ホストの電源投入機能が設定されている。
  • ホストが電源管理の対象として明示的に選択されている。
また、この機能でサーバーの電源を自動的に切断する場合は、以下の設定を行う必要があります。
  • ワークロードバランスの推奨項目が自動的に適用されるように設定されている。
  • ワークロードバランスの電源管理推奨項目が自動的に適用されるように設定されている。

電源管理と密度の最大化モードを有効にすると、使用されていないリソースがワークロードバランスにより検出され、そのホストの電源を切断するための推奨項目が生成されます。 サーバーの電源を切断するために必要なリソースがプールにない場合は、プールのワークロードが小さくなるまでそのサーバーを動作させておくことが推奨項目として提示されます。 余剰サーバーの電源を自動的に切断するように設定した場合は、電源を切るための推奨項目が自動的に適用されます。

電源管理の対象ホストを指定すると、そのホストの電源を投入したり切断したりするための推奨項目が生成されます。 これらの電源管理推奨項目の自動処理を有効にする場合、リソースプール全体に適用されます。 ただし、電源管理の対象ホストは個別に選択できます。

電源管理のしくみ

ワークロードバランスによりホストの電源が切断される前に、そのサーバー上の仮想マシンの移行先ホストが選択されます。 移行先ホストは、以下の順序で決定されます。
  1. プールマスタが最初の移行先ホストになります。これは、プールマスタの電源が切断されることがないためです。
  2. 次に、より多くの仮想マシンを実行しているホストが選択されます。
  3. 以降、実行している仮想マシンの数が多いホストから順番に選択されます。

ワークロードバランスでプールマスタに仮想マシンを移行する場合、意図的に低いしきい値が使用されます。 これにより、プールマスタが過負荷状態になるのを防ぎます。

次の図は、リソースプールでの仮想マシン密度を最大化するための以降順序を示しています。

この図では、最適化モードとして［密度を最大化］が選択されている場合の仮想マシンの移行順序を示しています。仮想マシンの集約先として、まずプールマスタが選択され、次に実行仮想マシン数の多いサーバー、最後に実行仮想マシン数の少ないサーバーが選択されます。

最適化モードとして密度の最大化が選択されているプールでパフォーマンスに関する問題が検出されると、電源投入済みのホスト間での仮想マシンの移行を推奨して問題を解決しようとします。 この方法でパフォーマンスが改善されない場合、シャットダウン状態のホストの電源を投入します。 このとき、最適化モードとしてパフォーマンスの最大化が選択された場合と同じ条件に基づいて、電源投入するホストが決定されます。

最適化モードとしてパフォーマンスの最大化が選択されているリソースプールでは、すべてのホストのリソース使用が高しきい値を下回るまで、電源投入の推奨項目が生成されます。

仮想マシンを移行しているときに、オンライン状態のホストを増やすことでプール全体のパフォーマンスが改善するとワークロードバランスが判断した場合、自動的にホストの電源を投入したり、電源投入の推奨項目を生成したりします。
重要： ワークロードバランスでは、推奨項目により電源が切断されたホストに対してのみ、電源投入の推奨項目を生成します。

電源管理および仮想マシン集約のための環境設計

XenServerを実装して電源管理と仮想マシン集約を自動化する場合は、 以下の点を考慮して環境を設計します。

  • 異なる種類のワークロードを個別のプールに配置する： 異なる種類のワークロードを実行する場合は、それらの仮想マシンを個別のプールに配置することを検討します（たとえば、ユーザーアプリケーションとドメインコントローラの仮想マシンを分離したり、特定のハードウェアを使用するアプリケーションを専用のプールで実行したりするなど）。

    電源管理機能および仮想マシンの集約はプールレベルで管理されるため、「詳細設定」で説明されている点を考慮して、同じ比率で集約するワークロードが含まれるようにプールを設計する必要があります。

  • ワークロードバランスから除外するホストを指定する： 特定のホストをワークロードバランスの対象から除外して、常に電源が投入された状態にしておくことができます。 詳しくは、「推奨項目からのサーバーの除外」を参照してください。

最適化推奨項目を自動適用するには

  1. XenCenterのリソースペインで、［XenCenter］ノードからリソースプールを選択します。
  2. プロパティペインの［WLB］タブをクリックします。
  3. ［WLB］タブの［設定］をクリックします。
  4. ダイアログボックス左側の［自動処理］をクリックします。
  5. 以下のオプションを設定します。
    • 最適化推奨項目を自動的に適用する： このチェックボックスをオンにすると、管理者の介在なしに最適化推奨項目を適用できます。 ワークロードバランスにより自動的に最適化が行われ、仮想マシンが再配置されます。
    • 電源管理推奨項目を自動的に適用する： このチェックボックスによる動作は、リソースプールの最適化モードにより異なります。
      • パフォーマンスを最大化： ［電源管理推奨項目を自動的に適用する］チェックボックスをオンにすると、ホストのパフォーマンスを改善するためにオフラインホストの電源が自動的に投入されます。
      • 密度を最大化： ［電源管理推奨項目を自動的に適用する］チェックボックスをオンにすると、自動的に余剰サーバー（リソース使用が低しきい値を下回るサーバー）の電源が切断されます。
  6. 次のいずれかを行います。
    • ［電源管理推奨項目に含めるサーバー］で、電源管理の対象サーバーを選択します。詳しくは、下記「電源管理対象のサーバーを選択するには」を参照してください。
    • 電源管理を有効にしない場合は、［OK］をクリックして設定を確定します。

電源管理対象のサーバーを選択するには

  1. ［自動処理］ページの［電源管理推奨項目に含めるサーバー］の一覧で、ワークロードバランス機能で電源を投入/切断するサーバーを選択します。
    注： ［電源管理推奨項目を自動的に適用する］チェックボックスをオフにしたままこの一覧でサーバーを選択した場合、それらのサーバーに対する電源管理推奨項目は自動的には適用されません。
  2. ［OK］をクリックします。 リソースプール内にリモートからの電源管理をサポートするサーバーがない場合、「電源管理機能をサポートするホストがありません」というメッセージが表示され、ワークロードバランスの電源管理機能は動作しません。


しきい値の変更

ここでは、デフォルトの限界しきい値の変更方法と、高、中、および低しきい値がどのように変更されるかについて説明します。

これらの情報は、しきい値を変更するときのリファレンスとして提供されています。 このトピックで説明されている概念を理解するには、『ワークロードバランス管理者ガイド』をよく読んでください。

概要

ワークロードバランスは、日別の平均値を4つのしきい値（低、中、高、および限界）と比較して、リソース使用を評価します。XenCenterでしきい値を指定（またはデフォルトのしきい値を使用）すると、その値は限界しきい値として設定され、それを基にほかの3つのしきい値が相対的に決定されます。 最適化の推奨項目の生成を制御するために、限界しきい値を変更することができます。

ワークロードバランスでは、リソースプールの各物理サーバーのCPU、メモリ、ネットワーク読み取り、およびネットワーク書き込みの測定値が評価されます。

ワークロードの再配置を推奨項目として提示するか、および物理サーバーが仮想マシンのワークロードに適しているかは、以下を評価して決定されます。
  • 物理サーバー上のリソースの負荷が限界しきい値に達しているかどうか。
  • （限界しきい値に達していない場合は）各リソースの重要度。
注： ワークロードバランスでは、パフォーマンス測定値に急激な増加があっても平滑化され、日別の平均値が評価されます。

詳しくは、『ワークロードバランス管理者ガイド』を参照してください。

リソース負荷の履歴平均値がそのしきい値を超えると、ワークロードバランスで推奨項目が生成されます。 『ワークロードバランス管理者ガイド』で説明されているように、パフォーマンスの最大化では高しきい値、密度の最大化では低しきい値または限界しきい値を超えたときに、推奨項目が生成されます。 限界しきい値を変更すると、それに基づいてほかのしきい値が相対的に変更されます （XenCenter上で変更できるのは限界しきい値のみです）。

しきい値のデフォルト設定

次の表は、各しきい値のデフォルト値を示しています。
設定 | デフォルト | 高 | 中 | 低
CPU使用率 | 90% | 76.5% | 45% | 22.5%
空きメモリ | 51MB | 63.75MB | 510GB | 1020GB
ネットワーク読み取り | 25MB/秒 | 21.25MB/秒 | 12.5MB/秒 | 6.25MB/秒
ネットワーク書き込み | 25MB/秒 | 21.25MB/秒 | 12.5MB/秒 | 6.25MB/秒
限界しきい値を以下の数で乗じたものが高、中、および低しきい値として設定されます。
  • 高しきい値：0.85
  • 中しきい値：0.50
  • 低しきい値：0.25
空きメモリのしきい値は、限界しきい値を以下の数で乗じたものが使用されます。
  • 高しきい値：1.25
  • 中しきい値：10.0
  • 低しきい値：20.0

つまり、CPU使用率の限界しきい値を95%に変更した場合、高、中、および低しきい値がそれぞれ80.75%、47.5%、および23.75%に変更されます。

特定のしきい値についてこの計算を行うには、限界しきい値として指定した数値にこれらの数を乗じます。

高、中、または低しきい値 ＝ 限界しきい値 × 上記の数

たとえば、［ネットワーク読み取り］のしきい値を40MB/秒に変更した場合、低しきい値は40×0.25＝10MB/秒となり、 中しきい値は40×0.50で計算できます。

プールマスタとして動作するサーバーが過負荷状態にならないように、プールマスタには自動的に低いしきい値が適用されます。

ほかのしきい値により生成される推奨項目

多くの推奨項目は限界しきい値に基づいて生成されますが、ほかのしきい値により推奨項目が生成される場合もあります。

高しきい値：
  • パフォーマンスを最大化： 高しきい値を超えたときに、仮想マシンをリソース負荷の低いサーバー上に移行するための推奨項目が生成されます。
  • 密度を最大化： 追加の仮想マシンによりサーバーのいずれかのリソース負荷が高しきい値を超える場合、そのサーバー上に仮想マシンを移行する推奨項目が生成されなくなります。
低しきい値：
  • パフォーマンスを最大化： 推奨項目は生成されません。

  • 密度を最大化： リソース負荷が低しきい値を下回ると、仮想マシンをそのホスト上に集約するための推奨項目が生成されます。 そのサーバーのいずれかのリソース負荷が高しきい値に達するまで、仮想マシンの集約先としてそのサーバーの推奨が続行されます。

    仮想マシンの集約によりそのサーバーのリソース負荷が限界しきい値を超えた場合は、パフォーマンスの最大化の場合と同様のロードバランスアルゴリズムにより、仮想マシンの新しい集約先が検索されます。 リソースプール内のすべてのサーバーのリソース負荷が高しきい値を下回るまで、このアルゴリズムによる推奨項目の生成が続行されます。

しきい値を変更するには

  1. リソースペインでプールを選択して［WLB］タブをクリックし、［設定］をクリックします。
  2. ダイアログボックス左側の［しきい値］をクリックします。

  3. ［しきい値］ページでは、各リソース使用量の限界しきい値を設定できます。 ワークロードバランスでは、仮想マシンの推奨再配置先を計算するときに、これらの限界しきい値が使用されます。 各サーバーのリソース使用がこれらのしきい値を超えないように、仮想マシンによるワークロードを分散できます。


測定基準の重要度の変更

注： 測定基準の重要度を変更する前に、『ワークロードバランス管理者ガイド』を参照して、最適化および集約化のプロセスについて確認しておくことをお勧めします。 このヘルプトピックでは、これらのプロセスについて詳しくは説明しません。

ワークロードバランスでは、リソースに重要度を割り当てる測定基準の重要度を使用して、最初に最適化するサーバーが決定されます。

ワークロードバランスでは、選択されている最適化モード（パフォーマンスの最大化または密度の最大化）に基づいて最適化するホストや仮想マシンの順番を決定するときに、各リソース測定基準の重要度が考慮されます。

推奨項目を生成するときに、ホストを最適化するための順番が算出されます。 この順番は、高い重要度が割り当てられている測定基準の値をホスト間で比較することで決定されます。

測定基準の重要度は、最適化モードとしてパフォーマンスの最大化が選択されているリソースプールで主に使用されます。 ただし、密度の最大化が選択されている場合でも、限界しきい値を超えた測定基準では、その重要度が考慮されます。

パフォーマンスを最大化する場合の測定基準の重要度

パフォーマンスの最大化が選択されているリソースプールでは、測定基準の重要度により、どのホストのパフォーマンスを先に最適化するか、およびどの仮想マシンを先に移行するかが決定されます。

たとえば、［ネットワーク書き込み］を［重要度：高］に設定し、ほかの測定基準のスライダを中央に設定（重要度：中）した場合、ネットワーク書き込みの値が最も高いホストが先に最適化の対象になります。

密度を最大化する場合の測定基準の重要度

密度の最大化が選択されているリソースプールでは、ホストが限界しきい値に達した場合にのみ測定基準の重要度が考慮されます。その後、すべてのホストが限界しきい値を下回るまで、パフォーマンスを最大化する場合と同じアルゴリズムが使用されます。 このアルゴリズムでは、測定基準の重要度に基づいて、ホストを最適化するための順番が決定されます。

つまり、複数のホストで限界しきい値を超えている場合、その重要度がチェックされ、先に最適化するホストが決定されます。

たとえば、ホストAとホストBで構成されるリソースプールを例に説明します。
  • CPU使用率に高い重要度が設定されており、サーバーAのCPU使用率が限界値を超えています。
  • メモリ使用に低い重要度が設定されており、サーバーBのメモリ使用が限界値を超えています。

この場合、高い重要度の測定基準が限界しきい値に達しているサーバーAが先に最適化の対象になります。 次に、サーバーA上の仮想マシンのうち、CPU使用率の最も高いものを移行するための推奨項目が作成されます。

サーバーAに対する推奨項目を生成したら、サーバーBが最適化の対象になります。 サーバーB上の仮想マシンに対しても、CPU使用率の最も高いものを移行するための推奨項目が作成されます。これは、このリソースプールでCPU使用率に対して高い重要度が設定されているためです。

リソースプールにほかのサーバーがある場合は、サーバーのCPU使用率が高いものから順に最適化が行われます。

デフォルトでは、すべての測定基準の重要度が最大（［重要度：高］）に設定されます。
注： 測定基準の重要度は、相対的に処理されます。 つまり、すべての測定基準の重要度が同じ場合、その重要度レベルは意味を持ちません。 重要度の相対的な高低により、各測定基準の評価が決定されます。

測定基準の重要度を変更するには

  1. リソースペインでプールを選択して［WLB］タブをクリックし、［設定］をクリックします。
  2. ダイアログボックス左側の［測定基準の重要度］をクリックします。
  3. ［測定基準の重要度］ページでは、必要に応じて各リソースの重要度を調節できます。

    スライダを［重要度：低］側にドラッグすると、そのリソースの負荷は仮想マシンの再配置先の決定には影響しなくなります。


推奨項目からのホストの除外

ワークロードバランスを設定するときに、最適化および仮想マシン配置の推奨項目から除外する物理ホストを指定できます。

なぜサーバーを除外するのか

以下の状況では、特定のホストを推奨項目の対象から除外することを検討します。
  • プールの最適化モードとして［密度を最大化］を使用するが、特定のホストをこの最適化（仮想マシンの集約化とホストのシャットダウン）から除外する場合。
  • 2つの仮想マシンワークロードを常に同一ホスト上で実行する必要がある場合（それらの仮想マシンが相補的な場合など）。
  • 移行すべきでないワークロードがある場合（ドメインコントローラやSQL Serverなど）。
  • サーバーの保守作業の間、仮想マシンの移行先サーバーから除外する場合。
  • ハードウェアのコストよりもワークロードのパフォーマンスの方が重要な場合。
  • 特定のホスト上で優先度の高いワークロード（仮想マシン）を実行し、それらの仮想マシンに高可用性機能の優先度を設定したくない場合。
  • プール内のワークロードの実行に不適切なハードウェアを持つホストがある場合。

最適化モードのスケジュールを設定するかどうかに関係なく、最適化モードが変更されても除外サーバーは常に推奨項目の対象から除外されます。 このため、サーバーの電源が自動的に切断されるのを防ぐためだけの場合は、そのサーバーに対する電源管理機能を無効にすることを検討します。方法については、「自動処理による電源の最適化と管理」を参照してください。

最適化および仮想マシン配置の推奨項目からサーバーを除外するには

  1. リソースペインでプールを選択して［WLB］タブをクリックし、［設定］をクリックします。
  2. ダイアログボックス左側の［除外ホスト］をクリックします。
  3. ［除外ホスト］ページで、ワークロードバランスの推奨項目から除外するホストサーバーを選択します。


詳細設定

［詳細］ページでは、主に自動モードで動作するワークロードバランスで推奨項目をどのように自動適用するかを設定します。
重要：

ワークロードバランスをしばらく使用して意図したとおりに推奨項目が生成されない場合は、パフォーマンスしきい値の設定を再評価することを強くお勧めします。方法については、『ワークロードバランス管理者ガイド』を参照してください。 運用環境に合ったしきい値を設定することで、より適切な最適化推奨項目が作成されるようになります。

概要：推奨項目の自動適用の積極度

自動モードで動作するワークロードバランスでは、最適化および集約化の推奨項目の頻度や自動適用の積極度が以下の複数の要因により決定されます。
  • 移行後の仮想マシンを次の推奨項目に含めるまでの時間（VM移行間隔）
  • 推奨項目を自動的に適用するまでの作成回数（推奨項目の回数）
  • 推奨項目を自動適用するときの最低重要度レベル（最適化の重要度）
  • 推奨項目を自動適用するときの推奨項目の一貫性レベル（移動する仮想マシンや移動先サーバーとして同じものが推奨されるかどうか）

VM移行間隔

ワークロードバランスにより仮想マシンを移動した後で、その仮想マシンを含んだ新しい最適化推奨項目を生成するまでの時間を分単位で指定できます。

仮想マシンの移行間隔は、人為的な操作（一時的な高負荷時など）が原因で推奨項目が生成されるのを防ぐために設定します。

ワークロードバランスの自動処理機能を有効にした場合は、仮想マシンの移行間隔を特に慎重に決定する必要があります。 継続的および反復的に負荷が増加する環境で頻度を増やす（小さい値を設定する）と、多くの推奨項目が生成され、仮想マシンの再配置が頻繁に発生します。
注： この設定は、前回と同じサーバーを仮想マシンの起動または再開先サーバー、および保守モードの推奨項目に含むかどうかの決定には影響しません。

推奨項目の回数

ワークロードバランスでは、そのリソースプールで推奨項目の生成が必要かどうかが2分ごとにチェックされます。 ワークロードバランスの自動処理機能では、推奨項目をいくつ生成したら自動的に適用するかを指定できます。 これを行うには、［推奨項目の回数］を設定します。 ［推奨項目の回数］と［最適化の積極度］の設定により、推奨項目をどのように自動適用するかを微調整できます。

上記の概要で説明したように、ワークロードバランスでは、推奨項目の類似性に基づいてその推奨項目が必要かどうか、および仮想マシンの移行先サーバーのパフォーマンスが長時間安定しているかどうか（仮想マシンの再移行が発生しないように）が決定されます。 ［推奨項目の回数］では、推奨項目を自動適用するまでの作成回数を指定します。同じ推奨項目の生成がこの回数に達すると、その推奨項目が自動的に適用されます。

この設定は、以下のように使用されます。
  1. ［最適化の積極度］により決定される一貫性要件を満たす推奨項目が生成されるたびに、推奨項目の回数が増分されます。 一貫性要件を満たさない推奨項目が生成されると、（『ワークロードバランス管理者ガイド』で説明されている要因によっては）推奨項目の回数が0にリセットされます。
  2. 一貫性要件を満たす推奨項目の生成が［推奨項目の回数］の値に達すると、その推奨項目が自動的に適用されます。
この設定を変更する場合は、その環境に最適な値を決定する必要があります。 以下の点を考慮して設定します。
  • サーバーの負荷およびアクティビティが極端に急増する環境では、［推奨項目の回数］の値を大きくします。 推奨項目の生成が必要かどうかは、2分ごとにチェックされます。 推奨化項目を適用するまでの作成回数として3を設定すると、6分後に推奨項目が自動適用されます。
  • サーバーの負荷およびアクティビティが段階的に増加する環境では、［推奨項目の回数］の値を小さくします。

推奨項目を適用すると仮想マシンの再配置処理が発生し、システムリソースに負担がかかってパフォーマンスが影響を受けます。 ［推奨項目の回数］の値を大きくすると、推奨項目が自動適用されるまでに、同様の推奨項目が多く生成されることになります。つまり、より慎重で一貫した推奨項目だけが適用され、仮想マシンが不適切に移行される可能性が低くなります。 デフォルトでは、このような値が設定されています。

この値の変更は運用環境への影響が大きいため、Citrixのサポート担当者からの指示がない限り、上記のオプションを変更しないことをお勧めします。変更する場合は、ワークロードバランスの動作について詳細にテストしてください。

最適化の重要度

すべての最適化推奨項目には、その推奨項目がどれだけ大切であるかを示す重要度レベル（最重要、高、中、低）が設定されます。 この重要度レベルは、パフォーマンスしきい値や重要度などの設定と、ワークロードで使用可能なリソース、およびリソース使用履歴データに基づいて決定されます。

ワークロードバランスの推奨項目が自動的に適用されるように設定した場合、指定した最低重要度レベルを満たす推奨項目だけが適用されます。

最適化の積極度

自動モードで動作するワークロードバランスでは、一時的または異常な負荷の増加により仮想マシンの移行が行われないように、推奨項目の一貫性を判断するためのいくつかの基準が使用されます。 自動モードでは、最初に生成された推奨項目は自動適用されません。 サーバーや仮想マシンでその動作が継続的に発生することが検出されるまで、自動適用は行われません。 つまり、同じサーバーや仮想マシンが原因で推奨項目が生成される場合、その推奨項目は一貫していると判断されます。

ワークロードバランスでは、一貫性を判断するための条件と、同じ推奨項目をいくつ生成したか（連続推奨数）により、その環境の動作の一貫性が決定されます。 一貫性をどれだけ厳密に評価するかを制御するには、［最適化の積極度］を設定します。

この［最適化の積極度］設定は主にデモ用として設計されましたが、このオプションにより運用環境の安定性を制御することができます。 デフォルトでは、積極度が低く設定されています。 積極度を高くすると、推奨項目の類似性を評価するときの厳密度が低くなり、運用環境の安定性が低下します。

ワークロードバランスは、最大で4つの条件を使用して推奨項目の一貫性を判断します。 使用される条件の数は、［最適化の積極度］で設定されている積極度レベルにより異なります。 積極度レベルが［低］または［中］の場合、推奨項目は積極的には自動適用されません。 つまり、積極度レベルが低いと最適化条件が厳密に評価され、それらに合致しないと自動適用は行われません。

たとえば、積極度レベルとして［低］を設定すると、このレベルの条件に合致する推奨項目の数が［推奨項目の回数］の値に達するまで、その推奨項目は自動適用されません。

たとえば、［推奨項目の回数］に「3」を設定した場合、低レベル用のすべての条件に合致する推奨項目（『ワークロードバランス管理者ガイド』参照）が連続して3回生成されたときに、その推奨項目が自動適用されます。 これにより、長時間安定して動作しているサーバーに仮想マシンが移行されるようになり、 移行されたばかりの仮想マシンが、そのサーバーのパフォーマンスが低下したために再移行されるという可能性が低くなります。 デフォルトでは、積極度レベルとして［低］が設定されています。

［最適化の積極度］を高くしてサーバーの最適化頻度を上げることは、推奨されません。 サーバーの最適化がより高速または頻繁に行われるようにするには、パフォーマンスしきい値の調整を検討します。詳しくは、「しきい値の変更」を参照してください。

各積極度レベルで推奨項目の一貫性を判断するときに使用される条件については、『ワークロードバランス管理者ガイド』を参照してください。

推奨項目の自動適用が意図したとおりに行われない場合は、積極度の設定を高くします。 ただし、その前に『ワークロードバランス管理者ガイド』の内容を確認することを強く推奨します。

仮想マシン推奨項目の間隔を設定するには

  1. ［インフラストラクチャ］ビューでプールを選択して［WLB］タブをクリックし、［設定］をクリックします。
  2. ダイアログボックス左側の［詳細］をクリックします。
  3. ［詳細］ページで、以下の設定を行います。

    ［VM移行間隔］で、移行後の仮想マシンを最適化推奨項目に含めるまでの時間を、分単位で指定します。

    ［推奨項目の回数］で、最適化推奨項目が自動的に適用されるまでの作成回数を指定します。

    ［最適化の重要度］で、最適化推奨項目の最低重要度レベルを指定します。このレベルに達すると、推奨項目が自動的に適用されます。

    ［最適化の積極度］で、最適化推奨項目をどれだけ積極的に自動適用するかを指定します。

プール監査記録でのデータ量

ワークロードバランスのプール監査記録レポートでは、収集されるデータの量を指定できます。 また、特定のユーザー、オブジェクト、および時間を指定して監査記録ログの内容を検索したりフィルタとして適用したりできます。

［プール監査記録レポートのデータ量］は、デフォルトで［最小］に設定されています。 この設定により、ユーザーおよびオブジェクトの種類についての限定された量のデータが収集されます。 この設定は、レポートで必要な情報の詳細度に応じていつでも変更できます。 たとえば、［中］を設定すると、監査ログのユーザーフレンドリなレポートが生成されます。 詳細なレポートが必要な場合は、［最大］を設定します。
重要： ［プール監査記録レポートのデータ量］で［最大］を設定すると、ワークロードバランスサーバーでより多くのディスク領域およびメモリが消費されます。 このため、［最大］を設定する場合は、ワークロードバランスサーバーでのディスク消費およびCPU負荷を注意深く監視することをお勧めします。 ワークロードバランスサーバーでのリソース負荷が高い場合は、［プール監査記録レポートのデータ量］の設定を［中］または［最小］に変更するか、ワークロードバランスサーバー上のメモリやディスク領域を増やしてください。

詳しくは、「ワークロードバランスレポートの種類について」および「イベントの監査ログ」を参照してください。


ワークロードバランスの管理

ワークロードバランスでは、以下の管理タスクが必要になることもあります。
  • ワークロードバランスからの切断
  • プールのワークロードバランス仮想アプライアンスの変更
  • ワークロードバランスまたはXenServerで使用される資格情報の変更
ワークロードバランス仮想アプライアンスを管理するときに、ワークロードバランスサービスコマンドを使用することもできます。 これらのコマンドでは、ワークロードバランス仮想アプライアンスの状態を確認したり、ユーザーアカウントを変更したり、より詳細な情報がログに記録されるようにしたりできます。 これらのコマンドについて詳しくは、『ワークロードバランス管理者ガイド』を参照してください。
注： ワークロードバランスで別の証明書を使用したり、XenServerで証明書の同一性が検証されるように設定したりする方法については、『ワークロードバランス管理者ガイド』を参照してください。


ワークロードバランスからの切断

リソースプールのワークロードバランス機能を停止するには、ワークロードバランス仮想アプライアンスから切断してこの機能を無効にします。

リソースプールとワークロードバランス仮想アプライアンスとの接続を切断すると、そのリソースプールの情報がワークロードバランスデータベースから完全に削除されます。また、データコレクタの処理も停止します。 このため、同じワークロードバランス仮想アプライアンスに再接続してこの機能を有効にするには、［WLBサーバーへの接続］ダイアログボックスでアプライアンスの情報を再入力する必要があります。
重要： ワークロードバランス機能を一時的に停止するには、［WLB］タブの［一時停止］をクリックします。

ワークロードバランスから切断するには

  1. XenCenterのリソースペインで、リソースプールを選択します。
  2. ［プール］メニューの［ワークロードバランスサーバーの切断］を選択します。 ［ワークロードバランスサーバーの切断］ダイアログボックスが開きます。
  3. ［切断］をクリックします。これにより、このプールでのワークロードバランス機能が停止します。
    注： ワークロードバランス仮想アプライアンスから切断した後でこの機能を再度有効にするには、ワークロードバランス仮想アプライアンスに再接続する必要があります。


プールで使用するワークロードバランス仮想アプライアンスの変更

必要な場合は、リソースプールのワークロードバランス仮想アプライアンスを変更することができます。

変更後も古いワークロードバランス仮想アプライアンスによりプールのデータが収集されるのを防ぐため、新しい仮想アプライアンスに接続する前に古い仮想アプライアンスを切断しておく必要があります。

古いワークロードバランス仮想アプライアンスを切断したら、新しい仮想アプライアンスの名前を指定して接続します。

使用するワークロードバランス仮想アプライアンスを変更するには

  1. リソースペインでリソースプールを選択し、［プール］メニューの［ワークロードバランスサーバーの切断］を選択します。これにより確認のメッセージが表示されるので、［切断］をクリックします。 詳しくは、「ワークロードバランスからの切断」を参照してください。
  2. ［WLB］タブの［接続］をクリックします。 ［WLBサーバーへの接続］ダイアログボックスが開きます。
  3. ［アドレス］ボックスに、新しいワークロードバランス仮想アプライアンスのIPアドレスまたはFQDNを入力します。
    新しい仮想アプライアンスで異なる資格情報を使用する場合は、その情報を入力します。
    注： リソースプールでワークロードバランス仮想アプライアンスに初めて接続するときと同様に、すべての情報を入力する必要があります。 詳しくは、「ワークロードバランスに接続する」を参照してください。


ワークロードバランスの資格情報の変更

XenServerとワークロードバランス仮想アプライアンス間の通信で使用される資格情報を変更するには、以下の3つの操作を行います。
  1. ワークロードバランスから切断します（下記手順を参照）。
  2. WlbConfigファイルを編集して資格情報を変更します。これを行うには、ワークロードバランス仮想アプライアンスのコンソールでWlbConfigコマンドを実行します。 詳しくは、『ワークロードバランス管理者ガイド』を参照してください。
  3. ワークロードバランスを有効にして、新しい資格情報を指定します（下記手順を参照）。
以下の状況で、資格情報を変更できます。
  • XenServerがワークロードバランスと通信するときのユーザーアカウントを変更する必要がある。
  • ワークロードバランスの資格情報が無効になったというエラーメッセージが表示される。
  • サービスが使用できない。

ワークロードバランスのパフォーマンスしきい値や特定のリソースの優先度を変更する場合は、「ワークロードバランス設定の変更」を参照してください。

ワークロードバランスから切断するには

  1. XenCenterのリソースペインで、リソースプールを選択します。
  2. ［プール］メニューの［ワークロードバランスサーバーの切断］を選択します。 ［ワークロードバランスサーバーの切断］ダイアログボックスが開きます。
  3. ［切断］をクリックします。これにより、ワークロードバランスによるプールの監視が完全に停止します。

ワークロードバランスを再有効化して新しい資格情報を指定するには

  1. 処理が完了するのを進行状況バーで確認し、［接続］をクリックします。 ［WLBサーバーへの接続］ダイアログボックスが開きます。
  2. ［資格情報を変更する］をクリックします。
  3. ［サーバーのアドレス］セクションで、以下の情報を変更します。
    • ［アドレス］ボックスに、ワークロードバランス仮想アプライアンスのIPアドレスまたはFQDNを入力します。
    • （オプション） ワークロードバランス仮想アプライアンスの設定時にポートを変更した場合は、そのポート番号を入力します。 このポートにより、XenServerとワークロードバランスが通信します。
      デフォルトでは、ポート8012が指定されています。
      注： ワークロードバランス仮想アプライアンスの設定ウィザードでポート番号を変更した場合のみ、ここでポート番号を変更してください。 ［ワークロードバランス設定］ダイアログボックスで指定するポート番号は、ワークロードバランスのインストールウィザードで指定したポート番号と同じである必要があります。
  4. ［WLBサーバーの資格情報］セクションで、XenServerでワークロードバランスサーバーに接続するときに使用するユーザー名（wlbuserなど）およびパスワードを入力します。
  5. ［XenServerの資格情報］セクションで、リソースプールにアクセスするためのユーザー名とパスワード（通常プールマスタのパスワード）を入力します。 ワークロードバランスは、この情報を使用してリソースプールのサーバーに接続します。 ［現在のXenCenterの資格情報を使用する］チェックボックスをオンにすると、XenCenterでこのプールに接続したときの資格情報が適用されます。


ワークロードバランスが有効なときの保守モード

ワークロードバランスが有効なリソースプールでは、物理サーバーを保守のためにオフラインにする（つまり保守モードに切り替える）と、そのサーバー上でホストされているすべての仮想マシンが自動的にほかの適切なサーバーに移行されます。 仮想マシンの移行先ホストは、ワークロードバランスが最適化モードとパフォーマンスしきい値の設定、およびパフォーマンス測定値に基づいて計算した推奨項目により決定されます。

移行先サーバーが使用できない状態である場合は、［保守モードへの切り替え］ダイアログボックスに「ここをクリックしてVMを一時停止します」というメッセージが表示されます。 この場合、十分なリソースを持つサーバーがないため、ワークロードバランスでは推奨再配置先が提示されません。 管理者は、仮想マシンを一時停止するか、保守モードを終了してほかのホスト上のワークロードを軽減する（仮想マシンを一時停止するなど）などの処置を行います。 十分なリソースを持つほかのホストが使用可能になると、再度［保守モードへの切り替え］ダイアログボックスを開いたときに、推奨再配置先が提示されます。
注： ワークロードバランスが有効なリソースプールでサーバーを保守モードにすると、［保守モードへの切り替え］ダイアログボックスの右上に「ワークロードバランスが有効」が表示されます。

ワークロードバランスが有効なリソースプールでホストを保守モードにするには

  1. リソースペインでサーバーを選択して、次のいずれかを行います。
    • 右クリックして［保守モードへの切り替え］を選択します。
    • ［サーバー］メニューの［保守モードへの切り替え］を選択します。
  2. ［保守モードへの切り替え］をクリックします。 これにより、そのサーバー上で実行中のすべての仮想マシンが、最適化モードとパフォーマンスしきい値の設定、およびパフォーマンス測定値に基づいて決定される最適なサーバーに自動的に移行されます。

サーバーの保守モードを終了するには

  1. リソースペインでサーバーを選択して、次のいずれかを行います。
    • 右クリックして［保守モードからの切り替え］を選択します。
    • ［サーバー］メニューの［保守モードからの切り替え］を選択します。
  2. ［保守モードからの切り替え］をクリックします。

    これにより、そのサーバーでホストされていたすべての仮想マシンが自動的に復元されます。


ワークロードバランスのトラブルシューティング

ここでは、ワークロードバランスの問題を解決するための手順について説明します。 追加のトラブルシューティングについては、『ワークロードバランス管理者ガイド』を参照してください。

一般的な問題を解決するには、以下のヒントを参考にしてください。

一般的なトラブルシューティングのヒント

まず、ワークロードバランスのログファイルを参照します。 デフォルトでは、ワークロードバランス仮想アプライアンスの以下の場所にログファイルが作成されます。

/var/log/wlb

また、XenCenterの［通知］ビューの［イベント］ページでイベントログを表示することもできます。

エラーメッセージ

ワークロードバランス機能のエラーメッセージは、XenCenterの［通知］ビューの［アラート］ページ、および（一部のメッセージは）ダイアログボックス内に表示されます。


ワークロードバランスの資格情報入力時の問題

［WLBサーバーへの接続］ダイアログボックスで入力したワークロードバランス仮想マシンのユーザー名およびパスワードで接続できない場合は、以下の点を確認してください。
  • ワークロードバランス仮想アプライアンスがインポートされており、正しく設定されていることを確認します。また、すべてのサービスが実行されていることを確認します（サービスを実行するにはservice workloadbalancing startコマンドを実行します）。
  • 「ワークロードバランスの起動時の問題」を参照して、入力した資格情報が正しいことを確認します。
  • ワークロードバランスサーバーのFQDNを入力して問題が生じる場合は、IPアドレスを入力します。

［アドレス］ボックスには、ワークロードバランス仮想アプライアンスのホスト名を入力できますが、く完全修飾ドメイン名（FQDN）である必要があります。 たとえば、「yourcomputername.yourdomain.net」などの形式を使用します。


ワークロードバランスの起動時の問題

ワークロードバランス仮想アプライアンスをインポートして設定した後にXenServerとワークロードバランスとの接続エラーが発生する場合は、［WLBサーバーへの接続］ダイアログボックスに不正な資格情報を入力したことが考えられます。 この問題を解決するには、以下を行います。
  • ［WLBサーバーへの接続］ダイアログボックスに入力した資格情報と、ワークロードバランス仮想アプライアンスおよびXenServer上で作成したアカウントの情報が一致していることを確認します。
  • ［WLBサーバーへの接続］ダイアログボックスに入力した、ワークロードバランス仮想アプライアンスのIPアドレスまたはFQDNを確認します。
  • ［WLBサーバーへの接続］ダイアログボックスに入力した資格情報が、［WLBサーバーへの接続］ダイアログボックスに入力したものと一致することを確認します。


ワークロードバランスの接続エラー

XenCenterの［WLB］タブに接続エラーが表示される場合は、リソースプールのワークロードバランスを再設定してください。

これを行うには、［WLB］タブの［接続］をクリックして、サーバーの認証情報を再入力します。

通常、ワークロードバランス仮想アプライアンスやプールマスタの認証情報の変更や、ワークロードバランス仮想アプライアンスの名前の変更により、この問題が発生します。


ワークロードバランスサーバーの変更時の問題

リソースプールのワークロードバランスで使用するワークロードバランス仮想アプライアンスを変更するときに、元の仮想アプライアンスから切断してから新しい仮想アプライアンスに接続する必要があります。これを行わないと、両方の仮想アプライアンスでプールのデータが収集されます。

この問題を解決するには、変更前のワークロードバランス仮想アプライアンスをシャットダウンして削除します。または、その仮想アプライアンスがワークロードバランス機能を停止するように、手作業で各サービス（Analysis Engine、Data Collection Manager、およびWeb Services Host）を停止することもできます。

pool-initialize-wlbコマンドを使ってワークロードバランスを無効にしたり、ワークロードバランスサーバーを変更したりすることは推奨されません。


XenServerのライセンスについて

XenServerでは、ほかのCitrix製品と同じライセンス処理が行われます。 このため、Citrixライセンスサーバーとして動作するサーバー上に、XenServer用のライセンスをインストールする必要があります。 Citrixライセンスサーバーのインストールと実行については、Citrix eDocsを参照してください。

XenServerのサポート契約を購入すると、 .LIC ライセンスキーが提供されます。 このライセンスキーを、以下のいずれかのライセンスサーバーにインストールします。

  • Citrixライセンスサーバーソフトウェアが動作するWindowsサーバー
  • LinuxベースのCitrixライセンスサーバー仮想アプライアンス

XenServerのライセンス管理方法は、バージョンにより異なります。 XenServerの各バージョンでのライセンス管理については、以下のトピックを参照してください。

バージョン | トピック
XenServer 6.5 | ライセンスの概要（XenServer 6.5） XenServer 6.5でのライセンスの管理
XenServer v6.2.0 | ライセンスの概要（XenServer 6.2.0） XenServer 6.2.0でのライセンスの管理
XenServer v6.1.0およびそれ以前 | ライセンスの概要（XenServer 6.1.0およびそれ以前） XenServer 6.1.0およびそれ以前のバージョンでのライセンスの管理 無償のXenServer製品のアクティブ化


XenServer 6.2.0でのライセンスの管理

このトピックでは、XenServer Version 6.2.0のライセンスを管理する方法について説明します。

インストールした直後のXenServerは、ライセンスが適用されていない状態で動作します。 ライセンスが適用されていない状態でも各機能に対する制限はなく、XenServer 6.2.0のすべての機能を無償で使用できます。 ただし、以下を行う場合はCitrix XenServer Per-SocketまたはCitrix XenServer for XenDesktopライセンスが必要です。

  • Citrixのテクニカルサポートを受ける。
  • XenCenterを使用してHotfixを適用する。

XenServerのライセンスは、サーバー上のCPUソケットごとに必要で、プール内のすべてのサーバーに適用する必要があります。 ライセンス済みのサーバーとそうでないサーバーを同一プール内で混在させた場合、ライセンスが適用されていない状態として動作します。

XenServerライセンスを割り当てるには

  1. ［ツール］メニューの［ライセンスマネージャ］を選択します。
  2. ライセンスを割り当てるホストまたはプールを選択し、［ライセンスの割り当て］をクリックします。
  3. ［ライセンスの適用］ダイアログボックスで、ライセンスサーバーから割り当てるライセンスの種類を選択します。
    • Citrix XenServer Per-Socket：サーバー上の動作CPUソケットごとにライセンスを適用するには、このオプションを選択します。 このライセンスモデルは、XenServer Version 6.2.0に適用されます。
    • Citrix XenServer for XenDesktop：既存のCitrix XenServer for XenDesktopライセンスを適用するには、このオプションを選択します。
  4. ライセンスサーバーの詳細を指定して、［OK］をクリックします。
    注： ライセンスサーバーは、デフォルトでポート27000を使用してCitrix製品と通信します。 ライセンスサーバー上でデフォルト以外のポート番号を使用している場合は、［ポート番号］ボックスの値を変更します。 ポート番号の変更手順について詳しくは、Citrix eDocsの「製品ライセンスの有効化 」を参照してください。

XenCenterは、指定されたCitrix V6ライセンスサーバーと通信し、必要なライセンスを要求します。 ライセンスの要求に成功すると、ライセンスがチェックアウトされ、XenCenterのライセンスマネージャの表示が更新されます。 ライセンスサーバーと通信できない場合は、サーバーが30日間のライセンス猶予期間に入ります。

注： ライセンスを要求または適用するときに、XenServerのバージョンおよびライセンスの種類に関する情報がCitrix社に送信される場合があります。 そのほかの情報（システムのユーザーの情報、環境で実行される仮想マシンの情報、XenServer環境の情報など）は収集されません。 ライセンス処理に付随してCitrix社により収集される情報は、Citrix社での個人情報保護ポリシーに基づいて慎重に処理されます。詳しくは、http://www.citrix.com/privacyを参照してください。

無償版からXenServer 6.2.0へのアップグレード

無償版のサーバーやプールをXenServer 6.2.0にアップグレードすると、XenServerの全機能が使用可能になりますが、ライセンスが適用されていない状態で動作します。 この場合、XenCenterにライセンスの状態として［サポートされません］と表示され、XenCenterでHotfixなどの更新ソフトウェアを適用できません。 ライセンスを購入してサーバーやプールに新しいライセンスを割り当てると、ライセンスの状態として［ライセンス済み］と表示され、［ライセンスの種類］に［Citrix XenServer Per-Socket Edition］と表示されます。

Advanced Edition、Enterprise Edition、またはPlatinum EditionからXenServer 6.2.0へのアップグレード

有償版のサーバーやプールをXenServer 6.2.0にアップグレードすると、XenServerの全機能が使用可能になりますが、ライセンスが適用されていない状態で動作します。 この場合、XenCenterにライセンスの状態として［サポートされません］と表示され、XenCenterでHotfixなどの更新ソフトウェアを適用できません。 この場合、以下の手順で新しいライセンスを適用します。

  1. 既存のサーバー単位のライセンスをCPUソケット単位のライセンスに交換します。
  2. 新しいライセンスファイルをライセンスサーバーに追加します。
  3. 既存のサーバーまたはプールに新しいライセンスを適用します。

新しいライセンスを適用すると、ライセンスの状態として［ライセンス済み］と表示され、［ライセンスの種類］に［Citrix XenServer Per-Socket Edition］と表示されます。

XenServerライセンスの割り当てを解除するには

  1. ［ツール］メニューの［ライセンスマネージャ］を選択します。
  2. ホストまたはプールを選択し、［ライセンスの割り当て解除］をクリックします。


XenServer 6.5でのライセンスの管理

このトピックでは、XenServer 6.5のライセンスを管理する方法について説明します。

ライセンスは、プール内のすべてのサーバーに適用する必要があります。 XenServerのライセンスを管理するには、XenCenterの［ライセンスマネージャ］ダイアログボックスを使用します。 ライセンスマネージャでは、以下のライセンス設定を行います。
  • ライセンスの割り当て：XenServerライセンスを特定のサーバーに割り当てます。 XenServerは、指定された種類のライセンスをCitrixライセンスサーバーに要求し、 割り当て可能なライセンスがある場合はそれをライセンスサーバーからチェックアウトします。
  • ライセンスの割り当て解除：ホストサーバーに割り当てられたXenServerライセンスをリリースします。 これにより、XenServerがCitrixライセンスサーバーと通信し、ライセンスをチェックインします。
重要： Citrix XenServer 6.5を使用するには、CitrixライセンスサーバーがVersion 11.12.1以降である必要があります。 Citrixライセンスサーバーは、Citrix Licensingページからダウンロードできます。

XenServerライセンスを割り当てるには

  1. ［ツール］メニューの［ライセンスマネージャ］を選択します。
  2. ライセンスを割り当てるホストまたはプールを選択し、［ライセンスの割り当て］をクリックします。
  3. ［ライセンスの適用］ダイアログボックスで、ライセンスサーバーから割り当てるライセンスのエディションを選択します。 XenServerのエディションについて詳しくは、「ライセンスの概要（XenServer 6.5）」を参照してください。
  4. ライセンスサーバーの詳細を指定して、［OK］をクリックします。
    注： ライセンスサーバーは、デフォルトでポート27000を使用してCitrix製品と通信します。 ライセンスサーバー上でデフォルト以外のポート番号を使用している場合は、［ポート番号］ボックスの値を変更します。 ポート番号の変更手順について詳しくは、Citrix eDocsの「製品ライセンスの有効化」を参照してください。

XenCenterは、指定されたCitrixライセンスサーバーと通信し、必要なライセンスを要求します。 ライセンスの要求に成功すると、ライセンスがチェックアウトされ、XenCenterのライセンスマネージャの表示が更新されます。 ライセンスサーバーと通信できない場合は、サーバーが30日間のライセンス猶予期間に入ります。

注： ライセンスを要求または適用するときに、XenServerのバージョンおよびライセンスの種類に関する情報がCitrix社に送信される場合があります。 そのほかの情報（システムのユーザーの情報、環境で実行される仮想マシンの情報、XenServer環境の情報など）は収集されません。 ライセンス処理に付随してCitrix社により収集される情報は、Citrix社での個人情報保護ポリシーに基づいて慎重に処理されます。詳しくは、http://www.citrix.com/privacyを参照してください。

XenServerライセンスの割り当てを解除するには

  1. ［ツール］メニューの［ライセンスマネージャ］を選択します。
  2. ホストまたはプールを選択し、［ライセンスの割り当て解除］をクリックします。


XenServer 6.1.0およびそれ以前のバージョンでのライセンスの管理

XenServer Advanced、Enterprise、およびPlatinum Editionでは、XenAppなどほかのCitrix製品と同じライセンスモデルが使用されます。このため、Citrixライセンスサーバーとして動作するサーバー上に、各XenServerホスト用のライセンスをインストールする必要があります。 Citrix製品のライセンスおよびライセンスサーバーについて詳しくは、オンラインのドキュメントライブラリCitrix eDocsの「製品ライセンスの有効化」を参照してください。

XenServer Advanced、Enterprise、およびPlatinum Editionのライセンス設定は、XenCenterのライセンスマネージャで行います。［ツール］メニューの［ライセンスマネージャ］を選択します。 ライセンスマネージャでは、以下のライセンス設定を行います。

  • ライセンスの割り当て：XenServerライセンスを特定のサーバーに割り当てます。 XenCenterは、指定された種類のライセンスをCitrixライセンスサーバーに要求し、 割り当て可能なライセンスがある場合はそれをライセンスサーバーからチェックアウトします。
  • ライセンスの割り当て解除：ホストサーバーに割り当てられたXenServerライセンスをリリースします。 これにより、XenCenterがCitrixライセンスサーバーと通信し、ライセンスをチェックインします。

ライセンスは、リソースプール内のすべてのホストサーバーについて個別に割り当てる必要があります。 たとえば、リソースプールで4つのXenServerホストを運用する場合、4つの異なるライセンスを各ホストに割り当てる必要があります。 異なるエディションのXenServerを同一リソースプール内で混在させることもできますが、そのプールで一番低いレベルのライセンスにより、すべてのプールメンバで使用できる機能が決定されることに注意してください。 たとえば、AdvancedレベルのホストとPlatinumレベルのホストが混在するプールでは、Advancedレベルの機能しか使用できません。 このため、プール内の任意のホストでライセンスレベルを下げると、結果的にそのプールで一部の機能が無効になります。

XenServerライセンスを割り当てるには

  1. ライセンスマネージャを開きます。ライセンスマネージャを開くには、［ツール］メニューの［ライセンスマネージャ］を選択します。
  2. 対象のサーバーを選択して、［ライセンスの割り当て］をクリックします。
  3. ［ライセンスの適用］ダイアログボックスで、ライセンスサーバーに要求するライセンスの種類を選択します。
    • Citrix XenServer Advanced Edition：このライセンスでは、高可用性（HA）、仮想マシンの保護と回復（VMPR）、動的メモリ制御、仮想マシンパフォーマンスのリアルタイムアラートおよび履歴レポートなどの機能がXenCenterに追加されます。
    • Citrix XenServer Enterprise Edition：このライセンスでは、Advanced Editionの機能に加えて、ワークロードバランスによる自動処理、および既存のストレージインフラストラクチャとStorageLinkとの統合機能が使用可能になります。
    • Citrix XenServer Platinum Edition：このライセンスでは、プロビジョニングサービスやラボ管理など、XenCenter以外のツールで管理される機能が使用可能になります。 ラボ管理（Lab Management）およびステージ管理（Stage Management）用のライセンスは、Citrix Lab ManagerインストールISOと同様にcitrix.comのMy Accountからダウンロードできます。ラボ管理用のライセンスは、Lab Manager管理コンソールを使用して適用します。
    • Citrix XenServer for XenDesktop：既存のCitrix XenServer for XenDesktopライセンスを適用するには、このオプションを選択します。 このライセンスにより、XenServer Enterprise Editionを使ってデスクトップ仮想マシンと、XenDesktopホストやXenAppホストを含むすべてのXenDesktopインフラストラクチャ仮想マシンを運用できるようになります。
  4. ライセンスサーバーの詳細を指定して、［OK］をクリックします。

XenCenterは、指定されたCitrix V6ライセンスサーバーと通信し、必要なライセンスを要求します。 ライセンスの要求に成功すると、ライセンスがチェックアウトされ、XenCenterのライセンスマネージャの表示が更新されます。 ライセンスサーバーと通信できない場合は、サーバーが30日間のライセンス猶予期間に入ります。

注： 無償のCitrix XenServer製品をアクティブ化したり、有償のXenServerエディションのライセンスを入手/適用したりするときに、XenServerのバージョンおよびライセンスの種類に関する情報がCitrix社に送信される場合があります。 そのほかの情報（システムのユーザーの情報、環境で実行される仮想マシンの情報、XenServer環境の情報など）は収集されません。 ライセンス処理に付随してCitrix社により収集される情報は、Citrix社での個人情報保護ポリシーに基づいて慎重に処理されます。詳しくは、http://www.citrix.com/privacyを参照してください。

XenServerライセンスの割り当てを解除するには

  1. ライセンスマネージャを開きます。ライセンスマネージャを開くには、［ツール］メニューの［ライセンスマネージャ］を選択します。
  2. 対象のサーバーを選択して、［ライセンスの割り当て解除］を選択します。


無償のXenServer製品のアクティブ化

無償のXenServer製品をアクティブ化するには、ホストサーバーにアクティブ化キー（「ライセンスキー」とも呼ばれます）を適用する必要があります。 これを行うには、以下の手順に従います。

  1. まず、Citrixにアクティブ化キーを要求します。 アクティブ化キーファイルlicense.xslicがメールで送信されます。
  2. 無償のXenServer製品のホストサーバーにアクティブ化キーを適用します。

アクティブ化キーを適用するには、Windowsエクスプローラでアクティブ化キーファイルをダブルクリックして適用先のサーバーを選択するか、XenCenterのライセンスマネージャを使用します。

注： 無償のCitrix XenServer製品をアクティブ化するときに、XenServerのバージョンおよびライセンスの種類に関する情報がCitrix社に送信される場合があります。 そのほかの情報（システムのユーザーの情報、環境で実行される仮想マシンの情報、XenServer環境の情報など）は収集されません。 ライセンス処理に付随してCitrix社により収集される情報は、Citrix社での個人情報保護ポリシーに基づいて慎重に処理されます。詳しくは、http://www.citrix.com/privacyを参照してください。

アクティブ化キーを要求するには

  1. ライセンスマネージャを開きます。ライセンスマネージャを開くには、［ツール］メニューの［ライセンスマネージャ］を選択します。
  2. 無償のXenServer製品が動作するサーバーを選択し、［無償のXenServerのアクティブ化］、［アクティブ化キーの取得］の順にクリックします。

    Webブラウザが起動して、XenServerアクティブ化用のCitrix Webページが開きます。このページでは、選択したサーバーのアクティブ化の詳細が記録されます。また、管理者の連絡先やメールアドレスを記入する必要があります。

    Citrix XenServerアクティブ化ページに接続できない場合は、選択したサーバーのアクティブ化情報をファイルに保存することができます。 後でCitrix XenServerアクティブ化ページに接続できるようになったら、このファイルをアクティブ化サーバーにインポートできます。

アクティブ化に必要な情報を入力したら、選択した各XenServer製品のアクティブ化キーファイルが、入力したメールアドレス宛てに送信されます。 下図はその例です。

アクティブ化キーファイルを受信したら、それを各XenServerホストにインストールします。これにより、XenServerホストがアクティブ化されます。

XenCenterでアクティブ化キーを適用するには

まず、XenCenterを実行しているコンピュータからアクティブ化キーファイルにアクセスできることを確認します。また、アクティブ化対象のサーバーをXenCenterに追加しておく必要があります。

  1. ライセンスマネージャを開きます。ライセンスマネージャを開くには、［ツール］メニューの［ライセンスマネージャ］を選択します。
  2. 無償のXenServer製品が動作するサーバーを選択し、［無償のXenServerのアクティブ化］、［アクティブ化キーの適用］の順にクリックします。
  3. アクティブ化キーファイル（license.xslic）を参照し、［開く］をクリックします。

アクティブ化キーファイルでアクティブ化キーを適用するには

  1. Windowsエクスプローラでアクティブ化キーファイル（license.xslic）をダブルクリックします。
  2. ［アクティブ化キーの適用］ダイアログボックスで無償のXenServer製品が動作するサーバーを選択し、［適用］をクリックします。


ライセンスの概要（XenServer 6.1.0およびそれ以前）

注： XenServer Version 6.2.0を使用している場合は、「ライセンスの概要（XenServer 6.2.0）」を参照してください。

無償のCitrix XenServer Free Editionには、仮想マシンインフラストラクチャの作成に必要なすべての機能が用意されています。 XenServer Free Editionは無償で提供され、業務での使用においても制限や使用期限はありません。ただし、製品を使用する意図があることを示すため、初回インストール後30日以内に製品をアクティブ化する必要があります。 アクティブ化の手続きは簡単で、数分で完了します。 XenServer Free Editionのアクティブ化については、「無償のXenServer製品のアクティブ化」を参照してください。

有償の3つのエディションであるXenServer Advanced Edition、Enterprise Edition、およびPlatinum Editionには、より高度な管理機能や自動化機能が追加されています。 XenServerの各エディションについて詳しくは、ここを参照してください。

Citrixライセンスサーバー

有償のXenServerエディションのライセンスは、Citrixライセンスサーバーにより一元管理されます。ほかのCitrix製品と同様に、Citrixライセンスサーバーで適切なライセンスを割り当てる必要があります。 Citrixライセンスサーバーとして動作する専用のサーバー上にXenServerのライセンスをインストールし、Citrixライセンス管理コンソールを使ってそれを管理します。 つまり、XenServerはほかのCitrix製品と同じライセンスモデルを使用するため、これらのCitrix製品とライセンスサーバーを共有することができます。 Citrix製品のライセンスおよびライセンスサーバーについて詳しくは、オンラインのドキュメントライブラリCitrix eDocsを参照してください。

ライセンスの管理については、「XenServer 6.1.0およびそれ以前のバージョンでのライセンスの管理」を参照してください。

ライセンスの猶予期間

Citrix V6ライセンスシステムには、タイムアウト機能が組み込まれています。 ライセンスサーバーのハードウェアまたはソフトウェアの問題、ネットワーク障害などの理由でXenServerホストがライセンスサーバーと通信できない場合、30日間の猶予期間に入ります。この期間中、XenServerホストは通常どおり動作します。 XenServerホストがスタートアップライセンスをチェックアウトすると、XenServerとライセンスサーバー間で5分ごとに「ハートビート」メッセージが交換されます。このメッセージにより、両者が正しく動作しており、接続が維持されていることが確認されます。 XenServerまたはライセンスサーバーでこのメッセージの送受信の失敗が検出されると、XenServerがライセンス猶予期間に入り、キャッシュ済みのライセンス情報に基づいて動作するようになります。 この猶予期間は30日間で、これが経過するとXenServerが接続を受け入れなくなります。 XenServerとライセンスサーバーとの通信が再確立されると、猶予期間の残り時間はリセットされます。 XenServerが猶予期間に入るためには、ライセンスサーバーとの接続が少なくとも1回確立されている必要があります。

個人情報の保護

無償のCitrix XenServer製品をアクティブ化したり、有償のXenServerエディションのライセンスを入手/適用したりするときに、XenServerのバージョンおよびライセンスの種類に関する情報がCitrix社に送信される場合があります。 そのほかの情報（システムのユーザーの情報、環境で実行される仮想マシンの情報、XenServer環境の情報など）は収集されません。 ライセンス処理に付随してCitrix社により収集される情報は、Citrix社での個人情報保護ポリシーに基づいて慎重に処理されます。詳しくは、http://www.citrix.com/privacyを参照してください。


ライセンスの概要（XenServer 6.2.0）

インストールした直後のXenServerは、ライセンスが適用されていない状態で動作します。 この状態でも、XenCenterを使用したHotfixの適用を除き、機能や動作に制限はありません。 ただし、Citrixからのサポートを得るには、XenServerのライセンスが必要です。

XenServerのライセンスは、サーバー上のCPUソケットごとに必要で、プール内のすべてのサーバーに適用する必要があります。 ライセンス済みのサーバーとそうでないサーバーを同一プール内で混在させた場合、ライセンスが適用されていない状態として動作します。 XenServer 6.2.0のライセンスについては、「XenServer 6.2.0でのライセンスの管理」を参照してください。

XenServerエディションのライセンス

XenServerでは、ほかのCitrix製品と同じライセンス処理が行われます。 このため、Citrixライセンスサーバーとして動作するサーバー上に、XenServer用のライセンスをインストールする必要があります。 XenServerのサポート契約を購入すると、 .LIC ライセンスキーが提供されます。 このライセンスキーを、以下のいずれかのライセンスサーバーにインストールします。
  • Citrixライセンスサーバーソフトウェアが動作するWindowsサーバー
  • LinuxベースのCitrixライセンスサーバー仮想アプライアンス
重要： XenServer Per-Socket Edition 6.2を使用するには、CitrixライセンスサーバーがVersion 11.6.1以降である必要があります。

ライセンスの有効期限

XenServer Per-Socket Editionのライセンスの有効期限が切れると、以下のようになります。

  • XenServerがライセンス適用前の状態に戻りますが、すべての機能を使用できます。
  • XenCenterに［期限切れ］と表示されます。
  • XenCenterでHotfixなどの更新ソフトウェアを適用できなくなります。
  • 新しいライセンスを購入するまで、XenServerに関するCitrixのテクニカルサポートを受けることができなくなります。

ライセンスの猶予期間

Citrix V6ライセンスシステムには、タイムアウト機能が組み込まれています。 ライセンスサーバーのハードウェアまたはソフトウェアの問題、ネットワーク障害などの理由でXenServerホストがライセンスサーバーと通信できない場合、30日間の猶予期間に入ります。この期間中、XenServerホストは通常どおり動作します。 XenServerホストがスタートアップライセンスをチェックアウトすると、XenServerとライセンスサーバー間で5分ごとに「ハートビート」メッセージが交換されます。このメッセージにより、両者が正しく動作しており、接続が維持されていることが確認されます。 XenServerまたはライセンスサーバーでこのメッセージの送受信の失敗が検出されると、XenServerがライセンス猶予期間に入り、キャッシュ済みのライセンス情報に基づいて動作するようになります。 この猶予期間は30日間で、これが経過するとXenServerが接続を受け入れなくなります。 XenServerとライセンスサーバーとの通信が再確立されると、猶予期間の残り時間はリセットされます。 XenServerが猶予期間に入るためには、ライセンスサーバーとの接続が少なくとも1回確立されている必要があります。


ライセンスの概要（XenServer 6.5）

XenServer 6.5には、以下のエディションが用意されています。

  • Standard
  • Enterprise
  • Desktop
  • Desktop+

Standard Editionはエントリレベルの商品で、Enterprise Editionで提供される高度な機能は使用できませんが、強固で高性能な仮想化プラットフォームに必要なさまざまな機能を備えています。Citrixの包括的なサポートおよび保守サービスも提供されます。

Enterprise Editionは最上位レベルの商品で、サーバー、デスクトップ、およびクラウドワークロード用に最適化されています。 Standard Editionのすべての機能に加えて、ブートストームガード（インメモリ読み取りキャッシュ）機能、動的ワークロードバランス機能、NVIDIA GRIDによるGPU仮想化（仮想GPU）、VMware vSphereからXenServerへの変換ユーティリティ、Intelセキュアメジャーブート（TXT）のサポート、およびリソースデータのエクスポート機能が提供されます。

Desktop EditionはXenAppまたはXenDesktopを購入済みのお客様向けの商品で、XenAppまたはXenDesktopのお客様に提供されていたXenServer機能が含まれています。 Standard Editionでは使用できない動的ワークロードバランス機能、NVIDIA GRIDによるGPU仮想化（仮想GPU）、VMware vSphereからXenServerへの変換ユーティリティ、Intelセキュアメジャーブート（TXT）のサポートなどが含まれ、Citrixのサポートおよび保守サービスも提供されます。

Desktop+ EditionはXenAppまたはXenDesktopのPlatinum Editionを購入済みのお客様向けの商品で、Desktop Editionのすべての機能に加えて、ブートストームガード（インメモリ読み取りキャッシュ）機能が含まれています。

注： Standard EditionからEnterprise Editionへのアップグレードがサポートされています。 XenServer 6.5のライセンスについて詳しくは、XenServer 6.5 Licensing FAQを参照してください。 XenServer 6.5のライセンスを購入するには、ここをクリックしてください。

Citrixライセンスサーバー

XenServerでは、ほかのCitrix製品と同じライセンス処理が行われます。このため、ライセンスサーバー上に有効なライセンスをインストールする必要があります。 Citrixライセンスサーバーは、Citrix Licensingページからダウンロードできます。 使用するXenServerエディションのライセンスをご購入いただくと、 .LIC ライセンスキーが提供されます。 このライセンスキーを、以下のいずれかのライセンスサーバーにインストールします。
  • Citrixライセンスサーバーソフトウェアが動作するWindowsサーバー
  • LinuxベースのCitrixライセンスサーバー仮想アプライアンス
XenServerサーバーにライセンスを割り当てると、XenServerがCitrixライセンスサーバーと通信して、必要なライセンスを要求します。 ライセンス要求に成功するとライセンスがチェックアウトされ、XenCenterのライセンスマネージャにそのXenServerサーバーのエディション情報が表示されます。
重要： Citrix XenServer 6.5を使用するには、CitrixライセンスサーバーがVersion 11.12.1以降である必要があります。

XenServerエディションのライセンス

ライセンスは、プール内のすべてのサーバーに適用する必要があります。 異なるエディションのXenServerを同一リソースプール内で混在させると、そのプールで一番低いエディションのライセンスにより、すべてのプールメンバで使用できる機能が決定されます。 ライセンス済みのサーバーとそうでないサーバーを同一プール内で混在させた場合、ライセンスが適用されていない状態として動作します。 XenServer 6.5のライセンス管理については、「XenServer 6.5でのライセンスの管理」を参照してください。

ライセンスの有効期限

ライセンスの有効期限が近くなると、XenCenterに通知が表示されます。 ライセンスの有効期限が切れる前に、ライセンスを購入してください。 XenServerライセンスの有効期限が切れると、

  • XenCenterのライセンスマネージャに、ライセンスの状態として「非ライセンス」が表示されます。
  • 新しいライセンスを購入するまでそのエディションの機能を使用できなくなり、またそのリソースプールの任意のサーバーで問題が生じてもCitrixのテクニカルサポートを受けることができなくなります。

ライセンスの猶予期間

Citrixライセンスシステムには、タイムアウト機能が組み込まれています。 XenServerサーバーがスタートアップライセンスをチェックアウトすると、XenServerとライセンスサーバー間で5分ごとに「ハートビート」メッセージが交換されます。このメッセージにより、両者が正しく動作しており、接続が維持されていることが確認されます。 ライセンスサーバーのハードウェアまたはソフトウェアの問題、ネットワーク障害などの理由でXenServerサーバーがライセンスサーバーと通信できなくなると、30日間の猶予期間に入ります。 この間、XenServerはキャッシュ済みのライセンス情報に基づいて通常どおり動作します。 この猶予期間は30日間で、これが経過するとXenServerが非ライセンス状態になります。 XenServerとライセンスサーバーとの通信が再確立されると、猶予期間の残り時間はリセットされます。

注： XenServerが猶予期間に入るためには、ライセンスサーバーとの接続が少なくとも1回確立されている必要があります。


ユーザーおよびグループへの役割の割り当て

XenServerを管理するすべてのユーザーには、RBAC役割が割り当てられている必要があります。 XenServer 6.2およびXenServer 6.5では、管理者ユーザーを作成した後で役割を割り当てないと、そのアカウントは使用できません。 役割が自動的に割り当てられないことに注意してください。 このため、これらのユーザーにXenServerリソースプールへのアクセスを許可するには、いずれかの役割を割り当てる必要があります。

XenServer 6.1.0およびそれ以前のバージョンでの役割の割り当て

XenServer 6.1.0およびそれ以前のバージョンでは、新しい管理者を追加すると、プール管理者の役割が自動的に割り当てられます。 ただし、XenServer Enterprise Editionおよびそれ以上のエディションでは、追加された管理者に役割は自動的に割り当てられません。 既存の管理者が個別に役割を割り当てる必要があります。

注： ユーザーやグループに役割を割り当てるには、そのユーザーやグループをActive Directoryドメインに追加して、そのアカウントをXenServerに追加する必要があります。詳しくは、「ドメインへの参加とユーザーの追加」を参照してください。

ユーザーに割り当て済みの役割を変更するには、次のいずれかを行います。

  1. XenCenterの［役割の選択］ダイアログボックスで、ユーザーに割り当てる役割を変更します。 これを行うには役割の割り当て/変更権限が必要であり、この権限はプール管理者のみに付与されます。
  2. そのユーザーのグループメンバシップを変更して、必要な役割が割り当てられているActive Directoryグループにユーザーを追加します。

ユーザーが複数のグループに属している場合など、複数の役割が割り当てられたユーザーには、自動的により権限の強い役割が適用されます。

ユーザーやグループの役割を変更したり割り当てたりするには

  1. リソースペインで、ユーザーやグループを含んでいるリソースプールまたはサーバーを選択します。
  2. ［ユーザー］タブをクリックします。
  3. ［アクセスが付与されたユーザーおよびグループ］の一覧で、ユーザーまたはグループを選択します。
  4. ［役割の変更］をクリックします。
  5. ［役割の選択］ダイアログボックスで、ユーザーに割り当てる役割を選択して［保存］をクリックします。 各役割で許可される管理タスクについては、「RBAC役割の定義とアクセス権」を参照してください。
    ヒント： 一覧でユーザーを選択して役割を割り当てるときに、Ctrlキーを押しながら複数のユーザーを選択できます。
  6. （オプション） リソースプールにログオン済みのユーザーの役割を変更する場合、新しい役割をすぐに適用するには［ユーザーをログアウト］をクリックします。 これにより、そのユーザーのプールに対するすべてのセッションが切断されます。ユーザーがそのプールに再接続すると、新しい役割が適用されます。
    注： 新しい役割を適用するには、そのユーザーがログアウトして再ログインする必要があります。 ［ユーザーをログアウト］ボタンを使用すると、ユーザーを強制的にログアウトできます （ただしアクティブなユーザー接続のログアウト権限が必要であり、この権限はプール管理者とプールオペレータに付与されます）。


監査履歴

XenServerの監査ログはデフォルトで有効になっており、特定の管理者ユーザーにより実行される管理操作（成功したものおよび失敗したもの）が記録されます。 以下のものが含まれます。

  • 操作を実行した管理者のユーザー名。 ユーザー名を取得できない場合はユーザーIDが記録されます。
  • 操作の対象サーバーの名前。
  • 操作の実行状態。成功したか失敗したか。およびその操作の実行が許可されたかどうか。操作に失敗した場合はそのエラーコードが記録されます。

監査ログはデフォルトで有効になります。 監査ログをバックアップするには、XenServerのsyslogコマンドを使用してログを安全な場所にコピーします。 このコマンドはCLIで実行します。詳しくは、『XenServer管理者ガイド』を参照してください。

監査ログ機能を使用するために管理者に役割を割り当てたりActive Directoryを使用したりする必要はありませんが、役割ベースのアクセス制御（RBAC）を実装することをお勧めします。

XenServerの監査ログでは、プールに対する操作が記録され、そのプールのマスタ上にログファイルが作成されます。

監査ログを表示するには、2つの方法があります 。

  • ワークロードバランスが有効な場合は、プール監査記録を生成する。
  • テキストエディタでログファイルを開く。 ログファイルはプールマスタ上に格納されています。


XenServerにログインしたユーザーのアクセス許可の決定プロセス

XenServerにログインしたユーザーのアクセス許可の決定プロセス

  1. Active Directoryサーバーがサブジェクトを認証します。 認証時に、そのサブジェクトがほかのActive Directoryグループに属しているかどうかもチェックされます。
  2. XenServerが、（a）そのサブジェクト、および所属する（b）Active Directoryグループにどの役割が割り当てられているかを検証します。
  3. XenServerが、そのサブジェクトに割り当てられている最も高いレベルのアクセス許可を適用します。 サブジェクトが複数のActive Directoryグループに属している場合は、割り当てられている役割のすべてのアクセス許可がそのサブジェクトに継承されます。

この図で、Subject 2（Group 2）はプールオペレータで、User 1はGroup 2に属しています。このため、Subject 3（User 1）がログインすると、Subject 3（VMオペレータ）およびGroup 2（プールオペレータ）の役割が継承されます。 ただし、プールオペレータの役割レベルの方が高いため、Subject 3（User 1）は（VMオペレータではなく）プールオペレータになります。


ドメインへの参加とユーザーの追加

管理者のユーザーアカウントやグループアカウントにRBAC役割を割り当てるには、そのアカウントをXenServerに追加する必要があります。 これを行うには、以下の2つのタスクを実行します。

  1. プールまたはサーバーをドメインに追加する。 この場合、目的のユーザーやグループの所属ドメインか、そのドメインと同じActive Directoryフォレスト内にあるか信頼関係が設定されているドメインにプールやサーバーを追加する必要があります。
  2. ユーザーのActive DirectoryアカウントまたはグループをXenServerに追加する。

無償のXenServer製品およびXenServer Advanced Editionでは、ユーザーのActive DirectoryアカウントまたはグループをXenServerに追加すると、そのユーザーに自動的にプール管理者の役割が割り当てられます。 XenServer Enterprise Editionおよびそれ以上のエディションでは、管理者がユーザーやグループに役割を割り当てる必要があります。

ドメインを変更するには、現在のドメインから脱退して新しいドメインに参加する必要があります。

XenServerまたはプールをドメインに追加するには

  1. リソースペインで、アクセス許可を付与する対象プールまたはサーバーを選択します。
  2. ［ユーザー］タブをクリックします。
  3. ［ドメインに追加］をクリックします。
  4. サーバーを追加するためのActive Directory資格情報を入力します。 追加先のドメインを、NetBIOS名ではなく完全修飾ドメイン名（FQDN）で指定します。 たとえば、「your_domain」ではなく「your_domain.net」と入力します。

Active Directoryのユーザーまたはグループをプールに追加するには

  1. ユーザーのドメインにプールまたはサーバーを追加した後で、［ユーザー］タブの［追加］をクリックします。
  2. ［ユーザーの追加］ダイアログボックスで、ユーザーやグループの名前を入力します。 コンマで区切って複数の項目を入力できます。 信頼関係が設定されたほかのドメインのユーザーを指定するには、ドメイン名とユーザー名を「other_domain\jsmith」形式またはFQDN（「jsmith@other_domain.com」形式）で入力します。
  3. ［アクセスを付与］をクリックします。
  4. 「ユーザーおよびグループへの役割の割り当て」の説明に従って役割を割り当ててアクセス許可を制御します。

XenServerまたはプールをドメインから削除するには

注： ドメインからサーバーやプールを削除する（つまりActive Directory認証を無効にしてプールまたはサーバーとドメインとの接続を切断する）と、Active Directoryの資格情報でログインした管理者ユーザーが切断されます。
  1. リソースペインで、Active Directoryドメインから削除するプールまたはサーバーを選択します。
  2. ［ドメインから削除］をクリックし、さらに［はい］をクリックします。
  3. サーバーを削除するためのActive Directory資格情報を入力します。
  4. Active Directoryサーバーでコンピュータアカウントを無効にするかどうかを指定します。
    • 無効化： プールまたはサーバーをドメインから削除して、そのプールマスタまたはサーバーのコンピュータアカウントをActive Directoryデータベース内で無効にします。
    • 無視： ユーザー名やパスワードを入力しなかった場合、またはActive Directoryデータベースからプールマスタやサーバーのコンピュータアカウントを削除するためのアカウント情報が不明な場合は、このオプションを選択します （これにより、プールまたはサーバーがドメインから削除され、そのプールマスタまたはサーバーのコンピュータアカウントがActive Directoryで無効になります）。


役割ベースのアクセス制御（RBAC）の概要

役割ベースのアクセス制御（RBAC：Role Based Access Control）機能では、XenServerの管理タスクの定義済みセットである役割を、Active Directoryのユーザーやグループアカウントを使用して特定のユーザー（つまりXenServer管理者）に割り当てることができます。 この役割により、その管理者がアクセスできるXenServerの機能が決定されます。役割ベースのアクセス制御は、個々のサーバーレベルではなくリソースプールレベルで適用されます。 各管理者には、そのユーザーアカウントまたはグループアカウントに割り当てられた役割によりアクセス許可が付与されます。

XenServerのユーザーアカウントとしてActive Directoryアカウントを使用する

役割ベースのアクセス制御では、管理者が実行可能な操作を、その管理者が属するグループに基づいて制御します。これにより、不適切な管理者による操作により壊滅的な問題が生じたり、意図しない変更が加えられたりすることを防ぐことができます。 また、法令遵守の観点から、許可を得ていない操作を禁止するためにこの機能を使用することもできます。 役割ベースのアクセス制御の監査ログ機能と、これに対応するワークロードバランスのプール監査記録レポートを、コンプライアンスおよび監査に役立てることもできます。

役割ベースのアクセス制御では、認証サービスとしてActive Directoryが使用されます。 XenServerは、認証されたユーザーの一覧をActive Directoryのユーザーおよびグループアカウントに基づいて管理します。 このため、役割を割り当てるには、事前にリソースプールをドメインに追加して、Active Directoryアカウントを追加しておく必要があります。

役割ベースのアクセス制御の基本的な手順

役割ベースのアクセス制御を有効にしてユーザーやグループに役割を割り当てるには、以下の手順を行います。

  1. ドメインに参加する。
  2. Active Directoryのユーザーまたはグループをプールに追加する。
  3. ユーザーまたはグループにRBACの役割を割り当てる（または変更する）。

ローカルスーパーユーザー

ローカルスーパーユーザー（LSU）（root）は特別なシステム管理用アカウントであり、すべての権限およびアクセス許可を持ちます。 ローカルスーパーユーザーは、XenServerをインストールする時のデフォルトのアカウントです。 このアカウントはXenServerにより認証され、外部の認証サービスは使用されません。 つまり、外部の認証サービスに障害が生じた場合でも、ローカルスーパーユーザーとしてログインすればシステムを管理できます。 ローカルスーパーユーザーは、SSHを使用して物理XenServerサーバーに常にアクセスできます。

RBACの役割

XenServerには、異なる管理業務を担当する各IT部門に合わせて、あらかじめ6つの役割が用意されています。

  • プール管理者（Pool Admin）： 最も強力な権限を持つ役割です。 プール管理者には、XenServer のすべての機能および設定に対する完全なアクセス権が付与されます。 役割やほかの管理者の管理を含む、すべての管理タスクを実行できます。 このレベルの管理者は、XenServerのコンソール画面にアクセスできます。 この役割を割り当てる管理者の数は、最小限にとどめておくことをお勧めします。
    注： ローカルスーパーユーザー（root）には、常にプール管理者の役割が適用されます。 つまり、プール管理者にはローカルスーパーユーザーと同じ権限が設定されます。
  • プールオペレータ（Pool Operator）： ストレージの作成、サーバーの管理、パッチの適用、プールの作成など、プール全体のリソースを管理できる役割です。 プールオペレータは、プールのリソースを設定できます。 また、以下の機能に対する完全なアクセスが付与されます。高可用性（HA）、ワークロードバランス、およびパッチ管理。 プールオペレータは、管理者ユーザーを追加したり役割を変更したりすることはできません。
  • 仮想マシンパワー管理者（VM Power Admin）： 仮想マシンおよびテンプレートに対する完全な管理権限を持つ役割です。 このレベルの管理者には、 動的メモリ制御機能および仮想マシンのスナップショット機能への完全なアクセスが付与されます。 さらに、ホームサーバーを設定したり、仮想マシンをどのサーバー上で実行するかを決定したりすることもできます。 この役割が割り当てられた管理者には、仮想マシンオペレータに仮想マシンを提供するために必要な権限が付与されます。
  • 仮想マシン管理者（VM Admin）： 仮想マシンおよびテンプレートを管理でき、そのために必要なストレージにアクセスできる役割です。 ただし、仮想マシンをどのサーバー上で実行するかを決定したり、テンプレートに定義されている動的メモリ制御やホームサーバーの設定を変更したりすることはできません （動的メモリ制御機能の使用、スナップショット作成、ホームサーバーの設定、および仮想マシンの実行サーバーの選択はできません）。
  • 仮想マシンオペレータ（VM Operator）： リソースプール内の仮想マシンを使用して、基本的なライフサイクル操作を行うための役割です。 仮想マシンオペレータは仮想マシンのコンソール画面を操作でき、仮想マシンの起動や終了を実行できます（十分なハードウェアリソースが使用可能な場合）。 同様に、仮想マシンのライフサイクル操作を開始したり終了したりできます。 ただし、仮想マシンの作成や破棄、および仮想マシンのプロパティやサーバーリソースを変更することはできません。
  • 読み取りのみ（Read Only）： この役割では、リソースプールとパフォーマンスデータを表示することしかできません。

各役割で許可される管理タスクについては、「RBAC役割の定義とアクセス権」を参照してください。 また、ユーザーに適用される役割の決定方法については、「XenServerにログインしたユーザーのアクセス許可の決定プロセス」を参照してください。

注： 管理者ユーザーを作成した後で役割を割り当てないと、そのアカウントは使用できません。 役割が自動的に割り当てられないことに注意してください。

XenServerのアップグレード

役割ベースのアクセス制御は、XenServer Version 5.6以降でサポートされています。 これ以前のバージョンのXenServerで作成されたユーザーアカウントには、XenServer Version 5.6以降へのアップグレードによりプール管理者の役割が割り当てられます。 これは後方互換性を維持するための機能です。 このため、XenServerをアップグレードした後で、各ユーザーアカウントに適切な役割が割り当てられているかどうかを確認する必要があります。


RBAC役割の定義とアクセス権

各役割に付与されるアクセス権

XenServerの各役割に付与されるアクセス権（実行可能な管理タスク）は以下のとおりです。 各アクセス権について詳しくは、後述の「アクセス権の定義」を参照してください。

権限 | プール管理者 | プールオペレータ | VMパワー管理者 | VM Admin | VMオペレータ | 読み取り専用
役割の割り当て/変更 | ○ |  |  |  |  |
物理サーバーのコンソールへのログイン（SSHおよびXenCenterの使用） | ○ |  |  |  |  |
サーバーのバックアップ/復元 | ○ |  |  |  |  |
OVF/OVAパッケージのインポート/エクスポートとディスクイメージのインポート | ○ |  |  |  |  |
ソケットごとのコア数の設定 | ○ |  |  |  |  |
XenServer Conversion Managerによる仮想マシンの変換 | ○ |  |  |  |  |
スイッチポートのロック | ○ | ○ |  |  |  |
接続中のユーザーのログアウト | ○ | ○ |  |  |  |
アラートの作成と解除 | ○ | ○ |  |  |  |
任意のユーザーのタスクのキャンセル | ○ | ○ |  |  |  |
プール管理 | ○ | ○ |  |  |  |
ストレージXenMotion | ○ | ○ | ○ |  |  |
高度な仮想マシン操作 | ○ | ○ | ○ |  |  |
仮想マシンの作成/破棄操作 | ○ | ○ | ○ | ○ |  |
仮想マシンのCDメディアの変更 | ○ | ○ | ○ | ○ | ○ |
仮想マシンの電源状態の変更 | ○ | ○ | ○ | ○ | ○ |
仮想マシンコンソールの表示 | ○ | ○ | ○ | ○ | ○ |
XenCenterの表示管理操作 | ○ | ○ | ○ | ○ | ○ |
自分のタスクのキャンセル | ○ | ○ | ○ | ○ | ○ | ○
監査ログの表示 | ○ | ○ | ○ | ○ | ○ | ○
WLBの設定、初期化、有効化、および無効化 | ○ | ○ |  |  |  |
WLB最適化推奨項目の適用 | ○ | ○ |  |  |  |
WLBレポートサブスクリプションの変更 | ○ | ○ |  |  |  |
WLB配置推奨項目の承諾 | ○ | ○ | ○ |  |  |
WLB設定の表示 | ○ | ○ | ○ | ○ | ○ | ○
WLBレポートの生成 | ○ | ○ | ○ | ○ | ○ | ○
プールへの接続およびすべてのプールメタデータの読み取り | ○ | ○ | ○ | ○ | ○ | ○
仮想GPUの構成 | ○ | ○ |  |  |  |
仮想GPU構成の表示 | ○ | ○ | ○ | ○ | ○ | ○

アクセス権の定義

各アクセス権の内容は以下のとおりです。

権限 許可されるタスク 説明
役割の割り当て/変更
  • ユーザーアカウントの追加と削除
  • ユーザーアカウントの役割の追加と削除
  • Active Directory統合機能の有効化および無効化（ドメインへの追加）

すべてのタスクの実行が許可されます。

警告：Active Directory統合機能およびActive Directoryから追加されたすべてのサブジェクトの無効化が許可されます。

サーバーコンソールへのログイン
  • SSHを使用したサーバーコンソールへのアクセス
  • XenCenterを使用したサーバーコンソールへのアクセス
警告：ルートシェルにアクセスできるため、RBACを含むシステム全体の再設定が独断的に可能になります。

サーバーのバックアップ/復元、仮想マシンの作成/破棄操作

  • サーバーのバックアップおよび復元
  • プールメタデータのバックアップおよび復元
バックアップからの復元が許可されるため、RBAC設定の変更を元に戻すことが可能です。
OVF/OVAパッケージのインポート/エクスポートとディスクイメージのインポート
  • OVFおよびOVAパッケージのインポート
  • ディスクイメージのインポート
  • OVF/OVAパッケージとしてのエクスポート
ソケットごとのコア数の設定
  • 仮想マシンに割り当てる仮想CPUのソケットごとのコア数の設定
仮想マシンの仮想CPUのトポロジを指定するための権限です。
XenServer Conversion Managerによる仮想マシンの変換
  • VMware仮想マシンのXenServer仮想マシンへの変換
VMwareの仮想マシンをXenServer用に変換できます。これにより、VMwareのワークロードをXenServer環境に移行できます。
スイッチポートのロック
  • ネットワークトラフィックの制御
特定のネットワーク上のトラフィックをすべてブロック（デフォルト）したり、特定のIPアドレス以外の送信トラフィックをブロックしたりできます。
接続中のユーザーのログアウト
  • ログインしているユーザーの切断
アラートの作成/解除
  • リソースの使用量が特定のしきい値に達したときにXenCenterで生成されるアラートの設定
  • ［アラート］ページのすべてのアラートの削除

警告：プール全体のアラートの解除が許可されます。

注：アラートの表示許可は、プールへの接続およびすべてのプールメタデータの読み取り権限に含まれます。

任意のユーザーのタスクのキャンセル
  • 任意のユーザーによるタスクのキャンセル
だれが実行したタスクかにかかわらず、実行中のXenServerタスクをキャンセルできます。
プール管理
  • プールプロパティ（名前、デフォルトSR）の設定
  • 高可用性の有効化、無効化、および設定
  • 各仮想マシンの再起動優先度の設定
  • 障害回復の設定、フェイルオーバー、フェイルバック、およびフェイルオーバーテストの実行
  • ワークロードバランス（WLB）の有効化、無効化、および設定
  • プールへのサーバーの追加とプールからの削除
  • メンバのマスタへの変換（pool-emergency-transition-to-master）
  • マスタアドレスの指定（pool-emergency-reset-master master-address）
  • マスタアドレスのメンバへの通知（pool-recover-slaves）
  • 新しいマスタの指定
  • プールおよびサーバー証明書の管理
  • パッチの適用
  • サーバープロパティの設定
  • サーバーのログ機能の設定
  • サーバーの有効化および無効化
  • サーバーのシャットダウン、再起動、および電源投入
  • ツールスタックの再起動
  • システム状態のレポート
  • ライセンスの適用
  • すべての仮想マシンのほかのサーバー上へのライブマイグレーション（WLB、保守モード、または高可用性での操作）
  • サーバーの管理インターフェイスの設定
  • サーバー管理の無効化
  • クラッシュダンプの削除
  • ネットワークの追加、変更、および削除
  • PBD/PIF/VLAN/ボンディング/ストレージリポジトリの追加、変更、および削除
役割の割り当て/変更
ストレージXenMotion
  • サーバー間での仮想マシンの移行
  • ストレージリポジトリ間での仮想ディスク（VDI）の移動
高度な仮想マシン操作
  • 仮想マシンメモリの調整（動的メモリ制御）
  • メモリを含んだスナップショット作成、スナップショット作成、および仮想マシンのロールバック
  • 仮想マシンの移行
  • 仮想マシンの起動（起動サーバーの指定を含む）
  • 仮想マシンの再開
サーバーコンソールへのログイン
仮想マシンの作成/破棄操作
  • 仮想マシンのインストールおよび削除
  • 仮想マシンの複製/コピー
  • 仮想ディスク/CDデバイスの追加、削除、および設定
  • 仮想ネットワークデバイスの追加、削除、および設定
  • XVAファイルのインポート/エクスポート
  • 仮想マシン設定の変更

サーバーのバックアップ/復元、仮想マシンの作成/破棄操作

仮想マシンのCDメディアの変更
  • CDのイジェクト
  • CDの挿入
OVF/OVAパッケージのインポート/エクスポートとディスクイメージのインポート
仮想マシンの電源状態の変更
  • 仮想マシンの起動（自動配置）
  • 仮想マシンのシャットダウン
  • 仮想マシンの再起動
  • 仮想マシンの一時停止
  • 仮想マシンの再開（自動配置）
接続中のユーザーのログアウト
仮想マシンコンソールの表示
  • 仮想マシンコンソールの表示と操作
アラートの作成/解除
WLBの設定、初期化、有効化、および無効化
  • WLBの設定
  • WLBの初期化とWLBの変更
  • WLBの有効化
  • WLBの無効化
WLB最適化推奨項目の適用
  • ［WLB］タブに表示されるすべての最適化推奨項目の適用
WLBレポートサブスクリプションの変更
  • 生成するWLBレポートおよびその送信先の変更
WLB配置推奨項目の承諾
  • ワークロードの配置先として（「星」で）提示された推奨サーバーからの選択
WLB設定の表示
  • プールのWLB設定の表示（［WLB］タブ）
WLBレポートの生成
  • プール監査記録レポートを含むWLBレポートの表示および実行
XenCenterの表示管理操作
  • グローバルXenCenterフォルダの作成および変更
  • XenCenterカスタムフィールドの作成および変更
  • グローバルXenCenter検索クエリの作成および変更
仮想マシンコンソールの表示
自分のタスクのキャンセル
  • 自分で実行したタスクのキャンセル
監査ログの表示
  • XenServer監査ログのダウンロード
WLB最適化推奨項目の適用
プールへの接続およびすべてのプールメタデータの読み取り
  • プールへのログイン
  • プールメタデータの表示
  • パフォーマンスの履歴データの表示
  • ログインユーザーの表示
  • ユーザーおよび役割の表示
  • タスクの表示
  • メッセージの表示
  • イベントの登録および受信
WLBレポートサブスクリプションの変更
仮想GPUの構成
  • プールレベルの割り当てポリシーの指定
  • 仮想マシンへの仮想GPUの割り当て
  • 仮想マシンからの仮想GPUの割り当て解除
  • 許可される仮想GPUの種類の変更
  • GPUグループの作成、破棄、または割り当て
仮想GPU構成の表示
  • GPU情報、GPUの割り当てポリシー、および仮想GPUの割り当ての表示