Workload Balancing 概述

Workload Balancing 是一种 XenServer 设备，可以将虚拟机重定位到资源池中最适合其工作负载的服务器，从而实现池的负载平衡。例如，Workload Balancing 可以：

  • 在一个 XenServer 资源池中的各主机间平衡虚拟机工作负载
  • 确定用来启动虚拟机的最佳主机
  • 确定用来启动已关闭虚拟机的最佳主机
  • 在您将主机置于维护模式时，为该主机的每个虚拟机确定最佳主机

Citrix XenServer 企业版或更高版本中提供 Workload Balancing。要了解有关不同 XenServer 版本中可用功能的详细信息，请单击此处。

Workload Balancing 可以根据您选择的优先顺序自动完成这些任务，或者提示您接受其优化、合并和放置建议。您还可以将 Workload Balancing 配置为在使用率低的时间段自动关闭主机（例如在夜间关闭主机以节能）。

Workload Balancing 将评估虚拟机工作负载在池中的利用率，当某个主机达到一项阈值时，会将虚拟机重定位到该池中的其他主机。

为确保重新平衡和放置建议能够满足环境的需求，您可以将 Workload Balancing 配置为根据资源性能优化工作负载，或者配置为实现密度最大化。可以将这些优化模式配置为在预定义的时间自动切换，或者始终保持不变。为提高精细程度，您可以调整各个资源指标（CPU、网络、内存和磁盘）的权重。

Workload Balancing 提供有关主机和池运行状况、优化和虚拟机性能的历史报告，以及虚拟机移动历史记录，以帮助您完成容量规划。

相关主题


Workload Balancing 入门

如果您的 XenServer 版本包含 Workload Balancing，可以按照以下步骤下载、启动并运行 Workload Balancing 虚拟设备：

  1. 从 MyCitrix.com 下载 Workload Balancing 虚拟设备软件包并将其导入 XenCenter 中。
  2. 使用 Workload Balancing 配置向导配置 Workload Balancing 虚拟设备；导入虚拟设备后，该向导将显示在 XenCenter 中该设备的控制台选项卡上。
  3. 将您的池连接到该 Workload Balancing 虚拟设备，如连接 Workload Balancing 中所述。

    有关这些步骤的详细信息，请参阅《Workload Balancing 快速入门》。

    Citrix XenServer 企业版或更高版本中提供 Workload Balancing。要了解有关不同 XenServer 版本中可用功能的详细信息，请单击此处。


Workload Balancing 基本概念

Workload Balancing 获取虚拟机和物理主机上的资源性能数据，并将这些数据与您设置的首选项相结合，以提供优化和放置建议。Workload Balancing 将性能数据存储在内部数据库中：Workload Balancing 运行时间越长，其建议就越有效。

Workload Balancing 将以实现最高效率为目的提供在池中移动虚拟机工作负载的建议，这里的效率是指性能或密度，具体取决于您的目标。在 Workload Balancing 环境中：

  • 性能指主机上物理资源的使用率（例如，主机上 CPU、内存、网络和磁盘的使用率）。将 Workload Balancing 的优化模式设置为性能最大化时，它提供的虚拟机放置建议将确保每个虚拟机获得最多的可用资源。
  • 密度是指一个主机上虚拟机的数量。将 Workload Balancing 优化模式设置为密度最大化时，它提出的建议将在确保虚拟机保持足够计算能力的前提下，将这些虚拟机放置在尽可能少的主机上，从而减少池中开启的主机数量。

Workload Balancing 允许您修改放置（性能或密度）、电源管理、自动化、指标加权和性能阈值的设置。

Workload Balancing 与高可用性设置不发生冲突；高可用性设置始终优先。


连接 Workload Balancing

在导入 Workload Balancing 虚拟设备并运行 Workload Balancing 配置向导后，必须将要监视的池连接到 Workload Balancing。为此，请使用 XenCenter 中的“连接 WLB 服务器”对话框，或者使用 XE 命令。

必备条件

要完成后面的 XenCenter 操作过程，您需要：

  • Workload Balancing 虚拟设备的 IP 地址或完全限定域名 (FQDN) 以及端口号。
  • 用于 Workload Balancing 所监视资源池（即池主服务器）的凭据。
  • 在 Workload Balancing 设备上创建的帐户的凭据。通常称为 Workload Balancing 用户帐户。XenServer 使用此帐户与 Workload Balancing 通信。（此帐户是 Workload Balancing 配置期间您在 Workload Balancing 虚拟设备上创建的帐户。）

如果要在连接 Workload Balancing 服务器时指定 Workload Balancing 虚拟设备的 FQDN（在“连接 WLB 服务器”对话框中），必须先手动将其主机名添加到您的 DNS 中。如果要配置受信任证书机构颁发的证书，Citrix 建议指定未过期的 FQDN 或 IP 地址。

首次连接 Workload Balancing 时，它使用默认的阈值和设置来平衡工作负载。默认情况下，自动功能（例如“自动优化模式”、“电源管理”和“自动化”）处于禁用状态。

重要提示如果您在 Workload Balancing 运行一段时间之后未获得最优放置建议，Citrix 强烈建议您对性能阈值进行评估，如评估优化阈值的效力中所述。为获得最优的 Workload Balancing 建议，务必为您的环境设置正确的阈值。

连接 Workload Balancing 虚拟设备

  1. 在 XenCenter 的资源窗格中，选择 XenCenter > your-resource-pool。
  2. 在属性窗格中，单击 WLB 选项卡。
  3. 在 WLB 选项卡中，单击连接。

    4. 此时将显示连接 WLB 服务器对话框。

  4. 在对话框的服务器地址部分中，输入以下信息：
    • 在地址框中，键入 Workload Balancing 服务器的 IP 地址或 FQDN。例如，输入 WLB-appliance-computername.yourdomain.net 作为 FQDN。
    • 在端口框中输入端口号。XenServer 使用此端口与 Workload Balancing 通信。

      默认情况下，XenServer 通过端口 8012 连接到 Workload Balancing（具体来说，是“Web 服务主机”服务）。如果在 Workload Balancing 配置期间更改了端口号，则必须在端口框中输入该端口号。

      重要提示除非您在 Workload Balancing 配置期间更改了默认端口，否则请勿更改默认端口号。在配置期间指定的端口号、在任何防火墙中指定的端口号以及连接 WLB 服务器对话框中指定的端口号必须一致。

  5. 在 WLB 服务器凭据部分，输入 XenServer 连接 Workload Balancing 虚拟设备时使用的用户名（例如 wlbuser）和密码。

    此帐户必须是您在 Workload Balancing 配置期间创建的帐户。默认情况下，此帐户的用户名为 wlbuser。

  6. 在 XenServer 凭据部分，输入您正在配置的池的用户名和密码。Workload Balancing 将使用这些凭据连接该池中的每个主机。

    要使用当前登录 XenServer 所使用的凭据，请选中使用当前 XenCenter 凭据复选框。如果已经使用基于角色的访问控制 (RBAC) 功能为帐户分配了权限，请确保这些权限足够使用 Workload Balancing。请参阅 RBAC 角色和权限定义。

  7. 连接到 Workload Balancing 设备后，如果要更改阈值设置或者更改为特定资源指定的优先级，请参阅编辑 Workload Balancing 设置。


基本任务简介

Workload Balancing 是一种功能强大的 XenServer 组件，具有许多用于在环境中优化工作负载的功能，例如主机电源管理、优化模式切换计划功能以及运行报告。此外，您还可以调整 Workload Balancing 用来提供优化建议的条件。

但是，当您初次使用 Workload Balancing 时，可能需要每天（或经常）使用 Workload Balancing 执行两项主要任务：

  • 确定用来启动虚拟机的最佳主机
  • 接受 Workload Balancing 优化建议

有关获取和配置 Workload Balancing 虚拟设备的信息，请参阅《Workload Balancing 快速入门》。

确定用来启动 VM 的最佳主机

另请参阅为 VM 的初始放置、迁移和恢复选择最优服务器。

当您需要重新启动已关闭的虚拟机以及将虚拟机迁移到其他主机时，Workload Balancing 可以提供有关主机的建议，确定在哪个主机上启动 VM（VM 放置）更为方便。此功能也可以在 XenDesktop 环境中使用。

接受 Workload Balancing 建议

另请参阅接受优化建议。

Workload Balancing 运行一段时间后，将开始提供有关环境改进方法的建议。例如，如果您的目标是提高主机上 VM 的密度（通过适当的设置），Workload Balancing 将就如何将多个虚拟机合并到一台主机上提出建议。如果未在自动化模式下运行，您可以选择应用此建议或直接将其忽略。

这些任务以及在 XenCenter 中执行这些任务的方法将在后面的各节中更深入地介绍。另一个常用的任务是环境中工作负载情况的运行报告，如生成并管理 Workload Balancing 报告中所述。

重要提示如果您在 Workload Balancing 运行一段时间之后未获得最优放置建议，Citrix 强烈建议您对性能阈值进行评估，如《Workload Balancing 管理员指南》中所述。对 Workload Balancing 设置适用于所用环境的正确阈值至关重要，否则其建议可能会不适用或者不会在正确的时间提供。


为 VM 的初始放置、迁移和恢复选择最优服务器

如果启用 Workload Balancing，当您启动处于脱机状态的虚拟机时，XenCenter 会提供建议，帮助您确定资源池中用来启动虚拟机的最优物理主机。由于最优主机以星形符号指示，因此这些建议又称星级建议。

由于 host17 是用来启动 VM 的最优主机，因此其旁边显示更多的实心星形符号。host16 旁边没有显示任何实心星形符号，表明此主机不是推荐主机，但是由于它处于启用状态，因此用户也可以选择该主机。host18 由于内存不足而处于灰显状态，因此用户无法选择该主机。

放置的实现

启用 Workload Balancing 后，XenCenter 会利用星级来指示用于启动虚拟机的最优主机，当您希望启动已关闭或挂起的虚拟机以及希望将该虚拟机迁移到不同服务器（迁移和维护模式）时，都会获得这样的最优主机建议。

如果在启用 Workload Balancing 的情况下使用这些功能，将物理主机旁显示星级，从而以这种方式提供主机建议。五颗空心星表示服务器的等级最低（最差）。如果无法在主机上启动虚拟机或将虚拟机移动到主机，或者当您使用菜单命令执行某种放置功能时，主机名称将呈灰色，并且名称旁将显示它无法接受 VM 的原因。

通常，如果您在 Workload Balancing 推荐的主机上启动虚拟机（即，通过一项放置功能选择星级最高的主机），则 Workload Balancing 的工作效率更高，提出的优化建议更加有效，并且提出建议的频率也更低。

最优的含义

术语最优是指最适合托管工作负载的物理服务器。Workload Balancing 在确定哪一个主机是工作负载的最优选择时会考虑以下几个因素：

  • 池中每个主机上的可用资源量。当池在性能最大化模式下运行时，Workload Balancing 会尽量在该池中的各主机之间均衡分配虚拟机，以使所有虚拟机都能达到良好的性能。当池在密度最大化模式下运行时，Workload Balancing 会在确保虚拟机有足够资源的同时，尽可能密集地将虚拟机放置到主机上。
  • 池运行时所采用的优化模式（性能最大化或密度最大化）。当池在性能最大化模式下运行时，Workload Balancing 会尽可能将虚拟机放置在可用资源最多且资源类型符合 VM 需求的主机上。在密度最大化模式下时，Workload Balancing 会尽可能将虚拟机放置在已经运行虚拟机的主机上，以使虚拟机在尽可能少的主机上运行。
  • VM 所需资源的数量和类型。在 Workload Balancing 监视虚拟机一段时间后，将使用收集的 VM 指标根据虚拟机所需的资源类型提出放置建议。例如，如果 VM 需要，Workload Balancing 可能会选择一个可用 CPU 较少但可用内存较多的主机（基于其过去的性能历史记录）。但应注意的是，Workload Balancing 只有在确定当前主机面临资源压力的情况下才会提出建议。

在最优服务器上启动虚拟机

  1. 在 XenCenter 的资源窗格中，选择要启动的虚拟机。
  2. 在 VM 菜单上，选择在服务器上启动，然后选择以下项之一：
    • 最优服务器。最优服务器是指最能满足所启动虚拟机的资源要求的物理主机。Workload Balancing 根据服务器性能指标的历史记录和您的放置策略来确定最优服务器。最优服务器是星级最高的服务器。
    • “最优服务器”命令下列出的带有星级的一台服务器。五颗星表示最值得推荐的（最优）服务器，五颗空心星表示最不值得推荐的服务器。

在最优服务器上恢复虚拟机

  1. 在 XenCenter 的资源窗格中，选择要恢复的已挂起虚拟机。
  2. 从 VM 菜单中，选择在服务器上恢复，然后选择以下项之一：
    • 最优服务器。最优服务器是指最能满足所启动虚拟机的资源要求的物理主机。Workload Balancing 根据服务器性能指标的历史记录和您的放置策略来确定最优服务器。最优服务器是星级最高的服务器。
    • “最优服务器”命令下列出的带有星级的一台服务器。五颗星表示最值得推荐的（最优）服务器，五颗空心星表示最不值得推荐的服务器。


接受优化建议

Workload Balancing 将就虚拟机的迁移方法提供建议，用以优化环境。优化建议显示在 XenCenter 的 WLB 选项卡中。

此图是“优化建议”列表的屏幕拍图，此列表显示在“WLB”选项卡上。“原因”列显示建议的目的。“操作”列显示就优化建议而提供的更改措施建议。此屏幕拍图显示了针对虚拟机 HA-prot-VM-7 和主机 host17.domain4.bedford4.ctx4 的优化建议。

优化建议的基础

优化建议基于以下因素：

  • 所选的放置策略（即放置优化模式），如调整优化模式中所述
  • 资源的性能指标，例如物理主机的 CPU、内存、网络和磁盘利用率
  • 主机在资源池中的角色。提出放置建议时，只有在没有其他主机能够接受工作负载时，Workload Balancing 才会考虑池主服务器。（同样，如果池在密度最大化模式下运行，则 Workload Balancing 在决定虚拟机填入各主机的顺序时，会最后考虑池主服务器。）

在优化建议中，将显示 Workload Balancing 建议重定位的虚拟机的名称、虚拟机当前所在主机的名称，以及 Workload Balancing 建议作为虚拟机新宿主的主机的名称。优化建议中还将显示 Workload Balancing 建议移动虚拟机的原因（例如，显示“CPU”表示为了提高 CPU 使用率）。

在您接受优化建议后，XenServer 会重定位所有建议优化的虚拟机。

提示：您可以通过在 XenCenter 中选择资源池并查看 WLB 选项卡的配置部分，来了解该资源池的优化模式。

接受优化建议

  1. 在资源窗格中，选择要显示建议的池，然后单击 WLB 选项卡。任何针对所选资源池中的虚拟机提出的优化建议（如果有）都将显示在 WLB 选项卡中。
  2. 要接受建议，请单击应用建议。XenServer 开始将优化建议部分中列出的所有虚拟机移动到建议的服务器中。

    单击应用建议之后，可以单击日志选项卡来显示虚拟机迁移的进度。

了解 WLB 建议的优先级低于高可用性

如果在同一个池中同时启用了 Workload Balancing 和 XenServer 高可用性功能，了解这两项功能的交互方式非常有用。根据设计，Workload Balancing 不会影响高可用性功能。如果在 Workload Balancing 建议与高可用性设置之间存在冲突，高可用性设置始终优先。在实际应用中，这意味着：

  • 对于超出配置高可用性对话框允许的故障数框中指定的故障数的任何主机，Workload Balancing 不会自动将其关闭。
    • 但是，Workload Balancing 建议关闭的主机数仍有可能多于允许的主机故障数。（例如，当高可用性配置为仅允许一个主机故障时，Workload Balancing 仍会提出关闭两个主机的建议。）但是，当您尝试应用该建议时，XenCenter 可能显示一条错误消息，指出不再保证实现高可用性。
    • 当 Workload Balancing 在自动化模式下运行并启用了电源管理功能时，任何超出允许的主机故障数的建议都将被忽略。在此情况下，如果您查看 Workload Balancing 日志，将会看到一条消息，说明由于启用了高可用性而未应用电源管理建议。


使用 Workload Balancing 报告

本主题提供关于 Workload Balancing 历史报告的一般性信息，并概要介绍有关这些报告的更多信息的查找位置。

要生成 Workload Balancing 报告，必须先导入 Workload Balancing 设备并且将池连接到该设备。

简介

Workload Balancing 针对三种类型的对象提供报告：物理主机、资源池和虚拟机。在较高级别上，Workload Balancing 提供两种类型的报告：

  • 按日期显示信息的历史报告
  • “汇总”式报告

Workload Balancing 提供一些用于审核目的的报告，以便您可以确定虚拟机移动次数等信息。

报告类型

Workload Balancing 提供关于池、主机和 VM 的多种不同报告。有关详细信息，请参阅 Workload Balancing 报告词汇表。

生成报告

Workload Balancing 允许您生成报告、将报告导出为 PDF 或电子表格，以及打印报告。有关详细信息，请参阅生成并管理 Workload Balancing 报告。


使用 Workload Balancing 报告执行任务

Workload Balancing 报告可以帮助您执行容量规划、确定虚拟机运行状况以及评估所配置阈值级别的效力。

评估性能阈值的效力

可以使用“池运行状况”报告来评估优化阈值的效力。Workload Balancing 提供了默认阈值设置。但是，您可能需要调整这些阈值的默认设置，以提供适合所用环境的值。如果没有根据所用环境将阈值调整为正确的级别，Workload Balancing 的建议可能不适用于该环境。

排除管理更改的故障

使用“池审核追踪”报告不仅可以确定有问题的更改来自哪里（即用户帐户），而且还可以确定该用户执行的事件或任务。


生成并管理 Workload Balancing 报告

本主题提供有关工作负载报告用法的基本说明，包括如何生成、导航、打印和导出报告。

生成 Workload Balancing 报告

  1. 在 XenCenter 的资源窗格中，选择 your-resource-pool。
  2. 从池菜单中，选择查看工作负载报告。

    提示：还可以通过在 WLB 选项卡上单击报告按钮来显示“工作负载报告”屏幕。

  3. 从“工作负载报告”屏幕的左侧窗格中选择一份报告。
  4. 选择报告期的开始日期和结束日期。根据所选报告，可能需要在主机列表框中指定一个主机。
  5. 单击运行报告。报告将显示在报告窗口中。

在 Workload Balancing 报告中导航

生成报告之后，您可以使用报告中的工具栏按钮进行导航并执行某些任务。要显示工具栏按钮的名称，请将鼠标指针停在工具栏图标上。

报告工具栏按钮
文档结构图。用于显示文档结构图，帮助您在大型报告中导航。
前一页/后一页。用于在报告中向前或向后移动一页。
返回到父报告。处理分层报告时，用于返回到父报告。注意：此按钮仅适用于分层报告，例如池运行状况报告。
停止呈现。停止生成报告。
打印。用于打印报告，并指定常规打印选项，例如打印机、页数和份数。
打印布局。用于在打印报告前显示报告预览。要退出打印布局，请再次单击打印布局按钮。
页面设置。用于指定打印选项，例如纸张大小、页面方向和页边距。
导出。用于以 Acrobat 文件格式 (.pdf) 或扩展名为 .xls 的 Excel 文件格式导出报告。
查找。用于在报告中搜索一个词语，例如虚拟机的名称。

打印 Workload Balancing 报告

必须先生成报告，然后才能打印该报告。

  1. （可选）要预览打印的文档，请单击 [image] 打印布局。
  2. （可选）要更改纸张大小/来源、页面方向或页边距，请单击 [image] 页面设置。
  3. 单击 [image] 打印。

导出 Workload Balancing 报告

可以采用 Microsoft Excel 和 Adobe Acrobat (.pdf) 格式导出报告。

生成报告后，单击 [image] 导出，然后选择以下格式之一：

  • Excel
  • Acrobat (.pdf) 文件

注意：导出报告时所包含的数据量可能因导出格式而异。导出为 Excel 格式的报告包含可供报告使用的所有数据，其中包括“明细”数据，而在 XenCenter 中显示的报告或导出为 .pdf 的报告仅包含在生成报告时所选择的数据。


Workload Balancing 报告词汇表

本主题提供关于以下 Workload Balancing 报告的信息。

计费使用分析

可以使用“计费使用分析”报告（计费报告）确定组织内的特定部门对某资源（如物理服务器）的使用情况。具体而言，该报告显示池中所有虚拟机的信息，包括其可用性和资源利用率。由于该报告提供虚拟机可用性（“运行时间”）信息，因而可以帮助您证明与服务水平协议的符合性及可用性。

计费报告可帮助您实施简单的计费解决方案，并简化收费方式。要对使用特定资源的客户收费，可以生成此报告，将其另存为 Excel 格式，然后通过自定义电子表格的数据来加入单价，或者将 Excel 数据导入到计费系统中。

如果确定将要对使用虚拟机的内部或外部客户收费，可以考虑在虚拟机命名约定中加入部门或客户名称。这样会使计费报告更易于阅读。

在某些情况下，计费报告中的资源报告以各虚拟机的物理资源分配量为基础。

同样，由于 XenServer 允许您分配固定的内存量或者由系统自动分配内存量，因此该报告中的平均内存数据以当前分配给虚拟机的内存量为基础，而无论采用固定内存分配方式还是自动内存分配方式（动态内存控制）。

计费报告包含以下数据列：

  • VM 名称。该行各列数据所对应的虚拟机的名称。
  • VM Uptime（VM 运行时间）。虚拟机开启（更确切地说，是 XenCenter 中该虚拟机旁显示绿色图标）的分钟数。
  • VCPU Allocation（VCPU 分配）。在虚拟机上配置的虚拟 CPU 的数目。每个虚拟 CPU 将获得相等份额的主机物理 CPU。例如，如果在一个包含两个物理 CPU 的主机上配置了八个虚拟 CPU，并且此列的值为“1”，则该值相当于主机总处理能力的 2/16。
  • Minimum CPU Usage (%)（最低 CPU 使用率 (%)）。在报告期间内所记录的最低虚拟 CPU 使用率值。该值以虚拟机虚拟 CPU 容量的百分比来表示，该容量以分配给虚拟机的虚拟 CPU 数为基础。例如，在您创建虚拟机时，如果为其分配了一个虚拟 CPU，则最低 CPU 使用率表示 XenServer 所记录的最低虚拟 CPU 使用率百分比（即使该使用率只持续了很短的时间）。如果为该虚拟机分配了两个虚拟 CPU，则此列中的值表示这两个虚拟 CPU 总容量的最低使用率 (%)。

    从根本上说，CPU 使用率百分比表示虚拟 CPU 所处理的最低记录工作负载。例如，如果为虚拟机分配一个虚拟 CPU，而主机上的物理 CPU 为 2.4 GHz，则该虚拟机将获得 2.4 GHz 的 1/8。这意味着，如果该虚拟机获得的容量为 0.3GHz (300MHz)，而其最低 CPU 使用率为 20%，则在报告期间内该虚拟机最低使用 60MHz 的物理主机 CPU。

  • Maximum CPU Usage (%)（最高 CPU 使用率 (%)）。在报告期间内虚拟机所占用的虚拟 CPU 容量的最高百分比。占用的 CPU 容量是基于分配给虚拟机的虚拟 CPU 容量的百分比。例如，创建虚拟机时，如果为其分配了一个虚拟 CPU，则最高 CPU 使用率表示在报告期间内所记录的最高虚拟 CPU 使用率百分比。如果为该虚拟机分配了两个虚拟 CPU，则此列中的值表示基于这两个虚拟 CPU 总容量的最高使用率。
  • Average CPU Usage (%)（平均 CPU 使用率 (%)）。平均的 CPU 使用率 (%)。在报告期间内所用虚拟机虚拟 CPU 容量的平均量 (%)。CPU 容量是分配给虚拟机的虚拟 CPU 容量。如果为该虚拟机分配两个虚拟 CPU，则此列中的值表示这两个虚拟 CPU 总容量的平均使用率。
  • Total Storage Allocation (GB)（总存储分配 (GB)）。运行报告时分配给虚拟机的磁盘空间量。通常，此磁盘空间是您在创建虚拟机时为其分配的磁盘空间量，除非对其进行了修改。
  • Virtual NIC Allocation（虚拟 NIC 分配）。分配给虚拟机的虚拟接口 (VIF) 的数目。
  • Current Minimum Dynamic Memory (MB)（当前最低动态内存 (MB)）。
    • Fixed memory allocation（固定内存分配）。如果为虚拟机分配了固定大小的内存（例如 1024MB），以下各列中都将显示此内存量：“Current Minimum Dynamic Memory (MB)”（当前最低动态内存 (MB)）、“Current Maximum Dynamic Memory (MB)”（当前最高动态内存 (MB)）、“Current Assigned Memory (MB)”（当前分配内存 (MB)）以及“Average Assigned Memory (MB)”（平均分配内存 (MB)）。
    • Dynamic memory allocation（动态内存分配）。如果将 XenServer 配置为根据范围自动调整虚拟机的内存（即启用了动态内存控制），则此列中将显示为该范围指定的最低内存量。例如，如果在 XenCenter 的“内存设置”对话框中为该虚拟机选择了“自动在此范围内分配内存”选项，然后指定此范围的最低内存量为 1024MB，最高内存量为 2048MB，则 1024MB 将显示在“Current Minimum Dynamic Memory (MB)”（当前最低动态内存 (MB)）列中。
  • Current Maximum Dynamic Memory (MB)（当前最高动态内存 (MB)）。
    • Dynamic memory allocation（动态内存分配）。如果将 XenServer 设置为根据某个范围自动调整 VM 的内存，则此列中将显示该范围内指定的最高内存量。例如，如果您指定的内存范围为最低 1024MB、最高 2048MB，则 2048MB 将显示在“Current Maximum Dynamic Memory (MB)”（当前最高动态内存 (MB)）列中。
    • Fixed memory allocation（固定内存分配）。如果为 VM 分配固定大小的内存（例如 1024MB），则以下各列中都将显示此内存量：“Current Minimum Dynamic Memory (MB)”（当前最低动态内存 (MB)）、“Current Maximum Dynamic Memory (MB)”（当前最高动态内存 (MB)）、“Current Assigned Memory (MB)”（当前分配内存 (MB)）以及“Average Assigned Memory (MB)”（平均分配内存 (MB)）。
  • Current Assigned Memory (MB)（当前分配内存 (MB)）。
    • Dynamic memory allocation（动态内存分配）。配置了动态内存控制时，此值表示在报告运行时 XenServer 分配给虚拟机的内存量。
    • Fixed memory allocation（固定内存分配）。如果为虚拟机分配了固定大小的内存（例如 1024MB），以下各列中都将显示此内存量：“Current Minimum Dynamic Memory (MB)”（当前最低动态内存 (MB)）、“Current Maximum Dynamic Memory (MB)”（当前最高动态内存 (MB)）、“Current Assigned Memory (MB)”（当前分配内存 (MB)）以及“Average Assigned Memory (MB)”（平均分配内存 (MB)）。

      注意： 如果在运行此报告之前刚刚更改了虚拟机的内存分配，则该列中的值将反映您配置的新内存分配。

  • Average Assigned Memory (MB)（平均分配内存 (MB)）。
    • Dynamic memory allocation（动态内存分配）。如果配置动态内存控制，则该值表示在报告期间 XenServer 分配给虚拟机的平均内存量。
    • Fixed memory allocation（固定内存分配）。如果为虚拟机分配了固定大小的内存（例如 1024MB），以下各列中都将显示此内存量：“Current Minimum Dynamic Memory (MB)”（当前最低动态内存 (MB)）、“Current Maximum Dynamic Memory (MB)”（当前最高动态内存 (MB)）、“Current Assigned Memory (MB)”（当前分配内存 (MB)）以及“Average Assigned Memory (MB)”（平均分配内存 (MB)）。

      注意：如果在运行此报告之前刚刚更改了虚拟机的内存分配，该列中显示的值可能不会改变。此列中的值反映的是一段时间内的平均值。

  • Average Network Reads (BPS)（平均网络读取量 (BPS)）。虚拟机在报告期间接收的平均数据量（比特/秒）。
  • Average Network Writes (BPS)（平均网络写入量 (BPS)）。虚拟机在报告期间发送的平均数据量（比特/秒）。
  • Average Network Usage (BPS)（平均网络使用量 (BPS)）。平均网络读取量和平均网络写入量的总和（比特/秒）。例如，如果虚拟机在报告期间平均每秒发送 1,027 比特，而平均每秒接收 23,831 比特，则平均网络使用量将是这两个值的总和：24,858 比特/秒。
  • Total Network Usage (BPS)（网络使用总量 (BPS)）。在报告期间发生的所有网络读写事务的总量（比特/秒）。

主机运行状况历史记录

此报告显示特定主机上相对于阈值的资源性能（CPU、内存、网络读取量和网络写入量）。

彩色线（红色、绿色和黄色）代表不同的阈值。可以将主机的这一报告与“池运行状况”报告结合使用，来确定此特定主机的性能对整体池运行状况可能产生的影响。编辑性能阈值时，可以通过此报告深入了解主机性能。

可以显示日均或时均资源利用率。时均利用率可以让您了解一天中某段时间内平均最忙的几个小时。

要查看按小时分组的报告数据，请展开主机运行状况历史记录标题栏下的 + Click to view report data grouped by house for the time period（+ 单击以查看该时段内按小时分组的报告数据）。

Workload Balancing 将显示所设置时段内每小时的平均值。数据点基于该时间段内各天该小时的平均利用率。例如，在 2009 年 5 月 1 日到 2009 年 5 月 15 日的报告中，“平均 CPU 使用率”数据点表示全部 15 天中每天 12:00 的资源利用率加总后的平均值。就是说，如果 CPU 在 5 月 1 日正午 12:00 的使用率是 82%，在 5 月 2 日正午 12:00 的使用率是 88%，在所有其他日期中正午 12:00 的使用率都是 75%，那么正午 12:00 的平均使用率显示为 76.3%。

注意：Workload Balancing 将对峰值进行平滑处理，因此数据不会出现不实的高峰值。

池优化性能历史记录

优化性能报告显示针对池的平均资源利用率进行的优化事件（即，在优化资源池时发生的事件）。具体来说，报告显示 CPU、内存、网络读取量和网络写入量的资源利用率。

虚线表示在所选日期范围内池的平均利用率。蓝条表示进行池优化的日期。

此报告可以帮助您确定 Workload Balancing 在您的环境中是否正常工作。可以使用此报告查看导致优化事件的原因（即，Workload Balancing 提出优化建议前的资源利用率）。

此报告显示当天的平均资源利用率，而不显示峰值利用率（例如系统负载沉重时）。如果 Workload Balancing 没有提出优化建议，您也可以通过此报告了解资源池的性能情况。

一般来说，在优化事件后，资源利用率应降低或保持不变。如果在优化后资源利用率没有改进，请考虑重新调整阈值。此外，请考虑资源池中是否有过多的虚拟机，以及在您指定的时段内是否添加或删除了新的虚拟机。

池审核追踪

此报告显示 XenServer 审核日志的内容；XenServer 审核日志功能用于记录执行未授权操作及选择已授权操作的尝试，包括导入/导出、主机和池备份以及来宾系统和主机控制台访问操作。当使用基于角色的访问控制功能为 XenServer 管理员指定具有不同角色的用户帐户时，此报告可提供更有用的信息。有关审核日志功能的信息，请参阅《Workload Balancing 管理员指南》中的审核日志文档。

重要提示：要运行审核日志报告，必须启用审核日志记录功能。默认情况下，在 Workload Balancing 虚拟设备中始终启用审核日志。但是，审核日志仅为特定对象和操作获取数量有限的数据。

此报告显示以下内容：

  • 时间。XenServer 记录用户操作的时间。
  • Event Action（事件操作）。发生的操作。有关这些操作的定义，请参阅审核日志事件名称。
  • 用户名。执行操作时所处会话的创建人的名称。在某些情况下，此项内容可能是用户 ID。
  • Access（访问权限）。用户是否有权执行操作。
  • Event Object（事件对象）。作为操作主体的对象（例如虚拟机）。
  • Object Name（对象名称）。对象的名称（例如，虚拟机的名称）。
  • 成功。此列提供操作的状态（即，操作是否成功）。

池运行状况

“池运行状况”报告显示资源池及其主机处于以下四个不同阈值范围的时长占总时间的百分比：临界、高、中和低。您可以使用“池运行状况”报告来评估性能阈值的效力。

关于此报告的几点解释：

  • 无论您选择哪种放置策略，平均中阈值（蓝色）中的资源利用率都是最优资源利用率。同样，饼图中的蓝色部分指示主机处于资源使用率最优状态的时长。
  • 平均低阈值百分比（绿色）中的资源利用率不必是正值。低资源利用率是否为正值取决于放置策略。例如，如果放置策略为密度最大化，但资源利用率大多数时间为绿色，则 Workload Balancing 可能未将尽可能多的虚拟机放置在该主机或池上。如果出现这种情况，应调整性能阈值，直到资源利用率大部分时间处于平均中阈值（蓝色）范围内。
  • 平均临界阈值百分比（红色）中的资源利用率指示平均资源利用率达到或超过临界阈值的时长。

如果双击表示主机资源利用率的饼图，XenCenter 将显示该主机上相应资源（例如 CPU）的“主机运行状况历史记录”报告。单击返回到父报告工具栏按钮将使您返回到“池运行状况历史记录”报告。注意：此按钮仅适用于分层报告，例如池运行状况报告。

如果发现大多数报告结果都不在平均中阈值范围内，则可能需要调整该资源池的临界阈值。Workload Balancing 提供默认的阈值设置，但这些默认设置并非在所有环境中都有效。如果不将阈值调整到适合所用环境的正确级别，Workload Balancing 的优化和放置建议可能不适用。有关详细信息，请参阅更改临界阈值。

注意：高、中和低阈值范围都以临界阈值为基础。

池运行状况历史记录

此报告提供池中所有物理主机的资源利用率随时间变化的线图。通过此报告，您可以了解资源利用率的趋势 - 是否相对于所设定的阈值（临界、高、中和低）趋向于增加。通过监视该报告中数据点的趋势，您可以评估性能阈值的效力。

Workload Balancing 会根据您设置的临界阈值来推断阈值范围。虽然与“池运行状况”报告相似，但“池运行状况历史记录”报告显示的是资源在某一特定日期的平均利用率，而不是处于某个阈值范围的总时长。

除“平均可用内存”图外，数据点的平均值在任何时候都不应越过临界阈值线（红色）。对于“平均可用内存”图，数据点的平均值在任何时候都不应在临界阈值线（位于图表底部）之下。由于此图显示可用内存，因此临界阈值为低值，这与其他资源不同。

关于此报告的几点解释：

  • 当图表中的“平均使用率”线接近平均中阈值线（蓝色）时，表示池的资源利用率处于最优状态，这与配置的放置策略无关。
  • 接近平均低阈值线（绿色）的资源利用率不必为正值。低资源利用率是否为正值取决于放置策略。例如，如果您的放置策略是“密度最大化”，而大部分日期的“平均使用率”线与绿线重合或在绿线之下，那么 Workload Balancing 可能未在该池上尽可能密集地放置虚拟机。如果是这种情况，您应调整池的临界阈值，直到其资源利用率大部分处于平均中阈值（蓝色）范围内。
  • 如果“平均使用率”线与“平均临界阈值百分比”线（红色）相交，则表示在这些天中，平均资源利用率达到或超过该资源的临界阈值。

如果您发现图中的大多数数据点都不在平均中阈值范围内，但该池的性能满足您的要求，则可能需要调整该池的临界阈值。有关详细信息，请参阅更改临界阈值。

池优化历史记录

利用“池优化历史记录”报告可以按时间顺序查看 Workload Balancing 优化活动。

优化活动以图形和表格的形式汇总。如果进入表格内的日期字段，将显示当日执行的每个池优化操作的详细信息。

利用此报告可以查看以下信息：

  • VM 名称。Workload Balancing 优化的虚拟机的名称。
  • 原因。进行优化的原因。
  • 状态。指示优化是否成功。
  • 源主机。最初托管虚拟机的物理服务器。
  • 目标主机。虚拟机移动到的物理服务器。
  • 时间。发生优化的时间。

提示：还可以通过在 WLB 选项卡上单击查看历史记录链接来生成“池优化历史记录”报告。

虚拟机移动历史记录

此线图显示一段时间内虚拟机在一个资源池中的移动次数。它将指示移动是否源于优化建议，以及虚拟机移动到哪个主机。该报告还将指出进行优化的原因。您可以使用此报告审核池中发生移动的次数。

关于此报告的几点解释：
  • 图表左侧的数值代表可能的移动次数，该值基于资源池中虚拟机的数量。
  • 展开报告日期部分中的加号 (+)，可以查看特定日期移动操作的详细信息。

虚拟机性能历史记录

此报告显示在您指定的时段内特定主机上每个虚拟机的性能数据。Workload Balancing 的性能数据基于为虚拟机分配的虚拟资源数量。例如，如果虚拟机的平均 CPU 使用率为 67%，则意味着在您指定的时段内，虚拟机平均占用了 67% 的虚拟 CPU。

该报告的初始视图显示在指定的时段内资源利用率的平均值。

展开加号 (+) 后，将显示各个资源的线图。可以通过这些图来查看资源利用率随时间变化的趋势。

该报告显示关于 CPU 使用率、可用内存、网络读取/写入量和磁盘读取/写入量的数据。


审核日志事件名称

下表定义了在 XenServer 审核日志和池审核追踪报告中经常出现的一些事件。有关其他事件的定义，请参阅 Citrix XenServer Management API（Citrix XenServer 管理 API）。

在池审核追踪报告中，Event Action（事件操作）列中列出的事件应用于池、VM 或主机。要确定事件应用的对象，请参阅该报告中的 Event Object（事件对象）和 Object Name（对象名称）列。

事件操作 | 用户操作
SR.destroy | 销毁存储库。
VM.start | 启动虚拟机。
http/get_audit_log | 检索审核日志。
reboot | 重新启动 XenServer 主机。
disable | 将主机置于无法启动任何新 VM 的状态。
migrate | 如果可能，迁移该主机的所有 VM。
suspend | 将 VM 状态保存到磁盘，并不再运行 VM。
hard_shutdown | 在不尝试执行干净关机的情况下停止执行指定的 VM。
hard_reboot | 在不尝试执行干净关机的情况下停止执行指定的 VM，并立即重新启动 该 VM。
start_on | 在特定主机上启动指定的 VM。
snapshot_with_quiesce | 以静默方式创建指定 VM 的快照，从而创建新的 VM。
enable_ha | 开启高可用性模式。
copy | 复制指定的 VM，从而创建新 VM。
disable_ha | 关闭高可用性模式。
join_force | 指示（强制）主机加入新池。
join | 指示主机加入新池。
shutdown | 关闭指定的 VM。
pool_migrate | 将 VM 迁移至另一台主机。
pool.retrieve_wlb_recommendations | 检索该池的 Workload Balancing 建议。


编辑 Workload Balancing 设置

连接到 Workload Balancing 虚拟设备后，可以编辑 Workload Balancing 在计算放置和优化建议所使用的设置。可以执行如下的任务：

  • 调整优化模式
  • 设置自动化和电源管理
  • 更改临界阈值
  • 调整指标加权
  • 从建议中排除主机
  • 高级设置

注意：连接或重新连接到 Workload Balancing 后，在更改设置之前应至少等待六十秒，直到 Workload Balancing (/var/log/wlb/LogFile.log) 显示检测完成。

Workload Balancing 设置的应用方式

Workload Balancing 设置共同应用于池中的所有虚拟机和主机。

如果网络和磁盘阈值与环境中的硬件相符，在初始时可以考虑使用 Workload Balancing 中的大多数默认设置。

在 Workload Balancing 启用一段时间后，Citrix 建议对性能阈值进行评估，以确定是否需要编辑这些阈值。例如，以下情况下应考虑调整阈值：

  • 在尚不需要时获得优化建议。这种情况下，请尝试调整阈值，直到 Workload Balancing 开始提供适当的优化建议。
  • 当您认为网络带宽不足时未获得建议。这种情况下，请尝试降低网络临界阈值，直到 Workload Balancing 开始提供优化建议。

您会发现，在编辑阈值前，为池中的每台物理主机生成主机运行状况历史记录报告将便于您进行编辑。

您可以在 XenCenter 中使用 Workload Balancing 配置属性或 XE 命令来修改配置设置。

要更新 XenServer 与 Workload Balancing 服务器通信时所使用的凭据，请参阅更新 Workload Balancing 凭据。

有关优化 Workload Balancing 设置的更详细指导，请参阅《Workload Balancing 管理员指南》。

显示 Workload Balancing 设置对话框

  1. 在 XenCenter 的资源窗格中，选择 your-resource-pool。
  2. 在属性窗格中，单击 WLB 选项卡。
  3. 在 WLB 选项卡中，单击设置。


调整优化模式

Workload Balancing 根据您选择的放置策略（称为优化模式）提出建议，以重新平衡（或称优化）环境中的虚拟机工作负载。

密度最大化和性能最大化模式

可以选择以下两种优化模式之一：

  • 性能最大化。（默认。）Workload Balancing 尝试在一个资源池中的所有物理主机之间平均分布工作负载。目标是最大程度地减小所有主机上的 CPU、内存和网络压力。如果选择性能最大化放置策略，Workload Balancing 将在某个虚拟机达到高阈值时提出优化建议。
  • 密度最大化。Workload Balancing 尝试在一台物理主机上启动尽可能多的虚拟机。目标是最大限度地减少需要联机的物理主机数量。

    如果选择密度最大化放置策略，可以指定与性能最大化相似的规则。但是，Workload Balancing 会使用这些规则来确定如何将这些虚拟机尽量放入一个主机中。如果选择密度最大化放置策略，Workload Balancing 将在某台虚拟机达到临界阈值时提出优化建议。

Workload Balancing 允许您始终应用这些优化模式（固定模式），或者在指定的时段切换模式（计划模式）。

固定

固定优化模式将 Workload Balancing 设置为始终执行特定的优化行为，即尽力实现最佳性能或者最大密度。

计划

计划优化模式允许您安排 Workload Balancing 根据一天中的具体时间应用不同的优化模式。例如，在白天，当有用户处于连接状态时，可以将 Workload Balancing 配置为针对性能进行优化，而在夜晚，为了节能，可以将 Workload Balancing 指定为针对密度最大化进行优化。

配置计划优化模式时，Workload Balancing 会在指定时段开始时（星期几以及具体时间）自动切换到相应优化模式。

设置所有时段的优化模式

  1. 在资源窗格中选择池，单击 WLB 选项卡，然后单击设置。
  2. 在左侧窗格中，单击优化模式。
  3. 选择固定，然后选择以下优化模式之一：
    • 性能最大化。（默认。）尝试在一个资源池中的所有物理主机上平均分布工作负载。目标是最大程度地减小所有主机上的 CPU、内存和网络压力。
    • 密度最大化。尝试在一台物理主机上启动尽可能多的虚拟机。目标是最大限度地减少需要联机的物理主机数量。（请注意，Workload Balancing 将考虑合并后 VM 的性能，并在主机上的资源达到临界阈值时，提出提高性能的建议。）

指定自动切换优化模式的时间

  1. 在资源窗格中选择池，单击 WLB 选项卡，然后单击设置。
  2. 在左侧窗格中，单击优化模式。
  3. 选择计划。
  4. 单击添加新项以打开优化模式计划程序对话框。
  5. 在更改为列表框中选择一种优化模式：
    • 性能最大化。尝试在一个资源池中的所有物理主机上平均分布工作负载。目标是最大程度地减小所有主机上的 CPU、内存和网络压力。
    • 密度最大化。尝试在一台物理主机上启动尽可能多的虚拟机。目标是最大限度地减少需要联机的物理主机数量。
  6. 选择希望 Workload Balancing 在星期几的什么时间开始以此模式运行。
  7. 创建更多的计划模式切换（即“任务”），直至达到所需的数量。如果只计划一个任务，Workload Balancing 将切换到该模式，而永远不会切换回原来的模式。
  8. 单击确定。

删除或暂停计划的优化模式任务

  1. 在资源窗格中选择池，单击 WLB 选项卡，然后单击设置。
  2. 单击优化模式。
  3. 选择一项计划的任务，并单击以下选项之一：
    • 永久删除任务。单击删除按钮。
    • 暂时停止任务运行。在任务上单击鼠标右键，然后单击禁用。
    要重新启用某个任务，请在 Scheduled Mode Changes（计划模式切换）列表中的该任务上单击鼠标右键。

编辑计划的优化模式任务

  1. 在资源窗格中选择池，单击 WLB 选项卡，然后单击设置。
  2. 选择一项计划的任务。
  3. 单击编辑。
  4. 在更改为框中，选择其他模式，或者根据需要进行其他更改。


自动优化和管理电源

可以将 Workload Balancing 配置为自动接受优化建议（自动化），并自动打开或关闭服务器（电源管理）。

自动接受优化建议

可以将 Workload Balancing 配置为代表您自动接受优化建议，并自动执行其建议的优化操作。您可以使用此功能（称为自动化）自动应用任何建议，包括提高性能或关闭主机的建议。但是，要在虚拟机使用率下降时关闭主机，必须配置自动化、电源管理和密度最大化模式。

默认情况下，Workload Balancing 不自动接受优化建议。如果希望 Workload Balancing 自动接受建议，必须启用“自动化”功能。否则，Workload Balancing 仍然会提示您手动接受建议。

如果建议与高可用性设置冲突，则 Workload Balancing 不会自动将这些建议应用于主机或虚拟机。如果应用 Workload Balancing 优化建议将导致某个池被过度使用，XenCenter 将询问您是否要继续应用建议。如果启用“自动化”功能，Workload Balancing 应用的电源管理建议的数量不会超出“高可用性”计划中允许的主机故障数量。

可以调整 Workload Balancing 在自动化模式下应用建议的方式。有关信息，请参阅高级设置。

启用电源管理

术语电源管理是指开启或关闭物理主机电源的能力。在 Workload Balancing 环境中，此术语是指根据池的总工作负载，开启或关闭该池中的主机。

在主机上配置 Workload Balancing 电源管理需要满足以下条件：

  • 主机服务器的硬件具有远程开/关机功能
  • 为该主机配置了主机开启功能
  • 已将该主机明确选择为参与 (Workload Balancing) 电源管理的主机

此外，如果希望 Workload Balancing 自动关闭主机，还需要进行以下配置：

  • 将 Workload Balancing 配置为自动应用建议
  • 将 Workload Balancing 配置为自动应用电源管理建议

启用了电源管理功能并且池处于密度最大化模式时，如果 Workload Balancing 检测到未使用的资源，会提出关闭主机的建议，直到消除池中的所有过剩容量。如果 Workload Balancing 检测到池中的主机容量不足以关闭服务器，会建议将服务器保持打开状态，直到该池的工作负载降低到足以关闭服务器的水平。如果您将 Workload Balancing 配置为自动关闭额外服务器，它会自动应用这些建议，其结果与手动模式相同。

主机设置为参与电源管理时，Workload Balancing 会根据需要提出开/关机建议。如果启用用于自动应用电源管理建议的选项，应在池级别启用。但可以指定希望池中的哪些主机参与电源管理。

了解电源管理行为

Workload Balancing 在提出开启或关闭主机的建议之前，会选择虚拟机要转移（即“填充”）到的主机。按以下顺序进行转移：

  1. 填充池主服务器，因为该主机无法关闭。
  2. 填充包含最多虚拟机的主机。
  3. 在后续主机中选择运行最多虚拟机的主机来填充。

当 Workload Balancing 填充池主服务器时，会假设该服务器的（内部）阈值非常低。Workload Balancing 使用这些低阈值作为缓冲，来防止池主服务器过载。

Workload Balancing 按照此顺序填充主机以提高密度。

此图解释了在密度最大化模式下在主机上合并 VM 时，XenServer 将尝试首先填充池主服务器，然后填充负载最高的服务器，最后填充负载最低的服务器。

当池处于密度最大化模式时，如果 Workload Balancing 检测到性能问题，它会通过建议在已开启的主机之间迁移工作负载，尝试解决该问题。如果 Workload Balancing 通过这种方法不能解决该问题，它会尝试开启一个主机。（Workload Balancing 将根据与性能最大化优化模式相同的条件来确定开启哪个/哪些主机。）

当 Workload Balancing 在性能最大化模式下运行时，只要池中所有主机上的资源利用率未降至高阈值以下，Workload Balancing 就会提出开启主机的建议。

在迁移一个或多个虚拟机时，如果 Workload Balancing 确定提高容量对池的整体性能有益，它会自动开启主机，或者建议开启主机。

重要提示除非 Workload Balancing 关闭了某个主机，否则 Workload Balancing 绝不会建议您将其打开。

针对电源管理和 VM 合并设计环境

如果要配置自动 VM 合并和电源管理功能，在对 XenServer 的实施进行规划时，应考虑工作负载设计。例如，您可能需要：

  • 将不同类型的工作负载放置在不同的池中。如果您的环境中包含不同类型的工作负载（例如，用户应用程序与域控制器）或者更适用于某些硬件类型的应用程序类型，则应考虑是否需要将托管这些工作负载的虚拟机放置在不同的池中。

    由于电源管理和 VM 合并在池级别进行管理，因此设计的池中应包含要以相同比率合并的工作负载，并需要考虑多项因素，例如高级设置主题中讨论的因素。

  • 从 Workload Balancing 排除主机。某些主机可能需要始终处于开启状态。有关详细信息，请参阅从建议中排除主机。

自动应用优化建议

  1. 在 XenCenter 的资源窗格中，选择 XenCenter > your-resource-pool。
  2. 在属性窗格中，单击 WLB 选项卡。
  3. 在 WLB 选项卡中，单击配置 WLB。
  4. 在左侧窗格中，单击自动化。
  5. 选中以下一个或多个复选框：
    • 自动应用优化建议。如果选中此选项，则无需手动接受优化建议。Workload Balancing 会自动接受其提出的优化和放置建议。
    • 自动应用电源管理建议。此选项的行为因池的优化模式而异：
      • 性能最大化模式。当启用了自动应用电源管理建议时，如果可以通过开启主机来提高主机性能，Workload Balancing 将自动开启主机。
      • 密度最大化模式。当启用了自动应用电源管理建议时，Workload Balancing 将在资源利用率降到低阈值以下时，自动关闭主机（即 Workload Balancing 在低资源利用率期间自动关闭主机）。
  6. 执行以下操作之一：
    • 如果要配置电源管理，请单击自动化/电源管理，并继续选择要进行电源管理的服务器。
    • 如果不希望配置电源管理并且配置了自动化功能，请单击确定。

选择要进行电源管理的服务器

  1. 在“电源管理”部分，选择希望 Workload Balancing 自动开启和关闭的主机。

    注意：如果在选择要应用电源管理建议的主机时，未选中自动应用电源管理建议复选框，Workload Balancing 会提出电源管理建议，但不会自动应用这些建议。

  2. 单击确定。

    如果资源池中的所有物理服务器均不支持远程电源管理，Workload Balancing 会显示所有主机均不支持电源管理消息。


更改临界阈值

本主题将介绍修改默认临界阈值的方法，并说明设置的临界阈值如何改变高、中、低阈值。

这些信息仅作为更改阈值时的参考。要了解本主题中所讨论的概念，务必在《Workload Balancing 管理员指南》所提供的更全面的参考环境中阅读这些内容。

概述

评估利用率时，Workload Balancing 将日常平均值与以下四个阈值相比较：低、中、高和临界阈值。在指定临界阈值（或接受默认临界阈值）后，Workload Balancing 将相对于临界阈值为池设置其他阈值。您可能需要通过更改临界阈值来控制触发优化建议的时机。

Workload Balancing 会对资源池中物理主机的 CPU、内存、网络读取、网络写入、磁盘读取和磁盘写入利用率进行评估。

通过评估以下内容，Workload Balancing 可以确定是否提出重定位工作负载的建议，以及确定物理主机是否适合虚拟机工作负载：

  • 物理主机上是否有资源达到临界阈值
  • （如果达到临界阈值）为资源指定的重要性

注意：为防止数据虚高，Workload Balancing 将评估资源的日常平均值，并对利用率峰值进行平滑处理。

有关详细信息，请参阅《Workload Balancing 管理员指南》。

Workload Balancing 将根据资源的历史平均利用率是否超出阈值来决定是否生成建议。如《Workload Balancing 管理员指南》中所述，如果在性能最大化模式下超出高阈值，或者在密度最大化模式下低于低阈值和临界阈值，将触发 Workload Balancing 建议。为资源指定新临界阈值后，Workload Balancing 会相对于新临界阈值重置该资源的其他阈值。（为了简化用户界面，通过 XenCenter 只能更改临界阈值。）

阈值的默认设置

下表显示了 Workload Balancing 阈值的默认值：

设置 | 默认值 | 高 | 中 | 低
CPU 使用率 | 90% | 76.5% | 45% | 22.5%
可用内存 | 51MB | 63.75MB | 510GB | 1020GB
网络读取 | 25MB/秒 | 21.25MB/秒 | 12.5MB/秒 | 6.25MB/秒
网络写入 | 25MB/秒 | 21.25MB/秒 | 12.5MB/秒 | 6.25MB/秒
磁盘读取 | 25MB/秒 | 21.25MB/秒 | 12.5MB/秒 | 6.25MB/秒
磁盘写入 | 26 MB/秒 | 21.25MB/秒 | 12.5MB/秒 | 6.25MB/秒

在计算“高”、“中”和“低”资源指标的值时，Workload Balancing 会将临界阈值的新值与以下因数相乘：

  • 高阈值因数： 0.85
  • 中阈值因数： 0.50
  • 低阈值因数： 0.25

在计算可用内存的阈值时，Workload Balancing 会将临界阈值与以下因数相乘：

  • 高阈值因数： 1.25
  • 中阈值因数： 10.0
  • 低阈值因数： 20.0

这意味着，如果您将池的 CPU 使用率临界阈值提高至 95%，Workload Balancing 会自动将高、中和低阈值分别重置为 80.75%、47.5% 和 23.75%。

要对特定阈值执行此计算，请将阈值因数与您为该资源输入的临界阈值相乘：

高、中或低阈值 = 临界阈值 * 阈值因数

例如，如果您将“网络读取”的临界阈值更改为 40MB/s，并且想知道其低阈值，可以用 40 乘以 0.25，得出 10MB/s。要得到中阈值，可以用 40 乘以 0.50，依此类推。

为防止池主服务器过载，Workload Balancing 会自动将池主服务器的临界阈值设置得较低。

其他阈值如何触发建议

尽管临界阈值可以触发许多建议，但其他阈值也可以触发建议，如下所述：

高阈值。

  • 性能最大化。超出高阈值会触发将虚拟机重定位到资源利用率较低的主机的优化建议。
  • 密度最大化。如果将虚拟机移动到主机会导致该主机上任何资源的利用率超出高阈值，Workload Balancing 将不会提出将该虚拟机放置到该主机的建议。

低阈值。

  • 性能最大化。Workload Balancing 不会因低阈值而触发建议。
  • 密度最大化。当某个指标值降到低阈值以下时，它会向 Workload Balancing 发出信号，告知主机利用率偏低，并触发将虚拟机合并到更少主机上的优化建议。Workload Balancing 将持续提出将虚拟机移动到某个主机的建议，直至该主机某个资源的指标值达到高阈值为止。

    但是，如果在重定位某个虚拟机后，该虚拟机所在新主机上的某种资源的利用率超出其临界阈值，Workload Balancing 将临时使用与性能最大化负载平衡算法相类似的算法来为虚拟机查找新主机。Workload Balancing 将持续使用此算法来提出移动虚拟机的建议，直到池中各主机上的资源利用率都降至高阈值以下。

更改临界阈值

  1. 在“资源”窗格中选择池，单击 WLB 选项卡，然后单击设置。
  2. 在左侧窗格中，选择临界阈值。
  3. 在临界阈值页面中，接受临界阈值框中的值或输入一个新值。

    Workload Balancing 在提出虚拟机放置和池优化建议时，会使用这些阈值。Workload Balancing 会尽力将主机上的资源利用率保持在设置的临界阈值以下。


调整指标加权

注意： 在调整指标加权之前，Citrix 建议您阅读《Workload Balancing 管理员指南》中关于优化和合并过程的内容。本帮助主题中的信息是该指南所含信息的一部分，仅作为更改用户界面时的参考。

Workload Balancing 使用指标加权（一种指定资源重要性的方法）确定应该首先优化的主机。

确定首先处理的主机和 VM 时，Workload Balancing 对指标加权的使用方式因优化模式（密度最大化或性能最大化）而异。

当 Workload Balancing 处理优化建议时，将创建优化顺序。确定此顺序时，Workload Balancing 将最重要资源拥有最高指标值的主机排在最优先处理的位置，资源的重要性通过指标加权页面排定。

通常，指标加权主要在池处于性能最大化模式时使用。但是，当 Workload Balancing 处于密度最大化模式时，如果某个资源超出其临界阈值，也会使用指标加权。

在性能最大化模式下应用指标加权的方式

在性能最大化模式下，Workload Balancing 使用指标加权确定：(a) 首先处理哪些主机的性能；(b) 建议首先迁移的 VM。

例如，如果将“网络写入”排定为 Workload Balancing 应考虑的最重要的资源，即您将指标加权滑块移动到最右端（更重要），而将所有其他滑块移动到中间，则 Workload Balancing 将首先在每秒网络写入量最多的主机上解决性能问题（即提供优化建议）。

如果将所有资源配置为同等重要（即所有资源的指标加权滑块都处于相同的位置），则 Workload Balancing 将首先解决 CPU 使用率问题，然后解决内存问题，因为这些资源通常是最受限制的资源。

在密度最大化模式下应用指标加权的方式

在密度最大化模式下，Workload Balancing 仅在某个主机达到临界阈值时使用指标加权，然后 Workload Balancing 应用一种类似性能最大化的算法，直到没有任何主机超出临界阈值。使用类似性能最大化的算法时，Workload Balancing 按照与性能最大化模式相同的方式，使用指标加权确定优化顺序。

如果两个或更多主机的资源超出其临界阈值，Workload Balancing 将首先验证您为每个资源设置的重要性，然后据此确定要优先进行优化的主机，以及该主机上要优先重定位的 VM。

例如，池中包含主机 A 和主机 B，二者分别处于以下状态：

  • 主机 A 上的 CPU 使用率超出了 CPU 临界阈值，而 CPU 使用率的指标加权设置为滑块偏右端（更重要）。
  • 主机 B 上的内存利用率超出了内存临界阈值，而内存利用率的指标加权设置为滑块偏左端（不太重要）。

Workload Balancing 将提出首先优化主机 A 的建议，因为该主机上达到临界阈值的资源是加权值最高的资源。在 Workload Balancing 确定需要处理主机 A 的性能后，便开始为该主机上的 VM 提出放置建议，首先从 CPU 使用率最高的 VM 开始，因为 CPU 使用率是加权值最高的资源。

在 Workload Balancing 提出优化主机 A 的建议后，将提出主机 B 的优化建议。当它为主机 B 上的 VM 提出放置建议时，将首先处理 CPU 使用率，因为 CPU 使用率具有最高加权值。

如果有其他需要优化的主机，Workload Balancing 将处理 CPU 使用率排在第三位的主机的性能。

默认情况下，所有指标加权设置为滑块上的最远点（更重要）。

注意：指标加权是相对值。这意味着如果所有指标设置为相同级别，那么即使该级别为不太重要，它们的加权也是相同的。比起为每个指标设置的实际加权值，各指标之间的关系更重要。

编辑指标加权系数

  1. 在资源窗格中选择池，单击 WLB 选项卡，然后单击设置。
  2. 在左侧窗格中，选择指标加权。
  3. 在指标加权页面中，根据需要调整各个资源旁边的滑块。

    如果将滑块移向不太重要，表明在此资源池中，确保虚拟机始终提供最高数量的此资源并不重要。


从建议中排除主机

配置 Workload Balancing 时，可以指定从 Workload Balancing 优化和放置建议（包括“启动于”放置建议）中排除特定的物理主机。

何时排除主机

以下情况下可能需要从建议中排除主机：

  • 您要在密度最大化模式下运行池、合并及关闭主机，但希望某些特定主机不实施该行为。
  • 两个虚拟机工作负载始终需要在同一主机上运行（例如，它们是互补的应用程序或工作负载）。
  • 不希望移动某些工作负载（例如，域控制器或 SQL Server）。
  • 您需要对主机执行维护，而不希望将虚拟机放置在该主机上。
  • 工作负载性能的重要程度远远高于专用硬件的成本。
  • 特定主机上正在运行高优先级的工作负载（虚拟机），而您并不希望使用高可用性功能来为这些虚拟机确定优先级。
  • 主机中的硬件对于池中的其他工作负载并不是最优选择。

无论指定固定优化模式还是计划优化模式，即使切换优化模式，已排除的主机仍会被排除。因此，如果您只希望阻止 Workload Balancing 自动关闭某个主机，则应考虑不为该主机启用（或取消选择）电源管理功能，如自动优化和管理电源中所述。

从放置和优化建议中排除主机

  1. 在资源窗格中选择池，单击 WLB 选项卡，然后单击设置。
  2. 在左侧窗格中，选择排除的主机。
  3. 在排除的主机页面中，选择您不希望 Workload Balancing 提供备选放置和优化建议的主机。


高级设置

高级对话框中的设置主要用于调整 Workload Balancing 在自动化模式下运行时应用建议的方式。

重要提示如果您在 Workload Balancing 运行一段时间之后未获得最优放置建议，Citrix 强烈建议您对性能阈值进行评估，如《Workload Balancing 管理员指南》中所述。对 Workload Balancing 设置适用于所用环境的正确阈值至关重要，否则其建议可能不适用。

概述：设置保守或主动的自动化建议

在自动化模式下运行时，提供优化和合并建议的频率以及自动应用这些建议的时间由多种因素决定，包括：

  • 您所指定的、Workload Balancing 在应用其他优化建议之前等待的时间
  • Workload Balancing 在自动应用某个建议之前必须提供的建议数
  • 在自动应用优化前建议必须达到的严重级别
  • Workload Balancing 在自动应用建议之前需要的建议（建议移动的虚拟机，目标主机）一致性级别

VM 迁移时间间隔

可以指定上次移动特定虚拟机后（无论是何原因），Workload Balancing 必须等待多久（分钟）才能生成包含该特殊虚拟机的其他优化建议。

建议间隔用于防止 Workload Balancing 由于不实的原因（例如，利用率短暂达到峰值）生成建议。

如果配置了“自动化”功能，则修改建议间隔时务必要非常小心。如果出现导致持续、反复出现高峰值的问题，则提高频率（即设置更低的间隔值）会产生大量建议，从而发生多次重新定位。

注意：Workload Balancing 需要等待一段时间才会考虑将最近重新平衡的服务器纳入启动放置、恢复及维护模式的建议，而设置建议间隔不会对这段等待时间产生影响。

建议计数

Workload Balancing 每两分钟进行一次检查，判断能否为正在监视的池生成建议。启用“自动化”功能时，可以指定 Workload Balancing 必须提供多少次一致的建议才能自动应用该建议。为此，需要配置一项称为“建议计数”的设置。“建议计数”和“优化主动性”设置用于调整建议在环境中的自动应用。

如概述部分中所述，Workload Balancing 利用建议的相似性来：a) 确认是否真正需要建议；b) 确定目标主机是否在较长时间内有足够稳定的性能来接受重定位的虚拟机（而无需在不久后将其再次从主机移出）。Workload Balancing 使用“建议计数”值来确定在 Workload Balancing 自动应用建议之前必须重复提出该建议的次数。

Workload Balancing 按如下所述使用此设置：

  1. 每次 Workload Balancing 生成满足一致性要求（如“优化主动性”设置所指定）的建议时，Workload Balancing 都会将“建议计数”值递增。如果该建议不满足一致性要求，Workload Balancing 可能会将“建议计数”重置为零，具体取决于《Workload Balancing 管理员指南》中所述的因素。
  2. 当 Workload Balancing 生成符合“建议计数”值（在“建议”文本框中指定）且足够数量的一致建议时，它将自动应用建议。

如果您选择修改此设置，应根据环境的不同来设置该值。请考虑以下情形：

  • 如果您环境中的服务器负载和活动急速增加，可能需要增大“建议计数”的值。Workload Balancing 每两分钟生成一次建议。举例来说，如果将此间隔设置为“3”，则在六分钟后，Workload Balancing 将自动应用建议。
  • 如果您环境中的服务器负载和活动逐渐增加，则可能需要减小“建议计数”的值。

在 Workload Balancing 重定位虚拟机时，接受建议会占用系统资源，并对性能产生影响。增大“建议计数”的值会增加在 Workload Balancing 应用建议之前必须出现的匹配建议的数目，从而促使 Workload Balancing 应用更保守、稳定的建议，并且降低错误移动虚拟机的可能性。但应注意，在默认情况下，“建议计数”设置为一个较保守的值。

由于调整此设置可能对您的环境产生影响，Citrix 建议在更改此设置时要极其小心，最好反复测试并更改此值，或者在 Citrix 技术支持人员的指导下进行。

建议严重性

所有优化建议都包含一个严重级别（严重、高、中、低），用于指示建议的重要程度。Workload Balancing 根据多项因素的组合确定该严重级别，这些因素包括您设置的配置选项，例如阈值和指标调整、可供工作负载使用的资源以及资源使用情况历史记录。

如果将 Workload Balancing 配置为自动应用优化建议，则可以设置在 Workload Balancing 自动应用优化建议之前应与该建议相关联的最低严重级别。

优化主动性

在自动化模式下运行时，为了提供更多的保证，Workload Balancing 针对自动接受优化规定了一致性条件，以避免由于高峰和异常而移动虚拟机。在自动化模式下，Workload Balancing 不会接受它生成的第一个建议，而是一直等到主机或虚拟机持续出现一致行为时才自动应用建议。“持续出现一致行为”这句话是指某个主机是否持续触发建议，以及该主机上的相同虚拟机是否持续触发建议等等因素。

Workload Balancing 通过使用一致性条件以及规定同一个建议提出次数（即建议计数）的条件来判断行为是否一致。您可以使用优化主动性设置来配置希望 Workload Balancing 应用一致性条件的严格程度。

虽然 Citrix 设计优化主动性设置主要是为了演示，但您可以使用该设置来控制在 Workload Balancing 应用优化建议之前，您环境中需要达到的稳定程度。默认情况下配置为最稳定的设置（低主动性）。在此上下文中，术语“稳定”是指建议的更改具有持续的相似性，如本部分内容所介绍。

Workload Balancing 最多使用四个条件来确定一致性。必须满足的条件数因您在优化主动性设置中设定的级别而异。级别越低（例如“低”或“中”），Workload Balancing 接受建议的主动性就越低。换言之，当主动性设置为“低”时，Workload Balancing 对于满足一致性条件的要求更加严格（或者说更忽视或更不主动）。

例如，如果主动性级别设置为“低”，则 Workload Balancing 要求在自动应用建议之前，每个“低”值条件都符合在“建议”框中（用于指定“建议计数”值）指定的次数。

例如，如果在建议框中将“建议计数”设置为“3”，则 Workload Balancing 将一直等到满足《Workload Balancing 管理员指南》中所示“低”值的所有条件并且连续三次重复提出建议时，才会应用该建议。这样有助于确保虚拟机确实需要移动，而且 Workload Balancing 推荐的目标主机在较长时间内具有持续稳定的资源利用率。这样可以降低最近移动过的虚拟机由于移动后主机性能发生改变而又从主机移出的可能性。默认情况下，此项设置设为保守设置（“低”）以促进稳定性。

Citrix 建议不要通过增加优化主动性值来提高主机优化频率。如果您感觉自己的主机优化速度或频率不够高，可以按照更改临界阈值中的说明，尝试调整临界阈值。

有关于与不同主动性级别相关联的一致性条件的详细信息，请参阅《Workload Balancing 管理员指南》。

如果您发现 Workload Balancing 自动应用优化建议的频率不够高，则需要增大主动性设置的值。但 Citrix 强烈建议您在进行上述调整之前，先查阅《Workload Balancing 管理员指南》中的相关信息。

配置虚拟机建议时间间隔

  1. 在资源窗格中选择池，单击 WLB 选项卡，然后单击设置。
  2. 在左侧窗格中，单击高级。
  3. 在 VM 建议时间间隔部分，执行以下一项或多项操作：
    • 在分钟框中，键入 Workload Balancing 在刚刚重新平衡的服务器上提出其他优化建议之前需要等待的时间（分钟）。
    • 在建议框中键入一个数值，您希望 Workload Balancing 在提出这些数量的优化建议后才能自动应用优化建议。
    • 选择自动应用优化之前的最低严重级别。
    • 修改 Workload Balancing 自动应用优化建议的主动性。


管理 Workload Balancing

您可能需要对 Workload Balancing 执行一些管理任务，这些任务包括：

  • 与 Workload Balancing 断开连接
  • 更改池使用的 Workload Balancing 虚拟设备
  • 更改 Workload Balancing 或 XenServer 用来通信的凭据

还可以使用 Workload Balancing 服务命令管理 Workload Balancing 虚拟设备。这些命令可用于确定 Workload Balancing 虚拟设备状态、更改用户帐户以及提高日志记录详细程度。有关这些命令的信息，请参阅《Workload Balancing 管理员指南》。

注意：有关将 Workload Balancing 配置为使用其他证书或者将 XenServer 配置为验证证书身份的信息，请参阅《Workload Balancing 管理员指南》。


与 Workload Balancing 断开连接

如果希望 Workload Balancing 停止监视池，必须通过与 Workload Balancing 服务器断开连接的方式为池禁用 Workload Balancing。

断开池与 Workload Balancing 虚拟设备的连接时，Workload Balancing 会从 Workload Balancing 数据库中永久删除关于该池的信息，并停止收集该池的数据。这意味着如果希望使用同一个 Workload Balancing 虚拟设备再次管理该池，必须在连接 WLB 服务器对话框中重新输入该设备的信息。

重要提示如果只是要暂时停止 Workload Balancing，请单击 WLB 选项卡，然后单击暂停按钮。

断开与 Workload Balancing 的连接

  1. 在 XenCenter 的资源窗格中，选择希望停止 Workload Balancing 的资源池。
  2. 从池菜单中，选择断开 Workload Balancing 服务器连接。此时将显示“断开 Workload Balancing 服务器连接”对话框。
  3. 单击断开连接使 Workload Balancing 停止监视该池。
注意： 如果断开了池与 Workload Balancing 虚拟设备的连接，要对该池重新启用 Workload Balancing，必须重新连接到该设备。


将池重新配置为使用其他 WLB 设备

可以将一个池重新配置为使用其他 Workload Balancing 虚拟设备。

但是，为了防止原来的 Workload Balancing 设备意外地继续保持已配置状态并收集该池的数据，在将该池连接到新的 Workload Balancing 设备之前，必须将其与原来的 Workload Balancing 设备断开连接。

一旦池与原来的 Workload Balancing 设备断开连接，就可以通过指定新的 Workload Balancing 设备名重新连接该池。

使用其他 Workload Balancing 设备

  1. 对于要使用其他 Workload Balancing 设备的池，从“池”菜单中，选择断开 Workload Balancing 服务器连接，然后在出现提示时单击断开连接。有关说明，请参阅与 Workload Balancing 断开连接。
  2. 在 WLB 选项卡中，单击连接。此时将显示连接 WLB 服务器对话框。
  3. 在地址框中，键入新 Workload Balancing 设备的 IP 地址或主机名 (FQDN)。

    如果新 Workload Balancing 设备使用不同凭据，还必须输入新凭据。

    4. 注意：必须输入在初次将池连接到 Workload Balancing 时通常会输入的所有信息。有关信息，请参阅连接 Workload Balancing。


更新 Workload Balancing 凭据

完成初始配置后，如果需要更新 XenServer 与 Workload Balancing 设备用来通信的凭据，可以按照以下三步过程操作：

  1. 如下面所述断开与 Workload Balancing 的连接。
  2. 通过编辑 WlbConfig 文件（在 Workload Balancing 虚拟设备的控制台中运行 WlbConfig 命令）更改 WLB 凭据。有关详细信息，请参阅《Workload Balancing 管理员指南》。
  3. 如下面所述重新启用 Workload Balancing 并指定新凭据。

在以下情况下您可能要执行这些步骤：

  • 如果需要更改 XenServer 用来与 Workload Balancing 进行通信的用户帐户
  • 如果您收到一条错误消息，说明 Workload Balancing 凭据不再有效
  • 如果服务不可用

如果要修改阈值设置，并更改为特定资源分配的优先级，请参阅编辑 Workload Balancing 设置。

断开与 Workload Balancing 的连接

  1. 在 XenCenter 的资源窗格中，选择要停止 Workload Balancing 的资源池。
  2. 从池菜单中，选择断开 Workload Balancing 服务器连接。此时将显示“断开 Workload Balancing 服务器连接”对话框。
  3. 单击断开连接以永久停止 Workload Balancing，从而停止 Workload Balancing 对池的监视。

重新启用 Workload Balancing 并指定新凭据

  1. 完成全部进度之后，单击连接。

    此时将显示“连接 WLB 服务器”对话框。

  2. 单击 Update Credentials（更新凭据）。
  3. 在服务器地址部分，根据需要修改以下内容：
    • 在地址框中，键入 Workload Balancing 设备的 IP 地址或 FQDN。
    • （可选）如果在 Workload Balancing 配置期间更改了端口号，请输入该端口号。XenServer 使用您在此框中以及 Workload Balancing 配置期间指定的端口号来连接 Workload Balancing。

      默认情况下，XenServer 通过端口 8012 连接 Workload Balancing。

      注意：除非您在 Workload Balancing 设置期间更改了此端口号，否则请勿对其进行编辑。设置期间指定的端口号必须与 Workload Balancing 配置对话框中指定的值一致。

  4. 在 WLB 服务器凭据部分，输入运行 XenServer 的计算机用来连接 Workload Balancing 服务器的用户名（例如 wlbuser）和密码。
  5. 在 XenServer 凭据部分，输入您正在配置的池的用户名和密码（通常是池主服务器的密码）。Workload Balancing 将使用这些凭据连接该池中运行 XenServer 的计算机。

    要使用当前登录 XenServer 所使用的凭据，请选中使用当前 XenCenter 凭据复选框。


在启用 Workload Balancing 的状态下进入维护模式

启用 Workload Balancing 后，如果将物理主机脱机以进行维护（即通过进入维护模式来挂起服务器），XenServer 会自动将该主机上运行的虚拟机迁移到最优服务器上（如果可用）。XenServer 会根据 Workload Balancing 的建议（性能数据、放置策略和性能阈值）迁移这些虚拟机。

如果没有最优服务器可供使用，进入维护模式对话框中会显示单击此处挂起 VM 字样。在这种情况下，Workload Balancing 不会提供放置建议，因为所有主机都没有足够的资源来运行此虚拟机。您可以将此虚拟机挂起，或者退出维护模式，并将同一资源池中另一台主机上的一个虚拟机挂起。这样，当您再次进入进入维护模式对话框时，Workload Balancing 可能会列出一台适合迁移的候选主机。

注意：如果您将一台服务器脱机以进行维护，并且 Workload Balancing 处于启用状态，则进入维护模式对话框的右上角会显示“Workload Balancing”字样。

在启用 Workload Balancing 的状态下进入维护模式

  1. 在资源窗格中选择服务器，然后执行以下操作之一：
    • 单击鼠标右键，在快捷菜单中单击进入维护模式。
    • 在服务器菜单中，单击进入维护模式。
  2. 单击进入维护模式。

服务器上运行的虚拟机会根据 Workload Balancing 的性能数据、放置策略和性能阈值，自动迁移到最优主机上。

使服务器退出维护模式：

  1. 在资源窗格中选择服务器，然后执行以下操作之一：
    • 单击鼠标右键，在快捷菜单中单击退出维护模式。
    • 在服务器菜单中，单击退出维护模式。
  2. 单击退出维护模式。

在服务器退出维护模式之后，XenServer 会自动将该服务器的原始虚拟机还原到该服务器。


Workload Balancing 故障排除

尽管通常情况下 Workload Balancing 都会顺畅地运行，但本帮助系统仍包含了一系列与故障排除相关的主题，以便在您遇到问题时为您提供指导。更多故障排除主题在《Workload Balancing 管理员指南》中提供。

下面是关于解决 Workload Balancing 常规问题的几点提示：

常规故障排除提示

执行故障排除时，首先应查看 Workload Balancing 日志。该日志位于 Workload Balancing 设备上的以下位置（默认位置）：

/var/log/wlb

此外，还要查看 XenCenter 中日志选项卡上的日志以了解更多（不同）信息。

错误消息

Workload Balancing 将错误消息显示在 XenCenter 中的日志选项卡上，在某些情况下，还会以对话框形式显示在屏幕上。


Workload Balancing 凭据输入问题

如果在配置连接 WLB 服务器对话框时无法使 Workload Balancing 接受设备的用户帐户和密码，请尝试以下操作：

  • 确保 Workload Balancing 设备已导入且配置正确，并且已通过 service workloadbalancing start 命令运行所有服务。
  • 按照 Workload Balancing 启动问题中的指导进行检查，以确保您输入的凭据正确无误。
  • 如果输入 Workload Balancing FQDN 遇到困难，请输入 Workload Balancing 服务器的 IP 地址。

    可以在地址框中输入 Workload Balancing 设备的主机名，但该名称必须是完全限定域名 (FQDN)。例如 yourcomputername.yourdomain.net。


Workload Balancing 启动问题

如果在导入和配置 Workload Balancing 设备后，收到一条错误消息，指出 XenServer 与 Workload Balancing 无法互相连接，原因可能是您在连接 WLB 服务器对话框中输入了错误的凭据。要解决此问题，请尝试：

  • 确认您在连接 WLB 服务器对话框中输入的凭据与您在 Workload Balancing 服务器和 XenServer 上创建的凭据相一致。
  • 确认您在连接 WLB 服务器对话框中输入的 Workload Balancing 设备的 IP 地址或 FQDN 正确无误。
  • 确认您在 Workload Balancing 配置期间创建的 Workload Balancing 帐户的帐户凭据与您在连接 WLB 服务器对话框中输入的凭据一致。


Workload Balancing 连接错误

如果在 WLB 选项卡上的“Workload Balancing 状态”行中收到连接错误消息，可能需要为该资源池重新配置 Workload Balancing。

单击 WLB 选项卡上的连接按钮，然后再次输入服务器凭据。

出现此错误通常是因为更改了 WLB 虚拟设备或池主服务器的凭据，或者更改了 WLB 虚拟设备的名称。


Workload Balancing 服务器的更改问题

如果在将资源池连接到其他 Workload Balancing 虚拟设备时，没有先断开该池与原始 Workload Balancing 设备的连接，则原来的和新的 Workload Balancing 设备都会监视该池。

要解决此问题，可以关闭并删除原来的 Workload Balancing 设备，或者手动停止 Workload Balancing 服务（分析、数据收集器和 Web 服务），使该设备不再监视池。

Citrix 建议不要使用 pool-initialize-wlb xe 命令取消配置或更改 Workload Balancing 服务器。


使用 Workload Balancing

显示所有文字

Workload Balancing 选项卡

什么是 Workload Balancing？

Workload Balancing 是一种 XenServer 虚拟设备，可用于：

  • 在 XenServer 资源池中的物理主机之间平衡虚拟机工作负载
  • 压缩工作负载并在预设时间（例如周末）关闭主机
  • 确定能否在特定的时间关闭物理主机
  • 确定虚拟机的启动位置
  • 当托管服务器发生故障或者您需要对虚拟机进行脱机维护时，确定虚拟机的移动位置
  • 运行关于优化和工作负载的历史报告，并审核管理员操作

必须先将池连接到 Workload Balancing 虚拟设备，然后 Workload Balancing 才能监视该池。利用 WLB 选项卡可以访问 Workload Balancing 的重要功能，其中包括报告、设置、建议和状态。

将 Workload Balancing 虚拟设备放入池中

Citrix XenServer 企业版或更高版本中提供 Workload Balancing。要了解有关不同 XenServer 版本中可用功能的详细信息，请单击此处。

如果您的许可证包含 Workload Balancing，可以按照以下步骤获得 Workload Balancing 虚拟设备以及启动并运行该设备：

  1. 从 MyCitrix.com 下载 Workload Balancing 虚拟设备软件包，并将其导入 XenCenter。
  2. 使用 Workload Balancing 配置向导配置 Workload Balancing 虚拟设备，在导入虚拟设备后，该向导将显示在 XenCenter 中该虚拟设备的控制台选项卡上。
  3. 将您的池连接到该 Workload Balancing 虚拟设备，如连接 Workload Balancing 中所述。

    有关这些步骤的详细信息，请参阅《Workload Balancing 快速入门》。

WLB 选项卡上的按钮

在池连接到 Workload Balancing 之前（或者池与 Workload Balancing 断开连接），WLB 选项卡上会显示以下按钮：

连接
如果显示此按钮，单击此按钮可将池连接到 Workload Balancing 虚拟设备，从而可以开始使用此功能。在连接 Workload Balancing 后，该按钮将被设置、暂停或恢复以及报告按钮所取代。有关连接 Workload Balancing 的信息，请参阅连接 Workload Balancing

连接后，WLB 选项卡上会显示以下按钮：

设置
此按钮可启动 Workload Balancing 配置属性页面。在这些页面上，您可以编辑 Workload Balancing 配置设置，例如优化模式（放置策略）、自动化、性能阈值、指标加权、主机排除和高级设置。只有在启用 Workload Balancing 后，才会显示设置按钮。有关编辑 Workload Balancing 设置的概述，请参阅编辑 Workload Balancing 设置。
暂停/恢复
连接后，Workload Balancing 会显示暂停或恢复按钮，具体取决于其状态。暂停按钮可用于暂时禁止 Workload Balancing 管理池。当 Workload Balancing 暂停时，暂停按钮将被恢复按钮所取代。
当恢复按钮可见时，单击该按钮可使 Workload Balancing 重新对池进行管理。
报告
此按钮可启动 Workload Balancing 报告对话框。有关连接 Workload Balancing 报告的信息，请参阅使用 Workload Balancing 报告。

WLB 选项卡中的各个部分

以下部分显示在 WLB 选项卡上：

配置
此部分显示 Workload Balancing 是否已启用、此资源池使用的 Workload Balancing 服务器的 IP 地址、池的优化模式、计划中的下一次优化模式切换、Workload Balancing 是否代表您自动接受优化建议，以及是否启用了 Workload Balancing 的电源管理功能。
优化建议
当 Workload Balancing 建议您将虚拟机移动到新主机时，优化建议会显示在此部分中。如果单击查看历史记录链接，Workload Balancing 会自动生成“池优化历史记录”报告，其中显示了池中 VM 移动的历史记录。
应用建议
当 Workload Balancing 提供优化建议时，应用建议将变为可用状态。单击此按钮将执行优化建议下列出的所有优化。单击应用建议后，可以在日志选项卡上显示优化和重定位进度。